マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
IP および MPLS-VPN 向け BGP PIC エッジ
IP および MPLS-VPN 向け BGP PIC エッジ
発行日;2012/01/31 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

IP および MPLS-VPN 向け BGP PIC エッジ

機能情報の確認

目次

の前提条件

に関する制約事項

について

通常時の BGP コンバージェンスの動作

BGP PIC によりコンバージェンスはどのように向上するか

BGP PIC 機能での BGP 高速リルートの役割

障害の検出方法

BGP PIC はどのようにして瞬間的にコンバージェンスを行うか

は MPLS VPN - BGP ローカル コンバージェンスの機能をどのように向上させるか

BGP PIC をイネーブル化するためのコンフィギュレーション モード

のシナリオ

CE 側での IP PE-CE リンクおよびノード保護(デュアル PE)

CE 側での IP PE-CE リンクおよびノード保護(デュアル CE およびデュアル PE プライマリ ノードとバックアップ ノード)

プライマリ パス、またはバックアップ/代替パスに対する IP MPLS PE-CE リンク保護

プライマリ パス、またはバックアップ/代替パスに対する IP MPLS PE-CE ノード保護

シスコ エクスプレス フォワーディングの再帰

の設定方法

のイネーブル化

前提条件

の設定例

の設定:例

に対するバックアップ/代替パスの表示:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

IP および MPLS-VPN 向け BGP PIC エッジ

IP および MPLS-VPN 向け BGP PIC エッジ機能により、ネットワーク障害後のコンバージェンスが向上します。このコンバージェンスはコア障害およびエッジ障害の両方に適用され、IP ネットワークおよび MPLS ネットワークの両方で使用可能です。IP および MPLS-VPN 向け BGP PIC エッジ機能は、障害が検出された場合、即座にバックアップ/代替パスが引き継ぎ、すばやくフェールオーバーがイネーブル化されるように、Routing Information Base(RIB; ルーティング情報ベース)、Forwarding Information Base(FIB; 転送情報ベース)、およびシスコ エクスプレス フォワーディングにバックアップ/代替パスを作成、保存します。

この機能には、次の利点があります。

フェールオーバー用の追加パスにより、プライマリ パスが無効であるか、またはプライマリ パスで障害が発生している場合に、すばやく接続を回復させることが可能。

トラフィック損失の軽減。

コンバージェンス時間が一定。これにより、すべてのプレフィクスで切り替え時間が一定になります。


) このマニュアルでは、IP および MPLS-VPN 向け BGP PIC エッジ機能を「BGP PIC」と呼びます。


機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「BGP PICの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

BGP PIC の前提条件

BGP および IP または Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークが稼動中であること、およびカスタマー サイトが複数のパスによってプロバイダー サイトと接続されていること(マルチホーム)を確認します。

バックアップ/代替パスが、最良パスのネクスト ホップとは別に、独自のネクスト ホップを持っていることを確認します。

直接接続されたネイバーのリンク障害をすばやく検出するために、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)プロトコルをイネーブルにします。

BGP PICに関する制約事項

BGP PIC 機能には、次のような制約事項が適用されます。

BGP マルチパスでは、BGP PIC 機能はすでにサポートされています。

MPLS VPN では、MPLS VPN Inter-Autonomous システム オプション B を使った BGP PIC 機能はサポートされていません。

BGP PIC 機能は、IPv4 および VPNv4 アドレス ファミリでのみプレフィクスをサポートしています。

マルチキャスト、L2VPN、または IPv6 VPN では BGP PIC 機能は設定できません。

ルート リフレクタがコントロール プレーンのみの場合、BGP PIC は必要ありません。これは BGP PIC はデータ プレーン コンバージェンスに対応しているためです。

2 つの PE ルータが互いに相手の CE ルータへのバックアップ/代替パスとなっている場合、CE ルータで障害が発生すると、トラフィックがループする可能性があります。いずれのルータも CE ルータにアクセスできず、Time-to-Live(TTL; 存続可能時間)タイマーが期限切れになるまで、PE ルータとの間でトラフィックの転送が継続されます。

BGP PIC 機能は、NSF/SSO をサポートしていません。ただし、両方のルート プロセッサに BGP PIC 機能が設定されている場合、ISSU がサポートされます。

BGP PIC 機能は、エッジとコアの両方で、単一のネットワーク障害についてのみ、トラフィック転送を解決します。

BGP PIC 機能と BGP 最良外部機能を同時に使用することはできません。BGP 最良外部機能の設定後に、BGP PIC 機能を設定しようとすると、エラーが表示されます。

BGP PICについて

BGP PIC 機能を設定する前に、次の概念を理解する必要があります。

「通常時の BGP コンバージェンスの動作」

「BGP PIC によりコンバージェンスはどのように向上するか」

「障害の検出方法」

「BGP PIC はどのようにして瞬間的にコンバージェンスを行うか」

「BGP PIC は MPLS VPN - BGP ローカル コンバージェンスの機能をどのように向上させるか」

「BGP PIC をイネーブル化するためのコンフィギュレーション モード」

「BGP PIC のシナリオ」

通常時の BGP コンバージェンスの動作

通常の状況では、ネットワークの変更後、BGP がコンバージェンスを行うまでには数秒から数分かかります。高いレベルでは、BGP は次のようなプロセスを完了します。

1. BGP は IGP または BFD イベント、もしくはインターフェイス イベントを通じて不具合を確認します。

2. BGP はこれらのルートを Routing Information Base(RIB; ルーティング情報ベース)から削除し、RIB はこれらを Forwarding Information Base(FIB; 転送情報ベース)、および distributed FIB(dFIB)から削除します。このプロセスにより、障害の影響を受けたプレフィクスへのデータ パスがクリアされます。

3. BGP は withdraw メッセージをネイバーに送信します。

4. BGP は、影響を受けたプレフィクスへの、2 番目に最適なパスを計算します。

5. BGP が影響を受けたプレフィクスへの 2 番目に最適なパスを RIB に挿入すると、RIB はこれらを FIB と dFIB にインストールします。

このプロセスを完了するまでには、ネットワークの遅延、ネットワークでのコンバージェンス時間、およびそのデバイスでのローカルな負荷に応じて、数秒から数分かかります。コントロール プレーンのコンバージェンスが行われて初めて、データ プレーンのコンバージェンスが行われます。

BGP PIC によりコンバージェンスはどのように向上するか

BGP PIC 機能は、BGP、RIB、シスコ エクスプレス フォワーディング、および MPLS の追加機能により実現されます。

BGP の機能

BGP PIC は、IPv4 および VPVN4 アドレス ファミリのプレフィクスに影響を与えます。これらのプレフィクスについて、BGP は最適パスの他に、2 番目に適したパスも計算します(2 番目に適したパスは「バックアップ/代替パス」と呼ばれます)。BGP は、影響を受けたプレフィクスへの最適パスとバックアップ/代替パスを BGP RIB にインストールします。バックアップ/代替パスは、1 つのネットワーク障害に対応するための高速リルート メカニズムを提供します。また、BGP は、IP RIB への Application Programming Interface(API; アプリケーション プログラミング インターフェイス)にもバックアップ/代替パスを追加します。

RIB の機能

BGP PIC について、RIB は代替パスがあれば、ルート 1 つにつき代替パスを 1 つインストールします。BGP PIC 機能では、RIB はバックアップ/代替パスを含む BGP ルートを選択した場合、最適パスとともにバックアップ/代替パスをインストールします。また、RIB は、この代替パスを FIB との API にも追加します。

Cisco Express Forwarding(FIB; シスコ エクスプレス フォワーディング)機能

BGP PIC では、シスコ エクスプレス フォワーディングは、プレフィクス 1 つにつき代替パスを 1 つ格納します。プライマリ パスがダウンすると、シスコ エクスプレス フォワーディングは、プレフィクスに依存しない方法でバックアップ/代替パスを検索します。また、シスコ エクスプレス フォワーディングは、局地的な障害を迅速に検出するために、BFD イベントをリッスンします。

MPLS の機能

MPLS 転送はシスコ エクスプレス フォワーディング同様、代替パスを格納し、プライマリ パスがなくなったときに代替パスに切り替えます。

BGP PIC 機能がイネーブルの場合、BGP はプレフィクスごとにバックアップ/代替パスを計算し、BGP RIB、IP RIB、および FIB にインストールします。これにより、ネットワーク障害後のコンバージェンスが向上します。BGP PIC 機能により検出されるネットワーク障害には次の 2 種類があります。

コア ノード/リンク障害(iBGP ノード障害):PE ノード/リンク障害が発生した場合、この障害は IGP コンバージェンスを通じて検出されます。IGP は、RIB を通じて FIB に障害を伝達します。

ローカル リンク/直近にあるネイバー ノードの障害(eBGP ノード/リンク障害):ローカル リンク障害、または eBGP シングルホップ ピア ノード障害を瞬時に検出するには、BFD をイネーブルにする必要があります。シスコ エクスプレス フォワーディングは eBGO シングルホップ ピアの不具合を検出するために BFD イベントを探します。

データ プレーンでのコンバージェンス

不具合を検出したシスコ エクスプレス フォワーディングは、この不具合により影響されるプレフィクスすべての代替ネクスト ホップを検出します。BGP PIC がソフトウェアまたはハードウェアに実装されているかどうかによっては、データ プレーン コンバージェンスは一瞬のうちに終わります。

コントロール プレーン コンバージェンスでのコンバージェンス

不具合を検出すると、BGP は IGP コンバージェンス、または BFD イベントを通じてこの不具合を確認してから、プレフィクスに withdraw メッセージを送信し、最適パスおよびバックアップ/代替パスを計算して、ネットワーク全体に 2 番目に最適なパスをアドバタイジングします。

BGP PIC 機能での BGP 高速リルートの役割

BGP Fast Reroute(FRR; 高速リルート)は、BGP、RIB、およびシスコ エクスプレス フォワーディングに最適パスおよびバックアップ/代替パスを提供します。BGP FRR は、その時点での最適パスが使用できない場合に目的地に到達するための非常に高速なリルート メカニズムを、バックアップ BGP ネクスト ホップの RIB およびシスコ エクスプレス フォワーディングに提供します。

BGP FRR は BGP で 2 番目に最適なパスをあらかじめ計算しておき、このパスを RIB およびシスコ エクスプレス フォワーディングにバックアップ/代替パスとして知らせます。その後、シスコ エクスプレス フォワーディングはこのパスをライン カードにプログラムします。

つまり、最適パスおよびバックアップ/代替パスをセットアップする責任は BGP FRR にあります。BGP PIC 機能により、シスコ エクスプレス フォワーディングは、その時点でのネクスト ホップ、またはこのネクスト ホップへのリンクがダウンしたときに、トラフィックを他の出力ポートにすばやく切り替えるようになります。これを図で表すと図 1 のようになります。

図 1 BGP PIC エッジおよび BGP FRR

障害の検出方法

障害が IBGP(リモート)ピアで検出される場合、障害は IGP によって検出されますが、検出を開始するまでには数秒かかります。コンバージェンスは、ラインカードで PIC がイネーブルにされているかどうかに応じて、瞬時、または数秒以内に行われます。

不具合が直接接続されているネイバー(EBGP)に関係している場合、BFD を使用すると、ネイバーにアクセスできなくなった時期の検出は瞬時に行われます。また、ラインカードで PIC がイネーブルにされているかどうかに応じて、瞬時、または数秒以内にコンバージェンスが行われます。

BGP PIC はどのようにして瞬間的にコンバージェンスを行うか

BGP PIC はシスコ エクスプレス フォワーディング レベルで機能します。また、シスコ エクスプレス フォワーディングの処理はハードウェア ライン カード、およびソフトウェアで行うことができます。

ラインカードでのシスコ エクスプレス フォワーディングの処理をサポートしているプラットフォームでは、BGP PIC 機能は瞬時のコンバージェンスが可能です。Cisco 7600 ルータ、および 10000 ルータはラインカードとソフトウェアでシスコ エクスプレス フォワーディング処理をサポートしているため、瞬間的なコンバージェンスを達成できます。

ハードウェア ラインカードでシスコ エクスプレス フォワーディングを使用していないプラットフォームでは、シスコ エクスプレス フォワーディングはソフトウェアで行われます。BGP PIC 機能は、このソフトウェアを通じてシスコ エクスプレス フォワーディングと連携し、数秒以内にコンバージェンスを行います。7200 ルータはシスコ エクスプレス フォワーディングをソフトウェアでサポートしているため、瞬間的にコンバージェンスを行うことはできず、数秒間を必要とします。

BGP PIC は MPLS VPN - BGP ローカル コンバージェンスの機能をどのように向上させるか

BGP PIC は、最適パスを再計算し、リンク障害後のフォワーディングに新しいパスをインストールするフェールオーバー メカニズムを提供する「 MPLS VPN--BGP Local Convergence 」機能への拡張機能です。この機能は、トラフィックがバックアップ/代替パスを使用して、トラフィック損失を最小限に抑えることができるようにローカル ラベルを 5 分間保持します。

BGP PIC 機能は、あらかじめバックアップ/代替パスを計算することにより、1 秒未満になるように LoC 時間を向上させます。リンク障害が発生すると、トラフィックはバックアップ/代替パスへ送られます。

BGP PIC 機能を設定した場合、この機能は「 MPLS VPN--BGP Local Convergence 」よりも優先されます。コンフィギュレーションから protection local-prefixes コマンドを削除する必要はありません。

BGP PIC をイネーブル化するためのコンフィギュレーション モード

さまざまなサービス プロバイダー ネットワークにさまざまな VRF が含まれているため、BGP PIC 機能では、すべての VRF に対して一度に BGP PIC 機能を設定することができます。

VPNv4 アドレス ファミリ コンフィギュレーション モードはすべての VRF を保護します。

VRF-IPv4 アドレス ファミリ コンフィギュレーション モードは、IPv4 VRF のみを保護します。

グローバル ルータ コンフィギュレーション モードは、グローバル ルーティング テーブルのプレフィクスを保護します。

CE 側での IP PE-CE リンクおよびノード保護(デュアル PE)

図 2 は、BGP PIC 機能を使用しているネットワークを示しています。このネットワークには、次のコンポーネントが含まれます。

PE ルータと CE ルータの間には eBGP セッションが存在します。

CE1 からのトラフィックは、ルータ CE3 経由でネットワーク 192.168.9.0/24 に到達するために PE1 を使用します。

CE1 には 2 つのパスがあります。

プライマリ パスとしての PE1

バックアップ/代替パスとしての PE2

CE1 は BGP PIC 機能を使って設定されています。BGP は最適パスとして PE1 を、バックアップ/代替パスとして PE2 を算出し、この両方のルートを RIB およびシスコ エクスプレス フォワーディングのフォワーディング プレーンにインストールします。CE1-PE1 リンクがダウンすると、シスコ エクスプレス フォワーディングはリンク障害を検出し、転送するオブジェクトをバックアップ/代替パスの方へ向けます。シスコ エクスプレス フォワーディングでローカルに行われる高速コンバージェンスにより、トラフィックは迅速にリルートされます。

図 2 BGP PIC を使用した PE-CE リンクの保護

 

CE 側での IP PE-CE リンクおよびノード保護(デュアル CE およびデュアル PE プライマリ ノードとバックアップ ノード)

図 3 は、CE1 で BGP PIC 機能を使用しているネットワークを示しています。このネットワークには、次のコンポーネントが含まれます。

PE ルータと CE ルータの間には eBGP セッションが存在します。

CE1 からのトラフィックは、ルータ CE3 経由でネットワーク 192.168.9.0/24 に到達するために PE1 を使用します。

CE1 には 2 つのパスがあります。

プライマリ パスとしての PE1

バックアップ/代替パスとしての PE2

CE1 ルータと CE2 ルータの間に、iBGP セッションが存在します。

この例では、CE1 および CE2 は BGP PIC 機能を使って設定されています。BGP は最適パスとして PE1 を、バックアップ/代替パスとして PE2 を算出し、この両方を RIB およびシスコ エクスプレス フォワーディング プレーンにインストールします。

eBGP ピア PE1 および PE2 について、CE1 および CE2 にはポリシーが設定されていてはいけません。これらの CE ルータは両方とも、ネクスト ホップとして外部 eBGP ルートをポイントする必要があります。CE1 では、CE3 に到達するためのネクスト ホップは PE1 を経由するため、CE3 に到達する最適パスは PE1 です。CE2 では、CE3 に到達するための最適パスは PE2 です。CE2 は、ネクスト ホップとして自身を CE1 にアドバタイズします。CE1 は同様のアドバタイズを CE2 に対して行います。この結果、CE1 は特定のプレフィクスに対するパスを 2 つ持ち、最適パス選択ルールに従って、通常、iBGP パスではなく、直接接続された eBGP パスを選択します。同様に、CE2 は、PE2 を経由する eBGP パスと CE1-PE1 を経由する iBGP パスの 2 つのパスを持ちます。

CE1-PE1 リンクがダウンすると、シスコ エクスプレス フォワーディングはリンク障害を検出し、転送するオブジェクトをバックアップ/代替ノード CE2 の方へ向けます。シスコ エクスプレス フォワーディングでローカルに行われる高速コンバージェンスにより、トラフィックは迅速にリルートされます。

CE1-PE1 リンク、または PE1 がダウンしたときに、CE1 で BGP PIC がイネーブル化されていた場合、BGP は最適パスを再計算し、RIB からネクスト ホップ PE1 を削除し、RIB およびシスコ エクスプレス フォワーディングに CE2 をネクスト ホップとして再インストールします。CE1 がバックアップ/代替修復パスをシスコ エクスプレス フォワーディングに自動的に組み入れるため、フォワーディング中のトラフィック損失はミリ秒単位に抑えられ、迅速なコンバージェンスが達成されます。

図 3 デュアル CE、デュアル PE ネットワークでの BGP PIC の使用

 

プライマリ パス、またはバックアップ/代替パスに対する IP MPLS PE-CE リンク保護

図 3 は、CE1 および CE2 で BGP PIC 機能を使用しているネットワークを示しています。このネットワークには、次のコンポーネントが含まれます。

PE ルータと CE ルータの間には eBGP セッションが存在します。

PE ルータは、MPLS ネットワークにリフレクト ルータを持つ VPNv4 iBGP ピアです。

CE1 からのトラフィックは、ルータ CE3 経由でネットワーク 192.168.9.0/24 に到達するために PE1 を使用します。

CE3 は PE3 および PE4 とデュアルホーム接続されています。

PE1 は、リフレクト ルータから CE3 に到達するためのパスを 2 つ持っています。

PE3 は、PE3 アドレスとしてネクスト ホップを持つプライマリ パスです。

PE4 は、PE4 アドレスとしてネクスト ホップを持つバックアップ/代替パスです。

この例では、PE ルータはすべて、IPv4 または VPNv4 アドレス ファミリの下で BGP PIC 機能を使って設定できます。

BGP PIC を PE-CE リンク保護のために BGP で動作させるには、PE ルータの 1 つがプライマリとして、残りのルータがバックアップ/代替として動作するように、CE3 から受信されるプレフィクスに対し、PE3 および PE4 でポリシーを設定します。通常、これはローカル プリファレンスを使用して行いますが、PE3 により優位なローカル プリファレンスを与えます。MPLS クラウドでは、トラフィックは内部的に PE3 経由でフローし、CE3 に到達します。したがって、PE1 は PE3 を最適パスとし、PE4 を 2 番目に最適なパスとします。

PE3-CE3 リンクがダウンすると、シスコ エクスプレス フォワーディングはリンク障害を検出し、PE3 は最適パスを再計算して、PE4 を最適パスとして選択し、PE3 プレフィクスの withdraw メッセージをリフレクト ルータに送信します。BGP が最適パス ルートとして RIB およびシスコ エクスプレス フォワーディングに PE4 をインストールするまで、一部のトラフィックは PE3-PE4 を通過します。PE1 は withdraw メッセージを受信し、最適パスを再計算して、PE4 を最適パスとして選択し、このルートを RIB およびシスコ エクスプレス フォワーディング プレーンにインストールします。

したがって、PE3 および PE4 で BGP PIC がイネーブル化された状態で、シスコ エクスプレス フォワーディングはリンク障害を検出し、シスコ エクスプレス フォワーディングにすでに存在するバックアップ/代替ノード PE4 へ転送するオブジェクトを直接修正します。PE4 はバックアップ/代替パスがローカルに生成されたことを認識し、CE3 に接続された出力ポートにトラフィックをルーティングします。この方法により、トラフィックの損失は最小限に抑えられ、迅速なコンバージェンスが行われます。

プライマリ パス、またはバックアップ/代替パスに対する IP MPLS PE-CE ノード保護

図 4 に、MPLS ネットワークにある PE ルータすべてで BGP PIC 機能を使用しているネットワークを示します。

図 4 MPLS ネットワークのすべての PE ルータで BGP PIC をイネーブル化

このネットワークには、次のコンポーネントが含まれます。

PE ルータと CE ルータの間には eBGP セッションが存在します。

PE ルータは、MPLS ネットワークにリフレクト ルータを持つ VPNv4 iBGP ピアです。

CE1 からのトラフィックは、ルータ CE3 経由でネットワーク 192.168.9.0/24 に到達するために PE1 を使用します。

CE3 は PE3 および PE4 とデュアルホーム接続されています。

PE1 は、リフレクト ルータから CE3 に到達するためのパスを 2 つ持っています。

PE3 は、PE3 アドレスとしてネクスト ホップを持つプライマリ パスです。

PE4 は、PE4 アドレスとしてネクスト ホップを持つバックアップ/代替パスです。

この例では、PE ルータはすべて、IPv4 および VPNv4 アドレス ファミリの下で BGP PIC 機能を使って設定されます。

BGP PIC を PE-CE ノード保護のために BGP で動作させるには、PE ルータの 1 つがプライマリとして、残りのルータがバックアップ/代替として動作するように、CE3 から受信されるプレフィクスに対し、PE3 および PE4 でポリシーを設定します。通常、これはローカル プリファレンスを使用して行いますが、PE3 により優位なローカル プリファレンスを与えます。MPLS クラウドでは、トラフィックは内部的に PE3 経由でフローし、CE3 に到達します。したがって、PE1 は PE3 を最適パスとし、PE4 を 2 番目に最適なパスとします。

PE3 がダウンすると、PE1 は瞬時に IGP によるホスト プレフィクスの削除を認識し、最適パスを再計算して、PE4 を最適パスとして選択し、RIB およびシスコ エクスプレス フォワーディングのフォワーディング プレーンにこれらのルートをインストールします。通常の BGP コンバージェンスが行われ、その一方で、BGP PIC は PE4 経由でトラフィックをリダイレクトします。したがって、パケットは失われません。

したがって、PE3 で BGP PIC がイネーブル化された状態で、シスコ エクスプレス フォワーディングは PE3 のノード障害を検出し、転送するオブジェクトをバックアップ/代替ノード PE4 の方に向けます。PE4 はバックアップ/代替パスがローカルに生成されたことを認識し、このバックアップ/代替パスを使用して出力ポートにトラフィックをルーティングします。この方法により、トラフィックの損失は最小限に抑えられます。

PE ルータではローカル ポリシーは設定されない

PE1 および PE2 は、ローカル ポリシーを使用せずに、ネクスト ホップとして eBGP CE パスをポイントします。PE ルータはそれぞれ、もう 1 つのパスを受信し、BGP はバックアップ/代替パスを計算して、これを CE に対する自身の eBGP パスとともに最適パスとして、シスコ エクスプレス フォワーディングにインストールします。MPLS PE-CE リンクおよびノード保護ソリューションには、BGP ポリシーを変更できないという制限があります。これらは、最適な外部パスを必要とせずに、動作するものでなければなりません。

PE ルータで設定されるローカル ポリシー

出力 CE にアクセスするためのプライマリ パスとして PE ルータの 1 つを選択するためのローカル ポリシーが PE ルータに設定されている場合には、ルート リフレクタおよび遠端側 PE ルータへ、バックアップ/代替ラベルの付いた外部 CE ルートを伝播するために、バックアップ/代替ノード PE3 には、bgp advertise-best-external コマンドが必要です。

シスコ エクスプレス フォワーディングの再帰

再帰は、プライマリ パスがなくなったときに、次に一致率の高いパスを発見する機能です。

BGP PIC 機能がインストールされていないときに、プレフィクスへのネクスト ホップで障害が発生すると、シスコ エクスプレス フォワーディングは、プレフィクスへ向かう別のパスを検索するために、FIB を再帰処理して、このプレフィクスと一致する部分が 2 番目に長いパスを探します。これは、ネクスト ホップが数ホップ先にあり、このネクスト ホップへ到達するための方法が複数存在する場合に便利です。

しかし、BGP PIC 機能を使用している場合は、次のような理由からシスコ エクスプレス フォワーディングの再帰をディセーブルにする必要があります。

シスコ エクスプレス フォワーディングがすべての FIB エントリを検索する場合、再帰によりコンバージェンスの速度が低下します。

BGP PIC エッジにより、あらかじめ代替パスは計算されているため、CEF 再帰の必要はなくなっています。

BGP PIC 機能がイネーブル化されているとき、シスコ エクスプレス フォワーディングの再帰は次の 2 つの場合に、デフォルトでディセーブルにされます。

ネクスト ホップが /32 ネットワーク マスクを使って認識されている場合(ホスト ルート)

ネクスト ホップが直接接続されている場合

これ以外のすべての場合で、シスコ エクスプレス フォワーディングの再帰はイネーブルにされています。

BGP PIC 機能の一部として、 bgp recursion host コマンドを実行し、BGP ホスト ルートに対するシスコ エクスプレス フォワーディングの再帰をディセーブル、またはイネーブルにすることができます。

ネクスト ホップに直接接続されている BGP に対するシスコ エクスプレス フォワーディングの再帰をディセーブル、またはイネーブルにするには、 disable-connected-check コマンドを実行します。

BGP PIC の設定方法

BGP PIC 機能を設定するには、次の作業を行います。

「BGP PIC のイネーブル化」

BGP PIC のイネーブル化

さまざまなサービス プロバイダー ネットワークにさまざまな VRF が含まれているため、BGP PIC 機能では、すべての VRF に対して一度に BGP PIC 機能を設定することができます。

VPNv4 アドレス ファミリ コンフィギュレーション モードはすべての VRF を保護します。

VRF-IPv4 アドレス ファミリ コンフィギュレーション モードは、IPv4 VRF のみを保護します。

グローバル ルータ コンフィギュレーション モードは、グローバル ルーティング テーブルのプレフィクスを保護します。

マルチプロトコル VRF の設定を含み、この機能がイネーブル化されていることを検証するための出力を示す完全な設定例については、「BGP PICの設定:例」を参照してください。

前提条件

MPLS VPN に BGP PIC 機能を実装する場合は、BGP PIC 機能を設定する前に、ネットワークが正常に動作していることを確認してください。詳細については、『 Configuring MPLS Layer 3 VPNs 』を参照してください。

MPLS VPN に BGP PIC 機能を実装している場合は、マルチプロトコル VRF を設定します。これにより、IPv4 と IPv6 との間でルート ターゲット ポリシー(インポートとエクスポート)を共有したり、IPv4 および IPv6 VPN に異なる route-target ポリシーを設定できるようになります。マルチプロトコル VRF の設定の詳細については、『 MPLS VPN--VRF CLI for IPv4 and IPv6 VPNs 』を参照してください。

CE ルータが少なくとも 2 つのパスでネットワークに接続されていることを確認します。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 [ unicast | vrf vrf-name ]
または
address-family vpnv4 [ unicast ]

5. bgp additional-paths install

6. neighbor ip-address remote-as autonomous-system-number

7. neighbor ip-address activate

8. bgp recursion host

9. neighbor ip-address fall-over [ bfd | route-map map-name ]

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 40000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast | vrf vrf-name ]

or

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family ipv4 unicast

or

Router(config-router)# address-family vpnv4

IPv4 または VPNv4 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードは、 IPv4 または VPNv4 ユニキャスト アドレス ファミリを指定します

vrf キーワードと vrf-name 引数は、それ以降の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドと関連付けられる Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスの名前を表します。

ステップ 5

bgp additional-paths install

 

Router(config-router-af)# bgp additional-paths install

バックアップ/代替パスを計算し、これを RIB およびシスコ エクスプレス フォワーディングにインストールします。

ステップ 6

neighbor ip-address remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 45000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義されたネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。その他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプについて、アドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要があります。

ステップ 7

neighbor ip-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

ネイバーが IPv4 ユニキャスト アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

ステップ 8

bgp recursion host

 

Router(config-router-af)# bgp recursion host

(任意)IPv4、VPNv4、および VRF アドレス ファミリについて、recursive-via-host フラグをイネーブルにします。

BGP PIC 機能がイネーブル化されている場合、シスコ エクスプレス フォワーディングの再帰はディセーブルにされます。ほとんどの場合、BGP PIC がイネーブルのときに、再帰をイネーブルにする必要はありません。

ステップ 9

neighbor ip-address fall-over [ bfd | route-map map-name ]

 

Router(config-router-af)# neighbor 192.168.1.1 fall-over bfd

ネイバーにアクセスできなくなったことを瞬時に検出するために、BFD プロトコルのサポートをイネーブルにします。

ステップ 10

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

BGP PIC の設定例

次に、BGP PIC 機能を設定し、検証する例を示します。

「BGP PICの設定:例」

「BGP PIC に対するバックアップ/代替パスの表示:例」

BGP PICの設定:例

次に、VPNv4 アドレス ファミリ コンフィギュレーション モードで BGP PIC 機能を設定する例を示します。これにより、VRF のすべての機能がイネーブル化されます( bgp additional-paths install コマンドは太字で表示されています)。次の例では、blue と green の 2 つの VRF が定義されています。blue と green を含むすべての VRF は、バックアップ/代替パスにより保護されています。

vrf definition test1
rd 400:1
route-target export 100:1
route-target export 200:1
route-target export 300:1
route-target export 400:1
route-target import 100:1
route-target import 200:1
route-target import 300:1
route-target import 400:1
address-family ipv4
exit-address-family
exit
!
interface Ethernet1/0
vrf forwarding test1
ip address 10.0.0.1 255.0.0.0
exit
router bgp 3
no synchronization
bgp log-neighbor-changes
redistribute static
redistribute connected
neighbor 10.6.6.6 remote-as 3
neighbor 10.6.6.6 update-source Loopback0
neighbor 10.7.7.7 remote-as 3
neighbor 10.7.7.7 update-source Loopback0
no auto-summary
!
address-family vpnv4
bgp additional-paths install
neighbor 10.6.6.6 activate
neighbor 10.6.6.6 send-community both
neighbor 10.7.7.7 activate
neighbor 10.7.7.7 send-community both
exit-address-family
!
address-family ipv4 vrf blue
import path selection all
import path limit 10
no synchronization
neighbor 10.11.11.11 remote-as 1
neighbor 10.11.11.11 activate
exit-address-family
!
address-family ipv4 vrf green
import path selection all
import path limit 10
no synchronization
neighbor 10.13.13.13 remote-as 1
neighbor 10.13.13.13 activate
exit-address-family
 

次の show vrf detail コマンド出力は、BGP PIC 機能がイネーブルになっていることを示しています(関連する出力は太字で示されています)。

Router# show vrf detail
 
VRF test1 (VRF Id = 1); default RD 400:1; default VPNID <not set>
Interfaces:
Se4/0
Address family ipv4 (Table ID = 1 (0x1)):
Export VPN route-target communities
RT:100:1 RT:200:1 RT:300:1
RT:400:1
Import VPN route-target communities
RT:100:1 RT:200:1 RT:300:1
RT:400:1
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
Prefix protection with additional path enabled
Address family ipv6 not active.

BGP PIC に対するバックアップ/代替パスの表示:例

次の例のコマンド出力は、VRF blue の VRF にはバックアップ/代替パスがあることを示しています。関連するコマンド出力は太字で示されています。

 
Router# show ip bgp vpnv4 vrf blue 10.0.0.0
 
BGP routing table entry for 10:12:12.0.0.0/24, version 88
Paths: (4 available, best #1, table blue)
Additional-path
Advertised to update-groups:
6
1, imported path from 12:23:12.0.0.0/24
10.3.3.3 (metric 21) from 10.6.6.6 (10.6.6.6)
Origin incomplete, metric 0, localpref 200, valid, internal, best
Extended Community: RT:12:23
Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
mpls labels in/out nolabel/37
1, imported path from 12:23:12.0.0.0/24
10.13.13.13 (via green) from 10.13.13.13 (10.0.0.2)
Origin incomplete, metric 0, localpref 100, valid, external
Extended Community: RT:12:23 , recursive-via-connected
1, imported path from 12:23:12.0.0.0/24
10.3.3.3 (metric 21) from 10.7.7.7 (10.7.7.7)
Origin incomplete, metric 0, localpref 200, valid, internal
Extended Community: RT:12:23
Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
mpls labels in/out nolabel/37
1
10.11.11.11 from 10.11.11.11 (1.0.0.1)
Origin incomplete, metric 0, localpref 100, valid, external, backup/repair
Extended Community: RT:11:12 , recursive-via-connected
 

次の例のコマンド出力は、VRF green の VRF にはバックアップ/代替パスがあることを示しています。関連するコマンド出力は太字で示されています。

 
Router# show ip bgp vpnv4 vrf green 12.0.0.0
 
BGP routing table entry for 12:23:12.0.0.0/24, version 87
Paths: (4 available, best #4, table green)
Additional-path
Advertised to update-groups:
5
1, imported path from 11:12:12.0.0.0/24
10.11.11.11 (via blue) from 10.11.11.11 (1.0.0.1)
Origin incomplete, metric 0, localpref 100, valid, external
Extended Community: RT:11:12 , recursive-via-connected
1
10.3.3.3 (metric 21) from 10.7.7.7 (10.7.7.7)
Origin incomplete, metric 0, localpref 200, valid, internal
Extended Community: RT:12:23
Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
mpls labels in/out nolabel/37
1
10.13.13.13 from 10.13.13.13 (10.0.0.2)
Origin incomplete, metric 0, localpref 100, valid, external, backup/repair
Extended Community: RT:12:23 , recursive-via-connected
1
10.3.3.3 (metric 21) from 10.6.6.6 (10.6.6.6)
Origin incomplete, metric 0, localpref 200, valid, internal, best
Extended Community: RT:12:23
Originator: 10.3.3.3, Cluster list: 10.0.0.1 , recursive-via-host
mpls labels in/out nolabel/37
 

次の例のコマンド出力は、バックアップ パスおよび代替パスの BGP ルーティング テーブル エントリを示しています。関連するコマンド出力は太字で示されています。

Router# show ip bgp 10.0.0.0 255.255.0.0
BGP routing table entry for 10.0.0.0/16, version 123
Paths: (4 available, best #3, table default)
Additional-path
Advertised to update-groups:
2 3
Local
10.0.101.4 from 10.0.101.4 (10.3.3.3)
Origin IGP, localpref 100, weight 500, valid, internal
Local
10.0.101.3 from 10.0.101.3 (10.4.4.4)
Origin IGP, localpref 100, weight 200, valid, internal
Local
10.0.101.2 from 10.0.101.2 (10.1.1.1)
Origin IGP, localpref 100, weight 900, valid, internal, best
Local
10.0.101.1 from 10.0.101.1 (10.5.5.5)
Origin IGP, localpref 100, weight 700, valid, internal, backup/repair
 

次の例のコマンド出力は、バックアップ パスおよび代替パスのルーティング情報ベース エントリを示しています。関連するコマンド出力は太字で示されています。

 
Router# show ip route repair-paths 10.0.0.0 255.255.0.0
 
Routing entry for 10.0.0.0/16
Known via "bgp 10", distance 200, metric 0, type internal
Last update from 10.0.101.2 00:00:56 ago
Routing Descriptor Blocks:
* 10.0.101.2, from 10.0.101.2, 00:00:56 ago
Route metric is 0, traffic share count is 1
AS Hops 0
MPLS label: none
[RPR]10.0.101.1, from 10.0.101.1, 00:00:56 ago
Route metric is 0, traffic share count is 1
AS Hops 0
MPLS label: none
 

次の例のコマンド出力は、バックアップ パスおよび代替パスのシスコ エクスプレス フォワーディング/転送情報ベース エントリを示しています。関連するコマンド出力は太字で示されています。

 
Router# show ip cef 40.0.0.0 255.255.0.0 detail
 
10.0.0.0/16, epoch 0, flags rib only nolabel, rib defined all labels
recursive via 10.0.101.2
attached to GigabitEthernet0/2
recursive via 10.0.101.1, repair
attached to GigabitEthernet0/2

その他の参考資料

ここでは、BGP PIC機能に関する関連資料について説明します。

関連資料

関連項目
参照先

基本的な MPLS VPN

『Configuring MPLS Layer 3 VPNs』

リンク障害またはノード障害後に新しいパスを作成するフェールオーバー機能

『MPLS VPN--BGP Local Convergence』

マルチプロトコル VRF の設定

『MPLS VPN--VRF CLI for IPv4 and IPv6 VPNs』

BGP ルーティング

『BGP Feature Roadmap』

規格

規格
タイトル

draft-walton-bgp-add-paths-04.txt

『Advertisement of Multiple Paths in BGP』

MIB

MIB
MIB リンク

該当なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

RFC 1771

『A Border Gateway Protocol 4 (BGP-4)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

BGP PICの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS、Catalyst OS、Cisco IOS XE ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 BGP PIC の機能情報

機能名
リリース
機能情報

IP および MPLS-VPN 向け BGP PIC エッジ

12.2(33)SRE
12.2(33)XNE
15.0(1)S

BGP PIC 機能は、障害が生じた場合すぐにバックアップ/代替パスが引き継ぎ、サブセカンド フェールオーバーがイネーブル化されるように、Routing Information Base(RIB; ルーティング情報ベース)およびシスコ エクスプレス フォワーディングにバックアップ/代替パスを作成、保存します。

この機能は、12.2(33)SRE で Cisco 7200 および Cisco 7600 ルータに導入されました。

Cisco 10000 ルータのサポートは、12.2(33)XNE で追加されました。

15.0(1)S では、シスコ エクスプレス フォワーディング処理のサポートが Cisco 10000 ルータのラインカードに追加されました。

この機能に関する詳細については、次の各項を参照してください。

「BGP PIC の前提条件」

「BGP PICに関する制約事項」

「BGP PICについて」

「BGP PIC の設定方法」

次のコマンドが導入または変更されました。 bgp additional-paths install bgp recursion host show ip bgp show ip route show ip cef show vrf