マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
BGP 最良外部
BGP 最良外部
発行日;2012/01/31 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

BGP 最良外部

機能情報の確認

目次

の前提条件

に関する制約事項

について

BGP 最良外部の概要

最良外部ルートの意味

機能の動作

BGP 最良外部をイネーブルにするためのコンフィギュレーション モード

の設定方法

機能のイネーブル化

前提条件

機能の確認

の設定例

機能の設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

の機能情報

BGP 最良外部

BGP 最良外部機能を使用すると、ネットワークにバックアップ外部ルートを用意でき、プライマリ外部ルートの接続が失われるのを回避できます。BGP 最良外部機能は、外部ネイバーから受信するルートのうち最も優先するルートを、バックアップ ルートとしてアドバタイズします。この機能は、アクティブバックアップ トポロジで便利です。アクティブバックアップ トポロジでは、サービス プロバイダーはルーティング ポリシーを使用し、そのルーティング ポリシーにより、境界ルータは、internal BGP(iBGP; 内部 BGP)セッションを通じて受信するパス(別の境界ルータのパス)を、プレフィクスの最良パスとして選択します。これは、ルータが external BGP(eBGP; 外部 BGP))学習パスを保持する場合も同じです。このアクティブバックアップ トポロジでは、自律システムのプレフィクスに対し 1 つの終了または出力ポイントが定義され、プライマリ リンクまたは eBGP ピアリングが使用不可になった場合のバックアップとして他のポイントが使用されます。ポリシーにより、境界ルータは、eBGP セッションを通じて学習したパスを、自律システムから隠します。これは、そういったプレフィクスのパスをアドバタイズしないためです。この状況に対処するために、一部のルータは、最良外部パスと呼ばれる 1 つの外部学習パスをアドバタイズします。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「BGP 最良外部の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

BGP 最良外部の前提条件

リンク障害を迅速に検出するために、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)プロトコルをイネーブルにする必要があります。

BGP および Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ネットワークが稼動していて、複数のパス(マルチホーム)によりプロバイダー サイトと接続されているカスタマー サイトで実行されている必要があります。

バックアップ パスには、最良パスのネクスト ホップと異なる固有のネクスト ホップがある必要があります。

BGP は、動作パス間の損失なしのスイッチオーバーをサポートする必要があります。

BGP 最良外部に関する制約事項

BGP マルチパスが設置され、マルチパスが BGP テーブルに存在する場合、BGP 最良外部機能では、バックアップ パスは設置されません。マルチパスの 1 つが、他のパスのバックアップとして自動的に動作します。

次の機能では、BGP 最良外部機能はサポートされません。

MPLS VPN Carrier Supporting Carrier

MPLS VPN 相互自律システム、オプション B

VRF ラベル単位での MPLS VPN

マルチキャスト、L2VPN、または IPv6 VPN では BGP 最良外部機能は設定できません。

ルート リフレクタでは BGP 最良外部機能は設定できません。

BGP 最良外部機能は、NSF/SSO をサポートしていません。ただし、両方のルート プロセッサに BGP 最良外部機能が設定されている場合、ISSU がサポートされます。

BGP 最良外部機能は、VPNv4 および IPv4 VRF アドレス ファミリでのみ設定できます。

bgp advertise-best-external コマンドを使用して BGP 最良外部機能を設定する場合、 bgp additional-paths install コマンドを使用して BGP PIC 機能もイネーブルにする必要はありません。BGP PIC 機能は、BGP 最良外部機能により自動的にイネーブルになります。

BGP 最良外部機能を設定した場合、この機能は MPLS VPN - BGP ローカル コンバージェンス よりも優先されます。ただし、設定から protection local-prefixes コマンドを削除する必要はありません。

BGP 最良外部について

BGP 最良外部機能を設定する前に、次の概念を理解する必要があります。

「BGP 最良外部の概要」

「最良外部ルートの意味」

「BGP 最良外部機能の動作」

「BGP 最良外部をイネーブルにするためのコンフィギュレーション モード」

BGP 最良外部の概要

サービス プロバイダーはルーティング ポリシーを使用し、そのルーティング ポリシーにより、境界ルータは、internal BGP(iBGP; 内部 BGP)セッションを通じて受信したパス(別の境界ルータのパス)を、プレフィクスの最良パスとして選択します。これは、ルータが external BGP(eBGP; 外部 BGP)学習パスを保持している場合も同じです。この実践は、アクティブバックアップ トポロジとして一般に知られており、自律システム内のプレフィクスに対し 1 つの終了または出力ポイントを定義するため、およびプライマリ リンクまたは eBGP ピアリングが使用不能になった場合のバックアップとして他のポイントを使用するために実行されます。

ポリシーには利点もありますが、ポリシーが原因で、境界ルータは eBGP セッションを通じて学習したパスを、自律システムから隠します。これは、そういったプレフィクスのパスをアドバタイズしないためです。この状況に対処するために、一部のルータは、最良外部パスと呼ばれる 1 つの外部学習パスをアドバタイズします。最良外部の動作により、BGP 選択プロセスは、各宛先への 2 つのパスを選択します。

その宛先への既知ルートの完全セットから最良パスが選択されます。

最良外部パスは、外部ピアから受信した一連のルートから選択されます。

BGP は外部ピアに最良パスをアドバタイズします。内部ピアから最良パスを回収する代わりに、BGP は、iBGP パスを最良パスとして選択するとき、最良外部パスを内部ピアにアドバタイズします。

BGP 最良外部機能は、Prefix Independent(PIC; プレフィクス非依存)エッジの重要コンポーネントで、アクティブバックアップ トポロジのネットワークで代替パスを使用できるようにするインターネット アクセス シナリオと MPLS VPN シナリオの両方に対応します。

最良外部ルートの意味

BGP 最良外部機能では、バックアップ パスとして最良外部ルートが使用されます。これは、 draft-marques-idr-best-external に従い、外部ネイバーから受信したルートの中で最も優先されるルートです。外部ネイバーからの最優先ルートとして以下が有効です。

間で iBGP セッションを使用する、異なるクラスター内の 2 つのルータ。

間で eBGP セッションを使用する、コンフェデレーションの異なる自律システム内の 2 つのルータ。

最良外部ルートは、RIB に設定された最良ルートとは異なる場合があります。最良ルートが内部ルートの場合もあります。最良ルートに加えて、最良外部ルートをアドバタイズおよび保存できるようにすることで、プライマリ パスで障害が発生した場合に使用できる追加パスが用意され、ネットワークで、接続の回復が高速化されます。

BGP 最良外部機能の動作

BGP 最良外部機能は、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の draft-marques-idr-best-external.txt に基づきます。BGP 最良外部機能は、最良外部ルートをバックアップ ルートとして内部ピアにアドバタイズします。バックアップ ルートは、Routing Information Base(RIB; ルーティング情報ベース)およびシスコ エクスプレス フォワーディングに保存されます。プライマリ パスで障害が発生した場合、BGP PIC 機能により、最良外部パスが処理を引き継ぐことができ、接続をより速く回復できます。

図 1 MPLS VPN:MPLS VPN のエッジにある最良外部

図 1 に、BGP 最良外部機能を使用する MPLS VPN を示します。このネットワークには、次のコンポーネントが含まれます。

Provider Edge(PE; プロバイダー エッジ)ルータと Customer Edge(CE; カスタマー エッジ)ルータの間に eBGP セッションが存在します。

PE1 はプライマリ ルータで、より高いローカル優先順位が設定されています。

CE2 からのトラフィックは PE1 を使用してルータ CE1 に到達します。

PE1 には、CE1 に到達する 2 つのパスがあります。

CE1 は、PE1 および PE2 とデュアルホーム接続しています。

PE1 がプライマリ パスで、PE2 がバックアップ パスです。

図 1 では、MPLS クラウド内のトラフィックは PE1 を通過して CE1 に到達します。したがって、PE2 は PE1 を最良パスとして使用し、PE2 をバックアップ パスとして使用します。

PE1 および PE2 には、BGP 最良外部機能が設定されています。BGP は、最良パス(PE1-CE1 リンク)とバックアップ パス(PE2)の両方を計算し、両方のパスを RIB およびシスコ エクスプレス フォワーディングに設定します。最良パスに加えて、最良外部パス(PE2)もピア ルータにアドバタイズされます。

シスコ エクスプレス フォワーディングは、PE1-CE1 リンクのリンク障害を検出すると、バックアップ パス PE2 にただちに切り替えます。シスコ エクスプレス フォワーディングのローカル高速コンバージェンスにより、トラフィックは、バックアップ パスを使用して非常に迅速に再ルーティングされます。これにより、トラフィックの損失は最小限となり、高速コンバージェンスが達成されます。

BGP 最良外部をイネーブルにするためのコンフィギュレーション モード

各種モードで BGP 最良外部機能をイネーブルにでき、それぞれのモードで独自の方法で VRF が保護されます。

VPNv4 アドレス ファミリ コンフィギュレーション モードで bgp advertise-best-external コマンドを発行すると、この機能はすべての IPv4 VRF に適用されます。このモードでコマンドを発行する場合、特定の VRF に対してコマンドを発行する必要はありません。

IPv4 アドレス ファミリ コンフィギュレーション モードで bgp advertise-best-external コマンドを発行すると、この機能はその VRF にのみ適用されます。

BGP 最良外部の設定方法

BGP 最良外部機能をイネーブルにするには、次の作業を実行します。

「BGP 最良外部機能のイネーブル化」

「BGP 最良外部機能の確認」

BGP 最良外部機能のイネーブル化

BGP 最良外部機能をイネーブルにするには、次の作業を実行します。この作業では、示されている設定により、IPv4 または VPNv4 アドレス ファミリで BGP 最良外部機能を設定できます。VPNv4 アドレス ファミリ コンフィギュレーション モードでは、BGP 最良外部機能は、すべての IPv4 VRF に適用され、特定の VRF に対してこの機能を設定する必要はありません。IPv4 VRF アドレス ファミリ コンフィギュレーション モードで bgp advertise-best-external コマンドを発行すると、BGP 最良外部機能はその VRF にのみ適用されます。

前提条件

BGP 最良外部機能を設定する前に、MPLS VPN を設定し、正しく動作することを確認します。詳細については、『 Configuring MPLS Layer 3 VPNs 』を参照してください。

マルチプロトコル VRF を設定します。これにより、IPv4 と IPv6 の間でルート ターゲット ポリシー(インポートおよびエクスポート)を共有すること、または IPv4 および IPv6 VPN に対し個別のルート ターゲット ポリシーを設定することができます。マルチプロトコル VRF の設定の詳細については、『 MPLS VPN--VRF CLI for IPv4 and IPv6 VPNs 』を参照してください。

CE ルータが少なくとも 2 つのパスでネットワークに接続されていることを確認します。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 [ unicast | vrf vrf-name ]
または
address-family vpnv4 [ unicast ]

5. bgp advertise-best-external

6. neighbor ip-address remote-as autonomous-system-number

7. neighbor ip-address activate

8. neighbor ip-address fall-over [ bfd | route-map map-name ]

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 40000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast | vrf vrf-name ]

または

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family ipv4 unicast

または

Router(config-router)# address-family vpnv4

IPv4 または VPNv4 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワード は、IPv4 または VPNv4 ユニキャスト アドレス ファミリを指定します。

vrf キーワードと vrf-name 引数は、それ以降の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドと関連付けられる Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンスの名前を表します。

ステップ 5

bgp advertise-best-external

 

Router(config-router-af)# bgp advertise-best-external

外部バックアップ パスを計算および使用し、その外部バックアップ パスを RIB およびシスコ エクスプレス フォワーディングに設定します。

ステップ 6

neighbor ip-address remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 45000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義されたネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。その他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプについて、アドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要があります。

ステップ 7

neighbor ip-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

ネイバーが IPv4 ユニキャスト アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

ステップ 8

neighbor ip-address fall-over [ bfd | route-map map-name ]

 

Router(config-router-af)# neighbor 192.168.1.1 fall-over bfd

高速セッション無効化を使用するように BGP ピアリングを設定し、フェールオーバーに関する BFD プロトコル サポートをイネーブルにします。

BGP は、セッションが無効になると、このピアで学習したすべてのルートを削除します。

ステップ 9

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

BGP 最良外部機能の確認

BGP 最良外部機能が正しく設定されていることを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show vrf detail

3. show ip bgp ipv4 { mdt { all | rd | vrf } | multicast | tunnel | unicast }
または
show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ rib-failure ] [ ip-prefix/length [ longer-prefixes ]] [ network-address [ mask ] [ longer-prefixes ]] [ cidr-only] [ community ] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics ] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ labels ]

4. show bgp vpnv4 unicast vrf vrf-name ip-address

5. show ip route vrf vrf-name repair-paths ip-address

6. show ip cef vrf vrf-name ip-address detail

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。次に例を示します。

Router> enable
Router#
 

ステップ 2 show vrf detail

このコマンドを使用して、BGP 最良外部機能がイネーブルになっていることを確認します。次の show vrf detail コマンド出力は、BGP 最良外部機能がイネーブルになっていることを示しています(関連する出力は太字で示されています)。

 
Router# show vrf detail
 
VRF test1 (VRF Id = 1); default RD 400:1; default VPNID <not set>
Interfaces:
Se4/0
Address family ipv4 (Table ID = 1 (0x1)):
Export VPN route-target communities
RT:100:1 RT:200:1 RT:300:1
RT:400:1
Import VPN route-target communities
RT:100:1 RT:200:1 RT:300:1
RT:400:1
No import route-map
No export route-map
VRF label distribution protocol: not configured
VRF label allocation mode: per-prefix
Prefix protection with additional path enabled
Address family ipv6 not active.
 

ステップ 3 show ip bgp ipv4 { mdt { all | rd | vrf } | multicast | tunnel | unicast }
または
show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ rib-failure ] [ ip-prefix/length [ longer-prefixes ]] [ network-address [ mask ] [ longer-prefixes ]] [ cidr-only] [ community ] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics ] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ labels ]

このコマンドを使用して、最良外部ルートがアドバタイズされることを確認します。コマンド出力では、コード b がバックアップ パスを示しており、コード x が最良外部パスを示しています。次の例では、関連する出力は太字で示されています。

Router# show ip bgp vpnv4 all
 
BGP table version is 1104964, local router ID is 10.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 11:12 (default for vrf blue)
*>i1.0.0.1/32 10.10.3.3 0 200 0 1 ?
* i 10.10.3.3 0 200 0 1 ?
* 10.0.0.1 0 1 ?
*bx 10.0.0.1 0 0 1 ?
* 10.0.0.1 0 1 ?
 

ステップ 4 show bgp vpnv4 unicast vrf vrf-name ip-address

このコマンドを使用して、最良外部ルートがアドバタイズされることを確認します。次の例では、関連する出力は太字で示されています。

Router# show bgp vpnv4 unicast vrf vpn1 10.10.10.10
 
BGP routing table entry for 10:10:10.10.10.10/32, version 10
Paths: (2 available, best #1, table vpn1)
Advertise-best-external
Advertised to update-groups:
1 2
200
10.6.6.6 (metric 21) from 10.6.6.6 (10.6.6.6)
Origin incomplete, metric 0, localpref 200, valid, internal, best
Extended Community: RT:1:1
mpls labels in/out 23/23
200
10.1.2.1 from 10.1.2.1 (10.1.1.1)
Origin incomplete, metric 0, localpref 100, valid, external, backup/repair, advertise-best-external
Extended Community: RT:1:1 , recursive-via-connected
mpls labels in/out 23/nolabel
 

ステップ 5 show ip route vrf vrf-name repair-paths ip-address

このコマンドを使用して、修復ルートを表示します(太字で示されています)。

Router# show ip route vrf vpn1 repair-paths
 
Routing Table: vpn1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override
 
Gateway of last resort is not set
 
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 10.1.1.0/24 [200/0] via 10.6.6.6, 00:38:33
[RPR][200/0] via 10.1.2.1, 00:38:33
B 10.1.1.1/32 [200/0] via 10.6.6.6, 00:38:33
[RPR][200/0] via 10.1.2.1, 00:38:33
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C 10.1.2.0/24 is directly connected, Ethernet0/0
L 10.1.2.2/32 is directly connected, Ethernet0/0
B 10.1.6.0/24 [200/0] via 10.6.6.6, 00:38:33
[RPR][200/0] via 10.1.2.1, 00:38:33
 

ステップ 6 show ip cef vrf vrf-name ip-address detail

このコマンドを使用して、最良外部ルートを表示します。次の例では、関連する出力は太字で示されています。

Router# show ip cef vrf test 10.71.8.164 detail
 
10.71.8.164/30, epoch 0, flags rib defined all labels
recursive via 10.249.0.102 label 35
nexthop 10.249.246.101 Ethernet0/0 label 25
recursive via 10.249.0.104 label 28, repair
nexthop 10.249.246.101 Ethernet0/0 label 24

BGP 最良外部の設定例

次に、BGP 最良外部 機能を設定し、検証する例を示します。

「BGP 最良外部機能の設定:例」

BGP 最良外部機能の設定:例

次の例では、VPNv4 モードで BGP 最良外部機能を設定します。

vrf definition test1
rd 400:1
route-target export 100:1
route-target export 200:1
route-target export 300:1
route-target export 400:1
route-target import 100:1
route-target import 200:1
route-target import 300:1
route-target import 400:1
address-family ipv4
exit-address-family
exit
!
interface Ethernet1/0
vrf forwarding test1
ip address 10.0.0.1 255.0.0.0
exit
!
router bgp 64500
no synchronization
bgp log-neighbor-changes
neighbor 10.5.5.5 remote-as 64500
neighbor 10.5.5.5 update-source Loopback0
neighbor 10.6.6.6 remote-as 64500
neighbor 10.6.6.6 update-source Loopback0
no auto-summary
!
address-family vpnv4
bgp advertise-best-external
neighbor 10.5.5.5 activate
neighbor 10.5.5.5 send-community extended
neighbor 10.6.6.6 activate
neighbor 10.6.6.6 send-community extended
exit-address-family
!
address-family ipv4 vrf test1
no synchronization
bgp recursion host
neighbor 192.168.13.2 remote-as 64511
neighbor 192.168.13.2 fall-over bfd
neighbor 192.168.13.2 activate
neighbor 192.168.13.2 as-override
exit-address-family

その他の参考資料

ここでは、BGP 最良外部機能に関する関連資料について説明します。

関連資料

関連項目
参照先

基本的な MPLS VPN

『Configuring MPLS Layer 3 VPNs』

マルチプロトコル VRF

『MPLS VPN--VRF CLI for IPv4 and IPv6 VPNs』

リンク障害またはノード障害後に新しいパスを作成するフェールオーバー機能

『MPLS VPN--BGP Local Convergence』

BGP ルーティング

『BGP Feature Roadmap』

規格

規格
タイトル

draft-marques-idr-best-external

『BGP Best-external, Advertisement of the best-external route to iBGP』

MIB

MIB
MIB リンク

該当なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

RFC 1771

A Border Gateway Protocol 4 (BGP-4)

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

BGP 最良外部の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 BGP 最良外部 の機能情報

機能名
リリース
機能情報

BGP 最良外部

12.2(33)SRE

BGP 最良外部機能は、障害が生じた場合すぐにバックアップ パスが引き継ぎ、サブセカンド フェールオーバーがイネーブル化されるように、ルーティング情報ベースおよび Cisco Express Forwarding にバックアップ パスを作成、保存します。

この機能は、Cisco IOS Release 12.2(33)SRE で導入されました。

この機能に関する詳細については、次の各項を参照してください。

「BGP 最良外部について」

「BGP 最良外部の設定方法」

「BGP 最良外部の設定例」

次のコマンドが導入または変更されました。 bgp advertise-best-external bgp recursion host、show ip bgp、show ip bgp vpnv4、show ip cef、show ip cef vrf、show ip route、show ip route vrf。