マルチプロトコル ラベル スイッチング コンフィギュ レーション ガイド、Cisco IOS Release 15.1S
マルチポイント GRE トンネルを使用するダイ ナミック レイヤ 3 VPN
マルチポイント GRE トンネルを使用するダイナミック レイヤ 3 VPN
発行日;2012/01/31 | 英語版ドキュメント(2010/05/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 16MB) | フィードバック

目次

マルチポイント GRE トンネルを使用するダイナミック レイヤ 3 VPN

機能情報の確認

目次

mGRE トンネルを使用するダイナミック L3 VPN の前提条件

mGRE トンネルを使用するダイナミック L3 VPN の制約事項

mGRE トンネルを使用したダイナミック L3 VPN について

レイヤ 3 mGRE トンネル

IP ネットワーク内でのプロバイダー エッジ ルータの相互接続

IP ネットワークと MPLS ネットワーク間のパケット転送

BGP ネクスト ホップの検証

L3 VPN mGRE トンネルの設定方法

VRF および mGRE トンネルの作成

前提条件

BGP VPN 変換の設定

MPLS VPN over mGRE トンネルのイネーブル化と L3VPN カプセル化プロファイルの設定

前提条件

MPLS VPN over mGRE のアドレス空間の定義とアドレス解決の指定

次の作業

mGRE トンネルを使用したダイナミック L3 VPN サポートの設定例

レイヤ 3 VPN mGRE トンネルの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

mGRE トンネルを使用するダイナミック L3 VPN の機能情報

マルチポイント GRE トンネルを使用するダイナミック レイヤ 3 VPN

マルチポイント GRE トンネル機能を使用したダイナミック レイヤ 3 VPN を使用すると、拡張された Multipoint Generic Routing Encapsulation(mGRE; マルチポイント総称ルーティング カプセル化)トンネリング テクノロジーに基づいた Layer 3(L3; レイヤ 3)転送メカニズムを IP ネットワークで使用できます。また、ダイナミック レイヤ 3 のトンネリング転送を IP ネットワーク内で使用して、サービス プロバイダーと企業のネットワーク間で Virtual Private Network(VPN; バーチャル プライベート ネットワーク)のトラフィックを転送したり、IP と Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN 間のパケット転送を相互運用したりできるようになります。この機能では RFC 2547 をサポートします。RFC 2547 は企業ネットワークにおける IP バックボーン サービスのアウトソーシングを定義します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「mGRE トンネルを使用するダイナミック L3 VPN の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

mGRE トンネルを使用するダイナミック L3 VPN の前提条件

マルチポイント GRE トンネル機能を使用したダイナミック レイヤ 3 VPN を設定する前に、使用している MPLS VPN が適切に設定され、正常に動作していることを確認します。MPLS VPN の設定の詳細については、『 Configuring MPLS Layer 3 VPNs 』モジュールを参照してください。

mGRE トンネルを使用するダイナミック L3 VPN の制約事項

IP/GRE と MPLS カプセル化の両方を単一のネットワーク内で使用する MPLS VPN の展開はサポートされていません。

各 Provider Edge(PE; プロバイダー エッジ)ルータは、1 つのトンネル設定だけをサポートします。

mGRE トンネルを使用したダイナミック L3 VPN について

IP バックボーンをオーバーレイするマルチポイント トンネル ネットワークを作成するように mGRE トンネルを設定できます。このオーバーレイによって PE ルータ同士が接続され、VPN トラフィックを転送します。

さらに、MPLS VPN を mGRE を介して設定すると、標準ベースの IP コアを使用して、L3 PE ベースの VPN サービスを導入できます。これにより、オーバーレイ方式を使用しないで VPN サービスをプロビジョニングできます。MPLS VPN over mGRE が設定されると、システムでは IPv4 ベースの mGRE トンネルを使用して、PE 間の VPN ラベルが付けられた IPv4 および IPv6 のパケットをカプセル化します。

ここでは、次の情報について説明します。

「レイヤ 3 mGRE トンネル」

レイヤ 3 mGRE トンネル

mGRE トンネルを設定して、マルチポイント トンネル ネットワークを IP バックボーンのオーバーレイとして作成します。このオーバーレイによって、PE ルータ同士が相互接続され、バックボーンを介して VPN トラフィックを転送します。このマルチポイント トンネル ネットワークは Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)を使用して、PE ルータ間の VPNv4 ルーティング情報を配布し、サービス プロバイダーまたは企業ネットワークとお客様のサイト間のピア関係を維持します。BGP VPNv4 内でアドバタイズされたネクスト ホップは、トンネル エンドポイント ディスカバリをトリガーします。この機能により、複数のサービス プロバイダーが連携して、あるサービス プロバイダーの入力 PE ルータから別のサービス プロバイダー サイトの出力 PE ルータに直接トラフィックをトンネルする、共同の VPN サービスを提供できます。

この VPN 転送機能に加えて、mGRE トンネルはフル メッシュ トポロジを作成し、複数のお客様のサイトを相互接続するために使用されているポイントツーポイント トンネルのフル メッシュに係わる管理および運用のオーバーヘッドを削減します。設定の要件が大幅に削減されるため、最小限の追加設定でネットワークを拡張できます。

ダイナミック L3 トンネルを使用すると、部分メッシュ VPN やフル メッシュ VPN を作成する場合のスケーリングが容易になります。新しいルータだけを設定すればすむため、新しいリモート VPN ピアを簡単に追加できます。新しいアドレスはダイナミックに学習され、ネットワーク内のノードに伝播されます。ダイナミック ルーティング機能により、VPN 内のすべてのルータに必要な設定のサイズが劇的に縮小します。たとえば、マルチポイント トンネルを使用する場合、多数の VPN にサービスを提供する PE で設定する必要があるのは、1 つのトンネル インターフェイスだけであり、L3 mGRE トンネルの設定が必要なのは PE ルータだけです。mGRE や Next Hop Routing Protocol(NHRP; ネクスト ホップ ルーティング プロトコル)トンネル トラフィックのダイナミック IP ルーティング、IP マルチキャスト、Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)スイッチングなど、GRE で利用できる機能は mGRE でも使用できます。

次の各項では、mGRE トンネルの使用方法を説明します。

「IP ネットワーク内でのプロバイダー エッジ ルータの相互接続」

「IP ネットワークと MPLS ネットワーク間のパケット転送」

「BGP ネクスト ホップの検証」

IP ネットワーク内でのプロバイダー エッジ ルータの相互接続

マルチポイント GRE トンネル機能を使用したダイナミック レイヤ 3 VPN を使用すると、IP ネットワークにサービスを提供する PE ルータ同士を相互接続するマルチアクセス トンネル ネットワークを作成できます。このトンネル ネットワークはすべての PE ルータに IP VPN トラフィックを転送します。図 1 は、PE ルータ間で VPN トラフィックを転送するために IP ネットワークで使用されるトンネル オーバーレイ ネットワークを表します。

図 1 IP ネットワーク内で PE ルータを接続する mGRE トンネル オーバーレイ

 

マルチアクセス トンネル オーバーレイ ネットワークでは PE ルータ間が完全に接続されます。PE ルータは RFC 2547 で定義されている BGP を使用して VPN ルートを交換します。IP トラフィックは、オーバーレイ ネットワークおよび転送ネットワークのダイレクト IP アドレス空間を使用し、アドレスの数値ではなくアドレス空間を変更することによって、マルチポイント トンネル オーバーレイ ネットワークからリダイレクトされます。

IP ネットワークと MPLS ネットワーク間のパケット転送

レイヤ 3 mGRE トンネルは、IP ネットワークと MPLS ネットワーク間のパケット転送メカニズムとして使用できます。2 つの異なるプロトコル間でパケットを転送できるようにするには、2 つのネットワーク間の接続の一方にある 1 台の PE ルータで MPLS を実行する必要があります。図 2 に、mGRE トンネルを使用して、PE ルータ間で VPN トラフィックを転送する方法を示します。

図 2 IP ネットワークと MPLS ネットワーク間の VPN トラフィックの転送に使用される mGRE

 

IP ネットワークと MPLS ネットワーク間でパケットを転送するには、MPLS VPN ラベルを GRE キーにマッピングします。このマッピングは、mGRE と MPLS の両方が設定されているルータで行われます。図 2 では、キーへのラベルのマッピングは、MPLS ネットワーク上にあるルータ M で行われます。

BGP ネクスト ホップの検証

BGP は PE で BGP パスの選択またはネクスト ホップの検証を実行します。ネットワークへの BGP パスがパスの選択プロセスで考慮されるには、そのパスのネクスト ホップが Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)で到達可能である必要があります。IP プレフィクスが受信され、ネクスト ホップ IP アドレスとしてアドバタイズされると、ネクスト ホップのアドレス空間を切り替えることによって、IP トラフィックは送信元から宛先にトンネルされます。

L3 VPN mGRE トンネルの設定方法

L3 VPN mGRE トンネルを展開するには、VRF インスタンスを作成し、mGRE トンネルを作成し、VPN IP トラフィックをトンネルにリダイレクトし、BGP VPNv4 変換を設定します。これにより、ルート マップによって更新がフィルタリングされ、対象のプレフィクスが VRF テーブルで解決されるようになります。

L3 VPN over mGRE を展開するための設定作業は、次の各項で説明されています。

「VRF および mGRE トンネルの作成」(必須)

「BGP VPN 変換の設定」(必須)

「MPLS VPN over mGRE トンネルのイネーブル化と L3VPN カプセル化プロファイルの設定」(必須)

「MPLS VPN over mGRE のアドレス空間の定義とアドレス解決の指定」(必須)

VRF および mGRE トンネルの作成

サービス プロバイダーのネットワークで VPN トラフィックを転送するトンネルは、それ自体のアドレス空間にあります。Resolve in VRF(RiV)と呼ばれる特別な VRF インスタンスが作成される必要があります。ここでは、VRF と GRE トンネルを作成する方法について説明します。

前提条件

インターフェイスの IP アドレスは、設定内に指定されている送信元インターフェイスと同じである必要があります。指定されている送信元インターフェイスは、BGP が VPNv4 更新の送信元として使用しているインターフェイスに一致する必要があります。


) トンネル モード IPSec は、MPLS over GRE トンネルではサポートされていません。


手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd 1:1

5. interface tunnel tunnel name

6. ip address ip-address subnet-id

7. tunnel source loopback n

8. tunnel mode gre multipoint l3vpn

9. tunnel key gre-key

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf customer a riv

特別な Resolve in VRF(RiV)VRF インスタンスと、IP アドレスのトンネルおよびリダイレクトに使用されるテーブルを作成します。

ステップ 4

rd 1:1

 

Router(config-vrf)# rd 1:1

VRF コンフィギュレーション モードを開始し、VPN VRF インスタンスの Route Distinguisher(RD; ルート識別子)を指定します。

ステップ 5

interface tunnel tunnel-name

 

Router(config-vrf)# interface tunnel 1

インターフェイス コンフィギュレーション モードを開始し、トンネルを作成します。

ステップ 6

ip address ip-address subnet-id

 

Router(config-if)# ipaddress 209.165.200.225 255.255.255.224

トンネルの IP アドレスを指定します。

ステップ 7

tunnel source loopback n

 

Router(config-if)# tunnel source loopback test1

ループバック インターフェイスを作成します。

ステップ 8

tunnel mode gre multipoint l3vpn

 

Router(config-if)# tunnel mode gre multipoint l3vpn

トンネルのモードを「gre multipoint l3vpn」に設定します。

ステップ 9

tunnel key gre-ke y

 

Router(config-if)# tunnel key 18

トンネルの GRE キーを指定します。

ステップ 10

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

BGP VPN 変換の設定

ここで説明されている設定作業では、ルート マップによって更新がフィルタリングされ、対象のプレフィクスが VRF テーブルで解決されるように、BGP VPNv4 変換を設定します。

手順の概要

1. enable

2. configure terminal

3. interface tunnel tunnel name

4. ip route vrf riv-vrf-name IP address subnet mask tunnel n

5. router bgp as-number

6. network network id

7. neighbor { ip-address | peer-group-name } remote-as as-number

8. neighbor { ip-address | peer-group-name } update-source interface-type

9. address-family vpnv4 [ unicast ]

10. neighbor { ip-address | peer-group-name } activate

11. neighbor { ip-address | peer-group-name } route-map map-name { in | out }

12. set ip next-hop resolve-in-vrf vrf name

13. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel tunnel-name

 

Router(config)# interface tunnel 1

トンネルのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip route vrf riv-vrf-name ip-address subnet- mask tunnel n

 

Router(config-if)# ip route vrf vrf1 209.165.200.226 255.255.255.224 tunnel 1

特別な RiV VRF へのパケット転送を設定します。

ステップ 5

router bgp as-number

 

Router(config)# router bgp 100

ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を指定します。

ステップ 6

network network-id

 

Router(config)# network 209.165.200.255

BGP およびマルチプロトコル BGP ルーティング プロセスによってアドバタイズされる、ネットワークのネットワーク ID を指定します。

ステップ 7

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config)# neighbor 209.165.200.227 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ステップ 8

neighbor { ip-address | peer-group-name } update-source interface-type

 

Router(config)# neighbor 209.165.200.228 update-source FastEthernet0/1

BGP セッションが TCP 接続で使用する特定の動作インターフェイスを指定します。

ステップ 9

address-family vpnv4 [ unicast ]

 

Router(config)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPN4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを指定します。

ステップ 10

neighbor { ip-address | peer-group-name } activate

 

Router(config)# neighbor 209.165.200.229 activate

ネイバー ルータとの情報交換をイネーブルにします。

ステップ 11

neighbor { ip-address | peer-group-name } route-map map-name { in | out }

 

Router(config)# neighbor 209.165.200.230 route-map mpt in

受信または発信ルートにルート マップを適用します。

各インバウンド ルートに一度だけ使用します。

ステップ 12

set ip next-hop resolve-in-vrf vrf-name

 

Router(config)# set ip next-hop resolve-in-vrf vrft

指定した VRF の VRF テーブルでネクスト ホップが解決されるように指定します。

ステップ 13

end

 

Router(config)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MPLS VPN over mGRE トンネルのイネーブル化と L3VPN カプセル化プロファイルの設定

ここでは、VRF を定義し、MPLS VPN over mGRE をイネーブルにし、L3VPN カプセル化プロファイルを設定する方法について説明します。


) この設定では、IPv6、MPLS、IP、レイヤ 2 トンネリング プロトコル バージョン 3(L2TPv3)などの転送プロトコルを使用することもできます。


前提条件

MPLS VPN over mGRE をイネーブルにして設定するには、まずトンネル カプセル化の VRF を定義し、システムで L3VPN カプセル化イネーブルにする必要があります。

手順の概要

1. enable

2. configure terminal

3. vrf definition vrf-name

4. rd 1:1

5. exit

6. ip cef

7. ipv6 unicast-routing

8. ipv6 cef

9. l3vpn encapsulation ip profile name

10. transport ipv4 [ source interface n ]

11. protocol gre [ key gre-key ]

12. exit

13. interface type number

14. ip address ip-address mask

15. ip router isis

16. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name

 

Router(config)# vrf definition tunnel encap

VPN VRF ルーティング テーブル インスタンスを設定し、VRF コンフィギュレーション モードを開始します。

ステップ 4

rd 1:1

 

Router(config-vrf)# rd 1:1

VPN VRF インスタンスに RD を指定します。

ステップ 5

exit

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了します。

ステップ 6

ip cef

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングをルータでイネーブルにします。

ステップ 7

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ステップ 8

ipv6 cef

 

Router(config)# ipv6 cef

IPv6 でのシスコ エクスプレス フォワーディングをルータでイネーブルにします。

ステップ 9

l3vpn encapsulation ip profile-name

 

Router(config)# l3vpn encapsulation ip tunnel encap

L3 VPN カプセル化コンフィギュレーション モードを開始し、トンネルを作成します。

ステップ 10

transport ipv4 source interface n

 

Router(config-l3vpn-encap-ip)# transport ipv4 source loopback 0

IPv4 転送送信元モードを指定し、転送送信元インターフェイスを定義します。

ステップ 11

protocol gre [ key gre-key ]

 

Router(config-l3vpn-encap-ip)# protocol gre key 1234

GRE をトンネル モードとして指定し、GRE キーを設定します。

ステップ 12

exit

 

Router(config-l3vpn-encap-ip)# exit

L3 VPN カプセル化コンフィギュレーション モードを終了します。

ステップ 13

interface type number

 

Router(config)# interface loopback 0

インターフェイス コンフィギュレーション モードを開始し、特定のインターフェイス タイプを設定します。

ステップ 14

ip address ip-address mask

 

Router(config-if)# ip address 10.10.10.4 255.255.255.255

インターフェイスのプライマリ IP アドレスおよびマスクを指定します。

ステップ 15

ip router isis

 

Router(config-if)# ip router isis

IP 用の Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスをインターフェイスに設定し、ルーティング プロセスにヌル エリア指示子を付加します。

ステップ 16

end

 

Router(config-if)#end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MPLS VPN over mGRE のアドレス空間の定義とアドレス解決の指定

ここでは、MPLS VPN over mGRE のアドレス空間を定義し、アドレス解決を指定する方法について説明します。次の手順を実行すると、ルート マップで更新をフィルタリングするために、ルート マップをアプリケーション テンプレートにリンクし、BGP VPNv4 および VPNv6 の変換を設定することもできます。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor ip-address remote-as as-number

6. neighbor ip-address update-source interface name

7. address-family ipv4

8. no synchronization

9. redistribute connected

10. neighbor ip-address activate

11. no auto-summary

12. exit

13. address-family vpnv4

14. neighbor ip-address activate

15. neighbor ip-address send-community both

16. neighbor ip-address route-map map-name in

17. exit

18. address-family vpnv6

19. neighbor ip-address activate

20. neighbor ip-address send-community both

21. neighbor ip-address route-map map-name in

22. exit

23. route-map map-tag permit position

24. set ip next-hop encapsulate l3vpn profile name

25. set ipv6 next-hop encapsulate l3vpn profile name

26. exit

27. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router (config)# router bgp 100

ルータを他の BGP ルータと識別する自律システムの番号を指定し、転送されるルーティング情報にタグを付け、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bgp log-neighbor-changes

 

Router (config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 5

neighbor ip-address remote-as as-number

 

Router (config-router)# neighbor 10.10.10.6 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ステップ 6

neighbor ip-address update-source interface-type interface-name

 

Router (config-router)# neighbor 10.10.10.6 update-source loopback 0

TCP 接続の動作インターフェイスを使用できるよう BGP セッションを許可します。

ステップ 7

address-family vpn4

 

Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、ルーティング セッションを設定します。このルーティング セッションは、IPv4 アドレス プレフィクスを使用します。

ステップ 8

no synchronization

 

Router (config-router-af)# no synchronization

IGP を待機せずにネットワーク ルートをアドバタイズするように、Cisco IOS ソフトウェアをイネーブルにします。

ステップ 9

redistribute connected

 

Router (config-router-af)# redistribute connected

1 つのルーティング ドメインから別のルーティング ドメインにルートを再配布します。また、送信元プロトコルが実行されている各インターフェイス上の送信元プロトコルおよび接続されているプレフィクスよって学習されたルートを、ターゲット プロトコルが再配布できるようにします。

ステップ 10

neighbor ip-address activate

 

Router (config-router-af)# neighbor 10.10.10.6 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 11

no auto-summary

 

Router (config-router-af)# no auto-summary

自動サマライズをディセーブルにし、サブプレフィクス ルーティング情報をクラスフル ネットワーク境界間で送信します。

ステップ 12

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 13

address-family vpnv4

 

Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

ステップ 14

neighbor ip-address activate

 

Router (config-router-af)# neighbor 10.10.10.6 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 15

neighbor ip-address send-community both

 

Router (config-router-af)# neighbor 10.10.10.6 send-community both

標準コミュニティと拡張コミュニティの両方のコミュニティ アトリビュートが BGP ネイバーに送信されるように指定します。

ステップ 16

neighbor ip-address route-map map-name in

 

Router (config-router-af)# neighbor 10.10.10.6 route-map SELECT UPDATE FOR L3VPN in

名前付きルート マップを着信ルートに適用します。

ステップ 17

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 18

address-family vpnv6

 

6Router (config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、VPNv6 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

ステップ 19

neighbor ip-address activate

 

Router (config-router-af)# neighbor 209.165.200.252 activate

BGP ネイバーとの情報交換をイネーブルにします。

ステップ 20

neighbor ip-address send-community both

 

Router (config-router-af)# neighbor 209.165.200.252 send-community both

標準コミュニティと拡張コミュニティの両方のコミュニティ アトリビュートが BGP ネイバーに送信されるように指定します。

ステップ 21

neighbor ip-address route-map ip-address in

 

Router (config-router-af)# neighbor 209.165.200.252 route-map SELECT UPDATE FOR L3VPN in

名前付きルート マップを着信ルートに適用します。

ステップ 22

exit

 

Router (config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 23

route-map map-tag permit position

 

Router (config-router)# route-map 192.168.10.1 permit 10

ルートマップ コンフィギュレーション モードを開始し、1 つのルーティング プロトコルから別のルーティング プロトコルにルートを再配布するための条件を定義します。

redistribute ルータ コンフィギュレーション コマンドでは、指定したマップ タグを使用して、このルート マップを参照します。複数のルート マップで同じマップ タグ名を共有できます。

このルート マップの一致基準が満たされている場合は、set アクションの制御に従ってルートが再配布されます。

一致基準が満たされない場合、同一のマップ タグを持つ次のルート マップがテストされます。あるルートが、同じ名前を共有するルート マップ セットの一致基準のいずれをも満たさない場合、そのセットによる再配布は行われません。

position 引数は、すでに同じ名前で設定されているルート マップのリスト内に新しいルート マップが入る位置を示します。

ステップ 24

set ip next-hop encapsulate l3vpn tunnel encap

 

Router (config-route-map)# set ip next-hop encapsulate l3vpn my profile

ルート マップの match 句を引き渡す出力 IPv4 パケットが、トンネル カプセル化のために VRF に送信されることを示します。

ステップ 25

set ipv6 next-hop encapsulate l3vpn profile name

 

Router (config-route-map)# set ip next-hop encapsulate l3vpn tunnel encap

 

ルート マップの match 句を引き渡す出力 IPv6 パケットが、トンネル カプセル化のために VRF に送信されることを示します。

ステップ 26

end

 

Router (config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 27

end

 

Router (config)# exit

グローバル コンフィギュレーション モードを終了します。

次の作業

次の作業を実行すると、設定が正しく動作していることを確認できます。

VRF プレフィクスの確認

指定した VRF プレフィクスが BGP で受信されていることを確認します。BGP テーブル エントリには、ルート マップが正しく動作していることと、ネクスト ホップが RiV に示されていることが示されます。この例に示すように、 show ip bgp vpnv4 コマンドを使用します。

Router# show ip bgp vpnv4 vrf customer 209.165.200.250
 
BGP routing table entry for 100:1:209.165.200.250/24, version 12
Paths: (1 available, best #1)
Not advertised to any peer
Local
209.165.200.251 in "my riv" from 209.165.200.251 (209.165.200.251)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:100:1
 

同じ情報がルーティング テーブルに伝播されていることを確認します。

Router# show ip route vrf customer 209.165.200.250
 
Routing entry for 209.165.200.250/24
Known via "bgp 100", distance 200, metric 0, type internal
Last update from 209.165.200.251 00:23:07 ago
Routing Descriptor Blocks:
* 209.165.200.251 (my riv), from 209.165.200.251, 00:23:07 ago
Route metric is 0, traffic share count is 1
AS Hops 0

CEF スイッチング

CEF スイッチングが正常に動作していることも確認できます。

Router# show ip cef vrf customer 209.165.200.250
 
209.165.200.250/24, version 6, epoch 0
0 packets, 0 bytes
tag information set
local tag: VPN-route-head
fast tag rewrite with Tu1, 123.1.1.2, tags imposed: {17}
via 209.165.200.251, 0 dependencies, recursive
next hop 209.165.200.251, Tunnel1 via 209.165.200.251/32 (my riv)
valid adjacency
tag rewrite with Tu1, 209.165.200.251, tags imposed: {17}

エンドポイントの作成

この例では、トンネル エンドポイントが正しく作成されていることを示しています。

Router# show tunnel endpoint tunnel 1
 
Tunnel1 running in multi-GRE/IP mode
RFC2547/L3VPN Tunnel endpoint discovery is active on Tu1
Transporting l3vpn traffic to all routes recursing through "my riv"
 
Endpoint 209.165.200.251 via destination 209.165.200.251
Endpoint 209.165.200.254 via destination 209.165.200.254

隣接

対応する隣接が作成されていることを確認します。

Router# show adjacency Tunnel 1 interface
Protocol Interface Address
TAG Tunnel1 209.165.200.251(4)
15 packets, 1980 bytes
4500000000000000FF2FC3C77B010103
7B01010200008847
Epoch: 0
Fast adjacency disabled
IP redirect disabled
IP mtu 1472 (0x0)
Fixup enabled (0x2)
GRE tunnel
Adjacency pointer 0x624A1580, refCount 4
Connection Id 0x0
Bucket 121
 

MPLS は mGRE を介して転送されているため、LINK_TAG 隣接は関連する隣接であることに注意してください。隣接で報告された MTU は、パケットが受け入れるペイロード長(MPLS ラベルを含む)です。隣接表示に示されている MAC 文字列は、次のように解釈できます。

45000000 -> Beginning of IP Header (Partially populated, tl & chksum
00000000 are fixed up per packet)
FF2FC3C7
7B010103 -> Source IP Address in transport network 209.165.200.253
7B010102 -> Destination IP address in transport network 209.165.200.252
00008847 -> GRE Header

 

MPLS レイヤ 3 VPN の設定の詳細については、『 Cisco IOS Multiprotocol Label Switching Configuration Guide 』を参照してください。

show l3vpn encapsulation profile-name コマンドを使用すると、アプリケーションの基本状態についての情報を取得できます。このコマンドの出力には、トンネルと VRF に関する関連資料について記されています。

mGRE トンネルを使用したダイナミック L3 VPN サポートの設定例

ここでは、レイヤ 3 VPN over mGRE を設定する例を示します。

「レイヤ 3 VPN mGRE トンネルの設定:例」

レイヤ 3 VPN mGRE トンネルの設定:例

この例では、mGRE トンネル作成の設定手順を示します。この設定手順には、特別な VRF インスタンスの定義も含まれています。

ip vrf my riv
rd 1:1
interface Tunnel1
ip vrf forwarding my_riv
ip address 209.165.200.250 255.255.255.224
tunnel source Loopback0
tunnel mode gre multipoint l3vpn
tunnel key 123
end
ip route vrf my riv ip address subnet mask Tunnel1
 
router bgp 100
network 209.165.200.251
neighbor 209.165.200.250 remote-as 100
neighbor 209.165.200.250 update-source Loopback0
!
address-family vpnv4
neighbor 209.165.200.250 activate
neighbor 209.165.200.250 route-map SELECT_UPDATES_FOR_L3VPN_OVER_MGRE in
!
route-map SELECT UPDATES FOR L3VPN OVER MGRE permit 10
set ip next-hop in-vrf my riv

 

この例では、ルート マップをアプリケーションにリンクする設定を示します。

vrf definition Customer A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
vrf definition tunnel encap
rd 1:1
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
l3vpn encapsulation ip profile name
transport source loopback 0
protocol gre key 1234
!
!
interface Loopback0
ip address 209.165.200.252 255.255.255.224
ip router isis
!
interface Serial2/0
vrf forwarding Customer A
ip address 209.165.200.253 255.255.255.224
ipv6 address 3FFE:1001::/64 eui-64
no fair-queue
serial restart-delay 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 209.165.200.254 remote-as 100
neighbor 209.165.200.254 update-source Loopback0
!
address-family ipv4
no synchronization
redistribute connected
neighbor 209.165.200.254 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
exit-address-family
!
address-family vpnv6
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT UPDATE FOR L3VPN in
exit-address-family
!
address-family ipv4 vrf Customer A
no synchronization
redistribute connected
exit-address-family
!
address-family ipv6 vrf Customer A
redistribute connected
no synchronization
exit-address-family
!
!
route-map SELECT UPDATE FOR L3VPN permit 10
set ip next-hop encapulate <profile_name>
set ipv6 next-hop encapsulate <profile_name>

その他の参考資料

ダイナミック L3 VPN mGRE トンネル関連のその他の情報については、次の資料を参照してください。

関連資料

関連項目
参照先

MPLS レイヤ 3 VPN の設定

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

MPLS VPN Over mGRE

Cisco IOS Interface and Hardware Component Configuration Guide

シスコ エクスプレス フォワーディング

『Cisco IOS IP Switching Configuration Guide』

総称ルーティング カプセル化

『Cisco IOS Interface and Hardware Component Configuration Guide』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

IETF-PPVPN-MPLS-VPN-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

RFC 2784

『Generic Routing Encapsulation (GRE)』

RFC 2890

Key Sequence Number Extensions to GRE

RFC 4023

Encapsulating MPLS in IP or Generic Routing Encapsulation

RFC 4364

『BGP/MPLS IP Virtual Private Networks (VPNs)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

mGRE トンネルを使用するダイナミック L3 VPN の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.0(23)S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 mGRE トンネルを使用するダイナミック L3 VPN の機能情報

機能名
リリース
機能情報

マルチポイント GRE トンネルを使用するダイナミック レイヤ 3 VPN

12.0(23)S

この機能により、拡張された mGRE トンネリング テクノロジーに基づき、L3 転送メカニズムを IP ネットワークで使用できます。