IP ルーティング:BGP コンフィギュレーション ガイド、Cisco IOS Release 15.1S
L2VPN アドレス ファミリに対する BGP サ ポート
L2VPN アドレス ファミリに対する BGP サポート
発行日;2012/02/01 | 英語版ドキュメント(2010/12/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

L2VPN アドレス ファミリに対する BGP サポート

機能情報の確認

目次

L2VPN アドレス ファミリに対する BGP サポートの前提条件

L2VPN アドレス ファミリに対する BGP サポートの制約事項

L2VPN アドレス ファミリに対する BGP サポートに関する情報

L2VPN アドレス ファミリ

L2VPN アドレス ファミリに対する BGP サポートの設定方法

BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定

VPLS ID

前提条件

次の作業

L2VPN アドレス ファミリに対する BGP サポートの設定例

BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定:例

関連情報

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

L2VPN アドレス ファミリに対する BGP サポートに関する機能情報

L2VPN アドレス ファミリに対する BGP サポート

Layer 2 Virtual Private Network(L2VPN; レイヤ 2 バーチャル プライベート ネットワーク)アドレス ファミリに対する Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)サポートでは、L2VPN エンドポイント プロビジョニング情報を配布する BGP をベースとしたオートディスカバリ メカニズムが導入されています。BGP では、エンドポイント プロビジョニング情報を保存する際に個別の L2VPN Routing Information Base(RIB; ルーティング情報ベース)が使用されます。これは、レイヤ 2 Virtual Forwarding Instance(VFI)が設定されたときに毎回アップデートされます。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して Pseudowire メッシュがセットアップされます。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「L2VPN アドレス ファミリに対する BGP サポートに関する機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

L2VPN アドレス ファミリに対する BGP サポートの前提条件

L2VPN アドレス ファミリに対する BGP サポート機能では、VPN、Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス)、および Multiprotocol Layer Switching(MPLS; マルチプロトコル レイヤ スイッチング)テクノロジーに関してあらかじめ知識があることを前提としています。

L2VPN アドレス ファミリに対する BGP サポートの制約事項

L2VPN アドレス ファミリ コンフィギュレーション モードで使用された場合、BGP 内で使用されるルート マップでは、プレフィクス処理、タグ処理、および自動タグ処理に関連するすべてのコマンドは無視されます。その他すべてのルート マップ コマンドはサポートされています。

L2VPN アドレス ファミリでは、BGP マルチパスおよびコンフェデレーションはサポートされていません。

L2VPN アドレス ファミリに対する BGP サポートに関する情報

L2VPN アドレス ファミリに対する BGP サポートを設定するには、次の概念について理解する必要があります。

「L2VPN アドレス ファミリ」

L2VPN アドレス ファミリ

Cisco IOS Release 12.2(33)SRB およびそれ以降のリリースでは、L2VPN アドレス ファミリに対するサポートが追加されました。L2VPN は、IP Security(IPsec; IP セキュリティ)または Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)などの暗号化テクノロジーを使用して、セキュアでないネットワーク内で運用されるセキュアなネットワークと定義されています。L2VPN アドレス ファミリは BGP ルーティング コンフィギュレーション モードで設定され、L2VPN アドレス ファミリ内では VPLS Subsequent Address Family Identifier(SAFI)がサポートされています。

L2VPN アドレス ファミリに対する BGP サポートでは、L2VPN エンドポイント プロビジョニング情報を配布する BGP をベースとしたオートディスカバリ メカニズムが導入されています。BGP では、エンドポイント プロビジョニング情報を保存する際に個別の L2VPN Routing Information Base(RIB; ルーティング情報ベース)が使用されます。これは、レイヤ 2 VFI が設定されたときに毎回アップデートされます。プレフィクスおよびパス情報は L2VPN データベースに保存され、最良パスが BGP により決定されるようになります。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して Pseudowire メッシュがセットアップされます。

BGP オートディスカバリ メカニズムにより、Cisco IOS バーチャル プライベート LAN サービス(VPLS)機能に必要不可欠な L2VPN サービスのセットアップが簡易化されます。VPLS は、高速イーサネット使用した堅牢でスケーラブルな IP MPLS ネットワークによる大規模な LAN として、地理的に分散した拠点間を接続することで柔軟なサービスの展開を実現します。VPLS の詳細については、「 VPLS Autodiscovery: BGP Based 」機能を参照してください。

L2VPN アドレス ファミリでは、次の BGP コマンドライン インターフェイス(CLI)コマンドがサポートされています。

bgp nexthop

bgp scan-time

neighbor activate

neighbor advertisement-interval

neighbor allowas-in

neighbor capability

neighbor inherit

neighbor maximum-prefix

neighbor next-hop-self

neighbor next-hop-unchanged

neighbor peer-group

neighbor remove-private-as

neighbor route-map

neighbor route-reflector-client

neighbor send-community

neighbor soft-reconfiguration

neighbor soo

neighbor weight


) L2VPN を使用したルート リフレクタでは、neighbor next-hop-self コマンドおよび neighbor next-hop-unchanged コマンドはサポートされていません。


L2VPN アドレス ファミリ コンフィギュレーションで使用された場合、BGP 内で使用されるルート マップでは、プレフィクス処理、タグ処理、および自動タグ処理に関連するすべてのコマンドは無視されます。その他すべてのルート マップ コマンドはサポートされています。

L2VPN アドレス ファミリでは、BGP マルチパスおよびコンフェデレーションはサポートされていません。

L2VPN アドレス ファミリに対する BGP サポートの設定方法

ここでは、次の作業について説明します。

「BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定」

BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定

特定の VPLS のメンバーである各 Provider Edge(PE; プロバイダー エッジ)ルータの VPLS オートディスカバリを実装するには、次の作業を実行します。Cisco IOS Release 12.2(33)SRB では、エンドポイント プロビジョニング情報が含まれる個別の L2VPN RIB とともに、BGP L2VPN アドレス ファミリが導入されました。BGP は、L2VPN データベースからのエンドポイント プロビジョニング情報を学習します。データベースは、Layer 2(L2)VFI が設定されるたびに更新されます。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して Pseudowire メッシュがセットアップされます。

BGP ベースの VPLS オートディスカバリにより、VPLS ネイバーを手動でプロビジョニングする必要がなくなります。PE ルータが自身を特定の VPLS のメンバーとして設定すると、同じ VPLS 内のリモート ルータへの接続を設定するために必要な情報が、ディスカバリ プロセスによって配布されます。ディスカバリ プロセスが完了したとき、VPLS の各メンバーは、VPLS に必要な疑似配線のフル メッシュを形成するよう VPLS 疑似配線を設定するために必要な情報を入手済みです。

この作業は 図 1 のルータ N-PE3 で設定し、ルータ N-PE1 と N-PE2 に対して、別の IP アドレスを指定するなどの必要な変更を加えて繰り返す必要があります。これらのルータの詳細な設定については、「BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定:例」を参照してください。

図 1 L2VPN アドレス ファミリを使用した BGP オートディスカバリのネットワーク図

 

この作業では、レイヤ 2 ルータ ID、VPN ID、VPLS ID を使用して 図 1 の PE ルータ N-PE3 を設定し、同じ VPLS ドメイン内にある他の PE ルータが自動的に検出されるように設定します。BGP セッションが作成され、L2VPN アドレス ファミリで BGP ネイバーがアクティブになります。最後に、2 つのオプション show コマンド が入力して、この作業の手順を検証します。

新しいVirtual Forwarding Instance(VFI)に対して Route Reflector(RR; ルート リフレクタ)ノードがプロビジョニングされると、BGP は L2VPN Address Family Identifier(AFI; アドレス ファミリ識別子)からの現在のテーブル全体を L2VPN xconnect データベースに対してアナウンスし、Virtual Circuit(VC; 仮想回線)がアクティブであることを確認します。

VPLS ID

VPLS ID は、VPLS ドメインを示す BGP 拡張コミュニティ値です。デフォルトの VPLS ID は BGP 自律システム番号および設定済みの VPN ID を使用して生成されるため、この ID の手動設定は任意です。VPLS ID は、自律システム番号と任意番号、または IP アドレスと任意番号のいずれかで構成できます。

VPLS ID は、次のいずれかの形式で入力できます。

16 ビット自律システム番号、コロン、32 ビット番号を入力します。次に例を示します。

45000:3

32 ビット IP アドレス、コロン、16 ビット番号を入力します。次に例を示します。

192.168.10.15:1

前提条件

この作業は、MPLS が VPLS オプションを使用して設定されていることを前提にしています。詳細については、「 VPLS Autodiscovery: BGP Based 」機能を参照してください。

手順の概要

1. enable

2. configure terminal

3. l2 router-id ip-address

4. l2 vfi vfi-name autodiscovery

5. vpn id vpn-id

6. vpls-id vpls-id

7. exit

8. ステップ 4ステップ 6 を繰り返して、他の L2 VFI および関連する VPN および VPLS ID を設定します。

9. router bgp autonomous-system-number

10. no bgp default ipv4-unicast

11. bgp log-neighbor-changes

12. bgp update-delay seconds

13. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

14. neighbor { ip-address | peer-group-name } update-source interface-type interface-number

15. ステップ 13ステップ 14 を繰り返して、他の BGP ネイバーを設定します。

16. address-family l2vpn [ vpls ]

17. neighbor { ip-address | peer-group-name } activate

18. neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

19. ステップ 17ステップ 18 を繰り返して、L2VPN アドレス ファミリ内の他の BGP ネイバーをアクティブにします。

20. end

21. show vfi

22. show ip bgp l2vpn vpls { all | rd vpn-rd }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l2 router-id ip-address

 

Router(config)# l2 router-id 10.1.1.3

VPLS オートディスカバリ疑似配線で使用する PE ルータのルータ ID を(IP アドレス形式で)指定します。

この例では、L2 ルータ ID が 10.1.1.3 として定義されています。

ステップ 4

l2 vfi vfi-name autodiscovery

 

Router(config)# l2 vfi customerA autodiscovery

L2 VFI を作成し、VPLS PE ルータが同じ VPLS ドメイン内の他の PE ルータを自動的に検出されるように設定し、L2 VFI オートディスカバリ コンフィギュレーション モードを開始します。

この例では、customerA という名前の L2 VFI が作成されます。

ステップ 5

vpn id vpn-id

 

Router(config-vfi)# vpn id 100

VPN ID を指定します。

同じ VPN に属する PE ルータには同じ VPN ID を使用します。サービス プロバイダー ネットワークの VPN ごとに、VPN ID が一意になるようにします。

vpn-id 引数を使用して、1 ~ 4294967295 の範囲で数値を指定します。

この例では、VPN ID 100 が指定されています。

ステップ 6

vpls-id vpls-id

 

Router(config-vfi)# vpls-id 65000:100

(任意)VPLS ID を指定します。

VPLS ID は、VPLS ドメインを識別するために使用される識別子です。デフォルトの VPLS ID は BGP 自律システム番号および VFI 用に設定済みの VPN ID を使用して自動生成されるため、このコマンドは任意です。各 VFI に 1 つの VPLS ID を設定できます。同じルータ上の複数の VFI で同じ VPLS ID を設定することはできません。

この例では、VPLS ID 65000:100 が指定されています。

ステップ 7

exit

 

Router(config-vfi)# exit

L2 VFI オートディスカバリ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

ステップ 4ステップ 6 を繰り返して、他の L2 VFI および関連する VPN および VPLS ID を設定します。

--

ステップ 9

router bgp autonomous-system-number

 

Router(config)# router bgp 65000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 10

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ルーティング プロセスで使用される IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

ルータ コンフィギュレーション コマンドを設定した場合は例外です。既存のネイバー コンフィギュレーションは影響されません。

ステップ 11

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットのロギングをイネーブルにします。

ステップ 12

bgp update-delay seconds

 

Router(config-router)# bgp update-delay 1

BGP 対応ネットワーキング デバイスが最初の更新を送信するまでの初期遅延の最大時間を設定します。

seconds 引数を使用して、遅延時間を設定します。

ステップ 13

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 10.10.10.1 remote-as 65000

指定された自律システム内のネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致する場合、ネイバーは内部ネイバーになります。

autonomous-system-number 引数が、 router bgp コマンドで指定された自律システム番号と一致しない場合、ネイバーは外部ネイバーになります。

この例では、10.10.10.1 のネイバーは内部 BGP ネイバーです。

ステップ 14

neighbor { ip-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 10.10.10.1 update-source loopback 1

(任意)ルーティング テーブル アップデートを受信するための特定のソース、またはインターフェイスを選択するようにルータを設定します。

この例では、ループバック インターフェイスを使用します。このコンフィギュレーションの利点は、ループバック インターフェイスはフラッピング インターフェイスの効果の影響を受けにくいところにあります。

ステップ 15

ステップ 13ステップ 14 を繰り返して、他の BGP ネイバーを設定します。

--

ステップ 16

address-family l2vpn [ vpls ]

 

Router(config-router)# address-family l2vpn vpls

L2VPN アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

オプションの vpls キーワード では、VPLS エンドポイント プロビジョニング情報が BGP ピアに配布されるように指定します。

この例では、L2VPN VPLS アドレス ファミリ セッションが作成されます。

ステップ 17

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.10.10.1 activate

このネイバーをイネーブルにして、L2VPN VPLS アドレス ファミリの情報をローカル ルータと交換します。

コマンドでは、ピア グループが自動的にアクティブになります。

ステップ 18

neighbor { ip-address | peer-group-name } send-community [ both | standard | extended ]

 

Router(config-router-af)# neighbor 10.10.10.1 send-community extended

コミュニティ アトリビュートが BGP ネイバーに送信されるように指定します。

この例では、拡張コミュニティ アトリビュートが 10.10.10.1 のネイバーに送信されます。

ステップ 19

ステップ 17ステップ 18 を繰り返して、L2VPN アドレス ファミリ内の他の BGP ネイバーをアクティブにします。

--

ステップ 20

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 21

show vfi

 

Router# show vfi

(任意)設定した VFI インスタンスに関する情報を表示します。

ステップ 22

show ip bgp l2vpn vpls { all | rd vpn-rd }

 

Router# show ip bgp l2vpn vpls all

(任意)L2 VPN VPLS アドレス ファミリに関する情報を表示します。

次に、CustomerA と CustomerB という 2 つの VFI と、それらに関連付けられた VPN および VPLS ID を表示する show vfi コマンドの出力例を示します。

Router# show vfi
 
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No
 
VFI name: customerA, state: down, type: multipoint
VPN ID: 100, VPLS-ID: 65000:100
RD: 65000:100, RT: 65000:100
Local attachment circuits:
Neighbors connected via pseudowires:
Peer Address VC ID Discovered Router ID S
10.10.10.1 100 10.10.10.99 Y
 
VFI name: customerB, state: down, type: multipoint
VPN ID: 200, VPLS-ID: 65000:200
RD: 65000:200, RT: 65000:200
Local attachment circuits:
Neighbors connected via pseudowires:
Peer Address VC ID Discovered Router ID S
10.10.10.3 200 10.10.10.98 Y
 

次に、VPN ルート識別子によって識別された 2 つの VFI を表示する show ip bgp l2vpn vpls all コマンドの出力例を示します。

Router# show ip bgp l2vpn vpls all
 
BGP table version is 5, local router ID is 10.10.10.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 65000:100
*> 65000:100:10.10.10.1/96
0.0.0.0 32768 ?
*>i65000:100:192.168.1.1/96
10.10.10.2 0 100 0 ?
Route Distinguisher: 65000:200
*> 65000:200:10.10.10.3/96
0.0.0.0 32768 ?
*>i65000:200:192.168.2.2/96
10.10.10.2 0 100 0 ?

次の作業

その他の VPLS 機能を設定するには、VPLS のメイン マニュアルで「 VPLS Autodiscovery: BGP Based 」機能に関する項を参照してください。

L2VPN アドレス ファミリに対する BGP サポートの設定例

ここでは、次の設定例を示します。

「BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定:例」

BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリの設定:例

この設定例では、図 2 に示す自律システム 65000 のすべてのルータが L2VPN アドレス ファミリの BPG サポートを提供するように設定されています。VPLS オートディスカバリはイネーブルで、L2 VFI および VPN ID が設定されています。VPLS エンドポイント プロビジョニング情報が個別の L2VPN RIB に保存され、BGP 更新メッセージで他の BGP ピアに配布されるように、BGP ネイバーが L2VPN アドレス ファミリで設定およびアクティブ化されます。BGP ピアでエンドポイント情報が受信されると、L2VPN ベースのサービスをサポートするために Pseudowire メッシュが設定されます。

図 2 BGP および L2VPN アドレス ファミリを使用した VPLS オートディスカバリのネットワーク図

 

ルータ N-PE1

ip subnet-zero
ip cef
no ip dhcp use vrf connected
!
no mpls traffic-eng auto-bw timers frequency 0
mpls label range 1000 2000
mpls label protocol ldp
l2 router-id 10.1.1.1
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.1 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 10.0.0.1 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.10.1.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 65000
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback 1
neighbor 10.10.10.3 remote-as 65000
neighbor 10.10.10.3 update-source Loopback 1
!
address-family l2vpn vpls
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 send-community extended
exit-address-family
!
ip classless

ルータ N-PE2

ip subnet-zero
ip cef
no ip dhcp use vrf connected
!
no mpls traffic-eng auto-bw timers frequency 0
mpls label range 2000 3000
mpls label protocol ldp
l2 router-id 10.1.1.2
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.2 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 10.0.0.2 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.10.1.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 65000
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback 1
neighbor 10.10.10.3 remote-as 65000
neighbor 10.10.10.3 update-source Loopback 1
!
address-family l2vpn vpls
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
neighbor 10.10.10.3 activate
neighbor 10.10.10.3 send-community extended
exit-address-family
!
ip classless

ルータ N-PE3

ip subnet-zero
ip cef
no ip dhcp use vrf connected
!
no mpls traffic-eng auto-bw timers frequency 0
mpls label range 2000 3000
mpls label protocol ldp
l2 router-id 10.1.1.3
l2 vfi auto autodiscovery
vpn id 100
!
pseudowire-class mpls
encapsulation mpls
!
interface Loopback1
ip address 10.1.1.3 255.255.255.255
!
interface Ethernet0/0
description Backbone interface
ip address 10.0.0.3 255.255.255.0
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.10.1.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
router bgp 65000
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp update-delay 1
neighbor 10.10.10.1 remote-as 65000
neighbor 10.10.10.1 update-source Loopback 1
neighbor 10.10.10.2 remote-as 65000
neighbor 10.10.10.2 update-source Loopback 1
!
address-family l2vpn vpls
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
neighbor 10.10.10.2 activate
neighbor 10.10.10.2 send-community extended
exit-address-family
!
ip classless

関連情報

VPLS オートディスカバリの設定の詳細については、「 VPLS Autodiscovery: BGP Based 」機能を参照してください。

その他の参考資料

ここでは、L2VPN アドレス ファミリに対する BGP サポート機能に関連する参考資料について説明します。

関連資料

関連項目
参照先

BGP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、コマンド履歴、使用上の注意事項、および例

『Cisco IOS IP Routing: BGP Command Reference』

BGP の概要

Cisco BGP Overview モジュール

BGP 基本作業の設定

Configuring a Basic BGP Network モジュール

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

L2VPN アドレス ファミリに対する BGP サポートに関する機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォーム サポートとソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その Cisco IOS ソフトウェア リリース トレインの以降のリリースでもその機能はサポートされます。


 

表 1 L2VPN アドレス ファミリに対する BGP サポートに関する機能情報

機能名
リリース
機能情報

L2VPN アドレス ファミリに対する BGP サポート

12.2(33)SRB

L2VPN アドレス ファミリに対する BGP サポートでは、L2VPN エンドポイント プロビジョニング情報を配布する BGP をベースとしたオートディスカバリ メカニズムが導入されています。BGP では、エンドポイント プロビジョニング情報を保存する際に個別の L2VPN RIB が使用されます。これは、レイヤ 2 VFI が設定されたときに毎回アップデートされます。BGP により、アップデート メッセージですべての BGP ネイバーにエンドポイント プロビジョニング情報が配布されるとき、L2VPN ベースのサービスをサポートするために、エンドポイント情報を使用して Pseudowire メッシュがセットアップされます。

Cisco IOS Release 12.2(33)SRB プラットフォームでは、この機能は Cisco 7600 プラットフォームに追加されました。

次のコマンドが、この機能によって導入または変更されました。 address-family l2vpn clear ip bgp l2vpn show ip bgp l2vpn