IP ルーティング:BGP コンフィギュレーション ガイド、Cisco IOS Release 15.1S
CLNS に対するマルチプロトコル BGP (MP-BGP)サポートの設定
CLNS に対するマルチプロトコル BGP(MP-BGP)サポートの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

CLNS に対するマルチプロトコル BGP(MP-BGP)サポートの設定

マニュアルの内容

CLNS に対する MP-BGP サポートの設定に関する制約事項

CLNS に対する MP-BGP サポートの設定の概要

CLNS に対する MP-BGP サポートの設計機能

汎用 BGP CLNS ネットワーク トポロジ

DCN ネットワーク トポロジ

CLNS に対する MP-BGP サポートの利点

CLNS に対する MP-BGP サポートの設定方法

CLNS をサポートするための BGP ネイバーの設定とアクティブ化

アドレス ファミリ ルーティング情報

IS-IS ルーティング プロセスの設定

BGP ネイバーに接続するインターフェイスの設定

ローカル OSI ルーティング ドメインと接続されているインターフェイスの設定

ネットワーキング プレフィクスのアドバタイジング

BGP から IS-IS へのルートの再配布

IS-IS から BGP への再配布ルート

BGP ピア グループおよびルート リフレクタの設定

NSAP プレフィクスに基づくインバウンド ルートのフィルタリング

前提条件

NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング

ネイバー ルーティング ドメインのデフォルト ルートの送信

CLNS に対する MP-BGP サポートの確認

CLNS に対する MP-BGP サポートのトラブルシューティング

CLNS に対する MP-BGP サポートの設定例

CLNS をサポートするための BGP ネイバーの設定とアクティブ化:例

IS-IS ルーティング プロセスの設定:例

インターフェイスの設定:例

ネットワーキング プレフィクスのアドバタイジング:例

BGP から IS-IS へのルートの再配布:例

IS-IS から BGP へのルートの再配布:例

BGP ピア グループおよびルート リフレクタの設定:例

NSAP プレフィクスに基づくインバウンド ルートのフィルタリング:例

NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング:例

デフォルト ルートの発信およびアウトバウンド ルート フィルタリング:例

CLNS に対する MP-BGP サポートの実装:例

自律システム AS65101

自律システム AS65202

自律システム AS65303

自律システム AS65404

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

CLNS に対する MP-BGP サポートの設定に関する機能情報

用語集

CLNS に対するマルチプロトコル BGP(MP-BGP)サポートの設定

このモジュールでは、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)ネットワークをスケーリングする機能を提供する、CLNS に対する Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)サポートを設定する作業について説明します。Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)のマルチプロトコル拡張は、ルーティング ドメインをマージせずに個別の Open System Interconnection(OSI; 開放型システム間相互接続)ルーティング ドメインを相互接続する機能を追加することによって、大規模な OSI ネットワークを確立する機能を実現します。

このモジュール内の機能情報の検索

ご使用の Cisco IOS ソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュール内に記載されている特定の機能のリンクにアクセスする場合、および各機能がサポートされているリリースのリストを参照する場合は、「CLNS に対する MP-BGP サポートの設定に関する機能情報」を参照してください。

プラットフォームと、Cisco IOS および Catalyst OS ソフトウェア イメージに関するサポート情報の検索

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

CLNS に対する MP-BGP サポートの設定に関する制約事項

CLNS に対する MP-BGP サポートの設定は、CLNS ネットワーク内の BGP コンフェデレーションの作成と使用をサポートしていません。大規模な内部 BGP メッシュの問題を解決するために、ルート リフレクタを使用することを推奨します。

BGP 拡張コミュニティは、この機能でサポートされません。

次の BGP コマンドは、この機能でサポートされません。

auto-summary

neighbor advertise-map

neighbor distribute-list

neighbor soft-reconfiguration

neighbor unsuppress-map

CLNS に対する MP-BGP サポートの設定の概要

CLNS に対する MP-BGP サポートを設定するには、次の概念について理解する必要があります。

「CLNS に対する MP-BGP サポートの設計機能」

「汎用 BGP CLNS ネットワーク トポロジ」

「DCN ネットワーク トポロジ」

「CLNS に対する MP-BGP サポートの利点」

CLNS に対する MP-BGP サポートの設計機能

CLNS に対する MP-BGP サポートの設定により、コネクションレス型ネットワーク サービス(CLNS)をネットワーク レイヤ プロトコルとして使用するネットワーク内のドメイン間ルーティング プロトコルとして、ボーダー ゲートウェイ プロトコル(BGP)を使用できるようになります。この機能は、多数のネットワーク要素がリモート管理される Data Communications Network(DCN; データ通信ネットワーク)でのスケーリング問題を解決するために開発されました。DCN の問題、およびこの機能を DCN トポロジ内に実装する方法の詳細については、「DCN ネットワーク トポロジ」を参照してください。

BGP は、Exterior Gateway Protocol(EGP; 外部ゲートウェイ プロトコル)として、インターネットによって生成されるルーティング情報の量を処理するように設計されています。BGP ネイバー関係(ピアリング)が手動で設定され、ルーティング アップデートがインクリメンタル ブロードキャストを使用するため、ネットワーク管理者は BGP ルーティング情報を制御できます。一方、Intermediate System-to-Intermediate System(IS-IS)などの内部ルーティング プロトコルには、一種の自動ネイバー探索手法やブロードキャスト アップデートを定期的な間隔で使用するものもあります。

CLNS は Network Service Access Point(NSAP; ネットワーク サービス アクセス ポイント)アドレスを使用して、そのすべてのネットワーク要素を識別します。BGP アドレス ファミリ サポートにより、NSAP アドレス プレフィクスは BGP を使用して転送できます。CLNS では、BGP プレフィクスが CLNS レベル 2 プレフィクス テーブルに挿入されます。この機能を使用すると、BGP をドメイン間ルーティング プロトコルとして個別の CLNS ルーティング ドメイン間で使用できます。

各内部ネットワークのエッジのルータに BGP を実装すると、既存の内部プロトコルを変更する必要がないため、ネットワークの中断が最小化されます。

汎用 BGP CLNS ネットワーク トポロジ

図 1 に、4 つの異なる自律システム(BGP 用語)またはルーティング ドメイン(OSI 用語)にグループ分けされる 9 つのルータを含む汎用 BGP CLNS ネットワークを示します。混乱を避けるために、このマニュアルでは BGP 用語である自律システムを使用します。各自律システムには番号が付いているため、図中や設定上の説明で識別が容易であるからです。

図 1 汎用 BGP CLNS ネットワークのコンポーネント

 

各自律システムでは、IS-IS がイントラドメイン ルーティング プロトコルとして使用されます。自律システム間で、BGP およびそのマルチプロトコル拡張は、ドメイン間ルーティング プロトコルとして使用されます。各ルータは、BGP またはレベル 2 IS-IS ルーティング プロセスのいずれかを実行します。この機能を支援するために、BGP ルータはレベル 2 IS-IS プロセスも実行しています。図にリンクが示されていませんが、各レベル 2 IS-IS ルータが複数のレベル 1 IS-IS ルータに接続され、次に、各レベル 1 IS-IS ルータが複数の CLNS ネットワークに接続されています。

この例では、各自律システムは、さまざまな BGP 機能およびその機能と CLNS が連動してスケーラブルなドメイン間ルーティング ソリューションを提供する方法を示すように構成されています。図 1 では、自律システム AS65101 には 1 つのレベル 2 IS-IS ルータの R1 があり、他の 1 つの自律システム AS65202 だけと接続されています。残りのネットワークとの接続が R2 によって可能になり、R1 が R2 に AS65101 外部の宛先 NSAP アドレスを持つすべてのパケットを送信するために、デフォルト ルートが生成されます。

AS65202 には R2 と R3 の 2 つのルータがあり、その両方が異なる外部 BGP(eBGP)ネイバーを持ちます。ルータ R2 および R3 は、お互いの間の内部接続上で内部 BGP(iBGP)を実行するように設定されています。

AS65303 は BGP ピア グループの使用方法を示し、ルート リフレクションはルータ間の TCP 接続の必要性を最小化できます。ルータ間の接続数が少ないため、ネットワーク設計が簡略化され、ネットワーク内のトラフィック量が少なくなります。

AS65404 は、BGP を実行していないレベル 2 IS-IS ルータと到着可能性情報を通信するための再配布の使用方法を示します。

このマニュアルでの設定作業および設定例は、図 1 に示される総称ネットワーク設計に基づいています。図 1 のすべてのルータの設定は、「CLNS に対する MP-BGP サポートの実装:例」に示されます。

DCN ネットワーク トポロジ

CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能は、多数のリモート SONET リングを管理するデータ通信ネットワーク(DCN)に利点を提供できます。SONET は通常、光ファイバ ネットワークをとしてデータを送信する電気通信会社によって使用されます。

図 2 に、DCN ネットワークの一部のコンポーネントを示します。BGP 用語との整合性をとるため、図には、3 つのルーティング ドメインではなく、自律システムを示すラベルがあります。図 2 の NE で示される、SONET リングのネットワーク要素は、File Transfer, Access, and Management(FTAM)および Common Management Information Protocol(CMIP; 共通管理情報プロトコル)などの OSI プロトコルによって管理されます。FTAM および CMIP は CLNS ネットワーク レイヤ プロトコルで実行されます。つまり、接続を提供するルータは OSI ルーティング プロトコルを実行する必要があります。

図 2 DCN ネットワークのコンポーネント

 

IS-IS は、この例では、CLNS をルーティングするために使用されるリンクステートのプロトコルです。各ルーティング ノード(ネットワーキングデバイス)は、Intermediate System(IS; 中継システム)と呼ばれます。ネットワークは、ルーティング ノードのコレクションとして定義される領域に分割されます。1 つの領域内のルーティングは、レベル 1 ルーティングと呼ばれます。領域間のルーティングは、レベル 2 ルーティングと呼ばれます。レベル 1 領域とレベル 2 領域をリンクするルータは、レベル 1-2 ルータとして定義されます。DCN コアにパスを提供するレベル 2 ルータに接続されるネットワーク要素は、ゲートウェイ ネットワーク要素によって表され、図 2 では GNE です。ここでのネットワーク トポロジは、各ネットワーク要素ルータ間のポイントツーポイント リンクです。この例では、レベル 1 IS-IS ルータは NE ルータと呼ばれます。

サービス プロバイダーの Central Office(CO; セントラル オフィス)のシェルフ スペースが非常に高価であるため、Cisco 2600 シリーズなどの小規模の Cisco ルータが選択されて、レベル 1-2 ルータとして実行されています。Cisco 2600 シリーズ ルータは、4 つ、または 5 つの異なるレベル 1 領域のレベル 1 ルータとして動作している場合、その処理電力が制限されます。この設定の下のレベル 1 領域の数は、約 200 に制限されています。レベル 2 ネットワーク全体も、最も遅いレベル 2 ルータの速度によって制限されます。

NE ルータ間を接続できるようにするには、インバンド シグナリングを使用します。インバンド シグナリングは、Data Communications Channel(DCC; データ通信チャネル)上の SONET/Synchronous Digital Hierarchy(SDH)フレームで伝送されます。DCC は 192- KB チャネルであり、管理トラフィックが非常に制限された量の帯域幅です。IS-IS を実行している NE ルータでは、ネットワーク要素間のシグナリング帯域幅が制限され、また、処理電力量とメモリ容量も制限されているため、各領域はルータの最大数が 30 ~ 40 に制限されます。各 SONET リングは、平均で 10 ~ 15 のネットワーク要素で構成されています。

領域あたり 10 ~ 15 のネットワーク要素を含む、最大 200 の領域により、1 つの自律システム内のネットワーク要素ルータの合計数は 3000 より少なくなる必要があります。サービス プロバイダーは、ネットワークが増大するにつれて 10,000 を超えるネットワーク要素を実装しようとしますが、1 つの領域のネットワーク要素の潜在数は制限されています。現在のソリューションは、DCN を多数のより小さい自律システムに分解し、スタティック ルートまたは ISO Interior Gateway Routing Protocol(IGRP)を使用して各システムを接続します。ISO IGRP は、将来の機器実装オプションを制限できる独自のプロトコルです。ネットワークの増大が、ネットワーク管理者のスタティック ルートを維持する能力を超える場合があるため、スタティック ルートはスケーリングしません。BGP は、100,000 ルートを超えるスケーリングを行うように示されています。

この例では、CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能を実装するために、DCN コア ネットワーク(図 2 の AS64800)の各ルータで実行する BGP を設定して、すべての自律システム間でルーティング情報を交換します。AS64600 および AS64700 の自律システムでは、レベル 2 ルータだけが BGP を実行します。BGP は TCP を使用して BGP 対応のネイバー ルータと通信します。つまり、IP アドレスのネットワークと NSAP アドレスのネットワークの両方が、自律システム AS64600 と AS64700 のすべてのレベル 2 IS-IS ルータ、および DCN コア ネットワークのすべてのルータを対象とするように設定される必要があります。

各自律システム、たとえば図 2 の AS64600 および AS64700 が最大 3000 ノードの同じサイズのままであるとすると、この機能によってサポートできる DCN ネットワークの規模を示すことが可能です。各自律システムは、1 つのアドレス プレフィクスをコア自律システムにアドバタイズします。各自律システムとコア自律システムとの間には 2 つのリンクがあるため、各アドレス プレフィクスは、冗長性を得るために、そのリンクに 2 つのパスを関連付けできます。BGP は 100,000 のルートをサポートするように示され、各自律システムが数個のルートしか生成しないため、コア自律システムは他の多数の直接リンクされた自律システムをサポートできます。コア自律システムは、約 2000 の直接リンクされた自律システムをサポートできると考えられます。各自律システムがコア自律システムに直接リンクされて、中継自律システムとして動作していないハブ アンド スポーク設計で、コア自律システムはデフォルト ルートをリンクされた各自律システムに生成できます。デフォルト ルートを使用すると、リンクされた自律システムのレベル 2 ルータは、追加ルーティング情報を少量しか処理しません。2000 のリンクされた自律システムに、各自律システムの 3000 ノードを掛けると、最大 6,000,000 のネットワーク要素が許容されることになります。

CLNS に対する MP-BGP サポートの利点

CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能は、ルーティング ドメインをマージせずに個別の OSI ルーティング ドメインを相互接続する機能を追加することによって、大規模な OSI ネットワークを確立する機能を提供します。この機能を使用する利点は、DCN ネットワーク内に限定されるのではなく、CLNS とともに OSI ルーティング プロトコルを使用してネットワークのスケーリングを容易にするように実装できることです。

CLNS に対する MP-BGP サポートの設定方法

ここでは、次の手順について説明します。特定のネットワークの場合、各手順を通して進める必要がない場合があります。必要な手順のステップを実行する必要がありますが、他のすべての手順は、ご使用のネットワークでの必要性に応じて実行します。

「CLNS をサポートするための BGP ネイバーの設定とアクティブ化」(必須)

「IS-IS ルーティング プロセスの設定」(必須)

「BGP ネイバーに接続するインターフェイスの設定」(必須)

「ローカル OSI ルーティング ドメインと接続されているインターフェイスの設定」(必須)

「ネットワーキング プレフィクスのアドバタイジング」(適宜)

「BGP から IS-IS へのルートの再配布」(適宜)

「IS-IS から BGP への再配布ルート」(適宜)

「BGP ピア グループおよびルート リフレクタの設定」

「NSAP プレフィクスに基づくインバウンド ルートのフィルタリング」(適宜)

「NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング」(適宜)

「ネイバー ルーティング ドメインのデフォルト ルートの送信」(適宜)

「CLNS に対する MP-BGP サポートの確認」(適宜)

「CLNS に対する MP-BGP サポートのトラブルシューティング」(適宜)

CLNS をサポートするための BGP ネイバーの設定とアクティブ化

BGP ルーティング プロセス、および CLNS をサポートする、関連付けられた BGP ネイバー(ピア)の設定とアクティブ化を行うには、次の手順のステップを実行します。

アドレス ファミリ ルーティング情報

デフォルトでは、 router bgp コマンドの下に入力されたコマンドが IPv4 アドレス ファミリに適用されます。この状態は、 router bgp コマンド下の最初のコマンドとして no bgp default ipv4-unicast コマンドを入力しない限り継続します。 no bgp default ipv4-unicast コマンドは、BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにするために、ルータで設定されます。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. address-family nsap [ unicast ]

7. neighbor ip-address activate

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65101

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータが存在する自律システムを識別します。有効値は、0 ~ 65535 です。内部ネットワークで使用できるプライベート自律システム番号の範囲は、64512 ~ 65535 です。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.1.2.2 remote-as 64202

指定された自律システム内の BGP ネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの BGP ネイバー テーブルに追加します。

ステップ 6

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

オプションの unicast キーワードは、NSAP ユニキャスト アドレス プレフィクスを指定します。デフォルトでは、 address-family nsap コマンドで unicast キーワードが指定されない場合、ルータはユニキャスト NSAP アドレス ファミリ コンフィギュレーション モードになります。

ステップ 7

neighbor ip-address activate

 

Router(config-router-af)# neighbor 10.1.2.2 activate

BGP ネイバーが、NSAP アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

(注) ピア グループを BGP ネイバーとして設定した場合は、このコマンドを使用しないでください。これは、ピア グループ パラメータの設定時にピア グループが自動的にアクティブにされるためです。

ステップ 8

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

IS-IS ルーティング プロセスの設定

Integrated IS-IS ルーティング プロセスを設定する場合、最初に設定される IS-IS ルーティング プロセスのインスタンスは、デフォルトで、レベル 1-2(領域内および領域間)ルータです。CLNS を実行しているネットワーク上の、後続の IS-IS ルーティング プロセスはすべてレベル 1 として設定されます。IP を実行しているネットワーク上の、後続の IS-IS ルーティング プロセスはすべてレベル 1-2 として設定されます。CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能を使用するには、レベル 2 ルーティング プロセスを設定します。

IS-IS ルーティング プロセスを設定してレベル 2 専用のプロセスとして割り当てるには、次の手順のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. router isis area-tag

4. net network-entity-title

5. is-type [ level-1 | level-1-2 | level-2-only ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis area-tag

 

Router(config)# router isis osi-as-101

IS-IS ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

area-tag 引数は、ルーティング プロセスの意味のある名前です。この名前は、特定のルータのすべての IP ルーティング プロセスおよび CLNS ルーティング プロセスの間で一意である必要があります。

ステップ 4

net network-entity-title

 

Router(config-router)# net 49.0101.1111.1111.1111.1111.00

ルーティング プロセスの Network Entity Title(NET)を設定します。マルチエリア IS-IS を設定する場合は、各ルーティング プロセスの NET を指定する必要があります。

ステップ 5

is-type [ level-1 | level-1-2 | level-2-only ]

 

Router(config-router)# is-type level-1

ルータを、レベル 1(領域内)ルータ、レベル 1 ルータおよびレベル 2(領域間)ルータ、または領域内専用ルータとして設定します。

マルチエリア IS-IS コンフィギュレーションでは、最初に設定される IS-IS ルーティング プロセスのインスタンスは、デフォルトで、レベル 1-2(領域内および領域間)ルータです。CLNS を実行しているネットワーク上の、後続の IS-IS ルーティング プロセスはすべてレベル 1 として設定されます。IP を実行しているネットワーク上の、後続の IS-IS ルーティング プロセスはすべてレベル 1-2 として設定されます。

ステップ 6

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP ネイバーに接続するインターフェイスの設定

IS-IS を実行しているルータが直接 eBGP ネイバーに接続される場合、2 つの eBGP ネイバー間のインターフェイスは、 clns enable コマンドを使用してアクティブになり、これにより、CLNS パケットをインターフェイス間で転送できます。 clns enable コマンドは、End System-to-Intermediate System(ES-IS)プロトコルをアクティブにして、ネイバー OSI システムを検索します。


) eBGP ネイバーと接続されている同じインターフェイス間で IS-IS を実行すると、2 つの OSI ルーティング ドメインが 1 つのドメインにマージされた場合に望ましくない結果になる場合があります。


ネイバー OSI システムが検出された場合、BGP は、そのシステムが、NSAP アドレス ファミリに設定された eBGP ネイバーでもあることを確認します。前の条件が満たされた場合、BGP は、専用の BGP ネイバー ルートを CLNS レベル 2 プレフィクス ルーティング テーブルに作成します。専用の BGP ネイバー ルートはレベル 2 ルーティング アップデートに自動的に再配布され、ローカル OSI ルーティング ドメイン内の他のレベル 2 IS-IS ルータすべてが、この eBGP ネイバーへの到達方法を認識するようにします。

eBGP ネイバーとの接続に使用されているインターフェイスを設定するには、次の手順のステップを実行します。このインターフェイスは通常、eBGP ネイバーに直接接続されます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. clns enable

6. no shutdown

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface serial 2/0

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 10.1.2.2 255.255.255.0

IP アドレスを使用してインターフェイスを設定します。

ステップ 5

clns enable

 

Router(config-if)# clns enable

CLNS パケットをインターフェイス間で転送できるように指定します。ES-IS プロトコルがアクティブになり、隣接 OSI システムの検索が開始されます。

ステップ 6

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをオンにします。

ステップ 7

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ローカル OSI ルーティング ドメインと接続されているインターフェイスの設定

ローカル OSI ルーティング ドメインと接続されているインターフェイスを設定するには、次の手順のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. clns router isis area-tag

6. ip router isis area-tag

7. no shutdown

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/1

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 10.2.3.1 255.255.255.0

IP アドレスを使用してインターフェイスを設定します。

(注) このステップは、インターフェイスが iBGP ネイバーと通信する必要がある場合だけ必要になります。

ステップ 5

clns router isis area-tag

 

Router(config-if)# clns router isis osi-as-202

ネットワーク プロトコルが ISO CLNS である場合にインターフェイスが IS-IS をアクティブにルーティングするように指定し、このルーティング プロセスに関連付けられた領域を識別します。

ステップ 6

ip router isis area-tag

 

Router(config-if)# ip router isis osi-as-202

ネットワーク プロトコルが IP である場合にインターフェイスが IS-IS をアクティブにルーティングするように指定し、このルーティング プロセスに関連付けられた領域を識別します。

(注) このステップは、インターフェイスが iBGP ネイバーと通信する必要があり、かつ、IGP が IS-IS である場合だけ必要になります。

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをオンにします。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ネットワーキング プレフィクスのアドバタイジング

NSAP アドレス プレフィクスをアドバタイジングすると、プレフィクスが BGP ルーティング テーブルに強制的に追加されます。ネットワーキング プレフィクスのアドバタイズメントを設定するには、次の手順のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. address-family nsap [ unicast ]

7. network nsap-prefix [ route-map map-tag ]

8. neighbor ip-address activate

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65101

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.1.2.2 remote-as 64202

指定された自律システム内の BGP ネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの BGP ネイバー テーブルに追加します。

ステップ 6

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

オプションの unicast キーワードは、NSAP ユニキャスト アドレス プレフィクスを指定します。デフォルトでは、 address-family nsap コマンドで unicast キーワードが指定されない場合、ルータはユニキャスト NSAP アドレス ファミリ コンフィギュレーション モードになります。

ステップ 7

network nsap-prefix [ route-map map-tag ]

 

Router(config-router-af)# network 49.0101.1111.1111.1111.1111.00

ローカル OSI ルーティング ドメインの 1 つのプレフィクスをアドバタイズし、そのプレフィクスを BGP ルーティング テーブルに入力します。

(注) 1 つのプレフィクスをアドバタイズできるのは、そのプレフィクスが、ローカル OSI ルーティング ドメインの一意の NSAP アドレス プレフィクスである場合です。または、それぞれが OSI ルーティング ドメインの小さい部分をカバーする、より長い複数のプレフィクスを使用すると、異なる領域を選択的にアドバタイズできます。

NSAP アドレス プレフィクスのアドバタイジングは、オプションの route-map キーワードを使用することで制御できます。ルート マップが指定されない場合は、すべての NSAP アドレス プレフィクスが再配布されます。

ステップ 8

neighbor ip-address activate

 

Router(config-router-af) neighbor 10.1.2.2 activate

NSAP ルーティング情報が、指定された BGP ネイバーに送信されるように指定します。

コマンドの説明を参照してください。

ステップ 9

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP から IS-IS へのルートの再配布

ルート再配布を実行する場合は注意が必要です。フルセットの BGP ルートを IS-IS に挿入することは、過剰なトラフィックが IS-IS に加えられるため推奨されません。ルート マップを使用すると、再配布されるダイナミック ルートを制御できます。

BGP から IS-IS へのルート再配布を設定するには、次の手順のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. router isis area-tag

4. net network-entity-title

5. redistribute protocol as-number [ route-type ] [ route-map map-tag ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis area-tag

 

Router(config)# router isis osi-as-404

IS-IS ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

(注) BGP ルートをレベル 1 専用の IS-IS ルーティング プロセスに再配布できません。

ステップ 4

net network-entity-title

 

Router(config-router)# net 49.0404.7777.7777.7777.7777.00

ルーティング プロセスの Network Entity Title(NET)を設定します。マルチエリア IS-IS を設定する場合は、各ルーティング プロセスの NET を指定する必要があります。

ステップ 5

redistribute protocol as-number [ route-type ] [ route-map map-tag ]

 

Router(config-router)# redistribute bgp 65404 clns

protocol 引数が bgp に設定され、 route-type 引数が clns に設定されている場合は、NSAP プレフィクス ルートを BGP から、IS-IS ルーティング プロセスに関連付けられた CLNS レベル 2 ルーティング テーブルに再配布します。

as-number 引数は、CLNS に再配布される BGP ルーティング プロセスの自律システム番号として定義されます。

ルートの再配布は、オプションの route-map キーワードを使用することによって制御できます。ルート マップが指定されない場合は、すべての BGP ルートが再配布されます。

ステップ 6

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

IS-IS から BGP への再配布ルート

ルート再配布は、その情報がルーティング テーブルに格納されるため、注意して実行する必要があります。大容量のルーティング テーブルの場合は、ルーティング プロセスが遅くなることがあります。ルート マップを使用すると、再配布されるダイナミック ルートを制御できます。

IS-IS から BGP へのルート再配布を設定するには、次の手順のステップを実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. address-family nsap [ unicast ]

6. redistribute protocol [ process-id ] [ route-type ] [ route-map map-tag ]

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65202

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 6

redistribute protocol [ process-id ] [ route-type ] [ route-map map-tag ]

 

Router(config-router-af)# redistribute isis osi-as-202 clns route-map internal-routes-only

protocol 引数が isis に設定され、 route-type 引数が clns に設定されている場合は、IS-IS ルーティング プロセスに関連付けられた CLNS レベル 2 ルーティング テーブルから BGP に、ルートを NSAP プレフィクスとして再配布します。

process-id 引数は、再配布される関連 IS-IS ルーティング プロセスの領域名として定義されます。

ルートの再配布は、オプションの route-map キーワードを使用することによって制御できます。ルート マップが指定されない場合は、すべてのレベル 2 ルートが再配布されます。

ステップ 7

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP ピア グループおよびルート リフレクタの設定

BGP ピア グループは、BGP neighbor コマンドを複数のネイバーに適用することによって、コンフィギュレーション コマンドの数を減らします。BGP ルート リフレクタとして設定されたローカル ルータとともに BGP ピア グループを使用すると、グループの 1 つのメンバから受信された BGP ルーティング情報を他のすべてのグループ メンバに複製できます。ピア グループがない場合は、各ルート リフレクタ クライアントを IP アドレスごとに指定する必要があります。

BGP ピア グループを作成し、そのグループを BGP ルート リフレクタ クライアントとして使用するには、次の手順のステップを実行します。これは任意の作業であり、内部 BGP ネイバーで使用されます。この作業では、一部の BGP 構文が peer-group-name 引数だけとともに表示され、1 つだけのネイバーがピア グループのメンバとして設定されます。他の BGP ネイバーをピア グループのメンバとして設定するには、ステップ 9 を繰り返します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. neighbor peer-group-name peer-group

6. neighbor peer-group-name remote-as as-number

7. address-family nsap [ unicast ]

8. neighbor peer-group-name route-reflector-client

9. neighbor ip-address peer-group peer-group-name

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65303

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

neighbor peer-group-name peer-group

 

Router(config-router)# neighbor ibgp-peers peer-group

BGP ピア グループを作成します。

ステップ 6

neighbor peer-group-name remote-as as-number

 

Router(config-router)# neighbor ibgp-peers remote-as 65303

指定された自律システム内の BGP ネイバーのピア グループ名を、ローカル ルータの BGP ネイバー テーブルに追加します。

ステップ 7

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 8

neighbor peer-group-name route-reflector-client

 

Router(config-router-af)# neighbor ibgp-peers route-reflector-client

ルータを BGP ルート リフレクタとして設定し、そのクライアントとして、指定されたピア グループを設定します。

ステップ 9

neighbor ip-address peer-group peer-group

 

Router(config-router-af)# neighbor 10.4.5.4 peer-group ibgp-peers

BGP ネイバーを BGP ピア グループに割り当てます。

ステップ 10

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

NSAP プレフィクスに基づくインバウンド ルートのフィルタリング

NSAP プレフィクスに基づいてインバウンド BGP ルートをフィルタリングするには、この作業を実行します。インバウンド ルートをフィルタリングするには、 neighbor prefix-list in コマンドをアドレス ファミリ コンフィギュレーション モードで設定します。

前提条件

neighbor コマンドを設定する前に、CLNS フィルタ セットまたは CLNS フィルタ表現を指定する必要があります。詳細については、 clns filter-expr コマンド、および clns filter-set コマンドの説明を参照してください。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. address-family nsap [ unicast ]

6. neighbor { ip-address | peer-group-name } prefix-list { clns-filter-expr-name | clns-filter-set-name } in

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65200

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 6

neighbor { ip-address | peer-group-name } prefix-list { clns-filter-expr-name | clns-filter-set-name } in

 

Router(config-router-af)# neighbor 10.23.4.1 prefix-list abc in

インバウンド BGP ルートのフィルタリングに使用される CLNS フィルタ セットまたは CLNS フィルタリング表現を指定します。

clns-filter-expr-name 引数は、 clns filter-expr コンフィギュレーション コマンドで定義されます。

clns-filter-set-name 引数は、 clns filter-set コンフィギュレーション コマンドで定義されます。

ステップ 7

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング

この作業を実行して NSAP プレフィクスに基づきアウトバウンド BGP アップデートをフィルタリングし、アドレス ファミリ コンフィギュレーション モードで neighbor prefix-list out コマンドを実行します。この作業は、図 1のルータ 7 で設定されます。この作業では、CLNS フィルタが 2 つのエントリで作成されて、49.0404 で始まる NSAP プレフィクスを拒否し、49 で始まる他のすべての NSAP プレフィクスを許可します。BGP ピア グループが作成され、ピア グループのメンバであるネイバーのアウトバウンド BGP アップデートにフィルタが適用されます。

手順の概要

1. enable

2. configure terminal

3. clns filter-set name [ deny ] template

4. clns filter-set name [ permit ] template

5. router bgp as-number

6. no bgp default ipv4-unicast

7. neighbor peer-group-name peer-group

8. neighbor { ip-address | peer-group-name } remote-as as-number

9. address-family nsap [ unicast ]

10. neighbor { ip-address | peer-group-name } prefix-list { clns-filter-expr-name | clns-filter-set-name } out

11. neighbor ip-address peer-group peer-group-name

12. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

clns filter-set name [ deny ] template

 

Router(config)# clns filter-set routes0404 deny 49.0404...

CLNS フィルタリング表現に使用する拒否条件の NSAP プレフィクスのマッチングを定義します。

この例では、アドレスが 49.0404 で始まる場合は拒否動作が戻ります。

ステップ 4

clns filter-set name [ permit ] template

 

Router(config)# clns filter-set routes0404 permit 49...

CLNS フィルタリング表現に使用する許可条件の NSAP プレフィクスのマッチングを定義します。

この例では、アドレスが 49 で始まる場合は許可動作が戻ります。

(注) このステップの許可例では 49 で始まるすべての NSAP アドレスを許可しますが、ステップ 3 の一致条件が最初に処理されるため、49.0404 で始まる NSAP アドレスは引き続き拒否されます。

ステップ 5

router bgp as-number

 

Router(config)# router bgp 65404

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 6

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 7

neighbor peer-group-name peer-group

 

Router(config-router)# neighbor ebgp-peers peer-group

BGP ピア グループを作成します。

この例では、ebgp-peers という名前の BGP ピア グループが作成されます。

ステップ 8

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor ebgp-peers remote-as 65303

指定された自律システム内の BGP ネイバーの IP アドレスまたはピア グループ名を、ローカル ルータの BGP ネイバー テーブルに追加します。

この例では、ebgp-peers という名前の BGP ピア グループが BGP ネイバー テーブルに追加されます。

ステップ 9

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 10

neighbor { ip-address | peer-group-name } prefix-list { clns-filter-expr-name | clns-filter-set-name } out

 

Router(config-router-af)# neighbor ebgp-peers prefix-list routes0404 out

アウトバウンド BGP アップデートのフィルタリングに使用される CLNS フィルタ セットまたは CLNS フィルタ表現を指定します。

clns-filter-expr-name 引数は、 clns filter-expr コンフィギュレーション コマンドで定義されます。

clns-filter-set-name 引数は、 clns filter-set コンフィギュレーション コマンドで定義されます。

この例では、routes0404 という名前のフィルタ セットがステップ 3 と 4 で作成されました。

ステップ 11

neighbor ip-address peer-group peer-group

 

Router(config-router-af)# neighbor 10.6.7.8 peer-group ebgp-peers

BGP ネイバーを BGP ピア グループに割り当てます。

ステップ 12

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ネイバー ルーティング ドメインのデフォルト ルートの送信

ネイバー OSI ルーティング ドメインのためにローカル ルータを指すデフォルト CLNS ルートを作成するには、次の手順のステップを実行します。これは任意の作業であり、通常は外部 BGP ネイバーだけで使用されます。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. address-family nsap [ unicast ]

6. neighbor { ip-address | peer-group-name } default-originate [ route-map map-tag ]

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 64803

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにします。

ステップ 5

address-family nsap [ unicast ]

 

Router(config-router)# address-family nsap

NSAP アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 6

neighbor { ip-address | peer-group-name } default-originate [ route-map map-tag]

 

Router(config-router-af)# neighbor 172.16.2.3 default-originate

ローカル ルータを指し、かつ、ネイバー OSI ルーティング ドメインにアドバタイズされる、デフォルト CLNS ルートを生成します。

ステップ 7

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

CLNS に対する MP-BGP サポートの確認

コンフィギュレーションを確認するには、 show running-config EXEC コマンドを使用します。出力例は、「CLNS に対する MP-BGP サポートの実装:例」にあります。CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能を確認するには、次の手順を実行します。

手順の概要

1. show clns neighbors

2. show clns route

3. show bgp nsap unicast summary

4. show bgp nsap unicast

手順の詳細


ステップ 1 show clns neighbors

このコマンドを使用して、ローカル OSI ルーティング ドメイン内の他のレベル 2 IS-IS ルータとともに、すべての必要な IS-IS 隣接をローカル ルータが作成したことを確認します。ローカル ルータに、直接接続された外部 BGP ピアがある場合、このコマンドの出力は、ES-IS 隣接の形式で、外部ネイバーが検出されたことを示します。

次に、図 1 に示されるルータ R2 に表示される出力例を示します。R2 には、3 つの CLNS ネイバーがあります。R1 および R4 は、R2 と異なる自律システム内にあるノードであるため ES-IS ネイバーです。R3 は、R2 と同じ自律システム内にあるため IS-IS ネイバーです。システム ID が、各コンフィギュレーション ファイルで定義された CLNS ホスト名(r1、r3、および r4)に置き換えられることに注意してください。CLNS ホスト名を指定すると、どのシステム ID がどのホスト名に対応するか覚える必要がありません。

Router# show clns neighbors
 
Tag osi-as-202:
System Id Interface SNPA State Holdtime Type Protocol
r1 Se2/0 *HDLC* Up 274 IS ES-IS
r3 Et0/1 0002.16de.8481 Up 9 L2 IS-IS
r4 Se2/2 *HDLC* Up 275 IS ES-IS
 

ステップ 2 show clns route

このコマンドを使用して、ローカル ルータに、ローカル OSI ルーティング ドメイン内の他の領域への計算されたルートがあることを確認します。次に、図 1 に示されるルータ R2 の出力例を示します。i 49.0202.3333 [110/10] via R3 のルーティング テーブル エントリは、ルータ R2 がローカル OSI ルーティング ドメイン内の他のローカル IS-IS 領域に関して認識していることを示します。

Router# show clns route
 
Codes: C - connected, S - static, d - DecnetIV
I - ISO-IGRP, i - IS-IS, e - ES-IS
B - BGP, b - eBGP-neighbor
 
C 49.0202.2222 [2/0], Local IS-IS Area
C 49.0202.2222.2222.2222.2222.00 [1/0], Local IS-IS NET
 
b 49.0101.1111.1111.1111.1111.00 [15/10]
via r1, Serial2/0
i 49.0202.3333 [110/10]
via r3, Ethernet0/1
b 49.0303.4444.4444.4444.4444.00 [15/10]
via r4, Serial2/2
B 49.0101 [20/1]
via r1, Serial2/0
B 49.0303 [20/1]
via r4, Serial2/2
B 49.0404 [200/1]
via r9
i 49.0404.9999.9999.9999.9999.00 [110/10]
via r3, Ethernet0/1
 

ステップ 3 show bgp nsap unicast summary

このコマンドを使用して、特定のネイバーへの TCP 接続がアクティブであることを確認します。次の出力例では、ネイバーの IP アドレスに基づいて適切な行を検索します。IState/PfxRcd カラム エントリが数字(ゼロを含む)である場合、そのネイバーの TCP 接続はアクティブです。

Router# show bgp nsap unicast summary
 
BGP router identifier 10.1.57.11, local AS number 65202
BGP table version is 6, main routing table version 6
5 network entries and 8 paths using 1141 bytes of memory
6 BGP path attribute entries using 360 bytes of memory
4 BGP AS-PATH entries using 96 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 5/0 prefixes, 8/0 paths, scan interval 60 secs
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.1.2.1 4 65101 34 34 6 0 0 00:29:11 1
10.2.3.3 4 65202 35 36 6 0 0 00:29:16 3
 

ステップ 4 show bgp nsap unicast コマンドを入力すると、ローカル ルータが検出された、すべての NSAP プレフィクス ルートが表示されます。次に、図 1 に示されるルータ R2 の出力例を示します。プレフィクス 49.0101 への 1 つの有効なルートが示されます。* でマーキングされている 2 つの有効なルートが、プレフィクス 49.0404 で示されます。2 番目のルートが *>i シーケンスでマーキングされ、このプレフィクスへの最良ルートを表しています。

Router# show bgp nsap unicast
 
BGP table version is 3, local router ID is 192.168.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 49.0101 49.0101.1111.1111.1111.1111.00
0 65101 i
* i49.0202.2222 49.0202.3333.3333.3333.3333.00
100 0 ?
*> 49.0202.2222.2222.2222.2222.00
32768 ?
* i49.0202.3333 49.0202.3333.3333.3333.3333.00
100 0 ?
*> 49.0202.2222.2222.2222.2222.00
32768 ?
*> 49.0303 49.0303.4444.4444.4444.4444.00
0 65303 i
* 49.0404 49.0303.4444.4444.4444.4444.00
0 65303 65404 i
*>i 49.0404.9999.9999.9999.9999.00
100 0 65404 i
 


 

CLNS に対する MP-BGP サポートのトラブルシューティング

debug bgp nsap unicast コマンドは、コンソール上に表示される BGP ルーティング プロトコルの CLNS パケットの操作に関連するさまざまなイベントに対する診断出力をイネーブルにします。これらのコマンドは、使用時にソフトウェアが生成する出力量によってルータの性能が著しく低下するため、トラブルシューティング専用となります。これらの degub コマンドの使用の詳細については、『 Cisco IOS Debug Command Reference 』を参照してください。

CLNS に対する MP-BGP サポートの設定に関する問題をトラブルシューティングして、この手順で使用される debug コマンドの影響を最小化するには、次の手順を実行します。

手順の概要

1. コンソールを接続します。

2. no logging console

3. Telnet を使用して、ルータ ポートにアクセスします。

4. enable

5. terminal monitor

6. debug bgp nsap unicast [ neighbor-address | dampening | keepalives | updates ]

7. no terminal monitor

8. no debug bgp nsap unicast [ neighbor-address | dampening | keepalives | updates ]

9. logging console

手順の詳細


ステップ 1 CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能を含む Cisco IOS ソフトウェア リリースを実行しているルータにコンソールを直接接続します。


) コンソール ポートが文字ごとにプロセッサ割り込みを生成しないため、この手順により、debug bgp nsap unicast コマンドが作成するルータの負荷が最小化されます。直接コンソールに接続できない場合は、ターミナル サーバを介してこの手順を実行できます。ただし、Telnet 接続を切断する必要がある場合は、debug bgp nsap unicast 出力を生成するプロセッサ負荷のためルータが応答できない場合があることから、再接続できないことがあります。


ステップ 2 no logging console

このコマンドは、コンソール端末へのすべてのロギングをディセーブルにします。

ステップ 3 Telnet を使用して、ルータ ポートにアクセスします。

ステップ 4 enable

このコマンドを入力して、特権 EXEC モードにアクセスします。

ステップ 5 terminal monitor

このコマンドは、仮想端末へのロギングをイネーブルにします。

ステップ 6 debug bgp nsap unicast [ neighbor-address | dampening | keepalives | updates ]

特定の debug bgp nsap unicast コマンドだけを入力して特定のサブコンポーネントへの出力を隔離し、プロセッサの負荷を最小化します。適切な引数とキーワードを使用すると、指定されたサブコンポーネントに関する詳細なデバッグ情報が生成されます。

ステップ 7 no terminal monitor

このコマンドは、仮想端末へのロギングをディセーブルにします。

ステップ 8 no debug bgp nsap unicast [ neighbor-address | dampening | keepalives | updates ]

終了したら、特定の no debug bgp nsap unicast コマンドを入力します。

ステップ 9 logging console

このコマンドは、コンソールへのロギングを再びイネーブルにします。


 

CLNS に対する MP-BGP サポートの設定例

このセクションでは、前項の指定されたコンフィギュレーション作業と一致するコンフィギュレーション例を示します。図 1 のすべてのルータ コンフィギュレーションの概要を説明するために、各ルータの詳細なコンフィギュレーションがこのセクションの終わりに加えられています。

「CLNS をサポートするための BGP ネイバーの設定とアクティブ化:例」

「IS-IS ルーティング プロセスの設定:例」

「インターフェイスの設定:例」

「ネットワーキング プレフィクスのアドバタイジング:例」

「BGP から IS-IS へのルートの再配布:例」

「IS-IS から BGP へのルートの再配布:例」

「BGP ピア グループおよびルート リフレクタの設定:例」

「NSAP プレフィクスに基づくインバウンド ルートのフィルタリング:例」

「NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング:例」

「デフォルト ルートの発信およびアウトバウンド ルート フィルタリング:例」

「CLNS に対する MP-BGP サポートの実装:例」

CLNS をサポートするための BGP ネイバーの設定とアクティブ化:例

次の例では、自律システム AS65101 で、図 3 に示されるルータ R1 が、BGP を実行して CLNS をサポートするためにアクティブになるように設定されています。ルータ R1 は、自律システム AS65101 ではレベル 2 IS-IS 専用ルータであり、AS65202 では、ルータ R2 を介して別の自律システムへの接続を 1 つだけ持ちます。 no bgp default ipv4-unicast コマンドは、BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにするために、ルータで設定されます。NSAP アドレス ファミリ コンフィギュレーション モードが address-family nsap コマンドでイネーブルにされると、ルータが 49.0101 の NSAP プレフィクスを BGP ネイバーにアドバタイズして、10.1.2.2 の BGP ネイバーに NSAP ルーティング情報を送信するように設定されます。

router bgp 65101
no bgp default ipv4-unicast
address-family nsap
network 49.0101...
neighbor 10.1.2.2 activate
exit-address-family

IS-IS ルーティング プロセスの設定:例

次の例では、図 3 に示されるルータ R1 が IS-IS プロセスを実行するように設定されます。

router isis osi-as-101
net 49.0101.1111.1111.1111.1111.00
 

デフォルトの IS-IS ルーティング プロセス レベルが使用されます。

インターフェイスの設定:例

次の例では、自律システム AS65202 で、図 3 に示されるルータ R2 の 2 つのインターフェイスが、CLNS を実行するように設定されています。イーサネット インターフェイス 0/1 は、ローカル OSI ルーティング ドメインに接続されており、ネットワーク プロトコルが clns router isis コマンドを使用する CLNS である場合に IS-IS を実行するように設定されています。ローカル IP アドレスが 10.1.2.2 のシリアル インターフェイス 2/0 は、eBGP ネイバーに接続されており、 clns enable コマンドで CLNS を実行するように設定されています。

interface serial 2/0
ip address 10.1.2.2 255.255.255.0
clns enable
no shutdown
!
interface ethernet 0/1
ip address 10.2.3.1 255.255.255.0
clns router isis osi-as-202
no shutdown

ネットワーキング プレフィクスのアドバタイジング:例

次の例では、図 3 に示されるルータ R1 が、49.0101 の NSAP プレフィクスを他のルータにアドバタイズするように設定されています。自律システム AS65101 に対して一意の NSAP プレフィクスがアドバタイズされることにより、他の自律システムは、ネットワーク内に自律システム AS65101 の存在を検出できます。

router bgp 65101
no bgp default ipv4-unicast
neighbor 10.1.2.2 remote-as 64202
address-family nsap
network 49.0101...
neighbor 10.1.2.2 activate

BGP から IS-IS へのルートの再配布:例

次の例では、自律システム AS65404 の 図 3 に示されるルータ R7 および R9 が、osi-as-404 と呼ばれる IS-IS ルーティング プロセスに BGP ルートを再配布するように設定されています。BGP ルートの再配布により、レベル 2 IS-IS ルータの R8 は、自律システム AS65404 の外部の宛先にルートをアドバタイズできるようになります。ルート マップが指定されない場合は、すべての BGP ルートが再配布されます。

ルータ R7

router isis osi-as-404
net 49.0404.7777.7777.7777.7777.00
redistribute bgp 65404 clns

ルータ R9

router isis osi-as-404
net 49.0404.9999.9999.9999.9999.00
redistribute bgp 65404 clns

IS-IS から BGP へのルートの再配布:例

次の例では、自律システム AS65202 の 図 3 に示されるルータ R2 が、レベル 2 CLNS NSAP を BGP に再配布するように設定されています。ルート マップを使用して、BGP に再配布されるローカル自律システム内からのルートだけを許可します。ルート マップを指定しない場合は、CLNS レベル 2 プレフィクス テーブルから、すべての NSAP ルートが再配布されます。 no bgp default ipv4-unicast コマンドは、BGP ネイバー ルータとの間で IPv4 アドレッシング情報を交換する BGP ルーティング プロセスのデフォルト動作をディセーブルにするために、ルータで設定されます。

clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
match clns address internal-routes
!
router isis osi-as-202
net 49.0202.2222.2222.2222.2222.00
!
router bgp 65202
no bgp default ipv4-unicast
address-family nsap
redistribute isis osi-as-202 clns route-map internal-routes-only

BGP ピア グループおよびルート リフレクタの設定:例

図 1 に示されるルータ R5 は iBGP ネイバーだけを持ち、両方のインターフェイスで IS-IS を実行します。コンフィギュレーション コマンドの数を減らすには、ibgp-peers と呼ばれる BGP ピア グループのメンバとして R5 を設定します。ピア グループをグループ メンバ間で NSAP ルーティング情報を交換できるようにするルート リフレクタ クライアントとして設定することによって、ピア グループは address-family nsap コマンド下で自動的にアクティブになります。BGP ピア グループは、すべての BGP ルータを相互にリンクする必要性を少なくする BGP ルート リフレクタ クライアントとしても設定されます。

次の例では、自律システム AS65303 のルータ R5 が、BGP ピア グループのメンバおよび BGP ルート リフレクタ クライアントとして設定されます。

router bgp 65303
no bgp default ipv4-unicast
neighbor ibgp-peers peer-group
neighbor ibgp-peers remote-as 65303
address-family nsap
neighbor ibgp-peers route-reflector-client
neighbor 10.4.5.4 peer-group ibgp-peers
neighbor 10.5.6.6 peer-group ibgp-peers
exit-address-family

NSAP プレフィクスに基づくインバウンド ルートのフィルタリング:例

次の例では、自律システム AS65101 の 図 3 に示されるルータ R1 が、デフォルト プレフィクス専用のプレフィクス リストで指定されたインバウンド ルートをフィルタリングするように設定されます。

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router isis osi-as-101
net 49.0101.1111.1111.1111.1111.00
!
router bgp 65101
no bgp default ipv4-unicast
neighbor 10.1.2.2 remote-as 64202
address-family nsap
network 49.0101.1111.1111.1111.1111.00
neighbor 10.1.2.2 activate
neighbor 10.1.2.2 prefix-list default-prefix-only in

NSAP プレフィクスに基づくアウトバウンド BGP アップデートのフィルタリング:例

次の例では、アウトバウンド BGP アップデートが NSAP プレフィクスに基づいてフィルタリングされます。この例は、図 3 のルータ 7 で設定されます。この作業では、CLNS フィルタが 2 つのエントリで作成されて、49.0404 で始まる NSAP プレフィクスを拒否し、49 で始まる他のすべての NSAP プレフィクスを許可します。BGP ピア グループが作成され、ピア グループのメンバであるネイバーのアウトバウンド BGP アップデートにフィルタが適用されます。

clns filter-set routes0404 deny 49.0404...
clns filter-set routes0404 permit 49...
!
router bgp 65404
no bgp default ipv4-unicast
neighbor ebgp-peers remote-as 65303
address-family nsap
neighbor ebgp-peers prefix-list routes0404 out
neighbor 10.6.7.8 peer-group ebgp-peers

デフォルト ルートの発信およびアウトバウンド ルート フィルタリング:例

図 3 では、自律システム AS65101 が、他の 1 つの自律システム AS65202 だけに接続されます。AS65202 のルータ R2 は、デフォルト ルートを R1 に送信することによって、自律システム AS65101 の残りのネットワークと接続します。ローカル レベル 1 ネットワークの外部の宛先 NSAP アドレスを持ち、自律システム AS65101 内にあるレベル 1 ルータからのパケットは、レベル 2 ルータに最も近い R1 に送信されます。ルータ R1 は、デフォルト ルートを使用してパケットをルータ R2 に転送します。

次の例では、自律システム AS65202 の 図 3 に示されるルータ R2 が、自律システム AS65101 のルータ R1 のデフォルト ルートを生成するように設定され、アウトバウンド フィルタが作成されて、BGP アップデート メッセージ内のデフォルト ルート NSAP アドレッシング情報だけをルータ R1 に送信します。

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router bgp 65202
no bgp default ipv4-unicast
neighbor 10.1.2.1 remote-as 64101
address-family nsap
network 49.0202...
neighbor 10.1.2.1 activate
neighbor 10.1.2.1 default-originate
neighbor 10.1.2.1 prefix-list default-prefix-only out

CLNS に対する MP-BGP サポートの実装:例

図 3 に、4 つの異なる自律システム(BGP 用語)またはルーティング ドメイン(OSI 用語)にグループ分けされる 9 つのルータを含む汎用 BGP CLNS ネットワークを示します。ここでは、図 3 に示される全ルータのすべてのコンフィギュレーションについて記述します。

図 3 汎用 BGP CLNS ネットワークのコンポーネント

 

次の例で使用されるコマンドについての詳細が必要な場合は、このマニュアルおよび 「参考資料」 に示される資料のコンフィギュレーション作業を参照してください。

自律システム AS65101

ルータ 1

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
router isis osi-as-101
net 49.0101.1111.1111.1111.1111.00
!
router bgp 65101
no bgp default ipv4-unicast
neighbor 10.1.2.2 remote-as 65202
address-family nsap
neighbor 10.1.2.2 activate
neighbor 10.1.2.2 prefix-list default-prefix-only in
network 49.0101...
exit-address-family
!
interface serial 2/0
ip address 10.1.2.1 255.255.255.0
clns enable
no shutdown

自律システム AS65202

ルータ 2

clns filter-set default-prefix-only deny 49...
clns filter-set default-prefix-only permit default
!
clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
match clns address internal-routes
!
router isis osi-as-202
net 49.0202.2222.2222.2222.2222.00
!
router bgp 65202
no bgp default ipv4-unicast
neighbor 10.1.2.1 remote-as 65101
neighbor 10.2.3.3 remote-as 65202
neighbor 10.2.4.4 remote-as 65303
address-family nsap
neighbor 10.1.2.1 activate
neighbor 10.2.3.3 activate
neighbor 10.2.4.4 activate
redistribute isis osi-as-202 clns route-map internal-routes-only
neighbor 10.1.2.1 default-originate
neighbor 10.1.2.1 prefix-list default-prefix-only out
exit-address-family
 
!
interface ethernet 0/1
ip address 10.2.3.2 255.255.255.0
clns router isis osi-as-202
no shutdown
!
interface serial 2/0
ip address 10.1.2.2 255.255.255.0
clns enable
no shutdown
!
interface serial 2/2
ip address 10.2.4.2 255.255.255.0
clns enable
no shutdown

ルータ 3

clns filter-set internal-routes permit 49.0202...
!
route-map internal-routes-only permit 10
match clns address internal-routes
!
router isis osi-as-202
net 49.0202.3333.3333.3333.3333.00
!
router bgp 65202
no bgp default ipv4-unicast
neighbor 10.2.3.2 remote-as 65202
neighbor 10.3.9.9 remote-as 65404
address-family nsap
neighbor 10.2.3.2 activate
neighbor 10.3.9.9 activate
redistribute isis osi-as-202 clns route-map internal-routes-only
exit-address-family
!
interface ethernet 0/1
ip address 10.2.3.3 255.255.255.0
clns router isis osi-as-202
no shutdown
!
interface serial 2/2
ip address 10.3.9.3 255.255.255.0
clns enable
no shutdown

自律システム AS65303

ルータ 4

router isis osi-as-303
net 49.0303.4444.4444.4444.4444.00
!
router bgp 65303
no bgp default ipv4-unicast
neighbor 10.2.4.2 remote-as 65202
neighbor 10.4.5.5 remote-as 65303
address-family nsap
no synchronization
neighbor 10.2.4.2 activate
neighbor 10.4.5.5 activate
network 49.0303...
exit-address-family
!
interface ethernet 0/2
ip address 10.4.5.4 255.255.255.0
clns router isis osi-as-303
no shutdown
!
interface serial 2/3
ip address 10.2.4.4 255.255.255.0
clns enable
no shutdown

ルータ 5

router isis osi-as-303
net 49.0303.5555.5555.5555.5555.00
!
router bgp 65303
no bgp default ipv4-unicast
neighbor ibgp-peers peer-group
neighbor ibgp-peers remote-as 65303
address-family nsap
no synchronization
neighbor ibgp-peers route-reflector-client
neighbor 10.4.5.4 peer-group ibgp-peers
neighbor 10.5.6.6 peer-group ibgp-peers
exit-address-family
!
interface ethernet 0/2
ip address 10.4.5.5 255.255.255.0
clns router isis osi-as-303
no shutdown
!
interface ethernet 0/3
ip address 10.5.6.5 255.255.255.0
clns router isis osi-as-303
no shutdown

ルータ 6

router isis osi-as-303
net 49.0303.6666.6666.6666.6666.00
!
router bgp 65303
no bgp default ipv4-unicast
neighbor 10.5.6.5 remote-as 65303
neighbor 10.6.7.7 remote-as 65404
address-family nsap
no synchronization
neighbor 10.5.6.5 activate
neighbor 10.6.7.7 activate
network 49.0303...
!
interface ethernet 0/3
ip address 10.5.6.6 255.255.255.0
clns router isis osi-as-303
no shutdown
!
interface serial 2/2
ip address 10.6.7.6 255.255.255.0
clns enable
no shutdown

自律システム AS65404

ルータ 7

clns filter-set external-routes deny 49.0404...
clns filter-set external-routes permit 49...
!
route-map noexport permit 10
match clns address external-routes
set community noexport
!
router isis osi-as-404
net 49.0404.7777.7777.7777.7777.00
redistribute bgp 404 clns
!
router bgp 65404
no bgp default ipv4-unicast
neighbor 10.6.7.6 remote-as 65303
neighbor 10.8.9.9 remote-as 65404
address-family nsap
neighbor 10.6.7.6 activate
neighbor 10.8.9.9 activate
neighbor 10.8.9.9 send-community
neighbor 10.8.9.9 route-map noexport out
network 49.0404...
!
interface ethernet 1/0
ip address 10.7.8.7 255.255.255.0
clns router isis osi-as-404
ip router isis osi-as-404
no shutdown
!
interface serial 2/3
ip address 10.6.7.7 255.255.255.0
clns enable
no shutdown

ルータ 8

router isis osi-as-404
net 49.0404.8888.8888.8888.8888.00
!
interface ethernet 1/0
ip address 10.7.8.8 255.255.255.0
clns router isis osi-as-404
ip router isis osi-as-404
no shutdown
!
interface ethernet 1/1
ip address 10.8.9.8 255.255.255.0
clns router isis osi-as-404
ip router isis osi-as-404
no shutdown

ルータ 9

clns filter-set external-routes deny 49.0404...
clns filter-set external-routes permit 49...
!
route-map noexport permit 10
match clns address external-routes
set community noexport
!
router isis osi-as-404
net 49.0404.9999.9999.9999.9999.00
redistribute bgp 404 clns
!
router bgp 65404
no bgp default ipv4-unicast
neighbor 10.3.9.3 remote-as 65202
neighbor 10.7.8.7 remote-as 65404
address-family nsap
network 49.0404...
neighbor 10.3.9.3 activate
neighbor 10.7.8.7 activate
neighbor 10.7.8.7 send-community
neighbor 10.7.8.7 route-map noexport out
!
interface serial 2/3
ip address 10.3.9.9 255.255.255.0
clns enable
no shutdown
!
interface ethernet 1/1
ip address 10.8.9.9 255.255.255.0
clns router isis osi-as-404
ip router isis osi-as-404
no shutdown

参考資料

次のセクションでは、CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能に関する参考資料について説明します。

関連資料

関連項目
参照先

BGP コマンド

『Cisco IOS IP Routing: BGP Command Reference』

CLNS コマンド

『Cisco IOS ISO CLNS Command Reference』

規格

規格
タイトル

ISO/IEC 8473

ISO CLNP: Connectionless Network Protocol (ISO-IP) 』 。コネクションレス型モード ネットワーク サービスを提供するプロトコル。

ISO/IEC 9542

End System to Intermediate System Protocol (ESIS) 』 。コネクションレス型モード ネットワーク サービス(ISO 8473)を提供するプロトコルとともに使用される、エンド システムから中継システムまでのルーティング交換プロトコル。

ISO/IEC 10589

IS-IS, Intermediate System-to-Intermediate System 』 。コネクションレス型モード ネットワーク サービス(ISO 8473)を提供するプロトコルとともに使用される、中継システム間のドメイン内ルーティング情報交換プロトコル。

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1700

『Assigned Numbers』

RFC 1771

『A Border Gateway Protocol 4 (BGP-4)』

RFC 1997

『BGP Communities Attribute』

RFC 2042

『Registering New BGP Attribute Types』

RFC 2439

『BGP Route Flap Dampening』

RFC 2842

『Capabilities Advertisement with BGP-4』

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 2918

『Route Refresh Capability for BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/en/US/support/index.html

CLNS に対する MP-BGP サポートの設定に関する機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。12.2(1) 以降のリリースで追加または変更された機能だけが、テーブルに示されています。

このテクノロジーの機能でここに記載されていない情報については、『 BGP Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 CLNS に対する MP-BGP サポートに関する機能情報

機能名
リリース
機能情報

CLNS に対するマルチプロトコル BGP(MP-BGP)サポート

12.2(8)T
12.2(33)SRB

CLNS に対するマルチプロトコル BGP(MP-BGP)サポート機能により、コネクションレス型ネットワーク サービス(CLNS)ネットワークをスケーリングする機能が提供されます。ボーダー ゲートウェイ プロトコル(BGP)のマルチプロトコル拡張は、ルーティング ドメインをマージせずに個別の開放型システム間相互接続(OSI)ルーティング ドメインを相互接続する機能を追加することによって、大規模な OSI ネットワークを確立する機能を実現します。

リリース 12.2(8)T では、この機能が次のプラットフォームで追加されました。

Cisco 2600 シリーズ

Cisco 3600 シリーズ

Cisco 7100 シリーズ

Cisco 7200 シリーズ

Cisco 7500 シリーズ

Cisco uBR7200 シリーズ

リリース 12.2(33)SRB では、この機能が Cisco 7600 シリーズで追加されました。

この機能によって、次の各コマンドが追加変更されています。 address-family nsap clear bgp nsap clear bgp nsap dampening、 clear bgp nsap external clear bgp nsap flap-statistics clear bgp nsap peer-group debug bgp nsap debug bgp nsap dampening debug bgp nsap updates neighbor prefix-list network(BGP およびマルチプロトコル BGP) redistribute(BGP から ISO ISIS) redistribute(ISO ISIS から BGP) show bgp nsap show bgp nsap community show bgp nsap community-list show bgp nsap dampened-paths show bgp nsap filter-list show bgp nsap flap-statistics show bgp nsap inconsistent-as show bgp nsap neighbors show bgp nsap paths show bgp nsap quote-regexp show bgp nsap regexp show bgp nsap summary

用語集

AS :Autonomous System(自律システム)。独立した独自のルーティング ポリシーを持ち、単一権限によって管理されるルーティング ドメインを表す IP 用語です。OSI 用語「ルーティング ドメイン」に相当します。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。他の BGP システムとの間で到着可能性情報を交換するドメイン間ルーティング プロトコルです。

CLNS :Connectionless Network Service(コネクションレス型ネットワーク サービス)。OSI ネットワーク レイヤ プロトコルです。

CMIP :Common Management Information Protocol(共通管理情報プロトコル)。OSI で、異種ネットワークのモニタリングと制御のために ISO によって作成および標準化されるネットワーク管理プロトコルです。

DCC :Data Communications Channel(データ通信チャネル)。

DCN :Data Communications Network(データ通信ネットワーク)。

ES-IS :End System-to-Intermediate System。エンド システム(ホスト)が自身を中継システム(ルータ)にアナウンスする方法を定義する OSI プロトコルです。

FTAM :File Transfer, Access, and Management。OSI で、さまざまなタイプのコンピュータ間でのネットワーク ファイルの交換と管理用に開発されたアプリケーション レイヤ プロトコルです。

IGP :Interior Gateway Protocol(内部ゲートウェイ プロトコル)。自律システム内でルーティング情報を交換するために使用されるインターネット プロトコルです。

IGRP :Interior Gateway Routing Protocol。大規模な異種ネットワークのルーティングに関連する問題を解決するために開発されたシスコ独自のプロトコルです。

IS :Intermediate System(中継システム)。OSI ネットワーク内のルーティング ノードです。

IS-IS :Intermediate System-to-Intermediate System。DECnet Phase V ルーティングに基づく OSI リンクステート階層型ルーティング プロトコルであり、ルータはこれを使用して、ネットワーク トポロジを決定するために、1 つのメトリックに基づいてルーティング情報を交換します。

ISO :International Organization for Standardization(国際標準化機構)。ネットワーキングに関連する標準を含む、広範囲の標準を策定する国際組織。ISO は、著名なネットワーキング参照モデルである開放型システム間相互接続(OSI)参照モデルを開発しました。

NSAP アドレス :Network Services Access Point(ネットワーク サービス アクセス ポイント)アドレス。OSI ネットワークによって使用されるネットワーク アドレス形式です。

OSI :Open System Interconnection(開放型システム間相互接続)。マルチベンダー機器の相互運用性の向上を目指すデータ ネットワーキングの規格を作るために、ISO と ITU-T が作成した国際標準プログラムです。

SDH :Synchronous Digital Hierarchy(同期デジタル階層)。一連のレートを定義する規格、また、光信号を使用して光ファイバで送信される形式規格です。

SONET :Synchronous Optical Network。光ファイバ上で稼動するように設計された高速同期ネットワーク仕様です。

アドレス ファミリ :ネットワーク アドレスの共通形式を共有するネットワーク プロトコルのグループ。アドレス ファミリは RFC 1700 で定義されています。

ルーティング ドメイン :BGP の自律システムに相当する OSI 用語。