IP ルーティング:BFD コンフィギュレーション ガイ ド、Cisco IOS Release 15.1S
双方向フォワーディング検出
双方向フォワーディング検出
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

双方向フォワーディング検出

機能情報の検索

マニュアルの内容

双方向フォワーディング検出の前提条件

双方向フォワーディング検出の制約事項

双方向フォワーディング検出について

BFD の動作

ネイバー関係

BFD の障害検出

BFD バージョンの相互運用性

Cisco 12000 ルータでの BFD サポート

BFD セッションの制限

非ブロードキャスト メディア インターフェイスに対する BFD サポート

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インターフェイスのための BFD サポート

ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート

ステートフル スイッチオーバーのための BFD サポート

スタティック ルーティングのための BFD サポート

BFD Control Channel over VCCV:ATM 疑似配線のサポート

障害検出に BFD を使用することの利点

双方向フォワーディング検出の設定方法

インターフェイスでの BFD セッション パラメータの作成

ダイナミック ルーティング プロトコルに対する BFD サポートの設定

BGP に対する BFD サポートの設定

EIGRP に対する BFD サポートの設定

IS-IS に対する BFD サポートの設定

OSPF に対する BFD サポートの設定

HSRP に対する BFD サポートの設定

スタティック ルーティングのための BFD サポートの設定

BFD エコー モードの設定

BFD エコー モード

前提条件

制約事項

BFD 低速タイマーの設定

非対称性のない BFD エコー モードのディセーブル化

BFD テンプレートの作成と設定

次の作業

BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定

前提条件

BFD のモニタリングとトラブルシューティング

Catalyst 7600 シリーズ ルータのモニタリングとトラブルシューティング

Catalyst 12000 シリーズ ルータのモニタリングとトラブルシューティング

Cisco 10720 インターネット ルータに対する BFD のモニタリングとトラブルシューティング

双方向フォワーディング検出の設定例

例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定

Cisco IOS Release 12.4(9)T の例

例:OSPF ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

例:BGP ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

例:IS-IS ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

例:HSRP ネットワークでの BFD の設定

例:スタティック ルーティングのための BFD サポートの設定

例:BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

双方向フォワーディング検出の機能情報

双方向フォワーディング検出

このマニュアルでは、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)プロトコルをイネーブルにする方法について説明します。BFD はあらゆるメディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの高速転送パス障害検出回数を提供するように設計された検出プロトコルです。高速転送パス障害検出に加えて、BFD はネットワーク管理者に整合性のある障害検出方法を提供します。ネットワーク管理者は BFD を使用して、複数のルーティング プロトコルの hello メカニズムの可変レートではなく、統一レートで転送パス障害を検出でき、ネットワークのプロファイリングおよび計画が簡単になり、コンバージェンス時間が一貫して予測できます。

機能情報の検索

お使いのソフトウェア リリースが、この章で説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「双方向フォワーディング検出の機能情報」 を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

双方向フォワーディング検出の前提条件

シスコ エクスプレス フォワーディングおよび IP ルーティングが、関連するすべてのルータでイネーブルになっていること。

BFD が正常に動作するには、Cisco 10720 インターネット ルータで Cisco Parallel eXpress Forwarding(PXF)をイネーブルにしてあること。PXF はデフォルトでイネーブルになり、オフにすることは通常ありません。

BFD を導入する前に、BFD でサポートされる IP ルーティング プロトコルのいずれかをルータで設定しておくこと。使用しているルーティング プロトコルの高速コンバージェンスを実装する必要があります。高速コンバージェンスの設定については、お使いのバージョンの Cisco IOS ソフトウェアの IP ルーティングのマニュアルを参照してください。Cisco IOS ソフトウェアでの BFD ルーティング プロトコルのサポートの詳細については、「双方向フォワーディング検出の制約事項」を参照してください。

疑似配線で Virtual Circuit Connection Verification(VCCV)BFD を実行するには、疑似配線がネットワーク上に設定されている必要があります。

双方向フォワーディング検出の制約事項

Cisco IOS Release 12.2(18)SXE、12.0(31)S、12.4(4)T、12.0(32)S、12.2(33)SRA、および 12.2(33)SRB 用のシスコの BFD 実装では、非同期モードだけがサポートされます。非同期モードでは、どちらの BFD ピアも BFD セッションを開始できます。

Cisco IOS Release 12.2(33)SRC、12.2(33)SXH、および 12.2(33)SXI では、デフォルトがエコー モードです。

Cisco IOS ソフトウェアでは、仮想テンプレートおよびダイヤラ インターフェイスで BFD を誤って設定する可能性がありますが、仮想テンプレートおよびダイヤラ インターフェイスで BFD 機能はサポートされません。仮想テンプレートおよびダイヤラ インターフェイスで BFD を設定しないでください。

Cisco IOS Release 12.2(18)SXE(およびそれ以降の SX リリース)、12.0(31)S、12.4(4)T、12.0(32)S、12.2(33)SRA、12.2(33)SRB、12.2(33)SRC、および 12.2(33)SB では、IPv4 ネットワークに対してだけシスコの BFD 実装がサポートされます。

Cisco IOS Release 12.2(33)SRB では、シスコの BFD 実装でサポートされるルーティング プロトコルは Border Gateway プロトコル(BGP; ボーダー ゲートウェイ プロトコル)、Enhanced IGRP(EIGRP)、Intermediate System-to-Intermediate System(IS-IS)、および Open Shortest Path First(OSPF)だけです。Cisco IOS Release 12.2(33)SRC では、BFD でスタティック ルーティングがサポートされます。

Cisco IOS Release 12.2(33)SRA では、シスコの BFD 実装でサポートされるルーティング プロトコルは BGP、IS-IS、および OSPF だけです。

Cisco IOS Release 12.4(4)T では、シスコの BFD 実装でサポートされるルーティング プロトコルは BGP、EIGRP、IS-IS、および OSPF だけです。

Cisco IOS Release 12.4(11)T では、シスコの BFD 実装でホット スタンバイ ルーティング プロトコル(HSRP)のサポートが導入されています。プラットフォームおよびインターフェイスによっては、BFD サポートを利用できないものがあります。

Cisco IOS Release 12.0(31)S および 12.0(32)S では、シスコの BFD 実装でサポートされるルーティング プロトコルは BGP、IS-IS、および OSPF だけです。

Cisco IOS Release 12.2(18)SXE では、シスコの BFD 実装でサポートされるルーティング プロトコルは EIGRP、IS-IS、および OSPF だけです。

Cisco IOS Release 12.2(18)SXH および 12.2(33)SB では、シスコの BFD 実装でサポートされるルーティング プロトコルは BGP、EIGRP、IS-IS、および OSPF です。

BFD は直接接続されたネイバーだけに対して動作します。BFD のネイバーは 1 ホップ以内に限られます。マルチホップのコンフィギュレーションはサポートされません。

プラットフォームおよびインターフェイスによっては、BFD サポートを利用できないものがあります。特定のプラットフォームまたはインターフェイスで BFD のサポートについて確認し、プラットフォームとハードウェアの正確な制約事項を入手するには、お使いのソフトウェア バージョンの Cisco IOS ソフトウェアのリリース ノートを参照してください。

Cisco IOS Release 12.2SXF、12.2SRC、および 12.2SRB では、BFD on PortChannel 設定がサポートされません。

Cisco 10720 インターネット ルータでは、ファスト イーサネット、ギガビット イーサネット、および RPR-IEEE インターフェイスだけで BFD がサポートされます。BFD は、Spatial Reuse Protocol(SRP)および Packet-over-SONET(POS)インターフェイスでサポートされません。

bfd コマンドを使用して(インターフェイス コンフィギュレーション モード)Cisco 10720 インターフェイスで BFD セッション パラメータを設定する場合、 interval milliseconds min_rx milliseconds パラメータの両方の milliseconds 引数でサポートされる設定可能な期間の最小値は 50 ミリ秒(ms)です。

Cisco 10720 インターネット ルータでは、最大 100 の BFD セッションがサポートされます。BFD がルーティング プロトコル間の接続をセットアップして Cisco 10720 インターネット ルータと隣接ルータの間で 101 番目のセッションを確立しようとすると、次のエラー メッセージが表示されます。

00:01:24: %OSPF-5-ADJCHG: Process 100, Nbr 10.0.0.0 on RPR-IEEE1/1 from LOADING to FULL, Loading Done
00:01:24: %BFD-5-SESSIONLIMIT: Attempt to exceed session limit of 100 neighbors.

Cisco 10720 インターネット ルータでは次の BFD 機能がサポートされません。

デマンド モード

エコー パケット

BFD over IP Version 6

Cisco 12000 シリーズのルータでは、ピア デバイス間の非対称ルーティングによって、BFD 制御パケットが、セッションを開始したラインカード以外のラインカードで受信されます。このような特殊な場合は、ルーティング ピア間の BFD セッションが確立されません。

分散 Cisco 12000 シリーズのインターネット ルータの 1 つのラインカードごとに、最大 100 セッションがサポートされます。ネイバーとのセッションがダウンしていると宣言される前に、リモート システムから受信する BFD 制御パケットの最大 3 回のリトライ回数での最大 hello 間隔は 50 ms です。

Cisco IOS Release 12.2(33)SB では、BFD が ステートフル スイッチオーバー(SSO)に対応しておらず、NSF/SSO でサポートされません。これらの機能は一緒に使用しないでください。NSF/SSO と BFD を同時にイネーブルにすると、BFD の隣接関係が維持されず、ルーティング クライアントには隣接関係停止と再コンバージェンスのマークが強制的に付けられるため、フェールオーバー中にノンストップ フォワーディング機能が動作しません。

BFD Control Channel over VCCV:ATM 疑似配線のサポート

BFD Control Channel over VCCV:非同期転送モード疑似配線のサポート機能では、IP/User Datagram Protocol(UDP; ユーザ データグラム プロトコル)のカプセル化なしで VCCV タイプ 1 のみがサポートされます。

すべての Transport over Multiprotocol Label Switching(AToM)のみが、BFD Control Channel over VCCV:ATM 疑似配線のサポート機能によってサポートされます。

Layer 2 Transport Protocol version 3(L2TPv3; レイヤ 2 トランスポート プロトコル バージョン 3)はサポートされません。

冗長疑似配線はサポートされません。

ATM の Attachment Circuit(AC; 接続回線)はサポートされます。

Cisco IOS Release 12.2(33)SXI2 と Cisco Catalyst 6500 シリーズ スイッチ

Cisco Catalyst 6500 シリーズ スイッチでは、最小 hello 間隔 50 ms、倍率 3 で最大 100 の BFD セッションがサポートされます。この倍率は、セッションがダウンしたと宣言される前に失われた可能性のある連続するパケットの最小数を指定します。

SSO がデュアル RP システムでイネーブルになっている場合、次の制約事項が適用されます。

サポートされる BFD セッションの最大数は 50 です。

倍率 3 以上の最小 hello 間隔は 500 ms です。

EIGRP がイネーブルの場合、サポートされる BFD セッションの最大数は 30 に減少します。

エコー モードは Distributed Forwarding Card(DFC)だけでサポートされます。

BFD SSO は E シャーシおよび 67xx ラインカードを使用する Cisco Catalyst 6500 シリーズだけでサポートされます。Centralized Forwarding Card(CFC)インターフェイスはサポートされません。

エコー モードをイネーブルにするには、システムを no ip redirects コマンドで設定する必要があります。

In Service Software Upgrade(ISSU)サイクルでは、ラインカードがリセットされ、BFD セッションでルーティング フラップが発生します。


) プラットフォームとハードウェアの正確な制約事項については、お使いのソフトウェア バージョンの Cisco IOS ソフトウェアのリリース ノートを参照してください。


双方向フォワーディング検出について

「BFD の動作」

「障害検出に BFD を使用することの利点」

BFD の動作

BFD は、インターフェイス、データリンク、および転送プレーンを含めて、2 つの隣接ルータ間の転送パスで、オーバーヘッドの少ない短期間の障害検出方法を提供します。

BFD はインターフェイス レベルおよびルーティング プロトコル レベルでイネーブルにする検出プロトコルです。シスコでは BFD 非同期モードをサポートしています。これは、ルータ間の BFD ネイバー セッションをアクティブにして維持するための、2 台のシステム間の BFD 制御パケットの送信に依存します。したがって、BFD セッションを作成するには、両方のシステムで(または BFD ピアで)BFD を設定する必要があります。適切なルーティング プロトコルに対して、インターフェイス レベルおよびルータ レベルで BFD がイネーブルになっている場合、BFD セッションが作成されて BFD タイマーがネゴシエートされ、ネゴシエートされた間隔で BFD ピアが互いに BFD 制御パケットの送信を開始します。

ここでは、次の内容について説明します。

「ネイバー関係」

「BFD の障害検出」

「BFD バージョンの相互運用性」

「Cisco 12000 ルータでの BFD サポート」

「BFD セッションの制限」

「非ブロードキャスト メディア インターフェイスに対する BFD サポート」

「VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インターフェイスのための BFD サポート」

「ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート」

「ステートフル スイッチオーバーのための BFD サポート」

「スタティック ルーティングのための BFD サポート」

「BFD Control Channel over VCCV:ATM 疑似配線のサポート」

ネイバー関係

BFD はあらゆるメディア タイプ、カプセル化、トポロジ、ルーティング プロトコル BGP、EIGRP、IS-IS、および OSPF の個別の高速 BFD ピア障害検出時間を提供します。ローカル ルータのルーティング プロトコルに高速障害検出通知を送信して、ルーティング テーブル再計算プロセスを開始すると、BFD はネットワーク コンバージェンス時間全体を大幅に短縮できます。図 1 に、OSPF と BFD を実行する 2 台のルータがある単純なネットワークを示します。OSPF がネイバー(1)を検出すると、OSPF ネイバー ルータ(2)で BFD ネイバー セッションを開始する要求が、ローカル BFD プロセスに送信されます。OSPF ネイバー ルータでの BFD ネイバー セッションが確立されます(3)。

図 1 BFD ネイバー関係の確立

図 2 に、ネットワーク(1)で障害が発生した場合を示します。OSPF ネイバー ルータでの BFD ネイバー セッションが停止されます(2)。BFD はローカル OSPF プロセスに BFD ネイバーに接続できなくなったことを通知します(3)。ローカル OSPF プロセスは OSPF ネイバー関係を解除します(4)。代替パスを使用できる場合、ルータはただちにコンバージェンスを開始します。

図 2 OSPF ネイバー関係の解除

 

ルーティング プロトコルでは、取得したネイバーそれぞれについて、BFD で登録する必要があります。ネイバーが登録されると、セッションがまだ存在していない場合、BFD によって、ネイバーとのセッションが開始されます。

次のとき、OSPF では、BFD を使用して登録が行われます。

ネイバーの Finite State Machine(FSM; 有限状態マシン)は、Full ステートに移行します。

OSPF BFD と BFD の両方がイネーブルにされます。

ブロードキャスト インターフェイスでは、OSPF によって、Designated Router(DR; 指定ルータ)と Backup Designated Router(BDR; バックアップ指定ルータ)とともにのみ、BFD セッションが確立されますが、DROTHER ステートのすべての 2 台のルータ間では確立されません。

BFD の障害検出

BFD セッションが確立され、タイマーの取り消しが完了すると、BFD ピアは IGP hello プロトコルと同様に動作する(ただし、より高速な)、BFD 制御パケットを送信して状態を検出します。次の点に注意する必要があります。

BFD はフォワーディング パスの障害検出プロトコルです。BFD は障害を検出しますが、障害が発生したピアをバイパスするには、ルーティング プロトコルがアクションを実行する必要があります。

通常、BFD はどのプロトコル レイヤでも使用できます。ただし、Cisco IOS Release 12.0(31)S および 12.4(4)T 用のシスコの BFD 実装では、特に BGP、EIGRP、IS-IS、および OSPF ルーティング プロトコルのレイヤ 3 クライアントだけがサポートされます。Cisco IOS Release 12.2(33)SRC の場合、スタティック ルーティングに BFD がサポートされます。

Cisco IOS Release 12.2(18)SXE 用のシスコの BFD 実装では、レイヤ 3 クライアントおよび EIGRP、IS-IS、および OSPF ルーティング プロトコルだけがサポートされます。BGP ルーティング プロトコルはサポートされません。

Cisco IOS Release 12.2(18)SXE、12.0(31)S、および 12.4(4)T のシスコの BFD 実装では、シスコ デバイスが複数のクライアント プロトコルに 1 つの BFD セッションを使用します。たとえば、同じピアへの同じリンクを介してネットワークで OSPF および EIGRP を実行している場合、1 つの BFD セッションだけが確立され、BFD で両方のルーティング プロトコルとセッション情報を共有します。

BFD バージョンの相互運用性

Cisco IOS Release 12.4(9)T では BFD バージョン 1 および BFD バージョン 0 がサポートされます。デフォルトでは、すべての BFD セッションがバージョン 1 で実行され、バージョン 0 と相互運用可能です。システムで自動的に FD バージョン検出が実行される場合、ネイバー間の BFD セッションがネイバー間の最も一般的な BFD バージョンで実行されます。たとえば、BFD ネイバーが BFD バージョン 0 を実行し、他の BFD ネイバーがバージョン 1 を実行している場合、セッションで BFD バージョン 0 が実行されます。 show bfd neighbors [ details ] コマンドの出力で、BFD ネイバーが実行している BFD バージョンを確認できます。

BFD バージョン検出の例については、「例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定」を参照してください。

Cisco 12000 ルータでの BFD サポート

Cisco 12000 シリーズのルータでは、Distributed Route Processor(RP; ルート プロセッサ)とラインカード(LC)アーキテクチャを利用する分散 BFD がサポートされます。次の項で説明するように、BFD タスクは分割され、RP および LC で BFD プロセスに割り当てられます。

「RP の BFD プロセス」

「LC の BFD プロセス」

RP の BFD プロセス

クライアントとの対話

RP の BFD プロセスでは、クライアントとの対話を処理します。これによって、BFD セッションが作成および削除されます。

RP の BFD プロセスのためのセッション管理

主に BFD RP プロセスが、ルータのすべての BFD セッションを所有します。その後、セッションの作成および削除の要求をすべての LC の BFD プロセスに渡します。BFD LC セッションには、クライアントによって追加または削除されるセッションの情報がありません。BFD RP プロセスだけがセッションの追加および削除のコマンドを BFD LC プロセスに送信します。

セッション データベースの管理

BFD RP プロセスは、ルータのすべての BFD セッションのデータベースを維持します。このデータベースには、必要最小限の情報だけが保存されます。

プロセスの EXEC コマンド

BFD RP プロセスは BFD の show コマンドを処理します。

LC の BFD プロセス

LC の BFD プロセスのためのセッション管理

BFD LC プロセスではセッションを管理し、BFD RP プロセスからのコマンドを追加および削除し、コマンドに基づいて新しいセッションを作成および削除します。送信の失敗、受信の失敗、またはセッション ダウンの検出が発生した場合、LC BFD インスタンスでただちに BFD RP プロセスが通知されます。また、送信および受信のカウンタが更新されます。BFD セッションは LC で完全に管理されます。BFD 制御パケットが、LC 自体から送信された場合と同様に受信され、処理されます。

セッション データベースの管理

BFD LC プロセスで、LC でホストされるすべての BFD セッションのデータベースを維持します。

受信と送信

BFD LC プロセスでは、LC のセッションに対する BFD の送受信を行います。

BFD セッションの制限

Cisco IOS Release 12.2(33)SRC では、作成できる BFD セッションの数が 128 に増えました。

非ブロードキャスト メディア インターフェイスに対する BFD サポート

Cisco IOS Release 12.2(33)SRC では、BFD 機能が非ブロードキャスト メディア インターフェイス(ATM、POS、シリアル、および VLAN インターフェイスなど)でサポートされます。BFD のサポートは ATM、Frame Relay(FR; フレーム リレー)、POS、およびシリアル サブインターフェイスに拡張されます。

bfd interval コマンドは、BFD モニタリングを開始するインターフェイスで設定する必要があります。

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インターフェイスのための BFD サポート

Cisco IOS Release 12.2(33)SRC では BFD 機能が、プロバイダー エッジ(PE)ルータとカスタマー エッジ(CE)ルータの間のルーティング プロトコル障害の高速検出を提供するように、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)対応に拡張されています。

ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート

通常、ネットワーキング デバイスを再起動すると、そのデバイスのすべてのルーティング ピアがデバイスの終了および再起動を検出します。この遷移によってルーティング フラップが発生し、そのために複数のルーティング ドメインに分散される可能性があります。ルーティングの再起動によって発生したルーティング フラップによって、ルーティングが不安定になります。これはネットワーク全体のパフォーマンスに悪影響を及ぼします。ノンストップ フォワーディング(NSF)は、ステートフル スイッチオーバー(SSO)がイネーブルになっているデバイスのルーティング フラップを抑制するのに役立ち、それによってネットワークの不安定さが減少します。

NSF では、ルーティング プロトコル情報がスイッチオーバー後に保存されるとき、既知のルータでデータ パケットのフォワーディングを継続できます。NSF を使用すると、ピア ネットワーキング デバイスでルーティング フラップが発生しません。データ トラフィックはインテリジェント ラインカードまたはデュアル フォワーディング プロセッサを介して転送されますが、スタンバイ RP では、スイッチオーバー中に障害が発生したアクティブな RP からの制御と見なされます。ラインカードおよびフォワーディング プロセッサの機能はスイッチオーバーによって維持され、アクティブな RP の Forwarding Information Base(FIB; 転送情報ベース)が NSF 動作で最新状態が維持されます。

デュアル RP をサポートするデバイスでは、SSO が RP の 1 つをアクティブなプロセッサとして確立し、他の RP はスタンバイ プロセッサに割り当てられ、それらの間で情報が同期されます。アクティブな RP に障害が発生したとき、ネットワーク デバイスから削除されたとき、または手動でメンテナンスから排除されたときに、アクティブなプロセッサとスタンバイ プロセッサからのスイッチオーバーが発生します。

Cisco IOS Release 12.2(33)SRC では、計画的スイッチオーバー時に BFD セッションが「Admin Down」状態になります。BFD 設定はアクティブなプロセッサからスタンバイ プロセッサに同期化され、すべての BFD クライアントがスタンバイ プロセッサでの BFD プロセスで再登録されます。

Cisco IOS Release 12.2(33)SB では、BFD が SSO に対応しておらず、NSF/SSO でサポートされません。これらの機能は一緒に使用しないでください。NSF/SSO と BFD を同時にイネーブルにすると、BFD の隣接関係が維持されず、ルーティング クライアントには隣接関係停止と再コンバージェンスのマークが強制的に付けられるため、フェールオーバー中にノンストップ フォワーディング機能が動作しません。

ステートフル スイッチオーバーのための BFD サポート

BFD プロトコルでは、隣接するフォワーディング エンジン間でパスに短期間の障害検出が行われます。デュアル RP ルータまたはスイッチ(冗長性のため)を使用するネットワーク導入では、ルータにグレースフル リスタート メカニズムがあり、アクティブな RP とスタンバイ RP の間のスイッチオーバー時にフォワーディング状態が保護されます。

ハードウェアの通信障害を検出する機能に応じて、デュアル RP のスイッチオーバー回数が異なります。BFD が RP で稼動している場合、一部のプラットフォームでは BFD プロトコルがタイム アウトになる前にスイッチオーバーを検出することはできません。このようなプラットフォームは低速スイッチオーバー プラットフォームと呼ばれます。

スタンバイ RP のステートフル BFD

スタンバイ RP へのスイッチオーバーを成功させるために、BFD プロトコルでチェックポイント メッセージを使用して、アクティブな RP Cisco IOS インスタンスからセッション情報をスタンバイ RP Cisco IOS インスタンスに送信します。セッション情報には、ローカル識別子およびリモート識別子、隣接ルータのタイマー情報、BFD セットアップ情報、およびセッション固有の情報(セッションのタイプやセッションのバージョンなど)が含まれます。さらに、BFD プロトコルはセッションの作成および削除のチェックポイント メッセージを送信して、スタンバイ RP でセッションを作成または削除します。

スタンバイ RP の BFD セッションはパケットの送受信を行わず、期限切れになったタイマーを処理しません。このようなセッションは、スイッチオーバーの発生を待ってからアクティブ セッションのパケットを送信し、セッションが隣接ルータでタイム アウトにならないようにします。

スタンバイ RP の BFD プロトコルはスイッチオーバーの通知を受けると、状態をアクティブに変更し、自分自身をシスコ エクスプレス フォワーディングに登録することで、パケットを受信し、期限切れになったすべての要素にパケットを送信できるようにします。

また、BFD ではチェックポイント メッセージを使用して、アクティブな RP でクライアントによって作成されたセッションをスイッチオーバー時に維持します。スイッチオーバーが発生すると、BFD は SSO 再要求タイマーを起動します。クライアントは再要求タイマーによって指定された期間内のセッションを再要求する必要があります。そうしないと、セッションが削除されます。

タイマーの値は、BFD セッションの数およびプラットフォームによって異なります。

表 1 に、Cisco 7600 シリーズ ルータのタイマー値について説明します。

表 1 Cisco 7600 シリーズ ルータの BFD タイマー値

BFD セッションの最大数
シャーシ タイプ
BFD セッション タイプ
最小タイマー値(ms)
クライアント
コメント

128

S シャーシ

非同期/エコー

500
倍率 3

すべて

--

512

S シャーシ

非同期/エコー

999
倍率 3

すべて

--

128

非 S シャーシ

非同期

999
倍率 5

すべて

--

128

非 S シャーシ

DFC ライン カード

エコー

999
倍率 3

すべて

5000 にされている BFD 低速タイマー

512

非 S シャーシ

非同期/エコー

999
倍率 5

すべて

--


) BFD SSO 機能は、Cisco IOS Release 12.2(33)SRE 以降のリリースの Cisco 7600 シリーズ ルータでサポートされます。


表 2 に、Cisco ASR 1000 シリーズの集約サービス ルータのタイマー値について説明します。

表 2 Cisco ASR 1000 シリーズの集約サービス ルータの BFD タイマー値

BFD セッションの最大数
シャーシ タイプ
BFD セッション タイプ
最小タイマー値(ms)
クライアント
コメント

128

すべて

非同期/エコー

50
倍率 3

すべて

--

512

すべて

非同期/エコー

999
倍率 3

すべて

--


) BFD SSO 機能は、Cisco IOS Release 12.2(33)XNA 以降のリリースの Cisco ASR 1000 シリーズ集約サービス ルータでサポートされます。


表 3 に、Cisco 6500 シリーズ ルータのタイマー値について説明します。

表 3 Cisco 6500 シリーズ ルータの BFD タイマー値

BFD セッションの最大数
シャーシ タイプ
BFD セッション タイプ
最小タイマー値(ms)
クライアント
コメント

50

E シャーシ/67XX ライン カード

非同期/エコー

500
倍率 3

すべて(EIGRP を除く)

CFC ライン カードはサポートされない

30

E シャーシ/67XX ライン カード

非同期/エコー

500
倍率 3

EIGRP

CFC ライン カードはサポートされない


) BFD SSO 機能は、Cisco IOS Release 12.2(33)SXI 2 以降のリリースの Cisco 6500 シリーズ ルータでサポートされます。


表 4 に、Cisco 10000 シリーズ ルータのタイマー値について説明します。

表 4 Cisco 10000 シリーズ ルータの BFD タイマー値

BFD セッションの最大数
シャーシ タイプ
BFD セッション タイプ
最小タイマー値(ms)
クライアント
コメント

1100

PRE3/PRE4

非同期/エコー

999
倍率 5

すべて

--


) BFD SSO 機能は、Cisco IOS Release 12.2(33)XNE 以降のリリースの Cisco 10000 シリーズ ルータでサポートされます。


スタティック ルーティングのための BFD サポート

OSPF や BGP などの動的なルーティング プロトコルとは異なり、スタティック ルーティングにはピア検出の方法がありません。したがって、BFD が設定されると、ゲートウェイの到達可能性は完全に指定されたネイバーへの BFD セッションの状態に依存します。BFD セッションが開始されない限り、スタティック ルートのゲートウェイは到達不能と見なされ、したがって、影響を受けるルートが適切な RIB にインストールされません。

BFD セッションが正常に確立されるように、ピア上のインターフェイスで BFD を設定し、ピア上の BFD クライアントに BFD ネイバーのアドレスを登録する必要があります。インターフェイスがダイナミック ルーティング プロトコルで使用される場合、後者の要件は通常、BFD の各ネイバーでルーティング プロトコル インスタンスを設定することによって満たされます。インターフェイスがスタティック ルーティングに排他的に使用される場合、この要件はピア上でスタティック ルートを設定することによって満たす必要があります。

BFD セッションが起動状態のときに BFD 設定がリモート ピアから削除された場合、BFD セッションの最新状態が IPv4 スタティックに送信されません。その結果、スタティック ルートが RIB に残ります。唯一の回避策は、IPv4 スタティック BFD ネイバー設定を削除して、スタティック ルートが BFD セッション状態を追跡しないようにすることです。また、シリアル インターフェイスのカプセル化のタイプを BFD でサポートされていないタイプに変更する場合、このインターフェイスで BFD がダウン状態になります。回避策はインターフェイスをシャットダウンし、サポートされているカプセル化のタイプに変更してから、BFD を再設定することです。

BFD Control Channel over VCCV:ATM 疑似配線のサポート

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)の疑似配線では、IP/MPLS コア ネットワークを介して送信するため、L2 トラフィックがイネーブルにされます。BFD Control Channel over VCCV:ATM 疑似配線のサポート機能では、MPLS 疑似配線の Operations And Management(OAM)機能が提供されます。


) この機能により、VCCV タイプ 1 のみがサポートされます。VCCV タイプ 1 は、インバンド VCCV で、コントロール ワードが使用されている MPLS 疑似配線のみで使用できます。


BFD 検出プロトコルを使用すると、MPLS プロトコルに OAM 機能を提供できます。VCCV では、疑似配線に関連付けられている制御チャネルが提供され、疑似配線を介して OAM 機能が提供されます。BFD では、VCCV 制御チャネルを疑似配線障害メカニズムとして使用され、データプレーンの障害が検出されます。BFD では、VCCV 制御チャネルを使用して、Attachment Circuit(接続回線; AC)の障害ステータスを示すことができます。

MPLS の疑似配線では、動的に信号を送信するか、静的に Virtual Circuit(VC; 仮想回線)ラベルを設定することができます。動的に信号が送信される疑似配線では、Control Channel(CC)タイプおよび Connection Verification(CV)タイプにも、信号が送信されます。静的に設定される疑似配線では、CC タイプと CV タイプは両方とも、疑似配線の両側に設定されます。

CC タイプでは、疑似配線に対して VCCV パケットはインバンドまたはアウトオブバウンドです。CV タイプでは、疑似配線に対して BFD のモニタリングが必要かどうかが定義されます。疑似配線に対して BFD のモニタリングが必要な場合、CV タイプでは、BFD パケットのカプセル化の方法、および、BFD によって、ステータスのシグナリング機能が提供されるかどうかが、定義されます。

BFD のモニタリングが必要なすべてのプロトコルでは、BFD を使用してクライアントとして登録される必要があります。たとえば、Xconnect プロトコルでは BFD クライアントとして定義され、BFD によって、Xconnect に対するクライアント ID が割り当てられます。Xconnect では、このクライアント ID が使用されて、疑似配線をモニタする BFD セッションが作成されます。

BFD では、疑似配線パスで、転送障害(エンドツーエンド)を検出できます。BFD で疑似配線の転送パスに障害が検出されると、セッションを作成した Xconnect クライアントに通知されます。さらに、BFD では、BFD セッションが中断されたリモート デバイスに、すべての連結パスまたは AC でのステータスの信号が送信されます。

図 3 に、ATM ペイロードが含まれる、動的に信号が送信される MPLS 疑似配線を示します。この例では、疑似配線の BFD のモニタリングは、ノード B デバイスから PE デバイスに対して発生します。BFD では、PE デバイスと CE2 デバイス、ノード B と CE1 デバイスとの間の、AC の信号ステータスがモニタされます。

図 3 MPLS ATM 疑似配線

 

障害検出に BFD を使用することの利点

機能を導入するときは、あらゆる代替策を検討し、トレードオフに注意することが重要です。

EIGRP、IS-IS、および OSPF の通常の導入で BFD に最も近い代替策は、EIGRP、IS-IS、および OSPF ルーティング プロトコルの変更された障害検出メカニズムを使用することです。

EIGRP の hello およびホールド タイマーを絶対最小値に設定する場合、EIGRP の障害検出速度が 1~2 秒程度に下がります。

IS-IS または OSPF に fast hello を使用する場合、これらの Interior Gateway Protocol(IGP)プロトコルによって障害検出メカニズムが最小 1 秒に減少します。

ルーティング プロトコルの減少したタイマー メカニズムで BFD を実装すると、いくつかの利点があります。

EIGRP、IS-IS、および OSPF タイマーによって 1 秒または 2 秒の最小検出タイマーを実現できますが、障害検出が 1 秒未満になる場合もあります。

BFD は特定のルーティング プロトコルに関連付けられていないため、EIGRP、IS-IS、および OSPF の汎用の整合性のある障害検出メカニズムとして使用できます。

BFD の一部をデータ プレーンに分散できるため、コントロール プレーンに全体が存在する分散 EIGRP、IS-IS、および OSPF タイマーよりも CPU の負荷を軽くすることができます。

双方向フォワーディング検出の設定方法

インターフェイスで BFD を設定して、BFD プロセスを開始します。BFD プロセスが開始されると、隣接するデータベースにエントリが作成されません。つまり、BFD 制御パケットが送受信されません。Cisco IOS Release 12.4(9)T の BFD バージョン 1 でサポートされない BFD エコー モードは、デフォルトではイネーブルです。BFD 制御パケットに加えて、BFD エコー パケットが送受信されます。適用可能なルーティング プロトコルの BFD サポートを設定すると、隣接作成が実行されます。ここでは、次の手順について説明します。

「インターフェイスでの BFD セッション パラメータの作成」(必須)

「ダイナミック ルーティング プロトコルに対する BFD サポートの設定」(必須)

「スタティック ルーティングのための BFD サポートの設定」(任意)

「BFD エコー モードの設定」(任意)

「BFD テンプレートの作成と設定」(任意)

「BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定」(任意)

「BFD のモニタリングとトラブルシューティング」(任意)

インターフェイスでの BFD セッション パラメータの作成

この手順では、インターフェイスで基本 BFD セッション パラメータを設定することによって、インターフェイスで BFD を設定する方法を示します。BFD ネイバーに対して BFD セッションを実行するインターフェイスごとに、この手順を繰り返します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet 6/0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

 

Router(config-if)# bfd interval 50 min_rx 50 multiplier 5

インターフェイスで BFD をイネーブルにします。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ダイナミック ルーティング プロトコルに対する BFD サポートの設定

ルータ レベルでダイナミック ルーティング プロトコルの BFD サポートをイネーブルにして、すべてのインターフェイスに対してグローバルに BFD サポートをイネーブルにするか、またはインターフェイス レベルでインターフェイスごとに BFD を設定することができます。

Cisco IOS Release 12.2(18)SXE では、ルーティング プロトコル EIGRP、IS-IS、および OSPF の 1 つ以上に対して BFD サポートを設定できます。

Cisco IOS Release 12.2(33)SRA では、ルーティング プロトコル EIGRP、IS-IS、および OSPF の 1 つ以上に対して BFD サポートを設定できます。

Cisco IOS Release 12.2(33)SRB では、ルーティング プロトコル BGP、EIGRP、IS-IS、および OSPF の 1 つ以上に対して BFD サポートを設定できます。

Cisco IOS Release 12.2(33)SRC では、スタティック ルーティングに対して BFD サポートを設定できます。

Cisco IOS Release 12.0(31)S および 12.4(4)T では、ルーティング プロトコル BGP、IS-IS、および OSPF の 1 つ以上に対して BFD サポートを設定できます。

Cisco IOS Release 12.0(32)S では、Cisco 10720 プラットフォームで、ルーティング プロトコル BGP、IS-IS、および OSPF の 1 つ以上に対して BFD を設定できます。

Cisco IOS Release 12.4(11)T では、HSRP に対する BFD サポートが導入されました。

ここでは、次の手順について説明します。

「BGP に対する BFD サポートの設定」(任意)

「EIGRP に対する BFD サポートの設定」(任意)

「IS-IS に対する BFD サポートの設定」(任意)

「OSPF に対する BFD サポートの設定」(任意)

「HSRP に対する BFD サポートの設定」(任意)

BGP に対する BFD サポートの設定

ここでは、BGP が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、BGP に対する BFD サポートを設定する手順について説明します。

前提条件

BGP は、関連するすべてのルータで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

手順の概要

1. enable

2. configure terminal

3. router bgp as-tag

4. neighbor ip-address fall-over bfd

5. end

6. show bfd neighbors [ details ]

7. show ip bgp neighbor

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-tag
 

Router(config)# router bgp tag1

BGP プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor ip-address fall-over bfd

 

Router(config-router)# neighbor 172.16.10.2 fall-over bfd

フェールオーバーに対する BFD サポートをイネーブルにします。

ステップ 5

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]

 

Router# show bfd neighbors detail

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されることを確認します。

の出力に表示されません。

ステップ 7

show ip bgp neighbor

 

Router# show ip bgp neighbor

(任意)ネイバーへの BGP および TCP 接続についての情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「EIGRP に対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

「HSRP に対する BFD サポートの設定」

EIGRP に対する BFD サポートの設定

ここでは、EIGRP が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、EIGRP に対する BFD サポートを設定する手順について説明します。EIGRP に対する BFD サポートをイネーブルにするには、2 つの方法があります。

ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用して、EIGRP がルーティングしているすべてのインターフェイスに対して BFD をイネーブルにできます。

ルータ コンフィギュレーション モードで bfd interface type number コマンドを使用して、EIGRP がルーティングしているインターフェイスのサブセットに対して BFD をイネーブルにできます。

前提条件

EIGRP は、関連するすべてのルータで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

制約事項

EIGRP に対する BFD は、Cisco IOS Release 12.0(31)S、12.0(32)S、12.4(4)T、および 12.2(33)SRA の Cisco 12000 シリーズ ルータでサポートされません。

手順の概要

1. enable

2. configure terminal

3. router eigrp as-number

4. bfd all-interfaces
または
bfd interface type number

5. end

6. show bfd neighbors [ details ]

7. show ip eigrp interfaces [ type number ] [ as-number ] [ detail ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

Router(config)# router eigrp 123

EIGRP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bfd all-interfaces
or
bfd interface type number

 

Router(config-router)# bfd all-interfaces

または

 

Router(config-router)# bfd interface FastEthernet 6/0

EIGRP ルーティング プロセスに関連付けられたすべてのインターフェイスで、BFD をグローバルにイネーブルにします。

または

EIGRP ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルにします。

ステップ 5

end

 

Router(config-router) end

ルータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されることを確認します。

の出力に表示されません。

ステップ 7

show ip eigrp interfaces [ type number ] [ as-number ] [ detail ]

 

Router# show ip eigrp interfaces detail

(任意)EIGRP に対する BFD サポートがイネーブルになっているインターフェイスを表示します。

 

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

「HSRP に対する BFD サポートの設定」

IS-IS に対する BFD サポートの設定

ここでは、IS-IS が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、IS-IS に対する BFD サポートを設定する手順について説明します。IS-IS に対する BFD サポートをイネーブルにするには、2 つの方法があります。

ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用して、IS-IS が IPv4 ルーティングをサポートしているすべてのインターフェイスに対して BFD をイネーブルにできます。インターフェイス コンフィギュレーション モードで isis bfd disable コマンドを使用して、1 つ以上のインターフェイスをディセーブルにできます。

インターフェイス コンフィギュレーション モードで isis bfd コマンドを使用して、IS-IS がルーティングしているインターフェイスのサブセットに対して BFD をイネーブルにできます。

IS-IS に対する BFD サポートを設定するには、次のいずれかの手順に従います。

「すべてのインターフェイスの IS-IS に対する BFD サポートの設定」

「1 つ以上のインターフェイスの IS-IS に対する BFD サポートの設定」

前提条件

IS-IS は、関連するすべてのルータで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

すべてのインターフェイスの IS-IS に対する BFD サポートの設定

IPv4 ルーティングをサポートするすべての IS-IS インターフェイスで BFD を設定するには、この項の手順に従います。

手順の概要

1. enable

2. configure terminal

3. router isis [ area-tag]

4. bfd all-interfaces

5. exit

6. interface type number

7. ip router isis [ tag ]

8. isis bfd [ disable ]

9. end

10. show bfd neighbors [ details ]

11. show clns interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis area-tag
 

Router(config)# router isis tag1

IS-IS プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bfd all-interfaces

 

Router(config-router)# bfd all-interfaces

IS-IS ルーティング プロセスに関連付けられたすべてのインターフェイスで、BFD をグローバルにイネーブルにします。

ステップ 5

exit

 

Router(config-router)# exit

(任意)ルータでグローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface type number
 

Router(config)# interface fastethernet 6/0

(任意)インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

ip router isis [tag]
 

Router(config-if)# ip router isis tag1

(任意)インターフェイスで IPv4 ルーティングのサポートをイネーブルにします。

ステップ 8

isis bfd [ disable ]

 

Router(config-if)# isis bfd

(任意)IS-IS ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルまたはディセーブルにします。

キーワードを使用する必要があります。

ステップ 9

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 10

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

の出力に表示されません。

ステップ 11

show clns interface

 

Router# show clns interface

(任意)IS-IS に対する BFD が、関連付けられた特定の IS-IS インターフェイスに対してイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。インターフェイスの特定のサブセットに対してだけ設定する場合は、「1 つ以上のインターフェイスの IS-IS に対する BFD サポートの設定」のタスクを実行します。

1 つ以上のインターフェイスの IS-IS に対する BFD サポートの設定

1 つ以上の IS-IS インターフェイスだけに BFD を設定するには、この項の手順に従います。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip router isis [ tag ]

5. isis bfd [ disable ]

6. end

7. show bfd neighbors [ details ]

8. show clns interface

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 

Router(config)# interface fastethernet 6/0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip router isis [tag]
 

Router(config-if)# ip router isis tag1

インターフェイスで IPv4 ルーティングのサポートをイネーブルにします。

ステップ 5

isis bfd [disable]

 

Router(config-if)# isis bfd

IS-IS ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルまたはディセーブルにします。

キーワードを使用する必要があります。

ステップ 6

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 7

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

の出力に表示されません。

ステップ 8

show clns interface

 

Router# show clns interface

(任意)IS-IS に対する BFD が、関連付けられた特定の IS-IS インターフェイスに対してイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングと維持の詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次のいずれかの項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

「HSRP に対する BFD サポートの設定」

OSPF に対する BFD サポートの設定

ここでは、OSPF が BFD の登録プロトコルとなり、BFD から転送パスの検出障害メッセージを受信するように、OSPF に対する BFD サポートを設定する手順について説明します。すべてのインターフェイスでグローバルに OSPF に対する BFD を設定するか、または 1 つ以上のインターフェイスで選択的に設定することができます。

OSPF に対する BFD サポートをイネーブルにするには、2 つの方法があります。

ルータ コンフィギュレーション モードで bfd all-interfaces コマンドを使用して、OSPF がルーティングしているすべてのインターフェイスに対して BFD をイネーブルにできます。インターフェイス コンフィギュレーション モードで ip ospf bfd [ disable ] コマンドを使用して、個々のインターフェイスで BFD をディセーブルにできます。

インターフェイス コンフィギュレーション モードで ip ospf bfd コマンドを使用して、OSPF がルーティングしているインターフェイスのサブセットに対して BFD をイネーブルにできます。

OSPF に対する BFD サポートのタスクについては、次の項を参照してください。

「すべてのインターフェイスの OSPF に対する BFD サポートの設定」(任意)

「1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定」(任意)

すべてのインターフェイスの OSPF に対する BFD サポートの設定

すべての OSPF インターフェイスに BFD を設定するには、この項の手順に従います。

すべての OSPF インターフェイスに対して BFD を設定するのではなく、特定の 1 つ以上のインターフェイスに対して BFD サポートを設定する場合は、「1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定」を参照してください。

前提条件

OSPF は、関連するすべてのルータで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

手順の概要

1. enable

2. configure terminal

3. router ospf process-id

4. bfd all-interfaces

5. exit

6. interface type number

7. ip ospf bfd [ disable ]

8. end

9. show bfd neighbors [ details ]

10. show ip ospf

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id
 

Router(config)# router ospf 4

OSPF プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

bfd all-interfaces

 

Router(config-router)# bfd all-interfaces

OSPF ルーティング プロセスに関連付けられたすべてのインターフェイスで、BFD をグローバルにイネーブルにします。

ステップ 5

exit

 

Router(config-router)# exit

(任意)ルータでグローバル コンフィギュレーション モードに戻ります。手順 7 を実行して 1 つ以上のインターフェイスに対して BFD をディセーブルにする場合にだけ、このコマンドを入力します。

ステップ 6

interface type number

 

Router(config)# interface fastethernet 6/0

(任意)インターフェイス コンフィギュレーション モードを開始します。手順 7 を実行して 1 つ以上のインターフェイスに対して BFD をディセーブルにする場合にだけ、このコマンドを入力します。

ステップ 7

ip ospf bfd [ disable ]

 

Router(config-if)# ip ospf bfd disable

(任意)OSPF ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をディセーブルにします。

キーワードを使用する必要があります。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 9

show bfd neighbors [ details ]

 

Router# show bfd neighbors detail

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

の出力に表示されません。

ステップ 10

show ip ospf

 

Router# show ip ospf

(任意)OSPF に対して BFD がイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「HSRP に対する BFD サポートの設定」

1 つ以上のインターフェイスの OSPF に対する BFD サポートの設定

1 つ以上の OSPF インターフェイスで BFD を設定するには、この項の手順に従います。

前提条件

OSPF は、関連するすべてのルータで実行する必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip ospf bfd [ disable ]

5. end

6. show bfd neighbors [ details ]

7. show ip ospf

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 

Router(config)# interface fastethernet 6/0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip ospf bfd [ disable ]

 

Router(config-if)# ip ospf bfd

OSPF ルーティング プロセスに関連付けられた 1 つ以上のインターフェイスに対して、インターフェイスごとに BFD をイネーブルまたはディセーブルにします。

キーワードを使用する必要があります。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD ネイバーがアクティブで、BFD が登録したルーティング プロトコルが表示されるかどうかの検証に使用できる情報を表示します。

コマンドの出力に表示されません。

ステップ 7

show ip ospf

 

Router# show ip ospf

(任意)OSPF に対して BFD サポートがイネーブルになっているかどうかを検証するために使用できる情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「HSRP に対する BFD サポートの設定」

HSRP に対する BFD サポートの設定

Hot-Standby Routing Protocol(HSRP)に対して BFD サポートをイネーブルにするには、このタスクを実行します。HSRP ピアに対して BFD セッションを実行するインターフェイスごとに、この手順を繰り返します。

デフォルトでは、HSRP は BFD をサポートします。BFD に対する HSRP サポートが手動でディセーブルになっている場合、ルータ レベルで再びイネーブルにして、すべてのインターフェイスに対してグローバルに BFD サポートをイネーブルにするか、またはインターフェイス レベルでインターフェイスごとにイネーブルにすることができます。

前提条件

HSRP は、関連するすべてのルータで実行する必要があります。

シスコ エクスプレス フォワーディングをイネーブルにする必要があります。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. interface type number

5. ip address ip-address mask

6. standby [ group-number ] ip [ ip-address [ secondary ]]

7. standby bfd

8. exit

9. standby bfd all-interfaces

10. exit

11. show standby [ neighbors ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface FastEthernet 6/0

インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask

 

Router(config-if)# ip address 10.0.0.11 255.255.255.0

インターフェイスに IP アドレスを設定します。

ステップ 6

standby [ group-number ] ip [ ip-address [ secondary ]]

 

Router(config-if)# standby 1 ip 10.0.0.11

HSRP をアクティブにします。

ステップ 7

standby bfd

 

Router(config-if)# standby bfd

(任意)インターフェイスで BFD に対する HSRP をイネーブルにします。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 9

standby bfd all-interfaces
 

Router(config)# standby bfd all-interfaces

(任意)すべてのインターフェイスで BFD に対する HSRP をイネーブルにします。

ステップ 10

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 11

show standby neighbors

 

Router# show standby neighbors

(任意)BFD に対する HSRP サポートについての情報を表示します。

次の作業

BFD のモニタリングとトラブルシューティングの詳細については、「BFD のモニタリングとトラブルシューティング」を参照してください。別のルーティング プロトコルに対して BFD サポートを設定する場合は、次の項を参照してください。

「BGP に対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

スタティック ルーティングのための BFD サポートの設定

スタティック ルーティングのための BFD サポートを設定するには、このタスクを実行します。

各 BFD ネイバーに対してこの手順を繰り返します。詳細については、「例:スタティック ルーティングのための BFD サポートの設定」を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

6. ip route static bfd interface-type interface-number gateway

7. ip route [vrf vrf-name ] prefix mask { ip-address | interface-type interface-number [ ip-address ]} [ dhcp ] [ distance ] [ name next-hop-name ] [ permanent | track number ] [ tag tag ]

8. end

9. show ip static route

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface serial 2/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 10.201.201.1 255.255.255.0

インターフェイスに IP アドレスを設定します。

ステップ 5

bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

 

Router(config-if)# bfd interval 500 min_rx 500 multiplier 5

インターフェイスで BFD をイネーブルにします。

ステップ 6

ip route static bfd interface-type interface-number gateway

 

Router(config-if)# ip route static bfd
Serial 2/0 10.201.201.2

スタティック ルートの BFD ネイバーを指定します。

BFD サポートは直接接続されたネイバーだけに存在するため、 interface-type interface-number および gateway 引数は必須です。

ステップ 7

ip route [ vrf vrf-name ] prefix mask { ip- address | interface-type interface-number [ ip-address ]} [ dhcp ] [ distance ] [ name next-hop-name ] [ permanent | track number ] [ tag tag ]

 

Router(config-if)# ip route 10.0.0.0 255.0.0.0

Serial 2/0 10.201.201.2

スタティック ルートの BFD ネイバーを指定します。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 9

show ip static route

 

Router# show ip static route

(任意)スタティック プロセスのローカル Routing Information Base(RIB)情報を表示します。

BFD エコー モードの設定

デフォルトでは BFD エコー モードがイネーブルになっていますが、方向ごとに個別に実行できるように、ディセーブルにすることもできます。エコー モードを設定するには、その前に次の概念を理解しておく必要があります。

「BFD エコー モード」

「前提条件」

「制約事項」

BFD エコー モード

BFD エコー モードを実行する利点

BFD エコー モードは非同期 BFD で動作します。エコー パケットはフォワーディング エンジンによって送信され、検出を実行するために、同じパスで転送されます。反対側の BFD セッションはエコー パケットの実際のフォワーディングに関与しません。エコー機能およびフォワーディング エンジンが検出プロセスを処理するため、2 つの BFD ネイバー間で送信される BFD 制御パケットの数が減少します。また、フォワーディング エンジンが、リモート システムを介さずにリモート(ネイバー)システムの転送パスをテストするため、パケット内遅延が向上する可能性があり、それによって BFD バージョン 0 を BFD セッションの BFD 制御パケットを使用する場合に、障害検出時間を短縮できます。

非対称性のないエコー モード

エコー モードを両端で実行している(両方の BFD ネイバーがエコー モードを実行している)場合は、非対称性がないと表現されます。

前提条件

BFD は、関連するすべてのルータで実行する必要があります。

CPU 使用率の上昇を避けるために、BFD エコー モードを使用する前に、 no ip redirects コマンドを入力して、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)リダイレクト メッセージの送信をディセーブルにする必要があります。

BFD セッションを BFD ネイバーに対して実行するインターフェイスで、BFD セッションの基本パラメータを設定する必要があります。詳細については、「インターフェイスでの BFD セッション パラメータの作成」を参照してください。

制約事項

BFD バージョン 1 でサポートされる BFD エコー モードは、Cisco IOS Release 12.4(9)T および 12.2(33)SRA だけで使用できます。

ここでは、BFD エコー モードの次の設定タスクについて説明します。

「BFD 低速タイマーの設定」

「非対称性のない BFD エコー モードのディセーブル化」


) BFD エコー モードは、Unicast Reverse Path Forwarding(uRPF; ユニキャスト リバース パス転送)の設定との組み合わせでは動作しません。BFD エコー モードと uRPF の設定がイネーブルの場合、セッションはフラップします。


BFD 低速タイマーの設定

この手順では、BFD の slow timer 値を変更する方法を示します。各 BFD ルータに対してこの手順を繰り返します。

手順の概要

1. enable

2. configure terminal

3. bfd slow-timer milliseconds

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bfd slow-timer milliseconds

 

Router(config)# bfd slow-timer 12000

BFD の slow timer を設定します。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

非対称性のない BFD エコー モードのディセーブル化

この手順では、非対称性のない BFD エコー モードをディセーブルにする方法を示します。ルータからエコー パケットが送信されず、ルータはネイバー ルータが受信した BFD エコー パケットを転送しません。

各 BFD ルータに対してこの手順を繰り返します。

手順の概要

1. enable

2. configure terminal

3. bfd echo

4. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bfd echo

 

Router(config)# no bfd echo

BFD エコー モードをイネーブルにします。

no 形式を使用すると、BFD エコー モードをディセーブルにできます。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BFD テンプレートの作成と設定

BFD テンプレートを作成し、BFD コンフィギュレーション モードを開始し、BFD インターバル タイマーを設定するには、次の手順を実行します。


) Cisco IOS Release 15.0(1)S では、インターフェイスから独立して BFD インターバル タイマーを設定できる BFD テンプレートの概念が導入されています。ATM 疑似配線に対する BFD Control Channel over VCCV:サポート機能に対するサポートの提供には、BFD テンプレートが必要です。


手順の概要

1. enable

2. configure terminal

3. bfd-template single-hop template-name

4. interval min-tx milliseconds min-rx milliseconds multiplier multiplier-value

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bfd-template single-hop template-name

 

Router(config)# bfd-template single-hop bfdtemplate1

BFD テンプレートを作成し、BFD コンフィギュレーション モードを開始します。

ステップ 4

interval min-tx milliseconds min-rx milliseconds multiplier multiplier-value

 

Router(bfd-config)# interval min-tx 120 min-rx 100 multiplier 3

BFD パケット間での送受信間隔を設定し、ピアが使用不能であると BFD が宣言する前に損失される連続的な BFD 制御パケット数を指定します。

ステップ 5

end

 

Router(bfd-config)# end

BFD コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

次の作業

作成した BFD テンプレートは、疑似配線に適用し、ATM 疑似配線ネットワークで BFD Control Channel over VCCV をイネーブルにできます。詳細については、「BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定」を参照してください。

BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定

BFD Control Channel over VCCV:ATM 疑似配線のサポート ネットワークを設定するには、次の手順を実行します。

前提条件

BFD テンプレートは、疑似配線クラスに割り当てる前に、作成し、設定する必要があります。詳細については、「BFD テンプレートの作成と設定」を参照してください。

疑似配線で VCCV BFD を実行できるようにするには、疑似配線がネットワーク上に設定されている必要があります。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class name

4. encapsulation type

5. protocol { ldp | none }

6. vccv { control-word | router-alert | ttl }

7. vccv bfd template name { udp | raw-bfd }

8. vccv bfd status signaling

9. exit

10. interface atm interface-number

11. atm asynchronous

12. pvc vpi / vci l2transport

13. xconnect peer-ip-address vc-id { encapsulation mpls [ manual ] | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class name

 

Router(config)# pseudowire-class vccv-bfd1

疑似配線クラスの名前を指定し、疑似配線クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation type

 

Router(config-pw-class)# encapsulation mpls

疑似配線を介したレイヤ 2 トラフィックをトンネリングするために、MPLS をデータ カプセル化方式として使用するよう、指定します。

適切に動作させるには、 xconnect コマンドの一部、または、AToM 仮想回線の疑似配線クラスの一部として、mpls encapsulation を指定する必要があります。

ステップ 5

protoco l { ldp | none }

 

Router(config-pw-class)# protocol none

シグナリングは設定されず、手動で設定されたセッションが使用されるように、指定します。

スタティック疑似配線を設定するには、 none キーワードを指定します。

ステップ 6

vccv { control-word | router-alert | ttl }

 

Router(config-pw-class)# vccv control-word

MPLS 疑似配線 CC タイプを設定します。

IP/UDP ヘッダーが含まれない CV タイプが使用される MPLS 疑似配線では、CC タイプを CC タイプ 1 疑似配線コントロール ワードに設定する必要があります。

ステップ 7

vccv bfd template name { udp | raw-bfd }

 

Router(config-pw-class)# vccv bfd template bfdtemplate1 raw-bfd

疑似配線クラスの VCCV BFD をイネーブルにします。

ステップ 8

vccv bfd status signaling

 

Router(config-pw-class)# vccv bfd status signaling

BFD VCCV のステータス シグナリングをイネーブルにします。

ステップ 9

exit

 

Router(config-pw-class)# exit

疑似配線クラス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

interface ATM interface-number

 

Router(config)# interface ATM 9/0/0

ATM インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

atm asynchronous

 

Router(config-if)# atm asynchronous

ATM インターフェイスで非同期モードをイネーブルにします。

ステップ 12

pvc vpi/ vci l2transport
 

Router(config-if)# pvc 0/100 l2transport

ATM Permanent Virtual Circuit(PVC; 相手先固定接続)を作成し、ATM PVC にカプセル化タイプを指定し、ATM 仮想回線コンフィギュレーション モードを開始します。

ステップ 13

xconnect peer-ip-address vc-id { encapsulation mpls [ manual ] | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

 

Router(cfg-if-atm-l2trans-pvc)# xconnect 10.0.0.7 100 pw-class vccv-bfd1

接続回線を疑似配線にバインドし、AToM スタティック疑似配線を設定し、疑似配線クラスを指定します。

ステップ 14

end

 

Router(cfg-if-atm-l2trans-pvc)# end

ATM 仮想回線コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

BFD のモニタリングとトラブルシューティング

ここでは、維持とトラブルシューティングのために BFD 情報を取得する方法について説明します。必要に応じてこれらのタスクのコマンドを、正しい順序で入力します。

BFD セッションの開始と障害の詳細については、「BFD の動作」を参照してください。

ここでは、次の Cisco プラットフォームに対する BFD のモニタリングとトラブルシューティングについて説明します。

「Catalyst 7600 シリーズ ルータのモニタリングとトラブルシューティング」

「Catalyst 12000 シリーズ ルータのモニタリングとトラブルシューティング」

「Cisco 10720 インターネット ルータに対する BFD のモニタリングとトラブルシューティング」

Catalyst 7600 シリーズ ルータのモニタリングとトラブルシューティング

Catalyst 7600 シリーズ ルータのモニタリングとトラブルシューティングを実行するには、この項の 1 つ以上の手順に従います。

手順の概要

1. enable

2. show bfd neighbors [ details ]

3. debug bfd [ packet | event ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD 隣接関係データベースを表示します。

details キーワードを指定すると、すべての BFD プロトコル パラメータとネイバーごとにタイマーが表示されます。

の出力に表示されません。

ステップ 3

debug bfd [ packet | event ]

 

Router# debug bfd packet

(任意)BFD パケットのデバッグ情報を表示します。

Catalyst 12000 シリーズ ルータのモニタリングとトラブルシューティング

Catalyst 12000 シリーズ ルータのモニタリングとトラブルシューティングを実行するには、この項の 1 つ以上の手順に従います。

手順の概要

1. enable

2. attach slot-number

3. show bfd neighbors [ details ]

4. show monitor event-trace bfd [ all ]

5. debug bfd event

6. debug bfd packet

7. debug bfd ipc-error

8. debug bfd ipc-event

9. debug bfd oir-error

10. debug bfd oir-event

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

attach slot-number

 

Router# attach 6

特定のラインカードでモニタリングとトラブルシューティングのコマンドを実行するため、そのラインカードに接続します。Cisco 12012 のスロット番号の範囲は 0~11 で、Cisco 12008 のスロット番号の範囲は 0~7 です。

スロット番号を省略した場合は、スロット番号の入力を求めるプロンプトが表示されます。

コマンドを実行して、ラインカードとの CLI セッションを確立します。

ステップ 3

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

BFD 隣接関係データベースを表示します。

details キーワードを指定すると、すべての BFD プロトコル パラメータとネイバーごとにタイマーが表示されます。

コマンドの出力に表示されません。

ステップ 4

show monitor event-trace bfd [ all ]

 

Router# show monitor event-trace bfd all

ラインカードで発生した「直前の」BFD アクティビティの重要なイベントに関して、記録されたメッセージを表示します。これはローリング バッファ ベースのログで、「最古の」イベントが失われます。トラフィックおよびイベントの頻度によっては、これらのイベントを可変時間ウィンドウに表示できないことがあります。

ステップ 5

debug bfd event

 

Router# debug bfd event

BFD 状態遷移のデバッグ情報を表示します。

ステップ 6

debug bfd packet

 

Router# debug bfd packet

BFD 制御パケットのデバッグ情報を表示します。

ステップ 7

debug bfd ipc-error

 

Router# debug bfd ipc-error

RP および LC でのデバッグ情報と IPC エラーを表示します。

ステップ 8

debug bfd ipc-event

 

Router# debug bfd ipc-event

RP および LC でのデバッグ情報と IPC イベントを表示します。

ステップ 9

debug bfd oir-error

 

Router# debug bfd oir-error

RP および LC でのデバッグ情報と OIR エラーを表示します。

ステップ 10

debug bfd oir-event

 

Router# debug bfd oir-event

RP および LC でのデバッグ情報と OIR イベントを表示します。

Cisco 10720 インターネット ルータに対する BFD のモニタリングとトラブルシューティング

Cisco 10720 シリーズ インターネット ルータのモニタリングとトラブルシューティングを実行するには、この項の 1 つ以上の手順に従います。

手順の概要

1. enable

2. show bfd neighbors [ details ]

3. debug bfd event

4. debug bfd packet

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show bfd neighbors [ details ]

 

Router# show bfd neighbors details

(任意)BFD 隣接関係データベースを表示します。

details キーワードを指定すると、すべての BFD プロトコル パラメータとネイバーごとにタイマーが表示されます。

コマンドの出力に表示されません。

ステップ 3

debug bfd event

 

Router# debug bfd event

(任意)BFD 状態遷移のデバッグ情報を表示します。

ステップ 4

debug bfd packet

 

Router# debug bfd packet

(任意)BFD 制御パケットのデバッグ情報を表示します。

双方向フォワーディング検出の設定例

ここでは、次の設定例について説明します。

「例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定」

「例:OSPF ネットワークでの BFD の設定」

「例:BGP ネットワークでの BFD の設定」

「例:IS-IS ネットワークでの BFD の設定」

「例:HSRP ネットワークでの BFD の設定」

「例:スタティック ルーティングのための BFD サポートの設定」

「例:BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定」

例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定

Cisco IOS Release 12.4(9)T の例

次の例では、EIGRP ネットワークにルータ A、ルータ B、およびルータ C が含まれています。ルータ A のファスト イーサネット インターフェイス 0/1 がルータ B のファスト イーサネット インターフェイス 0/1 と同じネットワークに接続されます。ルータ B のファスト イーサネット インターフェイス 0/1 が、ルータ C のファスト イーサネット インターフェイス 0/1 と同じネットワークに接続されます。

ルータ A とルータ B がエコー モードをサポートした BFD バージョン 1 を実行し、ルータ C はエコー モードをサポートしていない BFD バージョン 0 を実行しています。エコー モードはルータ A とルータ B の転送パスで動作するため、ルータ C とその BFD ネイバーの間の BFD セッションは非対称のエコー モードで実行されます。BFD セッションおよび障害検出のため、エコー パケットは同じパスで返されます。また、BFD ネイバー ルータ C は BFD バージョン 0 を実行し、BFD セッションおよび障害検出のために BFD 制御パケットを使用します。

図 4 V1 または V0 を実行する 3 台の BFD ネイバーがある EIGRP ネットワーク

図 4 に、複数のルータがある大規模な EIGRP ネットワークを示します。その中の 3 台は、ルーティング プロトコルとして EIGRP を実行している BFD ネイバーです。

この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。

ルータ A の設定

interface FastEthernet0/0
no shutdown
ip address 10.4.9.14 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no shutdown
duplex auto
speed auto
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
exec-timeout 30 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ルータ B の設定

!
interface FastEthernet0/0
no shutdown
ip address 10.4.9.34 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no shtdown
duplex auto
speed auto
 
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
exec-timeout 30 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ルータ C の設定

!
!
interface FastEthernet0/0
no shutdown
ip address 10.4.9.34 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
no shutdown
duplex auto
speed auto
 
!
router eigrp 11
network 172.16.0.0
bfd all-interfaces
auto-summary
!
ip default-gateway 10.4.9.1
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 10.4.9.1
ip route 172.16.1.129 255.255.255.255 10.4.9.1
!
no ip http server
!
logging alarm informational
!
control-plane
!
line con 0
exec-timeout 30 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end

ルータ A からの show bfd neighbors details コマンドの出力で、3 台のすべてのルータで BFD セッションが作成され、EIGRP が BFD サポートに対して登録されることを確認できます。出力の最初のグループは、IP アドレスが 172.16.1.3 のルータ C が BFD バージョン 0 を実行しているため、エコー モードを使用しないことを示します。出力の 2 番目のグループは、IP アドレスが 172.16.1.2 のルータ B が BFD バージョン 1 を実行していて、50 ミリ秒の BFD interval パラメータが使用されていることを示します。この出力では、対応するコマンド出力が太字で表示されています。

RouterA
 
RouterA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.3 5/3 1(RH) 150 (3 ) Up Fa0/1
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(1364284)
Rx Count: 1351813, Rx Interval (ms) min/max/avg: 28/64/49 last: 4 ms ago
Tx Count: 1364289, Tx Interval (ms) min/max/avg: 40/68/49 last: 32 ms ago
Registered protocols: EIGRP
Uptime: 18:42:45
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 3 - Your Discr.: 5
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.2 6/1 Up 0 (3 ) Up Fa0/1
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(317)
Rx Count: 305, Rx Interval (ms) min/max/avg: 1/1016/887 last: 448 ms ago
Tx Count: 319, Tx Interval (ms) min/max/avg: 1/1008/880 last: 532 ms ago
Registered protocols: EIGRP
Uptime: 00:04:30
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 1 - Your Discr.: 6
Min tx interval: 1000000 - Min rx interval: 1000000
Min Echo interval: 50000
 

ルータ B からの how bfd neighbors details コマンドの出力で、BFD セッションが作成され、EIGRP が BFD サポートに対して登録されていることを確認できます。前述のように、ルータ A は BFD バージョン 1 を実行するため、エコー モードを実行しており、ルータ C は BFD バージョン 0 を実行するため、エコー モードを実行しません。この出力では、対応するコマンド出力が太字で表示されています。

Router B
 
RouterB# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.2 172.16.1.1 1/6 Up 0 (3 ) Up Fa0/1
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(337)
Rx Count: 341, Rx Interval (ms) min/max/avg: 1/1008/882 last: 364 ms ago
Tx Count: 339, Tx Interval (ms) min/max/avg: 1/1016/886 last: 632 ms ago
Registered protocols: EIGRP
Uptime: 00:05:00
Last packet: Version: 1 - Diagnostic: 0
State bit: Up - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 6 - Your Discr.: 1
Min tx interval: 1000000 - Min rx interval: 1000000
Min Echo interval: 50000
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.2 172.16.1.3 3/6 1(RH) 118 (3 ) Up Fa0/1
Session state is UP and not using echo function.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
Received MinRxInt: 50000, Received Multiplier: 3
Holdown (hits): 150(0), Hello (hits): 50(5735)
Rx Count: 5731, Rx Interval (ms) min/max/avg: 32/72/49 last: 32 ms ago
Tx Count: 5740, Tx Interval (ms) min/max/avg: 40/64/50 last: 44 ms ago
Registered protocols: EIGRP
Uptime: 00:04:45
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 6 - Your Discr.: 3
Min tx interval: 50000 - Min rx interval: 50000
Min Echo interval: 0

図 5 ファスト イーサネット インターフェイス 0/1 の障害

図 5 は、ルータ B でファスト イーサネット インターフェイス 0/1 に障害が発生した状態を示しています。このネイバーがなければ、ルータ B からネットワークに到達する方法がありません。

ルータ B のファスト イーサネット インターフェイス 0/1 に障害が発生すると、BFD はルータ A またはルータ C の BFD ネイバーとしてルータ B を検出しなくなります。この例では、ルータ B でファスト イーサネット インターフェイス 0/1 が管理的にシャット ダウンされています。

ルータ A での show bfd neighbors コマンドからの次の出力では、EIGRP ネットワークのルータ A に対する唯一の BFD ネイバーを示します。この出力では、対応するコマンド出力が太字で表示されています。

RouterA# show bfd neighbors
 
OurAddr NeighAddr LD/RD RH/RS Holdown(mult) State Int
172.16.1.1 172.16.1.3 5/3 1(RH) 134 (3 ) Up Fa0/1
 

ルータ C での show bfd neighbors コマンドからの次の出力では、EIGRP ネットワークのルータ C に対する唯一の BFD ネイバーも示します。この出力では、対応するコマンド出力が太字で表示されています。

RouterC# show bfd neighbors
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.1.3 172.16.1.1 3/5 1 114 (3 ) Up Fa0/1

例:OSPF ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

次の例は、ルータ A とルータ B で構成される単純な OSPF ネットワークです。ルータ A のファスト イーサネット インターフェイス 0/1 がルータ B のファスト イーサネット インターフェイス 6/0 と同じネットワークに接続されます。この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。ルータ A と B に対して、OSPF プロセスに関連付けられたすべてのインターフェイスで、BFD がグローバルに設定されます。

ルータ A の設定

!
interface FastEthernet 0/1
ip address 172.16.10.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
!
router ospf 123
log-adjacency-changes detail
network 172.16.0.0 0.0.0.255 area 0
network 172.17.0.0 0.0.0.255 area 0
bfd all-interfaces

ルータ B の設定

!
interface FastEthernet 6/0
ip address 172.16.10.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
ip address 172.18.0.1 255.255.255.0
!
router ospf 123
log-adjacency-changes detail
network 172.16.0.0 0.0.255.255 area 0
network 172.18.0.0 0.0.255.255 area 0
bfd all-interfaces
 

show bfd neighbors details コマンドの出力で、BFD セッションが作成され、BFD サポートに対して OSPF が登録されることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

ルータ A

RouterA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.1 172.16.10.2 1/2 1 532 (3 ) Up Fa0/1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(22), Hello (hits): 200(84453)
Rx Count: 49824, Rx Interval (ms) min/max/avg: 208/440/332 last: 68 ms ago
Tx Count: 84488, Tx Interval (ms) min/max/avg: 152/248/196 last: 192 ms ago

Registered protocols: OSPF

Uptime: 02:18:49
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 2 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 1000
Min Echo interval: 0
 

ルータ B のラインカードからの show bfd neighbors details コマンドの出力で、BFD セッションが作成されたことを確認できます。


) ルータ B は Cisco 12000 シリーズ ルータです。show bfd neighbors details コマンドはラインカードで実行する必要があります。show bfd neighbors details コマンドがラインカードで入力された場合、登録されたプロトコルは表示されません。


ルータ B

RouterB# attach 6
 
Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session
 
Press RETURN to get started!
 
Router> show bfd neighbors details
 
Cleanup timer hits: 0
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.2 172.16.10.1 8/1 1 1000 (5 ) Up Fa6/0
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 5 - Length: 24
My Discr.: 1 - Your Discr.: 8
Min tx interval: 200000 - Min rx interval: 200000
Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
IPC Tx Failure Count: 0
IPC Rx Failure Count: 0
Total Adjs Found: 1
 

show ip ospf コマンドの出力で、BFD が OSPF に対してイネーブルになっていることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

ルータ A

RouterA# show ip ospf
 
Routing Process "ospf 123" with ID 172.16.10.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x000000
Number of opaque AS LSA 0. Checksum Sum 0x000000
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0

BFD is enabled

Area BACKBONE(0)
Number of interfaces in this area is 2 (1 loopback)
Area has no authentication
SPF algorithm last executed 00:00:08.828 ago
SPF algorithm executed 9 times
Area ranges are
Number of LSA 3. Checksum Sum 0x028417
Number of opaque link LSA 0. Checksum Sum 0x000000
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

ルータ B

RouterB# show ip ospf
 
Routing Process "ospf 123" with ID 172.18.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
Supports Link-local Signaling (LLS)
Supports area transit capability
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Incremental-SPF disabled
Minimum LSA interval 5 secs
Minimum LSA arrival 1000 msecs
LSA group pacing timer 240 secs
Interface flood pacing timer 33 msecs
Retransmission pacing timer 66 msecs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Number of areas transit capable is 0
External flood list length 0

BFD is enabled

Area BACKBONE(0)
Number of interfaces in this area is 2 (1 loopback)
Area has no authentication
SPF algorithm last executed 02:07:30.932 ago
SPF algorithm executed 7 times
Area ranges are
Number of LSA 3. Checksum Sum 0x28417
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
 

show ip ospf interface コマンドの出力で、ルータ A とルータ B を接続しているインターフェイスで OSPF に対して BFD がイネーブルになっていることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

ルータ A

RouterA# show ip ospf interface fastethernet 0/1
 
show ip ospf interface fastethernet 0/1
FastEthernet0/1 is up, line protocol is up
Internet Address 172.16.10.1/24, Area 0
Process ID 123, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State BDR, Priority 1, BFD enabled
Designated Router (ID) 172.18.0.1, Interface address 172.16.10.2
Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:03
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 172.18.0.1 (Designated Router)
Suppress hello for 0 neighbor(s)

ルータ B

RouterB# show ip ospf interface fastethernet 6/1
 
FastEthernet6/1 is up, line protocol is up
Internet Address 172.18.0.1/24, Area 0
Process ID 123, Router ID 172.18.0.1, Network Type BROADCAST, Cost: 1
Transmit Delay is 1 sec, State DR, Priority 1, BFD enabled
Designated Router (ID) 172.18.0.1, Interface address 172.18.0.1
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:01
Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)
 

例:BGP ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

次の例は、ルータ A とルータ B で構成される単純な BGP ネットワークです。ルータ A のファスト イーサネット インターフェイス 0/1 がルータ B のファスト イーサネット インターフェイス 6/0 と同じネットワークに接続されます。この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。

ルータ A の設定

!
interface FastEthernet 0/1
ip address 172.16.10.1 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
!
!
router bgp 40000
bgp log-neighbor-changes
neighbor 172.16.10.2 remote-as 45000
neighbor 172.16.10.2 fall-over bfd
!
address-family ipv4
neighbor 172.16.10.2 activate
no auto-summary
no synchronization
network 172.18.0.0 mask 255.255.255.0
exit-address-family
!

ルータ B の設定

!
interface FastEthernet 6/0
ip address 172.16.10.2 255.255.255.0
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
ip address 172.18.0.1 255.255.255.0
!
router bgp 45000
bgp log-neighbor-changes
neighbor 172.16.10.1 remote-as 40000
neighbor 172.16.10.1 fall-over bfd
!
address-family ipv4
neighbor 172.16.10.1 activate
no auto-summary
no synchronization
network 172.17.0.0 mask 255.255.255.0
exit-address-family
!
 

ルータ A からの show bfd neighbors details コマンドの出力で、BFD セッションが作成され、BFD サポートに対して BGP が登録されることを確認できます。この出力では、対応するコマンド出力が太字で表示されています。

ルータ A

RouterA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.1 172.16.10.2 1/8 1 332 (3 ) Up Fa0/1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(0), Hello (hits): 200(15491)
Rx Count: 9160, Rx Interval (ms) min/max/avg: 200/440/332 last: 268 ms ago
Tx Count: 15494, Tx Interval (ms) min/max/avg: 152/248/197 last: 32 ms ago
Registered protocols: BGP
Uptime: 00:50:45
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 8 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 1000
Min Echo interval: 0
 

ルータ B のラインカードからの show bfd neighbors details コマンドの出力で、BFD セッションが作成されたことを確認できます。


) ルータ B は Cisco 12000 シリーズ ルータです。show bfd neighbors details コマンドはラインカードで実行する必要があります。show bfd neighbors details コマンドがラインカードで入力された場合、登録されたプロトコルは表示されません。


ルータ B

RouterB# attach 6
 
Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session
 
Press RETURN to get started!
 
Router> show bfd neighbors details
 
Cleanup timer hits: 0
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.2 172.16.10.1 8/1 1 1000 (5 ) Up Fa6/0
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 5 - Length: 24
My Discr.: 1 - Your Discr.: 8
Min tx interval: 200000 - Min rx interval: 200000
Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
IPC Tx Failure Count: 0
IPC Rx Failure Count: 0
Total Adjs Found: 1
 

show ip bgp neighbors コマンドの出力で、BFD が BGP ネイバーに対してイネーブルになっていることを確認できます。

ルータ A

RouterA# show ip bgp neighbors
 
BGP neighbor is 172.16.10.2, remote AS 45000, external link
Using BFD to detect fast fallover
..

ルータ B

RouterB# show ip bgp neighbors
 
BGP neighbor is 172.16.10.1, remote AS 40000, external link
Using BFD to detect fast fallover
..

例:IS-IS ネットワークでの BFD の設定

例:Cisco IOS Release 12.0(31)S

次の例は、ルータ A とルータ B で構成される単純な IS-IS ネットワークです。ルータ A のファスト イーサネット インターフェイス 0/1 は、ルータ B に対するファスト イーサネット インターフェイス 6/0 と同じネットワークに接続されます。この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。

ルータ A の設定

!
interface FastEthernet 0/1
ip address 172.16.10.1 255.255.255.0
ip router isis
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 3/0.1
ip address 172.17.0.1 255.255.255.0
ip router isis
!
router isis
net 49.0001.1720.1600.1001.00
bfd all-interfaces
!

ルータ B の設定

!
interface FastEthernet 6/0
ip address 172.16.10.2 255.255.255.0
ip router isis
bfd interval 50 min_rx 50 multiplier 3
!
interface FastEthernet 6/1
ip address 172.18.0.1 255.255.255.0
ip router isis
!
router isis
net 49.0000.0000.0002.00
bfd all-interfaces
!
 

ルータ A からの show bfd neighbors details コマンドは、BFD セッションが作成され、IS-IS が BFD サポートに対して登録されることを確認できます。

Router A
 
RouterA# show bfd neighbors details
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.1 172.16.10.2 1/8 1 536 (3 ) Up Fa0/1
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
Received MinRxInt: 1000, Received Multiplier: 3
Holdown (hits): 600(0), Hello (hits): 200(23543)
Rx Count: 13877, Rx Interval (ms) min/max/avg: 200/448/335 last: 64 ms ago
Tx Count: 23546, Tx Interval (ms) min/max/avg: 152/248/196 last: 32 ms ago
Registered protocols: ISIS
Uptime: 01:17:09
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 3 - Length: 24
My Discr.: 8 - Your Discr.: 1
Min tx interval: 50000 - Min rx interval: 1000
Min Echo interval: 0
 

ルータ B のラインカードからの show bfd neighbors details コマンドの出力で、BFD セッションが作成されたことを確認できます。


) ルータ B は Cisco 12000 シリーズ ルータです。show bfd neighbors details コマンドはラインカードで実行する必要があります。show bfd neighbors details コマンドがラインカードで入力された場合、登録されたプロトコルは表示されません。


Router B
 
RouterB# attach 6
 
Entering Console for 8 Port Fast Ethernet in Slot: 6
Type "exit" to end this session
 
Press RETURN to get started!
 
Router> show bfd neighbors details
 
Cleanup timer hits: 0
 
OurAddr NeighAddr LD/RD RH Holdown(mult) State Int
172.16.10.2 172.16.10.1 8/1 1 1000 (5 ) Up Fa6/0
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
Received MinRxInt: 200000, Received Multiplier: 5
Holdown (hits): 1000(0), Hello (hits): 200(5995)
Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
Last packet: Version: 0 - Diagnostic: 0
I Hear You bit: 1 - Demand bit: 0
Poll bit: 0 - Final bit: 0
Multiplier: 5 - Length: 24
My Discr.: 1 - Your Discr.: 8
Min tx interval: 200000 - Min rx interval: 200000
Min Echo interval: 0
Uptime: 00:33:13
SSO Cleanup Timer called: 0
SSO Cleanup Action Taken: 0
Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
IPC Tx Failure Count: 0
IPC Rx Failure Count: 0
Total Adjs Found: 1

例:HSRP ネットワークでの BFD の設定

次の例は、ルータ A とルータ B で構成される HSRP ネットワークです。ルータ A のファスト イーサネット インターフェイス 2/0 は、ルータ B に対するファスト イーサネット インターフェイス 2/0 と同じネットワークに接続されます。この例は、グローバル コンフィギュレーション モードから開始し、BFD の設定を示します。


) 次の例では、standby bfd コマンドと standby bfd all-interfaces コマンドが表示されません。デフォルトでは BFD ピアリングの HSRP サポートがイネーブルになっていて、BFD は bfd interval コマンドを使用してルータまたはインターフェイスで設定されます。standby bfd コマンドと standby bfd all-interfaces コマンドは、ルータまたはインターフェイスで BFD が手動でディセーブルになっている場合にだけ必要です。


ルータ A

ip cef
interface FastEthernet2/0
no shutdown
ip address 10.0.0.2 255.0.0.0
ip router-cache cef
bfd interval 200 min_rx 200 multiplier 3
standby 1 ip 10.0.0.11
standby 1 preempt
standby 1 priority 110
standby 2 ip 10.0.0.12
standby 2 preempt
standby 2 priority 110

ルータ B

interface FastEthernet2/0
ip address 10.1.0.22 255.255.0.0
no shutdown
bfd interval 200 min_rx 200 multiplier 3
standby 1 ip 10.0.0.11
standby 1 preempt
standby 1 priority 90
 
standby 2 ip 10.0.0.12
standby 2 preempt
standby 2 priority 80
 

show standby neighbors コマンドの出力で、BFD セッションが作成されたことを確認できます。

RouterA# show standby neighbors
 
HSRP neighbors on FastEthernet2/0
10.1.0.22
No active groups
Standby groups: 1
BFD enabled !
 
RouterB# show standby neighbors
 
HSRP neighbors on FastEthernet2/0
10.0.0.2
Active groups: 1
No standby groups
BFD enabled !

例:スタティック ルーティングのための BFD サポートの設定

次の例は、ルータ A とルータ B で構成されるネットワークです。ルータ A のシリアル インターフェイス 2/0 がルータ B のシリアル インターフェイス 2/0 と同じネットワークに接続されます。BFD セッションを起動するには、ルータ B を設定する必要があります。

ルータ A

configure terminal
interface Serial 2/0
ip address 10.201.201.1 255.255.255.0
bfd interval 500 min_rx 500 multiplier 5
ip route static bfd Serial 2/0 10.201.201.2
ip route 10.0.0.0 255.0.0.0 Serial 2/0 10.201.201.2

ルータ B

configure terminal
interface Serial 2/0
ip address 10.201.201.2 255.255.255.0
bfd interval 500 min_rx 500 multiplier 5
ip route static bfd Serial 2/0 10.201.201.1
ip route 10.1.1.1 255.255.255.255 Serial 2/0 10.201.201.1
 

ルータ B のスタティック ルートが単独で存在していて、10.201.201.1 と 10.201.201.2 の間で BFD セッションをイネーブルにすることに注意してください。設定する必要のある有益なスタティック ルートがない場合、パケットの転送に影響しないプレフィクス、たとえば、ローカルで設定されたループバック インターフェイスを選択します。

例:BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定

図 6 に、通常の ATM 疑似配線の設定を示します。ネットワークは、2 つの Terminating Provider Edge(T-PE)デバイスの T-PE1 と T-PE2 との間の ATM ペイロードに含まれる MPLS 疑似配線で構成されます。疑似配線の BFD のモニタリングは、T-PE1 デバイスと Switching Providing Edge(S-PE)デバイスとの間、および、S-PE デバイスと T-PE2 デバイスとの間で、発生します。BFD では、Customer Edge(CE; カスタマー エッジ)デバイスと T-PE デバイスとの間の AC の信号ステータスがモニタされます。


) S-PE に必要な BFD Control Channel over VCCV に固有の設定はありません。


図 6 BFD Control Channel over VCCV の ATM 疑似配線例

CE1

interface ATM 0/0
description connect to mfi6 atm9/0/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM 0/0.2 point-to-point
ip address 10.25.1.1 255.255.255.0
no ip directed-broadcast
no atm enable-ilmi-trap
pvc 0/100
encapsulation aal5snap

T-PE1

interface Loopback 0
ip address 10.0.0.6 255.255.255.255
bfd-template single-hop nsn
interval min-tx 500 min-rx 500 multiplier 3
pseudowire-class vccv-bfd1
encapsulation mpls
vccv bfd template nsn raw-bfd
vccv bfd status signaling
interface ATM 9/0/0
description connect mfr4 atm0/0
no ip address
atm asynchronous
atm clock INTERNAL
no atm ilmi-keepalive
no atm enable-ilmi-trap
pvc 0/100 l2transport
xconnect 10.0.0.7 100 pw-class vccv-bfd1

T-PE2

interface Loopback 0
ip address 10.54.0.1 255.255.255.255
bfd-template single-hop nsn
interval min-tx 500 min-rx 500 multiplier 3
!
pseudowire-class vccv-bfd1
encapsulation mpls
vccv bfd template nsn raw-bfd
vccv bfd status signaling
interface ATM 2/0
no ip address
atm asynchronous
no atm ilmi-keepalive
no atm enable-ilmi-trap
pvc 0/100 l2transport
xconnect 10.0.0.7 102 pw-class vccv-bfd1
!

CE2

interface ATM 4/0.2 point-to-point
ip address 10.25.1.2 255.255.255.0
no snmp trap link-status
pvc 0/100
encapsulation aal5snap

参考資料

関連資料

関連項目
参照先

BGP の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の「 Cisco BGP Overview 」の章

EIGRP の設定とモニタリング

Cisco IOS IP Routing Protocols Configu ration Guide』の「 Configuring EIGRP」の章

HSRP の設定とモニタリング

Cisco IOS IP Application Services Configuration Guide 』の「 Configuring HSRP 」の章

IS-IS の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の「 Configuring Integrated IS-IS 」の章

OSPF の設定とモニタリング

Cisco IOS IP Routing Protocols Configuration Guide 』の 「Configuring OSPF」の章

BFD コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

BGP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

EIGRP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

HSRP コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Application Services Command Reference』

IS-IS コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

OSPF コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IP Routing: Protocol-Independent Command Reference』

規格

規格
タイトル

IETF ドラフト

Bidirectional Forwarding Detection 、2009 年 2 月

(http://www.ietf.org/internet-drafts/draft-ietf-bfd-base-09.txt)

IETF ドラフト

BFD for IPv4 and IPv6 (Single Hop) 、2009 年 2 月

(http://www.ietf.org/internet-drafts/draft-ietf-bfd-v4v6-1hop-09.txt)

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

双方向フォワーディング検出の機能情報

表 5 に、この章で説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 5 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 5 双方向フォワーディング検出の機能情報

機能名
リリース
機能情報

双方向フォワーディング検出(標準実装、バージョン 1)

12.2(18)SXE
12.0(31)S
12.0(32)S
12.4(9)T
12.2(33)SRB
12.4(11)T
12.4(15)T
12.2(33)SXH
12.2(33)SRC
15.0(1)S

このマニュアルでは、Bidirectional Forwarding Detection(BFD; 双方向フォワーディング検出)プロトコルをイネーブルにする方法について説明します。BFD はあらゆるメディア タイプ、カプセル化、トポロジ、およびルーティング プロトコルの高速転送パス障害検出回数を提供するように設計された検出プロトコルです。高速転送パス障害検出に加えて、BFD はネットワーク管理者に整合性のある障害検出方法を提供します。ネットワーク管理者は BFD を使用して、複数のルーティング プロトコルの hello メカニズムの可変レートではなく、統一レートで転送パス障害を検出でき、ネットワークのプロファイリングおよび計画が簡単になり、コンバージェンス時間が一貫して予測できます。

Release 12.0(31)S では、Cisco 12000 シリーズのインターネット ルータのサポートが追加されました。

Release 12.0(32)S では、Cisco 10720 インターネット ルータ、および、Cisco 12000 シリーズ インターネット ルータの IP サービス エンジン(エンジン 3)、エンジン 5 Shared Port Adapter(SPA; 共有ポート アダプタ)、SPA Interface Processors(SIP)のサポートが追加されました。

BFD Control Channel over VCCV:ATM 疑似配線のサポート

15.0(1)S

VCCV では、ATM 疑似配線に関連付けられている制御チャネルが提供され、疑似配線を介して操作と管理機能が提供されます。BFD では、VCCV 制御チャネルを使用して、疑似配線のデータプレーンの障害が検出されます。

Cisco IOS Release 15.0(1)S では、VCCV タイプ 1(IP/UDP ヘッダーなし)のみで、BFD Control Channel over VCCV の ATM 疑似配線のサポート機能がサポートされます。

この機能に関する詳細については、次の各項を参照してください。

「BFD Control Channel over VCCV:ATM 疑似配線のサポート」

「BFD テンプレートの作成と設定」

「例:BFD Control Channel over VCCV:ATM 疑似配線のサポートの設定」

この機能によって、 bfd-template debug mpls l2transport vc vccv interval (BFD)、 vccv vccv bfd template vccv bfd status signaling の各コマンドが導入または変更されました。

BFD エコー モード

12.4(9)T
12.2(33)SRB
15.0(1)S

BFD エコー モードは非同期 BFD で動作します。エコー パケットはフォワーディング エンジンによって送信され、検出を実行するために、同じパスで転送されます。反対側の BFD セッションはエコー パケットの実際のフォワーディングに関与しません。エコー機能およびフォワーディング エンジンが検出プロセスを処理するため、2 つの BFD ネイバー間で送信される BFD 制御パケットの数が減少します。また、フォワーディング エンジンが、リモート システムを介さずにリモート(ネイバー)システムの転送パスをテストするため、パケット内遅延が向上する可能性があり、それによって BFD バージョン 0 を BFD セッションの BFD 制御パケットを使用する場合に、障害検出時間を短縮できます。

次の項では、この機能に関する情報について説明します。

「BFD エコー モードの設定」

「非対称性のない BFD エコー モードのディセーブル化」

BFD:EIGRP サポート

12.0(31)S
12.4(4)T
12.2(18)SXE
12.2(33)SRA
12.2(33)SRB

EIGRP が BFD で登録されたプロトコルであり、BFD から転送パスの検出障害メッセージを受信するように、EIGRP に対する BFD サポート BFD を設定できます。

EIGRP に対する BFD は、Cisco IOS Release 12.0(31)S、12.0(32)S、12.4(4)T、および 12.2(33)SRA の Cisco 12000 シリーズ ルータでサポートされません。

次の項では、この機能に関する情報について説明します。

「ダイナミック ルーティング プロトコルに対する BFD サポートの設定」

「EIGRP に対する BFD サポートの設定」

「例:エコー モードがデフォルトでイネーブルになった EIGRP ネットワークでの BFD の設定」

BFD:VRF サポート

12.2(33)SRC 15.0(1)M
15.0(1)S

BFD 機能のサポートが、プロバイダー エッジ(PE)ルータとカスタマー エッジ(CE)ルータの間のルーティング プロトコル障害の高速検出を提供するように、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)対応に拡張されています。

この機能については、次の項に説明があります。

「VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インターフェイスのための BFD サポート」

BFD:WAN インターフェイス サポート

12.2(33)SRC 15.0(1)M
15.0(1)S

BFD 機能がブロードキャスト メディア以外のインターフェイス(ATM、POS、シリアル、および VLAN インターフェイスなど)でサポートされます。BFD のサポートは ATM、FR、POS、およびシリアル サブインターフェイスに拡張されます。

bfd interval コマンドは、BFD モニタリングを開始するインターフェイスで設定する必要があります。

この機能については、次の項に説明があります。

「非ブロードキャスト メディア インターフェイスに対する BFD サポート」

BFD に対する HSRP サポート

12.4(11)T
12.4(15)T
12.2(33)SRC

Release 12.4(11)T では、HSRP のサポートが追加されました。

Release 12.4(15)T では、BFD が Cisco ルータの Integrated Services Router(ISR; サービス統合型ルータ)ファミリ、たとえば Cisco 3800 ISR シリーズ ルータでサポートされます。

Release 12.2(33)SRC では、作成できる BFD セッションの数が増加し、BFD サポートが ATM、FR、POS、およびシリアル サブインターフェイスに拡張され、BFD 機能が VRF 対応に拡張され、計画されたスイッチオーバー時に BFD セッションが「Admin Down」状態になり、BFD サポートがスタティック ルーティングに拡張されました。

この機能については、次の項に説明があります。

「例:HSRP ネットワークでの BFD の設定」

IPv4 での BFD に対する IS-IS サポート

12.0(31)S
12.4(4)T
12.2(18)SXE
12.2(33)SRA
15.0(1)S

すべてのインターフェイスでグローバルに OSPF に対する BFD を設定するか、または 1 つ以上のインターフェイスで選択的に設定することができます。BFD で登録されたプロトコルとして IS-IS で BFD サポートが設定される場合、IS-IS が BFD から転送パスの検出障害メッセージを受信します。

次の項では、この機能に関する情報について説明します。

「ダイナミック ルーティング プロトコルに対する BFD サポートの設定」

「IS-IS に対する BFD サポートの設定」

「例:IS-IS ネットワークでの BFD の設定」

IPv4 での BFD に対する OSPF サポート

12.0(31)S
12.4(4)T
12.2(18)SXE
12.2(33)SRA
15.0(1)S

すべてのインターフェイスでグローバルに OSPF に対する BFD を設定するか、または 1 つ以上のインターフェイスで選択的に設定することができます。BFD で登録されたプロトコルとして OSPF で BFD サポートが設定される場合、OSPF が BFD から転送パスの検出障害メッセージを受信します。

次の項では、この機能に関する情報について説明します。

「ダイナミック ルーティング プロトコルに対する BFD サポートの設定」

「OSPF に対する BFD サポートの設定」

「例:OSPF ネットワークでの BFD の設定」

SSO:BFD

12.2(33)SXI2
12.2(33)SRE
12.2(33)XNE
15.0(1)S

デュアル RP ルータおよびスイッチを使用するネットワーク導入には、スイッチオーバー全体でフォワーディング状態を保護するためのグレースフル リスタート メカニズムがあります。この機能によって、BFD はスイッチオーバー全体でセッションを稼動状態に保つことができます。

この機能については、次の項に説明があります。

「ステートフル スイッチオーバーのための BFD サポート」

SSO:BFD(Admin Down)

12.2(33)SRC
15.0(1)S

SSO をサポートするために、計画されたスイッチオーバー時に BFD セッションが「Admin Down」状態になります。BFD 設定はアクティブなプロセッサからスタンバイ プロセッサに同期化され、すべての BFD クライアントがスタンバイ プロセッサでの BFD プロセスで再登録されます。

この機能については、次の項に説明があります。

「ステートフル スイッチオーバー機能を持つノンストップ フォワーディングのための BFD サポート」

BFD 用のスタティック ルート

12.2(33)SRC 15.0(1)M
15.0(1)S

OSPF や BGP などの動的なルーティング プロトコルとは異なり、スタティック ルーティングにはピア検出の方法がありません。したがって、BFD が設定されると、ゲートウェイの到達可能性は完全に指定されたネイバーへの BFD セッションの状態に依存します。BFD セッションが開始されない限り、スタティック ルートのゲートウェイは到達不能と見なされ、したがって、影響を受けるルートが適切な RIB にインストールされません。

次の項では、この機能に関する情報について説明します。

「スタティック ルーティングのための BFD サポート」

「スタティック ルーティングのための BFD サポートの設定」

「例:スタティック ルーティングのための BFD サポートの設定」