キャリア イーサネット コンフィギュレーション ガイド、Cisco IOS Release 15.1S
マルチシャーシ LACP
マルチシャーシ LACP
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

マルチシャーシ LACP

機能情報の確認

目次

mLACP に関する前提条件

mLACP に関する制約事項

mLACP について

マルチシャーシ EtherChannel の概要

MPLS 疑似ワイヤ冗長メカニズムとの相互作用

冗長メカニズムのプロセス

mLACP を使用したデュアルホーム接続トポロジ

LACP および 802.3ad でのパラメータの交換

ポート ID

ポート番号

ポート プライオリティ

マルチシャーシに関する考慮事項

システム MAC アドレス

システム プライオリティ

ポート キー

障害保護のシナリオ

動作可能なバリアント

DHD ベース コントロール

PoA コントロール

共有コントロール(PoA および DHD)

mLACP フェールオーバー

ダイナミック ポート プライオリティ

リバーティブ モードと非リバーティブ モード

ブルートフォース シャットダウン

シャーシ間冗長マネージャを使用したピア モニタリング

MAC フラッシュ メカニズム

mLACP の設定方法

シャーシ間グループ コマンドと基本的 mLACP コマンドの設定

mLACP シャーシ間グループ コマンドと他のポート チャネル コマンドの設定

VPWS の冗長性の設定

VPLS の冗長性の設定

VPLS の結合モードと分離モード

VPLS の冗長性の設定手順

階層型 VPLS の設定

mLACP のトラブルシューティング

mLACP のデバッグ

接続回線または EVC での mLACP のデバッグ

AToM 疑似ワイヤでの mLACP のデバッグ

相互接続、冗長マネージャ、およびセッション セットアップのデバッグ

VFI のデバッグ

セグメント スイッチング マネージャ(スイッチング セットアップ)のデバッグ

mLACP でのハイ アベイラビリティ機能のデバッグ

mLACP の設定例

例:VPWS の設定

VPWS のアクティブ PoA

VPWS のスタンバイ PoA

例:VPLS の設定

VPLS のアクティブ PoA

VPLS のスタンバイ PoA

例:H-VPLS の設定

H-VPLS のアクティブ PoA

H-VPLS のスタンバイ PoA

例:アクティブ PoA での VPWS の確認

show lacp multichassis group

show lacp multichassis port-channel

show mpls ldp iccp

show mpls l2transport

show etherchannel summary

show etherchannel number port-channel

show lacp internal

例:スタンバイ PoA での VPWS の確認

show lacp multichassis group

show lacp multichassis portchannel

show mpls ldp iccp

show mpls l2transport

show etherchannel summary

show lacp internal

例:アクティブ PoA での VPLS の確認

show lacp multichassis group

show lacp multichassis port-channel

show mpls ldp iccp

show mpls l2transport

show etherchannel summary

show lacp internal

例:スタンバイ PoA での VPLS の確認

show lacp multichassis group

show lacp multichassis portchannel

show mpls ldp iccp

show mpls l2transport vc 2

show lacp internal

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

mLACP に関する機能情報

用語集

マルチシャーシ LACP

キャリア イーサネット ネットワークでは、さまざまな冗長メカニズムにより、ノードおよびネットワークの復元力のある相互接続が提供されます。どの冗長メカニズムを選択するかは、トランスポート テクノロジー、トポロジ、単一ノード対ネットワーク全体のマルチホーミング、デバイスの機能、Autonomous System(AS; 自律システム)境界またはサービス プロバイダー操作モデル、およびサービス プロバイダー設定などのさまざまな要因により異なります。

キャリア イーサネット ネットワークのハイアベイラビリティは、シャーシ内およびシャーシ間の両方の冗長メカニズムを採用することで実現できます。Cisco の Multichassis EtherChannel(MCEC)ソリューションは、通信事業者が冗長性を確保するため、デバイスを 2 つのアップストリーム Points of Attachment(PoA)に「デュアルホーム接続」する場合の、シャーシ間冗長メカニズムに対するニーズを対象としています。一部の通信事業者は、アクセス ネットワークでループ防止コントロール プロトコルを実行できないか、実行していないため、代替の冗長方式を必要としています。MCEC は、802.3ad Link Aggregation Control Protocol(LACP)の実装環境に対し、拡張機能を使用して、この問題に対処します。これらの拡張機能は、本書に示すマルチシャーシ LACP(mLACP)機能の中で説明します。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「mLACP に関する機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

mLACP に関する前提条件

PoA コントロール モードおよび共有コントロール モードで動作するには、すべての PoA で lacp max-bundle コマンドを使用する必要があります。

設定されるリンクの最大数を、PoA に接続される Link Aggregation Group(LAG)でのインターフェイスの総数よりも少なくすることはできません。

各 PoA は、LAG に対するリンク数が異なる(異なる最大リンク数が設定された)Dual-Homed Device(DHD)に接続されることがあります。

LAG をアクティブ状態に保つには、必要な最小リンク数を指定する port-channel min-link コマンドを使用して、各 PoA を設定する必要があります。

ブルートフォース フェールオーバーが使用されている場合、 errdisable recovery cause mlacp コマンドを使用して、各 PoA を設定する必要があります。

DHD コントロールには、各 PoA までのリンクと同じ数のリンクが必要です。

max-bundle の値は、PoA(ローカル PoA 内のアクティブ保護またはスタンバイ保護なし)にローカル接続するリンク数と等しくする必要があります。

コンバージェンスの速度を上げるには、すべてのデバイスに LACP ファスト スイッチオーバーを設定する必要があります。

mLACP に関する制約事項

mLACP はファスト イーサネットをサポートしません。

mLACP は半二重リンクをサポートしません。

mLACP は複数のネイバーをサポートしません。

ポート チャネルを mLACP に変換すると、サービスが中断する可能性があります。

各 PoA の LAG あたりの最大メンバ リンク数は、プラットフォームによる制限を受け、ポート チャネルあたりの最大ポート数によって制限されます。

DHD のシステム プライオリティは、PoA のプライオリティよりも低くする必要があります。

MAC Tunneling Protocol(MTP; MAC トンネリング プロトコル)は、ポート チャネル内の 1 メンバ リンクのみサポートします。

ポート チャネルまたはそのメンバ リンクは、LACP が安定していてもフラップすることがあります。

DHD ベース コントロールは、min-links が設定されない場合は機能しません。

min-links が設定された DHD 制御のリバーティブ動作はサポートされていません。

ブルートフォース フェールオーバーでは、常に min-link 障害が発生します。

ブルートフォース フェールオーバーによるすべての障害はリバーティブ動作になります。

mLACP について

「マルチシャーシ EtherChannel の概要」

「MPLS 疑似ワイヤ冗長メカニズムとの相互作用」

「冗長メカニズムのプロセス」

「mLACP を使用したデュアルホーム接続トポロジ」

「障害保護のシナリオ」

「動作可能なバリアント」

「mLACP フェールオーバー」

マルチシャーシ EtherChannel の概要

Multichassis EtherChannel(MCEC; マルチシャーシ EtherChannel)では、DHD が 2 つのアップストリーム PoA にデュアルホーム接続されます。DHD は Multiple Spanning Tree(MST)などのいずれのループ防止コントロール プロトコルも実行できません。したがって、冗長セットアップによるループの転送を防ぐには別のメカニズムが必要です。そのメカニズムの 1 つとして、DHD のアップリンクを LAG に配置する方式があります。これは通常、EtherChannel と呼ばれます。この方式は、LAG の確立と維持のため、DHD は IEEE 802.3ad LACP のみ実行できることが前提になっています。

IEEE 802.3ad で定義された LACP は、LAG のダイナミック ネゴシエーションおよび確立を許可するリンク レベルのコントロール プロトコルです。PoA に対する LACP 実装の拡張は、2 つの独立したデバイスではなく、単一の仮想 LACP ピアに接続された DHD にまで拡張する必要があります。この拡張機能はマルチシャーシ LACP または mLACP と呼ばれます。図 1 に、このセットアップを示します。

図 1 mLACP による MCEC

仮想 LACP ピアを形成する PoA は、DHD の観点から、冗長グループのメンバとして定義されます。DHD への単一デバイスとして出現する冗長グループ内の PoA の場合、これらの PoA 間の状態は、コントロール専用の Interchassis Communication Channel(ICC)を提供する Interchassis Communication Protocol (ICCP)を経由して同期化する必要があります。

Cisco IOS Release 12.2(33)SRE では、システムはアクティブ/スタンバイ冗長モードで機能します。このモードでは、単一 PoA のみに接続する DHD アップリンクは随時アクティブにできます。DHD は 1 つの PoA をアクティブとして認識し、もう一方をスタンバイとして認識しますが、特定の PoA が、ある DHD ではアクティブとなり、別の DHD ではスタンバイとなる可能性があります。この機能により、2 つの PoA が別々のサービスに対してロード シェアを実行できます。

MPLS 疑似ワイヤ冗長メカニズムとの相互作用

図 1 に示すネットワーク セットアップは、Multiprotocol Label Switching(MPLS)による Virtual Private LAN Service(VPLS; バーチャル プライベート LAN サービス) および Virtual Private Wire Service(VPWS; バーチャル プライベート回線サービス)の導入に対する Provider Edge(PE; プロバイダー エッジ)ノード冗長性の提供に使用できます。このような導入では、コアからリモート PE ノードへの接続に冗長性を提供する MPLS 疑似ワイヤが、PoA のアップリンクに収容されます。ネットワークが適切に動作するには、mLACP などの接続回線に採用された冗長メカニズムと、MPLS 疑似ワイヤに採用された冗長メカニズムの間の相互動作が必要です。この相互作用により、特定の PoA で、接続回線と疑似ワイヤの間の状態(アクティブまたはスタンバイ)が同期化されます。

RFC 4447 では、Link Distribution Protocol(LDP)によって疑似ワイヤ ステータスを送信するメカニズムが導入され、接続回線と疑似ワイヤ障害情報をレポートするための一連のステータス コードが定義されています。優先転送ステータス ビット( draft-ietf-pwe3-redundancy-bit )定義では、これらのコードを拡張し、疑似ワイヤ冗長アプリケーションに次の 2 つのビットを含めることが提案されています。

優先転送ステータス:アクティブまたはスタンバイ

疑似ワイヤ スイッチオーバーの要求

このドラフトでは次の 2 つの動作モードも提案されます。

独立モード:ローカル PE は、リモート PE から独立した疑似ワイヤのステータスで決まります。

1 次モードおよび 2 次モード:PE のいずれか 1 つが、ハンドシェーク メカニズムを通じたリモート側の状態を決定します。

mLACP 機能の場合、動作は独立モードに基づいたものになります。PoA 間で ICC を実行することにより、優先転送ステータス ビットのみが必要となります。疑似ワイヤ スイッチオーバーの要求ビットは使用されません。

ローカル疑似ワイヤ ステータス(アクティブまたはスタンバイ)は、冗長グループ内の PoA 別に個別に決定され、通知形式でリモート PE にリレーされます。同様に、リモート PE は、その疑似ワイヤ ステータスの固有の選択を実行し、コアの別の側にある PoA に通知します。

このローカル状態の交換の後で、トラフィック転送に使用する疑似ワイヤは、ローカル側とリモート側の両方で別々にアクティブになるように選択されます。

接続回線の冗長メカニズムにより、疑似ワイヤの冗長メカニズムが決まり、管理されます。mLACP は、設定済みの LACP システム プライオリティおよびポート プライオリティに応じて、特定の PoA での接続回線のステータスを決定します。次に、特定の PoA での疑似ワイヤのステータスは、ローカル接続回線のステータスと同期化されます。この同期化によって、アクティブな接続回線のある PoA には、アクティブな疑似ワイヤが提供されます。同様に、スタンバイ モードの接続回線がある PoA には、スタンバイ モードで疑似ワイヤが提供されます。接続回線の転送ステータスが疑似ワイヤの転送ステータスと同期化されていることを確認することによって、冗長グループ内の PoA ノード間でデータを転送する必要がなくなります。この同期化により、プラットフォームの帯域幅が節約されます。同期化が行われないと、この帯域幅は、障害が発生した場合に PoA 間のデータ転送に消費されることになります。

冗長メカニズムのプロセス

キャリア イーサネットの冗長ソリューションには、次のプロセス(および mLACP ソリューションへのプロセスの適用方法)が含まれている必要があります。

接続回線のアクティブ ステータスまたはスタンバイ ステータスの選択:この選択は、アクセス ノードまたはネットワーク、集約ノード、あるいはこの 2 つの組み合わせにより実行できます。mLACP の場合、接続回線ステータスの選択は、DHD と PoA 間のコラボレーションによって決まります。

疑似ワイヤ転送ステータスの通知:この通知は VPWS 導入および VPLS 導入時、つまり、PoA アップリンクが疑似ワイヤ テクノロジーを採用する際に mLACP 動作で必須です。PoA がアクティブ ロールかスタンバイ ロールのどちらに決まっても、ネットワークの遠端にある PE に対して、関連する疑似ワイヤのステータスを送信する必要があります。MPLS 疑似ワイヤの場合、これは LDP を使用して実行されます。

MAC フラッシュ指示:この指示は、コンバージェンスにかかる時間を短縮し、トラフィックのブラックホール化の可能性を排除するため、すべての冗長メカニズムで必須のプロセスです。mLACP 冗長メカニズムは、関係する 802.1Q/802.1ad/802.1ah MAC フラッシュ メカニズムと VPLS の MAC フラッシュ メカニズムに組み込まれる必要があります。


) ブラックホールは、データがその目的とする受信側に到達しなかったことを送信元に通知せずに、受信トラフィックがドロップされた場合に発生します。ブラックホールは、失われたトラフィックがモニタされているときにのみ検出できます。


アクティブ VLAN 通知:mLACP では、PoA がアクティブ/スタンバイ冗長モデルに従っている限り、この通知は不要です。

図 2 に、キャリア イーサネット ネットワークにおける冗長メカニズムを示します。

図 2 キャリア イーサネット ネットワークにおける冗長メカニズム

mLACP を使用したデュアルホーム接続トポロジ

mLACP 機能により、LACP ステート マシンとプロトコルが、デュアルホーム接続トポロジで動作できるようになります。mLACP 機能は、既存の LACP 実装環境をマルチシャーシ特有の要件から分離し、LACP が IEEE 802.3ad 規格の順守を維持できるようにします。mLACP 機能は、各冗長グループの DHD に IEEE 802.3ad の単一仮想インスタンスを提示します。仮想 LACP インスタンスは、IEEE 802.3ad 規格に従って DHD と連動し、複数のシャーシにまたがる LAG を形成します。

LACP および 802.3ad でのパラメータの交換

IEEE 802.3ad では、LACP システムの MAC アドレスとシステム プライオリティの連結により、LACP システム ID(8 バイト)が形成されます。システム ID は、2 バイトのシステム プライオリティ値を、システム ID の最上位の 2 つのオクテットとすることで形成されます。システム MAC アドレスは、システム ID の残りの部分(オクテット 3 から 8)を形成します。システム ID のプライオリティ比較は、数値の小さい ID に基づいて行われます。

最もプライオリティの高い LACP を提供するには、mLACP モジュールは、特定の冗長グループのシステム MAC アドレスおよびプライオリティの値を、その冗長グループ ピアに伝達し、この逆の操作も行います。次に mLACP は特定の冗長グループ内の PoA 中で最も値の小さいシステム ID を選択し、冗長グループの仮想 LACP インスタンスのシステム ID として使用します。

Cisco IOS Release 12.2(33)SRE では、特定の冗長グループで使用するシステム MAC アドレスとシステム プライオリティを指定するため、2 つの LACP コンフィギュレーション コマンド( mlacp system-mac mac-address と mlacp system-priority priority-value )が導入されています。これらのコマンドでは、接続回線のどちら側が LAG の選択ロジックを制御するかの決定をうまく設定できます。システム MAC アドレスのデフォルト値は、シャーシのバックプレーンのデフォルト MAC アドレスです。プライオリティのデフォルト値は 32768 です。

ポート ID

IEEE 802.3ad はシステム内でポートを一意的に識別するため、4 バイトのポート ID を使用します。ポート ID はポート プライオリティとポート番号が連結したもので、システムごとに固有であり、システムでの個々のポートを識別します。ポート ID 間の数値による比較は、符号なし整数の比較により実行されます。2 バイトの Port Priority フィールドは、ポート ID の最上位 2 つのオクテットに配置されます。2 バイトのポート番号が 3 番目と 4 番目のオクテットを構成します。mLACP 機能は、特定の冗長グループのポート ID が一意になるように調整します。

ポート番号

ポート番号は、デバイス内のポートの固有 ID として機能します。ポートに対する LACP ポート番号はポートの ifIndex 値と同じです(または Cisco 7600 ルータ上のスロットおよびサブスロットに基づいています)。

LACP は、再配線を検出するポート番号により異なります。マルチシャーシ動作の場合、 mlacp node-id node-id コマンドを入力して、2 つの PoA 間でポート番号がオーバーラップしないように調整する必要があります。

ポート プライオリティ

ポート プライオリティは、LAG で使用できるリンクの最大数に関してハードウェアまたはソフトウェアの制約がある場合に、どのポートをアクティブ モードにして、どのポートをスタンバイ モードのままにしておくかを決める際に LACP の選択ロジックで使用されます。アクティブ/スタンバイ冗長モードでのマルチシャーシ操作の場合、アクティブ PoA に接続しているすべてのリンクのポート プライオリティが、スタンバイ PoA に接続しているリンクのポート プライオリティよりも高くなっている必要があります。これらのポート プライオリティは、明示的な設定によって保証されるか、選択基準に応じたポート プライオリティが、システムによって自動的に調整されます。たとえば、ポート プライオリティの最も高い PoA をアクティブ PoA として選択し、ポート キーが同じである他のすべてのリンクのプライオリティを等しい値になるようにダイナミックに調整します。

Cisco IOS Release 12.2(33)SRE では、mLACP 機能はアクティブ/スタンバイ冗長モデルのみがサポートされます。各メンバ リンクの LACP ポート プライオリティは、特定の PoA の LAG に属するリンクごとに同じにする必要があります。この要件をサポートするには、Command-Line Interface(CLI; コマンドライン インターフェイス)のインターフェイス コンフィギュレーション モードで mlacp lag-priority コマンドを実装します。このコマンドにより、LAG 内のすべてのローカル メンバ リンクに対して LACP ポート プライオリティが設定されます。個々のメンバ リンクの LACP プライオリティ( lacp port-priority コマンドで設定)は、mLACP ポート チャネルに属するリンクで無視されます。

mlacp lag-priority コマンドは、次の 2 つの操作で PoA フェールオーバーを強制するために使用されることもあります。

アクティブ PoA の LAG プライオリティを、スタンバイ PoA での LAG プライオリティよりも大きい値に設定します。この設定では、PoA がアクティブになる前にスタンバイ リンクでの LACP リンク状態遷移が最小数しか必要でないため、最速のフェールオーバーが発生します。

スタンバイ PoA の LAG プライオリティを、アクティブ PoA での LAG プライオリティよりも小さい値に設定します。この設定では、スタンバイ リンクが発生してアクティブになる前に、リンクが OUT_OF_SYNC を DHD に通知する必要があるため、フェールオーバーにかかる時間が若干長くなります。

場合によっては、動作プライオリティと、設定されたプライオリティは、フェールオーバーを強制するためにダイナミック ポートのプライオリティ管理を使用する際に異なることがあります。この場合、設定されたバージョンは、ポート チャネルが非リバーティブ モードで動作していない限り、変更されません。現在の動作プライオリティを表示するには、 show lacp multichassis port-channel コマンドを入力します。設定されたプライオリティ値は、 show running-config コマンドを使用して表示できます。

マルチシャーシに関する考慮事項

LACP はリンク層プロトコルであるため、リンク上で交換されるすべてのメッセージには、そのリンクに対して固有でローカルな情報が含まれます。交換される情報の内容は次のとおりです。

システム アトリビュート:プライオリティおよび MAC アドレス

リンク アトリビュート:ポート キー、プライオリティ、ポート番号、および状態

マルチシャーシ セットアップを経由して動作するために LACP を拡張すると、2 つのシャーシ間のプロトコル アトリビュートと状態の同期化が必要になります。

システム MAC アドレス

LACP は、特定のリンクを経由して接続しているリモート デバイスの ID を特定するシステム MAC アドレスにより異なります。したがって、この接続から 2 つの別個のデバイスへの DHD をマスクするには、2 つの PoA 間でのシステム MAC アドレスの調整が必要です。Cisco IOS ソフトウェアでは、LACP のシステム MAC アドレスのデフォルト値は、ROM バックプレーン ベース MAC アドレスで、設定による変更はできません。マルチシャーシ動作では、次の 2 つの条件が必要です。

各 PoA のシステム MAC アドレスは、そのピアに伝達される必要がある:たとえば、PoA は、より小さい数値の MAC アドレスをシステム MAC アドレスにするために選択します。このアービトレーション方式は、同じ値に解決される必要があります。より小さい数値の MAC アドレスの選択には、より高いシステム プライオリティを指定できるという利点があります。

システム MAC アドレスが設定可能:システム プライオリティは、MAC アドレスにより異なるものがあり、サービス プロバイダーは、PoA が DHD よりも高いプライオリティを持つことを保証できます(たとえば、DHD と PoA の両方に同じシステム プライオリティが設定され、サービス プロバイダーが DHD で制御しない場合)。プライオリティが高いと、PoA のポート プライオリティが、DHD のポート プライオリティ設定のすべてよりも優先されることが保証されます。システム MAC アドレスを設定する場合は、アドレスが両方の PoA で均一である必要があります。値が均一でないと、デフォルトの MAC アドレスが選択された時点で、システムが自動的に不一致をアービトレーションします。

システム プライオリティ

LACP では、LAG の確立時に、どのピアのポート プライオリティが選択ロジックで使用されるかを決定するため、システム プライオリティがすべてのデバイスに関連付けられている必要があります。Cisco IOS ソフトウェアでは、このパラメータは CLI による設定が可能です。マルチシャーシ操作の場合、このパラメータは PoA によって調整され、同じ値が DHD に示されます。

ポート キー

ポート キーは、特定のシステムに、どのリンクが LAG を形成できるかを示します。このキーは、LACP システムに対してローカルで重要であり、LACP ピアでのキーと一致する必要はありません。DHD 上と PoA 上に同じキーがある場合、同じ LAG に加わる候補として 2 つのリンクがありますが、DHD 上のキーが PoA 上のキーと同じである必要はありません。キーがポートを集約するニーズに応じて設定される場合は、マルチシャーシ動作に関してこのパラメータに対する特別な考慮事項はありません。

障害保護のシナリオ

mLACP 機能には、ポート障害、リンク障害、およびノード障害からの保護によるネットワーク復元力が備わっています。この機能は 5 つに分類できます。図 3 に、ネットワークでの障害ポイントを A から E で示します。

A:DHD 上のアップリンク ポート障害

B:イーサネット リンク障害

C:アクティブ PoA 上のダウンリンク ポート障害

D:アクティブ PoA ノード障害

E:アクティブ PoA アップリンク障害

図 3 mLACP 保護の障害ポイント

これらの障害のいずれかが発生すると、システムは、アクティブ PoA からスタンバイ PoA へのスイッチオーバーをトリガーすることにより応答します。スイッチオーバーには、PoA のアップリンクとダウンリンクの同時フェールオーバーが含まれます。

障害ポイント A と C はポート障害です。障害ポイント B はイーサネット リンク障害で、障害ポイント D はノード障害です。障害ポイント E は、PoA が MPLS ネットワークに接続する際の、次の 4 つの異なるタイプのアップリンク障害のうちの 1 つを示しています。

疑似ワイヤ障害:個々の疑似ワイヤのモニタリング(VCCV-BFD の使用など)および疑似ワイヤ障害時に、関連付けられたサービス インスタンスに対してアップリンク障害を宣言します。

リモート PE IP パス障害:リモート PE への IP 到達可能性のモニタリング(IP Route-Watch の使用など)およびルート障害時に、関連付けられたすべてのサービス インスタンスに対してアップリンク障害を宣言します。

LSP 障害:特定のリモート PE に対する LSP のモニタリング(自動化 LSP-Ping の使用など)および LSP 障害時に、関連付けられたすべてのサービス インスタンスに対してアップリンク障害を宣言します。

PE 分離:PE の物理コア側インターフェイスのモニタリング。これらのインターフェイスのすべてがダウンすると、PE は事実上コア ネットワークから分離され、影響を受けるすべてのサービス インスタンスに対してアップリンク障害が宣言されます。

IP/MPLS ネットワークが、MPLS Fast ReRoute(FRR)などのネイティブ冗長メカニズムおよび復元力メカニズムを採用している限りは、PE 分離からの保護を提供するには mLACP ソリューションで充分です。疑似ワイヤ、LSP、および IP パス障害は、ネイティブ IP/MPLS 保護手順によって管理されます。つまり、mLACP を介したシャーシ間フェールオーバーは、ネイティブ IP/MPLS 保護メカニズムが無効にされるため、PE がコア ネットワークから完全に分離した場合にのみトリガーされます。そのため、障害ポイント E は、コア ネットワークからの PE 分離を示すために使用されます。


) モニタリングが必要な core-facing インターフェイスの集合は、明示的な設定により識別されます。core-facing インターフェイスの集合は、冗長グループごとに個別に定義される必要があります。障害ポイント E は、障害ポイント A、B、C とは異なり、特定の PoA 上に設定されたすべてのマルチシャーシ LAG に対するフェールオーバーに影響し、フェールオーバーをトリガーします。


動作可能なバリアント

LACP には、デバイス間にリンク冗長性を提供するため、LAG 内の 1 つ以上のリンクの集合がスタンバイ モードで設定されるメカニズムが備わっています。この冗長性は、通常、(ハードウェアまたはソフトウェアの制限、あるいは設定の制限により)デバイスが特定の LAG に集約できるリンク数よりも多くのポートを同じキーで設定することで実現します。アクティブ/スタンバイ冗長性の場合、2 つのポートが同じポート キーで設定され、LAG で使用できるリンクの最大数は 1 に設定されます。DHD および PoA が、設定によって LAG ごとのリンク数をすべて制限できる場合、次の 3 つの動作可能なバリアントが使用できます。

DHD ベース コントロール

DHD はバンドルごとの最大リンク数を 1 に制限するように設定されますが、PoA は、この数を 1 よりも大きい値に制限するように設定されます。したがって、アクティブ/スタンバイ リンクの選択は DHD が担当します。アクティブに指定されるリンクとスタンバイに指定されるリンクは、プライオリティの高いシステムに設定した相対的なポート プライオリティにより異なります。プライオリティの高いシステムに設定された PoA が、引き続き選択の結果を決定できます。DHD は選択を行い、ポートのプライオリティが低いリンクをスタンバイ モードに設定します。

DHD コントロール フェールオーバーに対応するには、DHD をリンク数(L)と等しい max-bundle 値で設定する必要があります。L は、DHD を PoA に接続しているリンクの最小数です。max-bundle 値は、リンクのバンドルから両方の PoA まで、DHD を同時に制限(アクティブ/アクティブ)します。DHD はアクティブ/スタンバイ リンクの選択を制御しますが、PoA は、DHD のシステム プライオリティより低いプライオリティ値で、PoA の仮想 LACP インスタンスを設定することにより、引き続き個々のメンバ リンク プライオリティを決定できます。

DHD コントロール バリアントは、PoA の最小リンクしきい値障害ポリシーと組み合わせて使用する必要があります。しきい値は L(上記の例で説明したものと同じ)に設定されます。最小リンクしきい値は、PoA ごとに設定される必要があります。フェールオーバーがトリガーされない(最小リンクしきい値は満たされています)A リンク障害、B リンク障害、または C リンク障害により、DHD が、スタンバイ PoA に送信するスタンバイ リンクのうち 1 つをバンドルに追加するためです。こうして追加されたリンクにより、サポート対象外のアクティブ/アクティブ シナリオが発生します。


) DHD コントロールは、スタンバイ PoA で、他のバリアントよりもフェールオーバー回数が多い mLACP ホット スタンバイ状態を使用しません。


DHD コントロールは、DHD がすべてのリンクをバンドルしようとすることを制限し、接続回線側でのスプリット ブレイン問題を排除します。

PoA コントロール

PoA コントロールでは、PoA はバンドルごとの最大リンク数を、PoA に送信するリンク数(L)と等しくなるように設定します。DHD は、そのパラメータ セットを使用して L よりも大きいいずれかの値に設定されます。したがって、アクティブ/スタンバイ リンクの選択は PoA が担当します。

共有コントロール(PoA および DHD)

共有コントロールでは、DHD と PoA の両方はバンドルごとの最大リンク数を、PoA に送信するリンク数(L)に制限するように設定されます。この設定では、各デバイスがアクティブ/スタンバイ リンクを個別に選択します。共有コントロールは、DHD コントロールと同じ方法でスプリット ブレイン問題を制限するという点で有利です。共有コントロールは、DHD コントロールで普及しているアクティブ/アクティブ傾向には影響されません。共有コントロールの不利な点は、フェールオーバー時間が DHD と PoA の両方で決定されるという点です。それぞれがスタンバイ リンクを SELECTED に変え、リンクが IN_SYNC に移行する前に各 WAIT_WHILE_TIMER の期限が切れるのを待機します。フェールオーバー時間とリンク状態の変更を個別に決定することは、1 秒よりも短いフェールオーバー時間を提供するために、DHD と PoA の両方が LACP ファスト スイッチオーバー機能をサポートする必要があることを意味します。

mLACP フェールオーバー

mLACP は次の障害のいずれかが発生した場合、PoA フェールオーバーをスタンバイ PoA に強制的に変更します。

DHD アップリンク ポート、イーサネット リンク、またはアクティブ PoA 上のダウンリンク ポートの障害:ポリシー フェールオーバーが設定済みのフェールオーバー ポリシー経由でトリガーされ、強制フェールオーバーと見なされます。Cisco IOS Release 12.2(33)SRE では、設定済み最小バンドルしきい値が唯一のオプションです。アクティブ PoA へのアクティブ リンクおよび SELECTED リンクの数が、設定済みの最小しきい値を下回ると、mLACP は、スタンバイ PoA のメンバ リンクへのフェールオーバーを強制します。この最小しきい値は、インターフェイス コンフィギュレーション モードで port-channel min-links コマンドを使用して設定されます。PoA は、使用中の操作コントロール バリアントから独立してフェールオーバーを決定します。

アクティブ PoA の障害:この障害はスタンバイ PoA により検出されます。スタンバイ PoA 上の mLACP に、ICRM を経由した障害が通知され、そのローカル メンバ リンクが発生するため、mLACP は自動的にスタンバイ側にフェールオーバーされます。DHDコントロール バリアントでは、この障害は、合計メンバのリンク障害と同じように見えます。また、DHD はスタンバイ リンクをアクティブにします。

アクティブ PoA アップリンクの障害:mLACP は、PE 分離の ICRM によって通知され、そのアクティブ メンバ リンクを解放します。この障害は、「強制フェールオーバー」で、使用中の操作コントロール バリアントから独立した PoA により決定されます。

ダイナミック ポート プライオリティ

デフォルトのフェールオーバー メカニズムは、LACP の選択ロジックで、必要なスタンバイ リンクを SELECTED 状態および Collecting_Distributing 状態へ移行する場合、ローカル メンバ リンク上のダイナミック ポート プライオリティの変更を使用します。この状態の変更は、現在のアクティブ PoA にあるすべての対象メンバ リンクの LACP アクター ポート プライオリティ値が、スタンバイ PoA のポート プライオリティ(スタンバイ PoA のポートに、リンクをバンドルするためにより高い要求を付与する)よりも高い数値に変更されたときに発生します。アクター ポート プライオリティを変更すると、冗長グループ内のすべてのピアに対して mLACP Port Config Type-Length-Value(TLV)メッセージを送信します。これらのメッセージは、現在のアクティブ PoA がそのロールを解放しようとするスタンバイの PoA への通知としても機能します。次に、LACP はスタンバイ リンクを SELECTED 状態に移行し、現在アクティブなすべてのリンクを STANDBY に移行します。

ダイナミック ポート プライオリティの変更は、実行設定または NVRAM 設定に対して自動的に書き出されません。システムのリロード時に現在のプライオリティを使用する場合は、 mlacp lag-priority コマンドを使用し、設定を保存する必要があります。

リバーティブ モードと非リバーティブ モード

ダイナミック ポート プライオリティ機能は、リバーティブ モードと非リバーティブ モードの両方を提供するため、mLACP 機能によって使用されます。デフォルトの動作は、単一シャーシ LACP でのデフォルトであるリバーティブです。 lacp failover non-revertive コマンドをインターフェイス コンフィギュレーション モードで使用することにより、ポート チャネル ベースごとに、非リバーティブ モードをイネーブルにできます。Cisco IOS Release 12.2(33)SRE では、このコマンドは mLACP でのみサポートされます。

フェールオーバーの制限に非リバーティブ モードが使用され、トラフィックの損失が発生する可能性があります。ダイナミック ポート プライオリティの変更は、新たにアクティブになった PoA が、障害の発生した PoA が回復した後でも引き続きアクティブであることを確認するために使用されます。

リバーティブ モード操作により、設定済みのプライマリ PoA が障害から回復した後に、この PoA を強制的にアクティブ状態に戻します。ダイナミック ポート プライオリティの変更は、回復中の PoA がそのアクティブ ロールを再開できるようにするために必要なときに使用されます。

ブルートフォース シャットダウン

ブルートフォース シャットダウンは強制フェールオーバー メカニズムで、アクティブ ステータスを放棄する PoA 上の特定の LAG に対するアクティブな物理的メンバ リンク インターフェイスを終了させます。このメカニズムは、ダイナミック ポート プライオリティの変更を管理する DHD の機能に依存せず、DHD の LACP 実装の不備を補償するものです。

ブルートフォース シャットダウンは、個々のメンバ リンクのステータスを ADMIN_DOWN に変更し、スタンバイ リンクのアクティブ状態への移行を強制します。このプロセスにより、リンク状態をモニタするためのローカル LACP の実装環境の機能が排除されます。

ブルートフォース シャットダウンはリバーティブ モードで動作するため、ダイナミック ポート プライオリティはアクティブ選択のコントロールに使用できません。ブルートフォース アプローチは、インターフェイス コンフィギュレーション モードで lacp failover brute-force コマンドによって設定されます。このコマンドは、非リバーティブ設定とは併用できません。

シャーシ間冗長マネージャを使用したピア モニタリング

ピアが Interchassis Redundancy Manager(ICRM; シャーシ間冗長マネージャ)を使用してモニタする方法は次の 2 つがあります。

Routewatch(RW):この方式がデフォルトです。

Bidirectional Forwarding Detection(BFD;双方向フォワーディング検出):冗長グループは monitor peer bfd コマンドを指定して設定する必要があります。


) Stateful SwitchOver(SSO; ステートフル スイッチオーバー)導入(シャーシでの冗長サポートあり)の場合、SSO フェールオーバー後のスプリット ブレインを回避するには、BFD モニタリングと ICCP 接続のスタティック ルートが必要です。Routewatch は、ヘルス モニタに関して、SSO と互換性がありません。


冗長グループのピア(メンバ IP)ごとに、モニタリング隣接関係が作成されます。IP アドレスが同じピアが 2 つある場合、隣接関係はモニタリング モードに関わらず共有されます。たとえば、冗長グループ 1 と 2 がメンバ IP 10.10.10.10 と対になっていると、両方の冗長グループで共有される 10.10.10.10 への隣接関係のみが存在します。さらに、冗長グループ 2 が RW を使用している間は、冗長グループ 1 は BFD モニタリングを使用できます。


) BFD は RW に完全に依存します。BFD モニタリングを開始するには、ICRM に対するピアへのルートが必要です。BFD では RW も行われるため、隣接関係のステータスが誤解されることがありますが、ステータスは正確に状態を示しています。また、ピア PoA へのルートが、システム間の直接接続(バックツーバック)リンクを経由していない場合、BFD によって誤った結果がもたらされる可能性があります。


show redundancy interface コマンドからの出力例は次のとおりです。

Router# show redundancy interface
 
Redundancy Group 1 (0x1)
Applications connected: mLACP
Monitor mode: Route-watch
member ip: 201.0.0.1 ‘mlacp-201’, CONNECTED
Route-watch for 201.0.0.1 is UP
mLACP state: CONNECTED
 
ICRM fast-failure detection neighbor table
IP Address Status Type Next-hop IP Interface
========== ====== ==== =========== =========
201.0.0.1 UP RW
 

show redundancy interchassis コマンドによって表示される隣接ステータスを理解するには、 表 1 を参照してください。

表 1 show redundancy interchassis コマンドのステータス情報

隣接タイプ
隣接ステータス
意味

RW

DOWN

RW または BFD が設定済みですが、指定された IP アドレスへのルートがありません。

RW

UP

RW または BFD が設定済みです。RW が実行中です。ピアへの有効なルートがあります。BFD が設定済みで、隣接ステータスが UP の場合、BFD はルートの隣接インターフェイスに設定されていない可能性があります。

BFD

DOWN

BFD が設定済みです。ルートが存在し、ルートの隣接は、BFD がイネーブルになっているインターフェイスに対して設定されています。BFD は開始されていますがピアがダウンしています。ピアが存在しないか、BFD がピアのインターフェイスに設定されていないため、DOWN ステータスの可能性があります。

BFD

UP

BFD が設定済みで動作可能です。


) 隣接タイプが「BFD」の場合は、BFD のステータスに関わらず、RW のステータスは UP となります。


MAC フラッシュ メカニズム

マルチポイント ブリッジ サービス(VPLS など)にマルチシャーシ冗長性を提供するために mLACP が使用される場合には、トラフィックがブラックホール化する可能性をなくすため、MAC フラッシュ通知メカニズムが必要です。

プライマリ PoA からセカンダリ PoA へのフェールオーバーで、問題のある DHD が非アクティブのままになっていて、ネットワーク エリア内の他のリモート デバイスが、この DHD にトラフィックを送信しようとしている間は、サービスでトラフィック ブロックが発生します。ネットワーク内のリモート ブリッジには、障害の発生した PoA を示す失効した MAC のエントリと、障害の発生した PoA への DHD を宛先とする直接トラフィックがあります。このトラフィックはドロップされます。このブラックホール化は、リモート デバイスが、失効した MAC アドレス テーブルのエントリをエージアウトするまで続行されます(通常、5 分かかります)。この例外事態が起きないようにするため、サービスを管理する新たにアクティブとなった PoA が、問題のあるサービスに対して失効した MAC アドレスのエントリをフラッシュするため、MAC フラッシュ通知メッセージをネットワーク内のリモート デバイスに送信します。

MAC フラッシュ メッセージの実際の形式は、ネットワーク トランスポート(ネイティブ 802.1Q/802.1ad イーサネット、ネイティブ 802.1ah イーサネット、VPLS、または VPLS を経由する Provider Backbone Bridge(PBB; プロバイダー バックボーン ブリッジ))の特性により異なります。さらに、802.1ah に関しては、Customer-MAC(C-MAC)アドレスのフラッシュと Bridge-MAC(B-MAC)アドレスのフラッシュに使用されるメカニズム間の違いを認識することが重要です。

さまざまなメカニズムの詳細は、次のセクションで説明します。

マルチ I-SID 登録プロトコル

Multiple I-SID Registration Protocol(MIRP)は、802.1ah サービス インスタンスでデフォルトでイネーブルになっています。802.1ah ネットワーク内での MIRP の使用を図 4 に示します。

図 4 802.1ah ネットワークにおけるトラフィックのブラックホール化

デバイス DHD1 は、2 つの 802.1ah バックボーン エッジ ブリッジ(BEB1 と BEB2)にデュアルホーム接続しています。当初のプライマリ パスは BEB1 経由であると想定しています。この構成では、BEB3 は、DHD1 の背後にあるホスト(MAC アドレスは CM1)は、宛先 B-MAC M1 を介して到達できることを学習しています。DHD1 と BEB1 間のリンクに障害が発生し、DHD1 の背後にあるホストが非アクティブのままになっていると、BEB3 の MAC キャッシュ テーブルは、新規のパス ビューが B-MAC アドレスが M2 の BEB2 経由であっても、BEB1 の MAC アドレスを引き続き参照します。DHD2 の背後にあるホストから DHD1 の背後にあるホストに転送されたブリッジ トラフィックは、誤って B-MAC M1 でカプセル化され、MAC トンネルを経由して BEB1 に送信されて、トラフィックがブラックホール化しています。

DHD1 と BEB1 間のリンクに障害が発生した場合にトラフィックのブラックホール化問題が起きないようにするため、BEB2 は次の 2 つのタスクを実行します。

問題あるサービスに対して固有の MAC アドレス テーブルをフラッシュします。

MAC アドレス テーブルをフラッシュする遠端の BEB(BEB3)に通知するため、アップリンクで MIRP メッセージを送信します。MIRP メッセージは、Backbone Core Bridge(BCB; バックボーン コア ブリッジ)では認識されないことに注意してください。MIRP メッセージは BEB 上で処理されます。BCB だけが B-MAC アドレスに基づいた取得と転送を行っており、C-MAC アドレスでは認識されないためです。


) MIRP は、ネイティブ 802.1ah と VPLS 経由の PBB の両方に C-MAC アドレス フラッシュをトリガーします。


図 5 に MIRP の動作を示します。

図 5 802.1ah ネットワークにおける C-MAC フラッシュのための MIRP の動作

MIRP は IEEE で定義されていませんが、IEEE 802.1ak Multiple Registration Protocol(MRP)に基づいていると予想されます。RP は、汎用アトリビュートの登録のため、複雑な Finite State Machine(FSM; 有限状態マシン)を維持します。MIRP の場合、アトリビュートは I-SID です。したがって、MIRP は、I-SID マルチキャスト ツリーごとに構築と削除を行う BEB 向けメカニズムを提供します。MIRP の C-MAC フラッシュ通知機能は、アトリビュート登録の特殊なケースです。MIRP の宣言が「新規」であること、つまり BEB が特定の I-SID で関心を宣言した最初の通知であることを、デバイスが示しています。

LDP MAC アドレス回収

mLACP 機能が、(VPLS 経由の PBB でない)従来の VPLS で、PE 冗長性に使用される場合、MAC フラッシュ メカニズムは、RFC 4762 で定義された LDP MAC アドレス回収メッセージに基づきます。

必要な機能上の動作は次のとおりです。プライマリ PoA からスタンバイ PoA へのフェールオーバーで、スタンバイ PoA は影響を受けるサービスのローカル MAC アドレス テーブルをフラッシュし、LDP MAC アドレス回収メッセージを生成して、リモート PE に対し、その固有の MAC アドレス テーブルのフラッシュを通知します。影響を受ける Virtual Forwarding Instance(VFI; 仮想転送インスタンス)での疑似ワイヤごとに 1 つのメッセージが生成されます。

mLACP の設定方法

「シャーシ間グループ コマンドと基本的 mLACP コマンドの設定」(必須)

「mLACP シャーシ間グループ コマンドと他のポート チャネル コマンドの設定」

「VPWS の冗長性の設定」

「VPLS の冗長性の設定」

「階層型 VPLS の設定」

「mLACP のトラブルシューティング」(任意)

シャーシ間グループ コマンドと基本的 mLACP コマンドの設定

複数の PoA 間の通信を設定し、それら PoA を同じグループに設定するには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. redundancy

4. interchassis group group-id

5. monitor peer bfd

6. member ip ip-address

7. mlacp node-id node-id

8. mlacp system-mac mac-address

9. mlacp system-priority priority-value

10. backbone interface type number

11. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 4

interchassis group group-id

 

Router(config-red)# interchassis group 50

冗長コンフィギュレーション モードでシャーシ間グループを設定し、CLI をシャーシ間冗長モードにします。

ステップ 5

monitor peer bfd

 

Router(config-r-ic)# monitor peer bfd

ピアの状態をモニタするための BFD オプションを設定します。デフォルトのオプションは route-watch です。

ステップ 6

member ip ip-address

 

Router(config-r-ic)# member ip 172.3.3.3

mLACP ピア メンバ グループの IP アドレスを設定します。

ステップ 7

mlacp node-id node-id

 

Router(config-r-ic)# mlacp node-id 5

mLACP 冗長グループのこのメンバによって、LACP ポート ID フィールドで使用するノード ID を定義します。

有効な範囲は 0 から 7 で、値はピアの値と異なっている必要があります。

ステップ 8

mlacp system-mac mac-address

 

Router(config-r-ic)# mlacp system-mac aa12.be45.d799

冗長グループの mLACP メンバに、アービトレーション用のシステム MAC アドレス値を定義してアドバタイズします。

mac-address 引数のフォーマットは、MAC アドレス標準フォーマット(aabb.ccdd.eeff)にする必要があります。

ステップ 9

mlacp system-priority priority-value

 

Router(config-r-ic)# mlacp system-priority 100

冗長グループの他の mLACP メンバにアドバタイズされるシステム プライオリティを定義します。

システム プライオリティの値は 1 ~ 65535 です。デフォルト値は 32768 です。

割り当てる値は DHD よりも小さくする必要があります。

ステップ 10

backbone interface type number

 

Router(config-r-ic)# backbone interface GigabitEthernet2/3

mLACP コンフィギュレーションのバックボーン インターフェイス設定を定義します。

ステップ 11

end

 

Router(config-r-ic)# end

CLI を特権 EXEC モードに戻します。

mLACP シャーシ間グループ コマンドと他のポート チャネル コマンドの設定

ポート チャネル固有の mLACP アトリビュートを設定するには、次のタスクを実行します。 mlacp interchassis group シャーシ間グループ コマンドは、ポート チャネル インターフェイスを前の「シャーシ間グループ コマンドと基本的 mLACP コマンドの設定」で作成したシャーシ間グループにリンクします。

手順の概要

1. enable

2. configure terminal

3. interface port-channel port-channel-number

4. lacp max-bundle max-bundles

5. lacp failover { brute-force | non-revertive }

6. exit

7. redundancy

8. interchassis group group-id

9. exit

10. exit

11. errdisable recovery cause mlacp-minlink

12. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel port-channel- number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

lacp max-bundle max-bundles

 

Router(config-if)# lacp max-bundle 4

PoA に接続する max-bundle リンクを設定します。max-bundles 引数の値は、PoA に接続している LAG 内のリンクの総数よりも小さくする必要があります。

冗長グループが、DHD コントロール、PoA コントロール、またはこの両方に含まれるかどうかを決定します。

値の範囲は 1 ~ 8 です。デフォルト値は 8 です。

ステップ 5

lacp failover { brute-force | non-revertive }

 

Router(config-if)# lacp failover brute-force

mLACP スイッチオーバーを非リバーティブまたはブルートフォースに設定します。このコマンドはオプションです。

デフォルト値はリバーティブ(180 秒の遅延あり)です。

ブルートフォースを設定した場合、各 mLACP 障害に対して最小リンク障害が発生するか、ダイナミック ラグ プライオリティの値が変更されます。

ステップ 6

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 8

interchassis group group-id

 

Router(config-red)# interchassis group 230

ポート チャネルが mLACP ポート チャネルであることを指定します。 group-id は設定済みの冗長グループと一致している必要があります。

ステップ 9

exit

 

Router(config-r-ic)# exit

シャーシ間冗長コンフィギュレーション モードを終了します。

ステップ 10

exit

 

Router(config-red)# exit

冗長コンフィギュレーション モードを終了します。

ステップ 11

errdisable recovery cause mlacp-minlink

 

Router(config)# errdisable recovery cause mlacp-minlink

ポート チャネルのフェールオーバー状態からの自動リカバリをイネーブルにします。

ステップ 12

end

 

Router(config)# end

CLI を特権 EXEC モードに戻します。

VPWS の冗長性の設定

レイヤ 2 VPN サービス冗長性を提供するには、このタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class pw-class-name

4. encapsulation mpls

5. status peer topology dual-homed

6. exit

7. interface port-channel port-channel-number

8. no ip address

9. lacp fast-switchover

10. lacp max-bundle max-bundles

11. exit

12. redundancy

13. interchassis group group-id

14. exit

15. exit

16. interface port-channel port-channel-number

17. service instance id ethernet [ evc-name ]

18. encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

19. exit

20. xconnect peer-ip-address vc-id { encapsulation mpls | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

21. backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ] [ priority value ]

22. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class pw-class-name

 

Router(config)# pseudowire-class ether-pw

レイヤ 2 疑似ワイヤ クラスの名前を指定し、疑似ワイヤ クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

疑似ワイヤを経由したレイヤ 2 トラフィックのトンネリングに MPLS がデータ カプセル化方式として使用されることを指定します。

ステップ 5

status peer topology dual-homed

 

Router(config-pw-class)# status peer topology dual-homed

接続回線ステータスの反映を、プライマリ疑似ワイヤとセカンダリ疑似ワイヤの両方でイネーブルにします。この状態は、ピア PE がデュアルホーム接続デバイスに接続している場合に必要です。

ステップ 6

exit

 

Router(config-pw-class)# exit

疑似ワイヤ クラス コンフィギュレーション モードを終了します。

ステップ 7

interface port-channel port-channel-number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

no ip address

 

Router(config-if)# no ip address

VLAN インターフェイスに IP アドレスを割り当てないことを指定します。

ステップ 9

lacp fast-switchover

 

Router(config-if)# lacp fast-switchover

LACP の 1 対 1 のリンク冗長性をイネーブルにします。

ステップ 10

lacp max-bundle max-bundles

 

Router(config-if)# lacp max-bundle 4

PoA に接続する max-bundle リンクを設定します。max-bundles 引数の値は、PoA に接続している LAG 内のリンクの総数よりも小さくする必要があります。

冗長グループが、DHD コントロール、PoA コントロール、またはこの両方に含まれるかどうかを決定します。

値の範囲は 1 ~ 8 です。デフォルト値は 8 です。

ステップ 11

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 12

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 13

interchassis group group-id

 

Router(config-red)# interchassis group 230

ポート チャネルが mLACP ポート チャネルであることを指定します。

group-id は設定済みの冗長グループと一致している必要があります。

ステップ 14

exit

 

Router(config-r-ic)# exit

シャーシ間冗長コンフィギュレーション モードを終了します。

ステップ 15

exit

 

Router(config-red)# exit

冗長コンフィギュレーション モードを終了します。

ステップ 16

interface port-channel port-channel-number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 17

service instance id ethernet [ evc-name ]

 

Router(config-if)# service instance 1 ethernet

イーサネット サービス インスタンスを設定します。

ステップ 18

encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

 

Router(config-if-srv)# encapsulation dot1q 100

VLAN の指定されたサブインターフェイス上で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

ステップ 19

exit

 

Router(config-if-srv)# exit

サービス インスタンス コンフィギュレーション モードを終了します。

ステップ 20

xconnect peer-ip-address vc-id { encapsulation mpls | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

 

Router(config-if)# xconnect 10.0.3.201 123 pw-class ether-pw

接続回線を疑似ワイヤにバインドします。

ステップ 21

backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ] [ priority value ]

 

Router(config-if)# backup peer 10.1.1.1 123 pw-class ether-pw

疑似ワイヤ仮想回線用に冗長ピアを指定します。

ステップ 22

end

 

Router(config-if)# end

CLI を特権 EXEC モードに戻します。

VPLS の冗長性の設定

ここでは、VPLS の結合モードと分離モードについて簡単に説明し、VPLS の冗長性を設定する手順を説明します。

VPLS の結合モードと分離モード

VPLS は、結合モードにも分離モードにも設定できます。VFI で 1 つ以上の接続回線の状態がアクティブに変わると結合モードとなり、VFI のすべての疑似ワイヤの状態がアクティブになります。VFI のすべての接続回線の状態がスタンバイに変わると、VFI のすべての疑似ワイヤの状態がスタンバイ モードになります。図 6 を参照してください。

図 6 VPLS 結合モードの状態

VFI のすべての疑似ワイヤが常にアクティブであると、VPLS は分離モードになり、接続回線の状態は疑似ワイヤの状態と無関係です。このモードでは、プラットフォームが疑似ワイヤ ステータス機能をサポートしない場合、スイッチオーバーにかかる時間が短くなりますが、スタンバイ状態の接続回線のある PE で、余分なフラッディングとマルチキャスト トラフィックがドロップされます。図 7 を参照してください。

図 7 VPLS 分離モードの状態

VPLS の冗長性の設定手順

VPLS の冗長性を設定するには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. l2 vfi name manual

4. vpn id vpn-id

5. status decoupled (任意)

6. neighbor neighbor ip-address vc-id { encapsulation mpls | pw-class pw-class-name }

7. exit

8. interface port-channel port-channel-number

9. no ip address

10. lacp fast-switchover

11. lacp max-bundle max-bundles

12. exit

13. redundancy

14. interchassis group group-id

15. exit

16. exit

17. interface port-channel port-channel-number

18. service instance id ethernet [ evc-name ]

19. encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

20. bridge-domain bridge-id [ split-horizon [ group group-id ]]

21. exit

22. interface vlan vlanid

23. no ip address

24. xconnect vfi vfi-name

25. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l2 vfi name manual

 

Router(config)# l2 vfi vfi1 manual

2 つの独立したネットワーク間にレイヤ 2 VFI を確立し、VFI コンフィギュレーション モードを開始します。

ステップ 4

vpn id vpn-id

 

Router(config-vfi)# vpn id 100

VPN routing and forwarding(VRF)インスタンスに Virtual Private Network(VPN; バーチャル プライベート ネットワーク)ID を設定または更新します。

ステップ 5

status decoupled

 

Router(config-vfi)# status decoupled

(任意)分離モードをイネーブルにします。user-facing Provider Edge(uPE; ユーザ側プロバイダー エッジ)上の接続回線の状態は、疑似ワイヤの状態と無関係になります。mLACP が接続回線の状態をコントロールします。

ステップ 6

neighbor neighbor ip-address vc-id { encapsulation mpls | pw-class pw-class-name }

 

Router(config-vfi)# neighbor 10.1.1.1 50 encapsulation mpls

VFI 接続を形成する必要のあるルータを指定します。

ネイバーごとにこのコマンドを繰り返します。

ステップ 7

exit

 

Router(config-vfi)# exit

VFI コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel- number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

no ip address

 

Router(config-if)# no ip address

VLAN インターフェイスに IP アドレスを割り当てないことを指定します。

ステップ 10

lacp fast-switchover

 

Router(config-if)# lacp fast-switchover

LACP の 1 対 1 のリンク冗長性をイネーブルにします。

ステップ 11

lacp max-bundle max-bundles

 

Router(config-if)# lacp max-bundle 2

PoA に接続する max-bundle リンクを設定します。max-bundles 引数の値は、PoA に接続している LAG 内のリンクの総数よりも小さくする必要があります。

冗長グループが、DHD コントロール、PoA コントロール、またはこの両方に含まれるかどうかを決定します。

値の範囲は 1 ~ 8 です。デフォルト値は 8 です。

ステップ 12

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 13

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 14

interchassis group group-id

 

Router(config-red)# interchassis group 230

ポート チャネルが mLACP ポート チャネルであることを指定します。

group-id は設定済みの冗長グループと一致している必要があります。

ステップ 15

exit

 

Router(config-r-ic)# exit

シャーシ間冗長コンフィギュレーション モードを終了します。

ステップ 16

exit

 

Router(config-red)# exit

冗長コンフィギュレーション モードを終了します。

ステップ 17

interface port-channel port-channel- number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 18

service instance id ethernet [ evc-name ]

 

Router(config-if)# service instance 1 ethernet

イーサネット サービス インスタンスを設定し、イーサネット サービス コンフィギュレーション モードを開始します。

ステップ 19

encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

 

Router(config-if-srv)# encapsulation dot1q 100

VLAN の指定されたサブインターフェイス上で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

ステップ 20

bridge-domain bridge-id [ split-horizon [ group group-id ]]

 

Router(config-if-srv)# bridge-domain 200

ブリッジ ドメインを設定します。サービス インスタンスをブリッジ ドメインにバインドします。 domain-number はブリッジ ドメインの ID です。

ステップ 21

exit

 

Router(config-if-srv)# exit

サービス インスタンス コンフィギュレーション モードを終了します。

ステップ 22

interface vlan vlanid

 

Router(config-if)# interface vlan 200

ダイナミック Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)を作成します。

ステップ 23

no ip address

 

Router(config-if)# no ip address

VLAN インターフェイスに IP アドレスを割り当てないことを指定します。

ステップ 24

xconnect vfi vfi-name

 

Router(config-if)# xconnect vfi vfi-16

VLAP ポートにバインドするレイヤ 2 VFI を指定します。

ステップ 25

end

 

Router(config-if)# end

CLI を特権 EXEC モードに戻します。

階層型 VPLS の設定

Hierarchical VPLS(H-VPLS; 階層型 VPLS)を設定するには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. pseudowire-class pw-class-name

4. encapsulation mpls

5. status peer topology dual-homed

6. status decoupled (任意)

7. exit

8. interface port-channel port-channel-number

9. no ip address

10. lacp fast-switchover

11. lacp max-bundle max-bundles

12. exit

13. redundancy

14. interchassis group group-id

15. exit

16. exit

17. interface port-channel port-channel-number

18. service instance id ethernet [ evc-name ]

19. encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

20. exit

21. xconnect peer-ip-address vc-id { encapsulation mpls | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

22. backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ] [ priority value ]

23. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

pseudowire-class pw-class-name

 

Router(config)# pseudowire-class ether-pw

レイヤ 2 疑似ワイヤ クラスの名前を指定し、疑似ワイヤ クラス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation mpls

 

Router(config-pw-class)# encapsulation mpls

疑似ワイヤを経由したレイヤ 2 トラフィックのトンネリングに MPLS がデータ カプセル化方式として使用されることを指定します。

ステップ 5

status peer topology dual-homed

 

Router(config-pw-class)# status peer topology dual-homed

接続回線ステータスの反映を、プライマリ疑似ワイヤとセカンダリ疑似ワイヤの両方でイネーブルにします。この設定は、ピア PE がデュアルホーム接続デバイスに接続されている場合に必要です。

ステップ 6

status decoupled

 

Router(config-pw-class)# status decoupled

(任意)分離モードをイネーブルにします。uPE 上の接続回線の状態は、疑似ワイヤの状態と無関係になります。mLACP が接続回線の状態をコントロールします。

ステップ 7

exit

 

Router(config-pw-class)# exit

疑似ワイヤ クラス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel- number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

no ip address

 

Router(config-if)# no ip address

VLAN インターフェイスに IP アドレスを割り当てないことを指定します。

ステップ 10

lacp fast-switchover

 

Router(config-if)# lacp fast-switchover

LACP の 1 対 1 のリンク冗長性をイネーブルにします。

ステップ 11

lacp max-bundle max-bundles

 

Router(config-if)# lacp max-bundle 4

PoA に接続する max-bundle リンクを設定します。max-bundles 引数の値は、PoA に接続している LAG 内のリンクの総数よりも小さくする必要があります。

冗長グループが、DHD コントロール、PoA コントロール、またはこの両方に含まれるかどうかを決定します。

値の範囲は 1 ~ 8 です。デフォルト値は 8 です。

ステップ 12

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 13

redundancy

 

Router(config)# redundancy

冗長コンフィギュレーション モードを開始します。

ステップ 14

interchassis group group-id

 

Router(config-red)# interchassis group 230

ポート チャネルが mLACP ポート チャネルであることを指定します。

group-id は設定済みの冗長グループと一致している必要があります。

ステップ 15

exit

 

Router(config-r-ic)# exit

シャーシ間冗長コンフィギュレーション モードを終了します。

ステップ 16

exit

 

Router(config-red)# exit

冗長コンフィギュレーション モードを終了します。

ステップ 17

interface port-channel port-channel- number

 

Router(config)# interface port-channel1

ポート チャネルを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 18

service instance id ethernet [ evc-name ]

 

Router(config-if)# service instance 1 ethernet

イーサネット サービス インスタンスを設定し、イーサネット サービス コンフィギュレーション モードを開始します。

ステップ 19

encapsulation dot1q vlan-id [ , vlan-id [ - vlan-id ]] [ native ]

 

Router(config-if-srv)# encapsulation dot1q 100

VLAN の指定されたサブインターフェイス上で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

ステップ 20

exit

 

Router(config-if-srv)# exit

サービス インスタンス コンフィギュレーション モードを終了します。

ステップ 21

xconnect peer-ip-address vc-id { encapsulation mpls | pw-class pw-class-name } [ pw-class pw-class-name ] [ sequencing { transmit | receive | both }]

 

Router(config-if)# xconnect 10.0.3.201 123 pw-class vlan-xconnect

接続回線を疑似ワイヤにバインドし、Any Transport over MPLS(AToM)スタティック疑似ワイヤを設定します。

ステップ 22

backup peer peer-router-ip-addr vcid [ pw-class pw-class-name ] [ priority value ]

 

Router(config-if)# backup peer 10.1.1.1 123 pw-class ether-pw

疑似ワイヤ仮想回線用に冗長ピアを指定します。

ステップ 23

end

 

Router(config-if)# end

CLI を特権 EXEC モードに戻します。

mLACP のデバッグ

一般的な mLACP のトラブルシューティングには、次の debug コマンドを使用します。

手順の概要

1. enable

2. debug redundancy interchassis { all | application | error | event | monitor }

3. debug mpls ldp iccp

4. debug lacp [ all | event | fsm | misc | multi-chassis [ all | database | lacp-mgr | redundancy-group | user-interface ] | packet ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug redundancy interchassis { all | application | error | event | monitor }

 
Router# debug redundancy interchassis all

シャーシ間冗長マネージャのデバッグをイネーブルにします。

ステップ 3

debug mpls ldp iccp

 
Router# debug mpls ldp iccp

InterChassis Control Protocol(ICCP)のデバッグをイネーブルにします。

ステップ 4

debug lacp [ all | event | fsm | misc | multi-chassis [ all | database | lacp-mgr | redundancy-group | user-interface ] | packet ]

 
Router# debug lacp multi-chassis all

LACP アクティビティのデバッグをイネーブルにします。

このコマンドはスイッチ プロセッサで実行されます。

接続回線または EVC での mLACP のデバッグ

接続回線または EVC で mLACP をトラブルシューティングするには、次の debug コマンドを使用します。

手順の概要

1. enable

2. debug acircuit { checkpoint | error | event }

3. debug ethernet service { all | api | error | evc [ evc-id ] | ha | instance [ id id | interface type number | qos ] | interface type number | microblock | oam-mgr }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug acircuit { checkpoint | error | event }

 
Router# debug acircuit event

PE ルータと CE ルータ間の接続回線で発生するチェックポイント、エラー、およびイベントを表示します。

ステップ 3

debug ethernet service { all | api | error | evc [ evc-id ] | ha | instance [ id id | interface type number | qos ] | interface type number | microblock | oam-mgr }

 
Router# debug ethernet service all

イーサネット カスタマー サービス インスタンスをイネーブルにします。

AToM 疑似ワイヤでの mLACP のデバッグ

AToM 疑似ワイヤで mLACP をトラブルシューティングするには、 debug mpls l2transport vc コマンドを使用します。

手順の概要

1. enable

2. debug mpls l2transport vc { event | fsm | ldp | sss | status { event | fsm }}

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug mpls l2transport vc { event | fsm | ldp | sss | status { event | fsm }}

 
Router# debug mpls l2transport status event

AToM Virtual Circuit(VC; 仮想回線)のステータスに関する情報を表示します。

相互接続、冗長マネージャ、およびセッション セットアップのデバッグ

次の debug コマンドを使用して、相互接続、冗長マネージャ、およびセッション セットアップのトラブルシューティングを行います。

手順の概要

1. enable

2. debug sss error

3. debug sss event

4. debug xconnect { error | event }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug sss error

 
Router# debug sss error

Subscriber Service Switch(SSS)コール セットアップ中に発生する可能性のあるエラーに関する情報を表示します。

ステップ 3

debug sss events

 
Router# debug sss event

SSS コール セットアップ イベントに関する診断情報を表示します。

ステップ 4

debug xconnect { error | event }

 
Router# debug xconnect event

相互接続設定に関連するエラーまたはイベントを表示します。

VFI のデバッグ

VFI をトラブルシューティングするには debug vfi コマンドを使用します。

手順の概要

1. enable

2. debug vfi { checkpoint | error | event | fsm { error | event }}

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug vfi { checkpoint | error | event | fsm { error | event }}

 
Router# debug vfi checkpoint

VFI に関するチェックポイント情報を表示します。

セグメント スイッチング マネージャ(スイッチング セットアップ)のデバッグ

Segment Switching Manager(SSM; セグメント スイッチング マネージャ)をトラブルシューティングするには debug ssm コマンドを使用します。

手順の概要

1. enable

2. debug ssm { cm errors | cm events | fhm errors | fhm events | sm errors | sm events | sm counters | xdr }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug ssm { cm errors | cm events | fhm errors | fhm events | sm errors | sm events | sm counters | xdr }

 
Router# debug ssm cm events

スイッチド レイヤ 2 セグメントの SSM に関する情報を表示します。

mLACP でのハイ アベイラビリティ機能のデバッグ

mLACP でのハイ アベイラビリティ機能をトラブルシューティングするには、次の debug コマンドを使用します。

手順の概要

1. enable

2. debug mpls l2transport checkpoint

3. debug acircuit checkpoint

4. debug vfi checkpoint

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug mpls l2transport checkpoint

 
Router# debug mpls l2transport checkpoint

AToM が NonStop Forwarding/Stateful SwitchOver(NSF/SSO)およびグレースフル リスタート用に設定されている場合、AToM イベントの表示をイネーブルにします。

ステップ 3

debug acircuit checkpoint

 
Router# debug acircuit checkpoint

AToM が NSF/SSO およびグレースフル リスタート用に設定されている場合、接続回線イベントの表示をイネーブルにします。

ステップ 4

debug vfi checkpoint

 
Router# debug vfi checkpoint

AToM が NSF/SSO およびグレースフル リスタート用に設定されている場合、VFI イベントの表示をイネーブルにします。

mLACP の設定例

「例:VPWS の設定」

「例:VPLS の設定」

「例:H-VPLS の設定」

「例:アクティブ PoA での VPWS の確認」

「例:スタンバイ PoA での VPWS の確認」

「例:アクティブ PoA での VPLS の確認」

「例:スタンバイ PoA での VPLS の確認」

例:VPWS の設定

次に、2 つの VPWS の設定例を示します。1 つはアクティブ PoA の例で、もう 1 つはスタンバイ PoA の例です。

図 8 に VPWS 設定のサンプル トポロジを示します。

図 8 双方向疑似ワイヤ冗長性を持つ mLACP

VPWS のアクティブ PoA

次の VPWS のサンプル設定は、アクティブ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
mode sso
interchassis group 1
member ip 201.0.0.1
backbone interface Ethernet0/2
backbone interface Ethernet1/2
backbone interface Ethernet1/3
monitor peer bfd
mlacp node-id 0
!
pseudowire-class mpls-dhd
encapsulation mpls
status peer topology dual-homed
!
interface Loopback0
ip address 200.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp interchassis group 1
hold-queue 300 in
service instance 1 ethernet
encapsulation dot1q 100
xconnect 210.0.0.1 10 pw-class mpls-dhd
backup peer 211.0.0.1 10 pw-class mpls-dhd
!
interface Ethernet0/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.200 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3

VPWS のスタンバイ PoA

次の VPWS のサンプル設定は、スタンバイ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
mpls ldp graceful-restart
mpls label protocol ldp
!
Redundancy
mode sso
interchassis group 1
member ip 200.0.0.1
backbone interface Ethernet0/2
backbone interface Ethernet1/2
backbone interface Ethernet1/3
monitor peer bfd
mlacp node-id 1
!
pseudowire-class mpls-dhd
encapsulation mpls
status peer topology dual-homed
!
interface Loopback0
ip address 201.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp lag-priority 40000
mlacp interchassis group 1
hold-queue 300 in
service instance 1 ethernet
encapsulation dot1q 100
xconnect 210.0.0.1 10 pw-class mpls-dhd
backup peer 211.0.0.1 10 pw-class mpls-dhd
!
interface Ethernet1/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.201 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3

例:VPLS の設定

次に、2 つの VPLS の設定例を示します。1 つはアクティブ PoA の例で、もう 1 つはスタンバイ PoA の例です。

図 9 に VPLS 設定のサンプル トポロジを示します。

図 9 VPLS PE 冗長性を持つ mLACP

VPLS のアクティブ PoA

次の VPLS のサンプル設定は、アクティブ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
mode sso
interchassis group 1
member ip 201.0.0.1
backbone interface Ethernet0/2
monitor peer bfd
mlacp node-id 0
!
l2 vfi VPLS_200 manual
vpn id 10
neighbor 210.0.0.1 encapsulation mpls
neighbor 211.0.0.1 encapsulation mpls
neighbor 201.0.0.1 encapsulation mpls
!
interface Loopback0
ip address 200.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp interchassis group 1
service instance 1 ethernet
encapsulation dot1q 100
bridge-domain 200
!
interface Ethernet0/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.200 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3
!
interface Vlan200
no ip address
xconnect vfi VPLS_200
 

VPLS のスタンバイ PoA

次の VPLS のサンプル設定は、スタンバイ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
interchassis group 1
member ip 200.0.0.1
backbone interface Ethernet0/2
monitor peer bfd
mlacp node-id 1
!
l2 vfi VPLS1 manual
vpn id 10
neighbor 210.0.0.1 encapsulation mpls
neighbor 211.0.0.1 encapsulation mpls
neighbor 200.0.0.1 encapsulation mpls
!
interface Loopback0
ip address 201.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp lag-priority 40000
mlacp interchassis group 1
service instance 1 ethernet
encapsulation dot1q 100
bridge-domain 200
!
interface Ethernet1/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.201 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3
!
interface Vlan200
no ip address
xconnect vfi VPLS_200

例:H-VPLS の設定

次に、2 つの H-VPLS の設定例を示します。1 つはアクティブ PoA の例で、もう 1 つはスタンバイ PoA の例です。

図 10 に H-VPLS 設定のサンプル トポロジを示します。

図 10 H-VPLS uPE および nPE 冗長性を持つ mLACP

H-VPLS のアクティブ PoA

次の H-VPLS のサンプル設定は、アクティブ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
!
redundancy
mode sso
interchassis group 1
member ip 201.0.0.1
backbone interface Ethernet0/2
backbone interface Ethernet1/2
backbone interface Ethernet1/3
monitor peer bfd
mlacp node-id 0
!
pseudowire-class mpls-dhd
encapsulation mpls
status peer topology dual-homed
!
interface Loopback0
ip address 200.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp interchassis group 1
hold-queue 300 in
service instance 1 ethernet
encapsulation dot1q 100
xconnect 210.0.0.1 10 pw-class mpls-dhd
backup peer 211.0.0.1 10 pw-class mpls-dhd
!
interface Ethernet0/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.200 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3

H-VPLS のスタンバイ PoA

次の H-VPLS のサンプル設定は、スタンバイ PoA 用です。

mpls ldp graceful-restart
mpls label protocol ldp
!
Redundancy
mode sso
interchassis group 1
member ip 200.0.0.1
backbone interface Ethernet0/2
backbone interface Ethernet1/2
backbone interface Ethernet1/3
monitor peer bfd
mlacp node-id 1
!
pseudowire-class mpls-dhd
encapsulation mpls
status peer topology dual-homed
!
interface Loopback0
ip address 201.0.0.1 255.255.255.255
!
interface Port-channel1
no ip address
lacp fast-switchover
lacp max-bundle 1
mlacp lag-priority 40000
mlacp interchassis group 1
hold-queue 300 in
service instance 1 ethernet
encapsulation dot1q 100
xconnect 210.0.0.1 10 pw-class mpls-dhd
backup peer 211.0.0.1 10 pw-class mpls-dhd
!
interface Ethernet1/0
no ip address
channel-group 1 mode active
!
interface Ethernet1/3
ip address 10.0.0.201 255.255.255.0
mpls ip
bfd interval 50 min_rx 150 multiplier 3

例:アクティブ PoA での VPWS の確認

次の show コマンドを使用すると、アクティブ PoA での mLACP の動作を確認する統計情報および設定パラメータを表示できます。

「show lacp multichassis group」

「show lacp multichassis port-channel」

「show mpls ldp iccp」

「show mpls l2transport」

「show etherchannel summary」

「show etherchannel number port-channel」

「show lacp internal」

show lacp multichassis group

show lacp multichassis group コマンドを使用すると、シャーシ間冗長グループ値と、LACP 操作パラメータが表示されます。

Router# show lacp multichassis group 100
Interchassis Redundancy Group 100
Operational LACP Parameters:
RG State: Synchronized
System-Id: 200.000a.f331.2680
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 0
System-Id: 200.000a.f331.2680
 
Peer Information:
State: Up
Node-id: 7
System-Id: 2000.0014.6a8b.c680
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
1 A/S 28000/32768 4/4 0/0

 

show lacp multichassis port-channel

show lacp multichassis port-channel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンク ピア設定、およびスタンバイ リンクが表示されます。

Router# show lacp multichassis port-channel1
 
Interface Port-channel1
Local Configuration:
Address: 000a.f331.2680
Channel Group: 1
State: Active
LAG State: Up
Priority: 28000
Inactive Links: 0
Total Active Links: 4
Bundled: 4
Selected: 4
Standby: 0
Unselected: 0
 
Peer Configuration:
Interface: Port-channel1
Address: 0014.6a8b.c680
Channel Group: 1
State: Standby
LAG State: Up
Priority: 32768
Inactive Links: 0
Total Active Links: 4
Bundled: 0
Selected: 0
Standby: 4
Unselected: 0

show mpls ldp iccp

show mpls ldp iccp コマンドを使用すると、LDP セッション情報および ICCP 状態情報が表示されます。

Router# show mpls ldp iccp
 
ICPM RGID Table
iccp:
rg_id: 100, peer addr: 172.3.3.3
ldp_session 0x3, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM RGID Table total ICCP sessions: 1
ICPM LDP Session Table
iccp:
rg_id: 100, peer addr: 172.3.3.3
ldp_session 0x3, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM LDP Session Table total ICCP sessions: 1

show mpls l2transport

show mpls l2transport コマンドを使用すると、ローカル インターフェイスの詳細およびセッションの詳細、接続先アドレス、およびステータスが表示されます。

Router# show mpls l2transport vc 2
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Po1 Eth VLAN 2 172.2.2.2 2 UP
Po1 Eth VLAN 2 172.4.4.4 2 STANDBY
 

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスと ID が表示されます。

Router# show etherchannel summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
 
Number of channel-groups in use: 2
Number of aggregators: 2
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) LACP Gi2/9(P) Gi2/20(P) Gi2/31(P)
 

show etherchannel number port-channel

show etherchannel number port-channel コマンドを使用すると、EtherChannel およびポート チャネルのステータスと ID が表示されます。

Router# show etherchannel 51 port-c
Port-channels in the group:
----------------------
 
Port-channel: Po51 (Primary Aggregator)
 
------------
 
Age of the Port-channel = 0d:02h:25m:23s
Logical slot/port = 14/11 Number of ports = 2
HotStandBy port = null
Passive port list = Gi9/15 Gi9/16
Port state = Port-channel L3-Ag Ag-Inuse
Protocol = LACP
Fast-switchover = enabled
Direct Load Swap = disabled
 
Ports in the Port-channel:
 
Index Load Port EC state No of bits
------+------+--------+------------------+-----------
0 55 Gi9/15 mLACP-stdby 4
1 AA Gi9/16 mLACP-stdby 4
 
Time since last port bundled: 0d:01h:03m:39s Gi9/16
Time since last port Un-bundled: 0d:01h:03m:40s Gi9/16
 
Last applied Hash Distribution Algorithm: Fixed Channel-group Iedge Counts:
--------------------------:
Access ref count : 0
Iedge session count : 0

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/9 SA bndl-act 28000 0x1 0x1 0x820A 0x3D
Gi2/20 SA bndl-act 28000 0x1 0x1 0x8215 0x3D
Gi2/31 SA bndl-act 28000 0x1 0x1 0x8220 0x3D
Gi2/40 SA bndl-act 28000 0x1 0x1 0x8229 0x3D
 
Peer (MLACP-PE3) mLACP member links
 
Gi3/11 FA hot-sby 32768 0x1 0x1 0xF30C 0x5
Gi3/21 FA hot-sby 32768 0x1 0x1 0xF316 0x5
Gi3/32 FA hot-sby 32768 0x1 0x1 0xF321 0x7
Gi3/2 FA hot-sby 32768 0x1 0x1 0xF303 0x7

例:スタンバイ PoA での VPWS の確認

次の show コマンドを使用すると、スタンバイ PoA での mLACP の動作を確認する統計情報および設定パラメータを表示できます。

「show lacp multichassis group」

「show lacp multichassis portchannel」

「show mpls ldp iccp」

「show mpls l2transport」

「show etherchannel summary」

「show lacp internal」

show lacp multichassis group

show lacp multichassis group コマンドを使用すると、LACP パラメータ、ローカル設定、バックボーン アップリンクのステータス、ピア情報、ノード ID、チャネル、状態、プライオリティ、アクティブおよび非アクティブ リンクが表示されます。

Router# show lacp multichassis group 100
 
Interchassis Redundancy Group 100
Operational LACP Parameters:
RG State: Synchronized
System-Id: 200.000a.f331.2680
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 7
System-Id: 2000.0014.6a8b.c680
 
Peer Information:
State: Up
Node-id: 0
System-Id: 200.000a.f331.2680
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
1 S/A 32768/28000 4/4 0/0

show lacp multichassis portchannel

show lacp multichassis portchannel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンクピア設定、およびスタンバイ リンクが表示されます。

Router# show lacp multichassis port-channel1
 
Interface Port-channel1
Local Configuration:
Address: 0014.6a8b.c680
Channel Group: 1
State: Standby
LAG State: Up
Priority: 32768
Inactive Links: 0
Total Active Links: 4
Bundled: 0
Selected: 0
Standby: 4
Unselected: 0
 
Peer Configuration:
Interface: Port-channel1
Address: 000a.f331.2680
Channel Group: 1
State: Active
LAG State: Up
Priority: 28000
Inactive Links: 0
Total Active Links: 4
Bundled: 4
Selected: 4
Standby: 0
Unselected: 0

show mpls ldp iccp

show mpls ldp iccp コマンドを使用すると、LDP セッション情報および ICCP 状態情報が表示されます。

Router# show mpls ldp iccp
 
ICPM RGID Table
iccp:
rg_id: 100, peer addr: 172.1.1.1
ldp_session 0x2, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM RGID Table total ICCP sessions: 1
ICPM LDP Session Table
iccp:
rg_id: 100, peer addr: 172.1.1.1
ldp_session 0x2, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM LDP Session Table total ICCP sessions: 1

show mpls l2transport

show mpls l2transport コマンドを使用すると、ローカル インターフェイスの詳細およびセッションの詳細、接続先アドレス、およびステータスが表示されます。

Router# show mpls l2transport vc 2
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
Po1 Eth VLAN 2 172.2.2.2 2 STANDBY
Po1 Eth VLAN 2 172.4.4.4 2 STANDBY

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスと ID が表示されます。

Router# show etherchannel summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
 
Number of channel-groups in use: 2
Number of aggregators: 2
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) LACP Gi3/2(P) Gi3/11(P) Gi3/21(P)
Gi3/32(P)

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

Router# show lacp 1 internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi3/2 FA bndl-sby 32768 0x1 0x1 0xF303 0x7
Gi3/11 FA bndl-sby 32768 0x1 0x1 0xF30C 0x5
Gi3/21 FA bndl-sby 32768 0x1 0x1 0xF316 0x5
Gi3/32 FA bndl-sby 32768 0x1 0x1 0xF321 0x7
 
Peer (MLACP-PE1) mLACP member links
 
Gi2/20 SA bndl 28000 0x1 0x1 0x8215 0x3D
Gi2/31 SA bndl 28000 0x1 0x1 0x8220 0x3D
Gi2/40 SA bndl 28000 0x1 0x1 0x8229 0x3D
Gi2/9 SA bndl 28000 0x1 0x1 0x820A 0x3D

例:アクティブ PoA での VPLS の確認

次の show コマンドを使用すると、アクティブ PoA での mLACP の動作を確認する統計情報および設定パラメータを表示できます。

「show lacp multichassis group」

「show lacp multichassis port-channel」

「show mpls ldp iccp」

「show mpls l2transport」

「show etherchannel summary」

「show lacp internal」

show lacp multichassis group

show lacp multichassis group コマンドを使用すると、LACP パラメータ、ローカル設定、バックボーン アップリンクのステータス、ピア情報、ノード ID、チャネル、状態、プライオリティ、アクティブおよび非アクティブ リンクが表示されます。

Router# show lacp multichassis group 100
 
Interchassis Redundancy Group 100
 
Operational LACP Parameters:
RG State: Synchronized
System-Id: 200.000a.f331.2680
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 0
System-Id: 200.000a.f331.2680
 
Peer Information:
State: Up
Node-id: 7
System-Id: 2000.0014.6a8b.c680
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
1 A/S 28000/32768 4/4 0/0

show lacp multichassis port-channel

show lacp multichassis port-channel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンク ピア設定、およびスタンバイ リンクが表示されます。

Router# show lacp multichassis port-channel1
 
Interface Port-channel1
Local Configuration:
Address: 000a.f331.2680
Channel Group: 1
State: Active
LAG State: Up
Priority: 28000
Inactive Links: 0
Total Active Links: 4
Bundled: 4
Selected: 4
Standby: 0
Unselected: 0
 
Peer Configuration:
Interface: Port-channel1
Address: 0014.6a8b.c680
Channel Group: 1
State: Standby
LAG State: Up
Priority: 32768
Inactive Links: 0
Total Active Links: 4
Bundled: 0
Selected: 0
Standby: 4
Unselected: 0

show mpls ldp iccp

show mpls ldp iccp コマンドを使用すると、LDP セッション情報および ICCP 状態情報が表示されます。

Router# show mpls ldp iccp
 
ICPM RGID Table
iccp:
rg_id: 100, peer addr: 172.3.3.3
ldp_session 0x3, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM RGID Table total ICCP sessions: 1
ICPM LDP Session Table
iccp:
rg_id: 100, peer addr: 172.3.3.3
ldp_session 0x3, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM LDP Session Table total ICCP sessions: 1

show mpls l2transport

show mpls l2transport コマンドを使用すると、ローカル インターフェイスの詳細およびセッションの詳細、接続先アドレス、およびステータスが表示されます。

Router# show mpls l2transport vc 4000
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
VFI VPLS VFI 172.2.2.2 4000 UP
VFI VPLS VFI 172.4.4.4 4000 UP

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスと ID が表示されます。

Router# show etherchannel summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
 
Number of channel-groups in use: 2
Number of aggregators: 2
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) LACP Gi2/9(P) Gi2/20(P) Gi2/31(P)
Gi2/40(P)

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

Router# show lacp internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi2/9 SA bndl-act 28000 0x1 0x1 0x820A 0x3D
Gi2/20 SA bndl-act 28000 0x1 0x1 0x8215 0x3D
Gi2/31 SA bndl-act 28000 0x1 0x1 0x8220 0x3D
Gi2/40 SA bndl-act 28000 0x1 0x1 0x8229 0x3D
 
Peer (MLACP-PE3) mLACP member links
 
Gi3/11 FA hot-sby 32768 0x1 0x1 0xF30C 0x5
Gi3/21 FA hot-sby 32768 0x1 0x1 0xF316 0x5
Gi3/32 FA hot-sby 32768 0x1 0x1 0xF321 0x7
Gi3/2 FA hot-sby 32768 0x1 0x1 0xF303 0x7

例:スタンバイ PoA での VPLS の確認

ここに示す show コマンドを使用すると、mLACP 機能の動作を確認する統計情報および設定パラメータを表示できます。

「show lacp multichassis group」

「show lacp multichassis portchannel」

「show mpls ldp iccp」

「show mpls l2transport vc 2」

「show etherchannel summary」

「show lacp internal」

show lacp multichassis group

show lacp multichassis group interchassis group number コマンドを使用すると、LACP パラメータ、ローカル設定、バックボーン アップリンクのステータス、ピア情報、ノード ID、チャネル、状態、プライオリティ、アクティブおよび非アクティブ リンクが表示されます。

Router# show lacp multichassis group 100
Interchassis Redundancy Group 100
 
Operational LACP Parameters:
RG State: Synchronized
System-Id: 200.000a.f331.2680
ICCP Version: 0
Backbone Uplink Status: Connected
Local Configuration:
Node-id: 7
System-Id: 2000.0014.6a8b.c680
 
Peer Information:
State: Up
Node-id: 0
System-Id: 200.000a.f331.2680
ICCP Version: 0
 
State Flags: Active - A
Standby - S
Down - D
AdminDown - AD
Standby Reverting - SR
Unknown - U
mLACP Channel-groups
Channel State Priority Active Links Inactive Links
Group Local/Peer Local/Peer Local/Peer Local/Peer
1 S/A 32768/28000 4/4 0/0

show lacp multichassis portchannel

show lacp multichassis portchannel コマンドを使用すると、インターフェイス ポート チャネルの値、チャネル グループ、LAG の状態、プライオリティ、非アクティブ リンクピア設定、およびスタンバイ リンクが表示されます。

Router# show lacp multichassis port-channel1
 
Interface Port-channel1
Local Configuration:
Address: 0014.6a8b.c680
Channel Group: 1
State: Standby
LAG State: Up
Priority: 32768
Inactive Links: 0
Total Active Links: 4
Bundled: 0
Selected: 0
Standby: 4
Unselected: 0
 
Peer Configuration:
Interface: Port-channel1
Address: 000a.f331.2680
Channel Group: 1
State: Active
LAG State: Up
Priority: 28000
Inactive Links: 0
Total Active Links: 4
Bundled: 4
Selected: 4
Standby: 0
Unselected: 0

show mpls ldp iccp

show mpls ldp iccp コマンドを使用すると、LDP セッション情報および ICCP 状態情報が表示されます。

Router# show mpls ldp iccp
 
ICPM RGID Table
iccp:
rg_id: 100, peer addr: 172.1.1.1
ldp_session 0x2, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM RGID Table total ICCP sessions: 1
ICPM LDP Session Table
iccp:
rg_id: 100, peer addr: 172.1.1.1
ldp_session 0x2, client_id 0
iccp state: ICPM_ICCP_CONNECTED
app type: MLACP
app state: ICPM_APP_CONNECTED, ptcl ver: 0
ICPM LDP Session Table total ICCP sessions: 1

show mpls l2transport vc 2

show mpls l2transport コマンドを使用すると、ローカル インターフェイスの詳細およびセッションの詳細、接続先アドレス、およびステータスが表示されます。

Router# show mpls l2transport vc 2
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------------- --------------- ---------- ----------
VFI VPLS VFI 172.2.2.2 4000 UP
VFI VPLS VFI 172.4.4.4 4000 UP

show etherchannel summary

show etherchannel summary コマンドを使用すると、mLACP メンバ リンクのステータスと ID が表示されます。

Router# show etherchannel summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
 
Number of channel-groups in use: 2
Number of aggregators: 2
 
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(RU) LACP Gi3/2(P) Gi3/11(P) Gi3/21(P)
Gi3/32(P)

show lacp internal

show lacp internal コマンドを使用すると、デバイス情報、ポート情報、およびメンバ リンク情報が表示されます。

Router# show lacp 1 internal
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 1
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi3/2 FA bndl-sby 32768 0x1 0x1 0xF303 0x7
Gi3/11 FA bndl-sby 32768 0x1 0x1 0xF30C 0x5
Gi3/21 FA bndl-sby 32768 0x1 0x1 0xF316 0x5
Gi3/32 FA bndl-sby 32768 0x1 0x1 0xF321 0x7
 
Peer (MLACP-PE1) mLACP member links
 
Gi2/20 SA bndl 28000 0x1 0x1 0x8215 0x3D
Gi2/31 SA bndl 28000 0x1 0x1 0x8220 0x3D
Gi2/40 SA bndl 28000 0x1 0x1 0x8229 0x3D
Gi2/9 SA bndl 28000 0x1 0x1 0x820A 0x3D

その他の参考資料

関連資料

関連項目
参照先

キャリア イーサネットのコマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用上の注意事項、および例

『Cisco IOS Carrier Ethernet Command Reference』

キャリア イーサネットの設定

Cisco IOS Carrier Ethernet Configuration Guide , Release 12.2SR』

Cisco IOS コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項および例を記載したコマンド リスト

『Cisco IOS Master Command List, All Releases』

規格

規格
タイトル

IEEE 802.3ad

『Link Aggregation Control Protocol』

IEEE 802.1ak

『Multiple Registration Protocol』

MIB

MIB
MIB リンク

Cisco-LAG-MIB

IEEE 802.3ad-MIB

IEEE8023-LAG-MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 4762

『Virtual Private LAN Service (VPLS) Using Label Distribution Protocol (LDP) Signaling』

RFC 4447

『Pseudowire Setup and Maintenance Using the Label Distribution Protocol (LDP)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

mLACP に関する機能情報

表 2 に、この機能のリリース履歴を示します。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 2 mLACP に関する機能情報

機能名
リリース
機能情報

マルチシャーシ LACP(mLACP)

12.2(33)SRE 15.0(1)S

Cisco の mLACP 機能は、通信事業者が冗長性を確保するため、デバイスを 2 つのアップストリーム PoA にデュアルホーム接続する場合の、シャーシ間冗長メカニズムに対するニーズを対象としています。mLACP 機能はこの要件を満たすため、802.3ad LACP の実装を拡張したものです。

次のコマンドが、新たに導入または変更されました。 backbone interface debug acircuit checkpoint debug lacp ethernet mac-flush mirp notification interchassis group lacp failover lacp max-bundle lacp min-bundle member ip mlacp interchassis group mlacp lag-priority mlacp node-id mlacp system-mac mlacp system-priority monitor peer bfd redundancy show ethernet service instance interface port-channel show ethernet service instance id mac-tunnel show lacp status decoupled status peer topology dual-homed

用語集

BD :Bridge Domain(ブリッジ ドメイン)。

BFD :Bidirectional Forwarding Detection(双方向フォワーディング検出)。

DHD :Dual-Homed Device(デュアルホーム接続デバイス)。冗長性を得るため、マルチシャーシ リンク集約グループを経由して 2 台のスイッチに接続されたノードです。

DHN :Dual-Homed Network(デュアルホーム接続ネットワーク)。冗長性を提供するために 2 台のスイッチに接続されたネットワーク。

H-VPLS :Hierarchical Virtual Private LAN Service(階層型バーチャル プライベート LAN サービス)。

ICC :Interchassis Communication Channel(シャーシ間通信チャネル)。

ICCP :Interchassis Communication Protocol(シャーシ間通信プロトコル)。

ICPM :Interchassis Protocol Manager(シャーシ間プロトコル マネージャ)。

ICRM :Interchassis Redundancy Manager(シャーシ間冗長マネージャ)。

LACP :Link Aggregation Control Protocol(リンク集約コントロール プロトコル)。

LAG: Link Aggregation Group(リンク集約グループ)。

LDP: Link Distribution Protocol(リンク分散プロトコル)。

MCEC :Multichassis EtherChannel(マルチシャーシ EtherChannel)。

mLACP: Multichassis LACP(マルチシャーシ LACP)。

PoA :Point of Attachment(接続ポイント)。DHD を使用してマルチシャーシ リンク集約グループを実行するスイッチ ペアの 1 つです。

PW-RED :PseudoWire REDundancy(疑似ワイヤ冗長性)。

uPE :user-Facing Provider Edge(ユーザ側プロバイダー エッジ)。

VPLS :Virtual Private LAN Service(バーチャル プライベート LAN サービス)。

VPWS :Virtual Private Wire Service(バーチャル プライベート回線サービス)。

アクティブ PW :アクティブ PoA にトラフィックを転送する疑似ワイヤ。

アクティブ接続回線 :DHD とアクティブ PoA の間のトラフィックをアクティブに転送するリンク。

スタンバイ PW :アクティブ PoA またはスタンバイ PoA でスタンバイ モードになっている疑似ワイヤ。

スタンバイ接続回線 :DHD とスタンバイ PoA の間でスタンバイ モードになっているリンク。