キャリア イーサネット コンフィギュレーション ガイド、Cisco IOS Release 15.1S
IEEE 802.3ad リンク バンドルおよびロード バランシングの設定
IEEE 802.3ad リンク バンドルおよびロード バランシングの設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定

機能情報の確認

目次

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する前提条件

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する制約事項

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定について

ギガビット EtherChannel

ポート チャネル インターフェイスと LACP 対応インターフェイス

IEEE 802.3ad リンク バンドル

IEEE 802.3ad リンク バンドルの利点

Cisco IOS Release 12.2(33)SB で導入された LACP 拡張

EtherChannel ロード バランシング

LACP 単一障害の直接ロード バランス スワッピング

EtherChannel での負荷分散

重み付けロード バランシングによる 802.3ad リンク集約

ロード バランシングの併用

サービス グループのサポート

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定方法

LACP のイネーブル化

ポート チャネルの設定

チャネル グループとポート チャネルの関連付け

LACP システム プライオリティの設定

バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除

アクティブ リンクの最小数の設定

LACP ステータスのモニタリング

トラブルシューティングのヒント

LACP 単一障害のロード バランス スワッピングのイネーブル化

EtherChannel 負荷分散アルゴリズムの選択

802.3ad 重み付けロード バランシングのイネーブル化

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定の例

例:チャネル グループとポート チャネルとの関連付け

例:バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除

例:LACP ステータスのモニタリング

例:重み付けサービス インスタンスの設定

例:重み付けロード バランシングと手動ロード バランシングの設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する機能情報

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定

このマニュアルでは、IEEE 802.3ad リンク バンドル機能が、Cisco IOS ソフトウェアで EtherChannel インフラストラクチャを使用して、さまざまなリンクのバンドルを管理する方法について説明します。また、リンク バンドルにポートを追加したり、リンク バンドルからポートを削除した場合に発生する、ネットワークの中断を最小限にするために役立つネットワーク トラフィックのロード バランシング機能についても説明します。

機能情報の確認

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する前提条件

ネットワークでの EtherChannel と Link Aggregation Control Protocol(LACP)の機能に関する知識があること。

ネットワーク トラフィックの中断を減らすためのロード バランシングの知識があること。

LACP リンクの両端で同じバージョンの基本ソフトウェアが使用されていることを確認する

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する制約事項

バンドルごとにサポートされるリンクの数は、プラットフォームで決まります。

Cisco 7600 シリーズ ルータでは、バンドルごとのリンクの最大数は 8 です。

Cisco 10000 シリーズ ルータでは、バンドルごとのリンクの最大数は 8 です。

Cisco 10000 シリーズ ルータに限り、Gigabit EtherChannel(GEC)用の 1 ギガビット/秒(Gbps)ポートがサポートされています。

すべてのリンクが同じリンク速度かつ全二重モードで動作している必要があります(LACP では半二重モードはサポートされていません)。

すべてのリンクが EtherChannel リンクまたは LACP リンクとして設定されている必要があります。

物理インターフェイスだけが集約を形成できます。VLAN インターフェイスを集約したり、集約を集約したりすることはできません。

ルータがスイッチに接続されている場合、バンドルはそのスイッチ上で終了します。

いずれかの LAN ポートが Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)の宛先ポートである場合、EtherChannel は形成されません。

EtherChannel 内のすべてのポートで同じ EtherChannel プロトコルを使用する必要があります。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」に説明がある LACP 拡張は、Cisco 10000 シーズルータだけで利用できます。

LACP 単一障害の直接ロード バランス スワッピング機能は、単一のバンドル ポートの障害に制限されます。

LACP 単一障害の直接ロード バランス スワッピング機能は、Port Aggregation Protocol(PagP; ポート集約プロトコル)では使用できません。

LACP ポート プライオリティは、LACP 単一障害の直接ロード バランス スワッピングでは設定できず、逆にこの機能を LACP ポート プライオリティで設定することもできません。

EtherChannel 負荷分散が使用されている場合、適応型アルゴリズムは、Service Control Engine(SCE)に適用されません。

Cisco 7600 シリーズ ルータの重み付けロード バランシングによる 802.3ad リンク集約機能では、次の設定可能なサービス インスタンスの最大数が適用されます。

ポート チャネルあたり 8000

ライン カードあたり 16,000

システムあたり 64,000

Cisco 7600 シリーズ ルータは、最大 256 のポート チャネルをサポートしています。

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定について

「ギガビット EtherChannel」

「ポート チャネル インターフェイスと LACP 対応インターフェイス」

「IEEE 802.3ad リンク バンドル」

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

「EtherChannel ロード バランシング」

「LACP 単一障害の直接ロード バランス スワッピング」

「EtherChannel での負荷分散」

「重み付けロード バランシングによる 802.3ad リンク集約」

ギガビット EtherChannel

ギガビット EtherChannel は、Gbps の伝送レートを実現する高性能なイーサネット技術です。ギガビット EtherChannel は、個々のギガビット イーサネット リンクを 1 つの論理リンクにバンドルすることにより、最大 8 つの物理リンクの集約帯域幅を提供します。各 EtherChannel の LAN ポートの速度がすべて同じであり、これらのポートがレイヤ 2 LAN ポートまたはレイヤ 3 LAN ポートのいずれかとして設定されている必要があります。EtherChannel 内の 1 つのリンクに到達したインバウンド ブロードキャストおよびマルチキャスト パケットは、EtherChannel 内の別のリンクに戻されることはありません。

EtherChannel 内のリンクで障害が発生すると、障害が発生したリンクで伝送されていたトラフィックは、その EtherChannel 内の残りのリンクに切り替えられます。また、障害が発生すると、デバイス、EtherChannel、および障害が発生したリンクを特定するトラップが送信されます。

ポート チャネル インターフェイスと LACP 対応インターフェイス

各 EtherChannel には、番号が付いたポート チャネル インターフェイスが存在しています。このインターフェイスがまだ作成されていない場合には、最初の物理インターフェイスがチャネル グループに追加されると自動的に作成されます。ポート チャネル インターフェイスの設定は、そのポート チャネル インターフェイスに割り当てられているすべての LAN ポートに影響します。

EtherChannel 内のすべてのポートのパラメータを変更する場合(スパニング ツリー プロトコルを設定する場合やレイヤ 2 EtherChannel をトランクとして設定する場合など)は、ポート チャネル インターフェイスの設定を変更します。ポート チャネル インターフェイスに対して行った設定やアトリビュートの変更は、そのポート チャネルと同じチャネル グループ内のすべてのインターフェイスに反映されます。つまり、設定の変更は、ポート チャネルの一部ではないがチャネル グループの一部である物理インターフェイスに反映されます。

LAN ポートの設定は、LAN ポートだけに影響します。

IEEE 802.3ad リンク バンドル

IEEE 802.3ad リンク バンドル機能を使用すると、複数のイーサネット リンクを、IEEE 802.3ad 規格に基づいて単一の論理チャネルに集約できます。この機能により、ハードウェアをアップグレードしなくても、帯域幅を累積的に増大して、デバイスのコスト効率を向上できます。また、IEEE 802.3ad リンク バンドルにより、さまざまな集約リンクを動的にプロビジョニング、管理、およびモニタすることができ、さまざまなシスコ デバイスとサードパーティ ベンダーのデバイスを相互に運用できます。

LACP を使用すると、LAN ポート間で LACP パケットを交換することにより、EtherChannel を自動的に作成できます。LACP パケットが交換されるのは、パッシブ モードとアクティブ モードのポート間に限られます。このプロトコルは、LAN ポート グループの機能を動的に「学習」し、他の LAN ポートに通知します。LACP は、正しく一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel にグループ化します。次に、その EtherChannel は単一ブリッジ ポートとしてスパニング ツリーに追加されます。

LACP はパッシブ モードとアクティブ モードの両方で LAN ポート間のネゴシエーションを行い、ポートの速度やトランキング状態などの基準に基づいて LAN ポートが EtherChannel を形成できるかどうかを判別します(レイヤ 2 EtherChannel では VLAN 番号も使用されます)。次の例に示すように、LAN ポートは、互換性のある LACP モードの場合に EtherChannel を形成できます。

アクティブ モードの LAN ポートは、アクティブ モードの別の LAN ポートとともに EtherChannel を形成できます。

アクティブ モードの LAN ポートは、パッシブ モードの別の LAN ポートとともに EtherChannel を形成できます。

パッシブ モードの LAN ポートは、同様にパッシブ モードである別の LAN ポートとは EtherChannel を形成できません。これは、いずれのポートでもネゴシエーションが開始されないためです。

LACP では、次のパラメータが使用されます。

LACP システム プライオリティ:LACP を実行するデバイスごとに LACP システム プライオリティを設定する必要があります。システム プライオリティは、自動的に設定することも、Command-Line Interface(CLI; コマンド ライン インターフェイス)を使用して設定することもできます。LACP では、システム ID を形成するために、他のシステムとのネゴシエーション時にデバイスの MAC アドレスとともにシステム プライオリティが使用されます。

LACP ポート プライオリティ:LACP を使用するように設定されているポートごとに LACP ポート プライオリティを設定する必要があります。ポート プライオリティは、自動的に設定することも、CLI を使用して設定することもできます。ハードウェアの制約事項が原因で一部の互換ポートを集約できない場合、LACP ではポート プライオリティを使用して、スタンバイ モードにするポートが決定されます。また、LACP では、ポート ID を形成するために、ポート番号とともにポート プライオリティが使用されます。

LACP 管理キー:LACP では、LACP を使用するように設定されているポートごとに管理キー値が自動的に設定されます。管理キーによって、他のポートとの集約を行うポートの能力が定義されます。他のポートとの集約を行うポートの能力は、次の要因によって決まります。

データ レート、二重機能、ポイントツーポイント、共有メディアなどのポートの物理特性

ユーザが指定した設定の制約事項

LACP を使用するように設定されたポート上で、LACP はハードウェアで許容された最大数まで、EtherChannel の最大互換ポート数を設定しようとします。Cisco 10000 シリーズ ルータの Cisco IOS Release 12.2(31)SB2 では、バンドルあたり 4 つのポートだけを集約することができ、LACP をサポートするようピアを設定する必要があります。チャネル ポートで障害が発生した場合にホット スタンバイ機能を使用するには、LACP バンドルの両端で lacp max-bundle コマンドがサポートされている必要があります。

LACP では、制御プロトコルとして低速プロトコル マルチキャスト アドレス 01-80-C2-00-00-02 を使用して、LACP Protocol Data Unit(PDU; プロトコル データ ユニット)が転送されます。Operations, Administration, and Maintenance(OAM)パケットも、低速プロトコル リンク タイプを使用します。その後、サブタイプ フィールドが IEEE 802.3ad 規格 [1](Annex 43B、セクション 4)ごとに定義され、LACP PDU と OAM PDU が区別されます。

IEEE 802.3ad リンク バンドルの利点

物理接続を変更したりハードウェアをアップグレードしたりすることなく、ネットワーク容量を増大できる

既存のハードウェアおよびソフトウェアを使用して機能を追加できるためコストを削減できる

標準のソリューションを使用して、複数のネットワーク デバイスを相互運用できる

動作中のポートの障害時に、ユーザの介入なしにポートの冗長性を提供できる

Cisco IOS Release 12.2(33)SB で導入された LACP 拡張

Cisco 10000 シリーズ ルータの Cisco IOS Release 12.2(33)SB では、次の LACP 拡張がサポートされています。

LACP バンドルごとに 8 つのメンバ リンク。

Gigabit EtherChannel バンドルでの、Stateful Switchover(SSO; ステートフル スイッチオーバー)、In Service Software Upgrade(ISSU)、Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディンブ)、および Non-Stop Routing(NSR; ノンストップ ルーティング)。

Point-to-Point Protocol over Ethernet over Ethernet(PPPoEoE)、Point-to-Point Protocol over Ethernet over IEEE 802.1Q in 802.1Q(PPPoEoQinQ)、および Point-to-Point Protocol over VLAN(PPPoVLAN)セッションは、リンク スイッチオーバーが発生した場合に、強制的に再確立されません。スイッチオーバー中に、ポート チャネルは LINK_UP 状態に維持され、アクティブ リンクとスタンバイ リンクの両方で、スイッチオーバー後にコンフィギュレーション要素が同じと見なされます。

250 ミリ秒以下のリンク フェールオーバー時間、2 秒の最大リンク フェールオーバー時間。ポート チャネルは、スパンニングツリー プロトコルによる再コンバージェンスをなくすために、LINK_UP 状態のままになります。

アクティブ リンクの数が最小しきい値を下回った場合に、ポート チャネルをシャットダウンします。ポート チャネル インターフェイスには、アクティブ リンクの数が最小しきい値を下回った場合に、ポート チャネル インターフェイスを停止させるための設定可能なオプションがあります。チャネルの両側でポート チャネル状態を同期させるには、ピアでも LACP を実行し、同じ lacp min-bundle コマンド設定を行う必要があります。

IEEE LAG MIB。

EtherChannel ロード バランシング

EtherChannel ロード バランシングでは、MAC アドレス、IP アドレス、レイヤ 4 ポート番号、送信元アドレスか宛先アドレスのいずれか(または両方)、またはポートを使用できます。選択したモードは、デバイス上で設定されているすべての EtherChannel に適用されます。EtherChannel ロード バランシングは、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 2 情報も使用できます。

EtherChannel は、フレーム内のアドレスに基づいて形成されたバイナリ パターンの一部を、チャネル内の 1 つのリンクを選択する数値に縮小することによって、リンク間でトラフィックのロード バランシングを行います。ポートを EtherChannel に追加し、またはアクティブ ポートに障害が発生した場合、ロード バランス ビットはリセットされ、EtherChannel 内のすべてのポートに再割り当てされ、各ポートの ASIC に対して再プログラミングされます。このリセットによって、再割り当てと再プログラミングが実行されている間に、パケット損失が生じます。ポートの帯域幅が大きいほど、パケット損失は多くなります。

LACP 単一障害の直接ロード バランス スワッピング

LACP は、ホット スタンバイ ポートをサポートしています。これは、プラットフォームで集約できるポートの最大数がバンドルされた場合に作成されます。Cisco 7600 ルータでは、バンドルできるポートの最大数は 8 です。ホット スタンバイ ポートは、以前アクティブだったポートに障害が発生した場合に、集約内にバンドルされます(処理が引き継がれます)。

LACP 単一障害の直接ロード バランス スワッピング機能は、ロード バランス ビットを再割り当てすることにより、処理を引き継いだホット スタンバイ ポートに対し、故障したポートのロード バランス ビットが割り当てられ、集約内のその他のポートのロード バランス ビットはそのままにします。交換されたポートがバンドルされると、保存されている故障したポートのロードシェアが、処理を引き継いだポートに割り当てられます。バンドル内の他のポートには影響がありません。

LACP 単一障害の直接ロード バランス スワッピング機能は、単一のバンドル ポートの障害に対処します。最初の障害から回復する前に、別の障害が発生した場合、メンバ リンクのロード シェア ビットが再計算されます。

LACP 単一障害の直接ロード バランス スワッピング プロセスの概要は、次のとおりです。

1. 障害が発生した(バンドルされていない)ポートが検出され、それが最初の障害である場合、そのロード シェアは保存されます。

2. ホット スタンバイ ポートが確認され、バンドルされた場合、そのポートは以前に障害が発生したポートのロード シェア ビットを取得します。

3. 障害が発生したポートが回復した場合、そのポートはバンドル内のホット スタンバイ ポートと交換され、ロード シェア ビットは元のポートに戻されます。

LACP 単一障害の直接ロード バランス スワッピング機能は、ポートチャネル コンフィギュレーション モードで CLI コマンド lacp direct-loadswap を使用してイネーブルにします。

EtherChannel での負荷分散

Cisco IOS Release 12.(33)SRC よりも前のリリースでは、固定負荷分散アルゴリズムだけがサポートされていました。この固定アルゴリズムでは、ロード シェア ビットは、バンドル内の各ポートに順番に割り当てられます。このため、メンバ リンクがバンドルに追加され、またはバンドルから削除されたときに、既存のポートに対するロード シェア ビットは変更されます。これらの値が ASIC でプログラムされている場合、重大なトラフィックの中断や、場合によってはトラフィックの重複が発生することがあります。

EtherChannel の負荷分散機能は、適応型の負荷分散アルゴリズムで、負荷分散メカニズムを拡張します。このアルゴリズムでは、追加または削除されるポートに対して負荷分散の再割り当てを制限することにより、EtherChannel のアベイラビリティを高めるポート再割り当てスキームが使用されます。ポートが追加または削除されたときに、バンドルされた既存のポートに新しい負荷がかかっても、それらのポート上でプログラムされている負荷と競合することはありません。

この機能は、グローバル コンフィギュレーション モードまたはインターフェイス コンフィギュレーション モードのいずれかでイネーブルにできます。このアルゴリズムは、次回のハッシュ分散インスタンスで適用されます。通常、これは、リンクに障害が発生し、リンクがアクティブ化され、追加され、または削除された場合や、シャットダウンまたはシャットダウンなしに設定された場合に発生します。

選択したアルゴリズムは、次回のハッシュ分散インスタンスまで適用されないため、現在のアルゴリズムと設定したアルゴリズムが異なる場合があります。アルゴリズムが異なる場合、適切なアクションを実行するように警告するメッセージが表示されます。次に例を示します。

Router(config-if)# port-channel port hash-distribution fixed
 
This command will take effect upon a member link UP/DOWN/ADDITION/DELETION event.
Please do a shut/no shut to take immediate effect
 

show etherchannel コマンドの出力も、チャネル グループ番号を指定した場合に、適用されるアルゴリズムを表示するように拡張されました。ただし、プロトコルも指定した場合は、プロトコル固有の情報だけが表示されるため、この出力の拡張は利用できません。次に、適用されるアルゴリズムを表示する出力の例を示します。

Router# show etherchannel 10 summary
 
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use N - not in use, no aggregation
f - failed to allocate aggregator
<snip>
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
10 Po10(RU) LACP Gi3/7(P) Gi3/9(P)
 
! The following line of output is added with support
of the EtherChannel Load Distribution feature. !
 
Last applied Hash Distribution Algorithm: Fixed
 

重み付けロード バランシングによる 802.3ad リンク集約

ポート チャネル内のメンバ リンクでイーサネット サービス インスタンスのロード バランシングを行う現在のメカニズムは、サービス インスタンスのトラフィック負荷を考慮に入れていません。これにより、メンバ リンクで、トラフィックの分散が不均衡になることがあります。重み付けロード バランシングによる 802.3ad リンク集約機能(802.3ad LAG with WLB)は、サービス インスタンスに重みを割り当てて、ポート チャネルのアクティブ メンバ リンク間でトラフィック フローを効率的に分散できるようにする拡張機能で、Cisco IOS Release 15.0(1)S で導入されました。

LAG with WLB 機能は LACP(アクティブまたはパッシブ モード)と手動(モード オン)EtherChannel バンドルの両方をサポートしています。重み付けロード バランシングの設定は、EtherChannel 内のアクティブ メンバ リンクの選択に影響を与えません。メンバ リンクがアクティブまたは非アクティブになったときに、ロード バランシング アルゴリズムは、現在アクティブなメンバ リンクを使用するよう、イーサネット サービス インスタンスの分散を調整します。

ロード バランシングの併用

重み付けロード バランシングの追加サポートにより、ポート チャネルのメンバ リンクでイーサネット サービス インスタンスのロード バランシングを行うために、3 つの方法を利用できます。使用する方法は、次の順番で選択されます(優先順位の高いものから順に示します)。

1. 手動ロード バランシング

2. 重み付けロード バランシング

3. プラットフォームのデフォルトのロード バランシング

メンバ リンクに対して手動で割り当てるようにイーサネット サービス インスタンスを設定し、そのメンバ リンクがポート チャネルのアクティブ メンバになっている場合は、その手動割り当てが適用されます。イーサネット サービス インスタンスが手動でロード バランスされず、 port-channel load-balance weighted link コマンドで重み付けロード バランシングをイネーブルにした場合、サービス インスタンスは、設定した重みまたはデフォルトの重みに基づいてロード バランスされます。サービス インスタンスに対して手動または重み付けのいずれの方法も適用されない場合は、プラットフォームのデフォルト ロード バランシング メカニズムが使用されます。

手動と重み付けの両方の方法で、同じメンバ リンクまたは複数のリンクを通じてイーサネット サービス インスタンスのロード バランシングを行う場合、手動でロード バランスされたサービス インスタンスの重みは、重みの分散を決定する際に考慮に入れられます。その他のイーサネット サービス インスタンスすべてと同様に、手動でロード バランスされるイーサネット サービス インスタンスで重みを明示的に設定しない場合は、デフォルトの重みが使用されます。

重み付けロード バランシング方法は、特定の数のメンバ リンクだけを使用するように設定できます。この設定オプションによって、1 つ以上のメンバ リンクを、手動でロード バランスされるイーサネット サービス インスタンス専用にすることができます。

サービス グループのサポート

イーサネット サービス グループとは、イーサネット サービス インスタンス、サブインターフェイス、または両方の論理的な集合です。サービス グループのメンバであるすべてのイーサネット サービス インスタンスのトラフィックは、同じメンバ リンクから出力される必要があります。この制限は、正確な計算を実行するために、サービス グループに対して設定する Quality of Service(QoS)のために必要です。しかし、この制限によって、利用できるメンバ リンク間で重みの分散が不均一になることがあります。たとえば、サービス グループ内にそれぞれ重み 1 が設定された 100 のイーサネット サービス インスタンスがあり、重み 2 が設定され、サービス グループに含まれていない他のイーサネット サービス インスタンスが 1 つあるとします。この場合、1 つのメンバ リンクには合計 100 の重みが割り当てられ、別のメンバ リンクには合計 2 の重みが割り当てられます。この例は一般的なシナリオではありませんが、トラフィックのアンバランスが生じる可能性があることを示しています。

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定方法

「LACP のイネーブル化」

「ポート チャネルの設定」

「チャネル グループとポート チャネルの関連付け」

「LACP システム プライオリティの設定」

「バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除」

「アクティブ リンクの最小数の設定」

「LACP ステータスのモニタリング」

「LACP 単一障害のロード バランス スワッピングのイネーブル化」

「EtherChannel 負荷分散アルゴリズムの選択」

「802.3ad 重み付けロード バランシングのイネーブル化」

LACP のイネーブル化

LACP をイネーブルにするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface port-channel channel-number

4. channel-group channel-group-number mode { active | passive }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel channel-number

 

Router(config)# interface port-channel 10

インターフェイス ポート チャネルを決定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

channel-group channel-group-number mode { active | passive }

 

Router(config-if)# channel-group 25 mode active

インターフェイスをチャネル グループに設定し、アクティブとして設定します。

アクティブ モードでは、ポートは LACP パケットを送信することによって他のポートとのネゴシエーションを開始します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

ポート チャネルの設定

ポート チャネルの論理インターフェイスを手動で作成する必要があります。ポート チャネルを設定するには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface port-channel channel-number

4. ip address ip-address mask

5. end

6. show running-config interface port-channel group-number

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel channel-number

 

Router(config)# interface port-channel 10

インターフェイス ポート チャネルを決定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 172.31.52.10 255.255.255.0

IP アドレスおよびサブネット マスクを EtherChannel に割り当てます。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

ステップ 6

show running-config interface port-channel group-number

 

Router# show running-config interface port-channel 10

ポート チャネル設定を表示します。

ステップ 7

end

 

Router# end

現在のコンフィギュレーション セッションを終了します。

この例では、設定の確認方法を示します。

Router# show running-config interface port-channel10
 
Building configuration...
Current configuration:
!
interface Port-channel10
ip address 172.31.52.10 255.255.255.0
no ip directed-broadcast
end

チャネル グループとポート チャネルの関連付け

チャネル グループをポート チャネルに関連付けるには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface port-channel channel - number

4. interface type number

5. channel-group channel-group-number mode { active | passive }

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel channel - number

 

Router(config)# interface port-channel 5

ポート チャネルを作成します。

ステップ 4

interface type number

 

Router(config)# interface gigabitethernet 7/0/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

channel-group channel-group-number mode { active | passive }

 

Router(config-if)# channel-group 5 mode active

ポート チャネル バンドルの一部として、インターフェイスを含めます。

ステップ 6

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

LACP システム プライオリティの設定

LACP システム プライオリティを設定するには、次のタスクを実行します。システム ID は、LACP システム プライオリティと、デバイスの MAC アドレスの組み合せです。

手順の概要

1. enable

2. configure terminal

3. lacp system-priority priority

4. end

5. show lacp sys-id

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

lacp system-priority priority

 

Router(config)# lacp system-priority 200

システム プライオリティを設定します。

ステップ 4

end

 

Router(config)# end

特権 EXEC モードに戻ります。

ステップ 5

show lacp sys-id

 

Router# show lacp

システム ID を表示します。システム ID は、システム プライオリティと、デバイスの MAC アドレスの組み合せです。

ステップ 6

end

 

Router# end

現在のコンフィギュレーション セッションを終了します。

この例では、LACP 設定の確認方法を示します。

Router# show lacp
 
20369,01b2.05ab.ccd0

バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除

リンク バンドルにインターフェイスを追加したり、バンドルからインターフェイスを削除したりするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. channel-group channel-group-number mode { active | passive }

5. no channel-group

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface gigabitethernet 5/0/0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

channel-group channel-group-number mode { active | passive }

 
Router(config-if)# channel-group 5 mode active

チャネル グループにインターフェイスを追加します。

ステップ 5

no channel-group

 

Router(config-if)# no channel-group

チャネル グループからインターフェイスを削除します。

ステップ 6

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

アクティブ リンクの最小数の設定

LACP バンドルで許可されるアクティブ リンクの最小数を設定するには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. lacp min-bundle min-bundle

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface port-channel 1

ポート チャネル仮想インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

lacp min-bundle min-bundle

 

Router(config-if)# lacp min-bundle 5

アクティブ リンクの最小しきい値を設定します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

LACP ステータスのモニタリング

ネットワークでの LACP アクティビティをモニタするには、次のタスクを実行します。

手順の概要

1. enable

2. show lacp { number | counters | internal | neighbor | sys-id }

3. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show lacp { number | counters | internal | neighbor | sys-id }

 

Router# show lacp internal

内部デバイスの情報を表示します。

ステップ 3

end

 

Router# end

現在のコンフィギュレーション セッションを終了します。

トラブルシューティングのヒント

debug lacp コマンドを使用して、LACP の設定およびアクティビティの詳細を表示します。

debug lacp all コマンドの次のサンプル出力は、リモート デバイスによるリンクの削除および追加を示しています。

Router# debug lacp all
 
Link Aggregation Control Protocol all debugging is on
 
Router#
 
*Aug 20 17:21:51.685: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:21:51.685: LACP : packet size: 124
*Aug 20 17:21:51.685: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:21:51.685: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0x3C,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:21:51.685: LACP: Part: tlv:2, tlv-len:20, key:0x5, p-pri:0x8000, p:0x42, p-state:0x3D,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:21:51.685: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000
*Aug 20 17:21:51.685: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:21:51.685: LACP: Gi5/0/0 LACP packet received, processing
*Aug 20 17:21:51.685: lacp_rx Gi5: during state CURRENT, got event 5(recv_lacpdu)
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:21:59.869: lacp_ptx Gi5: during state SLOW_PERIODIC, got event 3(pt_expired)
*Aug 20 17:21:59.869: @@@ lacp_ptx Gi5: SLOW_PERIODIC -> PERIODIC_TX
*Aug 20 17:21:59.869: LACP: Gi5/0/0 lacp_action_ptx_slow_periodic_exit entered
*Aug 20 17:21:59.869: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:00.869: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:00.869: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:19.089: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:22:19.089: LACP : packet size: 124
*Aug 20 17:22:19.089: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:22:19.089: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0x4,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:22:19.089: LACP: Part: tlv:2, tlv-len:20, key:0x5, p-pri:0x8000, p:0x42, p-state:0x34,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:22:19.089: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000
*Aug 20 17:22:19.089: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:22:19.089: LACP: Gi5/0/0 LACP packet received, processing
*Aug 20 17:22:19.089: lacp_rx Gi5: during state CURRENT, got event 5(recv_lacpdu)
*Aug 20 17:22:19.989: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:19.989: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:19.989: LACP: timer lacp_t(Gi5/0/0) started with interval 1000.
*Aug 20 17:22:19.989: LACP: lacp_send_lacpdu: (Gi5/0/0) About to send the 110 LACPDU
*Aug 20 17:22:19.989: LACP :lacp_bugpak: Send LACP-PDU packet via Gi5/0/0
*Aug 20 17:22:19.989: LACP : packet size: 124
*Aug 20 17:22:20.957: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:22:20.957: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:22:21.205: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to down
*Aug 20 17:22:21.205: LACP: lacp_hw_off: Gi5/0/0 is going down
 
*Aug 20 17:22:21.205: LACP: if_down: Gi5/0/0
*Aug 20 17:22:21.205: lacp_ptx Gi5: during state SLOW_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:22.089: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to down
*Aug 20 17:22:22.153: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:22:23.413: LACP: Gi5/0/0 oper-key: 0x0
*Aug 20 17:22:23.413: LACP: lacp_hw_on: Gi5/0/0 is coming up
 
*Aug 20 17:22:23.413: lacp_ptx Gi5: during state NO_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:23.413: @@@ lacp_ptx Gi5: NO_PERIODIC -> NO_PERIODIC
*Aug 20 17:22:23.413: LACP: Gi5/0/0 lacp_action_ptx_no_periodic entered
*Aug 20 17:22:23.413: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:24.153: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to up
*Aug 20 17:22:24.153: LACP: lacp_hw_on: Gi5/0/0 is coming up
 
*Aug 20 17:22:24.153: lacp_ptx Gi5: during state FAST_PERIODIC, got event 0(no_periodic)
*Aug 20 17:22:24.153: @@@ lacp_ptx Gi5: FAST_PERIODIC -> NO_PERIODIC
*Aug 20 17:22:24.153: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:24.153: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:24.153: LACP:
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:22:25.021: lacp_ptx Gi5: during state FAST_PERIODIC, got event 3(pt_expired)
*Aug 20 17:22:25.021: @@@ lacp_ptx Gi5: FAST_PERIODIC -> PERIODIC_TX
*Aug 20 17:22:25.021: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:25.021: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:22:25.917: lacp_ptx Gi5: during state FAST_PERIODIC, got event 3(pt_expired)
*Aug 20 17:22:25.917: @@@ lacp_ptx Gi5: FAST_PERIODIC -> PERIODIC_TX
*Aug 20 17:22:25.917: LACP: Gi5/0/0 lacp_action_ptx_fast_periodic_exit entered
*Aug 20 17:22:25.917: LACP: lacp_p(Gi5/0/0) timer stopped
 

次のサンプル出力は、リモート デバイスによるリンクの追加を示しています。

Router#
 
*Aug 20 17:23:54.005: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:23:54.005: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:23:55.789: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:23:56.497: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) expired
*Aug 20 17:24:19.085: lacp_ptx Gi5: during state SLOW_PERIODIC, got event 3(pt_expired)
*Aug 20 17:24:19.085: @@@ lacp_ptx Gi5: SLOW_PERIODIC -> PERIODIC_TX
*Aug 20 17:24:19.085: LACP: Gi5/0/0 lacp_action_ptx_slow_periodic_exit entered
*Aug 20 17:24:19.085: LACP: lacp_p(Gi5/0/0) timer stopped
*Aug 20 17:24:19.957: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:19.957: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:21.073: LACP :lacp_bugpak: Receive LACP-PDU packet via Gi5/0/0
*Aug 20 17:24:21.073: LACP : packet size: 124
*Aug 20 17:24:21.073: LACP: pdu: subtype: 1, version: 1
*Aug 20 17:24:21.073: LACP: Act: tlv:1, tlv-len:20, key:0x1, p-pri:0x8000, p:0x14, p-state:0xC,
s-pri:0xFFFF, s-mac:0011.2026.7300
*Aug 20 17:24:21.073: LACP: Part: tlv:2, tlv-len:20, key:0x0, p-pri:0x8000, p:0x42, p-state:0x75,
s-pri:0x8000, s-mac:0014.a93d.4a00
*Aug 20 17:24:21.073: LACP: col-tlv:3, col-tlv-len:16, col-max-d:0x8000
*Aug 20 17:24:21.073: LACP: term-tlv:0 termr-tlv-len:0
*Aug 20 17:24:21.073: LACP: Gi5/0/0 LACP packet received, processing
*Aug 20 17:24:21.073: lacp_rx Gi5: during state DEFAULTED, got event 5(recv_lacpdu)
*Aug 20 17:24:21.929: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:21.929: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:21.929: LACP: timer lacp_t(Gi5/0/0) started with interval 1000.
*Aug 20 17:24:21.929: LACP: lacp_send_lacpdu: (Gi5/0/0) About to send the 110 LACPDU
*Aug 20 17:24:21.929: LACP :lacp_bugpak: Send LACP-PDU packet via Gi5/0/0
*Aug 20 17:24:21.929: LACP : packet size: 124
*Aug 20 17:24:22.805: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:22.805: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:23.025: LACP: lacp_w(Gi5/0/0) timer stopped
*Aug 20 17:24:23.025: LACP: lacp_w(Gi5/0/0) expired
*Aug 20 17:24:23.025: lacp_mux Gi5: during state WAITING, got event 4(ready)
*Aug 20 17:24:23.025: @@@ lacp_mux Gi5: WAITING -> ATTACHED
*Aug 20 17:24:23.921: LACP: lacp_t(Gi5/0/0) timer stopped
*Aug 20 17:24:23.921: LACP: lacp_t(Gi5/0/0) expired
*Aug 20 17:24:26.025: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to up

LACP 単一障害のロード バランス スワッピングのイネーブル化

EtherChannel で LACP 単一障害のロード バランス スワッピングをイネーブルにするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. lacp direct-loadswap

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface port-channel 1

ポート チャネル仮想インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

lacp direct-loadswap

 

Router(config-if)# lacp direct-loadswap

LACP 単一障害の直接ロード バランシングをイネーブルにします。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

EtherChannel 負荷分散アルゴリズムの選択

グローバル コンフィギュレーション モードまたはインターフェイス コンフィギュレーション モードのいずれかから、EtherChannel 負荷分散アルゴリズムを選択できます。グローバル コンフィギュレーション モードから適応型アルゴリズムまたは固定アルゴリズムのいずれかを選択するには、次のタスクを実行します。インターフェイス コンフィギュレーション モードからアルゴリズムを選択するには、 interface コマンドを実行してから port-channel hash-distribution コマンドを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number (任意)

4. port-channel hash-distribution { adaptive | fixed }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface port-channel1

(任意)ポート チャネル仮想インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

port-channel hash-distribution { adaptive | fixed }

 

Router(config)# port-channel hash-distribution adaptive

アルゴリズムのタイプを選択します。

(注) インターフェイス コンフィギュレーション モードでアルゴリズムを指定しなかった場合は、グローバル コンフィギュレーションが適用されます。それ以外の場合は、インターフェイス コンフィギュレーション モードで指定したアルゴリズムによって、グローバル コンフィギュレーション モードで指定したアルゴリズムが上書きされます。

ステップ 5

end

 

Router(config)# end

特権 EXEC モードに戻ります。

802.3ad 重み付けロード バランシングのイネーブル化

802.3ad 重み付けロード バランシングをイネーブルにするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. port-channel load-balance { link link-id | weighted { default weight weight | link { all | link-id } | rebalance { disable | weight }}}

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface portchannel10

ポート チャネル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

port-channel load-balance { link link-id | weighted { default weight weight | link { all | link-id } | rebalance { disable | weight }}}

 

Router(config-if)# port-channel load-balance weighted link all

ポート チャネルのメンバ リンクで重み付けロード バランシングを設定します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定の例

「例:チャネル グループとポート チャネルとの関連付け」

「例:バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除」

「例:LACP ステータスのモニタリング」

「例:重み付けサービス インスタンスの設定」

「例:重み付けロード バランシングと手動ロード バランシングの設定」

例:チャネル グループとポート チャネルとの関連付け

この例では、チャネル グループ番号 5 を設定し、それをチャネル グループに含める方法を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
Router(config)# interface port-channel5
Router(config-if)#
 
*Aug 20 17:06:14.417: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to down
*Aug 20 17:06:25.413: %LINK-3-UPDOWN: Interface Port-channel5, changed state to down
 
Router(config-if)#
Router(config-if)# interface gigabitethernet 7/0/0
Router(config-if)# channel-group 5 mode active
Router(config-if)#
 
*Aug 20 17:07:43.713: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:07:44.713: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:07:45.093: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 7/0/0 Physical Port Link Down
*Aug 20 17:07:45.093: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 7/0/0 Physical Port Link Down
*Aug 20 17:07:47.093: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:07:48.093: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:07:48.957: GigabitEthernet7/0/0 added as member-1 to port-channel5
 
*Aug 20 17:07:51.957: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel5, changed state to up
 
Router(config-if)# end
Router#
 
*Aug 20 17:08:00.933: %SYS-5-CONFIG_I: Configured from console by console
 
Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi7/0/0 SA bndl 32768 0x5 0x5 0x43 0x3D
 
Router# show interface port-channel5
 
Port-channel5 is up, line protocol is up
Hardware is GEChannel, address is 0014.a93d.4aa8 (bia 0000.0000.0000)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
No. of active members in this channel: 1
Member 0 : GigabitEthernet7/0/0 , Full-duplex, 1000Mb/s
Last input 00:00:05, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Interface Port-channel5 queueing strategy: PXF First-In-First-Out
Output queue 0/8192, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
9 packets output, 924 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

例:バンドルへのインターフェイスの追加およびバンドルからのインターフェイスの削除

次に、バンドルへのインターフェイスの追加方法の例を示します。

Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi7/0/0 SA bndl 32768 0x5 0x5 0x43 0x3D
 
Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
Router(config)# interface gigabitethernet 5/0/0
Router(config-if)# channel-group 5 mode active
Router(config-if)#
 
*Aug 20 17:10:19.057: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to down
*Aug 20 17:10:19.469: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:10:19.473: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:10:21.473: %LINK-3-UPDOWN: Interface GigabitEthernet5/0/0, changed state to up
*Aug 20 17:10:21.473: GigabitEthernet7/0/0 taken out of port-channel5
 
*Aug 20 17:10:23.413: GigabitEthernet5/0/0 added as member-1 to port-channel5
 
*Aug 20 17:10:23.473: %LINK-3-UPDOWN: Interface Port-channel5, changed state to up
 
Router(config-if)# end
Router#
 
*Aug 20 17:10:27.653: %SYS-5-CONFIG_I: Configured from console by console
 
*Aug 20 17:11:40.717: GigabitEthernet7/0/0 added as member-2 to port-channel5
 
Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi7/0/0 SA bndl 32768 0x5 0x5 0x43 0x3D
Gi5/0/0 SA bndl 32768 0x5 0x5 0x42 0x3D
 
Router# show interface port-channel5
 
Port-channel5 is up, line protocol is up
Hardware is GEChannel, address is 0014.a93d.4aa8 (bia 0000.0000.0000)
MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
No. of active members in this channel: 2
Member 0 : GigabitEthernet5/0/0 , Full-duplex, 1000Mb/s <---- added to port channel bundle
Member 1 : GigabitEthernet7/0/0 , Full-duplex, 1000Mb/s
Last input 00:00:00, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
Interface Port-channel5 queueing strategy: PXF First-In-First-Out
Output queue 0/8192, 0 drops; input queue 0/150, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 0 multicast, 0 pause input
104 packets output, 8544 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
 

次に、バンドルからのインターフェイスの削除方法の例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
 
Router(config)# interface gigabitethernet 7/0/0
Router(config-if)# no channel-group
Router(config-if)#
 
*Aug 20 17:15:49.433: GigabitEthernet7/0/0 taken out of port-channel5
 
*Aug 20 17:15:49.557: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:15:50.161: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 5/0/0 Physical Port Link Down
*Aug 20 17:15:51.433: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to down
*Aug 20 17:15:52.433: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to down
 
Router(config-if)# end
Router#
 
*Aug 20 17:15:58.209: %SYS-5-CONFIG_I: Configured from console by console
Router#
*Aug 20 17:15:59.257: %C10K_ALARM-6-INFO: ASSERT CRITICAL GigE 7/0/0 Physical Port Link Down
*Aug 20 17:15:59.257: %C10K_ALARM-6-INFO: CLEAR CRITICAL GigE 7/0/0 Physical Port Link Down
 
Router#
 
*Aug 20 17:16:01.257: %LINK-3-UPDOWN: Interface GigabitEthernet7/0/0, changed state to up
*Aug 20 17:16:02.257: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet7/0/0, changed state to up
 
Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi5/0/0 SA bndl 32768 0x5 0x5 0x42 0x3D

例:LACP ステータスのモニタリング

次に、 show lacp コマンドを使用してモニタできる LACP アクティビティの例を示します。

Router# show lacp internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi5/0/0 SA bndl 32768 0x5 0x5 0x42 0x3D
 
Router# show lacp 5 counters
 
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
---------------------------------------------------------------------
Channel group: 5
Gi5/0/0 21 18 0 0 0 0 0
 
Router# show lacp 5 internal
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Gi5/0/0 SA bndl 32768 0x5 0x5 0x42 0x3D
 
Router# show lacp 5 neighbor
 
Flags: S - Device is requesting Slow LACPDUs
F - Device is requesting Fast LACPDUs
A - Device is in Active mode P - Device is in Passive mode
 
Channel group 5 neighbors
 
Partner's information:
 
Partner Partner LACP Partner Partner Partner Partner Partner
Port Flags State Port Priority Admin Key Oper Key Port Number Port State
Gi5/0/0 SP 32768 0011.2026.7300 11s 0x1 0x14 0x3C
 
Router# show lacp counters
 
LACPDUs Marker Marker Response LACPDUs
Port Sent Recv Sent Recv Sent Recv Pkts Err
---------------------------------------------------------------------
Channel group: 5
Gi5/0/0 23 20 0 0 0 0 0
 
Router# show lacp sys-id
 
32768,0014.a93d.4a00

例:重み付けサービス インスタンスの設定

この例では、サービス インスタンス 100、101、および 200 のトラフィックが、ギガビット イーサネット インターフェイス 5/0/2 および 5/0/3 でロード バランスされます。設定した重みに基づいて、サービス インスタンス 100 および 101 からのトラフィックは 1 つのメンバ リンクから出力され、サービス インスタンス 200 からのトラフィックは、他のメンバ リンクから出力されます。

Router# configure terminal
Router(config)# interface GigabitEthernet5/0/2
Router(config-if)# channel-group 10 mode on
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/3
Router(config-if)# channel-group 10 mode on
Router(config-if)# exit
Router(config)# interface Port-channel10
Router(config-if)# port-channel load-balance weighted link all
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# weight 2
Router(config-if-srv)# exit
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# weight 2
Router(config-if-srv)# exit
Router(config-if)# service instance 200 ethernet
Router(config-if-srv)# encapsulation dot1q 200
Router(config-if-srv)# weight 10
Router(config-if-srv)# end

例:重み付けロード バランシングと手動ロード バランシングの設定

この例では、手動ロード バランシングと重み付けロード バランシングの組み合わせを設定します。サービス インスタンス 100 および 101 は、ギガビット イーサネット インターフェイス 5/0/2 のリンク 1 に手動で割り当てられます。ただし、ギガビット イーサネット インターフェイス 5/0/3 上のリンク 2 と、ギガビット イーサネット インターフェイス 5/0/4 上のリンク 3 には、重み付けロード バランシングが設定されます。サービス インスタンス 200 および 201 には明示的な重みを設定しないため、設定したデフォルトの 2 が継承されます。サービス インスタンス 200、201、および 300 は、ギガビット イーサネット インターフェイス 5/0/3 と 5/0/4 で分散されます。

Router(config)# interface GigabitEthernet5/0/2
Router(config-if)# channel-group 10 mode on link 1
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/3
Router(config-if)# channel-group 10 mode on link 2
Router(config-if)# exit
Router(config)# interface GigabitEthernet5/0/4
Router(config-if)# channel-group 10 mode on link 3
Router(config-if)# exit
!
Router(config)# interface Port-channel10
Router(config-if)# port-channel load-balance link 1
Router(config-if)# service-instance 100-150
Router(config-if)# port-channel load-balance weighted link 2,3
Router(config-if)# port-channel load-balance weighted default weight 2
Router(config-if)# port-channel load-balance weighted rebalance disable
Router(config-if)# service instance 100 ethernet
Router(config-if-srv)# encapsulation dot1q 100
Router(config-if-srv)# exit
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 101
Router(config-if-srv)# exit
Router(config-if)# service instance 200 ethernet
Router(config-if-srv)# encapsulation dot1q 200
Router(config-if-srv)# exit
Router(config-if)# service instance 201 ethernet
Router(config-if-srv)# encapsulation dot1q 201
Router(config-if-srv)# exit
Router(config-if)# service instance 300 ethernet
Router(config-if-srv)# encapsulation dot1q 300
Router(config-if-srv)# weight 5
Router(config-if-srv)# end

その他の参考資料

関連資料

関連項目
参照先

EtherChannel の設定

Catalyst 6500 Release 12.2SXF Software Configuration Guide 』の「 Configuring Layer 3 and Layer 2 EtherChannel 」の章

キャリア イーサネットの設定

『Cisco IOS Carrier Ethernet Configuration Guide』

Cisco IOS LACP のコマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用上の注意事項、および例

『Cisco IOS Carrier Ethernet Command Reference』

Cisco IOS コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項および例を記載したコマンド リスト

『Cisco IOS Master Command List, All Releases』

規格

規格
タイトル

IEEE 802.3ad-2000

『IEEE 802.3ad-2000 Link Aggregation』

MIB

MIB
MIB リンク

802.3ad MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連の Cisco IOS ソフトウェア リリースでもサポートされます。


 

表 1 IEEE 802.3ad リンク バンドルおよびロード バランシングの設定に関する機能情報

機能名
リリース
機能情報

重み付けロード バランシングによる 802.3ad リンク集約

15.0(1)S

802.3ad LAG with WLB 機能は、現在のロード バランシング メカニズムを拡張したものです。これにより、サービス インスタンスに重みを割り当て、ポート チャネル内のアクティブなメンバ リンク間にトラフィック フローを効率的に分散させることができます。

この機能については、次の項に説明があります。

「重み付けロード バランシングによる 802.3ad リンク集約」

次のコマンドが、新たに導入または変更されました。 debug port-channel load-balance port-channel load-balance (インターフェイス)、 port-channel load-balance weighted rebalance show ethernet service instance weight (サービス インスタンス)

EtherChannel での負荷分散

12.2(33)SRC

EtherChannel での負荷分散機能は、追加または削除されたポートに対するロード バランスの再割り当てを制限することで、EtherChannel の可用性を高めるポート再割り当て方法を使用します。ポートが追加または削除されたときに、バンドルされた既存のポートに新しい負荷がかかっても、それらのポート上でプログラムされている負荷と競合することはありません。

この機能に関する詳細については、次の各項を参照してください。

「EtherChannel での負荷分散」

「EtherChannel 負荷分散アルゴリズムの選択」

次のコマンドが、新たに導入または変更されました。 port-channel port hash-distribution show etherchannel

EtherChannel Min-Links

12.2(33)SB 15.0(1)S

EtherChannel Min-Links 機能を使用すると、アクティブ リンク数が最小しきい値を下回ったときに、ポート チャネルをシャットダウンすることができます。最小しきい値は、 lacp min-bundle コマンドを使用して設定します。

この機能に関する詳細については、次の各項を参照してください。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

「アクティブ リンクの最小数の設定」

次のコマンドが、新たに導入または変更されました。 lacp min-bundle

IEEE 802.3ad 高速リンク スイッチオーバー時間

12.2(33)SB

IEEE 802.3ad 高速リンク スイッチオーバー時間機能によって、250 ミリ秒以下から最大 2 秒のリンク フェールオーバー時間を実現します。また、ポート チャネルが LINK_UP 状態を維持し、スパニング ツリー プロトコルによる再収束が回避されます。

この機能については、次の項に説明があります。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

次のコマンドが、新たに導入または変更されました。 lacp fast-switchover

IEEE 802.3ad Link Aggregation(LACP)

12.2(31)SB212.2(33)SRB 12.2(33)SRC 15.0(1)S

IEEE 802.3ad リンク バンドル機能を使用すると、複数のイーサネット リンクを、IEEE 802.3ad 規格に基づいて単一の論理チャネルに集約できます。また、この機能により、さまざまな集約リンクを動的にプロビジョニング、管理、およびモニタすることができ、さまざまなシスコ デバイスとサードパーティ ベンダーのデバイスを相互に運用できます。

12.2(31)SB2 では、この機能が Cisco 10000 シリーズ ルータで実装されました。

12.2(33)SRB では、この機能が Cisco 7600 ルータに実装されました。

12.2(33)SRC では、 lacp rate コマンドが追加されました。

この機能に関する詳細については、次の各項を参照してください。

「IEEE 802.3ad リンク バンドル」

「IEEE 802.3ad リンク バンドルおよびロード バランシングの設定方法」

「IEEE 802.3ad リンク バンドルおよびロード バランシングの設定の例」

次のコマンドが、新たに導入または変更されました。 channel-group( インターフェイス debug lacp lacp max-bundle lacp port-priority lacp rate lacp system-priority show lacp

IEEE 802.3ad リンク最大数の追加

12.2(33)SB

IEEE 802.3ad リンク最大数の追加機能は、LACP バンドルによって、8 つのメンバ リンクをサポートします。メンバ数は、これまでのリリースの 4 つから増加しました。

この機能については、次の項に説明があります。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

この機能で使用される新しいコマンドまたは変更されたコマンドはありません。

LACP 単一障害の直接ロード バランス スワッピング

12.2(33)SRC 15.0(1)S

LACP 単一障害の直接ロード バランス スワッピング機能は、ロード バランス ビットを再割り当てすることにより、処理を引き継いだホット スタンバイ ポートに対し、故障したポートのロード バランス ビットが割り当てられ、集約内のその他のポートのロード バランス ビットはそのままにします。交換されたポートがバンドルされると、ロードシェアが再計算され、故障したポートで保存されているロードシェアが、処理を引き継いだポートに割り当てられます。バンドル内の他のポートには影響がありません。

この機能に関する詳細については、次の各項を参照してください。

「LACP 単一障害の直接ロード バランス スワッピング」

「LACP 単一障害のロード バランス スワッピングのイネーブル化」

次のコマンドが、新たに導入または変更されました。 lacp direct-loadswap show etherchannel

PPPoX ヒットレス フェールオーバー

12.2(33)SB

PPPoX ヒットレス フェールオーバー機能を使用すると、ポート チャネルは、リンク スイッチオーバーの間、LINK_UP 状態を維持できます。PPPoEoE、PPPoEoQinQ、および PPPoVLAN セッションでは、スイッチオーバー後、アクティブ リンクとスタンバイ リンクで同一の設定要素が実現されるので、セッションを再確立する必要がありません。

この機能については、次の項に説明があります。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

この機能で使用される新しいコマンドまたは変更されたコマンドはありません。

SSO - LACP

12.2(33)SB

SSO - LACP 機能は、ギガビット EtherChannel バンドルで、Stateful Switchover(SSO; ステートフル スイッチオーバー)、In Service Software Upgrade(ISSU)、Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)、および Nonstop Routing(NSR; ノンストップ ルーティング)をサポートしています。

この機能については、次の項に説明があります。

「Cisco IOS Release 12.2(33)SB で導入された LACP 拡張」

この機能で使用される新しいコマンドまたは変更されたコマンドはありません。