IPv6 コンフィギュレーション ガイド、Cisco IOS Release 15.1S
モバイル IPv6 の実装
モバイル IPv6 の実装
発行日;2012/02/05 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

モバイル IPv6 の実装

機能情報の確認

目次

モバイル IPv6 の実装の制約事項

モバイル IPv6 の実装に関する情報

モバイル IPv6 の概要

モバイル IPv6 の機能

IPv6 NEMO

モバイル IPv6 ホーム エージェント

モバイル IPv6 ホーム エージェントのバインディング キャッシュ

モバイル IPv6 ホーム エージェントのバインディング アップデート リスト

ホーム エージェント リスト

NEMO 対応ホーム エージェント

モバイル IPv6 のパケット ヘッダー

モバイル IPv6 での IPv6 ネイバー探索

NEMO での IPv6 ネイバー探索重複アドレス検出

モバイル IPv6 トンネルの最適化

IPv6 ホスト グループの設定

NAI に基づくモバイル IPv6 ノードの識別

モバイル IPv6 の認証プロトコル

モバイル IPv6 の実装方法

ルータでのモバイル IPv6 のイネーブル化

モバイル IPv6 のバインディング情報の設定

IPv6 モバイル ルータでの NEMO のイネーブルと設定

IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化

IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル

モバイル IPv6 プロトコル ヘッダーおよびオプションのフィルタリング

ICMP 到達不能メッセージの制御

モバイル IPv6 のネイティブ IPv6 トンネリングの検証

モバイル IPv6 のホスト グループの設定と検証

制約事項

インターフェイスでのモバイル IPv6 のカスタマイズ

ルータでのモバイル IPv6 の監視および保守

モバイル IPv6 の実装の設定例

例:ルータでのモバイル IPv6 のイネーブル化

例:IPv6 モバイル ルータでの NEMO のイネーブル化と設定

例:IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化

例:IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル化

例:モバイル IPv6 のホスト グループの設定

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

モバイル IPv6 の実装の機能情報

モバイル IPv6 の実装

モバイル IP は、IPv4 と IPv6 の両方の規格の一部として含まれています。モバイル IP を使用すると、ホスト デバイスが物理的な接続ポイントをあるネットワークから別のネットワークに移動する可能性がある場合でも、そのデバイスを単一の IP アドレスで識別できます。異なるネットワーク間での移動にかかわらず、異なるポイントでの接続は、ユーザの介入なくシームレスに行われます。有線ネットワークからワイヤレス ネットワークまたはワイドエリア ネットワークへのローミングも簡単に行われます。モバイル IP は、ユーザが企業ネットワーク内にいるか自宅から離れているかにかかわらず、ユーザにユビキタス接続を提供します。

このマニュアルでは、モバイル IPv6 に関する情報を説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「モバイル IPv6 の実装の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、および Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

モバイル IPv6 の実装の制約事項

Network Mobility(NEMO; ネットワーク モビリティ)基本サポート プロトコル機能を使用する場合、ユーザはどのローミング インターフェイスでも IPv6 ルーティング プロトコルをイネーブルにしてはなりません。

モバイル IPv6 の実装に関する情報

「モバイル IPv6 の概要」

「モバイル IPv6 の機能」

「IPv6 NEMO」

「モバイル IPv6 ホーム エージェント」

「モバイル IPv6 のパケット ヘッダー」

「モバイル IPv6 での IPv6 ネイバー探索」

「モバイル IPv6 トンネルの最適化」

「IPv6 ホスト グループの設定」

モバイル IPv6 の概要

モバイル IPv4 は、ネットワーク間を移動するときに、同じ IPv4 アドレスを保持し、中断のないネットワークおよびアプリケーション接続を維持する機能を IPv4 ノードに提供します。モバイル IPv6 では、IPv6 アドレス空間によって、任意の種類の大規模環境へのモバイル IP の展開がイネーブルになります。モバイル IPv6 を使用するために外部エージェントは不要です。

モバイル IPv6 ノードを受け入れるためにシステム インフラストラクチャをアップグレードする必要はありません。IPv6 自動設定によって、Mobile Node(MN; モバイル ノード)Care of Address(CoA; 気付アドレス)の割り当てが簡略化されます。

モバイル IPv6 は IPv6 プロトコルのメリットを利用します。たとえば、モバイル IPv6 では、IPv6 オプション ヘッダー(ルーティング、宛先、およびモビリティ)を使用し、ネイバー探索のメリットを利用します。

モバイル IPv6 は、三角ルーティングの回避に役立つ最適化されたルーティングを提供します。モバイル IPv6 ノードは、モビリティをサポートしないノードでも透過的に動作します(ただし、これらのノードはルートの最適化を行いません)。

モバイル IPv6 は、既存の IPv6 仕様との完全な下位互換性があります。したがって、新しいモバイル メッセージを認識しない既存のホストは、直接ルーティング最適化は行いませんが、エラー メッセージを送信し、モバイル ノードとの通信を継続できます。

モバイル IPv6 の機能

モバイル IPv6 を実装するには、モバイル ノードのホーム アドレスが存在するホーム サブネット上にホーム エージェントが必要です。IPv6 Home Address(HA; ホーム アドレス)がモバイル ノードに割り当てられます。モバイル ノードは、接続先のネットワーク上で新しい IPv6 アドレス(CoA)を取得します。ホーム エージェントは、モバイル ノードの場所をエージェントに通知する BU をモバイル ノードから受け入れます。ホーム エージェントは、モバイル ノードのプロキシとして機能し、モバイル ノードのホーム アドレスへのトラフィックを代行受信して、モバイル ノードにトンネリングします。

モバイル ノードは、元のホーム ネットワーク上のホーム エージェントに新しいアドレスを通知し、対応ノードはモバイル ノードに CoA について通知します。入力フィルタリングを使用しているため、モバイル ノードはホーム エージェントへのトンネル リターン トラフィックを反転させ、モバイル ノードの送信元アドレス(ホーム アドレス)が常に地理的に正しくなるようにします。

モバイル IPv6 とは、対応ノードへの IP パケットの送信時にモバイル ノードがホーム エージェントをバイパスする機能です。オプションの拡張によってモバイル IPv6 での直接ルーティングが可能になりますが、拡張は一部のモバイル IPv6 の展開では実装されない場合があります。

直接ルーティングはモバイル IPv6 に組み込まれており、直接ルーティング機能では IPv6 ルーティング ヘッダーと IPv6 宛先オプション ヘッダーが使用されます。ルーティング ヘッダーは現在の CoA を使用したモバイル ノードへのパケットの送信に使用され、現在の CoA はパケットの送信元アドレスであるため、新しいホーム アドレス宛先オプションがモバイル ノードのホーム アドレスを含めるために使用されます。

IPv6 NEMO

NEMO 基本サポート プロトコルにより、モバイル IPv6 ネットワークをインターネット上の異なるポイントに接続できます。このプロトコルはモバイル IPv6 の拡張であり、ネットワークが移動するときに、モバイル ネットワーク内のすべてのノードでセッションを継続できます。NEMO を使用すると、ユーザの移動中もモバイル ネットワーク内のすべてのノードが到達可能になります。ネットワークをインターネットに接続するモバイル ルータは、NEMO 基本サポート プロトコルをその Home Agent(HA; ホーム エージェント)で実行します。NEMO を使用すると、ネットワーク モビリティがモバイル ネットワークの内部のノードに対して透過的になります。

NEMO ルータは、ローミング インターフェイスを介した IPv6 のデフォルト ルートであるモバイル ルートを維持します。

モバイル IPv6 ホーム エージェント

ホーム エージェントは、モバイル IPv6 の 3 つの主要コンポーネントの 1 つです。ホーム エージェントは、対応ノードおよびモバイル ノードと連携して、モバイル IPv6 機能をイネーブルにします。

ホーム エージェント:ホーム エージェントは、モバイル モードのホーム IPv4 または IPv6 アドレスと、外部ネットワーク上のその CoA(貸与アドレス)との間の関連付けを維持します。

対応ノード:対応ノードは、モバイル ノードとのセッションでの宛先 IPv4 または IPv6 ホストです。

モバイル ノード:接続先のリンク(またはネットワーク)に関係なく、ホーム IPv4 または IPv6 アドレスを使用してネットワーク接続を維持する IPv4 ホストまたは IPv6 ホストです。

ここでは、モバイル IPv6 ホーム エージェントの機能について説明します。

「モバイル IPv6 ホーム エージェントのバインディング キャッシュ」

「モバイル IPv6 ホーム エージェントのバインディング アップデート リスト」

「ホーム エージェント リスト」

「NEMO 対応ホーム エージェント」

モバイル IPv6 ホーム エージェントのバインディング キャッシュ

各 IPv6 ノードによって、その IPv6 アドレスごとに個別のバインディング キャッシュが維持されます。ルータは、パケットの送信時に、ネイバー探索の概念的な宛先キャッシュを検索する前に IPv6 アドレスのバインディング キャッシュを検索します。

ノードのいずれの IPv6 アドレスのバインディング キャッシュにも、モバイル ノード ホーム アドレスごとに 1 つのエントリを含めることができます。ノードのすべてのバインディング キャッシュ エントリの内容は、再起動時にクリアされます。

バインディング キャッシュ エントリは、ホーム登録エントリまたは対応登録エントリとしてマークされます。ホーム登録エントリは、バインディング ライフタイムの期限が切れると削除されます。その他のエントリは、ローカル キャッシュ置換ポリシーを通じていつでも置換できます。

モバイル IPv6 ホーム エージェントのバインディング アップデート リスト

Binding Update(BU; バインディング アップデート)リストは、各モバイル ノードによって維持されます。BU リストには、ライフタイムがまだ期限切れになっていない、このモバイル ノードによって送信された各 BU の情報が記録されます。BU リストには、モバイル ノードによって送信されたすべての BU(対応ノードに送信されたバインディング、およびモバイル ノードのホーム エージェントに送信されたバインディング)が含まれます。

モビリティ拡張ヘッダーには、新しいルーティング ヘッダー タイプと新しい宛先オプションがあり、BU プロセス中に使用されます。このヘッダーは、バインディングの作成と管理に関連するすべてのメッセージで、モバイル ノード、対応ノード、およびホーム エージェントによって使用されます。

ホーム エージェント リスト

ホーム エージェント リストは、各ホーム エージェントと各モバイル ノードによって維持されます。ホーム エージェント リストには、このノードが最近受信した、ホーム エージェント(H)ビットが設定されたルータ アドバタイズメントの送信元の各ホーム エージェントに関する情報が記録されます。

各ホーム エージェントでは、ホーム エージェントが機能するリンクごとに別々のホーム エージェント リストが維持されます。このリストは、動的ホーム エージェント アドレス検出メカニズムでホーム エージェントによって使用されます。各ローミング モバイル ノードでは、新しいリンクに移動したときに前のリンク上のホーム エージェントに通知できるようにするホーム エージェント リストも維持されます。

NEMO 対応ホーム エージェント

モバイル IPv6 のプロトコル拡張を使用して、ネットワーク モビリティのサポートをイネーブルにします。拡張は、既存のモバイル IPv6 機能との下位互換性があります。NEMO 対応ホーム エージェントは、モバイル IPv6 ホーム エージェントとして動作できます。

Dynamic Home Agent Address Discovery(DHAAD; 動的ホーム エージェント アドレス検出)メカニズムにより、モバイル ノードはそのホーム リンク上のホーム エージェントのアドレスを検出できます。次のリストでは、DHAAD の機能について説明します。

モバイル ルータは、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)ホーム エージェント アドレス検出要求をモバイル IPv6 ホーム エージェントのホーム サブネット プレフィクスのエニーキャスト アドレスに送信する。

モバイル ルータをサポートするホーム エージェントを検出することを指定する新しいフラグ(R)が DHAAD 要求メッセージに導入されている。このフラグは、DHAAD 返信メッセージにも追加されています。

ホーム エージェント アドレス検出の返信メッセージを受信すると、モバイル ルータはホーム リンクで稼動しているホーム エージェントを検出する。

モバイル ルータは、登録が受け入れられるまで、各ホーム エージェントへのホーム登録を試行する。モバイル ルータは、ホーム登録試行のたびに、ホーム登録試行間の推奨時間が経過するまで待機します。

暗黙のプレフィクス登録

暗黙のプレフィクス登録を使用している場合、モバイル ルータはホーム エージェントでのバインディング アップデートの一部としてプレフィクスを登録しません。この機能には、ホーム エージェントでの静的な設定が必要であり、ルート転送を設定するには、ホーム エージェントに、特定のモバイル ルータに関連付けられたプレフィクスに関する情報が必要です。

明示的なプレフィクス登録

明示的なプレフィクス登録を使用する場合、モバイル ルータは、バインディング アップデート手順の一部として、プレフィクスのリストをホーム エージェントに提示します。ホーム エージェントは、モバイル ルータがこれらのプレフィクスの使用を承認されていると判断した場合に、バインド確認応答メッセージを送信します。

モバイル IPv6 のパケット ヘッダー

基本 IPv6 パケット ヘッダーには、合計サイズが 40 オクテット(320 ビット)の 8 つのフィールドがあります。IPv6 では、フラグメンテーションはルータによって処理されず、チェックサムはネットワーク レイヤで使用されないため、IPv4 ヘッダーと比べると、IPv6 ヘッダーからはフィールドが除去されました。代わりに、IPv6 のフラグメンテーションはパケットの送信元によって処理され、チェックサムはデータ リンク レイヤとトランスポート レイヤで使用されます また、基本 IPv6 パケット ヘッダーおよびオプション フィールドは 64 ビットに揃えられています。これにより、IPv6 パケットの処理が容易になります。

モバイル IPv6 では、モバイル ノードと対応ノード間の通信にルーティングおよび宛先オプション ヘッダーが使用されます。新しいモビリティ オプション ヘッダーは、BU プロセスにだけ使用されます。

モバイル IPv6 をサポートするために、いくつかの ICMP メッセージ タイプが定義されています。IPv6 アクセス リストを設定して、モバイル IPv6 固有の ICMP メッセージと一致する IPv6 アクセス リスト エントリを設定したり、モバイル IPv6 拡張ヘッダーを含むパケットに一致するエントリを定義したりできます。

IPv6 パケット ヘッダーの詳細については、「 Implementing IPv6 Addressing and Basic Connectivity 」の章を参照してください。

モバイル IPv6 での IPv6 ネイバー探索

IPv6 ネイバー探索機能は、モバイル IPv6 で動作するように次の変更が加えられています。

変更されたルータ アドバタイズメント メッセージ形式:ホーム エージェント サービスを示す単一のフラグ ビットがあります。

変更されたプレフィクス情報オプション形式:ルータがグローバル アドレスをアドバタイズできます。

新しいアドバタイズメント間隔オプション形式

新しいホーム エージェント情報オプション形式

ルータ アドバタイズメントの送信に対する変更

モバイル ノードのタイムリーな移動検出

NEMO での IPv6 ネイバー探索重複アドレス検出

IPv6 ルータは、ステートレスおよびステートフル自動設定モードで取得された IPv6 アドレスをいずれかのインターフェイスに割り当てる前に、すべての IPv6 アドレスに対して Duplicate Address Detection(DAD; 重複アドレス検出)を実行する必要があります。モバイル ルータがローミングして IPv6 アドレスを取得するたびに、モバイル ルータは、アドレスの衝突を回避するために、新規に取得した気付アドレスとそのリンクローカル アドレスに対して DAD を実行する必要があります。

ただし、DAD 機能は、特定のレイヤ 2 環境で大きなハンドオフ遅延を発生させます。これらの遅延は、オプティミスティック DAD 手法を使用して回避できます。NEMO では、気付アドレスまたは気付アドレスとリンクローカル アドレスの両方で DAD を省略するための最適化オプションがサポートされます。

IPv6 ネイバー探索の詳細については、「 IPv6 アドレッシングと基本接続の実装 」の章を参照してください。

モバイル IPv6 トンネルの最適化

モバイル IPv6 トンネルの最適化により、ネイティブ IPv6 トンネル インフラストラクチャ上でのルーティングがイネーブルになり、モバイル IPv6 は、シスコ エクスプレス フォワーディング スイッチング サポートなどのすべての IPv6 トンネリング インフラストラクチャ機能を使用できます。

ホーム エージェントは、モバイル ノードから有効な BU 要求を受信したあとで、双方向トンネルのエンドポイントを設定します。このプロセスには、カプセル化モードが IPv6/IPv6 に設定された論理インターフェイス、モバイル ノードのホーム リンク上のホーム エージェントのアドレスへのトンネル ソース、およびモバイル ノードの登録済み気付アドレスに設定されたトンネル宛先の作成が関係します。ルートは、トンネルを介してモバイル ノードのホーム アドレスのルーティング テーブルに挿入されます。

IPv6 ホスト グループの設定

ユーザは、IPv6 ホスト グループ設定を使用してモバイル ユーザ ポリシーまたはモバイル グループ ポリシーを作成できます。ホスト グループ プロファイル ルックアップ インターフェイスにより、任意の検索キーを使用して、BU の送信元に関連付けられているプロファイルをルックアップできます。

プロファイル名

IPv6 アドレス

Network Address Identifier(NAI; ネットワーク アドレス識別子)

ホスト プロファイル ルックアップ インターフェイスでは、単一方向または双方向 Security Parameter Index(SPI; セキュリティ パラメータ インデックス)を作成することにより、IPv6 モバイル ノードの認証プロパティも指定されます。

グループ プロファイルは、SPI オプションが設定され、NAI または IPv6 アドレスが設定されたあとでアクティブになります。また、必要な最小限のオプションが設定されていない場合は、プロファイルが非アクティブになります。アクティブ バインディングを持ついずれかのアクティブ プロファイルが非アクティブ化または削除された場合は、そのプロファイルに関連付けられているすべてのバインディングが無効になります。

NAI に基づくモバイル IPv6 ノードの識別

モバイル ノードは、ホーム アドレスを識別子として使用して自身を識別できます。モバイル IPv6 プロトコル メッセージでは、登録メッセージでこの識別子を使用します。ただし、特定の展開では、モバイル ノードに、ネットワーク アドレスではなく NAI などの論理識別子を使用して自身を識別する機能が必要です。モバイル IPv6 のモバイル ノード識別子オプションにより、IPv6 アドレスではなく NAI によってモバイル ノードを識別できます。この機能により、ネットワークはモバイル ノードに動的 IPv6 アドレスを付与したり、Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)を使用してモバイル ノードを認証したりできます。このオプションは、Internet Key Exchange(IKE; インターネット キー エクスチェンジ)または IPsec が BU または Binding Acknowledgments(BA; バインディング確認応答)の保護に使用されていない場合に使用する必要があります。

ローミング サービスを提供するために、NAI やモバイル ノード ホーム アドレスなど、ユーザを識別するための標準化された方法が必要です。ローミングとは、1 つの Internet Service Providers(ISP; インターネット サービス プロバイダー)との正式なカスタマー/ベンダー関係を維持したまま、複数の ISP のいずれか 1 つを使用できる機能として大まかに定義できます。ローミング機能が必要になる例として、ISP 連合および ISP が提供する企業ネットワーク アクセス サポートがあります。ローミング機能に関心を持つその他のエンティティは次のとおりです。

より広いエリアでダイヤルアップ サービスを提供するために他の地域プロバイダーとの協力を望む、特定の州や地域で営業している地域 ISP。

別の国の 1 つ以上の ISP と事業を連合して、複数の国や 1 つの大陸でより包括的なダイヤルアップ サービスを提供することを望む国内 ISP。

1 つ以上の ISP にサービスを提供するワイヤレス LAN ホット スポット。

世界規模で従業員にダイヤルアップ サービスの包括的なパッケージを提供することを望む企業。これらのサービスには、インターネット アクセスや、VPN を使用した企業イントラネットへのセキュア アクセスがあります。

モバイル IPv6 の認証プロトコル

モバイル IPv6 サポートの認証プロトコルでは、MN-HA モビリティ メッセージ認証オプションを使用してモバイル ノードとホーム エージェントのシグナリングが保護されます。このオプションは、共有キーに基づく Mobile Node(MN; モバイル ノード)と HA 間のセキュリティ アソシエーションに基づいて、BU および BA メッセージを認証します。この機能により、非 IPsec 認証方式が必要な実稼動環境にモバイル IPv6 を展開できます。MN-HA は、モビリティ SPI、共有キー、認証アルゴリズム、およびモビリティ メッセージ リプレイ保護オプションから構成されます。

モビリティ SPI は、256 ~ 4,294,967,296 の数値です。キーは、任意の値から構成され、16 オクテットの長さです。使用される認証アルゴリズムは HMAC_SHA1 です。リプレイ保護メカニズムでは、シーケンス番号オプションまたはタイムスタンプ オプションを使用できます。MN-HA モビリティ メッセージ認証オプションは、メッセージ内の唯一のモビリティ メッセージ認証オプションである場合には、モビリティ ヘッダーを持つメッセージの最後のオプションである必要があります。

BU または BA メッセージが MN-HA オプションなしで受信され、そのメッセージを受信したエンティティが MN-HA オプションを使用するように設定されているか、モビリティ メッセージ認証オプションの共有キーに基づくモビリティ セキュリティ アソシエーションを持つ場合は、エンティティによって受信メッセージが廃棄されます。

モビリティ メッセージ リプレイ保護オプションにより、ホーム エージェントは、BU がモバイル ノードによって新規に生成されたものであり、攻撃者によって以前の BU からリプレイされていないことを確認できます。この機能は、バインディング エントリが削除されたあとでホーム エージェントがモバイル ノードに関するステートフル情報を維持しない場合に特に役立ちます。ホーム エージェントは、BU が認証されたあとでリプレイ保護チェックを実行します。モビリティ メッセージ リプレイ保護オプションは、BA を BU と照合するためにモバイル ノードによって使用されます。ホーム エージェントは、モビリティ メッセージ リプレイ保護オプションを BU で受信した場合に、BA にモビリティ メッセージ リプレイ保護オプションを含める必要があります。

モバイル IPv6 の実装方法

「ルータでのモバイル IPv6 のイネーブル化」

「モバイル IPv6 のバインディング情報の設定」

「IPv6 モバイル ルータでの NEMO のイネーブルと設定」

「IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化」

「IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル」

「モバイル IPv6 プロトコル ヘッダーおよびオプションのフィルタリング」

「ICMP 到達不能メッセージの制御」

「モバイル IPv6 のネイティブ IPv6 トンネリングの検証」

「モバイル IPv6 のホスト グループの設定と検証」

「インターフェイスでのモバイル IPv6 のカスタマイズ」

「ルータでのモバイル IPv6 の監視および保守」

ルータでのモバイル IPv6 のイネーブル化

指定したインターフェイスでモバイル IPv6 をイネーブルにし、モバイル IPv6 情報を表示するには、次の作業を実行します。モバイル IPv6 を開始する前(「インターフェイスでのモバイル IPv6 のカスタマイズ」を参照)またはモバイル IPv6 が稼動しているときに、インターフェイス コンフィギュレーション パラメータをカスタマイズできます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 mobile home-agent [ preference preference-value ]

5. exit

6. exit

7. show ipv6 mobile globals

8. show ipv6 mobile home-agent [ interface - type interface-number [ prefix ]]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 2

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 mobile home-agent [ preference preference-value ]

 

Router(config-if)# ipv6 mobile home-agent

特定のインターフェイスでモバイル IPv6 ホーム エージェントを初期化し、起動します。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 6

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

ステップ 7

show ipv6 mobile globals

 

Router# show ipv6 mobile globals

グローバル モバイル IPv6 パラメータを表示します。

ステップ 8

show ipv6 mobile home-agent [ interface - type interface-number [ prefix ]]

 

Router# show ipv6 mobile home-agent

ローカルおよび検出済みのネイバー ホーム エージェントを表示します。

モバイル IPv6 のバインディング情報の設定

指定したインターフェイスでモバイル IPv6 を開始する前に、ルータでバインディング情報を設定できます。IPv6 ルータでバインディング情報を設定および検証するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. ipv6 mobile home-agent

4. binding [ access access-list-name | auth-option | seconds | maximum | refresh ]

5. exit

6. exit

7. show ipv6 mobile binding [ care-of-address address | home-address address | interface - type interface-number ]

8. show ipv6 mobile traffic

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 mobile home-agent

 

Router(config)# ipv6 mobile home-agent

ルータをホームエージェント コンフィギュレーション モードにします。

ステップ 4

binding [ access access-list-name | auth-option | seconds | maximum | refresh ]

 

Router(config-ha)# binding

モバイル IPv6 ホーム エージェント機能のバインディング オプションを設定します。

ステップ 5

exit

 

Router(config-ha)# exit

ホームエージェント コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 6

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

ステップ 7

show ipv6 mobile binding [ care-of-address address | home-address address | interface - type interface-number ]

 

Router# show ipv6 mobile binding

バインディング キャッシュに関する情報を表示します。

ステップ 8

show ipv6 mobile traffic

 
Router# show ipv6 mobile traffic

受信した BU および送信した BA に関する情報を表示します。

IPv6 モバイル ルータでの NEMO のイネーブルと設定

NEMO 基本サポート プロトコルにより、モバイル IPv6 ネットワークをインターネット上の異なるポイントに接続できます。IPv6 モバイル ルータで NEMO をイネーブルにし、設定するには、次の作業を実行します。また、NEMO 設定を検証する方法も示します。

手順の概要

1. enable

2. configure terminal

3. ipv6 mobile router

4. eui-interface interface-type interface-number

5. home-network ipv6-prefix

6. home-address { home-network | ipv6-address-identifier | interface }

7. explicit-prefix

8. register { extend expire seconds retry number interval seconds | lifetime seconds | retransmit initial milliseconds maximum milliseconds retry number }

9. exit

10. exit

11. show ipv6 mobile router [ running-config | status ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 mobile router

 

Router(config)# ipv6 mobile router

ルータで IPv6 NEMO 機能をイネーブルにし、ルータを IPv6 モバイル ルータ コンフィギュレーション モードにします。

ステップ 4

eui-interface interface-type interface-number

 

Router(IPv6-mobile-router)# eui-interface Ethernet0/0

IPv6 モバイル ホーム アドレスを取得するために、指定したインターフェイスの Media Access Control(MAC; メディア アクセス制御)アドレスを使用します。

ステップ 5

home-network ipv6-prefix

 

Router(IPv6-mobile-router)# home-network 2001:0DB1:1/64

モバイル ルータにホーム ネットワークの IPv6 プレフィクスを指定します。

ユーザは、最大 10 個のホームネットワーク エントリを設定できます。これらのエントリは優先度の順に使用されます。プレフィクスは、モバイル ルータのホーム ネットワークを識別し、モバイル ルータがいつ自宅にあるかを検出するために使用されます。

ステップ 6

home-address { home-network | ipv6-address-identifier | interface }
 

Router(IPv6-mobile-router)# home-address home-network eui-64

IPv6 アドレスまたはインターフェイス識別子を使用して、モバイル ルータ ホーム アドレスを指定します。

複数のホーム ネットワークが設定されている場合は、モバイル ルータが登録先のホーム ネットワークに一致するホーム アドレスを構築するように、 home-address home-network コマンド構文を使用することを推奨します。

ステップ 7

explicit-prefix
 

Router(IPv6-mobile-router)# explicit-prefix

IPv6 モバイル ルータに接続されている IPv6 プレフィクスを登録します。

ステップ 8

register { extend expire seconds retry number interval seconds | lifetime seconds | retransmit initial milliseconds maximum milliseconds retry number }

 

Router(IPv6-mobile-router)# register lifetime 600

IPv6 モバイル ルータの登録パラメータを制御します。

ステップ 9

exit

 

Router(IPv6-mobile-router)# exit

IPv6 モバイル ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 10

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

ステップ 11

show ipv6 mobile router [ running-config | status ]

 

Router# show ipv6 mobile router

IPv6 モバイル ルータに関する設定情報と監視統計情報を表示します。

IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化

手順の概要

1. enable

2. configure terminal

3. ipv6 router nemo

4. distance [ mobile-distance ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 router nemo

 

Router(config)# ipv6 router nemo

ホーム エージェントで NEMO ルーティング プロセスをイネーブルにし、ルータをルータ コンフィギュレーション モードにします。

ステップ 4

distance [ mobile- distance ]

 

Router(config-rtr)# distance 10

NEMO ルートの管理ディスタンスを定義します。

IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 mobile router-service roam [ bandwidth-efficient | cost-efficient | priority value ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 mobile router-service roam [ bandwidth-efficient | cost-efficient | priority value ]

 

Router(config-if)# ipv6 mobile router-service roam

IPv6 モバイル ルータ インターフェイスのローミングをイネーブルにします。

モバイル IPv6 プロトコル ヘッダーおよびオプションのフィルタリング

IPv6 拡張ヘッダーは、モバイル IPv6 に固有のオプション ヘッダーの使用をサポートするために開発されました。IPv6 モビリティ ヘッダー、タイプ 2 ルーティング ヘッダー、および宛先オプション ヘッダーにより、モバイル IPv6 固有の ICMPv6 メッセージと一致する IPv6 アクセス リスト エントリの設定と、新規および変更された IPv6 拡張ヘッダーを含むパケットと一致するエントリの定義が可能になります。

モバイル IPv6 プロトコル ヘッダーおよびオプションのフィルタリングをイネーブルにするには、次の作業を実行します。IPv6 アクセス リストの作成、設定、および適用方法については、「 Implementing Traffic Filters and Firewalls for IPv6 Security 」の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. ipv6 access-list access-list-name

4. permit icmp { source-ipv6-prefix / prefix-length | any | host source-ipv6-address | auth } [ operator [ port-number ]] { destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address | auth } [ operator [ port-number ]] [ icmp-type [ icmp-code ] | icmp-message ] [ dest-option-type [ doh-number | doh-type ]] [ dscp value ] [ flow-label value ] [ fragments ] [ log ] [ log-input ] [ mobility ] [ mobility-type [ mh-number | mh-type ]] [ routing ] [ routing-type routing-number ] [ sequence value ] [ time-range name ]
または
deny icmp { source-ipv6-prefix / prefix-length | any | host source-ipv6-address | auth } [ operator [ port-number ]] { destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address | auth } [ operator [ port-number ]] [ icmp-type [ icmp-code ] | icmp-message ] [ dest-option-type [ doh-number | doh-type ]] [ dscp value ] [ flow-label value ] [ fragments ] [ log ] [ log-input ] [ mobility ] [ mobility-type [ mh-number | mh-type ]] [ routing ] [ routing-type routing-number ] [ sequence value ] [ time-range name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 access-list access-list-name

 

Router(config)# ipv6 access-list list1

IPv6 アクセス リストを定義し、ルータを IPv6 アクセス リスト コンフィギュレーション モードにします。

ステップ 4

permit icmp { source-ipv6-prefix / prefix-length | any | host source-ipv6-address | auth } [ operator [ port-number ]] { destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address | auth } [ operator [ port-number ]] [ icmp-type [ icmp-code ] | icmp-message ] [ dest-option-type [ doh-number | doh-type ]] [ dscp value ] [ flow-label value ] [ fragments ] [ log ] [ log-input ] [ mobility ] [ mobility-type [ mh-number | mh-type ]] [ routing ] [ routing-type routing-number ] [ sequence value ] [ time-range name ]

 

または

deny icmp { source-ipv6-prefix / prefix-length | any | host source-ipv6-address | auth } [ operator [ port-number ]] { destination-ipv6-prefix/prefix-length | any | host destination-ipv6-address | auth } [ operator [ port-number ]] [ icmp-type [ icmp-code ] | icmp-message ] [ dest-option-type [ doh-number | doh-type ]] [ dscp value ] [ flow-label value ] [ fragments ] [ log ] [ log-input ] [ mobility ] [ mobility-type [ mh-number | mh-type ]] [ routing ] [ routing-type routing-number ] [ sequence value ] [ time-range name ]

 

Router(config-ipv6-acl)# permit icmp host 2001:0DB8:0:4::32 any routing-type 2

 

または

Router(config-ipv6-acl)# deny icmp host 2001:0DB8:0:4::32 any routing-type 2

IPv6 アクセス リストにモバイル IPv6 固有オプション ヘッダーの許可または拒否条件を指定します。

icmp-type 引数には、次のモバイル IPv6 固有オプションのいずれかを指定できます(ただし、これらに限定されません)。

dhaad-request:数値は 144 です。

dhaad-reply:数値は 145 です。

mpd-solicitation:数値は 146 です。

mpd-advertisement:数値は 147 です。

doh-number または doh-type 引数とともに dest-option-type キーワードを使用する場合、IPv6 パケットは、各 IPv6 パケット ヘッダー内の宛先オプション拡張ヘッダーと照合されます。

mobility キーワードが使用される場合、IPv6 パケットは、各 IPv6 パケット ヘッダー内のモビリティ拡張ヘッダーと照合されます。

mh- number または mh-type 引数とともに mobility-type キーワードを使用する場合、IPv6 パケットは各 IPv6 パケット ヘッダー内のモビリティタイプ オプション拡張ヘッダーと照合されます。

routing-type キーワードと routing-number 引数を使用する場合、IPv6 パケットは、各 IPv6 パケット ヘッダー内のルーティングタイプ オプション拡張ヘッダーと照合されます。

ICMP 到達不能メッセージの制御

IPv6 は、パケットをルーティングできない場合に、パケットの送信元に誘導される適切な ICMP 到達不能メッセージを生成します。指定したインターフェイスに到着したパケットの ICMP 到達不能メッセージを制御するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 unreachables

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 unreachables

 

Router(config-if)# ipv6 unreachables

指定したインターフェイスに到着したパケットの ICMPv6 到達不能メッセージの生成をイネーブルにします。

モバイル IPv6 のネイティブ IPv6 トンネリングの検証

モバイル IPv6 の IPv6 トンネル情報を検証するには、次の作業を実行します。

ネイティブ IPv6 トンネリング(または Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化))インフラストラクチャを使用すると、ホーム エージェントのスケーラビリティとスイッチングのパフォーマンスが向上します。ホーム エージェントがモバイル ノードから BU を送信したあとで、カプセル化モードが IPv6/IPv6 に設定され、送信元アドレスがモバイル ノードのホーム インターフェイスのホーム エージェント アドレスの送信元アドレスに設定され、トンネル宛先がモバイル ノードの CoA の宛先に設定されたトンネル インターフェイスが作成されます。

これらの機能は透過的であり、モバイル IPv6 で動作するために設定する必要はありません。IPv6 トンネリングの詳細と IPv6 で GRE トンネリングを実装する方法については、「 トンネリング for IPv6 の実装 」の章を参照してください。

手順の概要

1. enable

2. show ipv6 mobile tunnels [ summary | tunnel if-number ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

show ipv6 mobile tunnels [ summary | tunnel if-number ]

 

Router# show ipv6 mobile tunnels

ホーム エージェントのモバイル IPv6 トンネルをリストします。

モバイル IPv6 のホスト グループの設定と検証

モバイル IPv6 のホスト グループ情報を設定および検証するには、次の作業を実行します。

ユーザは、ホスト グループ設定を使用してモバイル ユーザ ポリシーまたはモバイル グループ ポリシーを作成できます。ホスト グループ プロファイル ルックアップ インターフェイスにより、送信元のプロファイル名、IPv6 アドレス、または NAI を使用して、BU の送信元に関連付けられているプロファイルをルックアップできます。ホスト プロファイル ルックアップ インターフェイスでは、単一方向または双方向 SPI を作成することにより、IPv6 モバイル ノードの認証プロパティも指定されます。

モバイル ノードは、プロファイル名またはホーム アドレスを識別子として自身を識別できます。モバイル IPv6 プロトコル メッセージは、この識別子を登録メッセージの識別子として使用します。ただし、特定の展開では、モバイル ノードに、ネットワーク アドレスではなく NAI などの論理識別子を使用して自身を識別する機能が必要です。

制約事項

IPv6 アドレス オプションを使用している場合は、同じ IPv6 アドレスを持つ 2 つのホスト グループ プロファイルを設定できません。

NAI オプションがレルム名に設定され、アドレス オプションが特定の IPv6 アドレスに設定されたプロファイルは設定できません。NAI オプションを削除するか、NAI オプションに完全修飾ユーザ名を指定できます。

手順の概要

1. enable

2. configure terminal

3. ipv6 mobile home-agent

4. binding [ access access-list-name | auth-option | seconds | maximum | refresh ]

5. host group profile-name

6. address { ipv6-address | autoconfig }

7. nai [ realm | user | macaddress ] { user@realm | @realm }

8. authentication { inbound-spi { hex-in | decimal decimal-in } outbound-spi { hex-out | decimal decimal-out } | spi { hex-value | decimal decimal-value }} key { ascii string | hex string } [ algorithm algorithm-type ] [ replay within seconds ]

9. exit

10. exit

11. show ipv6 mobile host groups [ profile-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 mobile home-agent

 

Router(config)# ipv6 mobile home-agent

ルータをホームエージェント コンフィギュレーション モードにします。

ステップ 4

binding [ access access-list-name | auth-option | seconds | maximum | refresh ]

 

Router(config-ha)# binding 15

モバイル IPv6 ホーム エージェント機能のバインディング オプションを設定します。

ステップ 5

host group profile-name

 

Router(config-ha)# host group profile1

モバイル IPv6 にホスト設定を作成します。

プロファイル名が異なる複数のインスタンスを作成および使用できます。

ステップ 6

address { ipv6-address | autoconfig }

 

Router(config-ha)# address baba 2001:0DB8:1

IPv6 モバイル ノードのホーム アドレスを指定します。

ステップ 7

nai [ realm | user | macaddress ] { user @ realm | @ realm }

 

Router(config-ha)# nai @cisco.com

IPv6 モバイル ノードの NAI を指定します。

ステップ 8

authentication { inbound-spi { hex-in | decimal decimal-in } outbound-spi { hex-out | decimal decimal-out } | spi { hex-value | decimal decimal-value }} key { ascii string | hex string }[ algorithm algorithm-type ] [ replay within seconds ]

 

Router(config-ha)# authentication spi 500 key ascii cisco

単一方向または双方向 SPI を作成することにより、IPv6 モバイル ノードの認証プロパティを指定します。

ステップ 9

exit

 

Router(config-ha)# exit

ホームエージェント コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 10

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了し、ルータを特権 EXEC モードに戻します。

ステップ 11

show ipv6 mobile host groups [ profile-name ]

 

Router# show ipv6 mobile host groups

モバイル IPv6 ホスト グループに関する情報を表示します。

インターフェイスでのモバイル IPv6 のカスタマイズ

この作業では、次のような、ルータ設定のインターフェイス設定パラメータをカスタマイズするいくつかの方法について説明します。

Router Advertisement(RA; ルータ アドバタイズメント)で送信されるアドバタイズメントの間隔オプションの設定

IPv6 RA にどの IPv6 プレフィクスが含まれるかの設定

インターフェイス上の IPv6 RA 送信間隔の設定

これらのインターフェイス設定パラメータは、モバイル IPv6 を開始する前またはモバイル IPv6 が稼動しているときに設定できます。これらのパラメータのいずれも必要に応じてカスタマイズできます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 mobile home-agent [ preference preference-value ]

5. ipv6 nd advertisement-interval

6. ipv6 nd prefix { ipv6-prefix / prefix-length | default } [[ valid-lifetime preferred-lifetime | at valid-date preferred-date ] | infinite | no-advertise | off-link | no-rtr-address | no-autoconfig ]

7. ipv6 nd ra interval { maximum-secs [ minimum-secs ] | msec maximum-msecs [ minimum-msecs ]}

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface serial 3

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 mobile home-agent [ preference preference-value ]

 

Router(config-if)# ipv6 mobile home-agent preference 10

インターフェイスでモバイル IPv6 ホーム エージェント プリファレンス値を設定します。

ステップ 5

ipv6 nd advertisement-interval

 

Router(config-if)# ipv6 nd advertisement-interval

RA で送信されるアドバタイズメントの間隔オプションを設定します。

ステップ 6

ipv6 nd prefix { ipv6-prefix / prefix-length | default } [[ valid-lifetime preferred-lifetime | at valid-date preferred-date ] | infinite | no-advertise | off-link | no-rtr-address | no-autoconfig ]

 

Router(config-if)# ipv6 nd prefix 2001:0DB8::/35 1000 900

IPv6 RA にどの IPv6 プレフィクスが含まれるかを設定します。

ステップ 7

ipv6 nd ra interval { maximum-secs [ minimum-secs ] | msec maximum-msecs [ minimum-msecs ]}

 

Router(config-if)# ipv6 nd ra interval 201

インターフェイス上の IPv6 RA 送信間隔を設定します。

ルータでのモバイル IPv6 の監視および保守

手順の概要

1. enable

2. clear ipv6 mobile binding [ care-of-address prefix | home-address prefix | interface - type interface-number ]

3. clear ipv6 mobile home-agents [ interface - type interface-number ]

4. clear ipv6 mobile traffic

5. debug ipv6 mobile { binding-cache | forwarding | home-agent | registration }

6. debug ipv6 mobile networks

7. debug ipv6 mobile router [ detail ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

clear ipv6 mobile binding [ care-of-address prefix | home-address prefix | interface - type interface-number ]

 

Router# clear ipv6 mobile binding

ルータのモバイル IPv6 バインディング キャッシュをクリアします。

ステップ 3

clear ipv6 mobile home-agents [ interface-type interface-number ]

 

Router# clear ipv6 mobile home-agents

ネイバー ホーム エージェント リストをクリアします。

ステップ 4

clear ipv6 mobile traffic

 

Router# clear ipv6 mobile traffic

モバイル IPv6 に関連付けられているカウンタをクリアします。

ステップ 5

debug ipv6 mobile { binding-cache | forwarding | home-agent | registration }

 

Router# debug ipv6 mobile registration

モバイル IPv6 のデバッグ情報の表示をイネーブルにします。

ステップ 6

debug ipv6 mobile networks

 

Router# debug ipv6 mobile networks

IPv6 モバイル ネットワークのデバッグ メッセージを表示します。

ステップ 7

debug ipv6 mobile router [ detail ]

 

Router# debug ipv6 mobile router

IPv6 モバイル ルータのデバッグ メッセージを表示します。

「show ipv6 mobile binding コマンドの出力例」

「show ipv6 mobile globals コマンドの出力例」

「show ipv6 mobile home-agent コマンドの出力例」

「show ipv6 mobile host groups コマンドの出力例」

「show ipv6 mobile router コマンドの出力例」

「show ipv6 mobile traffic コマンドの出力例」

「show ipv6 mobile tunnels コマンドの出力例」

show ipv6 mobile binding コマンドの出力例

Router # show ipv6 mobile binding

 

Mobile IPv6 Binding Cache Entries:
2001:DB8:2000::1111/64
via care-of address 2001:DB8::A8BB:CCFF:FE01:F611
home-agent 2001:DB8:2000::2001
Prefix 2001:DB8:8000::/64
Prefix 2001:DB8:2000::1111/128
Prefix 2001:DB8:1000::1111/128 installed
state ACTIVE, sequence 23, flags AHRlK
lifetime: remaining 44 (secs), granted 60 (secs), requested 60 (secs)
interface Ethernet0/2
tunnel interface Tunnel0
0 tunneled, 0 reversed tunneled
Selection matched 1 bindings

show ipv6 mobile globals コマンドの出力例

次の例では、 show ipv6 mobile globals コマンドによってバインディング パラメータが表示されます。

Router# show ipv6 mobile globals
 
Mobile IPv6 Global Settings:
 
1 Home Agent service on following interfaces:
Ethernet1/2
Bindings:
Maximum number is unlimited.
1 bindings are in use
1 bindings peak
Binding lifetime permitted is 262140 seconds
Recommended refresh time is 300 seconds

show ipv6 mobile home-agent コマンドの出力例

次の例では、ネイバー モバイル ホーム エージェントが見つからなかったことが表示されます。

Router# show ipv6 mobile home-agent
 
Home Agent information for Ethernet1/3
Configured:
FE80::20B:BFFF:FE33:501F
preference 0 lifetime 1800
global address 2001:0DB8:1::2/64
Discovered Home Agents:
FE80::4, last update 0 min
preference 0 lifetime 1800
global address 2001:0DB8:1::4/64

show ipv6 mobile host groups コマンドの出力例

次の例では、localhost という名前のホスト グループに関する情報が表示されます。

Router# show ipv6 mobile host groups
 
Mobile IPv6 Host Configuration
Mobile Host List:
 
Host Group Name: localhost
NAI: sai@cisco.com
Address: CAB:C0:CA5A:CA5A::CA5A
 
Security Association Entry:
SPI: (Hex: 501) (Decimal Int: 1281)
Key Format: Hex Key: baba
Algorithm: HMAC_SHA1
Replay Protection: On Replay Window: 6 secs

show ipv6 mobile router コマンドの出力例

次の例では、ルータで IPv6 NEMO が設定されている場合の IPv6 モバイル ルータ ステータスに関する情報が表示されます。

Router# show ipv6 mobile router
 
Mobile Reverse Tunnel established
---------------------------------
using Nemo Basic mode
Home Agent: 2001:DB8:2000::2001
CareOf Address: 2001:DB8::A8BB:CCFF:FE01:F611
Attachment Router: FE80::A8BB:CCFF:FE01:F511
Attachment Interface: Ethernet1/1
Home Network: 2001:DB8:2000:0:FDFF:FFFF:FFFF:FFFE/64
Home Address: 2001:DB8:2000::1111/64

show ipv6 mobile traffic コマンドの出力例

次の例では、モバイル IPv6 トラフィックに関する情報が表示されます。

Router# show ipv6 mobile traffic
 
MIPv6 statistics:
Rcvd: 6477 total
0 truncated, 0 format errors
0 checksum errors
Binding Updates received:6477
0 no HA option, 0 BU's length
0 options' length, 0 invalid CoA
Sent: 6477 generated
Binding Acknowledgements sent:6477
6477 accepted (0 prefix discovery required)
0 reason unspecified, 0 admin prohibited
0 insufficient resources, 0 home reg not supported
0 not home subnet, 0 not home agent for node
0 DAD failed, 0 sequence number
Binding Errors sent:0
0 no binding, 0 unknown MH
 
Home Agent Traffic:
6477 registrations, 0 deregistrations
00:00:23 since last accepted HA registration
unknown time since last failed HA registration
unknown last failed registration code
Traffic forwarded:
0 tunneled, 0 reversed tunneled
Dynamic Home Agent Address Discovery:
1 requests received, 1 replies sent
Mobile Prefix Discovery:
0 solicitations received, 0 advertisements sent

show ipv6 mobile tunnels コマンドの出力例

次の例では、ホーム エージェント上のモバイル IPv6 トンネルに関する情報が表示されます。

Router# show ipv6 mobile tunnels

 

Tunnel1:

Source: 2001:0DB1:1:1

Destination: 2001:0DB1:2:1

Encapsulation Mode: IPv6/IPv6

Egress Interface: Ethernet 1/0

Switching Mode: Process

Keep-Alive: Not Supported

Path MTU Discovery: Enabled

Input: 20 packets, 1200 bytes, 0 drops

Output: 20 packets, 1200 bytes, 0 drops

NEMO Options: Not Supported

モバイル IPv6 の実装の設定例

「例:ルータでのモバイル IPv6 のイネーブル化」

「例:IPv6 モバイル ルータでの NEMO のイネーブル化と設定」

「例:IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化」

「例:IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル化」

「例:モバイル IPv6 のホスト グループの設定」

例:ルータでのモバイル IPv6 のイネーブル化

次の例では、指定したインターフェイスでモバイル IPv6 を設定し、イネーブルにする方法を示します。

Router> enable

Router# config terminal

Router(config)# interface Ethernet 1

Router(config-if)# ipv6 mobile home-agent

例:IPv6 モバイル ルータでの NEMO のイネーブル化と設定

次の例では、IPv6 モバイル ルータで NEMO をイネーブルにし、設定する方法を示します。/128 サブネットを使用する必要があります。そうしないと、IPv6 モバイル ルータはホーム ネットワークがローカルに接続されていると想定するため、登録に失敗します。

ipv6 unicast-routing
!
interface ethernet0/0
no ip address
ipv6 address 2001:0DB8:2000::1111/128
ipv6 nd ra mtu suppress
!
interface ethernet0/1
no ip address
ipv6 address 2001:0DB8:1000::1111/128
ipv6 nd ra mtu suppress
!
interface Ethernet0/0
description Roaming Interface to AR2
no ip address
ipv6 address autoconfig
ipv6 enable
ipv6 nd ns-interval 5000
ipv6 mobile router-service roam
ipv6 rip home enable
!
interface Ethernet0/1
description Mobile Network Interface
no ip address
ipv6 address 2001:0DB8:8000::8001/64
ipv6 enable
ipv6 nd advertisement-interval
ipv6 nd ra interval msec 1000
ipv6 rip home enable
!
interface Ethernet1/1
description Roaming Interface to AR1
no ip address
ipv6 address autoconfig
ipv6 enable
ipv6 nd ns-interval 5000
ipv6 mobile router-service roam priority 99
ipv6 rip home enable
!
ipv6 router rip home
!
ipv6 mobile router
host group mr-host-group
nai mr1@cisco.com
address 2001:0DB8:2000::1112/128
authentication spi hex 100 key ascii hi
exit
home-network 2001:0DB8:2000::/64 discover priority 127
home-network 2001:0DB8:1000::/64 discover
home-address home-network eui-64
explicit-prefix
register lifetime 60
register retransmit initial 1000 maximum 1000 retry 1
register extend expire 20 retry 1 interval 1

例:IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化

次の例では、IPv6 モバイル ルータ ホーム エージェントで NEMO をイネーブルにし、設定する方法を示します。DHAAD が動作するためにはエニーキャスト アドレスが必要です。 redistribute nemo コマンドは、NEMO ルートをルーティング プロトコルに再配布します。

ipv6 unicast-routing
!
interface Ethernet0/2
description To Network
no ip address
no ipv6 address
ipv6 address 2001:0DB8:2000::2001/64
ipv6 address 2001:0DB8:2000::FDFF:FFFF:FFFF:FFFE/64 anycast
ipv6 enable
ipv6 nd advertisement-interval
ipv6 nd ra lifetime 2
ipv6 nd ra interval msec 1000
ipv6 mobile home-agent preference 100
ipv6 mobile home-agent
ipv6 rip home enable
!
interface Ethernet2/2
description To CN2
no ip address
no ipv6 address
ipv6 address 2001:0DB8:3000::3001/64
ipv6 enable
ipv6 rip home enable
!
ipv6 router nemo
!
ipv6 router rip home
redistribute nemo
poison-reverse
!
ipv6 mobile home-agent
host group mr-host-group
nai mr1@cisco.com
address 2001:0DB8:2000::1112/64
authentication spi hex 100 key ascii hi
exit
host group mr2-host-group
nai mr2@cisco.com
address 2001:0DB8:2000::2222
authentication spi decimal 512 key hex 12345678123456781234567812345678
exit

例:IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル化

次の例では、IPv6 モバイル ルータ インターフェイスでローミングをイネーブルにする方法を示します。

Router(config)# interface ethernet 0/0
Router(config-if)# ipv6 mobile router-service roam

例:モバイル IPv6 のホスト グループの設定

次の例では、group1 という名前のモバイル IPv6 ホスト グループを設定する方法を示します。

ipv6 mobile host group group1

nai sri@cisco.com

address autoconfig

authentication spi 500 key ascii cisco

その他の関連資料

関連資料

関連項目
参照先

IPv6 のサポート機能リスト

「Start Here: Cisco IOS Software Release Specifics for IPv6 Features」

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

IPv6 簡易パケット ヘッダー、IPv6 ネイバー探索、IPv6 ステートレス自動設定、IPv6 ステートフル自動設定

Cisco IOS IPv6 Configuration Guide 』の「 Implementing IPv6 Addressing and Basic Connectivity

IPv6 アクセス リスト

Cisco IOS IPv6 Configuration Guide 』の「 Implementing Traffic Filters and Firewalls for IPv6 Security

IPv6 トンネリング

Cisco IOS IPv6 Configuration Guide 』の「 Implementing Tunneling for IPv6

IPv4 モビリティの設定とコマンド

『Cisco IOS IP Mobility Configuration Guide』

『Cisco IOS IP Mobility Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3775

『Mobility Support in IPv6』

RFC 3846

『Mobile IPv4 Extension for Carrying Network Access Identifiers』

RFC 3963

『Network Mobility (NEMO) Basic Support Protocol』

RFC 4282

『The Network Access Identifier』

RFC 4283

『Mobile Node Identifier Option for Mobile IPv6 (MIPv6)』

RFC 4285

『Authentication Protocol for Mobile IPv6』

draft-ietf-nemo-terminology

『Network Mobility Support Terminology』

draft-ietf-nemo-home-network-models

『NEMO Home Network Model s

draft-thubert-nemo-ipv4-traversal

『IPv4 Traversal for MIPv6 Mobile Routers』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

モバイル IPv6 の実装の機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator により、どのソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 モバイル IPv6 の実装の機能情報

機能名
リリース
機能情報

モバイル IPv6 ホーム エージェント

12.3(14)T
12.4

モバイル IPv6 機能では、IPv6 アドレス空間を使用して、任意の種類の大規模環境でのモバイル IP 展開をイネーブルにします。モバイル IPv6 を使用するために外部エージェントは不要です。

この機能に関する詳細については、次の各項を参照してください。

「モバイル IPv6 ホーム エージェント」

「ルータでのモバイル IPv6 のイネーブル化」

「モバイル IPv6 のバインディング情報の設定」

「インターフェイスでのモバイル IPv6 のカスタマイズ」

「例:ルータでのモバイル IPv6 のイネーブル化」

モバイル IPv6 の IPv6 ACL 拡張

12.4(2)T 12.2(33)SRB
12.2(33)SXI
15.0(1)S

IPv6 アクセス リストを設定して、モバイル IPv6 固有の ICMP メッセージと一致する IPv6 アクセス リスト エントリを設定したり、モバイル IPv6 拡張ヘッダーを含むパケットに一致するエントリを定義したりできます。

この機能に関する詳細については、次の各項を参照してください。

「モバイル IPv6 のパケット ヘッダー」

「モバイル IPv6 プロトコル ヘッダーおよびオプションのフィルタリング」

「ICMP 到達不能メッセージの制御」

モバイル IP:モバイル IPv6 HA フェーズ 2

12.4(11)T

モバイル IPv6 のこの開発フェーズには、NAI、代替認証、およびネイティブ IPv6 トンネル インフラストラクチャのサポートが含まれます。

これらの機能に関する詳細については、次の各項を参照してください。

「モバイル IPv6 トンネルの最適化」

「IPv6 ホスト グループの設定」

「NAI に基づくモバイル IPv6 ノードの識別」

「モバイル IPv6 の認証プロトコル」

「モバイル IPv6 のネイティブ IPv6 トンネリングの検証」

「モバイル IPv6 のホスト グループの設定と検証」

「例:モバイル IPv6 のホスト グループの設定」

モバイル ネットワーク v6:基本 NEMO

12.4(20)T

Network Mobility(NEMO; ネットワーク モビリティ)基本サポート プロトコルにより、モバイル IPv6 ネットワークをインターネット上の異なるポイントに接続できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 NEMO」

「NEMO 対応ホーム エージェント」

「NEMO での IPv6 ネイバー探索重複アドレス検出」

「IPv6 モバイル ルータでの NEMO のイネーブルと設定」

「IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化」

「IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル」

「例:IPv6 モバイル ルータでの NEMO のイネーブル化と設定」

「例:IPv6 モバイル ルータ ホーム エージェントでの NEMO のイネーブル化」

「例:IPv6 モバイル ルータ インターフェイスでのローミングのイネーブル化」