IPv6 コンフィギュレーション ガイド、Cisco IOS Release 15.1S
IPv6 アドレッシングと基本接続の実装
IPv6 アドレッシングと基本接続の実装
発行日;2012/02/05 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

IPv6 アドレッシングと基本接続の実装

機能情報の確認

目次

IPv6 アドレッシングと基本接続の実装の前提条件

IPv6 アドレッシングと基本接続の実装の制約事項

IPv6 アドレッシングと基本接続の実装に関する情報

Cisco IOS ソフトウェアの IPv6

一意のアドレスを確保するための大きな IPv6 アドレス空間

IPv6 アドレスの形式

IPv6 アドレス タイプ:ユニキャスト

集約可能グローバル アドレス

リンクローカル アドレス

IPv4 互換 IPv6 アドレス

一意のローカル アドレス

IPv6 アドレス タイプ:エニーキャスト

IPv6 アドレス タイプ:マルチキャスト

IPv6 マルチキャスト グループ

IPv6 アドレスの出力表示

簡易 IPv6 パケット ヘッダー

IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチング

ユニキャスト Reverse Path Forwarding

IPv6 の DNS

IPv6 のパス MTU ディスカバリ

シスコ検出プロトコル IPv6 アドレスのサポート

IPv6 の ICMP

IPv6 ICMP レート制限

IPv6 ネイバー探索

ステートフル スイッチオーバー

IPv6 ネイバー請求メッセージ

IPv6 ルータ アドバタイズメント メッセージ

IPv6 ネイバー リダイレクト メッセージ

Per-Interface ネイバー探索キャッシュ制限

リンク、サブネット、およびサイト アドレッシングの変更

IPv6 ステートレス自動設定

IPv6 ホストの簡易ネットワーク リナンバリング

IPv6 の汎用プレフィクス

DHCP for IPv6 プレフィクス委任

IPv6 プレフィクス集約

IPv6 サイト マルチホーミング

IPv6 データ リンク

Cisco IOS ソフトウェアの IPv6 でのワイドエリア ネットワーク テクノロジーのサポート

IPv6 アドレスと PVC

IPv6 のルーテッド ブリッジ カプセル化

IPv6 リダイレクト メッセージ

ブリッジングおよびルーティングのための BVI インターフェイス上での IPv6

デュアル IPv4 および IPv6 プロトコル スタック

IPv6 アドレッシングと基本接続の実装方法

IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル

制約事項

ネイバー探索キャッシュ制限の設定

IPv6 汎用プレフィクスの定義と使用

汎用プレフィクスの手動定義

6to4 インターフェイスに基づく汎用プレフィクスの定義

DHCP for IPv6 プレフィクス委任クライアント機能での汎用プレフィクスの定義

IPv6 での汎用プレフィクスの使用

IPv4 および IPv6 プロトコル スタックをサポートするためのインターフェイスの設定

IPv6 ICMP レート制限の設定

トラフィック エンジニアリングの DRP 拡張の設定

IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定

分散型および非分散型アーキテクチャ プラットフォームでのシスコ エクスプレス フォワーディング スイッチングの設定

前提条件

制約事項

ユニキャスト RPF の設定

IPv6 アドレスへのホスト名のマッピング

IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング

IPv6 リダイレクト メッセージの表示

IPv6 アドレッシングと基本接続の実装の設定例

例:IPv6 アドレッシングと IPv6 ルーティングの設定

例:デュアル プロトコル スタックの設定

例:IPv6 ICMP レート制限の設定

例:シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングの設定

例:ホスト名からアドレスへのマッピングの設定

例:IPv6 アドレスから ATM PVC およびフレーム リレー PVC へのマッピングの設定

例:IPv6 ATM PVC マッピングの設定:ポイントツーポイント インターフェイス

例:IPv6 ATM PVC マッピングの設定:ポイントツーマルチポイント インターフェイス

例:IPv6 フレーム リレー PVC マッピングの設定:ポイントツーポイント インターフェイス

例:IPv6 フレーム リレー PVC マッピングの設定:ポイントツーマルチポイント インターフェイス

関連情報

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IPv6 アドレッシングと基本接続の実装の機能情報

IPv6 アドレッシングと基本接続の実装

Cisco IOS ソフトウェアでの基本的な IPv6 接続の実装は、個々のルータ インターフェイスへの IPv6 アドレスの割り当てで構成されます。IPv6 トラフィックの転送はグローバルにイネーブルにでき、IPv6 のシスコ エクスプレス フォワーディング スイッチングをイネーブルにすることもできます。基本接続は、Domain Name System(DNS; ドメイン ネーム システム)の名前からアドレスおよびアドレスから名前のルックアップ プロセスで AAAA レコード タイプのサポートを設定し、IPv6 ネイバー探索を管理することで拡張できます。

この章では、IPv6 アドレッシングおよび基本 IPv6 接続の作業について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「IPv6 アドレッシングと基本接続の実装の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、および Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

IPv6 アドレッシングと基本接続の実装の前提条件

このマニュアルでは、IPv4 に精通していることを前提としています。IPv4 の設定およびコマンド リファレンス情報については、「その他の関連資料」に示されている資料を参照してください。

Cisco Express Forwarding for IPv6 および分散型 Cisco Express Forwarding for IPv6 には、次の前提条件が適用されます。

シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングを使用して IPv6 トラフィックを転送するには、 ipv6 unicast-routing コマンドを使用してルータ上で IPv6 ユニキャスト データグラムの転送をグローバルに設定するか、 ipv6 address コマンドを使用してインターフェイスに IPv6 アドレスを設定する必要があります。

ipv6 cef コマンドを使用してルータ上で Cisco Express Forwarding for IPv6 をグローバルにイネーブルにする前に、 ip cef コマンドを使用してルータ上で Cisco Express Forwarding for IPv4 をグローバルにイネーブルにする必要があります。

Cisco 7500 シリーズ ルータなど、シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングの両方をサポートする分散型アーキテクチャ プラットフォームでは、 ipv6 cef distributed コマンドを使用してルータ上で分散型 Cisco Express Forwarding for IPv6 をグローバルにイネーブルにする前に、 ip cef distributed コマンドを使用してルータ上で分散型 Cisco Express Forwarding for IPv4 をグローバルにイネーブルにする必要があります。


) デフォルトでは、Gigabit Switch Router(GSR; ギガビット スイッチ ルータ)では分散型シスコ エクスプレス フォワーディングだけがサポートされます。


ユニキャスト Reverse Path Forwarding(RPF)を使用するには、ルータでシスコ エクスプレス フォワーディング スイッチングまたは分散型シスコ エクスプレス フォワーディング スイッチングをイネーブルにします。シスコ エクスプレス フォワーディング スイッチングの入力インターフェイスを設定する必要はありません。シスコ エクスプレス フォワーディングがルータ上で実行されているかぎり、個々のインターフェイスは他のスイッチング モードで設定できます。


) ユニキャスト RPF が機能するためには、ルータでシスコ エクスプレス フォワーディングがグローバルに設定されている必要があります。ユニキャスト RPF は、シスコ エクスプレス フォワーディングがないと動作しません。


IPv6 アドレッシングと基本接続の実装の制約事項

Cisco IOS Release 12.2(11)T またはそれ以前のリリースでは、IPv6 はパケット転送に対してプロセス スイッチングだけをサポートします。IPv6 のシスコ エクスプレス フォワーディング スイッチングおよび分散型シスコ エクスプレス フォワーディング スイッチングは、Cisco IOS Release 12.2(13)T でサポートされています。IPv6 の分散型シスコ エクスプレス フォワーディング スイッチングは、Cisco IOS Release 12.0(21)ST でサポートされています。

レイヤ 2 LAN スイッチは IPv6 フレームを転送する前にレイヤ 3 パケット情報を調べないため、IPv6 パケットはレイヤ 2 LAN スイッチに対して透過的です。したがって、IPv6 ホストをレイヤ 2 LAN スイッチに直接接続できます。

IPv6 がサポートされている任意の Cisco IOS リリースでは、1 つのインターフェイス上で同じプレフィクス内に複数の IPv6 グローバル アドレスを設定できます。ただし、1 つのインターフェイス上で複数の IPv6 リンクローカル アドレスはサポートされません。1 つのインターフェイス上での同じプレフィクス内の複数の IPv6 グローバル アドレスの設定については、「例:IPv6 アドレッシングと IPv6 ルーティングの設定」を参照してください。

RFC 3879 ではサイトローカル アドレスの使用が廃止されたため、プライベート IPv6 アドレスの設定は、RFC 4193 の Unique Local Addressing(ULA)に関する推奨事項に従って行う必要があります。

IPv6 での Bridge-Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)は、NAT-PT およびワイヤレス インターフェイス Dot11Radio でサポートされません。

IPv6 アドレッシングと基本接続の実装に関する情報

「Cisco IOS ソフトウェアの IPv6」

「一意のアドレスを確保するための大きな IPv6 アドレス空間」

「IPv6 アドレスの形式」

「IPv6 アドレス タイプ:ユニキャスト」

「IPv6 アドレス タイプ:エニーキャスト」

「IPv6 アドレス タイプ:マルチキャスト」

「IPv6 アドレスの出力表示」

「簡易 IPv6 パケット ヘッダー」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチング」

「IPv6 の DNS」

「IPv6 のパス MTU ディスカバリ」

「シスコ検出プロトコル IPv6 アドレスのサポート」

「IPv6 の ICMP」

「IPv6 ネイバー探索」

「リンク、サブネット、およびサイト アドレッシングの変更」

「IPv6 プレフィクス集約」

「IPv6 サイト マルチホーミング」

「IPv6 データ リンク」

「IPv6 のルーテッド ブリッジ カプセル化」

「IPv6 リダイレクト メッセージ」

「ブリッジングおよびルーティングのための BVI インターフェイス上での IPv6」

「デュアル IPv4 および IPv6 プロトコル スタック」

Cisco IOS ソフトウェアの IPv6

以前は IPng(次世代)と呼ばれていた IPv6 は、Internet Protocol(IP; インターネット プロトコル)の最新バージョンです。IP は、デジタル ネットワーク上でデータ、音声、およびビデオ トラフィックの交換に使用するパケットベースのプロトコルです。IP Version 4(IPv4; IP バージョン 4)の 32 ビット アドレッシング方式ではインターネットの成長の需要を十分に満たせないことが明らかになったときに、IPv6 が提案されました。長い議論のあとで、IP を IPng のベースにするが、はるかに大きなアドレス空間と、簡略化されたメイン ヘッダーや拡張ヘッダーなどの改善を追加することが決定されました。IPv6 は当初、Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)によって発行された RFC 2460『 Internet Protocol, Version 6 (IPv6) Specification 』に規定されていました。IPv6 でサポートされるアーキテクチャとサービスについては他の RFC で規定されています。

IPv6 のアーキテクチャは、エンドツーエンドのセキュリティ、Quality of Service(QoS; サービス品質)、グローバルに一意なアドレスなどのサービスを提供する一方で、既存の IPv4 ユーザが IPv6 に簡単に移行できるように設計されています。より大きな IPv6 アドレス空間により、ネットワークが拡張可能になり、グローバルな到達可能性が提供されます。簡素化された IPv6 パケット ヘッダー形式により、パケットの処理効率が向上しています。IPv6 プレフィクス集約、簡略化されたネットワーク リナンバリング、および IPv6 サイト マルチホーミング機能によって、より効率的なルーティングを実現する IPv6 アドレッシング階層が提供されます。IPv6 では、Routing Information Protocol(RIP; ルーティング情報プロトコル)、Integrated Intermediate System-to-Intermediate System(IS-IS)、Open Shortest Path First for IPv6、マルチプロトコル Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)などの広く導入されているルーティング プロトコルがサポートされます。使用可能なその他の機能として、ステートレス自動設定、拡張されたモバイル IPv6 のサポート、および増やされたマルチキャスト アドレス数があります。

一意のアドレスを確保するための大きな IPv6 アドレス空間

IPv6 の主な開発動機は、将来的に予想されるグローバルに一意な IP アドレスの需要を満たす必要性です。モバイル インターネット対応デバイス(Personal Digital Assistants(PDA)、電話、カードなど)、Home-Area Networks(HAN; ホームエリア ネットワーク)、ワイヤレス データ サービスなどのアプリケーションによって、グローバルに一意な IP アドレスの需要が増加しています。IPv6 は、ネットワーク アドレス ビット数を 32 ビット(IPv4)の 4 倍の 128 ビットにしているため、地球上のすべてのネットワーク デバイスにグローバルに一意な IP アドレスを十分に提供できます。IPv6 アドレスをグローバルに一意にすることで、ネットワーク デバイスのグローバルな到達可能性とエンドツーエンドのセキュリティが実現されます。これは、アドレスの需要を喚起するアプリケーションとサービスに不可欠な機能です。また、柔軟性の高い IPv6 アドレス空間により、プライベート アドレスの必要性と Network Address Translation(NAT; ネットワーク アドレス変換)の使用が低減されます。したがって、IPv6 を使用すると、ネットワーク エッジにある境界ルータによる特別な処理を必要としない新しいアプリケーション プロトコルがイネーブルになります。

IPv6 アドレスの形式

IPv6 アドレスは、x:x:x:x:x:x:x:x のようにコロン(:)で区切られた一連の 16 ビットの 16 進フィールドで表されます。次に、IPv6 アドレスの例を 2 つ示します。

2001:0DB8:7654:3210:FEDC:BA98:7654:3210

2001:0DB8:0:0:8:800:200C:417A

IPv6 アドレスには、通常、連続するゼロの 16 進フィールドが含まれます。IPv6 アドレスを扱いやすくするために、2 つのコロン(::)を使用して、IPv6 アドレスの先頭、中央、または末尾にある連続するゼロの 16 進フィールドを圧縮できます(コロンは連続するゼロの 16 進フィールドを表します)。 表 1 に、圧縮された IPv6 アドレスの形式をリストします。

連続する 16 ビット値がゼロとして指定されている場合は、2 つのコロンを ipv6-address 引数の一部として使用できます。インターフェイスごとに複数の IPv6 アドレスを設定できますが、設定できるリンクローカル アドレスは 1 つだけです。


) IPv6 アドレスでは、最も長く連続するゼロの 16 進フィールドを表すために 2 つのコロン(::)を 1 回だけ使用できます。

IPv6 アドレスの 16 進文字は大文字と小文字が区別されません。


 

表 1 圧縮された IPv6 アドレス形式

IPv6 アドレス タイプ
優先形式
圧縮形式

ユニキャスト

2001:0:0:0:0DB8:800:200C:417A

2001::0DB8:800:200C:417A

マルチキャスト

FF01:0:0:0:0:0:0:101

FF01::101

ループバック

0:0:0:0:0:0:0:1

::1

未指定

0:0:0:0:0:0:0:0

::

ノードは、 表 1 に示されているループバック アドレスを使用して、IPv6 パケットを自身に送信できます。IPv6 のループバック アドレスは、IPv4 のループバック アドレス(127.0.0.1)と同じように機能します。


) IPv6 ループバック アドレスを物理インターフェイスに割り当てることはできません。送信元または宛先のアドレスとして IPv6 ループバック アドレスを含むパケットは、そのパケットを作成したノードの外には転送できません。IPv6 ルータは、送信元または宛先のアドレスとして IPv6 ループバック アドレスを含むパケットを転送しません。


表 1 にリストされている未指定アドレスは、IPv6 アドレスがないことを示します。たとえば、IPv6 ネットワーク上の新規に初期化されたノードは、IPv6 アドレスを受け取るまで、パケット内で未指定アドレスを送信元アドレスとして使用できます。


) IPv6 未指定アドレスをインターフェイスに割り当てることはできません。未指定 IPv6 アドレスは、IPv6 パケット内の宛先アドレスまたは IPv6 ルーティング ヘッダーとして使用しないでください。


ipv6-prefix / prefix-length の形式の IPv6 アドレス プレフィクスを使用して、アドレス空間全体のビット単位の連続ブロックを表すことができます。 ipv6-prefix は、RFC 2373 に記載された形式で指定する必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。プレフィクス長は、アドレスのうち連続する上位何ビットがプレフィクス(アドレスのネットワーク部)を構成するかを示す 10 進数値です。たとえば、2001:0DB8:8086:6502::/32 は有効な IPv6 プレフィクスです。

IPv6 アドレス タイプ:ユニキャスト

IPv6 ユニキャスト アドレスは、単一ノード上の単一インターフェイスの識別子です。ユニキャスト アドレスに送信されたパケットは、そのアドレスが示すインターフェイスに配信されます。Cisco IOS ソフトウェアでは、次の IPv6 ユニキャスト アドレス タイプがサポートされます。

「集約可能グローバル アドレス」

「リンクローカル アドレス」

「IPv4 互換 IPv6 アドレス」

「一意のローカル アドレス」

集約可能グローバル アドレス

集約可能グローバル アドレスは、集約可能グローバル ユニキャスト プレフィクスによる IPv6 アドレスです。集約可能グローバル ユニキャスト アドレスの構造により、グローバル ルーティング テーブル内のルーティング テーブル エントリ数を制限するルーティング プレフィクスの厳密な集約が可能になります。集約可能グローバル アドレスは、組織を上に向かって、最終的に Internet Service Provider(ISP; インターネット サービス プロバイダー)まで集約されるリンクで使用されます。

集約可能グローバル IPv6 アドレスは、グローバル ルーティング プレフィクス、サブネット ID、およびインターフェイス ID により定義されます。バイナリ 000 から開始するアドレスを除き、すべてのグローバル ユニキャスト アドレスには 64 ビットのインターフェイス ID があります。IPv6 グローバル ユニキャスト アドレスの割り当てには、バイナリ値 001(2000::/3)から始まるアドレスの範囲が使用されます。図 1 に、集約可能グローバル アドレスの構造を示します。

図 1 集約可能グローバル アドレスの形式

 

2000::/3(001)~ E000::/3(111)のプレフィクスを持つアドレスには、Extended Universal Identifier(EUI; 拡張ユニバーサル識別子)64 形式の 64 ビット インターフェイス識別子が必要です。Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)は、2000::/16 の範囲の IPv6 アドレス空間を地域レジストリに割り当てます。

集約可能グローバル アドレスは、通常、48 ビットのグローバル ルーティング プレフィクスと、16 ビットのサブネット ID または Site-Level Aggregator(SLA; サイトレベル集約)で構成されます。IPv6 集約可能グローバル ユニキャスト アドレス形式の文書(RFC 2374)では、グローバル ルーティング プレフィクスには、Top-Level Aggregator(TLA; 最上位レベル集約)および Next-Level Aggregator(NLA; 次レベル集約)という他の 2 つの階層構造フィールドが含まれるとされていました。TLS フィールドと NLA フィールドはポリシーベースであるため、IETF はこれらのフィールドを RFC から削除することを決定しました。この変更の前に展開された既存の IPv6 ネットワークの中には、依然として古いアーキテクチャに基づくネットワークを使用しているものもあります。

個々の組織では、サブネット ID と呼ばれる 16 ビットのサブネット フィールドを使用して、独自のローカル アドレッシング階層を作成したり、サブネットを識別したりできます。サブネット ID は IPv4 でのサブネットに似ていますが、IPv6 サブネット ID を持つ組織では最大 65,535 個のサブネットをサポートできるという点が異なります。

インターフェイス ID は、リンク上のインターフェイスの識別に使用されます。インターフェイス ID は、リンク上で一意である必要があります。より広い範囲で一意にすることもできます。多くの場合、インターフェイス ID は、インターフェイスのリンクレイヤ アドレスと同じか、リンクレイヤ アドレスに基づいています。集約可能グローバル ユニキャストおよびその他の IPv6 アドレス タイプで使用されるインターフェイス ID は、長さが 64 ビットの変更された EUI-64 形式で構築されている必要があります。

インターフェイス ID は、次のいずれかに該当する変更された EUI-64 形式で構築されます。

すべての IEEE 802 インターフェイス タイプ(イーサネット、FDDI インターフェイスなど)の場合、最初の 3 オクテット(24 ビット)は、そのインターフェイスの 48 ビット リンクレイヤ アドレス(Media Access Control(MAC; メディア アクセス制御)アドレス)の Organizational Unique Identifier(OUI; 組織固有識別子)から取得され、4 番めと 5 番めのオクテット(16 ビット)は、FFFE の固定 16 進数値です。最後の 3 オクテット(24 ビット)は、MAC アドレスの最後の 3 オクテットから取得されます。インターフェイス ID の構成は、最初のオクテットの 7 番めのビットである Universal/Local(U/L; ユニバーサル/ローカル)ビットを 0 または 1 の値に設定することで完成します。値 0 はローカルに管理されている識別子を示し、値 1 はグローバルに一意の IPv6 インターフェイス識別子を示します。

その他のすべてのインターフェイス タイプ(シリアル ループバック、ATM、フレーム リレー、トンネル インターフェイスタイプなど。ただし、IPv6 オーバーレイ トンネルで使用されるトンネル インターフェイスを除く)の場合、インターフェイス ID は IEEE 802 インターフェイス タイプのインターフェイス ID と同じように構築されますが、識別子の構築にはルータの MAC アドレス プールの最初の MAC アドレスが使用されます(インターフェイスには MAC アドレスがないため)。

IPv6 オーバーレイ トンネルで使用されるトンネル インターフェイス タイプの場合、インターフェイス ID は、識別子の上位 32 ビットがすべてゼロであるトンネル インターフェイスに割り当てられた IPv4 アドレスです。


) Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)を使用するインターフェイスの場合は、接続の両端のインターフェイスが同じ MAC アドレスを持つ可能性があるため、接続の両端で使用されるインターフェイス識別子は、両方の識別子が一意になるまでネゴシエーション(ランダムに選択され、必要に応じて再構築)されます。ルータの最初の MAC アドレスが、PPP を使用するインターフェイスの識別子の構築に使用されます。


ルータに IEEE 802 インターフェイス タイプがない場合は、ルータのインターフェイスでリンクローカル IPv6 アドレスが次のシーケンスで生成されます。

1. ルータに MAC アドレスが(ルータの MAC アドレス プールから)照会されます。

2. 使用可能な MAC アドレスがルータにない場合は、ルータのシリアル番号を使用してリンクローカル アドレスが作成されます。

3. リンクローカル アドレスの作成にルータのシリアル番号を使用できない場合、ルータは Message Digest Algorithm 5(MD5)ハッシュを使用して、ルータのホスト名からルータの MAC アドレスを決定します。

リンクローカル アドレス

リンクローカル アドレスは、リンクローカル プレフィクス FE80::/10(1111 1110 10)と変更された EUI-64 形式のインターフェイス識別子を使用するどのインターフェイスでも自動的に設定できる IPv6 ユニキャスト アドレスです。リンクローカル アドレスは、ネイバー探索プロトコルとステートレス自動設定プロセスで使用されます。ローカル リンク上のノードは、リンクローカル アドレスを使用して通信できます。ノードの通信にグローバルに一意のアドレスは不要です。図 2 に、リンクローカル アドレスの構造を示します。

IPv6 ルータでは、送信元または宛先がリンクローカル アドレスであるパケットを他のリンクに転送できません。

図 2 リンクローカル アドレスの形式

 

IPv4 互換 IPv6 アドレス

IPv4 互換 IPv6 アドレスは、アドレスの上位 96 ビットがゼロであり、アドレスの下位 32 ビットが IPv4 アドレスである IPv6 ユニキャスト アドレスです。IPv4 互換 IPv6 アドレスの形式は、0:0:0:0:0:0:A.B.C.D または ::A.B.C.D です。IPv4 互換 IPv6 アドレスの 128 ビット全体がノードの IPv6 アドレスとして使用され、下位 32 ビットに埋め込まれた IPv4 アドレスがノードの IPv4 アドレスとして使用されます。IPv4 互換 IPv6 アドレスは、IPv4 と IPv6 の両方のプロトコル スタックをサポートするノードに割り当てられ、自動トンネルで使用されます。図 3 に、IPv4 互換 IPv6 アドレスの構造と、許容されるいくつかのアドレス形式を示します。

図 3 IPv4 互換 IPv6 アドレスの形式

 

一意のローカル アドレス

一意のローカル アドレスは、グローバルに一意であり、ローカル通信を目的とした IPv6 ユニキャスト アドレスです。グローバル インターネット上でのルーティングには対応しておらず、サイトなどの限定されたエリア内でルーティング可能です。限定された複数のサイト間でルーティングされることもあります。

一意のローカル アドレスには、次の特性があります。

グローバルに一意のプレフィクスがある(一意である可能性が高い)。

既知のプレフィクスがあるため、サイト境界で簡単にフィルタリングできる。

アドレス競合を発生させたり、これらのプレフィクスを使用するインターフェイスのリナンバリングを必要としたりすることなく、サイトを結合またはプライベートに相互接続できる。

ISP に依存せず、永続的または断続的なインターネット接続がなくてもサイト内での通信に使用できる。

ルーティングまたは DNS により誤ってサイト外にリークされた場合でも、他のアドレスと競合しない。

アプリケーションは、一意のローカル アドレスをグローバル スコープのアドレスのように扱うことができる。

図 4 に、一意のローカル アドレスの構造を示します。

図 4 一意のローカル アドレスの構造

 

サイトローカル アドレス

RFC 3879 ではサイトローカル アドレスの使用が廃止されたため、プライベート IPv6 アドレスの設定は、RFC 4193 の Unique Local Addressing(ULA)に関する推奨事項に従って行う必要があります。

IPv6 アドレス タイプ:エニーキャスト

エニーキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットに割り当てられます。エニーキャスト アドレスに送信されたパケットは、使用しているルーティング プロトコルの定義に従って、そのエニーキャスト アドレスが示す最も近いインターフェイスに送信されます。エニーキャスト アドレスは、ユニキャスト アドレス空間から割り当てられるため、その構文ではユニキャスト アドレスと区別できません。ユニキャスト アドレスを複数のインターフェイスに割り当てると、ユニキャスト アドレスがエニーキャスト アドレスになります。エニーキャスト アドレスが割り当てられたノードは、アドレスがエニーキャスト アドレスであることを認識するように明示的に設定されている必要があります。


) エニーキャスト アドレスを使用できるのはルータだけです。ホストでは使用できません。エニーキャスト アドレスは、IPv6 パケットの送信元アドレスとして使用できません。


図 5 に、サブネット ルータ エニーキャスト アドレスの形式を示します。アドレスには、連続するゼロで連結されたプレフィクス(インターフェイス ID)があります。サブネット ルータ エニーキャスト アドレスを使用すると、サブネット ルータ エニーキャスト アドレスのプレフィクスが示すリンク上のルータに到達できます。

図 5 サブネット ルータ エニーキャスト アドレスの形式

 

次に、6to4 リレー ルータのエニーキャスト プレフィクスの設定を示します。

interface Tunnel0
no ip address
ipv6 address 2001:0DB8:A00:1::1/64
ipv6 address 2001:oDB8:c058:6301::/128 anycast
tunnel source Ethernet0
tunnel mode ipv6ip 6to4
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
ip address 192.88.99.1 255.255.255.0 secondary
!
ipv6 route 2001:0DB8::/16 Tunnel0
!

IPv6 アドレス タイプ:マルチキャスト

IPv6 マルチキャスト アドレスは、FF00::/8(1111 1111)というプレフィクスを持つ IPv6 マルチキャスト アドレスです。IPv6 マルチキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットの識別子です。マルチキャスト アドレスに送信されたパケットは、マルチキャスト アドレスが示すすべてのインターフェイスに配信されます。プレフィクスに続く 2 番めのオクテットで、マルチキャスト アドレスのライフタイムとスコープが定義されます。永続マルチキャスト アドレスはライフタイム パラメータが 0 と等しく、一時マルチキャスト アドレスはライフタイム パラメータが 1 と等しくなっています。ノード、リンク、サイト、または組織のスコープ、またはグローバル スコープを持つマルチキャスト アドレスのスコープ パラメータは、それぞれ 1、2、5、8、E です。たとえば、プレフィクスが FF02::/16 のマルチキャスト アドレスは、リンク スコープを持つ永続マルチキャスト アドレスです。図 6 に、IPv6 マルチキャスト アドレスの形式を示します。

図 6 IPv6 マルチキャスト アドレスの形式

 

IPv6 ノード(ホストとルータ)は、(受信パケットの宛先となる)次のマルチキャスト グループに加入する必要があります。

全ノード マルチキャスト グループ FF02:0:0:0:0:0:0:1(スコープはリンクローカル)

割り当てられたユニキャスト アドレスおよびエニーキャスト アドレスごとの請求ノード マルチキャスト グループ FF02:0:0:0:0:1:FF00:0000/104

IPv6 ルータは、全ルータ マルチキャスト グループ FF02:0:0:0:0:0:0:2(スコープはリンクローカル)にも加入する必要があります。

請求ノード マルチキャスト アドレスは、IPv6 ユニキャスト アドレスまたはエニーキャスト アドレスに対応するマルチキャスト グループです。IPv6 ノードは、割り当てられているユニキャスト アドレスおよびエニーキャスト アドレスごとに、関連付けられた請求ノード マルチキャスト グループに加入する必要があります。IPv6 請求ノード マルチキャスト アドレスには、対応する IPv6 ユニキャスト アドレスまたは IPv6 エニーキャスト アドレスの下位 24 ビットに連結されたプレフィクス FF02:0:0:0:0:1:FF00:0000/104 があります(図 7 を参照)。たとえば、IPv6 アドレス 2037::01:800:200E:8C6C に対応する請求ノード マルチキャスト アドレスは FF02::1:FF0E:8C6C です。請求ノード アドレスは、ネイバー請求メッセージで使用されます。

図 7 IPv6 請求ノード マルチキャスト アドレスの形式

 


) IPv6 にはブロードキャスト アドレスがありません。IPv6 マルチキャスト アドレスがブロードキャスト アドレスの代わりに使用されます。


IPv6 マルチキャスト グループ

インターフェイスが IPv6 トラフィックを転送するためには、そのインターフェイス上に IPv6 アドレスを設定する必要があります。インターフェイスにグローバル IPv6 アドレスを設定すると、リンクローカル アドレスが自動的に設定され、そのインターフェイスに対して IPv6 がアクティブになります。また、設定されたインターフェイスは、そのリンクに必要な次のマルチキャスト グループに自動的に加入します。

インターフェイスに割り当てられたユニキャスト アドレスおよびエニーキャスト アドレスごとの請求ノード マルチキャスト グループ FF02:0:0:0:0:1:FF00::/104

全ノード リンクローカル マルチキャスト グループ FF02::1

全ルータ リンクローカル マルチキャスト グループ FF02::2


) 請求ノード マルチキャスト アドレスは、ネイバー探索プロセスで使用されます。


IPv6 マルチキャストの詳細については、「 Implementing IPv6 Multicast 」を参照してください。

IPv6 アドレスの出力表示

IPv6 または IPv4 コマンドの出力に IPv6 アドレスが表示される場合、長い IPv6 アドレスが隣接フィールドにオーバーフローし、出力が読みにくくなることがあります。出力フィールドは、考えられる最長の IPv4 アドレス(15 文字)に対応するように設計されました。IPv6 アドレスは最大 39 文字です。適切な長さの IPv6 アドレスを表示し、必要に応じて以降のフィールドを次の行に移動するために、以下の方式が IPv4 および IPv6 コマンドに採用されました。移動されるフィールドは、ヘッダー行に位置揃えされます。

たとえば、 where コマンドからの出力表示を使用すると、8 の接続が表示されます。最初の 6 つの接続には IPv6 アドレスを使用し、最後の 2 つの接続には IPv4 アドレスを使用しています。

Router# where
 
Conn Host Address Byte Idle Conn Name
1 test5 2001:0DB8:3333:4::5 6 24 test5
2 test4 2001:0DB8:3333:44::5
6 24 test4
3 2001:0DB8:3333:4::5 2001:0DB8:3333:4::5 6 24 2001:0DB8:3333:4::5
4 2001:0DB8:3333:44::5
2001:0DB8:3333:44::5
6 23 2001:0DB8:3333:44::5
5 2001:0DB8:3000:4000:5000:6000:7000:8001
2001:0DB8:3000:4000:5000:6000:7000:8001
6 20 2001:0DB8:3000:4000:5000:6000:
6 2001:0DB8:1::1 2001:0DB8:1::1 0 1 2001:0DB8:1::1
7 10.1.9.1 10.1.9.1 0 0 10.1.9.1
8 10.222.111.222 10.222.111.222 0 0 10.222.111.222
 

接続 1 には、アドレス フィールドの最大アドレス長を使用する IPv6 アドレスが含まれます。接続 2 では、IPv6 アドレスによってアドレス フィールドがオーバーフローし、以降のフィールドが次の行に移動されますが、適切なヘッダーに位置揃えされていることが示されています。接続 3 には、どの行もラップせずにホスト名フィールドとアドレス フィールドの最大長を充てんする IPv6 が含まれます。接続 4 は、ホスト名フィールドとアドレス フィールドの両方に長い IPv6 アドレスが含まれる場合の結果を示しています。出力は、適切な見出し位置を維持したまま、3 行にわたって表示されています。接続 5 は、接続 4 と同様の結果を示していますが、ホスト名フィールドとアドレス フィールドに非常に長い IPv6 アドレスがあります。実際には、接続名フィールドは切り捨てられています。接続 6 では、表示の変更が不要な非常に短い IPv6 アドレスが表示されます。接続 7 および 8 では、短い IPv4 アドレスと長い IPv4 アドレスが表示されます。


) IPv6 アドレスの出力表示は、IPv6 アドレスを表示するすべてのコマンドに適用されます。


簡易 IPv6 パケット ヘッダー

基本 IPv4 パケット ヘッダーには、合計サイズが 20 オクテット(160 ビット)の 12 のフィールドがあります(図 8 を参照)。この 12 個のフィールドのあとにはオプション フィールドが続く場合があり、さらにそのあとに、通常はトランスポートレイヤ パケットであるデータ部分が続きます。可変長のオプション フィールドは、IPv4 パケット ヘッダーの合計サイズに加算されます。図 8 に示す IPv4 パケット ヘッダーのグレーのフィールドは、IPv6 パケット ヘッダーに含まれません。

図 8 IPv4 パケット ヘッダーの形式

 

基本 IPv6 パケット ヘッダーには、合計サイズが 40 オクテット(320 ビット)の 8 つのフィールドがあります(図 9 を参照)。IPv6 では、フラグメンテーションはルータによって処理されず、チェックサムはネットワーク レイヤで使用されないため、IPv6 ヘッダーからフィールドが除去されました。代わりに、IPv6 のフラグメンテーションはパケットの送信元によって処理され、チェックサムはデータ リンク レイヤとトランスポート レイヤで使用されます(IPv4 では、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)トランスポート レイヤでオプションのチェックサムが使用されます。IPv6 では、内部パケットの整合性をチェックするために UDP チェックサムを使用する必要があります)。また、基本 IPv6 パケット ヘッダーとオプション フィールドは 64 ビットに揃えられるため、IPv6 パケットの処理が簡単になります。

図 9 IPv6 パケット ヘッダーの形式

 

表 2 に、IPv6 パケット ヘッダーのフィールドをリストします。

 

表 2 基本 IPv6 パケット ヘッダー フィールド

フィールド
説明

バージョン

IPv4 パケット ヘッダーのバージョン フィールドと同様ですが、IPv4 を意味する数字 4 の代わりに IPv6 を意味する数字 6 が示されます。

トラフィック クラス

IPv4 パケット ヘッダーのタイプ オブ サービス フィールドと同様です。トラフィック クラス フィールドは、差別化されたサービスで使用されるトラフィック クラスのタグをパケットに付けます。

フロー ラベル

IPv6 パケット ヘッダーの新しいフィールドです。フロー ラベル フィールドは、ネットワーク レイヤでパケットを差別化する特定のフローのタグをパケットに付けます。

ペイロード長

IPv4 パケット ヘッダーの合計長フィールドと同様です。ペイロード長フィールドは、パケットのデータ部分の合計長を示します。

次ヘッダー

IPv4 パケット ヘッダーのプロトコル フィールドと同様です。次ヘッダー フィールドの値により、基本 IPv6 ヘッダーに続く情報のタイプが決まります。基本 IPv6 ヘッダーに続く情報のタイプは、図 9 に示すように、TCP や UDP パケットなどのトランスポートレイヤ パケット、または拡張ヘッダーです。

ホップ リミット

IPv4 パケット ヘッダーの存続可能時間フィールドと同様です。ホップ リミット フィールドの値は、IPv6 パケットが無効と見なされる前に通過できるルータの最大数です。各ルータを通過するたびに、この値が 1 つずつ減少します。IPv6 ヘッダーにはチェックサムがないため、ルータは値を減らすたびにチェックサムを再計算する必要がなく、処理リソースが節約されます。

送信元アドレス

IPv4 パケット ヘッダーの送信元アドレス フィールドと同様ですが、IPv4 の 32 ビット送信元アドレスの代わりに、IPv6 では 128 ビットの送信元アドレスが含まれます。

宛先アドレス

IPv4 パケット ヘッダーの宛先アドレス フィールドと同様ですが、IPv4 の 32 ビット宛先アドレスの代わりに、IPv6 では 128 ビットの宛先アドレスが含まれます。

基本 IPv6 パケット ヘッダーの 8 つのフィールドのあとに、オプションの拡張ヘッダーおよびパケットのデータ部分が続きます。拡張ヘッダーが存在する場合は、各拡張ヘッダーが 64 ビットに揃えられます。IPv6 パケットの拡張ヘッダーの数は固定されていません。拡張ヘッダーがまとまってヘッダーのチェーンを形成します。各拡張ヘッダーは、前のヘッダーの次ヘッダー フィールドによって識別されます。通常は、最後の拡張ヘッダーに、TCP や UDP などのトランスポートレイヤ プロトコルの次ヘッダー フィールドがあります。図 10 に、IPv6 拡張ヘッダー形式を示します。

図 10 IPv6 拡張ヘッダーの形式

 

表 3 に、拡張ヘッダー タイプとその次ヘッダー フィールド値をリストします。

 

表 3 IPv6 拡張ヘッダー タイプ

ヘッダー タイプ
次ヘッダーの値
説明

ホップバイホップ オプション ヘッダー

0

このヘッダーは、パケットのパス上のすべてのホップで処理されます。存在する場合、ホップバイホップ オプション ヘッダーは、常に基本 IPv6 パケット ヘッダーの直後に続きます。

宛先オプション ヘッダー

60

宛先オプション ヘッダーは、任意のホップバイホップ オプション ヘッダーのあとに続くことがあります。その場合、宛先オプション ヘッダーは、最終的な宛先と、ルーティング ヘッダーで指定された各通過アドレスでも処理されます。また、宛先オプション ヘッダーは、任意の Encapsulating Security Payload(ESP; カプセル化セキュリティ ペイロード)ヘッダーのあとに続くこともあります。その場合、宛先オプション ヘッダーは、最終的な宛先でだけ処理されます。

ルーティング ヘッダー

43

ルーティング ヘッダーは送信元のルーティングに使用されます。

フラグメント ヘッダー

44

フラグメント ヘッダーは、送信元が、送信元と宛先の間のパスの Maximum Transmission Unit(MTU; 最大伝送ユニット)よりも大きいパケットをフラグメント化する必要がある場合に使用されます。フラグメント ヘッダーは、フラグメント化された各パケットで使用されます。

認証ヘッダー

および

ESP ヘッダー

51

50

認証ヘッダーと ESP ヘッダーは、パケットの認証、整合性、および機密性を提供するために IP Security Protocol(IPsec; IP セキュリティ プロトコル)内で使用されます。これらのヘッダーは、IPv4 と IPv6 の両方で同一です。

上位層ヘッダー

6(TCP)

17(UDP)

上位層(トランスポート)ヘッダーは、データを転送するためにパケットの内部で使用される典型的なヘッダーです。2 つの主要なトランスポート プロトコルは TCP と UDP です。

モビリティ ヘッダー

135

バインディングの作成と管理に関連するすべてのメッセージで、モバイル ノード、対応ノード、およびホーム エージェントによって使用される拡張ヘッダー。

IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチング

シスコ エクスプレス フォワーディングは、IPv6 パケットを転送するための高度なレイヤ 3 IP スイッチング テクノロジーです。分散型シスコ エクスプレス フォワーディングは、シスコ エクスプレス フォワーディングと同じ機能を実行しますが、GSR や Cisco 7500 シリーズ ルータなどの分散型アーキテクチャ プラットフォーム用です。分散型 Cisco Express Forwarding for IPv6 および Cisco Express Forwarding for IPv6 は、分散型 Cisco Express Forwarding for IPv4 および Cisco Express Forwarding for IPv4 と同じ機能と利点を提供します。使用しているルーティング プロトコルの指示に従って追加、削除、または変更された IPv6 Routing Information Base(RIB; ルーティング情報ベース)のネットワーク エントリが Forwarding Information Bases(FIB; 転送情報ベース)に反映され、IPv6 隣接関係テーブルによって各 FIB のすべてのエントリのレイヤ 2 ネクストホップ アドレスが管理されます。


) デフォルトでは、GSR では、分散型シスコ エクスプレス フォワーディングだけがサポートされます(シスコ エクスプレス フォワーディング スイッチングはライン カードによって実行されます)。Cisco 7500 シリーズ ルータでは、シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングの両方がサポートされます。シスコ エクスプレス フォワーディングが Cisco 7500 シリーズ ルータ上に設定されている場合、シスコ エクスプレス フォワーディング スイッチングは Route Processor(RP; ルート プロセッサ)によって実行されます。分散型シスコ エクスプレス フォワーディングが設定されている場合、シスコ エクスプレス フォワーディング スイッチングはライン カードによって実行されます。


Cisco IOS Release 12.0(21)ST では、分散型 Cisco Express Forwarding には IPv6 アドレスおよびプレフィクスのサポートが含まれていました。Cisco IOS Release 12.0(22)S またはそれ以降のリリース、および Cisco IOS Release 12.2(13)T またはそれ以降のリリースでは、分散型シスコ エクスプレス フォワーディングとシスコ エクスプレス フォワーディングが拡張され、IPv6 のグローバル アドレスおよびリンクローカル アドレス用に別々の FIB がサポートされるようになりました。

各 IPv6 ルータ インターフェイスには、1 つの IPv6 グローバル FIB と 1 つの IPv6 リンクローカル FIB への関連付けがあります(複数のインターフェイスが同じ FIB への関連付けを持つことができます)。同じ IPv6 リンクに接続されているすべての IPv6 ルータ インターフェイスが、同じ IPv6 リンクローカル FIB を共有します。IPv6 グローバル宛先アドレスを持つ IPv6 パケットは IPv6 グローバル FIB によって処理されますが、IPv6 グローバル宛先アドレスと IPv6 リンクローカル送信元アドレスを持つパケットは、プロセス スイッチングとスコープエラー処理のために RP に送信されます。リンクローカル送信元アドレスを持つパケットはローカル リンクの外部に転送されず、プロセス スイッチングとスコープエラー処理のために RP に送信されます。

ユニキャスト Reverse Path Forwarding

ユニキャスト RPF 機能を使用すると、IPv6 ルータを経由する不正形式または偽造(スプーフィング)IPv6 送信元アドレスを原因とする問題が軽減されます。不正形式または偽造送信元アドレスは、送信元 IPv6 アドレス スプーフィングに基づく Denial-of-Service(DoS; サービス拒絶)攻撃を示すことがあります。

インターフェイスでユニキャスト RPF がイネーブルになっている場合、ルータはそのインターフェイスで受信したすべてのパケットを調べます。ルータは、送信元アドレスがルーティング テーブルにあり、パケットを受信したインターフェイスと一致することを確認します。ルックアップは FIB の存在に依存するため、この「後方参照」機能はシスコ エクスプレス フォワーディングがルータでイネーブルになっている場合にだけ使用可能です。シスコ エクスプレス フォワーディングでは、その動作の一部として FIB が生成されます。


) ユニキャスト RPF は入力機能であり、接続のアップストリーム エンドのルータの入力インターフェイスだけに適用されます。


ユニキャスト RPF 機能では、ルータ インターフェイスで受信されたパケットが、パケットの送信元への最良リターン パスの 1 つで着信するかどうかが検証されます。この機能では、シスコ エクスプレス フォワーディング テーブルのリバース ルックアップが実行されます。ユニキャスト RPF がパケットのリバース パスを見つけることができない場合、ユニキャスト RPF は、Access Control List(ACL; アクセス コントロール リスト)が指定されているかどうかに応じてパケットをドロップまたは転送できます。ACL が指定されている場合は、パケットがユニキャスト RPF チェックに失敗した場合にだけ、パケットが(ACL の deny 文を使用して)ドロップされる必要があるか、(ACL の permit 文を使用して)転送される必要があるかを確認するために ACL がチェックされます。パケットがドロップされるか転送されるかにかかわらず、パケットは、ユニキャスト RPF ドロップのグローバル IP トラフィック統計情報とユニキャスト RPF のインターフェイス統計情報でカウントされます。

ACL が指定されていない場合、ルータは偽造または不正形式のパケットを即時にドロップし、ACL ロギングは行われません。ルータおよびインターフェイス ユニキャスト RPF カウンタが更新されます。

RPF イベントは、ACL エントリのロギング オプションを指定することでロギングできます。ログ情報を使用して、送信元アドレスや時間など、攻撃に関する情報を収集できます。


) ユニキャスト RPF では、コストが等しいすべての「最良」リターン パスが有効と見なされます。複数のリターン パスが存在していても、各パスのルーティング コスト(ホップ数や加重など)が他のパスと等しく、そのルートが FIB 内にあるかぎり、ユニキャスト RPF は機能します。


IPv6 の DNS

IPv6 では、DNS の名前からアドレスおよびアドレスから名前のルックアップ プロセスでサポートされる DNS レコード タイプがサポートされます。DNS レコード タイプでは、IPv6 アドレスがサポートされます。IPv6 では、IPv6 アドレスから DNS 名への逆マッピングもサポートされます。

ネーム サーバを使用して、ドメイン名に関連付けられている情報を追跡します。ネーム サーバでは、ホスト名からアドレスへのマッピングのデータベースを維持できます。各名前は、1 つ以上の IPv4 アドレス、IPv6 アドレス、または両方のアドレス タイプにマッピングできます。このサービスを使用してドメイン名を IPv6 アドレスにマッピングするには、ネーム サーバを指定し、DNS をイネーブルにする必要があります。

Cisco IOS ソフトウェアは、 connect telnet ping の各コマンド、関連する Telnet サポート操作、およびコマンド出力を生成する他の多くのコマンドで使用するために、ホスト名からアドレスへのマッピングのキャッシュを維持します。このキャッシュによって、名前からアドレスへの変換が高速になります。

IPv4 と同様に、IPv6 で使用されるネーミング方式では、ドメインに対して提供する階層名前空間内の場所によってネットワーク デバイスを識別できます。ドメイン名は、ピリオド(.)を区切り文字として結合されます。たとえば、シスコは com ドメイン名で識別される商業組織であるため、ドメイン名は cisco.com です。このドメイン内の特定のデバイス、たとえば FTP サーバは、ftp.cisco.com として識別されます。


) IP6.ARPA サポートは、Cisco IOS Release 12.3(11)T で追加されました。IP6.ARPA は、Cisco IOS Release 12.3(11)T よりも前のリリースではサポートされていません。


表 4 に、IPv6 DNS レコード タイプをリストします。

 

表 4 IPv6 DNS レコード タイプ

レコード タイプ
説明
形式

AAAA

ホスト名を IPv6 アドレスにマッピングします(IPv4 の A レコードと同等)。

(注) IPv6 トランスポートまたは IPv4 トランスポートでの AAAA レコードと A レコードは、Cisco IOS Release 12.2(8)T またはそれ以降のリリースでサポートされます。

www.abc.test AAAA 3FFE:YYYY:C18:1::2

PTR

IPv6 アドレスをホスト名にマッピングします(IPv4 の PTR レコードと同等)。

(注) Cisco IOS ソフトウェアでは、IP6.INT ドメインの PTR レコードの解決がサポートされます。

2.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.1.0.0.0.8.1.c.0.y.y.y.y.e.f.f.3.ip6.int PTR www.abc.test

IPv6 のパス MTU ディスカバリ

IPv4 の場合と同様に、IPv6 のパス MTU ディスカバリを使用すると、特定のデータ パス上のすべてのリンクの MTU サイズの差をホストが動的に検出し、調整できます。ただし、IPv6 では、特定のデータ パス上の 1 つのリンクのパス MTU がパケットのサイズに十分に対応できる大きさでない場合に、フラグメンテーションはパケットの送信元によって処理されます。IPv6 ホストでパケット フラグメンテーションを処理すると、IPv6 ルータの処理リソースが節約され、IPv6 ネットワークの効率が向上します。


) IPv6 では、最小リンク MTU は 1280 オクテットです。IPv6 リンクには 1500 オクテットの MTU 値の使用が推奨されます。


シスコ検出プロトコル IPv6 アドレスのサポート

ネイバー情報機能向けのシスコ検出プロトコル IPv6 アドレス サポートにより、2 台のシスコ デバイス間で IPv6 アドレッシング情報を転送できます。IPv6 アドレス向けシスコ検出プロトコル サポートでは、ネットワーク管理製品とトラブルシューティング ツールに IPv6 情報が提供されます。

IPv6 の ICMP

IPv6 の Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)の機能は、IPv4 の ICMP と同じです。ICMP は、ICMP 宛先到達不能メッセージなどのエラー メッセージと、ICMP エコー要求および応答メッセージなどの情報メッセージを生成します。また、IPv6 の ICMP パケットは、IPv6 ネイバー探索プロセス、パス MTU ディスカバリ、および Multicast Listener Discovery(MLD; マルチキャスト リスナー ディスカバリ)プロトコル for IPv6 で使用されます。MLD は、直接接続リンク上でマルチキャスト リスナー(特定のマルチキャスト アドレス宛てのマルチキャスト パケットを受信するノード)を検出するために IPv6 によって使用されます。MLD は、バージョン 2 の Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)for IPv4 をベースとしています。

基本 IPv6 パケット ヘッダーの次ヘッダー フィールドの値 58 は、IPv6 ICMP パケットを示します。IPv6 の ICMP パケットは、ICMP パケットがすべての拡張ヘッダーのあとに続き、IPv6 パケット内の最後の情報部分であるという点で、トランスポートレイヤ パケットと同様です。IPv6 ICMP パケット内の ICMPv6 タイプ フィールドと ICMPv6 コード フィールドは、ICMP メッセージ タイプなどの IPv6 ICMP パケットの詳細を示します。チェックサム フィールドの値は、(送信側で計算し、受信側がチェックすることにより)IPv6 ICMP パケットと IPv6 擬似ヘッダーのフィールドから抽出されます。ICMPv6 データ フィールドには、IP パケット処理に関連するエラー情報または診断情報が含まれます。図 11 に、IPv6 ICMP パケット ヘッダーの形式を示します。

図 11 IPv6 ICMP パケット ヘッダーの形式

 

IPv6 ICMP レート制限

Cisco IOS Release 12.2(8)T またはそれ以降のリリースでは、IPv6 ICMP レート制限機能によって、IPv6 ICMP エラー メッセージがネットワークへ送信されるレートを制限するためのトークン バケット アルゴリズムが実装されます。IPv6 ICMP レート制限の初期の実装では、エラー メッセージ間に固定の間隔が定義されていましたが、traceroute などの一部のアプリケーションでは、間断なく送信される要求のグループへの返信が必要になる場合があります。エラー メッセージ間の固定間隔は、traceroute などのアプリケーションで動作するのに十分な柔軟性がなく、アプリケーションが失敗する原因となることがあります。トークン バケット方式を実装すると、複数のトークンを仮想バケットに格納できます。トークンごとに 1 つのエラー メッセージを送信できます。バケットに格納できるトークンの最大数を指定でき、エラー メッセージが送信されるたびに 1 つのトークンがバケットから削除されます。一連のエラー メッセージが生成された場合は、バケットが空になるまでエラー メッセージを送信できます。トークンのバケットが空になると、新しいトークンがバケットに配置されるまで、IPv6 ICMP エラー メッセージは送信されません。トークン バケット アルゴリズムは、レート制限の平均時間間隔を増やさず、固定時間間隔方式よりも柔軟性が高くなります。

IPv6 ネイバー探索

IPv6 ネイバー探索プロセスでは、ICMP メッセージおよび請求ノード マルチキャスト アドレスを使用して、同じネットワーク(ローカル リンク)上のネイバーのリンクレイヤ アドレスを判断し、ネイバーに到達可能かどうかを確認し、ネイバー ルータを追跡します。

ネイバー探索機能の IPv6 スタティック キャッシュ エントリにより、IPv6 ネイバー キャッシュ内にスタティック エントリを作成できます。スタティック ルーティングでは、管理者が、各ルータの各インターフェイスの IPv6 アドレス、サブネット マスク、ゲートウェイ、および対応する MAC アドレスをテーブルに入力する必要があります。スタティック ルーティングによって、より詳細な制御が可能になりますが、テーブルの保守作業が増えます。ルートが追加または変更されるたびにテーブルを更新する必要があります。

ステートフル スイッチオーバー

IPv6 ネイバー探索では、シスコ エクスプレス フォワーディングを使用した Stateful Switchover(SSO; ステートフル スイッチオーバー)がサポートされます。スイッチオーバーが行われると、(チェックポイントされる)シスコ エクスプレス フォワーディングの隣接状態を使用して、ネイバー探索キャッシュが再構築されます。

IPv6 ネイバー請求メッセージ

ICMP パケット ヘッダーのタイプ フィールドの値 135 は、ネイバー請求メッセージを示します。ネイバー請求メッセージは、ノードが同じローカル リンク上の別のノードのリンクレイヤ アドレスを判断する必要がある場合にローカル リンクに送信されます(図 12 を参照)。ノードが別のノードのリンクレイヤ アドレスを判断する必要がある場合、ネイバー請求メッセージ内の送信元アドレスは、ネイバー請求メッセージを送信するノードの IPv6 アドレスです。ネイバー請求メッセージ内の宛先アドレスは、宛先ノードの IPv6 アドレスに対応する請求ノード マルチキャスト アドレスです。ネイバー請求メッセージには、送信元ノードのリンクレイヤ アドレスも含まれます。

図 12 IPv6 ネイバー探索:ネイバー請求メッセージ

 

ネイバー請求メッセージを受信したあと、宛先ノードは、ICMP パケット ヘッダーのタイプ フィールドに値 136 を含むネイバー アドバタイズメント メッセージをローカル リンクに送信することで応答します。ネイバー アドバタイズメント メッセージの送信元アドレスは、ネイバー アドバタイズメント メッセージを送信するノードの IPv6 アドレス(具体的には、ノード インターフェイスの IPv6 アドレス)です。ネイバー アドバタイズメント メッセージ内の宛先アドレスは、ネイバー請求メッセージを送信したノードの IPv6 アドレスです。ネイバー アドバタイズメント メッセージのデータ部分には、ネイバー アドバタイズメント メッセージを送信するノードのリンクレイヤ アドレスが含まれます。

送信元ノードがネイバー アドバタイズメントを受信すると、送信元ノードと宛先ノードが通信できるようになります。

ネイバー請求メッセージは、ネイバーのリンクレイヤ アドレスが識別されたあとに、ネイバーの到達可能性の確認にも使用されます。ノードがネイバーの到達可能性を確認するときに、ネイバー請求メッセージの宛先アドレスは、ネイバーのユニキャスト アドレスです。

ネイバー アドバタイズメント メッセージは、ローカル リンク上のノードのリンクレイヤ アドレスが変更されたときにも送信されます。このような変更がある場合、ネイバー アドバタイズメントの宛先アドレスは全ノード マルチキャスト アドレスです。

ネイバー請求メッセージは、ネイバーのリンクレイヤ アドレスが識別されたあとに、ネイバーの到達可能性の確認にも使用されます。ネイバー到達不能検出では、ネイバーの障害またはネイバーへの転送パスの障害が識別されます。この検出は、ホストとネイバー ノード(ホストまたはルータ)間のすべてのパスで使用されます。ネイバー到達不能検出は、ユニキャスト パケットだけが送信されるネイバーに対して実行され、マルチキャスト パケットが送信されるネイバーに対しては実行されません。

ネイバーは、(以前にネイバーに送信されたパケットが受信され、処理されたことを示す)肯定確認応答がネイバーから返された場合に、到達可能と見なされます。上位層プロトコル(TCP など)からの肯定確認応答は、接続で転送が順調に進行している(宛先に到達しつつある)こと、またはネイバー請求メッセージに対してネイバー アドバタイズメント メッセージが受信されたことを示します。パケットがピアに到達している場合、それらのパケットは送信元のネクストホップ ネイバーにも到達しています。したがって、転送の進行により、ネクストホップ ネイバーが到達可能であることも確認されます。

ローカル リンク上にない宛先の場合、転送の進行は、ファーストホップ ルータが到達可能であることを暗に意味します。上位層プロトコルからの確認応答がない場合、ノードは、ユニキャスト ネイバー請求メッセージを使用してネイバーを探し、転送パスがまだ機能していることを確認します。

ネイバーから返信された請求ネイバー アドバタイズメント メッセージは、転送パスがまだ機能しているという肯定確認応答です(請求フラグが値 1 に設定されたネイバー アドバタイズメント メッセージは、ネイバー請求メッセージへの返信としてだけ送信されます)。非請求メッセージでは、送信元ノードから宛先ノードへの一方向パスだけが確認されます。請求ネイバー アドバタイズメント メッセージは、両方向のパスが機能していることを示します。


) 請求フラグが値 0 に設定されたネイバー アドバタイズメント メッセージは、転送パスがまだ機能していることを示す肯定確認応答とは見なされません。


ネイバー請求メッセージは、ユニキャスト IPv6 アドレスがインターフェイスに割り当てられる前にそのアドレスが一意であることを確認するために、ステートレス自動設定プロセスでも使用されます。新規のリンクローカル IPv6 アドレスに対しては、アドレスがインターフェイスに割り当てられる前に、最初に重複アドレス検出が実行されます(重複アドレス検出の実行中、新規アドレスは一時的な状態のままです)。具体的には、ノードは未指定の送信元アドレスと一時的なリンクローカル アドレスをメッセージの本文に含むネイバー請求メッセージを送信します。そのアドレスが別のノードですでに使用されている場合、ノードは一時的なリンクローカル アドレスを含むネイバー アドバタイズメント メッセージを返します。別のノードが同じアドレスの一意性を同時に検証している場合は、そのノードもネイバー請求メッセージを返します。ネイバー請求メッセージの返信としてネイバー アドバタイズメント メッセージが受信されず、同じ一時アドレスの検証を試行している他のノードからのネイバー請求メッセージも受信されない場合、最初のネイバー請求メッセージを送信したノードは、一時的なリンクローカル アドレスを一意であると見なし、そのアドレスをインターフェイスに割り当てます。

リンク上のすべての IPv6 ユニキャスト アドレス(グローバルまたはリンクローカル)が一意であることを検証する必要がありますが、リンクローカル アドレスの一意性が確認されるまでは、リンクローカル アドレスに関連付けられている他の IPv6 アドレスに対して重複アドレス検出は実行されません。Cisco IOS ソフトウェアでの重複アドレス検出のシスコ実装では、64 ビット インターフェイス識別子から生成されるエニーキャスト アドレスまたはグローバル アドレスの一意性は確認されません。

IPv6 ルータ アドバタイズメント メッセージ

Router Advertisement(RA; ルータ アドバタイズメント)メッセージは、ICMP パケット ヘッダーのタイプ フィールドが値 134 であり、IPv6 ルータの設定済みの各インターフェイスへ定期的に送信されます。ステートレス自動設定が正しく機能するには、RA メッセージでアドバタイズされるプレフィクス長が常に 64 ビットである必要があります。

RA メッセージは、全ノード マルチキャスト アドレスに送信されます(図 13 を参照)。

図 13 IPv6 ネイバー探索:RA メッセージ

 

通常、RA メッセージには次の情報が含まれます。

ローカル リンク上のノードがその IPv6 アドレスの自動設定に使用できる 1 つ以上のオンリンク IPv6 プレフィクス

アドバタイズメントに含まれる各プレフィクスのライフタイム情報

完成可能な自動設定のタイプ(ステートレスまたはステートフル)を示すフラグのセット

デフォルト ルータ情報(アドバタイズメントを送信しているルータをデフォルト ルータとして使用する必要があるかどうか、また使用する必要がある場合はルータをデフォルト ルータとして使用する必要のある秒単位での時間)

ホストが発信するパケットで使用する必要のあるホップ リミットや MTU など、ホストに関する詳細情報

RA は、ルータ請求メッセージへの返信としても送信されます。ICMP パケット ヘッダーの Type フィールドの値が 133 であるルータ請求メッセージは、システム始動時にホストによって送信されるため、ホストは次のスケジュールされた RA メッセージを待機することなくすぐに自動設定できます。ルータ請求メッセージが通常システム起動時にホストによって送信される(ホストにユニキャスト アドレスが設定されていない)場合、ルータ請求メッセージの送信元アドレスは、通常は未指定の IPv6 アドレス(0:0:0:0:0:0:0:0)です。ホストにユニキャスト アドレスが設定されている場合は、ルータ請求メッセージを送信するインターフェイスのユニキャスト アドレスが、メッセージで送信元アドレスとして使用されます。ルータ請求メッセージの宛先アドレスは、スコープがリンクである全ルータ マルチキャスト アドレスです。RA がルータ請求への返信として送信される場合、RA メッセージ内の宛先アドレスは、ルータ請求メッセージの送信元のユニキャスト アドレスです。

次の RA メッセージ パラメータを設定できます。

RA メッセージが定期的に送信される時間の間隔

(特定のリンク上のすべてのノードで使用される)デフォルト ルータとしてのルータの実用性を示す「ルータ ライフタイム」値

特定のリンクで使用されているネットワーク プレフィクス

(特定のリンクで)ネイバー請求メッセージが再送信される時間の間隔

ノードによってネイバーが到達可能である(特定のリンク上のすべてのノードで使用できる)と見なされるまでの時間

設定されたパラメータはインターフェイスに固有です。RA メッセージ(デフォルト値を含む)の送信は、 ipv6 unicast-routing コマンドの設定時にイーサネットおよび FDDI インターフェイスで自動的にイネーブルになります。その他のインターフェイス タイプの場合は、 no ipv6 nd ra suppress コマンドを使用して、RA メッセージの送信を手動で設定する必要があります。個々のインターフェイスで、 ipv6 nd ra suppress コマンドを使用して、RA メッセージの送信をディセーブルにできます。

トラフィック エンジニアリングのデフォルト ルータ プリファレンス

ホストは、RA をリスニングすることでデフォルト ルータを検出し、選択します。通常のデフォルト ルータ選択メカニズムは、トラフィック エンジニアリングが必要な場合など、特定のケースでは次善のメカニズムです。たとえば、リンク上の 2 台のルータが、同等だが等しくはないコストのルーティングを提供している場合や、ポリシーによってルータの一方を優先することが指示されている場合があります。次に例をいくつか示します。

異なるプレフィクス セットへルーティングする複数のルータ:リダイレクト(宛先に対して最適でないルータによって送信される)は、ホストが任意のルータを選択でき、システムが機能することを意味します。ただし、トラフィック パターンは、ルータの 1 つを選択すると、リダイレクトがかなり少なくなることを意味する場合があります。

新しいルータの誤った展開:新しいルータを完全に設定する前に展開すると、ホストによって新しいルータがデフォルト ルータとして採用され、トラフィックが消える可能性があります。ネットワーク管理者は、一部のルータが他のルータよりも優先されることを指定できます。

マルチホーム環境:複数の物理リンクと IPv6 トランスポートでのトンネリングの使用により、マルチホーム環境はより一般的になる可能性があります。一部のルータは、6-to-4 プレフィクスにだけルーティングするか、企業イントラネットにだけルーティングするため、完全なデフォルト ルーティングを提供しないことがあります。このような状況は、単一リンク上でだけ機能するリダイレクトでは解決できません。

Default Router Preference(DRP; デフォルト ルータ プリファレンス)拡張は、大まかなプリファレンス メトリック(低、中、高)をデフォルト ルータに提供します。デフォルト ルータの DRP は、RA メッセージ内の未使用ビットで通知されます。この拡張は、ルータ(DRP ビットの設定)とホスト(DRP ビットの解釈)の両方に対して下位互換性があります。これらのビットは、DRP 拡張を実装しないホストでは無視されます。同様に、DRP 拡張を実装しないルータによって送信される値は、DRP 拡張を実装するホストによって「中」のプリファレンスが指定されたものと解釈されます。

DRP は手動で設定する必要があります。オプションの DRP 拡張の設定については、トラフィック エンジニアリングの DRP 拡張の設定を参照してください。

IPv6 ネイバー リダイレクト メッセージ

ICMP パケット ヘッダーのタイプ フィールドの値 137 は、IPv6 ネイバー リダイレクト メッセージを示します。ルータは、ネイバー リダイレクト メッセージを送信して、宛先へのパス上のより適切なファーストホップ ノードをホストに通知します(図 14 を参照)。

図 14 IPv6 ネイバー探索:ネイバー リダイレクト メッセージ

 


) リダイレクト メッセージ内のターゲット アドレス(最終的な宛先)によってネイバー ルータのリンクローカル アドレスが確実に識別されるように、ルータは各ネイバー ルータのリンクローカル アドレスを判断できる必要があります。スタティック ルーティングの場合、ネクストホップ ルータのアドレスは、ルータのリンクローカル アドレスを使用して指定する必要があります。ダイナミック ルーティングの場合は、すべての IPv6 プロトコルがネイバー ルータのリンクローカル アドレスを交換する必要があります。


パケットの転送後に、次の条件が満たされる場合、ルータはパケットの送信元にリダイレクト メッセージを送信する必要があります。

パケットの宛先アドレスがマルチキャスト アドレスではない。

パケットがルータにアドレッシングされていなかった。

パケットが、そのパケットを受信したインターフェイスから送信されようとしている。

ルータが、パケットにより適したファーストホップ ノードはパケットの送信元と同じリンク上にあると判断した。

パケットの送信元アドレスが、同じリンク上のネイバーのグローバル IPv6 アドレス、またはリンクローカル アドレスである。

ネイバー リダイレクト メッセージなどのすべての IPv6 ICMP エラー メッセージをルータが生成するレートを制限するには、 ipv6 icmp error-interval コマンドを使用します。これにより、リンクレイヤの輻輳が最終的に低減されます。


) ルータは、ネイバー リダイレクト メッセージの受信後はルーティング テーブルを更新できず、ホストはネイバー リダイレクト メッセージを発信できません。


Per-Interface ネイバー探索キャッシュ制限

ネイバー探索キャッシュ内のエントリ数は、インターフェイスごとに制限できます。この制限に達すると、新しいエントリは追加されなくなります。Per-Interface ネイバー探索キャッシュ制限機能を使用すれば、インターフェイスに接続された特定のお客様がネイバー探索キャッシュに過剰な負荷を与えることを、それが意図的かどうかにかかわらず防ぐことができます。

この機能をグローバルにイネーブルにすると、ルータ上のすべてのインターフェイスに、共通のインターフェイス単位のキャッシュ サイズ制限が設定されます。この機能をインターフェイスごとにイネーブルにすると、キャッシュ サイズ制限はそれに対応するインターフェイス上で設定されます。インターフェイスごとの制限は、グローバルに設定された制限よりも優先されます。

リンク、サブネット、およびサイト アドレッシングの変更

ここでは、リンク、サブネット、およびサイト アドレッシングの変更の管理に使用できる IPv6 ステートレス自動設定および汎用プレフィクスの機能について説明します。

IPv6 ステートレス自動設定

IPv6 ノード上のすべてのインターフェイスには、通常はインターフェイスの識別子とリンクローカル プレフィクス FE80::/10 から自動的に設定されるリンクローカル アドレスが必要です。リンクローカル アドレスを使用すると、ノードがリンク上の他のノードと通信できます。また、リンクローカル アドレスを使用して、ノードをさらに設定することもできます。

ノードは、手動の設定や Dynamic Host Configuration Protocol(DHCP)サーバなどのサーバの支援を必要とすることなく、ネットワークに接続し、グローバル IPv6 アドレスを自動的に生成できます。IPv6 では、リンク上のルータは、RA メッセージ内で、任意のグローバル プレフィクスと、リンクのデフォルト ルータとして機能する旨をアドバタイズします。RA メッセージは、定期的に送信される場合と、システム始動時にホストから送信されるルータ請求メッセージに対する応答として送信される場合があります。

リンク上のノードは、RA メッセージに含まれるプレフィクス(64 ビット)にインターフェイス識別子(64 ビット)を付加することで、グローバル IPv6 アドレスを自動的に設定できます。ノードによって設定された 128 ビットの IPv6 アドレスは、重複アドレス検出の対象となり、リンク上での一意性が確保されます。RA メッセージでアドバタイズされたプレフィクスがグローバルに一意である場合、ノードによって設定された IPv6 アドレスもグローバルに一意になります。ICMP パケット ヘッダーの Type フィールドの値が 133 であるルータ請求メッセージは、システム始動時にホストによって送信されるため、ホストは次のスケジュールされた RA メッセージを待機することなくすぐに自動設定できます。

IPv6 ホストの簡易ネットワーク リナンバリング

グローバル ルーティング テーブルの厳格な集約では、ネットワークのサービス プロバイダーが変更された場合にネットワークをリナンバリングする必要があります。IPv6 のステートレス自動設定機能を使用してネットワークをリナンバリングする場合は、新しいサービス プロバイダーからのプレフィクスが、リンク上に送信される RA メッセージに追加されます(RA メッセージには、古いサービス プロバイダーからのプレフィクスと新しいサービス プロバイダーからのプレフィクスの両方が含まれます)。リンク上のノードは、新しいサービス プロバイダーからのプレフィクスを使用して追加アドレスを自動的に設定します。ノードは、新しいプレフィクスから作成されたアドレスとリンク上の古いプレフィクスから作成された既存のアドレスを使用できます。古いプレフィクスと新しいプレフィクスに関連付けられているライフタイム パラメータの設定は、リンク上のノードが、新しいプレフィクスから作成されたアドレスだけを使用するように移行できることを意味します。移行期間中は、古いプレフィクスが RA メッセージから削除され、新しいプレフィクスを含むアドレスだけがリンク上で使用されます(リナンバリングが完了します)(図 15 を参照)。

図 15 ステートレス自動設定を使用したホストの IPv6 ネットワーク リナンバリング

 

IPv6 の汎用プレフィクス

IPv6 アドレスの上位 64 ビットは、RFC 3513 で定義されているように、グローバル ルーティング プレフィクスとサブネット ID から構成されます。汎用プレフィクス(/48 など)には、短いプレフィクスが保持されます。このプレフィクスに基づいて、より長く詳細な複数のプレフィクス(/64 など)を定義できます。汎用プレフィクスが変更されると、そのプレフィクスに基づくより詳細なプレフィクスもすべて変更されます。この機能により、ネットワーク リナンバリングが大幅に簡略化され、自動化されたプレフィクス定義が可能になります。

たとえば、汎用プレフィクスは 48 ビットの長さ(/48)で、そのプレフィクスから生成されるより詳細なプレフィクスは 64 ビットの長さ(/64)の場合があります。次の例では、すべての詳細プレフィクスの一番左の 48 ビットが同じになります。これは汎用プレフィクス自体と同じです。次の 16 ビットはすべて異なります。

汎用プレフィクス:2001:0DB8:2222::/48

詳細プレフィクス:2001:0DB8:2222:0000::/64

詳細プレフィクス:2001:0DB8:2222:0001::/64

詳細プレフィクス:2001:0DB8:2222:4321::/64

詳細プレフィクス:2001:0DB8:2222:7744::/64

汎用プレフィクスは、次のようないくつかの方法で定義できます。

手動で定義する

6to4 インターフェイスに基づいて定義する

DHCP for IPv6 プレフィクス委任クライアントによって受信されたプレフィクスから動的に定義する

汎用プレフィクスに基づくより詳細なプレフィクスは、インターフェイスに IPv6 を設定する場合に使用できます。

DHCP for IPv6 プレフィクス委任

DHCP for IPv6 を環境で使用して、ステートフルおよびステートレス情報を配信できます。この機能の詳細については、「 Implementing DHCP for IPv6 」を参照してください。

IPv6 プレフィクス集約

IPv6 アドレス空間の集約可能な特性により、IPv6 アドレッシング階層がイネーブルになります。たとえば、企業はサービス プロバイダーの単一の IPv6 プレフィクスを複数のより長いプレフィクスに分割して、社内ネットワーク内で使用できます。反対に、サービス プロバイダーは、カスタマーのすべてのプレフィクスを、サービス プロバイダーが IPv6 インターネット上でアドバタイズできる単一のより短いプレフィクスに集約できます(図 16 を参照)。

図 16 IPv6 プレフィクス集約

 

IPv6 サイト マルチホーミング

複数の IPv6 プレフィクスをネットワークとホストに割り当てることができます。複数のプレフィクスをネットワークに割り当てると、グローバル ルーティング テーブルを壊すことなくネットワークを複数の ISP に簡単に接続できるようになります(図 17 を参照)。

図 17 IPv6 サイト マルチホーミング

 

IPv6 データ リンク

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。データ リンクは、接続しているネットワークのアドレッシングの複雑さをサブネットワークから隠しながらマルチレベルの階層ルーティング構造を提供するために、ネットワーク管理者によって任意にセグメント化されるネットワークです。IPv6 のサブネットワークの機能は、IPv4 のサブネットワークと同様です。サブネットワーク プレフィクスは 1 つのデータ リンクに関連付けられ、複数のサブネットワーク プレフィクスを同じデータ リンクに割り当てることができます。

IPv6 では、ATM Permanent Virtual Circuit(PVC; 相手先固定接続)および ATM LANE、イーサネット、ファスト イーサネット、ギガビット イーサネット、FDDI、フレーム リレー PVC、Cisco High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)、PPP over Packet over SONET(PoS)、ISDN、シリアル インターフェイス、Dynamic Packet Transport(DPT; ダイナミック パケット トランスポート)の各データ リンクがサポートされます。

Cisco IOS ソフトウェアの IPv6 でのワイドエリア ネットワーク テクノロジーのサポート

Cisco IOS ソフトウェアの IPv6 では、Cisco HDLC、PoS、ISDN、シリアル(同期および非同期)インターフェイス タイプ、ATM PVC、フレーム リレー PVC などのワイドエリア ネットワーク テクノロジーがサポートされます。これらのテクノロジーは、IPv6 でも IPv4 と同様に動作します。IPv6 での機能強化はありません。

IPv6 アドレスと PVC

LAN では、プロトコル(ネットワークレイヤ)アドレスをリモート ノード(ホストおよびルータ)のハードウェア アドレスにマッピングするために、ブロードキャストとマルチキャストが使用されます。ブロードキャストおよびマルチキャストを使用した、ATM ネットワークやフレーム リレー ネットワークなどの回線ベースの WAN のハードウェア アドレスへのネットワークレイヤ アドレスのマッピングは実装が難しいため、これらのネットワークでは、リモート ノードのネットワークレイヤ アドレスおよびアドレスへの到達に使用される PVC に暗黙のマッピング、明示的なマッピング、およびダイナミック マッピングを利用します。

ipv6 address コマンドを使用した、インターフェイスへの IPv6 アドレスの割り当てでは、インターフェイスおよびインターフェイスに直接接続されているネットワークの IPv6 アドレスを定義します。インターフェイスで 1 つの PVC だけが終端されている(インターフェイスがポイントツーポイント インターフェイスである)場合は、ネットワーク上のすべての IPv6 アドレスとアドレスへの到達に使用される PVC 間に暗黙のマッピングがあります(追加のアドレス マッピングは不要です)。インターフェイスで複数の PVC が終端されている(インターフェイスがポイントツーマルチポイント インターフェイスである)場合は、 protocol ipv6 コマンド(ATM ネットワークの場合)または frame-relay map ipv6 コマンド(フレーム リレー ネットワークの場合)を使用して、リモート ノードの IPv6 アドレスとアドレスへの到達に使用される PVC との間に明示的なマッピングを設定します。


) IPv6 では複数のアドレス タイプがサポートされるため、ポイントツーマルチポイント インターフェイスに設定されるアプリケーションまたはプロトコルによっては、インターフェイスの IPv6 アドレスとアドレスへの到達に使用される PVC との間に複数の明示的なマッピングを設定することが必要な場合があります。たとえば、ポイントツーマルチポイント インターフェイスのリンクローカルとグローバルの両方の IPv6 アドレスを、インターフェイスが終端する PVC に明示的にマッピングすると、インターフェイスに設定された Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)が PVC との間でトラフィックを正しく転送することが保証されます。


IPv6 のルーテッド ブリッジ カプセル化

Routed Bridge Encapsulation(RBE; ルーテッド ブリッジ カプセル化)は、ブリッジ インターフェイスから別のルーテッド インターフェイスまたはブリッジ インターフェイスにプロトコルをルーティングするメカニズムを提供します。IPv6 の RBE は、IPv6 ハーフブリッジング用に設定された ATM ポイントツーポイント サブインターフェイス上で使用できます。IP パケットと IPv6 ハーフブリッジング、ブリッジング、PPP over Ethernet(PPPoE)、またはその他のイーサネット 802.3 カプセル化プロトコルのルーティングを同じサブインターフェイス上で設定できます。

IPv6 リダイレクト メッセージ

IPv6 リダイレクト メッセージ機能により、ルータは ICMP IPv6 ネイバー リダイレクト メッセージを送信して、宛先へのパス上のより適切なファースト ホップ ノード(ルータまたはホスト)をホストに通知できます。

ブリッジングおよびルーティングのための BVI インターフェイス上での IPv6

Integrated Routing and Bridging(IRB)により、ユーザは、ルーテッド インターフェイスとブリッジ グループの間またはブリッジ グループ間で所定のプロトコルをルーティングできるようになります。具体的には、ローカル トラフィックまたはルーティング不可能なトラフィックは同じブリッジ グループ内のブリッジ インターフェイス間でブリッジされ、ルーティング可能なトラフィックは他のルーテッド インターフェイスまたはブリッジ グループにルーティングされます。

IPv6 は、BVI でサポートされています。BVI は、ブリッジ インターフェイス用の IPv4 インターフェイスです。ブリッジングはデータリンク レイヤで実行され、ルーティングはネットワーク レイヤで実行されるため、それぞれ異なるプロトコル設定モデルに従います。基本的な IPv4 モデルでは、たとえば、すべてのブリッジ インターフェイスは同じネットワークに属している必要があり、それに対してルーテッド インターフェイスはそれぞれ別個のネットワークを表します。ルーティングされるトラフィックの宛先はルータになりますが、ブリッジされるトラフィックの宛先はルータになることはありません。BVI を使用すると、同じブリッジ グループ内で所定のプロトコルのブリッジングおよびルーティングを両方実行するとき、どのプロトコル設定モデルを使用するか混乱することはなくなります。


) IPv6 での Bridge-Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)は、NAT-PT およびワイヤレス インターフェイス Dot11Radio でサポートされません。


デュアル IPv4 および IPv6 プロトコル スタック

デュアル IPv4 および IPv6 プロトコル スタック手法を使用して IPv6 に移行できます。これにより、ノードで稼動しているアプリケーションに対する段階的な 1 つずつのアップグレードが可能になります。ノードで稼動しているアプリケーションは、IPv6 プロトコル スタックを使用するようにアップグレードされます。アップグレードされない(IPv4 プロトコル スタックだけをサポートする)アプリケーションは、ノード上のアップグレードされたアプリケーションと共存できます。新しいアプリケーションとアップグレードされたアプリケーションでは、IPv4 と IPv6 の両方のプロトコル スタックを使用します(図 18 を参照)。

図 18 デュアル IPv4 および IPv6 プロトコル スタック手法

 

1 つの Application Program Interface(API; アプリケーション プログラム インターフェイス)で、IPv4 アドレスと IPv6 アドレスの両方および DNS 要求がサポートされます。アプリケーションを新しい API にアップグレードしても、依然として IPv4 プロトコル スタックだけを使用できます。Cisco IOS ソフトウェアでは、デュアル IPv4 および IPv6 プロトコル スタック手法がサポートされます。IPv4 アドレスと IPv6 アドレスの両方でインターフェイスが設定されている場合、インターフェイスは IPv4 と IPv6 両方のトラフィックを転送します。

図 19 では、デュアル IPv4 および IPv6 プロトコル スタックをサポートするアプリケーションは、宛先ホスト名 www.a.com で使用可能なすべてのアドレスを DNS サーバに要求します。DNS サーバは、www.example.com で使用可能なすべてのアドレス(IPv4 アドレスと IPv6 アドレスの両方)で返信します。アプリケーションはアドレスを選択し(ほとんどの場合、IPv6 アドレスがデフォルトの選択肢です)、IPv6 プロトコル スタックを使用して送信元ノードを宛先に接続します。

図 19 デュアル IPv4 および IPv6 プロトコル スタック アプリケーション

 

IPv6 アドレッシングと基本接続の実装方法

「IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル」

「IPv6 汎用プレフィクスの定義と使用」

「IPv4 および IPv6 プロトコル スタックをサポートするためのインターフェイスの設定」

「IPv6 ICMP レート制限の設定」

「トラフィック エンジニアリングの DRP 拡張の設定」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

「IPv6 アドレスへのホスト名のマッピング」

「IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング」

「IPv6 リダイレクト メッセージの表示」

IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル

IPv6 アドレスを個々のルータ インターフェイスに割り当て、IPv6 トラフィックの転送をルータ上でグローバルにイネーブルにするには、次の作業を実行します。デフォルトでは、IPv6 アドレスは設定されず、IPv6 ルーティングはディセーブルになります。


ipv6 address コマンドの ipv6-address 引数は、RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ipv6 address コマンドの ipv6-prefix 引数は、RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ipv6 address コマンドの /prefix-length キーワードおよび引数は、アドレスのうち連続する上位何ビットがプレフィクス(アドレスのネットワーク部)を構成するかを示す 10 進数値です。10 進数値の前にスラッシュ記号が必要です。


制約事項

Cisco IOS Release 12.2(4)T またはそれ以降のリリース、Cisco IOS Release 12.0(21)ST、および Cisco IOS Release 12.0(22)S またはそれ以降のリリースでは、 ipv6 address または ipv6 address eui-64 コマンドを使用して、インターフェイス上の同じプレフィクス内に複数の IPv6 グローバル アドレスを設定できます。1 つのインターフェイス上で複数の IPv6 リンクローカル アドレスはサポートされません。

Cisco IOS Releases 12.2(4)T、12.0(21)ST、および 12.0(22)S よりも前のリリースでは、インターフェイス上の同じプレフィクス内に複数の IPv6 アドレスが設定されていると、Cisco IOS Command-Line Interface(CLI; コマンドライン インターフェイス)に次のエラー メッセージが表示されます。

Prefix <prefix-number> already assigned to <interface-type>

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 address ipv6-prefix / prefix-length eui-64
または
ipv6 address ipv6-address / prefix-length link-local
または
ipv6 address ipv6-prefix / prefix-length anycast
または
ipv6 enable

5. exit

6. ipv6 unicast-routing

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 address ipv6-prefix / prefix-length eui-64

または

ipv6 address ipv6-address / prefix-length link-local

 

または

ipv6 address ipv6-prefix / prefix-length anycast

または

ipv6 enable

 

Router(config-if)# ipv6 address 2001:0DB8:0:1::/64 eui-64

 

または

 

Router(config-if)# ipv6 address FE80::260:3EFF:FE11:6770 link-local

 

または

 
Router(config-if) ipv6 address 2001:0DB8:1:1:FFFF:FFFF:FFFF:FFFE/64 anycast
 

または

 

Router(config-if)# ipv6 enable

インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。

または

インターフェイスに割り当てられている IPv6 アドレスを指定し、そのインターフェイスで IPv6 処理をイネーブルにします。

または

インターフェイスで IPv6 リンクローカル アドレスを自動的に設定し、インターフェイスで IPv6 処理もイネーブルにします。リンクローカル アドレスは、同じリンク上のノードとの通信にだけ使用できます。

ipv6 address eui-64 コマンドを指定して、IPv6 アドレスの下位 64 ビットにインターフェイス識別子(ID)を持つグローバル IPv6 アドレスを設定します。指定する必要があるのはアドレスの 64 ビット ネットワーク プレフィクスだけです。最後の 64 ビットはインターフェイス ID から自動的に計算されます。

ipv6 address link-local コマンドを指定して、IPv6 がインターフェイスでイネーブルになっている場合に自動的に設定されるリンクローカル アドレスの代わりに使用されるリンクローカル アドレスを、インターフェイスに設定します。

ipv6 address anycast コマンドを指定して、IPv6 エニーキャスト アドレスを追加します。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 6

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ネイバー探索キャッシュ制限の設定

ネイバー探索キャッシュ制限をインターフェイスごとまたはグローバルに設定するには、次の作業を実行します。

「指定したルータ インターフェイス上でのネイバー探索キャッシュ制限の設定」

「すべてのルータ インターフェイス上でのネイバー探索キャッシュ制限の設定」

指定したルータ インターフェイス上でのネイバー探索キャッシュ制限の設定

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 nd cache interface-limit size [ log rate ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface GigabitEthernet 1/0/0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 nd cache interface-limit size [ log rate ]

 

Router(config-if)# ipv6 nd cache interface-limit 1

ルータ上の指定したインターフェイスにネイバー探索キャッシュ制限を設定します。

このコマンドを実行すると、グローバル コンフィギュレーション モードで ipv6 nd cache interface-limit を実行して作成されている設定が上書きされます。

すべてのルータ インターフェイス上でのネイバー探索キャッシュ制限の設定

手順の概要

1. enable

2. configure terminal

3. ipv6 nd cache interface-limit size [ log rate ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 nd cache interface-limit size [ log rate ]

 

Router(config)# ipv6 nd cache interface-limit 4

ルータ上のすべてのインターフェイスにネイバー探索キャッシュ制限を設定します。

IPv6 汎用プレフィクスの定義と使用

汎用プレフィクスは、次のようないくつかの方法で定義できます。

手動で定義する

6to4 インターフェイスに基づいて定義する

DHCP for IPv6 プレフィクス委任クライアントによって受信されたプレフィクスから動的に定義する

汎用プレフィクスに基づくより詳細なプレフィクスは、インターフェイスに IPv6 を設定する場合に使用できます。

次の作業では、IPv6 汎用プレフィクスを定義および使用する方法を示します。

「汎用プレフィクスの手動定義」

「6to4 インターフェイスに基づく汎用プレフィクスの定義」

「DHCP for IPv6 プレフィクス委任クライアント機能での汎用プレフィクスの定義」

「IPv6 での汎用プレフィクスの使用」

汎用プレフィクスの手動定義

手順の概要

1. enable

2. configure terminal

3. ipv6 general-prefix prefix-name [ ipv6-prefix / prefix-length ] [ 6to4 interface-type interface-number ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 general-prefix prefix-name { ipv6-prefix / prefix-length | 6to4 interface-type interface-number }

 

Router(config)# ipv6 general-prefix my-prefix 2001:0DB8:2222::/48

IPv6 アドレスの汎用プレフィクスを定義します。

汎用プレフィクスを手動で定義する場合は、 ipv6-prefix 引数と / prefix-length 引数の両方を指定します。

6to4 インターフェイスに基づく汎用プレフィクスの定義

手順の概要

1. enable

2. configure terminal

3. ipv6 general-prefix prefix-name [ ipv6-prefix / prefix-length ] [ 6to4 interface-type interface-number ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 general-prefix prefix-name { ipv6-prefix / prefix-length | 6to4 interface-type interface-number }

 

Router(config)# ipv6 general-prefix my-prefix 6to4 ethernet 0

IPv6 アドレスの汎用プレフィクスを定義します。

6to4 インターフェイスに基づく汎用プレフィクスを定義する場合は、 6to4 キーワードと interface-type interface-number 引数を指定します。

6to4 トンネリングに使用するインターフェイスに基づく汎用プレフィクスを定義する場合、汎用プレフィクスは 2001:a.b.c.d::/48 の形式になります。「a.b.c.d」は、参照されるインターフェイスの IPv4 アドレスです。

DHCP for IPv6 プレフィクス委任クライアント機能での汎用プレフィクスの定義

DHCP for IPv6 プレフィクス委任クライアント機能を使用して、汎用プレフィクスを動的に定義できます。この作業の実行方法については、「 DHCP for IPv6 の実装 」の章を参照してください。

IPv6 での汎用プレフィクスの使用

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

 

Router(config-if) ipv6 address my-prefix 2001:0DB8:0:7272::/64

IPv6 アドレスの IPv6 プレフィクス名を設定し、インターフェイスで IPv6 処理をイネーブルにします。

IPv4 および IPv6 プロトコル スタックをサポートするためのインターフェイスの設定

シスコのネットワーク デバイスのインターフェイスが IPv4 アドレスと IPv6 アドレスの両方で設定されている場合、インターフェイスは IPv4 トラフィックと IPv6 トラフィックの両方を転送します。インターフェイスは、IPv4 ネットワークと IPv6 ネットワークの両方でデータを送受信できます。IPv4 と IPv6 の両方のプロトコル スタックをサポートするようにシスコのネットワーク デバイスのインターフェイスを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ipv6 unicast-routing

4. interface type number

5. ip address ip-address mask [ secondary [ vrf vrf-name ]]

6. ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

手順の詳細

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 unicast-routing

 

Router(config)# ipv6 unicast routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask [ secondary [ vrf vrf-name ] ]

 

Router(config-if)# ip address 192.168.99.1 255.255.255.0

インターフェイスに対するプライマリ IPv4 アドレスまたはセカンダリ IPv4 アドレスを指定します。

ステップ 6

ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

 

Router(config-if)# ipv6 address 2001:0DB8:c18:1::3/64

インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。

(注) IPv6 アドレスの設定の詳細については、「IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル」を参照してください。

IPv6 ICMP レート制限の設定

手順の概要

1. enable

2. configure terminal

3. ipv6 icmp error-interval milliseconds [ bucketsize ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 icmp error-interval milliseconds [ bucketsize ]

 

Router(config)# ipv6 icmp error-interval 50 20

IPv6 ICMP エラー メッセージの間隔とバケット サイズを設定します。

milliseconds 引数では、トークンがバケットに追加される間隔を指定します。

オプションの bucketsize 引数では、バケットに格納されるトークンの最大数を定義します。

トラフィック エンジニアリングの DRP 拡張の設定

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 nd router-preference { high | medium | low }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ipv6 nd router-preference { high | medium | low }

 

Router(config-if)# ipv6 nd router-preference high

特定のインターフェイス上のルータに DRP を設定します。

IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定

IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングを設定するには、次の作業を実行します。

「分散型および非分散型アーキテクチャ プラットフォームでのシスコ エクスプレス フォワーディング スイッチングの設定」

「ユニキャスト RPF の設定」

分散型および非分散型アーキテクチャ プラットフォームでのシスコ エクスプレス フォワーディング スイッチングの設定

シスコ エクスプレス フォワーディングは、Cisco 7200 シリーズ ルータなどの非分散型アーキテクチャ プラットフォーム用に設計されています。分散型シスコ エクスプレス フォワーディングは、GSR や Cisco 7500 シリーズ ルータなどの分散型アーキテクチャ プラットフォーム用に設計されています。非分散型プラットフォームでは、分散型シスコ エクスプレス フォワーディングはサポートされませんが、Cisco 7500 シリーズ ルータなどの一部の分散型プラットフォームでは、シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングの両方がサポートされます。

シスコ エクスプレス フォワーディングが Cisco 7500 シリーズ ルータ上に設定されている場合、シスコ エクスプレス フォワーディング スイッチングは RP によって実行されます。分散型シスコ エクスプレス フォワーディングが設定されている場合、シスコ エクスプレス フォワーディング スイッチングはライン カードによって実行されます。デフォルトでは、GSR では、分散型シスコ エクスプレス フォワーディングだけがサポートされます(シスコ エクスプレス フォワーディング スイッチングはライン カードによって実行されます)。

前提条件

ルータでシスコ エクスプレス フォワーディング トラフィックおよび分散型シスコ エクスプレス フォワーディング トラフィックの転送をイネーブルにするには、 ipv6 unicast-routing コマンドを使用してルータ上に IPv6 ユニキャスト データグラムの転送をグローバルに設定し、 ipv6 address コマンドを使用してインターフェイス上に IPv6 アドレスおよび IPv6 処理を設定します。

ルータ上で Cisco Express Forwarding for IPv6 をグローバルにイネーブルにする前に、 ip cef コマンドを使用してルータ上で Cisco Express Forwarding for IPv4 をグローバルにイネーブルにする必要があります。

分散型 Cisco Express Forwarding for IPv6 をイネーブルにする前に、 ip cef distributed コマンドを使用して分散型 Cisco Express Forwarding for IPv4 をイネーブルにする必要があります。

制約事項

GSR は分散型シスコ エクスプレス フォワーディング モードでだけ動作するため、この分散型プラットフォームでは ipv6 cef コマンドと ipv6 cef distributed コマンドはサポートされません。

Cisco IOS Release 12.0(22)S またはそれ以降のリリースでは、シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングに設定されている非分散型および分散型アーキテクチャ プラットフォームに次の制約が適用されます。


) デフォルトでは、GSR では、分散型シスコ エクスプレス フォワーディングだけがサポートされます(シスコ エクスプレス フォワーディング スイッチングはライン カードによって実行されます)。


グローバルな送信元および宛先アドレスを持つ IPv6 パケットは、シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングでスイッチングされる。

リンクローカルの送信元アドレスと宛先アドレスを持つ IPv6 パケットは、プロセスでスイッチングされる。

手動で設定した IPv6 トンネル内でトンネリングされる IPv6 パケットは、シスコ エクスプレス フォワーディングでスイッチングされる。

次のインターフェイスおよびカプセル化タイプだけがサポートされる。

ATM PVC および ATM LANE

Cisco HDLC

イーサネット、ファスト イーサネット、およびギガビット イーサネット

FDDI

フレーム リレー PVC

PPP over Packet over SONET、ISDN、およびシリアル(同期および非同期)インターフェイス タイプ

次のインターフェイスおよびカプセル化タイプはサポートされない。

HP 100VG-AnyLAN

Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)

トークンリング

X.25


) シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングの詳細なハードウェア制約については、製品を購入されたシスコシステムズ代理店へお問い合せください。


手順の概要

1. enable

2. configure terminal

3. ipv6 cef
または
ipv6 cef distributed

4. ipv6 cef accounting [ non-recursive | per-prefix | prefix-length ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 cef

または

ipv6 cef distributed

 

Router(config)# ipv6 cef

または

 

Router(config)# ipv6 cef distributed

ルータでシスコ エクスプレス フォワーディングをグローバルにイネーブルにします。

または

ルータで分散型シスコ エクスプレス フォワーディングをグローバルにイネーブルにします。

ステップ 4

ipv6 cef accounting [ non-recursive | per-prefix | prefix-length ]

 

Router(config)# ipv6 cef accounting

ルータで、シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングのネットワーク アカウンティングをグローバルにイネーブルにします。

シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングのネットワーク アカウンティングにより、シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングのトラフィックに固有の統計情報を収集することで、ネットワーク内のシスコ エクスプレス フォワーディング トラフィック パターンをよりよく理解できます。たとえば、シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングのネットワーク アカウンティングにより、宛先にスイッチングされたパケット数とバイト数や、宛先を経由してスイッチングされたパケット数などの情報を収集できます。

オプションの per-prefix キーワードでは、IPv6 宛先(または IPv6 プレフィクス)にエクスプレス フォワーディングされたパケット数とバイト数の収集をイネーブルにします。

オプションの prefix-length キーワードでは、IPv6 プレフィクス長にエクスプレス フォワーディングされたパケット数とバイト数の収集をイネーブルにします。

(注) シスコ エクスプレス フォワーディングがルータでグローバルにイネーブルになっている場合、アカウンティング情報は RP で収集されます。分散型シスコ エクスプレス フォワーディングがルータでグローバルにイネーブルになっている場合、アカウンティング情報はライン カードで収集されます。

 

ユニキャスト RPF の設定

前提条件

ユニキャスト RPF を使用するには、ルータでシスコ エクスプレス フォワーディング スイッチングまたは分散型シスコ エクスプレス フォワーディング スイッチングをイネーブルにします。シスコ エクスプレス フォワーディング スイッチングの入力インターフェイスを設定する必要はありません。シスコ エクスプレス フォワーディングがルータ上で実行されているかぎり、個々のインターフェイスは他のスイッチング モードで設定できます。


) ルータでシスコ エクスプレス フォワーディングをグローバルに設定することが非常に重要です。ユニキャスト RPF は、シスコ エクスプレス フォワーディングがないと動作しません。


制約事項

ユニキャスト RPF は、ネットワーク内部のインターフェイスでは使用できません。内部インターフェイスは、ルーティングを非対称にする可能性が高く、パケットの送信元へのルートが複数存在する場合が多いからです。ユニキャスト RPF は、元々対称であるか、対称に設定されている場合にだけ適用してください。

たとえば、ISP のネットワークのエッジにあるルータは、ISP ネットワークのコアにあるルータよりも対称リバース パスを持つ可能性が高くなります。ISP ネットワークのコアにあるルータでは、ルータからの最良の転送パスがルータへ返されるパケットに対して選択されるパスとなることが保証されません。したがって、非対称ルーティングの可能性があるユニキャスト RPF の適用は推奨されません。ネットワークのエッジにだけ、または ISP の場合はネットワークのカスタマー エッジにだけユニキャスト RPF を配置するのが最も単純です。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 verify unicast source reachable-via { rx | any } [ allow-default ] [ allow-self-ping ] [ access-list-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface atm 0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 verify unicast source reachable-via { rx | any } [ allow-default ] [ allow-self-ping ] [ access-list-name ]

 

Router(config-if)# ipv6 verify unicast source reachable-via any

送信元アドレスが FIB テーブルに存在していることを確認し、ユニキャスト RPF をイネーブルにします。

IPv6 アドレスへのホスト名のマッピング

手順の概要

1. enable

2. configure terminal

3. ipv6 host name [ port ] ipv6-address1 [ ipv6-address2...ipv6-address4 ]

4. ip domain nam e [ vrf vrf-name ] name
または
ip domain lis t [ vrf vrf-name ] name

5. ip name-server [ vrf vrf-name ] server-address1 [ server-address2...server-address6 ]

6. ip domain-lookup

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 host name [ port ] ipv6-address1 [ ipv6-address2...ipv6-address4 ]

 

Router(config)# ipv6 host cisco-sj 2001:0DB8:20:1::12

ホスト名からアドレスへのスタティック マッピングをホスト名キャッシュに定義します。

通常は、数字のアドレスではなくシンボリック名でネットワーク デバイスを参照する方が簡単です(Telnet などのサービスでは、ホスト名またはアドレスを使用できます)。ホスト名と IPv6 アドレスは、静的または動的な手段で相互に関連付けることができます。

ダイナミック マッピングが使用可能でない場合は、ホスト名をアドレスに手動で割り当てると便利です。

ステップ 4

ip domain nam e [ vrf vrf-name ] name

または

ip domain lis t [ vrf vrf-name ] name

 

Router(config)# ip domain-name cisco.com

または

 

Router(config)# ip domain list cisco1.com

(任意)非修飾ホスト名を完成させるために Cisco IOS ソフトウェアで使用されるデフォルトのドメイン名を定義します。

または

(任意)非修飾ホスト名を完成させるためのデフォルト ドメイン名のリストを定義します。

ドメイン名要求を完成させるために Cisco IOS ソフトウェアで使用されるデフォルトのドメイン名を指定できます。単一のドメイン名またはドメイン名のリストを指定できます。完全なドメイン名を含まないホスト名では、名前が検索される前に、指定したデフォルト ドメイン名が付加されます。

コマンドは、IPv4 と IPv6 の両方で使用できるデフォルト ドメイン名の指定に使用されます。

ステップ 5

ip name-server [ vrf vrf-name ] server-address1 [ server-address2...server-address6 ]

 

Router(config)# ip name-server 2001:0DB8::250:8bff:fee8:f800 2001:0DB8:0:f004::1

名前情報を提供する 1 つ以上のホストを指定します。

DNS に名前情報を提供するネーム サーバとして機能できる 1 つ以上(6 つまで)のホストを指定します。

引数には、IPv4 アドレスまたは IPv6 アドレスを指定できます。

ステップ 6

ip domain-lookup

 

Router(config)# ip domain-lookup

DNS ベースのアドレス変換をイネーブルにします。

DNS はデフォルトでイネーブルになっています。

IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング

IPv6 アドレスを ATM PVC およびフレーム リレー PVC にマッピングするには、次の作業を実行します。具体的には、この項の手順では、アドレスに到達するために使用される ATM PVC およびフレーム リレー PVC に IPv6 アドレスを明示的にマッピングする方法について説明します。


) この作業では、ATM PVC とフレーム リレー PVC の両方の設定方法を示します。多くのネットワークで設定する必要がある PVC のタイプは 1 つだけであるため、手順の多くには任意というラベルが付いています。この項の手順は、ATM LANE には適用されません。


手順の概要

1. enable

2. configure terminal

3. interface type number

4. pvc [ name ] vpi / vci [ ces | ilmi | qsaal | smds | l2transport ]

5. protocol ipv6 ipv6-address [[ no ] broadcast ]

6. exit

7. ipv6 address ipv6-address / prefix-length link-local

8. exit

9. interface type number

10. frame-relay map ipv6 ipv6-address dlci [ broadcast ] [ cisco ] [ ietf ] [ payload-compression { packet-by-packet | frf9 stac [ hardware-options ] | data-stream stac [ hardware-options ]} ]

11. ipv6 address ipv6-address / prefix-length link-local

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface atm 0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

pvc [ name ] vpi / vci [ ces | ilmi | qsaal | smds | l2transport ]

 

Router(config-if)# pvc 1/32

(任意)ATM PVC に名前を割り当てるかまたは名前を作成し、ルータを ATM VC コンフィギュレーション モードにします。

ステップ 5

protocol ipv6 ipv6-address [[ no ] broadcast ]

 

Router(config-if-atm-vc)# protocol ipv6 2001:0DB8:2222:1003::45

(任意)リモート ノードの IPv6 アドレスを、アドレスへの到達に使用する PVC にマッピングします。

ipv6-address 引数は、RFC 2373 に記載された形式で指定する必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

オプションの [ no ] broadcast キーワードは、IPv6 マルチキャスト パケット(ブロードキャスト パケットではない)がインターフェイスに送信される場合にマップ エントリを使用する必要があるかどうかを示します。擬似ブロードキャストがサポートされます。 protocol ipv6 コマンドの [ no ] broadcast キーワードは、同じ ATM PVC に設定された broadcast コマンドよりも優先されます。

ステップ 6

exit

 

Router(config-if-atm-vc)# exit

ATM VC コンフィギュレーション モードを終了し、ルータをインターフェイス コンフィギュレーション モードに戻します。

ステップ 7

ipv6 address ipv6-address / prefix-length link-local

 

Router(config-if)# ipv6 address 2001:0DB8:2222:1003::72/64 link-local

インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。

この作業のコンテキストでは、リンクの反対側のノードのリンクローカル アドレスは、ネットワークで使用される IGP に必要です。

ipv6 address link-local コマンドを指定して、IPv6 がインターフェイスでイネーブルになっている場合に自動的に設定されるリンクローカル アドレスの代わりに使用されるリンクローカル アドレスを、インターフェイスに設定します。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 9

interface type number

 

Router(config)# interface serial 3

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 10

frame-relay map ipv6 ipv6-address dlci [ broadcast ] [ cisco ] [ ietf ] [ payload-compression { packet-by-packet | frf9 stac [ hardware-options ] | data-stream stac [ hardware-options ]}]

 

Router(config-if)# frame-relay map ipv6 FE80::E0:F727:E400:A 17 broadcast

(任意)リモート ノードの IPv6 アドレスを、アドレスへの到達に使用する PVC の Data-Link Connection Identifier(DLCI; データリンク接続識別子)にマッピングします。

ステップ 11

ipv6 address ipv6-address / prefix-length link-local

 

Router(config-if)# ipv6 address 2001:0DB8:2222:1044::46/64 link-local

インターフェイスに割り当てられている IPv6 ネットワークを指定し、インターフェイスで IPv6 処理をイネーブルにします。

この作業のコンテキストでは、リンクの反対側のノードのリンクローカル アドレスは、ネットワークで使用される IGP に必要です。

ipv6 address link-local コマンドを指定して、IPv6 がインターフェイスでイネーブルになっている場合に自動的に設定されるリンクローカル アドレスの代わりに使用されるリンクローカル アドレスを、インターフェイスに設定します。

IPv6 リダイレクト メッセージの表示

IPv6 リダイレクト メッセージを表示するには、次の作業を実行します。示されているコマンドはオプションであり、任意の順序で入力できます。

手順の概要

1. enable

2. show ipv6 interface [ brief ] [ type number ] [ prefix ]

3. show ipv6 neighbors [ interface-type interface-number | ipv6-address | ipv6-hostname | statistics ]

4. show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

5. show ipv6 traffic

6. show frame-relay map [ interface type number ] [ dlci ]

7. show atm map

8. show hosts [ vrf vrf-name | all | hostname | summary ]

9. show running-config

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router# enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

show ipv6 interface [ brief ] [ type number ] [ prefix ]

 

Router# show ipv6 interface ethernet 0

IPv6 用に設定されたインターフェイスが使用可能かどうかのステータスを表示します。

IPv6 ネイバー リダイレクト メッセージ、IPv6 ネイバー探索メッセージ、およびステートレス自動設定のステータスに関する情報を表示します。

ステップ 3

show ipv6 neighbors [ interface-type interface-number | ipv6-address | ipv6-hostname | statistics ]

 

Router# show ipv6 neighbors ethernet 2

IPv6 ネイバー探索キャッシュ情報を表示します。

ステップ 4

show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

 

Router# show ipv6 route

IPv6 ルーティング テーブルの現在の内容を表示します。

ステップ 5

show ipv6 traffic

 

Router# show ipv6 traffic

IPv6 トラフィックに関する統計情報を表示します。

ステップ 6

show frame-relay map [ interface type number ] [ dlci ]

 

Router# show frame-relay map

フレーム リレー接続に関する現在のマップ エントリと情報を表示します。

ステップ 7

show atm map

 

Router# show atm map

ATM ネットワークおよび ATM バンドル マップのリモート ホストに対して設定されたすべての ATM スタティック マップのリストを表示します。

ステップ 8

show hosts [ vrf vrf-name | all | hostname | summary ]

 
Router# show hosts

デフォルトのドメイン名、名前ルックアップ サービス、ネーム サーバ ホストのリスト、およびホスト名とアドレスのキャッシュされたリストを表示します。

ステップ 9

show running-config

 

Router# show running-config

ルータで実行されている現在の設定を表示します。

 

ここでは、次の出力例について説明します。

show ipv6 interface コマンドの出力例

ipv6 neighbors コマンドの出力例

show ipv6 route コマンドの出力例

show ipv6 traffic コマンドの出力例

show frame-relay map コマンドの出力例

show atm map コマンドの出力例

show hosts コマンドの出力例

show running-config コマンドの出力例

show ipv6 interface コマンドの出力例

次の例では、 show ipv6 interface コマンドを使用して、IPv6 アドレスがイーサネット インターフェイス 0 に対して正しく設定されていることを確認します。IPv6 ネイバー リダイレクト メッセージ、IPv6 ネイバー探索メッセージ、およびステートレス自動設定のステータスに関する情報も表示されます。

Router# show ipv6 interface ethernet 0
 
Ethernet0 is up, line protocol is up
IPv6 is stalled, link-local address is FE80::1
Global unicast address(es):
2001:0DB8:2000::1, subnet is 2001:0DB8:2000::/64
2001:0DB8:3000::1, subnet is 2001:0DB8:3000::/64
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF00:1
MTU is 1500 bytes
ICMP error messages limited to one every 100 milliseconds
ICMP redirects are enabled
ND DAD is enabled, number of DAD attempts: 1
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
Hosts use stateless autoconfig for addresses.

ipv6 neighbors コマンドの出力例

次の例では、 show ipv6 neighbors コマンドを使用して、IPv6 ネイバー探索キャッシュ情報を表示します。コマンド出力の Age フィールドのハイフン(-)は、スタティック エントリを示します。次の例は、イーサネット インターフェイス 2 に対する IPv6 ネイバー探索キャッシュ情報を表示します。

Router# show ipv6 neighbors ethernet 2
 
IPv6 Address Age Link-layer Addr State Interface
2001:0DB8:0:4::2 0 0003.a0d6.141e REACH Ethernet2
FE80::XXXX:A0FF:FED6:141E 0 0003.a0d6.141e REACH Ethernet2
2001:0DB8:1::45a - 0002.7d1a.9472 REACH Ethernet2

show ipv6 route コマンドの出力例

ipv6-address 引数または ipv6-prefix / prefix-length 引数が指定されている場合は、そのアドレスまたはネットワークのルート情報だけが表示されます。次に、IPv6 プレフィクス 2001:0DB8::/35 を指定して入力した show ipv6 route コマンドの出力例を示します。

Router# show ipv6 route 2001:0DB8::/35
 
IPv6 Routing Table - 261 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
 
B 2001:0DB8::/35 [20/3]
via FE80::60:5C59:9E00:16, Tunnel1

show ipv6 traffic コマンドの出力例

次の例では、 show ipv6 traffic コマンドを使用して、ICMP レート制限カウンタを表示します。

Router# show ipv6 traffic
 
ICMP statistics:
Rcvd: 188 input, 0 checksum errors, 0 too short
0 unknown info type, 0 unknown error type
unreach: 0 routing, 0 admin, 0 neighbor, 0 address, 0 port
parameter: 0 error, 0 header, 0 option
0 hopcount expired, 0 reassembly timeout,0 too big
0 echo request, 0 echo reply
0 group query, 0 group report, 0 group reduce
1 router solicit, 175 router advert, 0 redirects
0 neighbor solicit, 12 neighbor advert
Sent: 7376 output, 56 rate-limited
unreach: 0 routing, 15 admin, 0 neighbor, 0 address, 0 port
parameter: 0 error, 0 header, 0 option
0 hopcount expired, 0 reassembly timeout,0 too big
15 echo request, 0 echo reply
0 group query, 0 group report, 0 group reduce
0 router solicit, 7326 router advert, 0 redirects
2 neighbor solicit, 22 neighbor advert

show frame-relay map コマンドの出力例

次の例では、 show frame-relay map コマンドを使用して、リモート ノードの IPv6 アドレスがアドレスへの到達に使用される PVC の DLCI にマッピングされていることを確認します。次の例は、2 つのリモート ノードのリンクローカル IPv6 アドレスおよびグローバル IPv6 アドレス(FE80::E0:F727:E400:A と 2001:0DB8:2222:1044::73、FE80::60:3E47:AC8:8 と 2001.0DB8:2222:1044::72)がそれぞれ DLCI 17 と DLCI 19 に明示的にマッピングされていることを示しています。DLCI 17 と DLCI 19 の両方が、このノードのインターフェイス シリアル 3 で終端されているため、このノードのインターフェイス シリアル 3 はポイントツーマルチポイント インターフェイスです。

Router# show frame-relay map
 
Serial3 (up): ipv6 FE80::E0:F727:E400:A dlci 17(0x11,0x410), static,
broadcast, CISCO, status defined, active
Serial3 (up): ipv6 2001:0DB8:2222:1044::72 dlci 19(0x13,0x430), static,
CISCO, status defined, active
Serial3 (up): ipv6 2001:0DB8:2222:1044::73 dlci 17(0x11,0x410), static,
CISCO, status defined, active
Serial3 (up): ipv6 FE80::60:3E47:AC8:8 dlci 19(0x13,0x430), static,
broadcast, CISCO, status defined, active

show atm map コマンドの出力例

次の例では、 show atm map コマンドを使用して、リモート ノードの IPv6 アドレスがアドレスへの到達に使用される PVC にマッピングされていることを確認します。次の例は、リモート ノードのリンクローカル IPv6 アドレスおよびグローバル IPv6 アドレス(それぞれ FE80::60:3E47:AC8:C と 2001:0DB8:2222:1003::72)が ATM インターフェイス 0 の PVC 1/32 に明示的にマッピングされていることを示しています。

Router# show atm map
 
Map list ATM0pvc1 : PERMANENT
ipv6 FE80::60:3E47:AC8:C maps to VC 1, VPI 1, VCI 32, ATM0
, broadcast
ipv6 2001:0DB8:2222:1003::72 maps to VC 1, VPI 1, VCI 32, ATM0

show hosts コマンドの出力例

DHCP for IPv6 クライアントの名前ルックアップ システムの状態は、 show hosts コマンドで表示できます。

Router# show hosts
 
Default domain is not set
Domain list:example.com
Name/address lookup uses domain service
Name servers are 2001:0DB8:A:B::1, 2001:0DB8:3000:3000::42
 
Codes:UN - unknown, EX - expired, OK - OK, ?? - revalidate
temp - temporary, perm - permanent
NA - Not Applicable None - Not defined
 
Host Port Flags Age Type Address(es)
sdfasfd None (temp, UN) 0 IPv6

show running-config コマンドの出力例

次の例では、 show running-config コマンドを使用して、パケットの IPv6 処理がルータと該当インターフェイス上でグローバルにイネーブルになっていることと、IPv6 アドレスが該当インターフェイスで設定されていることを確認します。

Router# show running-config
 
Building configuration...
 
Current configuration : 22324 bytes
!
! Last configuration change at 14:59:38 PST Tue Jan 16 2001
! NVRAM config last updated at 04:25:39 PST Tue Jan 16 2001 by bird
!
hostname Router
!
ipv6 unicast-routing
!
interface Ethernet0
no ip route-cache
no ip mroute-cache
no keepalive
media-type 10BaseT
ipv6 address 2001:0DB8:0:1::/64 eui-64
!
 

次の例では、 show running-config コマンドを使用して、シスコ エクスプレス フォワーディングとシスコ エクスプレス フォワーディングのネットワーク アカウンティングが非分散型アーキテクチャ プラットフォームでグローバルにイネーブルになっていることと、シスコ エクスプレス フォワーディングが IPv6 インターフェイスでイネーブルになっていることを確認します。次の出力は、シスコ エクスプレス フォワーディングとシスコ エクスプレス フォワーディングのネットワーク アカウンティングの両方がルータでグローバルにイネーブルになっており、シスコ エクスプレス フォワーディングがイーサネット インターフェイス 0 でもイネーブルになっていることを示しています。

Router# show running-config
 
Building configuration...
 
Current configuration : 22324 bytes
!
! Last configuration change at 14:59:38 PST Tue Jan 16 2001
! NVRAM config last updated at 04:25:39 PST Tue Jan 16 2001 by bird
!
hostname Router
!
ip cef
ipv6 unicast-routing
ipv6 cef
ipv6 cef accounting prefix-length
!
!
interface Ethernet0
ip address 10.4.9.11 255.0.0.0
media-type 10BaseT
ipv6 address 2001:0DB8:C18:1::/64 eui-64
!

次の例では、 show running-config コマンドを使用して、分散型シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングのネットワーク アカウンティングが Cisco 7500 シリーズ ルータなどの分散型アーキテクチャ プラットフォームでグローバルにイネーブルになっていることを確認します。次の例は、分散型シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングのネットワーク アカウンティングの両方がルータでグローバルにイネーブルになっていることを示しています。


) 分散型シスコ エクスプレス フォワーディングは、GSR ではデフォルトでイネーブルになり、Cisco 7500 シリーズ ルータではデフォルトでディセーブルになります。したがって、GSR での show running-config コマンドの出力には、分散型シスコ エクスプレス フォワーディングがルータでグローバルに設定されているかどうかは表示されません。次に、Cisco 7500 シリーズ ルータからの出力を示します。


Router# show running-config
 
Building configuration...
 
Current configuration : 22324 bytes
!
! Last configuration change at 14:59:38 PST Tue Jan 16 2001
! NVRAM config last updated at 04:25:39 PST Tue Jan 16 2001 by bird
!
hostname Router
!
ip cef distributed
ipv6 unicast-routing
ipv6 cef distributed
ipv6 cef accounting prefix-length
 

次の例では、 show running-config コマンドを使用して、ホスト名からアドレスへのマッピング、デフォルト ドメイン名、およびホスト名キャッシュ内のネーム サーバを確認し、DNS サービスがイネーブルになっていることを確認します。

Router# show running-config
 
Building configuration...
!
ipv6 host cisco-sj 2001:0DB8:20:1::12
!
ip domain-name cisco.com
ip domain-lookup
ip name-server 2001:0DB8:C01F:768::1

IPv6 アドレッシングと基本接続の実装の設定例

「例:IPv6 アドレッシングと IPv6 ルーティングの設定」

「例:デュアル プロトコル スタックの設定」

「例:IPv6 ICMP レート制限の設定」

「例:シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングの設定」

「例:ホスト名からアドレスへのマッピングの設定」

「例:IPv6 アドレスから ATM PVC およびフレーム リレー PVC へのマッピングの設定」

例:IPv6 アドレッシングと IPv6 ルーティングの設定

次の例では、IPv6 は、ルータ上で IPv6 プレフィクス 2001:0DB8:c18:1::/64 に基づくリンクローカル アドレスとグローバル アドレスの両方でイネーブルになっています。EUI-64 インターフェイス ID が、両方のアドレスの下位 64 ビットで使用されます。 show ipv6 interface コマンドからの出力は、インターフェイス ID(260:3EFF:FE47:1530)がイーサネット インターフェイス 0 のリンクローカル プレフィクス FE80::/64 にどのように追加されるかを示します。

ipv6 unicast-routing
 
interface ethernet 0
ipv6 address 2001:0DB8:c18:1::/64 eui-64
 
Router# show ipv6 interface ethernet 0
 
Ethernet0 is up, line protocol is up
IPv6 is enabled, link-local address is FE80::260:3EFF:FE47:1530
Global unicast address(es):
2001:0DB8:C18:1:260:3EFF:FE47:1530, subnet is 2001:0DB8:C18:1::/64
Joined group address(es):
FF02::1
FF02::2
FF02::1:FF47:1530
FF02::9
MTU is 1500 bytes
ICMP error messages limited to one every 500 milliseconds
ND reachable time is 30000 milliseconds
ND advertised reachable time is 0 milliseconds
ND advertised retransmit interval is 0 milliseconds
ND router advertisements are sent every 200 seconds
ND router advertisements live for 1800 seconds
Hosts use stateless autoconfig for addresses.
 

次の例では、プレフィクス 2001:0DB8::/64 内の複数の IPv6 グローバル アドレスがイーサネット インターフェイス 0 に設定されています。

interface ethernet 0
ipv6 address 2001:0DB8::1/64
ipv6 address 2001:0DB8::/64 eui-64

例:デュアル プロトコル スタックの設定

次の例では、ルータで IPv6 ユニキャスト データグラムの転送をグローバルにイネーブルにし、IPv4 アドレスと IPv6 アドレスの両方でイーサネット インターフェイス 0 を設定します。

ipv6 unicast-routing
 
interface Ethernet0
ip address 192.168.99.1 255.255.255.0
ipv6 address 2001:0DB8:c18:1::3/64

例:IPv6 ICMP レート制限の設定

次の例は、50 ミリ秒の間隔と 20 トークンのバケット サイズが IPv6 ICMP エラー メッセージに対して設定されていることを示します。

ipv6 icmp error-interval 50 20

例:シスコ エクスプレス フォワーディングおよび分散型シスコ エクスプレス フォワーディングの設定

次の例では、Cisco Express Forwarding for IPv6 および Cisco Express Forwarding for IPv6 のネットワーク アカウンティングの両方が非分散型アーキテクチャ ルータでグローバルにイネーブルになっていて、Cisco Express Forwarding for IPv6 がイーサネット インターフェイス 0 でイネーブルになっています。例では、 ipv6 unicast-routing コマンドを使用して IPv6 ユニキャスト データグラムの転送がルータ上でグローバルに設定されていること、 ipv6 address コマンドを使用して IPv6 アドレスがイーサネット インターフェイス 0 に設定されていること、および ip cef コマンドを使用して Cisco Express Forwarding for IPv4 がルータでグローバルに設定されていることも示されています。

ip cef
ipv6 unicast-routing
ipv6 cef
ipv6 cef accounting prefix-length
 
interface Ethernet0
ip address 10.4.9.11 255.0.0.0
media-type 10BaseT
ipv6 address 2001:0DB8:C18:1::/64 eui-64
 

次の例では、分散型 Cisco Express Forwarding for IPv6 および分散型 Cisco Express Forwarding for IPv6 のネットワーク アカウンティングの両方が分散型アーキテクチャ ルータでグローバルにイネーブルになっています。 ipv6 unicast-routing コマンドで IPv6 ユニキャスト データグラムの転送がルータでグローバルに設定され、 ip cef distributed コマンドで分散型 Cisco Express Forwarding for IPv4 がルータでグローバルに設定されています。

ip cef distributed
ipv6 unicast-routing
ipv6 cef distributed
ipv6 cef accounting prefix-length

例:ホスト名からアドレスへのマッピングの設定

次の例では、ホスト名キャッシュに 2 つの静的なホスト名からアドレスへのマッピングを定義し、未修飾のホスト名を完成させるための複数の代替ドメイン名でドメイン リストを設定します。また、ホスト 2001:0DB8::250:8bff:fee8:f800 とホスト 2001:0DB8:0:f004::1 をネーム サーバとして指定し、DNS サービスを再びイネーブルにします。

ipv6 host cisco-sj 2001:0DB8:700:20:1::12
ipv6 host cisco-hq 2001:0DB8:768::1 2001:0DB8:20:1::22
ip domain list example1.com
ip domain list example2.com
ip domain list example3.edu
ip name-server 2001:0DB8::250:8bff:fee8:f800 2001:0DB8:0:f004::1
ip domain-lookup

例:IPv6 ATM PVC マッピングの設定:ポイントツーポイント インターフェイス

次の例では、ルータ 1 およびルータ 2 という名前の 2 つのノードが単一の PVC で接続されています。ポイントツーポイント サブインターフェイス ATM0.132 が、PVC を終端するために両方のノードで使用されています。したがって、両方のノードの IPv6 アドレスと PVC との間のマッピングは暗黙的です(追加のマッピングは不要です)。

ルータ 1 の設定

interface ATM 0
no ip address
!
interface ATM 0.132 point-to-point
pvc 1/32
encapsulation aal5snap
!
ipv6 address 2001:0DB8:2222:1003::72/64

ルータ 2 の設定

interface ATM 0
no ip address
!
interface ATM 0.132 point-to-point
pvc 1/32
encapsulation aal5snap
!
ipv6 address 2001:0DB8:2222:1003::45/64

例:IPv6 ATM PVC マッピングの設定:ポイントツーマルチポイント インターフェイス

次の例では、前の例と同じ 2 つのノード(ルータ 1 とルータ 2)が同じ PVC で接続されています。ただし、この例では、PVC を終端するために両方のノードでポイントツーマルチポイント インターフェイス ATM0 が使用されています。したがって、両方のノードのインターフェイス ATM0 のリンクローカル IPv6 アドレスおよびグローバル IPv6 アドレスと PVC との間には明示的なマッピングが必要です。また、両方のノードのインターフェイス ATM0 のリンクローカル アドレスで ATM 擬似ブロードキャストがイネーブルになっています。ここで指定したリンクローカル アドレスは、PVC のもう一方の側のリンクローカル アドレスです。

ルータ 1 の設定

interface ATM 0
no ip address
pvc 1/32
protocol ipv6 2001:0DB8:2222:1003::45
protocol ipv6 FE80::60:2FA4:8291:2 broadcast
encapsulation aal5snap
!
ipv6 address 2001:0DB8:2222:1003::72/64

ルータ 2 の設定

interface ATM 0
no ip address
pvc 1/32
protocol ipv6 FE80::60:3E47:AC8:C broadcast
protocol ipv6 2001:0DB8:2222:1003::72
encapsulation aal5snap
!
ipv6 address 2001:0DB8:2222:1003::45/64

例:IPv6 フレーム リレー PVC マッピングの設定:ポイントツーポイント インターフェイス

次の例では、ルータ A、ルータ B、およびルータ C という 3 つのノードが完全メッシュ ネットワークを構成します。各ノードは、他の 2 つの各ノードへの個別の接続を提供する 2 つの PVC で設定されています。各 PVC は異なるポイントツーポイント サブインターフェイスに設定され、3 つの固有な IPv6 ネットワーク(2001:0DB8:2222:1017:/64、2001:0DB8:2222:1018::/64、および 2001:0DB8:2222:1019::/64)を作成します。したがって、各ノードの IPv6 アドレスとアドレスへの到達に使用される PVC の DLCI(DLCI 17、18、19)との間のマッピングは暗黙的です(追加のマッピングは不要です)。


) 次の例の各 PVC が異なるポイントツーポイント サブインターフェイスに設定されている場合、次の例の設定は、完全メッシュでないネットワークでも使用できます。また、各 PVC を異なるポイントツーポイント サブインターフェイスに設定すると、ルーティング プロトコル設定を簡略化できます。ただし、次の例の設定では複数の IPv6 ネットワークが必要ですが、各 PVC をポイントツーマルチポイント インターフェイスに設定するために必要な IPv6 ネットワークは 1 つだけです。


ルータ A の設定

interface Serial 3
encapsulation frame-relay
!
interface Serial3.17 point-to-point
description to Router B
ipv6 address 2001:0DB8:2222:1017::46/64
frame-relay interface-dlci 17
!
interface Serial 3.19 point-to-point
description to Router C
ipv6 address 2001:0DB8:2222:1019::46/64
frame-relay interface-dlci 19

ルータ B の設定

interface Serial 5
encapsulation frame-relay
!
interface Serial5.17 point-to-point
description to Router A
ipv6 address 2001:0DB8:2222:1017::73/64
frame-relay interface-dlci 17
!
interface Serial5.18 point-to-point
description to Router C
ipv6 address 2001:0DB8:2222:1018::73/64
frame-relay interface-dlci 18

ルータ C の設定

interface Serial 0
encapsulation frame-relay
!
interface Serial0.18 point-to-point
description to Router B
ipv6 address 2001:0DB8:2222:1018::72/64
frame-relay interface-dlci 18
!
interface Serial0.19 point-to-point
description to Router A
ipv6 address 2001:0DB8:2222:1019::72/64
frame-relay interface-dlci 19

例:IPv6 フレーム リレー PVC マッピングの設定:ポイントツーマルチポイント インターフェイス

次の例では、前の例と同じ 3 つのノード(ルータ A、ルータ B、およびルータ C)が完全メッシュ ネットワークを構成し、各ノードに 2 つの PVC が設定されています(これにより、他の 2 つの各ノードへの個別の接続が提供されます)。ただし、次の例の各ノード上の 2 つの PVC は、単一のインターフェイス(それぞれ、シリアル 3、シリアル 5、およびシリアル 10)に設定されています。これにより、各インターフェイスはポイントツーマルチポイント インターフェイスになります。したがって、3 つのノードすべての各インターフェイスのリンクローカル IPv6 アドレスおよびグローバル IPv6 アドレスと、アドレスへの到達に使用される PVC の DLCI(DLCI 17、18、19)との間には、明示的なマッピングが必要です。

ルータ A の設定

interface Serial 3
encapsulation frame-relay
ipv6 address 2001:0DB8:2222:1044::46/64
frame-relay map ipv6 FE80::E0:F727:E400:A 17 broadcast
frame-relay map ipv6 FE80::60:3E47:AC8:8 19 broadcast
frame-relay map ipv6 2001:0DB8:2222:1044::72 19
frame-relay map ipv6 2001:0DB8:2222:1044::73 17

ルータ B の設定

interface Serial 5
encapsulation frame-relay
ipv6 address 2001:0DB8:2222:1044::73/64
frame-relay map ipv6 FE80::60:3E59:DA78:C 17 broadcast
frame-relay map ipv6 FE80::60:3E47:AC8:8 18 broadcast
frame-relay map ipv6 2001:0DB8:2222:1044::46 17
frame-relay map ipv6 2001:0DB8:2222:1044::72 18

ルータ C の設定

interface Serial 10
encapsulation frame-relay
ipv6 address 2001:0DB8:2222:1044::72/64
frame-relay map ipv6 FE80::60:3E59:DA78:C 19 broadcast
frame-relay map ipv6 FE80::E0:F727:E400:A 18 broadcast
frame-relay map ipv6 2001:0DB8:2222:1044::46 19
frame-relay map ipv6 2001:0DB8:2222:1044::73 18

関連情報

IPv6 ルーティング プロトコルを実装する場合は、「 Implementing RIP for IPv6 」、「 Implementing IS-IS for IPv6 」、または「 Implementing Multiprotocol BGP for IPv6 」の章を参照してください。

その他の関連資料

関連資料

関連項目
参照先

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用に関する注意事項、および例

『Cisco IOS IPv6 Command Reference』

IPv6 DHCP の説明と設定

Cisco IOS IPv6 Configuration Guide 』の「 Implementing DHCP for IPv6

IPv4 アドレッシングの設定作業

Cisco IOS IP Addressing Services Configuration Guide 』の Configuring IPv4 Addresses

IPv4 サービスの設定作業

Cisco IOS IP Application Services Configuration Guide 』の Configuring IP Services

IPv4 アドレッシング コマンド

『Cisco IOS IP Addressing Services Command Reference』

IPv4 IP サービス コマンド

『Cisco IOS IP Application Services Command Reference』

ステートフル スイッチオーバー

Cisco IOS High Availability Configuration Guide 』の「 Stateful Switchover

スイッチングの設定作業

『Cisco IOS IP Switching Configuration Guide』の「 Cisco IOS IP Switching Features Roadmap

スイッチング コマンド

『Cisco IOS IP Switching Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1981

『Path MTU Discovery for IP version 6』

RFC 2373

『IP Version 6 Addressing Architecture』

RFC 2374

『An Aggregatable Global Unicast Address Format』

RFC 2460

『Internet Protocol, Version 6 (IPv6) Specification』

RFC 2461

『Neighbor Discovery for IP Version 6 (IPv6)』

RFC 2462

『IPv6 Stateless Address Autoconfiguration』

RFC 2463

『Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) Specification』

RFC 2464

『Transmission of IPv6 Packets over Ethernet Networks』

RFC 2467

『Transmission of IPv6 Packets over FDDI Networks』

RFC 2472

『IP Version 6 over PPP』

RFC 2492

『IPv6 over ATM Networks』

RFC 2590

『Transmission of IPv6 Packets over Frame Relay Networks Specification』

RFC 3152

『Delegation of IP6.ARPA』

RFC 3162

『RADIUS and IPv6』

RFC 3513

『Internet Protocol Version 6 (IPv6) Addressing Architecture』

RFC 3596

『DNS Extensions to Support IP version 6』

RFC 3879

『Deprecating Site Local Addresses』

RFC 4193

『Unique Local IPv6 Unicast Addresses』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

IPv6 アドレッシングと基本接続の実装の機能情報

表 5 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator により、どのソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 5には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 5 IPv6 アドレッシングと基本接続の実装の機能情報

機能名
リリース
機能情報

IPv6:エニーキャスト アドレス

12.2(25)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA 12.2(33)SXH 12.3(4)T
12.4
12.4(2)T

エニーキャスト アドレスは、通常は異なるノードに属するインターフェイスのセットに割り当てられます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 アドレス タイプ:エニーキャスト」

「IPv6 アドレス タイプ:マルチキャスト」

「IPv6 マルチキャスト グループ」

「IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル」

IPv6:基本プロトコル ハイ アベイラビリティ

12.2(33)SRE

IPv6 ネイバー探索では SSO がサポートされます。

この機能に関する詳細については、次の項を参照してください。

「ステートフル スイッチオーバー」

IPv6:ICMPv6

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX112.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

ICMP for IPv6 は、ICMP 宛先到達不能メッセージなどのエラー メッセージと、ICMP エコー要求および応答メッセージなどの情報メッセージを生成します。また、IPv6 の ICMP パケットは、IPv6 ネイバー探索プロセス、パス MTU 探索、および IPv6 の MLD プロトコルで使用されます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 の ICMP」

「IPv6 ネイバー探索」

「IPv6 ネイバー請求メッセージ」

「IPv6 ルータ アドバタイズメント メッセージ」

「IPv6 ステートレス自動設定」

「IPv6 ICMP レート制限の設定」

「例:IPv6 ICMP レート制限の設定」

IPv6:ICMPv6 リダイレクト

12.0(22)S
12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX1
12.2(4)T
12.3
12.3(2)T
12.4
12.4(2)T

ICMP パケット ヘッダーのタイプ フィールドの値 137 は、IPv6 ネイバー リダイレクト メッセージを示します。ルータは、ネイバー リダイレクト メッセージを送信して、宛先へのパス上のより適切なファーストホップ ノードをホストに通知します。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 ネイバー リダイレクト メッセージ」

「IPv6 リダイレクト メッセージ」

IPv6:ICMP レート制限

12.2(8)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ICMP レート制限機能によって、IPv6 ICMP エラー メッセージがネットワークへ送信されるレートを制限するためのトークン バケット アルゴリズムが実装されます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 ICMP レート制限の設定」

「IPv6 ICMP レート制限」

「例:IPv6 ICMP レート制限の設定」

IPv6:IPv6 デフォルト ルータ プリファレンス

12.2(33)SB
12.2(33)SRA
12.4(2)T
12.2(33)SXH
15.0(1)S

DRP 拡張は、大まかなプリファレンス メトリック(低、中、高)をデフォルト ルータに提供します。

この機能に関する詳細については、次の各項を参照してください。

「トラフィック エンジニアリングのデフォルト ルータ プリファレンス」

「トラフィック エンジニアリングの DRP 拡張の設定」

IPv6:IPv6 MTU パス ディスカバリ

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX112.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 のパス MTU ディスカバリを使用すると、特定のデータ パス上のすべてのリンクの MTU サイズの差をホストが動的に検出し、調整できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 のパス MTU ディスカバリ」

「IPv6 の ICMP」

IPv6:IPv6 ネイバー探索

12.0(22)S
12.2(14)S
12.2(28)SB
12.2(25)SG
12.2(33)SRA
12.2(17a)SX1
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 ネイバー探索プロセスでは、ICMP メッセージおよび請求ノード マルチキャスト アドレスを使用して、同じネットワーク(ローカル リンク)上のネイバーのリンクレイヤ アドレスを判断し、ネイバーに到達可能かどうかを確認し、ネイバー ルータを追跡します。

この機能に関する詳細については、次の各項を参照してください。

「リンクローカル アドレス」

「IPv6 の ICMP」

「IPv6 ネイバー探索」

「IPv6 マルチキャスト グループ」

IPv6:IPv6 ネイバー探索重複アドレス検出

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX1
12.2(4)T
12.3
12.3(2)T
12.4
12.4(2)T

新規のリンクローカル IPv6 アドレスに対しては、アドレスがインターフェイスに割り当てられる前に、最初に IPv6 ネイバー探索重複アドレス検出が実行されます(重複アドレス検出の実行中、新規アドレスは一時的な状態のままです)。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 ネイバー請求メッセージ」

「IPv6 ステートレス自動設定」

IPv6:IPv6 ステートレス自動設定

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX112.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 ステートレス自動設定機能を使用して、リンク、サブネット、およびサイト アドレッシングの変更を管理できます。

この機能に関する詳細については、次の各項を参照してください。

「リンクローカル アドレス」

「IPv6 ネイバー請求メッセージ」

「IPv6 ルータ アドバタイズメント メッセージ」

「IPv6 ステートレス自動設定」

「IPv6 ホストの簡易ネットワーク リナンバリング」

IPv6:ネイバー探索用の IPv6 スタティック キャッシュ エントリ

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA
12.2(17a)SX1
12.2(8)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

ネイバー探索用の IPv6 スタティック キャッシュ エントリ機能により、IPv6 ネイバー キャッシュ内にスタティック エントリを作成できます。

この機能に関する詳細については、次の項を参照してください。

「IPv6 ネイバー探索」

IPv6:Per-Interface ネイバー探索キャッシュ制限

15.1(3)T

Per-Interface ネイバー探索キャッシュ制限機能により、インターフェイス単位でネイバー探索キャッシュのエントリ数を制限できます。この機能に関する詳細については、次の各項を参照してください。

「Per-Interface ネイバー探索キャッシュ制限」

「ネイバー探索キャッシュ制限の設定」

ipv6 nd cache interface-limit(グローバル) ipv6 nd cache interface-limit(インターフェイス) show ipv6 neighbors の各コマンドがこの機能のために導入または修正されました。

IPv6 アクセス サービス:Routed Bridged Encapsulation(RBE; ルーテッド ブリッジ カプセル化)

12.3(4)T
12.4
12.4(2)T

RBE は、ブリッジ インターフェイスから別のルーテッド インターフェイスまたはブリッジ インターフェイスにプロトコルをルーティングするメカニズムを提供します。

この機能に関する詳細については、次の項を参照してください。

「IPv6 のルーテッド ブリッジ カプセル化」

IPv6 アドレス タイプ:ユニキャスト

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA
12.2(17a)SX1
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ユニキャスト アドレスは、単一ノード上の単一インターフェイスの識別子です。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 アドレスの形式」

「IPv6 アドレス タイプ:ユニキャスト」

「IPv6 アドレス タイプ:エニーキャスト」

「IPv6 アドレス タイプ:マルチキャスト」

「IPv6 ネイバー請求メッセージ」

「IPv6 ルータ アドバタイズメント メッセージ」

「IPv6 アドレッシングの設定と IPv6 ルーティングのイネーブル」

IPv6 データ リンク:ATM PVC および ATM LANE

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。ATM PVC および ATM LANE は、IPv6 でサポートされるデータ リンクです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

「IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング」

IPv6 データ リンク:Cisco High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)

12.0(22)S 12.2(14)S 12.2(28)SB
12.2(33)SRA 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。HDLC は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

「IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング」

IPv6 データ リンク:Dynamic Packet Transport(DPT; ダイナミック パケット トランスポート)

12.0(23)S

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。DPT は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の項を参照してください。

「IPv6 データ リンク」

IPv6 データ リンク:イーサネット、ファスト イーサネット、ギガビット イーサネット、および 10-ギガビット イーサネット

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。イーサネット、ファスト イーサネット、ギガビット イーサネット、および 10-ギガビット イーサネットは、IPv6 でサポートされるデータ リンクです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

IPv6 データ リンク:FDDI

12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。FDDI は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

IPv6 データ リンク:フレーム リレー PVC

12.0(22)S 12.2(14)S
12.2(28)SB 12.2(33)SRA 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。フレーム リレー PVC は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

「IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング」

IPv6 データ リンク:PPP service over Packet over SONET、ISDN、およびシリアル(非同期および同期)インターフェイス

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(33)SRA 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。PPP service over Packet over SONET、ISDN、およびシリアル インターフェイスは、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 データ リンク」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

「IPv6 アドレスから IPv6 ATM およびフレーム リレー インターフェイスへのマッピング」

IPv6 データ リンク:Cisco Inter-Switch Link(ISL; スイッチ間リンク)を使用した VLAN

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(18)SXE
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。Cisco ISL を使用した VLAN は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の項を参照してください。

「IPv6 データ リンク」

IPv6 データ リンク:IEEE 802.1Q カプセル化を使用した VLAN

12.0(22)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(18)SXE
12.2(14)S
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 ネットワークでは、データ リンクは特定のリンクローカル プレフィクスを共有するネットワークです。IEEE 802.1Q カプセル化を使用した VLAN は、IPv6 でサポートされるデータ リンクのタイプです。

この機能に関する詳細については、次の項を参照してください。

「IPv6 データ リンク」

IPv6 サービス:IPv4 トランスポートでの AAAA DNS ルックアップ

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX1
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 基本接続は、DNS の名前からアドレスおよびアドレスから名前のルックアップ プロセスで AAAA レコード タイプのサポートを設定することで拡張できます。

この機能に関する詳細については、次の項を参照してください。

「IPv6 の DNS」

IPv6 サービス:シスコ検出プロトコル:ネイバー情報の IPv6 アドレス ファミリ サポート

12.2(14)S 12.2(28)SB 12.2(25)SG
12.2(33)SRA
12.2(18)SXE
12.2(8)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

ネイバー情報のシスコ検出プロトコル IPv6 アドレス サポート機能により、2 台のシスコ デバイス間で IPv6 アドレッシング情報を転送する機能が追加されます。

この機能に関する詳細については、次の項を参照してください。

「シスコ検出プロトコル IPv6 アドレスのサポート」

IPv6 サービス:IPv6 トランスポートでの DNS ルックアップ

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG
12.2(33)SRE2
12.2(8)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 では、DNS の名前からアドレスおよびアドレスから名前のルックアップ プロセスでサポートされる DNS レコード タイプがサポートされます。

この機能に関する詳細については、次の項を参照してください。

「IPv6 の DNS」

IPv6 サービス:汎用プレフィクス

12.3(4)T
12.4
12.4(2)T

IPv6 アドレスの上位 64 ビットは、グローバル ルーティング プレフィクスとサブネット ID から構成されます。汎用プレフィクス(/48 など)には、短いプレフィクスが保持されます。このプレフィクスに基づいて、より長く詳細な複数のプレフィクス(/64 など)を定義できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 の汎用プレフィクス」

「IPv6 汎用プレフィクスの定義と使用」

IPv6 スイッチング:シスコ エクスプレス フォワーディングと分散型シスコ エクスプレス フォワーディングのサポート

12.0(21)ST 12.0(22)S 12.2(14)S
12.2(28)SB
12.2(25)SG
12.2(33)SRA
12.2(17a)SX1
12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

Cisco Express Forwarding for IPv6 は、IPv6 パケットを転送するための高度なレイヤ 3 IP スイッチング テクノロジーです。分散型 Cisco Express Forwarding for IPv6 は、CEFv6 と同じ機能を実行しますが、GSR や Cisco 7500 シリーズ ルータなどの分散型アーキテクチャ プラットフォーム用です。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチング」

「IPv6 のシスコ エクスプレス フォワーディング スイッチングと分散型シスコ エクスプレス フォワーディング スイッチングの設定」

BVI インターフェイス上での IPv6 サポート

15.1(2)T

この機能により、IPv6 コマンドが BVI 上でサポートされます。それにより、ユーザが IPv6 アドレスを BVI に割り当て、IPv6 パケットをルーティングできるようになります。

この機能に関する詳細については、次の各項を参照してください。

「ブリッジングおよびルーティングのための BVI インターフェイス上での IPv6」

IPv6 のユニキャスト Reverse Path Forwarding

12.0(31)S

ユニキャスト RPF 機能により、IPv6 ルータを経由する不正形式または偽造(スプーフィング)IPv6 送信元アドレスを原因とする問題が軽減されます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 アドレッシングと基本接続の実装の前提条件」

「ユニキャスト Reverse Path Forwarding」