マルチトポロジ ルーティング コンフィギュレーション ガイド、Cisco IOS Release 15.1S
マルチトポロジ ルーティング
マルチトポロジ ルーティング
発行日;2012/02/04 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 986KB) | フィードバック

目次

マルチトポロジ ルーティング

機能情報の確認

目次

マルチトポロジ ルーティングの前提条件

マルチトポロジ ルーティングに関する制約事項

マルチトポロジ ルーティングに関する情報

MTR の概要

MTR に対するユニキャスト トポロジ サポート

MTR に対するマルチキャスト トポロジ サポート

MTR のトラフィック分類

MTR に対するルーティング プロトコル サポート

MTR に対する BGP ルーティング プロトコル サポート

BGP ネットワーク スコープ

BGP 下の MTR コマンドライン インターフェイス(CLI)階層

クラス固有のトポロジの BGP セッション

BGP を使用したトポロジの変換

BGP を使用したトポロジのインポート

MTR に対するインターフェイス コンフィギュレーション サポート

MTR に対するネットワーク管理サポート

ISSU:MTR

MTR 展開モデル

サービス分離型 MTR モデル

重複型 MTR モデル

MTR の展開設定

フル展開

逐次展開

MTR のイネーブル化およびディセーブル化に関するガイドライン

マルチトポロジ ルーティングの設定方法

MTR に対するユニキャスト トポロジの設定

この次の手順

MTR に対するマルチキャスト トポロジの設定

制約事項

この次の手順

MTR のトラフィック分類の設定

前提条件

制約事項

この次の手順

OSPF を使用した MTR トポロジのアクティブ化

前提条件

この次の手順

EIGRP を使用した MTR トポロジのアクティブ化

前提条件

制約事項

この次の手順

IS-IS を使用した MTR トポロジのアクティブ化

前提条件

制約事項

この次の手順

BGP を使用した MTR トポロジのアクティブ化

前提条件

制約事項

この次の手順

BGP を使用した MTR トポロジからのルートのインポート

前提条件

制約事項

インターフェイス コンフィギュレーション モードでの MTR トポロジの設定

前提条件

制約事項

インターフェイス コンフィギュレーション モードでの OSPF を使用した MTR トポロジのアクティブ化

前提条件

インターフェイス コンフィギュレーション モードでの EIGRP を使用した MTR トポロジのアクティブ化

インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化

前提条件

MTR に対する SNMP サポートの設定

MTR 用の SNMP コンテキストと VRF の関連付け

MTR 用の SNMP コンテキストとデータ トポロジの関連付け

MTR 用の SNMP コンテキストとルーティング プロトコルの関連付け

MTR トポロジ統計情報アカウンティングのイネーブル化とモニタリング

MTR に対するトポロジ統計情報アカウンティングのイネーブル化

MTR に関するインターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング

MTR のネットワーク接続テスト

マルチトポロジ ルーティングの設定例

例:MTR のユニキャスト トポロジ

例:グローバル インターフェイス コンフィギュレーション

例:逐次転送設定

例:ユニキャスト トポロジの確認

例:MTR のマルチキャスト トポロジ

例:ルート複製コンフィギュレーション

例:マルチキャスト RPF コンフィギュレーションに対するユニキャスト RIB の使用

例:マルチキャストの確認

例:MTR のトラフィック分類

例:OSPF を使用した MTR トポロジのアクティブ化

例:EIGRP を使用した MTR トポロジのアクティブ化

例:IS-IS を使用した MTR トポロジのアクティブ化

例:BGP を使用した MTR トポロジのアクティブ化

例:BGP トポロジ変換コンフィギュレーション

例:BGP スコープのグローバルおよび VRF コンフィギュレーション

例:BGP トポロジの確認

例:BGP を使用した MTR トポロジからのルートのインポート

例:インターフェイス コンフィギュレーション モードでの MTR トポロジ

例:インターフェイス コンフィギュレーション モードでの MTR OSPF トポロジ

例:インターフェイス コンフィギュレーション モードでの MTR EIGRP トポロジ

例:インターフェイス コンフィギュレーション モードでの MTR IS-IS トポロジ

MTR に対する SNMP サポート

例:インターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング

例:MTR のネットワーク接続テスト

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

マルチトポロジ ルーティングの機能情報

用語集

マルチトポロジ ルーティング

Multi-Topology Routing(MTR; マルチトポロジ ルーティング)を利用すると、クラスベースの転送によるサービスの区別化を設定できます。MTR では、複数のユニキャスト トポロジと別個のマルチキャスト トポロジがサポートされます。トポロジは、一連の独立した Network Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)によって特徴付けられる、基礎となるネットワーク(または基本トポロジ)のサブセットです。トポロジは、別のトポロジと重複することも、基礎となるネットワークのサブセットを共有することもあります。MTR は、トポロジ単位で別個の転送機能を提供します。別個の転送テーブルがトポロジごとに保持されており、独立した転送コンフィギュレーションを広範囲に適用したり、独立した転送コンフィギュレーションに詳細なレベルを追加したりすることができます。たとえば、MTR を使用して、音声、ビデオ、およびデータ トラフィック クラスに対して別個のトポロジを定義できます。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「マルチトポロジ ルーティングの機能情報」 を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームのサポート情報、およびシスコのソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

マルチトポロジ ルーティングの前提条件

MTR を導入する前に、ネットワークの物理トポロジとトラフィック分類について十分に理解しておく必要があります。

MTR は、ネットワーク全体にわたり一貫して導入する必要があります。すべてのネットワーキング デバイスで Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)または distributed CEF(dCEF; 分散 CEF)と IP ルーティングをイネーブルにする必要があります。

トポロジをイネーブルにする前に、ルート集約やデフォルト ルートなどのカスタム ルート コンフィギュレーションを解除し、トポロジが完全にイネーブルになった後でのみカスタム ルート コンフィギュレーションを再び適用することを推奨します。この推奨の目的は、移行中に宛先が不明になることによるトラフィックの中断を防ぐことにあります。また、既存のトポロジをディセーブルにするときのベスト プラクティスでもあります。カスタム ルート コンフィギュレーションは、トポロジのルーティング テーブル内のより明確なルートがすべて使用可能である場合に最も役立ちます。

マルチトポロジ ルーティングに関する制約事項

IPv4(ユニキャストおよびマルチキャスト)アドレス ファミリだけがサポートされています。

Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)インスタンス内に複数のユニキャスト トポロジを設定することはできません。ただし、複数のユニキャスト トポロジと別個のマルチキャスト トポロジはグローバル アドレス空間に設定でき、別個のマルチキャスト トポロジは VRF 内に設定できます。

すべてのトポロジは、共通のアドレス空間を共有します。MTR は、アドレスの再使用をイネーブルにするためのものではありません。別個のトポロジにおけるアドレスの再使用の設定はサポートされていません。

IP Differentiated Service または IP Precedence は、MTR も導入されているネットワークに個別に設定できます。ただし、MTR は、特定のトポロジ トラフィックの IP パケット ヘッダー内に DiffServ Code Point(DSCP)ビットの専用のサブセットを必要とします。このため、同時に設定する場合は、慎重に調整する必要があります。クラス固有のトポロジを含むルータでは、IP パケット ヘッダー内の DSCP ビットにリマークを設定することは推奨されておらず、サポートもされていません。

MTR サポートを提供する Cisco IOS ソフトウェア イメージには、Distance Vector Multicast Routing Protocol(DVMRP; ディスタンス ベクトル マルチキャスト ルーティング プロトコル)の CLI と機能は備わっていません。

マルチトポロジ ルーティングに関する情報

「MTR の概要」

「MTR に対するユニキャスト トポロジ サポート」

「MTR に対するマルチキャスト トポロジ サポート」

「MTR のトラフィック分類」

「MTR に対するルーティング プロトコル サポート」

「MTR に対する BGP ルーティング プロトコル サポート」

「MTR に対するインターフェイス コンフィギュレーション サポート」

「MTR に対するネットワーク管理サポート」

「ISSU:MTR」

「MTR 展開モデル」

「MTR の展開設定」

「MTR のイネーブル化およびディセーブル化に関するガイドライン」

MTR の概要

MTR の使用により、クラスベースの転送によるサービスの区別化を設定できます。MTR は、独立したトポロジ コンフィギュレーションとトラフィック分類コンフィギュレーションの 2 つの主要コンポーネントで構成されています。

トポロジは、別個のルート セットが計算される、ネットワーク内のルータおよびリンクのサブセットとして定義されます。通常のルート セットが計算されるネットワーク全体を基本トポロジと呼びます。基本トポロジ(または基礎となるネットワーク)は、NLRI によって特徴付けられます。ルータは、NLRI を使用してグローバル ルーティング テーブルを計算することで、ルーティングと転送を決定します。言い換えれば、基本トポロジは、MTR をイネーブルにするよりも前に存在するデフォルトのルーティング環境です。

追加のトポロジはいずれもクラス固有のトポロジと呼ばれ、基本トポロジのサブセットとなります。クラス固有の各トポロジは、特定のクラスのトラフィックを伝送し、別個の Routing Information Base(RIB)および Forwarding Information Base(FIB)の保持に使用される独立した NLRI のセットによって特徴付けられます。この設計により、ルータではトポロジごとに独立したルート計算と転送を実行できます。

MTR は、所定のルータ内で所定の宛先に転送する際のルート選択を作成します。特定のルート選択は、転送されるパケットのクラスに基づきます。クラスとは、パケット自体のアトリビュートです。この設計により、パケットをクラスごとに個別にルーティングすることができます。パケットがたどるパスは、ネットワーク内のルータとインターフェイスに設定されている分類子によって決定します。図 1 は、赤色、青色、緑色のトポロジのスーパーセットである基本トポロジを示しています。

図 1 MTR 基本トポロジ

図 2 は、サービス分離型モデルを使用して設定された MTR 対応のネットワークを示しています。基本トポロジ(黒色で表示)には、ネットワーク内の到達可能なすべてのデバイスからの NLRI が使用されています。青色、赤色、および紫色のパスは、それぞれ異なるクラス固有のトポロジを示しています。クラス固有の各トポロジでは、ネットワークを経由する別個のパス セットが計算されます。ルーティングと転送は、トポロジごとに伝送される個々の NLRI セットに基づいて個別に計算されます。

図 2 MTR トポロジの定義

 

図 3 は、ネットワーク エッジでトラフィックにマークが付けられることを示しています。トラフィックがネットワークをトラバースするときの分類および転送にこのマーキングが使用され、トラフィックは色分けされたそれぞれのトポロジに拘束されます。

図 3 トラフィックが通過するクラス固有の転送パス

 

同一のトポロジにバックアップ パスを設定できます。図 4 では、音声トポロジの優先パスが青色の実線で表されています。このパスが使用できない場合は、青色の点線で表された音声バックアップ パスを選択するように MTR を設定できます。これらのパスはいずれも同じトポロジを表し、重複はありません。

図 4 MTR によるトポロジ内の障害のバックアップ

 

図 5 は、システム レベルの MTR 転送モデルを示しています。パケットが着信インターフェイスに到達すると、マーキングが確認されます。パケットのマーキングがトポロジと一致すると、関連付けられたトポロジが参照されてネクスト ホップが決定し、パケットが転送されます。トポロジ内に転送エントリがない場合、パケットはドロップされます。パケットがどの分類子とも一致しない場合は、基本トポロジに転送されます。発信インターフェイスは、色分けされたルート テーブルの 1 つの機能であり、ここで検索が行われます。

図 5 システム レベルでの MTR 転送

 

MTR は、アドレス ファミリおよびサブアドレス ファミリに基づいて Cisco IOS ソフトウェアに実装されます。MTR は、最大 32 個のユニキャスト トポロジ(基本トポロジを含む)と別個のマルチキャスト トポロジをサポートします。トポロジは、別のトポロジと重複することも、基礎となるネットワークのサブセットを共有することもあります。各トポロジには、一意のトポロジ ID を設定します。トポロジ ID は、ルーティング プロトコル下に設定します。この ID は、所定のプロトコルのアップデート時に各トポロジの NLRI を識別してグループ分けするために使用されます。

MTR に対するユニキャスト トポロジ サポート

ルータごとに最大 32 個のユニキャスト トポロジを設定できます。まず、グローバル コンフィギュレーション モードで global-address-family コマンドを入力することによってトポロジを定義します。アドレス ファミリと任意のサブアドレス ファミリは、このステップで指定します。次に、グローバル アドレス ファミリ コンフィギュレーション モードで topology サブコマンドを入力します。このコマンドによって、ルータはアドレス ファミリ トポロジ コンフィギュレーション モードに設定され、このモードでグローバル トポロジ コンフィギュレーション パラメータが適用されます。

ルータに新規のトポロジを設定すると、グローバル ルーティング テーブルのルートの合計数が新規の各トポロジ内のルート数分だけ増加します [base+topology( n )]。ルータが大きなグローバル ルーティング テーブルを伝送する場合に、MTR のトポロジ コンフィギュレーションによってルート数が大幅に追加されるときは、ルータが所定のトポロジに対して許可し、対応する RIB にインストールするルート数を制限するよう、アドレス ファミリ トポロジ コンフィギュレーション モードで maximum routes (MTR)コマンドを設定できます。


) インターフェイス単位のトポロジ コンフィギュレーション パラメータは、グローバル アドレス ファミリ トポロジ コンフィギュレーション モードとルータ アドレス ファミリ トポロジ コンフィギュレーション モードで適用されるコンフィギュレーションよりも優先されます。


手順の詳細については、「MTR に対するユニキャスト トポロジの設定」を参照してください。

MTR に対するマルチキャスト トポロジ サポート

Cisco IOS ソフトウェアは、デフォルトでレガシー(事前 MTR)IP マルチキャストの動作をサポートします。IP マルチキャストに対する MTR サポートは、明示的にイネーブルにする必要があります。レガシー IP マルチキャストでは、ユニキャスト RIB(基本ユニキャスト トポロジ)内のルートでのリバース パス転送を使用して、Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を構築します。

MTR によって、ユニキャスト トポロジからは完全に独立したマルチキャスト トポロジが導入されます。MTR とマルチキャストの統合により、ユーザは、ネットワーク内のマルチキャスト トラフィックのパスを制御できます。

マルチキャスト トポロジには、別個のルーティングおよび転送テーブルが保持されます。次に、Cisco IOS ソフトウェアに統合されている MTR マルチキャスト サポートの一覧を示します。

マルチキャスト ルートに対する従来の最長一致のサポート。

Protocol Independent Multicast(PIM)に対する RPF のサポート。

AS 間 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)(SAFI 66)に対する Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)MDT Subaddress Family Identifier(SAFI)のサポート。

スタティック マルチキャスト ルートに対するサポートは、 ip route topology コマンドに統合されています( ip mroute コマンドを変更)。

事前 MTR ソフトウェアと同様に、マルチキャスト サポートをイネーブルにするには、グローバル コンフィギュレーション モードで ip multicast-routing コマンドを設定します。マルチキャストに対する MTR のサポートをイネーブルにするには、 ip multicast rpf multitopology コマンドを設定します。 global-address-family コマンドは、IPv4 アドレス ファミリおよびマルチキャスト サブアドレス ファミリと一緒に入力します。次に、 topology コマンドと base キーワードを入力すると、このモードでグローバル トポロジ コンフィギュレーション パラメータが適用されます。

手順の詳細については、「MTR に対するマルチキャスト トポロジの設定」を参照してください。

MTR のトラフィック分類

クラス固有のトポロジが 1 つしか設定されていない場合でも、トラフィック分類を設定するまでは、ルータで MTR をイネーブルにすることはできません。トラフィック分類は、複数のトポロジが同一ルータに設定されている場合に、トポロジ固有の転送動作を設定するために使用します。トラフィック分類は、ネットワーク全体に一貫性を持って適用する必要があります。クラス固有のパケットは、対応するトポロジ テーブルの転送エントリに関連付けられます。

トラフィック分類を設定するには、Modular QoS CLI(MQC; モジュラ QoS CLI)を使用します。MTR のトラフィック分類は、QoS のトラフィック分類に似ています。ただし、重大な相違があります。MTR のトラフィック分類は、QoS のようにインターフェイス レベルではなく、トポロジごとにグローバルに定義されます。

DSCP ビットのサブセットは、IP パケット ヘッダー内の分類値をエンコードするのに使用されます。クラス マップを設定してトラフィック クラスを定義するには、グローバル コンフィギュレーション モードで class-map コマンドを入力します。MTR に対してサポートされているのは、 match-any キーワードだけです。トラフィック クラスとポリシーを関連付けるには、グローバル コンフィギュレーション モードで policy-map type class-routing ipv4 unicast コマンドを設定します。トポロジに対してポリシーをアクティブにするには、グローバル アドレス ファミリ コンフィギュレーション モードで service-policy type class-routing コマンドを設定します。設定すると、サービス ポリシーがルータ上のすべてのインターフェイスに関連付けられます。

これらの目的の中には、QoS のコンフィギュレーションを介して実現できるものありますが、MTR はさらに強力で柔軟な代替方法を可能にします。MTR のトラフィック分類と IP Differentiated Service ベースまたは IP Precedence ベースのトラフィック分類は、同一のネットワークに設定できます。ただし、MTR には、特定のトポロジ トラフィックの IP パケット ヘッダーにある DSCP ビットの専用のサブセットが必要です。ネットワークで MTR トラフィック分類と QoS トラフィック分類を同時に設定する場合は、慎重に調整する必要があります。

手順の詳細については、「MTR のトラフィック分類の設定」を参照してください。

MTR に対するルーティング プロトコル サポート

MTR を動作させるには、ルータで IP ルーティングをイネーブルにする必要があります。MTR は、Cisco IOS ソフトウェアでのスタティック ルーティングおよびダイナミック ルーティングをサポートします。トポロジ単位のダイナミック ルーティングをイネーブルにすることで、ドメイン内およびドメイン間のルーティングをサポートできます。ルートの計算と転送は、各トポロジで個別に行われます。Cisco IOS ソフトウェアには、次のプロトコルについて MTR のサポートが組み込まれています。

Border Gateway Protocol(BGP)

Enhanced Interior Gateway Routing Protocol(EIGRP)

Integrated Intermediate System-to-Intermediate System(IS-IS)

Open Shortest Path First(OSPF)

グローバル ルーティング プロセス(ルータ コンフィギュレーション モード)のルータ アドレス ファミリ コンフィギュレーション モードでトポロジ単位のコンフィギュレーションを適用します。アドレス ファミリおよびサブアドレス ファミリは、アドレスファミリ コンフィギュレーション モードを開始するときに指定します。トポロジ名とトポロジ ID を指定するには、アドレスファミリ コンフィギュレーション モードで topology コマンドを入力します。

各トポロジに、ルーティング プロトコル下で一意のトポロジ ID を設定します。トポロジ ID は、所定のプロトコルのアップデート時に各トポロジの NLRI を識別してグループ化するために使用されます。OSPF、EIGRP、および IS-IS では、クラス固有のトポロジに対する topology コマンドの最初のコンフィギュレーションでトポロジ ID を入力します。BGP では、トポロジ コンフィギュレーションの下に bgp tid コマンドを入力することによってトポロジ ID を設定します。

クラス固有のトポロジには、基本トポロジとは異なるメトリックを設定できます。基本トポロジに設定されたインターフェイス メトリックをクラス固有のトポロジに継承することもできます。継承は、クラス固有のトポロジに明示的な継承メトリックが設定されていない場合に実行されます。

BGP サポートは、ルータ コンフィギュレーション モードだけで設定します。Interior Gateway Protocol(IGP)サポートは、ルータ コンフィギュレーション モードとインターフェイス コンフィギュレーション モードで設定します。

デフォルトでは、インターフェイスには基本トポロジ以外のトポロジは含まれません。EIGRP、IS-IS、および OSPF のルーティング プロトコル サポートについては、インターフェイスに基本トポロジ以外のトポロジを明示的に設定する必要があります。アドレス ファミリ トポロジ コンフィギュレーション モードで all-interfaces コマンドを使用すると、デフォルト動作を無効にできます。 all-interfaces コマンドを入力すると、デフォルトのアドレス空間、またはトポロジが設定される VRF に属する、ルータのすべてのインターフェイスに基本トポロジ以外のトポロジが設定されます。

手順の詳細については、次の項を参照してください。

「OSPF を使用した MTR トポロジのアクティブ化」

「EIGRP を使用した MTR トポロジのアクティブ化」

「IS-IS を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの MTR トポロジの設定」

「インターフェイス コンフィギュレーション モードでの OSPF を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの EIGRP を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化」

MTR に対する BGP ルーティング プロトコル サポート

MTR をサポートするために BGP を使用する前に、次の概念について十分に理解しておく必要があります。

「BGP ネットワーク スコープ」

「BGP 下の MTR コマンドライン インターフェイス(CLI)階層」

「クラス固有のトポロジの BGP セッション」

「BGP を使用したトポロジの変換」

「BGP を使用したトポロジのインポート」

BGP ネットワーク スコープ

BGP 用の MTR を実装するには、スコープ階層が必要ですが、スコープ階層は MTR の使用に制限されません。スコープ階層によって、ルータ スコープ コンフィギュレーション モードなどのいくつかの新しいコンフィギュレーション モードが導入されています。ルータ スコープ コンフィギュレーション モードを開始するには、ルータ コンフィギュレーション モードで scope コマンドを設定します。このコマンドを入力すると、ルーティング テーブルの集合が作成されます。

BGP コマンドはスコープ階層で単一のネットワーク用に(グローバルに)設定するか、または VRF 単位で設定します。このコマンドをスコープ コマンドと呼びます。スコープ階層には、1 つ以上のアドレス ファミリを含めることができます。

BGP 下の MTR コマンドライン インターフェイス(CLI)階層

BGP CLI は、事前 MTR の BGP コンフィギュレーションに対する下位互換性を提供し、MTR の階層化実装を可能にします。ルータ コンフィギュレーション モードには、事前アドレス ファミリおよび事前 MTR のコンフィギュレーション CLI との下位互換性があります。すべてのネットワークに影響を与えるグローバル コマンドはこのコンフィギュレーション モードで設定されます。アドレスファミリおよびトポロジ コンフィギュレーション用に、アドレスファミリ コンフィギュレーション モードまたはトポロジ コンフィギュレーション モードで使用する汎用のセッション コマンドとピア テンプレートを設定します。

グローバル コマンドの設定後に、スコープをグローバルに定義するか、特定の VRF に対して定義します。アドレス ファミリ コンフィギュレーション モードを開始するには、ルータ スコープ コンフィギュレーション モードまたはルータ コンフィギュレーション モードで address-family コマンドを設定します。Subaddress-Family Identifier(SAFI)が指定されていない場合は、ユニキャストがデフォルトのアドレス ファミリです。MTR では、ユニキャストまたはマルチキャストの SAFI が指定された IPv4 アドレス ファミリだけがサポートされます。

ルータ コンフィギュレーション モードからアドレス ファミリ コンフィギュレーション モードを開始すると、BGP は事前 MTR ベースの CLI を使用するよう設定されます。このコンフィギュレーション モードには、既存のアドレス ファミリ コンフィギュレーションとの下位互換性があります。ルータ スコープ コンフィギュレーション モードからアドレス ファミリ コンフィギュレーション モードを開始すると、ルータは、MTR をサポートする階層 CLI を使用するよう設定されます。トポロジに固有ではないアドレス ファミリ コンフィギュレーション パラメータは、このアドレス ファミリ コンフィギュレーション モードで入力します。

BGP トポロジ コンフィギュレーション モードを開始するには、アドレス ファミリ コンフィギュレーション モードで topology (BGP)コマンドを設定します。ルータには、最大 32 個のトポロジ(基本トポロジを含む)を設定できます。トポロジ ID を設定するには、 bgp tid コマンドを入力します。トポロジのすべてのアドレス ファミリ コンフィギュレーション パラメータとサブアドレス ファミリ コンフィギュレーション パラメータがここで設定されます。


) BGP ルーティング プロセスのスコープを設定すると、事前 MTR ベース設定に対する CLI サポートは削除されます。


次の例は、MTR の実装に対して BGP を設定するときに使用される階層レベルを示しています。

router bgp <autonomous-system-number>
! Global commands
scope {global | vrf <vrf-name>}
! Scoped commands
address-family {<afi>} [<safi>]
! Address family specific commands
topology {<topology-name> | base}
! topology specific commands
 

手順の詳細については、「BGP を使用した MTR トポロジのアクティブ化」を参照してください。

クラス固有のトポロジの BGP セッション

MTR は、セッション単位で BGP 下で設定されます。基本のユニキャスト トポロジとマルチキャスト トポロジは、グローバル(デフォルト)セッションで伝送されます。BGP ルーティング プロセス下で設定されるクラス固有のトポロジごとに別個のセッションが作成されます。各セッションは、トポロジ ID で識別されます。BGP は、クラス固有のトポロジごとに最良パスの計算を個別に実行します。セッションごとに別個の RIB と FIB が維持されます。

BGP を使用したトポロジの変換

ネットワークの設計とポリシー要件によっては、あるルータ上のクラス固有のトポロジから、ネイバー ルータ上のクラス固有のトポロジにルートをインストールしなければならないことがあります。BGP を使用したトポロジ変換機能によって、この操作がサポートされます。トポロジ変換は、BGP ネイバー セッション ベースで行われます。 neighbor translate-topology コマンドを設定するには、ネイバーの IP アドレスとトポロジ ID を使用します。

トポロジ ID は、ネイバーのクラス固有のトポロジを識別します。ネイバーのクラス固有のトポロジ内のルートは、ローカルのクラス固有の RIB にインストールされます。BGP は、インストールされているすべてのルートで最良パスを計算し、これらのルートをローカルのクラス固有の RIB にインストールします。重複するルートを変換すると、BGP は、標準の BGP 最良パスの計算ごとに、ルートのインスタンスを 1 つだけ選択してインストールします。

BGP を使用したトポロジのインポート

BGP を使用したトポロジのインポート機能はトポロジ変換と似ています。違いは、ルートが BGP を使用して同一ルータ上のクラス固有のトポロジ間で移動されることです。この機能を設定するには、 import topology コマンドを入力し、クラス固有のトポロジまたは基本トポロジの名前を指定します。最良パスの計算は、インポート済みのルートがトポロジの RIB にインストールされる前にこれらのルートで実行されます。このコマンドには、クラス固有のトポロジ間で移動されるルートをフィルタリングできるようにする route-map キーワードも含まれています。

手順の詳細については、「BGP を使用した MTR トポロジからのルートのインポート」を参照してください。

MTR に対するインターフェイス コンフィギュレーション サポート

インターフェイス コンフィギュレーション モードで MTR トポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにできます。デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

個々のインターフェイスを包含または除外するには、 topology インターフェイス コンフィギュレーション コマンドを設定します。このコマンドの入力時に、アドレス ファミリとトポロジ(基本またはクラス固有)を指定します。サブアドレス ファミリは、任意で指定できます。サブアドレス ファミリを指定しないと、デフォルトでユニキャスト サブアドレス ファミリが使用されます。

トポロジにルータ上のすべてのインターフェイスをグローバルに包含するには、ルーティング トポロジ コンフィギュレーション モードで all-interfaces コマンドを入力します。 topology (インターフェイス)コマンドで適用したインターフェイス単位のトポロジ コンフィギュレーションは、グローバル インターフェイス コンフィギュレーションよりも優先されます。

MTR に対するインターフェイス コンフィギュレーション サポートには、次の特徴があります。

インターフェイス単位のルーティング コンフィギュレーション

IGP ルーティングおよびメトリックのコンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用できます。インターフェイス単位のメトリックおよびルーティングの動作は、IGP ごとに設定できます。インターフェイス コンフィギュレーション モードの IGP コマンドについては、各ルーティング プロトコルのコンフィギュレーションの項に記載されています。

OSPF インターフェイス トポロジ コンフィギュレーション

クラス固有のトポロジに対するインターフェイス モードの OSPF コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。このモードでは、インターフェイスのコストを設定したり、グローバル トポロジ コンフィギュレーションからインターフェイスを削除することなく OSPF ルーティングをディセーブルにしたりすることができます。

EIGRP インターフェイス トポロジ コンフィギュレーション

クラス固有のトポロジに対するインターフェイス モードの EIGRP コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。このモードでは、各種の EIGRP 機能を設定できます。

IS-IS インターフェイス トポロジ コンフィギュレーション

クラス固有のトポロジに対するインターフェイス モードの IS-IS コンフィギュレーションは、インターフェイス トポロジ コンフィギュレーション モードで適用されます。このモードでは、インターフェイスのコストを設定したり、グローバル トポロジ コンフィギュレーションからインターフェイスを削除することなく IS-IS ルーティングをディセーブルにしたりすることができます。

手順の詳細については、「インターフェイス コンフィギュレーション モードでの MTR トポロジの設定」を参照してください。

MTR に対するネットワーク管理サポート

Cisco IOS ソフトウェアには、コンテキストベースの Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)のサポートが組み込まれています。MTR に対する SNMP サポートでは、コンテキストベースの SNMP を利用することで、基本トポロジのみの管理情報を表示する既存の MIB のサポートが拡張され、複数のトポロジの管理情報を表示できます。

既存の MIB アクセス機能にコンテキスト文字列を渡すように、ルータ上の SNMP エージェント ソフトウェア コンポーネントを設定できます。ネットワーク管理アプリケーションでは、これらのコンテキスト文字列を SNMP トランザクションに提供することで、それらのトランザクションが特定の Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンス、特定のトポロジ、またはルーティング プロトコル インスタンスに割り当てられるようにします。受信側のルータの SNMP インフラストラクチャは、コンテキスト文字列がルータ用に定義されていることと、付随する内部識別子がそのコンテキスト文字列に対して定義されていることを確認してから、コンテキスト文字列と内部識別子を MIB アクセス機能に渡します。

手順の詳細については、「MTR に対する SNMP サポートの設定」を参照してください。

ping や traceroute などの標準のネットワーク管理ユーティリティは、MTR をサポートするように拡張されています。標準または拡張 ping は、ホスト名や IP アドレスの代わりにトポロジ名を使用して設定できます。traceroute も同様に拡張されています。手順の詳細については、「MTR のネットワーク接続テスト」を参照してください。

ISSU:MTR

MTR をサポートし、In Service Software Upgrade(ISSU)もサポートするすべてのプロトコルおよびアプリケーションでは、MTR 機能が含まれるように ISSU サポートが拡張されています。ISSU 対応のプロトコルおよびアプリケーションの詳細については、『 Cisco IOS In Service Software Upgrade Process 』モジュールを参照してください。

ISSU を使用すると、アクティブおよびスタンバイの Route Processor(RP; ルート プロセッサ)上で異なるバージョンの Cisco IOS ソフトウェアが実行されている場合でも、High-Availability(HA; ハイアベイラビリティ)システムを Stateful Switchover(SSO; ステートフル スイッチオーバー)モードで実行できます。この機能を使用すると、アップグレードした(またはダウングレードした)ソフトウェアを実行しているセカンダリ RP に切り替えたり、セッション損失やパケット損失なく、または最小限のパケット損失でパケットの転送を続行したりすることができます。

この機能は、デフォルトでイネーブルにされています。

MTR 展開モデル

基本トポロジは、ネットワーク内のすべてのトポロジのスーパーセットです。基本トポロジは、使用されている展開モデルに関係なく、すべての到達可能ルータに対する NLRI によって定義されます。MTR は、サービス分離型 MTR モデル(図 6 参照)を使用して展開することも、重複型 MTR モデル(図 7 参照)を使用して展開することもできます。これらのモデルはそれぞれ、MTR の異なる展開方法を示します。ただし、これらのモデルは両立が可能です。一定のレベルでさまざまに組み合わせたモデルを展開できます。

サービス分離型 MTR モデル

図 6 は、色分けされたトポロジ(基本を除く)が互いに重なり合わないサービス分離型モデルを示しています。サービス分離型モデルでは、各クラスのトラフィックがその専用のトポロジに拘束されます。このモデルは、特定のクラスのトラフィックをネットワークのサブネットに制限します。このモデルには、トポロジ固有のメトリックを設定する必要がないので、あまり多くのコンフィギュレーションは使用されません。

図 6 サービス分離型 MTR モデル

 

重複型 MTR モデル

重複型 MTR モデルでは、すべてのトポロジがネットワーク内のすべてのルータで稼動するように設定されます。このモデルは、最大レベルの冗長性をもたらします。すべてのクラスのトラフィックにすべてのリンクを使用できます。ネットワークのさまざまな部分を使用するため、トラフィックがクラス別に偏るようにトポロジ単位のメトリックを設定します。ただし、このモデルは冗長性をもたらすため、多くのコンフィギュレーションが必要になります。図 7 に、赤色と灰色のトポロジを示します。すべてのトポロジは、すべてのネットワーク ルータで稼動するように設定されます。このモデルでは、優先ルートがトポロジごとに偏るように、トポロジ単位のメトリックを設定します。

図 7 重複型 MTR モデル

 

MTR の展開設定

MTR は、フル展開設定と逐次展開設定の両方をサポートしています。これらのオプションをサポートするため、MTR には、フル展開用の厳密転送モードと、逐次展開用の逐次転送モードという 2 つの設定可能な転送ルールが用意されています。

フル展開

厳密転送モードは、MTR のデフォルトの転送モードです。このモードでは、ルータはクラス固有の FIB だけで転送ルートを探します。転送ルートが見つからない場合、パケットはドロップされます。このモードでは、ルータは、トポロジ FIB エントリに対する最長一致検索を実行します。このモードは、ネットワーク内のすべてのルータまたはトポロジ内のすべてのルータで MTR がイネーブルになるフル展開用に用意されています。逐次展開の移行の完了後、あるいはネットワーク内またはトポロジ内のすべてのルータで MTR がイネーブルになった時点で、厳密転送モードをイネーブルにします。逐次転送モードの後に厳密転送モードをイネーブルにするには、アドレス ファミリ トポロジ コンフィギュレーション モードで no forward-base コマンドを入力します。

逐次展開

逐次転送モードは、ネットワーク内のルータで MTR がイネーブルになっていない場合に、MTR の移行または逐次展開をサポートするために用意されています。このモードでは、ルータは最初にクラス固有の FIB で転送エントリを探します。エントリが見つからない場合は、基本トポロジ FIB で最長一致検索を行います。基本トポロジ FIB でエントリが見つかると、パケットは基本トポロジで転送されます。基本トポロジ FIB で転送エントリが見つからない場合、パケットはドロップされます。

このモードは、MTR の逐次展開時の接続性を保つために用意されているものであるため、移行(MTR 非対応ネットワークから MTR 対応ネットワークへの移行)時にのみ使用することを推奨します。所定の宛先のクラス固有のトラフィックは、その宛先を含むクラス固有のトポロジの隣接するセグメント経由で転送されます。それ以外の場合は、基本トポロジ上で転送されます。

この転送モードをイネーブルにすると、一部のルータが MTR を実行するように設定されていない混合ネットワークをサポートできます。逐次転送モードをイネーブルにするには、アドレス ファミリ トポロジ コンフィギュレーション モードで forward-base コマンドを入力します。

MTR のイネーブル化およびディセーブル化に関するガイドライン

ここでは、実稼動ネットワークでの MTR のイネーブル化またはディセーブル化に関するガイドラインと手順について説明します。これらのガイドラインは、関与しているすべてのネットワーキング デバイスで、MTR をサポートするソフトウェア イメージが実行されていることを前提としています。これらのガイドラインの目的は、誤った設定による主要トラフィックの中断を防止することと、ネットワークに対してトポロジを追加したり削除したりするときに発生する一時的な移行の影響を最小限に抑えることにあります。次に示すガイドラインは、必ず記載されている順番で実行してください。

初めに、すべてのネットワーキング デバイスでクラス固有のトポロジを作成し、アドレス ファミリ トポロジ コンフィギュレーションで forward-base コマンドを入力することによって逐次転送モードをイネーブルにします。ネットワークに対してトポロジを追加または削除するときは、必ず逐次転送を設定します。この段階では、トポロジはグローバル コンテナとして定義されます。トポロジ内で実行されるルーティングや転送はありません。ルーティング プロトコルのサポートを設定する必要はありません。

次に、クラス固有のトポロジに対する分類ルールを設定します。トポロジ内のすべてのルータに一貫して分類を適用する必要があります。各ルータに、まったく同じ分類子コンフィギュレーションが存在します。有効な分類コンフィギュレーションをグローバル トポロジ コンフィギュレーションに付加すると、トポロジがアクティブになります。ping と traceroute を使用して、同じトポロジにあり、同じ分類が設定されているインターフェイスおよびネットワーキング デバイスの到達可能性を確認します。

3 番目に、ルーティング プロトコルのサポートまたはスタティック ルーティング、あるいはその両方を設定します。トポロジ内のルータは一度に 1 つずつ設定します。このコンフィギュレーションには、インターフェイス、ルータ プロセス、およびルーティング プロトコル固有のメトリックとフィルタが含まれます。

1 つの開始点を基準として連続する物理パターンを使用して、トポロジ内のルーティングをイネーブルにします。たとえば、1 つのルータのすべてのインターフェイスを設定してから、隣接する各ルータのすべてのインターフェイスを設定します。作業が完了するまで、このパターンに従います。開始点は、ネットワークのエッジにすることも、コアにすることもできます。このような推奨を行う目的は、クラス固有のトラフィックが逐次トポロジにおいても、MTR が完全に展開された状態のフル トポロジにおける場合と同じパスで転送される可能性を高めることにあります。

ネットワーク設計上、厳密転送モードにする必要がある場合は、所定のトポロジのすべてのルータでルーティングを設定した後に限り、逐次転送をディセーブルにしてください。この段階で、MTR は完全に動作可能になります。クラス固有のトラフィックは、トポロジ内のデバイスだけを介して転送されます。トポロジに対して分類されていないトラフィックや、トポロジを宛先としないトラフィックはドロップされます。

トポロジをディセーブルにすると、逐次転送モードが再びイネーブルにします。トポロジをディセーブルにする前に、ルート集約やデフォルト ルートなどのカスタム ルート コンフィギュレーションを削除します。カスタム ルート コンフィギュレーションは、トポロジを再びイネーブルにした後にのみ再適用します。このような推奨を行う目的は、一部の宛先が移行中に不明になることによるトラフィックの中断を防止することにあります。カスタム ルート コンフィギュレーションは、トポロジのルーティング テーブル内のより明確なルートがすべて使用可能である場合に最も役立ちます。


) これらの推奨は、所定のトポロジに対して所定の分類子をイネーブルまたはディセーブルにする場合にのみ適用されます。インターフェイスおよびルーティング プロトコル固有のコンフィギュレーション(トポロジ ID 以外)を含むその他すべての MTR コンフィギュレーションは、必要に応じて動的に変更できます。


マルチトポロジ ルーティングの設定方法

「MTR に対するユニキャスト トポロジの設定」(必須)

「MTR に対するマルチキャスト トポロジの設定」(必須)

「MTR のトラフィック分類の設定」(必須)

「OSPF を使用した MTR トポロジのアクティブ化」(任意)

「EIGRP を使用した MTR トポロジのアクティブ化」(任意)

「IS-IS を使用した MTR トポロジのアクティブ化」(任意)

「BGP を使用した MTR トポロジのアクティブ化」(任意)

「BGP を使用した MTR トポロジからのルートのインポート」(任意)

「インターフェイス コンフィギュレーション モードでの MTR トポロジの設定」(任意)

「インターフェイス コンフィギュレーション モードでの OSPF を使用した MTR トポロジのアクティブ化」(任意)

「インターフェイス コンフィギュレーション モードでの EIGRP を使用した MTR トポロジのアクティブ化」(任意)

「インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化」(任意)

「MTR に対する SNMP サポートの設定」(任意)

「MTR トポロジ統計情報アカウンティングのイネーブル化とモニタリング」(任意)

「MTR のネットワーク接続テスト」(任意)

MTR に対するユニキャスト トポロジの設定

この作業は、ユニキャスト トポロジを設定する場合に実行します。この作業では、ステップ 1 ~ 4 のみが必須です。残りのステップは任意です。

手順の概要

1. enable

2. configure terminal

3. global-address-family ipv4 [ multicast | unicast ]

4. topology { base | topology-name }

5. all-interfaces

6. forward-base

7. maximum routes number [ threshold [ reinstall threshold ] | warning-only ]

8. shutdown

9. end

10. show topology [ cache [ topology-id ] | ha | [[ detail | interface | lock | router ] [ all | ipv4 | ipv6 | vrf vpn-instance ]]]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

global-address-family ipv4 [ multicast |
unicast ]

 

Router(config)# global-address-family ipv4

グローバル アドレス ファミリ トポロジ コンフィギュレーション モードを開始して、グローバル トポロジを設定します。

クラス固有のトポロジに対するアドレス ファミリは、このステップで指定します。サブアドレス ファミリは、任意で指定できます。ユニキャストは、サブアドレス ファミリが入力されていない場合のデフォルトです。

ステップ 4

topology { base | topology-name }

 

Router(config-af)# topology VOICE

グローバル トポロジ インスタンスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

base キーワードを使用して、基本トポロジまたはマルチキャスト トポロジを設定します。

topology-name 引数を入力して、クラス固有のトポロジにラベルを付けます。トポロジ名は大文字と小文字が区別されます。たとえば、VOICE と voice は 2 つの異なるトポロジを識別します。

MTR は、基本トポロジを含む 32 個のユニキャスト トポロジをサポートします。

ステップ 5

all-interfaces

 

Router(config-af-topology)# all-interfaces

(任意)ルータのすべてのインターフェイスを使用するように、トポロジ インスタンスを設定します。

デフォルトでは、インターフェイスは使用されません。

(注) このコマンドを設定しても、インターフェイス コンフィギュレーション モードで適用したトポロジ コンフィギュレーションが優先されます。

ステップ 6

forward-base

 

Router(config-af-topology)# forward-base

(任意)トポロジ インスタンス下で転送モードを設定します。

厳密モード(デフォルト)は、トポロジ固有の FIB でのみ転送エントリを検索するようにルータを設定します。エントリが見つからない場合、パケットはドロップされます。

逐次モード(enable 形式)は、クラス固有のトポロジ FIB 内を最初に検索するようにルータを設定します。転送ルートが見つからない場合、ルータは基本トポロジ FIB 内を検索します。

ステップ 7

maximum routes number [ threshold [ reinstall threshold ] | warning-only ]

 

Router(config-af-topology)# maximum routes 1000 warning-only

(任意)トポロジ インスタンスで許可し、RIB にインストールする最大ルート数を設定します。

warning-only キーワードを使用すると、警告のみの生成、上限の設定、および最大限度を超えた後でルートを再インストールするための下限(最低基準)の設定を行うことができます。

ステップ 8

shutdown

 

Router(config-af-topology)# shutdown

(任意)(その他のトポロジ パラメータが設定され、その他のルータに MTR が設定されているときに)トポロジ コンフィギュレーションを削除せずに、トポロジ インスタンスを一時的にディセーブルにします。

ステップ 9

end

 

Router(config-af-topology)# end

(任意)ルーティング トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 10

show topology [ cache [ topology-id ] | ha | [[ detail | interface | lock | router ] [ all | ipv4 | ipv6 | vrf vpn-instance ]]]

 

Router# show topology

(任意)クラス固有のトポロジと基本トポロジに関する情報を表示します。

この次の手順

作成する必要がある各ユニキャスト トポロジ インスタンスに対して、この作業を繰り返します。

MTR に対するマルチキャスト トポロジの設定

この作業は、マルチキャスト トポロジを設定する場合に実行します。この作業では、ステップ 1 ~ 6 のみが必須です。残りのステップは任意です。

制約事項

設定できるのは 1 つのマルチキャスト トポロジのみであり、ステップ 6 でマルチキャスト トポロジを作成するときに入力できるのは base キーワードのみです。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ vrf name ]

4. ip multicast rpf multitopology

5. global-address-family ipv4 [ multicast | unicast ]

6. topology { base | topology-name }

7. route-replicate from { multicast | unicast } [ topology { base | name }] protocol [ route-map name | vrp name ]

8. use-topology unicast { base | topology-name }

9. shutdown

10. end

11. show topology [ cache [ topology-id] | ha | [[ detail | interface | lock | router ] [ all | ipv4 | ipv6 | vrf vpn - instance ]]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ vrf name ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

ip multicast rpf multitopology

 

Router(config)# ip multicast rpf multitopology

IP マルチキャスト ルーティングに対する MTR サポートをイネーブルにします。

ステップ 5

global-address-family ipv4 [ multicast |
unicast ]

 

Router(config)# global-address-family ipv4
multicast

グローバル アドレス ファミリ コンフィギュレーション モードを開始して、グローバル トポロジを設定します。

クラス固有のトポロジに対するアドレス ファミリは、このステップで指定します。サブアドレス ファミリを指定することもできます。ユニキャストは、サブアドレス ファミリが入力されていない場合のデフォルトです。

ステップ 6

topology { base | topology-name }

 

Router(config-af)# topology base

グローバル トポロジ インスタンスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

マルチキャスト トポロジに指定できるのは、 base キーワードのみです。

ステップ 7

route-replicate from { multicast | unicast } [ topology { base | name }] protocol [ route-map name | vrf name ]

 

Router(config-af-topology)# route-replicate from unicast topology VOICE ospf 100 route-map map1

(任意)別のマルチキャスト トポロジ RIB からルートを複製(コピー)します。

protocol 引数を設定して、ルートのソースとなるプロトコルを指定します。ルートは、ユニキャスト基本トポロジまたはクラス固有のトポロジから複製できます。

(注) ただし、ルートの複製は、基本トポロジに移行するように設定された(逐次転送)クラス固有のトポロジからは設定できません。

複製されたルートは、マルチキャスト RIB にインストールする前に、ルート マップを介してフィルタリングできます。

ステップ 8

use-topology unicast { base | topology-name }

 

Router(config-af-topology)# use-topology unicast VIDEO

(任意)ユニキャスト トポロジ RIB を使用して RPF 計算を実行するように、マルチキャスト トポロジを設定します。

基本またはクラス固有のユニキャスト トポロジを設定できます。このコマンドを設定すると、マルチキャスト トポロジでは、指定のユニキャスト トポロジ テーブル内のルートを使用してマルチキャスト配信ツリーが構築されます。

(注) マルチキャスト RIB が入力され、ルーティング プロトコルによってサポートされている場合でも、このコマンドがイネーブルであるときはこのマルチキャスト RIB は使用されません。

ステップ 9

shutdown

 

Router(config-af-topology)# shutdown

(任意)(その他のトポロジ パラメータが設定され、その他のルータに MTR が設定されているときに)トポロジ コンフィギュレーションを削除せずに、トポロジ インスタンスを一時的にディセーブルにします。

ステップ 10

end

 

Router(config-af-topology)# end

(任意)アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 11

show topology [ cache [ topology-ID ] | ha | [[ detail | interface | lock | router ] [ all | ipv4 | ipv6 | vrf vpn-instance ]]

 

Router# show topology detail

(任意)クラス固有のトポロジと基本トポロジに関する情報を表示します。

この次の手順

分類が設定されるまで、トポロジはアクティブになりません。「MTR のトラフィック分類の設定」に進み、クラス固有のトポロジに対する分類を設定します。

MTR のトラフィック分類の設定

この作業は、MTR のトラフィック分類を定義する場合に実行します。トラフィック分類は、複数のトポロジが同じルータに設定されているときに、異なるトラフィック クラスを異なるトポロジに関連付けるために使用します。

この作業では、正しい順序でコマンドを実行することが非常に重要です。 service-policy type class-routing コマンドを入力する前に、トラフィック分類に影響するすべてのコンフィギュレーションが完了していることを確認してください。

前提条件

MTR のトラフィック分類を設定する前に、「MTR のトラフィック分類」に記載されているすべての概念について理解しておく必要があります。

トラフィック分類を設定するには、トポロジを(QoS のようにインターフェイス レベルではなく)グローバルに定義しておく必要があります。

ネットワーク上のすべてのルータには、分類子の同一の定義と同一の順序が設定されています。

ネットワークで MTR のトラフィック分類と QoS のトラフィック分類を同時に設定する場合は、慎重に調整する必要があります。

制約事項

MTR 分類値は、トポロジごとに一意である必要があります。重複する値を設定しようとすると、エラー メッセージが生成されます。

トポロジがアクティブなポリシー マップによって参照されている場合、そのトポロジをシャットダウン ステートにすることはできません。

DSCP ビットのサブセットは、IP パケット ヘッダー内の分類値をエンコードするのに使用されます。特定の DSCP 値が予約されています。これらの DSCP 値は一般に、MTR に関係のない用途のルーティング ソフトウェア コンポーネント(OSPF、BFD、SNMP など)で使用されます。MTR 分類にこれらの値を使用すると、ルータの適切な動作が妨害されるおそれがあるので、使用しないでください。これらの値には、次のものが含まれます。

DSCP 48(cs6)

DSCP 16(cs2)

手順の概要

1. enable

2. configure terminal

3. class-map match-any class-map-name

4. match [ ip ] dscp dscp-value [ dscp-value dscp-value dscp-value dscp-value dscp-value dscp-value dscp-value ]

5. exit

6. policy-map type class-routing ipv4 unicast policy-map-name

7. class { class-name | class-default }

8. select-topology topology-name

9. exit

10. exit

11. global-address-family ipv4 [ multicast | unicast ]

12. service-policy type class-routing policy-map-name

13. end

14. show topology detail

15. show policy-map type class-routing ipv4 unicast [ interface [ interface-type interface-number ]]

16. show mtm table

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

class-map match-any class-map-name

 

Router(config)# class-map match-any VOICE-CLASS

指定したクラスとパケットをマッチングするために使用されるクラス マップを作成し、クラスマップ コンフィギュレーション モードを開始します。

MTR トラフィック クラスは、このコマンドを使用して定義します。

キーワードを入力する必要があります。

ステップ 4

match [ ip ] dscp dscp-value [ dscp-value
dscp-value dscp-value dscp-value dscp-value dscp-value dscp-value
]

 

Router(config-cmap)# match ip dscp 9

DSCP 値を一致基準として識別します。

dcsp-value 引数を使用して、特定のメトリック値を定義します。

DSCP 値 48 および 16 は使用しないでください。詳細については、「制約事項」を参照してください。

ステップ 5

exit

 

Router(config-cmap)# exit

クラスマップ コンフィギュレーション モードを終了します。

ステップ 6

policy-map type class-routing ipv4 unicast
policy-map-name

 

Router(config)# policy-map type class-routing ipv4 unicast VOICE-CLASS-POLICY

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または変更し、ポリシーマップ コンフィギュレーション モードを開始します。

type キーワード オプションを指定しないと、デフォルトで QoS ポリシーに設定されます。

ステップ 7

class { class-name | class-default }

 

Router(config-pmap)# class VOICE-CLASS

作成または変更するポリシーのクラス名を指定するか、デフォルト クラスを指定して、ポリシーマップ クラス コンフィギュレーション モードを開始します。

クラス マップが参照されます。

クラスルーティング ポリシー マップで参照されるクラス マップについては、ステップ 3 に示すとおり、 class-map コマンドで定義しておく必要があります。

ステップ 8

select-topology topology-name

 

Router(config-pmap-c)# select-topology VOICE

ポリシー マップをトポロジに付加します。

グローバル アドレス ファミリ コンフィギュレーション モードの topology コマンドで設定されるトポロジ名が参照されます。「MTR に対するユニキャスト トポロジの設定」のステップ 4 を参照してください。

ステップ 9

exit

 

Router(config-pmap-c)# exit

ポリシーマップ クラス コンフィギュレーション モードを終了します。

ステップ 10

exit

 

Router(config-pmap)# exit

ポリシーマップ コンフィギュレーション モードを終了します。

ステップ 11

global-address-family ipv4 [ multicast | unicast ]

 

Router(config)# global-address-family ipv4

MTR を設定するためにグローバル アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 12

service-policy type class-routing
policy-map-name

 

Router(config-af)# service-policy type class-routing VOICE-CLASS-POLICY

MTR トラフィック分類用のポリシー マップにサービス ポリシーを付加し、MTR をアクティブにします。

policy-map-name 引数は、ステップ 6 で設定した引数と一致する必要があります。

(注) このコマンドを入力した後、トラフィック分類がイネーブルになります。この重要なコマンドを入力する前に、トラフィック分類に影響するすべてのコンフィギュレーションが完了していることを確認してください。

ステップ 13

end

 

Router(config-af)# end

グローバル アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 14

show topology detail

 

Router# show topology detail

(任意)クラス固有のトポロジと基本トポロジの詳細情報を表示します。

ステップ 15

show policy-map type class-routing ipv4
unicast
[ interface [ interface-type
interface-number
]]

 

Router# show policy-map type class-routing ipv4 unicast

(任意)クラスルーティング ポリシー マップ コンフィギュレーションを表示します。

interface キーワードを引数なしで指定すると、グローバル空間のすべてのインターフェイスの統計情報が表示されます。

ステップ 16

show mtm table

 

Router# show mtm table

(任意)各トポロジに割り当てられる DSCP 値に関する情報を表示します。

この次の手順

次に、ルーティング プロトコル下で MTR サポートをイネーブルにする 4 つの作業を示します。「OSPF を使用した MTR トポロジのアクティブ化」に進み、ルーティング プロトコルのサポートをイネーブルにします。

OSPF を使用した MTR トポロジのアクティブ化

この作業は、MTR トポロジに対して OSPF を設定する場合に実行します。この作業には、MTR コマンドだけが示されています。

前提条件

MTR をサポートするために OSPF を使用する前に、「MTR に対するルーティング プロトコル サポート」に記載されている概念について十分に理解しておく必要があります。

グローバル トポロジ設定が行われ、アクティブになっています。

OSPF ルータ コンフィギュレーションを確認し、ルータ アドレス ファミリ コンフィギュレーション モードでトポロジ認識ルータ コンフィギュレーション コマンドを入力します。

いくつかの OSPF ルータ コンフィギュレーション コマンドがトポロジ認識である必要があります。OSPF MTR を設定する前に、これらのコマンドが元の OSPF ルータ コンフィギュレーションで使用されている場合は、ルータ アドレス ファミリ コンフィギュレーション モードでこれらのコマンドを入力する必要があります。

area area-id default-cost cost

area area-id filter-list prefix { prefix-list-name in | out }

area area-id nssa [ default-information-originate [ metric metric-number ] [ metric-type ]] | [ no-redistribution ] | [ no-summary ] [ metric ] [ metric-type ]] [ translate type7 suppress-fa ]

area area-id range ip-address mask [ advertise | not-advertise ] [ cost cost ]

area area-id stub [ no-summary ]

area transit-area-id virtual-link transit-router-id topology disable

default-information originate [ always ] [ metric metric-value ] [ metric-type type-value ] [ route-map map-name ]

default-metric metric-value

discard-route [ external | internal ]

distance ospf { external dist1 | inter-area dist2 | intra-area dist3 }

distribute-list in (IP)

distribute-list out (IP)

max-metric router-lsa [ on-startup { seconds | wait-for-bgp }]

maximum-paths maximum maximum-paths {[ number-of-paths ] [ import number-of-paths ] | [ import number-of-paths ]}

neighbor ip-address [ cost number ]

redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric { metric-value | transparent }] [ metric-type type-value ] [ match { external | internal | nssa-external }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

summary-address { ip-address mask | prefix mask } [ not-advertise ] [ tag tag ]

timers throttle spf spf-start spf-hold spf-max-wait

traffic-share min across-interfaces

手順の概要

1. enable

2. configure terminal

3. router ospf process-id [ vrf vrf-name ]

4. address-family ipv4 [ multicast | unicast ]

5. topology { base | topology-name tid number }

6. end

7. show ip ospf [ process-id ] topology-info [ multicast ] [ topology { topology-name | base }]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id [ vrf vrf-name ]

 

Router(config)# router ospf 1

OSPF ルーティング プロセスをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ multicast | unicast ]

 

Router(config-router)# address-family ipv4

ルータ アドレス ファミリ コンフィギュレーション モードを開始して、OSPF アドレス ファミリ セッションを設定します。

現在、マルチキャスト サブアドレス ファミリの下で設定できるのは、基本トポロジだけです。

ステップ 5

topology { base | topology-name tid number }

 

Router(config-router-af)# topology VOICE tid 10

トポロジに対する OSPF サポートを設定し、各トポロジに TID 番号を割り当てます。ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

tid キーワードと number 引数を使用して、トポロジ ID を設定します。トポロジ ID は、指定したトポロジの最初のコンフィギュレーションで設定する必要があります。後続のコンフィギュレーションについては、トポロジ ID の設定は任意です。

キーワードは、IPv4 または IPv6 ユニキャストに対してのみ指定できます。

ステップ 6

end

 

Router(config-router-af-topology)# end

ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 7

show ip ospf [ process-id ] topology-info [ multicast ] [ topology { topology-name | base }]

 

Router# show ip ospf topology-info topology VOICE

(任意)指定のトポロジに関する OSPF 情報を表示します。

この次の手順

EIGRP トポロジ コンフィギュレーションが必要な場合は、次の作業に進みます。IS-IS トポロジ コンフィギュレーションが必要な場合は、「IS-IS を使用した MTR トポロジのアクティブ化」に進みます。

EIGRP を使用した MTR トポロジのアクティブ化

この作業は、MTR トポロジに対して EIGRP を設定する場合に実行します。この作業には、MTR コマンドだけが示されています。

前提条件

MTR をサポートするために EIGRP を使用する前に、「MTR に対するルーティング プロトコル サポート」に記載されている概念について十分に理解しておく必要があります。

グローバル トポロジ設定が行われ、アクティブになっています。

制約事項

EIGRP のグレースフル リスタートは、基本トポロジにのみ機能します。その他のサービス トポロジはすべて、新規の隣接関係でリセットされます。

手順の概要

1. enable

2. configure terminal

3. router eigrp name

4. address-family ipv4 [ unicast | multicast | vrf vrf-name ] autonomous-system as-number

5. topology { base | topology-name tid number }

6. end

7. show ip protocols topology name [ summary ]

8. show ip eigrp topology name

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp name

 

Router(config)# router eigrp MTR

MTR に対して EIGRP プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

このコマンドは MTR を設定せずに使用できますが、デフォルトで基本トポロジに設定されます。

ステップ 4

address-family ipv4 [ unicast | multicast | vrf vrf-name ] autonomous-system as-number

 

Router(config-router)# address-family ipv4
autonomous-system 1

MTR に対して EIGRP を設定するには、ルータ アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 5

topology { base | topology-name tid number }

 

Router(config-router-af)# topology VIDEO tid 100

指定したトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

それぞれのトポロジは、固有のトポロジ ID を使用して設定する必要があります。このコマンドを入力するたびに、トポロジ ID を入力する必要があります。

ステップ 6

end

 

Router(config-router-af-topology)# end

ルータ アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 7

s how ip protocols topology name [ summary ]

 

Router# show ip protocols topology VIDEO

トポロジに設定されているルーティング プロトコルのステータスを表示します。

ヒント このコマンドを入力すると、設定されているルーティング プロトコルの、トポロジにおけるステータスを表示できます。

ステップ 8

show ip eigrp topology name

 

Router# show ip eigrp topology VIDEO

トポロジに設定されている EIGRP プロセスのルーティング テーブルを表示します。

この次の手順

IS-IS トポロジ コンフィギュレーションが必要な場合は、次の作業に進みます。BGP トポロジ コンフィギュレーションが必要な場合は、「BGP を使用した MTR トポロジのアクティブ化」に進みます。

IS-IS を使用した MTR トポロジのアクティブ化

MTR に IS-IS を設定するには、2 つの作業を実行する必要があります。IS-IS ルータで MTR トポロジをアクティブにする必要があります。また、 all-interfaces アドレス ファミリ トポロジ コンフィギュレーション コマンドを使用してすべてのインターフェイスをグローバルに設定するよう、MTR トポロジを設定するか、IS-IS インターフェイスだけを設定するよう、インターフェイス コンフィギュレーション モードで IS-IS トポロジを設定する必要があります。これらの作業を実行する順番は、重要ではありません。

この作業は、IS-IS ルータで MTR トポロジをイネーブルにして、IPv4 ユニキャストおよびマルチキャスト アドレス ファミリのサポートをイネーブルにする場合に実行します。この作業には、MTR コマンドだけが示されています。

前提条件

MTR をサポートするために IS-IS を使用する前に、「MTR に対するルーティング プロトコル サポート」に記載されている概念について十分に理解しておく必要があります。

グローバル トポロジ設定が行われ、アクティブになっています。

制約事項

IPv4 アドレス ファミリ(マルチキャストおよびユニキャスト)と IPv6 アドレス ファミリ ユニキャストだけがサポートされています。
IPv6 のマルチトポロジ IS-IS の設定については、『 Cisco IOS IPv6 Configuration Guide 』の「 Implementing IS-IS for IPv6 」モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. router isis [ area-tag ]

4. net network-entity-title

5. metric-style wide

6. address-family ipv4 [ multicast | unicast ]

7. topology topology-name tid number

8. end

9. show isis neighbors detail

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router isis [ area-tag ]

 

Router(config)# router isis

IS-IS ルーティング プロトコルをイネーブルにし、任意で IS-IS プロセスを指定します。ルータ コンフィギュレーション モードを開始します。

ステップ 4

net network-entity-title

 

Router(config-router)# net 31.3131.3131.3131.00

Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)ルーティング プロセスに対して IS-IS Network Entity Title(NET)を設定します。

ステップ 5

metric-style wide [ transition ] [ level-1 | level-2 | level-1-2 ]

 

Router(config-router)# metric-style wide

すべての IS-IS インターフェイスのメトリック値をグローバルに変更します。

(注) プレフィクス タギングには、ワイド形式のメトリックが必要です。

ステップ 6

address-family ipv4 [ multicast | unicast ]

 

Router(config-router)# address-family ipv4

IS-IS ルータ コンフィギュレーション モードの下でルータ アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 7

topology topology-name tid number

 

Router(config-router-af)# topology DATA tid 100

トポロジに対する IS-IS サポートを設定し、各トポロジに TID 番号を割り当てます。

DATA トポロジに対する IS-IS サポートが設定されます。

ステップ 8

end

 

Router(config-router-topology)# end

ルータ アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 9

show isis neighbors detail

 

Router# show isis neighbors detail

(任意)ルータとその IS-IS ネイバーの TID 値に関する MTR 情報を含む、IS-IS ネイバーの情報を表示します。

この次の手順

BGP トポロジ コンフィギュレーションが必要な場合は、「BGP を使用した MTR トポロジのアクティブ化」に進みます。

BGP を使用した MTR トポロジのアクティブ化

この作業は、BGP を使用してアドレス ファミリ内で MTR トポロジをアクティブにする場合に実行します。図 8 のルータ B で設定するこの作業は、ルータ D とルータ E でも設定する必要があります。この作業では、スコープ階層がグローバルに適用するよう設定され、ネイバーはルータ スコープ コンフィギュレーション モードで設定されます。IPv4 ユニキャスト アドレス ファミリでは、ビデオ トラフィックに適用される MTR トポロジは、指定されたネイバーについてアクティブにされます。BGP トポロジのインターフェイス コンフィギュレーション モードはありません。

図 8 BGP ネットワーク ダイアグラム

 

 

前提条件

MTR をサポートするために BGP を使用する前に、「MTR に対する BGP サポートに関する情報」(P.2)に記載されているすべての概念について十分に理解しておく必要があります。

グローバル MTR トポロジの設定が行われ、アクティブになっています。

制約事項

トポロジ内では再配布が可能です。あるトポロジから別のトポロジへの再配布はできません。この制限は、ルーティング ループを防ぐことを目的にしています。トポロジ変換またはトポロジ インポート機能を使用して、あるトポロジから別のトポロジにルートを移動できます。

単一のマルチキャスト トポロジだけを設定でき、マルチキャスト トポロジが作成される場合は基本トポロジだけを指定できます。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. scope { global | vrf vrf-name }

5. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

6. neighbor { ip-address | peer-group-name } transport { connection-mode { active | passive } | path-mtu-discovery | multi-session | single-session }

7. address-family ipv4 [ mdt | multicast | unicast ]

8. topology { base | topology-name }

9. bgp tid number

10. neighbor { ip-address } activate

11. neighbor { ip-address | peer-group-name } translate-topology number

12. end

13. clear ip bgp topology { * | topology-name } { as-number | dampening [ network-address [ network-mask ]] | flap-statistics [ network-address [ network-mask ]] | peer-group peer-group-name | table-map | update-group [ number | ip-address ]} [ in [ prefix-filter ] | out | soft [ in [ prefix-filter ] | out ]]

14. show ip bgp topology { * | topology-name } summary

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 45000

ルータ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成または設定します。

ステップ 4

scope { global | vrf vrf-name }

 

Router(config-router)# scope global

BGP ルーティング プロセスに対してスコープを定義して、ルータ スコープ コンフィギュレーション モードを開始します。

単一のネットワークに適用される BGP の一般的なセッション コマンドまたは指定された VRF が、このコンフィギュレーション モードで入力されます。

BGP がグローバル ルーティング テーブルを使用することを指定するには、 global キーワードを使用します。

BGP が特定の VRF ルーティング テーブルを使用することを指定するには、 vrf キーワードと vrf-name 引数を使用します。VRF がすでに存在している必要があります。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router-scope)# neighbor 172.16.1.2 remote-as 45000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータのマルチプロトコル BGP ネイバー テーブルに追加します。

ステップ 6

neighbor { ip-address | peer-group-name } transport { connection-mode { active | passive } | path-mtu-discovery | multi-session | single-session }

 

Router(config-router-scope)# neighbor 172.16.1.2 transport multi-session

BGP セッションの TCP 転送セッション オプションをイネーブルにします。

接続のタイプ(アクティブまたはパッシブのいずれか)を指定するには、 connection-mode キーワードを使用します。

TCP 転送パスの Maximum Transmission Unit(MTU; 最大伝送ユニット)検出をイネーブルにするには、 path-mtu-discovery キーワードを使用します。

アドレス ファミリごとに別個の TCP 転送セッションを指定するには、 multi-session キーワードを使用します。

すべてのアドレス ファミリが単一の TCP 転送セッションを使用することを指定するには、 single-session キーワードを使用します。

ステップ 7

address-family ipv4 [ mdt | multicast | unicast ]

 

Router(config-router-scope)# address-family ipv4

IPv4 アドレス ファミリを指定して、ルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始します。

IPv4 MDT アドレス プレフィクスを指定するには、 mdt キーワードを使用します。

IPv4 マルチキャスト アドレス プレフィクスを指定するには、 multicast キーワードを使用します。

IPv4 ユニキャスト アドレス ファミリを指定するには、 unicast キーワードを使用します。デフォルトでは、 address-family ipv4 コマンドに unicast キーワードが指定されていない場合、ルータは IPv4 ユニキャスト アドレス ファミリのアドレス ファミリ コンフィギュレーション モードになります。

トポロジに固有ではない設定パラメータは、このコンフィギュレーション モードで設定されます。

ステップ 8

topology { base | topology-name }

 

Router(config-router-scope-af)# topology VIDEO

BGP がクラス固有のトポロジまたは基本トポロジのトラフィックをルーティングするトポロジ インスタンスを設定し、ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 9

bgp tid number

 

Router(config-router-scope-af-topo)# bgp tid 100

BGP ルーティング プロセスを、指定されたトポロジ ID に関連付けます。

それぞれのトポロジは、固有のトポロジ ID を使用して設定する必要があります。

ステップ 10

neighbor ip-address activate

 

Router(config-router-scope-af-topo)# neighbor 172.16.1.2 activate

BGP ネイバーが、NSAP アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

(注) ピア グループを BGP ネイバーとして設定した場合は、このコマンドを使用しないでください。これは、ピア グループ パラメータの設定時にピア グループが自動的にアクティブにされるためです。

ステップ 11

neighbor { ip-address | peer-group-name }
translate-topology number

 

Router(config-router-scope-af-topo)# neighbor 172.16.1.2 translate-topology 200

(任意)別のルータ上のトポロジからローカル ルータ上のトポロジへのルートをインストールするよう BGP を設定します。

ルータ上のトポロジを識別するために、 number 引数にトポロジ ID を入力します。

ステップ 12

end

 

Router(config-router-scope-af-topo)# end

(任意)ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 13

clear ip bgp topology { * | topology-name } { as-number | dampening [ network-address [ network-mask ]] | flap-statistics [ network-address [ network-mask ]] | peer-group peer-group-name | table-map | update-group [ number | ip-address ]} [ in [ prefix-filter ] | out | soft [ in [ prefix-filter ] | out ]]

 

Router# clear ip bgp topology VIDEO 45000

指定されたトポロジまたはすべてのトポロジ下で BGP ネイバー セッションをリセットします。

ステップ 14

show ip bgp topology { * | topology } summary

 

Router# show ip bgp topology VIDEO summary

(任意)トポロジに関する BGP 情報を表示します。

ほとんどの標準の BGP キーワードと引数は、 topology キーワードの後に入力できます。

』を参照してください。

この次の手順

イネーブルにするトポロジごとにこの作業を繰り返して、トポロジを使用するすべてのネイバー ルータでこの設定を繰り返します。

同じルータ上のある MTR トポロジから別のトポロジにルートをインポートする場合は、「BGP を使用した MTR トポロジからのルートのインポート」に進みます。

BGP を使用した MTR トポロジからのルートのインポート

この作業は、複数のトポロジが同じルータで設定されている場合に、同じルータ上のある MTR トポロジから別のトポロジにルートをインポートする場合に実行します。この作業では、10.2.2.0 ネットワークからのプレフィクスを許可するためにプレフィクス リストが定義されます。このプレフィクス リストは、インポートされたトポロジから移動したルートをフィルタリングするために、ルート マップとともに使用されます。グローバル スコープが設定され、アドレス ファミリ IPv4 が入力されて、VIDEO トポロジが指定されます。また、VOICE トポロジがインポートされ、10NET という名前のルート マップを使用してルートがフィルタリングされます。

前提条件

グローバル トポロジ設定が行われ、アクティブになっています。

制約事項

トポロジ内では再配布が可能です。。あるトポロジから別のトポロジへの再配布はできません。この制限は、ルーティング ループの発生を防ぐことを目的にしています。トポロジ変換またはトポロジ インポート機能を使用して、あるトポロジから別のトポロジにルートを移動できます。

単一のマルチキャスト トポロジだけを設定でき、マルチキャスト トポロジが作成される場合は基本トポロジだけを指定できます。

手順の概要

1. enable

2. configure terminal

3. ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network/length } [ ge ge-value ] [ le le-value ]

4. route-map map-name [ permit | deny ] [ sequence-number ]

5. match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ... | access-list-name ] | prefix-list prefix-list-name [ prefix-list-name ...]}

6. exit

7. router bgp autonomous-system-number

8. scope { global | vrf vrf-name }

9. address-family ipv4 [ mdt | multicast | unicast ]

10. topology { base | topology-name }

11. import topology { base | topology-name } [ route-map map-name ]

12. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network / length } [ ge ge-value ] [ le le-value ]

 

Router(config)# ip prefix-list TEN permit 10.2.2.0/24

IP プレフィクス リストを設定します。

この例では、プレフィクス リスト TEN は、 match ip address コマンドによって設定されたマッチングに応じて、10.2.2.0/24 プレフィクスのアドバタイズを許可します。

ステップ 4

route-map map-name [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map 10NET

ルート マップを作成し、ルート マップ コンフィギュレーション モードを開始します。

この例では、10NET という名前のルート マップが作成されます。

ステップ 5

match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ...| access-list-name ] | prefix-list prefix-list-name [ prefix-list-name ...]}

 

Router(config-route-map)# match ip address prefix-list TEN

標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストにより許可されているプレフィクスと一致するルート マップを作成します。

この例では、ルート マップは、プレフィクス リスト TEN によって許可されるプレフィクスのマッチングを行うよう設定されます。

ステップ 6

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

router bgp autonomous-system-number

 

Router(config)# router bgp 50000

ルータ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成または設定します。

ステップ 8

scope { global | vrf vrf-name }

 

Router(config-router)# scope global

BGP ルーティング プロセスに対してスコープを定義して、ルータ スコープ コンフィギュレーション モードを開始します。

単一のネットワークに適用される BGP の一般的なセッション コマンドまたは指定された VRF が、このコンフィギュレーション モードで入力されます。

BGP がグローバル ルーティング テーブルを使用することを指定するには、 global キーワードを使用します。

BGP が特定の VRF ルーティング テーブルを使用することを指定するには、 vrf キーワードと vrf-name 引数を使用します。VRF がすでに存在している必要があります。

ステップ 9

address-family ipv4 [ mdt | multicast | unicast ]

 

Router(config-router-scope)# address-family ipv4

ルータ スコープ アドレス ファミリ コンフィギュレーション モードを開始して、BGP 下でアドレス ファミリ セッションを設定します。

トポロジに固有ではない設定パラメータは、このコンフィギュレーション モードで設定されます。

ステップ 10

topology { base | topology-name }

 

Router(config-router-scope-af)# topology VIDEO

BGP がクラス固有のトポロジまたは基本トポロジのトラフィックをルーティングするトポロジ インスタンスを設定し、ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 11

import topology { base | topology-name } [ route-map map-name ]

 

Router(config-router-scope-af-topo)# import
topology VOICE route-map 10NET

(任意)同じルータ上のあるトポロジから別のトポロジにルートを移動するよう BGP を設定します。

トポロジ間で移動するルートをフィルタリングするには、 route-map キーワードを使用できます。

ステップ 12

end

 

Router(config-router-scope-af-topo)# end

(任意)ルータ スコープ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

インターフェイス コンフィギュレーション モードでの MTR トポロジの設定

この作業は、インターフェイス コンフィギュレーション モードで MTR トポロジを設定する場合に実行します。インターフェイス コンフィギュレーション モードで MTR トポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにできます。デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

前提条件

インターフェイス単位でトポロジを設定するには、トポロジをグローバルに定義しておく必要があります。

制約事項

設計上、基本トポロジからインターフェイスを除外することはできません。ただし、基本トポロジ コンフィギュレーションでインターフェイスから IGP を除外することはできます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. topology ipv4 [ multicast | unicast ] { topology-name [ disable ] | base }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 0/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

topology ipv4 [ multicast | unicast ] { topology-name [ disable ] | base }

 

Router(config-if)# topology ipv4 VOICE

インターフェイス トポロジ コンフィギュレーション モードを開始して、インターフェイスに MTR トポロジ インスタンスを設定します。

disable キーワードを使用して、インターフェイスでトポロジ インスタンスをディセーブルにします。インターフェイスからトポロジ コンフィギュレーションを除外するには、この形式を使用します。

このコマンドの no 形式を使用すると、トポロジ インターフェイス コンフィギュレーションが削除されます。

このコマンドの no 形式と disable キーワードを使用すると、トポロジ インスタンスがインターフェイスでイネーブルになります。

ステップ 5

end

 

Router(config-if-topology)# end

インターフェイス トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

インターフェイス コンフィギュレーション モードでの OSPF を使用した MTR トポロジのアクティブ化

この作業は、インターフェイス コンフィギュレーション モードで MTR に使用する OSPF 機能を設定する場合に実行します。インターフェイス コンフィギュレーション モードでトポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにすることができます。デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

前提条件

インターフェイス単位でトポロジを設定するには、トポロジをグローバルに定義しておく必要があります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. topology ipv4 [ multicast | unicast ] { topology-name [ disable ] | base }

5. ip ospf cost number

6. ip ospf topology disable

7. end

8. show ip ospf [ process-id ] interface [ interface-type interface-number ] [ brief ] [ multicast ] [ topology { topology-name | base }]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 0/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

topology ipv4 [ multicast | unicast ]
{ topology-name [ disable ] | base }

 

Router(config-if)# topology ipv4 VOICE

インターフェイス トポロジ コンフィギュレーション モードを開始して、MTR を設定します。

キーワードを指定すると、トポロジ インスタンスがインターフェイスでディセーブルになります。インターフェイスからトポロジ コンフィギュレーションを除外するには、この形式を使用します。

ステップ 5

ip ospf cost number

 

Router(config-if-topology)# ip ospf cost 100

トポロジ インスタンスでインターフェイスにコストを適用します。

最低のコスト数値の優先度が、最も高くなります。

ステップ 6

ip ospf topology disable

 

Router(config-if-topology)# ip ospf topology disable

インターフェイスで OSPF プロセスやトポロジをディセーブルにせずに、OSPF がインターフェイスをトポロジの一部としてアドバタイズしないようにします。

ステップ 7

end

 

Router(config-if-topology)# end

インターフェイス トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 8

show ip ospf [ process-id ] interface
[ interface-type interface-number ] [ brief ]
[ multicast ] [ topology { topology-name | base }]

 

Router# show ip ospf 1 interface topology VOICE

(任意)OSPF 関連のインターフェイス情報を表示します。

topology キーワードを入力すると、指定したトポロジに関する OSPF およびインターフェイスの情報が表示されます。

インターフェイス コンフィギュレーション モードでの EIGRP を使用した MTR トポロジのアクティブ化

この作業は、インターフェイス コンフィギュレーション モードで MTR に使用する EIGRP 機能を設定する場合に実行します。インターフェイス コンフィギュレーション モードでトポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにすることができます。デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. topology ipv4 [ multicast | unicast ] { topology-name [ disable ] | base }

5. eigrp as-number delay value

6. eigrp as-number next-hop-self

7. eigrp as-number shutdown

8. eigrp as-number split-horizon

9. eigrp as-number summary-address ip-address wildcard-mask [ distance ]

10. end

11. show ip eigrp topology name interfaces

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 0/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

topology ipv4 [ multicast | unicast ]
{ topology-name [ disable ] | base }

 

Router(config-if)# topology ipv4 VOICE

インターフェイスに MTR トポロジ インスタンスを設定し、インターフェイス トポロジ コンフィギュレーション モードを開始します。

キーワードを指定すると、トポロジ インスタンスがインターフェイスでディセーブルになります。インターフェイスからトポロジ コンフィギュレーションを除外するには、この形式を使用します。

ステップ 5

eigrp as-number delay value

 

Router(config-if-topology)# eigrp 1 delay 100000

EIGRP がインターフェイス メトリック計算に使用する遅延値を設定します。

value 引数は、マイクロ秒単位で入力します。例では、インターフェイス遅延メトリックが 100 ミリ秒に設定されています。

ステップ 6

eigrp as-number next-hop-self

 

Router(config-if-topology)# eigrp 1 next-hop-self

EIGRP プロセスがそれ自体をネクスト ホップとしてアドバタイズするように設定します。

このコマンドは、デフォルトでイネーブルになります。

ステップ 7

eigrp as-number shutdown

 

Router(config-if-topology)# eigrp 1 shutdown

インターフェイスでグローバル トポロジ コンフィギュレーションをディセーブルにせずに、インターフェイスで EIGRP プロセスをディセーブルにします。

ステップ 8

eigrp as-number split-horizon

 

Router(config-if-topology)# eigrp 1
split-horizon

スプリット ホライズンを使用するように、EIGRP プロセスを設定します。

このコマンドは、デフォルトでイネーブルになります。

ステップ 9

eigrp as-number summary-address ip-address wildcard-mask [ distance ]

 

Router(config-if-topology)# eigrp 1
summary-address 10.1.1.0 0.0.0.255

EIGRP サマリー アドレスを設定します。

管理ディスタンスが指定されていない場合は、ディスタンス 5 が EIGRP サマリー ルートに適用されます。

ステップ 10

end

 

Router(config-if-topology)# end

インターフェイス トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 11

show ip eigrp topology name interfaces

 

Router# show ip eigrp topology VOICE interfaces

EIGRP が設定される、トポロジ内のインターフェイスに関する情報を表示します。

インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化

この作業は、インターフェイス コンフィギュレーション モードで MTR に使用する IS-IS 機能を設定する場合に実行します。インターフェイス コンフィギュレーション モードでトポロジを設定すると、インターフェイス単位で MTR をイネーブルまたはディセーブルにすることができます。デフォルトでは、クラス固有のトポロジにはインターフェイスは含まれません。

前提条件

インターフェイス単位でトポロジを設定するには、トポロジをグローバルに定義しておく必要があります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask [ secondary ]

5. ip router isis area-tag

6. topology ipv4 [ multicast | unicast ] { topology-name [ disable | base ]}

7. isis topology disable

8. topology ipv4 [ multicast | unicast ] { topology-name [ disable | base ]}

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 2/0

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.7.17 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

ip router isis [ area-tag ]

 

Router(config-if)# ip router isis

インターフェイス上で IP の IS-IS ルーティング プロセスを設定して、エリア指示子をルーティング プロセスに添付します。

(注) タグが指定されていない場合、ヌル タグと想定され、プロセスがヌル タグで参照されます。

ステップ 6

topology ipv4 [ multicast | unicast ] { topology-name [ disable | base ]}

 

Router(config-if)# topology ipv4 DATA

インターフェイスに MTR トポロジ インスタンスを設定し、インターフェイス トポロジ コンフィギュレーション モードを開始します。

(注) この例では、DATA というグローバル トポロジを持つ MTR ネットワークに対して、トポロジ インスタンス DATA が設定されます。

ステップ 7

isis topology disable

 

Router(config-if-topology)# isis topology
disable

(任意)IS-IS プロセスが、トポロジの一部としてインターフェイスをアドバタイズしないようにします。

(注) この例では、トポロジ インスタンス DATA は、トポロジの一部としてインターフェイスをアドバタイズしません。

ステップ 8

topology ipv4 [ multicast | unicast ] { topology-name [ disable | base ]}

 

Router(config-if-topology)# topology ipv4 VOICE

インターフェイス上で MTR トポロジ インスタンスを設定します。

(注) この例では、「VOICE」というグローバル トポロジを持つ MTR ネットワークに対して、トポロジ インスタンス VOICE が設定されます。

ステップ 9

end

 

Router(config-if-topology)# end

インターフェイス トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MTR 用の SNMP コンテキストと VRF の関連付け

この作業は、MTR 用に SNMP コンテキストと VRF を関連付ける場合に実行します。コンテキスト文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

前提条件

ルータで SNMP がイネーブルになっている必要があります。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. snmp context context-name

5. end

6. show snmp context mapping

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vrfA

VRF インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

ステップ 4

snmp context context-name

 

Router(config-vrf)# snmp context context-vrfA

特定の VRF に対して MTR 用の SNMP コンテキストを作成します。

ステップ 5

end

 

Router(config-af-topology)# end

VRF コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 6

show snmp context mapping

 

Router# show snmp context mapping

(任意)MTR 用の SNMP コンテキストに関する情報を表示します。

MTR 用の SNMP コンテキストとデータ トポロジの関連付け

この作業は、MTR 用に SNMP コンテキストとデータ トポロジを関連付ける場合に実行します。コンテキスト文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

前提条件

SNMP がイネーブルである必要があります。

手順の概要

1. enable

2. configure terminal

3. global-address-family ipv4 [ multicast | unicast ]

4. topology { base | topology-name }

5. snmp context context-name

6. end

7. show snmp context mapping

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

global-address-family ipv4 [ multicast |
unicast ]

 

Router(config)# global-address-family ipv4

グローバル アドレス ファミリ基本トポロジ コンフィギュレーション モードを開始して、グローバル トポロジを設定します。

クラス固有のトポロジに対するアドレス ファミリは、このステップで指定します。サブアドレス ファミリは、任意で指定できます。ユニキャストは、サブアドレス ファミリが入力されていない場合のデフォルトです。

ステップ 4

topology { base | topology-name }

 

Router(config-af)# topology VOICE

グローバル トポロジ インスタンスを設定し、ルーティング トポロジ コンフィギュレーション モードを開始します。

ステップ 5

snmp context context-name

 

Router(config-af-topology)# snmp context comp-topol

特定のトポロジに対して MTR 用の SNMP コンテキストを作成します。

ステップ 6

end

 

Router(config-af-topology)# end

ルーティング トポロジ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 7

show snmp context mapping

 

Router# show snmp context mapping

(任意)MTR 用の SNMP コンテキストに関する情報を表示します。

MTR 用の SNMP コンテキストとルーティング プロトコルの関連付け

この作業は、MTR 用に SNMP コンテキストとルーティング プロトコルを関連付ける場合に実行します。コンテキスト文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

前提条件

SNMP がイネーブルである必要があります。

手順の概要

1. enable

2. configure terminal

3. router ospf process-id [ vrf vrf-name ]

4. snmp context context-name

5. address-family ipv4 [ multicast | unicast ]

6. topology { base | topology-name tid number }

7. snmp context context-name

8. end

9. show snmp context mapping

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id [ vrf vrf-name ]

 

Router(config)# router ospf 1

OSPF ルーティング プロセスをイネーブルにして、ルータ コンフィギュレーション モードを開始します。

複数のルーティング プロトコルに対するサポートを設定できます。

ステップ 4

snmp context context-name

 

Router(config-router)# snmp context comp-prot

ルーティング プロトコル下で特定のトポロジに対して MTR 用の SNMP コンテキストを作成します。

ステップ 5

address-family ipv4 [ multicast | unicast ]

 

Router(config-router)# address-family ipv4

グローバル アドレス ファミリ コンフィギュレーション モードを開始して、OSPF アドレス ファミリ セッションを設定します。

ステップ 6

topology { base | topology-name tid number }

 

Router(config-router-af)# topology VOICE tid 10

グローバル トポロジ インスタンスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 7

snmp context context-name

 

Router(config-router-af-topology)# snmp context comp-protocol

ルーティング プロトコル下で特定のトポロジに対して MTR 用の SNMP コンテキストを作成します。

ステップ 8

end

 

Router(config-router-af-topology)# end

ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 9

show snmp context mapping

 

Router# show snmp context mapping

(任意)MTR 用の SNMP コンテキストに関する情報を表示します。

MTR に対するトポロジ統計情報アカウンティングのイネーブル化

この作業は、デフォルトの VRF インスタンスにおけるすべての IPv4 ユニキャスト トポロジについて、グローバル アドレス ファミリのすべてのインターフェイスでトポロジ統計情報アカウンティングをイネーブルにする場合、および、指定したインターフェイスに関連付けられた VRF インスタンスにおけるすべての IPv4 ユニキャスト トポロジについてトポロジ アカウンティングをイネーブルする場合に実行します。

前提条件

CEF がイネーブルである必要があります。

手順の概要

1. enable

2. configure terminal

3. global-address-family ipv4 [ multicast | unicast ]

4. topology-accounting

5. exit

6. interface type number

7. ip topology-accounting

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

global-address-family ipv4 [ multicast |
unicast ]

 

Router(config)# global-address-family ipv4

グローバル アドレス ファミリ コンフィギュレーション モードを開始します。

ステップ 4

topology accounting

 

Router(config-af)# topology accounting

デフォルトの VRF インスタンスにおけるすべての IPv4 ユニキャスト トポロジについて、グローバル アドレス ファミリのすべてのインターフェイスでトポロジ アカウンティングをイネーブルにします。

ステップ 5

exit

 

Router(config-af)# exit

グローバル アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 6

interface type number

 

Router(config)# interface FastEthernet 1/10

インターフェイスのタイプおよび番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

ip topology-accounting

 

Router(config-if)# ip topology-accounting

指定したインターフェイスに関連付けられた VPN VRF におけるすべての IPv4 ユニキャスト トポロジについて、トポロジ アカウンティングをイネーブルにします。

このトポロジ アカウンティングは、デフォルトの VRF に対してのみサポートされています。

ステップ 8

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MTR に関するインターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング

この作業は、MTR に関するインターフェイスおよびトポロジ IP トラフィック統計情報をモニタする場合に実行します。

手順の概要

1. enable

2. show ip interface [ type number ] [ topology { name | all | base }] [ stats ]

3. show ip traffic [ topology { name | all | base }]

4. clear ip interface type number [ topology { name | all | base }] [ stats ]

5. clear ip traffic [ topology { name | all | base}]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip interface [ type number ] [ topology { name | all | base }] [ stats ]

 

Router# show ip interface FastEthernet 1/10 stats

(任意)すべてのインターフェイスに関する IP トラフィック統計情報、または指定したインターフェイスに関係する統計情報を表示します。

インターフェイスのタイプと番号を指定すると、その特定のインターフェイスに関する情報が表示されます。省略可能な引数を指定しない場合は、すべてのインターフェイスに関する情報が表示されます。

topology name キーワードと引数を使用すると、統計情報はその特定のトポロジの IP トラフィックに制限されます。

base キーワードは、IPv4 ユニキャスト基本トポロジ専用です。

ステップ 3

show ip traffic [ topology { name | all | base }]

 

Router# show ip traffic topology VOICE

(任意)グローバル IP トラフィック統計情報(MTR がイネーブルである場合のすべてのトポロジの集約)または、特定のトポロジに関する統計情報を表示します。

base キーワードは、IPv4 ユニキャスト基本トポロジ専用です。

ステップ 4

clear ip interface type number [ topology { name | all | base }] [ stats ]

 

Router# clear ip interface FastEthernet 1/10 topology all

(任意)インターフェイスレベルの IP トラフィック統計情報をリセットします。

topology キーワードおよび関連するキーワードを使用しないと、インターフェイスレベルの集約統計情報だけがリセットされます。

すべてのトポロジをリセットする必要がある場合は、トポロジ名として all キーワードを使用します。

ステップ 5

clear ip traffic [ topology { name | all | base }]

 

Router# clear ip traffic topology all

(任意)IP トラフィック統計情報をリセットします。

トポロジ名を指定しないと、グローバル統計情報がクリアされます。

MTR のネットワーク接続テスト

この作業は、MTR のネットワーク接続をテストする場合に実行します。標準または拡張 ping は、ホスト名や IP アドレスの代わりにトポロジ名を使用して設定できます。traceroute も同様に拡張されています。

手順の概要

1. enable

2. ping [ vrf vrf-name | topology topology-name ] protocol [ target-address ] [ source-address ]

3. traceroute [ vrf vrf-name | topology topology-name ] [ protocol ] destination

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

ping [ vrf vrf-name | topology topology-name ] protocol [ target-address ] [ source-address ]

 

Router# ping topology VOICE

ping メッセージをトポロジ内のターゲット ホストに送信するように、ルータを設定します。

拡張 ping を設定するには、このコマンドにトポロジ名を指定するだけです。

ステップ 3

traceroute [ vrf vrf-name | topology topology-name ] [ protocol ] destination

 

Router# traceroute VOICE

トポロジ内の指定のホストをトレースするように、ルータを設定します。

拡張トレースを設定するには、このコマンドにトポロジ名を指定するだけです。

vrf vrf-name キーワードと引数を使用した場合、デフォルト VRF しかサポートされないため、 topology オプションは表示されません。ルータにトポロジが設定されている場合に限り、拡張 traceroute システム ダイアログに topology topology-name キーワードと引数、および DSCP オプションが表示されます。

マルチトポロジ ルーティングの設定例

「例:MTR のユニキャスト トポロジ」

「例:MTR のマルチキャスト トポロジ」

「例:MTR のトラフィック分類」

「例:OSPF を使用した MTR トポロジのアクティブ化」

「例:EIGRP を使用した MTR トポロジのアクティブ化」

「例:IS-IS を使用した MTR トポロジのアクティブ化」

「例:BGP を使用した MTR トポロジのアクティブ化」

「例:BGP を使用した MTR トポロジからのルートのインポート」

「例:インターフェイス コンフィギュレーション モードでの MTR トポロジ」

「例:インターフェイス コンフィギュレーション モードでの MTR OSPF トポロジ」

「例:インターフェイス コンフィギュレーション モードでの MTR EIGRP トポロジ」

「例:インターフェイス コンフィギュレーション モードでの MTR IS-IS トポロジ」

「MTR に対する SNMP サポート」

「例:インターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング」

「例:MTR のネットワーク接続テスト」

例:グローバル インターフェイス コンフィギュレーション

次に、VOICE というトポロジ インスタンスを作成する例を示します。このトポロジは、ルータ上の動作可能なすべてのインターフェイスを使用するように設定されます。デフォルトの転送ルール(厳密モード)によって、VOICE トポロジ RIB 内のルートを宛先とするパケットだけが転送されます。トポロジ固有の転送エントリを持たないパケットはドロップされます。

global-address-family ipv4
topology VOICE
all-interfaces
end

例:逐次転送設定

次に、VIDEO というトポロジ インスタンスを作成する例を示します。このトポロジは、最大 1000 個のルートを許可し、VIDEO トポロジ RIB にインストールするように設定されます。逐次転送モードを設定すると、クラス固有の RIB に転送エントリが見つからない場合に、ルータは基本トポロジでパケットを転送します。

global-address-family ipv4
topology VIDEO
forward-base
maximum routes 1000 90
end

例:ユニキャスト トポロジの確認

show topology detail コマンドの出力は、クラス固有のトポロジおよび基本トポロジに関する情報を示しています。この情報には、アドレス ファミリ、関連付けられたインターフェイス、インターフェイスとトポロジのステータス、トポロジ名、および関連付けられた VRF が含まれます。

Router# show topology detail
 
Topology: base
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
 
Topology: VIDEO
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology fallback is enabled
Topology maximum route limit 1000, warning limit 90% (900)
Associated interfaces:
 
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology is enabled on all interfaces
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
 
Topology: base
Address-family: ipv4 multicast
Associated VPN VRF is default
Topology state is DOWN
Route Replication Enabled:
from unicast all
Associated interfaces:

例:ルート複製コンフィギュレーション

次に、MTR に対するマルチキャスト サポートをイネーブルにし、別個のマルチキャスト トポロジを設定する例を示します。

ip multicast-routing
ip multicast rpf multitopology
!
global-address-family ipv4 multicast
topology base
end
 

次に、VOICE トポロジから OSPF ルートを複製するようにマルチキャスト トポロジを設定する例を示します。ルートは、マルチキャスト ルーティング テーブルにインストールされる前に、BLUE ルート マップを通じてフィルタリングされます。

ip multicast-routing
ip multicast rpf multitopology
!
access-list 1 permit 192.168.1.0 0.0.0.255
!
route-map BLUE
match ip address 1
exit
!
global-address-family ipv4 multicast
topology base
route-replicate from unicast topology VOICE ospf route-map BLUE

例:マルチキャスト RPF コンフィギュレーションに対するユニキャスト RIB の使用

次に、マルチキャスト配信ツリーを構築するために VIDEO トポロジ RIB のルートに対して RPF 計算を実行するよう、マルチキャスト トポロジを設定する例を示します。

ip multicast-routing
ip multicast rpf multitopology
!
global-address-family ipv4 multicast
topology base
use-topology unicast VIDEO
end

例:マルチキャストの確認

次に、VOICE トポロジの RIB からルートを複製するように、マルチキャスト トポロジを設定する例を示します。

Router# show topology detail
 
Topology: base
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
Topology: VIDEO
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology fallback is enabled
Topology maximum route limit 1000, warning limit 90% (900)
Associated interfaces:
 
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology is enabled on all interfaces
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
 
Topology: base
Address-family: ipv4 multicast
Associated VPN VRF is default
Topology state is DOWN
Multicast multi-topology mode is enabled.
Route Replication Enabled:
from unicast topology VOICE all route-map BLUE
Associated interfaces:

例:MTR のトラフィック分類

次に、2 つのトポロジに対して分類を設定し、MTR をアクティブにする例を示します。

global-address-family ipv4
topology VOICE
all-interfaces
exit
topology VIDEO
forward-base
maximum routes 1000 90
exit
exit
class-map match-any VOICE-CLASS
match ip dscp 9
exit
class-map match-any VIDEO-CLASS
match ip dscp af11
exit
policy-map type class-routing ipv4 unicast MTR
class VOICE-CLASS
select-topology VOICE
exit
class VIDEO-CLASS
select-topology VIDEO
exit
exit
global-address-family ipv4
service-policy type class-routing MTR
end
 

次に、VOICE トポロジおよび VIDEO トポロジの詳細を表示する例を示します。

Router# show topology detail
 
Topology: base
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
Topology: VIDEO
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology fallback is enabled
Topology maximum route limit 1000, warning limit 90% (900)
Associated interfaces:
 
Topology: VOICE
Address-family: ipv4
Associated VPN VRF is default
Topology state is UP
Topology is enabled on all interfaces
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
 
Topology: base
Address-family: ipv4 multicast
Associated VPN VRF is default
Topology state is DOWN
Multicast multi-topology mode is enabled.
Route Replication Enabled:
from unicast topology VOICE all route-map BLUE
Associated interfaces:
Ethernet0/0, operation state: UP
Ethernet0/1, operation state: DOWN
Ethernet0/2, operation state: DOWN
Ethernet0/3, operation state: DOWN
Loopback0, operation state: UP
 

次に、VOICE トポロジおよび VIDEO トポロジの分類値を表示する例を示します。

Router# show mtm table
 
MTM Table for VRF: default, ID:0
 
Topology Address Family Associated VRF Topo-ID
 
base ipv4 default 0
 
VOICE ipv4 default 2051
Classifier: ClassID:3
DSCP: cs1
DSCP: 9
 
VIDEO ipv4 default 2054
Classifier: ClassID:4
DSCP: af11

例:OSPF を使用した MTR トポロジのアクティブ化

次に、OSPF ルーティング プロセスに VOICE トポロジを設定し、VOICE トポロジに最も高いプライオリティを設定する例を示します。

router ospf 1
address-family ipv4
topology VOICE tid 10
priority 127
end
 

次の例では、 show ip ospf コマンドを topology-info キーワードおよび topology キーワードを指定して使用することで、VOICE というトポロジに関する OSPF 情報を表示しています。

Router# show ip ospf 1 topology-info topology VOICE
 
OSPF Router with ID (10.0.0.1) (Process ID 1)
 
VOICE Topology (MTID 66)
 
Topology priority is 64
Redistributing External Routes from,
isis
Number of areas transit capable is 0
Initial SPF schedule delay 5000 msecs
Minimum hold time between two consecutive SPFs 10000 msecs
Maximum wait time between two consecutive SPFs 10000 msecs
Area BACKBONE(0) (Inactive)
SPF algorithm last executed 16:45:18.984 ago
SPF algorithm executed 3 times
Area ranges are
Area 1
SPF algorithm last executed 00:00:21.584 ago
SPF algorithm executed 1 times
Area ranges are

例:EIGRP を使用した MTR トポロジのアクティブ化

次に、EIGRP を使用して VIDEO トポロジをアクティブにする例を示します。

router eigrp MTR
address-family ipv4 autonomous-system 1
network 10.0.0.0 0.0.0.255
topology VIDEO tid 10
redistribute connected
end
 

次に、VIDEO トポロジに設定されたルーティング プロトコルのステータスを表示する例を示します。EIGRP の情報が出力に表示されます。

Router# show ip protocols topology VIDEO
 
*** IP Routing is NSF aware ***
 
Routing Protocol is "eigrp 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Default networks flagged in outgoing updates
Default networks accepted from incoming updates
EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
EIGRP maximum hopcount 100
EIGRP maximum metric variance 1
Redistributing: eigrp 1
EIGRP graceful-restart disabled
EIGRP NSF-aware route hold timer is 240s
Topologies : 100(VOICE) 0(base)
 
Automatic network summarization is in effect
Maximum path: 4
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
Distance: internal 90 external 170
 

次に、VIDEO トポロジに設定されている EIGRP ルーティング テーブルを表示する例を示します。

Router# show ip eigrp topology VIDEO
 
EIGRP-IPv4 Topology Table for AS(1)/ID(10.1.1.2) Routing Table: VOICE
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
 
P 10.1.1.0/24, 1 successors, FD is 281600
via Connected, Ethernet0/0

例:IS-IS を使用した MTR トポロジのアクティブ化

次に、MTR トポロジの DATA および VIDEO と、MTR に対する IS-IS サポートの両方を設定する例を示します。DATA トポロジと VIDEO トポロジは、ネットワーク内の 3 つの IS-IS ネイバーでイネーブルになります。

ルータ 1

global-address-family ipv4
topology DATA
topology VOICE
end
 
interface Ethernet 0/0
ip address 192.168.128.2 255.255.255.0
ip router isis
topology ipv4 DATA
isis topology disable
topology ipv4 VOICE
end
 
router isis
net 33.3333.3333.3333.00
metric-style wide
address-family ipv4
topology DATA tid 100
topology VOICE tid 200
end

ルータ 2

global-address-family ipv4
topology DATA
topology VOICE
all-interfaces
forward-base
maximum routes 1000 warning-only
shutdown
end
 
interface Ethernet 0/0
ip address 192.168.128.1 255.255.255.0
ip router isis
topology ipv4 DATA
isis topology disable
topology ipv4 VOICE
end
 
interface Ethernet 1/0
ip address 192.168.130.1 255.255.255.0
ip router isis
topology ipv4 DATA
isis topology disable
topology ipv4 VOICE
end
 
router isis
net 32.3232.3232.3232.00
metric-style wide
address-family ipv4
topology DATA tid 100
topology VOICE tid 200
end

ルータ 3

global-address-family ipv4
topology DATA
topology VOICE
all-interfaces
forward-base
maximum routes 1000 warning-only
shutdown
end
 
interface Ethernet 1/0
ip address 192.168.131.1 255.255.255.0
ip router isis
topology ipv4 DATA
isis topology disable
topology ipv4 VOICE
end
 
router isis
net 31.3131.3131.3131.00
metric-style wide
address-family ipv4
topology DATA tid 100
topology VOICE tid 200
end
 

show isis neighbors detail コマンドを入力すると、IS-IS ネイバー ルータ 1 を使用したトポロジ変換を確認できます。

Router# show isis neighbors detail
 
System Id Type Interface IP Address State Holdtime Circuit Id
R1 L2 Et0/0 192.168.128.2 UP 28 R5.01
Area Address(es): 33
SNPA: aabb.cc00.1f00
State Changed: 00:07:05
LAN Priority: 64
Format: Phase V
Remote TID: 100, 200
Local TID: 100, 200

例:BGP トポロジ変換コンフィギュレーション

次に、VIDEO トポロジに BGP を設定し、192.168.2.2 ネイバーを使用してトポロジ変換を設定する例を示します。

router bgp 45000
scope global
neighbor 172.16.1.1 remote-as 50000
neighbor 192.168.2.2 remote-as 55000
neighbor 172.16.1.1 transport multi-session
neighbor 192.168.2.2 transport multi-session
address-family ipv4
topology VIDEO
bgp tid 100
neighbor 172.16.1.1 activate
neighbor 192.168.2.2 activate
neighbor 192.168.2.2 translate-topology 200
end
clear ip bgp topology VIDEO 50000

例:BGP スコープのグローバルおよび VRF コンフィギュレーション

次に、ユニキャスト トポロジとマルチキャスト トポロジのグローバル スコープを設定する例を示します。ルータ スコープ コンフィギュレーション モードの終了後に、DATA という名前の VRF についてスコープが設定されます。

router bgp 45000
scope global
bgp default ipv4-unicast
neighbor 172.16.1.2 remote-as 45000
neighbor 192.168.3.2 remote-as 50000
address-family ipv4 unicast
topology VOICE
bgp tid 100
neighbor 172.16.1.2 activate
exit
address-family ipv4 multicast
topology base
neighbor 192.168.3.2 activate
exit
exit
exit
scope vrf DATA
neighbor 192.168.1.2 remote-as 40000
address-family ipv4
neighbor 192.168.1.2 activate
end

例:BGP トポロジの確認

次に、 show ip bgp topology コマンドのサマリー出力の例を示します。VIDEO という名前の MTR トポロジを使用するよう設定された BGP ネイバーに関する情報が表示されます。

Router# show ip bgp topology VIDEO summary
 
BGP router identifier 192.168.3.1, local AS number 45000
BGP table version is 1, main routing table version 1
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
172.16.1.2 4 45000 289 289 1 0 0 04:48:44 0
192.168.3.2 4 50000 3 3 1 0 0 00:00:27 0
 

次の部分的な出力には、VIDEO トポロジ下に BGP ネイバー情報が表示されます。

Router# show ip bgp topology VIDEO neighbors 172.16.1.2
 
BGP neighbor is 172.16.1.2, remote AS 45000, internal link
BGP version 4, remote router ID 192.168.2.1
BGP state = Established, up for 04:56:30
Last read 00:00:23, last write 00:00:21, hold time is 180, keepalive interval is 60
seconds
Neighbor sessions:
1 active, is multisession capable
Neighbor capabilities:
Route refresh: advertised and received(new)
Message statistics, state Established:
InQ depth is 0
OutQ depth is 0
Sent Rcvd
Opens: 1 1
Notifications: 0 0
Updates: 0 0
Keepalives: 296 296
Route Refresh: 0 0
Total: 297 297
Default minimum time between advertisement runs is 0 seconds
 
For address family: IPv4 Unicast topology VIDEO
Session: 172.16.1.2 session 1
BGP table version 1, neighbor version 1/0
Output queue size : 0
Index 1, Offset 0, Mask 0x2
1 update-group member
Topology identifier: 100
.
.
.
Address tracking is enabled, the RIB does have a route to 172.16.1.2
Address tracking requires at least a /24 route to the peer
Connections established 1; dropped 0
Last reset never
Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Minimum incoming TTL 0, Outgoing TTL 255
Local host: 172.16.1.1, Local port: 11113
Foreign host: 172.16.1.2, Foreign port: 179
.
.
.

例:BGP を使用した MTR トポロジからのルートのインポート

次に、BLUE という名前のルート マップが VOICE という名前の MTR トポロジからインポートされたルートをフィルタリングするために使用するアクセス リストを設定する例を示します。プレフィクス 192.168.1.0 が付いたルートだけがインポートされます。

access-list 1 permit 192.168.1.0 0.0.0.255
route-map BLUE
match ip address 1
exit
router bgp 50000
scope global
neighbor 10.1.1.2 remote-as 50000
neighbor 172.16.1.1 remote-as 60000
address-family ipv4
topology VIDEO
bgp tid 100
neighbor 10.1.1.2 activate
neighbor 172.16.1.1 activate
import topology VOICE route-map BLUE
end
clear ip bgp topology VIDEO 50000

例:インターフェイス コンフィギュレーション モードでの MTR トポロジ

次に、イーサネット インターフェイス 0/0 で VOICE トポロジをディセーブルにする例を示します。

interface Ethernet 0/0
topology ipv4 VOICE disable

例:インターフェイス コンフィギュレーション モードでの MTR OSPF トポロジ

次に、グローバル トポロジ コンフィギュレーションからインターフェイスを削除せずに、インターフェイス イーサネット 0/0 で OSPF ルーティングをディセーブルにする例を示します。

interface Ethernet 0/0
topology ipv4 VOICE
ip ospf cost 100
ip ospf topology disable
end
 

次の例では、 show ip ospf interface コマンドを topology キーワードを指定して使用することで、インターフェイス コンフィギュレーション モードで OSPF に設定されたトポロジに関する情報を表示しています。

Router# show ip ospf 1 interface topology VOICE
 
VOICE Topology (MTID 66)
 
Serial3/0 is up, line protocol is up
Internet Address 10.0.0.5/30, Area 1
Process ID 1, Router ID 44.44.44.44, Network Type POINT_TO_POINT
Topology-MTID Cost Disabled Shutdown Topology Name
4 77 no no grc
Transmit Delay is 1 sec, State POINT_TO_POINT
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:05
Supports Link-local Signaling (LLS)
Cisco NSF helper support enabled
IETF NSF helper support enabled
Index 1/4, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.2.2.2
Suppress hello for 0 neighbor(s)
 

次の例では、 show ip ospf interface コマンドを brief キーワードおよび topology キーワードを指定して使用することで、インターフェイス コンフィギュレーション モードで OSPF に設定されたトポロジに関する情報を表示しています。

Router# show ip ospf 1 interface brief topology VOICE
 
VOICE Topology (MTID 66)
 
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Se3/0 1 1 10.0.0.5/30 1 UP 0/0
Se2/0 1 1 10.0.0.1/30 1 UP 0/0

例:インターフェイス コンフィギュレーション モードでの MTR EIGRP トポロジ

次に、インターフェイス イーサネット 0/0 での EIGRP 遅延計算を 100 ミリ秒に設定する例を示します。

interface Ethernet 0/0
topology ipv4 VOICE
eigrp 1 delay 100000
eigrp 1 next-hop-self
eigrp 1 shutdown
eigrp 1 split-horizon
eigrp 1 summary-address 10.1.1.0 0.0.0.255
end
 

次に、VOICE トポロジのインターフェイスに関する EIGRP の情報を表示する例を示します。

Router# show ip eigrp topology VOICE interfaces
 
EIGRP-IPv4 interfaces for process 1
 
Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Et0/0 1 0/0 20 0/2 0 0
 

次に、VOICE トポロジのリンクに関する EIGRP の情報を表示する例を示します。

Router# show ip eigrp topology VOICE detail-links
 
EIGRP-IPv4 Topology Table for AS(1)/ID(10.1.1.1) Routing Table: VOICE
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
 
P 10.1.1.0/24, 1 successors, FD is 25856000, serno 5
via Connected, Ethernet0/0

例:インターフェイス コンフィギュレーション モードでの MTR IS-IS トポロジ

次に、IS-IS プロセスによってインターフェイス イーサネット 1/0 が DATA トポロジの一部としてアドバタイズされないようにする例を示します。

interface Ethernet 1/0
ip address 192.168.130.1 255.255.255.0
ip router isis
topology ipv4 DATA
isis topology disable
topology ipv4 VOICE
end

MTR に対する SNMP サポート

次の例では、コンテキスト文字列「context-vrfA」が vrfA と関連付けるように設定されています。この文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

snmp-server community public
ip vrf vrfA
snmp context context-vrfA
exit
 

次の例では、コンテキスト文字列「context-voice」が voice というデータ トポロジに関連付けるように設定されています。この文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

global-address-family ipv4
topology voice
snmp context context-voice
exit
 

次の例では、コンテキスト文字列「context-ospf」と「context-voice」が OSPF プロセスおよび voice というトポロジに関連付けるように設定されています。これらの文字列は、SNMP トランザクションで MIB アクセス機能に渡されます。

router ospf 3
snmp context context-ospf
address-family ipv4
topology voice tid 10
snmp context ospf-voice
end
 

次に、コンテキスト文字列を指定の VRF、アドレス ファミリ、トポロジ、またはプロトコル インスタンスにマッピングする例を示します。

Router# show snmp context mapping
 
Context: ospf-voice
VRF Name:
Address Family Name: ipv4
Topology Name: voice
Protocol Instance: OSPF-3 Router
 
Context: context-ospf
VRF Name:
Address Family Name:
Topology Name:
Protocol Instance: OSPF-3 Router
 
Context: context-vrfA
VRF Name: vrfA
Address Family Name:
Topology Name:
Protocol Instance:
 
Context: context-voice
VRF Name:
Address Family Name: ipv4
Topology Name: voice
Protocol Instance:

例:インターフェイスおよびトポロジ IP トラフィック統計情報のモニタリング

次の例では、 show ip interface コマンドを type number 引数を指定して使用することで、ファスト イーサネット インターフェイス 1/10 の IP トラフィック統計情報を表示しています。

Router# show ip interface FastEthernet 1/10 stats
 
FastEthernet1/10
5 minutes input rate 0 bits/sec, 0 packet/sec,
5 minutes output rate 0 bits/sec, 0 packet/sec,
201 packets input, 16038 bytes
588 packets output, 25976 bytes
 

次の例では、 show ip traffic コマンドを topology instance キーワードおよび引数を指定して使用することで、特定のトポロジに関する統計情報を表示しています。

Router# show ip traffic topology VOICE
 
Topology: VOICE
5 minute input rate 0 bits/sec, 0 packet/sec,
5 minute output rate 0 bits/sec, 0 packet/sec,
100 packets input, 6038 bytes,
88 packets output, 5976 bytes.

例:MTR のネットワーク接続テスト

次に、VOICE トポロジ内の 10.1.1.2 ネイバーに ping を送信する例を示します。

Router# ping topology VOICE 10.1.1.2
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
 

次に、VOICE トポロジ内の 10.1.1.4 ホストをトレースする例を示します。

Router# traceroute VOICE ip 10.1.1.4
 
Type escape sequence to abort.
Tracing the route to 10.1.1.4
 
1 10.1.1.2 4 msec * 0 msec
2 10.1.1.3 4 msec * 2 msec
3 10.1.1.4 4 msec * 4 msec

その他の参考資料

関連資料

内容
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

MTR コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

Cisco IOS Multi-Topology Routing Command Reference

IP ルーティング プロトコル コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

Cisco IOS IP Routing: BGP Command Reference

Cisco IOS IP Routing: EIGRP Command Reference

Cisco IOS IP Routing: ISIS Command Reference

Cisco IOS IP Routing: OSPF Command Reference

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

Cisco IOS IP Multicast Command Reference

QoS コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

『Cisco IOS Quality of Service Solutions Command Reference』

IP ルーティング プロトコルの概念と作業

Cisco IOS IP Routing: BGP Configuration Guide

Cisco IOS IP Routing: EIGRP Configuration Guide

Cisco IOS IP Routing: ISIS Configuration Guide

Cisco IOS IP Routing: OSPF Configuration Guide

IP マルチキャストの概念と作業

『Cisco IOS IP Multicast Configuration Guide』

QoS の概念と作業

『Cisco IOS Quality of Service Solutions Configuration Guide』

IPv6 に対する Multitopology IS-IS の設定

Cisco IOS IPv6 Configuration Guide 』の「 Implementing IS-IS for IPv6 」モジュール

Cisco IOS In Service Software Upgrade のプロセス

Cisco IOS In Service Software Upgrade Process 』モジュール

規格

規格
タイトル

新しい規格または変更された規格はサポートされていません。また、既存の規格に対するサポートに変更はありません。

--

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

新しい RFC または変更された RFC はサポートされていません。また、既存の RFC に対するサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

マルチトポロジ ルーティングの機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームおよびソフトウェア イメージのサポート情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連のソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 マルチトポロジ ルーティングの機能情報

機能名
リリース
機能情報

マルチトポロジ ルーティング

12.2(33)SRB
15.0(1)S

MTR により、クラスベースの転送によるサービスの区別化を設定する機能が導入されました。MTR は、単一の物理ネットワークにおける複数の論理トポロジを可能にします。サービスの区別化は、同一宛先に対して異なるパスを利用する異なる論理トポロジで異なるタイプのトラフィックを転送することによって実現します。たとえば、MTR を使用して、音声、ビデオ、およびデータ トラフィック クラスに対して別個のトポロジを定義できます。

次のコマンドが追加または変更されました。 all-interfaces clear ip interface clear ip route topology clear ip traffic debug topology exit-global-af exit-if-topology exit-topo forward-base global-address-family ipv4 ip route topology ip topology accounting maximum routes ping route replicate show ip interface show ip protocols topology show ip route topology show ip static route show ip static route summary show ip traffic show topology shutdown topology topology accounting traceroute

MTR に対する BGP サポート

12.2(33)SRB
15.0(1)S

この機能により、単一の物理ネットワーク上の複数の論理トポロジに対する BGP サポートが実現します。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対する BGP ルーティング プロトコル サポート」

「BGP を使用した MTR トポロジのアクティブ化」

「BGP を使用した MTR トポロジからのルートのインポート」

「例:BGP を使用した MTR トポロジのアクティブ化」

「例:BGP を使用した MTR トポロジからのルートのインポート」

次のコマンドが追加または変更されました。 address-family ipv4 bgp tid clear ip bgp topology import topology neighbor translate-topology neighbor transport show ip bgp topology scope topology

MTR に対する EIGRP サポート

12.2(33)SRB
15.0(1)S

この機能により、単一の物理ネットワーク上の複数の論理トポロジに対する EIGRP サポートが実現します。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対するルーティング プロトコル サポート」

「EIGRP を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの EIGRP を使用した MTR トポロジのアクティブ化」

「例:EIGRP を使用した MTR トポロジのアクティブ化」

「例:インターフェイス コンフィギュレーション モードでの MTR EIGRP トポロジ」

次のコマンドが追加または変更されました。 address-family ipv4 eigrp delay clear ip eigrp neighbor eigrp next-hop-self eigrp shutdown eigrp split-horizon eigrp summary-address router eigrp show ip eigrp topology topology

MTR に対する IS-IS サポート

12.2(33)SRB

この機能により、単一の物理ネットワーク上の複数の論理トポロジに対する IS-IS サポートが実現します。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対するルーティング プロトコル サポート」

「IS-IS を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの IS-IS を使用した MTR トポロジのアクティブ化」

「例:IS-IS を使用した MTR トポロジのアクティブ化」

「例:インターフェイス コンフィギュレーション モードでの MTR IS-IS トポロジ」

次のコマンドが追加または変更されました。 address-family ipv4 isis topology disable show isis neighbors topology

ISSU:MTR

12.2(33)SRB1

MTR をサポートし、ISSU もサポートするすべてのプロトコルおよびアプリケーションでは、MTR 機能が含まれるように ISSU サポートが拡張されています。

この機能に関する詳細については、次の項を参照してください。

「ISSU:MTR」

この機能で追加または変更されたコマンドはありません。

マルチキャストに対する MTR サポート

12.2(33)SRB
15.0(1)M

この機能により、マルチキャストに対する MTR サポートが実現し、ユーザはネットワーク内のマルチキャスト トラフィックのパスを制御できます。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対するマルチキャスト トポロジ サポート」

「MTR に対するマルチキャスト トポロジの設定」

「例:MTR のマルチキャスト トポロジ」

次のコマンドが追加または変更されました。 clear ip route multicast ip multicast rpf multitopology show ip route multicast use-topology

MTR に対する OSPF サポート

12.2(33)SRB

この機能により、単一の物理ネットワーク上の複数の論理トポロジに対する OSPF サポートが実現します。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対するルーティング プロトコル サポート」

「OSPF を使用した MTR トポロジのアクティブ化」

「インターフェイス コンフィギュレーション モードでの OSPF を使用した MTR トポロジのアクティブ化」

「例:OSPF を使用した MTR トポロジのアクティブ化」

「例:インターフェイス コンフィギュレーション モードでの MTR OSPF トポロジ」

次のコマンドが追加または変更されました。 address-family ipv4 area capability default-exclusion ip ospf cost ip ospf topology disable priority router ospf show ip ospf interface show ip ospf topology-info topology

MTR に対する QoS/MQC サポート

12.2(33)SRB
15.0(1)S

この機能によって、MTR のトラフィック分類がイネーブルになります。トラフィック分類は、複数のトポロジが同じルータに設定されているときに、異なるトラフィック クラスを異なるトポロジに関連付けるために使用します。DSCP ビットのサブセットは、IP パケット ヘッダー内の分類値をエンコードし、パケットに分類用のマークを付けるのに使用されます。MTR のトラフィック分類をイネーブルにすると、MTR がアクティブになり、トポロジへの関与を開始するため、ルーティング プロトコルが準備されます。

この機能に関する詳細については、次の各項を参照してください。

「MTR のトラフィック分類」

「MTR のトラフィック分類の設定」

「例:MTR のトラフィック分類」

次のコマンドが追加または変更されました。 policy-map type class-routing ipv4 unicast select topology service-policy type class-routing show mtm table show policy-map type class-routing ipv4 unicast

MTR に対する SNMP サポート

12.2(33)SRB
12.2(33)SB
15.0(1)S

コンテキストベースの SNMP 機能が Cisco IOS ソフトウェアに組み込まれ、MTR のサポートに使用できるようになりました。MTR に対する SNMP サポートでは、コンテキストベースの SNMP を利用することで、基本トポロジのみの管理情報を表示する既存の MIB のサポートが拡張され、複数のトポロジの管理情報を表示できます。

この機能に関する詳細については、次の各項を参照してください。

「MTR に対するネットワーク管理サポート」

「MTR に対する SNMP サポートの設定」

「MTR に対する SNMP サポート」

次のコマンドが追加または変更されました。 show snmp context mapping snmp context

用語集

DSCP :DiffServ Code Point(DiffServ コード ポイント)。ToS の 6 ビットになります(現在 2 ビットが明示的輻輳通知に使用されています)。これらのビットを使用して、パケットにマークが付けられます。

NLRI :Network Layer Reachability Information(ネットワーク層到達可能性情報)。

TID :Topology Identifier(トポロジ ID)。各トポロジには、一意のトポロジ ID が設定されます。トポロジ ID は、ルーティング プロトコル下で設定され、所定のプロトコルのアップデート時に各トポロジの NLRI を識別し、グループ分けするために使用されます。

基本トポロジ :通常のルート セットが計算されるネットワーク全体。このトポロジは、MTR を使用しない現在のデフォルトのグローバル ルーティング テーブルと同じです。

クラス固有のトポロジ :既存の基本トポロジに加えて定義される新規のトポロジ。各クラス固有のトポロジは、独自の RIB および FIB によって表されます。

厳密転送モード :厳密転送モードは、MTR のデフォルトの転送モードです。トポロジ固有のルーティング テーブルにあるルートだけが考慮されます。それらのルートのうち、宛先アドレスとの最長一致が使用されます。トポロジ固有のテーブルに宛先アドレスを含むルートが見つからない場合、パケットはドロップされます。

逐次転送モード :逐次転送モードは、ネットワーク内に MTR がイネーブルでないルータが存在する場合に、MTR の移行または逐次展開をサポートするために用意されています。このモードでは、ルータは最初にクラス固有の FIB で転送エントリを検索します。エントリが見つからない場合、ルータは基本トポロジ FIB で最長一致検索を行います。基本トポロジ FIB でエントリが見つかると、パケットは基本トポロジで転送されます。基本トポロジ FIB で転送エントリが見つからない場合、パケットはドロップされます。

分類 :マークに基づいて異なる処理を行う必要のあるトラフィックの選択とマッチング。分類は、読み取り専用操作です。

マーキング :パケットまたはフレームへの値の設定。マーキングは、読み取りおよび書き込み操作です。

マルチトポロジ :マルチトポロジとは、分類条件によって定義されているとおりに、各トポロジがトラフィックのサブセットをルーティングまたは転送することを意味します。