Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Cisco Mobile Networks:マルチキャスト用 トンネル テンプレート
Cisco Mobile Networks:マルチキャスト用トンネル テンプレート
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco Mobile Networks:マルチキャスト用トンネル テンプレート

目次

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの前提条件

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの制約事項

マルチキャスト用トンネル テンプレートの設定方法

ホーム エージェントでのトンネル テンプレートの適用

モバイル ルータでのトンネル テンプレートの適用

マルチキャスト用トンネル テンプレートの設定例

マルチキャスト用トンネル テンプレートの例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

用語集

Cisco Mobile Networks:マルチキャスト用トンネル テンプレート

Cisco Mobile Networks:マルチキャスト用トンネル テンプレート機能を利用すると、静的に作成されたトンネルに対するマルチキャストの設定を、ホーム エージェントおよびモバイル ルータに通じるダイナミック トンネルに適用することができます。トンネル テンプレートが定義され、ホーム エージェントとモバイル ルータ間のトンネルに適用されます。モバイル ルータのローミングが可能である現在、トンネル テンプレートを利用することで、マルチキャスト セッションをモバイル ネットワークに伝送できます。

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの機能仕様

機能履歴
リリース
変更内容

12.2(15)T

この機能が追加されました。

サポートされているプラットフォーム

Cisco IOS Release 12.2(15)T でサポートされているプラットフォームについては、Cisco Feature Navigator で確認してください。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの前提条件

モバイル ルータからホーム エージェントへの反転トンネリングがイネーブルである必要があります。

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの制約事項

テンプレートとして使用しているトンネルは削除できません。

マルチキャスト用トンネル テンプレートの設定方法

ここでは、次の手順について説明します。

ホーム エージェントでのトンネル テンプレートの適用(必須)

モバイル ルータでのトンネル テンプレートの適用(必須)

ホーム エージェントでのトンネル テンプレートの適用

この作業では、ホーム エージェントに通じるトンネルにトンネル テンプレートを適用する方法を説明します。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing

4. interface tunnel interface-number

5. ip pim sparse-mode

6. exit

7. router mobile

8. exit

9. ip mobile mobile-networks

10. template tunnel interface-number

11. end

12. show ip mobile tunnel

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

interface tunnel interface-number

 

Router(config)# interface tunnel 100

トンネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

これが、モバイル ネットワークに適用されるトンネル テンプレートになります。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

トンネル インターフェイスに対してスパース モードで Protocol Independent Multicast(PIM)をイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

router mobile

 

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 8

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

ip mobile mobile-networks

 

Router(config)# ip mobile mobile-networks

モバイル ホストのモバイル ネットワークを設定し、モバイル ネットワーク コンフィギュレーション モードを開始します。

ステップ 10

template tunnel interface-number

 

Router(mobile-networks)# template tunnel 100

登録時に適用するトンネル テンプレートを指定します。

interface-number 引数は、ステップ 4 で定義したトンネル テンプレートに設定されます。

ステップ 11

end

 

Router(mobile-networks)# end

特権 EXEC モードに戻ります。

ステップ 12

show ip mobile tunnel

 

Router# show ip mobile tunnel

アクティブ トンネルを表示します。

このコマンドを使用して、設定を確認します。「例」の表示出力を参照してください。

次の例は、アクティブな Mobile IP トンネルと、ホーム エージェントでのトンネル テンプレートの設定を示しています。

Router# show ip mobile tunnel
 
Mobile Tunnels:
 
Total mobile ip tunnels 2
Tunnel1:
src 1.1.1.1, dest 20.20.0.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1460 bytes
Path MTU Discovery, mtu:0, ager:10 mins, expires:never
outbound interface Tunnel0
HA created, fast switching enabled, ICMP unreachable enabled
27 packets input, 2919 bytes, 0 drops
24 packets output, 2568 bytes
Running template configuration for this tunnel:
ip pim sparse-dense-mode
 
Tunnel0:
src 1.1.1.1, dest 30.30.10.2
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu:0, ager:10 mins, expires:never
outbound interface Ethernet1/3
HA created, fast switching enabled, ICMP unreachable enabled
0 packets input, 0 bytes, 0 drops
24 packets output, 3048 bytes

モバイル ルータでのトンネル テンプレートの適用

この作業では、モバイル エージェントに通じるトンネルにトンネル テンプレートを適用する方法を説明します。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing

4. interface tunne l interface-number

5. ip pim sparse-mode

6. exit

7. router mobile

8. exit

9. ip mobile router

10. template tunnel interface-number

11. end

12. show ip mobile tunnel

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 4

interface tunnel interface-number

 

Router(config)# interface tunnel 100

トンネル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

これが、モバイル ネットワークに適用されるトンネル テンプレートになります。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

トンネル インターフェイスに対してスパース モードで PIM をイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

router mobile

 

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 8

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

ip mobile router

 

Router(config)# ip mobile router

モバイル ルータをイネーブルにして、モバイル ルータ コンフィギュレーション モードを開始します。

ステップ 10

template tunnel interface-number

 

Router(mobile-router)# template tunnel 100

登録時に適用するトンネル テンプレートを指定します。

interface number 引数は、ステップ 4 で定義したトンネル テンプレートに設定されます。

ステップ 11

end

 

Router(mobile-router)# end

特権 EXEC モードに戻ります。

ステップ 12

show ip mobile tunnel

 

Router# show ip mobile tunnel

アクティブ トンネルを表示します。

このコマンドを使用して、設定を確認します。「例」の表示出力を参照してください。

次の例は、アクティブな Mobile IP トンネルと、モバイル ルータでのトンネル テンプレートの設定を示しています。

Router# show ip mobile tunnel
 
Mobile Tunnels:
 
Total mobile ip tunnels 1
Tunnel0:
src 20.20.0.1, dest 1.1.1.1
encap IP/IP, mode reverse-allowed, tunnel-users 1
IP MTU 1480 bytes
Path MTU Discovery, mtu:0, ager:10 mins, expires:never
outbound interface Ethernet4/2
MR created, fast switching enabled, ICMP unreachable enabled
22 packets input, 2468 bytes, 0 drops
27 packets output, 2892 bytes
Running template configuration for this tunnel:
ip pim sparse-mode

マルチキャスト用トンネル テンプレートの設定例

ここでは、次の設定例について説明します。

「マルチキャスト用トンネル テンプレートの例」

マルチキャスト用トンネル テンプレートの例

次の例では、トンネル テンプレートがホーム エージェントおよびモバイル ルータに通じるように定義され、設定されています。外部エージェントで Cisco Mobile Networks:マルチキャスト用トンネル テンプレート機能をサポートするために、その他の設定は必要ありません。

ホーム エージェントの設定

!
ip multicast-routing
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
!
! Tunnel template to be applied to mobile networks
interface tunnel100
ip address 13.0.0.1 255.0.0.0
ip pim sparse-mode
!
!
router mobile
ip mobile mobile-networks 11.1.0.1
description jet
network 11.1.2.0 255.255.255.0
network 11.1.1.0 255.255.255.0
! Select tunnel template to apply during registration
template tunnel100
!
ip mobile secure host 11.1.0.1 spi 101 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
no ip mobile tunnel route-cache
!
 

モバイル ルータの設定

!
ip multicast-routing
!
interface Loopback0
ip address 11.1.0.1 255.255.255.255
ip pim sparse-mode
!
!
! Tunnel template to be applied to mobile networks
interface tunnel 100
no ip address
ip pim sparse-mode
!
!
interface Ethernet1/1
ip address 20.0.0.1 255.0.0.0
ip pim sparse-mode
ip mobile router-service roam
!
router mobile
ip pim rp-address 7.7.7.7
ip mobile secure home-agent 1.1.1.1 spi 102 key hex 23456781234567812345678123456781 algorithm md5 mode prefix-suffix
ip mobile router
address 11.2.0.1 255.255.0.0
home-agent 1.1.1.1
! Select tunnel template to apply during registration
template tunnel 100
register extend expire 5 retry 2 interval 15
register lifetime 10000
reverse-tunnel
!

参考資料

Cisco Mobile Networks:マルチキャスト用トンネル テンプレートの詳細については、次の項を参照してください。

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

関連資料

関連項目
参照先

Mobile IP 設定作業

Cisco IOS IP Configuration Guide, Release 12.2』の「Configuring Mobile IP」の章

Mobile IP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2』の「Mobile IP Commands」の章

マルチキャスト設定作業

Cisco IOS IP Configuration Guide, Release 12.2』の「Configuring IP Multicast Routing」の章

マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

Cisco IOS IP Command Reference, Volume 3 of 3: Multicast, Release 12.2』の「IP Multicast Routing Commands」の章

Cisco Mobile Networks に関する Mobile IP コマンド

Cisco Mobile Networks 』機能マニュアル、Releases 12.2(4)T および 12.2(13)T

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

なし

プラットフォームおよび Cisco IOS リリースでサポートされる MIB のリストを入手して、MIB モジュールをダウンロードするには、次の URL にある Cisco.com の Cisco MIB Web サイトにアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html の『 Cisco IOS IP Mobility Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

show ip mobile tunnel

template tunnel(モバイル ネットワーク)

template tunnel(モバイル ルータ)

用語集

ホーム エージェント :モバイル ノードのホーム ネットワーク上のルータ。モバイル ノードまたはモバイル ルータがホームから離れているときに、それらへのパケットをトンネリングします。 モビリティ バインディング と呼ばれる登録モバイル ノードの現在の位置情報を維持します。

モバイル ネットワーク :モバイル ルータとともに移動するネットワーク。モバイル ネットワークは、相互に固定されていながら、インターネット全体に対しては 1 つの単位として移動可能な、ホストおよびルートの集合です。

モバイル ルータ :ルータの役割を持つモバイル ノード。航空機、船、電車、自動車、自転車、カヤック上などでまとまって移動する 1 つまたは複数のネットワーク全体にモビリティを提供します。モバイル ルータが提供するネットワークに接続するノードは、固定ノードにすることも、モバイル ノード、またはルータにすることもできます。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。