Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Cisco Mobile Networks:プライオリティに よる HA の割り当て
Cisco Mobile Networks:プライオリティによる HA の割り当て
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco Mobile Networks:プライオリティによる HA の割り当て

目次

Cisco Mobile Networks:プライオリティによる HA の割り当てに関する情報

Cisco Mobile Networks:プライオリティによる HA の割り当ての機能設計

Cisco Mobile Networks:プライオリティによる HA の割り当ての利点

Cisco Mobile Networks:プライオリティによる HA の割り当ての設定方法

HA への気付アドレス アクセス リストの設定

最適な HA 選択プロセス

制約事項

トラブルシューティングのヒント

モバイル ルータでの HA プライオリティの設定

Cisco Mobile Networks:プライオリティによる HA の割り当ての設定例

HA プライオリティの設定例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

用語集

Cisco Mobile Networks:プライオリティによる HA の割り当て

Cisco Mobile Networks:プライオリティによる HA の割り当て機能が導入されるまで、モバイル ルータは Home Agent(HA; ホーム エージェント)に異なるプライオリティを事前に設定し、プライオリティの最も高いホーム エージェントだけに登録していました。しかし、モバイル ルータは、より近いホーム エージェントに登録するほうが望ましいエリアにローミングする場合があります。この機能の導入により、モバイル ルータは、モバイル ルータに設定されているホーム エージェントのプライオリティと、ホーム エージェントに設定されている気付アドレス アクセス リストの組み合せを使用して、より近いホーム エージェントに登録できるようになりました。

Cisco Mobile Networks:プライオリティによる HA の割り当て機能の機能仕様

機能履歴
リリース
変更内容

12.2(15)T

この機能が追加されました。

サポートされているプラットフォーム

サポートされているプラットフォームについては、Cisco Feature Navigator を参照してください。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

Cisco Mobile Networks:プライオリティによる HA の割り当てに関する情報

Cisco Mobile Networks:プライオリティによる HA の割り当て機能を設定する前に、次の概念について理解しておく必要があります。

「Cisco Mobile Networks:プライオリティによる HA の割り当ての機能設計」

「Cisco Mobile Networks:プライオリティによる HA の割り当ての利点」

Cisco Mobile Networks:プライオリティによる HA の割り当ての機能設計

  1. この機能によって、コマンドを新たに追加することなく、モバイル ルータにおける HA のプライオリティ設定の動作を変えることができます。各 HA には、リージョン内のすべての外部エージェント気付アドレスを含むアクセス リストが設定されます。モバイル ルータが最適な HA に登録要求を送信すると、HA は登録要求に使用されている気付アドレスに応じてその要求を許可または拒否します。特定の HA のアクセス リストにその気付アドレスが存在しないために HA が要求を拒否した場合、モバイル ルータは次に適した HA、その次に適した HA、というように登録を試行していきます。HA のプライオリティが同じである場合、最近設定された HA が優先されます。プライオリティの最も低い HA への登録にも失敗すると、モバイル ルータはアドバタイズメントを待機してから、プライオリティの最も高い HA から再び登録を試行します。モバイル ルータは新しい HA に登録すると、古い外部エージェント気付アドレスを使用する古い HA の登録解除を試みます。

Cisco Mobile Networks:プライオリティによる HA の割り当ての利点

この機能により、モバイル ルータは地理的により近い HA に登録し、ネットワーク上の遅延を改善することができます。

Cisco Mobile Networks:プライオリティによる HA の割り当ての設定方法

ここでは、次の手順について説明します。

「HA への気付アドレス アクセス リストの設定」

「モバイル ルータでの HA プライオリティの設定」

HA への気付アドレス アクセス リストの設定

この作業では、HA に気付アドレス アクセス リストを設定する方法を説明します。

最適な HA 選択プロセス

モバイル ルータが使用できる気付アドレスから複数の HA に到達可能である場合、最適な HA 選択プロセスを施行するには、HA にアクセス リスト(外部エージェント気付アドレスまたは連結型気付アドレス)が設定されている必要があります。この設定によって、リージョン内の(アクセス リストとして設定されている)気付アドレスで定義された特定の HA の対象範囲となるリージョンが適用されます。リージョンの外側から発信された登録は管理上拒否され、リージョン内の登録は処理されます。

制約事項

distribute-list コマンドを設定しないと、各 HA が同一の仮想ネットワークにルートをアドバタイズします。その場合、ルーティングの競合が発生し、モバイル ルータのホーム ネットワークを宛先とするトラフィックがドロップされる可能性があります。

distribute-list コマンドを設定すると、仮想ネットワークのアドバタイズメントが残りのネットワークに配信されないようにすることができます。ただし、モバイル ルータのホーム アドレスへの ping は失敗し、モバイル ルータが提供するモバイル ネットワークのアドレスへの ping は成功します。モバイル ネットワークを宛先とするトラフィックは、そのまま問題なく宛先に到達します。

ホーム ネットワークがモバイル ルータとモバイル ノードの両方で構成されている場合、 distribute-list コマンドによってモバイル ルータのアドレスだけがブロックされ、サブネット全体はブロックされません。

モバイル ルータが登録されていないと、モバイル ルータへのルートはアドバタイズされません。モバイル ルータが登録されていないと、モバイル ネットワークのアドレスへの ping は到達不能を返します。

古い HA への登録解除が成功している限り、モバイル ネットワークは一度に 1 つの HA だけからアドバタイズされます。新しい HA にローミングした後、ルーティング プロトコルによってモバイル ネットワークのルートがネットワーク上に伝播される速さによって、モバイル ネットワークへの ping にしばらく時間が掛かる場合があります。

手順の概要

1. enable

2. configure terminal

3. ip mobile home-agent care-of-access access-list

4. ip access-list standard access-list-name

5. permit coa-ip-address

6. permit mr-home-address

7. exit

8. router protocol

9. redistribute mobile subnets

10. distribute-list access-list out

11. exit

12. access-list access-list-number deny source

13. access-list access-list-number permit any

14. モバイル ルータに設定された HA ごとにステップ 3 ~ 7 を繰り返します。仮想ネットワークが設定されている場合は、HA ごとにステップ 8 ~ 13 を繰り返します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip mobile home-agent care-of-access access-list

 

Router(config)# ip mobile home-agent care-of-access HA1-FA1

登録要求でどの気付アドレスをホーム エージェントで許可するかを制御します。

デフォルトでは、すべての気付アドレスが許可されます。アクセス リストは文字列か、1 ~ 99 の数字です。

ステップ 4

ip access-list standard access-list-name

 

Router(config)# ip access-list standard HA1-FA1

標準のアクセス リストを定義して、標準の名前付きアクセス リスト コンフィギュレーション モードを開始します。

このコマンドを使用して、モバイル ルータから到達可能な各 HA にアクセス リストを設定します。

ステップ 5

permit coa-ip-address

 

Router(config-std-nacl)# permit 3.3.3.2

アクセス リストの条件を設定します。

coa-ip-address は、外部エージェント気付アドレスか連結型気付アドレスとなります。このコマンドを実行すると、登録要求で許可する気付アドレスが HA に通知されます。

ステップ 6

permit mr-home-address

 

Router(config-std-nacl)# permit 5.5.5.3

アクセス リストの条件を設定します。

mr-home-address は、モバイル ルータのホーム アドレスです。モバイル ルータのホーム アドレスを指定することが重要である理由については、後述の「トラブルシューティングのヒント」を参照してください。

ステップ 7

exit

 

Router(config-std-nacl)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 8

router protocol

 

Router(config)# router ospf

ルーティング プロトコルを設定します。

ステップ 9

redistribute mobile subnets

 

Router(config-router)# redistribute mobile subnets

ルーティング プロトコルへの仮想ネットワークの再配布をイネーブルにします。

ステップ 10

distribute-list access-list out

 

Router(config-router)# distribute-list 1 out

(任意)ネットワークがアップデート時にアドバタイズされないようにします。

各 HA でこのコマンドが設定されていると、モバイル ルータに対する仮想ネットワークのアドバタイズメントが防止されます。このコマンドの詳細については、「制約事項」および「トラブルシューティングのヒント」を参照してください。

ステップ 11

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 12

access-list access-list-number deny source

 

Router(config)# access-list 1 deny 5.5.5.0

標準 IP アクセス リストを定義します。

条件が一致した場合にアクセスを拒否します。

この例では、 source 値が、HA に設定された仮想ネットワークになります。ステップ 10 で distribute-list コマンドを実行すると、この仮想ネットワークのアドバタイズメントが防止されます。

ステップ 13

access-list access-list-number permit any

 

Router(config)# access-list 1 permit any

標準 IP アクセス リストを定義します。

条件が一致した場合にアクセスを許可します。

ステップ 14

モバイル ルータに設定された HA ごとにステップ 3 ~ 7 を繰り返します。仮想ネットワークが設定されている場合は、HA ごとにステップ 8 ~ 13 を繰り返します。

--

トラブルシューティングのヒント

気付アドレス リストの作用

HA に気付アドレス アクセス リストが設定されている場合、アクセス リストでは常に、モバイル ルータのホーム アドレス(登録解除用)と対象の気付アドレス リスト(登録用)を認める必要があります。

気付アドレス リストの目的は、HA の限られた気付アドレス グループの登録だけを許可することにあります。プライオリティによる HA の割り当てを有効にするため、登録解除も許可する必要があります。登録解除は、登録解除の気付アドレス フィールドにモバイル ルータのホーム アドレスが入力された状態で送信されます。ホーム アドレスが認められないと、いずれの登録解除もアクセス リストでドロップされます。登録解除がドロップされると、プライオリティによる HA の割り当ては正しく機能しません。

仮想ネットワークのアドバタイズメント

プライオリティによる HA の割り当てが設定されたモバイル ルータと複数の HA を使用するネットワークでは、HA がルーティング情報を共有している場合があります。その場合、各 HA が redistribute mobile コマンドを通じて、同一のモバイル仮想ネットワークにルートをアドバタイズします。このために複数のルートが同一の仮想ネットワークにアドバタイズされ、ルーティングの競合とパケットの損失が発生するおそれがあります。各 HA に distribute-list コマンドを設定すると、モバイル ルータに対する仮想ネットワークのアドバタイズメントは防止されます。この動作は、登録には依存しません。

モバイル ルータでの HA プライオリティの設定

この作業では、モバイル ルータに HA プライオリティを設定する方法を説明します。

手順の概要

1. enable

2. configure terminal

3. ip mobile router

4. home-agent ip-address priority level

5. end

6. show ip mobile router

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip mobile router

 

Router(config)# ip mobile router

モバイル ルータをイネーブルにして、モバイル ルータ コンフィギュレーション モードを開始します。

ステップ 4

home-agent ip-address priority level

 

Router(mobile-router)# home-agent 1.1.1.1 priority 101

モバイル ルータが登録時に使用するホーム エージェントを指定します。

プライオリティ レベルによって、登録時の使用に最適なホーム エージェント アドレスの順位が決まります。指定できる範囲は 0 ~ 255 で、0 は最も低いプライオリティ、255 は最も高いプライオリティを示します。デフォルト値は 100 です。

ステップ 5

end

 

Router(mobile-router)# end

特権 EXEC モードに戻ります。

ステップ 6

show ip mobile router

 

Router# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

このコマンドを実行すると、モバイル ルータが登録されているホーム エージェントが表示されます。ホーム エージェントの後に表示されている修飾子の (best) (current) は、このホーム エージェントが登録に最適なホーム エージェントとして選択されたことを示しています。「例」の表示出力を参照してください。

ここでは、 show ip mobile router コマンドの出力例を示します。

次の例は、モバイル ルータが現在、200.200.200.1 にある最適なホーム エージェントに登録されていることを示しています。

Router# show ip mobile router
 
Mobile Router
Enabled 01/01/02 10:01:34
Last redundancy state transition NEVER
 
Configuration:
Home Address 5.5.5.3 Mask 255.255.255.0
Home Agent 200.200.200.1 Priority 102 (best) (current)
100.100.100.1 Priority 101
Registration lifetime 90 sec
Retransmit Init 1000, Max 5000 msec, Limit 3
Extend Expire 120, Retry 3, Interval 10
 
Monitor:
Status -Registered-
Active foreign agent 3.3.3.2, Care-of 3.3.3.2
On interface Ethernet5/3

Cisco Mobile Networks:プライオリティによる HA の割り当ての設定例

ここでは、次の設定例について説明します。

「HA プライオリティの設定例」

HA プライオリティの設定例

次の例では、2 つのホーム エージェントにアクセス リストが設定されています。モバイル ルータは、これらのアクセス リストを利用して、登録に最適な HA を選択します。

ホーム エージェント 1

interface Loopback0
ip address 100.100.100.1 255.255.255.255
!
interface Ethernet1
ip address 2.2.2.1 255.255.255.0
!
router mobile
!
router ospf 100
redistribute mobile subnets
network 2.0.0.0 0.255.255.255 area 0
network 100.100.100.0 0.255.255.255 area 0
! Suppresses virtual network to be advertised in updates
distribute-list 1 out
!
ip mobile home-agent care-of-access HA1-FA1
ip mobile virtual-network 5.5.5.0 255.255.255.0
ip mobile host 5.5.5.3 virtual-network 5.5.5.0 255.255.255.0 lifetime 90
ip mobile mobile-networks 5.5.5.3
description Jet
network 6.6.6.0 255.255.255.0
ip mobile secure host 5.5.5.3 spi 100 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
ip access-list standard HA1-FA1
! MR CCOA
permit 4.4.4.2
! FA1 COA
permit 7.7.7.1
! MR home address
permit 5.5.5.3
!
! Denies virtual network to
access-list 1 deny 5.5.5.0 0.0.0.255
access-list 1 permit any

ホーム エージェント 2

interface Loopback0
ip address 200.200.200.1 255.255.255.255
!
interface Ethernet0
ip address 1.1.1.1 255.255.255.0
!
router mobile
!
router ospf 100
redistribute mobile subnets
network 1.0.0.0 0.255.255.255 area 0
network 200.200.200.0 0.255.255.255 area 0
! Suppresses virtual network to be advertised in update
distribute-list 1 out
!
ip mobile home-agent care-of-access HA2-FA2
ip mobile virtual-network 5.5.5.0 255.255.255.0
ip mobile host 5.5.5.3 virtual-network 5.5.5.0 255.255.255.0 lifetime 90
ip mobile mobile-networks 5.5.5.3
description Jet
network 6.6.6.0 255.255.255.0
ip mobile secure host 5.5.5.3 spi 200 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
ip access-list standard HA2-FA2
! FA COA
permit 3.3.3.2
! MR home address
permit 5.5.5.3
!
access-list 1 deny 5.5.5.0 0.0.0.255
access-list 1 permit any

モバイル ルータ

interface Loopback0
ip address 5.5.5.3 255.255.255.255
!
! CCOA roaming interface registers with HA1 only
interface Ethernet5/1
ip address 4.4.4.3 255.255.255.0
ip mobile router-service roam priority 99
ip mobile router-service collocated gateway 4.4.4.2
!
! This roaming interface will use FA COA to register
interface Ethernet5/3
ip address 3.3.3.3 255.255.255.0
ip mobile router-service roam
!
! Mobile Network interface
interface Ethernet5/4
ip address 6.6.6.3 255.255.255.0
!
router mobile
!
ip mobile secure home-agent 100.100.100.1 spi 100 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
ip mobile secure home-agent 200.200.200.1 spi 200 key hex 12345678123456781234567812345678 algorithm md5 mode prefix-suffix
!
ip mobile router
address 5.5.5.3 255.255.255.0
home-agent 100.100.100.1 priority 101
home-agent 200.200.200.1 priority 102
register lifetime 90

参考資料

Cisco Mobile Networks:プライオリティによる HA の割り当て機能に関する詳細については、次の項を参照してください。

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

関連資料

関連項目
参照先

Mobile IP 設定作業

Cisco IOS IP Configuration Guide, Release 12.2』の「Configuring Mobile IP」の章

Mobile IP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2 T』の「Mobile IP Commands」の章

Cisco Mobile Networks に関する Mobile IP コマンド

Cisco Mobile Networks 』機能マニュアル、Release 12.2(4)T および 12.2(13)T

アクセス リスト コマンド

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2 T』の「 IP Services Commands 」の章

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

プラットフォームおよび Cisco IOS リリースでサポートされる MIB のリストを入手して、MIB モジュールをダウンロードするには、次の URL にある Cisco.com の Cisco MIB Web サイトにアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

用語集

外部エージェント :モバイル ノードがアクセスした外部ネットワーク上のルータ。モバイル ノードが登録されている間、そのモバイル ノードにルーティング サービスを提供します。外部エージェントは、モバイル ノードのホーム エージェントによってトンネリングされたパケットのトンネリングを解除して、モバイル ノードまたはモバイル ルータに送信します。パケットがモバイル ノードから送信された場合、外部エージェントは登録モバイル ノードのデフォルト ルータとして動作できます。

気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。これを連結型気付アドレスにすることによって、モバイル ノードまたはモバイル ルータはローカル アドレスを取得して、それぞれのパケットのトンネリングを解除できます。または、外部エージェント気付アドレスにすることによって、外部エージェントはパケットのトンネリングを解除し、モバイル ノードまたはモバイル ルータに転送することができます。

ホーム エージェント :モバイル ノードのホーム ネットワーク上のルータ。モバイル ノードまたはモバイル ルータがホームから離れているときに、それらへのパケットをトンネリングします。 モビリティ バインディング と呼ばれる登録モバイル ノードの現在の位置情報を維持します。

モバイル ネットワーク :モバイル ルータとともに移動するネットワーク。モバイル ネットワークは、相互に固定されていながら、インターネット全体に対しては 1 つの単位として移動可能な、ホストおよびルートの集合です。

モバイル ルータ :ルータの役割を持つモバイル ノード。飛行機、船、電車、自動車、自転車上などで、1 つまたは複数のネットワーク全体が一緒に移動できるようにします。モバイル ルータが提供するネットワークに接続するノードは、固定ノードにすることも、モバイル ノード、またはルータにすることもできます。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。