Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Mobile IP:NAT 検出
Mobile IP:NAT 検出
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Mobile IP:NAT 検出

目次

Mobile IP:NAT 検出の制約事項

Mobile IP:NAT 検出の設定方法

NAT 検出の設定

NAT 検出の設定の確認

Mobile IP:NAT 検出の設定例

NAT 検出を使用するホーム エージェントの例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

用語集

Mobile IP:NAT 検出

Network Address Translation(NAT; ネットワーク アドレス変換)の利用により、アドレスをグローバルにルーティング可能なアドレス空間に変換することによって、組織はグローバルにルーティングできないアドレスを使用してインターネットに接続できます。従来の Mobile IP トンネリングには、NAT との互換性がありません。Mobile IP:NAT 検出機能は、ホーム エージェントでの新しいサービスであり、NAT 対応デバイスの背後でプライベート IP アドレスを使用する Mobile IP クライアントまで、トラフィックをトンネリングできるようにします。ホーム エージェントでは、NAT 対応デバイスをトラバースした登録要求を検出し、Mobile IP クライアントに到達するためのトンネルを適用できるようになりました。

Mobile IP:NAT 検出機能の機能仕様

機能履歴
リリース
変更内容

12.2(13)T

この機能が追加されました。

サポートされているプラットフォーム

Feature Navigator を参照してください。

Cisco IOS ソフトウェアは、特定のプラットフォームがサポートされている機能セットにパッケージングされています。この機能のプラットフォーム サポートに関連した更新情報を取得するには、Cisco Feature Navigator にアクセスします。新しいプラットフォーム サポートが機能に追加されると、Cisco Feature Navigator によって、サポートされているプラットフォームのリストが自動的に更新されます。

Cisco Feature Navigator は Web ベースのツールであり、特定の機能セットがサポートされている Cisco IOS ソフトウェア イメージ、および、特定の Cisco IOS イメージ内でサポートされている機能を特定できます。機能またはリリースごとに検索できます。リリース セクションでは、各リリースを横に並べて比較し、各ソフトウェア リリースに固有の機能と共通機能の両方を表示できます。

Cisco Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウント情報を忘れた場合や紛失した場合は、cco-locksmith@cisco.com に空メールを送信してください。自動チェックにより、ご使用の E メール アドレスが Cisco.com に登録されているか検証されます。チェックが成功した場合は、アカウントの詳細がランダムな新パスワードと一緒に E メールで送信されます。認証されたユーザは、次の URL に表示される指示に従うことで、Cisco.com にアカウントを構築できます。

http://www.cisco.com/register

Cisco Feature Navigator は定期的に更新されています(Cisco IOS ソフトウェアの主要なリリース時およびテクノロジー リリース時)。最新情報については、次の URL から Cisco Feature Navigator ホームページにアクセスしてください。

http://www.cisco.com/go/fn

Cisco IOS ソフトウェア イメージの可用性

プラットフォームが特定の Cisco IOS ソフトウェア リリースをサポートするかどうかは、そのプラットフォーム用のソフトウェア イメージの有無により異なります。一部のプラットフォームのソフトウェア イメージは、事前の通知なしに延期、遅延、または変更される場合があります。各 Cisco IOS ソフトウェア リリースのプラットフォーム サポートおよび利用可能なソフトウェア イメージの更新情報は、オンライン リリース ノートまたは Cisco Feature Navigator(サポートされている場合)を参照してください。

Mobile IP:NAT 検出の制約事項

この機能は、連結型気付アドレスだけを使用するモバイル ノードに対してサポートされています。NAT ゲートウェイの裏側にある外部エージェント気付アドレスを使用するモバイル ノードは、ホーム エージェントから検出できません。

Mobile IP:NAT 検出の設定方法

ここでは、次の手順について説明します。

「NAT 検出の設定」(必須)

「NAT 検出の設定の確認」(任意)

NAT 検出の設定

ホーム エージェントに NAT 検出を設定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure { terminal | memory | network }

3. router mobile

4. exit

5. ip mobile home-agent [ address ip-address ] [ broadcast ] [ care-of-access access-list ] [ lifetime number ] [ nat-detect ] [ replay seconds ] [ reverse-tunnel-off ] [ roam-access access-list ] [ suppress-unreachable ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなどの上位の特権レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure { terminal | memory | network }

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router mobile

 

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 4

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip mobile home-agent [ address ip-address ][ broadcast ] [ care-of-access access-list ] [ lifetime number ] [ nat-detect ] [ replay seconds ] [ reverse-tunnel-off ] [ roam-access access-list ] [ suppress-unreachable ]

 

Router(config)# ip mobile home-agent nat-detect

ホーム エージェント サービスと NAT 検出をイネーブルにします。

NAT 検出の設定の確認

Mobile IP:NAT 検出機能が動作していることを確認するには、次の手順を実行します。

手順の概要

1. show ip mobile globals

2. show ip mobile binding

3. show ip mobile traffic

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show ip mobile globals

 
Router# show ip mobile globals

モバイル エージェントのグローバル情報を表示します。

ステップ 2

show ip mobile binding

 
Router# show ip mobile binding

モビリティ バインディング テーブルを表示します。

ステップ 3

show ip mobile traffic

 
Router# show ip mobile traffic

プロトコル カウンタを表示します。

このコマンドを実行すると、NAT 検出を使用して成功した登録要求の数が表示されます。

Mobile IP:NAT 検出の設定例

ここでは、次の設定例について説明します。

「NAT 検出を使用するホーム エージェントの例」

NAT 検出を使用するホーム エージェントの例

次の例では、ホーム エージェントが、NAT 対応ルータの裏側にあるモバイル ノードからの登録要求を検出できます。モバイル ノードは、登録要求で使用する連結型気付アドレスとして、NAT 内部アドレスを使用します。

ホーム エージェント

ip routing
!
interface ethernet1
ip address 1.0.0.1 255.0.0.0
!
interface ethernet2
ip address 2.0.0.1 255.0.0.0
!
router mobile
!
router ospf 100
redistribute mobile subnets metric 1500
network 1.0.0.0 0.255.255.255 area 0
network 2.0.0.0 0.255.255.255 area 0
!
ip mobile home-agent lifetime 65535 nat-detect replay 255
ip mobile virtual-network 65.0.0.0 255.0.0.0
ip mobile host 65.1.1.1 65.1.1.10 virtual-network 65.0.0.0 255.0.0.0
ip mobile secure host 65.1.1.1 65.1.1.10 spi 100 key hex 12345678123456781234567812345678
!

NAT が設定されているルータ

ip routing
!
interface ethernet2
ip address 2.0.0.2 255.0.0.0
ip nat outside
!
interface e4
ip address 4.0.0.1 255.0.0.0
ip nat outside
!
! Outside address 2.0.0.101 used for any packet coming from inside 4.0.0.101
! 4.0.0.101 is the collocated care-of address used by MN to register
ip nat inside source static 4.0.0.101 2.0.0.101
router mobile
!
router ospf 100
network 2.0.0.0 0.255.255.255 area 0
network 4.0.0.0 0.255.255.255 area 0
!

参考資料

Mobile IP:NAT 検出機能に関する詳細情報については、次の項を参照してください。

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

関連項目
参照先

Mobile IP 設定作業

Cisco IOS IP Configuration Guide , Release 12.2』の「Configuring Mobile IP」の章

Mobile IP コマンド

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services , Release 12.2』の「Mobile IP Commands」の章

NAT 設定作業

Cisco IOS IP Configuration Guide Release 12.2』の「Configuring IP Addressing」の章

NAT コマンド

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services , Release 12.2』の「IP Addressing Commands」の章

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

プラットフォームおよび Cisco IOS リリースでサポートされる MIB のリストを入手して、MIB モジュールをダウンロードするには、次の URL にある Cisco.com の Cisco MIB Web サイトにアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://tools.cisco.com/ITDIT/MIBS/servlet/index

Cisco MIB Locator で必要な MIB 情報がサポートされていない場合は、次の URL にある Cisco MIB ページにアクセスすれば、サポートされている MIB のリストを入手したり、MIB をダウンロードしたりできます。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Cisco MIB Locator にアクセスするには、Cisco.com のアカウントが必要です。アカウント情報を忘れた場合や紛失した場合は、cco-locksmith@cisco.com に空メールを送信してください。自動チェックにより、ご使用の E メール アドレスが Cisco.com に登録されているか検証されます。チェックが成功した場合は、アカウントの詳細がランダムな新パスワードと一緒に E メールで送信されます。認証されたユーザは、次の URL に表示される指示に従うことで、Cisco.com にアカウントを構築できます。

http://www.cisco.com/register

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、ツール等へのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html の『 Cisco IOS IP Mobility Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

ip mobile home-agent

show ip mobile binding

show ip mobile globals

show ip mobile traffic

用語集

気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。これを連結型気付アドレスにすることによって、モバイル ノードまたはモバイル ルータはローカル アドレスを取得して、それぞれのパケットのトンネリングを解除できます。または、外部エージェント気付アドレスにすることによって、外部エージェントはパケットのトンネリングを解除し、モバイル ノードまたはモバイル ルータに転送することができます。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。