Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Mobile IP:MR のマルチパスに対応するポリ シーおよびアプリケーションベースのルー ティング
Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティング
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティング

機能情報の検索

目次

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの前提条件

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの制約事項

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングに関する情報

モバイル ルータのマルチパス サポートの機能設計

モバイル ルータのマルチパス ロードバランシングの動作

モバイル ルータのマルチパス サポートの利点

モバイル ルータのマルチパス サポートの設定方法

モバイル ルータのマルチパス サポートの設定

前提条件

ポリシーに基づいたルーティングとローミング インターフェイスの選択

前提条件

プライオリティ レベルの設定と MR の登録

ローミング インターフェイスのイネーブル化

トラフィック ポリシーの定義

ホーム エージェントのマルチパス サポートの設定

ホーム エージェントでのモビリティ バインディングのクリア

制約事項

モバイル ルータのマルチパス サポートの確認

モバイル ルータのマルチパス サポートの設定例

モバイル ルータのマルチパス サポート:例

ホーム エージェントのマルチパス サポート:例

ローミング プライオリティに基づいた MR の登録:例

mobile-map モバイル ポリシー テンプレートの使用:例

HA へのダイナミック ルート マップの生成:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

Mobile IP:MR のマルチパスに対するポリシーおよびアプリケーションベースのルーティングの機能情報

用語集

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティング

公共の安全機関や公共の輸送機関では、ミッションクリティカルなアプリケーションおよび新規サービスをサポートするため、複数のワイヤレス テクノロジーが採用されている可能性が高いことから、Mobile IP の重要性はますます高まってきています。Mobile IP:モバイル ルータのマルチパス サポート機能が導入されるまで、シスコによる Mobile IP の実装では、Mobile Router(MR; モバイル ルータ)と Home Agent(HA; ホーム エージェント)間で 1 つのトンネルしかサポートされていませんでした。そのため、所定の時間に 1 つのトンネルと 1 つのワイヤレス テクノロジーだけを使用する必要がありました。この機能により、モバイル ルータとホーム エージェント間の複数のパス、およびそれに伴う複数のワイヤレス テクノロジーをサポートし、使用可能なすべてのインターフェイスに対してユーザ トラフィックのロードバランシングを行うことができます。

機能情報の検索

ご使用の Cisco IOS ソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。このモジュール内に記載されている特定の機能のリンクにアクセスする場合、および各機能がサポートされているリリースのリストを参照する場合は、「Mobile IP:MR のマルチパスに対するポリシーおよびアプリケーションベースのルーティングの機能情報」を参照してください。

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/fn からアクセスしてください。Cisco.com のアカウントは必要ありません。

目次

「Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの前提条件」

「Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの制約事項」

「Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングに関する情報」

「モバイル ルータのマルチパス サポートの設定方法」

「モバイル ルータのマルチパス サポートの設定例」

「参考資料」

「コマンド リファレンス」

「Mobile IP:MR のマルチパスに対するポリシーおよびアプリケーションベースのルーティングの機能情報」

「用語集」

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの前提条件

HA と MR の両方にマルチパス サポートを設定する必要があります。

登録を成功させるため、MR と HA 間にセキュリティ アソシエーションを確立する必要があります。

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの制約事項

ポリシーベースのアプリケーション ルーティングには、次の制約事項があります。

登録がアクティブであるときに、mobile-map の設定や ACL テンプレートの設定を変更すると、既存のダイナミック モバイル マップおよび ACL が削除され、新規に生成されます。この処理は、ユーザが「mobile-map」コンフィギュレーション サブモードを終了したときに実行されます。

プライオリティベースのマルチパス登録が唯一のモードであり、デフォルトでイネーブルになります。

MR と HA のいずれでも、ラベルベースのアプリケーション ルーティングはデフォルトでディセーブルになります。MR と HA で別個にイネーブルにすることができます。

アプリケーション ルーティングにマルチパスを設定する必要はありません。アプリケーション ルーティングは、単一パス モードでも動作します。
各 mobile-map エントリで許可される「match」句は、1 つだけです。

HA の ACL テンプレートには、宛先アドレスを設定できます。このような ACL を使用してダイナミック ACL を生成すると、そのダイナミック ACL では、設定されている宛先アドレスが無視され、代わりに MR の mobile-network(s)が使用されます。

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングに関する情報

モバイル ルータのマルチパス サポート機能とポリシーベースのアプリケーション ルーティングを設定する前に、次の概念について理解しておく必要があります。

「モバイル ルータのマルチパス サポートの機能設計」

「モバイル ルータのマルチパス ロードバランシングの動作」

「モバイル ルータのマルチパス サポートの利点」

モバイル ルータのマルチパス サポートの機能設計

モバイル ルータのマルチパス サポート機能によって、MR 機能が複数のインターフェイスに拡張されます。この機能が導入されるまで、MR は複数のローミング インターフェイスでエージェント アドバタイズメントや Collocated Care-of Address(CCoA; 連結型気付アドレス)を受信していました。しかし、登録に利用されるインターフェイスは 1 つだけで、その登録に基づいてトンネルとルートが設定されていました。パケットは、ルーティングやトンネリングの段階で HA に到達していました。HA でパケットの 2 つのカプセル化が行われ、外部エージェントや CCoA にトンネリングされていました。外部エージェントまたは CCoA で一方のカプセル化が解除され、パケットが MR に送信され、そこでもう一方のカプセル化が解除されます。その後に MR が元のパケットをモバイル ネットワーク上の IP デバイスに送信していました。単一のトンネルを使用したモバイル ネットワーク内のルーティングについては、図 1 を参照してください。

図 1 単一のトンネルを使用したモバイル ネットワーク内のルーティング

 

モバイル ルータのマルチパス サポート機能の導入に伴い、MR では使用可能なすべてのローミング インターフェイスを介して HA に登録できるようになりました。各登録は、その他のローミング インターフェイスで行われるその他の登録とは無関係になります。複数のローミング インターフェイスを介して登録された MR には、HA への複数のルートが設定されます。反転トンネルが設定されている場合、MR には複数のパスが設定されます。各トンネルは、それぞれのインターフェイスから開始されます。MR は各ローミング インターフェイスで個別に登録されているので、外部エージェントを使用して 1 つのインターフェイスで登録することも、CCoA を使用してもう 1 つのインターフェイスで登録することもできます。

複数のインターフェイスを介したモバイル ルータの登録については、図 2 を参照してください。

図 2 複数のインターフェイスを介したホーム エージェントへのモバイル ルータの登録

 

登録に成功すると、HA には同じ MR への複数の気付アドレス、モビリティ バインディング、トンネル、およびルートが保持されます。複数のバインディングは、同時バインディングとは異なります。複数のバインディングを伴うトラフィックはすべてのトンネルで複製されるのではなく、トンネル間でのロードバランシングが行われます。つまり、パケットは 1 つのパスだけを通じて送信されます。

モバイル ルータのマルチパス ロードバランシングの動作

MR と HA 間に複数のパスが存在する場合、モバイル ネットワークから HA へのトラフィックには通常ロードバランシングが適用されます。デフォルトの動作では、宛先ごとにロード バランシングが行われます。ただし、ポリシーベースのアプリケーション ルーティングという高度な動作を使用することもできます。ポリシーベースのアプリケーション ルーティングを使用すると、モバイル ネットワークから特定のタイプのトラフィックを識別して、そのトラフィックをルーティングするためのトンネルを選択できます。

ポリシーベースのアプリケーション ルーティングを使用すると、Mobile IP トンネルの反対側にトラフィックをルーティングするためにアプリケーションが使用するローミング インターフェイスを制御できます。この機能により、定義されたポリシーに基づいて、さまざまなモバイル ワイヤレス ネットワーク間でのアプリケーションのルーティングを柔軟に制御できます。アプリケーションには、ローミング インターフェイスのタイプに基づいてポリシー ルーティングが適用されます。ポリシーベースのアプリケーション ルーティングの詳細については、「ポリシーに基づいたルーティングとローミング インターフェイスの選択」を参照してください。

モバイル ルータのマルチパス サポートの利点

モバイル ネットワークには複数のアクセス テクノロジーを導入できるので、モバイル ルータのマルチパス サポート機能を利用することで、Mobile IP の使用時に利用可能なすべてのリンクを活用できるようになります。この複数パスのサポートは、既存のレガシー ワイヤレス接続や新規に購入または導入したワイヤレス テクノロジーの投資保護に役立ちます。

モバイル ルータのマルチパス サポートの設定方法

モバイル ルータのマルチパス サポート機能は、MR ではデフォルトでイネーブルになりますが、HA ではデフォルトでディセーブルになります。この機能を有効にするには、HA と MR の両方にマルチパス サポートを設定する必要があります。MR では、この機能はデフォルトでイネーブルになるので複数の登録が試みられます。ただし、MR は、複数のパスをサポートしていない登録応答を受信すると、HA にマルチパス サポートが設定されていないと判断し、単一パス モードに切り替えます。この機能は、HA ではデフォルトでディセーブルになるので、導入担当のエンジニアがソフトウェアのアップグレードで複数の登録に困惑することはありません。

MR を設定した後は、ポリシーベースのアプリケーション ルーティングと MR のローミング インターフェイスを設定できます。その後は、ローミング インターフェイスをイネーブルにして、トラフィック ポリシーを定義する必要があります。これによって、モバイル ネットワークから特定のタイプのトラフィックを識別し、そのトラフィックのルーティング用にトンネルを選択できるようになります。この機能により、ポリシーに基づいて、さまざまなモバイル ワイヤレス ネットワーク間でのアプリケーションのルーティングを柔軟に制御できます。

ここでは、次の作業について説明します。

「モバイル ルータのマルチパス サポートの設定」

「ポリシーに基づいたルーティングとローミング インターフェイスの選択」

「ホーム エージェントのマルチパス サポートの設定」

「ホーム エージェントでのモビリティ バインディングのクリア」

「モバイル ルータのマルチパス サポートの確認」

モバイル ルータのマルチパス サポートの設定

この作業では、モバイル ルータにマルチパス サポートを設定する方法を示します。

前提条件

登録を成功させるため、MR と HA 間にセキュリティ アソシエーションを確立します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. exit

6. router mobile

7. exit

8. ip mobile router

9. address address mask

10. home-agent ip-address

11. mobile-network interface-type interface number

12. multi-path [ metric { bandwidth | hopcount }]

13. end

手順の詳細
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface loopback0

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

インターフェイスのプライマリ IP アドレスを設定します。

これは、モバイル ルータのホーム アドレスです。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

router mobile

 

Router(config)# router mobile

ルータで Mobile IP をイネーブルにして、ルータ コンフィギュレーション モードを開始します。

ステップ 7

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

ip mobile router

 

Router(config)# ip mobile router

モバイル ルータをイネーブルにして、モバイル ルータ コンフィギュレーション モードを開始します。

ステップ 9

address address mask

 

Router(mobile-router)# address 209.165.200.225 255.255.255.224

モバイル ルータのホーム IP アドレスとネットワーク マスクを設定します。

ステップ 10

home-agent ip-address

 

Router(mobile-router)# home-agent 192.0.2.19

モバイル ルータが登録時に使用するホーム エージェントを指定します。

ステップ 11

mobile-network interface-type interface number

 

Router(mobile-router)# mobile-network Ethernet3/0

モバイル ネットワークに接続するモバイル ルータ インターフェイスを指定します。

ステップ 12

multi-path [ metric { bandwidth | hopcount }]

 

Router(mobile-router)# multi-path

モバイル ルータが複数のパスのサポートを要求できるようにします。

帯域幅は、デフォルト メトリックです。

ステップ 13

end

 

Router(mobile-router)# end

特権 EXEC モードに戻ります。

ポリシーに基づいたルーティングとローミング インターフェイスの選択

このセクションには次のトピックがあります。

「前提条件」

「プライオリティ レベルの設定と MR の登録」

「ローミング インターフェイスのイネーブル化」

「トラフィック ポリシーの定義」

前提条件

入力インターフェイスにモバイル ポリシーが設定されている場合に限り、ポリシーベースのアプリケーション ルーティングが実行されます。

プライオリティ レベルの設定と MR の登録

ポリシーベースのアプリケーション ルーティングと MR のローミング インターフェイスを設定できます。ローミング インターフェイスをイネーブルにする場合は、プライオリティ レベルを設定します。MR は、ローミング インターフェイスの設定に基づいて複数のローミング インターフェイスで登録します。MR の登録には、プライオリティの最も高いインターフェイスだけが利用されます。プライオリティの最も高いインターフェイスが複数存在する場合、MR は登録時に両方のインターフェイスを使用します。プライオリティの最も高いインターフェイスがいずれも使用できない場合、MR は、使用可能なインターフェイスで次にプライオリティの高いものに切り替えます。インターフェイスには、link-type ラベルが設定されています。例については、「ローミング プライオリティに基づいた MR の登録:例」を参照してください。

ラベルは、ローミング インターフェイスに関連付けられている link-type の記述に使用されます。ラベルには、リンク タイプ、実際の帯域幅、または安定性などのパスが示されます。ローミング インターフェイスへのラベルの設定は、 ip mobile router-service link-type コマンドを使用して手動で行う必要があります。

例:

interface ethernet 1/0
ip mobile router-service roam
ip mobile router-service link-type 802.11g

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip mobile router-service roam priority priority level

5. end

手順の詳細
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet0/2

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip mobile router-service roam priority priority-level

 

Router(config-if)# ip mobile router-service roam priority 101

ローミング インターフェイスをイネーブルにして、プライオリティ レベルを設定します。

ip mobile router-service roam コマンドの設定時にプライオリティを指定していないと、ローミング インターフェイスのプライオリティはデフォルトで 100 に設定されます。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

ローミング インターフェイスのイネーブル化

ローミング プライオリティ レベルを設定した後は、ローミング インターフェイスをイネーブルにすることができます。MR は、ローミングインターフェイスの設定に基づいて複数のローミング インターフェイスで登録します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip mobile router-service roam priority priority-level

5. ip mobile router-service link-type label

6. end

手順の詳細
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet0/2

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip mobile router-service roam priority priority-level

 

Router(config-if)# ip mobile router-service roam priority 101

ローミング インターフェイスをイネーブルにして、プライオリティ レベルを設定します。

ip mobile router-service roam コマンドの設定時にプライオリティを指定していないと、ローミング インターフェイスのプライオリティはデフォルトで 100 に設定されます。

ステップ 5

ip mobile router-service link-type label

 

Router(config-if)# ip mobile router-service link-type 802.11g

link-type ローミング インターフェイスをイネーブルにします。

ステップ 6

end

 

Router(config-if)# exit

特権 EXEC モードに戻ります。

トラフィック ポリシーの定義

アプリケーション トラフィックを識別し、ポリシーに基づいたルーティングのパスを選択することによって、トラフィック ポリシーを定義できます。ここでは、次の作業について説明します。

「アプリケーション トラフィックの識別」

「ルーティング パスの選択」

アプリケーション トラフィックの識別

MR と HA の両方で 1 つまたは複数の名前付き拡張 ACL を使用して、アプリケーション トラフィックを識別できます。登録時には MR と HA の名前付き ACL がテンプレートとして使用されて、ダイナミック ルート マップで使用するダイナミック ACL が生成されます。

手順の概要

1. enable

2. configure terminal

3. ip access-list extended access-list name

4. permit udp any any eq port

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip access-list extended access-list name

 

Router(config)# ip access-list extended WEB

名前付き拡張 ACL を設定します。

ステップ 4

permit udp any any eq port

 

Router(config-ext-nacl)# permit udp any any eq 8080

ポリシー ルーティングを適用するアプリケーション トラフィックを識別します。登録時には、これらがテンプレートとして使用されて、ダイナミック ルートマップで使用するダイナミック ACL が生成されます。

ステップ 5

end

 

Router(config-ext-nacl)# end

特権 EXEC モードに戻ります。

ルーティング パスの選択

MR および HA で 1 つまたは複数の mobile-map モバイル ポリシー テンプレートを使用して、ルーティング パスを選択できます。

複数のモバイル ポリシーを MR か HA のいずれかに設定できます。MR では、設定されているモバイル ポリシーごとに別個のダイナミック ルート マップが生成されます。複数の MR 入力インターフェイス(モバイル ネットワーク インターフェイス)にモバイル ポリシーが設定されており、インターフェイスごとに異なるポリシーが設定されています。HA では、1 つのダイナミック ルート マップだけが生成されますが、そのルート マップが最大 3 つの入力インターフェイスに適用されます。HA に複数のモバイル ポリシーが設定されている場合でも、1 つのルートだけが動的に生成され、入力インターフェイスに適用されます。

インターフェイスにアクセスするには、モバイル マップを適用する必要があります。モバイル マップは、「mobile-network」設定で MR のモバイル ネットワーク インターフェイスに関連付けられます。HA の mobile-map の設定では、最大 3 つの「入力」インターフェイスを指定できます。

MR でモバイル ネットワークからのトラフィックを受信すると、そのトラフィックはいずれかの ACL と比較されます。一致があった場合、MR は対応する mobile-map エントリを検出して、トラフィックを送信するローミング インターフェイスを指定します。同様に HA では、指定されている入力インターフェイスのいずれかでモバイル ネットワークのトラフィックを受信すると、いずれかの ACL と比較してから、対応する mobile-map エントリと比較して、トラフィックを送信するトンネルを決定します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip mobile router-service roam priority priority-level

5. ip mobile router-service link-type label

6. exit

7. ip access-list extended access-list name

8. permit udp any any eq port

9. exit

10. ip mobile mobile-map map name

11. match access-list acl

12. set link-type label

13. set interface interface-type number

14. ip mobile router

15. exit

手順の詳細
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet0/2

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip mobile router-service roam priority priority level

 

Router(config-if)# ip mobile router-service roam priority 101

ローミング インターフェイスをイネーブルにして、プライオリティ レベルを設定します。

ip mobile router-service roam コマンドの設定時にプライオリティを指定していないと、ローミング インターフェイスのプライオリティはデフォルトで 100 に設定されます。

ステップ 5

ip mobile router-service link-type label

 

Router(config-if)# ip mobile router-service link-type 802.11g

link-type ローミング インターフェイスをイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

ip access-list extended access-list-name

 

Router(config)# ip access-list extended WEB

名前付き拡張 ACL を設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

permit udp any any eq port

 

Router(config-ext-nacl)# permit udp any any eq 8080

ポリシー ルーティングを適用するアプリケーション トラフィックを識別します。登録時には MR と HA の両方で名前付き拡張 ACL がテンプレートとして使用されて、ダイナミック ルート マップで使用するダイナミック ACL が生成されます。

ステップ 9

exit

 

Router(config-ext-nacl)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

ip mobile mobile-map map name

 

Router(config)# ip mobile mobile-map MPATH_1 10

MR と HA にモバイル ポリシー テンプレートを設定します。

ステップ 11

match access-list acl

 

Router(config)# match access-list WEB

ACL 名を指定します。

ステップ 12

set link-type label

 

Router(config)# set link-type 802.11a GPRS

最大 3 つの link-type ラベルを指定します。

ステップ 13

set interface interface-type number

 

Router(config)# set interface Ethernet1/0

トラフィックをドロップするためのインターフェイスを指定します。

ステップ 14

ip mobile router

 

Router(config)# ip mobile router

モバイル マップを MR の入力インターフェイスと、HA の最大 3 つの入力インターフェイスに適用します。

ステップ 15

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

ホーム エージェントのマルチパス サポートの設定

この作業では、HA にマルチパス サポートを設定する方法を示します。

HA に対するマルチパス サポートの設定および設定解除は、グローバルに行うことができます。複数のパスの設定を解除すると、モバイル ルータが既存の単一パス モードに戻ります。

手順の概要

1. enable

2. configure terminal

3. router mobile

4. exit

5. ip mobile home-agent multi-path [ metric { bandwidth | hopcount }]

6. ip mobile virtual-network net mask [ address address ]

7. ip mobile host lower [ upper ] { interface name | virtual-network net mask }

8. ip mobile mobile-networks lower [ upper ]

9. register

10. multi-path [ metric { bandwidth | hopcount }]

11. exit

手順の詳細
コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router mobile

 

Router(config)# router mobile

ルータで Mobile IP をイネーブルにして、ルータ コンフィギュレーション モードを開始します。

ステップ 4

exit

 

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip mobile home-agent multi-path [ metric { bandwidth | hopcount }]

 

Router(config)# ip mobile home-agent multi-path

ホーム エージェントが、すべてのモバイル ルータに対して複数のパスのサポートを含む登録要求を処理できるようにします。

帯域幅は、デフォルト メトリックです。

ステップ 6

ip mobile virtual-network net mask [ address address ]

 

Router(config)# ip mobile virtual-network 209.165.200.225 255.255.255.224

仮想ネットワークを定義します。ホーム ネットワークが仮想ネットワークであることを指定します。つまり、モバイル ルータはホーム エージェントに物理的に接続していません。ルーティング プロトコルでサブネットを再配布できるように、ネットワークをホーム エージェントの転送テーブルに追加します。

ステップ 7

ip mobile host lower [ upper ] { interface name | virtual-network net mask }

 

Router(config)# ip mobile host 209.165.200.219 255.255.255.224 virtual-network 209.165.200.225 255.255.255.224

モバイル ルータをモバイル ホストとして設定します。IP アドレスは、ホーム ネットワーク内のものです。

interface name オプションは、ホーム エージェントからモバイル ルータへの物理接続を設定します。

ステップ 8

ip mobile mobile-networks lower [ upper ]

 

Router(config)# ip mobile mobile-networks 209.165.200.219 209.165.200.225

モバイル ホストのモバイル ネットワークを設定し、モバイル ネットワーク コンフィギュレーション モードを開始します。 upper 範囲は、動的に登録されるネットワークに対してのみ使用でき、複数のモバイル ルータを一度に設定できます。

範囲は、 ip mobile host コマンドで設定した範囲内にする必要があります。

ステップ 9

register

 

Router(mobile-networks)# register

ホーム エージェントにモバイル ネットワークを動的に登録します。

ステップ 10

multi-path [ metric { bandwidth | hopcount }]

 

Router(mobile-networks)# multi-path

グローバル デフォルト設定値を設定し、ホーム エージェントが特定のモバイル ルータに対して複数のパスのサポートを含む要求を処理できるようにします。帯域幅は、デフォルト メトリックです。

ステップ 11

exit

 

Router(mobile-networks)# no multi-path

特権 EXEC モードに戻ります。

次の作業

HA を設定した後は、トラフィック ポリシーを定義できます。これによって、モバイル ネットワークから特定のトラフィックを識別し、そのトラフィックのルーティング用にトンネルを選択できるようになります。この機能により、ポリシーに基づいて、さまざまなモバイル ワイヤレス ネットワーク間でのアプリケーションのルーティングを柔軟に制御できます。トラフィック ポリシーの定義方法については、「トラフィック ポリシーの定義」を参照してください。

ホーム エージェントでのモビリティ バインディングのクリア

MR IP アドレスとその気付アドレスに関連付けられているモビリティ バインディングを手動でクリアするには、次の作業を実行します。

制約事項

この clear コマンドを実行すると、MR で使用しているセッションが中断されるので注意してください。このコマンドを使用した後、モバイル ルータではローミングを続行するために再登録が必要になります。

手順の概要

1. enable

2. c lear ip mobile binding mr - ip - address [ coa care-of-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

c lear ip mobile binding mr - ip - address [ coa care-of-address ]

 

Router# clear ip mobile binding 192.0.2.72

モビリティ バインディングを削除します。

モバイル ルータに関連付けられている特定の気付アドレスまたはすべての気付アドレスを削除できます。

モバイル ルータのマルチパス サポートの確認

MR のマルチパス サポートを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip mobile binding [ home-agent ip-address | nai string [ session-id string ] | summary ]

3. show ip mobile global

4. show ip mobile mobile-networks

5. show ip mobile tunnel [ interface ]

6. show ip route

7. show ip mobile router

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip mobile binding [ home-agent ip-address | nai string [ session-id string ] | summary ]

 

Router# show ip mobile binding

ホーム エージェントのモビリティ バインディングを表示します。

ステップ 3

show ip mobile global

 

Router# show ip mobile global

モバイル エージェントのグローバル情報を表示します。

ステップ 4

show ip mobile mobile-networks

 

Router# show ip mobile mobile-networks

モバイル ルータに関連付けられているモバイル ネットワークのリストを表示します。

ステップ 5

show ip mobile tunnel [ interface ]

 

Router# show ip mobile tunnel

アクティブ トンネルを表示します。

ステップ 6

show ip route

 

Router# show ip route

ルーティング テーブルの現在の状態を表示します。

ステップ 7

show ip mobile router

 

Router# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

モバイル ルータのマルチパス サポートの設定例

ここでは、次の設定例について説明します。

「モバイル ルータのマルチパス サポート:例」

「ホーム エージェントのマルチパス サポート:例」

「ローミング プライオリティに基づいた MR の登録:例」

「mobile-map モバイル ポリシー テンプレートの使用:例」

「HA へのダイナミック ルート マップの生成:例」

モバイル ルータのマルチパス サポート:例

次に、モバイル ルータにマルチパス サポートを設定する例を示します。

interface Loopback0
! MR home address
ip address 209.165.200.225 255.255.255.224
interface Tunnel101
keep 5 3
interface Ethernet1/0
! MR roaming interface
ip address 209.165.200.239 255.255.255.224
ip mobile router-service roam
interface Ethernet2/0
! MR roaming interface
ip address 209.165.200.246 255.255.255.224
ip mobile router-service roam
interface Ethernet3/0
ip address 209.165.200.247 255.255.255.224
router mobile
ip mobile router
address 209.165.200.251 255.255.255.224
home-agent 192.0.2.12
mobile-network Ethernet3/0
tunnel mode gre
multi-path
template Tunnel101
ip mobile secure home-agent 192.0.2.16 spi 101 key hex 12345678901234567890123456789012

ホーム エージェントのマルチパス サポート:例

次に、ホーム エージェントにマルチパス サポートを設定する例を示します。

interface Ethernet 0/0
ip address 209.165.200.251 255.255.255.224
!
router mobile
exit
ip mobile home-agent multi-path
ip mobile virtual-network 209.165.200.252 255.255.255.224
ip mobile host 192.0.2.10 192.0.2.15 virtual-network 209.165.200.254 255.255.255.224
ip mobile secure host 192.0.2.20 192.0.2.25 spi 101 key hex 12345678901234567890123456789012
ip mobile mobile-networks 192.0.2.40 192.0.2.44
register
ip mobile mobile-networks 192.0.2.57
register
no multi-path
 

ローミング プライオリティに基づいた MR の登録:例

次に、MR の登録時にローミング プライオリティ レベルを選択する例を示します。

次の 4 つのインターフェイスについて考えます。

interface Fastethernet 1/0
ip mobile router-service roam priority 200
ip mobile router-service link-type 802.11g
interface Fastethernet 1/1
ip mobile router-service roam priority 200
ip mobile router-service link-type 802.11g
interface Fastethernet 2/0
ip mobile router-service roam priority 100
ip mobile router-service link-type 802.11g
interface Fastethernet 2/1
ip mobile router-service roam priority 100
ip mobile router-service link-type 802.11g
 

ファスト イーサネット インターフェイス 1/0 と 1/1 はプライオリティ 200 が指定されています。ファスト イーサネット インターフェイス 2/0 と 2/1 はプライオリティ 100 が指定されています。これらの 4 つのインターフェイスをイネーブルにしようとすると、MR は最も高いローミング プライオリティを持っているファスト イーサネット インターフェイス 1/0 と 1/1 の両方で登録します。しかし、ファスト イーサネット インターフェイス 1/0 と 1/1 が使用できない場合、使用可能なインターフェイスで次にプライオリティの高いファスト イーサネット 2/0 と 2/1 で登録します。

mobile-map モバイル ポリシー テンプレートの使用:例

次に、MR と HA で mobile-map モバイル ポリシー テンプレートを使用してルーティング パスを選択する例を示します。

ip mobile mobile-map MPATH_1 10
match access-list WEB
set link-type 802.11g UMTS
set interface null0

HA へのダイナミック ルート マップの生成:例

次に、HA にダイナミック ルート マップを生成する例を示します。

Router# show route-map dynamic
route-map MIP-10/24/06-04:18:15.243-1-MP-HA, permit, sequence 0, identifier 53856096
Match clauses:
ip address (access-lists): VOICE-to-192.0.2.0/24
Set clauses:
interface Tunnel0
Policy routing matches: 0 packets, 0 bytes
Current active dynamic routemaps = 1
 
Router# show ip access-lists dynamic
Extended IP access list VOICE-to-192.0.2.0/24
10 permit icmp any 209.165.200.225 255.255.255.224 tos max-reliability

参考資料

ここでは、Mobile IP:MR のマルチパス サポートに対応するポリシーおよびアプリケーションベースのルーティング機能に関する参考資料を紹介します。

関連資料

関連項目
参照先

Mobile IP コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Mobility Command Reference』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html の『 Cisco IOS IP Mobility Command Reference 』を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup でコマンド検索ツールを使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html で『 Cisco IOS Master Command List, All Releases 』を参照してください。

clear ip mobile binding

debug ip mobile dyn-pbr

ip mobile home-agent multi-path

ip mobile router-service link-type

ip mobile router-service roam

multi-path(モバイル ネットワーク)

multi-path(モバイル ルータ)

show ip mobile binding

show ip mobile globals

show ip mobile mobile-networks

show ip mobile router interface

show ip mobile router registration

show ip mobile tunnel

Mobile IP:MR のマルチパスに対するポリシーおよびアプリケーションベースのルーティングの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/fn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティングの機能情報

機能名
リリース
機能情報

Mobile IP:モバイル ルータのマルチパス サポート

12.4(9)T

この Mobile IP:モバイル ルータのマルチパス サポート機能により、モバイル ルータとホーム エージェント間の複数のパス、およびそれに伴う複数のワイヤレス テクノロジーをサポートし、使用可能なすべてのインターフェイスに対してユーザ トラフィックのロードバランシングを行うことができます。

Mobile IP:MR のマルチパスに対応するポリシーおよびアプリケーションベースのルーティング

12.4(24)T

この機能では、ローミング インターフェイス プライオリティに基づいたモバイル ルータのマルチパス登録、リンクまたはパス タイプに基づいたアプリケーション ルーティング、およびローミング インターフェイス プライオリティに基づいた複数登録をサポートします。

この機能によって、 ip mobile router-service link-type コマンドおよび ip mobile router-service roam コマンドが追加されました。

変更されたコマンドは次のとおりです。

show ip mobile binding、show ip mobile router interface、show ip mobile router registration、show ip mobile tunnel

用語集

エージェント アドバタイズメント :ICMP Router Discovery Protocol(IRDP)に特別な拡張子を付けることによって作成されるアドバタイズメント メッセージ。

外部エージェント :モバイル ノードがアクセスした外部ネットワーク上のルータ。モバイル ノードが登録されている間、そのモバイル ノードにルーティング サービスを提供します。外部エージェントは、モバイル ノードのホーム エージェントによってトンネリングされたパケットのトンネリングを解除して、モバイル ノードまたはモバイル ルータに送信します。パケットがモバイル ノードから送信された場合、外部エージェントは登録モバイル ノードのデフォルト ルータとして動作できます。

気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。これを連結型気付アドレスにすることによって、モバイル ノードまたはモバイル ルータはローカル アドレスを取得して、それぞれのパケットのトンネリングを解除できます。または、外部エージェント気付アドレスにすることによって、外部エージェントはパケットのトンネリングを解除し、モバイル ノードまたはモバイル ルータに転送することができます。

登録 :モバイル ノードがホームから離れているときに、そのモバイル ノードがホーム エージェント上の気付アドレスと関連付けられるプロセス。登録は、モバイル ノードからホーム エージェントに対して直接行うことも、外部エージェントを介して行うこともできます。

トンネル :パケットがホーム エージェントからモバイル ノードまでカプセル化されているときにたどる経路。カプセル化では、パケットは認識可能なカプセル化解除エージェントにルーティングされ、そこでデータグラムのカプセル化が解除され、最終的な宛先に正しく送信されます。

ホーム エージェント :モバイル ノードのホーム ネットワーク上のルータ、または、モバイル ノードがホームから離れているときに、モバイル ノードまたはモバイル ルータにパケットをトンネリングするルータ。 モビリティ バインディング と呼ばれる、登録モバイル ノードの現在位置情報を維持します。

ホーム ネットワーク :ネットワーク プレフィクスがモバイル ノードのホーム アドレスのネットワーク プレフィクスと等しいネットワークまたは仮想ネットワーク。

モバイル ネットワーク :モバイル ルータとともに移動するネットワーク。モバイル ネットワークは、相互に固定されていながら、インターネット全体に対しては 1 つの単位として移動可能な、ホストおよびルートの集合です。

モバイル ノード :接続ポイントがネットワーク間またはサブネット間で変化するホストまたはルータ。モバイル ノードは、自分の IP アドレスを変更せずに自分の位置を変更できます。接続ポイントへのリンクレイヤ接続が有効であれば、場所を問わず自分のホーム IP アドレスを使用したまま、他のインターネット ノードと通信できます。

モバイル ルータ :ルータの役割を持つモバイル ノード。航空機、船、電車、自動車、自転車、カヤック上などでまとまって移動する 1 つまたは複数のネットワーク全体にモビリティを提供します。モバイル ルータが提供するネットワークに接続するノードは、固定ノードにすることも、モバイル ノード、またはルータにすることもできます。

モビリティ バインディング :気付アドレスおよび残りのライフタイムとのホームアドレスの関連付け。

ローミング インターフェイス :モバイル ルータがローミング中に外部エージェントおよびホーム エージェントを検出するために使用されるインターフェイス。登録およびトラフィックはこのインターフェイス上で行われます。