Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Cisco Mobile Networks
Cisco Mobile Networks
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco Mobile Networks

機能概要

Cisco Mobile Networks の主要コンポーネント

モバイル ルータ

ホーム エージェント

モバイル ネットワークのセキュリティ

Cisco Mobile Networks の冗長性

メリット

関連する機能およびテクノロジー

関連資料

サポートされているプラットフォーム

サポートされる標準、管理情報ベース(MIB)、コメント要求(RFC)

前提条件

設定作業

ホーム エージェント サービスのイネーブル化

外部エージェント サービスのイネーブル化

モバイル ルータ サービスのイネーブル化

モバイル ルータ冗長性のイネーブル化

ホーム エージェントの設定の確認

外部エージェントの設定の確認

モバイル ルータの設定の確認

モバイル ルータの冗長性の確認

トラブルシューティングのヒント

モバイル ルータのモニタリングとメンテナス

設定例

ホーム エージェントの例

外部エージェントの例

モバイル ルータの例

Cisco Mobile Networks の冗長性の例

コマンド リファレンス

用語集

Cisco Mobile Networks

機能履歴

リリース
変更内容

12.2(4)T

この機能が追加されました。

12.2(4)T3

この機能のサポートが Cisco 7500 シリーズに追加されました。

12.2(13)T

ダイナミック ネットワークのサポートが追加されました。

このフィーチャ モジュールでは、Cisco Mobile Networks 機能について説明します。ここでは、次の内容について説明します。

「機能概要」

「サポートされているプラットフォーム」

「サポートされる標準、管理情報ベース(MIB)、コメント要求(RFC)」

「前提条件」

「設定作業」

「モバイル ルータのモニタリングとメンテナス」

「設定例」

「コマンド リファレンス」

「用語集」

機能概要

Cisco Mobile Networks 機能を使用すると、モバイル ルータをそのサブネットとともに移動できるようになり、このモバイル ルータ経由で接続している IP ホストに影響を与えることなくすべての IP 接続を維持することができます。

Mobile IP は、RFC 3344 の標準で定義されているように、モバイル ルータが自分のホーム ネットワークにまで戻って接続することを可能にするアーキテクチャを提供します。Mobile IP により、デバイスは、ユーザからはホーム ネットワークに存在しているように見えたまま、ローミングできるようになります。このようなデバイスをモバイル ノードと呼びます。モバイル ノードは、携帯情報端末、ラップトップ コンピュータ、データ対応の携帯電話など、自分の接続ポイントをネットワーク間またはサブネット間で変更できるノードです。このモバイル ノードは、同じ IP アドレスを使用したまま、リンク間を移動し、進行中の通信を維持できます。このソリューションはネットワーク層で提供されるため、アプリケーションの変更は必要ありません。したがって、トランスペアレントなネットワーク モビリティが実現されます。

Cisco Mobile Networks 機能は、Mobile Router(MR; モバイル ルータ)、Home Agent(HA; ホーム エージェント)、および Foreign Agent(FA; 外部エージェント)の 3 つのコンポーネントで構成されます。図 1 に、これら 3 つのコンポーネントと、モバイル ネットワーク内でのそれらの関係を示します。

図 1 Cisco Mobile Networks のコンポーネントおよび関係

 

モバイル ルータは、モバイル ノードと同じように機能しますが、重要な違いが 1 つあります。モバイル ルータでは、ネットワーク全体がローミングできます。たとえば、モバイル ルータを搭載した航空機は、乗客がインターネットに接続したまま、世界中を飛行することができます。こうした通信は、モバイル ネットワーク上のホスト宛のパケットをモバイル ルータがアクセスしている位置にトンネリングする Mobile IP 対応ルータによって実現されます。モバイル ルータは、それらのパケットを宛先デバイスに転送します。

これらの宛先デバイスは、Mobile IP クライアント ソフトウェアを稼動しているモバイル ノードにすることも、ソフトウェアなしのノードにすることもできます。モバイル ルータにより、Mobile IP クライアントは不要になります。実際、モバイル ネットワーク上のノードからは IP モビリティはまったく認識されません。モバイル ルータは、IP ローミングをローカル IP ノードから「隠す」ので、ローカル ノードはホーム ネットワークに直接接続されているように見えます。モバイル ルータの動作の詳細については、このマニュアル内で後述される「モバイル ルータ」を参照してください。

ホーム エージェントは、モバイル ルータのホーム ネットワーク上のルータです。モバイル ネットワークのアンカー ポイントを提供します。ホーム エージェントは、モバイル ルータのホーム IP アドレスとその 気付アドレス (外部またはビジター接続ネットワーク上のモバイル ルータの現在位置)の間のアソシエーションを維持します。ホーム エージェントは、モバイル ルータがローミングする場所の追跡と、モバイル ネットワークの現在位置へのパケットのトンネリングを担当します。また、ホーム エージェントは、モバイル ネットワークを自身の転送テーブルに注入します。ホーム エージェントの動作の詳細については、このマニュアル内で後述される「ホーム エージェント」を参照してください。

外部エージェントは、モバイル ルータがホーム エージェントに現在の気付アドレスを通知するのを支援する外部ネットワーク上のルータです。モバイル ルータに対して接続ポイントの役割を果たし、ホーム エージェントからのパケットをモバイル ルータに配信します。外部エージェントは、モバイル ルータへの直接的な論理接続を持つ固定ルータです。モバイル ルータと外部エージェントは、物理的なワイヤレス リンクで直接接続されている必要はありません。たとえば、モバイル ルータがローミングしていると、外部エージェントとモバイル ルータの間の接続は、同一サブネット上ではないインターフェイス上で起こります。この機能では、外部エージェント コンポーネントに新しい機能が追加されることはありません。

以前のこの機能は、スタブ ルータのみをサポートしたスタティック ネットワークの実装でした。Cisco IOS Release 12.2(13)T では、ダイナミック ネットワークのサポートが追加されています。つまり、モバイル ルータは、自分のモバイル ネットワークをホーム エージェントに動的に登録します。それにより、ホーム エージェントで必要な設定の量が軽減されます。たとえば、ホーム エージェントが 2000 台のモバイル ルータをサポートする場合、ホーム エージェントは、2000 個の設定をする必要はなく、それらのモバイル ルータに使用するホーム IP アドレスの範囲だけを設定します。

この機能では、Cisco Mobile Networks をサポートするために、Mobile IP MIB(RFC2006-MIB)の追加機能が実装されます。これよりも前のリリースでは、RFC2006-MIB のモバイル ノード グループがサポートされていませんでした。

Cisco IOS Release 12.2(4)T では、Cisco Mobile Networks アクティビティのモニタリングと管理のために、RFC2006-MIB のモバイル ノード MIB グループが実装されます。管理対象オブジェクトからのデータは、このマニュアルに記載されている show コマンドを使用することによって返されます。あるいは、SNMP を使用してネットワーク管理システムから取得することができます。

Cisco Mobile Networks の主要コンポーネント

Cisco Mobile Networks 機能では、次の項で説明するように、モバイル ルータが導入され、ホーム エージェント コンポーネントに新しい機能が追加されます。

モバイル ルータ

ホーム エージェント

図 2 に、モバイル ネットワーク内でパケットがどのようにルーティングされるかを示します。以降の項では、このルーティングの実現方法の詳細について説明します。

図 2 Cisco Mobile Networks 内でのルーティング

 

モバイル ルータ

モバイル ルータは、モバイル プラットフォーム上(自動車、航空機、電車、救急医療サービス車両など)に導入されると、そのモバイル ネットワークに接続を提供するローミング ルータとして機能します。モバイル ルータがローミング機能を提供しているため、モバイル ルータに接続されるデバイスは、モバイル ノードである必要はありません。

モバイル ルータのプロセスには、次の項で説明する 3 つの主要なフェーズがあります。

エージェントの検出

登録

ルーティング

エージェントの検出

エージェント検出フェーズ中、ホーム エージェントと外部エージェントは、 エージェント アドバタイズメント と呼ばれるメッセージを定期的にマルチキャストまたはブロードキャストして、それらに接続されたリンク上で自身の存在をアドバタイズします。エージェント アドバタイズメントは、Mobile IP 情報を運ぶ ICMP Router Discovery Protocol(IRDP)メッセージです。このアドバタイズメントには、IRDP ライフタイムが格納されています。これは、エージェントが有効であると見なされる秒数です。このアドバタイズメントには、気付アドレス、外部ネットワーク上の接続ポイント、許容される登録ライフタイム、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)や反転トンネルなどのサポートされているサービスも含まれます。

エージェント検出は、エージェントからの定期的なアドバタイズメントまたはモバイル ルータからの請求によって起こります。

定期的なアドバタイズメントの場合、モバイル ルータは、エージェントからのアドバタイズメントを受信できれば、エージェントがアップ状態であることがわかります。モバイル ルータは、エージェント アドバタイズメントを受信する場合、エージェントの状態をエージェント テーブルで常に把握します。IRDP ライフタイムの期限が切れると、そのエージェントは切断したと見なされ(インターフェイスのダウン、圏外、エージェントのダウンなど)、モバイル ルータはそのエージェントをエージェント テーブルから削除します。

モバイル ルータは、エージェント アドバタイズメントを待つ代わりに、エージェント請求を送信することができます。この請求により、リンク上のすべてのエージェントはただちにエージェント アドバタイズメントを送信します。

モバイル ルータは、ローミング用に設定されたインターフェイス上でこれらのアドバタイズメントを受信し、ホーム ネットワークと外部ネットワークのいずれに接続されているのかを判断します。モバイル ルータは、エージェント アドバタイズメントを受信し、ホーム ネットワークの外に移動したことを検出すると、登録を開始します。これは、プロセスの第 2 フェーズになります。

登録

モバイル ルータには、自分のホーム アドレス、ホーム エージェントの IP アドレスなどのアドレス、およびホーム エージェントのモビリティ セキュリティ アソシエーションが設定されます。モバイル ルータとホーム エージェントの間には、このマニュアル内の「モバイル ネットワークのセキュリティ」で後述されているように、認証用の共有キーが存在します。モバイル ルータは、この情報を外部エージェント アドバタイズメントから得られた情報と組み合わせて、登録要求を作成します。

モバイル ルータは、受信したインターフェイスに基づいて特定のエージェントに登録することを優先します。複数のインターフェイスがエージェント アドバタイズメントを受信すると、ローミング プライオリティ値の最も高いものが優先されます。複数のインターフェイスが同じプライオリティを持つ場合、帯域幅の最も高いものが優先されます。同じ帯域幅のインターフェイスがある場合は、最も大きい IP アドレスのインターフェイスが優先されます。

この優先経路を決定した後、モバイル ルータは、登録要求を送信して、ホーム エージェントに自分の現在の気付アドレスを通知します。モバイル ルータは外部ネットワークに接続しているため、登録要求は、最初に外部ネットワークへ送信されます。

モバイル ルータは、電源を切る場合、またはホーム リンクに再接続すると判断した場合、ホーム エージェントへ登録解除要求を送信して登録を解除します。

登録に成功すると、モバイル ルータのローミングに応じて、パケットをモバイル ネットワークに送受信するためのルーティング メカニズムがセットアップされます。これは、プロセスの第 3 フェーズになります。

ルーティング

ルーティングまたはトンネリング フェーズ中、パケットはホーム エージェントに着信します。ホーム エージェントは、パケットのカプセル化を 2 回実行し、それらを外部エージェントにトンネリングします。外部エージェントは、非カプセル化を 1 回実行し、パケットをモバイル ルータに転送します。モバイル ルータは、非カプセル化をもう 1 回実行します。その後、モバイル ルータはオリジナルのパケットをモバイル ネットワーク上の IP デバイスに転送します。

デフォルトでは、モバイル ネットワーク上のデバイスからのパケットは、モバイル ルータに着信します。モバイル ルータはそれらを外部エージェントに転送し、外部エージェントはそれらを通常どおりルーティングします。

モバイル ネットワークは、ホーム エージェント上で静的に設定することも、動的に登録することもできます。モバイル ルータは、外部エージェント間を移動するたびに、新しい経路を示すようにデフォルト ゲートウェイ定義を持続的に再設定します。モバイル ルータは異なる外部エージェントを経由して登録することもできますが、直前にアクセスした外部エージェントがアクティブな接続を提供します。

反転トンネルは、モバイル ルータが外部エージェントとホーム エージェントにパケットをトンネリングする場合です。この場合、デバイスからのパケットはモバイル ルータに着信します。モバイル ルータは、それらをカプセル化して外部エージェントに送信します。外部エージェントは、それらのパケットをカプセル化してホーム エージェントに転送します。ホーム エージェントは、両方のカプセル化を解除し、オリジナルのパケットをルーティングします。

ホーム エージェント

ホーム エージェントは、モバイル ネットワークのアンカー ポイントを提供します。ホーム エージェントのプロセスには、次の項で説明する 2 つの主要なフェーズがあります。

登録

ルーティング

登録

ホーム エージェントは、モバイル ルータから発信された登録要求を受信した後、その登録要求の有効性を確認します。これには、モバイル ルータの認証も含まれます。登録要求が有効な場合、ホーム エージェントは登録応答を外部エージェント経由でモバイル ルータに送信します。

ホーム エージェントは、モバイル ルータのホーム IP アドレスをモバイル ルータの現在の気付アドレスにマッピングする モビリティ バインディング テーブル も作成します。このテーブル内のエントリは、 モビリティ バインディング と呼ばれます。登録の主な目的は、モバイル ルータ(またはモバイル ノード)のモビリティ バインディングをホーム エージェントにおいて作成、変更、または削除することです。

ホーム エージェントは、モバイル ルータからの登録要求を、モバイル ノードに対するのと同じ方法で処理します。唯一異なるのは、モバイル ルータへの追加のトンネルが作成されることです。つまり、モバイル ネットワーク宛のパケットは、次の「ルーティング」で説明されているように、2 回カプセル化されます。ホーム エージェントは、静的に定義または動的に登録されたモバイル ネットワークを自分の転送テーブルに注入します。これにより、ホーム エージェント上に設定されたルーティング プロトコルでこれらのモバイル ルートを再配布できます。

ルーティング

ホーム エージェントは、モバイル ルータ上のモバイル ネットワークへの到達可能性をアドバタイズします。それにより、それら宛のパケットが着信するようになります。インターネット上のデバイス( コレスポンデント ノード と呼ぶ)がモバイル ネットワーク上のノードにパケットを送信すると、そのパケットはホーム エージェントにルーティングされます。ホーム エージェントは、次の 2 つのエリアにトンネルを構築します。

ホーム エージェントと外部エージェント気付アドレスの間

ホーム エージェントとモバイル ルータの間

ホーム エージェントは、コレスポンデント ノードからのオリジナルのパケットを 2 回カプセル化します。パケットは外部エージェントに着信します。外部エージェントは、HA と FA 気付アドレスのトンネル ヘッダーを非カプセル化して、パケットをモバイル ルータに転送します。モバイル ルータは、非カプセル化をもう 1 回実行して(HA と MR のトンネル ヘッダー)、パケットをモバイル ネットワーク上の宛先ノードに配信します。ネットワークの残りの部分に対し、宛先ノードはホーム エージェントに位置しているように見えます。しかし、実際には、モバイル ルータのモバイル ネットワーク上に存在します。これらのパケットのルーティングを図に表したものについては、図 2を参照してください。

モバイル ネットワークのセキュリティ

モバイル ルータのホーム エージェントには、モバイル ルータのホーム IP アドレスとモバイル ルータ上のモバイル ネットワークが設定されます。Message Digest Algorithm 5(MD5)16 進数キーは、ここでも定義される 128 ビットのキーです。MD5 は、登録メッセージとキーを使用して、 メッセージ ダイジェスト と呼ばれるより小さいデータのかたまりを計算するアルゴリズムです。モバイル ルータとホーム エージェントは、両方とも同じキー( 対称キー と呼ぶ)を持ち、計算の結果を比較することで相互に認証します。両方のキーから同じ結果が得られれば、そのパケットの内容が送信中に変化しなかったことになります。

Mobile IP は、Hash-based Message Authentication Code(HMAC-MD5)もサポートしています。これは、Cisco IOS Release 12.2(13)T 以降でのデフォルトの認証アルゴリズムです。

再送保護は、登録メッセージ内の識別子フィールドをタイムスタンプおよびシーケンス番号として使用します。ホーム エージェントは、自分のタイム スタンプを返して、登録のためにモバイル ルータを同期させます。

Cisco IOS ソフトウェアでは、TACACS+ プロトコルまたは RADIUS プロトコルを使用してアクセス可能な Authentication, Authorization, and Accounting(AAA; 認証、許可、アカウンティング)サーバにモビリティ キーを保管できます。Cisco IOS ソフトウェアの Mobile IP には登録フィルタも用意されており、企業は登録できる人を制限できます。

Mobile IP 環境でのセキュリティの詳細については、『 Cisco IOS IP Configuration Guide , Release 12.2』の「Configuring Mobile IP」の章を参照してください。

Cisco Mobile Networks の冗長性

Cisco Mobile Networks 機能は、Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)を使用して、モバイル ルータの完全冗長機能を提供します。

HSRP は、シスコによって開発されたプロトコルであり、ネットワークの冗長性を提供して、ユーザ トラフィックが障害から透過的に即座に回復することを保証します。HSRP グループは、IP アドレスと MAC(レイヤ 2)アドレスを共有する 2 台以上のルータで構成され、単一の仮想ルータとして機能します。たとえば、Mobile IP トポロジに、トポロジの他の部分からは単一の仮想ホーム エージェントに見える 1 台以上のスタンバイ ホーム エージェントを追加できます。

Mobile IP で冗長性を実現できるように、モバイル ルータのインターフェイス上で特定の HSRP グループ アトリビュートを定義する必要があります。モバイル ルータは、HSRP ステートを認識し、必要に応じてアクティブまたはスタンバイのロールになります。モバイル ルータの冗長性の詳細については、このマニュアル内で後述されている「モバイル ルータ冗長性のイネーブル化」を参照してください。ホーム エージェントの冗長性(HSRP 上で稼動するシスコ独自の機能)の詳細については、『 Cisco IOS IP Configuration Guide , Release 12.2』の「Configuring Mobile IP」の章を参照してください。

HSRP は、外部エージェント上で設定する必要はありません。外部エージェントの冗長性は、ワイヤレスの受信可能範囲を重複させることにより実現されます。

メリット

ネットワーク層でのモビリティ ソリューション

移動する車両内にモバイル ルータを導入した場合、そのルータに接続された多様なデバイスを車両の移動に応じて繰り返し設定することは、不要になります。モバイル ルータは、ネットワーク層で動作し、物理層から独立しているため、セル方式、衛星方式などのワイヤレス メディアや固定メディア上で透過的に動作します。

インターネットへの常時接続

この機能は、インターネットへの常時接続をサポートしており、現在および変化する情報へのアクセスを提供します。たとえば、航空機の操縦士は、飛行中に最新の気象情報にアクセスできます。また、EMS 車両は、病院へ向かいながら緊急治療室の医師と連絡が取れます。

多用途性

任意の IP 対応デバイスをモバイル ルータの LAN ポートに接続し、モビリティを実現できます。モビリティ用に特に設計されていないアプリケーションであっても、アクセスしたり、導入したりできます。

ダイナミック モバイル ネットワーク

ダイナミック ネットワークにより、モバイル ネットワークの動的な登録が可能になります。それにより、ホーム エージェント上での設定が最小限に抑えられ、管理とセットアップが簡単になります。動的な登録に設定した場合、モバイル ルータは、各登録要求でどのネットワークが設定されるかをホーム エージェントに通知できます。ホーム エージェントは、これらのネットワークを転送テーブルに動的に追加するので、ホーム エージェント上でネットワークを静的に定義する必要はありません。

優先経路

優先経路を使用することにより、ネットワーク設計者は、コストを削減したり、特定の通信事業者を使用したりするために、帯域幅やプライオリティに基づいてプライマリ リンクを指定できます。

標準ベースのソリューション

Mobile IP は、インターネットの公式のプロトコル標準に準拠しています。

Mobile IP MIB サポート

Mobile IP MIB のモバイル ノード MIB グループのサポートにより、Cisco IOS コマンド ライン インターフェイスまたは SNMP を使用してモバイル ネットワーク アクティビティをモニタリングできます。詳細については、Cisco.com の ftp://ftp.cisco.com/pub/mibs/v2/ から入手可能な RFC2006-MIB.my ファイル、および RFC 2006『 The Definitions of Managed Objects for IP Mobility Support using SMIv2 』を参照してください。

関連する機能およびテクノロジー

Mobile IP は、『 Cisco IOS IP Configuration Guide 』に記載されています。Mobile IP コンフィギュレーション コマンドは、『 Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services 』に記載されています。

関連資料

Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services , Release 12.2』

Cisco IOS IP Configuration Guide, Release 12.2』

Cisco Mobile Networks--Asymmetric Link Support , Release 12.2(13)T』

サポートされているプラットフォーム

Cisco 2500 シリーズ

Cisco 2600 シリーズ

Cisco 3620 ルータ

Cisco 3640 ルータ

Cisco 3660 ルータ

Cisco 7200 シリーズ

Cisco 7500 シリーズ(Cisco IOS Release 12.2(4)T2 以降のリリース)

Cisco Feature Navigator を使用したプラットフォーム サポートの特定

Cisco IOS ソフトウェアは、特定のプラットフォームがサポートされている機能セットにパッケージングされています。この機能のプラットフォーム サポートに関連した更新情報を取得するには、Cisco Feature Navigator にアクセスします。新しいプラットフォーム サポートが機能に追加されると、Cisco Feature Navigator によって、サポートされているプラットフォームのリストが自動的に更新されます。

Cisco Feature Navigator は Web ベースのツールであり、特定の機能セットがサポートされている Cisco IOS ソフトウェア イメージ、および、特定の Cisco IOS イメージ内でサポートされている機能を素早く特定できます。機能またはリリースごとに検索できます。リリース セクションでは、各リリースを横に並べて比較し、各ソフトウェア リリースに固有の機能と共通機能の両方を表示できます。

Cisco Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウント情報を忘れた場合や紛失した場合は、cco-locksmith@cisco.com に空メールを送信してください。自動チェックにより、ご使用の E メール アドレスが Cisco.com に登録されているか検証されます。チェックが成功した場合は、アカウントの詳細がランダムな新パスワードと一緒に E メールで送信されます。認証されたユーザは、次の URL に表示される指示に従うことで、Cisco.com にアカウントを構築できます。

http://www.cisco.com/register

Cisco Feature Navigator は定期的に更新されています(Cisco IOS ソフトウェアの主要なリリース時およびテクノロジー リリース時)。最新情報については、次の URL から Cisco Feature Navigator ホームページにアクセスしてください。

http://www.cisco.com/go/fn

Cisco IOS ソフトウェア イメージの可用性

特定の Cisco IOS ソフトウェア リリースをサポートしているプラットフォームは、そのプラットフォーム用のソフトウェア イメージがあるかどうかによります。一部のプラットフォームのソフトウェア イメージは、事前の通知なしに延期、遅延、または変更される場合があります。各 Cisco IOS ソフトウェア リリースのプラットフォーム サポートおよび利用可能なソフトウェア イメージの更新情報は、オンライン リリース ノートまたは Cisco Feature Navigator(サポートされている場合)を参照してください。

サポートされる標準、管理情報ベース(MIB)、コメント要求(RFC)

規格

この機能がサポートする新しい規格または変更された規格はありません。

MIB

RFC2006-MIB

CISCO-MOBILE-IP-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対する MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://tools.cisco.com/ITDIT/MIBS/servlet/index

Cisco MIB Locator で必要な MIB 情報がサポートされていない場合は、次の URL にある Cisco MIB ページにアクセスすれば、サポートされている MIB のリストを入手したり、MIB をダウンロードしたりできます。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Cisco MIB Locator にアクセスするには、Cisco.com のアカウントが必要です。アカウント情報を忘れた場合や紛失した場合は、cco-locksmith@cisco.com に空メールを送信してください。自動チェックにより、ご使用の E メール アドレスが Cisco.com に登録されているか検証されます。チェックが成功した場合は、アカウントの詳細がランダムな新パスワードと一緒に E メールで送信されます。認証されたユーザは、次の URL に表示される指示に従うことで、Cisco.com にアカウントを構築できます。

http://www.cisco.com/register

RFC

RFC 2003、『 IP Encapsulation within IP

RFC 2005、『 Applicability Statement for IP Mobility Support

RFC 2006、『 The Definitions of Managed Objects for IP Mobility Support

RFC 3024、『 Reverse Tunneling for Mobile IP, revised

RFC 3344、『 IP Mobility Support for IPv4

前提条件

ルータ上でホーム エージェント機能を設定するには、ローミング サービスを有効にする IP アドレスまたはサブネットを決定する必要があります。仮想ネットワーク上でローミングをサポートする場合は、このサービスを有効にするサブネットを特定し、これらの仮想ネットワークをホーム エージェント上に適切に配置する必要があります。ホーム エージェント機能は、物理サブネットにも、仮想サブネットにもイネーブルにできます。仮想サブネットの場合、 ip mobile virtual-network グローバル コンフィギュレーション コマンドを使用してルータ上に仮想ネットワークを定義する必要があります。

設定作業

Cisco Mobile Networks 機能の設定作業については、次の各項を参照してください。リスト内の各作業は、必須または任意のいずれかに識別されています。

ホーム エージェント サービスのイネーブル化(必須)

外部エージェント サービスのイネーブル化(必須)

モバイル ルータ サービスのイネーブル化(必須)

モバイル ルータ冗長性のイネーブル化(任意)

ホーム エージェントの設定の確認(任意)

外部エージェントの設定の確認(任意)

モバイル ルータの設定の確認(任意)

モバイル ルータの冗長性の確認(任意)

ホーム エージェント サービスのイネーブル化

ホーム エージェントは、動的に登録されたモバイル ネットワークと静的に設定されたモバイル ネットワークの両方で設定できます。ただし、静的に設定されたモバイル ネットワークは、同じネットワークの動的な登録よりも常に優先されます。

ルータ上でホーム エージェント サービスをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 2

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 3

Router(config)# ip mobile home-agent [ address ip-address ][ broadcast ] [ care-of-access acl ] [ lifetime number ] [ replay seconds ] [ reverse-tunnel-off ] [ roam-access acl ] [ suppress-unreachable ]

 

ホーム エージェント サービスをイネーブルにします。

ステップ 4

Router(config)# ip mobile virtual-network net mask [ address address ]

仮想ネットワークを定義します。ホーム ネットワークが仮想ネットワークであることを指定します。つまり、モバイル ルータはホーム エージェントに物理的に接続していません。ルーティング プロトコルでサブネットを再配布できるように、ネットワークをホーム エージェントの転送テーブルに追加します。

仮想ネットワークを使用しない場合は、ステップ 8 に進みます。

ステップ 5

Router(config-router)# router protocol

ルーティング プロトコルを設定します。

ステップ 6

Router(config)# redistribute mobile [ metric metric-value ] [ metric-type type-value ]

ルーティング プロトコルへの仮想ネットワークの再配布をイネーブルにします。

ステップ 7

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

Router(config)# ip mobile host lower [ upper ] { interface name | virtual-network net mask } [ lifetime number ]

モバイル ルータをモバイル ホストとして設定します。IP アドレスは、ホーム ネットワーク内のものです。

interface name オプションは、ホーム エージェントからモバイル ルータへの物理接続を設定します。

ステップ 9

Router(config)# ip mobile mobile-networks lower [ upper ]

モバイル ホストのモバイル ネットワークを設定し、モバイル ネットワーク コンフィギュレーション モードを開始します。 upper 範囲は、動的に登録されるネットワークに対してのみ使用でき、複数のモバイル ルータを一度に設定できます。

範囲は、 ip mobile host コマンドで設定された範囲と一致する必要があります。

ステップ 10

Router(mobile-networks)# description string

(任意)説明をモバイル ルータ設定に追加します。

ステップ 11

Router(mobile-networks)# network net mask

(任意)モバイル ルータに接続されているネットワークをモバイル ネットワークとして設定します。このコマンドを使用して、ネットワークを静的に設定します。

ステップ 12

Router(mobile-networks)# register

(任意)モバイル ネットワークをホーム エージェントに動的に登録します。ホーム エージェントは、この登録プロセスによってモバイル ネットワークについて学習します。モバイル ルータが自分のモバイル ネットワークをホーム エージェント上で登録するとき、ホーム エージェントは、モバイル ネットワーク設定を検索し、 register コマンドが設定されていることを確認してから、モバイル ネットワークへの転送エントリを追加します。

register コマンドが設定されていない場合、ホーム エージェントは、モバイル ネットワークを動的に登録しようとするモバイル ルータの試みを拒否します。

ステップ 13

Router(mobile-networks)# exit

モバイル ネットワーク コンフィギュレーション モードを終了します。

ステップ 14

Router(config)# ip mobile secure host address { inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string

モバイル ホスト セキュリティ アソシエーションを設定します。これは、モバイル ルータが登録要求で送信するときに使用するセキュリティ アソシエーションです。ホーム エージェントとモバイル ルータの間の SPI とキーが既知です。アドレスは、モバイル ルータのホーム IP アドレスです。

外部エージェント サービスのイネーブル化

ダイナミック ネットワークのサポートの追加に伴う外部エージェント設定の変更はありません。

デフォルトのサービスを提供する外部エージェントを開始するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 2

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 3

Router(config)# ip mobile foreign-agent care-of interface

少なくとも 1 つの気付アドレスが設定されているときに外部エージェント サービスをイネーブルにします。これは、外部エージェントとホーム エージェントの間のトンネルの外部ネットワーク終端ポイントです。気付アドレスは、インターフェイスの IP アドレスです。インターフェイスは、物理であってもループバックであっても、アクセス先のインターフェイスと同じである必要はありません。

ステップ 4

Router(config)# interface type number

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

Router(config-if)# ip address ip-address mask

インターフェイスのプライマリ IP アドレスを設定します。

ステップ 6

Router(config-if)# ip irdp

インターフェイスで IRDP 処理をイネーブルにします。

ステップ 7

Router(config-if)# ip irdp maxadvertinterval seconds

(任意)アドバタイズメントの最大間隔を秒単位で指定します。

ステップ 8

Router(config-if)# ip irdp minadvertinterval seconds

(任意)アドバタイズメントの最小間隔を秒単位で指定します。

ステップ 9

Router(config-if)# ip irdp holdtime seconds

 

(任意)アドバタイズメントが有効な秒単位の時間の長さ。デフォルトは、 maxadvertinterval 期間の 3 倍です。

ステップ 10

Router(config-if)# ip mobile foreign-service

インターフェイスで外部エージェント サービスをイネーブルにします。また、これにより、気付アドレス、ライフタイム、サービス フラグなどの Mobile IP 情報がアドバタイズメントに追加されます。

モバイル ルータ サービスのイネーブル化

モバイル ルータ サービスをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 2

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 3

Router(config)# ip mobile router

モバイル ルータをイネーブルにして、モバイル ルータ コンフィギュレーション モードを開始します。

ステップ 4

Router(mobile-router)# address address mask

モバイル ルータのホーム IP アドレスとネットワーク マスクを設定します。

ステップ 5

Router(mobile-router)# home-agent ip-address

モバイル ルータが登録時に使用するホーム エージェントを指定します。

ステップ 6

Router(mobile-router)# mobile-network interface

(任意)ダイナミック モバイル ネットワークに接続されているモバイル ルータ インターフェイスを指定します。1 台のモバイル ルータ上に複数のモバイル ネットワークを設定できます。モバイル ルータの登録には、これらのモバイル ネットワークが含まれます。

ステップ 7

Router(mobile-router)# register { extend expire seconds retry number interval seconds | lifetime seconds | retransmit initial milliseconds maximum milliseconds retry number }

(任意)モバイル ルータの登録パラメータを制御します。

ステップ 8

Router(mobile-router)# reverse-tunnel

(任意)反転トンネル機能をイネーブルにします。

ステップ 9

Router(mobile-router)# exit

モバイル ルータ コンフィギュレーション モードを終了します。

ステップ 10

Router(config)# ip mobile secure home-agent address { inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string

ホーム エージェント セキュリティ アソシエーションをセットアップします。モバイル ルータとホーム エージェントの間の SPI とキーが既知です。アドレスは、ホーム エージェントのホーム IP アドレスです。

ステップ 11

Router(config)# interface type number

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 12

Router(config-if)# ip address ip-address mask

インターフェイスのプライマリ IP アドレスを設定します。

ステップ 13

Router(config-if)# ip mobile router-service { hold-down seconds | roam [ priority value ] | solicit [ interval seconds ] [ retransmit initial min maximum seconds retry number ]}

インターフェイス上でローミングなどのモバイル ルータ サービスをイネーブルにします。

モバイル ルータ冗長性のイネーブル化

モバイル ルータ冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# standby [ group-number ] ip [ ip-address [ secondary ]]

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby priority priority

アクティブ ルータの選択時に使用されるホット スタンバイ プライオリティを設定します。

ステップ 3

Router(config-if)# standby preempt

プリエンプション処理するようにルータを設定します。つまり、ローカル ルータが現在のアクティブ ルータよりも高いホット スタンバイ プライオリティを持つ場合、そのローカル ルータはアクティブ ルータとして制御の引き継ぎを試みます。

ステップ 4

Router(config-if)# standby name group-name

スタンバイ グループの名前を設定します。

ステップ 5

Router(config-if)# standby [ group-number ] track interface-type interface-number [ interface-priority ]

ホット スタンバイ プライオリティが他のインターフェイスの可用性に基づいて変化するように、インターフェイスを設定します。 interface-priority 引数には、インターフェイスがダウン(またはアップ状態に復帰)したときに、ルータのホット スタンバイ プライオリティを減少(または増加)させる量を指定します。デフォルト値は 10 です。

ステップ 6

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 7

Router(config)# ip mobile router

モバイル ルータをイネーブルにします。

ステップ 8

Router(mobile-router)# redundancy group name

モバイル ルータの耐障害性を設定します。 name 引数は、 standby name group-name コマンドで指定された名前と一致する必要があります。

HSRP は、モバイル ルータのローミング インターフェイスと物理モバイル ネットワークに接続されたインターフェイスの両方に設定する必要はありません。一方のインターフェイスに HSRP を設定し、もう一方のインターフェイス上で standby track コマンドを設定すれば、冗長メカニズムは機能します。設定例については、「Cisco Mobile Networks の冗長性の例」を参照してください。

ホーム エージェントの設定の確認

ホーム エージェントの設定を確認するには、必要に応じて次のコマンドを特権 EXEC モードで使用します。

 

コマンド
目的

Router# show ip mobile mobile-networks [ address ]

モバイル ルータに関連付けられたモバイル ネットワークのリストを表示します。

Router# show ip mobile host [ address ]

モバイル ノード情報を表示します。

Router# show ip mobile secure host [ address ]

モバイル ホストのモビリティ セキュリティ アソシエーションを表示します。

外部エージェントの設定の確認

外部エージェントの設定を確認するには、必要に応じて次のコマンドを特権 EXEC モードで使用します。

 

コマンド
目的

Router# show ip mobile global

モバイル エージェントのグローバル情報を表示します。

Router# show ip mobile interface

外部エージェント サービスを提供しているか、モバイル ノードのホーム リンクになっているインターフェイスのアドバタイズメント情報を表示します。

モバイル ルータの設定の確認

モバイル ルータの設定を確認するには、必要に応じて次のコマンドを特権 EXEC モードで使用します。

 

コマンド
目的

Router# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

Router# show ip mobile router traffic

モバイル ルータが保持するカウンタを表示します。

モバイル ルータの冗長性の確認

モバイル ルータの冗長性がルータ上で正しく設定されていることを確認するには、必要に応じて次のコマンドを特権 EXEC モードで使用します。

 

コマンド
目的

Router# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

Router# show ip mobile router traffic

モバイル ルータが保持するカウンタを表示します。

Router# show standby

HSRP 情報を表示します。

トラブルシューティングのヒント

ip irdp maxadvertinterval seconds インターフェイス コンフィギュレーション コマンドを使用して外部エージェント上のエージェント アドバタイズメント間隔の値を調整します。最初にタイマーを 10 秒に設定し、必要に応じて調整します。

モバイル ルータ上のサブネットを ping できるようにするには、モバイル ルータをホーム エージェントに登録し、モバイル ネットワーク(サブネット)をホーム エージェント上で静的に設定するか、動的に登録する必要があります。

ローミング インターフェイス用の拡張 ping を使用します。モバイル ルータからの ping には、拡張 ping の送信元アドレスとしてモバイル ルータのホーム アドレスを設定する必要があります。標準 ping は、送信元アドレスとしてローミング インターフェイスの送信元アドレスが設定されます。これは、そのローミング インターフェイスがホーム エージェント上で静的に設定されない限り、ネットワークの残りの領域から見てルーティング不可能です。

リターン トラフィックをモバイル ルータへ返送できるように、ホーム エージェント上のモバイル サブネットを再配布します。ほとんどのルーティング プロトコルでは、再配布用にデフォルトのメトリックが設定されている必要があります。

外部エージェントからホーム エージェントへのリターン ルートを確立します。

モバイル ルータはスタブ ルータとして機能するため、モバイル ルータの背後にルータを設置しないようにします。

静的に設定されたモバイル ネットワークは、動的に登録された同じモバイル ネットワークよりも優先されます。

モバイル ネットワークは、一度に 1 台のモバイル ルータだけで設定または登録できます。

モバイル ルータのモニタリングとメンテナス

モバイル ルータのモニタリングとメンテナスを行うには、必要に応じて次のコマンドを特権 EXEC モードで使用します。

 

コマンド
目的

Router# clear ip mobile router agent

学習されたエージェントとそれに対応する外部エージェントの気付アドレスをモバイル ルータ エージェント テーブルから削除します。

Router# clear ip mobile router registration

登録エントリをモバイル ルータ登録テーブルから削除します。

Router# clear ip mobile router traffic

モバイル ルータが保持するカウンタをクリアします。

Router# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

Router# show ip mobile router agent

モバイル ルータのエージェントに関する情報を表示します。

Router# show ip mobile router interface

モバイル ルータがローミングに使用しているインターフェイスの情報を表示します。

Router# show ip mobile router registration

モバイル ルータの保留中の登録および許可された登録を表示します。

Router# show ip mobile router traffic

モバイル ルータが保持するカウンタを表示します。

Router# debug ip mobile router [ detail ]

モバイル ルータのデバッグ メッセージを表示します。

設定例

ここでは、次の設定例について説明します。

ホーム エージェントの例

外部エージェントの例

モバイル ルータの例

Cisco Mobile Networks の冗長性の例

以降の例では、ホーム エージェントが 3 台のモバイル ルータにサービスを提供します。各モバイル ルータには、ローミング時に衛星リンクとワイヤレス LAN リンクがあります。それぞれに、さらに分割可能なネットワークが割り当てられています。

モバイル ルータ上のモバイル ネットワークは、ホーム エージェント上で静的な設定と動的な登録の両方が行われ、モバイル ルータは外部エージェント経由でローミングします。

設定例のトポロジについては、図 3を参照してください。

図 3 ホーム エージェントが 3 台のモバイル ルータをサポートしているトポロジ

 

ホーム エージェントの例

次に、ホーム エージェントが 3 台のモバイル ルータにサービスを提供する例を示します。ホーム エージェントは仮想ネットワークへの到達可能性をアドバタイズします。

interface Loopback 0
ip address 1.1.1.1 255.255.255.255
router mobile
!
! Virtual network advertised by HA is the home network of the MR
ip mobile virtual-network 10.1.0.0 255.255.0.0
ip mobile host 10.1.0.1 virtual-network 10.1.0.0 255.255.0.0
ip mobile host 10.1.0.2 virtual-network 10.1.0.0 255.255.0.0
ip mobile host 10.1.0.3 10.1.0.10 virtual-network 10.1.0.0 255.255.0.0 aaa load-sa
!
! Associated host address that informs HA that 10.1.0.1 is actually an MR
ip mobile mobile-networks 10.1.0.1
! Static config of MR's mobile networks
description jet
network 172.6.1.0 255.255.255.0
network 172.6.2.0 255.255.255.0
!
! Associated host address that informs HA that 10.1.0.2 is actually an MR
ip mobile mobile-networks 10.1.0.2
! One static mobile network; MR may also dynamically register mobile nets
description ship
network 172.7.1.0 255.255.255.0
register
!
! Range of hosts that are MRs
ip mobile mobile-networks 10.1.0.3 10.1.0.10
! All can dynamically register their mobile networks
register
!
ip mobile secure host 10.1.0.1 spi 101 key hex 12345678123456781234567812345678
ip mobile secure host 10.1.0.2 spi 102 key hex 23456781234567812345678123456781

外部エージェントの例

次に、外部エージェントがシリアル インターフェイス 0 上でサービスを提供する例を示します。

router mobile
ip mobile foreign-agent care-of serial0
!
interface serial0
ip irdp
ip irdp maxadvertinterval 4
ip irdp minadvertinterval 3
ip irdp holdtime 12
ip mobile foreign-service

モバイル ルータの例

次に、3 台のモバイル ルータがモバイル ネットワークにサービスを提供する例を示します。

モバイル ルータ 1

interface loopback0
! MR home address
ip address 10.1.0.1 255.255.255.255
!
interface serial 0
! MR roaming interface
ip address 172.21.58.253 255.255.255.252
ip mobile router-service roam
interface ethernet 0
! MR roaming interface
ip address 172.21.58.249 255.255.255.252
ip mobile router-service roam
interface ethernet 1
ip address 172.6.1.1 255.255.255.0
interface ethernet 2
ip address 172.6.2.1 255.255.255.0
!
!
router mobile
ip mobile router
address 10.1.0.1 255.255.0.0
home-agent 1.1.1.1
ip mobile secure home-agent 1.1.1.1 spi 101 key hex 12345678123456781234567812345678

モバイル ルータ 2

interface loopback0
! MR home address
ip address 10.1.0.2 255.255.255.255
!
interface serial 0
! MR roaming interface
ip address 172.21.58.245 255.255.255.252
ip mobile router-service roam
interface ethernet 0
! MR roaming interface
ip address 172.21.58.241 255.255.255.252
ip mobile router-service roam
interface ethernet 1
ip address 172.7.1.1 255.255.255.0
interface ethernet 2
ip address 172.7.2.1 255.255.255.0
!
!
router mobile
ip mobile router
address 10.1.0.2 255.255.0.0
home-agent 1.1.1.1
mobile-network ethernet 2
ip mobile secure home-agent 1.1.1.1 spi 102 key hex 23456781234567812345678123456781

モバイル ルータ 3

interface loopback0
! MR home address
ip address 10.1.0.3 255.255.255.255
!
interface serial 0
! MR roaming interface
ip address 172.21.58.237 255.255.255.252
ip mobile router-service roam
interface ethernet 0
! MR roaming interface
ip address 172.21.58.233 255.255.255.252
ip mobile router-service roam
interface ethernet 1
ip address 172.8.1.1 255.255.255.0
interface ethernet 2
ip address 172.8.2.1 255.255.255.0
!
!
router mobile
ip mobile router
address 10.1.0.3 255.255.0.0
home-agent 1.1.1.1
mobile-network ethernet 1
mobile-network ethernet 2
ip mobile secure home-agent 1.1.1.1 spi 103 key hex 45678234567812312345678123456781
!

Cisco Mobile Networks の冗長性の例

Cisco Mobile Networks には、ホーム エージェントの冗長性、外部エージェントの冗長性、およびモバイル ルータの冗長性からなる 3 つのレベルの冗長性があります。

ホーム エージェントの例では、2 台のホーム エージェントがホーム エージェント コンポーネントの冗長性を提供します。一方のホーム エージェントに障害が発生すると、パケットが失われないように、スタンバイ ホーム エージェントがただちにアクティブになります。HSRP は、HSRP グループ名などの HSRP アトリビュートとともに、ホーム エージェント上で設定されます。したがって、トポロジの残りの領域は、これらのホーム エージェントを単一の仮想ホーム エージェントとして扱い、フェールオーバーはすべて透過的になります。

モバイル ネットワークは、モバイル ルータが登録されたときにホーム エージェントがそれらのネットワークをルーティング テーブルに注入することを認識できるように、ホーム エージェント上でも定義されます。

外部エージェントの例では、2 台のルータが外部エージェント サービスを提供します。外部エージェント上で設定しなければならない固有の冗長性機能はありません。ワイヤレスの受信可能範囲を重複させることで、冗長性が提供されます。

モバイル ルータは、HSRP を使用して冗長性を提供します。モバイル ルータのグループ名は、HSRP グループ名と関連付けられます。モバイル ルータは、HSRP ステートを認識します。HSRP がアクティブ ステートのとき、モバイル ルータはアクティブです。HSRP が非アクティブ ステートの場合、モバイル ルータはパッシブです。アクティブ モバイル ルータに障害が発生すると、スタンバイ モバイル ルータがアクティブになり、ローミング インターフェイスから請求を送出して外部エージェントについて学習し、登録を実行します。

HSRP がイネーブルの LAN 上で 2 台のモバイル ルータが相互に接続されている冗長ネットワークのトポロジ例については、図 4を参照してください。

図 4 Cisco Mobile Networks の冗長性のトポロジ

 

ホーム エージェント 1(HA1)の設定

interface Ethernet1/1
ip address 100.100.100.3 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
duplex half
standby ip 100.100.100.1
standby priority 100
standby preempt delay sync 60
!HSRP group name
standby name HA_HSRP2
!
router mobile
!
router rip
version 2
redistribute mobile
network 100.0.0.0
default-metric 1
!
ip classless
ip mobile home-agent
! Maps to HSRP group name
ip mobile home-agent redundancy HA_HSRP2 virtual-network address 100.100.100.1
ip mobile virtual-network 70.70.70.0 255.255.255.0
ip mobile host 70.70.70.70 virtual-network 70.70.70.0 255.255.255.0
ip mobile mobile-networks 70.70.70.70
description san jose jet
! Mobile Networks
network 20.20.20.0 255.255.255.0
network 10.10.10.0 255.255.255.0
ip mobile secure host 70.70.70.70 spi 100 key hex 12345678123456781234567812345678
ip mobile secure home-agent 100.100.100.2 spi 300 key hex 12345678123496781234567812345678

ホーム エージェント 2(HA2)の設定

interface Ethernet1/1
ip address 100.100.100.2 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
standby ip 100.100.100.1
standby priority 95
standby preempt delay sync 60
! HSRP group name
standby name HA_HSRP2
!
router mobile
!
router rip
version 2
redistribute mobile
network 100.0.0.0
default-metric 1
!
ip classless
ip mobile home-agent
!Maps to HSRP group name
ip mobile home-agent redundancy HA_HSRP2 virtual-network address 100.100.100.1
ip mobile virtual-network 70.70.70.0 255.255.255.0
ip mobile host 70.70.70.70 virtual-network 70.70.70.0 255.255.255.0
ip mobile mobile-networks 70.70.70.70
description san jose jet
!Mobile Networks
network 20.20.20.0 255.255.255.0
network 10.10.10.0 255.255.255.0
ip mobile secure host 70.70.70.70 spi 100 key hex 12345678123456781234567812345678
ip mobile secure home-agent 100.100.100.1 spi 300 key hex 12345978123456781234567812345678

外部エージェント 1(FA1)の設定

interface Ethernet0
ip address 171.69.68.2 255.255.255.0
media-type 10BaseT
!
interface Ethernet1
ip address 80.80.80.1 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
ip mobile foreign-service
media-type 10BaseT
!
router mobile
!
router rip
version 2
network 80.0.0.0
network 100.0.0.0
!
ip classless
no ip http server
ip mobile foreign-agent care-of Ethernet1

外部エージェント 2(FA2)の設定

interface Ethernet1
ip address 171.69.68.1 255.255.255.0
media-type 10BaseT
!
interface Ethernet2
ip address 80.80.80.2 255.255.255.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip irdp holdtime 30
ip mobile foreign-service
media-type 10BaseT
!
router mobile
!
router rip
version 2
network 80.0.0.0
network 100.0.0.0
!
ip classless
no ip http server
ip mobile foreign-agent care-of Ethernet2

モバイル ルータ 1 の設定

interface Ethernet5/2
! MR roaming interface
ip address 70.70.70.4 255.255.255.0
ip mobile router-service roam
! Configure redundancy for mobile router using HSRP
standby ip 70.70.70.70
standby priority 105
standby preempt
standby name MR_HSRP2
standby track Ethernet5/4
!
interface Ethernet5/4
! Interface to Mobile Network
ip address 20.20.20.2 255.255.255.0
!
router mobile
!
router rip
version 2
passive-interface Ethernet5/2
network 20.0.0.0
network 70.0.0.0
!
ip classless
no ip http server
ip mobile secure home-agent 100.100.100.100 spi 100 key hex 12345678123456781234567812345678
ip mobile router
! Maps to HSRP group name
redundancy group MR_HSRP2
! Using roaming interface hot address as MR address
address 70.70.70.70 255.255.255.0
home-agent 100.100.100.1

モバイル ルータ 2 の設定

interface Ethernet1/2
! MR roaming interface
ip address 70.70.70.3 255.255.255.0
ip mobile router-service roam
! Configure redundancy for mobile router using HSRP
standby ip 70.70.70.70
standby priority 100
standby preempt
standby name MR_HSRP2
standby track Ethernet1/4
!
interface Ethernet1/4
! Interface to Mobile Network
ip address 20.20.20.1 255.255.255.0
!
router mobile
!
router rip
version 2
passive-interface Ethernet1/2
network 20.0.0.0
network 70.0.0.0
!
ip classless
no ip http server
ip mobile secure home-agent 100.100.100.100 spi 100 key hex 12345678123456781234567812345678
ip mobile router
! Maps to HSRP group name
redundancy group MR_HSRP2
! Using roaming interface hot address as MR address
address 70.70.70.70 255.255.255.0
home-agent 100.100.100.1

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html の『 Cisco IOS IP Mobility Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

address(モバイル ルータ)

clear ip mobile router agent

clear ip mobile router registration

clear ip mobile router traffic

debug ip mobile

debug ip mobile router

description(モバイル ネットワーク)

home-agent

ip mobile mobile-networks

ip mobile router

ip mobile router-service

mobile-network

network(モバイル ネットワーク)

redundancy group

register(モバイル ネットワーク)

register(モバイル ルータ)

reverse-tunnel

show ip mobile binding

show ip mobile host

show ip mobile mobile-networks

show ip mobile router

show ip mobile router agent

show ip mobile router interface

show ip mobile router registration

show ip mobile router traffic

用語集

MTU :Maximum Transmission Unit(最大伝送ユニット)。個別のインターフェイスで処理可能な最大パケット サイズ(バイト単位)。

SPI :Security Parameter Index(セキュリティ パラメータ インデックス)。一対のノード間のセキュリティ コンテキストを識別するインデックス。ホーム エージェント上で、SPI により、どの共有秘密を使用して md5 ハッシュ値を計算するか特定されます。

エージェント アドバタイズメント :ICMP Router Discovery Protocol(IRDP)に特別な拡張を付加して構築されたアドバタイズメント メッセージ。

エージェント検出 :モバイル ノードまたはモバイル ルータがホーム ネットワークと外部ネットワークのいずれに現在接続しているのかを自分で判定し、移動したのかどうか、移動中なのかどうかを検出する方法。モバイル ノードまたはモバイル ルータがモビリティ エージェントを照会し、検出するメカニズムです。エージェント検出は、ICMP Router Discovery Protocol(IRDP)(RFC 1256)の拡張機能であり、モビリティ サービスを潜在ユーザにアドバタイズするメカニズムが組み込まれています。

エージェント請求 :モバイル ノードまたはモバイル ルータから送信されるエージェント アドバタイズメント要求。

外部エージェント :モバイル ノードがアクセスした外部ネットワーク上のルータ。モバイル ノードが登録されている間、そのモバイル ノードにルーティング サービスを提供します。外部エージェントは、モバイル ノードのホーム エージェントによってトンネリングされたパケットのトンネリングを解除して、モバイル ノードまたはモバイル ルータに送信します。パケットがモバイル ノードから送信された場合、外部エージェントは登録モバイル ノードのデフォルト ルータとして動作できます。

外部ネットワーク :モバイル ノードのホーム ネットワーク以外のネットワーク。

仮想ネットワーク :ルータから先の物理的な実体のないネットワーク(別のネットワークに対する物理ネットワーク インターフェイスがルータに存在する)。ルータ(ホーム エージェントなど)は、一般に、従来のルーティング プロトコルを使用して仮想ネットワークへの到達可能性をアドバタイズします。

気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。これを連結型気付アドレスにすることによって、モバイル ノードまたはモバイル ルータはローカル アドレスを取得して、それぞれのパケットのトンネリングを解除できます。または、外部エージェント気付アドレスにすることによって、外部エージェントはパケットのトンネリングを解除し、モバイル ノードまたはモバイル ルータに転送することができます。

コレスポンデント ノード :モバイル ノードの通信相手となるピア。コレスポンデント ノードは、固定にすることも、モバイルにすることもできます。

登録 :モバイル ノードがホームから離れているときに、そのモバイル ノードがホーム エージェント上の気付アドレスと関連付けられるプロセス。登録は、モバイル ノードからホーム エージェントに対して直接行うことも、外部エージェントを介して行うこともできます。

トンネル :パケットがホーム エージェントからモバイル ノードまでカプセル化されているときにたどる経路。このモデルでは、カプセル化されたパケットは、認識可能なカプセル化解除エージェントにルーティングされます。このエージェントにより、データグラムのカプセル化が解除され、最終的な宛先へ正しく配信されます。

ノード :ホストまたはルータ。

ビジター接続ネットワーク :モバイル ノードのホーム ネットワーク以外で、モバイル ノードが現在接続されているネットワーク。

ビジター リスト :外部エージェントにアクセスしているモバイル ノードのリスト。

ホーム アドレス :モバイル ノードに長期間割り当てられる IP アドレス。インターネットへのノードの接続位置が変更されても変化しません。

ホーム エージェント :モバイル ノードのホーム ネットワーク上のルータ。モバイル ノードまたはモバイル ルータがホームから離れているときに、それらへのパケットをトンネリングします。 モビリティ バインディング と呼ばれる登録モバイル ノードの現在の位置情報を維持します。

ホーム ネットワーク :ネットワーク プレフィクスがモバイル ノードのホーム アドレスのネットワーク プレフィクスと等しいネットワークまたは仮想ネットワーク。

モビリティ エージェント :ホーム エージェントまたは外部エージェント。

モビリティ バインディング :気付アドレスおよび残りのライフタイムとのホームアドレスの関連付け。

モバイル ネットワーク :モバイル ルータとともに移動するネットワーク。モバイル ネットワークは、相互に固定されていながら、インターネット全体に対しては 1 つの単位として移動可能な、ホストおよびルートの集合です。

モバイル ノード :接続ポイントがネットワーク間またはサブネット間で変化するホストまたはルータ。モバイル ノードは、自分の IP アドレスを変更せずに自分の位置を変更できます。接続ポイントへのリンクレイヤ接続が有効であれば、場所を問わず自分のホーム IP アドレスを使用したまま、他のインターネット ノードと通信できます。

モバイル ルータ :ルータの役割を持つモバイル ノード。航空機、船、電車、自動車、自転車、カヤック上などでまとまって移動する 1 つまたは複数のネットワーク全体にモビリティを提供します。モバイル ルータが提供するネットワークに接続するノードは、固定ノードにすることも、モバイル ノード、またはルータにすることもできます。

モビリティ セキュリティ アソシエーション :一対のノード間のセキュリティ コンテキストの集合。それらのノード間で交換される Mobile IP プロトコル メッセージに適用できます。各コンテキストにより、使用時の認証アルゴリズムとモード、秘密(共有キーまたは適切な公開/秘密キー ペア)、および再送保護の方式が指定されます。

リンク :ノードがリンク層で通信するために使用する機能またはメディア。リンクはネットワーク層の基盤です。

リンク層アドレス :物理リンク上の一部の通信のエンドポイントを識別するために使用されるアドレス。通常、リンク層アドレスは、インターフェイスの MAC アドレスです。

ローミング インターフェイス :モバイル ルータがローミング中に外部エージェントおよびホーム エージェントを検出するために使用されるインターフェイス。登録およびトラフィックはこのインターフェイス上で行われます。