Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Mobile Networks ダイナミック連結型気付ア ドレス
Mobile Networks ダイナミック連結型気付アドレス
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Mobile Networks ダイナミック連結型気付アドレス

目次

Mobile Networks ダイナミック CCoA の制約事項

Mobile Networks ダイナミック CCoA に関する情報

気付アドレス

Mobile Networks ダイナミック CCoA の機能設計

Mobile Networks ダイナミック CCoA の利点

Mobile Networks ダイナミック CCoA の設定方法

モバイル ルータ インターフェイスでのダイナミック CCoA 処理のイネーブル化

モバイル ルータ インターフェイスでの CCoA-Only 処理のイネーブル化

ダイナミック CCoA 設定の確認

Mobile Networks ダイナミック CCoA の設定例

Mobile Networks ダイナミック CCoA:例

CCoA-Only 処理を使用する Mobile Networks:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

用語集

Mobile Networks ダイナミック連結型気付アドレス

Mobile Networks ダイナミック連結型気付アドレス機能が導入されるまでは、シスコのモバイル ネットワークでは、外部エージェントの Care-of Address(CoA; 気付アドレス)登録およびスタティック Collocated Care-of Address(CCoA; 連結型気付アドレス)登録がサポートされていました。

スタティック CCoA 登録は特別な場合と見なされ、Cellular Digital Packet Data(CDPD)ワイヤレス ネットワークなどのエンドポイント IP アドレスが常に固定であるネットワークに適用されます。Mobile Networks スタティック連結型気付アドレス機能によって、スタティック IP アドレスを持つモバイル ルータは、外部エージェントが展開されていない外部ネットワークへのローミングを行うことができます。

Mobile Networks ダイナミック気付アドレス機能によって、IP Control Protocol(IPCP; IP 制御プロトコル)を使用して動的に取得される CCoA を使用して、モバイル ルータをホーム エージェントに登録することが可能です。Dynamic Host Configuration Protocol(DHCP)を使用して取得される CCoA は、今後のリリースでサポートされる予定です。

Mobile Networks ダイナミック連結型気付アドレス機能の履歴

リリース
変更内容

12.3(4)T

この機能が追加されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォーム サポートと Cisco IOS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

Mobile Networks ダイナミック CCoA の制約事項

Mobile Networks ダイナミック CCoA 機能を設定できるのは、シリアル(ポイントツーポイント)インターフェイスでだけです。

Mobile Networks ダイナミック CCoA に関する情報

Mobile Networks ダイナミック CCoA 機能を設定する前に、次の概念について理解しておく必要があります。

「気付アドレス」

「Mobile Networks ダイナミック CCoA の機能設計」

「Mobile Networks ダイナミック CCoA の利点」

気付アドレス

モバイル ルータは、外部ネットワークに接続していると判断した場合、気付アドレスを取得します。この気付アドレスが、ホーム エージェントからモバイル ルータへのトンネルの出口となります。気付アドレスは、Mobile IP 登録要求に含まれていて、現在のロケーションにあるモバイル ルータへパケットを転送するためにホーム エージェントによって使用されます。次の 2 つのタイプの気付アドレスがあります。

外部エージェントから取得される気付アドレス

連結型気付アドレス

外部エージェントの気付アドレスは、モバイル ルータがアクセスしている外部ネットワーク上でアドバタイズされる、外部エージェントでの IP アドレスです。外部エージェントの CoA は、他のモバイル ルータと共有できます。連結型気付アドレスは、モバイル ルータ自体のインターフェイスに割り当てられている IP アドレスです。連結型気付アドレスはモバイル ルータの外部ネットワーク上での現在の位置を表し、1 つのモバイル ルータだけが同時に使用できます。

Mobile Networks ダイナミック CCoA の機能設計

Mobile Networks ダイナミック CCoA 機能は、スタティック CCoA 実装と非常によく似ています。スタティック CCoA は、CCoA としてローミング インターフェイス上で設定されているアドレスを使用します。ダイナミック CCoA は、IPCP を使用してローミング インターフェイスの CCoA を取得します。スタティック CCoA 実装の詳細については、『 Cisco Mobile Networks - Static Collocated Care-of Address 』機能マニュアルを参照してください。

スタティック CCoA およびダイナミック CCoA の両方について、登録に CCoA を排他的に使用するか、外部エージェント CoA が利用できる場合に使用するかをインターフェイスで設定できます。外部エージェントの場合は、最初にインターフェイスが起動するときに、エージェントのアドバタイズメントの送信請求およびリッスンを行い、リンク上の外部エージェントの検出を試みます。外部エージェントが検出されると、モバイル ルータはアドバタイズされた CoA を使用して登録します。インターフェイスは、外部エージェントが検出される間は CoA を使用して登録を続行します。アドバタイズメントが受信されないか、外部エージェントのアドバタイズメントのホールド タイムが終了することで外部エージェントが検出されないと、CCoA 処理がイネーブルになり、インターフェイスは自身の CCoA を登録します。CCoA は、インターフェイスに静的に設定されている、または動的に取得されるプライマリ IP アドレスです。外部エージェントが再度検出されると、インターフェイスは再び外部エージェントの CoA を登録します。

ip mobile router-service collocated ccoa-only オプションを使用して、インターフェイス自身の CCoA だけを登録し、外部エージェントのアドバタイズメントを無視するように設定できます。

モバイル ルータが CCoA をホーム エージェントに登録すると、HA-CCoA トンネルが 1 つ作成され、モバイル ルータとそのモバイル ネットワークへのトラフィックに使用されます。

モバイル ルータ インターフェイスに設定されている CCoA は、ホーム エージェントがモバイル ルータへのパケットをトンネリングする場合の、HA-CCoA トンネルのエンドポイントとなります。このトンネルをリバース トンネルとして設定している場合、モバイル ルータは、この同じトンネルを使用してトンネル パケットをホーム エージェントに返します。

Mobile Networks ダイナミック CCoA の利点

この機能によって、モバイル ルータは外部エージェントが展開されていない外部ネットワークへのローミングを行い、IPCP を使用して CCoA を動的に取得することができます。

Mobile Networks ダイナミック CCoA の設定方法

ここでは、次の手順について説明します。

「モバイル ルータ インターフェイスでのダイナミック CCoA 処理のイネーブル化」(必須)

「モバイル ルータ インターフェイスでの CCoA-Only 処理のイネーブル化」(任意)

「ダイナミック CCoA 設定の確認」(任意)

モバイル ルータ インターフェイスでのダイナミック CCoA 処理のイネーブル化

この作業では、モバイル ルータ インターフェイスでのダイナミック CCoA 処理のイネーブル化の方法を示します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address negotiated

5. encapsulation ppp

6. ip mobile router-service roam

7. ip mobile router-service collocated

8. ip mobile router-service collocated registration retry seconds

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface serial 1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ダイナミック CCoA の取得は、シリアル インターフェイスでのみ可能です。

ステップ 4

ip address negotiated

 

Router(config-if)# ip address negotiated

IPCP アドレス ネゴシエーションを使用して、特定のインターフェイスの IP アドレスを取得するよう指定します。

ステップ 5

encapsulation ppp

 

Router(config-if)# encapsulation ppp

特定のシリアル インターフェイスで PPP カプセル化をイネーブルにします。

ステップ 6

ip mobile router-service roam

 

Router(config-if)# ip mobile router-service roam

インターフェイスでローミングをイネーブルにします。

ステップ 7

ip mobile router-service collocated

 

Router(config-if)# ip mobile router-service collocated

モバイル ルータ インターフェイスで CCoA 処理をイネーブルにします。

インターフェイスは、最初に外部エージェントのアドバタイズメントの送信請求を行い、アドバタイズメントが受信されると外部エージェント CoA に登録されます。アドバタイズメントが受信されないと、CCoA 登録が試行されます。

ステップ 8

ip mobile router-service collocated registration retry seconds

 

Router(config-if)# ip mobile router-service collocated registration retry 3

(任意)登録が失敗した後で、モバイル ルータが別の登録要求を送信するまで待機する時間を設定します。

デフォルト値は 60 秒です。このコマンドを使用する必要があるのは、異なる再試行間隔が必要な場合だけです。

モバイル ルータ インターフェイスでの CCoA-Only 処理のイネーブル化

ホーム エージェントへの登録に、外部エージェントのアドバタイズメントを無視して、CCoA を排他的に使用するようにモバイル ルータ インターフェイスを設定するには、次の作業を実行します。この機能は、スタティック CCoA 処理とダイナミック CCoA 処理の両方で動作します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask
または
ip address negotiated

5. ip mobile router-service roam

6. ip mobile router-service collocated ccoa-only

7. ip mobile router-service collocated gateway ip-address ccoa-only

8. ip mobile router-service collocated registration retry seconds

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 1

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask

または


ip address negotiated

 

Router(config-if)# ip-address 172.71.6.23 255.255.255.0

 

または

Router(config-if)# ip address negotiated

インターフェイスのプライマリ IP アドレスを設定します。

これがスタティック CCoA になります。スタティック CCoA は、シリアル インターフェイスまたはイーサネット インターフェイスで設定できます。

または

IPCP アドレス ネゴシエーションを使用して、特定のインターフェイスの IP アドレスを取得するよう指定します。

このコマンドは、ダイナミック CCoA 処理に使用します。ダイナミック CCoA の取得は、シリアル インターフェイスでのみ可能です。

ステップ 5

ip mobile router-service roam

 

Router(config-if)# ip mobile router-service roam

インターフェイスでローミングをイネーブルにします。

ステップ 6

ip mobile router-service collocated ccoa-only

 

Router(config-if)# ip mobile router-service collocated ccoa-only

モバイル ルータ インターフェイスで CCoA-Only 処理をイネーブルにします。

このコマンドは、シリアル インターフェイスでのダイナミック CCoA 処理またはスタティック CCoA 処理に使用できます。

このコマンドは、外部エージェント CoA 処理をディセーブルにして、CCoA 処理だけにインターフェイスを制限します。

外部エージェント CoA にすでに登録されているインターフェイスでこのコマンドを使用する場合、モバイル ルータは、即座に CCoA に再度登録されます。

ステップ 7

ip mobile router-service collocated gateway ip-address ccoa-only

 

Router(config-if)# ip mobile router-service collocated gateway 10.21.0.2 ccoa-only

(任意)モバイル ルータ インターフェイスで CCoA-Only 処理をイネーブルにします。

このコマンドは、イーサネット インターフェイスでのスタティック CCoA 処理だけに使用できます。

ゲートウェイ IP アドレスは、モバイル ルータがパケットを転送するためのネクスト ホップの IP アドレスです。ゲートウェイ IP アドレスは、イーサネット インターフェイスだけで必須であり、プライマリ インターフェイスと同じ論理サブネット上に存在する必要があります。

ステップ 8

ip mobile router-service collocated registration retry seconds

 

Router(config-if)# ip mobile router-service collocated registration retry 3

(任意)登録が失敗した後で、モバイル ルータが別の登録要求を送信するまで待機する時間を設定します。

デフォルト値は 60 秒です。このコマンドを使用する必要があるのは、異なる再試行間隔が必要な場合だけです。

ダイナミック CCoA 設定の確認

ダイナミック CCoA 設定を確認するには、次の作業を実行します。

手順の概要

1. show ip mobile router interface

2. show ip mobile router agent

3. show ip mobile router registration

4. show ip mobile router

5. show ip mobile binding

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show ip mobile router interface

 
Mobilerouter# show ip mobile router interface

モバイル ルータがローミングに使用しているインターフェイスの情報を表示します。

CCoA にインターフェイスが設定されている場合、インターフェイスがダウン状態にある場合でも CCoA(IP アドレス)は表示されます。

ステップ 2

show ip mobile router agent

 
Mobilerouter# show ip mobile router agent

モバイル ルータのエージェントに関する情報を表示します。

CCoA に設定されているインターフェイスがアップ状態になると、エントリが表示されます。

ステップ 3

show ip mobile router registration

 
Mobilerouter# show ip mobile router registration

モバイル ルータの保留中の登録および許可された登録を表示します。

ステップ 4

show ip mobile router

 
Mobilerouter# show ip mobile router

モバイル ルータに関する設定情報とモニタリング統計情報を表示します。

ステップ 5

show ip mobile binding

 
Homeagent# show ip mobile router

モビリティ バインディング テーブルを表示します。

CCoA がホーム エージェントに登録されている場合、[Routing Options] フィールドに [(D) direct-to-mobile node] が表示されます。

Mobile Networks ダイナミック CCoA の設定例

ここでは、次の設定例について説明します。

「Mobile Networks ダイナミック CCoA:例」

「CCoA-Only 処理を使用する Mobile Networks:例」

Mobile Networks ダイナミック CCoA:例

次に、IPCP を使用してダイナミックに CCoA を取得するモバイル ルータの設定例を示します。

interface loopback 0
! MR home address
ip address 10.1.0.1 255.255.255.255
!
! Dynamic CCoA.
interface Serial 3/1
ip address negotiated
encapsulation ppp
ip mobile router-service roam
ip mobile router-service collocated

CCoA-Only 処理を使用する Mobile Networks:例

次に、スタティックな CCoA だけを取得するモバイル ルータの設定例を示します。インターフェイスは外部エージェントのアドバタイズメントをリッスンしません。

interface loopback1
ip address 20.0.4.1 255.255.255.255
!
! Static CCoA with CCoA-only option
interface Ethernet 1/0
ip address 10.0.1.1 255.255.255.0
ip mobile router-service roam
ip mobile router-service collocated gateway 10.0.1.2 ccoa-only
ip mobile router-service collocated registration retry 30

 

次に、ダイナミック CCoA だけを取得するモバイル ルータの設定例を示します。インターフェイスは外部エージェントのアドバタイズメントをリッスンしません。

interface loopback1
ip address 20.0.4.1 255.255.255.255
!
! Dynamic CCoA with CCoA-only option
interface Serial 2/0
ip address negotiated
encapsulation ppp
ip mobile router-service roam
ip mobile router-service collocated ccoa-only
ip mobile router-service collocated registration retry 30
 

参考資料

ここでは、Mobile Networks ダイナミック CCoA 機能に関する参考資料を示します。

関連資料

関連項目
参照先

Mobile IP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

Cisco IOS IP Command Reference, Volume 4 of 4: IP Mobility, Release 12.3 T』

モバイル ネットワークに関連した Mobile IP コマンドと設定作業

Cisco Mobile Networks 』機能マニュアル、Release 12.2(4)T および 12.2(13)T

スタティック CCoA のマニュアル

Cisco Mobile Networks - Static Collocated Care-of Address , Release 12.2(15)T』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/ipmobility/command/reference/imo_book.html の『 Cisco IOS IP Mobility Command Reference 』を参照してください すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

ip mobile router-service collocated

show ip mobile router agent

show ip mobile router interface

用語集

外部エージェント :モバイル ノードがアクセスした外部ネットワーク上のルータ。モバイル ノードが登録されている間、そのモバイル ノードまたはモバイル ルータにルーティング サービスを提供します。外部エージェントは、モバイル ノードのホーム エージェントによってトンネリングされたパケットのトンネリングを解除して、モバイル ノードまたはモバイル ルータに送信します。パケットがモバイル ノードから送信された場合、外部エージェントは登録モバイル ノードのデフォルト ルータとして動作できます。

気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。これを連結型気付アドレスにすることによって、モバイル ノードまたはモバイル ルータはローカル アドレスを取得して、それぞれのパケットのトンネリングを解除できます。または、外部エージェント気付アドレスにすることによって、外部エージェントはパケットのトンネリングを解除し、モバイル ノードまたはモバイル ルータに転送することができます。

連結型気付アドレス :モバイル ノードまたはモバイル ルータへのトンネルの終端ポイント。CCoA は、独自のネットワーク インターフェイスに関連付けられているモバイル ノードまたはモバイル ルータのローカル アドレスです。


) この用語集に記載されていない用語については、『Internetworking Terms and Acronyms』を参照してください。