Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Mobile IP の設定
Mobile IP の設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Mobile IP の設定

Mobile IP の概要

Mobile IP が必要な理由

Mobile IP のコンポーネント

Mobile IP の機能

エージェントの検出

登録

ルーティング

Mobile IP のセキュリティ

MN-HA

MN-FA

FA-HA

HA-HA

セキュリティ アソシエーションの保存

AAA での SA の保存

ホーム エージェント冗長性

HSRP グループ

HA 冗長性の機能

前提条件

Mobile IP 設定のタスク リスト

ホーム エージェント サービスのイネーブル化

外部エージェント サービスのイネーブル化

Mobile IP 環境での AAA の設定

Mobile IP 環境での RADIUS の設定

Mobile IP 環境における TACACS+ の設定

設定の確認

Mobile IP のモニタリングとメンテナンス

Mobile IP のシャットダウン

Mobile IP HA 冗長性の設定のタスク リスト

Mobile IP のイネーブル化

HSRP のイネーブル化

HSRP グループのアトリビュートの設定

物理ネットワークの HA 冗長性のイネーブル化

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化

HA 冗長性の確認

HA 冗長性のモニタリングとメンテナンス

Mobile IP の設定例

ホーム エージェントの設定例

AAA サーバを使用するホーム エージェントの例

外部エージェントの設定例

Mobile IP HA 冗長性の設定例

物理ネットワークの HA 冗長性の例

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

Mobile IP の設定

この章では、Mobile IP の設定方法について説明します。この章に記載されている Mobile IP コマンドの詳細については、『 Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services 』の「Mobile IP Commands」の章を参照してください。この章に記載されたその他のコマンドに関するマニュアルを特定するには、コマンド リファレンスのマスター インデックスを使用するか、オンラインで検索してください。

Mobile IP の概要

たとえば Personal Digital Assistant(PDA)などの IP ノードが別のリンクに移動する場合、その IP アドレスのネットワーク プレフィクスは、その現在のリンクに割り当てられたネットワーク プレフィクスに一致しなくなります。その結果、パケットは PDA の現在位置には配信されません。

Mobile IP を使用すると、別のリンクへの移動中にも IP ノードが同じ IP アドレスを維持し、既存の通信を維持できます。

Mobile IP は、ネットワーク層(レイヤ 3)におけるモビリティ向け IETF 標準ベースのソリューションです。Mobile IP は、次の RFC をサポートしています。

RFC 2002『 IP Mobility Support

RFC 2003『 IP Encapsulation within IP

RFC 2005『 Applicability Statement for Mobile IP

RFC 2006『 The Definitions of Managed Objects for IP Mobility Support

機能に関するハードウェア プラットフォームまたはソフトウェア イメージの情報を確認するには、Cisco.com の Feature Navigator を使用してその機能に関する情報を検索するか、特定のリリースに対応するソフトウェア リリース ノートを参照してください。詳細については、本書の「Using Cisco IOS Software」の章の「Identifying Supported Platforms」の項を参照してください。

Mobile IP が必要な理由

PDA および次世代のデータ対応携帯電話やサービスなどの新しい装置およびビジネス慣行によって、ネットワーク接続を維持しつつ、ユーザが移動できる機能に対する興味が高まりつつあります。このユーザ グループ向けデータ接続ソリューションの要件は、固定のダイヤルアップ ユーザまたは固定型有線 LAN ユーザに対する要件とは大きく異なります。ソリューションに必要なのは、データ セッションまたは会話中の移動という課題に対応することです。

IP ルーティングは IP アドレスのネットワーク プレフィクスに基づいて決定され、インターネット用に拡張できます。同一リンク上のすべてのノードが、共通のネットワーク プレフィクスを共有します。ノードが別のリンクに移動すると、ネットワーク プレフィクスは、新しいネットワーク リンクのネットワーク プレフィクスと一致しなくなります。その結果、新しいリンクへの移動後の IP ルーティングでは、ノードにパケットをルーティングできません。

ネットワークプレフィクス ルーティングに代わるものとしては、ホスト固有のルーティングがあります。ホスト固有のルーティングは、小規模ネットワークでは問題ありません。しかし、インターネット上に莫大な数のホストが存在することを考えると、インターネット接続に適したソリューションとは言えません。ルータには、数千万のルーティング テーブル エントリを保存するのに十分なメモリが必要になり、コンピューティング リソースの大部分をルーティング テーブルの更新に費やすことになります。

企業環境では Dynamic Host Configuration Protocol(DHCP)が一般的に使用されています。DHCP では、サーバが動的に IP アドレスを割り当て、ノードにコンフィギュレーション パラメータを配信できます。DHCP サーバはノードの ID を確認し、アドレス プールからの IP アドレスを所定の期間「リース」し、リース期間が終了すると、アドレスに再割り当てを再請求します。ノードは既存の通信セッションを終了し、ネットワークへの新しい接続点に移動します。次にネットワークに再接続し、DHCP から新しいネットワーク アドレスを受信できます。これにより IP アドレスを節約し、インターネット アクセスのコストを削減できます。しかし、ユーザがモバイルであり、セッション中に中断しない連続的な通信およびアクセシビリティを必要とする場合、DHCP は十分なソリューションではありません。DHCP では、アプリケーションはサブネット/ネットワーク境界を超えて接続を維持できません。

Mobile IP は、インターネット用に拡張できます。これは、Mobile IP が IP に基づいており、IP をサポートしているすべてのメディアが Mobile IP をサポートできるためです。Mobile IP は、ノードの IP アドレスのネットワーク プレフィクスをドロップしません。このプレフィクスは、インターネット全体でパケットを適切にルーティングするために重要です。また、ソフトウェア ライセンスやアクセス権限などの特定のネットワーク サービスは、IP アドレスに基づいています。これらの IP アドレスを変更すると、ネットワーク サービスに障害をきたす場合があります。モバイル ノードの別のリンクへの移動中に通信を中断することが望ましくない利用の例としては、リモート ログイン、リモート印刷、およびファイル転送など特定の利用が挙げられます。したがって、Mobile IP は、インターネット用に拡張可能な常時接続を実現するためのソリューションです。

Mobile IP のコンポーネント

Mobile IP は、図 1 に示すとおり次の 3 つのコンポーネントで構成されます。

Mobile Node(MN; モバイル ノード)

Home Agent(HA; ホーム エージェント)

Foreign Agent(FA; 外部エージェント)

図 1 Mobile IP のコンポーネントと関係

 

 

MN は、PDA、ラップトップ コンピュータ、またはデータ対応携帯電話などのノードで、別のネットワークまたはサブネットに接続ポイントを変更できます。このノードでは、ホーム IP アドレスだけを使用して、通信を続けることができます。

HA は、MN のホーム IP アドレスと 気付アドレス (外部ネットワークまたは訪問先ネットワーク上の MN の現在位置)とのアソシエーションを維持する、MN のホーム ネットワーク上のルータです。HA は、MN がホームから離れているときに、パケットをトンネリングして MN にリダイレクトします。

FA は、MN が HA に現在の気付アドレスを通知するのを支援する、外部ネットワーク上のルータです。FA は、HA によってトンネリングされたパケットのトンネリングを解除して、MN に送信します。また、MN が外部ネットワークに接続している間に生成したパケットのデフォルト ルータとして機能します。

HA および FA の機能は、回線プロトコルが通常アップ状態であるインターフェイスを想定して設計することを推奨します。

Mobile IP の機能

ここでは、Mobile IP の機能について説明します。Mobile IP プロセスには、3 つの主要フェーズがあります。これらのフェーズについては、次の項で説明します。

エージェントの検出

登録

ルーティング

エージェントの検出

エージェントの検出フェーズでは、HA および FA が エージェント アドバタイズメント と呼ばれるメッセージを定期的にマルチキャストするか、ブロードキャストすることによって、接続先のリンク上で自身の存在をアドバタイズします。MN はこれらのアドバタイズメントをリッスンし、ホーム リンクに接続されているのか、外部リンクに接続されているのかを判断します。MN は、エージェント アドバタイズメントを待たずに、 エージェントの送信請求 を送信することもできます。この請求により、リンク上のすべてのエージェントはただちにエージェント アドバタイズメントを送信します。

MN が外部ネットワークに接続されていると判断すると、モバイル ノードは気付アドレスを取得します。気付アドレスには、次の 2 つのタイプがあります。

FA 気付アドレス

連結型気付アドレス

FA 気付アドレスは、MN が FA エージェント アドバタイズメントから取得した、一時的な貸し出し IP アドレスです。この種の気付アドレスは、HA から FA へのトンネルの出口です。連結型気付アドレスは、MN インターフェイスに一時的に割り当てられたアドレスです。このアドレスは、DHCP または手動設定によって割り当てられます。

登録

MN が気付アドレスを受信すると、MN はメッセージの交換を通じてこのアドレスを HA に登録します。HA は、MN のホーム IP アドレスを MN の現在の気付アドレスにマップする モビリティ バインディング テーブル を作成します。このテーブル内のエントリは、 モビリティ バインディング と呼ばれます。登録の主な目的は、HA における MA のモビリティ バインディングの作成、変更、または削除です。

登録の際には、MN は FA からのサービスも要求します。

HA は MN のホーム IP アドレスの到達可能性をアドバタイズし、これによってこのアドレス宛てのパケットを集めます。 Corresponding Node (CN; 対応ノード)と呼ばれるインターネット上のデバイスが MN にパケットを送信すると、このパケットは MN のホーム ネットワークにルーティングされます。HA はパケットを代行受信し、MN の登録されている気付アドレスにトンネリングします。気付アドレスでは、FA がトンネルからパケットを抽出し、MN に配信します。

MN が FA を経由して登録要求を送信している場合、FA は、ビジター リストを維持することによってすべての訪問 MN を記録します。FA は、登録要求を直接 HA にリレーします。トンネリングは不要です。FA は、訪問 MN によって送信されたすべてのパケットのルータとして機能します。

MN の電源が切断されたか、MN がホーム リンクに再接続されたと判断すると、HA に登録解除要求を送信することによって登録を解除します。次に、HA が MN を再請求します。

ルーティング

レイヤ 3 プロトコルの主な機能はルーティングです。したがって、Mobile IP の主な機能は、モバイル ユーザへのパケットのルーティング方法を処理することです。

Mobile IP は、シスコが開発した Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネリング テクノロジーとより単純な IP-in-IP トンネリング プロトコルを活用する、トンネリングベースのソリューションです。MN 宛てのトラフィックは、三角形の方法で転送されます。CN(インターネット上のデバイス)が MN にパケットを転送すると、HA が外部ネットワーク上の MN の気付アドレス(現在位置)にトンネリングすることによってパケットをリダイレクトします。FA は HA からパケットを受信し、ローカルに MN に転送します。ただし、MN が送信したパケットは、CN に直接ルーティングされます。

Mobile IP での一般的なパケット転送の図については、図 2を参照してください。

図 2 Mobile IP の一般的なパケット転送

 

Mobile IP のセキュリティ

Mobile IP には、そのコンポーネント間のセキュリティに関して次のガイドラインがあります。

MN と HA との通信では認証が必要です。

MN と FA との通信は、任意で認証できます。

FA と HA との通信は、任意で認証できます。

また、HA 冗長性機能を使用するときに実装された場合のアクティブ HA とスタンバイ HA との通信には、認証が必要です。この機能の詳細については、この章で後述する「ホーム エージェント冗長性」の項を参照してください。

MN-HA

特に、Mobile IP の登録プロセスは、セキュリティ攻撃に対して脆弱です。これは、このプロセスが、移動中の MN へのパケットのトンネリング先を HA に通知するからです。不正なノードは、HA に偽の登録要求を送信し、MN ではなく、不正なノードにすべてのパケットをトンネリングさせることができます。 サービス拒否攻撃 と呼ばれるこの種の攻撃により、MN はすべてのパケットの送受信を行うことができなくなります。サービス拒否攻撃を防止するために、Mobile IP は MN と HA との間のすべての登録メッセージに認証を要求します。

Cisco IOS ソフトウェアは、Mobile-Home Authentication Extension(MHAE)をサポートしています。MN と HA との間のすべての登録メッセージには、必須の認証拡張子が含まれます。

Message Digest 5(MD5)は、登録メッセージおよびキーを取得して、 メッセージ ダイジェスト と呼ばれる、より少量のデータの塊と秘密キーを計算するアルゴリズムです。MN と HA は、いずれも 対称キー と呼ばれるキーのコピーを持っており、計算の結果と比較することによって相互に認証します。

タイム スタンプは、登録要求の送信元および送信時間を保証するメッセージ内の ID であり、これによって リプレイ アタック を防止します。リプレイ アタックは、以前送信された正規のメッセージを個人が記録し、後で送信する場合に発生します。タイム スタンプも MD5 によって保護されています。

この認証プロセスは、MN が登録要求を送信した時点で開始します。MN はタイム スタンプを追加し、メッセージ ダイジェストを計算し、登録要求に MHAE を追加します。HA は要求を受信し、タイム スタンプが有効であることを確認します。同じキーを使用してメッセージ ダイジェストを計算し、メッセージ ダイジェストの結果を比較します。結果が一致した場合、要求は正常に認証されます。登録応答の場合は、HA がタイム スタンプを追加し、メッセージダイジェストを計算し、登録応答に MHAE を追加します。HA から登録応答が届いたら、MN はこの登録応答を認証します。

MN-FA

Mobile IP では、MN と FA との通信の認証は要求されません。Cisco IOS ソフトウェアは、任意の Mobile-Foreign Authentication Extension(MFAE)をサポートしています。MFAE は、MN と FA との間の共有キーを保管することによってこれらの間の通信を保護します。

FA-HA

Mobile IP では、FA と HA との通信の認証は要求されません。Cisco IOS ソフトウェアは、任意の Foreign-Home Authentication Extension(FHAE)をサポートしています。FHAE は、FA と HA との間の共有キーを保管することによってこれらの間の通信を保護します。

HA-HA

HA 冗長性トポロジにおけるアクティブ HA とスタンバイ HA との通信には、認証が必要です。認証プロセスは、前述の「MN-HA」の項と同じ方法で機能します。しかし HA-HA 認証は、追加されたシスコ独自の認証を拡張したものであり、ピア HA 同士の通信を保護して HA 冗長性を実現するために必要です(アクティブ HA とスタンバイ HA は、互いにピアです)。

ip mobile secure home-agent グローバル コンフィギュレーション コマンドを使用して、スタンバイ グループ内の他の HA ごとに、スタンバイ グループ内のすべてのピア HA 間のセキュリティ アソシエーションを設定します。この設定は、スタンバイ グループ内のすべての HA が任意の時点でアクティブ HA またはスタンバイ HA になる可能性があるので必要です。HA-HA 認証の詳細については、この章で後述する「Mobile IP HA 冗長性の設定のタスク リスト」の項を参照してください。

セキュリティ アソシエーションの保存

この章の「Mobile IP のセキュリティ」の項で既に述べたように、MN と HA との間の認証ではキーが使用されます。このキー、つまり Security Association (SA; セキュリティ アソシエーション)は次のいずれかの場所に保存できます。

HA の NVRAM

TACACS+ または RADIUS のいずれかを使用してアクセス可能な Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)サーバ

一般的に HA の NVRAM には制約があるため、MN の数が少ない場合は、HA に SA を保存する必要があります。MN の数が多い場合は、AAA サーバに SA を保存する必要があります。

AAA での SA の保存

AAA サーバは、多数の SA を保存でき、将来の SA の保存のために拡張することもできます。AAA サーバは MN-HA 認証用の SA だけではなく、他の Mobile IP コンポーネント間の認証用 SA も収容できます。すべての SA を 1 つの場所に保存すると、SA 関連の管理タスクおよびメンテナンス タスクを簡素化できます。

HA における SA のキャッシング

MN が HA に登録されると、MN-HA 認証プロセスにはキーが必要になり、Mobile IP に AAA 認証が必要になります。SA が AAA サーバに保存されている場合、HA はサーバから適切な SA を取得する必要があります。SA が HA にダウンロードされると、HA は SA をキャッシュして、必要になると SA を再利用します。AAA サーバから再取得することはありません。

ホーム エージェント冗長性

Mobile IP の登録プロセス中に HA は、MN のホーム IP アドレスを MN の現在の気付アドレスにマップするモビリティ バインディング テーブルを作成します。HA で障害が発生すると、モビリティ バインディング テーブルは失われ、HA に登録されたすべての MN が接続を失います。HA 障害の影響を低減するために、Cisco IOS ソフトウェアは、HA 冗長性機能をサポートしています。

HA 冗長性機能は、Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)に基づいて動作します。HSRP は、シスコによって開発されたプロトコルであり、ネットワークの冗長性を提供して、ユーザ トラフィックが障害から透過的に即座に回復することを保証します。

HSRP グループ

HA 冗長性を設定する前に、HSRP グループの概念を理解しておく必要があります。

HSRP グループ は、IP アドレスおよび MAC(レイヤ 2)アドレスを共有し、単一の仮想ルータとして機能する、複数のルータで構成されます。たとえば、Mobile IP トポロジには、1 つのアクティブ HA と、他のトポロジを単一の仮想 HA として表示する 1 つまたは複数のスタンバイ HA を含めることができます。

Mobile IP が冗長性を実装できるように、HA のインターフェイスで所定の HSRP グループ アトリビュートを定義する必要があります。このグループを使用して、グループのインターフェイス( 物理ネットワーク )上または仮想ネットワーク上のいずれかでホーム リンクを備える MN に冗長性を提供できます。 仮想ネットワーク は、プログラミングされ、共通の物理インフラストラクチャを共有する論理回線です。

HA 冗長性の機能

HA 冗長性機能を使用すると、1 つのアクティブ HA と 1 つまたは複数のスタンバイ HA を設定できます。

HA 機能は、ルータが提供するサービスであり、インターフェイス固有ではありません。したがって、HA および MN は、MN が登録要求を送信する HA インターフェイスと、反対に HA が登録要求を受信する HA インターフェイスに同意する必要があります。この同意は次の 2 つのシナリオを考慮する必要があります。

MN には、MN と同じサブネット上にない HA インターフェイス(HA IP アドレス)があります。

MN は、MN と同じサブネット上に HA インターフェイスを配置する必要があります。つまり、HA と MN は同じホーム ネットワーク上にいる必要があります。

物理ネットワークの MN の場合、アクティブ HA は MN からの登録要求を受け入れ、バインディング アップデートをスタンバイ HA に送信します。このプロセスにより、アクティブ HA およびスタンバイ HA のモビリティ バインディング テーブルの同期が維持されます。このプロセスの例については、図 3 の(a)を参照してください。

仮想ネットワークの MN の場合、アクティブ HA およびスタンバイ HA はピアです。つまり、どちらかの HA が MN からの登録要求を処理し、モビリティ バインディング テーブルをピア HA で更新できます。

スタンバイ HA がアップすると、アクティブ HA からすべてのモビリティ バインディング情報を要求する必要があります。アクティブ HA は、モビリティ バインディング テーブルをスタンバイ HA にダウンロードすることで応答します。スタンバイ HA は、要求したバインディング情報を受信したことを確認応答します。アクティブ HA がモビリティ バインディングをスタンバイ HA にダウンロードする例については、図 3 の(b)を参照してください。この段階のプロセスの主な懸念事項は、スタンバイ HA が適切なモビリティ バインディング テーブルを取得するのにどの HA IP インターフェイスを使用する必要があるか、そしてどのスタンバイ HA のインターフェイスでバインディング要求を送信する必要があるかです。

図 3 モビリティ バインディング プロセス

 

モビリティ バインディング テーブルの管理

アクティブ ホーム エージェントでバンディングがクリアされても、スタンバイ/ピア ホーム エージェントではクリアされません。スタンバイ/ピア ホーム エージェントでバインディングをクリアする場合、 clear ip mobile binding コマンドを使用して手動でクリアする必要があります。この設計のおかげで、バインディング情報が間違って失われることはありません。

ネットワークの問題が原因で、冗長グループ内の 2 つのホーム エージェントのバインディング テーブルが同期しない場合があります。バインディング テーブルは、 clear ip mobile binding all load standby-group-name コマンドを使用して同期させることができます。

前提条件

ルータ上でホーム エージェント機能を設定するには、ローミング サービスを有効にする IP アドレスまたはサブネットを決定する必要があります。仮想ネットワーク上でローミングをサポートする場合は、このサービスを有効にするサブネットを特定し、これらの仮想ネットワークをホーム エージェント上に適切に配置する必要があります。ホーム エージェント機能は、物理サブネットにも、仮想サブネットにもイネーブルにできます。仮想サブネットの場合、 ip mobile virtual-network グローバル コンフィギュレーション コマンドを使用してルータ上に仮想ネットワークを定義する必要があります。Mobile IP のホーム エージェント サービスおよび外部エージェント サービスは、同じルータまたは個々のルータで設定し、ユーザへの Mobile IP サービスをイネーブルにすることができます。

Mobile IP はホスト デバイス上でのサポートが必要なため、各モバイル ノードは、クライアント ソフトウェアを使用して目的の Mobile IP サービス用に適切に設定されている必要があります。詳細については、モバイル対応 IP スタックのベンダーのマニュアルで、手動設定に関する項目を参照してください。

Mobile IP 設定のタスク リスト

ネットワークで Mobile IP サービスをイネーブルにするには、選択した IP アドレスのトンネリングを効率化するホーム エージェントだけではなく、これらのデバイスまたはホストがローミングできる領域も決定する必要があります。ホストのローミングが許可される領域またはサブネットによって、外部エージェント サービスの設定場所が決定します。

Mobile IP を設定するには、サポートする機能に関連する次の項に記載されるタスクを実行します。最初の 2 つの項のタスクは必須で、残りの項のタスクは任意です。

ホーム エージェント サービスのイネーブル化(必須)

外部エージェント サービスのイネーブル化(必須)

Mobile IP 環境での AAA の設定(任意)

Mobile IP 環境での RADIUS の設定(任意)

Mobile IP 環境における TACACS+ の設定(任意)

設定の確認(任意)

Mobile IP のモニタリングとメンテナンス(任意)

Mobile IP のシャットダウン(任意)

ホーム エージェント サービスのイネーブル化

ホーム エージェント機能は企業ネットワーク内で有用です。この機能を使用すると、ラップトップ PC を机上から会議室、ラボ、または共有領域に移動させても IP アドレスを維持できます。データグラムのトンネリングによってホストの移動が隠され、したがってベース ステーション間でシームレスな移動が可能になるため、ワイヤレス LAN が使用されている環境で特に効果的です。企業ネットワークの境界を越えたユーザのモビリティをサポートするために、DMZ の仮想サブネットまたはネットワークの周辺のホーム エージェント機能をイネーブルにして、ネットワーク外の外部エージェントと通信できるようになります。

ルータ上でホームに設定された、または仮想的にホームに設定された IP アドレスを持つユーザのホーム エージェント サービスをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 2

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 3

Router(config)# ip mobile home-agent

ホーム エージェント サービスをイネーブルにします。

ステップ 4

Router(config)# ip mobile virtual-network net mask [ address address ]

ルーティング テーブルに仮想ネットワークを追加します。仮想ネットワークを使用しない場合は、ステップ 6 に進みます。

ステップ 5

Router(config)# router protocol

ルーティング プロトコルを設定します。

ステップ 6

Router(config)# redistribute mobile

ルーティング プロトコルへの仮想ネットワークの再配布をイネーブルにします。

ステップ 7

Router(config)# ip mobile host lower [ upper ] virtual-network net mask [ aaa [ load-sa ]]

(仮想ネットワーク上の)モバイル ノードとセキュリティ アソシエーションの保存場所を指定します。1

ステップ 8

Router(config)# ip mobile host lower [ upper ] { interface name }

インターフェイスでモバイル ノードとセキュリティ アソシエーションの保存場所を指定します。モバイル ノードがインターフェイスにない場合は、このステップを省略します。

ステップ 9

Router(config)# ip mobile secure host lower-address [ upper-address ]{ inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string

モバイル ホスト セキュリティ アソシエーションを設定します。AAA を使用する場合は、このステップを省略します。

ステップ 10

Router(config)# ip mobile secure foreign-agent address { inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string

(任意)外部エージェントのセキュリティ アソシエーションを設定します。リモート外部エージェントとのセキュリティ アソシエーションがある場合を除いて、このステップを省略します。

1.デフォルトでは、セキュリティ アソシエーションはローカルに設定されていると考えられますが、セキュリティ アソシエーション設定は AAA サーバに解放されることができます。

外部エージェント サービスのイネーブル化

部エージェント サービスは、モバイル ノードがローミングを行う可能性のある任意のサブネットに接続されているルータ上でイネーブルにする必要があります。したがって、外部エージェント機能は、たとえば会議室やラボのサブネットに接続されているルータ上で設定する必要があります。ワイヤレス LAN 間のローミングを使用する管理者は、各ベース ステーションに接続されているルータで外部エージェント機能を設定します。この場合、ホーム エージェント機能と外部エージェント機能の両方がこれらのワイヤレス LAN に接続されているルータの一部でイネーブルになっていることが考えられます。

デフォルトのサービスを提供する外部エージェントを開始するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

ステップ 2

Router(config-router)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 3

Router(config)# ip mobile foreign-agent care-of interface

すべての外部エージェント対応インターフェイスにアドバタイズされる気付アドレスを設定します。

ステップ 4

Router(config-if)# ip mobile foreign-service

インターフェイスで外部エージェント サービスをイネーブルにします。

ステップ 5

Router(config)# ip mobile secure home-agent address { inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string

(任意)ホーム エージェントのセキュリティ アソシエーションを設定します。リモート ホーム エージェントまたはビジターとのセキュリティ アソシエーションがある場合を除いて、ステップ 4 および 5 を省略します。

ステップ 6

Router(config)# ip mobile secure visitor address { inbound-spi spi-in outbound-spi spi-out | spi spi } key hex string [ replay timestamp ]

(任意)ビジターのセキュリティ アソシエーションを設定します。

Mobile IP 環境での AAA の設定

Mobile IP 環境で AAA を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# aaa new-model

AAA アクセス コントロール モデルをイネーブルにします。

ステップ 2

Router(config)# aaa authorization ipmobile { tacacs+ | radius }

Mobile IP が、TACACS+ または RADIUS を使用して AAA サーバからのセキュリティ アソシエーションを取得することを認可します。

Mobile IP 環境での RADIUS の設定

Remote Authentication Dial-in User Service(RADIUS; リモート認証ダイヤルイン ユーザ サービス)は、ネットワークでの AAA 情報の交換を定義するための方法です。シスコの実装では、RADIUS クライアントは Cisco ルータ上で稼動し、ユーザ認証およびネットワーク サーバ アクセスに関するすべての情報を保持する RADIUS サーバへ認証要求を送信します。RADIUS の設定オプションの詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring RADIUS」の章を参照してください。

Mobile IP 環境で RADIUS を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# radius-server host

RADIUS サーバ ホストを指定します。

ステップ 2

Router(config)# radius-server key

ルータと RADIUS デーモンとの間におけるすべての RADIUS 通信用の認証および暗号化キーを設定します。

Mobile IP 環境における TACACS+ の設定

Terminal Access Controller Access Control System Plus(TACACS+)は、イベント ロギングなどリモート アクセス認証や関連サービスを提供する認証プロトコルです。TACACS+ の設定オプションの詳細については、『 Cisco IOS Security Configuration Guide 』の「Configuring TACACS+」の章を参照してください。

Mobile IP 環境で TACACS+ を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# tacacs-server host

TACACS+ サーバ ホストを指定します。

ステップ 2

Router(config)# tacacs-server key

アクセス サーバと TACACS+ デーモンとのすべての TACACS+ 通信に使用される認証暗号キーを設定します。

設定の確認

Mobile IP が正常に設定されているかどうかを確認するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip mobile globals

ホーム エージェントおよび外部エージェントのグローバル設定を表示します。

Router# show ip mobile host group

モバイル ノード グループを表示します。

Router# show ip mobile secure { host | visitor | foreign-agent | home-agent | summary } address

セキュリティ アソシエーションを表示します。

Router# show ip mobile interface

インターフェイス上のアドバタイズメントを表示します。

Mobile IP のモニタリングとメンテナンス

Mobile IP のモニタリングおよびメンテナンスを実行するには、次のいずれかの EXEC コマンドを使用します。

 

コマンド
目的

Router# show ip mobile host

モバイル ノード カウンタを表示します(ホーム エージェントのみ)。

Router# show ip mobile binding

モビリティ バインディングを表示します(ホーム エージェントのみ)。

Router# show ip mobile tunnel

アクティブ トンネルを表示します。

Router# show ip mobile visitor

ビジター バインディングを表示します(外部エージェントのみ)。

Router# show ip route mobile

Mobile IP ルートを表示します。

Router# show ip mobile traffic

プロトコル統計情報を表示します。

Router# clear ip mobile traffic

カウンタをクリアします。

Router# show ip mobile violation

セキュリティ違反に関する情報を表示します。

Router# debug ip mobile advertise

アドバタイズメント情報を表示します。2

Router# debug ip mobile host

モビリティ イベントを表示します。

2.インターフェイスで IRDP が作動しているかどうかを確認します。

Mobile IP のシャットダウン

Mobile IP をシャットダウンするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# no ip mobile home-agent

ホーム エージェント サービスをディセーブルにします。

ステップ 2

Router(config)# no ip mobile foreign-agent

外部エージェント サービスをディセーブルにします。

ステップ 3

Router(config)# no router mobile

Mobile IP プロセスをディセーブルにします。

Mobile IP HA 冗長性の設定のタスク リスト

ルータに Mobile IP HA 冗長性を設定するには、次の項で説明する必須タスクを実行します。

Mobile IP のイネーブル化(必須)

HSRP のイネーブル化(必須)

物理ネットワークの HA 冗長性のイネーブル化(必須)

ネットワーク構成によっては、次の項で説明する任意のタスクのいずれかを実行します。

物理ネットワークの HA 冗長性のイネーブル化(任意)

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化(任意)

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化(任意)

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化(任意)

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化(任意)

HA 冗長性の確認(任意)

Mobile IP のイネーブル化

ルータで Mobile IP をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# router mobile

ルータで Mobile IP をイネーブルにします。

HSRP のイネーブル化

インターフェイスで HSRP をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router (config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

HSRP グループのアトリビュートの設定

ローカル ルータの HSRP への参加方法に影響を与える HSRP グループのアトリビュートを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドのいずれかを使用します。

 

コマンド
目的

Router(config-if)# standby [ group-number ] priority priority [ preempt [ delay [ minimum | sync ] delay ]]

 

または

 

Router(config-if)# standby [ group-number ] [ priority priority ] preempt [ delay [ minimum | sync ] delay ]

 

アクティブ ルータの選択時に使用されるホット スタンバイ プライオリティを設定します。デフォルトでは、あとでアップするルータがスタンバイになります。1 つのルータがアクティブ HA として指定されると、プライオリティは HSRP グループで最高位に設定され、プリエンプトが設定されます。ルータがアクティブになる前にすべてのバインディングがルータにダウンロードされるように、 preempt delay sync コマンドを設定します。すべてのバインディングがダウンロードされるか、タイマーがタイムアウトするかのいずれか早い方の時点で、ルータはアクティブになります。

物理ネットワークの HA 冗長性のイネーブル化

物理ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router (config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name

スタンバイ グループの名前を設定します。

ステップ 3

Router(config)# ip mobile home-agent standby hsrp-group-name

HSRP グループ名を使用して、ホーム エージェントに冗長性を設定します。

ステップ 4

Router(config)# ip mobile secure home-agent address spi spi key hex string

ピア ルータ間にホーム エージェントのセキュリティ アソシエーションを設定します。アクティブ HA で設定されている場合、IP アドレスの address 引数はスタンバイ HA の address 引数です。スタンバイ HA で設定されている場合、IP アドレスの address 引数はアクティブ ルータの address 引数です。セキュリティ アソシエーションはスタンバイ グループのすべての HA 間で設定する必要があることに注意してください。

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化

仮想ネットワークおよび物理ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router (config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name

スタンバイ グループの名前を設定します。

ステップ 3

Router(config)# ip mobile home-agent address address

 

 

 

または

Router(config)# ip mobile home-agent

グローバル ホーム エージェント アドレスを定義します。この設定では、address は HSRP グループ アドレスです。モバイル ノードとホーム エージェントが異なるサブネット上にある場合、このコマンドを入力します。

または

ルータに対するホーム エージェント サービスをイネーブルにし、制御します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、このコマンドを入力します。

ステップ 4

Router(config)# ip mobile virtual-network net mask [ address address ]

仮想ネットワークを定義します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、[ address address ] オプションを使用します。

ステップ 5

Router(config)# ip mobile home-agent standby hsrp-group-name [[ virtual-network ] address address ]

HSRP グループを使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 6

Router(config)# ip mobile secure home-agent address spi spi key hex string

ピア ルータ間にホーム エージェントのセキュリティ アソシエーションを設定します。アクティブ HA で設定されている場合、IP アドレスの address 引数はスタンバイ HA の address 引数です。スタンバイ HA で設定されている場合、IP アドレスの address 引数はアクティブ ルータの address 引数です。セキュリティ アソシエーションはスタンバイ グループのすべての HA 間で設定する必要があることに注意してください。

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性のイネーブル化

複数の物理ネットワークを使用して仮想ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name1

スタンバイ HSRP グループ 1 の名前を設定します。

ステップ 3

Router(config-if)# standby name hsrp-group-name2

スタンバイ HSRP グループ 2 の名前を設定します。

ステップ 4

Router(config)# ip mobile home-agent address address

 

 

 

 

または

Router(config)# ip mobile home-agent

仮想ネットワークのグローバル ホーム エージェント アドレスを定義します。この設定では、address はループバック インターフェイス アドレスです。モバイル ノードとホーム エージェントが異なるサブネット上にある場合、このコマンドを入力します。

または

ルータに対するホーム エージェント サービスをイネーブルにし、制御します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、このコマンドを入力します。

ステップ 5

Router(config)# ip mobile virtual-network net mask [ address address ]

仮想ネットワークを定義します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、[ address address ] オプションを使用します。

ステップ 6

Router(config)# ip mobile home-agent standby hsrp-group-name1 [[ virtual-network ] address address ]

HSRP グループ 1 を使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 7

Router(config)# ip mobile home-agent standby hsrp-group-name2 [[ virtual-network ] address address ]

HSRP グループ 2 を使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 8

Router(config)# ip mobile secure home-agent address spi spi key hex string

ピア ルータ間にホーム エージェントのセキュリティ アソシエーションを設定します。アクティブ HA で設定されている場合、IP アドレスの address 引数はスタンバイ HA の address 引数です。スタンバイ HA で設定されている場合、IP アドレスの address 引数はアクティブ ルータの address 引数です。セキュリティ アソシエーションはスタンバイ グループのすべての HA 間で設定する必要があることに注意してください。

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化

1 つの物理ネットワークを使用して複数の仮想ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name

スタンバイ グループの名前を設定します。

ステップ 3

Router(config)# ip mobile home-agent address address

 

 

 

または

Router(config)# ip mobile home-agent

グローバル ホーム エージェント アドレスを定義します。この設定では、address は HSRP グループ アドレスです。モバイル ノードとホーム エージェントが異なるサブネット上にある場合、このコマンドを入力します。

または

ルータに対するホーム エージェント サービスをイネーブルにし、制御します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、このコマンドを入力します。

ステップ 4

Router(config)# ip mobile virtual-network net mask [ address address ]

仮想ネットワークを定義します。仮想ネットワークごとにこのステップを繰り返します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、[ address address ] オプションを使用します。

ステップ 5

Router(config)# ip mobile home-agent standby hsrp-group-name [[ virtual-network ] address address ]

HSRP グループを使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 6

Router(config)# ip mobile secure home-agent address spi spi key hex string

ピア ルータ間にホーム エージェントのセキュリティ アソシエーションを設定します。アクティブ HA で設定されている場合、IP アドレスの address 引数はスタンバイ HA の address 引数です。スタンバイ HA で設定されている場合、IP アドレスの address 引数はアクティブ ルータの address 引数です。セキュリティ アソシエーションはスタンバイ グループのすべての HA 間で設定する必要があることに注意してください。

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性のイネーブル化

複数の物理ネットワークを使用して複数の仮想ネットワークの HA 冗長性をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router (config-if)# standby [ group-number ] ip ip-address

HSRP をイネーブルにします。

ステップ 2

Router(config-if)# standby name hsrp-group-name1

スタンバイ HSRP グループ 1 の名前を設定します。

ステップ 3

Router(config-if)# standby name hsrp-group-name2

スタンバイ HSRP グループ 2 の名前を設定します。

ステップ 4

Router(config)# ip mobile home-agent address address

 

 

 

 

または

Router(config)# ip mobile home-agent

仮想ネットワークのグローバル ホーム エージェント アドレスを定義します。この設定では、address はループバック インターフェイス アドレスです。モバイル ノードとホーム エージェントが異なるサブネット上にある場合、このコマンドを入力します。

または

ルータに対するホーム エージェント サービスをイネーブルにし、制御します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、このコマンドを入力します。

ステップ 5

Router(config)# ip mobile virtual-network net mask [ address address ]

仮想ネットワークを定義します。仮想ネットワークごとにこのステップを繰り返します。モバイル ノードとホーム エージェントが同一サブネット上にある場合、[ address address ] オプションを使用します。

ステップ 6

Router(config)# ip mobile home-agent standby hsrp-group-name1 [[ virtual-network ] address address ]

HSRP グループ 1 を使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 7

Router(config)# ip mobile home-agent standby hsrp-group-name2 [[ virtual-network ] address address ]

HSRP グループ 2 を使用してホーム エージェントに冗長性を設定し、仮想ネットワークをサポートします。

ステップ 8

Router(config)# ip mobile secure home-agent address spi spi key hex string

ピア ルータ間にホーム エージェントのセキュリティ アソシエーションを設定します。アクティブ HA で設定されている場合、IP アドレスの address 引数はスタンバイ HA の address 引数です。スタンバイ HA で設定されている場合、IP アドレスの address 引数はアクティブ ルータの address 引数です。セキュリティ アソシエーションはスタンバイ グループのすべての HA 間で設定する必要があることに注意してください。

HA 冗長性の確認

Mobile IP ホーム エージェント冗長性機能がルータで正常に設定されているかどうかを確認するには、次の手順を実行します。


ステップ 1 show ip mobile globals EXEC コマンドを入力します。

ステップ 2 モバイル エージェントのグローバル情報を調べます。

ステップ 3 show ip mobile binding [ home-agent address | summary ] EXEC コマンドを入力します。

ステップ 4 ホーム エージェント アドレスに関連するモビリティ バンディングを調べます。

ステップ 5 show standby EXEC コマンドを入力します。

ステップ 6 HSRP グループに関連する情報を調べます。


 

HA 冗長性のモニタリングとメンテナンス

HA 冗長性ののモニタリングおよびメンテナンスを実行するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# debug ip mobile standby

Mobile IP 冗長性アクティビティのデバッグ メッセージを表示します。

Router# show ip mobile globals

グローバル ホーム アドレスを設定している場合は、グローバル ホーム アドレスを表示します。Mobile IP スタンバイ グループごとに、サポートされているホーム エージェント アドレスを表示します。

Router# show ip mobile binding [home-agent address | summary]

特定のホーム エージェント アドレスとのモビリティ バインディングを表示します。

Mobile IP の設定例

ここでは、次の Mobile IP の設定例を示します。

ホーム エージェントの設定例

AAA サーバを使用するホーム エージェントの例

外部エージェントの設定例

Mobile IP HA 冗長性の設定例

物理ネットワークの HA 冗長性の例

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

ホーム エージェントの設定例

次の例では、ホーム エージェントのモバイル ホストがインターフェイス Ethernet1(ネットワーク 11.0.0.0)上に 5 個、仮想ネットワーク 10.0.0.0 上に 10 個存在します。2 つのモバイル ノード グループがあります。各モバイル ホストには 1 つのセキュリティ アソシエーションがあります。ホーム エージェントにはアクセス リストが設定されており、モバイル ホスト 11.0.0.5 のローミング機能をディセーブルにします。11.0.0.0 グループのライフタイムは 1 時間(3600 秒)です。10.0.0.0 グループは、13.0.0.0 のネットワーク領域ではローミングできません。

router mobile
!
! Define which hosts are permitted to roam
ip mobile home-agent broadcast roam-access 1
!
! Define a virtual network
ip mobile virtual-network 10.0.0.0 255.0.0.0
!
! Define which hosts are on the virtual network, and the care-of access list
ip mobile host 10.0.0.1 10.0.0.10 virtual-network 10.0.0.0 255.0.0.0 care-of-access 2
!
! Define which hosts are on Ethernet 1, with lifetime of one hour
ip mobile host 11.0.0.1 11.0.0.5 interface Ethernet1 lifetime 3600
!
! The next ten lines specify security associations for mobile hosts
! on virtual network 10.0.0.0
!
ip mobile secure host 10.0.0.1 spi 100 key hex 12345678123456781234567812345678
ip mobile secure host 10.0.0.2 spi 200 key hex 87654321876543218765432187654321
ip mobile secure host 10.0.0.3 spi 300 key hex 31323334353637383930313233343536
ip mobile secure host 10.0.0.4 spi 100 key hex 45678332353637383930313233343536
ip mobile secure host 10.0.0.5 spi 200 key hex 33343536313233343536373839303132
ip mobile secure host 10.0.0.6 spi 300 key hex 73839303313233343536313233343536
ip mobile secure host 10.0.0.7 spi 100 key hex 83930313233343536313233343536373
ip mobile secure host 10.0.0.8 spi 200 key hex 43536373839313233330313233343536
ip mobile secure host 10.0.0.9 spi 300 key hex 23334353631323334353637383930313
ip mobile secure host 10.0.0.10 spi 100 key hex 63738393132333435330313233343536
!
! The next five lines specify security associations for mobile hosts
! on Ethernet1
!
ip mobile secure host 11.0.0.1 spi 100 key hex 73839303313233343536313233343536
ip mobile secure host 11.0.0.2 spi 200 key hex 83930313233343536313233343536373
ip mobile secure host 11.0.0.3 spi 300 key hex 43536373839313233330313233343536
ip mobile secure host 11.0.0.4 spi 100 key hex 23334353631323334353637383930313
ip mobile secure host 11.0.0.5 spi 200 key hex 63738393132333435330313233343536
!
! Deny access for this host
access-list 1 deny 11.0.0.5
!
! Deny access to anyone on network 13.0.0.0 trying to register
access-list 2 deny 13.0.0.0

AAA サーバを使用するホーム エージェントの例

次の AAA サーバ設定では、ホーム エージェントが AAA サーバを使用してセキュリティ アソシエーションを保存できます。Mobile IP は、RADIUS サーバを使用してセキュリティ アソシエーション情報を取得することが許可されます。この情報は、ホーム エージェントが登録の認証に使用します。このフォーマットは、CiscoSecure サーバにインポートできます。

user = 20.0.0.1 {
service = mobileip {
set spi#0 = “spi 100 key hex 12345678123456781234567812345678”
}
}
 
user = 20.0.0.2 {
service = mobileip {
set spi#0 = “spi 100 key hex 12345678123456781234567812345678”
}
}
 
user = 20.0.0.3 {
service = mobileip {
set spi#0 = “spi 100 key hex 12345678123456781234567812345678”
}
}
 

上記の例では、user はモバイル ノードの IP アドレスです。セキュリティ アソシエーションの構文は、 spi# num = " string " です。 string は、 ip mobile secure { host | visitor | home-agent | foreign-agent } key hex string コマンドの残りの部分です。

次に、AAA サーバを使用するようにホーム エージェントを設定する例を示します。

aaa new-model
aaa authorization ipmobile radius
!
ip mobile home-agent
ip mobile virtual-network 20.0.0.0 255.0.0.0
ip mobile host 20.0.0.1 20.0.0.3 virtual-network 20.0.0.0 255.0.0.0 aaa load-sa
!
radius-server host 1.2.3.4
radius-server key cisco

外部エージェントの設定例

次の例では、外部エージェントが Ethernet1 インターフェイスでサービスを提供しており、気付アドレス 68.0.0.31 とライフタイムの 1 時間をアドバタイズしています。

interface Ethernet0
ip address 68.0.0.31 255.0.0.0
interface Ethernet1
ip address 67.0.0.31 255.0.0.0
ip irdp
ip irdp maxadvertinterval 10
ip irdp minadvertinterval 7
ip mobile foreign-service
ip mobile registration-lifetime 3600
!
router mobile
!
ip mobile foreign-agent care-of Ethernet0

 

Mobile IP HA 冗長性の設定例

表 1 に、物理ホーム ネットワークおよび仮想ホーム ネットワークでモバイル ノードをサポートするために必要な Mobile IP HA 冗長性の設定の概要を示します。この表を参照して、この項の例を読む際に活用してください。

 

表 1 Mobile IP HA 冗長性の設定の概要

モバイル ノードのホーム ネットワーク
物理接続
ホーム エージェント アドレス
設定
ホーム エージェントが異なるサブネット上にあるモバイル ノード

物理ネットワーク

単数

HSRP グループ アドレス

ip mobile home-agent standby hsrp-group-name

仮想ネットワーク

単数

ip mobile home-agent address address

この設定では、 address は HSRP グループ アドレスです。

ip mobile home-agent standby hsrp-group-name virtual-network

仮想ネットワーク

複数

ip mobile home-agent address address

この設定では、 address はループバック インターフェイス アドレスです。

ip mobile home-agent standby hsrp-group-name1 virtual-network

ip mobile home-agent standby hsrp-group-name2 virtual-network

物理接続に関連する HSRP グループごとにこのコマンドを繰り返します。

複数の仮想ネットワーク

単数

ip mobile home-agent address address

この設定では、 address は HSRP グループ アドレスです。

ip mobile home-agent standby hsrp-group-name virtual-network

複数の仮想ネットワーク

複数

ip mobile home-agent address address

この設定では、 address はループバック インターフェイス アドレスです。

ip mobile home-agent standby hsrp-group-name1 virtual-network

ip mobile home-agent standby hsrp-group-name2 virtual-network

物理接続に関連する HSRP グループごとにこのコマンドを繰り返します。

ホーム エージェントが同一サブネット上にあるモバイル ノード

物理ネットワーク

単数

HSRP グループ アドレス

ip mobile home-agent standby hsrp-group-name

仮想ネットワーク

単数

ip mobile virtual-network net mask address address

この設定では、 address はループバック インターフェイス アドレスです。

ip mobile home-agent standby hsrp-group-name virtual-network

仮想ネットワーク

複数

ip mobile virtual-network net mask address address

この設定では、 address はループバック インターフェイス アドレスです。

ip mobile home-agent standby hsrp-group-name1 virtual-network

ip mobile home-agent standby hsrp-group-name2 virtual-network

物理接続に関連する HSRP グループごとにこのコマンドを繰り返します。

複数の仮想ネットワーク

単数

ip mobile virtual-network net mask address address

仮想ネットワークごとにこのコマンドを繰り返します。 address 引数は、同一サブネット上に配置されるループバック インターフェイスで設定されたアドレスです。

ip address address mask secondary インターフェイス コンフィギュレーション コマンドを指定して、同一インターフェイス上で設定された複数の IP アドレスをサポートします。

ip mobile home-agent standby hsrp-group-name virtual-network

複数の仮想ネットワーク

複数

ip mobile virtual-network net mask address address

仮想ネットワークごとにこのコマンドを繰り返します。 address 引数は、同一サブネット上に配置されるループバック インターフェイスで設定されたアドレスです。

ip address address mask secondary インターフェイス コンフィギュレーション コマンドを指定して、同一インターフェイス上で設定された複数の IP アドレスをサポートします。

ip mobile home-agent standby hsrp-group-name1 virtual-network

ip mobile home-agent standby hsrp-group-name2 virtual-network

物理接続に関連する HSRP グループごとにこのコマンドを繰り返します。

物理ネットワークの HA 冗長性の例

図 4 に、物理ネットワークのネットワーク トポロジの例を示します。この設定例は、同一または異なる物理ネットワーク上に存在するホーム エージェントをモバイル ノードとしてサポートします。

図 4 物理ネットワーク上での HA 冗長性を示すトポロジ

 

デフォルトの 100 よりも高い 110 にプライオリティが設定されているため、HA1 は物理ネットワーク e0 上のモバイル ノードを優先してホーム エージェント サービスを提供します。HA1 がアップすると、すべてのアクティブ ホーム エージェントをプリエンプション処理します。プリエンプト中は、現在のアクティブ ホーム エージェントからモビリティ バインディング テーブルを取得するか、ホーム エージェントの同期の 100 秒が終了するまで、HA1 はアクティブ ホーム エージェントにはなりません。


standby preempt コマンドが使用された場合、プリエンプト同期遅延が設定されている必要があります。または、ホーム エージェントがプリエンプション処理してアクティブになる前にモビリティ バインディングを取得できません。


スタンバイ HSRP グループ名は SanJoseHA です。HSRP グループ アドレスは 1.0.0.10 です。スタンバイ HA はこの HSRP グループ アドレスを使用して、物理ネットワーク上のモバイル ノードのモビリティ バインディングを取得します。Mobile IP は、SanJoseHA スタンバイ グループを使用してホーム エージェント冗長性を提供するように設定されています。

モバイル ノードは、HA アドレス 1.0.0.10 に設定されています。登録を受信すると、アクティブ ホーム エージェントのみが登録を処理します。アクティブ ホーム エージェントは、モビリティ バインディング アップデートをスタンバイ ホーム エージェントに送信します。これにより、同一のソース エンドポイントおよび宛先エンドポイントを持つトンネルも設定されます。アップデートおよびテーブルの取得は、ピア ホーム エージェントのホーム エージェントで設定されたセキュリティ アソシエーションを使用して認証されます。モバイル ノード宛のパケットが受信されると、いずれかのホーム エージェントがトンネリングします。HA1 がダウンすると、HSRP によって HA2 がアクティブになり、ホーム エージェント アドレス 1.0.0.10 に送信されるパケットを処理します。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
standby preempt delay sync 100
standby priority 110
 
ip mobile home-agent standby SanJoseHA
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
ip mobile home-agent standby SanJoseHA
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
 

1 つの物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

ここでは、次の 2 つの設定例を示します。

モバイル ノードとホーム エージェントは異なるサブネット上に存在します。

モバイル ノードとホーム エージェントは同一のサブネット上に存在します。

異なるサブネット上にあるモバイル ノードとホーム エージェント

HA1 および HA2 は、仮想ネットワーク 20.0.0.0 上のモバイル ノードにホーム エージェント サービスを提供するという役割を共有しています。ホーム エージェントは、1 つの物理ネットワーク上だけで接続されています。

スタンバイ グループ名は SanJoseHA です。HSRP グループ アドレスは 1.0.0.10 です。Mobile IP は、SanJoseHA スタンバイ グループを使用してホーム エージェント冗長性を提供するように設定されています。したがって、HSRP を使用すれば、ホームエージェントは、1.0.0.10 宛てのパケットを受信できます。

この設定が物理ネットワークの例と異なるのは、仮想ネットワークをサポートするためにグローバル HA アドレスを指定する必要がある点です。このアドレスは、モバイル ノードに対する登録応答で返されます。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! specifies global HA address=HSRP group address to be used by all mobile nodes
ip mobile home-agent address 1.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455

 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! specifies global HA address=HSRP group address to be used by all mobile nodes
ip mobile home-agent address 1.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455

同一サブネット上のモバイル エージェントとホーム エージェント

この例では、仮想ネットワークと同一のサブネット上に配置される HA でループバック アドレスが設定されます。仮想ネットワーク上のモバイル ノードは、HA IP アドレス、つまり仮想ネットワーク用に設定されたループ バックアドレスを使用します。スタンバイ HA がアップすると、この HA IP アドレスを使用して、仮想ネットワーク上のモバイル ノードのモビリティ バインディングを取得します。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! loopback to receive registration from MN on virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download)
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! loopback to receive registration from MN on virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download)
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
 

複数の物理ネットワークを使用した仮想ネットワークの HA 冗長性の例

ここでは、次の 2 つの設定例を示します。

モバイル ノードとホーム エージェントは異なるサブネット上に存在します。

モバイル ノードとホーム エージェントは同一のサブネット上に存在します。

異なるサブネット上にあるモバイル ノードとホーム エージェント

HA1 および HA2 は、仮想ネットワーク 20.0.0.0 上のモバイル ノードにホーム エージェント サービスを提供するという役割を共有しています。両方のホーム エージェントとも、10.0.0.10 というグローバル ホーム エージェント アドレスで設定されています。これは、これらのホーム エージェントのループバック インターフェイス アドレスです。この設定では、ホーム エージェントは 10.0.0.10 宛ての登録要求およびパケットを受信できます。

ループバック アドレスは、HSRP グループ アドレス 1.0.0.10 および 2.0.0.10 の代わりにグローバル HA アドレスとして使用され、いずれかの物理ネットワークがダウンしても HA が仮想ネットワークに対応し続けることができます。

モバイル ノードは、ホーム エージェント アドレス 10.0.0.10 で設定されます。登録を受信すると、(ルーティング プロトコルに応じて)いずれかのホーム エージェントが登録を処理し、ピア ホーム エージェントを更新します。登録を受信したホーム エージェントは、グループ内にピアのある、10.0.0.10 にマップされている最初の HSRP グループを検出し、このインターフェイスからアップデートを送信します。ネットワークの問題(たとえば、ホーム エージェントのネットワーク アダプタ障害、またはケーブルの切断)が存在する場合、HSRP はピアの不在を通知します。ホーム エージェントはこの HSRP グループを使用せずに、別の HSRP グループを検出して使用します。


) すべてのルータには、同一のループバック インターフェイス アドレスが設定されている必要があります。このアドレスは、グローバル HA アドレスとして使用されます。ただし、ルーティング プロトコルのルータ ID としてこのアドレスを使用してはいけません。


ピア ホーム エージェントが登録アップデートを受信すると、両方のホーム エージェントがモバイル ノードへパケットをトンネリングします。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip add 2.0.0.1 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
interface loopback0
ip address 10.0.0.10 255.255.255.255
 
!Specifies global HA address=loopback address to be used by all mobile nodes
ip mobile home-agent address 10.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
! Used to map to the HSRP group SanJoseHANet1
ip mobile home-agent standby SanJoseHANet1 virtual-network
! Used to map to the HSRP group SanJoseHANet2
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.2 spi 100 key hex 00112233445566778899001122334455

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip address 2.0.0.2 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
interface loopback0
ip address 10.0.0.10 255.255.255.255
 
!Specifies global HA address=loopback address to be used by all mobile nodes
ip mobile home-agent address 10.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
! Used to map to the HSRP group SanJoseHANet1
ip mobile home-agent standby SanJoseHANet1 virtual-network
! Used to map to the HSRP group SanJoseHANet2
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.1 spi 100 key hex 00112233445566778899001122334455

同一サブネット上のモバイル エージェントとホーム エージェント

この例では、仮想ネットワークと同一のサブネット上に配置される HA でループバック アドレスが設定されます。仮想ネットワーク上のモバイル ノードは、HA IP アドレス、つまり仮想ネットワーク用に設定されたループ バックアドレスを使用します。スタンバイ HA がアップすると、この HA IP アドレスを使用して、仮想ネットワーク上のモバイル ノードのモビリティ バインディングを取得します。

HA1 の設定

interface ethernet0
ip addr 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip addr 2.0.0.1 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
! loopback to receive registration from MN on virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download)
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile home-agent standby SanJoseHANet1 virtual-network
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.2 spi 100 key hex 00112233445566778899001122334455
 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
interface ethernet1
ip address 2.0.0.2 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
! loopback to receive registration from MN on virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download)
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile home-agent standby SanJoseHANet1 virtual-network
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.1 spi 100 key hex 00112233445566778899001122334455
 

1 つの物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

ここでは、次の 2 つの設定例を示します。

モバイル ノードとホーム エージェントは異なるサブネット上に存在します。

モバイル ノードとホーム エージェントは同一のサブネット上に存在します。

図 5 に、最初のシナリオのネットワーク トポロジの例を示します。図 6 に、2 番目のシナリオのネットワーク トポロジの例を示します。

図 5 1 つの物理ネットワークを使用した複数の仮想ネットワーク上での HA 冗長性を示すトポロジ(異なるサブネットの場合)

 

図 6 1 つの物理ネットワークを使用した複数の仮想ネットワーク上での HA 冗長性を示すトポロジ(同一サブネットの場合)

 

異なるサブネット上にあるモバイル ノードとホーム エージェント

HA1 と HA2 は、仮想ネットワーク 20.0.0.0 および 30.0.0.0 上のモバイル ノードにホーム エージェント サービスを提供するという役割を共有します。ホーム エージェントは、1 つの物理ネットワーク上だけで接続されています。

スタンバイ グループ名は SanJoseHA です。HSRP グループ アドレスは 1.0.0.10 です。Mobile IP は、SanJoseHA スタンバイ グループを使用してホーム エージェント冗長性を提供するように設定されています。したがって、HSRP を使用すれば、ホームエージェントは、1.0.0.10 宛てのパケットを受信できます。

この設定が物理ネットワークの例と異なるのは、仮想ネットワークをサポートするためにグローバル HA アドレスを指定する必要がある点です。このアドレスは、モバイル ノードに対する登録応答で返されます。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! specifies global HA address=HSRP group address to be used by all mobile nodes
ip mobile home-agent address 1.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
ip mobile virtual-network 30.0.0.0 255.0.0.0
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455

 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! specifies global HA address=HSRP group address to be used by all mobile nodes
ip mobile home-agent address 1.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
ip mobile virtual-network 30.0.0.0 255.0.0.0
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455

同一サブネット上のモバイル エージェントとホーム エージェント

仮想ネットワークごとに、仮想ネットワークと同一のサブネット上に配置される HA でループバック アドレスが設定されます。これは、1 つのループバック インターフェイスを設定し、 ip address ip-address mask [ secondary ] インターフェイス コンフィギュレーション コマンドを使用して、仮想ネットワークごとに異なる IP アドレスをそのループバック インターフェイスに割り当てるだけです。特定の仮想ネットワーク上のモバイル ノードは、HA IP アドレス、つまりこの仮想ネットワーク用に設定されたループ バックアドレスを使用します。スタンバイ HA がアップすると、この HA IP アドレスも使用して、特定の仮想ネットワーク上のモバイル ノードのモビリティ バインディングを取得します。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! loopback to receive registration from MN on each virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
ip address 30.0.0.1 255.255.255.255 secondary
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download) for
! each virtual-network
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile virtual-network 30.0.0.0 255.0.0.0 address 30.0.0.1
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455

HA2 の設定

interface e0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
! loopback to receive registration from MN on each virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
ip address 30.0.0.1 255.255.255.255 secondary
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download) for
! each virtual-network
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile virtual-network 30.0.0.0 255.0.0.0 address 30.0.0.1
! used to map to the HSRP group SanJoseHA
ip mobile home-agent standby SanJoseHA virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455

複数の物理ネットワークを使用した複数の仮想ネットワークの HA 冗長性の例

ここでは、次の 2 つの設定例を示します。

モバイル ノードとホーム エージェントは異なるサブネット上に存在します。

モバイル ノードとホーム エージェントは同一のサブネット上に存在します。

図 7 に、この設定タイプのネットワーク トポロジの例を示します。

図 7 複数の物理ネットワークを使用した仮想ネットワーク上での HA 冗長性を示すトポロジ

 

異なるサブネット上にあるモバイル ノードとホーム エージェント

HA1 と HA2 は、仮想ネットワーク 20.0.0.0、30.0.0.0、および 40.0.0.0 上のモバイル ノードにホーム エージェント サービスを提供するという役割を共有します。両方のホーム エージェントとも、10.0.0.10 というグローバル ホーム エージェント アドレスで設定されています。これは、これらのホーム エージェントのループバック インターフェイス アドレスです。この設定では、ホーム エージェントは 10.0.0.10 宛ての登録要求およびパケットを受信できます。

ループバック アドレスは、HSRP グループ アドレス 1.0.0.10 および 2.0.0.10 の代わりにグローバル HA アドレスとして使用され、いずれかの物理ネットワークがダウンしても HA が仮想ネットワークに対応し続けることができます。

モバイル ノードは、ホーム エージェント アドレス 10.0.0.10 で設定されます。登録を受信すると、(ルーティング プロトコルに応じて)いずれかのホーム エージェントが登録を処理し、ピア ホーム エージェントを更新します。登録を受信したホーム エージェントは、グループ内にピアのある、10.0.0.10 にマップされている最初の HSRP グループを検出し、このインターフェイスからアップデートを送信します。ネットワークの問題(たとえば、ホーム エージェントのネットワーク アダプタ障害、またはケーブルの切断)が存在する場合、HSRP はピアの不在を通知します。ホーム エージェントはこの HSRP グループを使用せずに、別の HSRP グループを検出して使用します。


) すべてのルータには、同一のループバック インターフェイス アドレスが設定されている必要があります。このアドレスは、グローバル HA アドレスとして使用されます。ただし、ルーティング プロトコルのルータ ID としてこのアドレスを使用してはいけません。


ピア ホーム エージェントが登録アップデートを受信すると、両方のホーム エージェントがモバイル ノードへパケットをトンネリングします。

HA1 の設定

interface ethernet0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip address 2.0.0.1 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
interface loopback0
ip address 10.0.0.10 255.255.255.255
 
!Specifies global HA address=loopback address to be used by all mobile nodes
ip mobile home-agent address 10.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
ip mobile virtual-network 30.0.0.0 255.0.0.0
ip mobile virtual-network 40.0.0.0 255.0.0.0
! Used to map to the HSRP group SanJoseHANet1
ip mobile home-agent standby SanJoseHANet1 virtual-network
! Used to map to the HSRP group SanJoseHANet2
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.2 spi 100 key hex 00112233445566778899001122334455

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip address 2.0.0.2 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
interface loopback0
ip address 10.0.0.10 255.255.255.255
 
!Specifies global HA address=loopback address to be used by all mobile nodes
ip mobile home-agent address 10.0.0.10
ip mobile virtual-network 20.0.0.0 255.0.0.0
ip mobile virtual-network 30.0.0.0 255.0.0.0
ip mobile virtual-network 40.0.0.0 255.0.0.0
! Used to map to the HSRP group SanJoseHANet1
ip mobile home-agent standby SanJoseHANet1 virtual-network
! Used to map to the HSRP group SanJoseHANet2
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.1 spi 100 key hex 00112233445566778899001122334455

同一サブネット上のモバイル エージェントとホーム エージェント

仮想ネットワークごとに、仮想ネットワークと同一のサブネット上に配置される HA でループバック アドレスが設定されます。これは、1 つのループバック インターフェイスを設定し、仮想ネットワークごとに、異なる IP アドレスをそのループバック インターフェイスに割り当てるだけです。つまり、 ip address ip-address mask [ secondary ] インターフェイス コンフィギュレーション コマンドを使用します。特定の仮想ネットワーク上のモバイル ノードは、HA IP アドレス、つまりこの仮想ネットワーク用に設定されたループ バックアドレスを使用します。スタンバイ HA がアップすると、この HA IP アドレスも使用して、特定の仮想ネットワーク上のモバイル ノードのモビリティ バインディングを取得します。

HA1 の設定

interface e0
ip address 1.0.0.1 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHANet1
 
interface ethernet1
ip address 2.0.0.1 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
! loopback to receive registration from MN on each virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
ip address 30.0.0.1 255.255.255.255 secondary
ip address 40.0.0.1 255.255.255.255 secondary
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download) for
! each virtual-network
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile virtual-network 30.0.0.0 255.0.0.0 address 30.0.0.1
ip mobile virtual-network 40.0.0.0 255.0.0.0 address 40.0.0.1
! used to map to the HSRP groups SanJoseHANet1 and SanJoseHANet2
ip mobile home-agent standby SanJoseHANet1 virtual-network
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.2 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.2 spi 100 key hex 00112233445566778899001122334455
 

HA2 の設定

interface ethernet0
ip address 1.0.0.2 255.0.0.0
standby ip 1.0.0.10
standby name SanJoseHA
 
interface ethernet1
ip address 2.0.0.2 255.0.0.0
standby ip 2.0.0.10
standby name SanJoseHANet2
 
! loopback to receive registration from MN on each virtual-network
interface loopback0
ip address 20.0.0.1 255.255.255.255
ip address 30.0.0.1 255.255.255.255 secondary
ip address 40.0.0.1 255.255.255.255 secondary
 
ip mobile home-agent
! address used by Standby HA for redundancy (update and download) for
! each virtual-network
ip mobile virtual-network 20.0.0.0 255.0.0.0 address 20.0.0.1
ip mobile virtual-network 30.0.0.0 255.0.0.0 address 30.0.0.1
ip mobile virtual-network 40.0.0.0 255.0.0.0 address 40.0.0.1
! used to map to the HSRP groups SanJoseHANet1 and SanJoseHANet2
ip mobile home-agent standby SanJoseHANet1 virtual-network
ip mobile home-agent standby SanJoseHANet2 virtual-network
ip mobile secure home-agent 1.0.0.1 spi 100 key hex 00112233445566778899001122334455
ip mobile secure home-agent 2.0.0.1 spi 100 key hex 00112233445566778899001122334455