Cisco IOS IP モビリティ コンフィギュレーション ガ イド
Router-to-Radio 通信用 Mobile Ad Hoc Network
Router-to-Radio 通信用 Mobile Ad Hoc Network
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Router-to-Radio 通信用 Mobile Ad Hoc Network

機能情報の検索

目次

Router-to-Radio 通信用 Mobile Ad Hoc Network の前提条件

Router-to-Radio 通信用 Mobile Ad Hoc Network の制約事項

Router-to-Radio 通信用 Mobile Ad Hoc Network に関する情報

CiscoIOS ソフトウェアで Virtual Multipoint Interface と PPPoE を使用する Router-to-Radio リンクの利点

Router-to-Radio 通信用 MANET

移動無線通信用 PPPoE インターフェイス

Radio-Aware ルーティング RFC 4938

Virtual Multipoint Interface

VMI インターフェイスによる OSPFv3 および EIGRP のリンク品質メトリック レポート

VMI インターフェイスの OSPF コスト計算

VMI インターフェイスの EIGRP コスト メトリック

VMI メトリックから EIGRP メトリックへの変換

VMI インターフェイスの動的コスト メトリック

VMI インターフェイスの EIGRP メトリック ダンプニング

OSFPv3 および EIGRP のネイバー アップ/ダウン シグナリング

PPPoE のクレジットベースおよびメトリックベース スケーリングおよびフロー制御

VMI インターフェイスでサポートされる IPv6 アドレス

IPv6 アドレス指定の制約事項

NBMA モードのマルチキャスト ルーティング

VMI インターフェイスのマルチキャスト サポート

VMI PPPoE を使用した Router-to-Radio リンクの設定方法

PPPoE サービス選択のためのサブスクライバ プロファイルの設定

PPPoE プロファイルへのサブスクライバ プロファイルの割り当て

インターフェイスでの PPPoE セッションのイネーブル化

IPv4 および IPv6 用仮想テンプレートの作成

EIGRP IPv4 用 VMI インターフェイスの作成とインターフェイスの割り当て

EIGRP IPv6 用 VMI インターフェイスの作成とインターフェイスの割り当て

従来型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定

名前指定型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定

従来型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定

名前指定型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定

OSPFv3 用 VMI インターフェイスの作成とインターフェイスの割り当て

マルチキャスト アプリケーション用 VMI インターフェイスでのバイパス モードのイネーブル化

VMI の設定確認

VMI PPPoE の設定例

例:EIGRP IPv4 を使用した基本的な VMI PPPoE の設定

例:IPv6 用 EIGRP を使用した基本的な VMI PPPoE の設定

例:IPv4 および IPv6 用 EIGRP を使用した VMI PPPoE の設定

例:VMI インターフェイスの EIGRP 変更ベース ダンプニング

例:VMI インターフェイスの EIGRP インターバルベース ダンプニング

例:OSPFv3 での VMI PPPoE の設定

例:複数の仮想テンプレートを使用した VMI の設定

例:集約モードを使用した、仮想テンプレートと VMI の設定における IP アドレスの調整

例:バイパスまたは集約モードを使用した VMI インターフェイスでのマルチキャスト サポートのイネーブル化

例:PPPoE の設定

例:2 つの VMI、2 つの仮想テンプレート、2 つのサービス名の設定

例:VMI でのパケットのマーキングおよびキューイング

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

Router-to-Radio 通信用 Mobile Ad Hoc Network の機能情報

Router-to-Radio 通信用 Mobile Ad Hoc Network

Router-to-Radio 通信用 Mobile Ad Hoc Network(MANET)は、IP ルーティングと移動無線通信をアドホック ネットワーキング アプリケーションに統合する際に生じる問題に対応します。MANET 向けシスコ ソリューションは、以下の機能を提供します。

無線ネットワークからのレイヤ 2 フィードバックに基づいた最適なルートの選択

ノードがネットワークに参加またはネットワークから脱退する際の高速コンバージェンス

ポイントツーポイントの指向性無線トポロジとマルチホップ ルーティングの効率的統合

各無線とそのパートナー ルータ間におけるフロー制御通信

ノードがネットワークに参加またはネットワークから脱退すると、無線はただちに Router-to-Radio リンクを介してルータに通知できるので、ルータはタイマーを利用するよりも迅速にトポロジの変更を認識できます。無線からのこうしたリンクステータス通知がなければ、ルータは多くの場合、トラフィックを待機している間にタイムアウトします。無線からのリンクステータス通知により、ルータはすみやかにネットワーク トポロジの変更に対応できます。ルータと無線の間でリンク品質に関するメトリック情報がやり取りされるので、ルータは使用するリンクをより適切に判断できます。

Router-to-Radio リンクで提供されるリンクステータス シグナリングを使用すると、トポロジの変更による停止が緩和または解消されるため、音声やビデオなどのアプリケーションがより円滑に動作します。セッションの安定性が高まり、アクティブな時間が長くなります。

機能情報の検索

ご使用のソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「Router-to-Radio 通信用 Mobile Ad Hoc Network の機能情報」 を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

Router-to-Radio 通信用 Mobile Ad Hoc Network の前提条件

このマニュアルで説明する機能には、次のルータ プラットフォームのいずれかが必要です。

Cisco 2800 シリーズ(2801、2811、2821、2851)

Cisco 3250 および Cisco 3270

Cisco 3800 シリーズ(3825 または 3845)

このマニュアルで説明する PPP over Ethernet(PPPoE)と Virtual Multipoint Interface(VMI)機能を使用するには、ドラフト RFC 2516 および RFC 4938 bis に記載の PPPoE 機能拡張を実装する無線デバイスが必要です。高速無線には、draft-bberry-rfc4938.txt( クレジット フローおよびリンク メトリック用 PPPoE 拡張 )を実装できます。

Router-to-Radio 通信用 Mobile Ad Hoc Network の制約事項

ルーテッド ポートおよび VLAN インターフェイスの VMI

VMI はルーテッド ポートおよび VLAN インターフェイス上で設定できます。

Quality of Service

VMI では、シスコが提供する Quality of Service(QoS)キューイング機能のうち、クラスベースの Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)のみがサポートされます。VMI では、Differentiated Service Code Point(DSCP; 差別化サービス コード ポイント)値の識別と Network-Based Application Recognition(NBAR; ネットワークベース アプリケーション認識)の実行が可能ですが、それらの照合においてポリシングまたはポリシー マッピングは行われません。

Router-to-Radio 通信用 Mobile Ad Hoc Network に関する情報

「Cisco IOS ソフトウェアで Virtual Multipoint Interface と PPPoE を使用する Router-to-Radio リンクの利点」

「Router-to-Radio 通信用 MANET」

「移動無線通信用 PPPoE インターフェイス」

「Radio-Aware ルーティング RFC 4938」

「Virtual Multipoint Interface」

「VMI インターフェイスによる OSPFv3 および EIGRP のリンク品質メトリック レポート」

「OSFPv3 および EIGRP のネイバー アップ/ダウン シグナリング」

「PPPoE のクレジットベースおよびメトリックベース スケーリングおよびフロー制御」

「VMI インターフェイスでサポートされる IPv6 アドレス」

「NBMA モードのマルチキャスト ルーティング」

「VMI インターフェイスのマルチキャスト サポート」

Cisco IOS ソフトウェアで Virtual Multipoint Interface と PPPoE を使用する Router-to-Radio リンクの利点

音声、ビデオ、およびデータ ソリューションのコンバージェンスによって、ミッションクリティカルなネットワーキングと IP 通信を必要とする組織は以下のような利点が得られます。

無線ネットワークからのレイヤ 2 フィードバックに基づいて最適なルートを選択できます。

ポイントツーポイントの指向性無線トポロジとマルチホップ ルーティングが効率的に統合されます。

ルータはネットワーク トポロジの変更にすみやかに対応できるので、ノードがネットワークに参加またはネットワークから脱退する際、より高速にコンバージェンスを実行できます。

無線とそのパートナー ルータ間におけるフロー制御により、通信リンクの移動による停止が緩和または解消されるのため、音声やビデオなどのアプリケーションがより円滑に動作します。セッションの安定性が高まり、アクティブな時間が長くなります。

Router-to-Radio 通信用 MANET

Mobile Ad Hoc Network(MANET)を使用すると、固定通信インフラストラクチャのないエリアに配属されたユーザが、重要な音声、ビデオ、およびデータ サービスにアクセスできるようになります。たとえば戦地にいる兵士は、ユニファイド コミュニケーション、マルチメディア アプリケーション、リアルタイムの情報配信を利用して、状況確認を強化し、戦況の変化に迅速に対応できます。災害担当マネージャは、ビデオ会議、データベース アクセス、連携用ツールを使用して、複数の機関の対応を Incident Command System(ICS; 緊急時指令システム)の枠組みの中で調整できます。イベント プランナーや試写会のマネージャは、モバイル エンド ユーザを短期ベースで調整するコスト効率の高い手段として MANET を活用できます。

MANET 環境では、移動の激しいノードが、帯域幅に制約のある無線リンク上で相互通信を行います。個々のノードは無線ルータとネットワーク ルータの両方を備え、これら 2 つのデバイスはイーサネットで相互接続されています。これらのノードはネットワークに頻繁に出入りできるため、MANET ルーティング トポロジはきわめて動的に変化します。MANET での高速コンバージェンスは難しくなってきています。なぜなら、ルーティング プロトコルの標準的なタイミング メカニズムによってイベントが検出されるよりもずっと前に、ノードの状態が変化するからです。

MANET 内の無線リンク品質は、ノイズ、フェージング、干渉、電源変動などさまざまな要因の影響を受けるため、大きく変動することがあります。その結果、輻輳を回避して最適なルーティング パスを判断すると、ルータ ネットワークにはさらに多大な困難が生じます。狭いビーム幅で動作する指向性無線は、ネイバー ノードとの連続した物理的ポイントツーポイント接続としてネットワークをモデリングする傾向があります。このようなポイントツーポイント モデルは、マルチホップのマルチポイント ルータ環境に正しく変換されません。なぜなら、各ルータのトポロジ データベースのサイズが拡大し、ルーティング効率が低下するからです。

したがって、MANET 環境における効果的なネットワーキングでは、次のようなメカニズムが求められます。

ルータと無線が、無線ネットワークの運用に影響を与えることなく、効率的に相互運用できる。

無線のポイントツーポイント パラダイムとルータのポイントツーマルチポイント パラダイムを合理的に処理できる。

無線が、各リンクおよびネイバーのステータスをルータに報告できる。

ルータは上記の情報を使用して、最適なルーティングを決定できる。

移動無線通信用 PPPoE インターフェイス

MANET の実装は PPPoE セッションを使用して、ルータとそのパートナー無線間でノード間通信ができるようにします。各無線は、他の無線への無線リンクを確立すると、ただちに PPPoE セッションを開始します。PPPoE セッションがアクティブになった後、エンドツーエンド(ルータ間)の PPP セッションが確立されます。このプロセスは、無線が新しい無線リンクを確立するたびに繰り返されます。ルータ上の VMI は、オプションで複数の PPPoE セッションを集約し、多重化します。これにより、ルーティング プロセスからは単一のインターフェイスのように見えます。VMI は一連の PPP/PPPoE 接続を収集します。VMI インターフェイスの配下には仮想アクセス インターフェイスがあり、各 PPP/PPPoE 接続に関連付けられています。VMI インターフェイスでのマルチキャスト アプリケーションの実行については、「VMI インターフェイスのマルチキャスト サポート」を参照してください。

MANET に配置された他の各ルータ/無線ネイバーの代わりに、ルータと無線間で PPPoE セッションが確立されます。これらのレイヤ 2 セッションを使用して、無線ネットワークのステータスがルータのレイヤ 3 プロセスに報告されます。図 1は、モバイル ルータと指向性無線によって MANET ネットワーク内で行われる PPPoE セッションのやり取りを示しています。

図 1 モバイル ルータと指向性無線間の PPPoE セッション交換

 

この機能は、RFC 4938 準拠の無線がイーサネットを使用してルータに接続することを前提としています。ルータは常に、イーサネット リンクがアップ状態であると見なします。リンクの無線側がダウンすると、ルータはルーティング更新がタイムアウトになるまで待機してからルート ダウンを宣言し、その後ルーティング テーブルを更新します。図 2 に、単純な Router-to-Radio リンク トポロジを示します。

図 2 Router-to-Radio リンク

 

VMI PPPoE に使用されるルーティング プロトコルは、Enhanced Interior Gateway Routing Protocol(EIGRP)(IPv4、IPv6)と Open Shortest Path First version 3(OSPFv3)(IPv4、IPv6)です。

Radio-Aware ルーティング RFC 4938

Radio-Aware ルーティングの Router-to-Radio 統合に関するレイヤ間フィードバックでは、RFC 4938 で定義された機能が活用されます。RFC 4938 は Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の標準規格で、ルータと、可変帯域幅環境で動作し、バッファリング機能が制限されているデバイス(移動無線など)とのイーサネットベースの通信向けに、PPPoE 拡張が定義されています。これらの拡張は、PPPoE セッションベースのメカニズムを提供し、リンク品質メトリックなどの無線ネットワーク ステータスの共有や、ルータと RFC 4938 対応無線間のフロー制御の設定を可能にします。

RFC 4938 無線は、ネットワークで検出された各ルータおよび無線ネイバーの代わりに、隣接するルータとのレイヤ 2 PPPoE セッションを開始します。これらのレイヤ 2 セッションを使用して、各ネイバー リンクの無線ネットワーク ステータスがルータに報告されます。無線は、各 PPPoE セッションと、ネイバーへの各リンクを対応付けます。

Virtual Multipoint Interface

VMI インターフェイスは、パケットのネクストホップの転送アドレスに基づいて、発信パケットを適切な PPPoE セッションにマッピングするサービスを提供します。VMI インターフェイスはブロードキャスト サービスも提供し、一連のポイントツーポイント接続を、ブロードキャスト機能を備えたポイントツーマルチポイント インターフェイスとしてエミュレートします。マルチキャスト アドレスを持つパケットが集約モードの VMI インターフェイス経由で転送される場合、VMI はそのパケットを複製し、仮想アクセス インターフェイス経由で各ネイバーに送信します。

指向性無線は、広い帯域幅、広い電力送信範囲、または低い検出確率を必要とするアプリケーションでよく利用されます。これらの無線は、ポイントツーポイント モードで動作し、ブロードキャスト機能は通常備えていません。ただし、MANET のルーティング プロセスは、ブロードキャスト機能によってネットワーク リンクがポイントツーマルチポイントとして扱われるため、最も効率的に動作します。ルータでは、MANET をポイントツーポイント ノードの集合としてモデリングすると、内部データベースのサイズに非常に大きく影響します。

ルータの VMI は、オプションで無線イーサネット接続から各ネイバーへの PPPoE セッションをすべて集約します。VMI は、レイヤ 3 のルーティング プロトコルとアプリケーションからは、単一のポイントツーマルチポイント、マルチアクセス、ブロードキャスト対応ネットワークに見えるよう、これらのセッションをマッピングします。ただし、無線側の PPPoE セッションの整合性は VMI によって維持されるので、各ポイントツーポイント接続は固有の QoS キューを使用できます。

リンク品質メトリックとネイバー アップ/ダウン シグナリングも、VMI によって無線からルーティング プロトコルへリレーされます。VMI 信号は、EIGRP(IPv4 および IPv6 ネイバー用)と OSPFv3(IPv4 および IPv6 ネイバー用)によって使用されます。

VMI インターフェイスによる OSPFv3 および EIGRP のリンク品質メトリック レポート

無線リンクの品質は、ルータ間トラフィックのスループットに直接影響します。PPPoE プロトコルで提供されるプロセスによって、ルータはリンク品質メトリック情報を要求でき、無線はこの情報を報告できます。Cisco OSFPv3 および EIGRP を実装することで、ネイバーに対するルート コストは、無線から報告されるメトリックに基づいて動的に更新されます。これにより、所定の無線リンク内で最適なルートを選択し、ルーティングの頻繁な変更による影響を軽減できます。

ルーティング プロトコルは、raw 無線リンクを受け取り、各リンクのコンポジット品質メトリックを計算します。これらのメトリックを計算する場合は、以下の要因を考慮する必要があります。

最大データ レート:無線リンクの理論上の最大データ レート(バイト/秒)

現在のデータ レート:リンクの現在のデータ レート(バイト/秒)

遅延:パケットで発生する伝送遅延(ms)

リソース:リソースの残量(電池残量など)を表すパーセンテージ(0 ~ 100)

相対的リンク品質:相対的品質を表す数値(0 ~ 100)、最高品質は 100

設定プロセスでは、メトリックを重み付けし、個々の特性の重要度を指定できます。たとえば、スループットが特に重視される場合は、 現在のデータ レート メトリックに重みを設定し、コンポジット メトリックでの重要度を高くすることができます。同様に、重要でないメトリックをコンポジットの計算から除外することもできます。

リンク メトリックは急速に、ただし多くの場合はごくわずかな程度で変化する可能性があります。その結果、無意味なルーティング更新が頻繁に発生します。最悪の場合、リンク品質のわずかな変化にその都度対応しようとして、ほぼ途切れることなくネットワークでチャーンが発生します。この問題を回避するために、シスコは調整可能な緩和メカニズムを提供します。ユーザはこのメカニズムを使用して、しきい値を設定することができます。しきい値を下回るメトリックの変化は無視されます。

新しく検出されたピアや到達不能な既存のピアを通知する信号をルータが受信すると、ルーティングが変更されます。調整可能なヒストリシス メカニズムを使用することで、こうしたルーティング変更のしきい値を調整できます。調整可能なメトリックは、重み付けされ、以下の特性を表すために動的に調整されます。

現在の帯域幅と最大帯域幅

遅延

リソース

ヒステリシス

ユーザは、個々の重みの設定を解除できます。すべての重みを削除すると、コストをそのインターフェイス タイプのデフォルト値に戻すことができます。ルーティングの変更に基づき、これらのメトリックを適用することで、コストを判断できます。OSPF および EIGRP メトリックの詳細については、以下の項を参照してください。

「VMI インターフェイスの OSPF コスト計算」

「VMI インターフェイスの EIGRP コスト メトリック」

「VMI メトリックから EIGRP メトリックへの変換」

「VMI インターフェイスの動的コスト メトリック」

「VMI インターフェイスの EIGRP メトリック ダンプニング」

VMI インターフェイスの OSPF コスト計算

コスト コンポーネントは急速に変化する可能性があるため、変化量を抑えてネットワーク全体のチャーンを減らすことが重要です。S2、S3、S4 の推奨値は、ネットワークの変更率を抑制するためのネットワーク シミュレーションに基づきます。S1 の推奨値は 0 です。これは、この変数がルート コスト計算から除外されるようにするためです。

全体的なリンク コストは図 3の式を使用して計算されます。

図 3 VMI インターフェイスの OSPF コスト計算

 

OSPF コスト計算で使用される記号の定義を 表 1 に示します。

 

表 1 OSPF コスト計算の定義

コスト コンポーネント
コンポーネントの定義

OC

次の式を使用して参照帯域幅から計算される「デフォルトの OSPF コスト」

reference_bw/(MDR × 1000)(reference_bw = 10^8)

A ~ D

各種の無線固有のデータに基づく式。0 ~ 64,000 の範囲で結果が生成されます。

A

CDR および MDR 関連の式

(2^16 × (100 - (CDR × 10 /MDR)))/100

B

リソース関連の式

((100 - RESOURCES)^3 × 2^16/10^6)

C

無線によって報告された遅延(報告された時点ですでに 0 ~ 64,000 の範囲内)(LATENCY)

D

RLF 関連の式

((100 - RLF) × 2^16)/100

S1 ~ S4

CLI から入力されるスカラー重み付け係数。これらのスカラーにより、A ~ D で計算された値は縮小されます。

あるコンポーネントに対し、0 の値は 0~ 64,000 の全範囲をディセーブルにし、100 の値はイネーブルにします。

各ネットワークには固有の特性があり、実際のネットワーク パフォーマンスを最適化するには、それぞれに異なる設定が必要です。したがって、 表 2 に示す推奨されるコストの設定値は、OSPFv3 ネットワークを最適化するための開始点として捉えてください。

 

表 2 OSPF コスト メトリックの推奨値設定

設定
メトリックの説明
デフォルト値
推奨値

S1

ipv6 ospf 動的重み付けスループット

100

0

S2

ipv6 ospf 動的重み付けリソース

100

29

S3

ipv6 ospf 動的重み付け遅延

100

29

S4

ipv6 ospf 動的重み付け L2 係数

100

29

図 3 の式を使用して、デフォルト パスのコストが次のように計算されました。これらの値が使用しているネットワークに適していない場合は、独自のパス コストの計算方法を使用できます。

56 kbps シリアル リンク:デフォルトのコストは 1785 です。

64 kbps シリアル リンク:デフォルトのコストは 1562 です。

T1(1.544-Mbps シリアル リンク):デフォルトのコストは 64 です。

E1(2.048-Mbps シリアル リンク):デフォルトのコストは 48 です。

4 Mbps トークン リング:デフォルトのコストは 25 です。

イーサネット:デフォルトのコストは 10 です。

16 Mbps トークン リング:デフォルトのコストは 6 です。

FDDI:デフォルトのコストは 1 です。

X.25:デフォルトのコストは 5208 です。

非同期:デフォルトのコストは 10,000 です。

ATM:デフォルトのコストは 1 です。

これらの設定を説明するために、VMI インターフェイスに対する OSPF コスト メトリックの定義例を次に示します。

interface vmi1
ipv6 ospf cost dynamic weight throughput 0
ipv6 ospf cost dynamic weight resources 29
ipv6 ospf cost dynamic weight latency 29
ipv6 ospf cost dynamic weight L2-factor 29

VMI インターフェイスの EIGRP コスト メトリック

EIGRP がルーティング プロトコルとして使用される場合、メトリックを使用することで EIGRP はルーティングの変更に対応できます。リンクステート メトリックは、ルータ リンク アドバタイズメントでリンク コストとしてアドバタイズされます。ルーティング クエリーに対して送信される応答には、常に最新のメトリック情報が含まれています。以下の例外は、即時更新が送信される原因となります。

ダウンしたインターフェイス

ダウンしたルート

ルータが新規のネクスト ホップを選択する原因となるメトリックの変更

EIGRP は動的 raw 無線リンク特性を受け取り、独自の式に基づいてコンポジット EIGRP メトリックを計算します。リンク特性が変わった結果としてネットワーク内でチャーンが生じないようにするために、調整可能な緩和メカニズムが使用されます。

EIGRP は、一連のベクトル メトリックとともにメトリック重みを使用して、ローカル Routing Information Base(RIB; ルーティング情報ベース)のインストールとルート選択に関するコンポジット メトリックを計算します。EIGRP コンポジット メトリックは次の式で計算されます。

EIGRP メトリック = 256×((K1×帯域幅) + (K2×帯域幅)/(256 - 負荷) + (K3×遅延)×(K5/(信頼性 + K4)))

表 3 に、EIGRP のベクトル メトリックおよびその説明を示します。

 

表 3 EIGRP のベクトル メトリック

ベクトル メトリック
説明

帯域幅

ルートの最小帯域幅(kb/s)。0 または任意の正の整数です。この式の帯域幅は、次の式によってスケーリングおよび反転されます。

(10^7 / minimum Bw in kb/s)

遅延

ルート遅延(10 マイクロ秒単位)

遅延信頼性

0 ~ 255 の数で表現される、成功したパケット伝送の可能性。値 255 は信頼性が 100% であること、0 は信頼性がないことを意味します。

負荷

0 ~ 255 の数値で表現される、ルートの有効な帯域幅(255 は 100% 負荷)。

MTU

ルートの最小の最大伝送ユニット(MTU)サイズ(バイト単位)。0 または任意の正の整数です。

EIGRP はインターフェイス上でメトリック重みをモニタし、EIGRP のメトリック計算の調整を可能にし、タイプ オブ サービス(ToS)を示します。 表 4 に、K 値とそのデフォルト値を示します。

 

表 4 EIGRP の K 値とデフォルト

設定
デフォルト値

K1

1

K2

0

K3

1

K4

0

K5

0

大半の設定では、優先される帯域幅とともに、最初の 2 つのメトリック、つまり遅延と帯域幅を使用します。256 × (Bw + Delay) のデフォルト式は EIGRP メトリックです。この式の帯域幅は、次の式によってスケーリングおよび反転されます。

(10^7/最小帯域幅(KB/秒))

IGRP の場合と同様、重みの変更は可能ですが、これらの重みはすべてのルータ上で同じにする必要があります。たとえば、特定の宛先に対する帯域幅が 128 kb/s、遅延が 84000 マイクロ秒である IGRP リンクについて見てみます。

カットダウン式を使用すると、EIGRP メトリックの計算は 256 × (Bw + Delay) に単純化され、結果は次のようになります。

Metric = 256 × (10^7/128 + 84000/10) = 256 × 86525 = 22150400

ルート遅延を計算するには、遅延の値を 10 で割り、マイクロ秒の 10 分の 1 単位で真の値を得ます。

MANET の遅延を計算する際、ルータ インターフェイスからその遅延が得られる場合、遅延は常に 10 マイクロ秒の単位で計算されます。通常、MANET を使用する場合には、インターフェイス遅延を使用せずに、無線でアドバタイズされた遅延を使用します。無線から受ける遅延はマイクロ秒単位であるため、カットダウン式を次のように調整する必要があります。

メトリック = (256×(10^7/128) + (84000×256)/10) = 20000000 + 2150400 = 22150400

VMI メトリックから EIGRP メトリックへの変換

VMI ネイバーへの接続品質は、レイヤ 2 からレイヤ 3 へのフィードバックに基づいて動的に計算されるさまざまな特性によって異なります。 表 5 に、EIGRP のメトリックとその意味を示します。

 

表 5 VMI インターフェイスの EIGRP MANET メトリック

メトリック
意味

現在のデータ レート

リンクのデータ レートのスナップショット値(バイト/秒)

最大データ レート

リンクの最大レート(バイト/秒)

遅延

リンクの平均遅延(ms)

リソース

パーセンテージ(0 ~ 100)で表されるリソース(電池残量など)Harris の実装では常に 100 が報告されます。

相対的リンク品質

無線側から見たリンク品質を表す不透明な数値(0 ~ 100)。0 は最低品質のリンク、100 は最高品質のリンクを表します。

これらの EIGRP ベクトル メトリック値は、 表 6 に示す基本的な EIGRP インターフェイス パラメータに対応しています。

 

表 6 VMI メトリック値と EIGRP ベクトル メトリック値の対応付け

VMI メトリック
EIGRP メトリック
対応付け

現在のデータ レート

帯域幅

直接使用され、キロビットに変換されます。

現在のデータ レート = 0 の場合、(現在のデータ レート/最大データ レート)は 1 であると定義されます。

相対的リンク品質リソース

信頼性

次の式で計算されます。

リソース < 30 % の場合

(255 × ((relative link quality + resources)/2)/100

または

(255 × relative link quality)/100

最大データ レート

相対的リンク品質

遅延

次の式で計算されます。

calc_delay(maximum_data_rate) × 100/relative link quality)/USEC_TO_MSEC

USEC_TO_MSEC に使用される値は 1000 です。

calc_delay は、既知の遅延/帯域幅値に対する値をチェックする関数です。既知の値と一致しない場合は、10,000,000,000/max_data_rate の式が使用されます。

負荷

負荷

次の式で計算されます。

((255 × load)/100)

VMI インターフェイスの動的コスト メトリック

インターフェイスに使用される動的コスト メトリックは、レイヤ 3(L3)へのレイヤ 2(L2)フィードバックに基づいて計算されます。動的コストは次の式を使用して計算されます。

L2L3API

メトリックは次のように計算されます。

S1 = ipv6 ospf 動的重み付けスループット
S2 = ipv6 ospf 動的重み付けリソース
S3 = ipv6 ospf 動的重み付け遅延
S4 = ipv6 ospf 動的重み付け L2 係数
OC = 非 VMI ルートの標準コスト

スループット = (current-data-rate)/(maximum-data-rate)

ルータの動的コスト = OC + (S1) + (S2) + (S3) + (S4)

動的コストとデフォルト コストを同じにするには、すべてのパラメータを 0 にする必要があります。

各レイヤ 2 フィードバックは、0 ~ 65535 の範囲でコストに影響します。このコスト範囲を縮小するには、オプションの weight キーワードを throughput resources latency 、または L2-factor キーワードとともに使用します。各重みのデフォルト値は 100 %で、0 ~ 100 の範囲で設定できます。特定の重みに 0 が設定された場合、その重みは OSPF コストには影響しません。

コスト コンポーネントは急速に変化する可能性があるため、変化数を抑えてネットワーク全体のチャーンを減らす必要が生じることがあります。コスト変更のしきい値を設定するには、オプションの hysteresis キーワードを threshold threshold-value キーワードおよび引数とともに使用します。このしきい値を下回るコスト変更は無視されます。

VMI インターフェイスの EIGRP メトリック ダンプニング

メトリック コンポーネントが急速に変化すると、VMI インターフェイスを通じて学習されたプレフィクスを更新し、すべての隣接にそれを送信する必要があるため、ネットワークに影響を及ぼす可能性があります。このような更新は、さらなる更新の原因となり、最悪の場合はネットワーク全体でチャーンを引き起こします。こうした影響を回避するには、メトリックを抑制するか、しきい値を設定し、ダンプニングしきい値を超える変更が無視されるようにします。

即時更新の原因となるネットワークの変更は次のとおりです。

ダウンしたインターフェイス

ダウンしたルート

ルータが新規のネクスト ホップを選択する原因となるメトリックの変更

メトリック変更のダンプニングは、変更または時間間隔に基づいて設定できます。

ダンプニング方式が変更ベースの場合、特定のインターフェイスを通じて学習されたルートの変更(つまり特定のインターフェイスのメトリックの変更)は隣接にアドバタイズされません。ただし、計算されたメトリック変更が、最後にアドバタイズされた値と大きく異なるために、更新の送信が必要になる場合を除きます。

ダンプニング方式が時間間隔ベースの場合、特定のインターフェイスを通じて学習されたルートの変更(つまり特定のインターフェイスのメトリックの変更)は、変更によって新しいルート パスが選択される場合を除き、所定の時間が経過するまで隣接にはアドバタイズされません。

タイマーが時間切れになると、報告すべき顕著な変更があったルートが報告されます。ルートが変更された結果、ルートの最終的なメトリックと最後に更新されたメトリックが一致すれば、更新は送信されません。

OSFPv3 および EIGRP のネイバー アップ/ダウン シグナリング

MANET は、非常に変化の激しい環境です。ノードは速いペースで無線範囲に出入りします。ノードが出入りするたびに、ルータはネットワーク トポロジを論理的に再構築する必要があります。通常、ルーティング プロトコルは、タイマー方式の「hello」メッセージまたはネイバー タイムアウトを使用してトポロジの変更を追跡しますが、MANET の場合はこうしたメカニズムに依存することで、コンバージェンスが受け入れがたいほど低速になる可能性があります。

ネイバー アップ/ダウン シグナリング機能は、無線によって生成されるリンクステータス信号を使用して、より迅速にネットワーク コンバージェンスを実行します。PPPoE セッションの作成または終了によって他のネイバーへのリンクが確立または終端されるたびに、無線がルータに通知します。ルータでは、ルーティング プロトコル(OSPFv3 または EIGRP)が新しい隣接関係(新規ネイバー用)を構築するか、既存の隣接関係を破棄する(ネイバーが失われた場合)ことで、これらの信号にただちに応答します。たとえば、自動車がビルの陰を走行していて接続が失われた場合、ルータはただちにその接続損失を検出し、ブロックされていないネイバーを経由してその自動車への新しいルートを確立します。このような高速ネットワーク コンバージェンスは、音声コールのドロップやビデオ セッションの中断を最小限に抑えるために必要不可欠な機能です。

PPPoE が設定された VMI が使用されている場合、パートナー ノードが脱退するか、新規パートナーが参加すると、無線はただちにトポロジの変更をルータに通知します。信号を受け取ると、ルータはただちに変更を宣言し、ルーティング テーブルを更新します。シグナリング機能には次のような利点があります。

ルーティングの遅延を低減し、アプリケーションのタイムアウトを防止します。

指向性無線リンクを介して、ネットワークベースのアプリケーションおよび情報を確実かつ迅速に配信できます。

高速コンバージェンスと最適なルート選択が可能なため、音声やビデオなど遅延の影響を受けやすいトラフィックが中断されません。

内部キューイングおよびバッファリングの必要性を最小限に抑えることで、無線機器への影響を軽減します。

複数の無線が配置されたネットワークに、一貫した Quality Of Service を提供します。

メッセージングを使用すると、以下のような状況で必要となる柔軟なルーティングを実行できます。

無線リンクのノイズ

無線リンクのフェージング

無線リンクの輻輳

無線リンクの電力フェージング

無線の活用

図 4に、無線リンクがアップおよびダウンした場合に実行されるシグナリング シーケンスを示します。

図 4 アップおよびダウン シグナリング シーケンス

 

PPPoE のクレジットベースおよびメトリックベース スケーリングおよびフロー制御

各無線は、他の無線とのリンクを確立すると、ただちにローカル ルータとの PPPoE セッションを開始します。各ノードの PPPoE セッションがアクティブになった後、エンドツーエンド(ルータ間)の PPP セッションが確立されます。このプロセスは、無線が無線リンクを確立するたびに繰り返されます。

各無線リンクの伝送容量は、場所の違いや環境の状態によって異なり、多くの無線伝送システムは、バッファリング機能が制限されています。無線でのパケット キューイングの必要性を軽減するために、PPPoE プロトコル拡張では、輻輳が発生した場合にルータがトラフィックのバッファリングを制御できるようにします。これらの Router-to-Radio セッションにフロー制御を実装すると、均等化キューイングなどの QoS 機能を使用できます。

フロー制御ソリューションでは、RFC 4938 に記載されているクレジット認可メカニズムを利用します。PPPoE セッションが確立されると、無線はフロー制御されたセッションを要求します。ルータがこの要求を確認した場合、後続のトラフィックはすべてフロー制御されている必要があります。フロー制御セッションが要求され、ルータがそれに対応できない場合、セッションは終了します。通常、無線とルータは、セッション検出における最初の段階でクレジットを認可します。クレジットを使い切ったデバイスは、新たなクレジットが認可されるまで送信を中止する必要があります。クレジットは、セッションを通して徐々に追加できます。

メトリック スケーリングは、高速リンクを必要とする高性能無線で使用されます。無線は、最大データ レートと現在のデータ レートを別々のスケーラー値で表すことができます。クレジット スケーリングを使用すると、無線は 64 バイトのデフォルト クレジット認可(またはスケーリング係数)をデフォルト値に変更できます。ユーザは、無線によって設定された最大データ レート、現在のデータ レート、およびスカラー値を show vmi neighbor detail コマンド出力に表示できます。

VMI インターフェイスでサポートされる IPv6 アドレス

VMI インターフェイスには、IPv6 アドレスのみ、IPv4 アドレスのみ、または IPv4 と IPv6 の両方のアドレスを設定できます。

IPv6 アドレスは個々のルータ インターフェイスに割り当てられ、ルータ上で IPv6 トラフィックのグローバルな転送が可能になります。デフォルトでは IPv6 アドレスは設定されておらず、IPv6 ルーティングはディセーブルになっています。


ipv6 address コマンドの ipv6-address 引数には、RFC 2373 に記載されている形式を使用する必要があります。その場合、16 ビット値を使用した 16 進数でアドレスを指定し、コロンで区切ります。

ipv6 address コマンドの /prefix-length 引数は 10 進数の値で、プレフィクスを構成しているアドレスの連続する上位ビット数(アドレスのネットワーク部)を指定します。10 進値の前にはスラッシュが必要です。


IPv6 アドレス指定の制約事項

Cisco IOS Release 12.2(4)T 以降のリリース、Cisco IOS Release 12.0(21)ST、および Cisco IOS Release 12.0(22)S 以降のリリースでは、 ipv6 address または ipv6 address eui-64 コマンドを使用して、インターフェイスで同じプレフィクス内に複数の IPv6 グローバル アドレスを設定できます。インターフェイスでは、複数の IPv6 リンクローカル アドレスはサポートされません。

Cisco IOS Release 12.2(4)T、12.0(21)ST、および 12.0(22)S よりも前のリリースでは、インターフェイス上で同じプレフィクスに複数の IPv6 アドレスが設定されると、Cisco IOS CLI に次のメッセージが表示されまれす。

Prefix <prefix-number> already assigned to <interface-type>
 

IPv6 アドレス指定の詳細については、『 Cisco IOS IPv6 Configuration Guide 』の「Implementing IPv6 Addressing」の章を参照してください。

NBMA モードのマルチキャスト ルーティング

マルチキャストは、ネットワーク全体に広がるネットワーク グループ メンバーシップとして定義されています。通常、マルチキャストはソースから受信側グループへの単方向通信です。IPv4 および IPv6 アーキテクチャでは、アドレス空間の一部がマルチキャスト グループ用に予約されており、グループ アドレスは Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)に要求して割り当てられます。IPv4 の例については、 表 7 を参照してください。

 

表 7 IPv4 マルチキャスト アドレスの割り当て

アドレス
割り当て先

224.0.0.1

すべてのホスト

224.0.0.2

すべてのマルチキャスト ホスト

224.0.0.5

OSPF ルータ

224.0.0.10

IGRP ルータ

224.0.0.13

すべての PIM ルータ

224.0.0.19 ~ 224.0.0.255

未割り当て

VMI インターフェイスのマルチキャスト サポート

デフォルトでは、VMI インターフェイスは集約モードで動作します。これは、PPPoE セッションで作成されるすべての仮想アクセス インターフェイスが、設定済み VMI の下で論理的に集約されることを意味します。つまり、EIGRP や OSPFv3 などレイヤ 2 よりも上位層にあるアプリケーションは、VMI インターフェイスでのみ定義される必要があります。VMI インターフェイスへ送信されたパケットは、正しい仮想アクセス インターフェイスへ転送されます。集約モードの VMI インターフェイスは、NonBroadcast Multiple Aaccess(NBMA; 非ブロードキャスト マルチアクセス)モードで動作します。マルチキャスト トラフィックは、そのグループのリスナーが存在する NBMA ネイバーのみで転送されます。

ユーザがマルチキャスト アプリケーションを実行しており、レイヤ 2 よりも上位層にあるアプリケーションに仮想アクセス インターフェイスを直接公開する必要がある場合は、バイパス モードで動作するように VMI を設定できます。大半のマルチキャスト アプリケーションでは、マルチキャスト Reverse Path Forwarding(RPF; リバース パス フォワーディング)が予想したとおりに動作できるよう、仮想アクセス インターフェイスをルーティング プロトコルに直接公開する必要があります。バイパス モードを使用する場合は、ネイバー アップ、ネイバー ダウン、メトリックなどのレイヤ間信号の送出を処理するために、VMI インターフェイスを定義する必要があります。アプリケーションは、実際の基本的な仮想アクセス インターフェイスを認識し、それらのインターフェイスへパケットを直接送信します。仮想テンプレートの設定では、さらに情報が必要になります。VMI をバイパス モードで操作すると、アプリケーション内のデータベースが通常予想されるよりも大きくなる可能性があります。これは、通常の操作でより多くのインターフェイスに関する情報が必要になるためです。

バイパス モードの設定後は、実行コンフィギュレーションを NVRAM に保存して、仮想アクセス インターフェイスを論理的に集約するデフォルト モードの VMI 動作を上書きしてください。

設定情報については、以下の項を参照してください。

「マルチキャスト アプリケーション用 VMI インターフェイスでのバイパス モードのイネーブル化」

「例:バイパスまたは集約モードを使用した VMI インターフェイスでのマルチキャスト サポートのイネーブル化」

VMI PPPoE を使用した Router-to-Radio リンクの設定方法

この項では、VMI PPPoE の設定に使用されるタスクについて説明します。VMI PPPoE の設定タスクには、インフラストラクチャの実装、IPv4 および IPv6 アドレス指定方式の設定、および、ルーティング環境の設定が含まれます。このマニュアルでは、VMI と関連性のある PPPoE の設定についてのみ、設定時の注意事項が示されています。PPPoE の設定の詳細については、『 Cisco IOS Broadband and DSL Configuration Guide 』を参照してください。PPPoE コマンドの詳細については、『 Cisco IOS Broadband and DSL Command Reference』を参照してください。

ここでは、次の作業について説明します。

「PPPoE サービス選択のためのサブスクライバ プロファイルの設定」(必須)

「PPPoE プロファイルへのサブスクライバ プロファイルの割り当て」(必須)

「インターフェイスでの PPPoE セッションのイネーブル化」(必須)

「IPv4 および IPv6 用仮想テンプレートの作成」(任意)

「EIGRP IPv4 用 VMI インターフェイスの作成とインターフェイスの割り当て」(任意)

「EIGRP IPv6 用 VMI インターフェイスの作成とインターフェイスの割り当て」(任意)

「従来型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定」(任意)

「名前指定型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定」(任意)

「従来型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定」(任意)

「名前指定型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定」(任意)

「OSPFv3 用 VMI インターフェイスの作成とインターフェイスの割り当て」(任意)

「マルチキャスト アプリケーション用 VMI インターフェイスでのバイパス モードのイネーブル化」(任意)

「VMI の設定確認」(任意)

PPPoE サービス選択のためのサブスクライバ プロファイルの設定

PPPoE サービスを選択するためのサブスクライバ プロファイルを設定するには、次の作業を実行します。この項では、PPPoE サービス名を設定します。このサービス名は、Cisco IOS PPPoE サーバと接続するために RFC 4938 bis 無線 PPPoE クライアントによって使用されます。VMI が機能するには、PPPoE サービスを選択するためのサブスクライバ プロファイルを設定する必要があります。

前提条件

MANET の実装で使用されるすべての PPPoE サービス名は、VMI および RFC 4938 bis 機能とともに使用できるよう、「manet_radio」で始まる 必要があります 。例を挙げると、manet_radio や manet_radio_satellite などです。

手順の概要

1. enable

2. configure terminal

3. subscriber profile profile-name

4. pppoe service manet_radio

5. exit

6. subscriber authorization enable

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

subscriber profile profile-name

 

Router(config)# subscriber profile manet

サブスクライバ プロファイル コンフィギュレーション モードを開始します。

ステップ 4

pppoe service manet_radio

 

Router(config-sss-profile)# pppoe service manet_radio

サブスクライバ プロファイルに PPPoE MANET 無線サービス名を追加し、VMI インターフェイスの使用をイネーブルにします。

ステップ 5

exit

 

Router(config-sss-profile)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

subscriber authorization enable

 

Router(config)# subscriber authorization enable

サブスクライバ サービス スイッチ タイプの認証をイネーブルにします。

このコマンドは、Virtual Private Dialup Network(VPDN; バーチャル プライベート ダイヤルアップ ネットワーク)が使用されていない場合に必要です。

ステップ 7

exit

 

Router(config)# exit

特権 EXEC モードに戻ります。

PPPoE プロファイルへのサブスクライバ プロファイルの割り当て

PPPoE プロファイルにサブスクライバ プロファイルを割り当てるには、次の作業を実行します。この設定では、BBA グループ名が、サブスクライバ プロファイルで以前定義されたサブスクライバ プロファイル名と一致している必要があります。この場合、サービス名として使用されるプロファイル名は manet_radio です。

手順の概要

1. enable

2. configure terminal

3. bba-group pppoe { group-name | global }

4. virtual-template template-number

5. service profile subscriber-profile-name [ refresh minutes ]

6. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bba-group pppoe { group-name | global }

 

Router(config)# bba-group pppoe group1

PPPoE プロファイルを定義し、BBA グループ コンフィギュレーション モードを開始します。

global キーワードは、特定のプロファイルが割り当てられていない任意の PPPoE ポートのデフォルト プロファイルとして機能するプロファイルを作成します。

ステップ 4

virtual-template template-number

 

Router(config-bba-group)# virtual-template 1

この PPPoE プロファイルを使用するすべての PPPoE ポートに対し、どの仮想テンプレートを使用して仮想アクセス インターフェイスを複製するかを指定します。

ステップ 5

service profile subscriber-profile-name [ refresh minutes ]

 

Router(config-bba-group)# service profile subscriber-group1

PPPoE プロファイルにサブスクライバ プロファイルを割り当てます。

PPPoE サーバは、サブスクライバ プロファイルにリストされているサービス名を、設定済み PPPoE プロファイルを使用する各 PPPoE クライアント接続にアドバタイズします。

refresh minutes キーワードおよび引数は、キャッシュされた PPPoE 設定が所定の分数の経過後にタイムアウトするよう指定するために使用します。

ステップ 6

end

 

Router(config-bba-group)# end

(任意)特権 EXEC モードに戻ります。

トラブルシューティングのヒント

PPPoE セッションのトラブルシューティングを行うには、 show pppoe session および debug pppoe コマンドを使用します。

インターフェイスでの PPPoE セッションのイネーブル化

インターフェイスで PPPoE セッションをイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. pppoe enable [ group group-name ]

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interfac e type number

 

 

Router(config)# interface fastethernet 3/1

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

イーサネット、ファスト イーサネット、ギガビット イーサネット、VLAN、および VLAN サブインターフェイスを使用できます。

ステップ 4

pppoe enable [ group group-name ]

 

Router(config-if)# pppoe enable group bba1

インターフェイスまたはサブインターフェイスで PPPoE セッションをイネーブルにします。

オプションを使用して PPPoE プロファイルがインターフェイスに割り当てられていない場合、そのインターフェイスは

グローバルな PPPoE プロファイルを使用します。

ステップ 5

end

 

Router(config-if)# end

(任意)特権 EXEC モードに戻ります。

IPv4 および IPv6 用仮想テンプレートの作成

IPv4 および IPv6 用の仮想テンプレートを作成するには、次の作業を実行します。仮想テンプレート インターフェイスを使用して、VMI ネイバー用に作成された各仮想アクセス インターフェイスの設定を動的に複製します。

前提条件

仮想テンプレートを使用する場合は、PPP キープアライブ メッセージをオフにして CPU をより効率的に使用し、損失の多発する Radio Frequency(RF; 無線周波数)リンクで PPP キープアライブ パケットが失われても、ルータによって接続が切断されないようにしておくことを推奨します。

手順の概要

1. enable

2. configure terminal

3. interface virtual-template number

4. IPv4 を使用している場合は、ステップ 5 および 8 を実行します。

IPv6 を使用している場合は、ステップ 6 ~ 8 を実行します。

両方を使用している場合は、ステップ 5 ~ 8 を実行します。

5. ip unnumbered interface-type interface-number

6. ipv6 enable

7. ipv6 unnumbered interface-type interface-number

8. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface virtual-template number

 
Router(config)# interface virtual-template 1

仮想テンプレートを作成し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

IPv4 を使用している場合は、ステップ 5 および 8 を実行します。

IPv6 を使用している場合は、ステップ 6 ~ 8 を実行します。

両方を使用している場合は、ステップ 5 ~ 8 を実行します。

--

ステップ 5

ip unnumbered interface-type interface-number

 
Router(config-if)# ip unnumbered vmi 1

インターフェイスに明示的な IP アドレスを割り当てなくても、インターフェイスで IPv4 の IP 処理をイネーブルにします。

ステップ 6

ipv6 enable

 

Router(config-if)# ipv6 enable

インターフェイスで IPv6 処理をイネーブルにします。

ステップ 7

ipv6 unnumbered interface-type interface-number

 

Router(config-if)# ipv6 unnumbered vmi i

インターフェイスに明示的な IPv6 アドレスを割り当てなくても、インターフェイスで IPv6 処理をイネーブルにします。

ステップ 8

end

 

Router(config-if)# end

(任意)特権 EXEC モードに戻ります。

次の手順

仮想テンプレートの設定の詳細については、『 Cisco IOS Dial Solutions Configuration Guide 』の「Virtual Template Interface Service」の章を参照してください。

EIGRP IPv4 用 VMI インターフェイスの作成とインターフェイスの割り当て

EIGRP IPv4 用の VMI インターフェイスを作成し、PPPoE がイネーブルなインターフェイスを割り当てるには、次の作業を実行します。


) この設定には、QoS 均等化キューイングと、VMI インターフェイスに適用されるサービス ポリシーが含まれます。VMI の設定で仮想テンプレートに新しいポリシー マップを適用する前に、以前の設定に残っている均等化キューイングを削除してください。


前提条件

VMI インターフェイスを作成する場合は、その VMI インターフェイスの定義に IPv4 アドレスを割り当てます。

無線は PADT メッセージを使用して、レイヤ 2 RF 接続が動作していないことをルータに警告します。シスコは、PPP キープアライブ メッセージをオフにして CPU をより効率的に使用し、損失の多発する RF リンクで PPP キープアライブ パケットが失われても、ルータによって接続が切断されないようにしておくことを推奨します。

制約事項

対応する物理インターフェイスにはアドレスを割り当てないでください。

手順の概要

1. enable

2. configure terminal

3. ip routing

4. no virtual-template subinterface

5. policy-map policy-mapname

6. class class-default

7. fair-queue

8. exit

9. exit

10. interface virtual-template number

11. ip unnumbered interface-type interface-number

12. service-policy output policy-mapname

13. no keepalive

14. interface type number

15. ip address address mask

16. no ip redirects

17. no ip split-horizon eigrp autonomous-system-number

18. physical-interface type number

19. exit

20. router eigrp autonomous-system-number

21. network network-number ip-mask

22. redistribute connected

23. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip routing

 

Router(config)# ip routing

ルータ上で IP ルーティングをイネーブルにします。

ステップ 4

no virtual-template subinterface

 

Router(config)# no virtual-template subinterface

サブインターフェイスで仮想テンプレートをディセーブルにします。

ステップ 5

policy-map policy-mapname

 

Router(config)# policy-map fair-queue

QoS ポリシーマップ コンフィギュレーション モードを開始し、サービス ポリシーを指定するため 1 つ以上のインターフェイスに適用できるポリシー マップを作成または修正します。

ステップ 6

class class-default

 

Router(config-pmap)# class class-default

ポリシーを設定する前に、ポリシーを作成または変更するクラス名を指定するか、デフォルト クラス(通常は class-default class)を指定します。

Qos ポリシーマップ クラス コンフィギュレーション モードを開始します。

ステップ 7

fair-queue

 

Router(config-pmap-c)# fair-queue

インターフェイスで WFQ をイネーブルにします。

ステップ 8

exit

 

Router(config-pmap-c)# exit

QoS ポリシーマップ コンフィギュレーション モードに戻ります。

ステップ 9

exit

 

Router(config-pmap)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

interface virtual-template number

 

Router(config)# interface virtual-template 1

インターフェイス コンフィギュレーション モードを開始し、仮想アクセス インターフェイスの作成時に動的に設定および適用できる仮想テンプレート インターフェイスを作成します。

ステップ 11

ip unnumbered interface-type interface-number

 
Router(config-if)# ip unnumbered vmi 1

インターフェイスに明示的な IP アドレスを割り当てなくても、シリアル インターフェイスで IPv4 の IP 処理をイネーブルにします。

ステップ 12

service-policy output policy-mapname

 

Router(config-if)# service-policy output fair-queue

入力インターフェイスまたは Virtual Circuit(VC; 仮想回線)、あるいは出力インターフェイスまたは VC にポリシー マップを適用します。

ポリシー マップは、適用先のインターフェイスまたは VC のサービス ポリシーを指定します。

ステップ 13

no keepalive

 

Router(config-if)# no keepalive

インターフェイスへの PPP キープアライブ メッセージをオフにします。

ステップ 14

interface type number

 

Router(config-if)# interface vmi 1

VMI インターフェイスの番号を指定します。

ステップ 15

ip address address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

VMI インターフェイスの IP アドレスを指定します。

ステップ 16

no ip redirects

 

Router(config-if)# no ip redirects

Cisco IOS ソフトウェアが、パケットを受信したのと同じインターフェイス経由でパケットを再送するように設定されている場合は、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)リダイレクト メッセージの送信をディセーブルにします。

ステップ 17

no ip split-horizon eigrp autonomous-system-number

 

Router(config-if)# no ip split-horizon eigrp 101

指定されたセッションのスプリット ホライズン メカニズムをディセーブルにします。

ステップ 18

physical-interface type number

 

Router(config-if)# physical-interface FastEthernet 0/1

ルータ上で VMI インターフェイスに関連付ける物理サブインターフェイスを作成します。

ステップ 19

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 20

router eigrp autonomous-system-number

 

Router(config)# router eigrp 100

ルータで EIGRP ルーティングをイネーブルにし、自律システム番号を特定し、ルータ コンフィギュレーション モードを開始します。

ステップ 21

network network-number ip-mask

 

Router(config-router)# network 209.165.200.225 255.255.255.224

EIGRP ネットワークを特定します。

ステップ 22

redistribute connected

 

Router(config-router)# redistribute connected

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

ステップ 23

end

 

Router(config-router)# end

(任意)特権 EXEC モードに戻ります。

EIGRP IPv6 用 VMI インターフェイスの作成とインターフェイスの割り当て

EIGRP IPv6 用の VMI インターフェイスを作成し、PPPoE がイネーブルなインターフェイスを割り当てるには、次の作業を実行します。


) この設定には、QoS 均等化キューイングと、VMI インターフェイスに適用されるサービス ポリシーが含まれます。VMI の設定で仮想テンプレートに新しいポリシー マップを適用する前に、以前の設定に残っている均等化キューイングを削除してください。


前提条件

VMI インターフェイスを作成する場合は、その VMI インターフェイスの定義に IPv6 アドレスを割り当てます。

無線は PADT メッセージを使用して、レイヤ 2 RF 接続が動作していないことをルータに警告します。シスコは、PPP キープアライブ メッセージをオフにして CPU をより効率的に使用し、損失の多発する RF リンクで PPP キープアライブ パケットが失われても、ルータによって接続が切断されないようにしておくことを推奨します。

制約事項

対応する物理インターフェイスにはアドレスを割り当てないでください。

手順の概要

1. enable

2. configure terminal

3. no virtual-template subinterface

4. ipv6 unicast-routing

5. ipv6 cef

6. policy-map policy-mapname

7. class class-default

8. fair-queue

9. exit

10. exit

11. interface virtual-template number

12. ipv6 enable

13. no keepalive

14. service-policy output policy-mapname

15. interface type number

16. ipv6 address address / prefix-length

17. ipv6 enable

18. ipv6 eigrp as-number

19. no ipv6 redirects

20. no ipv6 split-horizon eigrp as-number

21. physical-interface type number

22. no shutdown

23. ipv6 router eigrp as-number

24. redistribute connected

25. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

no virtual-template subinterface

 

Router(config)# no virtual-template subinterface

サブインターフェイスで仮想テンプレートをディセーブルにします。

ステップ 4

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト ルーティングをイネーブルにします。

ステップ 5

ipv6 cef

 

Router(config)# ipv6 cef

ルータで IPv6 Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)をイネーブルにします。

ステップ 6

policy-map policy-mapname

 

Router(config-pmap)# policy-map fair-queue

QoS ポリシーマップ コンフィギュレーション モードを開始し、サービス ポリシーを指定するため 1 つ以上のインターフェイスに適用できるポリシー マップを作成または修正します。

ステップ 7

class class-default

 

Router(config-pmap)# class class-default

ポリシーを設定する前に、ポリシーを作成または変更するクラス名を指定するか、デフォルト クラス(通常は class-default class)を指定します。

Qos ポリシーマップ クラス コンフィギュレーション モードを開始します。

ステップ 8

fair-queue

 

Router(config-pmap-c)# fair-queue

インターフェイスで WFQ をイネーブルにします。

ステップ 9

exit

 

Router(config-pmap-c)# exit

QoS ポリシーマップ コンフィギュレーション モードに戻ります。

ステップ 10

exit

 

Router(config-pmap)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

interface virtual-template number

 

Router(config)# interface virtual-template 1

インターフェイス コンフィギュレーション モードを開始し、仮想アクセス インターフェイスの作成時に動的に設定および適用できる仮想テンプレート インターフェイスを作成します。

ステップ 12

ipv6 enable

 

Router(config-if)# ipv6 enable

仮想テンプレートで IPv6 ルーティングをイネーブルにします。

ステップ 13

no keepalive

 

Router(config-if)# no keepalive

仮想テンプレートへの PPP キープアライブ メッセージをオフにします。

ステップ 14

service-policy output policy-mapname

 

Router(config-if)# service-policy output fair-queue

入力インターフェイスまたは Virtual Circuit(VC; 仮想回線)、あるいは出力インターフェイスまたは VC にポリシー マップを適用します。

ポリシー マップは、適用先のインターフェイスまたは VC のサービス ポリシーを指定します。

ステップ 15

interfac e type number

 

Router(config-if)# interface vmi 1

VMI インターフェイスを作成します。

ステップ 16

ipv6 address address / prefix-length

 

Router(config-if)# ipv6 address 2001:0DB8::/32

インターフェイスの IPv6 アドレスを指定します。

ステップ 17

ipv6 enable

 

Router(config-if)# ipv6 enable

インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 18

ipv6 eigrp as-number

 

Router(config-if)# ipv6 eigrp 1

指定されたインターフェイスで IPv6 の EIGRP をイネーブルにし、自律システム番号を指定します。

ステップ 19

no ipv6 redirects

 

Router(config-if)# no ipv6 redirects

Cisco IOS ソフトウェアが、パケットを受信したのと同じインターフェイス経由でパケットを再送するように設定されている場合は、ICMP IPv6 リダイレクト メッセージの送信をディセーブルにします。

ステップ 20

no ipv6 split-horizon eigrp as_number

 

Router(config-if)# no ipv6 split-horizon eigrp 100

EIGRP IPv6 のスプリット ホライズンをディセーブルにします。

このコマンドを特定の EIGRP 自律システム番号に関連付けます。

ステップ 21

physical-interface type number

 

Router(config-if)# physical-interface FastEthernet 1/0

ルータ上で VMI インターフェイスに関連付ける物理サブインターフェイスを作成します。

ステップ 22

no shutdown

 

Router(config-if)# no shutdown

ディセーブルなインターフェイスを再起動します。あるいは、インターフェイスがシャットダウンするのを防ぎます。

ステップ 23

ipv6 router eigrp as-number

 

Router(config-if)# ipv6 router eigrp 100

ルータでルータ コンフィギュレーション モードを開始し、IPv6 で EIGRP ルーティング プロセスを作成し、このプロセスを設定するためのコマンドを追加入力できるようにします。

ステップ 24

redistribute connected

 

Router(config-router)# redistribute connected

ソース プロトコルから学習したルートと、ソース プロトコルが動作しているインターフェイス上の接続先プレフィクスを、ターゲット プロトコルが再配布できるようにします。

あるルーティング ドメインから別のルーティング ドメインへ IPv6 ルートを再配布します。

ステップ 25

end

 

Router(config-router)# end

(任意)特権 EXEC モードに戻ります。

従来型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定

従来型の設定を使用して、VMI インターフェイスに EIGRP 変更ベースのダンプニング間隔を設定するには、次の作業を実行します。

ここでは、VMI インターフェイスとピアに関係する許容ルーティング更新のしきい値を 50% に設定します。

前提条件

このタスクを実行する前に、仮想テンプレートと該当する PPPoE の設定を完了してください。


) この機能は、IPv4 または IPv6 アドレス、あるいはその両方で設定できます。IPv4 と IPv6 の両方を使用している場合は、すべての設定を完了してください。


手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address address mask

5. no ip redirects

6. no ip split-horizon eigrp autonomous-system-number

7. ip dampening-change eigrp autonomous-system-number percentage

8. ipv6 address address または
ipv6 enable

9. ipv6 eigrp autonomous-system-number

10. no ipv6 split-horizon eigrp autonomous-system-number

11. ipv6 dampening-change eigrp autonomous-system-number percentage

12. router eigrp autonomous-system-number

13. network address

14. ipv6 router eigrp autonomous-system-number

15. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface vmi 1

インターフェイス コンフィギュレーション モードを開始し、VMI インターフェイスを作成します。

ステップ 4

ip address address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

VMI インターフェイスの IP アドレスを指定します。

ステップ 5

no ip redirects

 

Router(config-if)# no ip redirects

ルータがリダイレクトを送信しないようにします。

ステップ 6

no ip split-horizon eigrp autonomous-system-number

 

Router(config-if)# no ip split-horizon eigrp 101

EIGRP スプリット ホライズンをディセーブルにします。

ステップ 7

ip dampening-change eigrp autonomous-system-number percentage

 

Router(config-if)# ip dampening-change eigrp 1 50

しきい値の割合を設定することで、IPv4 の頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 8

ipv6 address address

 

または

ipv6 enable

 

Router(config-if)# ipv6 address 2001:0DB8::/32

 

または

Router(config-if)# ipv6 enable

IPv6 アドレスを指定します。

または

インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 9

ipv6 eigrp autonomous-system-number

 

Router(config-if)# ipv6 eigrp 1

インターフェイスで IPv6 の EIGRP をイネーブルにします。

ステップ 10

no ipv6 split-horizon eigrp autonomous-system-number

 

Router(config-if)# no ipv6 split-horizon eigrp 1

インターフェイスで IPv6 リダイレクト メッセージの送信をディセーブルにします。

ステップ 11

ipv6 dampening-change eigrp autonomous-system-number percentage

 

Router(config-if)# ipv6 dampening-change eigrp 1 30

しきい値の割合を設定することで、IPv6 の頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 12

router eigrp autonomous-system-number
 

Router(config-if)# router eigrp 1

EIGRP アドレス ファミリ プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 13

network address
 

Router(config-router)# network 209.165.200.225

ネットワーク アドレスを設定します。

ステップ 14

ipv6 router eigrp autonomous-system-number
 

Router(config-router)# ipv6 router eigrp 1

IPv6 で EIGRP ルーティング プロセスを設定します。

ステップ 15

end
 

Router(config-router)# end

(任意)特権 EXEC モードに戻ります。

名前指定型の設定を使用した、VMI インターフェイスの EIGRP 変更ベース ダンプニング間隔の設定

名前指定型の設定を使用して、VMI インターフェイスに EIGRP 変更ベースのダンプニング間隔を設定するには、次の作業を実行します。

ここでは、VMI インターフェイスとピアに関係する許容ルーティング更新のしきい値を 50% に設定します。

前提条件

このタスクを実行する前に、仮想テンプレートと該当する PPPoE の設定を完了してください。


) この機能は、IPv4 または IPv6 アドレス、あるいはその両方で設定できます。IPv4 と IPv6 の両方を使用している場合は、すべての設定を完了してください。


手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address address mask

5. no ip redirects

6. ipv6 address address または
ipv6 enable

7. router eigrp virtual-instance-name

8. address-family ipv4 autonomous-system autonomous-system-number

9. network address

10. af-interface type number

11. dampening-change percentage

12. exit

13. exit

14. address-family ipv6 autonomous-system autonomous-system-number

15. af-interface type number

16. dampening-change percentage

17. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface vmi 1

インターフェイス コンフィギュレーション モードを開始し、VMI インターフェイスを作成します。

ステップ 4

ip address address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

VMI インターフェイスの IP アドレスを指定します。

ステップ 5

no ip redirects

 

Router(config-if)# no ip redirects

ルータがリダイレクトを送信しないようにします。

ステップ 6

ipv6 address address

 

または

ipv6 enable

 

Router(config-if)# ipv6 address 2001:0DB8::/32

 

または

Router(config-if)# ipv6 enable

IPv6 アドレスを指定します。

または

インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 7

router eigrp virtual-instance-name

 

Router(config-if)# router eigrp name

インターフェイスで IPv6 の EIGRP をイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 8

address-family ipv4 autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 autonomous-system 1

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

ステップ 9

network address

 

Router(config-router-af)# network 209.165.200.225

ネットワーク アドレスを設定します。

ステップ 10

af-interface type number

 

Router(config-router-af)# af-interface vmi 1

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

dampening-change percentage
 

Router(config-router-af-interface)# dampening-change 50

しきい値の割合を設定することで、EIGRP アドレス ファミリにおけるインターフェイス経由の頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 12

exit
 

Router(config-router-af-interface)# exit

アドレス ファミリ インターフェイス コンフィギュレーション モードを終了します。

ステップ 13

exit
 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

ステップ 14

address-family ipv6 autonomous-system autonomous-system-number
 

Router(config-router)# address-family ipv6 autonomous-system 1

アドレス ファミリ コンフィギュレーション モードを開始して、IPv6 の EIGRP ルーティング インスタンスを設定します。

ステップ 15

af-interface type number

 

Router(config-router-af)# af-interface vmi 1

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始します。

ステップ 16

dampening-change percentage

 

Router(config-router-af-interface)# dampening-change 50

しきい値の割合を設定することで、インターフェイスを介した頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 17

end
 

Router(config-router-af-interface)# end

(任意)特権 EXEC モードに戻ります。

従来型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定

従来型の設定を使用して、VMI インターフェイスに EIGRP インターバルベースのダンプニング間隔を設定するには、次の作業を実行します。

ここでは、VMI インターフェイスとピアに影響するトポロジの変更に対して更新が行われる間隔を 30 秒に設定します。

前提条件

このタスクを実行する前に、仮想テンプレートと該当する PPPoE の設定を完了してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address address mask

5. no ip redirects

6. no ip split-horizon eigrp autonomous-system-number

7. ip dampening-interval eigrp autonomous-system-number interval

8. ipv6 address address または
ipv6 enable

9. ipv6 eigrp autonomous-system-number

10. no ipv6 split-horizon eigrp autonomous-system-number

11. ipv6 dampening-interval eigrp autonomous-system-number interval

12. router eigrp autonomous-system-number

13. network address

14. ipv6 router eigrp autonomous-system-number

15. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface vmi 1

インターフェイス コンフィギュレーション モードを開始し、VMI インターフェイスを作成します。

ステップ 4

ip address address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

VMI インターフェイスの IP アドレスを指定します。

ステップ 5

no ip redirects

 

Router(config-if)# no ip redirects

ルータがリダイレクトを送信しないようにします。

ステップ 6

no ip split-horizon eigrp autonomous-system-number

 

Router(config-if)# no ip split-horizon eigrp 101

EIGRP スプリット ホライズンをディセーブルにします。

ステップ 7

ip dampening-interval eigrp autonomous-system-number interval

 

Router(config-if)# ip dampening-change eigrp 1 30

しきい値の時間間隔を設定することで、インターフェイスを介した頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 8

ipv6 address address

 

または

ipv6 enable

 

Router(config-if)# ipv6 address 2001:0DB8::/32

 

または

Router(config-if)# ipv6 enable

IPv6 アドレスを指定します。

または

インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 9

ipv6 eigrp autonomous-system-number

 

Router(config-if)# ipv6 eigrp 1

インターフェイスで IPv6 の EIGRP をイネーブルにします。

ステップ 10

no ipv6 split-horizon eigrp autonomous-system-number

 

Router(config-if)# no ipv6 split-horizon eigrp 1

インターフェイスで IPv6 リダイレクト メッセージの送信をディセーブルにします。

ステップ 11

ipv6 dampening-interval eigrp autonomous-system-number interval

 

Router(config-if)# ipv6 dampening-interval eigrp 1 30

しきい値の時間間隔を設定することで、インターフェイスを介した頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 12

router eigrp autonomous-system-number
 

Router(config-if)# router eigrp 1

EIGRP アドレス ファミリ プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 13

network address
 

Router(config-router)# network 209.165.200.225

ネットワーク アドレスを設定します。

ステップ 14

ipv6 router eigrp autonomous-system-number
 

Router(config-router)# ipv6 router eigrp 1

IPv6 で EIGRP ルーティング プロセスを設定します。

ステップ 15

end
 

Router(config-router)# end

(任意)特権 EXEC モードに戻ります。

名前指定型の設定を使用した、VMI インターフェイスの EIGRP インターバルベース ダンプニング間隔の設定

名前指定型の設定を使用して、VMI インターフェイスに EIGRP インターバルベースのダンプニング間隔を設定するには、次の作業を実行します。

ここでは、VMI インターフェイスとピアに影響するトポロジの変更に対して更新が行われる間隔を 30 秒に設定します。

前提条件

このタスクを実行する前に、仮想テンプレートと該当する PPPoE の設定を完了してください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address address mask

5. no ip redirects

6. ipv6 address address
または
ipv6 enable

7. router eigrp virtual-instance-name

8. address-family ipv4 autonomous-system autonomous-system-number

9. network address

10. af-interface type number

11. dampening-interval interval

12. exit

13. exit

14. address-family ipv6 autonomous-system autonomous-system-number

15. af-interface type number

16. dampening-interval interval

17. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface vmi 1

インターフェイス コンフィギュレーション モードを開始し、VMI インターフェイスを作成します。

ステップ 4

ip address address mask

 

Router(config-if)# ip address 209.165.200.225 255.255.255.224

VMI インターフェイスの IP アドレスを指定します。

ステップ 5

no ip redirects

 

Router(config-if)# no ip redirects

ルータがリダイレクトを送信しないようにします。

ステップ 6

ipv6 address address

 

または

ipv6 enable

 

Router(config-if)# ipv6 address 2001:0DB8::/32

 

または

Router(config-if)# ipv6 enable

IPv6 アドレスを指定します。

または

インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 7

router eigrp virtual-instance-name

 

Router(config-if)# router eigrp name

インターフェイスで IPv6 の EIGRP をイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 8

address-family ipv4 autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 autonomous-system 1

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

ステップ 9

network address

 

Router(config-router-af)# network 209.165.200.225

ネットワーク アドレスを設定します。

ステップ 10

af-interface type number

 

Router(config-router-af)# af-interface vmi 1

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始します。

ステップ 11

dampening-interval interval
 

Router(config-router-af-interface)# dampening-interval 30

しきい値の時間間隔を設定することで、インターフェイスを介した頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 12

exit
 

Router(config-router-af-interface)# exit

アドレス ファミリ インターフェイス コンフィギュレーション モードを終了します。

ステップ 13

exit
 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

ステップ 14

address-family ipv6 autonomous-system autonomous-system-number
 

Router(config-router)# address-family ipv6 autonomous-system 1

アドレス ファミリ コンフィギュレーション モードを開始して、IPv6 の EIGRP ルーティング インスタンスを設定します。

ステップ 15

af-interface type number

 

Router(config-router-af)# af-interface vmi 1

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始します。

ステップ 16

dampening-interval interval

 

Router(config-router-af-interface)# dampening-interval 30

しきい値の時間間隔を設定することで、インターフェイスを介した頻繁なルーティング変更の影響を抑制または緩和します。

ステップ 17

end
 

Router(config-router-af-interface)# end

(任意)特権 EXEC モードに戻ります。

OSPFv3 用 VMI インターフェイスの作成とインターフェイスの割り当て

OSPFv3 用の VMI インターフェイスを作成し、PPPoE がイネーブルなインターフェイスを割り当てるには、次の作業を実行します。


) この設定には、QoS 均等化キューイングと、VMI インターフェイスに適用されるサービス ポリシーが含まれます。VMI の設定で仮想テンプレートに新しいポリシー マップを適用する前に、以前の設定に残っている均等化キューイングを削除してください。


前提条件

VMI インターフェイスを作成する場合は、その VMI インターフェイスの定義に IPv6 または IPv4 アドレスを割り当てます。

制約事項

対応する物理インターフェイスにはアドレスを割り当てないでください。

手順の概要

1. enable

2. configure terminal

3. no virtual-template subinterface

4. ipv6 unicast-routing

5. ipv6 cef

6. policy-map policy-mapname

7. class class-default

8. fair-queue

9. exit

10. exit

11. interface virtual-template number

12. ipv6 enable

13. no keepalive

14. service-policy output policy-mapname

15. interface type number

16. ipv6 enable

17. ipv6 ospf process-id area area-id [ instance instance-id ]

18. ipv6 ospf network point-to-multipoint

19. ipv6 ospf cost dynamic hysteresis [threshold threshold-value]

20. ipv6 ospf cost dynamic weight throughput percent

21. ipv6 ospf cost dynamic weight resources percent

22. ipv6 ospf cost dynamic weight latency percent

23. ipv6 ospf cost dynamic weight L2-factor percent

24. ipv6 ospf process-id area area-id [ instance instance-id ]

25. physical-interface type number

26. ipv6 router ospf process-id

27. router-id ip-address

28. redistribute connected metric-type number

29. timers spf spf-delay spf-hold

30. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

no virtual-template subinterface

 

Router(config)# no virtual-template subinterface

サブインターフェイスで仮想テンプレートをディセーブルにします。

ステップ 4

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト ルーティングをイネーブルにします。

ステップ 5

ipv6 cef

 

Router(config)# ipv6 cef

ルータで IPv6 CEF をイネーブルにします。

ステップ 6

policy-map policy-mapname

 

Router(config)# policy-map fair-queue

QoS ポリシーマップ コンフィギュレーション モードを開始し、サービス ポリシーを指定するため 1 つ以上のインターフェイスに適用できるポリシー マップを作成または修正します。

ステップ 7

class class-default

 

Router(config-pmap)# class class-default

ポリシーを設定する前に、ポリシーを作成または変更するクラス名を指定するか、デフォルト クラス(通常は class-default class)を指定します。

Qos ポリシーマップ クラス コンフィギュレーション モードを開始します。

ステップ 8

fair-queue

 

Router(config-pmap-c)# fair-queue

インターフェイスで WFQ をイネーブルにします。

ステップ 9

exit

 

Router(config-pmap-c)# exit

ポリシーマップ コンフィギュレーション モードに戻ります。

ステップ 10

exit

 

Router(config-pmap)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

interface virtual-template number

 

Router(config)# interface virtual-template 1

インターフェイス コンフィギュレーション モードを開始し、仮想アクセス インターフェイスの作成時に動的に設定および適用できる仮想テンプレート インターフェイスを作成します。

ステップ 12

ipv6 enable

 

Router(config-if)# ipv6 enable

仮想テンプレートで IPv6 をイネーブルにします。

ステップ 13

no keepalive

 

Router(config-if)# no keepalive

PPP キープアライブ メッセージをオフにします。

ステップ 14

service-policy output policy-mapname

 

Router(config-if)# service-policy output fair-queue

入力インターフェイスまたは Virtual Circuit(VC; 仮想回線)、あるいは出力インターフェイスまたは VC にポリシー マップを適用します。

ポリシー マップは、適用先のインターフェイスまたは VC のサービス ポリシーを指定します。

ステップ 15

interfac e type number

 

Router(config-if)# interface vmi 1

VMI インターフェイスを作成します。

ステップ 16

ipv6 enable

 

Router(config-if)# ipv6 enable

VMI インターフェイスで IPv6 ルーティングをイネーブルにします。

ステップ 17

ipv6 ospf process-id area area-id [ instance instance-id]

 

Router(config-if)# ipv6 ospf 1 area 0

インターフェイスで IPv6 OSPF ルーティングをイネーブルにします。

ステップ 18

ipv6 ospf network point-to-multipoint

 

Router(config-if)# ipv6 ospf network point-to-multipoint

OSPF ネットワーク タイプを指定します。

ステップ 19

ipv6 ospf cost dynamic hysteresis [threshold threshold-value]

 

Router(config-if)# ipv6 ospf cost dynamic hysteresis threshold 1000

インターフェイスのヒステリシス許容値を設定します。

ステップ 20

ipv6 ospf cost dynamic weight throughput percent

 

Router(config-if)# ipv6 ospf cost dynamic weight throughput 0

スループットしきい値のメトリックを設定します。

ステップ 21

ipv6 ospf cost dynamic weight resources percent

 

Router(config-if)# ipv6 ospf cost dynamic weight resources 29

リソース要素のメトリックを設定します。

ステップ 22

ipv6 ospf cost dynamic weight latency percent

 

Router(config-if)# ipv6 ospf cost dynamic weight latency 29

遅延要素のしきい値を設定します。

ステップ 23

ipv6 ospf cost dynamic weight L2-factor percent

 

Router(config-if)# ipv6 ospf cost dynamic weight L2-factor 29

レイヤ 2 からレイヤ 3 への遅延要素にメトリックを設定します。

ステップ 24

ipv6 ospf process-id area area-id [ instance instance-id ]

 

Router(config-if)# ipv6 ospf 1 area 0

インターフェイスで IPv6 の OSPF をイネーブルにします。

ステップ 25

physical-interface type number

 

Router(config-if)# physical-interface FastEthernet 0/1

ルータ上で VMI インターフェイスに関連付ける物理サブインターフェイスを作成します。

ステップ 26

ipv6 router ospf process-id

 

Router(config-if)# ipv6 router ospf 1

IPv6 ルータ コンフィギュレーション モードの OSPF をイネーブルにします。

ステップ 27

router-id ip-address

 

Router(config-router)# router-id 10.1.1.1

ルータの動的割り当てを許可する代わりに、特定のルータを識別します。

ステップ 28

redistribute connected metric-type number

 

Router(config-router)# redistribute connected metric-type 1

あるルーティング ドメインから別のルーティング ドメインへ IPv6 ルートを再配布します。

ソース プロトコルから学習したルートと、ソース プロトコルが動作しているインターフェイス上の接続先プレフィクスを、ターゲット プロトコルが再配布できるようにします。

ステップ 29

timers spf spf-delay spf-hold

 

Router(config-router)# timers spf 1 1

Shortest Path First(SPF)遅延時間と最大ホールド タイムをミリ秒単位で指定し、計算を遅らせます。これらの引数値の範囲は 1 ~ 600,000 ミリ秒(ms)です。

OSPF SPF スロットリング機能により、SPF スケジューリングをミリ秒間隔で設定して、ネットワークが不安定な場合に SPF 計算を遅らせることができます。SPF は、トポロジに変化が生じた場合には、Shortest Path Tree(SPT)を再計算するようにスケジューリングされます。

ステップ 30

end

 

Router(config-router)# end

(任意)特権 EXEC モードに戻ります。

次の出力例に、VMI の OSPF コストの変動を示します。

Router1# show ipv6 ospf interface serial2/0
 
Serial2/0 is up, line protocol is up
Link Local Address FE80::A8BB:CCFF:FE00:100, Interface ID 10
Area 1, Process ID 1, Instance ID 0, Router ID 200.1.1.1
Network Type POINT_TO_MULTIPOINT, Cost: 64 (dynamic), Cost Hysteresis: 200
Cost Weights: Throughput 100, Resources 20, Latency 80, L2-factor 100
Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
Hello due in 00:00:19
Index 1/2/3, flood queue length 0
Next 0x0(0)/0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 0
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)

マルチキャスト アプリケーション用 VMI インターフェイスでのバイパス モードのイネーブル化

VMI インターフェイスでパイパス モードをイネーブルにし、VMI インターフェイスで実行されるデフォルトの集約を上書きするには、次の作業を実行します。マルチキャスト アプリケーションにはパイパス モードを使用することを推奨します。

前提条件

このタスクは、VMI インターフェイスに仮想テンプレートと適切な PPPoE セッションが設定済みであることを前提としています。

制約事項

バイパス モードを使用すると、アプリケーション内のデータベースが大きくなる可能性があります。これは、通常の操作でより多くのインターフェイスに関する情報が必要になるためです。

デフォルト モードの VMI では、仮想アクセス インターフェイスが論理的に集約されるので、 mode bypass コマンドを入力したら、実行コンフィギュレーションを NVRAM に保存することを推奨します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. mode bypass

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interfac e type number

 

Router(config)# interface vmi 1

インターフェイス コンフィギュレーション モードを開始し、VMI インターフェイスを作成します。

ステップ 4

mode bypass

 

Router(config-if)# mode bypass

VMI インターフェイスでデフォルトの集約を上書きし、インターフェイスでのマルチキャスト トラフィックのサポートをバイパスするモードを設定します。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

VMI の設定確認

次のコマンドを使用して、VMI の設定を確認できます。

show pppoe session all

show interface vmi

show vmi neighbors

show vmi neighbors detail

show ip eigrp interfaces

show ip eigrp neighbors

show ipv6 eigrp interfaces

show ipv6 eigrp neighbors

show ipv6 ospf interface

VMI PPPoE の設定例

「例:EIGRP IPv4 を使用した基本的な VMI PPPoE の設定」

「例:IPv6 用 EIGRP を使用した基本的な VMI PPPoE の設定」

「例:IPv4 および IPv6 用 EIGRP を使用した VMI PPPoE の設定」

「例:VMI インターフェイスの EIGRP 変更ベース ダンプニング」

「例:VMI インターフェイスの EIGRP インターバルベース ダンプニング」

「例:OSPFv3 での VMI PPPoE の設定」

「例:複数の仮想テンプレートを使用した VMI の設定」

「例:集約モードを使用した、仮想テンプレートと VMI の設定における IP アドレスの調整」

「例:バイパスまたは集約モードを使用した VMI インターフェイスでのマルチキャスト サポートのイネーブル化」

「例:PPPoE の設定」

「例:2 つの VMI、2 つの仮想テンプレート、2 つのサービス名の設定」

「例:VMI でのパケットのマーキングおよびキューイング」

例:EIGRP IPv4 を使用した基本的な VMI PPPoE の設定

次に、ルーティング プロトコルとして EIGRP IPv4 を使用し、基本的な VMI PPPoE を設定する例を示します。この設定には、VMI インターフェイスが 1 つ含まれます。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname host1
!
logging buffered 3000000
no logging console
enable password test
!
no aaa new-model
clock timezone EST -5
ip cef
!
no ip domain lookup
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
subscriber profile test
pppoe service manet_radio
!
!
multilink bundle-name authenticated
no virtual-template subinterface
!
archive
log config
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe test
virtual-template 1
service profile test
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 209.165.200.225 255.255.255.224
no ip proxy-arp
load-interval 30
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
ip unnumbered vmi1
load-interval 30
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
ip address 209.165.200.226 255.255.255.224
no ip mroute-cache
load-interval 30
!
interface Vlan503
ip address 209.165.200.226 255.255.255.224
load-interval 30
!
interface vmi1
ip address 209.165.200.226 255.255.255.224
no ip redirects
no ip split-horizon eigrp 1
load-interval 30
dampening-change 50
physical-interface FastEthernet0/0
!
router eigrp 1
redistribute connected
network 209.165.200.226 255.255.255.224
network 209.165.200.227 255.255.255.224
auto-summary
!
no ip http server
no ip http secure-server
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
line vty 0 4
login
!
end

例:IPv6 用 EIGRP を使用した基本的な VMI PPPoE の設定

次に、ルーティング プロトコルとして IPv6 用 EIGRP を使用して VMI インターフェイスを設定する際の基本的な要件を示します。この設定には、VMI インターフェイスが 1 つ含まれます。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname host1
!
logging buffered 3000000
no logging console
enable password lab
!
no aaa new-model
clock timezone EST -5
ip cef
!
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
subscriber profile test
pppoe service manet_radio
!
!
multilink bundle-name authenticated
no virtual-template subinterface
!
!
!
!
archive
log config
!
!
policy-map FQ
class class-default
fair-queue
!
!
!
!
!
bba-group pppoe test
virtual-template 1
service profile test
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
!
interface Loopback1
ip address 209.165.200.226 255.255.255.224
no ip proxy-arp
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
no ip address
load-interval 30
ipv6 enable
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
ip address 209.165.200.225 255.255.255.224
no ip mroute-cache
load-interval 30
!
interface Vlan503
ip address 209.165.200.225 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface vmi1
no ip address
load-interval 30
ipv6 enable
no ipv6 redirects
ipv6 eigrp 1
no ipv6 split-horizon eigrp 1
physical-interface FastEthernet0/0
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
router-id 10.9.1.1
no shutdown
redistribute connected
!
control-plane
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
line vty 0 4
login
!
end

例:IPv4 および IPv6 用 EIGRP を使用した VMI PPPoE の設定

インターフェイスに IPv4 と IPv6 の両方のアドレスが設定されている場合に、EIGRP をルーティング プロトコルとして使用し、VMI PPPoE を設定する例を次に示します。この設定には、VMI インターフェイスが 1 つ含まれます。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname host1
!
logging buffered 3000000
no logging console
enable password lab
!
no aaa new-model
clock timezone EST -5
ip cef
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
subscriber profile test
pppoe service manet_radio
!
!
multilink bundle-name authenticated
no virtual-template subinterface
!
archive
log config
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe test
virtual-template 1
service profile test
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 209.165.200.225 255.255.255.224
no ip proxy-arp
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
ip unnumbered vmi1
load-interval 30
ipv6 enable
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
ip address 209.165.200.225 255.255.255.224
no ip mroute-cache
load-interval 30
!
interface Vlan503
ip address 209.165.200.225 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface vmi1
ip address 209.165.200.225 255.255.255.224
no ip redirects
no ip split-horizon eigrp 1
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
no ipv6 redirects
ipv6 eigrp 1
no ipv6 split-horizon eigrp 1
dampening-interval 30
physical-interface FastEthernet0/0
!
router eigrp 1
redistribute connected
network 209.165.200.225 255.255.255.224
network 209.165.200.226 255.255.255.224
auto-summary
!
!
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
router-id 10.9.1.1
no shutdown
redistribute connected
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
line vty 0 4
login
!
end

例:VMI インターフェイスの EIGRP 変更ベース ダンプニング

次の例では、メトリック変更の頻度を 45 秒間隔で 1 回の変更だけに制限するよう、EIGRP アドレス ファミリ イーサネット インターフェイス 0/0 を設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# dampening-interval 45

例:VMI インターフェイスの EIGRP インターバルベース ダンプニング

次の例では、メトリック変更の頻度を 45 秒間隔で 1 回の変更だけに制限するよう、EIGRP アドレス ファミリ イーサネット インターフェイス 0/0 を設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0

例:OSPFv3 での VMI PPPoE の設定

次に、ルーティング プロトコルとして OSPFv3 を使用し、VMI PPPoE を設定する例を示します。この設定には 3 つの VMI インターフェイスが含まれます。

logging buffered 3000000
no logging console
enable password lab
!
no aaa new-model
clock timezone EST -5
!
!
ip cef
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host2
pppoe service manet_radio
!
!
multilink bundle-name authenticated
no virtual-template subinterface
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe VMI1
virtual-template 1
service profile host2
!
bba-group pppoe VMI2
virtual-template 2
service profile host2
!
bba-group pppoe VMI3
virtual-template 3
service profile host2
!
!
interface Loopback1
ip address 209.165.200.225 255.255.255.224
no ip proxy-arp
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
load-interval 30
duplex full
speed 100
pppoe enable group VMI3
!
interface GigabitEthernet0/0
no ip address
load-interval 30
duplex full
speed 100
pppoe enable group VMI1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
load-interval 30
duplex full
speed 100
pppoe enable group VMI2
!
interface Serial1/0
no ip address
shutdown
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
no ip address
load-interval 30
ipv6 enable
no keepalive
service-policy output FQ
!
interface Virtual-Template2
no ip address
load-interval 30
ipv6 enable
no keepalive
service-policy output FQ
!
interface Virtual-Template3
no ip address
load-interval 30
ipv6 enable
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
ip address 209.165.200.225 255.255.255.224
load-interval 30
!
interface Vlan503
ip address 10.2.2.2 255.255.255.0
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 ospf 1 area 0
!
interface vmi1
no ip address
load-interval 30
ipv6 enable
ipv6 ospf network point-to-multipoint
ipv6 ospf cost dynamic hysteresis threshold 1000
ipv6 ospf cost dynamic weight throughput 0
ipv6 ospf cost dynamic weight resources 29
ipv6 ospf cost dynamic weight latency 29
ipv6 ospf cost dynamic weight L2-factor 29
ipv6 ospf 1 area 0
physical-interface GigabitEthernet0/0
!
interface vmi2
no ip address
load-interval 30
ipv6 enable
ipv6 ospf network point-to-multipoint
ipv6 ospf cost dynamic hysteresis threshold 1000
ipv6 ospf cost dynamic weight throughput 0
ipv6 ospf cost dynamic weight resources 29
ipv6 ospf cost dynamic weight latency 29
ipv6 ospf cost dynamic weight L2-factor 29
ipv6 ospf 1 area 0
physical-interface GigabitEthernet0/1
!
interface vmi3
no ip address
load-interval 30
ipv6 enable
ipv6 ospf network point-to-multipoint
ipv6 ospf cost dynamic hysteresis threshold 1000
ipv6 ospf cost dynamic weight throughput 0
ipv6 ospf cost dynamic weight resources 29
ipv6 ospf cost dynamic weight latency 29
ipv6 ospf cost dynamic weight L2-factor 29
ipv6 ospf 1 area 0
physical-interface FastEthernet0/0
!
!
!
no ip http server
no ip http secure-server
!
ipv6 router ospf 1
router-id 10.16.1.1
log-adjacency-changes
redistribute connected metric-type 1
timers spf 1 1
 
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
 

例:複数の仮想テンプレートを使用した VMI の設定

次に、複数の仮想テンプレートを使用して VMI を設定する例を示します。ここでは、それぞれ異なるサービス名を持つ 2 つの VMI を例示します。

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
clock timezone EST -5
ip cef
no ip domain lookup
!
!
subscriber authorization enable
!
subscriber profile router1_ground
pppoe service manet_radio_ground
!
subscriber profile router1_satellite
pppoe service manet_radio_satellite
!
ipv6 unicast-routing
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe router1_ground
virtual-template 1
service profile router1_ground
!
bba-group pppoe router1_satellite
virtual-template 2
service profile router1_satellite
!
!
interface Ethernet0/0
pppoe enable group router1_ground
!
interface Ethernet0/1
pppoe enable group router1_satellite
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Virtual-Template1
ip unnumbered vmi1
load-interval 30
no peer default ip address
no keepalive
service-policy output FQ
!
interface Virtual-Template2
ip unnumbered vmi1
load-interval 30
no peer default ip address
no keepalive
service-policy output FQ
!
interface vmi1
description ground connection
ip address 209.165.200.225 255.255.255.224
physical-interface Ethernet0/0
!
interface vmi2
description satellite connection
ip address 209.165.200.225 255.255.255.224
physical-interface Ethernet0/1
!
router eigrp 1
network 209.165.200.225 255.255.255.224
network 209.165.200.227 255.255.255.224
auto-summary
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

例:集約モードを使用した、仮想テンプレートと VMI の設定における IP アドレスの調整

デフォルト モードの VMI は集約モードで動作します。集約モードでは、PPPoE セッションによって作成されるすべての仮想アクセス インターフェイスは、VMI の下で論理的に集約されます。したがって、EIGRP や OSPFv3 などレイヤ 2 よりも上位層にあるアプリケーションは、VMI インターフェイスでのみ定義される必要があります。VMI へ送信されたパケットは、正しい仮想アクセス インターフェイスへ転送されます。

次に、仮想テンプレートの設定と VMI の設定との間で必要となる IP アドレスの調整例を示します。

ルーティング プロトコルとして IPv4 を使用し、集約モードの VMI を設定する例を以下に示します。

interface Virtual-Template1
ip unnumbered vmi1
service-policy output FQ
!
interface vmi1
ip address 2.2.2.1 255.255.255.0
physical-interface FastEthernet0/0
!
 

ルーティング プロトコルとして IPv4 および IPv6 を使用し、集約モードの VMI を設定する例を以下に示します。

interface Virtual-Template1
ip unnumbered vmi1
ipv6 enable
service-policy output FQ
!
interface vmi1
ip address 2.2.2.1 255.255.255.0
ipv6 enable
physical-interface FastEthernet0/0
!
 

ルーティング プロトコルとして IPv6 を使用し、集約モードの VMI を設定する例を以下に示します。

interface Virtual-Template1
ipv6 enable
service-policy output FQ
!
interface vmi1
ipv6 enable
physical-interface FastEthernet0/0
!

例:バイパスまたは集約モードを使用した VMI インターフェイスでのマルチキャスト サポートのイネーブル化


) VMI インターフェイスで設定した IPv4 アドレスは、アドバタイズまたは使用されません。代わりに、仮想テンプレートの IPv4 アドレスが使用されます。


例:マルチキャスト トラフィック用 VMI インターフェイスのパイパス モード

次に、VMI インターフェイスでマルチキャストをイネーブルにする例を示します。この例には、VMI のバイパス モードへの変更と、仮想テンプレート インターフェイスでの PIM スパース モードのイネーブル化が含まれます。

Router# enable
Router# configure terminal
!
Router(config)# interface Virtual-Template1
Router(config-if)# ip address 209.165.200.227 255.255.255.224
Router(config-if)# load-interval 30
Router(config-if)# no keepalive
Router(config-if)# ip pim sparse-dense-mode
Router(config-if)# service-policy output FQ
!
!
Router(config)# interface vmi1
Router(config-if)# ip address 10.3.9.1 255.255.255.0
Router(config-if)# load-interval 30
Router(config-if)# physical-interface FastEthernet0/0
Router(config-if)# mode bypass
!
Router(config)# end
 

例:バイパス モードを使用した IPv6 マルチキャスト トラフィック用 OSPFv3

次に、バイパス モードを使用して、IPv6 マルチキャスト トラフィック用の OSPFv3 を設定する例を示します。この OSPF 例の ipv6 ospf network point-to-multipoint コマンドは、OSPFv3 がリンクから動的メトリックを学習するために必要です。

version 12.4
!
hostname host1
!
enable
configure terminal
!
no aaa new-model
clock timezone EST -5
!
!
!
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
no virtual-template subinterface
!
!
archive
log config
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
interface Loopback1
no ip address
load-interval 30
ipv6 address 2001:0DB1::1/64
ipv6 enable
 
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
ipv6 enable
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
no ip address
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
!
ipv6 ospf network point-to-multipoint
ipv6 ospf cost dynamic
ipv6 ospf 1 area 0
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
no ip address
no ip mroute-cache
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 ospf 1 area 0
!
interface Vlan503
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 ospf 1 area 0
!
interface vmi1
no ip address
load-interval 30
ipv6 enable
physical-interface FastEthernet0/0
mode bypass
!
!
no ip http server
no ip http secure-server
!ipv6 router ospf 1
log-adjacency-changes
redistribute connected metric-type 1
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
stopbits 1
line aux 0
line vty 0 4
login
!
end
 

例:バイパス モードを使用した IPv4 用 EIGRP

次に、バイパス モードを使用して、IPv4 の EIGRP を設定する例を示します。この例では、VMI1 インターフェイスの IP アドレスを指定する必要がありますが、VMI インターフェイスはダウン/ダウンとして設定されるので、このアドレスへのルーティングはできません。

 
hostname host1
!
no aaa new-model
clock timezone EST -5
ip cef
!
no ip domain lookup
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
!
multilink bundle-name authenticated
no virtual-template subinterface
!
archive
log config
!
policy-map FQ
class class-default
fair-queue
!
!
!bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 209.165.200.225 255.255.255.224
load-interval 30
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
ip address 209.165.200.225 255.255.255.224
load-interval 30
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
ip address 209.165.200.225 255.255.255.224
no ip mroute-cache
load-interval 30
!
interface Vlan503
ip address 209.165.200.225 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
!
interface vmi1
ip address 209.165.200.226 255.255.255.224
load-interval 30
physical-interface FastEthernet0/0
mode bypass
!
router eigrp 1
redistribute connected
network 209.165.200.225 255.255.255.224
network 209.165.200.226 255.255.255.224

例:バイパス モードを使用した IPv6 用 EIGRP

次に、バイパス モードを使用して、IPv6 の EIGRP を設定する例を示します。

version 12.4
enable
configure terminal
 
ip cef
!
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
no virtual-template subinterface
!
!
!
archive
log config
!
!
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
 
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
no ip address
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
no ip address
no ip mroute-cache
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface Vlan503
no ip address
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface vmi1
no ip address
load-interval 30
ipv6 enable
physical-interface FastEthernet0/0
mode bypass
!
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
no shutdown
redistribute connected
!
!
!

例:バイパス モードを使用した IPv4 および IPv6 トラフィック用 EIGRP

次に、バイパス モードを使用して、IPv4 および IPv6 に EIGRP を設定する例を示します。

version 12.4T
!
hostname host1
!
enable
configure terminal
 
ip cef
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
subscriber authorization enable
!
subscriber profile host1
pppoe service manet_radio
!
multilink bundle-name authenticated
no virtual-template subinterface
!
archive
log config
!
!
policy-map FQ
class class-default
fair-queue
!
bba-group pppoe VMI1
virtual-template 1
service profile host1
!
!
interface Loopback1
ip address 209.165.200.225 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
load-interval 30
speed 100
full-duplex
pppoe enable group VMI1
!
interface Serial1/0
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/1
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/2
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface Serial1/3
no ip address
no ip mroute-cache
shutdown
clock rate 2000000
!
interface FastEthernet2/0
switchport access vlan 2
duplex full
speed 100
!
interface FastEthernet2/1
switchport access vlan 503
load-interval 30
duplex full
speed 100
!
interface FastEthernet2/2
shutdown
!
interface FastEthernet2/3
shutdown
!
interface Virtual-Template1
ip address 209.165.200.225 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
no keepalive
service-policy output FQ
!
interface Vlan1
no ip address
no ip mroute-cache
shutdown
!
interface Vlan2
ip address 209.165.200.226 255.255.255.224
no ip mroute-cache
load-interval 30
!
interface Vlan503
ip address 209.165.200.226 255.255.255.224
load-interval 30
ipv6 address 2001:0DB8::/32
ipv6 enable
ipv6 eigrp 1
!
interface vmi1
ip address 209.165.200.226 255.255.255.224
load-interval 30
ipv6 enable
physical-interface FastEthernet0/0
mode bypass
!
router eigrp 1
redistribute connected
network 209.165.200.226 255.255.255.224
network 209.165.200.227 255.255.255.224
auto-summary
!
!
no ip http server
no ip http secure-server
!
ipv6 router eigrp 1
eigrp router-id 10.9.1.1
no shutdown
redistribute connected
!
!
!
end

例:集約モードを使用した、NBMA ネットワークとしてのマルチキャスト トラフィックの OSPFv3

この例で、マルチキャストは NBMA ネットワークとして設定されます。マルチキャストを設定するには、 ip multicast-routing グローバル コンフィギュレーション コマンドが必要です。マルチキャストに VMI 集約モードを設定するには、 ip pim nbma-mode コマンドを使用して VMI を設定する必要があります。次に、OSPF ネットワークの VMI の例を示します。

Building configuration...
 
 
Current configuration : 6121 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname mcrtr4
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
!
no aaa new-model
!
ip source-route
!
!
ip cef
!
!
ip domain name yourdomain.com
ip multicast-routing
ip multicast cache-headers
no ipv6 cef
subscriber authorization enable
!
subscriber profile chan
pppoe service manet_radio
!
!
multilink bundle-name authenticated
!username lab privilege 15 secret 5 $1$v1bl$B5KD7o3jVKYqfoKoS0FUJ1
!
!
!
archive
log config
hidekeys
!
!
!
!
!
bba-group pppoe chan
virtual-template 1
service profile chan
!
!
interface Loopback0
ip address 15.15.15.15 255.255.255.255
ip broadcast-address 0.0.0.0
!
 
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
ip address 1.1.1.2 255.255.255.0
ip broadcast-address 0.0.0.0
ip pim sparse-mode
ip igmp version 3
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
ip broadcast-address 0.0.0.0
duplex auto
speed auto
pppoe enable group chan
!
interface FastEthernet0/0/0
!
interface FastEthernet0/0/1
!
interface FastEthernet0/0/2
!
interface FastEthernet0/0/3
interface FastEthernet0/1/0
no ip address
ip broadcast-address 0.0.0.0
duplex auto
speed auto
!
interface Virtual-Template1
ip unnumbered vmi1
no peer default ip address
fair-queue
!
interface Vlan1
ip address 10.15.60.53 255.255.255.0
!
interface vmi1
ip address 2.2.2.2 255.255.255.0
ip pim nbma-mode
ip pim sparse-mode
ip ospf network point-to-multipoint
load-interval 30
physical-interface FastEthernet0/1
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
redistribute static
network 1.1.1.0 0.0.0.255 area 0
network 2.2.2.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip pim rp-address 16.16.16.16
ip pim register-source vmi1
!
access-list 23 permit 10.10.10.0 0.0.0.7
access-list 110 permit ip any any
!
!
!
!
control-plane
!
!
!
!
mgcp fax t38 ecm
!
!
line con 0
exec-timeout 0 0
login local
line aux 0
line vty 0 4
access-class 23 inprivilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
end

例:PPPoE の設定

次の例に示すサブスクライバ プロセスは、事前定義された manet_radio 文字列を使用して、インバウンド PPPoE セッションが、VMI をサポートするデバイスから送信されているかどうかを判断します。すべての IP の定義は、VMI インターフェイス上で設定されます。ファスト イーサネットまたは仮想テンプレート インターフェイスでは設定されません。これらのインターフェイスが設定されている場合は、IP アドレスおよび IPv6 アドレスを指定しないでください。

IP アドレスが指定されない場合、VMI インターフェイスではデフォルトにより IPv6 がイネーブルになります。

subscriber profile list1
pppoe service manet_radio
subscriber authorization enable
 
!
bba-group pppoe bba1
virtual-template 1
service profile list1
!
interface FastEthernet0/1
no ip address
pppoe enable group bba1
!
interface Virtual-Template 1
no ip address
no peer default ip-address
!
interface vmi 1
no ip address
physical-interface FastEthernet0/1

例:2 つの VMI、2 つの仮想テンプレート、2 つのサービス名の設定

次に、2 つの VMI、2 つの仮想テンプレート、2 つのサービス名が含まれる設定例を示します。お使いの VMI PPPoE 接続には、複数の仮想テンプレート インターフェイスを設定できます。使用する仮想テンプレートは、PPPoE セッションの確立時に無線から送信されるサービス名に基づいて選択されます。

この例では、「manet_radio_ground」というサービス名の PPPoE セッション要求(PPPoE Active Discovery Initiate(PADI)パケットの送出)で、Virtual-Template1 が複製対象のインターフェイスとして使用されます。反対に、「manet_radio_satellite」というサービス名で無線から送出される PADI では、Virtual-Template2 が使用されます。

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
clock timezone EST -5
ip cef
no ip domain lookup
!
!
subscriber authorization enable
!
subscriber profile router1_ground
pppoe service manet_radio_ground
!
subscriber profile router1_satellite
pppoe service manet_radio_satellite
!
ipv6 unicast-routing
policy-map FQ
class class-default
fair-queue
!
!
!
bba-group pppoe router1_ground
virtual-template 1
service profile router1_ground
!
bba-group pppoe router1_satellite
virtual-template 2
service profile router1_satellite
!
!
interface Ethernet0/0
pppoe enable group router1_ground
!
interface Ethernet0/1
pppoe enable group router1_satellite
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Ethernet1/0
no ip address
shutdown
!
interface Ethernet1/1
no ip address
shutdown
!
interface Ethernet1/2
no ip address
shutdown
!
interface Ethernet1/3
no ip address
shutdown
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial3/3
no ip address
shutdown
serial restart-delay 0
!
interface Virtual-Template1
ip unnumbered vmi1
load-interval 30
no peer default ip address
no keepalive
service-policy output FQ
!
interface Virtual-Template2
ip unnumbered vmi2
load-interval 30
no peer default ip address
no keepalive
service-policy output FQ
!
interface vmi1
description ground connection
ip address 209.165.200.226 255.255.255.224
physical-interface Ethernet0/0
!
interface vmi2
description satellite connection
ip address 209.165.200.227 255.255.255.224
physical-interface Ethernet0/1
!
router eigrp 1
network 209.165.200.226 255.255.255.224
network 209.165.200.227 255.255.255.224
auto-summary
!
!
no ip http server
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
end

例:VMI でのパケットのマーキングおよびキューイング

この設定例には、VMI とともに使用される QoS 機能が含まれます。VMI では、インターフェイスで定義されたポリシー マップに従って、パケットがアウトバウンドまたはインバウンドとしてマークされます。この設定は、2 つの異なるインターフェイスに 2 つの異なるポリシーを適用する必要があるため、標準の QoS 設定とは若干異なります。

キューイング メカニズムを定義するために、仮想テンプレートに均等化キューイング ポリシーを適用します。パケットをマークするために、もう一つ別のポリシーを作成して VMI に適用し、トラフィックをマークします。これらの 2 つのポリシー マップは同時に機能し、無線インターフェイスで QoS をサポートします。


) 標準の均等化キューイング クラスを使用する場合、または、仮想テンプレートに適用された階層型ポリシー マップを使用する場合、パケットはマークされません。


 

次に、VMI でのマーキングとキューイングをサポートするデバイス設定の例を示します。

ルータ 1 に設定された VMI およびポリシー マップの出力設定

次に、ルータ 1 に設定された VMI およびポリシー マップの出力設定例を示します。

 
!
!
!
class-map match-all udp-traffic
match access-group 100
!
!
policy-map FQ
class class-default
fair-queue
policy-map my-marker
class udp-traffic
set dscp af41
!
!
interface Virtual-Template1
.
.
.
service-policy output FQ
!
!
interface vmi1
.
.
.
service-policy output my-marker
.
.
.
!
access-list 100 permit udp any any
!

ルータ 2 に設定された VMI およびポリシー マップの入力設定

次に、ルータ 2 に設定された VMI およびポリシー マップの入力設定例を示します。

!
!
!
class-map match-all udp-traffic
match access-group 100
!
!
policy-map FQ
class class-default
fair-queue
policy-map my-marker
class udp-traffic
set dscp ef
!
interface Virtual-Template1
.
.
.
service-policy output FQ
!
interface vmi1
.
.
.
service-policy input my-marker
!
access-list 100 permit udp any any
!
 

次の表示は、ルータ 1 に設定された VMI およびポリシー マップに対する show policy-map interface コマンドから出力されます。

 
Router1# show policy-map interface vmi1
 
vmi1
 
Service-policy output: my-marker
 
Class-map: udp-traffic (match-all)
5937331 packets, 6234197550 bytes
30 second offered rate 840000 bps, drop rate 0 bps
Match: access-group 100
QoS Set
dscp af41
Packets marked 5937331
 
Class-map: class-default (match-any)
12829 packets, 769740 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any
!
 

次の表示は、ルータ 2 に設定された VMI およびポリシー マップに対する show policy-map interface コマンドから出力されます。

Router2# show policy-map interface vmi1
 
vmi1
 
Service-policy input: my-marker
 
Class-map: udp-traffic (match-all)
5971417 packets, 6150560540 bytes
30 second offered rate 824000 bps, drop rate 0 bps
Match: access-group 100
QoS Set
dscp ef
Packets marked 5971418
 
Class-map: class-default (match-any)
26167 packets, 1623087 bytes
30 second offered rate 0 bps, drop rate 0 bps
Match: any

参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

Cisco IOS Master Commands List, All Releases』

EIGRP

『Cisco IOS IP Routing Protocols Configuration Guide

『Cisco IOS IP Routing Protocols Command Reference

『Implementing IPv6 addressing and basic connectivity』

『Cisco IOS IPv6 Configuration Guide

IPv6

『Cisco IOS IPv6 Configuration Guide

『Cisco IOS IPv6 Command Reference

OSPF

『Cisco IOS IP Routing Protocols Configuration Guide

『Cisco IOS IP Routing Protocols Command Reference

PPPoE

『Cisco IOS Dial Solutions Configuration Guide

『Cisco IOS Dial Solutions Command Reference

PPPoE 設定およびコマンド

『Cisco IOS Broadband and DSL Configuration Guide

『Cisco IOS Broadband and DSL Command Reference

規格

規格
タイトル

サポートされる新しい規格または変更された規格はありません。

また、変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2373

『IP Version 6 Addressing Architecture』

RFC 2516

『A Method for Transmitting PPP Over Ethernet (PPPoE)』

RFC 4938 bis

『PPP Over Ethernet (PPPoE) Extensions for Credit Flow and Link Metrics』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

Router-to-Radio 通信用 Mobile Ad Hoc Network の機能情報

表 8 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするソフトウェア イメージを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 8には、特定のソフトウェア リリース群で特定の機能をサポートするソフトウェア リリースだけが記載されています。特に明記されていない限り、そのソフトウェア リリース群の後続のリリースでもこの機能がサポートされます。


 

表 8 Router-to-Radio 通信用 Mobile Ad Hoc Network の機能情報

機能名
リリース
機能情報

Mobile Ad Hoc Network の EIGRP L2/L3 API および調整可能なメトリック

12.4(15)XF
12.4(15)T
15.0(1)M

EIGRP は動的 raw 無線リンク特性(現在の帯域幅、最大帯域幅、遅延、リソース)を使用して、コンポジット EIGRP コスト メトリックを計算します。調整可能なヒステリシス メカニズムは、リンク特性の変化によって発生するネットワークのチャーンを回避するのに役立ちます。

L2/L3 API はリンク特性に加えて、新しい隣接が検出されたり、到達不能な既存の隣接が再度到達可能になったりすると、通知を送信します。EIGRP は隣接信号を受け取ると、指定されたインターフェイスからただちに hello パケットを送信し、EIGRP ピアを迅速に検出します。

次のセクションで、この機能に関する情報を参照できます。

「VMI インターフェイスによる OSPFv3 および EIGRP のリンク品質メトリック レポート」

「例:IPv6 用 EIGRP を使用した基本的な VMI PPPoE の設定」

「例:IPv4 および IPv6 用 EIGRP を使用した VMI PPPoE の設定」

dampening-change dampening-interval debug eigrp notifications debug vmi の各コマンドが追加または変更されています。

Virtual Multipoint Interface 用マルチキャスト

15.1(3)T

Virtual Multipoint Interface 用マルチキャスト機能により、RFC 4938 bis に基づく Radio-Aware ルーティング向けのマルチキャストをサポートできます。

次のセクションで、この機能に関する情報を参照できます。

「NBMA モードのマルチキャスト ルーティング」

「VMI インターフェイスのマルチキャスト サポート」

「マルチキャスト アプリケーション用 VMI インターフェイスでのバイパス モードのイネーブル化」

「例:バイパスまたは集約モードを使用した VMI インターフェイスでのマルチキャスト サポートのイネーブル化」

この機能によって追加または変更されたコマンドはありません。

OSPFv3 動的インターフェイス コスト サポート

12.4(15)XF
12.4(15)T 15.0(1)M

OSPFv3 動的インターフェイス コスト サポートは、モバイル アドホック ネットワーキングをサポートする OSPFv3 コスト メトリックの拡張を提供します。

次の項で、この機能に関する情報を参照できます。

「VMI インターフェイスの OSPF コスト計算」

debug ipv6 ospf l2api ipv6 ospf cost test ospfv3 interface の各コマンドが追加または変更されています。

Router-to-Radio リンクでのクレジット フローおよびメトリック向け PPPoE サポート機能

12.4(15)XF
12.4(15)T
15.0(1)M

クレジットベースのフロー制御では、各方向でインバンドおよびアウトオブバンド クレジットが認可されます。リンク品質メトリックは、リンク パフォーマンスに関する統計情報のレポートに使用されます。この情報は、その後のルーティングに利用されます。

次のセクションで、この機能に関する情報を参照できます。

「移動無線通信用 PPPoE インターフェイス」

「PPPoE のクレジットベースおよびメトリックベース スケーリングおよびフロー制御」

「VMI PPPoE の設定例」

show pppoe session および show vmi neighbors コマンドが追加または変更されています。

Radio-Aware ルーティング(RFC)4938 bis

15.1(3)T

Radio Aware ルーティングでは、Cisco ルータを PPPoE 経由で高性能無線にインターフェイスするための RFC 4938 bis の更新が採用されています。

次のセクションで、この機能に関する情報を参照できます。

「Radio-Aware ルーティング RFC 4938」

show vmi neighbors コマンドが追加または変更されています。