IPv6 コンフィギュレーション ガイド Cisco IOS Release M&T
IPv6 over MPLS の実装
IPv6 over MPLS の実装
発行日;2012/05/10 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

IPv6 over MPLS の実装

機能情報の確認

目次

IPv6 over MPLS の実装の前提条件

IPv6 over MPLS の実装に関する情報

IPv6 over MPLS バックボーンの展開の利点

回線トランスポートを介した IPv6 over MPLS

カスタマー エッジ ルータでトンネルを使用する IPv6

IPv6 プロバイダー エッジ ルータ(6PE)

6PE マルチパス

IPv6 over MPLS の実装方法

回線トランスポートを介した IPv6 over MPLS の展開

IPv6 プロバイダー エッジ ルータ(6PE)の展開

6PE ルータでの送信元アドレス インターフェイスの指定

前提条件

制約事項

プレフィクスをアドバタイズするための 6PE ラベルのバインドおよびアドバタイズ

iBGP マルチパス ロード シェアリングの設定

6PE の設定および動作の確認

出力例

IPv6 over MPLS の設定例

例:カスタマー エッジ ルータ

例:プロバイダー エッジ ルータ

例:コア ルータ

関連情報

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IPv6 over MPLS の実装の機能情報

IPv6 over MPLS の実装

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)は、多くのサービス プロバイダーによって、その IPv4 ネットワークに展開されています。サービス プロバイダーは、IPv6 サービスをカスタマーに提供しようと考えていますが、既存の IPv4 インフラストラクチャを変更するのは非常にコストがかかり、IPv6 トラフィックが少量であることを考えると、費用対効果は妥当なものとはなりません。既存の IPv4 MPLS インフラストラクチャを活用し、ネットワーク バックボーンに変更を加えることなく IPv6 サービスを追加するために、複数の統合シナリオが開発されています。このマニュアルでは、IPv6 over MPLS を実装する方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「IPv6 over MPLS の実装の機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

IPv6 over MPLS の実装の前提条件

この章では、IPv4 に精通していることを前提としています。IPv4 の設定およびコマンド リファレンス情報については、「関連資料」の関連資料を参照してください。

MPLS を介した IPv6 プロバイダー エッジ ルータ(6PE)機能を実装する前に、MPLS がコア IPv4 ネットワーク上で実行されている必要があります。Cisco ルータが使用されている場合は、シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングが、IPv4 プロトコルと IPv6 プロトコルの両方でイネーブルになっている必要があります。この章では、MPLS に精通していることを前提としています。

IPv6 over MPLS の実装に関する情報

「IPv6 over MPLS バックボーンの展開の利点」

「回線トランスポートを介した IPv6 over MPLS」

「カスタマー エッジ ルータでトンネルを使用する IPv6」

「IPv6 プロバイダー エッジ ルータ(6PE)」

IPv6 over MPLS バックボーンの展開の利点

IPv6 over MPLS バックボーンを使用すると、孤立した複数の IPv6 ドメインが、MPLS IPv4 コア ネットワークを介して互いに通信できます。この実装では、転送が IP ヘッダー自体ではなくラベルに基づいて行われるため、バックボーン インフラストラクチャのアップグレードは少量で済み、コア ルータの再設定は必要ないため、非常にコスト効率の高い IPv6 の展開計画が提供されます。

また、MPLS 環境で本来提供されている Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスおよび MPLS Traffic Engineering(MPLS TE; MPLS トラフィック エンジニアリング)サービスを使用して、IPv4 VPN および MPLS-TE をサポートするインフラストラクチャを介して IPv6 ネットワークを IPv4 VPN やエクストラネットに組み込むことができます。

回線トランスポートを介した IPv6 over MPLS

いずれの回線トランスポートを IPv6 over MPLS ネットワークの展開に使用しても、MPLS の動作またはインフラストラクチャに影響はなく、コア ルータまたはプロバイダー エッジ ルータの設定を変更する必要もありません。リモート IPv6 ドメイン間の通信では、専用リンクを介してネイティブ IPv6 プロトコルを実行します。この場合、基礎となるメカニズムは IPv6 に対して完全に透過的です。IPv6 トラフィックは、ATM OC-3 またはイーサネット インターフェイスを介してそれぞれ接続されているルータで Any Transport over MPLS(MPLS/AToM)または Ethernet over MPLS(EoMPLS)機能を使用してトンネル化されます。

図 1 に、任意の回線トランスポートを介した IPv6 over MPLS の設定を示します。

図 1 回線トランスポートを介した IPv6 over MPLS

カスタマー エッジ ルータでトンネルを使用する IPv6

Customer Edge(CE; カスタマー エッジ)ルータでのトンネルの使用が、IPv6 over MPLS ネットワークを最も簡単に展開できる方法です。この方法では、MPLS の動作およびインフラストラクチャには影響を与えず、コア ルータやプロバイダー エッジ ルータの設定を変更する必要もありません。リモート IPv6 ドメイン間の通信では、標準のトンネリング メカニズムが使用され、デュアル IPv4 および IPv6 プロトコル スタックを実行するように CE ルータを設定する必要があります。図 2 に、CE ルータでトンネルを使用する設定を示します。

図 2 CE ルータでトンネルを使用する IPv6

手動で設定されたトンネル、自動トンネル、および 6to4 トンネルに関する設定情報については、「 Implementing Tunneling for IPv6 」を参照してください。

トンネルを使用する場合、CE ルータでトンネルのメッシュを手動で設定するという制限があるため、大規模ネットワークではスケーリング上の問題となります。

IPv6 プロバイダー エッジ ルータ(6PE)

MPLS を介した IPv6 プロバイダー エッジ ルータのシスコ実装は 6PE と呼ばれ、これにより、IPv6 サイトは、MPLS Label Switched Path(LSP; ラベル スイッチド パス)を使用して MPLS IPv4 コア ネットワークを介して互いに通信できます。この機能は、Provider Edge(PE; プロバイダー エッジ)ルータ上の IPv4 ネットワーク設定のマルチプロトコル Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)拡張に依存して、IPv6 到達可能性情報、およびアドバタイズされる各 IPv6 アドレス プレフィクスに関する MPLS ラベルを交換します。エッジ ルータは、IPv4 と IPv6 の両方を実行するデュアル スタックとして設定され、IPv4 マッピング IPv6 アドレスを使用して IPv6 プレフィクスの到達可能性情報を交換します。

IPv6 トラフィックの透過性をすべてのコア ルータに対して維持するために、ラベルの階層が 6PE 出力ルータでインポーズされています。最上位ラベルは、IPv4 MPLS コア ネットワーク内での接続を提供し、Label Distribution Protocol(LDP; ラベル配布プロトコル)、Tag Distribution Protocol(TDP; タグ配布プロトコル)、または Resource Reservation Protocol(RSVP; リソース予約プロトコル)によってラベルが配布されます。TDP と LDP の両方をラベル配布に使用できますが、RSVP は、MPLS-TE ラベル交換のコンテキストでだけ使用されます。宛先の IPv6 プレフィクスに自動的に割り当てられる一番下のラベルは、マルチプロトコル BGP によって配布され、各 6PE 出力ルータで IPv6 転送のために使用されます。

図 3 では、6PE ルータが IPv4 と IPv6 の両方のトラフィックをルーティングできるデュアル スタック ルータとして設定されています。各 6PE ルータは、LDP、TDP、または RSVP(トラフィック エンジニアリングが設定されている場合)を実行して IPv4 ラベルをバインドするように設定されています。6PE ルータでは、マルチプロトコル BGP を使用して、MPLS ドメイン内の他の 6PE デバイスとの間で到着可能性情報を交換し、IPv6 集約ラベルを配布します。MPLS ドメイン内のすべての 6PE ルータおよびコア ルータ(図 3 の P ルータ)は、Open Shortest Path First(OSPF)または Integrated Intermediate System-to-Intermediate System(IS-IS)などの一般的な IPv4 Interior Gateway Protocol(IGP)を共有します。

図 3 6PE ルータ トポロジ

CE ルータに接続している 6PE ルータ上のインターフェイスは、カスタマーの要件に基づいて IPv6 トラフィック、IPv4 トラフィック、または両方のタイプのトラフィックを転送するように設定できます。6PE ルータは、MPLS クラウドを介して 6PE ピアから学習した IPv6 到達可能性情報をアドバタイズします。サービス プロバイダーは、6PE インフラストラクチャを介して、登録済み IPv6 プレフィクスから IPv6 プレフィクスを委任できます。それ以外の場合は、CE ルータに対する影響はありません。

ネットワークのコア内にある P ルータは、P ルータ自身が IPv6 パケットをスイッチングしていることを認識しません。コア ルータは、MPLS クラウド内の内部到達可能性情報を確立するために MPLS および PE ルータと同じ IPv4 IGP をサポートするように設定されています。コア ルータでは、IPv4 ラベルをバインドするために、LDP、TDP、または RSVP も使用されています。Cisco 6PE 機能の実装による MPLS コア デバイスへの影響はありません。

MPLS ネットワークでは、IPv6 トラフィックがラベル スイッチングを使用して転送され、IPv6 トラフィックを MPLS ネットワークのコアに対して透過的にします。IPv6 over IPv4 トンネルまたはレイヤ 2 カプセル化の手法は必要ありません。

6PE マルチパス

IPv6 の内部および外部 Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)マルチパスによって、IPv6 ルータは、複数のパス(同じネイバー Autonomous System(AS; 自律システム)やサブ AS、または同じメトリックなど)間のロード バランシングを行って、宛先に到達できます。6PE マルチパス機能では、Multiprotocol internal BGP(MP-iBGP; マルチプロトコル内部 BGP)を使用して、MPLS IPv4 コア ネットワークを介して IPv6 ルートを配布し、MPLS ラベルを各ルートに付加します。

MP-iBGP マルチパスが 6PE ルータでイネーブルになっていると、MPLS 情報が使用できる場合は、MPLS 情報(ラベル スタック)を使用して、ラベルの付いたすべてのパスが、転送テーブルにインストールされます。この機能によって、6PE はロード バランシングを実行できます。

IPv6 over MPLS の実装方法

「回線トランスポートを介した IPv6 over MPLS の展開」

「IPv6 プロバイダー エッジ ルータ(6PE)の展開」

「iBGP マルチパス ロード シェアリングの設定」

「6PE の設定および動作の確認」

回線トランスポートを介した IPv6 over MPLS の展開

回線トランスポートを介した IPv6 over MPLS を展開するには、IPv6 ルータが IPv6 接続用に設定されている必要があります。基本的な IPv6 設定の詳細については、「 Implementing IPv6 Addressing and Basic Connectivity 」を参照してください。MPLS ルータの設定では、AToM 設定または EoMPLS 設定が必要です。

6PE ルータでの送信元アドレス インターフェイスの指定

図 4 に示すネットワークを使用する 2 つの設定作業は、6PE 機能をイネーブルにするために、6PE1 ルータでは必須です。

カスタマー エッジ ルータ(図 4 の CE1)は、その IPv6 トラフィックを 6PE1 ルータに転送するように設定されています。ネットワークのコア内の P1 ルータは、MPLS、ラベル配布プロトコル、IPv4 IGP、およびシスコ エクスプレス フォワーディングか分散型シスコ エクスプレス フォワーディングを実行していると想定されるため、6PE 機能をイネーブルにするための新しい設定は必要ありません。

図 4 6PE の設定例

 

前提条件

6PE ルータ(図 4 の 6PE1 ルータと 6PE2 ルータ)は、コア IPv4 ネットワークのメンバである必要があります。コア ネットワークに接続されている 6PE ルータ インターフェイスは、MPLS、およびコア ネットワークと同じラベル配布プロトコルおよび IPv4 IGP を実行している必要があります。

6PE ルータは、IPv4 と IPv6 の両方を実行するデュアル スタックとして設定されている必要もあります。

制約事項


) Cisco IOS Release 12.2(22)S 時点では、次の制約事項は Cisco IOS 12.2S リリースには適用されません。


次の制約事項は、IPv6 プロバイダー エッジ ルータ over MPLS(6PE)機能を実装している場合に適用されます。

コア MPLS ルータは、MPLS と IPv4 だけをサポートしているため、IPv6 Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)メッセージの転送または作成を行うことはできません。

Cisco 6PE では、MPLS パスと IPv6 パス間のロード バランシング機能が提供されません。両方が使用可能な場合は、MPLS パスが常に優先されます。2 つの MPLS パス間のロード バランシングは実行できます。

BGP マルチパスは、Cisco 6PE ルータではサポートされていません。2 つの BGP ピアが等価コストで同じプレフィクスをアドバタイズする場合、Cisco 6PE では、最後のルートを使用して MPLS コアを通過します。

6PE 機能は、RSVP-TE トンネル以外のトンネルではサポートされていません。

手順の概要

1. enable

2. configure terminal

3. ipv6 unicast-routing

4. ipv6 cef

5. interface type number

6. ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 unicast-routing

 

Router(config)# ipv6 unicast-routing

IPv6 ユニキャスト データグラムの転送をイネーブルにします。

ステップ 4

ipv6 cef

 

Router(config)# ipv6 cef

IPv6 シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 5

interface type number

 

Router(config)# interface Serial 0/0

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

この機能のコンテキストでは、設定されるインターフェイスは、CE ルータと通信するインターフェイスとなります。

ステップ 6

ipv6 address { ipv6-address / prefix-length | prefix-name sub-bits / prefix-length }

 

Router(config-if)# ipv6 address 2001:DB8:FFFF::2/64

IPv6 の一般的なプレフィクスに基づいて IPv6 アドレスを設定し、インターフェイスにおける IPv6 処理をイネーブルにします。

プレフィクスをアドバタイズするための 6PE ラベルのバインドおよびアドバタイズ

指定した BGP ネイバーに IPv6 プレフィクスをアドバタイズするときに、集約ラベルのバインドとアドバタイズをイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | ipv6-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

7. address-family ipv6 [ unicast ]

8. neighbor { ip-address | peer-group-name | ipv6-address } activate

9. neighbor { ip-address | ipv6-address } send-label

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

前の手順で指定した BGP ルーティング プロセスの IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

コマンドを設定している場合は除きます。

ステップ 5

neighbor { ip-address | ipv6-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 192.168.99.70 remote-as 65000

指定した自律システムのネイバーの IP アドレスをローカル ルータの BGP ネイバーテーブルに追加します。

ステップ 6

neighbor { ip-address | ipv6-address | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor 192.168.99.70 update-source Loopback 0

IPv4 アドレスがピアリングの送信元アドレスとして使用されるインターフェイスを指定します。

この作業のコンテキストでは、このインターフェイスは、32 ビットのマスクが設定された IPv4 アドレスを持っている必要があります。ループバック インターフェイスを使用することを推奨します。このアドレスを使用して、IPv6 ネクストホップがピア 6PE によって決定されます。

ステップ 7

address-family ipv6 [ unicast ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

ステップ 8

neighbor { ip-address | peer-group-name | ipv6-address } activate

 

Router(config-router-af)# neighbor 192.168.99.70 activate

ローカル ルータとの間で IPv6 アドレス ファミリを交換できるようにネイバーを設定します。

ステップ 9

neighbor { ip-address | ipv6-address } send-label

 

Router(config-router-af)# neighbor 192.168.99.70 send-label

BGP ルートとともに MPLS ラベルを送信するルータの機能をアドバタイズします。

IPv6 アドレス ファミリ コンフィギュレーション モードでは、このコマンドによって、BGP での IPv6 プレフィクスのアドバタイズ時に集約ラベルをバインドおよびアドバタイズできるようになります。

iBGP マルチパス ロード シェアリングの設定

iBGP マルチパス ロード シェアリングを設定し、ルーティング テーブルにインストールできる並列 iBGP ルートの最大数を制御するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. maximum-paths ibgp number-of-paths

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

maximum-paths ibgp number-of-paths

 

Router(config-router)# maximum-paths ibgp 3

ルーティング テーブルにインストールできる並列 iBGP ルートの最大数を制御します。

6PE の設定および動作の確認

6PE の実行中は、次のコンポーネントをモニタできます。

マルチプロトコル BGP

MPLS

Cisco Express Forwarding for IPv6

IPv6 ルーティング テーブル

手順の概要

1. show bgp ipv6 { unicast | multicast } [ ipv6-prefix / prefix-length ] [ longer-prefixes ] [ labels ]

2. show bgp ipv6 { unicast | multicast } neighbors [ ipv6-address ] [ received-routes | routes | flap-statistics | advertised-routes | paths regular-expression | dampened-routes ]

3. show mpls forwarding-table [ network { mask | length } | labels label [ - label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

4. show ipv6 cef [ ipv6-prefix / prefix-length ] | [ interface-type interface-number ] [ longer-prefixes | similar-prefixes | detail | internal | platform | epoch | source ]]

5. show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

show bgp ipv6 { unicast | multicast } [ ipv6-prefix / prefix-length ] [ longer-prefixes ] [ labels ]

 

Router> show bgp ipv6 unicast 2001:DB8:DDDD::/48

(任意)IPv6 BGP ルーティング テーブルのエントリを表示します。

この例では、プレフィクス 2001:DB8:DDDD::/48 の IPv6 ルートに関する情報が表示されます。

ステップ 2

show bgp ipv6 { unicast | multicast } neighbors [ ipv6-address ] [ received-routes | routes | flap-statistics | advertised-routes | paths regular-expression | dampened-routes ]

 

Router> show bgp ipv6 neighbors unicast 192.168.99.70

(任意)ネイバーへの IPv6 BGP 接続に関する情報が表示されます。

この例では、IPv6 ラベル機能などの情報が、192.168.99.70 の BGP ピアに表示されます。

ステップ 3

show mpls forwarding-table [ network { mask | length } | labels label [ - label ] | interface interface | nexthop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

 

Router> show mpls forwarding-table

(任意)MPLS Forwarding Information Base(FIB; 転送情報ベース)の内容を表示します。

この例では、MPLS ラベルを IPv6 プレフィクスにリンクする情報が表示され、そこではラベルは集約で示され、プレフィクスは IPv6 で示されます。

ステップ 4

show ipv6 cef [ ipv6-prefix / prefix-length ] | [ interface-type interface-number ] [ longer-prefixes | similar-prefixes | detail | internal | platform | epoch | source ]]

 

Router> show ipv6 cef 2001:DB8:DDDD::/64

(任意)IPv6 アドレス情報に基づく FIB エントリを表示します。

この例では、プレフィクス 2001:DB8:DDDD::/64 についてのシスコ エクスプレス フォワーディング テーブルからのラベル情報が表示されます。

ステップ 5

show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

 

Router> show ipv6 route

(任意)IPv6 ルーティング テーブルの現在の内容を表示します。

出力例

「show bgp ipv6 コマンドの出力例」

「show bgp ipv6 neighbors コマンドの出力例」

「show mpls forwarding-table コマンドの出力例」

「show bgp ipv6 コマンドの出力例」

「show ipv6 cef コマンドの出力例」

「show ipv6 route コマンドの出力例」

show bgp ipv6 コマンドの出力例

次に、IPv6 プレフィクスを指定して show bgp ipv6 コマンドを使用した場合の、IPv6 ルートの出力情報の例を示します。

Router# show bgp ipv6 2001:DB8:DDDD::/48
 
BGP routing table entry for 2001:DB8:DDDD::/48, version 15
Paths: (1 available, best #1, table Global-IPv6-Table)
Not advertised to any peer
Local
::FFFF:192.168.99.70 (metric 20) from 192.168.99.70 (192.168.99.70)
Origin IGP, localpref 100, valid, internal, best

show bgp ipv6 neighbors コマンドの出力例

次に、IP アドレスを指定して show bgp ipv6 neighbors コマンドを使用した場合の、BGP ピア(「IPv6 ラベル」機能を含む)に関する出力情報の例を示します。

Router# show bgp ipv6 neighbors 192.168.99.70
 
BGP neighbor is 192.168.99.70, remote AS 65000, internal link
BGP version 4, remote router ID 192.168.99.70
BGP state = Established, up for 00:05:17
Last read 00:00:09, hold time is 0, keepalive interval is 60 seconds
Neighbor capabilities:
Route refresh: advertised and received
Address family IPv6 Unicast: advertised and received
ipv6 MPLS Label capability: advertised and received
Received 54 messages, 0 notifications, 0 in queue
Sent 55 messages, 1 notifications, 0 in queue
Default minimum time between advertisement runs is 5 seconds
 
For address family: IPv6 Unicast
BGP table version 21880, neighbor version 21880
Index 1, Offset 0, Mask 0x2
Route refresh request: received 0, sent 0
77 accepted prefixes consume 4928 bytes
Prefix advertised 4303, suppressed 0, withdrawn 1328
Number of NLRIs in the update sent: max 1, min 0

show mpls forwarding-table コマンドの出力例

次に、 show mpls forwarding-table コマンドを使用した場合の、MPLS ラベルとプレフィクスをリンクする出力情報の例を示します。6PE 機能が設定されている場合、ラベルは集約されます。これは、1 つのローカル ラベルに対して複数のプレフィクスが存在し、プレフィクスのカラムにはターゲットのプレフィクスではなく「IPv6」が含まれているためです。

Router# show mpls forwarding-table
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Aggregate IPv6 0
17 Aggregate IPv6 0
18 Aggregate IPv6 0
19 Pop tag 192.168.99.64/30 0 Se0/0 point2point
20 Pop tag 192.168.99.70/32 0 Se0/0 point2point
21 Pop tag 192.168.99.200/32 0 Se0/0 point2point
22 Aggregate IPv6 5424
23 Aggregate IPv6 3576
24 Aggregate IPv6 2600

show bgp ipv6 コマンドの出力例

次に、 labels キーワードを指定して show bgp ipv6 コマンドを使用した場合の、ラベル スイッチング情報を持つスタック ラベルのトップについての出力情報の例を示します。

Router# show bgp ipv6 labels
 
Network Next Hop In tag/Out tag
2001:DB8:DDDD::/64 ::FFFF:192.168.99.70 notag/20

show ipv6 cef コマンドの出力例

次に、IPv6 プレフィクスを指定して show ipv6 cef コマンドを使用した場合の、シスコ エクスプレス フォワーディング テーブルからのラベルの出力情報の例を示します。

Router# show ipv6 cef 2001:DB8:DDDD::/64
 
2001:DB8:DDDD::/64
nexthop ::FFFF:192.168.99.70
fast tag rewrite with Se0/0, point2point, tags imposed {19 20}

show ipv6 route コマンドの出力例

次に、 show ipv6 route コマンドを使用した場合の、IPv6 ルーティング テーブルからの出力情報の例を示します。この出力では、IPv6 MPLS 仮想インターフェイスが、MPLS クラウドを介して転送される IPv6 ルートの出力インターフェイスとして示されています。図 4 のルータを使用するこの例では、出力は 6PE1 ルータから得られます。

6PE2 ルータは、CE2 ルータに設定された IPv6 プレフィクス 2001:DB8:dddd::/48 をアドバタイズし、ネクストホップ アドレスは IPv4 互換 IPv6 アドレス ::ffff:192.168.99.70 です。ここで、192.168.99.70 は、6PE2 ルータの IPv4 アドレスです。

Router# show ipv6 route
 
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
B 2001:DB8:DDDD::/64 [200/0]
via ::FFFF:192.168.99.70, IPv6-mpls
B 2001:DB8:DDDD::/64 [200/0]
via ::FFFF:192.168.99.70, IPv6-mpls
L 2001:DB8:FFFF::1/128 [0/0]
via ::, Ethernet0/0
C 2001:DB8:FFFF::/64 [0/0]
via ::, Ethernet0/0
S 2001:DB8:FFFF::/48 [1/0]
via 2001:DB8:B00:FFFF::2, Ethernet0/0

IPv6 over MPLS の設定例

次の例では、図 4 で示し、「6PE ルータでの送信元アドレス インターフェイスの指定」および「プレフィクスをアドバタイズするための 6PE ラベルのバインドおよびアドバタイズ」の項で使用している 3 台のルータの 6PE 設定例を示します。

「例:カスタマー エッジ ルータ」

「例:プロバイダー エッジ ルータ」

「例:コア ルータ」

例:カスタマー エッジ ルータ

次に、カスタマー エッジ ルータ(図 4 の CE1)のシリアル インターフェイス 0/0 がサービス プロバイダーに接続され、IPv6 アドレスを割り当てられている例を示します。IPv6 がイネーブルになっており、デフォルトのスタティック ルートが、6PE1 ルータのシリアル インターフェイス 0/0 の IPv6 アドレスを使用してインストールされています。

ip cef
!
ipv6 unicast-routing
!
interface Serial 0/0
description to_6PE1_router
no ip address
ipv6 address 2001:DB8:FFFF::2/64
!
ipv6 route ::/0 Serial 0/0 FE80::210:XXXX:FEE1:1001

例:プロバイダー エッジ ルータ

6PE ルータ(図 4 の 6PE1)は、IPv4 と IPv6 の両方のトラフィック用に設定されています。イーサネット インターフェイス 0/0 は、IPv4 アドレスを使用して設定され、ネットワークのコア内のルータ(図 4 のルータ P1)に接続されています。このルータ上の統合 IS-IS および TDP の設定は、P1 ルータと似ています。

ルータ 6PE1 は、IPv4 接続を介して確立された internal BGP(iBGP; 内部 BGP)を使用して、別の 6PE(図 4 のルータ 6PE2)と IPv6 ルーティング情報を交換することから、すべての neighbor コマンドで 6PE2 ルータの IPv4 アドレスが使用されます。すべての BGP ピアは自律システム 65000 内に存在するため、IGP との同期は、IPv4 の場合はオフになっています。IPv6 アドレス ファミリ コンフィギュレーション モードでは、同期はデフォルトでディセーブルになっています。

IPv6 および Cisco Express Forwarding for IPv6 はイネーブルであり、6PE2 ネイバーはアクティブ化されており、IPv6 プレフィクスの集約ラベルのバインディングとアドバタイズメントは neighbor send-label コマンドを使用してイネーブルになっています。接続されているスタティックな IPv6 ルートは、BGP を使用して再配布されます。IPv6 パケットがローカル ルータで生成される場合、MPLS 処理用の IPv6 アドレスは、ループバック インターフェイス 0 のアドレスになります。

次に、シリアル インターフェイス 0/0 がカスタマーに接続され、カスタマーに委任された IPv6 プレフィクスは、サービス プロバイダーの IPv6 プレフィクスから決定された 2001:DB8:ffff::/48 となっている例を示します。スタティック ルートは、IPv6 パケットを 6PE ルートと CE ルータ間でルーティングするように設定されています。

ip cef
ipv6 cef
ipv6 unicast-routing
!
mpls ipv6 source-interface Loopback0
tag-switching tdp router-id Loopback0
!
interface Loopback0
ip address 192.168.99.5 255.255.255.255
ipv6 address 2001:DB8:1000:1::1/64
!
interface Ethernet0/0
description to_P_router
ip address 192.168.99.1 255.255.255.252
ip router isis
tag-switching ip
!
interface Serial0/0
description to_CE_router
no ip address
ipv6 address 2001:DB8:FFFF::1/64
!
router isis
passive-interface Loopback0
net 49.0001.1921.6809.9005.00
!
router bgp 65000
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 192.168.99.70 remote-as 65000
neighbor 192.168.99.70 description to_6PE2
neighbor 192.168.99.70 update-source Loopback0
!
address-family ipv6
neighbor 192.168.99.70 activate
neighbor 192.168.99.70 send-label
network 2001:DB8:FFFF::/48
exit-address-family
!
ipv6 route 2001:DB8:FFFF::/48 Ethernet0/0 2001:DB8:FFFF::2

例:コア ルータ

次に、ネットワークのコアにあるルータ(図 4 のルータ P)が MPLS、IS-IS、および IPv4 のみを実行している例を示します。イーサネット インターフェイスは、IPv4 アドレスを使用して設定されており、6PE ルータに接続されています。IS-IS は、ネットワークの IGP であり、P1 ルータと 6PE ルータは、同じ IS-IS エリア 49.0001 に存在します。TDP およびタグ スイッチングが、両方のイーサネット インターフェイスでイネーブルになっています。シスコ エクスプレス フォワーディングが、グローバル コンフィギュレーション モードでイネーブルになっています。

ip cef
!
tag-switching tdp router-id Loopback0
!
interface Loopback0
ip address 192.168.99.200 255.255.255.255
!
interface Ethernet0/0
description to_6PE1
ip address 192.168.99.2 255.255.255.252
ip router isis
tag-switching ip
!
interface Ethernet0/1
description to_6PE2
ip address 192.168.99.66 255.255.255.252
ip router isis
tag-switching ip
 
router isis
passive-interface Loopback0
net 49.0001.1921.6809.9200.00

関連情報

MPLS ネットワークをさらにカスタマイズする場合は、『 Cisco IOS IP Switching Configuration Guide 』を参照してください。

その他の関連資料

関連資料

関連項目
参照先

CE ルータでトンネルを使用する IPv6

Cisco IOS IPv6 Configuration Guide 』の「 Implementing Tunneling for IPv6

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

MPLS の設定作業

Cisco IOS Multiprotocol Label Switching Configuration Guide 』の「 Multiprotocol Label Switching Overview

MPLS コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS Multiprotocol Label Switching Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

IPv6 over MPLS の実装の機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 IPv6 over MPLS の実装の機能情報

機能名
リリース
機能情報

回線トランスポートを介した IPv6 over MPLS

12.0(22)S
12.2(14)S
12.2(28)SB 12.2(15)T
12.3
12.3(2)T
12.4
12.4(2)T

この機能では、リモート IPv6 ドメイン間の通信は、専用リンクを介してネイティブ IPv6 プロトコルを実行します。この場合、基礎となるメカニズムは IPv6 に対して完全に透過的です。

この機能に関する詳細については、次の各項を参照してください。

「回線トランスポートを介した IPv6 over MPLS」

「回線トランスポートを介した IPv6 over MPLS の展開」

カスタマー エッジ ルータを介するトンネルを使用する IPv6

12.0(22)S
12.2(14)S
12.2(28)SB
12.2(15)T
12.3
12.3(2)T
12.4
12.4(2)T

CE ルータでトンネルを使用することが、MPLS の動作またはインフラストラクチャに影響を与えることなく、IPv6 over MPLS ネットワークを最も簡単に展開できる方法です。

この機能に関する詳細については、次の各項を参照してください。

「カスタマー エッジ ルータでトンネルを使用する IPv6」

IPv6 スイッチング:プロバイダー エッジ ルータ over MPLS(6PE)

12.0(22)S
12.2(14)S
12.2(28)SB
12.2(33)SRA
12.2(15)T
12.3
12.3(2)T
12.4
12.4(2)T

MPLS を介した IPv6 プロバイダー エッジ ルータのシスコ実装によって、IPv6 サイトは、MPLS LSP を使用して、MPLS IPv4 コア ネットワークを介して互いに通信できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 プロバイダー エッジ ルータ(6PE)」

「IPv6 プロバイダー エッジ ルータ(6PE)の展開」

「6PE ルータでの送信元アドレス インターフェイスの指定」

「プレフィクスをアドバタイズするための 6PE ラベルのバインドおよびアドバタイズ」

「IPv6 over MPLS の設定例」

6PE マルチパス

12.2(25)S
12.2(28)SB
12.2(33)SRA
12.4(6)T

6PE マルチパス機能では、Multiprotocol internal BGP(MP-iBGP; マルチプロトコル内部 BGP)を使用して、MPLS IPv4 コア ネットワークを介して IPv6 ルートを配布し、MPLS ラベルを各ルートに付加します。

この機能に関する詳細については、次の各項を参照してください。

「6PE マルチパス」

「iBGP マルチパス ロード シェアリングの設定」