IPv6 コンフィギュレーション ガイド Cisco IOS Release M&T
NAT-PT for IPv6 の実装
NAT-PT for IPv6 の実装
発行日;2012/05/10 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

NAT-PT for IPv6 の実装

機能情報の確認

目次

NAT-PT for IPv6 の実装の前提条件

NAT-PT for IPv6 の実装の制約事項

NAT-PT for IPv6 の実装に関する情報

NAT-PT の概要

スタティック NAT-PT 動作

ダイナミック NAT-PT 動作

ポート アドレス変換(オーバーロード)

IPv4-Mapped 動作

NAT-PT for IPv6 の実装方法

NAT-PT for IPv6 に対する IPv6 から IPv4 への基本的な接続の設定

IPv4-Mapped NAT-PT の設定

IPv4 ホストにアクセスする IPv6 ホストのマッピングの設定

この次の手順

IPv6 ホストにアクセスする IPv4 ホストのマッピングの設定

IPv6 から IPv4 へのアドレス マッピングのための PAT の設定

この次の手順

NAT-PT の設定および動作の確認

NAT-PT for IPv6 の設定例

例:スタティック NAT-PT 設定

例:IPv6 ネットワークから IPv4 ネットワークへのトラフィック送信のイネーブル化(IPv6 宛先アドレス マッピングは使用しない)

例:IPv4 ホストにアクセスする IPv6 ホストのダイナミック NAT-PT 設定

IPv6 ホストにアクセスする IPv4 ホストのダイナミック NAT-PT 設定の例

関連情報

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

NAT-PT for IPv6 の実装の機能情報

NAT-PT for IPv6 の実装

ネットワーク アドレス変換 - プロトコル変換(NAT-PT)は、RFC 2765 および RFC 2766 で定義されている IPv6 から IPv4 への変換メカニズムです。これにより、IPv6 専用デバイスと IPv4 専用デバイスとの間の通信が可能になります。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「NAT-PT for IPv6 の実装の機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

NAT-PT for IPv6 の実装の前提条件

NAT-PT を実装する前に、IPv4 専用ネットワークと IPv6 専用ネットワークの間で通信を行うルータ インターフェイスで、IPv4 および IPv6 を設定する必要があります。

NAT-PT for IPv6 の実装の制約事項

NAT-PT は、シスコ エクスプレス フォワーディングではサポートされていません。

NAT-PT では、Application Layer Gateway(ALG)サポート(Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)、File Transfer Protocol(FTP; ファイル転送プロトコル)、および Domain Naming System(DNS)に対する ALG サポート)に制限があります。

NAT-PT には、IPv4 NAT と同じ制約事項があります。NAT-PT はエンドツーエンドのセキュリティを提供しないため、NAT-PT ルータがネットワーク内のシングル ポイント障害となることがあります。

スタティック NAT-PT 動作、ダイナミック NAT-PT 動作、Port Address Translation(PAT; ポート アドレス変換)、または IPv4-mapped 動作のいずれを使用するかを、ユーザが決定する必要があります。使用する動作を決定すると、ユーザが NAT-PT を設定および操作する方法も決まります。

IPv6 での Bridge-Group Virtual Interface(BVI; ブリッジ グループ仮想インターフェイス)は、NAT-PT およびワイヤレス インターフェイス Dot11Radio でサポートされません。

NAT-PT for IPv6 の実装に関する情報

ここでは、Cisco IOS ソフトウェアでの NAT-PT の概要を示します。ユーザは、スタティック NAT-PT、ダイナミック NAT-PT、Port Address Translation(PAT; ポート アドレス変換)、または IPv4-mapped 動作のいずれかを使用して NAT-PT を設定できます。次の各項で、これらの動作について説明します。

「NAT-PT の概要」

「スタティック NAT-PT 動作」

「ダイナミック NAT-PT 動作」

「ポート アドレス変換(オーバーロード)」

「IPv4-Mapped 動作」

NAT-PT の概要

Cisco IOS ソフトウェア用の NAT-PT は、カスタマーが IPv4 ネットワークを IPv6 ネットワークに移行するための移行ツールとして、RFC 2766 および RFC 2765 を使用して設計されたものです。IPv6 と IPv4 の間のプロトコル トランスレータを使用すると、異なるネットワーク プロトコルを使用するホスト間でダイレクトな通信を行うことができます。ユーザは、NAT-PT 動作に対してスタティックな定義または IPv4-mapped 定義を使用できます。

図 1 に、Ipv6 専用ノードを IPv4 専用ノードと接続するための、IPv6 ネットワークと IPv4 ネットワークの間のルータで行われる NAT-PT 実行を示します。

図 1 NAT-PT の基本的な動作

 

IPv6 によってカスタマーのアドレッシング問題が解決されますが、カスタマーが排他的な IPv6 ネットワーク環境に移行するまでには、通常は長い移行期間がかかります。この移行期間中に、新しい IPv6 専用ネットワークが導入されても、IPv6 専用ネットワークは既存の IPv4 ネットワークと引き続き通信する必要があります。NAT-PT は、IPv6 専用ネットワークと IPv4 専用ネットワークの間のダイレクトな通信を可能にするように展開される設計になっています。たとえば、サービス プロバイダー カスタマーでは、IPv6 専用クライアントが IPv4 専用 Web サーバにアクセスしようとする場合があります。また、企業カスタマーも段階的に IPv6 に移行し、IPv4 専用ネットワークの多くは何年も運用されることになります。デュアル スタック ネットワークには、IPv6 自動設定、グローバル アドレッシング、および簡略化された管理を利用するように設定された IPv6 専用ホストが含まれることがあります。これらのホストは、NAT-PT を使用して、同じ組織内の既存の IPv4 専用ネットワークと通信できます。

NAT-PT の利点の 1 つは、すべての NAT-PT 設定が NAT-PT ルータで実行されるため、既存のホストに変更を加える必要がないことです。すでに安定した IPv4 ネットワークを使用しているカスタマーは、IPv6 ネットワークを導入し、NAT-PT を使用して、既存のネットワークを中断せずに通信を行うことができます。シームレスな移行をさらに示すと、IPv4 ネットワーク内部と同様に、IPv4 ネットワークと IPv6 ネットワークの間でも File Transfer Protocol(FTP; ファイル転送プロトコル)を使用できます。IPv6 が設定されている場合は、デフォルトでパケット フラグメンテーションがイネーブルになっているため、IPv6 ネットワークと IPv4 ネットワークではネットワーク間のフラグメンテーション問題を解決できます。フラグメンテーションを解決する機能がない場合、フラグメント化されたパケットがドロップされたり、誤って解釈されたりすると、接続が断続的に中断されることがあります。

シスコはこれまでに、他にも、デュアル スタック、IPv6 over MPLS、トンネリングなどの移行技術を開発してきました。ネイティブな通信技術が他にある場合は、NAT-PT を使用しないでください。ホストが IPv4 と IPv6 の両方でデュアル スタック ホストとして設定されている場合に、NAT-PT を使用してデュアル スタック ホストと IPv6 専用ホストまたは IPv4 専用ホストとの通信を行うことは推奨しません。IPv6 専用ネットワークが IPv4 バックボーンを介して別の IPv6 専用ネットワークと通信しようとする場合、またはその逆の場合、NAT-PT を使用すると、二重の変換が必要となるため、推奨しません。このような場合は、トンネリング技術を使用することを推奨します。

ここでは、NAT-PT の設定に使用できる動作について説明します。ユーザは、NAT-PT 動作に対して次のいずれかの動作を使用できます。ただし、4 つすべての動作を使用することはできません。

スタティック NAT-PT 動作

スタティック NAT-PT では、スタティック変換ルールを使用して、1 つの IPv6 アドレスを 1 つの IPv4 アドレスにマップします。IPv6 ネットワーク ノードは、NAT-PT ルータで設定されている IPv4 アドレスの IPv6 マッピングを使用して、IPv4 ネットワーク ノードと通信します。

図 2 に、A という名前の IPv6 専用ノードが、NAT-PT を使用して C という名前の IPv4 専用ノードとどのように通信するかを示します。NAT-PT デバイスは、ノード A の送信元 IPv6 アドレス 2001:DB8:bbbb:1::1 を IPv4 アドレス 192.168.99.2 にマップするように設定されています。また、NAT-PT は IPv4 ノード C の送信元アドレス 192.168.30.1 を 2001:DB8::a にマップするようにも設定されています。ノード A の送信元 IPv6 アドレスを持つパケットは、NAT-PT ルータで受信されると、IPv4 専用ネットワーク内のノード C に一致する宛先アドレスを持つように変換されます。また、送信元 IPv4 アドレスと一致させ、パケットを IPv6 宛先アドレスに変換して、IPv4 専用ホストが IPv6 専用ホストと通信できるように NAT-PT を設定することもできます。

通信する必要のある IPv6 専用ホストまたは IPv4 専用ホストが複数存在する場合は、スタティック NAT-PT マッピングを多数設定する必要があることがあります。アプリケーションまたはサーバがステーブルな IPv4 アドレスにアクセスする必要がある場合(外部の IPv4 DNS サーバにアクセスする場合など)、スタティック NAT-PT を使用すると有効です。

図 2 スタティック NAT-PT 動作

 

ダイナミック NAT-PT 動作

ダイナミック NAT-PT を使用すると、プールからアドレスを割り当てることにより、複数の NAT-PT マッピングが可能になります。NAT-PT は、IPv6 アドレスまたは IPv4 アドレス(あるいはその両方)とともに設定されます。NAT-PT セッションの開始時に、プールから一時アドレスが動的に割り当てられます。アドレス プール内で使用可能なアドレスの数により、並列セッションの最大数が決まります。NAT-PT デバイスにより、アドレス間の各マッピングがダイナミック状態テーブルに記録されます。

図 3 に、ダイナミック NAT-PT の動作を示します。IPv6 専用ノード B は、ダイナミック NAT-PT を使用して、IPv4 専用ノード D と通信できます。NAT-PT デバイスは、NAT-PT により変換されるパケットを決定するために、IPv6 アクセス リスト、プレフィクス リスト、またはルート マップとともに設定されています。IPv4 アドレスのプール(図 3 では 10.21.8.1 から 10.21.8.10 まで)も設定されています。変換する IPv6 パケットが指定されている場合、NAT-PT は、設定済みのマッピング ルールを使用して、設定済みの IPv4 アドレス プールから一時 IPv4 アドレスを割り当てます。

図 3 ダイナミック NAT-PT 動作

 

ダイナミック NAT-PT 変換動作では、IPv4 DNS サーバに対して少なくとも 1 つのスタティック マッピングが必要です。

IPv6 から IPv4 への接続が確立されると、IPv4 から IPv6 への応答パケットは、すでに確立されているダイナミック マッピングを利用して、IPv4 から IPv6 に再び変換します。IPv4 専用ホストから接続が開始された場合は、この逆の説明になります。

ポート アドレス変換(オーバーロード)

Port Address Translation(PAT; ポート アドレス変換)は、オーバーロードとも呼ばれます。ポート番号上で多重化することで複数の IPv6 ユーザを単一の IPv4 アドレスと関連付けて、複数のセッション間で単一の IPv4 アドレスを使用できるようにします。PAT は、特定のインターフェイスまたはアドレス プールを介して実施できます。図 4 に、単一の IPv4 インターフェイスにリンクされている IPv6 ネットワークから IPv4 ネットワークへの、複数の IPv6 アドレスを示します。

図 4 ポート アドレス変換

 

IPv4-Mapped 動作

カスタマーは、IPv6 宛先アドレス マッピングを設定せずに、IPv6 ネットワークから IPv4 ネットワークにトラフィックを送信することもできます。インターフェイスに到着したパケットは、 ipv6 nat prefix v4-mapped コマンドで設定された NAT-PT プレフィクスが含まれているかどうかがチェックされます。プレフィクスが一致した場合、アクセスリスト チェックが実行され、送信元アドレスがアクセス リストまたはプレフィクス リストと一致するかどうか調べられます。プレフィクスが一致しない場合、パケットはドロップされます。

プレフィクスが一致した場合は、送信元アドレス変換が実行されます。送信元アドレス変換に対してルールが設定されている場合、宛先 IPv6 アドレスの最後の 32 ビットが IPv4 宛先として使用され、フロー エントリが作成されます。

ルータで IPv4 マッピングが設定されている場合、DNS ALG IPv4 アドレスが IPv6 アドレスに変換されると、IPv6 アドレスが処理され、IPv4 ネットワークからの DNS パケットの ALG が IPv6 ネットワークに変換されます。

NAT-PT for IPv6 の実装方法

「NAT-PT for IPv6 に対する IPv6 から IPv4 への基本的な接続の設定」(必須)

「IPv4-Mapped NAT-PT の設定」(必須)

「IPv4 ホストにアクセスする IPv6 ホストのマッピングの設定」(必須)

「IPv6 ホストにアクセスする IPv4 ホストのマッピングの設定」(任意)

「IPv6 から IPv4 へのアドレス マッピングのための PAT の設定」

「NAT-PT の設定および動作の確認」(任意)

NAT-PT for IPv6 に対する IPv6 から IPv4 への基本的な接続の設定

NAT-PT に対して IPv6 から IPv4 への基本的な接続を設定するには、次の作業を実行して、NAT-PT プレフィクスをグローバルに設定し、インターフェイスで NAT-PT をイネーブルにします。NAT-PT が機能するためには、着信インターフェイスと発信インターフェイスの両方で NAT-PT をイネーブルにする必要があります。

NAT-PT を使用するためには、プレフィクスの長さが 96 の IPv6 プレフィクスを指定する必要があります。IPv6 プレフィクスは、固有のローカル ユニキャスト プレフィクス、割り当てられた IPv6 プレフィクスのサブネット、または Internet Service Provider(ISP; インターネット サービス プロバイダー)から取得した追加プレフィクスにすることができます。NAT-PT プレフィクスは、IPv6 パケットの宛先アドレスと一致させるために使用されます。一致に成功すると、NAT-PT は設定済みのアドレス マッピング ルールを使用して、IPv6 パケットを IPv4 パケットに変換します。NAT-PT プレフィクスは、グローバルに設定することも、個々のインターフェイス上で別々の IPv6 プレフィクスを使用して設定することもできます。複数のインターフェイスで異なる NAT-PT プレフィクスを使用すると、NAT-PT ルータは、IPv4 ネットワークへの複数の出力点を持つ IPv6 ネットワークをサポートできます。

手順の概要

1. enable

2. configure terminal

3. ipv6 nat prefix ipv6-prefix / prefix-length

4. interface type number

5. ipv6 address ipv6-prefix { / prefix-length | link-local }

6. ipv6 nat

7. exit

8. interface type number

9. ip address ip-address mask [ secondary ]

10. ipv6 nat

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 nat prefix ipv6-prefix / prefix-length

 

Router# ipv6 nat prefix 2001:DB8::/96

IPv6 プレフィクスをグローバル NAT-PT プレフィクスとして割り当てます。

IPv6 パケット内で一致した宛先プレフィクスは、NAT-PT によって変換されます。

サポートされるプレフィクスの長さは、96 だけです。

ステップ 4

interface type number

 

Router(config)# interface ethernet 3/1

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 5

ipv6 address ipv6-address {/ prefix-length | link-local }

 

Router(config-if)# ipv6 address 2001:DB8:yyyy:1::9/64

インターフェイスに割り当てられている IPv6 アドレスを指定し、そのインターフェイスで IPv6 処理をイネーブルにします。

ステップ 6

ipv6 nat

 

Router(config-if)# ipv6 nat

インターフェイスで NAT-PT をイネーブルにします。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 8

interface type number

 

Router(config)# interface ethernet 3/3

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 9

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.30.9 255.255.255.0

インターフェイスに割り当てられている IP アドレスおよびマスクを指定し、そのインターフェイスで IP 処理をイネーブルにします。

ステップ 10

ipv6 nat

 

Router(config-if)# ipv6 nat

インターフェイスで NAT-PT をイネーブルにします。

IPv4-Mapped NAT-PT の設定

カスタマーが IPv6 宛先アドレス マッピングを設定せずに、IPv6 ネットワークから IPv4 ネットワークにトラフィックを送信できるようにするには、次の作業を実行します。この作業では、指定されたインターフェイスで ipv6 nat prefix v4-mapped コマンドを設定していますが、このコマンドをグローバルに設定することもできます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 nat prefix ipv6-prefix v4-mapped { access-list-name | ipv6-prefix }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 3/1

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 nat prefix ipv6-prefix v4-mapped { access-list-name | ipv6-prefix }

 

Router(config-if)# ipv6 nat prefix 2001::/96 v4-mapped v4mapacl

カスタマーが IPv6 宛先アドレス マッピングを設定せずに IPv6 ネットワークから IPv4 ネットワークにトラフィックを送信できるようにします。

IPv4 ホストにアクセスする IPv6 ホストのマッピングの設定

IPv6 から IPv4 へのスタティックまたはダイナミックなアドレス マッピングを設定するには、次の作業を実行します。ダイナミック アドレス マッピングでは、IPv4 アドレス プールを割り当て、変換するパケットを定義するためにアクセス リスト、プレフィクス リスト、またはルート マップを使用します。

手順の概要

1. enable

2. configure terminal

3. ipv6 nat v6v4 source ipv6-address ipv4-address
または
ipv6 nat v6v4 source { list access-list-name | route-map map-name } pool name

4. ipv6 nat v6v4 pool name start-ipv4 end-ipv4 prefix-length prefix-length

5. ipv6 nat translation [ max-entries number ] { timeout | udp-timeout | dns-timeout | tcp-timeout | finrst-timeout | icmp-timeout } { seconds | never }

6. ipv6 access-list access-list-name

7. permit protocol { source-ipv6-prefix / prefix-length | any | host source-ipv6-address } [ operator [ port-number ]] { destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address }

8. exit

9. show ipv6 nat translations [ icmp | tcp | udp ] [ verbose ]

10. show ipv6 nat statistics

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 nat v6v4 source ipv6-address ipv4-address

または

ipv6 nat v6v4 source { list access-list-name | route-map map-name } pool name

 

Router(config)# ipv6 nat v6v4 source 2001:DB8:yyyy:1::1 10.21.8.10

または

 

Router(config)# ipv6 nat v6v4 source list pt-list1 pool v4pool

NAT-PT を使用して、IPv6 から IPv4 へのスタティック アドレス マッピングをイネーブルにします。

または

NAT-PT を使用して、IPv6 から IPv4 へのダイナミック アドレス マッピングをイネーブルにします。

キーワード list または route-map を使用して、変換するパケットを定義するためのプレフィクス リスト、アクセス リスト、またはルート マップを指定します。

pool キーワードを使用して、 ipv6 nat v6v4 pool コマンドにより作成されるアドレス プールの名前を指定します。この名前は、ダイナミック NAT-PT アドレス マッピングで使用されます。

ステップ 4

ipv6 nat v6v4 pool name start-ipv4 end-ipv4 prefix-length prefix-length

 

Router(config)# ipv6 nat v6v4 pool v4pool 10.21.8.1 10.21.8.10 prefix-length 24

NAT-PT でダイナミック アドレス マッピングに使用される IPv4 アドレス プールを指定します。

ステップ 5

ipv6 nat translation [ max-entries number ] { timeout | udp-timeout | dns-timeout | tcp-timeout | finrst-timeout | icmp-timeout } { seconds | never }

 

Router(config)# ipv6 nat translation udp-timeout 600

(任意)NAT-PT 変換がタイムアウトになる時間を指定します。

ステップ 6

ipv6 access-list access-list-name

 

Router(config)# ipv6 access-list pt-list1

(任意)IPv6 アクセス リストを定義し、IPv6 アクセス リスト コンフィギュレーション モードを開始します。ルータにより、Router(config-ipv6-acl)# に対する変更が要求されます。

access-list name 引数は、IPv6 Access Control List(ACL; アクセス コントロール リスト)の名前を指定します。IPv6 ACL の名前にスペースまたは引用符を含めることはできません。また、先頭を数字にすることはできません。

ステップ 7

permit protocol { source-ipv6-prefix / prefix-length | any | host source-ipv6-address } [ operator [ port-number ]] { destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address }

 

Router(config-ipv6-acl)# permit ipv6 2001:DB8:bbbb:1::/64 any

(任意)IPv6 ACL に許可条件を指定します。

protocol 引数は、インターネット プロトコルの名前または番号を指定します。これは、キーワード ahp esp icmp ipv6 pcp sctp tcp 、または udp にするか、IPv6 プロトコル番号を表す 0 ~ 255 の整数にすることができます。

引数 source-ipv6-prefix / prefix-length および destination-ipv6-prefix / prefix-length は、許可条件を設定する IPv6 ネットワークまたはネットワーク クラスの送信元および宛先を指定します。これらの引数は RFC 2373 に記載された形式にする必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

any キーワードは、IPv6 プレフィクス ::/0 の省略形です。

host source-ipv6-address キーワードと引数の組み合わせは、許可条件を設定する送信元 IPv6 ホスト アドレスを指定します。 source-ipv6-address 引数は、RFC 2373 に記載された形式で指定する必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

ここでは、この作業に関連する引数およびキーワードだけを指定しています。サポートされている引数およびキーワードの詳細については、『 IPv6 for Cisco IOS Command Reference 』の permit コマンドを参照してください。

ステップ 8

exit

 

Router(config-if)# exit

アクセス リスト コンフィギュレーション モードを終了し、ルータを再びグローバル コンフィギュレーション モードに設定します。 exit コマンドを 2 回入力して、特権 EXEC モードに戻ります。

ステップ 9

show ipv6 nat translations [ icmp | tcp | udp ] [ verbose ]

 

Router# show ipv6 nat translations verbose

(任意)アクティブな NAT-PT 変換を表示します。

任意キーワード icmp tcp 、および udp を使用して、指定したプロトコルの NAT-PT 変換イベントに関する詳細情報を表示します。

任意キーワード verbose を使用して、アクティブな変換に関する詳細情報を表示します。

ステップ 10

show ipv6 nat statistics

 

Router# show ipv6 nat statistics

(任意)NAT-PT 統計情報を表示します。

この次の手順

IPv4 から IPv6 へのマッピングが必要でない場合は、「NAT-PT の設定および動作の確認」の作業に進んでください。

IPv6 ホストにアクセスする IPv4 ホストのマッピングの設定

IPv4 から IPv6 へのスタティックまたはダイナミックなアドレス マッピングを設定するには、次の任意作業を実行します。ダイナミック アドレス マッピングでは、IPv6 アドレス プールを割り当て、変換するパケットを定義するためにアクセス リスト、プレフィクス リスト、またはルート マップを使用します。

手順の概要

1. enable

2. configure terminal

3. ipv6 nat v4v6 source ipv4-address ipv6-address
または
ipv6 nat v4v6 source list { access-list-number | name } pool name

4. ipv6 nat v4v6 pool name start-ipv6 end-ipv6 prefix-length prefix-length

5. access-list { access-list-name | number } { deny | permit } [ source source-wildcard ] [ log ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 nat v4v6 source ipv6-address ipv4-address

または

ipv6 nat v4v6 source list { access-list-number | name } pool name

 

Router(config)# ipv6 nat v4v6 source 10.21.8.11 2001:DB8:yyyy::2

または

Router(config)# ipv6 nat v4v6 source list 1 pool v6pool

NAT-PT を使用して、IPv4 から IPv6 へのスタティック アドレス マッピングをイネーブルにします。

または

NAT-PT を使用して、IPv4 から IPv6 へのダイナミック アドレス マッピングをイネーブルにします。

list キーワードを使用して、変換するパケットを定義するためのアクセス リストを指定します。

pool キーワードを使用して、 ipv6 nat v4v6 pool コマンドにより作成されるアドレス プールの名前を指定します。この名前は、ダイナミック NAT-PT アドレス マッピングで使用されます。

ステップ 4

ipv6 nat v4v6 pool name start-ipv6 end-ipv6 prefix-length prefix-length

 

Router(config)# ipv6 nat v4v6 pool v6pool 2001:DB8:yyyy::1 2001:DB8:yyyy::2 prefix-length 128

NAT-PT でダイナミック アドレス マッピングに使用される IPv6 アドレス プールを指定します。

ステップ 5

access-list { access-list-name | number } { deny | permit } [ source source-wildcard ] [ log ]

 

Router(config)# access-list 1 permit 192.168.30.0 0.0.0.255

標準の IPv4 アクセス リスト内のエントリを指定します。

IPv6 から IPv4 へのアドレス マッピングのための PAT の設定

IPv6 から IPv4 へのアドレス マッピングのために PAT を設定するには、次の作業を実行します。複数の IPv6 アドレスを単一の IPv4 アドレスまたは IPv4 アドレス プールにマップします。このとき、変換するパケットを定義するためのアクセス リスト、プレフィクス リスト、またはルート マップを使用します。

手順の概要

1. enable

2. configure terminal

3. ipv6 nat v6v4 source { list access-list-name | route-map map-name } pool name overload

または

ipv6 nat v6v4 source { list access-list-name | route-map map-name } interface interface name overload

4. ipv6 nat v6v4 pool name start-ipv4 end-ipv4 prefix-length prefix-length

5. ipv6 nat translation [ max-entries number ] { timeout | udp-timeout | dns-timeout | tcp-timeout | finrst-timeout | icmp-timeout } { seconds | never }

6. ipv6 access-list access-list-name

7. permit protocol { source-ipv6-prefix / prefix-length | any | host source-ipv6-address } [ operator [ port-number ]] { destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 nat v6v4 source { list access-list-name | route-map map-name } pool name overload

または

ipv6 nat v6v4 source { list access-list-name | route-map map-name } interface interface name overload

 

Router(config)# ipv6 nat v6v4 source 2001:DB8:yyyy:1::1 10.21.8.10

または

 

Router(config)# ipv6 nat v6v4 source list pt-list1 pool v4pool overload

プール アドレスを使用して、IPv6 から IPv4 へのダイナミック アドレス オーバーロード マッピングをイネーブルにします。

または

インターフェイス アドレスを使用して、IPv6 から IPv4 へのダイナミック アドレス オーバーロード マッピングをイネーブルにします。

キーワード list または route-map を使用して、変換するパケットを定義するためのプレフィクス リスト、アクセス リスト、またはルート マップを指定します。

pool キーワードを使用して、 ipv6 nat v6v4 pool コマンドにより作成されるアドレス プールの名前を指定します。この名前は、ダイナミック NAT-PT アドレス マッピングで使用されます。

interface キーワードを使用して、オーバーロードに使用されるインターフェイス アドレスを指定します。

ステップ 4

ipv6 nat v6v4 pool name start-ipv4 end-ipv4 prefix-length prefix-length

 

Router(config)# ipv6 nat v6v4 pool v4pool 10.21.8.1 10.21.8.10 prefix-length 24

NAT-PT でダイナミック アドレス マッピングに使用される IPv4 アドレス プールを指定します。

ステップ 5

ipv6 nat translation [ max-entries number ] { timeout | udp-timeout | dns-timeout | tcp-timeout | finrst-timeout | icmp-timeout } { seconds | never }

 

Router(config)# ipv6 nat translation udp-timeout 600

(任意)NAT-PT 変換がタイムアウトになる時間を指定します。

ステップ 6

ipv6 access-list access-list-name

 

Router(config)# ipv6 access-list pt-list1

(任意)IPv6 アクセス リストを定義し、IPv6 アクセス リスト コンフィギュレーション モードを開始します。ルータにより、Router(config-ipv6-acl)# に対する変更が要求されます。

access-list name 引数は、IPv6 Access Control List(ACL; アクセス コントロール リスト)の名前を指定します。IPv6 ACL の名前にスペースまたは引用符を含めることはできません。また、先頭を数字にすることはできません。

ステップ 7

permit protocol { source-ipv6-prefix / prefix-length | any | host source-ipv6-address } [ operator [ port-number ]] { destination-ipv6-prefix / prefix-length | any | host destination-ipv6-address }

 

Router(config-ipv6-acl)# permit ipv6 2001:DB8:bbbb:1::/64 any

(任意)IPv6 ACL に許可条件を指定します。

protocol 引数は、インターネット プロトコルの名前または番号を指定します。これは、キーワード ahp esp icmp ipv6 pcp sctp tcp 、または udp にするか、IPv6 プロトコル番号を表す 0 ~ 255 の整数にすることができます。

引数 source-ipv6-prefix / prefix-length および destination-ipv6-prefix / prefix-length は、許可条件を設定する IPv6 ネットワークまたはネットワーク クラスの送信元および宛先を指定します。これらの引数は RFC 2373 に記載された形式にする必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

any キーワードは、IPv6 プレフィクス ::/0 の省略形です。

host source-ipv6-address キーワードと引数の組み合わせは、許可条件を設定する送信元 IPv6 ホスト アドレスを指定します。 source-ipv6-address 引数は、RFC 2373 に記載された形式で指定する必要があります。この形式では、アドレスは、16 進数値を 16 ビット単位でコロンで区切って指定します。

ここでは、この作業に関連する引数およびキーワードだけを指定しています。サポートされている引数およびキーワードの詳細については、『 Cisco IOS IPv6 Command Reference 』の permit コマンドを参照してください。

この次の手順

IPv6 から IPv4 へのマッピングも IPv4 から IPv6 へのマッピングも必要ない場合は、「NAT-PT の設定および動作の確認」の作業に進んでください。

NAT-PT の設定および動作の確認

手順の概要

1. clear ipv6 nat translation *

2. enable

3. debug ipv6 nat [ detailed | port ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

clear ipv6 nat translation *

 

Router> clear ipv6 nat translation *

(任意)ダイナミック変換ステート テーブルからダイナミック NAT-PT 変換をクリアします。

* キーワードを使用すると、すべてのダイナミック NAT-PT 変換がクリアされます。

(注) スタティック変換の設定は、このコマンドの影響を受けません。

ステップ 2

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 3

debug ipv6 nat [ detailed | port ]

 

Router# debug ipv6 nat detail

NAT-PT 変換イベントのデバッグ メッセージを表示します。

show ipv6 nat translations コマンドの出力例

show ipv6 nat statistics コマンドの出力例

clear ipv6 nat translation コマンドの出力例

debug ipv6 nat コマンドの出力例

show ipv6 nat translations コマンドの出力例

次の例では、 show ipv6 nat translations コマンドを使用して、アクティブ NAT-PT 変換に関する出力情報を表示しています。

Router# show ipv6 nat translations
 
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
--- --- ---
192.168.123.2 2001:DB8::2
 
--- --- ---
192.168.122.10 2001:DB8::10
 
tcp 192.168.124.8,11047 2001:DB8:3::8,11047
192.168.123.2,23 2001:DB8::2,23
 
udp 192.168.124.8,52922 2001:DB8:3::8,52922
192.168.123.2,69 2001::2,69
 
udp 192.168.124.8,52922 2001:DB8:3::8,52922
192.168.123.2,52922 2001:DB8::2,52922
 
--- 192.168.124.8 2001:DB8:3::8
192.168.123.2 2001:DB8::2
 
--- 192.168.124.8 2001:DB8:3::8
--- ---
 
--- 192.168.121.4 2001:DB8:5::4
--- ---
 

次の例では、 show ipv6 nat translations コマンドを verbose キーワードとともに使用して、アクティブ NAT-PT 変換に関する詳細な出力情報を表示しています。

Router# show ipv6 nat translations verbose
 
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
--- --- ---
192.168.123.2 2001:DB8::2
create 00:04:24, use 00:03:24,
 
--- --- ---
192.168.122.10 2001:DB8::10
create 00:04:24, use 00:04:24,
 
tcp 192.168.124.8,11047 2001:DB8:3::8,11047
192.168.123.2,23 2001:DB8::2,23
create 00:03:24, use 00:03:20, left 00:16:39,
 
udp 192.168.124.8,52922 2001:DB8:3::8,52922
192.168.123.2,69 2001:DB8::2,69
create 00:02:51, use 00:02:37, left 00:17:22,
 
udp 192.168.124.8,52922 2001:DB8:3::8,52922
192.168.123.2,52922 2001:DB8::2,52922
create 00:02:48, use 00:02:30, left 00:17:29,
 
--- 192.168.124.8 2001:DB8:3::8
192.168.123.2 2001:DB8::2
create 00:03:24, use 00:02:34, left 00:17:25,
 
--- 192.168.124.8 2001:DB8:3::8
--- ---
create 00:04:24, use 00:03:24,
 
--- 192.168.121.4 2001:DB8:5::4
--- ---
create 00:04:25, use 00:04:25,

show ipv6 nat statistics コマンドの出力例

次の例では、 show ipv6 nat statistics コマンドを使用して、NAT-PT 統計情報に関する出力情報を表示しています。

Router# show ipv6 nat statistics
 
Total active translations: 4 (4 static, 0 dynamic; 0 extended)
NAT-PT interfaces:
Ethernet3/1, Ethernet3/3
Hits: 0 Misses: 0
Expired translations: 0

clear ipv6 nat translation コマンドの出力例

次の例では、 clear ipv6 nat translation コマンドを * キーワードとともに使用して、ダイナミック変換ステート テーブルからすべてのダイナミック NAT-PT 変換をクリアしています。 show ipv6 nat translations コマンドを使用してアクティブ NAT-PT 変換に関する出力情報を表示すると、スタティック変換設定だけが残ります。この show コマンド出力を、ステップ 1 の show ipv6 nat translations コマンドの出力と比較します。

Router# clear ipv6 nat translation *
 
Router# show ipv6 nat translations
 
Prot IPv4 source IPv6 source
IPv4 destination IPv6 destination
--- --- ---
192.168.123.2 2001:DB8::2
 
--- --- ---
192.168.122.10 2001:DB8::10
 
--- 192.168.124.8 2001:DB8:3::8
--- ---
 
--- 192.168.121.4 2001:DB8:5::4
--- ---

debug ipv6 nat コマンドの出力例

次の例では、 debug ipv6 nat コマンドを使用して、NAT-PT 変換のデバッグ メッセージを表示しています。

Router# debug ipv6 nat
 
00:06:06: IPv6 NAT: icmp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: icmp src (192.168.123.2) -> (2001:DB8:2001::2), dst (192.168.124.8) -> (2001:DB8:3002::8)
00:06:06: IPv6 NAT: icmp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: icmp src (192.168.123.2) -> (2001:DB8:2001::2), dst (192.168.124.8) -> (2001:DB8:3002::8)
00:06:06: IPv6 NAT: tcp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: tcp src (192.168.123.2) -> (2001:DB8:2001::2), dst (192.168.124.8) -> (2001:DB8:3002::8)
00:06:06: IPv6 NAT: tcp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: tcp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: tcp src (2001:DB8:3002::8) -> (192.168.124.8), dst (2001:DB8:2001::2) -> (192.168.123.2)
00:06:06: IPv6 NAT: tcp src (192.168.123.2) -> (2001:DB8:2001::2), dst (192.168.124.8) -> (2001:DB8:3002::8)

NAT-PT for IPv6 の設定例

ここでは、次の設定例について説明します。

「例:スタティック NAT-PT 設定」

「例:IPv6 ネットワークから IPv4 ネットワークへのトラフィック送信のイネーブル化(IPv6 宛先アドレス マッピングは使用しない)」

「例:IPv4 ホストにアクセスする IPv6 ホストのダイナミック NAT-PT 設定」

「IPv6 ホストにアクセスする IPv4 ホストのダイナミック NAT-PT 設定の例」

例:スタティック NAT-PT 設定

次の例では、NAT-PT プレフィクスをグローバルに設定し、2 つのインターフェイスで NAT-PT をイネーブルにして、2 つのスタティック NAT-PT マッピングを設定しています。イーサネット インターフェイス 3/1 を IPv6 専用として設定し、イーサネット インターフェイス 3/3 を IPv4 専用として設定しています。

interface Ethernet3/1
ipv6 address 2001:DB8:3002::9/64
ipv6 enable
ipv6 nat
!
interface Ethernet3/3
ip address 192.168.30.9 255.255.255.0
ipv6 nat
!
ipv6 nat v4v6 source 192.168.30.1 2001:DB8:0::2
ipv6 nat v6v4 source 2001:DB8:bbbb:1::1 10.21.8.10
ipv6 nat prefix 2001:DB8:0::/96

例:IPv6 ネットワークから IPv4 ネットワークへのトラフィック送信のイネーブル化(IPv6 宛先アドレス マッピングは使用しない)

次の例では、アクセス リストにより、プレフィクスが 2001::/96 の IPv6 送信元アドレスからプレフィクスが 2000::/96 の宛先への送信が許可されています。続いて、宛先が IPv6 アドレスの最後の 32 ビットに変換されています。たとえば、送信元アドレスは 2001::1 で、宛先アドレスは 2000::192.168.1.1 です。そのあと、宛先は IPv4 ネットワーク内で 192.168.1.1 となります。

ipv6 nat prefix 2000::/96 v4-mapped v4map_acl
 
ipv6 access-list v4map_acl
permit ipv6 2001::/96 2000::/96

例:IPv4 ホストにアクセスする IPv6 ホストのダイナミック NAT-PT 設定

次の例では、NAT-PT プレフィクスをグローバルに設定し、2 つのインターフェイスで NAT-PT をイネーブルにして、(たとえば、DNS サーバへのアクセスに使用される)1 つのスタティック NAT-PT マッピングを設定しています。また、v4pool という名前の IPv4 アドレス プールを使用して、IPv6 アドレスを IPv4 アドレスにマップするためのダイナミック NAT-PT マッピングも設定しています。NAT-PT により変換されるパケットは、pt-list1 という名前の IPv6 アクセス リストを使用してフィルタ処理されます。User Datagram Protocol(UDP; ユーザ データグラム プロトコル)変換エントリが、10 分後にタイムアウトになるように設定しています。イーサネット インターフェイス 3/1 を IPv6 専用として設定し、イーサネット インターフェイス 3/3 を IPv4 専用として設定しています。

interface Ethernet3/1
ipv6 address 2001:DB8:bbbb:1::9/64
ipv6 enable
ipv6 nat
!
interface Ethernet3/3
ip address 192.168.30.9 255.255.255.0
ipv6 nat
!
ipv6 nat v4v6 source 192.168.30.1 2001:DB8:0::2
ipv6 nat v6v4 source list pt-list1 pool v4pool
ipv6 nat v6v4 pool v4pool 10.21.8.1 10.21.8.10 prefix-length 24
ipv6 nat translation udp-timeout 600
ipv6 nat prefix 2001:DB8:1::/96
!
ipv6 access-list pt-list1
permit ipv6 2001:DB8:bbbb:1::/64 any

IPv6 ホストにアクセスする IPv4 ホストのダイナミック NAT-PT 設定の例

次の例では、NAT-PT プレフィクスをグローバルに設定し、2 つのインターフェイスで NAT-PT をイネーブルにして、(たとえば、DNS サーバへのアクセスに使用される)1 つのスタティック NAT-PT マッピングを設定しています。また、v6pool という名前の IPv6 アドレス プールを使用して、IPv4 アドレスを IPv6 アドレスにマップするためのダイナミック NAT-PT マッピングも設定しています。NAT-PT により変換されるパケットは、pt-list2 という名前のアクセス リストを使用してフィルタ処理されます。イーサネット インターフェイス 3/1 を IPv6 専用として設定し、イーサネット インターフェイス 3/3 を IPv4 専用として設定しています。

interface Ethernet3/1
ipv6 address 2001:DB8:bbbb:1::9/64
ipv6 enable
ipv6 nat
!
interface Ethernet3/3
ip address 192.168.30.9 255.255.255.0
ipv6 nat
!
ipv6 nat v4v6 source list 72 pool v6pool
ipv6 nat v4v6 pool v6pool 2001:DB8:0::1 2001:DB8:0::2 prefix-length 128
ipv6 nat v6v4 source 2001:DB8:bbbb:1::1 10.21.8.0
ipv6 nat prefix 2001:DB8:0::/96
!
access-list 72 permit 192.168.30.0 0.0.0.255

関連情報

IPv6 ルーティング プロトコルを実装する場合は、「 Implementing RIP for IPv6 」、「 Implementing IS-IS for IPv6 」、または「 Implementing Multiprotocol BGP for IPv6 の章を参照してください。

その他の関連資料

関連資料

関連項目
参照先

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

IPv6 アドレッシングおよび IPv6 アドレッシング サービス

「Implementing IPv6 Addressing and Basic Connectivity」

IPv4 アドレッシング サービス コマンド

『Cisco IOS IP Addressing Services Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2765

『Stateless IP/ICMP Translation Algorithm (SIIT)』

RFC 2766

『Network Address Translation - Protocol Translation (NAT-PT)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

NAT-PT for IPv6 の実装の機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


表 1 NAT-PT for IPv6 の実装の機能情報

機能名
リリース
機能情報

NAT プロトコル変換

12.2(13)T
12.3
12.3(2)T
12.4

NAT-PT は、IPv6 専用デバイスと IPv4 専用デバイスとの通信を可能にする、IPv6 から IPv4 への(またはその逆方向の)変換メカニズムです。NAT-PT は、シスコ エクスプレス フォワーディングではサポートされていません。

このマニュアルでは、この機能について説明しています。

NAT-PT:DNS ALG に対するサポート

12.2(13)T 12.3
12.3(2)T
12.4

IPv6 は、DNS ALG のサポートを提供します。

この機能に関する詳細については、次の項を参照してください。

「NAT-PT for IPv6 の実装の制約事項」

NAT-PT:FTP ALG に対するサポート

12.3(2)T
12.4
12.4(2)T

IPv6 は、FTP ALG のサポートを提供します。

この機能に関する詳細については、次の項を参照してください。

「NAT-PT for IPv6 の実装の制約事項」

NAT-PT:フラグメンテーションに対するサポート

12.3(2)T
12.4
12.4(2)T

IPv6 が設定されている場合は、デフォルトでパケット フラグメンテーションがイネーブルになっているため、IPv6 ネットワークと IPv4 ネットワークではネットワーク間のフラグメンテーション問題を解決できます。

この機能に関する詳細については、次の項を参照してください。

「NAT-PT の概要」

NAT-PT:オーバーロード(PAT)に対するサポート

12.3(2)T
12.4
12.4(2)T

PAT は、オーバーロードとも呼ばれます。ポート番号上で多重化することで複数の IPv6 ユーザを単一の IPv4 アドレスと関連付けて、複数のセッション間で単一の IPv4 アドレスを使用できるようにします。

この機能に関する詳細については、次の各項を参照してください。

「ポート アドレス変換(オーバーロード)」

「IPv6 から IPv4 へのアドレス マッピングのための PAT の設定」

「NAT-PT の設定および動作の確認」