IPv6 コンフィギュレーション ガイド Cisco IOS Release M&T
マルチプロトコル BGP for IPv6 の実装
マルチプロトコル BGP for IPv6 の実装
発行日;2012/05/10 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

マルチプロトコル BGP for IPv6 の実装

機能情報の確認

目次

マルチプロトコル BGP for IPv6 の実装の前提条件

マルチプロトコル BGP for IPv6 の実装に関する情報

マルチプロトコル BGP for IPv6 拡張

IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP

MP-BGP IPv6 アドレス ファミリのノンストップ フォワーディングおよびグレースフル リスタート

6PE マルチパス

マルチプロトコル BGP for IPv6 の実装方法

IPv6 BGP ルーティング プロセスおよび BGP ルータ ID の設定

IPv6 マルチプロトコル BGP ピアの設定

リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定

制約事項

トラブルシューティングのヒント

IPv6 マルチプロトコル BGP ピア グループの設定

制約事項

IPv6 マルチプロトコル BGP へのルートのアドバタイズ

制約事項

IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定

制約事項

IPv6 マルチプロトコル BGP へのプレフィクスの再配布

IPv6 BGP ピア間での IPv4 ルートのアドバタイズ

BGP の管理ディスタンスの割り当て

IPv6 マルチキャスト BGP の変換アップデートの生成

IPv6 BGP グレースフル リスタート機能の設定

BGP セッションのリセット

外部 BGP ピアのクリア

IPv6 BGP ルート減衰情報のクリア

IPv6 BGP フラップ統計情報のクリア

IPv6 マルチプロトコル BGP の設定および動作の確認

マルチプロトコル BGP for IPv6 の設定例

例:BGP プロセス、BGP ルータ ID、および IPv6 マルチプロトコル BGP ピアの設定

例:リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定

例:IPv6 マルチプロトコル BGP ピア グループの設定

例:IPv6 マルチプロトコル BGP へのルートのアドバタイズ

例:IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定

例:IPv6 マルチプロトコル BGP へのプレフィクスの再配布

例:IPv6 ピア間での IPv4 ルートのアドバタイズ

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

マルチプロトコル BGP for IPv6 の実装の機能情報

マルチプロトコル BGP for IPv6 の実装

この章では、マルチプロトコル Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)for IPv6 を設定する方法について説明します。BGP は、独立したルーティング ポリシーを持つ個別のルーティング ドメイン(自律システム)を接続する場合に主に使用される Exterior Gateway Protocol(EGP; 外部ゲートウェイ プロトコル)です。BGP の一般的な用途は、サービス プロバイダーに接続してインターネットにアクセスすることです。BGP は、自律システム内で使用することもできます。このタイプの BGP は、internal BGP(iBGP; 内部 BGP)と呼ばれます。マルチプロトコル BGP は、複数のネットワーク レイヤ プロトコル アドレス ファミリ(IPv6 アドレス ファミリなど)、および IP マルチキャスト ルートに関するルーティング情報を伝送する拡張 BGP です。すべての BGP コマンドおよびルーティング ポリシー機能をマルチプロトコル BGP で使用できます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「マルチプロトコル BGP for IPv6 の実装の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、および Cisco ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

マルチプロトコル BGP for IPv6 の実装の前提条件

この章では、IPv6 アドレッシングおよび基本設定に精通していることを前提としています。詳細については、「 IPv6 アドレッシングと基本接続の実装 」の章を参照してください。

この章では、IPv4 に精通していることを前提としています。IPv4 の設定およびコマンド リファレンス情報については、「関連資料」の関連資料を参照してください。

VPN for IPv6(VPNv6)は、IPv6 VPN over MPLS(6VPE)を介してサポートされています。

マルチプロトコル BGP for IPv6 の実装に関する情報

「マルチプロトコル BGP for IPv6 拡張」

「IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP」

マルチプロトコル BGP for IPv6 拡張

マルチプロトコル BGP は、IPv6 用にサポートされている EGP です。マルチプロトコル BGP for IPv6 拡張では、IPv4 BGP と同じ機能および機能性がサポートされています。マルチプロトコル BGP に対する IPv6 拡張には、IPv6 アドレス ファミリ、Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)、および IPv6 アドレスを使用するネクストホップ(宛先へのパス内の次のルータ)属性のサポートが含まれています。

IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP

IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP 機能では、マルチプロトコル BGP for IPv6 拡張を提供し、IPv4 BGP と同じ機能と機能性をサポートします。マルチキャスト BGP に対する IPv6 拡張には、IPv6 マルチキャスト アドレス ファミリ、Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)、および IPv6 アドレスを使用するネクストホップ(宛先へのパス内の次のルータ)属性のサポートが含まれています。

マルチキャスト BGP は、ドメイン間 IPv6 マルチキャストの配布を可能にする、拡張された BGP です。マルチプロトコル BGP では、複数のネットワーク レイヤ プロトコル アドレス ファミリ(IPv6 アドレス ファミリなど)および IPv6 マルチキャスト ルートに関するルーティング情報を伝送します。IPv6 マルチキャスト アドレス ファミリには、IPv6 PIM プロトコルによる RPF ルックアップに使用される複数のルートが含まれており、マルチキャスト BGP IPV6 は、同じドメイン間転送を提供します。ユニキャスト BGP が学習したルートは IPv6 マルチキャストには使用されないため、ユーザは、BGP で IPv6 マルチキャストを使用する場合は、マルチプロトコル BGP for IPv6 マルチキャストを使用する必要があります。

マルチキャスト BGP 機能は、個別のアドレス ファミリ コンテキストを介して提供されます。Subsequent Address Family Identifier(SAFI)では、属性で伝送されるネットワーク レイヤ到達可能性情報のタイプに関する情報を提供します。マルチプロトコル BGP ユニキャストでは SAFI 1 メッセージを使用し、マルチプロトコル BGP マルチキャストでは SAFI 2 メッセージを使用します。SAFI 1 メッセージは、ルートは IP ユニキャストだけに使用でき、IP マルチキャストには使用できないことを示します。この機能があるため、IPv6 ユニキャスト RIB 内の BGP ルートは、IPv6 マルチキャスト RPF ルックアップでは無視される必要があります。

IPv6 マルチキャスト RPF ルックアップを使用して、異なるポリシーおよびトポロジ(IPv6 ユニキャストとマルチキャストなど)を設定するために、個別の BGP ルーティング テーブルが維持されています。マルチキャスト RPF ルックアップは、IP ユニキャスト ルート ルックアップと非常によく似ています。

IPv6 マルチキャスト BGP テーブルと関連付けられている MRIB はありません。ただし、必要な場合、IPv6 マルチキャスト BGP は、ユニキャスト IPv6 RIB で動作します。マルチキャスト BGP では、IPv6 ユニキャスト RIB へのルートの挿入や更新は行いません。

MP-BGP IPv6 アドレス ファミリのノンストップ フォワーディングおよびグレースフル リスタート

グレースフル リスタート機能は、IPv6 BGP ユニキャスト、IPv6 BGP マルチキャスト、および VPNv6 アドレス ファミリでサポートされており、BGP IPv6 用の Cisco NonStop Forwarding(NSF; ノンストップ フォワーディング)機能をイネーブルにします。BGP グレースフル リスタート機能を使用すると、TCP 状態を維持することなく、BGP ルーティング テーブルをピアから回復できます。

NSF では、ルーティング プロトコルのコンバージェンス時にも引き続きパケットが転送されるため、スイッチオーバー時のルート フラップが回避されます。転送は、アクティブ RP とスタンバイ RP 間で FIB を同期することで維持されます。スイッチオーバー時、転送は FIB を使用して維持されます。RIB の同期は維持されないため、RIB はスイッチオーバー時に空になります。RIB は、ルーティング プロトコルによって再入力され、次に、NSF_RIB_CONVERGED レジストリ コールを使用して RIB コンバージェンスに関する情報を FIB に伝えます FIB テーブルは、RIB から更新され、古いエントリが削除されます。RIB は、ルーティング プロトコルが RIB のコンバージェンスの通知に失敗した場合、RP スイッチオーバー時にフェールセーフ タイマーを開始します。

Cisco BGP Address Family Identifier(AFI)モデルは、モジュラ式でスケーラブルな設計となっており、複数の AFI 設定および Subsequent Address Family Identifier(SAFI)設定をサポートするように設計されています。

6PE マルチパス

IPv6 の内部および外部 BGP マルチパスによって、IPv6 ルータは、宛先に到達するために複数のパス(同じネイバー自律システムやサブ自律システム、または同じメトリックなど)間のロード バランシングを行うことができます。6PE マルチパス機能では、Multiprotocol internal BGP(MP-iBGP; マルチプロトコル内部 BGP)を使用して、MPLS IPv4 コア ネットワークを介して IPv6 ルートを配布し、MPLS ラベルを各ルートに付加します。

MP-iBGP マルチパスが 6PE ルータでイネーブルになっていると、MPLS 情報が使用できる場合は、MPLS 情報(ラベル スタック)を使用して、ラベルの付いたすべてのパスが、転送テーブルにインストールされます。この機能によって、6PE はロード バランシングを実行できます。

マルチプロトコル BGP for IPv6 の実装方法

マルチプロトコル BGP for IPv6 拡張を設定する場合は、BGP ルーティング プロセスを作成し、ピアリング関係を設定し、特定のネットワーク用に BGP をカスタマイズする必要があります。

「IPv6 BGP ルーティング プロセスおよび BGP ルータ ID の設定」(必須)

「IPv6 マルチプロトコル BGP ピアの設定」(必須)

「リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定」(任意)

「IPv6 マルチプロトコル BGP ピア グループの設定」(任意)

「IPv6 マルチプロトコル BGP へのルートのアドバタイズ」(必須)

「IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定」(任意)

「IPv6 マルチプロトコル BGP へのプレフィクスの再配布」(任意)

「IPv6 BGP ピア間での IPv4 ルートのアドバタイズ」(任意)

「BGP の管理ディスタンスの割り当て」(任意)

「IPv6 マルチキャスト BGP の変換アップデートの生成」(任意)

「IPv6 BGP グレースフル リスタート機能の設定」(任意)

「BGP セッションのリセット」(任意)

「外部 BGP ピアのクリア」(任意)

「IPv6 BGP ルート減衰情報のクリア」(任意)

「IPv6 BGP フラップ統計情報のクリア」(任意)

「IPv6 マルチプロトコル BGP の設定および動作の確認」(任意)

IPv6 BGP ルーティング プロセスおよび BGP ルータ ID の設定

IPv6 BGP ルーティング プロセスを設定し、オプションの BGP スピーキング ルータ用 BGP ルータ ID を設定するには、次の作業を実行します。

BGP では、ルータ ID を使用して、BGP スピーキング ピアを識別します。BGP ルータ ID は、32 ビット値であり、多くの場合、IPv4 アドレスで表されます。デフォルトでは、Cisco IOS ソフトウェアによって、ルータ ID がルータ上のループバック インターフェイスの IPv4 アドレスに設定されます。ルータ上でループバック インターフェイスが設定されていない場合は、BGP ルータ ID を表すためにルータ上の物理インターフェイスに設定されている最上位の IPv4 アドレスがソフトウェアによって選択されます。IPv6 だけがイネーブルになっているルータ(IPv4 アドレスを持っていないルータ)で BGP を設定する場合、そのルータの BGP ルータ ID を手動で設定する必要があります。IPv4 アドレス構文を使用して 32 ビット値で表される BGP ルータ ID は、ルータの BGP ピアで一意である必要があります。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no bgp default ipv4-unicast

5. bgp router-id ip-address

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

BGP ルーティング プロセスを設定し、指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

前の手順で指定した BGP ルーティング プロセスの IPv4 ユニキャスト アドレス ファミリをディセーブルにします。

コマンドを設定している場合は除きます。

ステップ 5

bgp router-id ip-address

 

Router(config-router)# bgp router-id 192.168.99.70

(任意)固定 32 ビット ルータ ID を、BGP を実行するローカル ルータの ID として設定します。

コマンドを使用してルータ ID を設定すると、アクティブな BGP ピアリング セッションがすべてリセットされます。

IPv6 マルチプロトコル BGP ピアの設定

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。IPv6 プレフィクスなどの他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプ(IPv6 プレフィクスなど)のアドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要もあります。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

5. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

6. neighbor { ip-address | peer-group-name | ipv6-address % } activate

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

 

Router(config-router)# neighbor 2001:DB8:0:CC00::1 remote-as 64600

指定した自律システム内のネイバーの IPv6 アドレスを、ローカル ルータの IPv6 マルチプロトコル BGP ネイバーテーブルに追加します。

ステップ 5

address-family ipv6 [ unicast | multicast ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 6

neighbor { ip-address | peer-group-name | ipv6-address % } activate

 

Router(config-router-af)# neighbor 2001:DB8:0:CC00::1 activate

ローカル ルータとの間で IPv6 アドレス ファミリを交換できるようにネイバーを設定します。

リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定

リンクローカル アドレスを使用して 2 台の IPv6 ルータ(ピア)間に IPv6 マルチプロトコル BGP を設定する場合は、ネイバーのインターフェイスが update-source コマンドを使用して識別され、IPv6 グローバル ネクストホップを設定するようにルート マップが設定されている必要があります。

制約事項

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。IPv6 プレフィクスなどの他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプ(IPv6 プレフィクスなど)のアドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要もあります。

デフォルトでは、 neighbor route-map コマンドを使用してルータ コンフィギュレーション モードで適用されるルート マップは、IPv4 ユニキャスト アドレス プレフィクスだけに適用されます。IPv6 アドレス ファミリなどのその他のアドレス ファミリのルート マップは、 neighbor route-map コマンドを使用してアドレス ファミリ コンフィギュレーション モードで適用される必要があります。ルート マップは、指定したアドレス ファミリの下にあるネイバーの着信ルーティング ポリシーまたは発信ルーティング ポリシーとして適用されます。各アドレス ファミリ タイプで個別のルート マップを設定すると、各アドレス ファミリの複雑なポリシーまたはさまざまなポリシーを簡単に管理できるようになります。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

5. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } update-source interface-type interface-number

6. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

7. neighbor { ip-address | peer-group-name | ipv6-address % } activate

8. neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

9. exit

10. ステップ 9 を繰り返します。

11. route-map map-tag [ permit | deny ] [ sequence-number ]

12. match ipv6 address { prefix-list prefix-list-name | access-list-name }

13. set ipv6 next-hop ipv6-address [ link-local-address ] [ peer-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

 

Router(config-router)# neighbor FE80::XXXX:BFF:FE0E:A471% remote-as 64600

指定したリモート自律システム内のネイバーのリンクローカル IPv6 アドレスをローカル ルータの IPv6 マルチプロトコル BGP ネイバーテーブルに追加します。

省略可能な % キーワードは、IPv6 リンクローカル アドレス ID です。このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

ステップ 5

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } update-source interface-type interface-number

 

Router(config-router)# neighbor FE80::XXXX:BFF:FE0E:A471% update-source fastethernet0

ピアリングが発生するリンクローカル アドレスを指定します。

省略可能な % キーワードは、IPv6 リンクローカル アドレス ID です。このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

ネイバーへの接続が複数存在し、 neighbor update-source コマンドで interface-type 引数と interface-number 引数を使用してネイバー インターフェイスを指定していない場合は、リンクローカル アドレスを使用してネイバーとの TCP 接続を確立することはできません。

ステップ 6

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 7

neighbor { ip-address | peer-group-name | ipv6-address % } activate

 

Router(config-router-af)# neighbor FE80::XXXX:BFF:FE0E:A471% activate

ネイバーが、指定したリンクローカル アドレスを使用して IPv6 アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

省略可能な % キーワードは、IPv6 リンクローカル アドレス ID です。このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

ステップ 8

neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

 

Router(config-router-af)# neighbor FE80::XXXX:BFF:FE0E:A471% route-map nh6 out

着信ルートまたは発信ルートにルート マップを適用します。

省略可能な % キーワードは、IPv6 リンクローカル アドレス ID です。このキーワードは、リンクローカル IPv6 アドレスがそのインターフェイスのコンテキスト外で使用される場合は、追加する必要があります。

ステップ 9

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

ステップ 10

ステップ 9 を繰り返します。

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 11

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map nh6 permit 10

ルート マップを定義し、ルート マップ コンフィギュレーション モードを開始します。

ステップ 12

match ipv6 address { prefix-list prefix-list-name | access-list-name }

 

Router(config-route-map)# match ipv6 address prefix-list cisco

プレフィクス リストで許可されている宛先 IPv6 ネットワーク番号アドレスを持つすべてのルートを配布するか、パケットに対してポリシー ルーティングを実行します。

ステップ 13

set ipv6 next-hop ipv6-address [ link-local-address ] [ peer-address ]

 

Router(config-route-map)# set ipv6 next-hop 2001:DB8::1

ポリシー ルーティング用のルート マップの match 句を渡す IPv6 パケットのピアにアドバタイズされるネクストホップを上書きします。

ipv6-address 引数では、ネクストホップの IPv6 グローバル アドレスを指定します。隣接ルータである必要はありません。

link-local-address 引数では、ネクストホップの IPv6 リンクローカル アドレスを指定します。隣接ルータである必要があります。

引数で指定したインターフェイスのリンクローカル アドレスが、BGP アップデートのネクストホップとして含まれています。したがって、リンクローカル アドレスを使用する複数の BGP ピアに必要となるのは、BGP アップデートにグローバル IPv6 ネクストホップ アドレスを設定する 1 つのルート マップだけとなります。

トラブルシューティングのヒント

この作業でピアリングが確立されなかった場合、ルート マップの set ipv6 next-hop コマンドの欠落が原因である可能性があります。 debug bgp ipv6 update コマンドを使用して、アップデートに関するデバッグ情報を表示し、ピアリングの状態の識別に役立てます。

IPv6 マルチプロトコル BGP ピア グループの設定

制約事項

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。IPv6 プレフィクスなどの他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプ(IPv6 プレフィクスなど)のアドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要もあります。

デフォルトでは、 neighbor peer-group コマンドを使用してルータ コンフィギュレーション モードで定義されたピア グループは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。IPv6 プレフィクスなどの他のプレフィクス タイプを交換するには、その他のプレフィクス タイプ(IPv6 プレフィクスなど)のアドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ピア グループをアクティブ化する必要があります。

ピア グループのメンバは、そのピア グループのアドレス プレフィクス設定を自動的に継承します。

アクティブな IPv4 ネイバーは、アクティブな IPv6 ネイバーと同じピア グループに存在することはできません。IPv4 ピアと IPv6 ピア用に個別のピア グループを作成します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor peer-group-name peer-group

5. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

6. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

7. neighbor { ip-address | peer-group-name | ipv6-address % } activate

8. neighbor { ip-address | ipv6-address } send-label

9. neighbor { ip-address | ipv6-address } peer-group peer-group-name

10. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定した BGP ルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor peer-group-name peer-group

 

Router(config-router)# neighbor group1 peer-group

マルチプロトコル BGP ピア グループを作成します。

ステップ 5

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

 

Router(config-router)# neighbor 2001:DB8:0:CC00::1 remote-as 64600

指定した自律システム内のネイバーの IPv6 アドレスを、ローカル ルータの IPv6 マルチプロトコル BGP ネイバーテーブルに追加します。

neighbor remote-as コマンドの ipv6-address 引数は、RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

ステップ 6

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6 unicast

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードでは、 IPv6 マルチキャスト アドレス プレフィクス を指定します。

ステップ 7

neighbor { ip-address | peer-group-name | ipv6-address % } activate

 

Router(config-router-af)# neighbor 2001:DB8:0:CC00::1 activate

ネイバーが、指定したファミリ タイプのプレフィクスをネイバーおよびローカル ルータと交換できるようにします。

各ネイバーでの追加の設定手順を回避するために、この手順の代替として、 peer-group-name 引数を指定して neighbor activate コマンドを使用します。

ステップ 8

neighbor { ip-address | ipv6-address } send-label

 

Router(config-router-af)# neighbor 192.168.99.70 send-label

BGP ルートとともに MPLS ラベルを送信するルータの機能をアドバタイズします。

IPv6 アドレス ファミリ コンフィギュレーション モードでは、このコマンドによって、BGP の IPv6 プレフィクスのアドバタイズ時に集約ラベルをバインドおよびアドバタイズできるようになります。

ステップ 9

neighbor { ip-address | ipv6-address } peer-group peer-group-name

 

Router(config-router-af)# neighbor 2001:DB8:0:CC00::1 peer-group group1

BGP ネイバーの IPv6 アドレスをピア グループに割り当てます。

ステップ 10

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

このステップを繰り返して、ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

IPv6 マルチプロトコル BGP へのルートのアドバタイズ

制約事項

デフォルトでは、 network コマンドを使用してルータ コンフィギュレーション モードで定義されたネットワークは、IPv4 ユニキャスト データベースに挿入されます。ネットワークを IPv6 BGP データベースなどの他のデータベースに挿入するには、他のデータベース(IPv6 BGP データベースなど)のアドレス ファミリ コンフィギュレーション モードで network コマンドを使用して、ネットワークを定義する必要があります。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

5. network { network-number [ mask network-mask ] | nsap-prefix } [ route-map map-tag ]

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定した BGP ルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6 unicast

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードでは、 IPv6 マルチキャスト アドレス プレフィクス を指定します。

ステップ 5

network { network-number [ mask network-mask ] | nsap-prefix } [ route-map map-tag ]

 

Router(config-router-af)# network 2001:DB8::/24

指定したプレフィクスを IPv6 BGP データベースにアドバタイズ(挿入)します(ルートは、まず IPv6 ユニキャスト ルーティング テーブルで検索される必要があります)。

具体的には、前の手順で指定したアドレス ファミリのデータベースにプレフィクスが挿入されます。

ルートには指定したプレフィクスによって「local origin」のタグが付けられます。

network コマンドの ipv6-prefix 引数は、RFC 2373 に記載された形式にする必要があり、16 ビット値をコロンで区切った 16 進でアドレスを指定します。

prefix-length 引数は、アドレスのうち連続する上位何ビットがプレフィクス(アドレスのネットワーク部)を構成するかを示す 10 進数値です。10 進数値の前にスラッシュ記号が必要です。

ステップ 6

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

この手順を繰り返して、ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定

制約事項

デフォルトでは、ルータ コンフィギュレーション モードで neighbor remote-as コマンドを使用して定義したネイバーは、IPv4 ユニキャスト アドレス プレフィクスだけを交換します。IPv6 プレフィクスなどの他のアドレス プレフィクス タイプを交換するには、その他のプレフィクス タイプ(IPv6 プレフィクスなど)のアドレス ファミリ コンフィギュレーション モードで neighbor activate コマンドを使用して、ネイバーをアクティブ化する必要もあります。

デフォルトでは、 neighbor route-map コマンドを使用してルータ コンフィギュレーション モードで適用されるルート マップは、IPv4 ユニキャスト アドレス プレフィクスだけに適用されます。IPv6 アドレス ファミリなどのその他のアドレス ファミリのルート マップは、 neighbor route-map コマンドを使用してアドレス ファミリ コンフィギュレーション モードで適用される必要があります。ルート マップは、指定したアドレス ファミリの下にあるネイバーの着信ルーティング ポリシーまたは発信ルーティング ポリシーとして適用されます。各アドレス ファミリ タイプで個別のルート マップを設定すると、各アドレス ファミリの複雑なポリシーまたはさまざまなポリシーを簡単に管理できるようになります。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

5. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

6. neighbor { ip-address | peer-group-name | ipv6-address % } activate

7. neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

8. exit

9. ステップ 8 を繰り返します。

10. route-map map-tag [ permit | deny ] [ sequence-number ]

11. match ipv6 address { prefix-list prefix-list-name | access-list-name }

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

 

Router(config-router)# neighbor 2001:DB8:0:cc00::1 remote-as 64600

指定したリモート自律システム内のネイバーのリンクローカル IPv6 アドレスをローカル ルータの IPv6 マルチプロトコル BGP ネイバーテーブルに追加します。

ステップ 5

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 6

neighbor { ip-address | peer-group-name | ipv6-address % } activate

 

Router(config-router-af)# neighbor 2001:DB8:0:cc00::1 activate

ネイバーが、指定したリンクローカル アドレスを使用して IPv6 アドレス ファミリのプレフィクスをローカル ルータと交換できるようにします。

ステップ 7

neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

 

Router(config-router-af)# neighbor 2001:DB8:0:cc00::1 route-map rtp in

着信ルートまたは発信ルートにルート マップを適用します。

ルート マップへの変更は、ピアリングがリセットされるまで、またはソフト リセットが実行されるまで、現在のピアでは有効になりません。 soft キーワードと in キーワードを指定して clear bgp ipv6 コマンドを使用すると、ソフト リセットが実行されます。

ステップ 8

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

ステップ 9

ステップ 8 を繰り返します。

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 10

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map rtp permit 10

ルート マップを定義し、ルート マップ コンフィギュレーション モードを開始します。

match コマンドを使用して、この手順を実行します。

ステップ 11

match ipv6 address { prefix-list prefix-list-name | access-list-name }

 

Router(config-route-map)# match ipv6 address prefix-list cisco

プレフィクス リストで許可されている宛先 IPv6 ネットワーク番号アドレスを持つすべてのルートを配布するか、パケットに対してポリシー ルーティングを実行します。

IPv6 マルチプロトコル BGP へのプレフィクスの再配布

再配布は、あるルーティング プロトコルから別のルーティング プロトコルにプレフィクスを再配布(挿入)するプロセスです。ここでは、あるルーティング プロトコルのプレフィクスを IPv6 マルチプロトコル BGP に挿入する方法について説明します。具体的には、 redistribute ルータ コンフィギュレーション コマンドを使用して IPv6 マルチプロトコル BGP に再配布されたプレフィクスが、IPv6 ユニキャスト データベースに挿入されます。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

5. redistribute bgp [ process-id ] [ metric metric-value ] [ route-map map-name ] [ source-protocol-options ]

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定した BGP ルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 5

redistribute bgp [ process-id ] [ metric metric-value ] [ route-map map-name ] [ source-protocol-options ]

 

Router(config-router-af)# redistribute bgp 64500 metric 5 metric-type external

あるルーティング ドメインから別のルーティング ドメインへ IPv6 ルートを再配布します。

ステップ 6

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

このステップを繰り返して、ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

IPv6 BGP ピア間での IPv4 ルートのアドバタイズ

IPv6 ネットワークが 2 つの個別の IPv4 ネットワークに接続されている場合、IPv6 を使用して IPv4 ルートをアドバタイズできます。IPv4 アドレス ファミリ内で IPv6 アドレスを使用してピアリングを設定します。アドバタイズされるネクストホップは、通常、到着不能であるため、スタティック ルートまたはインバウンド ルート マップを使用してネクストホップを設定します。2 つの IPv4 ピア間での IPv6 ルートのアドバタイズでは、同じモデルを使用することもできます。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor peer-group-name peer-group

5. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

6. address-family ipv4 [ mdt | multicast | tunnel | unicast [ vrf vrf-name ] | vrf vrf-name ]

7. neighbor ipv6-address peer-group peer-group-name

8. neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

9. exit

10. ステップ 11 を繰り返します。

11. route-map map-tag [ permit | deny ] [ sequence-number ]

12. set ip next-hop ip-address [ ... ip-address ] [ peer-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

neighbor peer-group-name peer-group

 

Router(config-router)# neighbor 6peers peer-group

マルチプロトコル BGP ピア グループを作成します。

ステップ 5

neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number [ alternate-as autonomous-system-number ...]

 

Router(config-router)# neighbor 6peers remote-as 65002

指定した自律システム内のネイバーの IPv6 アドレスを、ローカル ルータの IPv6 マルチプロトコル BGP ネイバーテーブルに追加します。

ステップ 6

address-family ipv4 [ mdt | multicast | tunnel | unicast [ vrf vrf-name ] | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始し、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 7

neighbor ipv6-address peer-group peer-group-name

 

Router(config-router-af)# neighbor 2001:DB8:yyyy::2 peer-group 6peers

BGP ネイバーの IPv6 アドレスをピア グループに割り当てます。

ステップ 8

neighbor { ip-address | peer-group-name | ipv6-address [ % ]} route-map map-name { in | out }

 

Router(config-router-af)# neighbor 6peers route-map rmap out

着信ルートまたは発信ルートにルート マップを適用します。

ルート マップへの変更は、ピアリングがリセットされるまで、またはソフト リセットが実行されるまで、現在のピアでは有効になりません。 soft キーワードと in キーワードを指定して clear bgp ipv6 コマンドを使用すると、ソフト リセットが実行されます。

ステップ 9

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータをルータ コンフィギュレーション モードに戻します。

ステップ 10

ステップ 11 を繰り返します。

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、ルータをグローバル コンフィギュレーション モードに戻します。

ステップ 11

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map rmap permit 10

ルート マップを定義し、ルート マップ コンフィギュレーション モードを開始します。

ステップ 12

set ip next-hop ip-address [... ip-address ] [ peer-address ]

 

Router(config-route-map)# set ip next-hop 10.21.8.10

ピアにアドバタイズされる IPv4 パケットのネクストホップを上書きします。

BGP の管理ディスタンスの割り当て

RPF ルックアップでユニキャスト ルートとの比較に使用されるマルチキャスト BGP ルートの管理ディスタンスを指定するには、次の作業を実行します。


注意 BGP 内部ルートの管理ディスタンスを変更することは、推奨されません。発生する可能性のある 1 つの問題は、ルーティング テーブルの不整合が累積され、それによってルーティングが中断する可能性があることです。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

5. distance bgp external-distance internal-distance local-distance

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 5

distance bgp external-distance internal-distance local-distance

 
Router(config-router-af)# distance bgp 10 50 100

BGP ルートの管理ディスタンスを設定します。

IPv6 マルチキャスト BGP の変換アップデートの生成

ピアから受信したユニキャスト IPv6 アップデートに対応する IPv6 マルチキャスト BGP アップデートを生成するには、次の作業を実行します。

MBGP 変換アップデート機能は、一般に、BGP 対応ルータだけを持つカスタマー サイト(つまり、ルータを MBGP 対応イメージにアップグレードしていない、またはアップグレードできないカスタマー サイト)とピアリングする MBGP 対応ルータで使用されます。そのカスタマー サイトでは MBGP アドバタイズメントを発信できないため、カスタマー サイトがピアリングするルータは、BGP プレフィクスを、マルチキャストソース Reverse Path Forwarding(RPF)ルックアップに使用される MBGP プレフィクスに変換します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

5. neighbor ipv6-address translate-update ipv6 multicast [ unicast ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

unicast キーワードでは、IPv6 ユニキャスト アドレス ファミリを指定します。デフォルトでは、 address-family ipv6 コマンドで unicast キーワードを指定しない場合、ルータは IPv6 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

multicast キーワードは、IPv6 マルチキャスト アドレス プレフィクスを指定します。

ステップ 5

neighbor ipv6-address translate-update ipv6 multicast [ unicast ]
 
Router(config-router-af)# neighbor 7000::2 translate-update ipv6 multicast

ピアから受信したユニキャスト IPv6 アップデートに対応するマルチプロトコル IPv6 BGP アップデートを生成します。

IPv6 BGP グレースフル リスタート機能の設定

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

5. bgp graceful-restart [ restart-time seconds | stalepath-time seconds ] [ all ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

指定したルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv6 [ vrf vrf-name ] [ unicast | multicast | vpnv6 ]

 

Router(config-router)# address-family ipv6

IPv6 アドレス ファミリを指定します。

ステップ 5

bgp graceful-restart [ restart-time seconds | stalepath-time seconds ] [ all ]

 

Router(config-router)# bgp graceful-restart

BGP グレースフル リスタート機能をイネーブルにします。

BGP セッションのリセット

手順の概要

1. enable

2. clear bgp ipv6 { unicast | multicast } { * | autonomous-system-number | ip- address | ipv6-address | peer-group-name } [ soft ] [ in | out ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

clear bgp ipv6 { unicast | multicast } { * | autonomous-system-number | ip-address | ipv6-address | peer-group-name } [ soft ] [ in | out ]

 

Router# clear bgp ipv6 unicast peer-group marketing soft out

IPv6 BGP セッションをリセットします。

外部 BGP ピアのクリア

手順の概要

1. enable

2. clear bgp ipv6 { unicast | multicast } external [ soft ] [ in | out ]

3. clear bgp ipv6 { unicast | multicast } peer-group [ name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

clear bgp ipv6 { unicast | multicast } external [ soft ] [ in | out ]

 

Router# clear bgp ipv6 unicast external soft in

外部 IPv6 BGP ピアをクリアします。

ステップ 3

clear bgp ipv6 { unicast | multicast } peer-group [ name ]

 

Router# clear bgp ipv6 unicast peer-group

IPv6 BGP ピア グループのすべてのメンバをクリアします。

IPv6 BGP ルート減衰情報のクリア

手順の概要

1. enable

2. clear bgp ipv6 { unicast | multicast } dampening [ ipv6-prefix / prefix-length ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

clear bgp ipv6 { unicast | multicast } dampening [ ipv6-prefix / prefix-length ]

 
Router# clear bgp ipv6 unicast dampening 2001:DB8::/64

IPv6 BGP ルート減衰情報をクリアし、抑制ルートの抑制を解除します。

IPv6 BGP フラップ統計情報のクリア

手順の概要

1. enable

2. clear bgp ipv6 { unicast | multicast } flap-statistics [ ipv6-prefix / prefix-length | regexp regexp | filter-list list ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

clear bgp ipv6 { unicast | multicast } flap-statistics [ ipv6-prefix / prefix-length | regexp regexp | filter-list list ]

 
Router# clear bgp ipv6 unicast flap-statistics filter-list 3

IPv6 BGP フラップ統計情報をクリアします。

IPv6 マルチプロトコル BGP の設定および動作の確認

手順の概要

1. show bgp ipv6 { unicast | multicast } [ ipv6-prefix / prefix-length ] [ longer-prefixes ] [ labels ]

2. show bgp ipv6 { unicast | multicast } summary

3. show bgp ipv6 { unicast | multicast } dampening dampened-paths

4. enable

5. debug bgp ipv6 { unicast | multicast } dampening [ prefix-list prefix-list-name ]

6. debug bgp ipv6 { unicast | multicast } updates [ ipv6-address ] [ prefix-list prefix-list-name ] [ in | out ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

show bgp ipv6 { unicast | multicast } [ ipv6-prefix / prefix-length ] [ longer-prefixes ] [ labels ]

 

Router> show bgp ipv6 unicast

(任意)IPv6 BGP ルーティング テーブルのエントリを表示します。

ステップ 2

show bgp ipv6 { unicast | multicast } summary

 

Router> show bgp ipv6 unicast summary

(任意)すべての IPv6 BGP 接続のステータスを表示します。

ステップ 3

show bgp ipv6 { unicast | multicast } dampening dampened-paths

 

Router> show bgp ipv6 unicast dampening dampened-paths

(任意)IPv6 BGP 減衰ルートを表示します。

ステップ 4

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 5

debug bgp ipv6 { unicast | multicast } dampening [ prefix-list prefix-list-name ]

 

Router# debug bgp ipv6 unicast dampening

(任意)IPv6 BGP 減衰パケットのデバッグ情報を表示します。

プレフィクス リストが指定されていない場合は、すべての IPv6 BGP 減衰パケットのデバッグ メッセージが表示されます。

ステップ 6

debug bgp ipv6 { unicast | multicast } updates [ ipv6-address ] [ prefix-list prefix-list-name ] [ in | out ]

 

Router# debug bgp ipv6 unicast updates

(任意)IPv6 BGP アップデート パケットのデバッグ情報を表示します。

ipv6-address 引数が指定されている場合は、指定したネイバーへの IPv6 BGP アップデートのデバッグ メッセージが表示されます。

in キーワードを使用して、インバウンド アップデートのデバッグ メッセージだけを表示するようにします。

out キーワードを使用して、アウトバウンド アップデートのデバッグ メッセージだけを表示するようにします。

show bgp ipv6 コマンドの出力例

show bgp ipv6 summary コマンドの出力例

show bgp ipv6 dampened-paths コマンドの出力例

debug bgp ipv6 dampening コマンドの出力例

debug bgp ipv6 updates コマンドの出力例

show bgp ipv6 コマンドの出力例

次の例では、IPv6 BGP ルーティング テーブルのエントリが、 show bgp ipv6 コマンドを使用して表示されています。

Router> show bgp ipv6 unicast
 
BGP table version is 12612, local router ID is 192.168.99.70
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
*> 2001:DB8:E:C::2 0 3748 4697 1752 i
* 2001:DB8:0:CC00::1
0 1849 1273 1752 i
* 2001:618:3::/48 2001:DB8:E:4::2 1 0 4554 1849 65002 i
*> 2001:DB8:0:CC00::1
0 1849 65002 i
*> 2001:620::/35 2001:DB8:0:F004::1
0 3320 1275 559 i
* 2001:DB8:E:9::2 0 1251 1930 559 i
* 2001:DB8::A 0 3462 10566 1930 559 i
* 2001:DB8:20:1::11
0 293 1275 559 i
* 2001:DB8:E:4::2 1 0 4554 1849 1273 559 i
* 2001:DB8:E:B::2 0 237 3748 1275 559 i
* 2001:DB8:E:C::2 0 3748 1275 559 i

show bgp ipv6 summary コマンドの出力例

次の例では、すべての IPv6 BGP 接続のステータスが、 unicast キーワードを指定した show bgp ipv6 summary コマンドを使用して表示されています。

Router# show bgp ipv6 unicast summary
 
BGP router identifier 172.30.4.4, local AS number 200
BGP table version is 1, main routing table version 1
 
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:DB8:101::2 4 200 6869 6882 0 0 0 06:25:24 Active

show bgp ipv6 dampened-paths コマンドの出力例

次の例では、IPv6 BGP 減衰ルートが、 unicast キーワードを指定した show bgp ipv6 dampened-paths コマンドを使用して表示されています。

Router# show bgp ipv6 unicast dampening dampened-paths
 
BGP table version is 12610, local router ID is 192.168.7.225
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network From Reuse Path
*d 3FFE:1000::/24 3FFE:C00:E:B::2 00:00:10 237 2839 5609 i
*d 2001:228::/35 3FFE:C00:E:B::2 00:23:30 237 2839 5609 2713 i

debug bgp ipv6 dampening コマンドの出力例

次の例では、IPv6 BGP 減衰パケットのデバッグ メッセージが、 unicast キーワードを指定した debug bgp ipv6 dampening コマンドを使用して表示されています。


) デフォルトでは、debug コマンドからの出力、およびシステム エラー メッセージがコンソールに送信されます。デバッグ出力をリダイレクトするには、コンフィギュレーション モードで logging コマンド オプションを使用します。指定できる宛先として、コンソール、仮想端末、内部バッファ、および syslog サーバを実行している UNIX ホストがあります。debug コマンドおよびデバッグ出力のリダイレクトの詳細については、『Cisco IOS Debug Command Reference』を参照してください。


Router# debug bgp ipv6 unicast dampening
 
00:13:28:BGP(1):charge penalty for 2001:DB8:0:1::/64 path 2 1 with halflife-time 15 reuse/suppress 750/2000
00:13:28:BGP(1):flapped 1 times since 00:00:00. New penalty is 1000
00:13:28:BGP(1):charge penalty for 2001:DB8:0:1:1::/80 path 2 1 with halflife-time 15 reuse/suppress 750/2000
00:13:28:BGP(1):flapped 1 times since 00:00:00. New penalty is 1000
00:13:28:BGP(1):charge penalty for 2001:DB8:0:5::/64 path 2 1 with halflife-time 15 reuse/suppress 750/2000
00:13:28:BGP(1):flapped 1 times since 00:00:00. New penalty is 1000
00:16:03:BGP(1):charge penalty for 2001:DB8:0:1::/64 path 2 1 with halflife-time 15 reuse/suppress 750/2000
00:16:03:BGP(1):flapped 2 times since 00:02:35. New penalty is 1892
00:18:28:BGP(1):suppress 2001:DB8:0:1:1::/80 path 2 1 for 00:27:30 (penalty 2671)
00:18:28:halflife-time 15, reuse/suppress 750/2000
00:18:28:BGP(1):suppress 2001:DB8:0:1::/64 path 2 1 for 00:27:20 (penalty 2664)
00:18:28:halflife-time 15, reuse/suppress 750/2000

debug bgp ipv6 updates コマンドの出力例

次の例では、IPv6 BGP アップデート パケットのデバッグ メッセージが、 unicast キーワードを指定した debug bgp ipv6 updates コマンドを使用して表示されています。

Router# debug bgp ipv6 unicast updates
 
14:04:17:BGP(1):2001:DB8:0:2::2 computing updates, afi 1, neighbor version 0, table version 1, starting at ::
14:04:17:BGP(1):2001:DB8:0:2::2 update run completed, afi 1, ran for 0ms, neighbor version 0, start version 1, throttled to 1
14:04:19:BGP(1):sourced route for 2001:DB8:0:2::1/64 path #0 changed (weight 32768)
14:04:19:BGP(1):2001:DB8:0:2::1/64 route sourced locally
14:04:19:BGP(1):2001:DB8:0:2:1::/80 route sourced locally
14:04:19:BGP(1):2001:DB8:0:3::2/64 route sourced locally
14:04:19:BGP(1):2001:DB8:0:4::2/64 route sourced locally
14:04:22:BGP(1):2001:DB8:0:2::2 computing updates, afi 1, neighbor version 1, table version 6, starting at ::
14:04:22:BGP(1):2001:DB8:0:2::2 send UPDATE (format) 2001:DB8:0:2::1/64, next 2001:DB8:0:2::1, metric 0, path
14:04:22:BGP(1):2001:DB8:0:2::2 send UPDATE (format) 2001:DB8:0:2:1::/80, next 2001:DB8:0:2::1, metric 0, path
14:04:22:BGP(1):2001:DB8:0:2::2 send UPDATE (prepend, chgflags:0x208) 2001:DB8:0:3::2/64, next 2001:DB8:0:2::1, metric 0, path
14:04:22:BGP(1):2001:DB8:0:2::2 send UPDATE (prepend, chgflags:0x208) 2001:DB8:0:4::2/64, next 2001:DB8:0:2::1, metric 0, path

マルチプロトコル BGP for IPv6 の設定例

「例:BGP プロセス、BGP ルータ ID、および IPv6 マルチプロトコル BGP ピアの設定」

「例:リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定」

「例:IPv6 マルチプロトコル BGP ピア グループの設定」

「例:IPv6 マルチプロトコル BGP へのルートのアドバタイズ」

「例:IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定」

「例:IPv6 マルチプロトコル BGP へのプレフィクスの再配布」

「例:IPv6 ピア間での IPv4 ルートのアドバタイズ」

例:BGP プロセス、BGP ルータ ID、および IPv6 マルチプロトコル BGP ピアの設定

次の例では、IPv6 をグローバルにイネーブルにし、BGP プロセスを設定して BGP ルータ ID を確立します。また、IPv6 マルチプロトコル BGP ピア 2001:DB8:0:CC00:: も設定およびアクティブ化されます。

ipv6 unicast-routing
!
router bgp 65000
no bgp default ipv4-unicast
bgp router-id 192.168.99.70
neighbor 2001:DB8:0:CC00::1% remote-as 64600
 
address-family ipv6 unicast
neighbor 2001:DB8:0:CC00::1% activate

例:リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定

次の例では、ファスト イーサネット インターフェイス 0 上で IPv6 マルチプロトコル BGP ピア FE80::XXXX:BFF:FE0E:A471 を設定し、ファスト イーサネット インターフェイス 0 の IPv6 ネクストホップ グローバル アドレスを BGP アップデートに含めるために nh6 という名前のルート マップを設定します。IPv6 ネクストホップ リンクローカル アドレスは、nh6 ルート マップ(次の例では示されていません)によって、または neighbor update-source コマンド(次の例で示しています)で指定したインターフェイスから設定できます。

router bgp 65000
neighbor FE80::XXXX:BFF:FE0E:A471 remote-as 64600
neighbor FE80::XXXX:BFF:FE0E:A471 update-source fastethernet 0
 
address-family ipv6
neighbor FE80::XXXX:BFF:FE0E:A471 activate
neighbor FE80::XXXX:BFF:FE0E:A471 route-map nh6 out
 
route-map nh6 permit 10
match ipv6 address prefix-list cisco
set ipv6 next-hop 2001:DB8:5y6::1
 
ipv6 prefix-list cisco permit 2001:DB8:2Fy2::/48 le 128
ipv6 prefix-list cisco deny ::/0

neighbor update-source コマンドでネイバー インターフェイス(interface-type 引数)を指定したあとに、set ipv6 next-hop コマンドでグローバル IPv6 ネクストホップ アドレス(ipv6-address 引数)だけを指定している場合は、interface-type 引数で指定したインターフェイスのリンクローカル アドレスが BGP アップデートのネクストホップとして含まれています。したがって、リンクローカル アドレスを使用する複数の BGP ピアに必要となるのは、BGP アップデートにグローバル IPv6 ネクストホップ アドレスを設定する 1 つのルート マップだけとなります。


例:IPv6 マルチプロトコル BGP ピア グループの設定

次に、group1 という名前の IPv6 マルチプロトコル BGP ピア グループを設定する例を示します。

router bgp 65000
no bgp default ipv4-unicast
neighbor group1 peer-group
neighbor 2001:DB8:0:CC00::1 remote-as 64600
 
address-family ipv6 unicast
neighbor group1 activate
neighbor 2001:DB8:0:CC00::1 peer-group group1

例:IPv6 マルチプロトコル BGP へのルートのアドバタイズ

次に、ローカル ルータの IPv6 ユニキャスト データベースに IPv6 ネットワーク 2001:DB8::/24 を挿入する例を示します(BGP は、ネットワークをアドバタイズする前に、ネットワークのルートがローカル ルータの IPv6 ユニキャスト データベースに存在することを確認します)。

router bgp 65000
no bgp default ipv4-unicast
 
address-family ipv6 unicast
network 2001:DB8::/24

例:IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定

次に、rtp という名前のルート マップを設定して、ネットワーク 2001:DB8::/24 からの IPv6 ユニキャスト ルートが cisco という名前のプレフィクス リストに一致する場合は、その IPv6 ユニキャスト ルートを許可する例を示します。

router bgp 64900
no bgp default ipv4-unicast
neighbor 2001:DB8:0:CC00::1 remote-as 64700
 
address-family ipv6 unicast
neighbor 2001:DB8:0:CC00::1 activate
neighbor 2001:DB8:0:CC00::1 route-map rtp in
 
ipv6 prefix-list cisco seq 10 permit 2001:DB8::/24
 
route-map rtp permit 10
match ipv6 address prefix-list cisco

例:IPv6 マルチプロトコル BGP へのプレフィクスの再配布

次の例では、RIP ルートをローカル ルータの IPv6 ユニキャスト データベースに再配布しています。

router bgp 64900
no bgp default ipv4-unicast
address-family ipv6 unicast
redistribute rip

例:IPv6 ピア間での IPv4 ルートのアドバタイズ

次の例では、IPv6 ネットワークが 2 つの個別 IPv4 ネットワークに接続している場合に、IPv6 ピア間で IPv4 ルートをアドバタイズしています。ピアリングは、IPv4 アドレス ファミリ コンフィギュレーション モードで IPv6 アドレスを使用して設定されています。アドバタイズされたネクストホップは到達不能である可能性があるため、rmap という名前のインバウンド ルート マップによってネクストホップが設定されます。

router bgp 65000
!
neighbor 6peers peer-group
neighbor 2001:DB8:yyyy::2 remote-as 65002
address-family ipv4
neighbor 6peers activate
neighbor 6peers soft-reconfiguration inbound
neighbor 2001:DB8:yyyy::2 peer-group 6peers
neighbor 2001:DB8:yyyy::2 route-map rmap in
!
route-map rmap permit 10
set ip next-hop 10.21.8.10

その他の関連資料

関連資料

関連項目
参照先

IPv4 BGP の設定作業

Cisco IOS IP Routing Protocols Configuration Guide』の「 BGP Features Roadmap

マルチプロトコル BGP の設定作業

Cisco IOS IP Routing Protocols Configuration Guide 』の「 BGP Features Roadmap

BGP およびマルチプロトコル BGP コマンド:complete コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

Cisco IOS IP Routing Protocols Command Reference 』の「 BGP Commands

Cisco ノンストップ フォワーディング

Cisco IOS High Availability Configuration Guide 』の「 Cisco Nonstop Forwarding

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2545

『Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain Routing』

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 4007

『IPv6 Scoped Address Architecture』

RFC 4364

『BGP MPLS/IP Virtual Private Networks (VPNs)』

RFC 4382

『MPLS/BGP Layer 3 Virtual Private Network (VPN) Management Information Base』

RFC 4659

『BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPN』

RFC 4724

『Graceful Restart Mechanism for BGP』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

マルチプロトコル BGP for IPv6 の実装の機能情報

表1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator により、どのソフトウェア イメージが特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表1には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表1 マルチプロトコル BGP for IPv6 の実装の機能情報

機能名
リリース
機能情報

6PE マルチパス

12.2(25)S 12.2(28)SB 12.2(33)SRA
12.2(33)SXI1
12.4(6)T

6PE マルチパス機能では、Multiprotocol internal BGP(MP-iBGP; マルチプロトコル内部 BGP)を使用して、MPLS IPv4 コア ネットワークを介して IPv6 ルートを配布し、MPLS ラベルを各ルートに付加します。

この機能に関する詳細については、次の各項を参照してください。

「6PE マルチパス」

IPv6 マルチプロトコル BGP へのルートのアドバタイズ

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

ユーザは、プレフィクスを IPv6 マルチプロトコル BGP にアドバタイズ(挿入)します。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 マルチプロトコル BGP へのルートのアドバタイズ」

「例:IPv6 マルチプロトコル BGP へのルートのアドバタイズ」

IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定

12.0(22)S
12.2(14)S
12.2(28)SB
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

ユーザは、IPv6 マルチプロトコル BGP プレフィクスのルート マップを設定できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定」

「例:IPv6 マルチプロトコル BGP プレフィクスのルート マップの設定」

IPv6:MP-BGP IPv6 アドレス ファミリの NSF およびグレースフル リスタート

12.2(33)SRE
12.2(33)XNE

グレースフル リスタート機能は、IPv6 BGP ユニキャスト、IPv6 BGP マルチキャスト、および VPNv6 アドレス ファミリでサポートされており、BGP IPv6 用の Cisco NonStop Forwarding(NSF; ノンストップ フォワーディング)機能をイネーブルにします。BGP グレースフル リスタート機能を使用すると、TCP 状態を維持することなく、BGP ルーティング テーブルをピアから回復できます。

この機能については、次の項に説明があります。

「MP-BGP IPv6 アドレス ファミリのノンストップ フォワーディングおよびグレースフル リスタート」

「IPv6 BGP グレースフル リスタート機能の設定」

IPv6 マルチキャスト アドレス ファミリでのマルチプロトコル BGP のサポート

12.0(26)S 12.2(25)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA 12.2(33)SXH 12.3(4)T
12.4
12.4(2)T

IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP 機能では、マルチプロトコル BGP for IPv6 拡張を提供し、IPv4 BGP と同じ機能と機能性をサポートします。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 マルチキャスト アドレス ファミリのマルチプロトコル BGP」

「マルチプロトコル BGP for IPv6 の実装方法」

IPv6 ルーティング:マルチプロトコル BGP for IPv6 拡張

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX1
12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

マルチプロトコル BGP for IPv6 拡張では、IPv4 BGP と同じ機能および機能性がサポートされています。

この機能に関する詳細については、次の各項を参照してください。

「マルチプロトコル BGP for IPv6 拡張」

「マルチプロトコル BGP for IPv6 の実装方法」

IPv6 ルーティング:マルチプロトコル BGP リンクローカル アドレス ピアリング

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(25)SG 12.2(33)SRA
12.2(17a)SX112.2(4)T
12.3
12.3(2)T
12.4
12.4(2)T
15.0(1)S

IPv6 では、マルチプロトコル BGP リンクローカル アドレス ピアリングをサポートしています。

この機能に関する詳細については、次の各項を参照してください。

「リンクローカル アドレスを使用した IPv6 マルチプロトコル BGP ピアの設定」

IPv6 マルチプロトコル BGP へのプレフィクスの再配布

12.0(22)S 12.2(14)S 12.2(28)SB 12.2(2)T
12.3
12.3(2)T
12.4
12.4(2)T

ユーザは、別のルーティング プロトコルから IPv6 マルチプロトコル BGP にプレフィクスを再配布(挿入)できます。

この機能に関する詳細については、次の各項を参照してください。

「IPv6 マルチプロトコル BGP へのプレフィクスの再配布」

「例:IPv6 マルチプロトコル BGP へのプレフィクスの再配布」

IPv6 に対する VRF Lite サポート

12.2(58)SE

この機能は、サポートされています。