IPv6 コンフィギュレーション ガイド Cisco IOS Release M&T
IPv6 への ADSL の実装およびダイヤル アク セスの展開
IPv6 への ADSL の実装およびダイヤル アクセスの展開
発行日;2012/05/10 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

IPv6 への ADSL の実装およびダイヤル アクセスの展開

機能情報の確認

目次

IPv6 の ADSL およびダイヤル アクセスの実装の前提条件

IPv6 への ADSL の実装およびダイヤル アクセスの展開の制約事項

IPv6 への ADSL の実装およびダイヤル アクセスの展開に関する情報

IPv6 のアドレス割り当て

ステートレス アドレス自動設定

プレフィクス委任

AAA over IPv6

RADIUS over IPv6

TACACS+ Over IPv6

IPv6 プレフィクス プール

IPv6 での ADSL の設定方法とダイヤル アクセスの展開方法

NAS の設定

リモート CE ルータの設定

この次の手順

RADIUS サーバからプレフィクスを取得するよう DHCPv6 サーバを設定

前提条件

DHCPv6 AAA および SIP オプションの設定

TACACS+ over IPv6 の設定

IPv6 を介した TACACS+ サーバの設定

TACACS+ パケットでの送信元アドレスの指定

TACACS+ サーバ グループ オプションの設定

IPv6 の ADSL の実装およびダイヤル アクセスの展開の設定例

例:IPv6 の ADSL の実装およびダイヤル アクセスの展開

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

IPv6 への ADSL の実装およびダイヤル アクセスの展開

この章では、IPv6 でのプレフィクス プールとユーザ単位の RADIUS 属性の実装について説明します。Digital Subscriber Line(DSL; デジタル加入者線)およびダイヤルアクセス環境での IPv6 の展開についても説明します。Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)およびダイヤル展開では、IPv6 RADIUS 属性、PPP リンク上のステートレス アドレス設定、ユーザ単位のスタティック ルート、Access Control List(ACL; アクセス コントロール リスト)など、IPv6 環境での大規模なアクセスを可能にする拡張が提供されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

IPv6 の ADSL およびダイヤル アクセスの実装の前提条件

このマニュアルでは、IPv4 に精通していることを前提としています。

IPv6 の AAA 属性は RFC 3162 に準拠しており、RFC 3162 をサポートできる RADIUS サーバを必要とします。

IPv6 への ADSL の実装およびダイヤル アクセスの展開の制約事項

ADSL およびダイヤル展開は、PPP over ATM(PPPoA)、PPP over Ethernet(PPPoE)、PPP over async、および PPP over ISDN など、PPP カプセル化がイネーブルにされたインターフェイスで使用可能です。

Network Address Translation(NAT; ネットワーク アドレス変換)は、Cisco IOS Release 15.1(1)S の IPv6 TACACS サーバではサポートされません。

IPv6 への ADSL の実装およびダイヤル アクセスの展開に関する情報

「IPv6 のアドレス割り当て」

「AAA over IPv6」

IPv6 のアドレス割り当て

IPv6 が設定された Cisco ルータは、その IPv6 プレフィクスを 1 つ以上のインターフェイスでアドバタイズし、IPv6 クライアントが自身のアドレスを自動的に設定できるようにします。多くの機能が PPP レイヤで処理される IPv4 とは対照的に、IPv6 では、アドレス割り当てはネットワーク レイヤで実行されます。IPv6 Control Protocol(IPv6CP; IPv6 コントロール プロトコル)で処理される機能は、一意のインターフェイス識別子のネゴシエーションだけです。Domain Name Server(DNS; ドメイン ネーム サーバ)サーバ ディスカバリを含むその他すべての機能は、IPv6 プロトコル自体の中で行われます。

IPv4 アドレス割り当てとは対照的に、IPv6 ユーザには、単一アドレスではなくプレフィクスが割り当てられます。通常、ISP は 64 または 48 ビットのプレフィクスを割り当てます。

IPv6 では、ISP は、存続期間の長いプレフィクスをユーザに割り当てます。これは、ルーティング システムに影響を与えます。通常の IPv4 環境では、各 Network Access Server(NAS; ネットワーク アクセス サーバ)には 24 ビット アドレスのプールがあり、ユーザはダイヤルイン時にこのプールからアドレスを取得します。ユーザが、別の Point of Presence(POP; アクセス ポイント)にダイヤルする場合、または同じ POP にある別の NAS に接続されている場合は、異なる IPv4 アドレスが割り当てられます。

IPv6 用のアドレスは、次の項で説明する 2 つの方式で割り当てられます。

「ステートレス アドレス自動設定」

「プレフィクス委任」

ステートレス アドレス自動設定

ステートレス アドレス自動設定方式を使用したアドレスの割り当ては、64 ビット プレフィクスの割り当てだけに使用できます。各ユーザには、Router Advertisement(RA; ルータ アドバタイズメント)でユーザにアドバタイズされる 64 ビット プレフィクスが割り当てられます。すべてのアドレスは、割り当てられたプレフィクスに基づいて自動的に設定されます。

一般的なシナリオでは、ユーザごとに別々の 64 ビット プレフィクスが割り当てられますが、ユーザにアドレスの共有プールからプレフィクスを割り当てることもできます。共有プールを使用すると、アドレスは、ユーザごとに 1 つのアドレスのみに制限されます。

この方式は、Customer Provider Edge(CPE)ルータが単一の PC であるか、1 つのサブネットのみに制限されている場合に最適です。ユーザが複数のサブネットを持つ場合は、レイヤ 2(L2)ブリッジング、マルチリンク サブネット、またはプロキシ RA を使用できます。RA でアドバタイズされたプレフィクスは、Authentication, Authorization, Accounting(AAA; 認証、認可、アカウンティング)サーバから取得できます。このプレフィクスは、プレフィクス属性も提供し、手動で設定するか、プレフィクス プールから割り当てることができます。

Framed-Interface-Id AAA 属性はピアのインターフェイス識別子の選択に影響し、プレフィクスと組み合せて完全な IPv6 アドレスを判断できます。

プレフィクス委任

プレフィクス委任では、Dynamic Host Configuration Protocol(DHCP)を使用します。ユーザがプレフィクス委任元(通常は NAS)にプレフィクスを要求する場合、プレフィクスは「ステートレス アドレス自動設定」で説明するように割り当てられます。

IPv6 プレフィクス委任ルータは、クライアントから要求を受信すると、要求元ルータに割り当てる IPv6 プレフィクスを選択します。委任ルータは、次の方法で要求元ルータのプレフィクスを選択できます。

ISP へのサブスクリプションに基づく静的割り当て

使用可能なプレフィクスのプールからの動的割り当て

Framed-IPv6-Prefix 属性を使用した、RADIUS サーバなどの外部権限に基づく選択(「Framed-IPv6-Prefix」を参照)。

DHCP SIP サーバ オプション

IPv6 Session Initiation Protocol(SIP)サーバ オプションの 2 つの DHCP は、ローカル アウトバウンド SIP プロキシを示します。一方はドメイン名のリストを示し、もう一方は IPv6 アドレスのリストを示します。この 2 つのオプションは、DHCPv6 設定プールで設定できます。

AAA over IPv6

Vendor-Specific Attribute(VSA; ベンダー固有属性)は、IPv6 で AAA をサポートするために開発されました。Cisco VSA は、inacl、outacl、prefix、および route です。

プレフィクス プールとプール名は、AAA を使用して設定できます。お客様は、Cisco IOS ルータと通信するために IPv6 RADIUS または TACACS+ サーバを導入できます。

AAA 機能の詳細については、次の項を参照してください。

「RADIUS over IPv6」

「TACACS+ Over IPv6」

「IPv6 プレフィクス プール」

RADIUS over IPv6

RFC 3162 で説明されているように、次の RADIUS 属性が IPv6 に対してサポートされます。

Framed-Interface-Id

Framed-IPv6-Pool

Framed-IPv6-Prefix

Framed-IPv6-Route

Login-IPv6-Host

これらの属性は、RADIUS サーバで設定して、アクセス サーバにダウンロードして、ここでアクセス接続に適用できます。

IPv6 環境での仮想アクセス用の RADIUS ユーザ単位属性

RADIUS Attribute-Value(AV; 属性値)のペアの次の IPv6 属性が仮想アクセスに対してサポートされます。

「Framed-Interface-Id」

「Framed-IPv6-Pool」

「Framed-IPv6-Prefix」

「Framed-IPv6-Route」

「IPv6 ACL」

「IPv6 Pool」

「IPv6 Prefix#」

「IPv6 Route」

「Login-IPv6-Host」

Framed-Interface-Id

Framed-Interface-Id 属性は、設定する IPv6 インターフェイス識別子を示します。このユーザ単位属性は、IPv6CP ネゴシエーション中に使用され、access-accept パケットでも使用されることがあります。Interface-Identifier IPv6CP オプションが正常にネゴシエーションされた場合は、NAS によって、その値を優先するサーバへの Acc-0Request パケットにこの属性をヒントとして含める必要があります。

Framed-IPv6-Pool

Framed-IPv6-Pool 属性は、ユーザの IPv6 プレフィクスを割り当てるために使用する必要がある割り当て済みプールの名前が含まれる、ユーザ単位属性です。このプールは、ルータでローカルに定義するか、プールをダウンロードできる RADIUS サーバで定義する必要があります。

Framed-IPv6-Prefix

Framed-IPv6-Prefix 属性は、Cisco VSA と同じ機能を実行します。これは、仮想アクセスのみに使用され、設定する IPv6 プレフィクス(および対応するルート)を示しています。この属性はユーザ単位属性であり、ユーザはネイバー ディスカバリ ルータ アドバタイズメント メッセージでアドバタイズするプレフィクスを指定できます。Framed-IPv6-Prefix 属性は、access-accept パケットで使用でき、複数回出現することがあります。NAS では、プレフィクスの対応ルートが作成されます。

DHCP for IPv6 プレフィクス委任にこの属性を使用するには、RADIUS サーバに同じユーザのプロファイルを作成します。2 番目のプロファイルに関連付けられたユーザ名には、サフィクス「-dhcpv6」が付いています。

2 つのプロファイルの Framed-IPv6-Prefix 属性は異なる方法で処理されます。NAS が Router Advertisement(RA; ルータ アドバタイズメント)でのプレフィクスの送信と、リモート ユーザのネットワークへのプレフィクスの委任の両方を行う必要がある場合、RA のプレフィクスは、ユーザの通常のプロファイルの Framed-IPv6-Prefix 属性に配置され、プレフィクス委任に使用されるプレフィクスはユーザの別のプロファイルの属性に配置されます。

Framed-IPv6-Route

Framed-IPv6-Route 属性は、Cisco VSA と同じ機能を実行します。これは、NAS 上のユーザに対して設定するルーティング情報を提供するユーザ単位属性です。この属性は文字列属性であり、 ipv6 route コマンドを使用して指定します。

IPv6 ACL

完全な IPv6 アクセス リストを指定できます。アクセス リストの一意の名前が自動的に生成されます。アクセス リストは、ユーザがログアウトしたときに削除されます。インターフェイス上の以前のアクセス リストが再適用されます。

inacl 属性と outacl 属性では、ルータに特定の既存のアクセス リストを設定できます。次の例では、アクセス リストとして指定された ACL 番号 1 を示します。

cisco-avpair = "ipv6:inacl#1=permit 2001:DB8:cc00:1::/48",
cisco-avpair = "ipv6:outacl#1=deny 2001:DB8::/10",

IPv6 Pool

RADIUS 認証では、IPv6 Pool 属性は、IPv6 プロトコルをサポートするために IPv4 アドレス プール属性を拡張します。これは、プレフィクスを取得する NAS 上のローカル プールの名前を指定し、サービスが PPP として設定されるたび、およびプロトコルが IPv6 として指定されるたびに使用されます。アドレス プールはローカル プーリングと連動することに注意してください。これは NAS 上に事前に設定されたローカル プールの名前を指定します。

IPv6 Prefix#

IPv6 Prefix# 属性を使用すると、ネイバー探索ルータ メッセージでアドバタイズするプレフィクスを示すことができます。IPv6 Prefix# 属性が使用されている場合は、対応するルート(ユーザ単位のスタティック ルートとしてマークされています)が、特定のプレフィクスの Routing Information Base(RIB; ルーティング情報ベース)テーブルにインストールされます。

cisco-avpair = "ipv6:prefix#1=2001:DB8::/64",
cisco-avpair = "ipv6:prefix#2=2001:DB8::/64",

IPv6 Route

IPv6 route 属性では、ユーザ単位のスタティック ルートを指定できます。スタティック ルートが適切なのは、Cisco IOS ソフトウェアが宛先へのルートを動的に作成できない場合です。スタティック ルートの作成の詳細については、 ipv6 route コマンドの説明を参照してください。

次の例に、スタティック ルートの定義に使用される IPv6 route 属性を示します。

cisco-avpair = "ipv6:route#1=2001:DB8:cc00:1::/48",
cisco-avpair = "ipv6:route#2=2001:DB8:cc00:2::/48",

Login-IPv6-Host

Login-IPv6-Host 属性は、Login-Service 属性が含まれている場合にユーザを接続するために使用する IPv6 システムを示すユーザ単位属性です。

TACACS+ Over IPv6

IPv6 サーバは、TACACS+ を使用するよう設定できます。IPv4 または IPv6 アドレスの代わりに名前を使用して、TACACS+ を使用するよう IPv6 と IPv4 の両方のサーバを設定できます。

IPv6 プレフィクス プール

IPv6 のプレフィクス プールの機能は、IPv4 のアドレス プールと同様です。主な違いは、IPv6 が単一アドレスではなくプレフィクスを割り当てることです。

IPv4 と同様に、IPv6 でのプールまたはプール定義は、ローカルで設定するか、AAA サーバから取得できます。プール間でオーバーラップするメンバシップは許可されません。

プールが設定されたあとは、プールを変更できません。設定を変更した場合、プールは削除されて再作成されます。前に割り当てられたすべてのプレフィクスは解放されます。

プレフィクス プールは、各ユーザに 64 ビット プレフィクスが割り当てられるように、または単一のプレフィクスが複数のユーザによって共有されるように定義できます。共有プレフィクス プールでは、各ユーザがプールからアドレスを 1 つだけ受け取ることができます。

IPv6 での ADSL の設定方法とダイヤル アクセスの展開方法

「NAS の設定」

「リモート CE ルータの設定」

「RADIUS サーバからプレフィクスを取得するよう DHCPv6 サーバを設定」

「DHCPv6 AAA および SIP オプションの設定」

「TACACS+ over IPv6 の設定」

NAS の設定

ダイヤル アクセスの設定の最初の手順は、NAS の設定です。ダイヤラ グループ、アクセス リスト、およびルータはすべて NAS によって認識されます。この作業では、IPv6 環境で ADSL を実装し、ダイヤル アクセスを展開するように NAS を設定する方法を示します。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. aaa new-model

5. aaa authentication ppp { default | list-name } method1 [ method2 ...]

6. aaa authorization configuration default { radius | tacacs + }

7. show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

8. virtual-profile virtual-template number

9. interface serial controller-number : timeslot

10. encapsulation encapsulation-type

11. exit

12. dialer-group group-number

13. ppp authentication protocol1 [ protocol2... ] [ if-needed ] [ list-name | default ] [ callin ] [ one-time ] [ optional ]

14. interface virtual-template number

15. ipv6 enable

16. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

17. radius-server host { hostname | ip-address } [ test username user-name ] [ auth-port port-number ] [ ignore-auth-port ] [ acct-port port-number ] [ ignore-acct-port ] [ timeout seconds ] [ retransmit retries ] [ key string ] [ alias { hostname | ip-address }] [ idle-time seconds ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname cust1-53a

ネットワーク サーバのホスト名を指定します。

ステップ 4

aaa new-model

 

Router(config)# aaa new-model

AAA サーバをイネーブルにします。

ステップ 5

aaa authentication ppp { default | list-name } method1 [ method2 ...]

 

Router(config)# aaa authentication ppp default if-needed group radius

PPP を実行しているシリアル インターフェイス上で使用する 1 つ以上の AAA 認証方式を指定します。

ステップ 6

aaa authorization configuration default { radius | tacacs+ }

 

Router(config)# aaa authorization configuration default radius

AAA サーバから設定情報をダウンロードします。

ステップ 7

show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

 

Router(config)# show ipv6 route

前のコマンドでインストールされたルートを表示します。

ステップ 8

virtual-profile virtual-template number

 

Router(config)# virtual-profile virtual-template 1

仮想インターフェイス テンプレートで仮想プロファイルをイネーブルにします。

ステップ 9

interface serial controller-number : timeslot

 

Router(config)# interface serial 0 : 15

チャネライズド E1 またはチャネライズド T1 コントローラで作成したシリアル インターフェイスを指定します(ISDN PRI、チャネル連携シグナリング、または robbed-bit シグナリングの場合)。

このコマンドを入力しても、ルータはインターフェイス コンフィギュレーション モードになります。

ステップ 10

encapsulation encapsulation-type

 

Router(config-if)# encapsulation ppp

インターフェイスで使用するカプセル化方式を設定します。

ステップ 11

exit
 
Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 12

dialer-group group-number

 

Router(config)# dialer-group 1

特定のダイヤリング グループに属するようインターフェイスを設定して、アクセスを制御します。

ステップ 13

ppp authentication protocol1 [ protocol2 ...] [ if-needed ] [ list-name | default ] [ callin ] [ one-time ] [ optional ]

 

Router(config)# ppp authentication chap

Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)および Password Authentication Protocol(PAP; パスワード認証プロトコル)のいずれかまたは両方をイネーブルにし、CHAP および PAP 認証がインターフェイスで選択される順序を指定します。

ステップ 14

interface virtual-template number

 

Router(config)# interface virtual-template 1

仮想アクセス インターフェイスの作成時にダイナミックに設定および適用される仮想テンプレート インターフェイスを作成します。

ステップ 15

ipv6 enable

 

Router(config)# ipv6 enable

明示的な IPv6 アドレスが設定されていないインターフェイスにおける IPv6 処理をイネーブルにします。

ステップ 16

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ipv6 permit

プロトコルによって、またはプロトコルと以前に定義したアクセス リストの組み合せによって、ダイヤルするための Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)ダイヤラ リストを定義します。

ステップ 17

radius-server host { hostname | ip-address } [ test username user-name ] [ auth-port port-number ] [ ignore-auth-port ] [ acct-port port-number ] [ ignore-acct-port ] [ timeout seconds ] [ retransmit retries ] [ key string ] [ alias { hostname | ip-address }] [ idle-time seconds ]

 

Router(config)# radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

RADIUS サーバ ホストを指定します。

リモート CE ルータの設定

手順の概要

1. enable

2. configure terminal

3. hostname name

4. interface bri number . subinterface-number [ multipoint | point-to-point ]

5. encapsulation encapsulation-type

6. ipv6 address autoconfig [ default ]

7. isdn switch-type switch-type

8. ppp authentication protocol1 [ protocol2 ...] [ if-needed ] [ list-name | default ] [ callin ] [ one-time ]

9. ppp multilink [ bap | required ]

10. exit

11. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

12. ipv6 route ipv6-prefix / prefix-length { ipv6-address | interface-type interface-number [ ipv6-address ]} [ administrative-distance ] [ administrative-multicast-distance | unicast | multicast ] [ tag tag ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname cust1-36a

ネットワーク サーバのホスト名を指定します。

ステップ 4

interface bri number . subinterface-number [ multipoint | point-to-point ]

 

Router(config)# interface bri 1.0

BRI インターフェイスを設定します。

ステップ 5

encapsulation encapsulation-type

 

Router(config-if)# encapsulation ppp

インターフェイスで使用するカプセル化方式を設定します。

ステップ 6

ipv6 address autoconfig [ default ]

 

Router(config-if)# ipv6 address autoconfig

IPv6 アドレスが自動的に生成されることを指定します。

ステップ 7

isdn switch-type switch-type

 

Router(config-if)# isdn switch-type basic-net3

ISDN インターフェイス上のセントラル オフィス スイッチ タイプを指定します。

ステップ 8

ppp authentication { protocol1 [ protocol2 ...]} [ if-needed ] [ list-name | default ] [ callin ] [ one-time ]

 

Router(config-if)# ppp authentication chap

Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)および Password Authentication Protocol(PAP; パスワード認証プロトコル)のいずれかまたは両方をイネーブルにし、CHAP および PAP 認証がインターフェイスで選択される順序を指定します。

ステップ 9

ppp multilink [ bap | required ]

 

Router(config-if)# ppp multilink

インターフェイスで Multilink PPP(MLP; マルチリンク PPP)をイネーブルにし、オプションで、動的な帯域幅割り当てを行うために Bandwidth Allocation Control Protocol(BACP; 帯域幅割り当て制御プロトコル)と Bandwidth Allocation Protocol(BAP; 帯域幅割り当てプロトコル)をイネーブルにします。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ipv6 permit

プロトコルによって、またはプロトコルと以前に定義したアクセス リストの組み合せによって、ダイヤルするための Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)ダイヤラ リストを定義します。

ステップ 12

ipv6 route ipv6-prefix / prefix-length { ipv6-address | interface-type interface-number [ ipv6-address ]} [ administrative-distance ] [ administrative-multicast-distance | unicast | multicast ] [ tag tag ]

 

Router(config)# ipv6 route 2001:DB8::1/128 BRI1/0

スタティック IPv6 ルートを確立します。

ルートごとに 1 つのコマンドを使用します。

この次の手順

NAS および CE ルータを設定したあとで、RADIUS を設定してコールバック用の AV ペアを確立します。コールバックにより、リモート ネットワーク ユーザは、課金なしで NAS にダイヤルインできます。コールバックが必要な場合、NAS は現在の通話を終了し、呼び出し元にダイヤルします。NAS がコールバックを実行する場合は、発信接続の情報だけが適用されます。事前認証 access-accept メッセージからの残りの属性は廃棄されます。

次の例では、ローカル キャンパス用の RADIUS プロファイル設定を示します。

campus1 Auth-Type = Local, Password = "mypassword"
User-Service-Type = Framed-User,
Framed-Protocol = PPP,
cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
cisco-avpair = "ipv6:route=dead::/64",
cisco-avpair = "ipv6:route=cafe::/64",
cisco-avpair = "ipv6:prefix=dead::/64 0 0 onlink autoconfig",
cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",
 

IPv6 の RADIUS AV ペアについては「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位属性」で説明しています。

RADIUS サーバからプレフィクスを取得するよう DHCPv6 サーバを設定

前提条件

この作業を実行する前に、ルータに AAA クライアントと PPP を設定する必要があります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 nd prefix framed-ipv6-prefix

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 nd prefix framed-ipv6-prefix

 

Router(config-if)# ipv6 nd prefix framed-ipv6-prefix

受信した RADIUS framed IPv6 prefix 属性のプレフィクスを、インターフェイスのネイバー ディスカバリ プレフィクス キューに追加します。

DHCPv6 AAA および SIP オプションの設定

手順の概要

1. enable

2. configure terminal

3. ipv6 dhcp pool poolname

4. prefix-delegation aaa [ method-list method-list ] [ lifetime ]

5. sip address ipv6-address

6. sip domain-name domain-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 dhcp pool poolname

 
Router(config)# ipv6 dhcp pool pool1

DHCP for IPv6 設定情報プールを設定し、DHCP for IPv6 プール コンフィギュレーション モードを開始します。

ステップ 4

prefix-delegation aaa [ method-list method-list ] [ lifetime ]

 
Router(config-dhcp)# prefix-delegation aaa method-list list1

プレフィクスを AAA サーバから取得することを指定します。

ステップ 5

sip address ipv6-address

 

Router(config-dhcp)# sip address 2001:DB8::2

SIP サーバの IPv6 アドレス リスト オプションでクライアントに返す SIP サーバ IPv6 アドレスを設定します。

ステップ 6

sip domain-name domain-name

 
Router(config-dhcp)# sip domain sip1.cisco.com

SIP サーバのドメイン名リスト オプションでクライアントに返す SIP サーバ ドメイン名を設定します。

IPv6 を介した TACACS+ サーバの設定

手順の概要

1. enable

2. configure terminal

3. tacacs server name

4. address ipv6 ipv6-address

5. key [ 0 | 7 ] key-string

6. port [ number ]

7. send-nat-address

8. single-connection

9. timeout seconds

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

tacacs server name

 
Router(config)# tacacs server server1

IPv6 に対して TACACS+ サーバを設定して、TACACS+ サーバ コンフィギュレーション モードを開始します。

ステップ 4

address ipv6 ipv6-address

 

Router(config-server-tacacs)# address ipv6 2001:DB8:3333:4::5

TACACS+ サーバの IPv6 アドレスを設定します。

ステップ 5

key [ 0 | 7 ] key-string

 
Router(config-server-tacacs)# key 0 key1

TACACS+ サーバでサーバ単位の暗号キーを設定します。

ステップ 6

port [ number ]

 
Router(config-server-tacacs)# port 12

TACACS+ 接続に使用する TCP ポートを指定します。

ステップ 7

send-nat-address

 
Router(config-server-tacacs)# send-nat-address

クライアントの NAT 後のアドレスを TACACS+ サーバに送信します。

ステップ 8

single-connection

 
Router(config-server-tacacs)# single-connection

単一の TCP 接続を使用してすべての TACACS パケットを同じサーバに送信できるようにします。

ステップ 9

timeout seconds

 
Router(config-server-tacacs)# timeout 10

指定された TACACS サーバからの応答を待機する時間を設定します。

TACACS+ パケットでの送信元アドレスの指定

手順の概要

1. enable

2. configure terminal

3. ipv6 tacacs source-interface type number

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 tacacs source-interface type number

 

Router(config)# ipv6 tacacs source-interface GigabitEthernet 0/0/0

TACACS パケットで送信元アドレスに使用するインターフェイスを指定します。

TACACS+ サーバ グループ オプションの設定

手順の概要

1. enable

2. configure terminal

3. aaa group server tacacs+ group-name

4. server name server-name

5. server-private { ip-address | name | ipv6-address } [ nat ] [ single-connection ] [ port port-number ] [ timeout seconds ] [ key [ 0 | 7 ] string ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

aaa group server tacacs+ group-name

 

Router(config)# aaa group server tacacs+ group1

各種の TACACS+ サーバ ホストを別個のリストと別個の方式にグループ化します。

ステップ 4

server name server-name

 
Router(config-sg-tacacs+)# server name server1

IPv6 TACACS+ サーバを指定します。

ステップ 5

server-private { ip-address | name | ipv6-address } [ nat ] [ single-connection ] [ port port-number ] [ timeout seconds ] [ key [ 0 | 7 ] string ]

 

Router(config-sg-tacacs+)# server-private 2001:DB8:3333:4::5 port 19 key key1

グループ サーバに対するプライベート TACACS+ サーバの IPv6 アドレスを設定します。

IPv6 の ADSL の実装およびダイヤル アクセスの展開の設定例

「例:IPv6 の ADSL の実装およびダイヤル アクセスの展開」

例:IPv6 の ADSL の実装およびダイヤル アクセスの展開

この例では、ADSL およびダイヤル アクセスの一般的な設定を示します。次の 3 つの設定が必要です。

NAS の設定

リモート CE ルータの設定

RADIUS の設定

NAS の設定

ISP NAS の次の設定は、リモート CE ルータからのアクセスをサポートする設定を示しています。

hostname cust1-53a
aaa new-model
aaa authentication ppp default if-needed group radius
aaa authorization network default group radius
virtual-profile virtual-template 1
interface Serial0:15
encapsulation ppp
dialer-group 1
ppp authentication chap
!
interface Virtual-Template1
ipv6 enable
!
dialer-list 1 protocol ipv6 permit
radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

リモート CE ルータの設定

リモート カスタマー エッジ ルータの次の設定は、定義された PPP カプセル化と IPv6 ルートを示しています。

hostname cust-36a
interface BRI1/0
encapsulation ppp
ipv6 enable
isdn switch-type basic-net3
ppp authentication chap optional
ppp multilink
!
dialer-list 1 protocol ipv6 permit
ipv6 route 2001:DB8::1/128 BRI1/0
ipv6 route ::/0 2001:DB8::1

RADIUS の設定

次の RADIUS 設定は、スタティック ルートを確立するための AV ペアの定義を示しています。

campus1 Auth-Type = Local, Password = "mypassword"
User-Service-Type = Framed-User,
Framed-Protocol = PPP,
cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
cisco-avpair = "ipv6:route=library::/64",
cisco-avpair = "ipv6:route=cafe::/64",
cisco-avpair = "ipv6:prefix=library::/64 0 0 onlink autoconfig",
cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",

その他の関連資料

関連資料

関連項目
参照先

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 基本接続

Cisco IOS IPv6 Configuration Guide 』の「 Implementing IPv6 Addressing and Basic Connectivity

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

認証局と相互運用性、RA プロキシ

Cisco IOS Security Configuration Guide 』の「 Security Overview

RADIUS サーバ設定

Cisco IOS Security Configuration Guide 』の「 Security Overview

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3162

『RADIUS and IPv6』

RFC 3177

『IAB/IESG Recommendations on IPv6 Address』

RFC 3319

『Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiated Protocol (SIP) Servers』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 1 IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

機能名
リリース
機能情報

Cisco VSA IPv6 属性の AAA サポート

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

Vendor-Specific Attribute(VSA; ベンダー固有属性)は、IPv6 で AAA をサポートするために開発されました。

この機能については、次の項に説明があります。

「AAA over IPv6」

RFC 3162 IPv6 RADIUS 属性の AAA サポート

12.3(4)T
12.4
12.4(2)T

IPv6 の AAA 属性は RFC 3162 に準拠しており、RFC 3162 をサポートできる RADIUS サーバを必要とします。

これらの機能に関する詳細については、次の各項を参照してください。

「AAA over IPv6」

「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位属性」

「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位属性」

「RADIUS サーバからプレフィクスを取得するよう DHCPv6 サーバを設定」

「DHCPv6 AAA および SIP オプションの設定」

AAA を介した IPv6 プレフィクス委任のための DHCP

12.2(18)SXE
12.3(14)T
12.4
12.4(2)T

これらの機能に関する詳細については、次の各項を参照してください。

「ステートレス アドレス自動設定」

「プレフィクス委任」

「IPv6 プレフィクス プール」

「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位属性」

「DHCPv6 AAA および SIP オプションの設定」

ADSL およびダイヤル展開のための IPv6 拡張機能

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 で ADSL およびダイヤル展開の使用をイネーブルにするために、いくつかの機能が拡張されました。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「ステートレス アドレス自動設定」

「NAS の設定」

「リモート CE ルータの設定」

IPv6 プレフィクス プール

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 のプレフィクス プール機能は、IPv4 のアドレス プール機能に類似しています。主な違いは、IPv6 では単一アドレスではなくプレフィクスが割り当てられることです。

これらの機能に関する詳細については、次の各項を参照してください。

「AAA over IPv6」

「ステートレス アドレス自動設定」

「IPv6 プレフィクス プール」

「NAS の設定」

「リモート CE ルータの設定」

PPPoA

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

ADSL およびダイヤル展開は、PPPoA など、PPP カプセル化がイネーブルになっているインターフェイスで使用できます。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「NAS の設定」

「リモート CE ルータの設定」

PPPoE

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

ADSL およびダイヤル展開は、PPPoE など、PPP カプセル化がイネーブルになっているインターフェイスで使用できます。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「NAS の設定」

「リモート CE ルータの設定」

RADIUS over IPv6

12.2(58)SE
15.2(1)T

この機能は、サポートされています。

SSO - PPPoE IPv6

12.2(33)XNE

この機能は、Cisco IOS Release 12.2(33)XNE でサポートされます。

TACACS+ over IPv6

12.2(33)SXJ
12.2(58)SE
15.1(1)S
15.2(1)T

TACACS+ over IPv6 がサポートされます。

この機能に関する詳細については、次の各項を参照してください。

「TACACS+ Over IPv6」

「TACACS+ over IPv6 の設定」

この機能によって、 aaa group server tacacs+ address ipv6 (TACACS+) ipv6 tacacs source-interface key (TACACS+) port (TACACS+) send-nat-address server name (IPv6 TACACS+) server-private (TACACS+) single-connection tacacs server timeout (TACACS+) の各コマンドが導入または変更されました。