Cisco IOS IP ルーティング:BGP コンフィギュ レーション ガイド
BGP の AS パスからのプライベート AS 番号 の削除
BGP の AS パスからのプライベート AS 番号の削除
発行日;2012/02/05 | 英語版ドキュメント(2011/11/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP の AS パスからのプライベート AS 番号の削除

機能情報の検索

目次

AS パスからのプライベート ASN の削除および置換に関する制約事項

AS パスからのプライベート ASN の削除および置換に関する情報

パブリックおよびプライベート AS 番号

AS パスからプライベート ASN を削除および置換する利点

AS パスからのプライベート ASN の削除に関する以前の制約事項

AS パスからのプライベート ASN の削除に関する強化

AS パスからプライベート ASN を削除および置換する方法

AS パスからのプライベート ASN の削除および置換(Cisco IOS Release15.1(2)T 以降)

AS パスからプライベート ASN を削除および置換するための設定例

例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)

例:プライベート ASN の削除と置換(Cisco IOS Release 15.1(2)T)

例:プライベート ASN の削除(Cisco IOS Release 12.2)

参考資料

関連資料

規格

MIB

シスコのテクニカル サポート

AS パスからプライベート ASN への削除および置換に関する機能情報

BGP の AS パスからのプライベート AS 番号の削除

プライベート Autonomous System Number(ASN; 自律システム番号)は、ISP と顧客ネットワークがグローバルに一意の AS 番号を節約するために使用されます。プライベート AS は一意ではないため、グローバル インターネット アクセスには使用できません。AS 番号は、ルーティング アップデートで eBGP AS パスに出現します。プライベート ASN を使用していて、今後、グローバル インターネットにアクセスする場合は、AS パスからプライベート ASN を削除する処理が必要です。

機能情報の検索

ご使用のソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「AS パスからプライベート ASN への削除および置換に関する機能情報」を参照してください。

プラットフォーム サポートと Cisco ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

AS パスからのプライベート ASN の削除および置換に関する制約事項

この機能には、次の制約事項があります。

この機能は、eBGP ネイバーにのみ適用されます。

この機能は、パブリック AS のルータにのみ適用されます。この制約事項の回避策は、ネイバーごとに neighbor local-as コマンドを適用して、ローカル AS 番号をパブリック AS 番号に置換することです。

AS パスからのプライベート ASN の削除および置換に関する情報

「パブリックおよびプライベート AS 番号」

「AS パスからプライベート ASN を削除および置換する利点」

「AS パスからのプライベート ASN の削除に関する以前の制約事項」

「AS パスからのプライベート ASN の削除に関する強化」

パブリックおよびプライベート AS 番号

パブリック AS 番号は InterNIC によって割り当てられ、グローバルに一意です。範囲は 1 ~ 64511 です。プライベート AS は、グローバルに一意の AS 番号を節約するために使用され、範囲は 64512 ~ 65535 です。プライベート AS 番号は、グローバル BGP ルーティング テーブルに公開できません。プライベート AS は一意ではなく、BGP の最適パスの計算には一意の AS 番号が必要なためです。結果として、場合によっては、BGP ピアにルートをプロパゲートする前に、AS パスからプライベート AS 番号を削除する必要があります。

AS パスからプライベート ASN を削除および置換する利点

外部 BGP では、グローバル インターネットにルーティングする際に、グローバルに一意の AS 番号を使用する必要があります。(一意ではない)プライベート AS 番号を使用すると、グローバル インターネットにアクセスできません。この機能を使用すると、プライベート AS に属するルータはグローバル インターネットにアクセスできます。ネットワーク管理者は、発信更新メッセージに含まれる AS パスからプライベート AS 番号を削除し、オプションで、AS パスの長さが変わらないように、その AS 番号をローカル ルータの ASN に置換するようにルータを設定します。

AS パスからのプライベート ASN の削除に関する以前の制約事項

AS パスからプライベート AS 番号を削除する機能は、かなり以前から使用できる機能でした。Cisco IOS Release 15.1(2)T よりも前のリリースでは、この機能には次の制約事項がありました。

AS パスにプライベートおよびパブリックの AS 番号が両方含まれる場合、 neighbor remove-private-as コマンドを使用すると、プライベート AS 番号は削除されませんでした。

AS パスにコンフェデレーション セグメントが含まれる場合、 neighbor remove-private-as コマンドを使用すると、自律パスのコンフェデレーション部分にプライベート AS 番号が続く場合にのみ、プライベート AS 番号のみが削除されました。

AS パスに eBGP ネイバーの AS 番号が含まれる場合、プライベート AS 番号は削除されませんでした。

AS パスからのプライベート ASN の削除に関する強化

AS パスから AS 番号を削除および置換する機能は、次のように強化されました。

neighbor remove-private-as コマンドを使用すると、パスにパブリックおよびプライベート ASN の両方が含まれる場合でも、プライベート AS 番号は AS パスから削除されます。

neighbor remove-private-as コマンドを使用すると、AS パスにプライベート AS 番号のみが含まれる場合でも、プライベート AS 番号は削除されます。このコマンドは eBGP ピアにのみ適用され、ローカル ルータの AS 番号が AS パスに付加されるため、長さが 0 の AS パスが出現する可能性はありません。

neighbor remove-private-as コマンドを使用すると、プライベート ASN が AS パスでコンフェデレーション セグメントよりも前に出現しても、プライベート AS 番号は削除されます。

replace-as キーワードを使用して、パスから削除されるプライベート AS 番号を、ローカル AS 番号で置換できます。その結果、AS パスの長さが維持されます。

この機能は、1 つのアドレス ファミリにつき複数のネイバーに適用できます(アドレス ファミリ コンフィギュレーション モード)。そのため、あるアドレス ファミリのネイバーについて機能を適用し、別のファミリには適用しないことができます。その結果、機能を設定したアドレス ファミリについてのみ、発信側に更新メッセージの影響があります。

この機能は、ピア グループ テンプレート モードで適用できます。

この機能を設定すると、 show ip bgp update-group および show ip bgp neighbor コマンドの出力は、プライベート AS 番号が削除または置換されたことを示します。

AS パスからプライベート ASN を削除および置換する方法

ここでは、次の作業について説明します。

「AS パスからのプライベート ASN の削除および置換(Cisco IOS Release 15.1(2)T 以降)」(必須)

AS パスからのプライベート ASN の削除および置換(Cisco IOS Release 15.1(2)T 以降)

eBGP ネイバーの発信側で AS パスからプライベート AS 番号を削除するには、次の作業を実行します。また、プライベート AS 番号をローカル ルータの AS 番号で置換するには、ステップ 17 で all replace-as キーワードを指定します。

この作業の例では、図 1のシナリオのルータ 2 に関する設定を反映しています。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask

5. exit

6. interface type number

7. ip address ip-address mask

8. exit

9. interface type number

10. ip address ip-address mask

11. exit

12. router bgp autonomous-system-number

13. network network-number

14. network network-number

15. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number

16. neighbor { ip-address | ipv6-address [ % ] | peer-group-name } remote-as autonomous-system-number

17. neighbor { ip-address | peer-group-name } remove-private-as [ all [ replace-as ]]

18. end

19. show ip bgp update-group

20. show ip bgp neighbors

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface gigabitethernet 0/0

インターフェイスを設定します。

ステップ 4

ip address ip-address mask

 

Router(config-if)# ip address 172.30.1.1 255.255.0.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

exit

 

Router(config-if)# exit

次に高いコンフィギュレーション モードに戻ります。

ステップ 6

interface type number

 

Router(config)# interface serial 0/0

インターフェイスを設定します。

ステップ 7

ip address ip-address mask

 

Router(config-if)# ip address 172.16.0.2 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 8

exit

 

Router(config-if)# exit

次に高いコンフィギュレーション モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface serial 1/0

インターフェイスを設定します。

ステップ 10

ip address ip-address mask

 

Router(config-if)# ip address 192.168.0.1 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 11

exit

 

Router(config-if)# exit

次に高いコンフィギュレーション モードに戻ります。

ステップ 12

router bgp autonomous-system-number

 

Router(config)# router bgp 5

BGP インスタンスを指定します。

ステップ 13

network network-number

 

Router(config-router)# network 172.30.0.0

BGP からアドバタイズするネットワークを指定します。

ステップ 14

network network-number

 

Router(config-router)# network 192.168.0.0

BGP からアドバタイズするネットワークを指定します。

ステップ 15

neighbor { ip-address | ipv6-address [ % ]| peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 172.16.0.1 remote-as 65000

ルーティング テーブルにエントリを追加します。

次に、プライベート AS 65000 で、eBGP ネイバーとしてルータ 3 を設定する例を示します。

ステップ 16

neighbor { ip-address | ipv6-address [ % ]| peer-group-name } remote-as autonomous-system-number

 

Router(config-router)# neighbor 192.168.0.2 remote-as 1

ルーティング テーブルにエントリを追加します。

次に、パブリック AS 1 で、eBGP ネイバーとしてルータ 1 を設定する例を示します。

ステップ 17

neighbor { ip-address | peer-group-name } remove-private-as [ all [ replace-as ]]

 

Router(config-router)# neighbor 192.168.0.2 remove-private-as all replace-as

発信の更新で、AS パスからプライベート AS 番号を削除します。

次に、発信 eBGP の更新で AS パスからプライベート AS 番号を削除し、5(ローカル ルータのパブリック AS 番号)で置換する例を示します。

ステップ 18

end

 

Router(config-router)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 19

show ip bgp update-group

 

Router# show ip bgp update-group

(任意)BGP 更新グループの情報を表示します。

ステップ 20

show ip bgp neighbors

 

Router# show ip bgp neighbors

(任意)BGP ネイバーに関する情報を表示します。

AS パスからプライベート ASN を削除および置換するための設定例

ここでは、次の例について説明します。

「例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)」

「例:プライベート ASN の削除と置換(Cisco IOS Release 15.1(2)T)」

「例:プライベート ASN の削除(Cisco IOS Release 12.2)」

例:プライベート ASN の削除(Cisco IOS Release 15.1(2)T)

次の例では、ルータ A には neighbor remove-private-as コマンドが設定されています。これによって、172.30.0.7 のネイバーに送信される更新に含まれるプライベート AS 番号が削除されます。以降の show コマンドでは、ホスト 1.1.1.1 に対するルートの情報が必要です。出力の 1001 65200 65201 65201 1002 1003 1003 の AS パスには、プライベート AS 番号 65200、65201、65201 が含まれます。

AS パスからプライベート AS 番号が削除された場合、ルータ B での show コマンドでも、ホスト 1.1.1.1 に関する情報が必要です。出力は、100 1001 1002 1003 1003 の短い AS パスを示します。これは、プライベート AS 番号 65200、65201、および 65201 が削除された結果です。パスの先頭が 100 から始まる数値は、ルータ B の固有の AS 番号です。

ルータ A

router bgp 100
bgp log-neighbor-changes
neighbor 19.0.101.1 remote-as 1001
neighbor 172.30.0.7 remote-as 200
neighbor 172.30.0.7 remove-private-as all
no auto-summary
 
RouterA# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 2
Paths: (1 available, best #1, table default)
Advertised to update-groups:
1 2
1001 65200 65201 65201 1002 1003 1003
19.0.101.1 from 19.0.101.1 (19.0.101.1)
Origin IGP, localpref 100, valid, external, best RouterA#

ルータ B(すべてのプライベート ASN は削除されました)

RouterB# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 3
Paths: (1 available, best #1, table default)
Not advertised to any peer
100 1001 1002 1003 1003
172.30.0.6 from 172.30.0.6 (19.1.0.1)
Origin IGP, localpref 100, valid, external, best RouterB#

例:プライベート ASN の削除と置換(Cisco IOS Release 15.1(2)T)

次の例では、ルータ A からプレフィクスをピア 172.30.0.7 に送信すると、AS パスに含まれるすべての ASN は、ルータ固有の ASN(100)で置換されます。

ルータ A

router bgp 100
bgp log-neighbor-changes
neighbor 172.16.101.1 remote-as 1001
neighbor 172.16.101.1 update-source Loopback0
neighbor 172.30.0.7 remote-as 200
neighbor 172.30.0.7 remove-private-as all replace-as
no auto-summary
 

ルータ A は、プライベート ASN(65200、65201、および 65201)を AS パス リストに含むピア 172.16.101.1 から 1.1.1.1 を受信します。次に出力例を示します。

 
RouterA# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 2
Paths: (1 available, best #1, table default)
Advertised to update-groups:
1 2
1001 65200 65201 65201 1002 1003 1003
172.16.101.1 from 172.16.101.1 (172.16.101.1)
Origin IGP, localpref 100, valid, external, best RouterA#
 

ルータ A は neighbor 172.30.0.7 remove-private-as all replace-as で設定されているため、ルータ A からは、すべてのプライベート ASN を 100 で置換したプレフィクス 1.1.1.1 を送信します。

ルータ B

RouterB# show ip bgp 1.1.1.1
 
BGP routing table entry for 1.1.1.1/32, version 3
Paths: (1 available, best #1, table default)
Not advertised to any peer
100 1001 100 100 100 1002 1003 1003
172.30.0.6 from 172.30.0.6 (192.168.1.2)
Origin IGP, localpref 100, valid, external, best RouterB#

ルータ B

router bgp 200
bgp log-neighbor-changes
neighbor 172.30.0.6 remote-as 100
no auto-summary

例:プライベート ASN の削除(Cisco IOS Release 12.2)

この例では、ルータ 3 がプライベート ASN 65000 を使用しています。ルータ 1 とルータ 2 はパブリック ASN の AS 1 と AS 5 をそれぞれ使用しています。

図 1 に、ルータ 2 がサービス プロバイダーに属し、ルータ 1 とルータ 3 がそのクライアントの場合を示します。

図 1 プライベート AS 番号の削除

 


この例では、ルータ 2 がサービス プロバイダーに属し、次のように AS 番号を削除します。


ステップ 1 ルータ 3 は、AS パス アトリビュートが 65000 のネットワーク 10.0.0.0/24 をルータ 2 にアドバタイズします。

ステップ 2 ルータ 2 はルータ 3 から更新を受信し、ネットワーク 10.0.0.0/24 のエントリをルーティング テーブルに作成します。このとき、ネクスト ホップを 172.16.0.1(ルータ 3 上のシリアル インターフェイス S0)にします。

ステップ 3 ルータ 2(サービス プロバイダー デバイス)を neighbor 192.168.0.2 remove-private-as コマンドで設定すると、プライベート AS 番号が削除され、10.0.0.0/24 ネットワークの AS パス アトリビュートとして独自の AS 番号で新しい更新パケットが構築され、パケットがルータ 1 に送信されます。

ステップ 4 ルータ 1 は、ネットワーク 10.0.0.0/24 の eBGP の更新を受信し、ルーティング テーブルにエントリを作成し、ネクスト ホップを 192.168.0.1(ルータ 2 上のシリアル インターフェイス S1)にします。ルータ 1 から見えるこのネットワークの AS パス アトリビュートは AS 5(ルータ 2)です。そのため、プライベート AS 番号は、インターネットの BGP テーブルに入力されません。

ルータ 3、ルータ 2、およびルータ 1 の設定は次のとおりです。

ルータ 3

interface gigabitethernet 0/0
ip address 10.0.0.1 255.255.255.0
!
interface Serial 0
ip address 172.16.0.1 255.255.255.0
!
router bgp 65000
network 10.0.0.0 mask 255.255.255.0
neighbor 172.16.0.2 remote-as 5
!---Configures Router 2 as an eBGP neighbor in public AS 5.
!
end

ルータ 2

interface gigabitethernet 0/0
ip address 172.30.1.1 255.255.0.0
!
interface Serial 0
ip address 172.16.0.2 255.255.255.0
!
interface Serial 1
ip address 192.168.0.1 255.255.255.0
!
router bgp 5
network 172.30.0.0
network 192.168.0.0
neighbor 172.16.0.1 remote-as 65000
!---Configures Router 3 as an eBGP neighbor in private AS 65000.
neighbor 192.168.0.2 remote-as 1
!---Configures Router 1 as an eBGP neighbor in public AS 1.
neighbor 192.168.0.2 remove-private-as
!---Removes the private AS numbers from outgoing eBGP updates.
!
end

ルータ 1

version 12.2
!
!
interface Serial 0
ip address 192.168.0.2 255.255.255.0
!
router bgp 1
neighbor 192.168.0.1 remote-as 5
!---Configures Router 2 as an eBGP neighbor in public AS 5.
!
end


 

参考資料

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

BGP コマンド

『Cisco IOS IP Routing: BGP Command Reference』

ここで説明されていないこのテクノロジーに関する情報

『BGP Features Roadmap』

規格

規格
タイトル

なし

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

AS パスからプライベート ASN への削除および置換に関する機能情報

表 1 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


表 1 BGP に関する機能情報:プライベート AS の削除と置換

 

機能名
リリース
機能情報

BGP:プライベート AS の削除と置換

15.1(2)T、15.0(1)S

プライベート Autonomous System(AS; 自律システム)番号は、ISP と顧客ネットワークがグローバルに一意の AS 番号を節約するために使用されます。プライベート AS は一意ではないため、グローバル インターネット アクセスには使用できません。AS 番号は、ルーティング テーブルで eBGP AS パスに出現します。AS パスからプライベート AS 番号を削除する処理は、プライベート AS 番号を使用してして、グローバル インターネットにアクセスする場合に必要です。

次のコマンドが変更されています。

neighbor remove-private-as