Cisco IOS IP ルーティング:BGP コンフィギュ レーション ガイド
BGP ポリシー アカウンティング出力インター フェイス アカウンティング
BGP ポリシー アカウンティング出力インターフェイス アカウンティング
発行日;2012/02/05 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP ポリシー アカウンティング出力インターフェイス アカウンティング

マニュアルの内容

BGP PA 出力インターフェイス アカウンティングの前提条件

BGP PA 出力インターフェイス アカウンティングの制約事項

BGP PA 出力インターフェイス アカウンティングに関する情報

BGP PA 出力インターフェイス アカウンティング

BGP PA 出力インターフェイス アカウンティングの利点

BGP PA 出力インターフェイス アカウンティングの設定方法

BGP PA の一致基準の指定

IP トラフィックの分類および BGP PA のイネーブル化

BGP ポリシー アカウンティングの確認

BGP PA 出力インターフェイス アカウンティングの設定例

BGP ポリシー アカウンティングの一致基準の指定:例

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化:例

次の作業

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

用語集

BGP ポリシー アカウンティング出力インターフェイス アカウンティング

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)Policy Accounting(PA; ポリシー アカウンティング)では、異なるピア間で送受信される IP トラフィックを測定および分類します。ポリシー アカウンティングは、以前は入力インターフェイスだけで使用可能でした。BGP ポリシー アカウンティング出力インターフェイス アカウンティング機能により、BGP PA を出力インターフェイスでイネーブルにし、インターフェイスの入力トラフィックおよび出力トラフィックの両方の送信元アドレスに基づくアカウンティングを組み込むための複数の拡張機能が追加されます。IP トラフィックを識別するために、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられます。

BGP PA 出力インターフェイス アカウンティング機能の履歴

リリース
変更内容

12.0(9)S

この機能が追加されました。

12.0(17)ST

この機能は、Cisco IOS リリース 12.0(17)ST に統合されました。

12.0(22)S

出力インターフェイス アカウンティングが追加され、バケット サイズが増やされました。

12.3(4)T

この機能は、Cisco IOS リリース 12.3(4)T に統合されました。

12.2(22)S

この機能は、Cisco IOS リリース 12.2(22)S に統合されました。

プラットフォームと、Cisco IOS および Catalyst OS ソフトウェア イメージに関するサポート情報の検索

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

BGP PA 出力インターフェイス アカウンティングの前提条件

BGP ポリシー アカウンティング出力インターフェイス アカウンティング機能を使用する前に、BGP および Cisco Express Forwarding(CEF)または distributed CEF(dCEF)をルータでイネーブルにする必要があります。

BGP PA 出力インターフェイス アカウンティングの制約事項

CISCO-BGP-POLICY-ACCOUNTING-MIB は、Cisco IOS リリース 12.0(9)S、12.0(17)ST、12.2(22)S、およびこれ以降のリリースだけで使用できます。この管理情報ベース(MIB)は、いずれのメインラインおよび T トレイン リリースでも使用できません。

BGP PA 出力インターフェイス アカウンティングに関する情報

BGP PA 出力インターフェイス アカウンティングを設定するには、次の概念について理解する必要があります。

「BGP PA 出力インターフェイス アカウンティング」

「BGP PA 出力インターフェイス アカウンティングの利点」

BGP PA 出力インターフェイス アカウンティング

BGP を使用したポリシー アカウンティングでは、異なるピア間で送受信される IP トラフィックを測定および分類します。BGP PA は元々、入力インターフェイスだけで使用可能でした。BGP PA 出力インターフェイス アカウンティングでは、BGP PA を出力インターフェイスでイネーブルにし、インターフェイスの入力トラフィックおよび出力トラフィックの両方の送信元アドレスに基づくアカウンティングを組み込むための複数の拡張機能が導入されています。IP トラフィックを識別するために、コミュニティ リスト、自律システム番号、または自律システム パスなどのパラメータに基づくカウンタが割り当てられます。

BGP の table-map コマンドを使用することで、ルーティング テーブルに追加されるプレフィクスは、BGP アトリビュート、自律システム番号、または自律システム パス別に分類されます。パケット カウンタおよびバイト カウンタは、入力インターフェイスまたは出力インターフェイス単位で増加します。Cisco IOS のポリシーベースの分類機能によって、トラフィックは異なるトラフィック クラスを表す 8 つのうちいずれか 1 つのバケットにマッピングされます。

BGP PA を使用することで、トラフィックの発信元またはトラフィックが通過したルートに応じてトラフィックのアカウンティングを行うことができます。Service Provider(SP; サービス プロバイダー)は、すべてのトラフィックをカスタマー別に識別してアカウンティングを行うことができ、それに応じて課金できます。図 1 では、BGP PA をルータ A に実装して、自律システム バケット内のパケット量およびバイト量を測定できます。カスタマーは、国内、海外、または衛星経由の送信元からルーティングされたトラフィックに応じて適切に課金されます。

図 1 BGP ポリシー アカウンティングのトポロジ例

 

自律システム番号を使用した BGP ポリシー アカウンティングは、Internet Service Provider(ISP; インターネット サービス プロバイダー)間でのネットワーク回線のピアリングおよび中継の契約に関する設計を改善するために使用できます。

BGP PA 出力インターフェイス アカウンティングの利点

格差を付けた IP トラフィックのアカウンティング

BGP ポリシー アカウンティングは、自律システム番号、自律システム パス、またはコミュニティ リスト ストリングに基づいて IP トラフィックを分類し、パケットおよびバイト カウンタの値を増加させます。ポリシー アカウンティングは、送信元アドレスを基本とすることもできます。サービス プロバイダーはトラフィックのアカウンティングを行い、トラフィックの発信元または特定のトラフィックが通過したルートに応じた課金を適用できます。

ネットワーク回線のピアリングおよび中継の契約に関する効率的な設計

BGP ポリシー アカウンティングをエッジ ルータに実装すると、ピアリングおよび中継の契約に関する設計の潜在的な改善点を明らかにすることができます。

BGP PA 出力インターフェイス アカウンティングの設定方法

ここでは、次の作業について説明します。

「BGP PA の一致基準の指定」(必須)

「IP トラフィックの分類および BGP PA のイネーブル化」(必須)

「BGP ポリシー アカウンティングの確認」(任意)

BGP PA の一致基準の指定

BGP PA を設定する最初の作業は、一致させる必要がある基準を指定することです。コミュニティ リスト、自律システム パス、または自律システム番号は、指定が可能で、後でルート マップを使用してマッチングできる BGP アトリビュートの例です。BGP PA に使用する BGP アトリビュートを指定し、ルート マップ内の一致基準を作成するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip community-list { standard-list-number | expanded-list-number [ regular-expression ] | { standard | expanded } community-list-name } { permit | deny } { community-number | regular-expression }

4. route-map map-name [ permit | deny ] [ sequence-number ]

5. match community-list community-list-number [ exact ]

6. set traffic-index bucket-number

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip community-list { standard-list-number | expanded-list-number [ regular-expression ] | { standard | expanded } community-list-name } { permit | deny } { community-number | regular-expression }

 

Router(config)# ip community-list 30 permit 100:190

BGP のコミュニティ リストを作成してアクセスを制御します。

指定する各コミュニティについて、このステップを繰り返します。

ステップ 4

route-map map-name [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map set_bucket permit 10

ルート マップ コンフィギュレーション モードを開始し、ポリシー ルーティングの条件を定義します。

map-name 引数はルート マップを識別します。

オプションの permit および deny の各キーワードは一致基準および設定基準とともに機能し、パケットのアカウンティングを行う方法を制御します。

オプションの sequence-number 引数は、同一の名前ですでに設定されているルート マップのリスト内における新しいルート マップの場所を示します。

ステップ 5

match community-list community-list-number [ exact ]

 

Router(config-route-map)# match community-list 30

BGP コミュニティを一致させます。

ステップ 6

set traffic-index bucket-number

 

Router(config-route-map)# set traffic-index 2

BGP ポリシー アカウンティングのルート マップの match 句を渡すパケットの出力先を示します。

ステップ 7

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

IP トラフィックの分類および BGP PA のイネーブル化

ルート マップを定義して一致基準を指定した後、BGP ポリシー アカウンティングをイネーブルにする前に、IP トラフィックを分類する方法を設定する必要があります。

table-map コマンドを使用することで、BGP ではルーティング テーブルに追加した各プレフィクスを、一致基準に応じて分類します。BGP ポリシー アカウンティングは、インターフェイスで bgp-policy accounting コマンドが設定されたときにイネーブル化されます。

IP トラフィックを分類して BGP ポリシー アカウンティングをイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. table-map route-map-name

5. network network-number [ mask network-mask ]

6. neighbor ip-address remote-as as-number

7. exit

8. interface type number

9. ip address ip-address mask

10. bgp-policy accounting [ input | output ] [ source ]

11. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65000

BGP ルーティング プロセスを設定し、指定されたルーティング プロセスのルータ コンフィギュレーション モードを開始します。

as-number 引数は、BGP 自律システム番号を識別します。

ステップ 4

table-map route-map-name

 

Router(config-router)# table-map set_bucket

ルーティング テーブルに入力された BGP プレフィクスを分類します。

ステップ 5

network network-number [ mask network-mask ]

 

Router(config-router)# network 10.15.1.0 mask 255.255.255.0

BGP ルーティング プロセスによってアドバタイズされるネットワークを指定します。

ステップ 6

neighbor ip-address remote-as as-number

 

Router(config-router)# neighbor 10.14.1.1 remote-as 65100

BGP ルーティング テーブルにエントリを追加して、BGP ピアを指定します。

ステップ 7

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface type number

 

Router(config)# interface POS 7/0

インターフェイスのタイプと番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数は、インターフェイスのタイプを識別します。

number 引数は、インターフェイスのスロット番号およびポート番号を識別します。インターフェイスのタイプと番号の間のスペースは任意です。

ステップ 9

ip address ip-address mask

 

Router(config-if)# ip-address 10.15.1.2 255.255.255.0

IP アドレスを使用してインターフェイスを設定します。

ステップ 10

bgp-policy accounting [ input | output ] [ source ]

 

Router(config-if)# bgp-policy accounting input source

インターフェイスに対して、BGP ポリシー アカウンティングをイネーブルにします。

任意の input または output キーワードを使用すると、ルータに入力または出力されるいずれかのトラフィックのアカウンティングを行うことができます。デフォルトでは、BGP ポリシー アカウンティングは、ルータに入力されるトラフィックに基づきます。

任意の source キーワードを使用すると、送信元アドレスに基づいてトラフィックのアカウンティングを行うことができます。

ステップ 11

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

BGP ポリシー アカウンティングの確認

BGP ポリシー アカウンティングが動作していることを確認するには、次の作業を実行します。

手順の概要

1. show ip cef [ network [ mask ]] [ detail ]

2. show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

3. show cef interface [ type number ] policy-statistics [ input | output ]

4. show cef interface [ type number ] [ statistics ] [ detail ]

手順の詳細


ステップ 1 show ip cef [ network [ mask ]] [ detail ]

detail キーワードを指定して show ip cef コマンドを入力し、指定されたプレフィクスに割り当てられているアカウンティング バケットを調べます。

この例では、プレフィクス 192.168.5.0 についての出力が表示されます。このプレフィクスにアカウンティング バケット番号 4(traffic_index 4)が割り当てられていることが示されます。

Router# show ip cef 192.168.5.0 detail
 
192.168.5.0/24, version 21, cached adjacency to POS7/2
0 packets, 0 bytes, traffic_index 4
via 10.14.1.1, 0 dependencies, recursive
next hop 10.14.1.1, POS7/2 via 10.14.1.0/30
valid cached adjacency
 

ステップ 2 show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

ステップ 1 で使用したのと同じプレフィクス(192.168.5.0)について show ip bgp コマンドを入力し、このプレフィクスに割り当てられているコミュニティを調べます。

この例では、プレフィクス 192.168.5.0 についての出力が表示されます。この例では、コミュニティ「100:197」がこのプレフィクスに割り当てられていることが示されています。

Router# show ip bgp 192.168.5.0
 
BGP routing table entry for 192.168.5.0/24, version 2
Paths: (1 available, best #1)
Not advertised to any peer
100
10.14.1.1 from 10.14.1.1 (32.32.32.32)
Origin IGP, metric 0, localpref 100, valid, external, best
Community: 100:197
 

ステップ 3 show cef interface [ type number ] policy-statistics [ input | output ]

show cef interface policy-statistics コマンドを入力して、インターフェイス単位のトラフィック統計情報を表示します。

この例では、各アカウンティング バケットに割り当てられているパケットおよびバイトの数が出力に表示されます。

Router# show cef interface policy-statistics input
 
FastEthernet1/0/0 is up (if_number 6)
Corresponding hwidb fast_if_number 6
Corresponding hwidb firstsw->if_number 6
BGP based Policy accounting on input is enabled
Index Packets Bytes
1 9999 999900
2 0 0
3 0 0
4 0 0
5 0 0
6 0 0
7 0 0
8 0 0
9 0 0
10 0 0
11 0 0
12 0 0
13 0 0
14 0 0
15 0 0
16 0 0
17 0 0
18 0 0
19 0 0
20 0 0
21 0 0
22 0 0
23 0 0
24 0 0
25 0 0
26 0 0
27 0 0
28 0 0
29 0 0
30 0 0
31 0 0
32 0 0
33 0 0
34 1234 123400
35 0 0
36 0 0
37 0 0
38 0 0
39 0 0
40 0 0
41 0 0
42 0 0
43 0 0
44 0 0
45 1000 100000
46 0 0
47 0 0
48 0 0
49 0 0
50 0 0
51 0 0
52 0 0
53 0 0
54 5123 1198782
55 0 0
56 0 0
57 0 0
58 0 0
59 0 0
60 0 0
61 0 0
62 0 0
63 0 0
64 0 0
 

ステップ 4 show cef interface [ type number ] [ statistics ] [ detail ]

show cef interface EXEC コマンドを入力して、指定されたインターフェイスの BGP ポリシー アカウンティングの状態を表示します。

この例では、BGP ポリシー アカウンティングは、ファスト イーサネット インターフェイス 1/0/0 の入力トラフィックに基づいて設定されていることが出力に示されています。

Router# show cef interface Fast Ethernet 1/0/0
 
FastEthernet1/0/0 is up (if_number 6)
Corresponding hwidb fast_if_number 6
Corresponding hwidb firstsw->if_number 6
Internet address is 10.1.1.1/24
ICMP redirects are always sent
Per packet load-sharing is disabled
IP unicast RPF check is disabled
Inbound access list is not set
Outbound access list is not set
IP policy routing is disabled
BGP based policy accounting on input is enabled
BGP based policy accounting on output is disabled
Hardware idb is FastEthernet1/0/0 (6)
Software idb is FastEthernet1/0/0 (6)
Fast switching type 1, interface type 18
IP Distributed CEF switching enabled
IP Feature Fast switching turbo vector
IP Feature CEF switching turbo vector
Input fast flags 0x100, Output fast flags 0x0, Flags 0x0
ifindex 7(7)
Slot 1 Slot unit 0 VC -1
Transmit limit accumulator 0xE8001A82 (0xE8001A82)
IP MTU 1500


 

BGP PA 出力インターフェイス アカウンティングの設定例

ここでは、次の設定例について説明します。

「BGP ポリシー アカウンティングの一致基準の指定:例」

「IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化:例」

BGP ポリシー アカウンティングの一致基準の指定:例

次の例では、BGP コミュニティがコミュニティ リストに指定され、set_bucket という名前のルート マップが、 set traffic-index コマンドを使用して、各コミュニティ リストが特定のアカウンティング バケットに一致するように設定されます。

ip community-list 30 permit 100:190
ip community-list 40 permit 100:198
ip community-list 50 permit 100:197
ip community-list 60 permit 100:296
!
route-map set_bucket permit 10
match community-list 30
set traffic-index 2
!
route-map set_bucket permit 20
match community-list 40
set traffic-index 3
!
route-map set_bucket permit 30
match community-list 50
set traffic-index 4
!
route-map set_bucket permit 40
match community-list 60
set traffic-index 5

IP トラフィックの分類および BGP ポリシー アカウンティングのイネーブル化:例

次の例では、BGP ポリシー アカウンティングが POS インターフェイス 7/0 でイネーブルにされます。ポリシー アカウンティング基準は入力トラフィックの送信元アドレスに基づいており、 table-map コマンドを使用して、IP ルーティング テーブルが BGP から学習したルートで更新されるときにバケット番号を変更するようにします。

router bgp 65000
table-map set_bucket
network 10.15.1.0 mask 255.255.255.0
neighbor 10.14.1.1 remote-as 65100
!
ip classless
ip bgp-community new-format
!
interface POS7/0
ip address 10.15.1.2 255.255.255.0
bgp-policy accounting input source
no keepalive
crc 32
clock source internal

次の作業

その他の BGP、CEF、および dCEF コマンドおよび設定情報は、該当する Cisco IOS コマンド リファレンスまたはコンフィギュレーション ガイド マニュアルから入手できます。詳細については、「関連資料」の項を参照してください。

参考資料

次の項では、BGP ポリシー アカウンティングに関連する参考資料を示します。

関連資料

関連項目
参照先

BGP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Routing: BGP Command Reference』

BGP 設定機能の検索

「BGP Feature Roadmap」 モジュール

スイッチング コマンド:コマンド構文の詳細、コマンド モード、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Switching Command Reference』

CEF および dCEF 設定情報

「Cisco Express Forwarding Overview」 モジュール

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

MIB

MIB
MIB リンク

CISCO-BGP-POLICY-ACCOUNTING-MIB

(注) この MIB は、Cisco IOS リリース 12.0(9)S、12.0(17)ST、12.2(22)S、およびこれ以降のリリースだけで使用できます。この管理情報ベース(MIB)は、いずれのメインラインおよび T トレイン リリースでも使用できません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/iproute_bgp/command/reference/irg_book.html の『 Cisco IOS IP Routing: BGP Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

bgp-policy

set traffic-index

show cef interface

show cef interface policy-statistics

用語集

AS :Autonomous System(自律システム)。独立した独自のルーティング ポリシーを持ち、単一権限によって管理されるルーティング ドメインを表す IP 用語です。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。他の BGP システムとの間で到着可能性情報を交換するドメイン間ルーティング プロトコルです。

CEF :Cisco Express Forwarding(シスコ エクスプレス フォワーディング)。

dCEF :distributed Cisco Express Forwarding(分散シスコ エクスプレス フォワーディング)。