Cisco IOS IP ルーティング:BGP コンフィギュ レーション ガイド
BGP のネイバーごとの SoO 設定
BGP のネイバーごとの SoO 設定
発行日;2012/02/05 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP のネイバーごとの SoO 設定

機能情報の検索

マニュアルの内容

BGP のネイバーごとの SoO 設定の前提条件

BGP のネイバーごとの SoO 設定の制約事項

BGP のネイバーごとの SoO の設定に関する情報

Site of Origin BGP コミュニティ アトリビュート

4 バイト自律システム番号に対する BGP サポート

BGP によるネイバーごとの Site of Origin の設定

BGP のネイバーごとの Site of Origin の利点

BGP のネイバーごとの SoO の設定方法

CEF の確認および VRF インスタンスの設定

ルート識別子

BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定

BGP ピア ポリシー テンプレート

前提条件

制約事項

BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定

前提条件

BGP ピア グループを使用したネイバーごとの SoO 値の設定

前提条件

制約事項

BGP のネイバーごとの SoO 設定の設定例

BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定:例

BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例

BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定:例

BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例

BGP ピア グループを使用したネイバーごとの SoO 値の設定:例

次の作業

参考資料

関連資料

MIB

シスコのテクニカル サポート

BGP のネイバーごとの SoO 設定の機能情報

BGP のネイバーごとの SoO 設定

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)のネイバー Site-of-Origin(SoO)ごとの設定機能を使用すると、SoO 値の設定が簡略化されます。Cisco IOS リリース 12.4(9)T、12.2(33)SRA、12.2(31)SB2、およびこれら以前のリリースでは、SoO 値は、アップデート プロセス中に SoO 値を設定するインバウンド ルート マップを使用して設定されます。ネイバーごとの SoO 設定により、ルータ コンフィギュレーション モードの下のサブモードで設定可能な 2 つの新しいコマンドが導入され、SoO 値が設定されます。Cisco IOS リリース 12.4(24)T では、4 バイト自律システム番号の asdot 形式に限りサポートが追加されました。

機能情報の検索

ご使用のソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「BGP のネイバーごとの SoO 設定の機能情報」を参照してください。

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

BGP のネイバーごとの SoO 設定の前提条件

この機能は、ボーダー ゲートウェイ プロトコル(BGP)ネットワークが設定され、Cisco Express Forwarding(CEF)がご使用のネットワークでイネーブルになっていることを前提としています。

BGP のネイバーごとの SoO 設定の制約事項

BGP ネイバーまたはピア ポリシーのテンプレート ベースの SoO 設定は、インバウンド ルート マップで設定された SoO 値よりも優先されます。

BGP のネイバーごとの SoO の設定に関する情報

BGP ネイバーの SoO 値を設定する前に、次の概念を理解しておく必要があります。

「Site of Origin BGP コミュニティ アトリビュート」

「4 バイト自律システム番号に対する BGP サポート」

「BGP によるネイバーごとの Site of Origin の設定」

「BGP のネイバーごとの Site of Origin の利点」

Site of Origin BGP コミュニティ アトリビュート

Site-of-Origin(SoO)拡張コミュニティは、サイトを発信元とするルートを識別し、そのプレフィクスの再アドバタイズメントが送信元のサイトに戻されることを防ぐために使用される BGP 拡張コミュニティ アトリビュートです。この SoO 拡張コミュニティは、ルータがルートを学んだサイトを一意に識別します。BGP は、ルートに関連付けられた SoO 値を使用し、ルーティング ループを防止できます。

4 バイト自律システム番号に対する BGP サポート

Cisco IOS リリース 12.4(24)T では、RFC 5396 の『 Textual Representation of Autonomous System (AS) Numbers 』で説明されているとおり、4 バイト自律システム番号のサポートが追加されました。Cisco IOS リリース 12.4(24)T では、4 バイト自律システム番号の Cisco による実装は、設定形式、正規表現一致、および出力表示として asdot 表記(1.2 など)だけを使用し、asplain 形式はサポートしません。

Cisco IOS リリース 12.2(33)SRE、12.2(33)XNE、およびこれら以降のリリースでは、デフォルト形式として asplain 形式を使用する 4 オクテット(4 バイト)自律システム番号に対する BGP サポートが導入されました。デフォルトの asplain 形式は、65536 などの 10 進数値を使用しますが、4 バイト自律システム番号を asplain 形式と asdot 形式の両方で設定できます。デフォルトの show コマンド出力で、4 バイト自律システム番号が asdot 形式で表示されるように変更する場合は、ルータ コンフィギュレーション モードで bgp asnotation dot コマンドを使用します。

4 バイト自律システム番号に関する設定例については、「BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」または「BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」を参照してください。

BGP 自律システム番号形式の Cisco による実装の詳細については、「 Cisco BGP Overview 」モジュールを参照してください。

BGP によるネイバーごとの Site of Origin の設定

BGP ネイバーに SoO 値を設定するには 3 つの方法があります。

BGP ピア ポリシー テンプレート:ピア ポリシー テンプレートが作成され、SoO 値がこのピア ポリシーの一部として設定されます。アドレス ファミリ IPv4 Virtual Routing and Forwarding(VRF; 仮想ルーティング/転送)の下で、ネイバーが特定され、SoO 値を含むピア ポリシーを継承するように設定されます。

BGP neighbor コマンド:アドレス ファミリ IPv4 VRF の下で、ネイバーが特定され、SoO 値がこのネイバーに設定されます。

BGP ピア グループ:アドレス ファミリ IPv4 VRF の下で、BGP ピア グループが設定され、SoO 値がそのピア グループに設定され、ネイバーが特定され、このネイバーがこのピア グループのメンバとして設定されます。

BGP ネイバーに対する SoO 値の設定は、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)の入り口である Provider Edge(PE; プロバイダー エッジ)ルータで実行されます。SoO がイネーブルになると、プレフィクスの SoO タグが Customer Premises Equipment(CPE; 顧客宅内機器)用に設定された SoO タグと一致しない場合だけ PE ルータがプレフィクスを CPE に転送します。たとえば、図 1 では、SoO タグは、自律システム番号 65000 のルータ CPE1 と CPE2 を含むお客様のサイトに対して 65000:1 に設定されています。CPE1 がプレフィクスを PE1 に送信すると、PE1 は、このプレフィクスに CPE1 および CPE2 の SoO タグである 65000:1 をタグ付けします。PE1 がタグを付けられたプレフィクスを PE2 に送信すると、PE2 は、CPE2 から SoO タグに対する一致処理を実行します。タグ値が 65000:1 であるすべてのプレフィクスは、SoO タグが CPE2 の SoO タグと一致するため、CPE2 には送信されず、ルーティング ループが回避されます。

図 1 SoO に対するネットワーク ダイアグラム例

 

BGP のネイバーごとの Site of Origin の利点

Cisco IOS リリース 12.4(11)T、12.2(33)SRB、および 12.2(33)SB 以前のリリースでは、SoO 拡張コミュニティ アトリビュートは、アップデート プロセス中に SoO 値を設定するインバウンド ルート マップを使用して設定されます。ルータ コンフィギュレーション モードの下のサブモードで設定される 2 つの新しいコマンドの導入により、SoO 値の設定が簡素化されます。

BGP のネイバーごとの SoO の設定方法

BGP ネイバーに SoO 値を設定するには、次のリストの最初の作業およびその次の 3 つの作業のいずれかを実行する必要があります。最後の 3 つの作業は、相互に排他的な関係です。これらのうち 1 つだけを実行する必要があります。

「CEF の確認および VRF インスタンスの設定」

「BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定」

「BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定」

「BGP ピア グループを使用したネイバーごとの SoO 値の設定」

CEF の確認および VRF インスタンスの設定

次の作業を図 1 の両方の PE ルータで実行し、仮想ルーティング/転送(VRF)インスタンスを VRF 割り当てごとの作業とともに使用されるように設定します。この作業では、CEF がイネーブルであることが確認された後、SOO_VRF という名前の VRF インスタンスが設定されます。この VRF を機能させるために、ルート識別子が作成され、この VRF はインターフェイスに関連付けられます。ルート識別子が作成されると、SOO_VRF という名前の VRF インスタンスにルーティング テーブルおよびフォワーディング テーブルが作成されます。VRF をインターフェイスと関連付けた後、インターフェイスは、IP アドレスによって設定されます。

ルート識別子

Route Distinguisher(RD; ルート識別子)はルーティング テーブルとフォワーディング テーブルを作成し、VPN のデフォルトのルート識別子を指定します。IPv4 プレフィクスをグローバルに固有の VPN-IPv4 プレフィクスに変更するために、RD が IPv4 プレフィクスの先頭に追加されます。RD は、自律システム番号と任意番号、または IP アドレスと任意番号のいずれかで構成できます。

RD は、次のいずれかの形式で入力できます。

16 ビット自律システム番号、コロン、32 ビット番号を入力します。次に例を示します。

45000:3

32 ビット IP アドレス、コロン、16 ビット番号を入力します。次に例を示します。

192.168.10.15:1

手順の概要

1. enable

2. show ip cef

3. configure terminal

4. ip vrf vrf-name

5. rd route-distinguisher

6. route-target { import | both } route-target-ext-community

7. route-target { export | both } route-target-ext-community

8. exit

9. interface type number

10. ip vrf forwarding vrf-name [ downstream vrf-name2 ]

11. ip address ip-address mask [ secondary ]

12. end

13. show ip vrf [ brief | detail | interfaces | id ] [ vrf-name ] [ output-modifiers ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip cef

 

Router# show ip cef

CEF がイネーブルであることを確認します。

CEF は、ほとんどの Cisco IOS リリースで、デフォルトでイネーブルになっています。

CEF がイネーブルでない場合、 ip cef コマンドをグローバル コンフィギュレーション モードで入力します。一部のプラットフォームでは、このコマンドとともに追加のキーワードが必要です。詳細については、『 Cisco IOS IP Switching Command Reference 』を参照してください。

ステップ 3

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 4

ip vrf vrf-name

 

Router(config)# ip vrf SOO_VRF

VRF インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

ステップ 5

rd route-distinguisher

 

Router(config-vrf)# rd 1:1

VRF にルーティング テーブルとフォワーディング テーブルを作成し、VPN にデフォルト RD を指定します。

VPN にデフォルト RD を指定するには、 route-distinguisher 引数を使用します。次の 2 つの形式を使用して RD を指定できます。

16 ビットの自律システム番号、コロン、および 32 ビットの数字(例:65000:3)。

32 ビットの IP アドレス、コロン、および 16 ビットの数字
(例:192.168.1.2:51)

この例では、RD は自律システム番号とコロンの後に数字 1 を使用しています。

ステップ 6

route-target { export | both } route-target-ext-community

 

Router(config-vrf)# route-target export 1:1

VRF 用にルート ターゲット拡張コミュニティを作成します。

ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートするには、 export キーワードを使用します。

ターゲット VPN 拡張コミュニティからルーティング情報をインポートするとともに、ルーティング情報を拡張コミュニティにエクスポートするには、 both キーワードを使用します。

VPN 拡張コミュニティを指定するには、 route-target-ext-community 引数を使用します。

(注) この手順に適用される構文だけが表示されます。この構文の別の使用方法については、ステップ 7 を参照してください。

ステップ 7

route-target { import | both } route-target-ext-community

 

Router(config-vrf)# route-target import 1:1

VRF 用にルート ターゲット拡張コミュニティを作成します。

ターゲット VPN 拡張コミュニティからルーティング情報をインポートするには、 import キーワードを使用します。

ターゲット VPN 拡張コミュニティからルーティング情報をインポートするとともに、ルーティング情報を拡張コミュニティにエクスポートするには、 both キーワードを使用します。

VPN 拡張コミュニティを指定するには、 route-target-ext-community 引数を使用します。

ステップ 8

exit

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface Ethernet 1/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

この例では、イーサネット インターフェイス 1/0 が設定されます。

ステップ 10

ip vrf forwarding vrf-name [ downstream vrf-name2 ]

 

Router(config-if)# ip vrf forwarding SOO_VRF

VRF をインターフェイスまたはサブインターフェイスと関連付けます。

この例では、SOO_VRF という名前の VRF がイーサネット インターフェイス 1/0 と関連付けられます。

(注) このコマンドをインターフェイス上で実行すると、IP アドレスが削除されるため、IP アドレスを再設定する必要があります。

ステップ 11

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 192.168.1.2 255.255.255.0

IP アドレスを設定します。

この例では、イーサネット インターフェイス 1/0 が IP アドレス 192.168.1.2 で設定されます。

ステップ 12

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 13

show ip vrf [ brief | detail | interfaces | id ] [ vrf-name ] [ output-modifiers ]

 

Router# show ip vrf

設定された VRF を表示します。

このコマンドを使用して、この作業の設定を確認します。

show ip vrf コマンドの次の出力は、この作業で設定された SOO_VRF という名前の VRF を表示します。

Router# show ip vrf
 
Name Default RD Interfaces
SOO_VRF 1:1 Eth1/0

BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定

次の作業を図 1 のルータ PE1 で実行し、ピア ポリシー テンプレートを使用して、図 1 のルータ CPE1 で BGP ネイバーに SoO 値を設定します。この作業では、ピア ポリシー テンプレートが作成され、SoO 値がピア ポリシーに対して設定されます。アドレス ファミリ IPv4 仮想ルーティング/転送(VRF)の下で、ネイバーが特定され、SoO 値を含むピア ポリシーを継承するように設定されます。

4 バイト自律システム番号に関する設定例については、「BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」を参照してください。


) BGP ピアが異なる SoO 値を指定する複数のピア ポリシー テンプレートから継承される場合、最後に適用されたテンプレートの SoO 値が優先され、ピアに適用されます。ただし、BGP ネイバーで SoO 値を直接設定すると、SoO 値の、継承されたあらゆるテンプレート設定が上書きされます。


BGP ピア ポリシー テンプレート

ピア ポリシー テンプレートは、特定のアドレス ファミリに属するネイバーに設定される BGP ポリシー コマンドの設定に使用します。ピア ポリシー テンプレートは、1 回設定され、その後、ピア ポリシー テンプレートを直接適用するか、またはピア ポリシー テンプレートから継承することによって、多くのネイバーに適用されます。ピア ポリシー テンプレートの設定により、自律システム内のすべてのネイバーに適用される BGP ポリシー コマンドの設定が簡略化されます。

ピア ポリシー テンプレートは継承をサポートします。直接適用されたピア ポリシー テンプレートは、最大 7 つのピア ポリシー テンプレートから設定を直接的または間接的に継承できます。したがって、合計 8 つのピア ポリシー テンプレートをネイバーまたはネイバー グループに適用できます。

ピア ポリシー テンプレートの設定により、BGP 設定が簡略化され、柔軟性が向上します。特定のポリシーを 1 回設定すれば、何回も参照できます。ピア ポリシーは最大 8 レベルの継承をサポートするため、非常に具体的で複雑な BGP ポリシーを作成できます。

BGP ピア ポリシー テンプレートの詳細については、 「Configuring a Basic BGP Network」 モジュールを参照してください。

前提条件

この作業は、「CEF の確認および VRF インスタンスの設定」で説明された作業が実行済みであることを前提としています。

制約事項

BGP ピアは、ピア ポリシー テンプレートまたはピア セッション テンプレートからの継承と、ピア グループ メンバとしての設定を同時に行うことはできません。BGP テンプレートと BGP ピア グループは同時に使用できません。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. template peer-policy policy-template-name

5. soo extended-community-value

6. exit-peer-policy

7. address-family ipv4 [ unicast | multicast | vrf vrf-name ]

8. neighbor ip-address remote-as autonomous-system-number

9. neighbor ip-address activate

10. neighbor ip-address inherit peer-policy policy-template-name

11. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 50000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

template peer-policy policy-template-name

 

Router(config-router)# template peer-policy SOO_POLICY

ピア ポリシー テンプレートを作成し、ポリシー テンプレート コンフィギュレーション モードを開始します。

ステップ 5

soo extended-community-value

 

Router(config-router-ptmp)# soo 65000:1

SoO 値を BGP ピア ポリシー テンプレートに設定します。

extended-community-value 引数を使用して、VPN 拡張コミュニティ値を指定します。この値は、次のいずれかの形式です。

16 ビットの自律システム番号、コロン、および 32 ビットの数字(例:45000:3)。

32 ビットの IP アドレス、コロン、および 16 ビットの数字(例:192.168.10.2:51)

この例では、SoO 値は、65000:1 に設定されます。

ステップ 6

exit-peer-policy

 

Router(config-router-pmtp)# exit-peer-policy

ポリシー テンプレート コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 7

address-family ipv4 [ unicast | multicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf SOO_VRF

IPv4 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

IPv4 ユニキャスト アドレス ファミリを指定するには、キーワード unicast を使用します。デフォルトでは、 address-family ipv4 コマンドに unicast キーワードが指定されていない場合、ルータは IPv4 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

IPv4 マルチキャスト アドレス プレフィクス を指定するには、 multicast キーワードを使用します。

後続する IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF インスタンス名を指定するには、 vrf キーワードと vrf-name 引数を使用します。

ステップ 8

neighbor ip-address remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 65000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

ステップ 9

neighbor ip-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーをイネーブルにして、IPv4 VRF アドレス ファミリのプレフィクスをローカル ルータと交換します。

ステップ 10

neighbor ip-address inherit peer-policy policy-template-name

 

Router(config-router-af)# neighbor 192.168.1.1 inherit peer-policy SOO_POLICY

ネイバーが設定を継承できるように、ピア ポリシー テンプレートをこのネイバーに送信します。

この例では、このルータは、SOO_POLICY という名前のピア ポリシー テンプレートを 192.168.1.1 ネイバーに送信して継承するように設定されます。別のピア ポリシー テンプレートが間接的に SOO_POLICY から継承される場合、間接的に継承された設定も適用されます。最大 7 つの追加ピア ポリシー テンプレートを SOO_POLICY から間接的に継承できます。

ステップ 11

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定

次の作業を図 1 のルータ PE2 で実行し、 neighbor コマンドを使用して、図 1 のルータ CPE2 で BGP ネイバーに SoO 値を設定します。アドレス ファミリ IPv4 VRF の下で、ネイバーが特定され、SoO 値がこのネイバーに設定されます。

4 バイト自律システム番号に関する設定例については、「BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」を参照してください。


) BGP ネイバーで SoO 値を直接設定すると、継承されたあらゆる SoO 値のピア ポリシー テンプレート設定が上書きされます。


前提条件

この作業は、「CEF の確認および VRF インスタンスの設定」で説明された作業が適切な変更を加えてインターフェイスおよび IP アドレスに対して実行されていることを前提としています。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 [ unicast | multicast | vrf vrf-name ]

5. neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

6. neighbor ip-address activate

7. neighbor { ip-address | peer-group-name } soo extended-community-value

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 50000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast | multicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf SOO_VRF

IPv4 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

IPv4 ユニキャスト アドレス ファミリを指定するには、キーワード unicast を使用します。デフォルトでは、 address-family ipv4 コマンドに unicast キーワードが指定されていない場合、ルータは IPv4 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

IPv4 マルチキャスト アドレス プレフィクス を指定するには、 multicast キーワードを使用します。

後続する IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF インスタンス名を指定するには、 vrf キーワードと vrf-name 引数を使用します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.2.1 remote-as 65000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

ステップ 6

neighbor ip-address activate

 

Router(config-router-af)# neighbor 192.168.2.1 activate

このネイバーをイネーブルにして、IPv4 VRF アドレス ファミリのプレフィクスをローカル ルータと交換します。

この例では、外部 BGP ピア 192.168.2.1 がアクティブ化されます。

コマンドを使用して SoO 値が設定されるときにアクティブになります。

ステップ 7

neighbor { ip-address | peer-group-name } soo extended-community-value

 

Router(config-router-af)# neighbor 192.168.2.1 soo 65000:1

BGP ネイバーまたはピア グループの Site-of-Origin(SoO)値を設定します。

この例では、ネイバー 192.168.2.1 が SoO 値 65000:1 で設定されます。

ステップ 8

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP ピア グループを使用したネイバーごとの SoO 値の設定

この作業を図 1 のルータ PE1 で実行し、 neighbor コマンドと BGP ピア グループ使用して、図 1 のルータ CPE1 で BGP ネイバーに SoO 値を設定します。アドレス ファミリ IPv4 VRF の下に BGP ピア グループが作成され、BGP neighbor コマンドを使用して SoO 値が設定され、その後ネイバーが特定され、ピア グループ メンバとして追加されます。BGP ピア グループ メンバは、ピア グループに関連付けられた設定を継承します。この例では、ピア グループには SoO 値が含まれます。


) BGP ネイバーで SoO 値を直接設定すると、継承されたあらゆる SoO 値のピア グループ設定が上書きされます。


前提条件

この作業は、「CEF の確認および VRF インスタンスの設定」で説明された作業が実行済みであることを前提としています。

制約事項

BGP ピアは、ピア ポリシー テンプレートまたはピア セッション テンプレートからの継承と、ピア グループ メンバとしての設定を同時に行うことはできません。BGP テンプレートと BGP ピア グループは同時に使用できません。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. address-family ipv4 [ unicast | multicast | vrf vrf-name ]

5. neighbor peer-group-name peer-group

6. neighbor { ip-address | peer-group-name } soo extended-community-value

7. neighbor ip-address remote-as autonomous-system-number

8. neighbor ip-address activate

9. neighbor ip-address peer-group peer-group-name

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 50000

指定されたルーティング プロセスでルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast | multicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf SOO_VRF

IPv4 アドレス ファミリを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

IPv4 ユニキャスト アドレス ファミリを指定するには、キーワード unicast を使用します。デフォルトでは、 address-family ipv4 コマンドに unicast キーワードが指定されていない場合、ルータは IPv4 ユニキャスト アドレス ファミリのコンフィギュレーション モードになります。

IPv4 マルチキャスト アドレス プレフィクス を指定するには、 multicast キーワードを使用します。

後続する IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF インスタンス名を指定するには、 vrf キーワードと vrf-name 引数を使用します。

ステップ 5

neighbor peer-group-name peer-group

 

Router(config-router-af)# neighbor SOO_group peer-group

BGP ピア グループを作成します。

ステップ 6

neighbor { ip-address | peer-group-name } soo extended-community-value

 

Router(config-router-af)# neighbor SOO_group soo 65000:1

BGP ネイバーまたはピア グループの Site-of-Origin(SoO)値を設定します。

この例では、BGP ピア グループである SOO_group が SoO 値 65000:1 を使用して設定されます。

ステップ 7

neighbor ip-address remote-as autonomous-system-number

 

Router(config-router-af)# neighbor 192.168.1.1 remote-as 65000

指定された自律システムのネイバーの IP アドレスを、ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに追加します。

ステップ 8

neighbor ip-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーをイネーブルにして、IPv4 VRF アドレス ファミリのプレフィクスをローカル ルータと交換します。

ステップ 9

neighbor ip-address peer-group peer-group-name

 

Router(config-router-af)# neighbor 192.168.1.1 peer-group SOO_group

BGP ネイバーの IP アドレスをピア グループに割り当てます。

ステップ 10

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

BGP のネイバーごとの SoO 設定の設定例

ここでは、次の設定例について説明します。

「BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定:例」

「BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」

「BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定:例」

「BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」

「BGP ピア グループを使用したネイバーごとの SoO 値の設定:例」

BGP ピア ポリシー テンプレートを使用したネイバーごとの SoO 値の設定:例

次に、ピア ポリシー テンプレートを作成し、SoO 値をピア ポリシーの一部として設定する方法の例を示します。CEF がイネーブルであることを確認し、SOO_VRF という名前の VRF インスタンスを設定した後、ピア ポリシー テンプレートが作成され、SoO 値がピア ポリシーの一部として設定されます。アドレス ファミリ IPv4 VRF の下で、ネイバーが特定され、SoO 値を含むピア ポリシーを継承するように設定されます。

show ip cef
ip vrf SOO_VRF
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Ethernet 1/0
ip vrf forwarding SOO_VRF
ip address 192.168.1.2 255.255.255.0
exit
router bgp 50000
template peer-policy SOO_POLICY
soo 65000:1
exit-peer-policy
address-family ipv4 vrf SOO_VRF
neighbor 192.168.1.1 remote-as 65000
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 inherit peer-policy SOO_POLICY
end

BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例

次に、ピア ポリシー テンプレートを作成し、4 バイト自律システム番号(asdot 形式の 1.2)を使用して SoO 値をピア ポリシーの一部として設定する方法の例を示します。アドレス ファミリ IPv4 VRF の下で、ネイバーが特定され、SoO 値を含むピア ポリシーを継承するように設定されます。この例では、Cisco IOS リリース 12.4(24)T、または以降のリリースが必要です。

router bgp 1.2
template peer-policy SOO_POLICY
soo 1.2:3
exit-peer-policy
address-family ipv4 vrf SOO_VRF
neighbor 192.168.3.2 remote-as 1.14
neighbor 192.168.3.2 activate
neighbor 192.168.3.2 inherit peer-policy SOO_POLICY
end
 

次に、ピア ポリシー テンプレートを作成し、4 バイト自律システム番号(asplain 形式の 65538)を使用して SoO 値をピア ポリシーの一部として設定する方法の例を示します。アドレス ファミリ IPv4 VRF の下で、ネイバーが特定され、SoO 値を含むピア ポリシーを継承するように設定されます。この例では、Cisco IOS リリース 12.2(33)SRE、12.2(33)XNE、または以降のリリースが必要です。

router bgp 65538
template peer-policy SOO_POLICY
soo 65538:3
exit-peer-policy
address-family ipv4 vrf SOO_VRF
neighbor 192.168.3.2 remote-as 65550
neighbor 192.168.3.2 activate
neighbor 192.168.3.2 inherit peer-policy SOO_POLICY
end

BGP ネイバー コマンドを使用したネイバーごとの SoO 値の設定:例

次に、BGP ネイバーに SoO 値を設定する方法の例を示します。CEF がイネーブルであることを確認後、SOO_VRF という名前の VRF インスタンスが設定され、ネイバーがアドレス ファミリ IPv4 VRF の下で特定され、SoO 値がこのネイバーに設定されます。

show ip cef
ip vrf SOO_VRF
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Ethernet 1/0
ip vrf forwarding SOO_VRF
ip address 192.168.2.2 255.255.255.0
exit
router bgp 50000
address-family ipv4 vrf SOO_VRF
neighbor 192.168.2.1 remote-as 65000
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 soo 65000:1
end

BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例

次に、BGP ネイバーに SoO 値を設定する方法の例を示します。この例では、すべての BGP ネイバー、ルート ターゲット、および SoO 値が 4 バイト自律システム番号を asplain 形式で使用します。CEF がイネーブルであることが確認された後、SOO_VRF という名前の VRF インスタンスがルート ターゲットによって設定されます。BGP ルータ セッションでネイバーがアドレス ファミリ IPv4 VRF の下で特定され、SoO 値がこのネイバーに設定されます。この例では、Cisco IOS リリース 12.4(24)T、または以降のリリースが必要です。

show ip cef
ip vrf SOO_VRF
rd 100:200
route-target export 1.14:1
route-target import 1.14:1
exit
interface Ethernet 1/0
ip vrf forwarding SOO_VRF
ip address 192.168.2.2 255.255.255.0
exit
router bgp 1.2
address-family ipv4 vrf SOO_VRF
neighbor 192.168.2.1 remote-as 1.14
neighbor 192.168.2.1 activate
neighbor 192.168.2.1 soo 1.14:1
end

BGP ピア グループを使用したネイバーごとの SoO 値の設定:例

次に、BGP ピア グループに SoO 値を設定する方法の例を示します。CEF がイネーブルであることを確認後、SOO_VRF という名前の VRF インスタンスが設定され、BGP ピア グループがアドレス ファミリ IPv4 VRF の下に設定され、SoO 値がピア グループに設定され、ネイバーが特定され、このネイバーがピア グループのメンバとして設定されます。

show ip cef
ip vrf SOO_VRF
rd 1:1
route-target export 1:1
route-target import 1:1
exit
interface Ethernet 1/0
ip vrf forwarding SOO_VRF
ip address 192.168.1.2 255.255.255.0
exit
router bgp 50000
address-family ipv4 vrf SOO_VRF
neighbor SOO_GROUP peer-group
neighbor SOO_GROUP soo 65000:65
neighbor 192.168.1.1 remote-as 65000
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 peer-group SOO_GROUP
end

次の作業

BGP の概要を表示するには、 「Cisco BGP Overview 」モジュールに進みます。

基本的な BGP 機能の作業を実行するには、 「Configuring a Basic BGP Network 」モジュールに進みます。

BGP の拡張機能の作業を実行するには、 「Configuring Advanced BGP Features」 モジュールに進みます。

BGP ネイバー セッションのオプションを設定するには、 「Configuring BGP Neighbor Session Options」 モジュールに進みます。

内部 BGP 作業を実行するには、 「Configuring Internal BGP Features」 モジュールに進みます。

参考資料

ここでは、ネイバーごとの SoO 設定に対する BGP サポート機能に関連する参考資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

BGP コマンド:コマンド構文の詳細、コマンド モード、デフォルト、コマンド履歴、使用上の注意事項、および例

『Cisco IOS IP Routing: BGP Command Reference』

IP スイッチング コマンド(コマンド構文の詳細、コマンド モード、デフォルト、コマンド履歴、使用上の注意事項、例)

『Cisco IOS IP Switching Command Reference』

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

BGP のネイバーごとの SoO 設定の機能情報

表 1 に、この機能のリリース履歴を示します。

このテクノロジーの機能でここに記載されていないものについては、『 BGP Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 BGP のネイバーごとの SoO 設定の機能情報

機能名
リリース
機能情報

BGP のネイバーごとの SoO 設定

12.2(33)SB
12.2(33)SRB
12.4(11)T

BGP のネイバー SOO ごとの設定機能を使用すると、Site-of-Origin(SoO)パラメータの設定が簡略化されます。Cisco IOS リリース 12.4(9)T、12.2(33)SRA、12.2(31)SB2、およびこれら以前のリリースでは、SoO パラメータは、アップデート プロセス中に SoO 値を設定するインバウンド ルート マップを使用して設定されます。ネイバーごとの SoO 設定により、ルータ コンフィギュレーション モードの下のサブモードで設定可能な 2 つの新しいコマンドが導入され、SoO 値が設定されます。

次のコマンドがこの機能によって導入されました。 neighbor soo soo

4 バイト ASN に対する BGP サポート

12.0(32)S12
12.0(32)SY8
12.2(33)SRE
12.2(33)XNE
12.4(24)T

4 バイト ASN に対する BGP サポート機能により、4 バイト自律システム番号がサポートされるようになりました。自律システム番号の要求の増加に伴い、Internet Assigned Number Authority(IANA; インターネット割り当て番号局)は 2009 年 1 月から 65536 ~ 4294967295 の範囲の 4 バイト自律システム番号の割り当てを開始します。

Cisco IOS リリース 12.0(32)SY8、12.2(33)SRE、および 12.2(33)XNE では、4 バイト自律システム番号の Cisco による実装は、自律システム番号のデフォルトの正規表現一致および出力表示形式として asplain 形式を使用しますが、RFC 5396 で説明されているように、4 バイト自律システム番号を asplain 形式と asdot 形式の両方に設定できます。4 バイト自律システム番号の正規表現マッチングと出力表示のデフォルトを asdot 形式に変更するには、 bgp asnotation dot コマンドを使用します。

Cisco IOS リリース 12.0(32)S12 および 12.4(24)T では、4 バイト自律システム番号の設定形式、正規表現マッチング、出力表示の実装として、シスコは asdot だけを使用しており、asplain はサポートされていません。

次の項で、この機能に関する情報を参照できます。

「4 バイト自律システム番号に対する BGP サポート」

「BGP ピア ポリシー テンプレートを使用し、4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」

「BGP ネイバー コマンドおよび 4 バイト自律システム番号を使用したネイバーごとの SoO 値の設定:例」

次のコマンドがこの機能によって変更されました。 bgp asnotation dot bgp confederation identifier bgp confederation peers clear ip bgp ip bgp-community new-format ip extcommunity-list match source-protocol neighbor local-as neighbor remote-as neighbor soo redistribute( IP router bgp set as-path set extcommunity set origin soo 、および自律システム番号を表示するすべての show ip bgp コマンド。