Cisco IOS IP ルーティング:BGP コンフィギュ レーション ガイド
BGP コスト コミュニティ
BGP コスト コミュニティ
発行日;2012/02/05 | 英語版ドキュメント(2011/11/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

BGP コスト コミュニティ

機能情報の検索

マニュアルの内容

BGP コスト コミュニティ機能の前提条件

BGP コスト コミュニティ機能の制約事項

BGP コスト コミュニティ機能に関する情報

BGP コスト コミュニティの概要

BGP コスト コミュニティはどのように最良パス選択プロセスに影響するか

集約ルートおよびマルチパスに対するコスト コミュニティのサポート

マルチエグジット IGP ネットワークにおけるルート プリファレンスの反映

バックドア リンクを持つ EIGRP MPLS VPN Provider Edge-Customer Edge(PE-CE)に対する BGP コスト コミュニティ サポート

BGP コスト コミュニティ機能の設定方法

BGP コスト コミュニティの設定

BGP コスト コミュニティの設定確認

トラブルシューティングのヒント

BGP コスト コミュニティ機能の設定例

BGP コスト コミュニティ設定例

BGP コスト コミュニティ検証例

次の作業

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

BGP コスト コミュニティの機能情報

BGP コスト コミュニティ

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)コスト コミュニティ機能により、コスト拡張コミュニティ アトリビュートが導入されます。コスト コミュニティとは、非遷移の拡張コミュニティ アトリビュートで、internal BGP(iBGP; 内部 BGP)およびコンフェデレーション ピアには渡されますが、external BGP(eBGP; 外部 BGP)ピアには渡されません。コスト コミュニティ機能により、コスト値を特定のルートに割り当てることで、ローカル ルート プリファレンスをカスタマイズし、最良パス選択プロセスに反映させることができます。

Cisco IOS リリース 12.0(27)S、12.3(8)T、12.2(25)S、およびそれ以降のリリースでは、Virtual Private Network(VPN; バーチャル プライベート ネットワーク)およびバックドア リンクを備えた多様な Enhanced Interior Gateway Routing Protocol(EIGRP; 拡張内部ゲートウェイ ルーティング プロトコル)Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN ネットワーク トポロジのためにサポートが導入されました。

機能情報の検索

ご使用のソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「BGP コスト コミュニティの機能情報」を参照してください。

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

BGP コスト コミュニティ機能の前提条件

このマニュアルは、BGP がネットワークで設定されていること、およびピアリングが確立されていることを前提としています。

BGP コスト コミュニティ機能の制約事項

BGP コスト コミュニティ機能には次の制約事項が適用されます。

BGP コスト コミュニティ機能が設定できるのは、自律システムまたはコンフェデレーション内だけです。コスト コミュニティは非遷移の拡張コミュニティ アトリビュートで、iBGP およびコンフェデレーション ピアだけに渡され、eBGP ピアには渡されません。

コスト コミュニティ フィルタリングを設定するには、BGP コスト コミュニティ機能がすべての自律システムまたはコンフェデレーションでサポートされている必要があります。潜在的なルーティング ループを回避するために、コスト コミュニティはローカルの自律システムまたはコンフェデレーション全体に一貫して適用される必要があります。

単一のルート マップ ブロックまたはシーケンスにおいて、 set extcommunity cost コマンドで複数の cost community set 句を設定することも可能です。ただし、各 set 句は、各 Point Of Insertion(POI; 挿入ポイント)に対し異なる ID 値(0 ~ 255)を持つよう設定する必要があります。ID 値は、その他のアトリビュートがすべて等しい場合に、プリファレンスを決定します。最も小さい ID 値が優先されます。

BGP コスト コミュニティ機能に関する情報

BGP コスト コミュニティ機能を設定するには、次の概念について理解する必要があります。

「BGP コスト コミュニティの概要」

「BGP コスト コミュニティはどのように最良パス選択プロセスに影響するか」

「集約ルートおよびマルチパスに対するコスト コミュニティのサポート」

「マルチエグジット IGP ネットワークにおけるルート プリファレンスの反映」

「バックドア リンクを持つ EIGRP MPLS VPN Provider Edge-Customer Edge(PE-CE)に対する BGP コスト コミュニティ サポート」

BGP コスト コミュニティの概要

コスト コミュニティは非遷移の拡張コミュニティ アトリビュートで、iBGP およびコンフェデレーション ピアには渡されますが、eBGP ピアには渡されません。BGP コスト コミュニティ機能のコンフィギュレーションにより、ローカルの自律システムまたはコンフェデレーションにおける BGP 最良パス選択プロセスがカスタマイズできます。

コスト コミュニティ アトリビュートは、ルート マップで set extcommunity cost コマンドを設定することにより、内部ルートに適用されます。cost community set 句は、コスト コミュニティ ID 番号(0 ~ 255)およびコスト番号(0 ~ 4294967295)で設定されます。パスのプリファレンスは、コスト番号値により決定されます。最も小さいコスト コミュニティ番号を持つパスが優先されます。コスト コミュニティ アトリビュートで特別に設定されていないパスは、デフォルトのコスト番号値である 2147483647(0 ~ 4294967295 の中央値)が割り当てられ、最良パス選択プロセスにより評価されます。2 つのパスに同一のコスト番号値が設定されている場合、パス選択プロセスにより最も小さいコスト コミュニティ ID を持つパスが優先されます。コスト拡張コミュニティ アトリビュートは、 neighbor send-community コマンドにより拡張コミュニティ交換がイネーブルになったときに iBGP ピアに伝播されます。

cost community set 句で設定されたルート マップの適用に使用できるコマンドは、次のとおりです。

aggregate-address

neighbor default-originate route-map {in | out}

neighbor route-map

network route-map

redistribute route-map

BGP コスト コミュニティはどのように最良パス選択プロセスに影響するか

BGP 最良パス選択プロセスは、挿入ポイント(POI)においてコスト コミュニティ アトリビュートの影響を受けます。デフォルトでは、POI は Interior Gateway Protocol(IGP)メトリック比較に準拠します。同一の宛先に向かう複数のパスを受信したとき、BGP は最良パス選択プロセスを使用して、いずれのパスが最良パスであるかを決定します。最良パスは BGP により自動的に決定され、ルーティング テーブルにインストールされます。複数の等価コスト パスが使用可能な場合、POI で特定のパスにプリファレンスを割り当てることができます。ローカルの最良パス選択で POI が有効でない場合は、コスト コミュニティ アトリビュートは暗黙的に無視されます。

コスト コミュニティ アトリビュートを使用して、同一の POI に対し複数のパスを設定できます。最も小さいコスト コミュニティ ID を持つパスが最優先されます。つまり、特定の POI に対するすべてのコスト コミュニティ パスは、最も小さいコスト コミュニティを持つパスから考慮されていきます。コスト コミュニティを持たないパス(POI でコミュニティ ID が評価されるもの)には、デフォルトのコミュニティ コスト値(2147483647)が割り当てられます。コスト コミュニティ値が等しい場合、コスト コミュニティ比較は次にその POI において最も小さいコミュニティ ID を持つパスに進みます。


) パスにコスト コミュニティ アトリビュートが設定されていない場合、最良パス選択プロセスはそのパスにデフォルトのコスト値(最大値 [4294967295] の半分である 2147483647)が割り当てられているものと見なします。


POI でコスト コミュニティ アトリビュートを適用することで、ローカルの自律システムまたはコンフェデレーションにおける任意のピアを起点とするパスまたは任意のピアで学習したパスに、値を割り当てることができるようになります。コスト コミュニティは、最良パス選択プロセス中の「タイ ブレーカ」として使用できます。同一の自律システムまたはコンフェデレーションにおける別個の等コスト パスに対し、コスト コミュニティのインスタンスを複数設定できます。たとえば、複数の等コスト出口ポイントがあるネットワークにおいて、特定の出口パスに、より低いコスト コミュニティ値を適用すれば、そのパスは BGP 最良パス選択プロセスにより優先されることになります。「マルチエグジット IGP ネットワークにおけるルート プリファレンスの反映」 に記載されているシナリオを参照してください。

集約ルートおよびマルチパスに対するコスト コミュニティのサポート

BGP コスト コミュニティ機能により、集約ルートおよびマルチパスがサポートされています。コスト コミュニティ アトリビュートは、いずれかのルートのタイプに適用できます。コスト コミュニティ アトリビュートは、コスト コミュニティ アトリビュートを伝送するコンポーネント ルートから集約ルートまたはマルチパス ルートに伝送されます。伝送されるのは一意の ID だけであり、個々のコンポーネント ルートの中で最も高いコストが、ID 単位で集約に適用されます。複数のコンポーネント ルートに同一の ID が含まれる場合は、最も高く設定されたコストがルートに適用されます。たとえば、次の 2 つのコンポーネント ルートにインバウンド ルート マップ経由でコスト コミュニティ アトリビュートが設定されているとします。

10.0.0.1 (POI=IGP, ID=1, Cost=100)

192.168.0.1 (POI=IGP, ID=1, Cost=200)

これらのコンポーネント ルートがマルチパスとして集約または設定された場合、コスト値 200(POI=IGP、ID=1、コスト =200)が最も高いコストとなるため、このコスト値がアドバタイズされます。

1 つ以上のコンポーネント ルートがコスト コミュニティ アトリビュートを伝送しない場合、またはこれらのコンポーネント ルートに異なる ID が設定されている場合は、デフォルト値(2147483647)が集約ルートまたはマルチパス ルートに対してアドバタイズされます。たとえば、次の 3 つのコンポーネント ルートにインバウンド ルート マップ経由でコスト コミュニティ アトリビュートが設定されているとします。ただし、これらのコンポーネント ルートには 2 つの異なる ID が設定されています。

10.0.0.1 (POI=IGP, ID=1, Cost=100)

172.16.0.1 (POI=IGP, ID=2, Cost=100)

192.168.0.1 (POI=IGP, ID=1, Cost=200)

アドバタイズされる単一のパスには、次のように集約コスト コミュニティが含まれます。

{POI=IGP, ID=1, Cost=2147483647} {POI=IGP, ID=2, Cost=2147483647}

マルチエグジット IGP ネットワークにおけるルート プリファレンスの反映

図 1 に、エッジに 2 つの Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)がある Interior Gateway Protocol(IGP)ネットワークを示します。各 ASBR は、ネットワーク 10.8/16 に対して等コスト パスを持ちます。

図 1 マルチエグジット ポイント IGP ネットワーク

 

BGP では、両パスは等しいと見なされます。マルチパス ロードシェアリングが設定されている場合、両方のパスがルーティング テーブルにインストールされ、トラフィックのロード バランスに使用されます。マルチパス ロードシェアリングが設定されていない場合、BGP により最初に最良パスであると学習されたパスが選択され、ルーティング テーブルにインストールされます。この動作は、一部の条件下では望ましくない場合があります。たとえば、パスは最初に ISP1 PE2 から学習されますが、ISP1 PE2 と ASBR1 間のリンクは低速です。

コスト コミュニティ アトリビュートのコンフィギュレーションを使用して ASBR2 が学習したパスにより低いコスト コミュニティ値を適用することで、BGP 最良パス選択プロセスに影響を与えることができます。たとえば、次のコンフィギュレーションは ASBR2 に適用されます。

route-map ISP2_PE1 permit 10
set extcommunity cost 1 1
match ip address 13
!
ip access-list 13 permit 10.8.0.0 0.0.255.255
 

上のルート マップでは、コスト コミュニティ番号値の 1 がルート 10.8.0.0 に適用されます。デフォルトでは、ASBR1 で学習したパスにはコスト コミュニティ値 2147483647 が割り当てられます。ASBR2 で学習したパスのコスト コミュニティ値の方が低いため、こちらのパスが優先されます。

バックドア リンクを持つ EIGRP MPLS VPN Provider Edge-Customer Edge(PE-CE)に対する BGP コスト コミュニティ サポート

EIGRP Site of Origin(SoO)BGP コスト コミュニティ サポートの導入以前は、BGP ピアが学習したルートよりもローカル ソース ルートの方が BGP により優先されました。バックドア リンクの方が先に学習された場合、BGP により EIGRP MPLS VPN トポロジにおけるバックドア リンクが優先されます(バックドア リンクまたはルートは遠隔地の拠点と主拠点間の VPN の外で設定される接続。たとえば、遠隔地の拠点を企業のネットワークに接続する WAN リース ライン)。

VPN およびバックドア リンクが混在する EIGRP VPN ネットワーク トポロジをサポートするために、BGP コスト コミュニティ機能で「プレ最良パス」挿入ポイント(POI)が導入されました。この POI は BGP に再配布される EIGRP ルートに適用されます。「プレ最良パス」POI は、EIGRP ルート タイプおよびメトリックを伝送します。この POI は、BGP がその他のあらゆる比較ステップの前にこの POI を考慮するように影響を与えておくことで、最良パス計算プロセスに作用します。コンフィギュレーションは必要ありません。Cisco IOS リリース 12.0(27)S が Provider Edge(PE; プロバイダー エッジ)、Customer Edge(CE; カスタマーエッジ)、またはバック ドア ルータにインストールされている場合、この機能は自動的に EIGRP VPN 拠点に対してイネーブルになります。

EIGRP MPLS VPN の設定については、Cisco IOS リリース 12.0(27)S の『MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge』マニュアルを参照してください。

EIGRP MPLS VPN PE-CE Site of Origin(SoO)機能の詳細については、Cisco IOS リリース 12.0(27)S の『EIGRP MPLS VPN PE-CE Site of Origin (SoO)』機能マニュアルを参照してください。

BGP コスト コミュニティ機能の設定方法

ここでは、次の手順について説明します。

「BGP コスト コミュニティの設定」

「BGP コスト コミュニティの設定確認」

BGP コスト コミュニティの設定

コスト コミュニティを設定するには、この項の手順を実行してください。

手順の概要

1. enable

2. configure terminal

3. router bgp autonomous-system-number

4. neighbor ip-address remote-as autonomous-system-number

5. address-family ipv4 [ mdt | multicast | tunnel | unicast [ vrf vrf-name ] | vrf vrf-name ] | ipv6 [ multicast | unicast ] | vpnv4 [ unicast ]

6. neighbor ip-address route-map map-name { in | out }

7. exit

8. route-map map-name { permit | deny } [ sequence-number ]

9. set extcommunity cost [ igp ] community-id cost-value

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなどの上位の特権レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp autonomous-system-number

 

Router(config)# router bgp 50000

ルータ コンフィギュレーション モードを開始して、BGP ルーティング プロセスを作成または設定します。

ステップ 4

neighbor ip-address remote-as autonomous-system-number

 

Router(config-router)# neighbor 10.0.0.1 remote-as 101

指定したネイバーまたはピアグループとのピアリングを確立します。

ステップ 5

address-family ipv4 [ mdt | multicast | tunnel | unicast [ vrf vrf-name ] | vrf vrf-name ] | ipv6 [ multicast | unicast ] | vpnv4 [ unicast ]

 

Router(config-router)# address-family ipv4

ルータをアドレス ファミリ コンフィギュレーション モードにします。

ステップ 6

neighbor ip-address route-map map-name { in | out }

 

Router(config-router)# neighbor 10.0.0.1 route-map MAP-NAME in

指定したネイバーまたはピアグループに対し着信または発信ルート マップを適用します。

ステップ 7

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードを開始します。

ステップ 8

route-map map-name { permit | deny } [sequence-number]

 

Router(config)# route-map MAP-NAME permit 10

ルート マップ コンフィギュレーション モードを開始し、ルート マップを作成または設定します。

ステップ 9

set extcommunity cost [ igp ] community-id cost-value

 

Router(config-route-map)# set extcommunity cost 1 100

set 句を作成しコスト コミュニティ アトリビュートを適用します。

各ルート マップ ブロックまたはシーケンスで複数の cost community set 句を設定できます。各 cost community set 句には、異なる ID(0 ~ 255)を持たせる必要があります。その他すべてのアトリビュートが等しい場合、最も小さいコスト値を持つ cost community set 句が最良パス選択プロセスにより優先されます。

コスト コミュニティ アトリビュートが設定されていないパスにはデフォルトのコスト値が割り当てられます。この値は最大値(4294967295)の半分である 2147483647 です。

ステップ 10

end

 

Router(config-route-map)# end

ルート マップ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

BGP コスト コミュニティの設定確認

BGP コスト コミュニティコンフィギュレーションは、ローカルまたは特定のネイバーに対して確認できます。コスト コミュニティのローカル コンフィギュレーションを確認するには、 show route-map または show running-config コマンドを使用します。特定のネイバーがコスト コミュニティを伝送することを確認するには、 show ip bgp ip-address コマンドを使用します。これらのコマンドの出力により、POI(IGP はデフォルトの POI)、設定された ID、および設定されたコストが表示されます。大きなコスト コミュニティ値に対しては、これらのコマンドからの出力は設定されたコストとデフォルトのコストの差異を + または - の値で表示します。「BGP コスト コミュニティの設定確認」 に出力の具体例を示します。

トラブルシューティングのヒント

bgp bestpath cost-community ignore コマンドでコスト コミュニティ アトリビュートの評価をディセーブルにし、BGP 最良パス選択に関連する問題の切り分けおよびトラブルシューティングに役立てることができます。

debug ip bgp updates コマンドは BGP アップデート メッセージを印刷する際に使用できます。コスト コミュニティ拡張コミュニティ アトリビュートをネイバーから受信した際に、このコマンドの出力で表示することができます。外部ピアから非遷移の拡張コミュニティを受信した場合も、メッセージが表示されます。

BGP コスト コミュニティ機能の設定例

次に、この機能のコンフィギュレーションおよび検証の例を示します。

「BGP コスト コミュニティ設定例」

「BGP コスト コミュニティ検証例」

BGP コスト コミュニティ設定例

次に、 set extcommunity cost コマンドによるコンフィギュレーションの例を示します。次の例では、コスト コミュニティ ID「1」、コスト コミュニティ値「100」がルート マップで許可されたルートに適用されます。このコンフィギュレーションでは、このルート マップ シーケンスで許可されていないその他の等コスト パスよりもこのルートが、最良パス選択プロセスにより優先されます。

Router(config)# router bgp 50000
Router(config-router)# neighbor 10.0.0.1 remote-as 50000
Router(config-router)# neighbor 10.0.0.1 update-source Loopback 0
Router(config-router)# address-family ipv4
Router(config-router-af)# neighbor 10.0.0.1 activate
Router(config-router-af)# neighbor 10.0.0.1 route-map COST1 in
Router(config-router-af)# neighbor 10.0.0.1 send-community both
Router(config-router-af)# exit
Router(config)# route-map COST1 permit 10
Router(config-route-map)# match ip-address 1
Router(config-route-map)# set extcommunity cost 1 100

BGP コスト コミュニティ検証例

BGP コスト コミュニティコンフィギュレーションは、ローカルまたは特定のネイバーに対して確認できます。コスト コミュニティのローカル コンフィギュレーションを確認するには、 show route-map または show running-config コマンドを使用します。特定のネイバーがコスト コミュニティを伝送することを確認するには、 show ip bgp ip-address コマンドを使用します。

show route-map コマンドの出力では、ローカルで設定されたルート マップ、match 句、set 句、continue 句、およびコスト コミュニティ アトリビュートのステータスおよびアトリビュートが表示されます。次の出力例は、表示される出力に類似しています。

Router# show route-map
 
route-map COST1, permit, sequence 10
Match clauses:
as-path (as-path filter): 1
Set clauses:
extended community Cost:igp:1:100
Policy routing matches: 0 packets, 0 bytes
route-map COST1, permit, sequence 20
Match clauses:
ip next-hop (access-lists): 2
Set clauses:
extended community Cost:igp:2:200
Policy routing matches: 0 packets, 0 bytes
route-map COST1, permit, sequence 30
Match clauses:
interface FastEthernet0/0
extcommunity (extcommunity-list filter):300
Set clauses:
extended community Cost:igp:3:300
Policy routing matches: 0 packets, 0 bytes
 

次に、ローカルで設定された大きいコスト コミュニティ値を持つルートの例を示します。

Router# show route-map
 
route-map set-cost, permit, sequence 10
Match clauses:
Set clauses:
extended community RT:1:1 RT:2:2 RT:3:3 RT:4:4 RT:5:5 RT:6:6 RT:7:7
RT:100:100 RT:200:200 RT:300:300 RT:400:400 RT:500:500 RT:600:600
RT:700:700 additive
extended community Cost:igp:1:4294967295 (default+2147483648)
Cost:igp:2:200 Cost:igp:3:300 Cost:igp:4:400
Cost:igp:5:2147483648 (default+1) Cost:igp:6:2147484648 (default+1001)
Cost:igp:7:2147284648 (default-198999)
Policy routing matches: 0 packets, 0 bytes
 

show running config コマンドの出力では、ルート マップ内で設定された match 句、set 句、continue 句が表示されます。次に、実行中のコンフィギュレーションのうち、関連する部分だけをフィルタリングして表示した出力例を示します。

Router# show running-config | begin route-map
 
route-map COST1 permit 20
match ip next-hop 2
set extcommunity cost igp 2 200
!
route-map COST1 permit 30
match interface FastEthernet0/0
match extcommunity 300
set extcommunity cost igp 3 300
.
.
.
 

show ip bgp ip-address コマンドの出力は、特定のネイバーがコスト コミュニティ アトリビュートを設定したパスを伝送するかを確認する際に使用できます。コスト コミュニティ アトリビュート情報は、「Extended Community」フィールドに表示されます。POI、コスト コミュニティ ID、およびコスト コミュニティ番号値が表示されます。次に、ネイバー 172.16.1.2 が、ID「1」、コスト「100」のコスト コミュニティを伝送している出力例を示します。

Router# show ip bgp 10.0.0.0
 
BGP routing table entry for 10.0.0.0/8, version 2
Paths: (1 available, best #1)
Not advertised to any peer
2 2 2
172.16.1.2 from 172.16.1.2 (172.16.1.2)
Origin IGP, metric 0, localpref 100, valid, external, best
Extended Community: Cost:igp:1:100
 

指定されたネイバーにデフォルトのコスト コミュニティ番号値が設定されている場合、またはコスト コミュニティ評価のためにデフォルト値が自動的に割り当てられている場合は、出力ではコスト コミュニティ番号値の後ろに + および - の値を伴った「default」が表示されます。

次の作業

EIGRP MPLS VPN PE-CE Site of Origin(SoO)機能についての詳細は、Cisco IOS リリース 12.0(27)S で追加された『 EIGRP MPLS VPN PE-CE Site of Origin (SoO) 』機能マニュアルを参照してください。

参考資料

BGP コスト コミュニティ機能に関する詳細情報については、次の資料を参照してください。

関連資料

関連項目
参照先

BGP 最良パスの選択

『BGP Best Path Selection Algorithm』

BGP コマンド

『Cisco IOS IP Routing: BGP Command Reference』

設定作業および設定例を含む BGP モジュールおよび機能のロードマップ

『BGP Features Roadmap』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存の MIB のサポートはありません。

プラットフォームおよび Cisco IOS リリースでサポートされる MIB のリストを入手して、MIB モジュールをダウンロードするには、次の URL にある Cisco.com の Cisco MIB Web サイトにアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

draft-retana-bgp-custom-decision-00.txt

『BGP Custom Decision Process』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドについては、 http://www.cisco.com/en/US/docs/ios/iproute_bgp/command/reference/irg_book.html の『 Cisco IOS IP Routing: BGP Command Reference 』を参照してください。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にアクセスしてコマンド検索ツールを使用するか、『 Cisco IOS Master Commands List 』を参照してください。

bgp bestpath cost-community ignore

debug ip bgp updates

set extcommunity cost

BGP コスト コミュニティの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS リリース 12.0(24)S、Cisco IOS リリース 12.3(2)T、12.2(18)S またはそれ以降のリリースで導入または変更された新しい機能だけが記載されています。

このテクノロジーの機能でここに記載されていない情報については、『 BGP Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 BGP コスト コミュニティの機能情報

機能名
リリース
機能情報

BGP コスト コミュニティ

12.0(24)S
12.3(2)T
12.2(18)S
12.2(27)SBC
15.0(1)S

BGP コスト コミュニティ機能により、コスト拡張コミュニティ アトリビュートが導入されます。コスト コミュニティとは、非遷移の拡張コミュニティ アトリビュートで、内部 BGP(iBGP)およびコンフェデレーション ピアには渡されますが、外部 BGP(eBGP)ピアには渡されません。コスト コミュニティ機能により、コスト値を特定のルートに割り当てることで、ローカル ルート プリファレンスをカスタマイズし、最良パス選択プロセスに反映させることができます。

次の項で、この機能に関する情報を参照できます。

「BGP コスト コミュニティの概要」

「BGP コスト コミュニティはどのように最良パス選択プロセスに影響するか」

「集約ルートおよびマルチパスに対するコスト コミュニティのサポート」

「マルチエグジット IGP ネットワークにおけるルート プリファレンスの反映」

「BGP コスト コミュニティ機能の設定方法」

「BGP コスト コミュニティ機能の設定例」

bgp bestpath cost-community ignore debug ip bgp updates set extcommunity cost の各コマンドが追加または変更されています。

バックドア リンクを持つ EIGRP MPLS VPN Provider Edge-Customer Edge(PE-CE)に対する BGP コスト コミュニティ サポート

12.0(27)S
12.3(8)T
12.2(25)S

バックドア リンクの方が先に学習された場合、BGP により EIGRP MPLS VPN トポロジにおけるバックドア リンクが優先されます。VPN およびバックドア リンクが混在する EIGRP VPN ネットワーク トポロジをサポートするために、BGP コスト コミュニティ機能で「プレ最良パス」挿入ポイント(POI)が導入されました。この POI は BGP に再配布される EIGRP ルートに自動的に適用されます。この POI は、BGP がその他のあらゆる比較ステップの前にこの POI を考慮するように影響を与えておくことで、最良パス計算プロセスに影響します。コンフィギュレーションは必要ありません。Cisco IOS リリース 12.0(27)S、12.3(8)T、12,2(25)S、およびそれ以降のリリースが PE、CE、またはバックドア ルータにインストールされている場合、この機能は自動的に EIGRP VPN 拠点に対してイネーブルになります。

次の項で、この機能に関する情報を参照できます。

「バックドア リンクを持つ EIGRP MPLS VPN Provider Edge-Customer Edge(PE-CE)に対する BGP コスト コミュニティ サポート」

追加または変更されたコマンドはありません。