Cisco IOS サービス品質(QoS)ソリューション コ ンフィギュレーション ガイド
RSVP スケーラビリティ拡張
RSVP スケーラビリティ拡張
発行日;2012/02/06 | 英語版ドキュメント(2011/04/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

RSVP スケーラビリティ拡張

機能の概要

利点

制約事項 

関連機能およびテクノロジー

関連資料

サポートされているプラットフォーム

サポートされている規格、MIB、および RFC

前提条件

設定タスク

インターフェイス上での RSVP のイネーブル化

リソース プロバイダーの設定

データ パケット分類のディセーブル化

クラス マップとポリシー マップの設定

インターフェイスへのポリシー マップの対応付け

RSVP スケーラビリティ拡張設定の確認

RSVP スケーラビリティ機能のモニタリングと保守

設定例

予約されたトラフィックに適合するための CBWFQ の設定:例

リソース プロバイダーをなしにして、データ分類をオフにする設定:例

コマンド リファレンス

用語集

RSVP スケーラビリティ拡張

このマニュアルでは、Cisco Resource Reservation Protocol(RSVP; リソース予約プロトコル)スケーラビリティ拡張について説明します。また、サポートされているプラットフォームを特定し、設定例を紹介し、関連する IOS Command Line Interface(CLI; コマンドライン インターフェイス)コマンドを列挙します。

このマニュアルは次の項で構成されています。

「機能の概要」

「サポートされているプラットフォーム」

「サポートされている規格、MIB、および RFC」

「前提条件」

「設定タスク」

「RSVP スケーラビリティ機能のモニタリングと保守」

「設定例」

「コマンド リファレンス」

「用語集」

機能の概要

RSVP は、フロー単位でデータ パケットのアドミッション コントロール、分類、ポリシング、およびスケジューリングを実行し、フローごとに情報のデータベースを維持します。RSVP スケーラビリティ拡張を使用すれば、リソース プロバイダー(以前は Quality of Service(QoS; サービス品質)プロバイダーと呼ばれていた)を選択して、データ パケット分類をディセーブルにすることによって、RSVP でアドミッション コントロールだけを実行するようにできます。これによって、サービス プロバイダー(ディファレンシエーテッド サービス(DiffServ))ネットワークとの統合が促進され、企業ネットワーク全体のスケーラビリティが向上します。

Class-based weighted fair queueing(CBWFQ; クラスベース重み付け均等化キューイング)は、分類、ポリシング、およびスケジューリング機能を提供します。CBWFQ は、パケットの Internet Protocol(IP; インターネット プロトコル)ヘッダー内の Differentiated Services Code Point(DSCP)に基づいてパケットをクラスに配置します。そのため、フロー単位の状態やフロー単位の処理の必要がありません。

図 1 は、Service Provider(SP; サービス プロバイダー)ネットワーク経由で相互接続された 2 つの企業ネットワークを表しています。SP ネットワークには、DiffServ ネットワークとして設定された IP バックボーンがあります。企業ネットワークごとに、Wide Area Network(WAN; ワイドエリア ネットワーク)リンク経由で SP エッジ/集約ルータに接続された音声ゲートウェイがあります。企業ネットワークは Private Branch eXchange(PBX; 構内交換機)に接続されています。

図 1 RSVP/DiffServ 統合トポロジ

 

音声ゲートウェイは、従来の RSVP を実行しています。これは、RSVP がフローごとに安定状態を維持しており、フロー単位でパケットを分類、マーキング、およびスケジューリングしていることを意味します。エッジ/集約ルータは、音声ゲートウェイに接続されたインターフェイス(C と D のラベルが付けられている)上で従来の RSVP を実行しており、コア ルータ 1 と 3 に接続されたインターフェイス上でのみアドミッション コントロール用に RSVP を実行しています。DiffServ ネットワーク内のコア ルータは、RSVP を実行していませんが、ネクストホップに RSVP メッセージを転送しています。DiffServ ネットワーク内のコア ルータは、DSCP 値が同じフローの集合ごとに Per Hop Behavior(PHB)を実装しています。

音声ゲートウェイは、音声データ パケットを識別して、該当する DSCP を IP ヘッダー内に設定し、パケットがエッジ/集約ルータとコア ルータの 1、2、3 または 1、4、3 内のプライオリティ クラスに分類されるようにします。

コア ルータ 1 と 3 に接続されたインターフェイスまたはエッジ/集約ルータ(A と B のラベルが付けられた)は RSVP を実行していますが、エッジ/集約ルータの DiffServ インターフェイス上で設定された RSVP 帯域幅プールに対してはフロー単位のみのアドミッション コントロールを実行しています。CBWFQ は、分類、ポリシング、スケジューリング機能を実行しています。

スケーラビリティの向上

RSVP スケーラビリティ拡張は、フロー単位ではなく、クラス単位で同様のフローを処理します。クラス単位 QoS 保証を維持しなければならないリソースが少ないため、処理が高速化され、その結果、スケーラビリティが向上します。

ルータ性能の向上

RSVP スケーラビリティ拡張では、データ パケットの分類とスケジューリングに関するコストを削減することによって、Central Processing Unit(CPU; 中央処理装置)のリソース消費が削減され、ルータ性能が向上します。こうして節約されたリソースは、他のネットワーク管理機能に使用できます。

制約事項 

送信元は、予約が設定されていなければ、マークされたパケットを送信しないようにする必要があります。

送信元は、予約帯域幅を超えている、マークされたパケットを送信しないようにする必要があります。

送信元は、マークされたパケットを予約パス以外の宛先に送信しないようにする必要があります。

関連機能およびテクノロジー

RSVP スケーラビリティ拡張は、シグナリング、分類、輻輳管理などの QoS 機能に関係します (「関連資料」を参照)。

関連資料

次のドキュメントに追加情報が記載されています。

Quality of Service Overview 』モジュール

『Cisco IOS Quality of Service Solutions Command Reference』

サポートされているプラットフォーム

Cisco 2600 シリーズ

Cisco 3600 シリーズ(Cisco 3620、3640、および 3660)

Cisco 3810 マルチサービス アクセス コンセントレータ

Cisco 7200 シリーズ

Cisco 7500 Route/Switch Processor(RSP; ルート/スイッチ プロセッサ)のみ

サポートされている規格、MIB、および RFC

規格

RSVP スケーラビリティ拡張は、新しいまたは変更された標準をサポートしていません。

MIB

RFC 2206(『RSVP Management Information Base using SMIv2』)

プラットフォームと Cisco IOS リリースでサポートされている MIB のリストを入手したり、MIB モジュールをダウンロードしたりするには、http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml にある Cisco.com の Cisco MIB Web サイトにアクセスしてください。

RFC

RFC 2205(『Resource Reservation Protocol』)

前提条件

RSVP スケーラビリティ拡張をイネーブルにするには、次の Cisco IOS 機能をネットワークでサポートする必要があります。

リソース予約プロトコル(RSVP)

クラスベース重み付け均等化キューイング(CBWFQ)

設定タスク

RSVP スケーラビリティ拡張に関する設定タスクについては、次の項を参照してください。リスト内のタスクごとに、任意か必須かが示されています。

インターフェイス上での RSVP のイネーブル化(必須)

リソース プロバイダーの設定(必須)

データ パケット分類のディセーブル化(必須)

クラス マップとポリシー マップの設定(必須)

インターフェイスへのポリシー マップの対応付け(必須)

インターフェイス上での RSVP のイネーブル化

インターフェイス上で RSVP をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip rsvp bandwidth [ interface-kbps ] [ single-flow-kbps ]

インターフェイス上で RSVP をイネーブルにします。


) インターフェイス上で設定する帯域幅は、CBWFQ プライオリティ キューに対して設定された帯域幅と一致する必要があります。「設定例」を参照してください。


リソース プロバイダーの設定


) 以前は、リソース プロバイダーが QoS プロバイダーと呼ばれていました。


リソース プロバイダーを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip rsvp resource-provider none

リソース プロバイダーをなしに設定します。


) リソース プロバイダーをなしに設定すると、RSVP は WFQ キューや帯域幅などのリソースを予約に関連付けないように指示されます。


データ パケット分類のディセーブル化

データ パケット分類をオフ(ディセーブル)にするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ip rsvp data-packet classification none

データ パケット分類をディセーブルにします。


) データ パケット分類をディセーブルにすると、RSVP はすべてのパケットを処理するのではなく、アドミッション コントロールのみを実行するように指示されます。


クラス マップとポリシー マップの設定

クラス マップとポリシー マップを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# class-map class-map-name

クラス マップ一致基準を作成または変更するクラスの名前を指定します。

ステップ 2

Router(config)# policy-map policy-map-name

クラス マップ内で一致基準が定義されているクラスのポリシーを設定するには、作成する、追加する、または変更するポリシー マップの名前を指定します。

インターフェイスへのポリシー マップの対応付け

ポリシー マップをインターフェイスに対応付けるには、ンターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy { input | output } policy-map-name

単一のポリシー マップを 1 つ以上のインターフェイスに対応付け、これらのインターフェイスに対してサービス ポリシーを指定します。


) RSVP スケーラビリティ拡張を設定した時点で、従来の RSVP を使用している予約が存在していた場合は、それらのフローに対して追加のマーキング、分類、またはスケジューリングが実施されません。RSVP スケーラビリティ拡張を設定後に、このような予約を削除することもできます。


RSVP スケーラビリティ拡張設定の確

RSVP スケーラビリティ拡張を確認するには、次の手順を使用します。


ステップ 1 show ip rsvp interface detail コマンドを入力して、インターフェイス、サブインターフェイス、リソース プロバイダー、およびデータ パケット分類に関する情報を表示します。次の例の出力は、ATM 6/0 インターフェイスにどのリソース プロバイダーも設定されておらず、データ パケット分類がオフになっていることを示しています。

Router# show ip rsvp interface detail
AT6/0:
Bandwidth:
Curr allocated: 190K bits/sec
Max. allowed (total): 112320K bits/sec
Max. allowed (per flow): 112320K bits/sec
Neighbors:
Using IP encap: 1. Using UDP encaps: 0
DSCP value used in Path/Resv msgs: 0x30
RSVP Data Packet Classification is OFF
RSVP resource provider is: none

) この出力内の最後の 2 行で、RSVP スケーラビリティ拡張(データ パケット分類がディセーブルになっており、リソース プロバイダーが設定されていない)の存在を確認しています。


ステップ 2 show ip rsvp installed detail コマンドを入力して、インターフェイス、サブインターフェイス、その許可された予約、帯域幅、リソース プロバイダー、およびデータ パケット分類に関する情報を表示します。

Router# show ip rsvp installed detail
RSVP: Ethernet3/3 has no installed reservations
 
RSVP: ATM6/0 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 14, Source port is 14
Reserved bandwidth: 50K bits/sec, Maximum burst: 1K bytes, Peak rate: 50K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 0 packets (0 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 54 seconds
Long-term average bitrate (bits/sec): 0M reserved, 0M best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth: 20K bits/sec, Maximum burst: 1K bytes, Peak rate: 20K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 0 packets (0 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 80 seconds
Long-term average bitrate (bits/sec): 0M reserved, 0M best-effort

 

ステップ 3 しばらく待ってから、もう一度、 show ip rsvp installed detail コマンドを入力します。次の出力で、分類されたパケット数が増えていないことに注目してください。

Router# show ip rsvp installed detail
RSVP: Ethernet3/3 has no installed reservations
 
RSVP: ATM6/0 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 14, Source port is 14
Reserved bandwidth: 50K bits/sec, Maximum burst: 1K bytes, Peak rate: 50K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 0 packets (0 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 60 seconds
Long-term average bitrate (bits/sec): 0 reserved, OM best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth: 20K bits/sec, Maximum burst: 1K bytes, Peak rate: 20K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 0 packets (0 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 86 seconds
Long-term average bitrate (bits/sec): OM reserved, 0M best-effort


 

RSVP スケーラビリティ機能のモニタリングと保守

RSVP スケーラビリティ拡張を監視して保守するには、EXEC モードで次のコマンドを使用する必要があります。

 

コマンド
目的

Router# show ip rsvp installed

インターフェイスとその許可された予約に関する情報を表示します。

Router# show ip rsvp installed detail

インターフェイスとその許可された予約に関する追加情報を表示します。

Router# show ip rsvp interface

RSVP 関連のインターフェイス情報を表示します。

Router# show ip rsvp interface detail

RSVP 関連のインターフェイス追加情報を表示します。

Router# show queueing [ custom | fair | priority | random-detect [ interface serial-number ]]

RSVP 予約に関するすべてのまたは選択された設定済みキューイング戦略と使用可能な帯域幅を表示します。

設定

ここでは、次の設定例について説明します。

予約されたトラフィックに適合するための CBWFQ の設定:例

リソース プロバイダーをなしにして、データ分類をオフにする設定:例

予約されたトラフィックに適合するための CBWFQ の設定:例

次の出力は、音声に対して設定されるクラス マップとポリシー マップを示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# class-map match-all voice
Router(config-cmap)# match access-group 100
Router(config-cmap)# exit
Router(config)# policy-map wfq-voip
Router(config-pmap)# class voice
Router(config-pmap-c)# priority 24
Router(config-pmap-c)# end
Router#

) CBWFQ プライオリティ キューに対して設定する帯域幅(24 kbps)は、インターフェイスに対して設定された帯域幅と一致する必要があります。「インターフェイス上での RSVP のイネーブル化」を参照してください。


次の出力は、設定するアクセス リストを示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# access-list 100 permit udp any any range 16384 32500

 

次の出力は、発信インターフェイスに適用するクラスを示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int atm6/0
Router(config-if)# service-policy output wfq-voip

 

次の出力は、インターフェイス上で設定する帯域幅を示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int atm6/0
Router(config-if)# ip rsvp bandwidth 24

) インターフェイス上で設定する帯域幅(24 kbps)は、CBWFQ プライオリティ キューに対して設定された帯域幅と一致する必要があります。


リソース プロバイダーをなしにして、データ分類をオフにする設定:例

show run コマンドは、ルータ内の現在の設定を表示します。

Router# show run int atm6/0
class-map match-all voice
match access-group 100
!
policy-map wfq-voip
class voice
priority 24
class class-default
fair-queue
!
interface ATM6/0
ip address 20.20.22.1 255.255.255.0
no ip redirects
no ip proxy-arp
no ip route-cache cef
atm uni-version 4.0
atm pvc 1 0 5 qsaal
atm pvc 2 0 16 ilmi
atm esi-address 111111111181.00
no atm auto-configuration
no atm ilmi-keepalive
pvc blue 200/100
abr 700 600
inarp 1
broadcast
encapsulation aal5snap
service-policy output wfq-voip
!
ip rsvp bandwidth 24 24
ip rsvp signalling dscp 48
access-list 100 permit udp any any range 16384 32500

 

リソース プロバイダーなしを設定し、データ パケット分類をオフにする前の show ip rsvp interface detail コマンドの出力を次に示します。

Router# show ip rsvp interface detail
AT6/0:
Bandwidth:
Curr allocated: 190K bits/sec
Max. allowed (total): 112320K bits/sec
Max. allowed (per flow): 112320K bits/sec
Neighbors:
Using IP encap: 1. Using UDP encaps: 0
DSCP value used in Path/Resv msgs: 0x30

 

リソース プロバイダーなしを設定し、データ パケット分類をオフにする前の show queueing コマンドの出力を次に示します。

Router# show queueing int atm6/0
Interface ATM6/0 VC 200/100
Queueing strategy: weighted fair
Output queue: 63/512/64/3950945 (size/max total/threshold/drops)
Conversations 2/5/64 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 450 kilobits/sec

) 新しい予約によって、使用可能な帯域幅(上記の 450 kbps)は削減されません。代わりに、RSVP が ip rsvp bandwidth コマンドで設定された帯域幅制限を使用してアドミッション コントロールのみを実行します。このコマンドで設定する帯域幅は、予約されたトラフィックを処理するためにセットアップした CBWFQ クラス内で設定された帯域幅と一致する必要があります。


次の出力は、リソース プロバイダーなしの設定を示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int atm6/0
Router(config-if)# ip rsvp resource-provider none
Router(config-if)# end
Router#

 

次の出力は、オフにするデータ パケット分類を示しています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int atm6/0
Router(config-if)# ip rsvp data-packet classification none
Router(config-if)# end
Router#

 

リソース プロバイダーなしを設定し、データ パケット分類をオフにした後の show ip rsvp interface detail コマンドの出力を次に示します。

Router# show ip rsvp interface detail
AT6/0:
Bandwidth:
Curr allocated: 190K bits/sec
Max. allowed (total): 112320K bits/sec
Max. allowed (per flow): 112320K bits/sec
Neighbors:
Using IP encap: 1. Using UDP encaps: 0
DSCP value used in Path/Resv msgs: 0x30
RSVP Data Packet Classification is OFF
RSVP resource provider is: none

 

次の show ip rsvp installed detail コマンドの出力は、リソース プロバイダーなしが設定され、データ パケット分類がオフになっていることを確認しています。

Router# show ip rsvp installed detail
RSVP: ATM6/0 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 14, Source port is 14
Reserved bandwidth: 50K bits/sec, Maximum burst: 1K bytes, Peak rate: 50K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 3192 packets (1557696 bytes)
Data given best-effort service: 42 packets (20496 bytes)
Reserved traffic classified for 271 seconds
Long-term average bitrate (bits/sec): 45880 reserved, 603 best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth: 20K bits/sec, Maximum burst: 1K bytes, Peak rate: 20K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 1348 packets (657824 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 296 seconds
Long-term average bitrate (bits/sec): 17755 reserved, 0M best-effort

 

次の出力は、送信元が予約と一致するデータ パケットを送信後のパケット カウントが増加していないことを示しています。

Router# show ip rsvp installed detail
RSVP: Ethernet3/3 has no installed reservations
 
RSVP: ATM6/0 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 14, Source port is 14
Reserved bandwidth: 50K bits/sec, Maximum burst: 1K bytes, Peak rate: 50K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 3192 packets (1557696 bytes)
Data given best-effort service: 42 packets (20496 bytes)
Reserved traffic classified for 282 seconds
Long-term average bitrate (bits/sec): 44051 reserved, 579 best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth: 20K bits/sec, Maximum burst: 1K bytes, Peak rate: 20K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 1348 packets (657824 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 307 seconds
Long-term average bitrate (bits/sec): 17121 reserved, 0M best-effort

 

次の出力は、データ パケット分類が再度イネーブルにされたことを示しています。

Router# configure terminal
Router(config)# int atm6/0
Router(config-if) no ip rsvp data-packet classification
Router(config-if)# end

 

次の出力は、データ パケット分類が設定されていることを確認しています。

Router# show ip rsvp installed detail
Enter configuration commands, one per line. End with CNTL/Z.
RSVP: ATM6/0 has the following installed reservations
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 14, Source port is 14
Reserved bandwidth: 50K bits/sec, Maximum burst: 1K bytes, Peak rate: 50K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 3683 packets (1797304 bytes)
Data given best-effort service: 47 packets (22936 bytes)
Reserved traffic classified for 340 seconds
Long-term average bitrate (bits/sec): 42201 reserved, 538 best-effort
RSVP Reservation. Destination is 145.20.20.212, Source is 145.10.10.211,
Protocol is UDP, Destination port is 10, Source port is 10
Reserved bandwidth: 20K bits/sec, Maximum burst: 1K bytes, Peak rate: 20K bits/sec
Min Policed Unit: 0 bytes, Max Pkt Size: 1514 bytes
Resource provider for this flow: None
Conversation supports 1 reservations
Data given reserved service: 1556 packets (759328 bytes)
Data given best-effort service: 0 packets (0 bytes)
Reserved traffic classified for 364 seconds
Long-term average bitrate (bits/sec): 16643 reserved, 0M best-effort

 

これまでの設定タスクのすべてを実行した後の show run コマンドの出力を次に示します。

Router# show run int atm6/0
class-map match-all voice
match access-group 100
!
policy-map wfq-voip
class voice
priority 24
class class-default
fair-queue
!
interface ATM6/0
ip address 20.20.22.1 255.255.255.0
no ip redirects
no ip proxy-arp
no ip route-cache cef
atm uni-version 4.0
atm pvc 1 0 5 qsaal
atm pvc 2 0 16 ilmi
atm esi-address 111111111181.00
no atm auto-configuration
no atm ilmi-keepalive
pvc blue 200/100
abr 700 600
inarp 1
broadcast
encapsulation aal5snap
service-policy output wfq-voip
!
ip rsvp bandwidth 24 24
ip rsvp signalling dscp 48
ip rsvp data-packet classification none
ip rsvp resource-provider none
 
access-list 100 permit udp any any range 16384 32500

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドの詳細については、 http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html にある『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、Cisco IOS マスター コマンド リストを参照してください。

debug ip rsvp traffic-control

debug ip rsvp wfq

ip rsvp data-packet classification none

ip rsvp resource-provider

show ip rsvp installed

show ip rsvp interface

show queueing


debug ip rsvp traffic-controldebug ip rsvp wfq は同時に使用できます。show debug コマンドは、どのデバッギング コマンドがイネーブルになっているかを確認するために使用します。


用語集

CBWFQ :クラスベース重み付け均等化キューイング。標準の WFQ 機能を拡張して、ユーザ定義のトラフィック クラスに対するサポートを提供するキューイング メカニズム。

Differentiated Service Code Point :「DSCP」を参照してください。

DiffServ :ネットワークに入力されたトラフィックが、ネットワークの境界で分類され、場合によって、条件付けされる単純なモデルに基づくアーキテクチャ。その後で、IP ヘッダー内の DS コード ポイントまたはビット マーキングを使用してトラフィックのクラスが識別されます。ネットワークのコア内部では、パケットが、DS コード ポイントに関連付けられた PHB に従って転送されます。

DSCP :Differentiated Services Code Point。1 バイトの IP Type of Service(ToS; タイプ オブ サービス)フィールドの最上位 6 ビット。特定の DSCP 値で表される PHB は設定可能です。DSCP 値の範囲は 0 ~ 63 です。

PBX :プライベート ブランチ。加入者の建物内に設置され、プライベート電話網と公衆電話網の接続に使用されるデジタルまたはアナログ電話機切り替えボード。

PHB :Per Hop Behavior。マークされたパケットを各 DiffServ ルータで具体的にどのように処理すべきかを指定する DiffServ 概念。

QoS :Quality of service。転送システムのパフォーマンスの尺度の 1 つであり、転送品質とサービスのアベイラビリティを反映したものです。

RSVP :Resource Reservation Protocol(リソース予約プロトコル)。アプリケーション フローに対してサービス品質保証を提供するためにネットワーク リソースを予約するプロトコル。

Voice over IP :「VoIP」を参照してください。

VoIP :Voice over IP。電話機と同様の機能、信頼性、および音声品質を維持しながら、IP ベースのインターネット上で通常のテレフォニー スタイルの音声を伝送する機能。

WFQ :Weighted Fair Queueing(重み付け均等化キューイング)。リンク帯域幅の一部をいくつかのキューに適用された相対的帯域幅に基づいてそれぞれのキューに提供するキュー管理アルゴリズム。

アドミッション コントロール :RSVP 予約が、エンドツーエンドで使用可能なネットワーク リソースに基づいて許可または拒否されるプロセス。

重み付け均等化キューイング :「WFQ」を参照してください。

企業ネットワーク :会社などの組織内でほとんどの主要点を接続する大規模かつ多種多様なネットワーク。

クラスベース重み付け均等化キューイング :「 CBWFQ 」を参照してください。

サービス品質 :「QoS」を参照してください。

集約 :DSCP が同じパケットの集合。

帯域幅 :ネットワーク信号に対して使用可能な最高周波数と最低周波数の差。この用語は、特定のネットワーク メディアまたはプロトコルの格付けされたスループット容量を意味する場合もあります。

ディファレンシエーテッド サービス :「DiffServ」を参照してください。

パケット :情報を論理的にグループ化したもの。制御情報が格納されたヘッダーと、(通常は)ユーザ データが含まれています。ほとんどの場合、パケットはデータのネットワーク レイヤ単位を意味します。

フロー :ネットワーク上の 2 つのエンドポイント間(2 台の LAN ステーション間など)を流れるデータのストリーム。単一の回線上で複数のフローを転送できます。

リソース予約プロトコル :「RSVP」を参照してください。