Cisco IOS サービス品質(QoS)ソリューション コ ンフィギュレーション ガイド
RSVP リフレッシュ削減および信頼性の高い メッセージング
RSVP リフレッシュ削減および信頼性の高いメッセージング
発行日;2012/02/06 | 英語版ドキュメント(2011/05/06 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

RSVP リフレッシュ削減および信頼性の高いメッセージング

目次

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する前提条件

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する制約事項

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する情報

RSVP リフレッシュ削減および信頼性の高いメッセージングの機能設計

RSVP リフレッシュ削減および信頼性の高いメッセージングにおけるメッセージ タイプ

信頼性の高いメッセージ

バンドル メッセージ

サマリー リフレッシュ メッセージ

RSVP リフレッシュ削減および信頼性の高いメッセージングのメリット

RSVP リフレッシュ削減および信頼性の高いメッセージングの設定方法

インターフェイス上での RSVP のイネーブル化

RSVP リフレッシュ削減のイネーブル化

RSVP リフレッシュ削減および信頼性の高いメッセージングの確認

RSVP リフレッシュ削減および信頼性の高いメッセージングの設定例

RSVP リフレッシュ削減および信頼性の高いメッセージング:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

RSVP リフレッシュ削減および信頼性の高いメッセージング

RSVP リフレッシュ削減および信頼性の高いメッセージング機能には、Resource Reservation Protocol(RSVP; リソース予約プロトコル)シグナリングのスケーラビリティ、遅延、および信頼性を高め、ネットワーク性能とメッセージ配信を向上させるリフレッシュ削減が含まれています。

RSVP リフレッシュ削減および信頼性の高いメッセージング機能の履歴

リリース
変更点

12.2(13)T

この機能が追加されました。

12.0(24)S

この機能は、Cisco IOS Release 12.0(24)S に統合されました。

12.2(14)S

この機能は、Cisco IOS Release 12.2(14)S に統合されました。

12.0(26)S

ip rsvp signalling refresh misses ip rsvp signalling refresh interval の 2 つのコマンドが Cisco IOS Release 12.0(26)S に追加されました。

12.0(29)S

ip rsvp signalling rate-limit コマンドの burst 引数と max-size 引数のデフォルトが、それぞれ、8 メッセージと 2000 バイトに増加されました。

12.2(28)SB

この機能は、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(18)SXF5

この機能は、Cisco IOS Release 12.2(18)SXF5 に統合されました。

12.2(33)SRB

この機能は、Cisco IOS Release 12.2(33)SRB に統合されました。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する前提条件

RSVP リフレッシュ削減および信頼性の高いメッセージング機能を使用するには、RSVP をネットワーク内の複数のルータ上で設定する必要があります。

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する制約事項

マルチキャスト フローが、信頼性の高いメッセージおよびサマリー リフレッシュ機能に対してサポートされません。

RSVP リフレッシュ削減および信頼性の高いメッセージングに関する情報

RSVP リフレッシュ削減および信頼性の高いメッセージング機能を設定するには、次の概念を理解しておく必要があります。

「RSVP リフレッシュ削減および信頼性の高いメッセージングの機能設計」

「RSVP リフレッシュ削減および信頼性の高いメッセージングにおけるメッセージ タイプ」

「RSVP リフレッシュ削減および信頼性の高いメッセージングのメリット」

RSVP リフレッシュ削減および信頼性の高いメッセージングの機能設計

RSVP は、インターネット アプリケーションによって、データ フローに対する特別な Qualities of Service(QoS; サービス品質)の取得を可能にするネットワーク制御ソフト状態プロトコルです。ソフト状態プロトコルとして、RSVP では定期的に状態をリフレッシュする必要があります。指定された期間にリフレッシュ メッセージが転送されなかった場合は、RSVP 状態が自動的にタイムアウトして削除されます。

RSVP シグナリングを使用しているネットワーク上では、RSVP メッセージが転送中に失われた場合に信頼性と遅延に関する問題が発生します。RSVP セットアップ メッセージが失われた場合は、予約が遅延または失敗する可能性があります。RSVP リフレッシュ メッセージが失われた場合は、予約の変更または予約タイムアウトが遅延する可能性があります。その結果、貧弱なアプリケーションで障害が発生する可能性があります。

ネットワーク上で大量の予約が原因の過剰な RSVP リフレッシュ メッセージ トラフィックが発生した場合は、信頼性の問題も発生する可能性があります。サマリー リフレッシュ メッセージを使用して RSVP リフレッシュ トラフィックを大幅に削減することによって、信頼性を向上できます。


) RSVP パケットは、メッセージのタイプを識別するヘッダーと、コンテンツの解釈方法や処理方法を示す属性やプロパティが格納されたオブジェクト フィールドで構成されます。


RSVP リフレッシュ削減および信頼性の高いメッセージングにおけるメッセージ タイプ

RSVP リフレッシュ削減および信頼性の高いメッセージング機能(図 1)には、次の拡張機能を導入することによって、RSVP シグナリングのスケーラビリティ、遅延、および信頼性を向上させるリフレッシュ削減が含まれています。

信頼性の高いメッセージ(MESSAGE_ID オブジェクト、MESSAGE_ID_ACK オブジェクト、および ACK メッセージ)

バンドル メッセージ(受信と処理のみ)

サマリー リフレッシュ メッセージ(MESSAGE_ID_LIST オブジェクトと MESSAGE_ID_NACK オブジェクト)

図 1 RSVP リフレッシュ削減および信頼性の高いメッセージング

信頼性の高いメッセージ

信頼性の高いメッセージ拡張は、MESSAGE_ID オブジェクトと MESSAGE_ID_ACK オブジェクトで構成された確認応答メカニズムを実装することによって、隣接するルータ間の信頼できるメッセージ配信をサポートします。確認応答は、ACK メッセージ内で転送することも、他の RSVP メッセージに埋め込むこともできます。

RSVP メッセージごとに MESSAGE_ID オブジェクトが 1 つずつ含まれています。ACK_Desired フラグ フィールドが MESSAGE_ID オブジェクト内で設定されている場合は、配信を確認するために、受信側から送信側に MESSAGE_ID_ACK オブジェクトが送信されます。

バンドル メッセージ

バンドル メッセージは、単一の RSVP メッセージにグループ分けされたいくつかの標準 RSVP メッセージで構成されます。

バンドル メッセージには、少なくとも 1 つのサブメッセージを含める必要があります。サブメッセージは、他のバンドル メッセージ以外の任意の RSVP メッセージ タイプにできます。サブメッセージ タイプには、Path、PathErr、Resv、ResvTear、ResvErr、ResvConf、および ACK があります。

バンドル メッセージは、直接、RSVP ネイバーに宛先指定されます。バンドル ヘッダーの直後に IP ヘッダーが続き、中間の転送ヘッダーはありません。

ルータでそのローカル IP アドレスのいずれにも宛先指定されていないバンドル メッセージが受信された場合は、そのメッセージが転送されます。


) バンドル メッセージは受信できますが、送信できません。


サマリー リフレッシュ メッセージ

サマリー リフレッシュ メッセージは、条件付き Path メッセージと Resv メッセージの転送を伴わない RSVP 状態のリフレッシュをサポートします。そのため、RSVP 状態の同期を維持するために転送して処理すべき情報量が大幅に削減されます。

サマリー リフレッシュ メッセージは、リフレッシュすべき Path 状態と Resv 状態を識別する一連の MESSAGE_ID オブジェクトを伝送します。RSVP ノードでサマリー リフレッシュ メッセージが受信されると、その中の MESSAGE_ID オブジェクトとローカルにインストールされた Path 状態または Resv 状態が照合されます。MESSAGE_ID オブジェクトとローカル状態が一致すれば、標準の RSVP リフレッシュ メッセージが受信された場合と同様にその状態が更新されます。ただし、MESSAGE_ID オブジェクトと受信側のローカル状態が一致しなかった場合は、受信側から送信側に MESSAGE_ID_NACK オブジェクトが転送され、サマリー リフレッシュ メッセージが通知されます。

サマリー リフレッシュ メッセージが RSVP セッションの状態のリフレッシュに使用された場合は、条件付きリフレッシュ メッセージの転送が抑制されます。サマリー リフレッシュ拡張は、過去にアドバタイズされた状態への変更が含まれる Path メッセージまたは Resv メッセージに使用できません。また、サマリー リフレッシュ メッセージを使用してリフレッシュできるのは、MESSAGE_ID オブジェクトを含む Path メッセージまたは Resv メッセージ内で過去にアドバタイズされた状態のみです。

RSVP リフレッシュ削減および信頼性の高いメッセージングのメリット

ネットワーク性能の向上

リフレッシュ削減によって、生成された安定状態のネットワーク トラフィックの容量、使用された CPU リソースの数量、および応答時間が削減されるため、ネットワーク性能が向上します。

メッセージ配信の改善

MESSAGE_ID オブジェクトと MESSAGE_ID_ACK オブジェクトによって、信頼性の高いメッセージ配信が保証され、ネットワーク上の問題が発生したときの迅速な状態リフレッシュがサポートされます。たとえば、MESSAGE_ID_ACK オブジェクトは、リンク転送損失の検出に使用されます。

RSVP リフレッシュ削減および信頼性の高いメッセージングの設定方法

ここでは、次の各手順について説明します。

「インターフェイス上での RSVP のイネーブル化」(必須)

「RSVP リフレッシュ削減のイネーブル化」(必須)

「RSVP リフレッシュ削減および信頼性の高いメッセージングの確認」(任意)

インターフェイス上での RSVP のイネーブル化

インターフェイス上で RSVP をイネーブルにするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip rsvp bandwidth [ interface-kbps [ sub-pool ]]

5. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet1

インターフェイス コンフィギュレーション モードを開始します。

type 引数と number 引数は、設定すべきインターフェイスを識別します。

ステップ 4

ip rsvp bandwidth [ interface-kbps [ sub-pool ]]

 

Router(config-if)# ip rsvp bandwidth 7500 7500

インターフェイス上で RSVP をイネーブルにします。

オプションの interface-kbps 引数と sub-pool 引数は、それぞれ、RSVP フローで割り当て可能な帯域幅と単一のフローに割り当て可能な帯域幅を指定します。値は、それぞれ、1 ~ 10000000 と 0 ~ 10000000 です。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

RSVP リフレッシュ削減のイネーブル化

RSVP リフレッシュ削減をイネーブルにするには、次のタスクを実行します。

手順の概要

1. enable

2. configure terminal

3. ip rsvp signalling refresh reduction

4. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip rsvp signalling refresh reduction

 

Router(config)# ip rsvp signalling refresh reduction

リフレッシュ削減をイネーブルにします。

ステップ 4

end

 

Router(config)# end

特権 EXEC モードに戻ります。

RSVP リフレッシュ削減および信頼性の高いメッセージングの確認

RSVP リフレッシュ削減および信頼性の高いメッセージング機能が動作していることを確認するには、次のタスクを実行します。

手順の概要

1. enable

2. clear ip rsvp counters [ confirm ]

3. show ip rsvp

4. show ip rsvp counters [ interface interface-unit | summary | neighbor ]

5. show ip rsvp interface [ interface-type interface-number ] [ detail ]

6. show ip rsvp neighbor [ detail ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

clear ip rsvp counters [ confirm ]

 

Router# clear ip rsvp counters

(任意)ルータで維持されているすべての IP RSVP カウンタをクリア(0 に設定)します。

ステップ 3

show ip rsvp

 

Router# show ip rsvp

(任意)RSVP レート制限、リフレッシュ削減、およびネイバー情報を表示します。

ステップ 4

show ip rsvp counters [ interface interface-unit | summary | neighbor ]

 

Router# show ip rsvp counters summary

(任意)各インターフェイスで送受信された RSVP メッセージの数を表示します。

オプションの summary キーワードは、すべてのインターフェイス上でルータによって送受信された RSVP メッセージの累積数を表示します。

ステップ 5

show ip rsvp interface [ interface-type interface-number ] [ detail ]

 

Router# show ip rsvp interface detail

(任意)RSVP がイネーブルになっているインターフェイスに関する情報(現在の割り当て量と使用可能な最大帯域幅を含む)を表示します。

オプションの detail キーワードは、帯域幅パラメータとシグナリング パラメータを表示します。

ステップ 6

show ip rsvp neighbor [ detail ]

 

Router# show ip rsvp neighbor detail

(任意)IP アドレスを含む RSVP ネイバー情報を表示します。

オプションの detail キーワードは、現在の RSVP ネイバーを表示し、そのネイバーが、指定されたインターフェイスまたはすべてのインターフェイスに対して、IP、User Datagram Protocol(UDP; ユーザ データグラム プロトコル)、または RSVP カプセル化を使用しているかどうかを識別します。

RSVP リフレッシュ削減および信頼性の高いメッセージングの設定例

ここでは、次の設定例について説明します。

「RSVP リフレッシュ削減および信頼性の高いメッセージング:例」

RSVP リフレッシュ削減および信頼性の高いメッセージング:例

次の例では、RSVP リフレッシュ削減がイネーブルにされます。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface Ethernet1
Router(config-if)# ip rsvp bandwidth 7500 7500
Router(config-if)# exit
Router(config)# ip rsvp signalling refresh reduction
Router(config)# end
 

次の例では、RSVP リフレッシュ削減がイネーブルになっていることを確認します。

Router# show running-config
 
Building configuration...
Current configuration : 1503 bytes
 
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service internal
!
hostname Router
!
no logging buffered
logging rate-limit console 10 except errors
!
ip subnet-zero
ip cef
!
ip multicast-routing
no ip dhcp-client network-discovery
lcp max-session-starts 0
mpls traffic-eng tunnels
!
!
interface Loopback0
ip address 192.168.1.1 255.255.255.0
ip rsvp bandwidth 1705033 1705033
!
interface Tunnel777
no ip address
shutdown
!
interface Ethernet0
ip address 192.168.0.195 255.0.0.0
no ip mroute-cache
media-type 10BaseT
!
interface Ethernet1
ip address 192.168.5.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim dense-mode
no ip mroute-cache
media-type 10BaseT
ip rsvp bandwidth 7500 7500
!
interface Ethernet2
ip address 192.168.1.2 255.255.255.0
no ip redirects
no ip proxy-arp
ip pim dense-mode
no ip mroute-cache
media-type 10BaseT
mpls traffic-eng tunnels
ip rsvp bandwidth 7500 7500
!
interface Ethernet3
ip address 192.168.2.2 255.255.255.0
ip pim dense-mode
media-type 10BaseT
mpls traffic-eng tunnels
!
!
router eigrp 17
network 192.168.0.0
network 192.168.5.0
network 192.168.12.0
network 192.168.30.0
auto-summary
no eigrp log-neighbor-changes
!
ip classless
no ip http server
ip rsvp signalling refresh reduction
!
!
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
transport input pad v120 telnet rlogin udptn
!
end
 

その他の関連資料

ここでは、RSVP リフレッシュ削減および信頼性の高いメッセージング機能に関する関連資料について説明します。

関連資料

内容
参照先

RSVP コマンド:完全なコマンドの構文、コマンド モード、デフォルト、使用上の注意事項、および例

『Cisco IOS Quality of Service Solutions Command Reference』

シグナリング、分類、輻輳管理を含む QoS 機能

Quality of Service Overview 』モジュール

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2205

『Resource Reservation Protocol』

RFC 2206

『RSVP Management Information Base Using SMIv2』

RFC 2209

『RSVP--Version 1 Message Processing Rules』

RFC 2210

『The Use of RSVP with IETF Integrated Services』

RFC 2211/2212

『Specification of the Controlled-Load Network Element Service』

RFC 2702

『Requirements for Traffic Engineering over MPLS』

RFC 2749

『Common Open Policy Service (COPS) Usage for RSVP』

RFC 2750

『RSVP Extensions for Policy Control』

RFC 2814

『SBM Subnet Bandwidth Manager: A Protocol for RSVP-based Admission Control over IEEE 802-style Networks』

RFC 2961

『RSVP Refresh Overhead Reduction Extensions』

RFC 2996

『Format of the RSVP DCLASS Object』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドの詳細については、 http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html にある『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、Cisco IOS マスター コマンド リストを参照してください。

ip rsvp signalling rate-limit

show ip rsvp signalling rate-limit