Cisco IOS サービス品質(QoS)ソリューション コ ンフィギュレーション ガイド
IP-ATM 間サービス クラス(CoS)の設定
IP-ATM 間サービス クラス(CoS)の設定
発行日;2012/02/03 | 英語版ドキュメント(2011/04/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

IP-ATM 間サービス クラス(CoS)の設定

単一の ATM VC での IP to ATM CoS の設定作業リスト

WRED パラメータ グループの定義

WRED パラメータ グループの設定

WRED パラメータの表示

キューイングの統計情報の表示

ATM バンドルの IP to ATM CoS の設定作業リスト

VC バンドルの作成

バンドルレベル パラメータの適用

バンドルレベル パラメータの設定

バンドルに適用する VC クラス パラメータの設定

バンドルへのクラスの適用

バンドルへの VC のコミット

個々の VC へのパラメータの適用

VC バンドル メンバの直接設定

VC バンドル メンバに適用する VC クラス パラメータの設定

個々の VC バンドル メンバへの VC クラスの適用

バンピングされたトラフィックを拒否する場合の VC の設定

VC バンドルとその VC メンバのモニタリングと保守

VC 単位の WFQ および CBWFQ の設定作業リスト

クラスベース Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)の設定

サービス ポリシーのアタッチおよび VC の CBWFQ のイネーブル化

フローベースの WFQ を使用する場合の VC の設定

VC 単位の WFQ および CBWFQ のモニタリング

コンソールへのエラー メッセージのロギングのイネーブル化

IP to ATM CoS の設定例

WRED グループおよび IP Precedence を使用した単一の ATM VC の例

VC クラスを使用した VC バンドルの設定例

Bundle-Class クラス

Control-Class クラス

Premium-Class クラス

Priority-Class クラス

Basic-Class クラス

new-york バンドル

san-francisco バンドル

los-angeles バンドル

スタンドアロンの VC での VC 単位の WFQ および CBWFQ の例

バンドル メンバの VC に対する VC 単位の WFQ および CBWFQ の例

IP-ATM 間サービス クラス(CoS)の設定

この章では、IP-ATM 間サービス クラス(CoS)の設定作業について説明します。IP-ATM CoS とは、IP と ATM の間に QoS 特性をマップする機能セットです。

全体的な概念に関する情報については、『 IP to ATM Class of Service Overview 』モジュールを参照してください。

この章の IP to ATM CoS コマンドの詳細な説明については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。この章に記載されている他のコマンドのドキュメントについては、コマンド リファレンス マスター インデックスを使用するか、オンライン検索してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator により、どの Cisco IOS および Catalyst OS ソフトウェア イメージが特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートするか調べることができます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

単一の ATM VC での IP to ATM CoS の設定作業リスト

単一の ATM Virtual Circuit(VC; 仮想回線) に IP to ATM CoS を設定するには、次の項で説明する作業を実行します。最初の 2 つの項の作業は必須です。残りの項の作業は任意です。

WRED パラメータ グループの定義(必須)

WRED パラメータ グループの設定(必須)

WRED パラメータの表示(任意)

キューイングの統計情報の表示(任意)

IP to ATM CoS 機能には、ATM Permanent Virtual Circuit(PVC; 相手先固定接続)の管理が必要です。

WRED グループおよび IP Precedence を使用した単一の ATM VC の例については、この章の末尾を参照してください。

WRED パラメータ グループの定義

Weighted Random Early Detection(WRED; 重み付けランダム早期検出)パラメータ グループを定義するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# random-detect-group group-name

WRED または VIP-distributed WRED(DWRED; VIP 分散 WRED)パラメータ グループを定義します。

WRED パラメータ グループの設定

WRED パラメータ グループの平均キュー サイズを計算する場合の指数関数的加重係数を設定したり、特定の IP precedence の WRED パラメータ グループを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# random-detect-group group-name

WRED または DWRED パラメータ グループを指定します。

ステップ 2

Router(config)# exponential-weighting-constant exponent

 

または

Router(config)# precedence precedence min-threshold max-threshold mark-probability-denominator

指定された WRED または DWRED パラメータ グループの平均キュー サイズを計算する場合の指数関数的加重係数を設定します。

または

特定の IP precedence の指定された WRED または DWRED パラメータ グループを設定します。

WRED パラメータの表示

設定済みの WRED パラメータを表示するには、特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queueing random-detect [ interface atm_subinterface [ vc [[ vpi /] vci ]]]

指定された ATM サブインターフェイスで、WRED または DWRED がイネーブルであるすべての VC のパラメータを表示します。

キューイングの統計情報の表示

インターフェイスのキューイングの統計情報を表示するには、特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queueing interface interface-number [ vc [[ vpi /] vci ]]

インターフェイスの特定の VC のキューイングの統計情報を表示します。

ATM バンドルの IP to ATM CoS の設定作業リスト

ATM バンドルに IP to ATM CoS を設定するには、次の項で説明する作業を実行します。最初の 4 つ項は必須ですが、残りの項は任意です。

VC バンドルの作成(必須)

バンドルレベル パラメータの適用(必須)

バンドルレベル パラメータの設定

バンドルに適用する VC クラス パラメータの設定

バンドルへのクラスの適用

バンドルへの VC のコミット(必須)

個々の VC へのパラメータの適用(必須)

VC バンドル メンバの直接設定

VC バンドル メンバに適用する VC クラス パラメータの設定

個々の VC バンドル メンバへの VC クラスの適用

バンピングされたトラフィックを拒否する場合の VC の設定(任意)

VC バンドルとその VC メンバのモニタリングと保守(任意)

IP to ATM CoS 機能には、ATM PVC の管理が必要です。

VC クラスを使用した VC バンドルの設定例については、この章の末尾を参照してください。

VC バンドルの作成

バンドルを作成してバンドル コンフィギュレーション モードを開始し、バンドルとそのすべてのメンバ VC にアトリビュートとパラメータを割り当てることができるようにするには、サブインターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-subif)# bundle bundle-name

指定されたバンドルを作成し、バンドル コンフィギュレーション モードを開始します。

バンドルレベル パラメータの適用

VC クラスを割り当てるか、VC クラスをバンドルに直接適用することによって、バンドルレベル パラメータを適用できます。

バンドルに割り当てられた VC クラスを使用して適用されたパラメータは、バンドル レベルで適用されたパラメータに置き換えられます。バンドルレベル パラメータは、個々の VC に適用されたパラメータに置き換えられます。

バンドルレベル パラメータの設定

設定するバンドルにクラスが適用されている場合、バンドルレベル パラメータの設定は任意です。

バンドルとそのすべてのメンバに適用するパラメータを設定するには、必要に応じて、バンドル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-atm-bundle)# protocol protocol { protocol-address | inarp } [[ no ] broadcast ]

スタティック マップを設定するか、バンドルの Inverse Address Resolution Protocol(Inverse ARP)または Inverse ARP ブロードキャストをイネーブルにします。

Router(config-atm-bundle)# encapsulation aal-encap

ATM Adaptation Layer(AAL; ATM アダプテーション レイヤ)およびそのバンドルのカプセル化のタイプを設定します。

Router(config-atm-bundle)# inarp minutes

すべての VC バンドル メンバの Inverse ARP 期間を設定します。

Router(config-atm-bundle)# broadcast

すべての VC バンドル メンバのブロードキャスト転送をイネーブルにします。

Router(config-atm-bundle)# oam retry up-count down-count retry frequency

Operation, Administration, and Maintenance(OAM; 保守運用管理)に関連する VC バンドル パラメータを設定します。

Router(config-atm-bundle)# oam-bundle [ manage ] [ frequency ]

エンドツーエンドの F5 OAM ループバック セルの生成と、バンドルのすべての VC の OAM 管理をイネーブルにします。

バンドルに適用する VC クラス パラメータの設定

VC クラスを使用すると、クラス自体をバンドルに適用できるため、一度に複数のアトリビュートを適用するようにバンドルを設定できます。クラスを使用すると、すべての VC でパラメータを一般化することができます。一部のパラメータについては、その後で個々の VC のパラメータを変更できます (詳細については、個々の VC へのパラメータの適用を参照してください)。

バンドルにクラスを適用する場合に、バンドルのすべての VC メンバを設定するコマンドを含むように VC クラスを設定するには、VC クラス コンフィギュレーション モードで次のコマンドを使用します。VC クラス コンフィギュレーション モードを開始するには、 vc-class atm コマンドを使用します。

 

コマンド
目的

Router(config-vc-class)# oam-bundle [ manage ] [ frequency ]

エンドツーエンドの F5 OAM ループバック セルの生成と、バンドルのすべての VC の OAM 管理をイネーブルにします。

このコマンドに加えて、 broadcast encapsulation inarp oam retry 、および protocol コマンドを VC クラスに追加すると、バンドルの設定に使用できます。これらのコマンドの詳細については、『 Cisco IOS Wide-Area Networking Command Reference 』を参照してください。

バンドルへのクラスの適用

バンドルレベル コンフィギュレーション コマンドを含む定義済みの VC クラスをバンドルに適用するには、バンドル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-atm-bundle)# class-bundle vc-class-name

指定された VC クラスに含まれるバンドルレベルのコマンドでバンドルを設定します。

VC クラスに含まれるバンドルレベル コマンドを使用して設定されたパラメータは、バンドルとそのすべての VC メンバに適用されます。バンドルに直接設定されたコマンドを使用して適用されたバンドルレベル パラメータは、VC クラスを使用して適用されたパラメータよりも優先されます。

VC クラスを使用して適用されたバンドル レベル パラメータ、またはバンドルに直接適用されたバンドルレベル パラメータの一部は、バンドル VC コンフィギュレーション モードで個々の VC に直接適用されたコマンドによって置き換えることができる点に注意してください。

バンドルへの VC のコミット

VC既存のバンドルに追加して、バンドル VC コンフィギュレーション モードを開始するには、バンドル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-atm-bundle)# pvc-bundle pvc-name [ vpi /] [ vci ]

指定された VC をバンドルに追加し、指定された VC バンドル メンバを設定するためにバンドル VC コンフィギュレーション モードを開始します。

バンドルを初めて作成して設定する方法の詳細については、この章の前半のVC バンドルの作成およびバンドルレベル パラメータの適用の項を参照してください。

個々の VC へのパラメータの適用

VC クラスを使用するか、バンドル メンバに直接適用することによって、個々の VC にパラメータを適用できます。

個々の VC に適用されたパラメータは、バンドルレベル のパラメータよりも優先されます。VC に直接適用されたパラメータは、クラス内でバンドル VC コンフィギュレーション レベルの VC に対して適用された同じパラメータよりも優先されます。

VC バンドル メンバの直接設定

VC クラスがバンドル メンバに適用されている場合、VC バンドル メンバの直接設定は任意です。

個々の VC バンドル メンバを直接設定するには、必要に応じてバンドル VC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-member)# ubr output-pcr [ input-pcr ]

Unspecified Bit Rate(UBR; 未指定ビット レート)の QoS の VC を設定し、出力の Peak Cell Rate(PCR; ピーク セル レート)を指定します。

Router(config-if-atm-member)# ubr+ output-pcr output-mcr [ input-pcr ] [ input-mcr ]

UBR の QoS の VC を設定し、出力の PCR と出力の最低保証セル レートを指定します。

Router(config-if-atm-member)# vbr-nrt output-pcr output-scr output-mbs [ input-pcr ] [ input-scr ] [ input-mbs ]

Variable Bit Rate-nonreal time(VBR-NRT; 可変ビット レート非リアルタイム)の VC を設定し、出力の PCR、出力の平均セル レート、および出力の最大バースト セル サイズを指定します。

Router(config-if-atm-member)# precedence [ other | range ]

VC の Precedence レベルを設定します。

Router(config-if-atm-member)# bump { implicit | explicit precedence-level | traffic }

VC のバンピング ルールを設定します。

Router(config-if-atm-member)# protect { group | vc }

VC がバンドルの保護されたグループに所属するか、個別に保護された VC バンドル メンバになるように設定します。

バンドル VC コンフィギュレーション レベルで VC に直接設定されたパラメータは、バンドル VC コンフィギュレーション レベルで VC クラスによって適用された場合など、他のレベルで VC に設定されたパラメータの値よりも優先されます。

VC バンドル メンバに適用する VC クラス パラメータの設定

バンドルにクラスを適用する場合に、バンドルの特定の VC メンバを設定するコマンドを含むように VC クラスを設定するには、必要に応じて VC クラス コンフィギュレーション モードで次のコマンドを使用します。VC クラス コンフィギュレーション モードを開始するには、グローバル コンフィギュレーション モードで vc-class atm コマンドを使用します。

 

コマンド
目的

Router(config-vc-class)# bump { implicit | explicit precedence-level | traffic }

クラスを適用する VC メンバのバンピング ルールを指定します。これらのルールは、キャリアの VC バンドル メンバがダウンした場合に、バンドル トラフィックの VC を送信するルールを決定します。

Router(config-vc-class)# precedence precedence min-threshold max-threshold mark-probability-denominator

クラスを適用する VC メンバの Precedence レベルを定義します。

Router(config-vc-class)# protect { group | vc }

VC をバンドルの保護されたグループのメンバとして設定するか、個別に保護された VC として設定します。

また、 ubr ubr+ 、および vbr-nrt コマンドを VC クラスに追加すると、VC バンドル メンバの設定に使用できます。

VC クラスを使用すると、クラスを VC に適用できるため、一度に複数のアトリビュートを持つ VC メンバを設定できます。


) VC が VC バンドルのメンバである場合、VC クラス モードでの VC の設定に encapsulationprotocolinarp、および broadcast コマンドを使用することはできません。これらのコマンドは、バンドル メンバ レベルではなくバンドル レベルでのみ使用できます。


バンドル内の個々の VC のバンピングを処理する方法を設定するには、バンドル VC コンフィギュレーション モードで bump コマンドを使用します。バンピング ルールの詳細については、このマニュアルの「 IP to ATM Class of Service Overview 」モジュールを参照してください。

個々の VC に対する設定は、VC クラスをバンドルに適用することによってすべての VC バンドル メンバに適用された共有の設定を上書きします。

個々の VC バンドル メンバへの VC クラスの適用

バンドルレベル コンフィギュレーション コマンドを含む定義済みの VC クラスをバンドル メンバに適用するには、バンドル VC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-member)# class-vc vc-class -name

VC クラスを VC バンドル メンバに割り当てます。

VC に割り当てる VC クラスに含まれる VC を設定するパラメータは、バンドル VC コンフィギュレーション モードで入力された個々のコマンドによって VC に直接設定されたパラメータによって置き換えられます。

バンピングされたトラフィックを拒否する場合の VC の設定

トラフィックを伝送している元の VC がダウンした場合、転送される可能性があるトラフィックを受け入れないように個々の VC バンドル メンバを設定するには、バンドル VC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-member)# no bump traffic

リダイレクトされる可能性のあるバンピングされたトラフィックを受け入れないように VC を設定します。

VC バンドルとその VC メンバのモニタリングと保守

バンドルをモニタしたり、設定または使用に関連する問題のトラブルシューティングを行うために、バンドルに関する情報を収集するには、必要に応じて特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show atm bundle bundle-name

各バンドルの VC メンバに割り当てられたバンドルのアトリビュートと、VC メンバの現在の稼動ステータスを表示します。

Router# show atm bundle bundle-name statistics [ detail ]

指定されたバンドルの統計情報または詳細な統計情報を表示します。

Router# show atm map

ATM ネットワークおよび ATM バンドル マップのリモート ホストに対するすべての設定済みの ATM スタティック マップのリストを表示します。

Router# debug atm bundle errors

バンドルのエラーに関する情報を表示します。

Router# debug atm bundle events

バンドルのイベントの記録を表示します。

VC 単位の WFQ および CBWFQ の設定作業リスト

VC 単位の WFQ および CBWFQ に IP to ATM CoS を設定するには、次の項で説明する作業を実行します。最初の 2 つの項の作業は必須です。残りの項の作業は任意です。

クラスベース Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)の設定(必須)

サービス ポリシーのアタッチおよび VC の CBWFQ のイネーブル化(必須)

フローベースの WFQ を使用する場合の VC の設定(任意)

VC 単位の WFQ および CBWFQ のモニタリング(任意)

コンソールへのエラー メッセージのロギングのイネーブル化(任意)

IP to ATM CoS 機能には、ATM PVC の管理が必要です。

スタンドアロンの VC での VC 単位の WFQ および CBWFQ の例については、この章の末尾、およびバンドル メンバの VC に対する VC 単位の WFQ および CBWFQ の例を参照してください。

クラスベース Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)の設定

VC の CBWFQ を設定する前に、標準の CBWFQ コマンドを使用して次の作業を実行する必要があります。

VC 間で送信されるトラフィックの分類に使用される 1 つまたは複数のクラスを作成する

サービス ポリシーとして使用するクラスを含むポリシー マップを定義する


) クラス ポリシーはルータで定義可能な数だけ設定できます(最大 64 個)。ただし、VC にアタッチされるポリシー マップに含まれ、すべてのクラスに割り当てられている帯域幅の合計は、VC の使用可能な帯域幅の 75% を超えてはいけません。使用可能な帯域幅の残りの 25% は、ATM セルのオーバーヘッド(ATM セル タックスとも呼ばれる)、ルーティングとベストエフォート型のトラフィック、およびオーバーヘッドが想定されるその他の機能などのカプセル化に使用されます。帯域割り当ての詳細については、「Congestion Management Overview」を参照してください。


CBWFQ の設定方法と前述の作業の実行方法の詳細については、このマニュアルの「 Configuring Weighted Fair Queueing 」の章を参照してください。

サービス ポリシーのアタッチおよび VC の CBWFQ のイネーブル化

CBWFQ では最小帯域幅のみを保証するため、Available Bit Rate(ABR; 使用可能ビット レート)および Variable Bit Rate(VBR; 可変ビット レート)のサービス クラスを持つ VC のみに CBWQF を適用できます。UBR および Unspecified Bit Rate plus(UBR+; 未指定ビット レート プラス)には VC 単位の WFQ および CBWFQ を適用できません。これは、両方のサービス クラスはどちらもベストエフォート型のクラスであり、最小帯域幅が保証されないためです。VC の CBWFQ がイネーブルの場合、サービス ポリシーの一部として設定されているすべてのクラスは、均等化キューイング システムに組み込まれます。

サービス ポリシーとして使用するスタンドアロンの VC にポリシー マップをアタッチしたり、その VC で CBWFQ をイネーブルにするには、VC サブモードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-vc)# service-policy output policy-map

CBWFQ をイネーブルにし、指定されたサービス ポリシー マップを作成または変更する VC にアタッチします。

サービス ポリシーとして使用する個々の VC バンドル メンバにポリシー マップをアタッチしたり、その VC で CBWFQ をイネーブルにするには、バンドル VC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-member)# service-policy output policy-map

CBWFQ をイネーブルにし、指定されたサービス ポリシー マップを作成または変更する VC にアタッチします。


service-policy output および random-detect-group コマンドは同時に使用できません。サービス ポリシーを適用することによって CBWFQ をイネーブルにした VC に WRED を適用することはできません。さらに、1 つのコマンドが設定されている場合に、他のコマンドを設定できるようにするには、他のコマンドをディセーブルにする必要があります。


フローベースの WFQ を使用する場合の VC の設定

VC レベルで CBWFQ を設定するほかに、IP to ATM CoS 機能を使用すると、VC レベルでフローベースの WFQ を設定できます。フローベースの WFQ はベストエフォート型のサービス クラスを提供する(つまり、最小帯域幅が保証されない)ため、すべてのタイプの CoS VC(ABR、VBR、UBR、および UBR+)に VC 単位の WFQ を設定できます。

VC 単位の WQF では class-default クラスを使用します。そのため、VC 単位の WFQ を設定するには、最初にポリシー マップを作成してから class-default クラスを設定する必要があります (class-default クラスを作成する必要はありません。このクラスは事前に定義されていますが、設定する必要があります)。VC 単位の WFQ の場合、class-default クラスは fair-queue ポリシーマップ クラス コンフィギュレーション コマンドを使用して設定する必要があります。

fair-queue ポリシーマップ クラス コンフィギュレーション コマンドの設定に加えて、 queue-limit コマンドまたは random-detect コマンドの両方ではなくどちらか一方を使用して、デフォルト クラスを設定できます。さらに、デフォルト クラスでフローベースの WFQ を使用する場合は、 bandwidth ポリシーマップ クラス コンフィギュレーション コマンドを使用してデフォルト クラスを設定することはできません。このコマンドを使用すると、デフォルト クラスがフローベースの WFQ として見なされないため、そのクラスを含むサービス ポリシーの適用が ABR および VBR の VC に制限されます。

ポリシー マップを作成して class-default クラスを設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するポリシー マップの名前を指定します。

ステップ 2

Router(config-pmap)# class class-default default-class-name

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 3

Router(config-pmap-c)# fair-queue number-of-dynamic-queues

デフォルト クラスで実行するフローベースの WFQ が使用するために予約する、ダイナミック キューの数を指定します。

ステップ 4

Router(config-pmap-c)# queue-limit number-of-packets

 

または

Router(config-pmap-c)# random-detect

そのクラスのキューに投入できるパケットの最大数を指定します。

WRED をイネーブルにします。クラス ポリシーは、テール ドロップではなく WRED を使用してパケットをドロップします。

ポリシー マップの作成と class-default クラスの設定の詳細については、このマニュアルの「 Configuring Weighted Fair Queueing 」モジュールを参照してください。

デフォルトでは(つまり、 fair-queue ポリシーマップ クラス コンフィギュレーション コマンドを使用して class-default クラスを設定しておらず、 bandwidth ポリシーマップ クラス コンフィギュレーション コマンドを使用して class-default クラスを設定していない場合)、デフォルト クラスはフローベースの WFQ として定義されます。

フローベース の WFQ クラスを含むポリシーマップと同じポリシーマップに他のクラスを含めることができることに注意してください。他の方法では一致しなかったパケットが、デフォルトの class-default クラスの一致基準によって選択されます。

class-default クラスを含むポリシー マップをスタンドアロンの VC にアタッチして、サービス ポリシーで その VC の WFQ をイネーブルにするには、VC サブモードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-vc)# service-policy output policy-map

作成または変更される VC に class-default クラスを含む指定されたポリシー マップをアタッチすることで、VC の WFQ をイネーブルにします。

class-default クラスを含むポリシー マップを個々の VC バンドル メンバにアタッチして、ポリシー マップを使用してサービス ポリシーが VC の WFQ をイネーブルにできるようにするには、バンドル VC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if-atm-member)# service-policy output policy-map

class-default クラスを含む指定されたポリシー マップを VC バンドル メンバにアタッチすることで、VC バンドル メンバの WFQ をイネーブルにします。

VC 単位の WFQ および CBWFQ のモニタリング

ネットワークで VC 単位の WFQ および CBWFQ をモニタするには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queue interface-name interface-number [ vc [ vpi/ ] vci ]]

特定のインターフェイスまたは VC のキュー内部のパケットのコンテンツを表示します。

Router# show queueing interface interface-number [ vc [[ vpi/ ] vci ]]

インターフェイスの特定の VC のキューイングの統計情報を表示します。

コンソールへのエラー メッセージのロギングのイネーブル化

VC を作成または変更するために VC を設定する場合、ルータは割り込みモードで作業を実行します。そのため、エラーが発生した場合に、ルータが printf 文を発行してエラー状態を通知することができません。ルータは、それよりも、コンソールへのすべてのエラー メッセージをログに記録します。このような状況に対応するために、コンソールへのエラー メッセージのロギングをイネーブルにする必要があります。

コンソールへのエラー メッセージのロギングをイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# logging console level

重大度に基づいて、コンソールにログ記録されるメッセージを制限します。

logging console コマンドの詳細については、『 Cisco IOS Configuration Fundamentals Command Reference 』を参照してください。

IP to ATM CoS の設定例

ここでは、IP to ATM CoS の設定例について説明します。

WRED グループおよび IP Precedence を使用した単一の ATM VC の例

VC クラスを使用した VC バンドルの設定例

スタンドアロンの VC での VC 単位の WFQ および CBWFQ の例

バンドル メンバの VC に対する VC 単位の WFQ および CBWFQ の例

IP to ATM CoS の設定方法の詳細については、この章の「単一の ATM VC での IP to ATM CoS の設定作業リスト」および「ATM バンドルの IP to ATM CoS の設定作業リスト」の項を参照してください。

WRED グループおよび IP Precedence を使用した単一の ATM VC の例

次の例では、ATM インターフェイスに PVC を作成し、sanjose という名前の WRED パラメータ グループを PVC に適用します。次に、WRED パラメータ グループ sanjose の IP Precedence の値を設定します。

interface ATM1/1/0.46 multipoint
ip address 200.126.186.2 255.255.255.0
no ip mroute-cache
shutdown
pvc cisco 46
encapsulation aal5nlpid
random-detect attach sanjose
!
random-detect-group sanjose
precedence 0 200 1000 10
precedence 1 300 1000 10
precedence 2 400 1000 10
precedence 3 500 1000 10
precedence 4 600 1000 10
precedence 5 700 1000 10
precedence 6 800 1000 10
precedence 7 900 1000 10

VC クラスを使用した VC バンドルの設定例

この例では、IP ルーティング プロトコルとして Intermediate System-to-Intermediate System(IS-IS)を使用するルータで、VC バンドル管理を設定します。

Bundle-Class クラス

最初に、この設定では、VC パラメータの設定コマンドを含む bundle-class という名前の VC クラスを定義します。バンドル レベルで bundle-class クラスを適用する場合、これらのパラメータはバンドルに所属するすべての VC に適用されます。バンドル VC モードでバンドルの個々の VC に直接適用されたコマンドは、バンドル レベルでグローバルに適用されたコマンドより優先されます。階層の優先ルールを考慮すると、クラス bundle-class が適用されるバンドルに属する VC は、aal5snap カプセル化、ブロードキャスト オン、Inverse ARP を使用した IP アドレスの解決、OAM のイネーブル化などのパラメータを特性として持ちます。

router isis
net 49.0000.0000.0000.1111.00
 
vc-class atm bundle-class
encapsulation aal5snap
broadcast
protocol ip inarp
oam-bundle manage 3
oam retry 4 3 10
 

設定の次のセクションでは VC クラスを定義します。この VC クラスには、VC にクラスを割り当てることによってバンドルの個々の VC に適用できるパラメータを指定するコマンドが含まれます。

Control-Class クラス

control-class という名前のクラスを VC に適用すると、VC は IP Precedence レベルが 7 のトラフィックを伝送します。このクラスを割り当てた VC がダウンした場合はバンドルも一緒にダウンします。これは、このクラスが VC を保護された VC にするためです。このクラスを使用する VC の QoS タイプは vbr-nrt です。

vc-class atm control-class
precedence 7
protect vc
vbr-nrt 10000 5000 32

Premium-Class クラス

premium-class という名前のクラスを VC に適用すると、VC は IP Precedence レベルが 6 および 5 のトラフィックを伝送します。この VC では他のトラフィックのバンピングを許可しません。このクラスが適用された VC がダウンした場合、バンピングされたトラフィックは IP Precedence レベルが 7 の VC にリダイレクトされます。このクラスは、VC をバンドルの保護されたグループのメンバにします。保護されたグループのすべてのメンバがダウンした場合は、バンドルもダウンします。このクラスを使用する VC の QoS タイプは vbr-nrt です。

vc-class atm premium-class
precedence 6-5
no bump traffic
protect group
bump explicitly 7
vbr-nrt 20000 10000 32

Priority-Class クラス

priority-class という名前のクラスを VC に適用すると、VC は IP Precedence の範囲が 4 ~2 のトラフィックを伝送するように設定されます。VC は暗黙のバンピング ルールを使用し、トラフィックのバンピングを許可します。また、VC はバンドルの保護されたグループに所属します。このクラスを使用する VC の QoS タイプは ubr+ です。

vc-class atm priority-class
precedence 4-2
protect group
ubr+ 10000 3000

Basic-Class クラス

basic-class という名前のクラスを VC に適用すると、VC は precedence other コマンドを使用して設定され、プロファイルに指定されていない IP Precedence レベルを持つトラフィックを伝送します。このクラスを使用する VC は、バンドルの保護されたグループに所属します。このクラスを使用する VC の QoS タイプは ubr です。

vc-class atm basic-class
precedence other
protect group
ubr 10000
 

次のコマンド セットは、ルータのサブインターフェイスが 3 つのネイバーへの接続に使用する 3 つのバンドルを設定します。これらのバンドルは new-york、san-francisco、および los-angeles と呼ばれます。バンドル new-york には 4 つの VC メンバ、バンドル san-francisco には 4 つの VC メンバ、バンドル los-angeles には 3 つの VC メンバがあります。

new-york バンドル

この例の最初の部分では、サブインターフェイスの IP アドレスとルータのプロトコル(ルータは IP ルーティング プロトコルとして IS-IS を使用)を指定します。また、1 つ目のバンドル new-york を作成し、バンドル コンフィギュレーション モードを開始します。

interface atm 1/0.1 multipoint
ip address 10.0.0.1 255.255.255.0
ip router isis
bundle new-york
 

次の設定部分では、バンドル コンフィギュレーション モードから 2 つのプロトコル コマンドを使用し、バンドルでの IP および Open Systems Interconnect(OSI)トラフィック フローをイネーブルにします。OSI ルーティング パケットは、バンドルで一番優先度の高い VC を使用します。OSI データ パケットは、バンドルで一番優先度の低い VC を使用します。設定されている場合、IPX や AppleTalk などの他のプロトコルは、常にバンドルで一番優先度の低い VC を使用します。

前のコマンドと次のコマンドのインデントのレベルが示すように、バンドル new-york の下位には、プロトコルを設定するコマンドと、bundle-class という名前のクラスを適用するコマンドがあります。

protocol ip 1.1.1.2 broadcast
protocol clns 49.0000.0000.2222.00 broadcast
class-bundle bundle-class
 

bundle-class という名前のクラスは、バンドル new-york に適用され、 protocol ip inarp コマンドを含みます。継承ルールに従って、バンドル レベルで設定される protocol ip は、bundle-class クラスに指定された protocol ip inarp より優先されます。

pvc-bundle ny-control 207 で始まる次のコマンド セットは、かなり下位にありますが、バンドル new-york に 4 つの VC(ny-control、ny-premium、ny-priority、および ny-basic)を追加します。特定のクラス、つまり、この設定例で事前に定義されたクラスの 1 つが各 VC に適用され、クラスに含まれるコマンドで指定されたパラメータを使用して設定されます。

この設定の場合と同様、バンドルに属する個々の VC を設定するには、ルータがマザー バンドルに対してバンドル モードである必要があります。バンドルに所属する各 VC では、下位のモードは特定の VC の pvc モードです。

次のコマンドでは、バンドル new-york の個々の VC を設定します。

pvc-bundle ny-control 207
class-vc control-class
pvc-bundle ny-premium 206
class-vc premium-class
pvc-bundle ny-priority 204
class-vc priority-class
pvc-bundle ny-basic 201
class-vc basic-class

san-francisco バンドル

次のコマンド セットは、san-francisco という名前のバンドルを作成して設定します。バンドル コンフィギュレーション レベルでは、bundle-class クラスに含まれるコンフィギュレーション コマンドは、バンドル san-francisco およびバンドルに所属する個々の VC に属します。そのため、 pvc-bundle コマンドはバンドルに追加するために個々の VC に対して実行されます。VC が追加され、バンドル VC コンフィギュレーション モードが開始されると、特定の事前設定済みのクラスが VC に割り当てられます。そのクラスを構成するコンフィギュレーション コマンドは、VC の設定に使用されます。階層ルールはこの時点で適用されます。適用されたクラスに含まれるコマンド パラメータは、バンドル コンフィギュレーション レベルで適用された同じパラメータによって置き換えられます。このパラメータは、VC に直接適用された同じパラメータによって置き換えられます。

bundle san-francisco
protocol clns 49.0000.0000.0000.333.00 broadcast
inarp 1
class-bundle bundle-class
pvc-bundle sf-control 307
class-vc control-class
pvc-bundle sf-premium 306
class-vc premium-class
pvc-bundle sf-priority 304
class-vc priority-class
pvc-bundle sf-basic 301
class-vc basic-class

los-angeles バンドル

次のコマンド セットは、los-angeles という名前のバンドルを作成して設定します。バンドル コンフィギュレーション レベルでは、bundle-class クラスに含まれるコンフィギュレーション コマンドは、バンドル los-angeles およびバンドルに所属する個々の VC に属します。そのため、 pvc-bundle コマンドはバンドルに追加するために個々の VC に対して実行されます。VC が追加され、バンドル VC コンフィギュレーション モードが開始されると、VC に優先度が設定され、その VC は保護されたグループ(protect グループ)のメンバとして設定されるか、個別に保護された VC として設定されます。次に、特定のクラスが各 VC に割り当てられ、さらに特徴付けられます。階層ルールが適用されます。VC に直接かつ個別に適用されたコマンドのパラメータは、クラス内でバンドル VC コンフィギュレーション レベルの VC に対して適用された同じパラメータよりも優先されます。このパラメーターは、バンドル コンフィギュレーション レベルでバンドル全体に適用された同じパラメータよりも優先されます。

bundle los-angeles
protocol ip 1.1.1.4 broadcast
protocol clns 49.0000.0000.4444.00 broadcast
inarp 1
class-bundle bundle-class
pvc-bundle la-high 407
precedence 7-5
protect vc
class-vc premium-class
pvc-bundle la-mid 404
precedence 4-2
protect group
class-vc priority-class
pvc-bundle la-low 401
precedence other
protect group
class-vc basic-class

スタンドアロンの VC での VC 単位の WFQ および CBWFQ の例

次の例では、2 つのクラス マップを作成し、その一致基準を定義します。1 つ目の class1 という名前のマップクラスでは、一致基準として番号付きの Access Control List(ACL; アクセス コントロール リスト)101 が使用されます。2 つ目の class2 という名前のマップクラスでは、一致基準として番号付きの ACL 102 が使用されます。

次に、この例では policy1 という名前のポリシー マップにこれらのクラスが含まれています。class1 のポリシーでは、このクラスのために予約されたキューに対して、最小帯域幅の割り当て要求に 500 kbps、最大パケット数の制限が 30 と指定されています。class2 のポリシーでは、最小帯域幅の割り当て要求に 1000 kbps が指定されているため、デフォルトのキューの制限は 64 パケットであると想定されます。policy1 を構成する 2 つのクラスの帯域幅要求の合計が、ポリシー マップがアタッチされた cisco という名前の PVC の総帯域幅(2000 kbps)の 75% になることに注意してください。

この例では、policy1 という名前のポリシー マップを cisco という名前の PVC にアタッチします。ポリシー マップ policy1 が PVC cisco にアタッチされると、そのクラスによって PVC の CBWFQ サービス ポリシーが構成されます。この PVC で送信されるパケットは、ACL 101 および 102 に対する一致基準をチェックされ、それに従って分類されます。

このポリシー マップでは class-default コマンドが明確に設定されていないため、サービス ポリシーを構成する 2 つのクラスの一致基準に一致しないすべてのトラフィックは、ベストエフォート型のフロー ベースの WFQ を提供する事前定義済みの class-default クラスによって処理されます。

class-map class1
match access-group 101
 
class-map class2
match access-group 102
 
policy-map policy1
class class1
bandwidth 500
queue-limit 30
 
class class2
bandwidth 1000
 
interface ATM1/1/0.46 multipoint
ip address 200.126.186.2 255.255.255.0
pvc cisco 46
vbr-nrt 2000 2000
encap aal5snap
service policy output policy1
 

バンドル メンバの VC に対する VC 単位の WFQ および CBWFQ の例

次の例では、VC 単位の WFQ および CBWFQ がイネーブルであり、サービス ポリシーが設定されているメンバを持つ san-francisco という名前の PVC バンドルを示します。この例では、次のポリシー マップに含まれるクラスが定義済みであり、policy1、policy2、および policy4 というポリシー マップが作成済みであると仮定します。各 PVC では、IP to ATM CoS の pvc-bundle コマンドを使用して、指定されたポリシー マップをアタッチする PVC を指定します。

PVC 0/34 および 0/31 には、同じポリシー マップ policy2 がアタッチされていることに注意してください。同じポリシー マップを複数の VC に割り当てることはできますが、各 VC が持つことができるのは出力 PVC にアタッチされた 1 つのポリシー マップのみです。

bundle san-francisco
protocol ip 1.0.2.20 broadcast
encapsulation aal5snap
pvc-bundle 0/35
service policy output policy1
vbr-nrt 5000 3000 500
precedence 4-7
pvc-bundle 0/34
service policy output policy2
vbr-nrt 5000 3000 500
precedence 2-3
pvc-bundle 0/33
vbr-nrt 4000 3000 500
precedence 2-3
service policy output policy4
pvc-bundle 0/31
service policy output policy2