Cisco IOS サービス品質(QoS)ソリューション コ ンフィギュレーション ガイド
Weighted Random Early Detection (WRED)の設定
Weighted Random Early Detection(WRED)の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Weighted Random Early Detection(WRED)の設定

重み付けランダム早期検出の設定作業リスト

WRED のイネーブル化

WRED パラメータの変更

WRED のモニタリング

DWRED の設定作業リスト

トラフィック ポリシーの DWRED の設定

トラフィック ポリシーの IP precedence 値を使用する DWRED の設定

DWRED のモニタリングと保守

フローベース WRED の設定作業リスト

フローベース WRED の設定

DiffServ 準拠の WRED の設定作業リスト

Differentiated Services Code Point 値を使用するための WRED の設定

インターフェイス レベルの WRED

VC 単位レベルの WRED

クラス レベルの WRED

DSCP 値の設定確認

WRED の設定例

WRED の設定例

DWRED のパラメータ設定例

WRED のパラメータ設定例

DWRED の設定例

インターフェイスでの DWRED:例

モジュラ QoS CLI:例

トラフィック ポリシーの DWRED の設定:例

フローベース WRED の設定例

DiffServ 準拠の WRED の設定例

DSCP 値を使用するように設定した WRED:例

DSCP 値の設定確認:例

Weighted Random Early Detection(WRED)の設定

機能の履歴

リリース
変更点

Cisco IOS

Cisco IOS ソフトウェアの機能サポートに関する情報については、Cisco Feature Navigator を使用してください。

ここでは、ルータでの Weighted Random Early Detection(WRED; 重み付けランダム早期検出)Distributed WRED(DWRED; 分散 WRED)、フローベース WRED、および DiffServ 準拠の WRED の設定作業について説明します。

詳細な概念情報については、このマニュアルの「 Congestion Avoidance Overview 」モジュールを参照してください。

この章の WRED および DWRED コマンドの詳細については、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。この章に記載されている他のコマンドのドキュメントについては、コマンド リファレンス マスター インデックスを使用するか、オンライン検索してください。

RSVP-ATM QoS インターワーキングおよび IP-ATM 間サービス クラス機能でも、WRED を使用します。WRED を使用してこれらの機能を設定する方法については、このマニュアルの「 Configuring RSVP-ATM QoS Interworking 」および「 Configuring IP to ATM Class of Service 」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


) WRED は TCP/IP などの適応型トラフィックに有効です。TCP では、破棄されたパケットは輻輳を示しているため、パケットの発信元は伝送レートを低くします。他のプロトコルでは、パケットの発信元は応答しないか、または破棄されたパケットを同じレートで再送信します。そのため、パケットをドロップしても輻輳は軽減されません。

WRED は非 IP トラフィックを最も低い優先度 0 として扱います。そのため、非 IP トラフィックは、IP トラフィックよりもドロップ確率が高くなります。

同じインターフェイス上の WRED を Route Switch Processor(RSP)ベースの Custom Queueing(CQ; カスタム キューイング)、Priority Queueing(PQ; プライオリティ キューイング)、または Weighted Fair Queueing(WFQ; 重み付け均等化キューイング)で設定できません。ただし、同じインターフェイスで DWRED および DWFQ の両方を設定できます。


重み付けランダム早期検出の設定作業リスト

Random Early Detection(RED; ランダム早期検出)は、TCP の輻輳制御メカニズムを利用する輻輳回避メカニズムです。高輻輳期間の前にランダムにパケットをドロップすることにより、RED はパケットの送信元に、その伝送レートを低下させるよう指示します。WRED では、IP Precedence に基づいてパケットを選択的にドロップします。エッジ ルータは、ネットワークに送信されてくるパケットに IP Precedence を割り当てます (WRED は、輻輳が予想される任意の出力インターフェイスに有効です。ただし、通常は WRED はエッジではなくネットワークのコア ルータに使用されます)。WRED はこれらの IP precedence を使用して、さまざまなタイプのトラフィックの処理方法を決定します。

パケットが着信すると、次のイベントが発生します。

1. 平均キュー サイズが計算されます。

2. 平均が最低キューしきい値未満の場合は、到着したパケットはキューイングされます。

3. 平均値がそのトラフィック タイプの最小キューしきい値と、インターフェイスの最大しきい値の間の場合、そのトラフィック タイプのパケット ドロップ確率に応じて、パケットはドロップされるか、キューに保存されます。

4. 平均キュー サイズが最大しきい値を超える場合、パケットはドロップします。

キュー計算の詳細と WRED の機能については、「 Congestion Avoidance Overview 」モジュールを参照してください。

インターフェイスで WRED を設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

WRED のイネーブル化(必須)

WRED パラメータの変更(任意)

WRED のモニタリング(任意)

WRED の設定例については、この章の末尾を参照してください。

WRED のイネーブル化

WRED を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# random-detect

WRED をイネーブルにします。Versatile Interface Processor(VIP)インターフェイスでこのコマンドを設定すると、DWRED がイネーブルになります。

インターフェイスで WRED を設定するために、その他のコマンドまたはパラメータを指定する必要はありません。WRED はデフォルトのパラメータ値を使用します。

WRED パラメータの変更

WRED パラメータを変更するには、必要に応じてインターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# random-detect exponential-weighting-constant exponent

平均キュー長の計算に使用する加重係数を設定します。

Router(config-if)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominator

特定の IP precedence を持つパケットのパラメータを設定します。IP precedence 0 の最小しきい値は、インターフェイスの最大しきい値の半分に相当します。precedence ごとにこのコマンドを繰り返します。WRED ではなく RED を設定するには、各 precedence に同じパラメータを使用します。

random-detect インターフェイス コンフィギュレーション コマンドで WRED をイネーブルにすると、パラメータはデフォルト値に設定されます。加重係数は 9 です。すべての precedence について、マーク確率値は 10 で、最大しきい値は、インターフェイスの出力バッファリング容量と送信速度に基づいています。

デフォルトの最小しきい値は precedence によって変わります。IP precedence 0 の最小しきい値は、最大しきい値の半分に相当します。残りの precedence の値は、均等な間隔で、最大しきい値の半分と最大しきい値の間に含まれます。


) デフォルトの WRED パラメータ値は、最高の使用可能データに基づきます。値を変更することでアプリケーションに利点があると判断した場合を除き、パラメータのデフォルト値を変更しないことをお勧めします。


WRED のモニタリング

ネットワークで WRED サービスを監視するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queue interface-type interface-number

キュー内のパケットのヘッダー情報を表示します。このコマンドは DWRED をサポートしません。

Router# show queueing interface interface-number [ vc [[ vpi/ ] vci ]]

インターフェイス上の特定の Virtual Circuit(VC; 仮想回線)の WRED 統計情報を表示します。

Router# show queueing random-detect

WRED のキューイング設定を表示します。

Router# show interfaces [ type slot | port-adapter | port ]

インターフェイス上の WRED 設定を表示します。

DWRED の設定作業リスト

DWRED を設定するには、以下の項で説明する作業を実行します。最初の 2 つの項は必須です。残りの項は任意です。

トラフィック ポリシーの DWRED の設定(必須)

トラフィック ポリシーの IP precedence 値を使用する DWRED の設定(必須)

DWRED のモニタリングと保守(任意)

DWRED の設定例については、この章の末尾を参照してください。

トラフィック ポリシーの DWRED の設定

トラフィック ポリシーで DWRED を設定するには、グローバル コンフィギュレーション モードで policy-map コマンドを使用して、トラフィック ポリシー名を指定します。次に、トラフィック ポリシーを設定するには、policy-map コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するトラフィック ポリシーの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

作成し、トラフィック ポリシーに含めるトラフィック クラスの名前を指定します。

手順 3、4、および 5 は任意です。指数加重係数を設定しない場合、帯域幅の量を指定しない場合、または予約するキュー数を指定しない場合、これら 3 つの手順をスキップし、手順 6 に進むことができます。

ステップ 3

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

平均キュー長の計算に使用する指数加重係数を設定します。

ステップ 4

Router(config-pmap-c)# bandwidth bandwidth-kbps

トラフィック クラスに割り当てる帯域幅の量(kbps 単位)を指定します。

ステップ 5

Router(config-pmap-c)# fair-queue [ queue-limit queue-values ]

トラフィック クラス用に予約するキューの数を指定します。

ステップ 6

Router(config-pmap-c)# queue-limit number-of-packets

指定したトラフィック クラスでキューできるパケットの最大数を指定します。

トラフィック ポリシーのデフォルト トラフィック クラスは、ポリシーがトラフィック ポリシーに定義されている他のトラフィック クラスの一致基準を、トラフィックが満たさない場合に、トラフィックを誘導する先のトラフィック クラスです。同じポリシー マップの複数のトラフィック クラスについてポリシーを設定するには、ステップ 2 ~ステップ 4 を繰り返します。

トラフィック ポリシーをインターフェイスに適用し、インターフェイスで CBWFQ をイネーブルにするには、トラフィック ポリシーを作成する必要があります。トラフィック クラス ポリシーはルータで定義可能な数だけ設定できます(最大 64 個)。

policy-map コマンドを使用してトラフィック ポリシーを設定した後は、インターフェイスにトラフィック ポリシーを適用してからイネーブルにする必要があります。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

トラフィック ポリシーの IP precedence 値を使用する DWRED の設定

IP precedence 値に基づいてパケットをドロップするように DWRED を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map

作成または変更するトラフィック ポリシーの名前を指定します。

ステップ 2

Router(config-pmap)# class class-name

トラフィック ポリシーに関連付けるトラフィック クラスの名前を指定します。

ステップ 3

Router(config-pmap-c)# random-detect exponential-weighting-constant exponent

平均キュー長の計算に使用する指数加重係数を設定します。

ステップ 4

Router(config-pmap-c)# random-detect precedence precedence min-threshold max-threshold mark-prob-denominato r

特定の IP precedence を持つパケットのパラメータを設定します。IP precedence 0 の最小しきい値は、インターフェイスの最大しきい値の半分に相当します。precedence ごとにこのコマンドを繰り返します。

policy-map コマンドを使用してトラフィック ポリシーを設定した後は、インターフェイスにトラフィック ポリシーを適用してからイネーブルにする必要があります。トラフィック ポリシーをインターフェイスに適用する方法については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

DWRED のモニタリングと保守

トラフィック ポリシーと関連するトラフィック クラスの設定を表示するには、必要に応じて EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show policy-map

設定済みトラフィック ポリシーをすべて表示します。

Router# show policy-map policy-map-name

ユーザが指定したトラフィック ポリシーを表示します。

Router# s how policy-map interface

インターフェイスに適用されているすべての入力および出力ポリシーの統計情報と設定を表示します。

Router# show policy-map interface interface-spec

特定のインターフェイスに適用されている入力および出力ポリシーの設定と統計情報を表示します。

Router# show policy-map interface interface-spec input

インターフェイスに適用されている入力ポリシーの設定と統計情報を表示します。

Router# show policy-map interface interface-spec output

インターフェイスに適用されている出力ポリシーの設定と統計情報を表示します。

Router# show policy-map [ interface [ interface-spec [ input | output ] [ class class-name ]]]]

ポリシーに設定されているクラス名の設定と統計情報を表示します。

フローベース WRED の設定作業リスト

インターフェイスでフローベース WRED を設定するには、「フローベース WRED の設定」で説明している必須の作業を実行します。

フローベース WRED の設定例については、この章の末尾を参照してください。

フローベース WRED の設定

フローベース WRED の設定前に、WRED をイネーブルにし、設定する必要があります。WRED の設定方法については、この章の「重み付けランダム早期検出の設定作業リスト」を参照してください。

フローベース WRED のインターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# random-detect flow

フローベース WRED をイネーブルにします。

ステップ 2

Router(config-if)# random-detect flow average-depth-factor scaling-factor

フローベース WRED のフローしきい値乗数を設定します。

ステップ 3

Router(config-if)# random-detect flow count number

フローベース WRED の最大フロー カウントを設定します。

DiffServ 準拠の WRED の設定作業リスト

DiffServ Compliant Weighted Random Early Detection(DiffServ 準拠の重み付けランダム早期検出)機能を設定するには、以下の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

Differentiated Services Code Point 値を使用するための WRED の設定(必須)

DSCP 値の設定確認(任意)

DiffServ 準拠の WRED の設定例については、この章の末尾を参照してください。

Differentiated Services Code Point 値を使用するための WRED の設定

Differentiated Services Code Point(DSCP)値を使用するときに WRED の設定に使用するコマンドは、WRED がインターフェイス レベル、VC 単位レベル、またはクラス レベルのどのレベルで使用されるかによって変わります。

インターフェイス レベルの WRED

ドロップ確率を計算するときに DSCP を使用するように WRED を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config-if)# random-detect dscp-based

パケットのドロップ確率を計算するときに、WRED で DSCP を使用するように指示します。

ステップ 2

Router(config-if)# random-detect dscp dscpvalue min-threshold max-threshold [ mark-probability-denominator ]

最小および最大のしきい値を指定し、任意で指定した DSCP 値のマーク確率値を指定します。

VC 単位レベルの WRED

ドロップ確率を計算するときに DSCP を使用するように WRED を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# random-detect-group group-name dscp-based

パケットのドロップ確率を計算するときに、WRED で DSCP を使用するように指示します。

ステップ 2

Router(cfg-red-grp)# dscp dscpvalue min-threshold max-threshold [ mark-probability-denominator ]

DSCP 値、最小および最大のパケットしきい値、および任意で DSCP 値のマーク確率値を指定します。

ステップ 3

Router(config-atm-vc)# random-detect [ attach group-name ]

VC 単位 WRED または VC 単位 VIP-DWRED をイネーブルにします。

クラス レベルの WRED

ドロップ確率を計算するときに DSCP を使用するように WRED を設定するには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。これらは、ポリシー マップ内のクラス レベルで使用するコマンドです。

 

コマンド
目的

ステップ 1

Router(config-if)# class-map class-map-name

指定したクラスへのパケットのマッチングに使用するクラス マップを作成します。

ステップ 2

Router(config-cmap)# match match criterion

クラス マップの一致基準を設定します。一致基準の詳細については、『 Applying QoS Features Using the MQC 』モジュールを参照してください。

ステップ 3

Router(config-if)# policy-map policy-map

1 つ以上のインターフェイスに対応付けることができるポリシー マップを作成または修正し、トラフィック ポリシーを指定します。

ステップ 4

Router(config-pmap)# class class-map-name

デフォルト クラスの QoS 処理を指定します。

ステップ 5

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

ポリシー マップに属するクラスに割り当てる帯域幅を指定または変更します。

ステップ 6

Router(config-pmap-c)# random-detect dscp-based

パケットのドロップ確率を計算するときに、WRED で DSCP を使用するように指示します。

ステップ 7

Router(config-pmap-c)# random-detect dscp dscpvalue min-threshold max-threshold [ mark-probability-denominator ]

最小および最大のパケットしきい値を指定し、任意で DSCP 値のマーク確率値を指定します。

ステップ 8

Router(config-if)# service-policy output policy-map

ポリシー マップを出力インターフェイスまたは VC に適用し、そのインターフェイスまたは VC のトラフィック ポリシーとして使用します。

DSCP 値の設定確認

DSCP 値の設定を確認するには、必要に応じてグローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router# show queueing interface

インターフェイスまたは VC のキューイングの統計情報を表示します。

Router# show policy-map interface

指定したインターフェイスまたは Permanent Virtual Circuit(PVC; 相手先固定接続)でトラフィック ポリシーに設定されてクラスの設定を表示します。

WRED の設定例

ここでは、WRED および DWRED の設定例を示します。

WRED の設定例

DWRED のパラメータ設定例

WRED のパラメータ設定例

WRED の設定方法については、この章の「重み付けランダム早期検出の設定作業リスト」を参照してください。

WRED の設定例

次に、デフォルトのパラメータ値で WRED をイネーブルにする例を示します。

interface Serial5/0
description to qos1-75a
ip address 200.200.14.250 255.255.255.252
random-detect
 

show interfaces コマンドの出力を使用して、設定を確認します。「キューイング戦略」レポートには、「Random Early Detection(RED; ランダム早期検出)」が表示されます。

Router# show interfaces serial 5/0
 
Serial5/0 is up, line protocol is up
Hardware is M4T
Description: to qos1-75a
Internet address is 200.200.14.250/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 237/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive not set
Last input 00:00:15, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:05:08
Input queue: 0/75/0 (size/max/drops); Total output drops: 1036
Queueing strategy: random early detection(RED)
5 minutes input rate 0 bits/sec, 2 packets/sec
5 minutes output rate 119000 bits/sec, 126 packets/sec
594 packets input, 37115 bytes, 0 no buffer
Received 5 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
37525 packets output, 4428684 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
0 carrier transitions DCD=up DSR=up DTR=up RTS=up CTS=up
 

show queue コマンドの出力を使用して、インターフェイス キューの現在の内容を表示します。ドロップが発生した後にすべての IP precedence のパケットを配置するキューは 1 つだけです。5 パケットのうち 3 パケットのみを示すために、出力を省略しました。

Router# show queue serial 5/0
Output queue for Serial5/0 is 5/0
 
Packet 1, linktype: ip, length: 118, flags: 0x288
source: 190.1.3.4, destination: 190.1.2.2, id: 0x0001, ttl: 254,
TOS: 128 prot: 17, source port 11111, destination port 22222
data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321
0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765
 
Packet 2, linktype: ip, length: 118, flags: 0x288
source: 190.1.3.5, destination: 190.1.2.2, id: 0x0001, ttl: 254,
TOS: 160 prot: 17, source port 11111, destination port 22222
data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321
0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765
 
Packet 3, linktype: ip, length: 118, flags: 0x280
source: 190.1.3.6, destination: 190.1.2.2, id: 0x0001, ttl: 254,
TOS: 192 prot: 17, source port 11111, destination port 22222
data: 0x2B67 0x56CE 0x005E 0xE89A 0xCBA9 0x8765 0x4321
0x0FED 0xCBA9 0x8765 0x4321 0x0FED 0xCBA9 0x8765
 

show queueing コマンドの出力を使用して、各 precedence の現在の設定を表示します。また、デフォルトの最小しきい値は、最大しきい値の半分と最大しきい値の間で均等の間隔です。しきい値はパケット カウントを単位として指定します。

Router# show queueing
 
Current random-detect configuration:
Serial5/0
Queueing strategy:random early detection (WRED)
Exp-weight-constant:9 (1/512)
Mean queue depth:28
Class Random Tail Minimum Maximum Mark
drop drop threshold threshold probability
0 330 0 20 40 1/10
1 267 0 22 40 1/10
2 217 0 24 40 1/10
3 156 0 26 40 1/10
4 61 0 28 40 1/10
5 6 0 31 40 1/10
6 0 0 33 40 1/10
7 0 0 35 40 1/10
rsvp 0 0 37 40 1/10

DWRED のパラメータ設定例

次に、各 IP precedence に同じパラメータを指定する例を示します。したがって、すべての IP precedence が同じ扱いを受けます。DWRED をイネーブルにすることから始めます。

interface FastEthernet1/0/0
ip address 200.200.14.250 255.255.255.252
random-detect
 

次に、 show queueing random-detect コマンドを入力して、precedence 固有のパラメータに使用する適切な値を決定します。

Router# show queueing random-detect
 
Current random-detect configuration:
FastEthernet2/0/0
Queueing strategy:fifo
Packet drop strategy:VIP-based random early detection (DWRED)
Exp-weight-constant:9 (1/512)
Mean queue depth:0
Queue size:0 Maximum available buffers:6308
Output packets:5 WRED drops:0 No buffer:0
 
Class Random Tail Minimum Maximum Mark Output
drop drop threshold threshold probability Packets
0 0 0 109 218 1/10 5
1 0 0 122 218 1/10 0
2 0 0 135 218 1/10 0
3 0 0 148 218 1/10 0
4 0 0 161 218 1/10 0
5 0 0 174 218 1/10 0
6 0 0 187 218 1/10 0
7 0 0 200 218 1/10 0
 

各 precedence に同じパラメータを割り当てることで、設定を完了します。 show queueing random-detect コマンドの出力から取得される値を使用して、適切なパラメータ値を選択します。

interface FastEthernet1/0/0
random-detect precedence 0 100 218 10
random-detect precedence 1 100 218 10
random-detect precedence 2 100 218 10
random-detect precedence 3 100 218 10
random-detect precedence 4 100 218 10
random-detect precedence 5 100 218 10
random-detect precedence 6 100 218 10
random-detect precedence 7 100 218 10

WRED のパラメータ設定例

次に、インターフェイスで WRED をイネーブルにし、異なる IP precedence にパラメータを指定する例を示します。

interface Hssi0/0/0
description 45Mbps to R1
ip address 10.200.14.250 255.255.255.252
random-detect
random-detect precedence 0 32 256 100
random-detect precedence 1 64 256 100
random-detect precedence 2 96 256 100
random-detect precedence 3 120 256 100
random-detect precedence 4 140 256 100
random-detect precedence 5 170 256 100
random-detect precedence 6 290 256 100
random-detect precedence 7 210 256 100
random-detect precedence rsvp 230 256 100

DWRED の設定例

ここでは、DWRED の設定例を示します。

「インターフェイスでの DWRED:例」

「モジュラ QoS CLI:例」

「トラフィック ポリシーの DWRED の設定:例」

DWRED の設定方法については、この章の「DWRED の設定作業リスト」を参照してください。

インターフェイスでの DWRED:例

次に、加重係数が 10 のインターフェイスで DWRED を設定する例を示します。

Router(config)# interface hssi0/0/0
Router(config-if)# description 45mbps to R1
Router(config-if)# ip address 192.168.14.250 255.255.255.252
Router(config-if)# random-detect
Router(config-if)# random-detect exponential-weighting-constant 10

モジュラ QoS CLI:例

次に、インターフェイスで Legacy CLI(非モジュラ QoS コマンドライン インターフェイス)機能を使用して、DWRED をイネーブルにし、異なる IP precedence にパラメータを指定する例を示します。

interface Hssi0/0/0
description 45Mbps to R1
ip address 200.200.14.250 255.255.255.252
random-detect
random-detect precedence 0 32 256 100
random-detect precedence 1 64 256 100
random-detect precedence 2 96 256 100
random-detect precedence 3 120 256 100
random-detect precedence 4 140 256 100
random-detect precedence 5 170 256 100
random-detect precedence 6 290 256 100
random-detect precedence 7 210 256 100
random-detect precedence rsvp 230 256 100
 

次に、モジュラ QoS CLI を使用して、policy10 というトラフィック ポリシーを設定する例を示します。輻輳回避のために、テール ドロップではなく WRED パケットのドロップが使用されます。レベル 0 ~ 5 の IP precedence はリセットされます。

policy-map policy10
class acl10
bandwidth 2000
random-detect exponential-weighting-constant 10
random-detect precedence 0 32 256 100
random-detect precedence 1 64 256 100
random-detect precedence 2 96 256 100
random-detect precedence 3 120 256 100
random-detect precedence 4 140 256 100
random-detect precedence 5 170 256 100

トラフィック ポリシーの DWRED の設定:例

次に、int10 というトラフィック クラスのポリシーを設定して、指数加重係数を 12 に設定する例を示します。これは、トラフィック クラス int10 のキューの平均キュー サイズ計算に使用される加重係数です。トラフィック クラス int10 では、輻輳回避のためにテール ドロップではなく WRED パケットのドロップが使用されます。

policy-map policy12
class int10
bandwidth 2000
random-detect exponential-weighting-constant 12

フローベース WRED の設定例

次に、シリアル インターフェイス 1 で WRED をイネーブルにし、フローベース WRED を設定する例を示します。 random-detect インターフェイス コンフィギュレーション コマンドは、WRED をイネーブルにするために使用されます。WRED をイネーブルにしたら、 random-detect flow コマンドを使用してフローベース WRED をイネーブルにします。

フローベース WRED をイネーブルにした後は、 random-detect flow average-depth-factor コマンドを使用して倍率を 8 に設定し、 random-detect flow count コマンドを使用してフロー カウントを 16 に設定します。倍率は、フローごとに使用可能なバッファ数を拡張する場合、および各アクティブ フローで出力キューに保存できるパケット数を決定する場合に使用されます。

configure terminal
interface Serial1
random-detect
random-detect flow
random-detect flow average-depth-factor 8
random-detect flow count 16
end
 

例の次の部分では、前のフローベース WRED コマンドを発行した後の設定例を示します。

Router# more system:running-config
 
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug datetime msec localtime
service timestamps log uptime
no service password-encryption
service tcp-small-servers
!
no logging console
enable password lab
!
clock timezone PST -8
clock summer-time PDT recurring
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
no ip mroute-cache
no keepalive
shutdown
!
interface Serial1
ip address 190.1.2.1 255.255.255.0
no ip directed-broadcast
load-interval 30
no keepalive
random-detect
random-detect flow
random-detect flow count 16
random-detect flow average-depth-factor 8
!
router igrp 8
network 190.1.0.0
!
ip classless
no ip http server
!
line con 0
transport input none
line 1 16
transport input all
line aux 0
transport input all
line vty 0 4
password lab
login
!
end

DiffServ 準拠の WRED の設定例

ここでは、DiffServ 準拠の WRED の設定例を示します。

「DSCP 値を使用するように設定した WRED:例」

「DSCP 値の設定確認:例」

DiffServ 準拠の WRED の設定方法については、この章の「DiffServ 準拠の WRED の設定作業リスト」を参照してください。

DSCP 値を使用するように設定した WRED:例

次に、DSCP 値 8 を使用するように WRED を設定する例を示します。DSCP 値 8 の最小しきい値は 24 で、最大しきい値は 40 です。この設定はインターフェイス レベルで実行されました。

Router(config-if)# interface seo/0
Router(config-if)# random-detect dscp-based
Router(config-if)# random-detect dscp 8 24 40
 

次に、WRED が DSCP 値 9 を使用できるようにする例を示します。DSCP 値 9 の最小しきい値は 20 で、最大しきい値は 50 です。この設定は、必要に応じて他の VC に適用できます。

Router(config)# random-detect-group sanjose dscp-based
Router(cfg-red-grp)# dscp 9 20 50
Router(config-subif-vc)# random-detect attach sanjose
 

次に、WRED がクラス c1 に DSCP 値 8 を使用できるようにする例を示します。DSCP 値 8 の最小しきい値は 24 で、最大しきい値は 40 です。最後の行は、トラフィック ポリシーを出力インターフェイスまたは VC p1 に適用します。

Router(config-if)# class-map c1
Router(config-cmap)# match access-group 101
Router(config-if)# policy-map p1
Router(config-pmap)# class c1
Router(config-pmap-c)# bandwidth 48
Router(config-pmap-c)# random-detect dscp-based
Router(config-pmap-c)# random-detect dscp 8 24 40
Router(config-if)# service-policy output p1

DSCP 値の設定確認:例

パケットのドロップ確率を計算するときに、DSCP 値を使用するように WRED を設定すると、DSCP テーブルのすべてのエントリは、適切なデフォルト値で初期化されます。この項の例は、クラス レベルの WRED の show policy interface コマンドの例です。

次に、DSCP テーブル全体とともにパケットの統計情報を表示して、パケットのドロップ確率を計算するときに DSCP 値を使用するように WRED がイネーブルにされたことを確認する例を示します。

Router# show policy interface Serial6/3
Serial6/3
 
Service-policy output: test
 
Class-map: c1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: protocol ip
0 packets, 0 bytes
5 minute rate 0 bps
Weighted Fair Queueing
Output Queue: Conversation 265
Bandwidth 20 (%)
Bandwidth 308 (kbps)
(pkts matched/bytes matched) 0/0
(depth/total drops/no-buffer drops) 0/0/0
exponential weight: 9
mean queue depth: 0
 
dscp Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
af11 0/0 0/0 0/0 32 40 1/10
af12 0/0 0/0 0/0 28 40 1/10
af13 0/0 0/0 0/0 24 40 1/10
af21 0/0 0/0 0/0 32 40 1/10
af22 0/0 0/0 0/0 28 40 1/10
af23 0/0 0/0 0/0 24 40 1/10
af31 0/0 0/0 0/0 32 40 1/10
af32 0/0 0/0 0/0 28 40 1/10
af33 0/0 0/0 0/0 24 40 1/10
af41 0/0 0/0 0/0 32 40 1/10
af42 0/0 0/0 0/0 28 40 1/10
af43 0/0 0/0 0/0 24 40 1/10
cs1 0/0 0/0 0/0 22 40 1/10
cs2 0/0 0/0 0/0 24 40 1/10
cs3 0/0 0/0 0/0 26 40 1/10
cs4 0/0 0/0 0/0 28 40 1/10
cs5 0/0 0/0 0/0 30 40 1/10
cs6 0/0 0/0 0/0 32 40 1/10
cs7 0/0 0/0 0/0 34 40 1/10
ef 0/0 0/0 0/0 36 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
default 0/0 0/0 0/0 20 40 1/10