Cisco IOS サービス品質(QoS)ソリューション コ ンフィギュレーション ガイド
AutoQoS - VoIP
AutoQoS - VoIP
発行日;2012/02/06 | 英語版ドキュメント(2011/05/09 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

AutoQoS - VoIP

目次

AutoQoS — VoIP の前提条件

AutoQoS — VoIP の制約事項

AutoQoS — VoIP の概要

AutoQoS — VoIP の利点

設計の考慮事項

インターフェイス設定、ポリシー マップ、クラス マップ、ACL の設定

AutoQoS — VoIP 機能の設定方法

AutoQoS — VoIP 機能のイネーブル化

auto qos コマンド使用の前提条件

auto qos コマンド使用の制約事項

FAQ とトラブルシューティングのヒント

この次の手順

設定の確認

AutoQoS — VoIP の設定例

AutoQoS — VoIP 機能の設定例

AutoQoS — VoIP 機能の設定の確認例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

AutoQoS - VoIP

AutoQoS -- VoIP 機能では、ネットワークでの Quality of Service の配信を自動化でき、Voice over IP(VoIP)トラフィックへの QoS の実装とプロビジョニングを簡略化できます。

AutoQos -- VoIP の機能仕様

機能の履歴
リリース
変更点

12.2(15)T

この機能が追加されました。

サポートされているプラットフォーム

Cisco 2600 シリーズ、Cisco 2600 XM シリーズ、Cisco 2691、Cisco 3620、Cisco 3640、Cisco 3660、Cisco 3725、Cisco 3745、Cisco 7200 シリーズ

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスするには、Cisco.com のアカウントが必要です。アカウントをお持ちでない場合や、ユーザ名やパスワードを忘れた場合は、ログイン ダイアログボックスで [Cancel] をクリックし、表示される説明に従ってください。

AutoQoS -- VoIP の前提条件

QoS ポリシー(サービス ポリシー)がインターフェイスに適用されていないことを確認します。この機能は、QoS ポリシー(サービス ポリシー)がインターフェイスに適用されていると設定できません。

簡易ネットワーク管理プロトコル(SNMP)トラップ(監視イベント)を含めるには、SNMP サーバがイネーブルになっている必要があります。

AutoQoS -- VoIP の制約事項

一般的な制約事項

AutoQoS -- VoIP 機能は、次のインターフェイス、データリンク接続識別子(DLCI)および相手先固定接続(PVC)のみでサポートされています。

PPP または High-Level Data Link Control(HDLC; ハイレベル データ リンク コントロール)付属のシリアル インターフェイス

ポイントツーポイント インターフェイスのフレームリレー DLCI のみ

ATM PVC

AutoQoS -- VoIP 機能は、ポイントツーポイント サブインターフェイスの低速 ATM PVC だけでサポートされています。AutoQoS -- VoIP 機能は、あらゆるタイプのサブインターフェイスの高速 ATM PVC でサポートされています。


) ATM PVC は、帯域幅が 768 Kbps 以下の場合は低速と分類され、768 Kpbs を上回る場合は高速と分類されます。


フレームリレーと ATM インターワーキング リンク

シリアル インターフェイスの制約事項

低速リンクのシリアル インターフェイスの場合、マルチリンク PPP(MLP)が自動的に設定されます。シリアル インターフェイスには、IP アドレスが必要です。MLP の設定時、この IP アドレスは削除され、MLP バンドルに置かれます。低速リンクでトラフィックを確実に通過させるには、次の条件を満たす必要があります。

AutoQoS -- VoIP 機能が、リンクの 両方 の終端で設定されている必要があります。

設定された帯域幅の量は、リンクの 両方 の終端で同じである必要があります。

フレームリレー DLCI の制約事項

マップ クラスが DLCI に適用されている場合、AutoQoS -- VoIP 機能は、フレームリレー DLCI で設定できません。

フレームリレー DLCI がすでに 1 つのサブインターフェイスに割り当てられている場合、AutoQoS -- VoIP 機能を異なるサブインターフェイスから設定することはできません。

フレームリレー/ATM 間ネットワークで使用するように設定された低速フレームリレー DLCI の場合、MLP over Frame Relay(MLPoFR)が自動的に設定されます。サブインターフェイスには IP アドレスが必要です。

MLPoFR の設定時、この IP アドレスは削除され、MLP バンドルに置かれます。AutoQoS -- VoIP 機能は、ネットワークの ATM 側でも設定する必要があります。

フレームリレー/ATM 間インターワーキングの低速フレームリレー DLCI では、バーチャル テンプレートがすでに DLCI に対して設定されている場合、AutoQoS -- VoIP 機能は設定できません。

ATM PVC の制約事項

低速 ATM PVC では、バーチャル テンプレートがすでに ATM PVC に対して設定されている場合、AutoQoS -- VoIP 機能は設定できません。

低速 ATM PVC では、MLP over ATM(MLPoATM)が自動的に設定されます。サブインターフェイスには IP アドレスが必要です。

MLPoATM の設定時、この IP アドレスは削除され、MLP バンドルに置かれます。AutoQoS -- VoIP 機能は、ネットワークの ATM 側でも設定する必要があります。

AutoQoS -- VoIP の概要

AutoQoS -- VoIP 機能を設定および使用するには、次の考えを理解する必要があります。

「AutoQoS -- VoIP の利点」

「設計の考慮事項」

「インターフェイス設定、ポリシー マップ、クラス マップ、ACL の設定」

AutoQoS -- VoIP の利点

AutoQoS -VoIP 機能の主要な利点は次のとおりです。

ユーザは、次の基礎となるテクノロジーに関する深い知識がなくても、VoIP トラフィックに必要な QoS 機能を実装できます。

PPP

フレームリレー

ATM

サービス ポリシー

Link Fragmentation and Interleaving(LFI; リンク フラグメンテーション/インターリーブ)などのリンク効率メカニズム(LEM)

AutoQoS -- VoIP 機能は、QoS の実装を簡略化し、Cisco ネットワークでの QoS テクノロジーのプロビジョニングを迅速に行えます。人的なエラーを減らし、トレーニング コストを抑えます。AutoQoS -- VoIP 機能を使用すると、1 つのコマンド( auto qos コマンド)で、すべてのCisco ルータとスイッチにわたって VoIP トラフィック向けの QoS がイネーブルになります。

ユーザは、既存の Cisco IOS コマンドを使用して、AutoQoS -- VoIP 機能で自動生成された設定を変更し、必要に応じて固有の要件を満たすことができます。

シスコ製品の CiscoWorks QoS Policy Manager (QPM)を AutoQoS -- VoIP 機能と一緒に使用して、ネットワーク全域で QoS ポリシーを費用効果の高い方法で管理および監視できる集中型の Web ベース ツールを提供できます。AutoQoS -- VoIP 機能と CiscoWorks QPM は、QoS 実装、プロビジョニング、および管理を容易にします。

設計の考慮事項

QoS の一般的な要件

推奨される方法と値は、音声トラフィックの QoS 要件を満たすために設定されます。

AutoQoS -- VoIP 機能では、次の QoS 機能の実装時にインターフェイス タイプと帯域幅が考慮されます。

分類

分類は、音声パケットをデータ パケットと区別し、音声パケットを適切に処理するために使用されます。

Low Latency Queueing(LLQ; 低遅延キューイング):Priority Queueing(PQ; プライオリティ キューイング)

LLQ(特に PQ)は、遅延要件を満たすために音声パケットに適用されます。

Compressed Real-Time Protocol(cRTP)

cRTP では、音声パケットの 40 バイトの IP ヘッダーは 2 ~ 4 バイトに減るため、音声帯域幅の要件が低減されます。cRTP はネットワーク リンクの両端で適用する必要があります。

LFI

LFI は、音声パケットがキュー内の大きなデータ パケットのために遅延するのを防ぐことで、音声パケットのジッタを軽減するために使用されます。LFI はネットワーク リンクの両端で適用する必要があります。

帯域幅の影響

シリアル インターフェイスの帯域幅によって、リンクの速度が決まります。そして、リンクの速度によって、AutoQoS -- VoIP 機能によって生成される設定が決まります。


) AutoQoS -- VoIP 機能の設定前に帯域幅を変更しないことをお勧めします。


AutoQoS -- VoIP 機能は、機能が設定された時点の帯域幅を使用します。AutoQoS -- VoIP 機能は、機能の設定後に帯域幅に加えられた変更には対応しません。

たとえば、 auto qos voip を使用して、1000 Kbps のインターフェイスで AutoQoS -- VoIP 機能を設定した場合、AutoQoS -- VoIP 機能により、高速インターフェイス用の設定が生成されます。しかし、後で帯域幅を 500 Kbps に変更しても、低帯域幅は使用されません。AutoQoS -- VoIP 機能により、高帯域幅が維持され、高速インターフェイス用に生成した設定がそのまま使用されます。

AutoQoS -- VoIP 機能で低帯域幅を使用するように(低速インターフェイス用の設定の生成)強制するには、 no auto qos voip コマンドを使用して AutoQoS -- VoIP 機能を削除してから、機能を再設定します。

フレームリレー ネットワークのフラグメンテーション

フレームリレー ネットワークの場合、10 ミリ秒(ms)の遅延と最小フラグメント サイズ 60 バイトを使用してフラグメンテーションが設定されます。この設定により、VoIP パケットのフラグメンテーションは行われなくなります。しかし、低速リンクで G.711 コーダ/デコーダ(codec)を使用すると、AutoQoS -- VoIP 機能で設定されたフラグメント サイズが、G.711 Voice over IP(VoIP)パケットのサイズより小さくなることがあります。

このような問題を解決するには、次のいずれかを選択します。

フラグメント サイズを必要な値に変更する。

G.711 VoIP パケットのサイズを小さな値に変更する。

たとえば、AutoQoS -- VoIP 機能が 128 Kbps のフレームリレー DLCI で設定されている場合、AutoQoS -- VoIP 機能によって設定されるフラグメント サイズは 160 バイトです。G.711 VoIP パケットのサイズは 160 バイトからレイヤのパケット ヘッダーのバイト数を引いたサイズになります。この問題を解決するには、フラグメント サイズを 160 バイトから 220 バイトに変更するか、G.711 VoIP パケットのサイズを 160 バイトから 80 バイトに変更します。

シグナリング プロトコル

AutoQoS -- VoIP 機能は、現在次のシグナリング プロトコルを識別します。

H.323

H.225(ユニキャストのみ)

Session Initiation Protocol(SIP)

「Skinny」ゲートウェイ プロトコル

Media Gateway Control Protocol(MGCP; メディア ゲートウェイ コントロール プロトコル)


) 必要となる可能性のある追加シグナリング プロトコルを識別するようにアクセス コントロール リスト(ACL)を設定できます。


インターフェイス設定、ポリシー マップ、クラス マップ、ACL の設定

AutoQoS -- VoIP 機能では、自動的に設定が作成され、その設定がインターフェイス設定、ポリシー マップ、クラス マップ、および ACL に使用されます。インターフェイス設定、ポリシー マップ、クラス マップ、および ACL は、VoIP パケットを分類し、ネットワーク トラフィックの適切な QoS 処理を提供するために作成されます。

この機能では、インターフェイス(または PVC)固有の設定も作成されます。これらのインターフェイス(または PVC)固有の設定は、インターフェイス タイプとリンク速度に従って作成されます。


) 帯域幅が 768 kbps 以下の帯域幅のリンクは低速リンクと見なされ、帯域幅が 768 kbps を超える帯域幅のリンクは高速リンクと見なされます。


AutoQoS -- VoIP 機能の設定方法

ここでは、次の作業について説明します。各作業は、必須または任意として示されています。

「AutoQoS -- VoIP 機能のイネーブル化」(必須)

「設定の確認」(任意)

AutoQoS -- VoIP 機能のイネーブル化

AutoQoS - VoIP 機能のイネーブル化に必要なステップは、 auto qos voip コマンドを使用することだけです。このコマンドにより、インターフェイス設定、ポリシー マップ、クラス マップ、および ACL 用の設定が自動的に作成されます。インターフェイス設定、ポリシー マップ、クラス マップ、および ACL は、VoIP パケットを分類し、ネットワーク トラフィックの適切な QoS 処理を提供するために使用されます。

auto qos コマンド使用の前提条件

インターフェイスまたは ATM PVC で auto qos コマンドを使用する前に、次の前提条件が満たされていることを確認してください。

Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)がインターフェイスまたは ATM PVC でイネーブルになっている必要があります。

インターフェイスまたはサブインターフェイスのリンク速度が 768 kpbs 以下の場合、 ip address コマンドを使用して、インターフェイスのプライマリおよびセカンダリ IP アドレスを設定してください。

すべてのインターフェイスまたはサブインターフェイスについて、 bandwidth コマンドを使用して帯域幅の量を設定します。割り当てられる帯域幅の量は、インターフェイスのリンク速度に基づいている必要があります。

ATM PVC の場合、 vbr-nrt コマンドまたは vbr-rt コマンドを使用して可変ビット レート(VBR)を設定するか、 cbr コマンドを使用して固定ビット レート(CBR)を設定します。

auto qos コマンド使用の制約事項

auto qos voip コマンドはサブインターフェイスではサポートされていません。

auto qos コマンドを使用する前に、インターフェイスの帯域幅の量を変更しないでください。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. bandwidth kilobits

5. vbr-nrt output-pcr output-scr output-mbs [ input-pcr ] [ input-scr ] [ input-mbs ]

6. vbr-rt peak-rate average-rate burst

7. cbr rate

8. pvc [ name ] vpi / vci [ ces | ilmi | qsaal | smds ]

9. ip address ip-address mask [ secondary ]

10. frame-relay interface-dlci dlci [ ietf | cisco ] [ voice-cir cir ] [ ppp virtual-template-name ]

11. auto qos voip [ trust ] [ fr-atm ]

12. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config-if)# interface s4/0

インターフェイス(サブインターフェイス)タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

インターフェイスのタイプ番号を入力します。

ステップ 4

bandwidth kilobits

 

Router(config-if)# bandwidth 1540

 

(任意)インターフェイスの帯域幅値を設定します。

帯域幅値を Kbps で入力します。

(注) このステップはインターフェイスとサブインターフェイスだけに該当します。ATM PVC には必要ありません。

ステップ 5

vbr-nrt output-pcr output-scr output-mbs [ input-pcr ] [ input-scr ] [ input-mbs ]

 

Router(config-if)# vbr-nrt 10000 5000 32 20000 10000 64

 

(任意)Variable Bit Rate-Nonreal Time(VBR-NRT; 可変ビット レート非リアルタイム)QoS を設定し、ATM PVC の出力 Peak Cell Rate(PCR; ピーク セル レート)、出力 Sustainable Cell Rate(SCR; 平均セル レート)、出力最大バースト セル サイズ(MBS)、PVC 範囲、Switched Virtual Circuit(SVC; 相手先選択接続)、仮想回線(VC)クラス、または VC バンドル番号を指定します。

出力 PCR、SCR、および MBS を入力します。

(注) このステップは ATM PVC だけに該当します。インターフェイスとサブインターフェイスには必要ありません。

ステップ 6

vbr-rt peak-rate average-rate burst

 

Router(config-if)# vbr-rt 640 56 80

(任意)Voice over ATM 接続のリアルタイム VBR を設定します。

Peak Information Rate(PIR; 最大情報レート)、Average Information Rate(AIR; 平均情報レート)、およびバースト サイズを入力します。

(注) このステップは ATM PVC だけに該当します。インターフェイスとサブインターフェイスには必要ありません。

ステップ 7

cbr rate
 

Router(config-if-atm-vc)# cbr 56

 

(任意)ATM PVC の ATM Circuit Emulation Service(CES; 回線エミュレーション サービス)の CBR を設定します。

このコマンドは、ATM-VC コンフィギュレーション モード(ATM PVC と SVC の場合)、ATM PVC 範囲コンフィギュレーション モード(ATM PVC 範囲の場合)、ATM PVC 範囲内設定モード(PVC 範囲内の個々の PVC の場合)を含むさまざまなモードで使用できます。

CBR を入力します。

(注) このステップは ATM PVC だけに該当します。インターフェイスとサブインターフェイスには必要ありません。

ステップ 8

pvc [ name ] vpi / vci [ ces | ilmi | qsaal | smds ]
 

Router(config-if)# pvc 1/32

 

(任意)ATM PVC に名前を作成するか割り当て、ATM PVC でカプセル化タイプを指定します。

ATM PVC の ATM 網 Virtual Path Identifier(VPI; 仮想パス識別子)と ATM 網 Virtual Channel Identifier(VCI; 仮想チャネル識別子)を入力します。

(注) このステップは ATM PVC だけに該当します。インターフェイスとサブインターフェイスには必要ありません。

ステップ 9

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.10.100.1 255.255.255.0

(任意)インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

(注) 低速インターフェイス(リンク速度が 768 Kbps 以下のインターフェイス)だけに該当します。

ステップ 10

frame-relay interface-dlci dlci [ ietf | cisco ] [ voice-cir cir ] [ ppp virtual-template-name ]
 

Router(config-if)# frame-relay interface-dlci 100

 

(任意)ルータまたはアクセス サーバの指定されたフレームリレー サブインターフェイスに DLCI を割り当てるか、特定の PVC を DLCI に割り当てるか、PPP セッションにバーチャル テンプレート設定を適用します。

DLCI 番号を入力します。

(注) このステップは、フレームリレー インターフェイス(低速と高速)だけに該当します。

ステップ 11

auto qos voip [trust] [fr-atm]

 

Router(config-if)# auto qos voip

または

Router(config-fr-dlci)# auto qos voip

 

AutoQoS -- VoIP 機能を設定します。

として設定する必要があります。

ステップ 12

exit

 

Router(config-if)# exit

(任意)インターフェイス コンフィギュレーション モードに戻ります。

FAQ とトラブルシューティングのヒント

下に、AutoQoS -- VoIP 機能の設定または使用時に発生する可能性のある状況のトラブルシューティングに関する FAQ に対する解答とヒントを紹介します。

AutoQoS -- VoIP 機能を設定できません。

機能を設定するには、CEF をイネーブルにする必要があります。ネットワークで CEF がイネーブルになっていることを確認してください。

また、サービス ポリシーがインターフェイスにすでに適用されている場合、機能をイネーブルにできません。インターフェイスにサービス ポリシーが適用されていないかどうか確認してください。適用されている場合は、インターフェイスからサービス ポリシーを削除してください。

ルータで AutoQoS -- VoIP 機能がサポートされていません。

AutoQoS -- VoIP 機能は、ローエンド プラットフォームの IP Plus イメージだけでサポートされています。IP Plus イメージがルータにインストールされていることを確認してください。

AutoQoS -- VoIP 機能をディセーブルにした後も、QoS 設定の一部が残ります。

AutoQoS -- VoIP 機能によって変更された QoS 設定を手動でディセーブルにする必要があります。

AutoQoS -- VoIP 機能をイネーブルにすると、低速ネットワーク リンクがダウンします。

AutoQoS -- VoIP がネットワーク リンクの 両側 でイネーブルになっていることを確認してください。

フレームリレー リンクでエンドツーエンドの接続を確立できません。

フレームリレー リンクの両側で帯域幅をチェックしてください。リンクの両側で帯域幅が 同じである必要があります 。異なっている場合、フラグメンテーション サイズの不一致が発生し、接続を確立できません。


) さらにヘルプが必要な場合は「シスコのテクニカル サポート」を参照してください。


この次の手順

作成されたインターフェイス設定、ポリシー マップ、クラス マップ、および ACL(AutoQoS -- VoIP 機能で作成された設定に基づく)がネットワークのニーズを満たしていない場合は、該当する Cisco IOS コマンドを使用して、インターフェイス設定、ポリシー マップ、クラス マップ、および ACL を変更できます。


) インターフェイス設定、ポリシー マップ、クラス マップおよび ACL を変更できますが、no auto qos コマンドを使用して AutoQoS -- VoIP 機能をディセーブルにするときに適切に削除できない可能性があります。変更されたインターフェイス設定、ポリシー マップ、クラス マップ、および ACL を手動で削除しなければならない場合があります。no auto qos コマンドの詳細については、『Cisco IOS Quality of Service Solutions Command Reference』を参照してください。


設定の確認

AutoQoS -- VoIP 機能により、自動的に設定が生成され、その設定を使用して、インターフェイス設定、ポリシー マップ、クラス マップ、ACL が作成されます。これらのインターフェイス設定、ポリシー マップ、クラス マップ、および ACL によって、ネットワークで QoS 機能が設定されます。

設定(インターフェイス設定、ポリシー マップ、クラス マップ、および ACL の内容)を確認するには、次のコマンドを使用します。

手順の概要

1. enable

2. show auto qos [ interface [ interface type ]]

3. show policy-map interface [ interface type ]

4. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show auto qos [ interface [ interface type ]]

 

Router# show auto qos interface s4/0

(任意)自動的に生成された設定に基づいて作成されたインターフェイス設定、ポリシー マップ、クラス マップ、および ACL を表示します。

特定のインターフェイスまたはすべてのインターフェイスについて、インターフェイス設定、ポリシー マップ、クラス マップ、および ACL を表示できます。

ステップ 3

show policy-map interface [ interface type ]

 

Router# show policy-map interface s4/0

 

(任意)指定されたインターフェイスまたはサブインターフェイス、またはインターフェイス上の特定の PVC のどちらかで、すべてのポリシーに対して設定されたすべてのクラスのパケット統計値を表示します。

パケット統計値は、特定のインターフェイス、サブインターフェイス、PVC、またはすべてのインターフェイス、サブインターフェイス、または PVC に関して表示できます。

ステップ 4

exit

 

Router# exit

(任意)特権 EXEC モードを終了します。

AutoQoS -- VoIP の設定例

ここでは、次の設定例について説明します。

「AutoQoS -- VoIP 機能の設定例」

「AutoQoS -- VoIP 機能の設定の確認例」

AutoQoS -- VoIP 機能の設定例

auto qos voip コマンドを使用して AutoQoS -- VoIP 機能を設定すると、設定が生成されます。これらの設定は、その後、インターフェイス設定、ポリシー マップ、クラス マップ、および ACL の作成に使用されます。

ここでは、インターフェイス、PVC、およびリンクでの AutoQoS -- VoIP 機能の設定例を示します。

高速シリアル インターフェイスでの AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は高速シリアル インターフェイス s1/2 で設定されます。

Router> enable
Router# configure terminal

Router(config)# interface s1/2

Router(config-if)# bandwidth 1540

Router(config-if)# auto qos voip

Router(config-if)# exit

低速シリアル インターフェイスでの AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は低速シリアル インターフェイス s1/3 で設定されます。

Router# configure terminal

Router(config)# interface s1/3

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if# auto qos voip

Router(config-if)# exit

高速フレームリレー インターフェイスでの AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は、高速シリアル ポイントツーポイント フレームリレー サブインターフェイス s4/1.2 で設定されます。

Router> enable
Router# configure terminal

Router(config)# interface s4/1.2 point-to-point

Router(config-if)# bandwidth 1540

Router(config-if)# frame-relay interface-dlci 100

Router(config-fr-dlci)# auto qos voip

Router(config-if)# exit

低速フレームリレー インターフェイスでの AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は、低速ポイントツーポイント フレームリレー サブインターフェイス s4/2.1 で設定されます。

Router# configure terminal

Router(config)# interface s4/2.1 point-to-point

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# frame-relay interface-dlci 100

Router(config-fr-dlci)# auto qos voip

Router(config-if)# exit

高速 ATM PVC での AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は、高速ポイントツーポイント ATM PVC ATM5/0.1 で設定されます。

Router# configure terminal

Router(config)# interface ATM5/0.1 point-to-point

Router(config-if)# pvc 1/32

Router(config-if)# vbr-nrt 1540 1540

Router(config-if)# auto qos voip

Router(config-if)# exit

低速 ATM PVC での AutoQoS -- VoIP 機能の設定例

この例では、AutoQoS -- VoIP 機能は、低速ポイントツーポイント ATM PVC ATM5/0.2 で設定されます。

Router# configure terminal

Router(config)# interface ATM5/0.2 point-to-point

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# pvc 1/32

Router(config-if)# vbr-nrt 512 512

Router(config-if)# auto qos voip

Router(config-if)# exit

フレームリレー/ATM 間インターワーキングでの AutoQoS -- VoIP の設定例

この例では、AutoQoS -- VoIP 機能はフレームリレー/ATM 間インターワーキングに対して設定されます。AutoQoS -- VoIP 機能は、シリアル ポイントツーポイント サブインターフェイス s1/3.1 で設定されます。

Router# configure terminal

Router(config)# interface s1/3.1 point-to-point

Router(config-if)# bandwidth 512

Router(config-if)# ip address 10.10.100.1 255.255.255.0

Router(config-if)# frame-relay interface-dlci 100

Router(config-if)# auto qos voip fr-atm

Router(config-if)# exit

 

この設定では、オプションの fr-atm キーワードは、フレームリレー/ATM 間インターワーキングに対して AutoQoS -- VoIP 機能をイネーブルにするために使用されます。


) ネットワークの ATM/ATM 側では、ネットワークの ATM/フレームリレー側と区別するために特別な設定は必要ありません。


AutoQoS -- VoIP 機能の設定の確認例

auto qos voip コマンドを使用して AutoQoS -- VoIP 機能を設定すると、設定が生成されます。これらの設定は、その後、インターフェイス設定、ポリシー マップ、クラス マップ、および ACL の作成に使用されます。 show auto qos interface コマンドは、インターフェイス設定、ポリシー マップ、クラス マップ ACL の内容を確認するために使用されます。

ここでは、インターフェイス、PVC、およびリンクに対する show auto qos interface コマンドの出力サンプルを紹介します。


show auto qos interface コマンド出力には、AutoQoS -- VoIP 機能によって作成された設定だけが表示されます。


高速シリアル インターフェイスに対する show auto qos interface コマンドの出力例

次に、高速シリアル インターフェイスに対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface s6/0
 
Serial6/0 -
!
interface Serial6/0
service-policy output AutoQoS-Policy-UnTrust

低速シリアル インターフェイスに対する show auto qos interface コマンドの出力例

次に、低速シリアル インターフェイスに対する show auto qos interface コマンドの出力例を示します。

Router# show auto qos interface s6/0
 
Serial6/0 -
!
interface Serial6/0
no ip address
encapsulation ppp
no fair-queue
ppp multilink
multilink-group 2001100126
!
interface Multilink2001100126
bandwidth 512
ip address 10.10.100.1 255.255.255.0
service-policy output AutoQoS-Policy-UnTrust
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
ip rtp header-compression iphc-format

高速フレームリレー インターフェイスに対する show auto qos Interface コマンドの出力例

次に、高速フレームリレー インターフェイスに対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface s6/1.1
 
Serial6/1.1: DLCI 100 -
!
interface Serial6/1
frame-relay traffic-shaping
!
interface Serial6/1.1 point-to-point
frame-relay interface-dlci 100
class AutoQoS-VoIP-FR-Serial6/1-100
!
map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100
frame-relay cir 1540000
frame-relay bc 15400
frame-relay be 0
frame-relay mincir 1540000
service-policy output AutoQoS-Policy-UnTrust

) 高速フレームリレー インターフェイスに対する show autoqos interface コマンドの出力は、低速フレームリレー インターフェイスの出力と似ています。唯一の違いは、高速フレームリレー インターフェイスには、フレームリレーのフラグメンテーションおよび cRTP は設定されていない点です。


低速フレームリレー インターフェイスに対する show auto qos interface コマンドの出力例

次に、低速フレームリレー インターフェイスに対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface s6/1.1
 
Serial6/1.1: DLCI 100 -
!
interface Serial6/1
frame-relay traffic-shaping
!
interface Serial6/1.1 point-to-point
frame-relay interface-dlci 100
class AutoQoS-VoIP-FR-Serial6/1-100
frame-relay ip rtp header-compression
!
map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000
service-policy output AutoQoS-Policy-UnTrust
frame-relay fragment 640

高速 ATM PVC に対する show auto qos interface コマンドの出力例

次に、高速 ATM PVC に対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface a2/0.1
 
ATM2/0.1: PVC 1/100 -
!
interface ATM2/0.1 point-to-point
pvc 1/100
tx-ring-limit 3
service-policy output AutoQoS-Policy-UnTrust

低速 ATM PVC に対する show auto qos interface コマンドの出力例

次に、低速 ATM PVC に対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface a2/0.1
 
ATM2/0.1: PVC 1/100 -
!
interface ATM2/0.1 point-to-point
pvc 1/100
tx-ring-limit 3
encapsulation aal5mux ppp Virtual-Template200
!
interface Virtual-Template200
bandwidth 512
ip address 10.10.100.1 255.255.255.0
service-policy output AutoQoS-Policy-UnTrust
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave

フレームリレー/ATM 間インターワーキング リンクの show auto qos interface コマンドの出力サンプル

次に、フレームリレー/ATM 間インターワーキング リンクに対する show auto qos コマンドの出力例を示します。

Router# show auto qos interface s6/1.1
 
Serial6/1.1: DLCI 100 -
!
interface Serial6/1
frame-relay traffic-shaping
!
interface Serial6/1.1 point-to-point
frame-relay interface-dlci 100 ppp Virtual-Template200
class AutoQoS-VoIP-FR-Serial6/1-100
!
interface Virtual-Template200
bandwidth 512
ip address 10.10.100.1 255.255.0.0
service-policy output AutoQoS-Policy-UnTrust
ppp multilink
ppp multilink fragment-delay 10
ppp multilink interleave
!
map-class frame-relay AutoQoS-VoIP-FR-Serial6/1-100
frame-relay cir 512000
frame-relay bc 5120
frame-relay be 0
frame-relay mincir 512000

その他の関連資料

AutoQoS -- VoIP に関連した追加情報については、次の参考資料を参照してください。

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

内容
参照先

QoS コマンド:コマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

『Cisco IOS Quality of Service Solutions Command Reference』

LFI および cRTP

Header Compression 』モジュール

パケット分類

Classifying Network Traffic 』モジュール

LLQ

Configuring Weighted Fair Queueing 』モジュール

サービス ポリシー(ポリシー マップ)

Applying QoS Features Using the MQC モジュール

フレームリレーおよび ATM コマンド:詳細なコマンド構文、コマンド モード、コマンド履歴、デフォルト、使用上のガイドライン、および例

『Cisco IOS Wide-Area Networking Command Reference』

フレームリレーの設定

Configuring Frame Relay 』モジュール

MLPPP

Configuring Media-Independent PPP and Multilink PPP 』モジュール

CEF

Cisco Express Forwarding Features Roadmap 』モジュール

SNMP

Configuring SNMP Support 』モジュール

CiscoWorks QoS Policy Manager(QPM)

製品情報はオンライン( Cisco.com )で入手できます。

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存規格のサポートに変更はありません。

プラットフォームおよび Cisco IOS リリースによりサポートされている MIB のリストを入手し、MIB モジュールをダウンロードするには、Cisco.com の次の Cisco MIB Web サイトの URL にアクセスしてください。

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存規格のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

Technical Assistance Center(TAC)ホーム ページ:多数の技術関連の記事と、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクを提供する Web サイトです。必要な記事は検索して見つけることができます。Cisco.com の登録ユーザであれば、ログインしてさらに多くの情報を参照できます。

http://www.cisco.com/public/support/tac/home.shtml

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドの詳細については、 http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_book.html にある『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、Cisco IOS マスター コマンド リストを参照してください。

新しいコマンド

auto qos voip

show auto qos