Cisco IOS IPv6 コンフィギュレーション ガイド
IPv6 への ADSL の実装およびダイヤル アク セスの展開
IPv6 への ADSL の実装およびダイヤル アクセスの展開
発行日;2012/02/01 | 英語版ドキュメント(2011/09/26 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 6MB) | フィードバック

目次

IPv6 への ADSL の実装およびダイヤル アクセスの展開

機能情報の確認

目次

IPv6 の ADSL およびダイヤル アクセスの実装の前提条件

IPv6 への ADSL の実装およびダイヤル アクセスの展開の制約事項

IPv6 への ADSL の実装およびダイヤル アクセスの展開に関する情報

IPv6 のアドレス割り当て

ステートレス アドレス自動設定

プレフィクス委任

IPv6 の AAA アトリビュート

IPv6 での AAA アトリビュートの使用の前提条件

IPv6 環境での仮想アクセス用の RADIUS ユーザ単位アトリビュート

IPv6 プレフィクス プール

IPv6 での ADSL の設定方法とダイヤル アクセスの展開方法

NAS の設定

トラブルシューティングのヒント

リモート CE ルータの設定

この次の手順

RADIUS サーバからプレフィクスを取得するための DHCP for IPv6 サーバの設定

前提条件

DHCP for IPv6 AAA および SIP オプションの設定

IPv6 の ADSL の実装およびダイヤル アクセスの展開の設定例

IPv6 への ADSL の実装およびダイヤル アクセスの展開:例

関連情報

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

IPv6 への ADSL の実装およびダイヤル アクセスの展開

この章では、IPv6 でのプレフィクス プールの実装およびユーザ単位の Remote Access Dial-In User Service(RADIUS)アトリビュートの実装について説明します。Digital Subscriber Line(DSL; デジタル加入者線)およびダイヤルアクセス環境での IPv6 の展開についても説明します。Asymmetric Digital Subscriber Line(ADSL; 非対称デジタル加入者線)およびダイヤル展開では、IPv6 RADIUS アトリビュート、Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)リンク上のステートレス アドレス設定、ユーザ単位のスタティック ルート、Access Control List(ACL; アクセス コントロール リスト)など、IPv6 環境での大規模なアクセスを可能にする拡張も提供されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

IPv6 の ADSL およびダイヤル アクセスの実装の前提条件

このマニュアルでは、IPv4 に精通していることを前提としています。IPv4 の設定およびコマンド リファレンス情報については、「その他の関連資料」の関連資料を参照してください。

IPv6 への ADSL の実装およびダイヤル アクセスの展開の制約事項

ADSL およびダイヤル展開は、PPP over ATM(PPPoA)、PPP over Ethernet(PPPoE)、PPP over async、PPP over ISDN など、PPP カプセル化がイネーブルになっているインターフェイスで使用可能です。

IPv6 への ADSL の実装およびダイヤル アクセスの展開に関する情報

IPv6 に対して ADSL を実装し、ダイヤル アクセスを展開するには、次の概念を理解する必要があります。

「IPv6 のアドレス割り当て」

「IPv6 の AAA アトリビュート」

IPv6 のアドレス割り当て

IPv6 が設定された Cisco ルータは、その IPv6 プレフィクスを 1 つ以上のインターフェイスでアドバタイズし、IPv6 クライアントが自身のアドレスを自動的に設定できるようにします。多くの機能が PPP レイヤで処理される IPv4 とは対照的に、IPv6 では、アドレス割り当てはネットワーク レイヤで実行されます。IPv6 Control Protocol(IPv6CP; IPv6 コントロール プロトコル)で処理される機能は、一意のインターフェイス識別子のネゴシエーションだけです。DNS サーバ検出などの他のすべての機能は IPv6 プロトコル自体で実行されます。

IPv4 アドレス割り当てとは対照的に、IPv6 ユーザには、単一アドレスではなくプレフィクスが割り当てられます。通常、Internet Service Provider(ISP; インターネット サービス プロバイダー)は 64 ビットまたは 48 ビットのプレフィクスを割り当てます。

IPv6 環境では、Internet Service Provider(ISP; インターネット サービス プロバイダー)は、寿命の長いプレフィクスをユーザに割り当てます。これにより、ルーティング システムが何らかの影響を受けます。通常の IPv4 環境では、各 Network Access Server(NAS; ネットワーク アクセス サーバ)には 24 ビット アドレスのプールがあり、ユーザはダイヤルイン時にこのプールからアドレスを取得します。ユーザが別の POP にダイヤルする場合、または同じ POP の別の NAS に接続する場合は、異なる IPv4 アドレスが割り当てられます。

IPv6 のアドレスは、2 つの異なる方法で割り当てられます。

「ステートレス アドレス自動設定」

「プレフィクス委任」

ステートレス アドレス自動設定

ステートレス アドレス自動設定方式を使用したアドレスの割り当ては、64 ビット プレフィクスの割り当てにだけ使用できます。各ユーザには、Router Advertisement(RA; ルータ アドバタイズメント)でユーザにアドバタイズされる 64 ビット プレフィクスが割り当てられます。すべてのアドレスは、割り当てられたプレフィクスに基づいて自動的に設定されます。

一般的なシナリオでは、ユーザごとに別々の 64 ビット プレフィクスが割り当てられますが、ユーザにアドレスの共有プールからプレフィクスを割り当てることもできます。共有を使用すると、アドレスがユーザあたり 1 アドレスだけに制限されます。

このソリューションは、Customer Provider Edge(CPE; カスタマー プロバイダー エッジ)ルータが単一の PC であるか 1 つのサブネットだけに制限されている場合に最もよく機能します。ユーザが複数のサブネットを持つ場合は、レイヤ 2(L2)ブリッジング、マルチリンク サブネット、またはプロキシ RA を使用できます。RA でアドバタイズされたプレフィクスは、Authentication, Authorization, Accounting(AAA; 認証、認可、アカウンティング)サーバから取得できます。このプレフィクスは、プレフィクス アトリビュートも提供し、手動で設定するか、プレフィクス プールから割り当てることができます。

Framed-Interface-Id AAA アトリビュートはピアのインターフェイス識別子の選択に影響し、プレフィクスと組み合せて完全な IPv6 アドレスを判断できます。

プレフィクス委任

プレフィクス委任では、Dynamic Host Configuration Protocol(DHCP)を使用します。ユーザがプレフィクス委任元(通常は NAS)にプレフィクスを要求する場合、プレフィクスは「ステートレス アドレス自動設定」で説明するように割り当てられます。

IPv6 プレフィクス委任ルータは、クライアントから要求を受信すると、要求元ルータに割り当てる IPv6 プレフィクスを選択します。委任ルータは、次の方法で要求元ルータのプレフィクスを選択できます。

ISP へのサブスクリプションに基づく静的割り当て

使用可能なプレフィクスのプールからの動的割り当て

Framed-IPv6-Prefix アトリビュートを使用した、RADIUS サーバなどの外部権限に基づく選択(「Framed-IPv6-Prefix」を参照)。

DHCP SIP サーバ オプション

IPv6 Session Initiation Protocol(SIP)サーバ オプションの 2 つの DHCP は、ローカル アウトバウンド SIP プロキシを示します。一方はドメイン名のリストを示し、もう一方は IPv6 アドレスのリストを示します。この 2 つのオプションは、DHCPv6 設定プールで設定できます。

IPv6 の AAA アトリビュート

Vendor-Specific Attribute(VSA; ベンダー固有アトリビュート)は、IPv6 で AAA をサポートするために開発されました。シスコの VSA は、inacl、outacl、route、および prefix です。

プレフィクス プールとプール名は、AAA を使用して設定できます。

RFC 3162 で説明されているように、次の RADIUS アトリビュートが IPv6 に対してサポートされます。

Framed-Interface-Id

Framed-IPv6-Prefix

Login-IPv6-Host

Framed-IPv6-Route

Framed-IPv6-Pool

これらのアトリビュートは、RADIUS サーバで設定でき、アクセス サーバにダウンロードして、そこでアクセス接続に適用できます。

AAA アトリビュートについては、次の各項で説明します。

「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位アトリビュート」

「IPv6 プレフィクス プール」

IPv6 での AAA アトリビュートの使用の前提条件

IPv6 の AAA アトリビュートは、RFC 3162 に準拠し、RFC 3162 をサポートできる RADIUS サーバを必要とします。

IPv6 環境での仮想アクセス用の RADIUS ユーザ単位アトリビュート

RADIUS Attribute-Value(AV; アトリビュート値)のペアの次の IPv6 アトリビュートが仮想アクセスに対してサポートされます。

「Framed-Interface-Id」

「Framed-IPv6-Prefix」

「Login-IPv6-Host」

「Framed-IPv6-Route」

「Framed-IPv6-Pool」

「IPv6 Route」

「IPv6 ACL」

「IPv6 Prefix#」

「IPv6 Pool」

新しい IPv6 プレフィクスおよび IPv6 プール アトリビュートとは別に、これらはすべて IPv6 プロトコルをサポートするために拡張された既存の Cisco VSA です。

Framed-Interface-Id

Framed-Interface-Id アトリビュートは、設定する IPv6 インターフェイス識別子を示します。このユーザ単位アトリビュートは、IPv6CP ネゴシエーション中に使用され、access-accept パケットでも使用されることがあります。Interface-Identifier IPv6CP オプションが正常にネゴシエーションされた場合は、NAS によって、その値を優先するサーバへの Acc-0Request パケットにこのアトリビュートをヒントとして含める必要があります。

Framed-IPv6-Prefix

Framed-IPv6-Prefix アトリビュートは Cisco VSA と同じ機能を実行します。これは、仮想アクセスにだけ使用され、設定する IPv6 プレフィクス(および対応するルート)を示します。このアトリビュートはユーザ単位アトリビュートであり、ユーザはネイバー ディスカバリ ルータ アドバタイズメント メッセージでアドバタイズするプレフィクスを指定できます。Framed-IPv6-Prefix アトリビュートは、access-accept パケットで使用でき、複数回出現することがあります。NAS では、プレフィクスの対応ルートが作成されます。

DHCP for IPv6 プレフィクス委任にこのアトリビュートを使用するには、RADIUS サーバに同じユーザのプロファイルを作成します。2 番めのプロファイルに関連付けられているユーザ名には、「-dhcpv6」というサフィックスがあります。

2 つのプロファイルの Framed-IPv6-Prefix アトリビュートは異なる方法で処理されます。NAS が Router Advertisement(RA; ルータ アドバタイズメント)でのプレフィクスの送信と、リモート ユーザのネットワークへのプレフィクスの委任の両方を行う必要がある場合、RA のプレフィクスは、ユーザの通常のプロファイルの Framed-IPv6-Prefix アトリビュートに配置され、プレフィクス委任に使用されるプレフィクスはユーザの別のプロファイルのアトリビュートに配置されます。

Login-IPv6-Host

Login-IPv6-Host アトリビュートは、Login-Service アトリビュートが含まれる場合にユーザの接続に使用される IPv6 システムを示すユーザ単位アトリビュートです。

Framed-IPv6-Route

Framed-IPv6-Route アトリビュートは、Cisco VSA と同じ機能を実行します。これは、NAS 上のユーザに対して設定するルーティング情報を提供するユーザ単位アトリビュートです。このアトリビュートは文字列アトリビュートであり、 ipv6 route コマンドを使用して指定します。

Framed-IPv6-Pool

IPv6-Pool アトリビュートは、割り当てられたプールの名前を含むユーザ単位アトリビュートであり、ユーザに IPv6 プレフィクスを割り当てるために使用する必要があります。このプールは、ルータ上でローカルに定義するか、プールをダウンロードできる RADIUS サーバに定義する必要があります。

IPv6 Route

IPv6 route アトリビュートでは、ユーザ単位のスタティック ルートを指定できます。スタティック ルートは、Cisco IOS ソフトウェアが宛先へのルートを動的に構築できない場合に適しています。スタティック ルートの構築の詳細については、 ipv6 route コマンドの説明を参照してください。

次の例では、スタティック ルートの定義に使用される IPv6 route アトリビュートを示します。

cisco-avpair = "ipv6:route#1=2001:0DB8:cc00:1::/48",
cisco-avpair = "ipv6:route#2=2001::0DB8:cc00:2::/48",

IPv6 ACL

完全な IPv6 アクセス リストを指定できます。アクセス リストの一意の名前が自動的に生成されます。アクセス リストは、ユーザがログアウトしたときに削除されます。インターフェイス上の以前のアクセス リストが再適用されます。

inacl アトリビュートと outacl アトリビュートでは、ルータに特定の既存のアクセス リストを設定できます。次の例では、アクセス リストとして指定された ACL 番号 1 を示します。

cisco-avpair = "ipv6:inacl#1=permit 2001:0DB8:cc00:1::/48",
cisco-avpair = "ipv6:outacl#1=deny 2001:0DB8::/10",

IPv6 Prefix#

IPv6 prefix# アトリビュートでは、ネイバー ディスカバリ ルータ アドバタイズメント メッセージでアドバタイズするプレフィクスを指定します。prefix# アトリビュートが使用されている場合は、対応するルート(ユーザ単位のスタティック ルートとしてマークされています)が、特定のプレフィクスの Routing Information Base(RIB; ルーティング情報ベース)テーブルにインストールされます。

cisco-avpair = "ipv6:prefix#1=2001:0db8::/64",
cisco-avpair = "ipv6:prefix#2=2001:0db8::/64",

IPv6 Pool

RADIUS 認証では、IPv6 pool アトリビュートによって、IPv6 プロトコルをサポートするために IPv4 address pool アトリビュートが拡張されます。これは、プレフィクスを取得する NAS 上のローカル プールの名前を指定し、サービスが PPP として設定されるたび、およびプロトコルが IPv6 として指定されるたびに使用されます。アドレス プールはローカル プーリングと連動することに注意してください。これは NAS 上に事前に設定されたローカル プールの名前を指定します。

IPv6 プレフィクス プール

IPv6 のプレフィクス プールの機能は、IPv4 のアドレス プールと同様です。主な違いは、IPv6 が単一アドレスではなくプレフィクスを割り当てることです。

IPv4 では、プールまたはプール定義はローカルに設定するか、AAA サーバから取得できます。プール間でオーバーラップするメンバシップは許可されません。

プールが設定されたあとは、プールを変更できません。設定を変更した場合、プールは削除されて再作成されます。前に割り当てられたすべてのプレフィクスは解放されます。

プレフィクス プールは、各ユーザに 64 ビット プレフィクスが割り当てられるように、または単一のプレフィクスが複数のユーザによって共有されるように定義できます。共有プレフィクス プールでは、各ユーザがプールからアドレスを 1 つだけ受け取ることができます。

IPv6 での ADSL の設定方法とダイヤル アクセスの展開方法

ここに記載されている設定ガイドラインは、IPv6 環境で ADSL およびダイヤル アクセスを設定する方法を示します。

「NAS の設定」(必須)

「リモート CE ルータの設定」(必須)

「RADIUS サーバからプレフィクスを取得するための DHCP for IPv6 サーバの設定」(任意)

「DHCP for IPv6 AAA および SIP オプションの設定」(任意)

NAS の設定

ダイヤル アクセスの設定の最初の手順は、NAS の設定です。ダイヤラ グループ、アクセス リスト、およびルータはすべて NAS によって認識されます。この作業では、IPv6 環境で ADSL を実装し、ダイヤル アクセスを展開するように NAS を設定する方法を示します。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. aaa new-model

5. aaa authentication ppp { default | list-name } method1 [ method2 ...]

6. aaa authorization configuration default { radius | tacacs + }

7. show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

8. virtual-profile virtual-template number

9. interface serial controller-number : timeslot

10. encapsulation encapsulation-type

11. exit

12. dialer-group group-number

13. ppp authentication { protocol1 [ protocol2... ]} [ if-needed ] [ list-name | default ] [ callin ] [ one-time ] [ optional ]

14. interface virtual-template number

15. ipv6 enable

16. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

17. radius-server host { hostname | ip-address } [ test username user-name ] [ auth-port port-number ] [ ignore-auth-port ] [ acct-port port-number ] [ ignore-acct-port ] [ timeout seconds ] [ retransmit retries ] [ key string ] [ alias { hostname | ip-address }] [ idle-time seconds ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname cust1-53a

ネットワーク サーバのホスト名を指定します。

ステップ 4

aaa new-model

 

Router(config)# aaa new-model

AAA サーバをイネーブルにします。

ステップ 5

aaa authentication ppp { default | list-name } method1 [ method2 ...]

 

Router(config)# aaa authentication ppp default if-needed group radius

PPP を実行しているシリアル インターフェイス上で使用する 1 つ以上の AAA 認証方式を指定します。

ステップ 6

aaa authorization configuration default { radius | tacacs + }

 

Router(config)# aaa authorization network default group radius

AAA サーバから設定情報をダウンロードします。

ステップ 7

show ipv6 route [ ipv6-address | ipv6-prefix / prefix-length | protocol | interface-type interface-number ]

 

Router(config)# show ipv6 route

前のコマンドでインストールされたルートを表示します。

ステップ 8

virtual-profile virtual-template number

 

Router(config)# virtual-profile virtual-template 1

仮想インターフェイス テンプレートで仮想プロファイルをイネーブルにします。

ステップ 9

interface serial controller-number : timeslot

 

Router(config)# interface Serial0:15

チャネライズド E1 またはチャネライズド T1 コントローラで作成したシリアル インターフェイスを指定します(ISDN PRI、チャネル連携シグナリング、または robbed-bit シグナリングの場合)。

ステップ 10

encapsulation encapsulation-type

 

Router(config-if)# encapsulation ppp

インターフェイスで使用するカプセル化方式を設定します。

ステップ 11

exit

 
Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 12

dialer-group group-number

 

Router(config)# dialer-group 1

特定のダイヤリング グループに属するようにインターフェイスを設定することでアクセスを制御します。

ステップ 13

ppp authentication { protocol1 [ protocol2 ...]} [ if-needed ] [ list-name | default ] [ callin ] [ one-time ] [ optional ]

 

Router(config)# ppp authentication chap

Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)および Password Authentication Protocol(PAP; パスワード認証プロトコル)のいずれかまたは両方をイネーブルにし、CHAP および PAP 認証がインターフェイスで選択される順序を指定します。

ステップ 14

interface virtual-template number

 

Router(config)# interface virtual-template1

仮想アクセス インターフェイスの作成時にダイナミックに設定および適用される仮想テンプレート インターフェイスを作成します。

ステップ 15

ipv6 enable

 

Router(config)# ipv6 enable

明示的な IPv6 アドレスが設定されていないインターフェイスにおける IPv6 処理をイネーブルにします。

ステップ 16

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ipv6 permit

プロトコルによって、またはプロトコルと以前に定義したアクセス リストの組み合せによって、ダイヤルするための Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)ダイヤラ リストを定義します。

ステップ 17

radius-server host { hostname | ip-address } [ test username user-name ] [ auth-port port-number ] [ ignore-auth-port ] [ acct-port port-number ] [ ignore-acct-port ] [ timeout seconds ] [ retransmit retries ] [ key string ] [ alias { hostname | ip-address }] [ idle-time seconds ]

 

Router(config)# radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

RADIUS サーバ ホストを指定します。

トラブルシューティングのヒント

次の作業に進む前に、アクセス リストが正しくインストールされていることを確認します。 show ipv6 access-list コマンドおよび show ipv6 interface コマンドを使用します。

リモート CE ルータの設定

次の作業では、各リモート CE ルータを設定する方法を示します。

手順の概要

1. enable

2. configure terminal

3. hostname name

4. interface bri number . subinterface-number [ multipoint | point-to-point ]

5. encapsulation encapsulation-type

6. ipv6 address autoconfig [ default ]

7. isdn switch-type switch-type

8. ppp authentication { protocol1 [ protocol2 ...]} [ if-needed ] [ list-name | default ] [ callin ] [ one-time ]

9. ppp multilink [ bap | required ]

10. exit

11. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

12. ipv6 route ipv6-prefix / prefix-length { ipv6-address | interface-type interface-number [ i pv6-address ]} [ administrative-distance ] [ administrative-multicast-distance | unicast | multicast ] [ tag tag ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname name

 

Router(config)# hostname cust1-36a

ネットワーク サーバのホスト名を指定します。

ステップ 4

interface bri number . subinterface-number [multipoint | point-to-point]

 

Router(config)# interface BRI1/0

BRI インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

encapsulation encapsulation-type

 

Router(config-if)# encapsulation ppp

インターフェイスで使用するカプセル化方式を設定します。

ステップ 6

ipv6 address autoconfig [ default ]

 

Router(config-if)# ipv6 address autoconfig

IPv6 アドレスが自動的に生成されることを指定します。

ステップ 7

isdn switch-type switch-type

 

Router(config-if)# isdn switch-type basic-net3

ISDN インターフェイス上のセントラル オフィス スイッチ タイプを指定します。

ステップ 8

ppp authentication { protocol1 [ protocol2 ...]} [ if-needed ] [ list-name | default ] [ callin ] [ one-time ]

 

Router(config-if)# ppp authentication chap optional

Challenge Handshake Authentication Protocol(CHAP; チャレンジ ハンドシェーク認証プロトコル)および Password Authentication Protocol(PAP; パスワード認証プロトコル)のいずれかまたは両方をイネーブルにし、CHAP および PAP 認証がインターフェイスで選択される順序を指定します。

ステップ 9

ppp multilink [ bap | required ]

 

Router(config-if)# ppp multilink

インターフェイスで Multilink PPP(MLP; マルチリンク PPP)をイネーブルにし、オプションで、動的な帯域幅割り当てを行うために Bandwidth Allocation Control Protocol(BACP; 帯域幅割り当て制御プロトコル)と Bandwidth Allocation Protocol(BAP; 帯域幅割り当てプロトコル)をイネーブルにします。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ipv6 permit

プロトコルによって、またはプロトコルと以前に定義したアクセス リストの組み合せによって、ダイヤルするための Dial-on-Demand Routing(DDR; ダイヤルオンデマンド ルーティング)ダイヤラ リストを定義します。

ステップ 12

ipv6 route ipv6-prefix / prefix-length { ipv6-address | interface-type interface-number [ i pv6-address ]} [ administrative-distance ] [ administrative-multicast-distance | unicast | multicast ] [ tag tag ]

 

Router(config)# ipv6 route 2001:0db8:1/128 BRI1/0

スタティック IPv6 ルートを確立します。ルートごとに 1 つのコマンドを使用します。

この次の手順

NAS および CE ルータを設定したあとで、RADIUS を設定してコールバック用の AV ペアを確立します。コールバックにより、リモート ネットワーク ユーザは、課金なしで NAS にダイヤルインできます。コールバックが必要な場合、NAS は現在の通話を終了し、呼び出し元にダイヤルします。NAS がコールバックを実行する場合は、発信接続の情報だけが適用されます。事前認証 access-accept メッセージからの残りのアトリビュートは廃棄されます。

次の例では、ローカル キャンパス用の RADIUS プロファイル設定を示します。

campus1 Auth-Type = Local, Password = "mypassword"
User-Service-Type = Framed-User,
Framed-Protocol = PPP,
cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
cisco-avpair = "ipv6:route=dead::/64",
cisco-avpair = "ipv6:route=cafe::/64",
cisco-avpair = "ipv6:prefix=dead::/64 0 0 onlink autoconfig",
cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",
 

IPv6 の RADIUS AV ペアについては「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位アトリビュート」で説明しています。

RADIUS サーバからプレフィクスを取得するための DHCP for IPv6 サーバの設定

次の作業では、RADIUS サーバからプレフィクスを取得するように DHCP for IPv6 サーバを設定する方法を示します。

前提条件

この作業を実行する前に、ルータに AAA クライアントと PPP を設定する必要があります。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ipv6 nd prefix framed-ipv6-prefix

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスのタイプと番号を指定し、ルータをインターフェイス コンフィギュレーション モードにします。

ステップ 4

ipv6 nd prefix framed-ipv6-prefix

 

Router(config-if)# ipv6 nd prefix framed-ipv6-prefix

受信した RADIUS framed IPv6 prefix アトリビュートのプレフィクスを、インターフェイスのネイバー ディスカバリ プレフィクス キューに追加します。

DHCP for IPv6 AAA および SIP オプションの設定

この任意の作業では、ユーザがルータでの AAA および SIP オプションのサポートをイネーブルにできます。

手順の概要

1. enable

2. configure terminal

3. ipv6 dhcp pool poolname

4. prefix-delegation aaa [ method-list method-list ] [ lifetime ]

5. sip address ipv6-address

6. sip domain-name domain-name

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

必要に応じてパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ipv6 dhcp pool poolname

 
Router(config)# ipv6 dhcp pool pool1

DHCP for IPv6 設定情報プールを設定し、DHCP for IPv6 プール コンフィギュレーション モードを開始します。

ステップ 4

prefix-delegation aaa [ method-list method-list ] [ lifetime ]

 
Router(config-dhcp)# prefix-delegation aaa method-list list1

プレフィクスを AAA サーバから取得することを指定します。

ステップ 5

sip address ipv6-address

 

Router(config-dhcp)# sip address 2001:0DB8::2

SIP サーバの IPv6 アドレス リスト オプションでクライアントに返す SIP サーバ IPv6 アドレスを設定します。

ステップ 6

sip domain-name domain-name

 
Router(config-dhcp)# sip domain sip1.cisco.com

SIP サーバのドメイン名リスト オプションでクライアントに返す SIP サーバ ドメイン名を設定します。

IPv6 の ADSL の実装およびダイヤル アクセスの展開の設定例

ここでは、次の設定例について説明します。

「IPv6 への ADSL の実装およびダイヤル アクセスの展開:例」

IPv6 への ADSL の実装およびダイヤル アクセスの展開:例

この例では、ADSL およびダイヤル アクセスの一般的な設定を示します。次の 3 つの設定が必要です。

「NAS の設定」

「リモート CE ルータの設定」

「RADIUS の設定」

NAS の設定

ISP NAS の次の設定は、リモート CE ルータからのアクセスをサポートする設定を示しています。

hostname cust1-53a
aaa new-model
aaa authentication ppp default if-needed group radius
aaa authorization network default group radius
virtual-profile virtual-template 1
interface Serial0:15
encapsulation ppp
dialer-group 1
ppp authentication chap
!
interface Virtual-Template1
ipv6 enable
!
dialer-list 1 protocol ipv6 permit
radius-server host 172.17.250.8 auth-port 1812 acct-port 1813 key testing123

リモート CE ルータの設定

リモート カスタマー エッジ ルータの次の設定は、定義された PPP カプセル化と IPv6 ルートを示しています。

hostname cust-36a
interface BRI1/0
encapsulation ppp
ipv6 enable
isdn switch-type basic-net3
ppp authentication chap optional
ppp multilink
!
dialer-list 1 protocol ipv6 permit
ipv6 route 2001:0DB8:1/128 BRI1/0
ipv6 route ::/0 2001:0db8:1

RADIUS の設定

次の RADIUS 設定は、スタティック ルートを確立するための AV ペアの定義を示しています。

campus1 Auth-Type = Local, Password = "mypassword"
User-Service-Type = Framed-User,
Framed-Protocol = PPP,
cisco-avpair = "ipv6:inacl#1=permit dead::/64 any",
cisco-avpair = "ipv6:route=library::/64",
cisco-avpair = "ipv6:route=cafe::/64",
cisco-avpair = "ipv6:prefix=library::/64 0 0 onlink autoconfig",
cisco-avpair = "ipv6:prefix=cafe::/64 0 0 onlink autoconfig",
cisco-avpair = "ip:route=10.0.0.0 255.0.0.0",

関連情報

IPv6 のルーティング プロトコルの実装については、「 Implementing RIP for IPv6 」、「 Implementing IS-IS for IPv6 」、または「 Implementing Multiprotocol BGP for IPv6 」の章を参照してください。IPv6 環境のセキュリティの実装については、「 Implementing IPsec in IPv6 Security 」および「 Implementing Traffic Filters and Firewalls for IPv6 Security 」の章を参照してください。

その他の関連資料

ここでは、IPv6 への ADSL の実装およびダイヤル アクセスの展開機能に関する関連資料について説明します。

関連資料

 

関連項目
参照先

IPv6 のサポート機能リスト

Cisco IOS IPv6 Configuration Guide 』の「 Start Here: Cisco IOS Software Release Specifics for IPv6 Features

IPv6 基本接続

Cisco IOS IPv6 Configuration Guide 』の「 Implementing IPv6 Addressing and Basic Connectivity

IPv6 コマンド:コマンド構文、コマンド モード、デフォルト、使用上のガイドライン、および例

『Cisco IOS IPv6 Command Reference』

認証局と相互運用性、RA プロキシ

Cisco IOS Security Configuration Guide 』の「 Security Overview

RADIUS サーバ設定

Cisco IOS Security Configuration Guide 』の「 Security Overview

規格

 

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

 

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3162

『RADIUS and IPv6』

RFC 3177

『IAB/IESG Recommendations on IPv6 Address』

RFC 3319

『Dynamic Host Configuration Protocol (DHCPv6) Options for Session Initiated Protocol (SIP) Servers』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(13)T 以降のリリースで導入または変更された機能だけを示します。

ここに記載されていないこのテクノロジーの機能情報については、「 Start Here: Cisco IOS Software Release Specifies for IPv6 Features 」を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


表 1 に、各機能が使用可能になる各早期開発トレインの最も早いリリースを示します。

 

表 1 IPv6 への ADSL の実装およびダイヤル アクセスの展開の機能情報

機能名
リリース
機能情報

ADSL およびダイヤル展開用の拡張 IPv6 機能

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 で ADSL およびダイヤル展開の使用をイネーブルにするために、いくつかの機能が拡張されました。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「ステートレス アドレス自動設定」

「NAS の設定」

「リモート CE ルータの設定」

Cisco VSA IPv6 アトリビュートの AAA サポート

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

Vendor-Specific Attribute(VSA; ベンダー固有アトリビュート)は、IPv6 で AAA をサポートするために開発されました。

この機能に関する詳細については、次の項を参照してください。

「IPv6 の AAA アトリビュート」

PPPoA

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

ADSL およびダイヤル展開は、PPPoA など、PPP カプセル化がイネーブルになっているインターフェイスで使用できます。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「NAS の設定」

「リモート CE ルータの設定」

PPPoE

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

ADSL およびダイヤル展開は、PPPoE など、PPP カプセル化がイネーブルになっているインターフェイスで使用できます。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 のアドレス割り当て」

「NAS の設定」

「リモート CE ルータの設定」

IPv6 プレフィクス プール

12.2(13)T
12.3
12.3(2)T
12.4
12.4(2)T

IPv6 のプレフィクス プールの機能は、IPv4 のアドレス プールと同様です。主な違いは、IPv6 が単一アドレスではなくプレフィクスを割り当てることです。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 の AAA アトリビュート」

「ステートレス アドレス自動設定」

「IPv6 プレフィクス プール」

「NAS の設定」

「リモート CE ルータの設定」

RFC 3162 IPv6 RADIUS アトリビュートの AAA サポート

12.3(4)T
12.4
12.4(2)T

IPv6 の AAA アトリビュートは、RFC 3162 に準拠し、RFC 3162 をサポートできる RADIUS サーバを必要とします。

これらの機能に関する詳細については、次の各項を参照してください。

「IPv6 の AAA アトリビュート」

「IPv6 での AAA アトリビュートの使用の前提条件」

「IPv6 環境での仮想アクセス用の RADIUS ユーザ単位アトリビュート」

「RADIUS サーバからプレフィクスを取得するための DHCP for IPv6 サーバの設定」

「DHCP for IPv6 AAA および SIP オプションの設定」

AAA を介した DHCP for IPv6 プレフィクス委任

12.2(18)SXE
12.3(14)T
12.4
12.4(2)T

これらの機能に関する詳細については、次の各項を参照してください。

「ステートレス アドレス自動設定」

「プレフィクス委任」

「IPv6 プレフィクス プール」

「IPv6 での AAA アトリビュートの使用の前提条件」

「DHCP for IPv6 AAA および SIP オプションの設定」

SSO - PPPoE IPv6

12.2(33)XNE

この機能は、Cisco IOS Release 12.2(33)XNE でサポートされます。