Cisco IOS セキュリティ コンフィギュレーション ガ イド:ユーザ サービスのセキュリティ保護
FTP および Telnet セッション用のファイア ウォール認証プロキシ
FTP および Telnet セッション用のファイアウォール認証プロキシ
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 7MB) | フィードバック

目次

FTP および Telnet セッション用のファイアウォール認証プロキシ

機能情報の確認

この章の構成

FTP および Telnet セッション用のファイアウォール認証プロキシの制約事項

FTP および Telnet セッション用のファイアウォール認証プロキシに関する情報

FTP および Telnet 認証プロキシの機能設計

FTP と Telnet のログイン方法

絶対タイムアウト

FTP または Telnet 認証プロキシの設定方法

AAA の設定

この次の手順

認証プロキシの設定

FTP または Telnet 認証プロキシの確認

FTP または Telnet 認証プロキシ セッションのモニタおよびメンテナンス

FTP および Telnet 認証プロキシの設定例

認証プロキシの設定例

AAA サーバのユーザ プロファイル例

TACACS+ ユーザ プロファイルの例

Livingston RADIUS ユーザ プロファイルの例

Ascend RADIUS ユーザ プロファイルの例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

FTP および Telnet セッション用のファイアウォール認証プロキシの機能情報

FTP および Telnet セッション用のファイアウォール認証プロキシ

FTP および Telnet セッション用のファイアウォール認証プロキシ機能が導入されるまでは、認証プロキシを設定するときにユーザがイネーブルにできるのは HTTP だけでした。この機能により、FTP と Telnet のサポートが導入され、認証プロキシを設定するときに 3 つのプロトコル オプションが提供されるようになりました。

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「FTP および Telnet セッション用のファイアウォール認証プロキシの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスできます。Cisco.com のアカウントは必要ありません。

FTP および Telnet セッション用のファイアウォール認証プロキシの制約事項

認証プロキシは IP 専用の機能です。そのため、-o3 イメージだけが提供されています。

Authentication, Authorization, and Accounting(AAA; 認証、認可、アカウンティング)サーバのユーザ設定でサポートされる唯一のアトリビュートは、「proxyacl#<n>」です。

認証プロキシは、ルータを通過するトラフィックだけに適用されます。ルータ宛のトラフィックは、引き続き Cisco IOS で提供される既存の認証方式によって認証されます。

FTP および Telnet セッション用のファイアウォール認証プロキシに関する情報

FTP および Telnet セッション用のファイアウォール認証プロキシ機能を設定するには、次の概念について理解する必要があります。

「FTP および Telnet 認証プロキシの機能設計」

「絶対タイムアウト」

FTP および Telnet 認証プロキシの機能設計

FTP および Telnet セッション用の認証プロキシは、HTTP 用の認証プロキシと同様に機能します。つまり、FTP と Telnet は Cisco IOS ソフトウェア中の独立したコンポーネントであり、認証されていないホストのインターフェイス上でイネーブルまたはディセーブルにできます。

認証時の認証プロキシ ルータと AAA サーバの通信など、FTP または Telnet 用の認証プロキシの機能の多くは、HTTP で使用される機能と似ています。しかし、プロトコルが違うため、FTP と Telnet のログイン方法は、HTTP とは異なります。

FTP と Telnet のログイン方法

図 1 に、一般的な認証プロキシのトポロジを示します。

図 1 一般的な認証プロキシのトポロジ

 

HTTP と同様に、認証プロキシ ルータは、クライアント ホストから送信されたトラフィックを代行受信します。FTP または Telnet パケットを受信すると、ルータはその認証キャッシュを検索して、クライアント ホストがすでに認証済みかどうかを確認します。認証済みの場合、ルータは、さらなる認証のためにクライアント ホストのトラフィックを FTP サーバまたは Telnet サーバに転送します。クライアント ホストの IP アドレスがルータのキャッシュにない場合、ルータは、ルータのユーザ名およびパスワードを使用して、AAA サーバでクライアント ホストを認証しようとします。

FTP ログイン

FTP ログインの場合、クライアント ホストは、認証プロキシ ルータによってルータのユーザ名とパスワードの入力を求められます。クライアントは、「login: proxy_username@ftp_username」および「password: proxy_passwd@ftp_passwd :」の形式で、ユーザ名とパスワードを応答する必要があります。認証プロキシは、プロキシのユーザ名とパスワードを使用して、AAA サーバのユーザ データベースに対し、クライアントのプロファイルを確認します。クライアントが AAA サーバで正常に認証されると、認証プロキシは、アプリケーション サーバによる認証のために、FTP(リモート)ユーザ名とパスワードを FTP サーバ(宛先サーバ)に渡します。

図 2 に、FTP 認証プロキシの処理の概要を示すフロー チャートを示します。

図 2 FTP 認証プロキシの概要

 

Telnet ログイン

Telnet ログインの場合、クライアント ホストは認証プロキシ ルータによってユーザ名とパスワードの入力を求められます。クライアントは、「login: proxy_username:」および「password: proxy_passwd:」の形式でユーザ名とパスワードを応答する必要があります。ユーザ名とパスワードは、AAA サーバのユーザ データベースに対して確認されます。クライアントが AAA サーバで正常に認証されると、Telnet サーバ(宛先サーバ)は、クライアントに対し、Telnet サーバのユーザ名とパスワードの入力を求めます。

図 3 に、Telnet 認証プロキシの処理の概要を示すフロー チャートを示します。

図 3 Telnet 認証プロキシの概要

 

AAA サーバでの認証に失敗すると、プロキシはクライアントにそのことを知らせます。Telnet の場合、プロキシは、Telnet サーバのユーザ名とパスワードに関与しません。クライアントが AAA サーバで認証され、Telnet サーバでの認証に失敗した場合、クライアントは、次回ネットワークにログインするときに AAA サーバで認証される必要はありません。これは、クライアントの IP アドレスが認証キャッシュに格納されるためです。クライアントは Telnet サーバだけで認証される必要があります。


) FTP の場合、クライアントは、ネットワークにログインしようとするたびに、AAA サーバの認証の成功にかかわらず、ローカルおよびリモートのユーザ名とパスワードの組み合わせを常に再入力する必要があります。


絶対タイムアウト

イネーブルになっているインターフェイス上で認証プロキシがアクティブとなる期間をユーザが設定できるように、絶対タイムアウト値が追加されました。絶対タイマーが満了すると、認証プロキシは、アクティビティにかかわらずディセーブルになります。絶対タイムアウト値は、プロトコルごと( ip auth-proxy name コマンドを使用)またはグローバルに( ip auth-proxy コマンドを使用)設定できます。絶対タイムアウトのデフォルト値はゼロです。つまり、絶対タイマーはデフォルトではオフになっており、認証プロキシは無期限でイネーブルとなり、 inactivity-timer キーワードで指定したタイムアウトだけに従います。


inactivity-timer キーワードは、ip auth-proxy name コマンドおよび ip auth-proxy コマンドの auth-cache-time キーワードを変更します。


FTP または Telnet 認証プロキシの設定方法

FTP または Telnet 認証プロキシをイネーブルにするには、AAA サービスをイネーブルにし、FTP または Telnet サーバを設定し、認証プロキシをイネーブルにする必要があります。ここでは、次の各手順について説明します。

「AAA の設定」

「認証プロキシの設定」

「FTP または Telnet 認証プロキシの確認」

「FTP または Telnet 認証プロキシ セッションのモニタおよびメンテナンス」

AAA の設定

認証プロキシを使用するには、AAA サーバを認証用に設定する必要があります。AAA サーバの認証プロキシ サービスも、認可用に設定する必要があります。これらの設定を行うには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. aaa new-model

4. aaa authentication login default group tacacs+ group radius

5. aaa authorization auth-proxy default [[ group tacacs+ ] [ group radius ]]

6. aaa authorization exec default [ group tacacs+ ] [ group radius ]

7. aaa accounting auth-proxy default stop-only [ group tacacs+ ] [ group radius ]

8. access-list access-list-number { permit | deny } {t cp | ip | icmp } host source eq tacacs host destination

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

aaa new-model

 
Router (config)# aaa new-model

ルータで AAA 機能をイネーブルにします。

ステップ 4

aaa authentication login default group tacacs+ group radius

 
Router (config)# aaa authentication login default group tacacs+ group radius

ログイン時の認証方式リストを定義します。

ステップ 5

aaa authorization auth-proxy default [[ group tacacs+ ] [ group radius ]]

 
Router (config)# aaa authorization auth-proxy default group tacacs+ group radius

auth-proxy キーワードを使用して、AAA 方式に対して認可プロキシをイネーブルにします。

ステップ 6

aaa authorization exec default [ group tacacs+ ] [ group radius ]

 
Router (config)# aaa authorization exec default group tacacs+ group radius

TACACS+ および RADIUS の認可をイネーブルにします。

ステップ 7

aaa accounting auth-proxy default stop-only [ group tacacs+ ] [ group radius ]

 

Router (config)# aaa accounting auth-proxy default stop-only group tacacs+ group radius

認証プロキシのアカウンティングをアクティブ化し、 auth-proxy キーワードを使用して、ダウンロード可能なダイナミック Access Control List(ACL; アクセス コントロール リスト)として認可ポリシーを設定します。

ステップ 8

access-list access-list-number { permit | deny } { tcp | ip | icmp } host source eq tacacs host destination

 
Router (config)# access-list 111 permit tcp host 209.165.200.225 eq tacacs host 209.165.200.254
 

または

Router (config)# access-list 111 deny ip any any
 

または

Router (config)# access-list 111 permit icmp any any

AAA サーバがトラフィックをファイアウォールに返すのを許可する ACL エントリを作成します。

送信元アドレスは AAA サーバの IP アドレスで、宛先は AAA サーバが存在するルータ インターフェイスの IP アドレスです。

この次の手順

FTP サーバまたは Telnet サーバがイネーブルになっていることと、クライアントのユーザ資格情報(ユーザ名とパスワード)がサーバのデータベースに格納されていることを確認します。

認証プロキシの設定

認証プロキシ機能を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. ip auth-proxy { inactivity-timer min | absolute-timer min }

4. ip auth-proxy auth-proxy-banner { ftp | http | telnet } [ banner-text ]

5. ip auth-proxy name auth-proxy-name { ftp | http | telnet } [ inactivity-timer min | absolute-timer min ] [ list { acl | acl-name }]

6. interface type

7. ip auth-proxy auth-proxy-name

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip auth-proxy { inactivity-timer min | absolute-timer min }

 
Router (config)# ip auth-proxy inactivity-timer 30

グローバル認証プロキシ アイドル タイムアウト値を分単位で設定します。

inactivity-timer min アクティビティがなくなってから認証キャッシュ エントリが管理される期間を分単位で指定します。値は 1 ~ 2,147,483,647 の範囲で入力します。デフォルト値は 60 分です。

absolute-timer min イネーブルになっているインターフェイス上で認証プロキシがアクティブな期間を指定します。値は、1 ~ 65,535 分(45.5 日間)の範囲で入力します。デフォルト値は 0 分です。

ステップ 4

ip auth-proxy auth-proxy-banner { ftp | http | telnet }[ banner-text ]

 
Router (config)# ip auth-proxy auth-proxy-banner ftp hello

(任意)認証プロキシのログイン ページにファイアウォール ルータの名前を表示します。デフォルトではディセーブルになっています。

ftp :FTP プロトコルを指定します。

http :HTTP プロトコルを指定します。

telnet :Telnet プロトコルを指定します。

banner-text :(任意)デフォルトのバナーを置き換えるテキスト文字列。

ステップ 5

ip auth-proxy name auth-proxy-name { ftp | http | telnet } [ inactivity-timer min ] [ absolute-timer min ] [ list { acl | acl-name }]

 
Router (config)# ip auth-proxy name ftp_list1 ftp absolute-timer 60 ftp list 102

インターフェイス上で認証プロキシを設定します。

ftp :FTP で認証プロキシを起動することを指定します。

http :HTTP で認証プロキシを起動することを指定します。

telnet :Telnet で認証プロキシを起動することを指定します。

inactivity-timer min :特定の認証プロキシ名に対し、グローバル認証プロキシ キャッシュ タイマーを上書きします。

absolute-timer min ip auth-proxy コマンドで指定したグローバルな値を上書きします。

list { acl | acl-name }: 認証プロキシで使用する標準(1 ~ 99)、拡張(1 ~ 199)、または名前付きアクセス リストを指定します。

ステップ 6

interface type

 
Router (config)# interface e0

認証プロキシを適用するインターフェイス タイプを指定して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

ip auth-proxy auth-proxy-name

 

Router(config-if)# ip auth-proxy authproxyrule

インターフェイス コンフィギュレーション モードで、名前付き認証プロキシのルールをインターフェイスに適用します。

このコマンドにより、指定の名前を持つ認証プロキシのルールがイネーブルになります。

FTP または Telnet 認証プロキシの確認

FTP または Telnet 認証プロキシの設定を確認するには、オプションで次の手順を実行します。

手順の概要

1. enable

2. show ip auth-proxy configuration

3. show ip auth-proxy cache

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

show ip auth-proxy configuration
 
Router# show ip auth-proxy configuration

現在の認証プロキシの設定を表示します。

ステップ 3

show ip auth-proxy cache
 
Router# show ip auth-proxy cache

ユーザ認証エントリのリストを表示します。

認証プロキシ キャッシュにより、ホストの IP アドレス、送信元ポート番号、認証プロキシのタイムアウト値、接続の状態が一覧表示されます。認証プロキシの状態が ESTAB または INTERCEPT の場合、ユーザ認証が成功したことを示します。

FTP または Telnet 認証プロキシ セッションのモニタおよびメンテナンス

FTP または Telnet 認証プロキシ セッションを監視するには、オプションで次の手順を実行します。

手順の概要

1. enable

2. debug ip auth-proxy { detailed | ftp | function-trace | object-creation | object-deletion | telnet | timers }

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードなど、高位の権限レベルをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

debug ip auth-proxy { detailed | ftp | function-trace | object-creation | object-deletion | telnet | timers }
 
Router# debug ip auth-proxy ftp

ルータ上の認証プロキシの設定情報を表示します。

FTP および Telnet 認証プロキシの設定例

ここでは、次の設定例について説明します。

「認証プロキシの設定例」

「AAA サーバのユーザ プロファイル例」

認証プロキシの設定例

次に、ルータで認証プロキシを設定する例を示します。

aaa new-model
aaa authentication login default group tacacs+
aaa authorization exec default group tacacs+
aaa authorization auth-proxy default group tacacs+
enable password lab
!
ip inspect name pxy_test ftp
ip auth-proxy name pxy auth-cache-time 1
!
interface Ethernet0/0
ip address 209.165.200.225 255.255.255.224
ip access-group 105 in
no ip directed-broadcast
ip inspect pxy_test in
ip auth-proxy pxy
no shut
!
interface Ethernet0/1
ip address 209.165.200.225 255.255.255.224
ip access-group 102 in
no ip directed-broadcast
no shut
!
ip http authentication aaa
!
access-list 102 permit any
access-list 102 permit tcp host 209.165.200.234 eq tacacs any
access-list 102 deny tcp any any
access-list 102 deny udp any any
access-list 102 permit ip any any
access-list 105 permit tcp any any eq www
access-list 105 permit ip any any
access-list 105 deny tcp any any
access-list 105 deny udp any any
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
tacacs-server host 209.165.200.234
tacacs-server key cisco
!
line con 0
transport input none
login authentication special
line aux 0
line vty 0 4
password lab

AAA サーバのユーザ プロファイル例

ここでは、AAA サーバでの認証プロキシのユーザ プロファイル エントリの例を示します。「proxyacl」エントリを使用して、ユーザのアクセス権限を定義します。ユーザが認証プロキシを使用してログインに成功すると、これらのエントリはファイアウォール ルータに転送されます。プロファイル内の各エントリにはサービスまたはアプリケーションの「permit」アクセスを指定する必要があります。各エントリの送信元アドレスは、「any」に設定します。アドレスは、プロファイルがファイアウォールにダウンロードされるときに認証ホストの IP アドレスに置換されます。すべての AAA ユーザの特権レベルは 15 に設定する必要があります。

ここでは、次の例について説明します。

「TACACS+ ユーザ プロファイルの例」

「Livingston RADIUS ユーザ プロファイルの例」

「Ascend RADIUS ユーザ プロファイルの例」

TACACS+ ユーザ プロファイルの例

次に、TACACS+ ユーザ プロファイルの例を示します。

default authorization = permit
key = cisco
user = http_1 {
default service = permit
login = cleartext test
service = exec
{
priv-lvl = 15
inacl#4=”permit tcp any host 209.165.200.234 eq 23”
inacl#5=”permit tcp any host 209.165.200.234 eq 20”
inacl#6=”permit tcp any host 209.165.200.234 eq 21”
inacl#3=”deny -1”
 
}
service = auth-proxy
{
priv-lvl=15
proxyacl#4=”permit tcp any host 209.165.201.1 eq 23”
proxyacl#5=”permit tcp any host 209.165.201.1 eq 20”
proxyacl#6=”permit tcp any host 209.165.201.1 eq 21”
proxyacl#7=”permit tcp any host 209.165.201.1 eq 25”
}
 
}
user = http {
login = cleartext test
service = auth-proxy
{
priv-lvl=15
proxyacl#4=”permit tcp any host 209.165.201.1 eq 23”
proxyacl#5=”permit tcp any host 209.165.201.1 eq 20”
proxyacl#6=”permit tcp any host 209.165.201.1 eq 21”
}
}
user = proxy_1 {
login = cleartext test
service = auth-proxy
{
priv-lvl=14
}
}
 
user = proxy_3 {
login = cleartext test
service = auth-proxy
{
priv-lvl=15
}
}

Livingston RADIUS ユーザ プロファイルの例

次に、Livingston RADIUS サーバのユーザ プロファイルの例を示します。

#--------------- Proxy user ---------------------------------
 
http Password = “test” User-Service-Type=Outbound-User
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
http_1 Password = “test”
User-Service-Type = Shell-User,
User-Service-Type=Dialout-Framed-User,
cisco-avpair = “shell:priv-lvl=15”,
cisco-avpair = “shell:inacl#4=permit tcp any host 209.165.200.234
eq 23
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
 
http_fail Password = “test” User-Service-Type=Outbound-User
cisco-avpair = “auth-proxy:priv-lvl=14”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
proxy Password = “cisco” User-Service-Type=Outbound-User cisco-avpair = “auth-proxy:proxyacl#4=permit tcp any any eq 20”

Ascend RADIUS ユーザ プロファイルの例

次に、Ascend RADIUS サーバのユーザ プロファイルの例を示します。

#--------------- Proxy user ---------------------------------
 
http Password = “test” User-Service=Dialout-Framed-User
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
http_2 Password = “test”
User-Service=Dialout-Framed-User
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”,
cisco-avpair = “shell:inacl#4=permit tcp any host 209.165.200.234 eq 25”
 
http_1 Password = “test”
User-Service=Dialout-Framed-User,
cisco-avpair = “shell:inacl#4=permit tcp any host 209.165.200.234 eq 23”,
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
http_fail Password = “test” User-Service=Dialout-Framed-User
cisco-avpair = “auth-proxy:priv-lvl=14”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq 23”
 
cisco-avpair = “auth-proxy:proxyacl#1=permit tcp any any eq 23”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq ftp”,
cisco-avpair = “auth-proxy:proxyacl#4=permit tcp any any eq 20”
 
 
#------------------------------------------------------------
 
proxy Password = “cisco” User-Service = Dialout-Framed-User
 
cisco-avpair = “auth-proxy:priv-lvl=15”,
 
cisco-avpair = “auth-proxy:priv-lvl=15”,
cisco-avpair = “auth-proxy:proxyacl#1=permit tcp any any eq 26”,
cisco-avpair = “auth-proxy:proxyacl#3=permit tcp any any eq ftp”,

その他の参考資料

ここでは、FTP および Telnet セッション用のファイアウォール認証プロキシ機能に関する関連資料について説明します。

関連資料

内容
参照先

認証プロキシのその他の設定作業

Configuring Authentication Proxy

追加の認証プロキシ コマンド

『Cisco IOS Security Command Reference』

RADIUS および TACACS+ の設定情報

Configuring RADIUS 」および「 Configuring TACACS+

RADIUS および TACACS+ のアトリビュート情報

RADIUS Attributes Overview and RADIUS IETF Attributes 」および「 TACACS+ Attribute-Value Pairs

追加の認証プロキシ情報

Firewall Support of HTTPS Authentication Proxy

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、豊富なオンライン リソースが提供されており、それらに含まれる資料やツールを利用して、トラブルシューティングやシスコ製品およびテクノロジーに関する技術上の問題の解決に役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト(http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。http://www.cisco.com/jp/go/tac

http://www.cisco.com/techsupport

FTP および Telnet セッション用のファイアウォール認証プロキシの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージを確認できます。Cisco Feature Navigator には、 http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスできます。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 FTP および Telnet セッション用のファイアウォール認証プロキシの機能情報

機能名
リリース
機能情報

FTP および Telnet セッション用のファイアウォール認証プロキシ

12.3(1)

FTP および Telnet セッション用のファイアウォール認証プロキシ機能が導入されるまでは、認証プロキシを設定するときにユーザがイネーブルにできるのは HTTP だけでした。この機能により、FTP と Telnet のサポートが導入され、認証プロキシを設定するときに 3 つのプロトコル オプションが提供されるようになりました。

この機能は、Cisco IOS リリース 12.3(1) で導入されました。

次のコマンドが導入または変更されました。 debug ip auth-proxy、ip auth-proxy、ip auth-proxy auth-proxy-banner、ip auth-proxy name

 

このマニュアルで使用している IP アドレスおよび電話番号は、実際のアドレスおよび電話番号を示すものではありません。マニュアル内の例、コマンド出力、ネットワーク トポロジ図、およびその他の図は、説明のみを目的として使用されています。説明の中に実際のアドレスおよび電話番号が使用されていたとしても、それは意図的なものではなく、偶然の一致によるものです。

© 2003-2009 Cisco Systems, Inc.
All rights reserved.