Cisco IOS パフォーマンス ルーティング コンフィ ギュレーション ガイド
パフォーマンス ルーティング リンク グループ
パフォーマンス ルーティング リンク グループ
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

パフォーマンス ルーティング リンク グループ

機能情報の検索

マニュアルの内容

パフォーマンス ルーティング リンク グループの前提条件

パフォーマンス ルーティング リンク グループの概要

パフォーマンス ルーティング リンク グループ

パフォーマンス ルーティング リンク グループの設定方法

パフォーマンス ルーティング リンク グループの実装

パフォーマンス ルーティング リンク グループの設定例

パフォーマンス ルーティング リンク グループの実装:例

次の作業

参考資料

関連資料

シスコのテクニカル サポート

パフォーマンス ルーティング リンク グループの機能情報

パフォーマンス ルーティング リンク グループ

パフォーマンス ルーティング - リンク グループ機能は、出口リンクのグループを優先リンク セットとして、または Performance Routing(PfR; パフォーマンス ルーティング)用フォールバック リンク セットとして定義し、PfR ポリシーで指定されたトラフィック クラスを最適化する際に使用できる機能を導入しました。

機能情報の検索

このモジュールに記載されている機能の一部が、ご使用のソフトウェア リリースでサポートされていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「パフォーマンス ルーティング リンク グループの機能情報」を参照してください。

プラットフォームのサポート、ならびに Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

パフォーマンス ルーティング リンク グループの前提条件

この機能では、マスター コントローラおよびボーダー ルータが Cisco IOS リリース 12.4(15)T 以降で稼動している必要があります。

パフォーマンス ルーティング リンク グループの概要

PfR リンク グループを設定するには、次の概念を理解する必要があります。

「パフォーマンス ルーティング リンク グループ」

パフォーマンス ルーティング リンク グループ

パフォーマンス ルーティング - リンク グループ機能は、出口リンクのグループを優先リンク セットとして、または PfR 用フォールバック リンク セットとして定義し、PfR ポリシーで指定されたトラフィック クラスを最適化する際に使用できる機能を導入しました。現在 PfR は、ポリシーで指定されたプリファレンスと、指定リンク外のパスでのトラフィック クラスのパフォーマンス(到達可能性、遅延、損失、ジッター、MOS などのパラメータを使用)に基づいて、トラフィック クラスに最良のリンクを選択しています。最良リンクの選択では、帯域幅の使用率、コスト、リンクの範囲を考慮することもできます。リンクのグループ化に使用される手法では、1 つ以上のトラフィック クラスに対する優先リンクを PfR ポリシーで指定し、プライマリ リンク グループと呼ばれる優先リンクのリストにある最良リンクを介してトラフィック クラスがルーティングされるようにします。プライマリ グループに所定のポリシーとパフォーマンス要件を満たすリンクがない場合は、フォールバック リンク グループを指定することもできます。プライマリ グループ リンクを使用できない場合、トラフィック クラスはフォールバック グループ内の最良リンクを介してルーティングされます。最良のリンクを特定するために、PfR はプライマリ グループとフォールバック グループの両方をプローブします。

プライマリおよびフォールバック リンク グループは、マスター コントローラで設定でき、一意な名前で識別されます。リンク グループでは、PfR ポリシーで最良のリンクが高帯域幅リンクだけで構成されるリンク グループから選択されるように設定することで、たとえば、ビデオ トラフィックで使用される高帯域幅リンクなど、リンクをグループ化できます。ポリシーで指定されるトラフィック クラスは、プライマリ リンク グループ 1 つ、フォールバック リンク グループ 1 つだけで設定できます。リンク グループの優先順位は、ポリシーにより異なるので、同じリンク グループが、ポリシーによっては、プライマリ リンク グループになったり、フォールバック リンク グループになったりすることがあります。

リンク グループ化の実装例については、図 1 を参照してください。3 つのリンク グループ、ISP1、ISP2 および ISP3 は、異なる Internet Service Provider(ISP; インターネット サービス プロバイダー)を表しています。これら 3 つの ISP にはすべて、図 1 で示されている 3 つのボーダー ルータのインターフェイスのリンクがあります。ISP1 リンクは、最もコストがかかるリンクですが、Service Level Agreement(SLA; サービス レベル契約)の保証は最高です。ISP3 リンクは、ベスト エフォート型リンクで、最もコストが低いリンクです。ISP2 リンクは、ISP1 リンクほどは優れていませんが、ISP3 リンクよりは信頼できます。ISP2 リンクのコストは、ISP3 リンクよりは高く、ISP1 リンクより低いです。この状況で、各 ISP は、リンク グループとして作成され、図 1 で示されている各ボーダー ルータのインターフェイスに関連付けられています。

図 1 リンク グループの図

 

ビデオ、ボイス、FTP、データの 4 種類のトラフィック クラスがあるとします。各トラフィック クラスは、適切なリンク グループに属するボーダー ルータ インターフェイスを介してルーティングできます。ビデオとボイスのトラフィック クラスでは、最良のリンクが必要であるため、ISP1 リンク グループがプライマリ リンク グループとして、ISP2 がフォールバック グループとして設定されます。FTP トラフィックでは、信頼できるリンクが必要であり、コスト効率も考慮が必要となる可能性があるので、ISP2 をプライマリ グループとして、ISP3 をフォールバック リンク グループとして割り当てます。ISP1 は、最も信頼できるリンクを提供しますが、ファイル転送トラフィックとしてコストが高すぎることがあります。データ トラフィックにおいて、ISP3 はプライマリ リンク グループに、ISP2 はフォールバック グループに適しています。

スピルオーバー

パフォーマンス ルーティング リンク グループを使用して、スピルオーバーをサポートできます。スピルオーバーは次のように機能します。ネットワークを介して同じ Provider Edge(PE; プロバイダー エッジ)ルータに 2 つのパス(たとえば、Traffic Engineering(TE; トラフィック エンジニアリング)トンネル)があり、これらのトンネルのパスがネットワーク上で異なる場合、トラフィックは、一方のトンネルを介して送信され、トラフィック負荷しきい値に達すると、もう一方のトンネルにスピルオーバーされます。PfR リンク グループを使用すると、一方のトンネルをプライマリ リンク グループとして作成して、もう一方のトンネルをフォールバック リンク グループにできます。最初のトンネルがポリシー違反になると、PfR はフォールバック トンネル リンク グループに切り替えます。これにより、最初のトンネルのトラフィック負荷がしきい値を下回るまで、スピルオーバー容量が提供されます。トンネルは、PfR リンク グループが設定される前に確立される必要があります。

パフォーマンス ルーティング リンク グループの設定方法

ここでは、次のタスクについて説明します。

「パフォーマンス ルーティング リンク グループの実装」

パフォーマンス ルーティング リンク グループの実装

ボーダー ルータの出口リンクをリンク グループのメンバーとして識別しいくつかのパフォーマンス ルーティング リンク グループを設定して、PfR マップを作成して PfR ポリシーで定義されるトラフィック クラスのリンク グループを指定するには、マスター コントローラでこのタスクを実行します。このタスクでは、リンク グループは、ビデオ トラフィックに設定されます。高帯域幅の出口リンクのセットは、プライマリ リンク グループとして識別されるビデオ リンク グループのメンバーとして識別されます。フォールバック リンク グループも指定されます。

PfR ポリシーは、PfR マップを使用して作成されます。ここで、プライマリおよびフォール リンク グループが、PfR マップ条件と一致するトラフィック クラスに指定されます。PfR は、プライマリとフォールバックの両方のグループ リンクをプローブし、プライマリ リンク グループから、このタスクで指定されるトラフィック クラスに最良のリンクを選択します。ポリシー内でプライマリ リンクがない場合、PfR は、フォールバック グループから最良のリンクを選択します。リンク グループの詳細については、「パフォーマンス ルーティング リンク グループ」を参照してください。

手順の概要

1. enable

2. configure terminal

3. oer master

4. border ip-address [ key-chain key-chain-name ]

5. interface type number external

6. link-group link-group-name [ link-group-name [ link-group-name ]]

7. exit

8. ステップ 5ステップ 7 を繰り返して、すべての外部インターフェイスのリンク グループを設定するために適切な変更を行います。

9. interface type number internal

10. exit

11. ip access-list { standard | extended } access-list-name

12. [ sequence-number ] permit udp source source-wildcard [ operator [ port ]] destination destination-wildcard [ operator [ port ]] [ dscp dscp-value ]

13. 必要なすべてのアクセス リスト エントリについてステップ 12 を繰り返します。

14. exit

15. oer-map map-name sequence-number

16. match traffic-class access-list access-list-name

17. set link-group link-group-name [ fallback link-group-name ]

18. end

19. show oer master link-group [ link-group-name ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、ルータをマスター コントローラとして設定します。

マスター コントローラおよびボーダー ルータのプロセスを同じルータ上でイネーブルにできます(別個のサービス プロバイダーに 2 つの出口リンクを持つ 1 つのルータを含むネットワーク内など)。

ステップ 4

border ip-address [ key-chain key-chain-name ]

 

Router(config-oer-mc)# border 192.168.1.2 key-chain border1_OER

OER 管理ボーダー ルータ コンフィギュレーション モードを開始して、ボーダー ルータとの通信を確立します。

ボーダー ルータを識別するために、IP アドレスを設定します。

PfR の管理対象ネットワークを作成するには、少なくとも 1 台のボーダー ルータを指定する必要があります。1 台のマスター コントローラで制御できるボーダー ルータは、最大 10 台です。

key-chain-name 引数の値は、ボーダー ルータの設定時に指定されたキー チェーン名と一致する必要があります。

引数を入力する必要があります。ただし、既存のボーダー ルータを再設定する場合、このキーワードは省略可能です。

ステップ 5

interface type number external

 

Router(config-oer-mc-br)# interface Serial 2/0 external

PfR 管理の外部インターフェイスとしてボーダー ルータ インターフェイスを設定します。

外部インターフェイスは、トラフィックの転送およびアクティブ モニタリングに使用されます。

PfR 管理のネットワークには、最低 2 つの外部ボーダー ルータ インターフェイスが必要です。各ボーダー ルータでは、少なくとも 1 つの外部インターフェイスを設定する必要があります。1 台のマスター コントローラで制御できる外部インターフェイスは、最大 20 です。

ヒント ルータでインターフェイスを PfR 管理外部インターフェイスとして設定すると、OER ボーダー出口インターフェイス コンフィギュレーション モードが開始されます。このモードでは、インターフェイスに対して最大リンク使用率またはコストベースの最適化を設定できます。
形式は慎重に適用してください。

ステップ 6

link-group link-group-name [ link-group-name [ link-group-name ]]

 

Router(config-oer-mc-br-if)# link-group VIDEO

PfR ボーダー ルータ出口インターフェイスをリンク グループのメンバーとして設定します。

インターフェイスのリンク グループ名を指定するには、 link-group-name を使用します。

各インターフェイスには最高 3 つのリンク グループを指定できます。

この例では、シリアル 2/0 外部インターフェイスが、VIDEO という名前のリンク グループのメンバーとして設定されます。

コマンドを使用して、PfR マップで定義されているトラフィック クラスのプライマリまたはフォールバック グループとしてリンク グループを識別します。

ステップ 7

exit

 

Router(config-oer-mc-br-if)# exit

OER 管理ボーダー出口インターフェイス コンフィギュレーション モードを終了して、OER 管理ボーダー ルータ コンフィギュレーション モードに戻ります。

ステップ 8

ステップ 5ステップ 7 を繰り返して、すべての外部インターフェイスのリンク グループを設定するために適切な変更を行います。

ステップ 9

interface type number internal

 

Router(config-oer-mc-br)# interface FastEthernet 0/1 internal

ボーダー ルータ インターフェイスを PfR 制御内部インターフェイスとして設定します。

内部インターフェイスはパッシブ モニタリングだけに対して使用されます。内部インターフェイスはトラフィックを転送しません。

各ボーダー ルータでは、少なくとも 1 つの内部インターフェイスを設定する必要があります。

(注) VLAN インターフェイスを内部インターフェイスとして設定するサポートは Cisco IOS リリース 12.3(14)T と 12.2(33)SRB で導入されました。

ステップ 10

exit

 

Router(config-oer-mc-br)# exit

OER 管理ボーダー コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

ip access-list { standard | extended } access-list-name

 

Router(config)# ip access-list extended ACCESS_VIDEO

IP アクセス リストを名前で定義し、拡張名前付きアクセス リスト コンフィギュレーション モードを開始します。

PfR は、名前付きアクセス リストだけをサポートします。

例では、ACCESS_VIDEO という名前の拡張 IP アクセス リストが作成されます。

ステップ 12

[ sequence-number ] permit udp source source-wildcard [ operator [ port ]] destination destination-wildcard [ operator [ port ]] [ dscp dscp-value ]

 

Router(config-ext-nacl)# permit tcp any any 500

パケットが名前付き IP アクセス リストを通過できる条件を設定します。

例では、任意の宛先または送信元から、および宛先ポート番号 500 からのすべての Transmission Control Protocol(TCP; 伝送制御プロトコル)トラフィックを識別するように設定されます。この特定の TCP トラフィックが最適化されます。

ステップ 13

必要に応じて、追加のアクセス リスト エントリについてステップ 12 を繰り返します。

ステップ 14

exit

 

Router(config-ext-nacl)# exit

(任意)拡張名前付きアクセス リスト コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 15

oer-map map-name sequence-number

 

Router(config)# oer-map VIDEO_MAP 10

OER マップ コンフィギュレーション モードを開始して、PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

permit シーケンスは最初に IP プレフィクス リストに定義してから、ステップ 16 match ip address (OER)コマンドを使用して適用します。

例では、VIDEO_MAP という名前の PfR マップが作成されます。

ステップ 16

match traffic-class access-list access-list-name

 

Router(config-oer-map)# traffic-class access-list ACCESS_VIDEO

PfR マップを使用して、トラフィック クラスの作成に使用される一致基準として、アクセス リストを手動で設定します。

各アクセス リスト エントリには、宛先プレフィクスが含まれている必要があります。また、他の省略可能なパラメータを含むこともできます。

例では、ACCESS_VIDEO という名前のアクセス リストで定義された条件を使用してトラフィック クラスが定義されます。

ステップ 17

set link-group link-group-name [ fallback link-group-name ]

 

Router(config-oer-map)# set link-group video fallback voice

PfR マップで指定されているトラフィック クラスのリンク グループを指定して、PfR ポリシーを作成します。

ポリシーのプライマリ リンク グループ名を指定するには、 link-group-name を使用します。

ポリシーのフォールバック リンク グループ名を指定するには、 fallback キーワードを使用します。

この例では、アクセス リスト ACCESS_VIDEO と一致するトラフィック クラスのプライマリ リンク グループとして VIDEO リンク グループを指定します。リンク グループ VOICE は、フォールバック リンク グループとして指定されます。

ステップ 18

end

 

Router(config-oer-map)# end

(任意)OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 19

show oer master link-group [ link-group-name ]

 

Router# show oer master link-group

設定されている PfR リンク グループに関する情報を表示します。

指定された PfR リンク グループの情報を表示するには、オプションの link-group-name 引数を使用します。

link-group-name 引数を指定しない場合、すべての PfR リンク グループに関する情報が表示されます。

この例では、設定されているすべてのリンク グループに関する情報を表示します。

次に、PfR を使用して設定されるパフォーマンス ルーティング リンク グループに関する情報を表示する show oer master link-group コマンドの出力例を示します。この例では、VIDEO リンク グループと、設定されている他のリンク グループが示されています。

Router# show oer master link-group
 
link group video
Border Interface Exit id
192.168.1.2 Serial2/0 1
link group voice
Border Interface Exit id
192.168.1.2 Serial2/0 1
192.168.1.2 Serial3/0 2
192.168.3.2 Serial4/0 4
link group data
Border Interface Exit id
192.168.3.2 Serial3/0 3

パフォーマンス ルーティング リンク グループの設定例

次に、サンプル PfR リンク グループ設定の例を示します。

「パフォーマンス ルーティング リンク グループの実装:例」

パフォーマンス ルーティング リンク グループの実装:例

次の例に、リンク グループを実装する方法を示します。この例では、ACCESS_VIDEO という名前のアクセス リストと一致するトラフィック クラスを定義するように PfR を設定する、VIDEO_MAP という名前の PfR マップが作成されます。トラフィック クラスは、VIDEO という名前のリンク グループをプライマリ リンク グループとして使用し、VOICE という名前のフォールバック グループを使用するように設定されています。VIDEO リンク グループには、ビデオ トラフィックに適した高帯域幅リンクのセットが選択されることがあります。

enable
configure terminal
border 10.1.4.1
interface serial 2/0 external
link-group VIDEO
exit
interface serial 3/0 external
link-group VOICE
exit
interface Ethernet 1/0 internal
exit
ip access-list extended ACCESS_VIDEO
permit tcp any 10.1.1.0 0.0.0.255 eq 500
permit tcp any 172.17.1.0 0.0.255.255 eq 500
permit tcp any 172.17.1.0 0.0.255.255 range 700 750
permit tcp 192.168.1.1 0.0.0.0 10.1.2.0 0.0.0.255 eq 800 any any dscp ef
exit
oer-map VIDEO_MAP 10
match traffic-class access-list ACCESS_VIDEO
set link-group VIDEO fallback VOICE
end

次の作業

他のパフォーマンス ルーティング機能の詳細または一般的な概念に関する資料については、「関連資料」に記載の資料を参照してください。

参考資料

ここでは、パフォーマンス ルーティング リンク グループ機能に関する参考資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

Cisco OER コマンド(コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例)

Cisco IOS Optimized Edge Routing Command Reference』

ベーシック PfR 設定

「Configuring Basic Performance Routing」 モジュール

アドバンスド PfR の設定

「Configuring Advanced Performance Routing」 モジュール

パフォーマンス ルーティングの運用フェーズを理解するために必要な概念

「Understanding Performance Routing」 モジュール

PfR 機能の位置

「Cisco IOS Performance Routing Features Roadmap」 モジュール

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

パフォーマンス ルーティング リンク グループの機能情報

表 1 に、この機能のリリース履歴を示します。

本書に記載されていないこのテクノロジーの機能については、 「Cisco IOS Performance Routing Features Roadmap」 を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 パフォーマンス ルーティング リンク グループの機能情報

機能名
リリース
機能情報

パフォーマンス ルーティング - リンク グループ

12.4(15)T

パフォーマンス ルーティング - リンク グループ機能によって、出口リンクのグループを優先リンク セットとして、または PfR 用フォールバック リンク セットとして定義し、PfR ポリシーで指定されたトラフィック クラスを最適化する際に使用できるようになっています。

link-group set link-group 、および show oer master link-group の各コマンドが、この機能によって導入または変更されました。

CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.