Cisco IOS パフォーマンス ルーティング コンフィ ギュレーション ガイド
アドバンスド パフォーマンス ルーティングの 設定
アドバンスド パフォーマンス ルーティングの設定
発行日;2012/01/08 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

アドバンスド パフォーマンス ルーティングの設定

機能情報の検索

マニュアルの内容

アドバンスド パフォーマンス ルーティングの設定の前提条件

アドバンスド パフォーマンス ルーティングの概要

パフォーマンス ルーティングの概要

アドバンスド パフォーマンス ルーティングの導入

プロファイル フェーズ

測定フェーズ

ポリシー適用フェーズ

施行フェーズ

確認フェーズ

アドバンスド パフォーマンス ルーティングの設定方法

プロファイリング フェーズのタスク

アクセス リストを使用して自動的に学習されたアプリケーション トラフィック クラスの学習リストの定義

プレフィクス リストを使用した、プレフィクスベースのトラフィック クラスの手動選択

トラフィック クラスおよび学習リストの情報の表示とリセット

測定フェーズのタスク

アウトバウンド トラフィックの PfR リンク使用率の変更

PfR 出口リンクの使用率範囲の変更

PfR パッシブ モニタリングの設定および確認

最長一致ターゲット割り当てを使用した PfR アクティブ プローブの設定

強制ターゲット割り当てを使用した PfR 音声プローブの設定

高速フェールオーバー用 PfR 音声プローブの設定

アクティブ プローブのソース アドレスの設定

ポリシー適用フェーズのタスク

PfR ポリシーの設定および学習済みトラフィック クラスへの適用

学習済みプレフィクスの PfR 最適化の防止

PfR マップ用ポリシー ルールの設定

複数 PfR ポリシーの競合解決の設定

PfR マップを使用したブラック ホール ルーティングの設定

PfR マップを使用したシンクホール ルーティングの設定

施行フェーズのタスク

アプリケーション トラフィックの制御

確認フェーズのタスク

PfR ルート強制変更の手動確認

アドバンスド パフォーマンス ルーティングの設定例

プロファイル フェーズのタスク:例

自動的に学習されたプレフィクスベースのトラフィック クラスの学習リストの定義:例

アクセス リストを使用して自動的に学習されたアプリケーション トラフィック クラスの学習リストの定義:例

プレフィクス リストを使用した、プレフィクスベースのトラフィック クラスの手動選択:例

アクセス リストを使用したアプリケーション トラフィック クラスの手動選択:例

測定フェーズのタスク:例

アウトバウンド トラフィックの PfR リンク使用率の変更:例

PfR 出口リンクの使用率範囲の変更:例

最長一致ターゲット割り当ての TCP プローブ:例

強制ターゲット割り当ての UDP プローブ:例

高速フェールオーバー用 PfR 音声プローブの設定:例

アクティブ プローブのソース アドレスの設定:例

ポリシー適用フェーズのタスク:例

PfR ポリシーの設定および学習済みトラフィック クラスへの適用:例

PfR ポリシーの設定および設定されたトラフィック クラスへの適用:例

学習済みプレフィクスの PfR 最適化の防止:例

PfR マップ用ポリシー ルールの設定:例

複数 PfR ポリシーの競合解決の設定:例

出口リンクの ロード バランシング PfR ポリシーの設定:例

PfR マップを使用したブラック ホール ルーティングの設定:例

PfR マップを使用したシンクホール ルーティングの設定:例

施行フェーズのタスク:例

挿入された PfR スタティック ルートのタグ値の設定:例

PfR 制御 BGP ルートの BGP ローカル プリファレンス値の設定:例

アプリケーション トラフィックの制御:例

確認フェーズのタスク:例

PfR ルート制御変更の手動確認:例

次の作業

参考資料

関連資料

シスコのテクニカル サポート

アドバンスド パフォーマンス ルーティングに関する機能情報

アドバンスド パフォーマンス ルーティングの設定

Performance Routing(PfR; パフォーマンス ルーティング)マスター コントローラおよびボーダー ルータの設定後( 「Configuring Basic Performance Routing」 モジュールを参照)に PfR のすべての最適化機能をアクティブ化するには、追加設定が必要です。このモジュールには、PfR の各フェーズを表すタスクおよび設定例が記載されているので、PfR の各フェーズの高度なオプションの一部の設定方法を理解し、確認できます。機能の詳細については、 「Cisco IOS Performance Routing Features Roadmap 」を参照してください。

機能情報の検索

このモジュールに記載されている機能の一部が、ご使用のソフトウェア リリースでサポートされていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「アドバンスド パフォーマンス ルーティングに関する機能情報」を参照してください。

プラットフォームのサポート、ならびに Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

アドバンスド パフォーマンス ルーティングの設定の前提条件

このモジュールでは、マスター コントローラおよびボーダー ルータが Cisco IOS リリース 12.4(15)T 以降で稼動している必要があります。

このモジュールのタスクを設定する前に、 「Configuring Basic Performance Routing」 モジュールを使用して、マスター コントローラおよび少なくとも 2 台のボーダー ルータを設定する必要があります。

このモジュールのタスクを設定する前に、 「Understanding Performance Routing」 モジュールに記載の概念についての知識が必要です。

ネットワークでルーティング プロトコル ピアリングを確立するか、スタティック ルーティングを設定してから、ルート制御モードをイネーブルにする必要があります。

ボーダー ルータで Internal Border Gateway Protocol(iBGP; 内部ボーダー ゲートウェイ プロトコル)を設定した場合は、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ピアリングを確立してネットワーク全体に一貫して適用するか、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)に再配布する必要があります。Enhanced Interior Gateway Routing Protocol(EIGRP; 拡張内部ゲートウェイ ルーティング プロトコル)、Open Shortest Path First(OSPF)、Intermediate System-to-Intermediate System(IS-IS)、または Routing Information Protocol(RIP; ルーティング情報プロトコル)の各 IGP がサポートされています。

ネットワークに IGP が導入されている場合、 redistribute コマンドを使用してスタティック ルートの再配布を設定する必要があります(ただし、iBGP が設定されている場合は除きます)。IGP またはスタティック ルーティングが、Optimized Edge Routing(OER)管理のネットワーク全体に一貫して適用され、ボーダー ルータがネットワークの一貫したビューを持つことも必要です。


注意 OER スタティック ルートを IGP に再配布する際は、慎重に行う必要があります。OER によって挿入されるルートは IGP のルートよりも具体的なことがあり、OER ボーダー ルータがこれらのルートの生成元であるかのように表示されます。ルーティング ループを回避するためには、再配布された OER スタティック ルートが、OER ボーダー ルータまたは他のルータによって WAN 上でアドバタイズされないようにする必要があります。OER スタティック ルートがアドバタイズされないようにするために、ルート フィルタリングおよびスタブ ネットワーク設定を使用できます。OER スタティック ルートが OER 外部インターフェイスを終端とするルータに再配布された場合、ルーティング ループが発生することがあります。

アドバンスド パフォーマンス ルーティングの概要

アドバンスド PfR を設定するには、次の概念を理解する必要があります。

「パフォーマンス ルーティングの概要」

「アドバンスド パフォーマンス ルーティングの導入」

パフォーマンス ルーティングの概要

パフォーマンス ルーティング(PfR)はシスコの先進テクノロジーです。追加のサービスアビリティ パラメータを使用して従来のルーティング テクノロジーを補完して、最良の出力パスまたは入力パスを選択できます。PfR は、追加機能を使用して従来のルーティング テクノロジーを補完します。PfR は、到達可能性、遅延、コスト、ジッター、Mean Opinion Score(MOS; 平均オピニオン評点)などのパラメータに基づいて、出力または入力の WAN インターフェイスを選択できます。または、負荷、スループット、および金銭的コストなどのインターフェイス パラメータを使用することもできます。一般的に従来のルーティング(たとえば、EIGRP、OSPF、Routing Information Protocol version 2(RIPv2)、BGP など)では、最短または最小のコスト パスに基づいてループフリーのトポロジを作成することが重視されます。

PfR には、計測装置を使用する追加機能が備わっています。PfR は、インターフェイス統計、Cisco IP Service Level Agreement(SLA; サービス レベル契約)(アクティブ モニタリング)、および NetFlow(パッシブ モニタリング)を使用します。IP SLA または NetFlow に関する予備知識または経験は不要です。PfR は、手動設定なしでこれらのテクノロジーを自動的にイネーブルにします。

Cisco パフォーマンス ルーティングは、到達可能性、遅延、コスト、ジッター、平均オピニオン評点(MOS)などの、アプリケーション パフォーマンスに影響を与えるパラメータに基づいて、出力または入力の WAN パスを選択します。このテクノロジーでは、ロード バランシングを効率化したり、WAN をアップグレードせずにアプリケーション パフォーマンスを向上させたりすることによって、ネットワーク コストを削減できます。

PfR は、IP トラフィック フローを監視してから、トラフィック クラスのパフォーマンス、リンクの負荷分散、リンク帯域幅の金銭的コスト、およびトラフィック タイプに基づいてポリシーとルールを定義できる、統合型の Cisco IOS ソリューションです。PfR は、アクティブ モニタリング システム、パッシブ モニタリング システム、障害のダイナミック検出、およびパスの自動修正を実行できます。PfR を導入することによって、インテリジェントな負荷分散や、企業ネットワーク内での最適なルート選択が可能になります。

アドバンスド パフォーマンス ルーティングの導入

アドバンスド PfR は、Cisco IOS Command-Line Interface(CLI; コマンドライン インターフェイス)設定を使用して Cisco ルータ上で設定されます。PfR インフラストラクチャには、クライアント-サーバ メッセージング モードで通信が行われるパフォーマンス ルーティング プロトコルが含まれています。PfR で使用されるルーティング プロトコルは、マスター コントローラと呼ばれるネットワーク コントローラと、ボーダー ルータと呼ばれるパフォーマンスアウェアなデバイスとの間で実行されます。このパフォーマンス ルーティング プロトコルは、ネットワーク パフォーマンス ループを作成します。このネットワーク パフォーマンス ループでは、ネットワークが、最適化が必要なトラフィック クラスのプロファイリング、識別したトラフィック クラスのパフォーマンス メトリックの測定と監視、このトラフィック クラスへのポリシーの適用、および指定されたトラフィック クラスの最良のパフォーマンス パスに基づくルーティングを行います。

PfR パフォーマンス ループは、プロファイル フェーズから始まり、測定、ポリシー適用、制御、および確認の各フェーズが続きます。このフローは、確認フェーズ後にプロファイル フェーズに戻って続行し、プロセスを通じてトラフィック クラスおよびサイクルをアップデートします。

アドバンスド PfR では、次の各 PfR フェーズに対応するために設定タスクを行う必要があります。

「プロファイル フェーズ」

「測定フェーズ」

「ポリシー適用フェーズ」

「施行フェーズ」

「確認フェーズ」

プロファイル フェーズ

中規模から大規模のネットワークでは、何十万台ものルータが Routing Information Base(RIB; ルーティング情報ベース)に存在し、デバイスがトラフィックのルーティングを試みています。パフォーマンス ルーティングは一部のトラフィックを優先させる手段なので、RIB 内の全ルートのサブセットを選択してパフォーマンス ルーティング用に最適化する必要があります。PfR は、自動学習または手動設定のいずれかの方法でトラフィックをプロファイリングします。

自動学習:デバイスは、デバイスを通過するフローを学習し、遅延またはスループットが最も高いフローを選択することによって、パフォーマンス ルーティング(最適化)の必要なトラフィックをプロファイリングします。

手動設定:学習に加えて、または学習の代わりに、トラフィック クラスにパフォーマンス ルートを設定します。

一部のプロファイリング フェーズ オプションの設定方法を示すタスクについては、「プロファイリング フェーズのタスク」を参照してください。

測定フェーズ

パフォーマンス ルーティングの必要なトラフィックのプロファイリングが終わると、PfR は、これらの個々のトラフィック クラスのパフォーマンス メトリックを測定します。パフォーマンス メトリックの測定には、パッシブ モニタリングとアクティブ モニタリングという 2 種類のメカニズムがあり、1 つまたは両方のメカニズムをネットワークに導入して次のタスクを実行できます。モニタリングとは、定期的な間隔で測定するアクションです。

パッシブ モニタリングとは、フローがデータ パス内のデバイスを通過するときにトラフィックのパフォーマンス メトリックを測定するアクションです。パッシブ モニタリングは NetFlow 機能を使用しますが、一部のトラフィック クラスのパフォーマンス メトリック測定には使用できません。一部のハードウェアまたはソフトウェアに関する制約もあります。

アクティブ モニタリングは、IP サービス レベル契約(SLA)を使用して合成トラフィックを生成し、監視対象のトラフィック クラスをエミュレートすることからなります。合成トラフィックは、実際のトラフィック クラスの代わりに測定されます。合成トラフィックのモニタリング結果は、合成トラフィックで表されるトラフィック クラスをパフォーマンス ルーティングするために適用されます。

トラフィック クラスには、パッシブ モニタリング モードとアクティブ モニタリング モードの両方を適用できます。パッシブ モニタリング フェーズは、PfR ポリシーに準拠しないトラフィック クラスのパフォーマンスを検出することがあります。次に、このトラフィック クラスにアクティブ モニタリングを適用して、代替パフォーマンス パスがある場合は、最良の代替パフォーマンス パスを検出できます。

NetFlow または IP SLA 設定のサポートは、自動的にイネーブルになります。

一部の測定フェーズ オプションの設定方法を示すタスクについては、「測定フェーズのタスク」を参照してください。

ポリシー適用フェーズ

最適化の対象となるトラフィック クラスのパフォーマンス メトリックを収集すると、PfR は、その結果と、ポリシーとして設定された各メトリックに設定された低しきい値および高しきい値のセットを比較します。メトリックでは、その結果としてポリシーが境界値を越えた場合は、Out-of-Policy(OOP; ポリシー違反)イベントになります。結果の比較は、相対ベース(実際の平均値からの偏差)、しきい値ベース(値の下限または上限)、または両方の組み合わせで行われます。

PfR で定義できるポリシーは、トラフィック クラス ポリシーとリンク ポリシーの 2 種類です。トラフィック クラス ポリシーは、プレフィクスまたはアプリケーションに対して定義されます。リンク ポリシーは、ネットワーク エッジの出口リンクまたは入口リンクに対して定義されます。どちらのタイプの PfR ポリシーも、OOP イベントを判断する基準を定義します。ポリシーは、すべてのトラフィック クラスに一連のポリシーが適用されるグローバル ベース、またはトラフィック クラスの選択された(フィルタリングされた)リストに一連のポリシーが適用されるより絞り込まれたベースで適用されます。

複数のポリシー、多数のパフォーマンス メトリック パラメータ、およびこれらのポリシーをトラフィック クラスに割り当てるさまざまな方法が存在するために、ポリシーの競合解決方法が作成されました。デフォルトの裁定方法では、各パフォーマンス メトリック変数および各ポリシーに指定されたデフォルトのプライオリティ レベルが使用されます。異なるプライオリティ レベルを設定して、すべてのポリシーまたは選択した一連のポリシーに対してデフォルトの裁定を上書きするように設定できます。

一部のポリシー適用フェーズ オプションの設定方法を示すタスクについては、「ポリシー適用フェーズのタスク」を参照してください。

施行フェーズ

パフォーマンス ループの PfR 施工フェーズ(制御フェーズとも呼ばれます)では、ネットワークのパフォーマンスが向上するようにトラフィックが制御されます。トラフィックの制御に使用される方法は、トラフィックのクラスによって異なります。プレフィクスだけを使用して定義されるトラフィック クラスでは、従来のルーティングで使用されるプレフィクスの到達可能性情報が操作されることがあります。ボーダー ゲートウェイ プロトコル(BGP)または RIP などのプロトコルは、ルートやその適切なコスト メトリックを導入または削除することによってプレフィクスの到達可能性情報をアナウンスしたり、削除したりするために使用されます。

プレフィクスおよび追加のパケット一致基準が指定されているアプリケーションによって定義されるトラフィック クラスでは、PfR は従来のルーティング プロトコルを使用できません。これは、ルーティング プロトコルが、プレフィクスの到達可能性だけを伝達するからです。これらのアプリケーション トラフィック クラスでは、PfR は 2 種類の制御方法(デバイス固有およびネットワーク固有)を使用します。

デバイス固有の制御方法は、Policy-Based Routing(PBR; ポリシーベース ルーティング)との対話を使用して実現されます。

ネットワーク固有の制御方法は、次の 2 種類の方法で実現されます。

オーバーレイ パフォーマンス ネットワーク:オーバーレイ ネットワークは、ネットワーク エッジにある各デバイスがネットワーク エッジにある他のすべての存在を学習できる場所に作成されます。次に Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)テクノロジーまたは Multipoint Generic Routing Encapsulation(mGRE; マルチポイント総称ルーティング カプセル化)テクノロジーを使用して、必要なエッジ デバイスに到達できます。

コンテキスト拡張プロトコル:プレフィクスに対応付けられるコンテキストに関する情報を伝達するように、既存のルーティング プロトコル(BGP、Open Shortest Path First(OSPF)、拡張内部ゲートウェイ ルーティング プロトコル(EIGRP))が拡張されます。トラフィック クラス フロー内の追加のパケット一致基準が、ルート アップデート内のプレフィクスに対応付けられるコンテキストを作成します。

一部の施行フェーズ オプションの設定方法を示すタスクについては、「施行フェーズのタスク」を参照してください。

確認フェーズ

PfR 施行フェーズ中にトラフィック クラスが OOP の場合、PfR は制御を導入して、OOP トラフィック クラスのトラフィック に影響を及ぼします(最適化します)。スタティック ルートおよび BGP ルートは、PfR によってネットワークに導入される制御の例です。制御が導入されると、PfR は、最適化されたトラフィックがネットワーク エッジの優先出口リンクまたは優先入口リンクを経由していることを確認します。トラフィック クラスが OOP から変化しない場合、PfR は OOP トラフィック クラスのトラフィックの最適化に導入された制御をドロップし、ネットワーク パフォーマンス ループを繰り返します。

施行フェーズ オプションが実行されていることを確認する方法を示すタスクについては、「確認フェーズのタスク」を参照してください。

アドバンスド パフォーマンス ルーティングの設定方法

ここでは、次のタスクについて説明します。

「プロファイリング フェーズのタスク」

「測定フェーズのタスク」

「ポリシー適用フェーズのタスク」

「施行フェーズのタスク」

「確認フェーズのタスク」

アクセス リストを使用して自動的に学習されたアプリケーション トラフィック クラスの学習リストの定義

アクセス リストを使用して PfR で自動的に学習されたトラフィック クラスを含む学習リストを定義して、カスタマイズされたアプリケーション トラフィック クラスを作成するには、マスター コントローラで次のタスクを実行します。次のタスクでは、カスタム アプリケーション トラフィック クラスを定義するアクセス リストが作成されます。アクセス リスト内のエントリごとに 1 つのアプリケーションが定義されます。次に学習リストが定義され、アクセス リストが適用されます。集約方法が設定されます。 count コマンドを使用すると、LEARN_USER_DEFINED_TC という名前の学習リストの 1 つの学習セッションで 50 個のトラフィック クラスを学習できます。この学習リストで指定できるトラフィック クラスの最大数は 90 です。マスター コントローラは、フィルタリング対象トラフィックの最高遅延に基づいてトップ プレフィクスを学習するように設定され、その結果得られたトラフィック クラスが PfR アプリケーション データベースに追加されます。

プレフィクス リストを使用して自動的に学習されたプレフィクスベースのトラフィック クラスの学習リストの定義については、「自動的に学習されたプレフィクスベースのトラフィック クラスの学習リストの定義:例」に例が示されています。

PfR によって学習されたトラフィック クラスに関する情報を表示するには、「トラフィック クラスおよび学習リストの情報の表示とリセット」の手順を使用します。

手順の概要

1. enable

2. configure terminal

3. ip access-list { standard | extended } access-list-name

4. [ sequence-number ] permit udp source source-wildcard [ operator [ port ]] destination destination-wildcard [ operator [ port ]] [ dscp dscp-value ]

5. 必要に応じて、追加のアクセス リスト エントリについてステップ 4 を繰り返します。

6. exit

7. oer master

8. learn

9. list seq number refname refname

10. count number max max-number

11. traffic-class access-list access-list-name [ filter prefix-list-name ]

12. aggregation-type { bgp | non-bgp | prefix-length prefix-mask }

13. delay

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip access-list { standard | extended } access-list-name

 

Router(config)# ip access-list extended USER_DEFINED_TC

IP アクセス リストを名前で定義します。

PfR は、名前付きアクセス リストだけをサポートします。

例では、USER_DEFINED_TC という名前の拡張 IP アクセス リストが作成されます。

ステップ 4

[ sequence-number ] permit udp source source-wildcard [ operator [ port ]] destination destination-wildcard [ operator [ port ]] [ dscp dscp-value ]

 

Router(config-ext-nacl)# permit tcp any any 500

パケットが名前付き IP アクセス リストを通過できる条件を設定します。

例では、任意の宛先または送信元から、および宛先ポート番号 500 からのすべての Transmission Control Protocol(TCP; 伝送制御プロトコル)トラフィックを識別するように設定されます。この特定の TCP トラフィックが最適化されます。

』を参照してください。

ステップ 5

必要に応じて、追加のアクセス リスト エントリについてステップ 4 を繰り返します。

ステップ 6

exit

 

Router(config-ext-nacl)# exit

(任意)拡張アクセス リスト コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとして Cisco ルータを設定し、マスター コントローラ ポリシーおよびタイマー設定を設定します。

ステップ 8

learn

 

Router(config-oer-mc)# learn

OER Top Talker/Top Delay 学習コンフィギュレーション モードを開始して、トラフィック クラスを自動的に学習します。

ステップ 9

list seq number refname refname

 

Router(config-oer-mc-learn)# list seq 10 refname LEARN_USER_DEFINED_TC

PfR 学習リストを作成し、学習リスト コンフィギュレーション モードを開始します。

学習リスト基準が適用される順番の決定に使用されるシーケンス番号を指定するには、 seq キーワードおよび number 引数を使用します。

学習リストの参照名を指定するには、 refname キーワードおよび refname 引数を使用します。

例では、LEARN_USER_DEFINED_TC という名前の学習リストが作成されます。

ステップ 10

count number max max-number

 

Router(config-oer-mc-learn-list)# count 50 max 90

PfR 学習セッション中に学習されるトラフィック クラスの数を設定します。

1 つの学習セッション中に、指定した学習リストについて学習されるトラフィック クラスの数を指定するには、 number 引数を使用します。

すべての学習セッション中に、指定した学習リストについて学習されるトラフィック クラスの最大数を指定するには、 max キーワードおよび max-number 引数を使用します。

例では、LEARN_USER_DEFINED_TC という名前のリストについて各学習セッションで 50 個のトラフィック クラスが学習され、この学習リストについて合計で最大 90 個のトラフィック クラスが学習されるように指定されます。

ステップ 11

traffic-class access-list access-list-name [ filter prefix-list-name ]

 

Router(config-oer-mc-learn-list)# traffic-class access-list USER_DEFINED_TC

アクセス リストを使用して PfR トラフィック クラスを定義します。

トラフィック クラスを定義するための基準を含むアクセス リストを指定するには、 access-list-name 引数を使用します。

例では、USER_DEFINED_TC という名前のアクセス リストが使用されて、トラフィック クラスが作成されます。

ステップ 12

aggregation-type { bgp | non-bgp | prefix-length } prefix-mask

 

Router(config-oer-mc-learn-list)# aggregation-type prefix-length 24

(任意)トラフィック フロー タイプに基づいて学習済みのプレフィクスを集約するように、マスター コントローラを設定します。

bgp キーワードは、BGP ルーティング テーブル内のエントリに基づいてプレフィクスを集約するように設定します。このキーワードは、BGP ピアリングがネットワーク内でイネーブルの場合に使用されます。

non-bgp キーワードは、スタティック ルートに基づいて学習済みのプレフィクスを集約するように設定します。このキーワードが入力された場合、BGP ルーティング テーブル内のエントリは無視されます。

prefix-length キーワードは、指定したプレフィクス長に基づいて集約するように設定します。この引数に設定できる値の範囲は、1 ~ 32 のプレフィクス マスクです。

このコマンドが指定されない場合、デフォルトの集約が、/24 のプレフィクス長に基づいて実行されます。

例では、/24 のプレフィクス長に基づいて、プレフィクス長の集約が設定されます。

ステップ 13

delay

 

Router(config-oer-mc-learn-list)# delay

最高遅延時間に基づいたプレフィクス学習をイネーブルにします。

Top Delay プレフィクスは、最高遅延時間から最低遅延時間の順にソートされます。

例では、最高遅延に基づいたプレフィクス学習が設定されます。

コマンドのいずれかを指定できますが、これらのコマンドは、学習リスト コンフィギュレーション モードでは同時に使用できません。

ステップ 14

end

 

Router(config-oer-mc-learn-list)# end

学習リスト コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

プレフィクス リストを使用した、プレフィクスベースのトラフィック クラスの手動選択

宛先プレフィクスだけに基づいてトラフィック クラスを手動で選択するには、マスター コントローラで次のタスクを実行します。次のタスクは、トラフィック クラスに選択する宛先プレフィクスが判明している場合に実行します。宛先プレフィクスを定義するために IP プレフィクス リストが作成され、PfR マップを使用してこのトラフィック クラスのプロファイリングが行われます。

アクセス リストを使用してアプリケーション トラフィック クラスを手動で選択する方法については、~に例が示されています。

PfR によって学習されたトラフィック クラスに関する情報を表示するには、「トラフィック クラスおよび学習リストの情報の表示とリセット」の手順を使用します。

手順の概要

1. enable

2. configure terminal

3. ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

4. 必要に応じて、追加のプレフィクス リスト エントリについてステップ 3 を繰り返します。

5. oer-map map-name sequence-number

6. match traffic-class prefix-list prefix-list-name

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

 

Router(config)# ip prefix-list PREFIX_TC permit 172.16.1.0/24

宛先プレフィクスベースのトラフィック クラスを指定するために、プレフィクス リストを作成します。

例では、トラフィック クラスに選択される 172.16.1.0/24 宛先プレフィクスを指定する、PREFIX_TC という名前のプレフィクス リストが作成されます。

ステップ 4

必要に応じて、追加のプレフィクス リスト エントリについてステップ 3 を繰り返します。

ステップ 5

oer-map map-name sequence-number

 

Router(config)# oer-map PREFIX_MAP 10

OER マップ コンフィギュレーション モードを開始して、PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

permit シーケンスは最初に IP プレフィクス リストに定義してから、ステップ 6 match traffic-class コマンドを使用して適用します。

例では、PREFIX_MAP という名前の PfR マップが作成されます。

ステップ 6

match traffic-class prefix-list prefix-list-name

 

Router(config-oer-map)# match traffic-class prefix-list PREFIX_TC

PfR マップを使用して、トラフィック クラスの作成に使用される一致基準として、プレフィクス リストを手動で設定します。

例では、PREFIX_TC という名前の IP プレフィクス リストで定義された宛先アドレスを使用してトラフィック クラスが定義されます。

ステップ 7

end

 

Router(config-oer-map)# end

(任意)OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

トラフィック クラスおよび学習リストの情報の表示とリセット

トラフィック クラスおよび学習リストの情報を表示し、任意で一部のトラフィック クラス情報をリセットするには、次の作業を実行します。これらのコマンドは、学習リストが設定されてトラフィック クラスが自動的に学習された後で、または PfR マップを使用してトラフィック クラスが手動で設定されたときに入力できます。コマンドは、任意の順番で入力できます。すべてのコマンドは、省略可能です。

手順の概要

1. enable

2. show oer master traffic-class [ access-list access-list-name | application application-name [ prefix ] | inside | learned [ delay | inside | list list-name | throughput ] | prefix prefix | prefix-list prefix-list-name ] [ active | passive | status ] [ detail ]

3. show oer master learn list list-name

4. clear oer master traffic-class [ access-list access-list-name | application application-name [ prefix ] | inside | learned [ delay | inside | list list-name | throughput ] | prefix prefix | prefix-list prefix-list-name ]

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show oer master traffic-class [ access-list access-list-name | application application-name [ prefix ] | inside | learned [ delay | inside | list list-name | throughput ] | prefix prefix | prefix-list prefix-list-name ] [ active | passive | status ] [ detail ]

このコマンドは、学習済みのトラフィック クラス、または PfR 学習リスト コンフィギュレーション モードで手動設定されたトラフィック クラスに関する情報を表示するために使用されます。

Router# show oer master traffic-class
 
OER Prefix Statistics:
Pas - Passive, Act - Active, S - Short term, L - Long term, Dly - Delay (ms),
P - Percentage below threshold, Jit - Jitter (ms),
MOS - Mean Opinion Score
Los - Packet Loss (packets-per-million), Un - Unreachable (flows-per-million),
E - Egress, I - Ingress, Bw - Bandwidth (kbps), N - Not applicable
U - unknown, * - uncontrolled, + - control more specific, @ - active probe all
# - Prefix monitor mode is Special, & - Blackholed Prefix
% - Force Next-Hop, ^ - Prefix is denied
 
DstPrefix Appl_ID Dscp Prot SrcPort DstPort SrcPrefix
Flags State Time CurrBR CurrI/F Protocol
PasSDly PasLDly PasSUn PasLUn PasSLos PasLLos EBw IBw
ActSDly ActLDly ActSUn ActLUn ActSJit ActPMOS
--------------------------------------------------------------------------------
10.1.1.0/24 N defa N N N N
# OOPOLICY 32 10.11.1.3 Et1/0 BGP
N N N N N N N IBwN
130 134 0 0 N N
 

ステップ 3 show oer master learn list [ list-name ]

このコマンドは、設定された PfR 学習リストの 1 つまたはすべてを表示するために使用されます。この例では、2 つの学習リストに関する情報が表示されます。

Router# show oer master learn list
 
Learn-List LIST1 10
Configuration:
Application: ftp
Aggregation-type: bgp
Learn type: thruput
Policies assigned: 8 10
Stats:
Application Count: 0
Application Learned:
Learn-List LIST2 20
Configuration:
Application: telnet
Aggregation-type: prefix-length 24
Learn type: thruput
Policies assigned: 5 20
Stats:
Application Count: 2
Application Learned:
Appl Prefix 10.1.5.0/24 telnet
Appl Prefix 10.1.5.16/28 telnet
 

ステップ 4 clear oer master traffic-class [ access-list access-list-name | application application-name [ prefix ] | inside | learned [ delay | inside | list list-name | throughput ] | prefix prefix | prefix-list prefix-list-name ]

このコマンドは、PfR の制御対象トラフィック クラスをマスター コントローラ データベースからクリアするために使用されます。次の例では、Telnet アプリケーションおよび 10.1.1.0/24 プレフィクスによって定義されたトラフィック クラスがクリアされます。

Router# clear oer master traffic-class application telnet 10.1.1.0/24
 


 

アウトバウンド トラフィックの PfR リンク使用率の変更

PfR の出口(アウトバウンド)リンク使用率のしきい値を変更するには、マスター コントローラで次のタスクを実行します。ボーダー ルータ用外部インターフェイスが設定されると、PfR は、ボーダー ルータ上の外部リンク使用率を 20 秒ごとに自動的に監視します。使用率はマスター コントローラに報告されます。使用率が 75% を超えると、PfR はこのリンク上のトラフィック クラス用に別の出口リンクを選択します。キロバイト/秒(kbps)単位の絶対値または割合を指定できます。

インバウンド トラフィックの測定の設定については、 「BGP Inbound Optimization Using Performance Routing」 モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. oer master

4. border ip-address [ key-chain key-chain-name ]

5. interface type number external

6. max-xmit-utilization { absolute kbps | percentage value }

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとしてルータを設定し、グローバル処理およびポリシーを設定します。

ステップ 4

border ip-address [ key-chain key-chain-name ]

 

Router(config-oer-mc)# border 10.1.1.2

OER 管理ボーダー ルータ コンフィギュレーション モードを開始して、ボーダー ルータとの通信を確立します。

ボーダー ルータを識別するために、IP アドレスを設定します。

PfR の管理対象ネットワークを作成するには、少なくとも 1 台のボーダー ルータを指定する必要があります。1 台のマスター コントローラで制御できるボーダー ルータは、最大 10 台です。

引数を入力する必要があります。ただし、既存のボーダー ルータを再設定する場合、このキーワードは省略可能です。

ステップ 5

interface type number external

 

Router(config-oer-mc-br)# interface Ethernet 1/0 external

PfR 管理の外部インターフェイスとしてボーダー ルータを設定し、OER ボーダー出口インターフェイス コンフィギュレーション モードを開始します。

外部インターフェイスは、トラフィックの転送およびアクティブ モニタリングに使用されます。

PfR 管理のネットワークには、最低 2 つの外部ボーダー ルータ インターフェイスが必要です。各ボーダー ルータでは、少なくとも 1 つの外部インターフェイスを設定する必要があります。1 台のマスター コントローラで制御できる外部インターフェイスは、最大 20 です。

形式は慎重に適用してください。

ステップ 6

max-xmit-utilization { absolute kbps | percentage value

 

Router(config-oer-mc-br-if)# max-xmit-utilization absolute 500000

単一の PfR 管理の出口リンクの最大使用率を設定します。

PfR 管理の出口リンクでの絶対最大使用率を kbps 単位で指定するには、 absolute キーワードおよび kbps 引数を使用します。

出口リンクの使用割合を指定するには、 percentage キーワードおよび value 引数を使用します。

ステップ 7

end

 

Router(config-oer-mc-br-if)# end

OER ボーダー出口インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

PfR 出口リンクの使用率範囲の変更

すべてのボーダー ルータで出口リンクの最大使用率範囲のしきい値を変更するには、マスター コントローラで次のタスクを実行します。デフォルトでは、PfR はボーダー ルータ上の外部リンクの使用率を 20 秒ごとに自動監視し、ボーダー ルータがマスター コントローラに使用率を報告します。すべての出口リンク間の使用率範囲が 20% を超えると、マスター コントローラは、一部のトラフィック クラスを別の出口リンクに移動させることによって、トラフィック負荷の均等化を試みます。最大使用率の範囲は、割合として設定されます。

PfR は、最大使用率の範囲を使用して、出口リンクがポリシーに準拠しているかどうかを判断します。PfR は、過剰使用されている、またはポリシー違反の出口から、ポリシー準拠の出口にトラフィック クラスを移動することによって、すべての出口リンクでアウトバウンド トラフィックを均等化します。

インバウンド トラフィックの測定の設定については、 「BGP Inbound Optimization Using Performance Routing」 モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. oer master

4. max-range-utilization percent maximum

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとしてルータを設定し、グローバル処理およびポリシーを設定します。

ステップ 4

max-range-utilization percent maximum

 

Router(config-oer-mc)# max-range-utilization percent 25

すべての PfR 管理の出口リンクに最大使用率の範囲を設定します。

すべての出口リンク間の最大使用率の範囲を指定するには、 percent キーワードおよび maximum 引数を使用します。

この例では、ボーダー ルータ上のすべての出口リンク間の最大使用率の範囲が 25% 以内になるように設定されます。

ステップ 5

end

 

Router(config-oer-mc)# end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

PfR パッシブ モニタリングの設定および確認

PfR 管理のネットワークが作成されているが、パッシブ モニタリングがディセーブルになることもある場合、PfR は、デフォルトでパッシブ モニタリングをイネーブルにします。パッシブ モニタリングを設定してから、パッシブ モニタリングが実行されていることを確認するには、次のタスクを使用します。監視対象プレフィクスまたはアプリケーション トラフィック フローについて NetFlow で収集されたパッシブ測定情報を表示するには、ボーダー ルータで次のタスクを実行します。これらのコマンドは、アプリケーション トラフィックが通過するボーダー ルータで入力します。 show コマンドは、任意の順番で入力できます。

手順の概要

1. enable

2. configure terminal

3. oer master

4. mode monitor { active | both | passive }

5. end

6. show oer border passive cache { applications | learned [ application ] | prefix }

7. show oer border passive prefixes

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 configure terminal

グローバル コンフィギュレーション モードを開始します。

Router# configure terminal
 

ステップ 3 oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとしてルータを設定し、グローバル処理およびポリシーを設定します。

Router(config)# oer master
 

ステップ 4 mode monitor { active | both | passive }

PfR マスター コントローラでルート モニタリングまたはルート制御を設定します。アクティブ モニタリング、パッシブ モニタリング、またはアクティブ モニタリングとパッシブ モニタリングの両方を設定するには、 monitor キーワードを使用します。パッシブ モニタリングは、 both キーワードまたは passive キーワードのいずれかが指定されている場合にイネーブルになります。この例では、パッシブ モニタリングがイネーブルになります。

Router(config-oer-mc)# mode monitor passive
 

ステップ 5 end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

Router(config-oer-mc)# end
 

ステップ 6 show oer border passive cache { applications | learned [ application ] | prefix }

このコマンドは、PfR の監視対象プレフィクスおよびトラフィック フロー用のボーダー ルータから NetFlow によって収集されたリアルタイムのパッシブ測定情報を表示するために使用します。 applications キーワードを指定すると、監視対象アプリケーション トラフィック クラスに関する情報が表示されます。 prefix キーワードを指定すると、監視対象プレフィクスに関する情報が表示されます。 learned キーワードおよび application キーワードを指定すると、学習済みアプリケーションに関する情報を表示できます。次の出力は、 show oer border passive cache prefix コマンドが実行されたボーダー ルータの監視対象プレフィクスおよびトラフィック フローについて NetFlow によって収集されたパッシブ測定情報を示します。

Router# show oer border passive cache prefix
 
OER Passive Prefix Cache, State: enabled, 278544 bytes
1 active, 4095 inactive, 2 added
82 ager polls, 0 flow alloc failures
Active flows timeout in 1 minutes
Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 17416 bytes
2 active, 1022 inactive, 4 added, 2 added to flow
0 alloc failures, 0 force free
1 chunk, 2 chunks added
 
Prefix NextHop Src If Dst If
Flows Pkts B/Pk Active sDly #Dly PktLos #UnRch
------------------------------------------------------------------------------
10.1.5.0/24 10.1.2.2 Et0/0 Et1/0
381 527 40 65.5 300 2 10 1
 

次の出力は、 show oer border passive cache applications コマンドが実行されたボーダー ルータの監視対象アプリケーション トラフィック フローについて NetFlow によって収集されたパッシブ測定情報を示します。

Router# show oer border passive cache applications
 
OER Passive Prefix Cache, State: enabled, 278544 bytes
6 active, 4090 inactive, 384 added
6438 ager polls, 0 flow alloc failures
Active flows timeout in 1 minutes
Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 25800 bytes
18 active, 1006 inactive, 1152 added, 384 added to flow
0 alloc failures, 0 force free
1 chunk, 1 chunk added
 
Prefix NextHop Src If Dst If Flows
Prot DSCP SrcPort DstPort Appl_ID
Pkts B/Pk Active sDly #Dly PktLos #UnRch
------------------------------------------------------------------------
10.1.1.0/24 10.1.1.2 Et8/0 Et0/0 1
17 ef [1, 65535] [3000, 4000] 2
2 28 16.5 0 0 0 0
10.1.3.0/24 10.1.1.2 Et8/0 Et0/0 1
17 ef [1, 65535] [3000, 4000] 1
16 28 19.9 0 0 0 0
 

ステップ 7 show oer border passive prefixes

このコマンドは、PfR の監視対象プレフィクスおよびトラフィック フローについて NetFlow によって収集されたパッシブ測定情報を表示するのに使用されます。次の出力は、 show oer border passive prefixes コマンドが実行されたボーダー ルータについて NetFlow によってパッシブ モニタリングが行われたプレフィクスを示します。

Router# show oer border passive prefixes
 
OER Passive monitored prefixes:
 
Prefix Mask Match Type
10.1.5.0 /24 exact


 

最長一致ターゲット割り当てを使用した PfR アクティブ プローブの設定

最長一致ターゲット割り当てを使用してアクティブ プローブを設定するには、マスター コントローラで次のタスクを実行します。アクティブ モニタリングは、 mode monitor active コマンドまたは mode monitor both コマンドを使用した場合にイネーブルになります。アクティブ プローブのタイプは、 active-probe コマンドを使用して指定します。アクティブ プローブは、特定のホストまたはターゲット アドレスを使用して設定し、このアクティブ プローブはボード ルータをソースとします。アクティブ プローブのソース外部インターフェイスは、最適化されたプレフィクスの優先ルートである場合も、ない場合もあります。この例では、アクティブ モニタリングとパッシブ モニタリングの両方がイネーブルであり、ターゲット IP アドレスの 10.1.5.1 は、Internet Control Message Protocol(ICMP; インターネット制御プロトコル)のエコー(ping)メッセージを使用してアクティブに監視されます。次のタスクでは、IP SLA Responder をイネーブルにする必要はありません。

PfR アクティブ プローブのターゲットへの到達可能性

アクティブ プローブはボーダー ルータをソースとし、外部インターフェイスを介して送信されます(外部インターフェイスは、最適化されたプレフィクスの優先ルートである場合も、ない場合もあります)。指定されたターゲットに対して外部インターフェイス経由のアクティブ プローブを作成する場合は、その外部インターフェイスを介してターゲットに到達できる必要があります。指定されたターゲットの到達可能性をテストするために、PfR は BGP およびスタティック ルーティング テーブルで、所定のターゲットと外部インターフェイスのルート ルックアップを実行します。

ICMP エコー プローブ

ICMP エコー プローブの設定には、ターゲット デバイスからの大きな協力を必要としません。しかし、プローブを繰り返し行うと、ターゲット ネットワーク内で Intrusion Detection System(IDS; 侵入検知システム)アラームが発生することがあります。自身の管理制御下にないターゲット ネットワークで IDS が設定されている場合には、ターゲット ネットワークの管理エンティティに通知することを推奨します。

アクティブ モニタリングがイネーブルの場合には、次のデフォルトが適用されます。

トラフィック クラスが学習済みまたは集約されている場合、ボーダー ルータは、アクティブ プローブを行うために最大 5 個のホスト アドレスをトラフィック クラスから収集します。

アクティブ プローブは、1 分間に 1 回送信されます。

ICMP プローブは、学習済みのトラフィック クラスをアクティブに監視するために使用されます。

手順の概要

1. enable

2. configure terminal

3. oer master

4. mode monitor { active | both | passive }

5. active-probe { echo ip-address | tcp-conn ip-address target-port number | udp-echo ip-address target-port number }

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとしてルータを設定し、グローバル処理およびポリシーを設定します。

ステップ 4

mode monitor { active | both | passive }

 

Router(config-oer-mc)# mode monitor both

PfR マスター コントローラでルート モニタリングを設定します。

アクティブ モニタリング、パッシブ モニタリング、またはその両方を設定するには、 monitor キーワードを使用します。

例では、アクティブ モニタリングとパッシブ モニタリングの両方をイネーブルにします。

ステップ 5

active-probe { echo ip-address | tcp-conn ip-address target-port number | udp-echo ip-address target-port number }

 

Router(config-oer-mc)# active-probe echo 10.1.5.1

ターゲット プレフィクスのアクティブ プローブを設定します。

アクティブ プローブは、パッシブ モニタリングだけを行った場合よりも正確にターゲット プレフィクスの遅延およびジッターを測定します。

アクティブ プローブには、特定のホストまたはターゲット アドレスを設定する必要があります。

アクティブ プローブは、PfR 管理の外部インターフェイスをソースとします。この外部インターフェイスは、最適化されたプレフィクスの優先ルートである場合も、ない場合もあります。

UDP エコー プローブを設定する場合、または 23 以外のポート番号で設定される TCP 接続プローブを設定する場合には、ターゲット デバイス上で対応するポート番号を持つリモート レスポンダを設定する必要があります。リモート レスポンダは、 ip sla monitor responder グローバル コンフィギュレーション コマンドで設定します。

コマンドが、このコマンドに置き換えられました。

ステップ 6

end

 

Router(config-oer-mc)# end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

強制ターゲット割り当てを使用した PfR 音声プローブの設定

PfR ジッター プローブを使用してアクティブ モニタリングをイネーブルにするには、次のタスクを実行します。ジッター プローブのサポートは、Cisco IOS リリース 12.4(6)T および 12.2(33)SRB で導入されました。この例では、監視対象トラフィックは音声トラフィックであり、アクセス リストを使用して識別されます。アクティブ音声プローブは、通常の最長一致割り当てのターゲットではなく、PfR の強制ターゲットを割り当てられます。次のタスクは、Cisco IOS リリース 12.4(6)T および 12.2(33)SRB で追加された別の機能である PfR プローブ頻度の変更方法も示します。

ソース デバイスで PfR ジッター プローブを設定する前に、ターゲット デバイス(動作のターゲット)で IP SLA Responder をイネーブルにする必要があります。IP SLA Responder を使用できるのは、Cisco IOS ソフトウェアベースのデバイスだけです。IP SLA Responder が稼動するネットワーク デバイスで次のタスクを開始します。


) IP SLA Responder が稼動するデバイスは、PfR 用に設定されている必要はありません。


ジッター

ジッターとは、パケット間遅延の分散です。複数のパケットが発信元から宛先に連続的に送信された場合、たとえば 10 ms 間隔で送信された場合、ネットワークが理想的に動作していれば、宛先は 10 ms 間隔でパケットを受信します。しかし、ネットワーク内に遅延(キューイング、代替ルートを介した受信など)が存在する場合、パケット間の到着遅延は、10 ms より大きい場合も、10 ms より小さい場合もあります。この例を使用すると、正のジッター値は、パケットが 10 ms を超える間隔で到着することを示します。パケットが 12 ms 間隔で到着する場合、正のジッターは 2 ms です。パケットが 8 ms 間隔で到着する場合、負のジッターは 2 ms です。Voice over IP(VoIP)など遅延に影響されやすいネットワークでは、正のジッター値は望ましくありません。0 のジッター値が理想的です。

MOS

平均オピニオン評点(MOS)は、PfR アクティブ プローブを使用して測定可能な音声トラフィック向けの定量的な品質メトリックです。すべての要因が音声品質に影響を与えるので、音声品質の測定方法については多くの人々が疑問を持っています。ITU などの標準化団体によって、P.800(MOS)および P.861(Perceptual Speech Quality Measurement(PSQM))という 2 つの重要な勧告が作成されています。P.800 は、音声品質の平均オピニオン評点を算出する方法の定義に関するものです。MOS スコアの範囲は、最低の音声品質を表す 1 から最高を表す 5 までです。MOS 4.0 は、「トール品質」音声と見なされます。

前提条件

次のタスクを続行する前に、アクセス リストを定義する必要があります。アクセス リストの例およびアクティブ プローブを使用した音声トラフィックの設定の詳細については、 「PfR Voice Traffic Optimization Using Active Probes」 ソリューション モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. ip sla monitor responder

4. exit

5. PfR マスター コントローラになっているネットワーク デバイスに移動します。

6. enable

7. configure terminal

8. oer master

9. mode monitor { active | both | passive }

10. exit

11. oer-map map-name sequence-number

12. match ip address { access-list access-list-name | prefix-list prefix-list-name }

13. set active probe probe-type ip-address [ target-port number ] [ codec codec-name ]

14. set probe frequency seconds

15. end

16. show oer master active-probes forced

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip sla monitor responder

 

Router(config)# ip sla monitor responder

IP SLA Responder をイネーブルにします。

ステップ 4

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 5

PfR マスター コントローラになっているネットワーク デバイスに移動します。

ステップ 6

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 7

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、マスター コントローラとしてルータを設定し、グローバル処理およびポリシーを設定します。

ステップ 9

mode monitor { active | both | passive }

 

Router(config-oer-mc)# mode monitor active

PfR マスター コントローラでルート モニタリングを設定します。

アクティブ モニタリング、パッシブ モニタリング、またはその両方を設定するには、 monitor キーワードを使用します。

例では、アクティブ モニタリングがイネーブルになります。

』を参照してください。

ステップ 10

exit

 

Router(config-oer-mc)# exit

OER マスター コントローラ コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

oer-map map-name sequence-number

 

Router(config)# oer-map TARGET_MAP 10

OER マップ コンフィギュレーション モードを開始して、選択した IP プレフィクスにポリシーを適用するように PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

deny シーケンスは最初に IP プレフィクス リストに定義してから、ステップ 12 match ip address (OER)コマンドを使用して適用します。

例では、TARGET_MAP という名前の PfR マップが作成されます。

ステップ 12

match ip address { access-list access-list-name | prefix-list prefix-list-name }

 

Router(config-oer-map)# match ip address access-list VOICE_ACCESS_LIST

PfR マップ内の一致基準として拡張 IP アクセス リストまたは IP プレフィクスを参照します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、VOICE_ACCESS_LIST という名前の IP アクセス リストが、PfR マップ内の一致基準として設定されます。

ステップ 13

set active-probe probe-type ip-address [ target-port number ] [ codec codec-name ]

 

Router(config-oer-map)# set active-probe jitter 10.20.22.1 target-port 2000 codec g729a

set 句エントリを作成して、アクティブ プローブのターゲット プレフィクスを割り当てます。

4 種類のプローブ タイプ(echo、jitter、tcp-conn、または udp-echo)のうち 1 つを指定するには、 probe-type 引数を使用します。

指定したタイプのプローブを使用して監視されるプレフィクスのターゲット IP アドレスを指定するには、 ip-address 引数を使用します。

アクティブ プローブの宛先ポート番号を指定するには、 target-port キーワードおよび number 引数を使用します。

codec キーワードおよび codec-name 引数を使用するのは、ジッター プローブ タイプだけです。平均オピニオン評点(MOS)の計算に使用されるコーデック値を指定します。コーデック値は、g711alaw、g711ulaw、または g729a のいずれかを指定します。

例では、set 句エントリを作成し、ジッターを使用してアクティブに監視するプレフィクスのターゲット IP アドレスと特定のポート番号を指定しています。

ステップ 14

set probe frequency seconds

 

Router(config-oer-map)# set probe frequency 10

set 句エントリを作成して、PfR アクティブ プローブの頻度を設定します。

指定した IP プレフィクスのアクティブ プローブ モニタリングの間隔を秒単位で設定するには、 seconds 引数を使用します。

例では、アクティブ プローブ頻度を 10 秒に設定する set 句を作成しています。

ステップ 15

set jitter threshold maximum

 

Router(config-oer-map)# set jitter threshold 20

set 句エントリを作成して、ジッターしきい値を設定します。

最大ジッター値をミリ秒単位で設定するには threshold キーワードを使用します。

例では、同じ PfR マップ シーケンスで一致するトラフィックのジッターしきい値を 20 に設定する set 句を作成しています。

ステップ 16

set mos { threshold minimum percent percent }

 

Router(config-oer-map)# set mos threshold 4.0 percent 30

set 句エントリを作成して、代替出口を選択するかどうかの判断に使用される MOS しきい値および割合値を設定します。

最低 MOS 値を設定するには threshold キーワードを使用します。

MOS しきい値を下回る MOS 値の割合を設定するには percent キーワードを使用します。

PfR は、5 分間隔で記録された MOS しきい値を下回る MOS 値の割合を計算します。この割合値が、設定した割合値またはデフォルト値を上回る場合、マスター コントローラは代替出口リンクを検索します。

例では、同じ PfR マップ シーケンスで一致するトラフィックのしきい値 MOS 値を 4.0 に設定し、割合値を 30% に設定する set 句を作成しています。

ステップ 17

set delay { relative percentage | threshold maximum }

 

Router(config-oer-map)# set delay threshold 100

set 句エントリを作成して、遅延しきい値を設定します。

遅延しきい値は、相対割合または一致基準の絶対値として設定できます。

相対遅延割合を設定するには relative キーワードを使用します。相対遅延割合は、短期測定値および長期測定値の比較に基づいています。

絶対最大遅延期間をミリ秒単位で設定するには threshold キーワードを使用します。

例では、同じ PfR マップ シーケンスで一致するトラフィックの絶対最大遅延しきい値を 100 ミリ秒に設定する set 句を設定しています。

ステップ 18

end

 

Router(config-oer-map)# end

OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 19

show oer master active-probes [ appl | forced ]

 

Router# show oer master active-probes forced

PfR マスター コントローラ上のアクティブ プローブに関する接続情報およびステータス情報を表示します。

このコマンドからの出力には、アクティブ プローブのタイプおよび宛先、アクティブ プローブのソースであるボーダー ルータ、アクティブ プローブに使用されるターゲット プレフィクス、およびプローブが学習済みだったか、または設定済みだったかが表示されます。

出力をフィルタリングして、マスター コントローラによって最適化されるアプリケーションに関する情報を表示するには、 appl キーワードを使用します。

割り当てられたすべての強制ターゲットを表示するには、 forced キーワードを使用します。

例では、強制ターゲット割り当てで設定された音声トラフィック用に生成されたアクティブ プローブに関する接続情報およびステータス情報が表示されます。

次に、 show oer master active-probes forced コマンドからの出力例を示します。出力はフィルタリングされ、強制ターゲット割り当てで設定された音声トラフィック用に生成されたアクティブ プローブに関する接続情報およびステータス情報だけが表示されます。

Router# show oer master active-probes forced
 
OER Master Controller active-probes
Border = Border Router running this Probe
Policy = Forced target is configure under this policy
Type = Probe Type
Target = Target Address
TPort = Target Port
N - Not applicable
 
The following Forced Probes are running:
 
Border State Policy Type Target TPort
10.20.20.2 ACTIVE 40 jitter 10.20.22.1 3050
10.20.21.3 ACTIVE 40 jitter 10.20.22.4 3050

高速フェールオーバー用 PfR 音声プローブの設定

PfR ジッター プローブを使用して高速モニタリングをイネーブルにするには、次のタスクを実行します。高速フェールオーバー モニタリング モードでは、アクティブ モニタリングとパッシブ モニタリングを使用して、すべての出口が継続的にプローブされます。高速フェールオーバー モニタリング モードのプローブ頻度は、他のモニタリング モードよりも低く設定できます。これにより、より迅速なフェールオーバー機能が可能になります。高速フェールオーバー モニタリングは、すべてのタイプのアクティブ プローブ(ICMP エコー、ジッター、TCP 接続、および UDP エコー)で使用できます。

高速フェールオーバー モニタリングは、パフォーマンス上の問題または輻輳したリンクに非常に影響されやすいトラフィック クラス向けに設計されています。音声トラフィックは、ドロップされたリンクに非常に影響されやすいトラフィックです。この例では、高速フェールオーバー モードがイネーブルになり、IP プレフィクス リストを使用して監視対象の音声トラフィックが識別されます。高速フェールオーバー モードで発生するオーバーヘッドを削減するために、アクティブ音声プローブが PfR の強制ターゲットに割り当てられます。PfR プローブ頻度は、2 秒に設定されます。タスク テーブルの後の例の項では、タスクのステップで指定されたプレフィクスのポリシー設定を表示するために show oer master prefix コマンドが使用され、高速フェールオーバーが設定されていることを表示するためにロギング出力が表示されます。


) 高速モニタリングは、継続的なプローブによって多くのオーバーヘッドが発生する、非常にアグレッシブなモードです。高速モニタリングは、パフォーマンスに影響されやすいトラフィックだけに使用することを推奨します。


ソース デバイスで PfR ジッター プローブを設定する前に、ターゲット デバイス(動作のターゲット)で IP SLA Responder をイネーブルにする必要があります。IP SLA Responder を使用できるのは、Cisco IOS ソフトウェアベースのデバイスだけです。IP SLA Responder が稼動するネットワーク デバイスで次のタスクを開始します。


) IP SLA Responder が稼動するデバイスは、PfR 用に設定されている必要はありません。


手順の概要

1. enable

2. configure terminal

3. ip sla monitor responder

4. exit

5. PfR マスター コントローラになっているネットワーク デバイスに移動します。

6. enable

7. configure terminal

8. ip prefix-list -name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

9. 必要に応じて、追加のプレフィクス リスト エントリについてステップ 8 を繰り返します。

10. oer-map map-name sequence-number

11. match traffic-class prefix-list prefix-list-name

12. set mode monitor { active | both | fast | passive }

13. set jitter threshold maximum

14. set mos { threshold minimum percent percent }

15. set delay { relative percentage | threshold maximum }

16. set active probe probe-type ip-address [ target-port number ] [ codec codec-name ]

17. set probe frequency seconds

18. end

19. show oer master prefix [ prefix [ detail | policy | traceroute [ exit-id | border-address | current ]]]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip sla monitor responder

 

Router(config)# ip sla monitor responder

IP SLA Responder をイネーブルにします。

ステップ 4

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 5

PfR マスター コントローラになっているネットワーク デバイスに移動します。

ステップ 6

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 7

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

 

Router(config)# ip prefix-list VOICE_FAIL_LIST permit 10.1.0.0/24

IP プレフィクス リストを作成します。

ここで指定する IP プレフィクス リストは PfR マップで使用され、トラフィック クラスの宛先 IP アドレスを指定します。

例では、VOICE_FAIL_LIST という名前の IP プレフィクス リストが作成され、PfR で 10.1.0.0/24 プレフィクスのプロファイリングが行われます。

ステップ 9

必要に応じて、追加のプレフィクス リスト エントリについてステップ 4 を繰り返します。

ステップ 10

oer-map map-name sequence-number

 

Router(config)# oer-map FAST_FAIL_MAP 10

OER マップ コンフィギュレーション モードを開始して、選択した IP プレフィクスにポリシーを適用するように PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、FAST_FAIL_MAP という名前の PfR マップが作成されます。

ステップ 11

match traffic-class prefix-list prefix-list-name

 

Router(config-oer-map)# match traffic-class prefix-list VOICE_FAIL_LIST

PfR マップ内の トラフィック クラス一致基準として IP プレフィクス リストを参照します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、VOICE_FAIL_LIST という名前の IP プレフィクス リストが、PfR マップ内の一致基準として設定されます。

ステップ 12

set mode monitor { active | both | fast | passive }

 

Router(config-oer-map)# set mode monitor fast

set 句エントリを作成して、PfR マスター コントローラでルート モニタリングを設定します。

アクティブ モニタリング、パッシブ モニタリング、またはその両方を設定するには、 monitor キーワードを使用します。

継続的なアクティブ モニタリングおよびパッシブ モニタリングがイネーブルである高速フェールオーバー モニタリング モードを設定するには、 fast キーワードを使用します。

例では、高速フェールオーバー モニタリングがイネーブルになります。

ステップ 13

set jitter threshold maximum

 

Router(config-oer-map)# set jitter threshold 12

set 句エントリを作成して、ジッターしきい値を設定します。

最大ジッター値をミリ秒単位で設定するには threshold キーワードを使用します。

例では、同じ PfR マップ シーケンスで一致するトラフィックのジッターしきい値を 12 に設定する set 句が作成されます。

ステップ 14

set mos { threshold minimum percent percent }

 

Router(config-oer-map)# set mos threshold 3.6 percent 30

set 句エントリを作成して、代替出口を選択するかどうかの判断に使用される MOS しきい値および割合値を設定します。

最低 MOS 値を設定するには threshold キーワードを使用します。

MOS しきい値を下回る MOS 値の割合を設定するには percent キーワードを使用します。

PfR は、5 分間隔で記録された MOS しきい値を下回る MOS 値の割合を計算します。この割合値が、設定した割合値またはデフォルト値を上回る場合、マスター コントローラは代替出口リンクを検索します。

例では、同じ PfR マップ シーケンスで一致するトラフィックのしきい値 MOS 値を 3.6 に設定し、割合値を 30% に設定する set 句が作成されます。

ステップ 15

set delay { relative percentage | threshold maximum }

 

Router(config-oer-map)# set delay relative 50

set 句エントリを作成して、遅延しきい値を設定します。

遅延しきい値は、相対割合または一致基準の絶対値として設定できます。

相対遅延割合を設定するには relative キーワードを使用します。相対遅延割合は、短期測定値および長期測定値の比較に基づいています。

絶対最大遅延期間をミリ秒単位で設定するには threshold キーワードを使用します。

例では、同じ PfR マップ シーケンスで一致するトラフィックの相対遅延割合を 50% に設定する set 句が作成されます。

ステップ 16

set active-probe probe-type ip-address [ target-port number ] [ codec codec-name ]

 

Router(config-oer-map)# set active-probe jitter 10.120.120.1 target-port 20 codec g729a

set 句エントリを作成して、アクティブ プローブのターゲット プレフィクスを割り当てます。

4 種類のプローブ タイプ(echo、jitter、tcp-conn、または udp-echo)のうち 1 つを指定するには、 probe-type 引数を使用します。

指定したタイプのプローブを使用して監視されるプレフィクスのターゲット IP アドレスを指定するには、 ip-address 引数を使用します。

アクティブ プローブの宛先ポート番号を指定するには、 target-port キーワードおよび number 引数を使用します。

codec キーワードおよび codec-name 引数を使用するのは、ジッター プローブ タイプだけです。平均オピニオン評点(MOS)の計算に使用されるコーデック値を指定します。コーデック値は、g711alaw、g711ulaw、または g729a のいずれかを指定します。

例では、set 句エントリを作成し、ジッターを使用してアクティブに監視するプレフィクスのターゲット IP アドレスと特定のポート番号を指定しています。

ステップ 17

set probe frequency seconds

 

Router(config-oer-map)# set probe frequency 2

set 句エントリを作成して、PfR アクティブ プローブの頻度を設定します。

指定した IP プレフィクスのアクティブ プローブ モニタリングの間隔を秒単位で設定するには、 seconds 引数を使用します。

例では、アクティブ プローブ頻度を 2 秒に設定する set 句が作成されます。

(注) ステップ 12 で高速フェールオーバー モードがイネーブルになっているため、ここでは、4 秒未満のプローブ頻度も設定可能です。

ステップ 18

end

 

Router(config-oer-map)# end

OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 19

show oer master prefix [ prefix [ detail | policy | traceroute [ exit-id | border-address | current ]]]

 

Router# show oer master prefix 10.1.1.0/24 policy

(任意)監視対象プレフィクスのステータスを表示します。

prefix 引数は、IP アドレスおよびビット長マスクとして入力します。

指定したプレフィクスのポリシー情報を表示するには、 policy キーワードを使用します。

例では、10.1.1.0/24 プレフィクスのポリシー情報が表示されます。

この例は、ポリシー キーワードを使用してプレフィクスを指定し、 10.1.1.0/24 プレフィクスに設定したポリシーを表示するときの、 show oer master prefix コマンドからの出力を示します。mode monitor は fast に設定されています。したがって、select-exit は自動的に best に設定され、probe frequency を 2 に設定できます。

Router# show oer master prefix 10.1.1.0/24 policy
 
* Overrides Default Policy Setting
oer-map MAP 10
sequence no. 8444249301975040, provider id 1, provider priority 30
host priority 0, policy priority 10, Session id 0
match ip prefix-lists: VOICE_FAIL_LIST
backoff 90 90 90
delay relative 50
holddown 90
periodic 0
*probe frequency 2
mode route control
*mode monitor fast
*mode select-exit best
loss relative 10
*jitter threshold 12
mos threshold 3.60 percent 30
unreachable relative 50
next-hop not set
forwarding interface not set
resolve jitter priority 1 variance 10
resolve utilization priority 12 variance 20
 
Forced Assigned Target List:
active-probe jitter 10.120.120.1 target-port 20 codec g729a
 

次のタスクに示されるように、マスター コントローラが高速フェールオーバー用に設定された後でトラフィック クラスがポリシー違反を犯すと、次のロギング出力に、10.1.1.0 プレフィクスで表されるトラフィック クラスが、PfR によって 3 秒以内に 10.3.3.4 インターフェイスの新しいボーダー ルータ出口を経由してルーティングされることが表示されます。ロギング出力から、トラフィック クラスは、ジッターしきい値を超えたためにポリシー違反状態になったと考えられます。

May 2 10:55:27.355: %OER_MC-5-NOTICE: Active ABS Jitter OOP Prefix 10.1.1.0/24,
jitter 15, BR 10.4.4.2, i/f Et2/0
May 2 10:55:27.367: %OER_MC-5-NOTICE: Route changed Prefix 10.1.1.0/24, BR 10.3.3.4,
i/f Et5/0, Reason Jitter, OOP Reason Jitter
 

アクティブ プローブのソース アドレスの設定

アクティブ プローブのソース インターフェイスを指定するには、ボーダー ルータで次のタスクを実行します。アクティブ プローブのソース インターフェイスは、ボーダー ルータ上で設定します。OER ボーダー ルータ コンフィギュレーション モードで、 active-probe address source を使用します。アクティブ プローブのソース インターフェイス IP アドレスは、プローブ応答が指定したソース インターフェイスに必ず戻されるようにするために、一意である必要があります。

デフォルトの動作は、次のとおりです。

このコマンドがイネーブルではない、または no 形式を入力した場合、ソース IP アドレスは、アクティブ プローブを送信するデフォルトの PfR 外部インターフェイスから使用されます。

インターフェイスに IP アドレスが設定されていない場合、アクティブ プローブは生成されません。

インターフェイスがアクティブ プローブのソースとして設定された後で IP アドレスが変更されると、アクティブ プローブは停止します。その後、新しい IP アドレスで再開します。

インターフェイスがアクティブ プローブのソースとして設定された後で IP アドレスが削除されると、アクティブ プローブは停止します。有効なプライマリ IP アドレスが設定されるまで再開しません。

手順の概要

1. enable

2. configure terminal

3. oer border

4. active-probe address source interface type number

5. end

6. show oer border active-probes

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer border

 

Router(config)# oer border

OER ボーダー ルータ コンフィギュレーションモードを開始して、ルータをボーダー ルータとして設定します。

ステップ 4

active-probe address source interface type number

 

Router(config-oer-br)# active-probe address source interface FastEthernet 0/0

ボーダー ルータ上のインターフェイスをアクティブ プローブのソースとして設定します。

例では、FastEthernet 0/0 インターフェイスがソース インターフェイスとして設定されます。

ステップ 5

end

 

Router(config-oer-br)# end

OER ボーダー ルータ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 6

show oer border active-probes

 

Router# show oer border active-probes

PfR ボーダー ルータ上のアクティブ プローブに関する接続ステータスおよび情報を表示します。

このコマンドを使用すると、設定されたソース IP アドレスを確認できます。

PfR ポリシーの設定および学習済みトラフィック クラスへの適用

PfR ポリシーを設定し、学習済みトラフィック クラスに適用するには、マスター コントローラで次のタスクを実行します。 oer master コマンドを使用して PfR マスター コントローラをルートとして設定した後は、次のタスクのほとんどのコマンドは省略可能です。各ステップでは、グローバル ベースで学習済みトラフィック クラスに適用されるパフォーマンス ポリシーが設定されます。この例では、PfR は、ポリシー準拠の最初の出口を選択するように設定されます。

次のタスクでは、一部の PfR タイマーが変更されます。PfR タイマーの調整を行う際は、新しい設定値が残り時間よりも少ないと、既存の設定はただちに新しいタイマー設定に置き換えられることに注意してください。値が残り時間よりも多い場合、既存タイマーが期限切れになるか、リセットされると、新しい設定が適用されます。


) 極端なタイマー設定を行うと、出口リンクまたはトラフィック クラス エントリがポリシー違反状態になることがあります。


手順の概要

1. enable

2. configure terminal

3. oer master

4. backoff min-timer max-timer [ step-timer ]

5. delay { relative percentage | threshold maximum }

6. holddown timer

7. loss { relative average | threshold maximum }

8. periodic timer

9. unreachable { relative average | threshold maximum }

10. mode select-exit { best | good }

11. end

12. show oer master policy [ sequence-number | policy-name | default ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始します。

ステップ 4

backoff min-timer max-timer [ step-timer ]

 

Router(config-oer-mc)# backoff 400 4000 400

(任意)バックオフ タイマーを設定して、ポリシー決定期間を調整します。

最低移行期間を秒単位で設定するには、 min-timer 引数を使用します。

トラフィック クラス エントリのポリシー要件を満たすリンクがない場合に PfR がポリシー違反トラフィック クラスを保持する最大期間を設定するには、 max-timer 引数を使用します。

step-timer 引数を使用すると、最大制限時間に達するまで最低タイマーの期限が切れるたびに時間を追加するように PfR を任意で設定できます。

ステップ 5

delay { relative percentage | threshold maximum }

 

Router(config-oer-mc)# delay relative 80

(任意)遅延しきい値を相対割合または絶対値で設定します。

相対遅延割合を設定するには relative キーワードを使用します。相対遅延割合は、短期測定値および長期測定値の比較に基づいています。

絶対最大遅延期間をミリ秒単位で設定するには threshold キーワードを使用します。

設定した遅延しきい値を超えると、プレフィクスはポリシー違反になります。

例では、相対平均に基づいて 80% の遅延しきい値が設定されます。

ステップ 6

holddown timer

 

Router(config-oer-mc)# holddown 600

(任意)トラフィック クラス エントリのルート ダンプニング タイマーを設定して、代替出口が選択可能になる前に新しい出口の使用が必要な最低期間を設定します。

トラフィック クラス エントリがホールドダウン状態の間は、PfR はルート変更を実行できません。

ホールドダウン タイマーの期限が切れると、PfR は、パフォーマンスおよびポリシー設定に基づいて最良の出口を選択します。

トラフィック クラス エントリの現在の出口が到達不能になると、PfR は、代替パスの検索プロセスを開始します。

例では、トラフィック クラス エントリのダンプニング タイマーが 600 秒に設定されます。

ステップ 7

loss { relative average | threshold maximum }

 

Router(config-oer-mc)# loss relative 20

(任意)PfR がトラフィック クラス エントリに許可する相対パケット損失または最大パケット損失を設定します。

relative キーワードは、短期間のパケット損失割合および長期間のパケット損失割合の比較に基づいてパケットの相対割合を設定します。

threshold キーワードは、絶対パケット数(百万パケットあたりのパケット数)を設定します。

例では、パケット損失の比較割合が 20% 以上の場合にマスター コントローラが新しい出口リンクを検索するように設定されます。

ステップ 8

periodic timer

 

Router(config-oer-mc)# periodic 300

(任意)周期タイマーの期限が切れると、最良の出口リンクを定期的に選択するように PfR を設定します。

このコマンドがイネーブルの場合、マスター コントローラが定期的に評価し、トラフィック クラスのポリシー決定を行います。

例では、周期タイマーが 300 秒に設定されます。タイマーの期限が切れると、PfR は最良の出口またはポリシー準拠の最初の出口のいずれかを選択します。

コマンドを使用します。

ステップ 9

unreachable { relative average | threshold maximum }

 

Router(config-oer-mc)# unreachable relative 10

(任意)到達不能ホストの最大数を設定します。

このコマンドは、PfR がトラフィック エントリに許可する到達不能ホストの相対割合または最大数(100 万フローあたりのフロー数(fpm))を指定するために使用します。到達不能ホストの絶対数または相対割合がユーザ定義の値またはデフォルト値を超える場合、PfR はトラフィック クラス エントリが OOP であると判断し、代替出口リンクを検索します。

到達不能ホストの相対割合を設定するには relative キーワードを使用します。到達不能ホストの相対割合は、短期測定値および長期測定値の比較に基づいています。

到達不能ホストの絶対最大数を fpm に基づいて設定するには threshold キーワードを使用します。

例では、到達不能ホストの相対割合が 10% 以上の場合にトラフィック クラス エントリの新しい出口リンクを検索するように PfR が設定されます。

ステップ 10

mode select-exit { best | good }}

 

Router(config-oer-mc)# mode select-exit good

パフォーマンスまたはポリシーに基づいて、出口リンクを選択できるようにします。

マスター コントローラが、 best キーワードが入力されたときに利用可能な最良の出口を選択するか、 good キーワードが入力されたときにポリシー準拠の最初の出口を選択するかを設定するには select-exit キーワードを使用します。

ステップ 11

end

 

Router(config-oer-mc)# end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

ステップ 12

show oer master policy [ sequence-number | policy-name | default ]

 

Router# show oer master policy

PfR マスター コントローラ上のポリシー設定を表示します。

このコマンドの出力では、デフォルトのポリシーおよび任意で PfR マップに設定されているポリシーが表示されます。

指定した PfR マップ シーケンスのポリシー設定を表示するには sequence-number 引数を使用します。

指定した PfR ポリシー マップ名のポリシー設定を表示するには policy-name 引数を使用します。

デフォルトのポリシー設定だけを表示するには、 default キーワードを使用します。

例では、デフォルトのポリシー設定および次のタスクの設定によって更新されたポリシー設定が表示されます。

次に、 show oer master policy コマンドからの出力例を示します。次のタスクの設定によって特定のポリシー設定が上書きされた部分を除いて、デフォルトのポリシー設定が表示されます。

Router# show oer master policy
 
Default Policy Settings:
backoff 400 4000 400
delay relative 80
holddown 600
periodic 300
probe frequency 56
mode route observe
mode monitor both
mode select-exit good
loss relative 20
unreachable relative 10
resolve delay priority 11 variance 20
resolve utilization priority 12 variance 20
*tag 0

学習済みプレフィクスの PfR 最適化の防止

PfR が指定した学習済みプレフィクスを最適化しないようにするために PfR ポリシーを設定および適用するには、マスター コントローラで次のタスクを実行します。次のタスクは、PfR 最適化から除外する一部のプレフィクスが判明しているものの、これらのプレフィクスが PfR で自動的に学習される場合に便利です。次のタスクでは、IP プレフィクス リストは、最適化されない異なるプレフィクスに対する 2 つのエントリで設定されます。PfR マップは、1 つのシーケンスの 2 つのエントリで設定されます。これによって、プレフィクスは学習されますが、PfR は、プレフィクス リストで指定したプレフィクスを最適化しなくなります。PfR マップ エントリのシーケンス番号が逆方向になった場合、PfR はプレフィクスを学習し、プレフィクスの最適化を試みます。

手順の概要

1. enable

2. configure terminal

3. ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

4. ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

5. oer-map map-name sequence-number

6. match ip address prefix-list prefix-list-name

7. oer-map map-name sequence-number

8. match oer learn { delay | inside | throughput }

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network / length } [ le le-value ]

 

Router(config)# ip prefix-list DENY_LIST deny 10.1.1.0/24

IP プレフィクス リストを作成します。

IP プレフィクス リストは、マスター コントローラによるモニタリング用のプレフィクスを手動で拒否する、または許可するために使用されます。

IP プレフィクス リストで指定されたプレフィクスは、 match ip address (OER)コマンドで PfR マップにインポートされます。

例では、10.1.1.0/24 サブネットからのプレフィクスだけを拒否するエントリを含む IP プレフィクス リストが作成されます。

ステップ 4

ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network / length } [ le le-value ]

 

Router(config)# ip prefix-list DENY_LIST deny 172.20.1.0/24

IP プレフィクス リストを作成します。

IP プレフィクス リストは、マスター コントローラによるモニタリング用のプレフィクスを手動で拒否する、または許可するために使用されます。

IP プレフィクス リストで指定されたプレフィクスは、 match ip address (OER)コマンドで PfR マップにインポートされます。

例では、172.20.1.0/24 サブネットからのプレフィクスだけを拒否する IP プレフィクス エントリが作成されます。

ステップ 5

oer-map map-name sequence-number

 

Router(config)# oer-map DENY_MAP 10

OER マップ コンフィギュレーション モードを開始して、選択した IP プレフィクスにポリシーを適用するように PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

deny シーケンスは最初に IP プレフィクス リストに定義してから、ステップ 6 match ip address (OER)コマンドを使用して適用します。

例では、シーケンス番号が 10 の DENY_MAP という名前の PfR マップが作成されます。

ステップ 6

match ip address { access-list access-list-name | prefix-list prefix-list-name }

 

Router(config-oer-map)# match ip address prefix-list DENY_LIST

PfR マップ内の一致基準として拡張 IP アクセス リストまたは IP プレフィクス リストを参照します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、DENY_LIST という名前のプレフィクス リストが、PfR マップ内の一致基準として設定されます。

ステップ 7

exit

 

Router(config-oer-map)# exit

OER マップ コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

oer-map map-name sequence-number

 

Router(config)# oer-map DENY_MAP 20

PfR マップ エントリを入力します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

deny シーケンスは最初に IP プレフィクス リストに定義してから、ステップ 9 match ip address (OER)コマンドを使用して適用します。

例では、シーケンス番号が 20 の DENY_MAP という名前の PfR マップの PfR マップ エントリを作成します。

ステップ 9

match oer learn { delay | inside | throughput }

 

Router(config-oer-map)# match oer learn throughput

学習済みの PfR プレフィクスに一致させるために、PfR マップ内で match 句エントリを作成します。

PfR は、最高遅延または最高アウトバウンド スループットに基づいた内部プレフィクスまたはプレフィクスであるトラフィック クラスを学習するように設定できます。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、最高スループットに基づいて学習されたトラフィック クラスに一致する match 句エントリが作成されます。

ステップ 10

end

 

Router(config-oer-map)# end

(任意)OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

PfR マップ用ポリシー ルールの設定

PfR マップを選択し、OER マスター コントローラ コンフィギュレーション モードでこの設定を適用するには、次のタスクを実行します。 policy-rules コマンドを使用すると、定義済み PfR マップ間の切り替えを容易に実行できます。

前提条件

少なくとも 1 つの PfR マップを設定しなければ、ポリシー ルールのサポートはイネーブルにできません。

手順の概要

1. enable

2. configure terminal

3. oer master

4. policy-rules map-name

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始して、グローバル プレフィクスおよび出口リンク ポリシーを設定します。

ステップ 4

policy-rules map-name

 

Router(config-oer-mc)# policy-rules RED

OER マスター コントローラ コンフィギュレーション モードで、PfR マップからマスター コントローラ コンフィギュレーションに設定を適用します。

新しい PfR マップ名でこのコマンドを再入力すると、以前の設定がただちに上書きされます。この動作は、定義済みの PfR 間での迅速な選択および切り替えを可能にするように設計されています。

例では、RED という名前の PfR マップから設定が適用されます。

ステップ 5

end

 

Router(config-oer-mc)# end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

複数 PfR ポリシーの競合解決の設定

PfR 解決機能を使用して、最初に実行される PfR ポリシーに関する競合を回避するためのプライオリティをポリシーに割り当てるには、次のタスクを実行します。各ポリシーに一意の値が割り当てられ、最高値を設定されたポリシーが最高プライオリティとして選択されます。デフォルトでは、遅延ポリシーに最高プライオリティが設定され、トラフィック負荷(使用率)ポリシーに 2 番目に高いプライオリティが設定されます。いずれかのポリシーにプライオリティ値を割り当てると、デフォルト設定が上書きされます。

手順の概要

1. enable

2. configure terminal

3. oer master

4. resolve { cost priority value | delay priority value variance percentage | loss priority value variance percentage | range priority value | utilization priority value variance percentage }

5. ステップ 4 を繰り返して、必要な各 PfR ポリシーにプライオリティを割り当てます。

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

oer master

 

Router(config)# oer master

OER マスター コントローラ コンフィギュレーション モードを開始します。

ステップ 4

resolve { cost priority value | delay priority value variance percentage | loss priority value variance percentage | range priority value | utilization priority value variance percentage }

 

Router(config-oer-mc)# resolve loss priority 2 variance 10

ポリシー プライオリティを設定するか、ポリシーの競合を解決します。

このコマンドは、同じプレフィクスに対して複数のポリシーが設定されている場合にプライオリティを設定するために使用されます。このコマンドが設定されている場合、最高プライオリティのポリシーが選択されて、ポリシー決定を行います。

プライオリティ値を指定するには、 priority キーワードを使用します。1 という番号を設定すると、ポリシーに最高プライオリティが割り当てられます。10 という番号を設定すると、最低プライオリティが割り当てられます。

各ポリシーには、異なるプライオリティ番号を割り当てる必要があります。

ユーザ定義のポリシーに許容分散を設定するには、 variance キーワードを使用します。このキーワードでは、出口リンクまたはプレフィクスがユーザ定義のポリシー値と異なっても、まだ同等であると見なす許容割合が設定されます。

例では、損失ポリシーのプライオリティが、10% の分散で 2 に設定されます。

(注) 範囲またはコスト ポリシーには分散を設定できません。

』を参照してください。

ステップ 5

ステップ 4 を繰り返して、必要な各 PfR ポリシーにプライオリティを割り当てます。

ステップ 6

end

 

Router(config-oer-mc)# end

OER マスター コントローラ コンフィギュレーション モードを終了して、特権 EXEC モードを開始します。

PfR マップを使用したブラック ホール ルーティングの設定

ヌル インターフェイスに転送されるパケット、つまり、「ブラック ホール」に廃棄されるパケットをフィルタリングするために PfR マップを設定するには、次のタスクを実行します。IP プレフィクスが、ネットワーク上の攻撃のソースとして識別されると、プレフィクス リストが設定されます。BGP など一部のプロトコルでは、バック ホール ルートの再配布が許可されますが、他のプロトコルでは許可されません。

この省略可能なタスクを実行すると、ネットワーク上での攻撃を阻止したり、軽減したりできます。

手順の概要

1. enable

2. configure terminal

3. ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

4. oer-map map-name sequence-number

5. match ip address { access-list access-list-name | prefix-list prefix-list-name }

6. set interface null0

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network / length } [ le le-value ]

 

Router(config)# ip prefix-list BLACK_HOLE_LIST seq 10 permit 10.20.21.0/24

IP プレフィクス リストを作成します。

IP プレフィクス リストは、PfR マスター コントローラでモニタリングするプレフィクスを手動で選択するために使用されます。

マスター コントローラは、デフォルト ルートを含む任意の長さの、完全に一致するプレフィクスを監視し、制御できます。完全に一致するプレフィクスが指定される場合、PfR は、この完全に一致するプレフィクスだけを監視します。

マスター コントローラは、 le キーワードを使用して 32 に設定された包含プレフィクスを監視し、制御できます。PfR は、設定されたプレフィクスおよびより限定されたプレフィクス(たとえば、10.0.0.0/8 le 32 プレフィクスを設定すると、10.1.0.0/16 プレフィクスおよび 10.1.1.0/24 プレフィクスを含みます)を同じ出口で監視し、この情報をルーティング情報ベース(RIB)に記録します。

IP プレフィクス リストで指定されたプレフィクスは、 match ip address (OER)コマンドを使用して PfR マップにインポートします。

例では、10.20.21.0/24 サブネットからのプレフィクスを許可する、BLACK_HOLE_LIST という名前の IP プレフィクス リストが作成されます。

ステップ 4

oer-map map-name sequence-number

 

Router(config)# oer-map BLACK_HOLE_MAP 10

OER マップ コンフィギュレーション モードを開始して、選択した IP プレフィクスにポリシーを適用するように PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

deny シーケンスは最初に IP プレフィクス リストに定義してから前のステップで match ip address (OER)コマンドを使用して適用します。

例では、BLACK_HOLE_MAP という名前の PfR マップが作成されます。

ステップ 5

match ip address { access-list access-list-name | prefix-list prefix-list-name }

 

Router(config-oer-map)# match ip address prefix-list BLACK_HOLE_LIST

PfR マップ内の一致基準として拡張 IP アクセス リストまたは IP プレフィクスを参照します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、PfR マップ内の一致基準として BLACK_HOLE_LIST という名前の IP プレフィクス リストが、設定されます。

ステップ 6

set interface null0

 

Router(config-oer-map)# set interface null0

set 句エントリを作成して、パケットをヌル インターフェイスに転送します(つまり、パケットが廃棄されます)。

例では、BLACK_HOLE_LIST プレフィクス リストに一致するパケットが廃棄されるように指定するための set 句エントリが作成されます。

ステップ 7

end

 

Router(config-oer-map)# end

(任意)OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

PfR マップを使用したシンクホール ルーティングの設定

PfR マップを設定して、ネクスト ホップに転送されるパケットをフィルタリングするには、次のタスクを実行します。ネクスト ホップは、パケットの保存、分析、または廃棄を実行できるルータです(シンクホール アナロジー)。IP プレフィクスがネットワーク上の攻撃のソースとして識別されると、プレフィクス リストが設定されます。

この省略可能なタスクを実行すると、ネットワーク上での攻撃を阻止したり、軽減したりできます。

手順の概要

1. enable

2. configure terminal

3. ip prefix-list list-name [ seq seq-value ] { deny network/length | permit network/length } [ le le-value ]

4. oer-map map-name sequence-number

5. match ip address { access-list access-list-name | prefix-list prefix-list-name }

6. set next-hop ip-address

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip prefix-list list-name [ seq seq-value ] { deny network / length | permit network / length } [ le le-value ]

 

Router(config)# ip prefix-list SINKHOLE_LIST seq 10 permit 10.20.21.0/24

IP プレフィクス リストを作成します。

IP プレ フィクス リストは、PfR マスター コントローラでモニタリングするプレフィクスを手動で選択するために使用されます。

マスター コントローラは、デフォルト ルートを含む任意の長さの、完全に一致するプレフィクスを監視し、制御できます。完全に一致するプレフィクスが指定される場合、PfR は、この完全に一致するプレフィクスだけを監視します。

マスター コントローラは、 le キーワードを使用して 32 に設定された包含プレフィクスを監視し、制御できます。PfR は、設定されたプレフィクスおよびより限定されたプレフィクス(たとえば、10.0.0.0/8 le 32 プレフィクスを設定すると、10.1.0.0/16 プレフィクスおよび 10.1.1.0/24 プレフィクスを含みます)を同じ出口で監視し、この情報をルーティング情報ベース(RIB)に記録します。

IP プレフィクス リストで指定されたプレフィクスは、 match ip address (OER)コマンドを使用して PfR マップにインポートします。

例では、10.20.21.0/24 サブネットからのプレフィクスを許可する、SINKHOLE_LIST という名前の IP プレフィクス リストが作成されます。

ステップ 4

oer-map map-name sequence-number

 

Router(config-oer-mc)# oer-map SINKHOLE_MAP 10

OER マップ コンフィギュレーション モードを開始して、選択した IP プレフィクスにポリシーを適用するように PfR マップを設定します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

deny シーケンスは最初に IP プレフィクス リストに定義してから前のステップで match ip address (OER)コマンドを使用して適用します。

例では、SINKHOLE_MAP という名前の PfR マップが作成されます。

ステップ 5

match ip address { access-list access-list-name | prefix-list prefix-list-name }

 

Router(config-oer-map)# match ip address prefix-list SINKHOLE_LIST

PfR マップ内の一致基準として拡張 IP アクセス リストまたは IP プレフィクスを参照します。

各 PfR マップ シーケンスには、match 句を 1 つだけ設定できます。

例では、PfR マップ内の一致基準として SINKHOLE_LIST という名前の IP プレフィクス リストが設定されます。

ステップ 6

set next-hop ip-address

 

Router(config-oer-map)# set next-hop 10.20.21.6

パケットがネクスト ホップに転送されるように指定する set 句エントリを作成します。

例では、SINKHOLE_LIST プレフィクス リストに一致するパケットが 10.20.21.6 のネクスト ホップに転送されるように指定するための set 句エントリが作成されます。

ステップ 7

end

 

Router(config)# end

(任意)OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

施行フェーズのタスク

次のタスクは、PfR ポリシーの設定および適用フェーズの要素の設定方法を示します。

「アプリケーション トラフィックの制御」

アプリケーション トラフィックの制御

アプリケーション トラフィックを制御するには、マスター コントローラで次のタスクを実行する必要があります。次のタスクは、ポリシーベース ルーティング(PBR)を使用して、指定したアプリケーション トラフィック クラスを PfR で制御できるようにする方法を示します。拡張 IP アクセス リストで permit 文を使用したフィルタリングが可能なアプリケーション トラフィックを設定するための、アプリケーション アウェア ポリシー ルーティング。

Telnet トラフィックなどのアプリケーション トラフィックは遅延に影響されやすいので、TCP 遅延が長い場合は、Telnet セッションの使用が困難になることがあります。次のタスクでは、Telnet トラフィックを許可するために拡張 IP アクセス リストが設定されます。PfR マップは、192.168.1.0/24 ネットワークをソースとする Telnet トラフィックに一致させるために match 句を参照する拡張アクセス リストで設定されます。PfR ルート制御がイネーブルになり、遅延ポリシーが設定されて、Telnet トラフィックが 30 ミリ秒以下の応答時間で出口リンクを経由して送信されるようになります。この設定は、 show oer master appl コマンドを使用して確認します。

制約事項

ボーダー ルータは、シングルホップのピアである必要があります。

名前付き拡張 IP アドレス リストだけがサポートされます。

アプリケーション トラフィックの最適化は、CEF スイッチング パス上での PfR だけでサポートされます。

手順の概要

1. enable

2. configure terminal

3. ip access-list { standard | extended } access-list-name }

4. [ sequence-number ] permit protocol source source-wildcard destination destination-wildcard [ option option-name ] [ precedence precedence ] [ tos tos ] [ ttl operator value ] [ log ] [ time-range time-range-name ] [ fragments ]

5. exit

6. oer-map map-name sequence-number

7. match ip address { access-list name | prefix-list name }

8. set mode route control

9. set delay { relative percentage | threshold maximum }

10. set resolve { cost priority value | delay priority value variance percentage | loss priority value variance percentage | range priority value | utilization priority value variance percentage }

11. end

12. show oer master appl [ access-list name ] [ detail ] | [ tcp | udp ] [ protocol-number ] [ min-port max-port ] [ dst | src ] [ detail | policy ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip access-list { standard | extended } access-list-name }

 

Router(config)# ip access-list extended TELNET_ACL

拡張アクセス リストを作成し、拡張アクセス リスト コンフィギュレーション モードを開始します。

名前付きアクセス リストだけがサポートされます。

ステップ 4

[ sequence-number ] permit protocol source source-wildcard destination destination-wildcard [ option option-name ] [ precedence precedence ] [ tos tos ] [ ttl operator value ] [ log ] [ time-range time-range-name ] [ fragments ]

 

Router(config-ext-nacl)# permit tcp 192.168.1.0 0.0.0.255 any eq telnet

拡張アクセス リストを定義します。

任意のプロトコル、ポート、またはその他の IP パケット ヘッダー値を指定できます。

例では、192.168.1.0/24 ネットワークをソースとする Telnet トラフィックが許可されます。

ステップ 5

exit

 

Router(config-ext-nacl)# exit

拡張アクセス リスト コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

oer-map map-name sequence-number

 

Router(config# oer-map BLUE

OER マップ コンフィギュレーション モードを開始して、PfR マップを設定します。

ステップ 7

match ip address { access-list name | prefix-list name }

 

Router(config-oer-map)# match ip address access-list TELNET

PfR マップ内の一致基準として拡張 IP アクセス リストまたは IP プレフィクスを参照します。

拡張 IP アクセス リストは、監視対象プレフィクスからトラフィックのサブセットをフィルタリングするために使用されます。

ステップ 8

set mode route control

 

Router(config-oer-map)# set mode route control

一致したトラフィックのルート制御を設定するために、set 句エントリを作成します。

制御モードでは、マスター コントローラが監視対象プレフィクスを分析し、ポリシー パラメータに基づいて変更を実行します。

この例では、PfR 制御モードをイネーブルにする set 句を作成しています。

ステップ 9

set delay { relative percentage | threshold maximum }

 

Router(config-oer-map)# set delay threshold 30

(任意)PfR が遅延しきい値を設定するように PfR マップを設定します。

この例では、遅延ポリシーを設定しています。他のポリシーも設定できます。

Telnet トラフィックの遅延しきい値が 30 ミリ秒に設定されます。

ステップ 10

set resolve { cost priority value | delay priority value variance percentage | loss priority value variance percentage | range priority value | utilization priority value variance percentage }

 

Router(config-oer-map)# set resolve delay priority 1 variance 20

(任意)ポリシーを上書きするためにポリシー プライオリティを設定するように PfR マップを設定します。

解決ポリシーは、遅延ポリシーを 20% の分散の最高プライオリティに設定します。

ステップ 11

end

 

Router(config-oer-map)# end

OER マップ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

ステップ 12

show oer master appl [ access-list name ] [ detail ] | [ tcp | udp ] [ protocol-number ] [ min-port max-port ] [ dst | src ] [ detail | policy ]

 

Router# show oer master appl tcp 23 23 dst policy

(任意)PfR マスター コントローラによって監視され、制御されるアプリケーションに関する情報を表示します。

次の例では、ポート 23(Telnet)に基づいてフィルタリングされる TCP アプリケーション トラフィックを表示する、 show oer master appl コマンドの出力を示します。

Router# show oer master appl tcp 23 23 dst policy
 
Prefix Appl Prot Port Port Type Policy
--------------------------------------------------------------------------------
10.1.1.0/24 tcp [23, 23] src 10

確認フェーズのタスク

次のタスクは、PfR 確認フェーズの要素の設定方法を示します。

「PfR ルート強制変更の手動確認」

PfR ルート強制変更の手動確認

PfR は、NetFlow 出力を使用して、ネットワーク内のルート強制変更を自動的に確認します。PfR は NetFlow メッセージを監視し、メッセージでルート強制変更を確認できない場合は、トラフィック クラスを制御しません。PfR 施行フェーズで実行されたトラフィック制御が実際にトラフィック フローを変更し、OOP イベントをポリシー準拠に変更したことを手動で確認する場合は、この任意のタスクのステップを実行します。すべてのステップは任意ですが、順番は任意ではありません。これらのステップから得られる情報では、トラフィック クラスに関連付けられた特定のプレフィクスが、別の出口リンク インターフェイスまたは入口リンク インターフェイスに移動されたか、または PfR によって制御されているかを確認できます。最初の 3 つのコマンドは、マスター コントローラで入力します。最後の 2 つのコマンドは、ボーダー ルータで入力します。他の OER 表示コマンドの詳細については、『 Cisco IOS Optimized Edge Routing Command Reference 』を参照してください。

手順の概要

1. enable

2. show logging [ slot slot-number | summary ]

3. show oer master prefix prefix [ detail ]

4. ボーダー ルータに移動して、次のステップを開始します。

5. enable

6. show oer border routes { bgp | static }

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show logging [ slot slot-number | summary ]

このコマンドは、システム ロギング(syslog)の状態および標準的なシステム ロギング バッファの内容を表示するために使用します。省略可能な区切り文字を使用したこの例では、OOP であり、ルート変更が行われた 10.1.1.0 プレフィクスについての PfR メッセージが含まれるロギング バッファが示されます。

Router# show logging | i 10.1.1.0
 
*Apr 26 22:58:20.919: %OER_MC-5-NOTICE: Discovered Exit for prefix 10.1.1.0/24, BR
10.10.10.1, i/f Et9/0
*Apr 26 23:03:14.987: %OER_MC-5-NOTICE: Route changed 10.1.1.0/24, BR 10.10.10.1, i/f
Se12/0, Reason Delay, OOP Reason Timer Expired
*Apr 26 23:09:18.911: %OER_MC-5-NOTICE: Passive REL Loss OOP 10.1.1.0/24, loss 133, BR
10.10.10.1, i/f Se12/0, relative loss 23, prev BR Unknown i/f Unknown
*Apr 26 23:10:51.123: %OER_MC-5-NOTICE: Route changed 10.1.1.0/24, BR 10.10.10.1, i/f
Et9/0, Reason Delay, OOP Reason Loss
 

ステップ 3 show oer master prefix prefix [ detail ]

このコマンドは、監視対象プレフィクスの状態を表示するために使用します。このコマンドからの出力には、送信元ボーダー ルータ、現在の出口インターフェイス、プレフィクス遅延、出口インターフェイスの帯域幅、および入口インターフェイスの帯域幅に関する情報が含まれています。この例では、出力で 10.1.1.0 プレフィクスのフィルタリングが行われ、現在ホールドダウン状態のプレフィクスが表示されます。このステップでは、次のタスクに関連する構文だけを示します。

Router# show oer master prefix 10.1.1.0
 
Prefix State Time Curr BR CurrI/F Protocol
PasSDly PasLDly PasSUn PasLUn PasSLos PasLLos
ActSDly ActLDly ActSUn ActLUn EBw IBw
--------------------------------------------------------------------------------
10.1.1.0/24 HOLDDOWN 42 10.10.10.1 Et9/0 STATIC
16 16 0 0 0 0
U U 0 0 55 2
 

ステップ 4 ボーダー ルータに移動して、次のステップを開始します。

次のコマンドは、マスター コントローラではなく、ボーダー ルータで入力します。

 

ステップ 5 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 6 show oer border routes { bgp | static }

このコマンドは、ボーダー ルータで入力します。このコマンドは、ボーダー ルータ上の PfR 制御ルートに関する情報を表示するために使用します。BGP またはスタティック ルートに関する情報も表示できます。この例の出力では、PfR によって制御される 10.1.1.0 プレフィクスが示されます。

Router# show oer border routes bgp
 
OER BR 10.10.10.1 ACTIVE, MC 10.10.10.3 UP/DOWN: UP 00:10:08,
Auth Failures: 0
Conn Status: SUCCESS, PORT: 3949
BGP table version is 12, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
OER Flags: C - Controlled, X - Excluded, E - Exact, N - Non-exact, I - Injected
 
Network Next Hop OER LocPrf Weight Path
*> 10.1.1.0/24 10.40.40.2 CE 0 400 600 i
 


 

アドバンスド パフォーマンス ルーティングの設定例

ここでは、次の例について説明します。

「プロファイル フェーズのタスク:例」

「測定フェーズのタスク:例」

「ポリシー適用フェーズのタスク:例」

「施行フェーズのタスク:例」

「確認フェーズのタスク:例」

自動的に学習されたプレフィクスベースのトラフィック クラスの学習リストの定義:例

マスター コントローラ上で設定された次の例では、プレフィクス リストだけに基づいて自動的に学習されたトラフィック クラスを含む学習リストが定義されます。この例では、3 つの支社があり、支社 A および B へのすべてのトラフィックを 1 つのポリシー(Policy1)を使用して最適化し、支社 C へのトラフィックを別のポリシー(Policy2)を使用して最適化することが目的です。

支社 A は、10.1.0.0./16 に一致するすべてのプレフィクスとして定義され、支社 B は、10.2.0.0./16 に一致するすべてのプレフィクスとして定義されます。支社 C は、10.3.0.0./16 に一致するすべてのプレフィクスとして定義されます。

次のタスクでは、最高アウトバウンド スループットに基づいたプレフィクスの学習が設定されます。

ip prefix-list BRANCH_A_B permit seq 10 10.1.0.0/16
ip prefix-list BRANCH_A_B permit seq 20 10.2.0.0/16
ip prefix-list BRANCH_C permit seq 30 10.3.0.0/16
oer master
learn
list seq 10 refname LEARN_BRANCH_A_B
traffic-class prefix-list BRANCH_A_B
throughput
exit
exit
learn
list seq 20 refname LEARN_BRANCH_C
traffic-class prefix-list BRANCH_C
throughput
exit
exit
oer-map POLICY1 10
match learn list LEARN_BRANCH_A_B
exit
oer-map POLICY2 10
match learn list LEARN_BRANCH_C
end

アクセス リストを使用して自動的に学習されたアプリケーション トラフィック クラスの学習リストの定義:例

次の例では、カスタム アプリケーション トラフィック クラスを定義するアクセス リストが作成されます。この例のカスタム アプリケーションは、次の 4 つの基準で構成されます。

宛先ポート 500 上のすべての TCP トラフィック

700 ~ 750 の範囲のポート上のすべての TCP トラフィック

送信元ポート 400 上のすべての UDP トラフィック

ef の Differentiated Service Code Point(DSCP; DiffServ コード ポイント)ビットでマーキングされた、すべての IP パケット

目的は、すべての学習されたトラフィック クラスに適用される、同一の POLICY_CUSTOM_APP ポリシーを最適化することです。次のタスクでは、最高アウトバウンド スループットに基づいたトラフィック クラスの学習が設定されます。

ip access-list extended USER_DEFINED_TC
permit tcp any any 500
permit tcp any any range 700 750
permit udp any eq 400 any
permit ip any any dscp ef
exit
oer master
learn
list seq 10 refname CUSTOM_APPLICATION_TC
traffic-class access-list USER_DEFINED_TC
aggregation-type prefix-length 24
throughput
exit
exit
oer-map POLICY_CUSTOM_APP 10
match learn list CUSTOM_APPLICATION_TC
end

プレフィクス リストを使用した、プレフィクスベースのトラフィック クラスの手動選択:例

次の例は、マスター コントローラ上で設定されます。トラフィック クラスが、宛先プレフィクスだけに基づいて手動で選択されます。次のタスクは、トラフィック クラスに選択する宛先プレフィクスが判明している場合に実行します。宛先プレフィクスを定義するために IP プレフィクス リストが作成され、PfR マップを使用してこのトラフィック クラスのプロファイリングが行われます。

ip prefix-list PREFIX_TC permit 10.1.1.0/24
ip prefix-list PREFIX_TC permit 10.1.2.0/24
ip prefix-list PREFIX_TC permit 172.16.1.0/24
oer-map PREFIX_MAP 10
match traffic-class prefix-list PREFIX_TC

アクセス リストを使用したアプリケーション トラフィック クラスの手動選択:例

次の例は、マスター コントローラ上で設定されます。トラフィック クラスが、アクセス リストを使用して手動で選択されます。アクセス リストの各エントリは、トラフィック クラスであり、宛先プレフィクスが必ず含まれています。他の省略可能なパラメータが含まれていることもあります。

ip access-list extended ACCESS_TC
permit tcp any 10.1.1.0 0.0.0.255 eq 500
permit tcp any 172.17.1.0 0.0.255.255 eq 500
permit tcp any 172.17.1.0 0.0.255.255 range 700 750
permit tcp 192.168.1.1 0.0.0.0 10.1.2.0 0.0.0.255 eq 800any any dscp ef
exit
oer-map ACCESS_MAP 10
match traffic-class access-list ACCESS_TC

アウトバウンド トラフィックの PfR リンク使用率の変更:例

次に、PfR 出口リンクの使用率のしきい値を変更する例を示します。この例では、出口使用率は 80% に設定されています。この出口リンクの使用率が 80% を超えると、PfR は、この出口リンクを使用していたトラフィック クラスのために別の出口リンクを選択します。

Router(config)# oer master
Router(config-oer-mc)# border 10.1.4.1
Router(config-oer-mc-br)# interface Ethernet 1/0 external
Router(config-oer-mc-br-if)# max-xmit-utilization percentage 80
Router(config-oer-mc-br-if)# end

PfR 出口リンクの使用率範囲の変更:例

次に、PfR 出口リンクの使用率範囲を変更する例を示します。この例では、すべての出口リンクの出口使用率範囲が 10% に設定されています。PfR は、最大使用率の範囲を使用して、出口リンクがポリシーに準拠しているかどうかを判断します。PfR は、過剰使用されている、またはポリシー違反の出口から、ポリシー準拠の出口にプレフィクスを移動することによって、すべての出口リンクでアウトバウンド トラフィックを均等化します。

Router(config)# oer master
Router(config-oer-mc)# max-range-utilization percentage 10
Router(config-oer-mc)# end

最長一致ターゲット割り当ての TCP プローブ:例

次に、最長一致ターゲット割り当てを使用した TCP プローブを使用してアクティブ プローブを設定する例を示します。まず、ターゲット デバイスで IP SLA Responder をイネーブルにする必要があります。このデバイスを PfR 用に設定する必要はありません。ボーダー ルータは、ターゲット デバイスとして使用できます。2 番目の設定は、マスター コントローラ上で実行します。

ターゲット デバイス

Router> enable
Router# configure terminal
Router(config)# ip sla monitor responder type tcpConnect port 49152
Router(config)# exit

マスター コントローラ

Router(config)# oer master
Router(config-oer-mc)# mode monitor active
Router(config-oer-mc)# active-probe tcp-conn 10.4.4.44 target-port 49152

強制ターゲット割り当ての UDP プローブ:例

次に、プローブ頻度が 20 秒に設定されている、強制ターゲット割り当てを使用したアクティブ プローブを設定する例を示します。この例では、ターゲット デバイスで IP SLA Responder をイネーブルにする必要があります。

ターゲット デバイス

Router> enable
Router# configure terminal
Router(config)# ip sla monitor responder type udpEcho port 1001
Router(config)# exit

マスター コントローラ

Router(config)# oer master
Router(config-oer-mc)# mode monitor active
Router(config-oer-mc)# exit
Router(config)# oer-map FORCED_MAP 10
Router(config-oer-map)# match ip address access-list FORCED_LIST
Router(config-oer-map)# set active-probe udp-echo 10.5.5.57 target-port 1001
Router(config-oer-map)# set probe frequency 20
Router(config-oer-map)# end

高速フェールオーバー用 PfR 音声プローブの設定:例

次に、グローバル コンフィギュレーション モードで開始し、高速フェールオーバーが設定されている場合に迅速に新しい出口を作成する例を示します。


) 高速モニタリングは、継続的なプローブによって多くのオーバーヘッドが発生する、非常にアグレッシブなモードです。高速モニタリングは、パフォーマンスに影響されやすいトラフィックだけに使用することを推奨します。


最初の出力は、3 台のボーダー ルータのマスター ルータでの設定を示します。ルート制御モードは、イネーブルです。

Router# show run | sec oer master
 
oer master
policy-rules MAP
port 7777
logging
!
border 10.3.3.3 key-chain key1
interface Ethernet9/0 external
interface Ethernet8/0 internal
!
border 10.3.3.4 key-chain key2
interface Ethernet5/0 external
interface Ethernet8/0 internal
!
border 10.4.4.2 key-chain key3
interface Ethernet2/0 external
interface Ethernet8/0 internal
backoff 90 90
mode route control
resolve jitter priority 1 variance 10
no resolve delay
!

基本設定を確認し、ボーダー ルータのステータスを表示するには、 show oer master コマンドを実行します。

Router# show oer master
 
OER state: ENABLED and ACTIVE
Conn Status: SUCCESS, PORT: 7777
Version: 2.1
Number of Border routers: 3
Number of Exits: 3
Number of monitored prefixes: 1 (max 5000)
Max prefixes: total 5000 learn 2500
Prefix count: total 1, learn 0, cfg 1
 
Border Status UP/DOWN AuthFail Version
10.4.4.2 ACTIVE UP 17:00:32 0 2.1
10.3.3.4 ACTIVE UP 17:00:35 0 2.1
10.3.3.3 ACTIVE UP 17:00:38 0 2.1
 
Global Settings:
max-range-utilization percent 20 recv 20
mode route metric bgp local-pref 5000
mode route metric static tag 5000
trace probe delay 1000
logging
 
Default Policy Settings:
backoff 90 90 90
delay relative 50
holddown 90
periodic 0
probe frequency 56
mode route control
mode monitor both
mode select-exit good
loss relative 10
jitter threshold 20
mos threshold 3.60 percent 30
unreachable relative 50
resolve jitter priority 1 variance 10
resolve utilization priority 12 variance 20
 
Learn Settings:
current state : DISABLED
time remaining in current state : 0 seconds
no throughput
no delay
no inside bgp
no protocol
monitor-period 5
periodic-interval 120
aggregation-type prefix-length 24
prefixes 100
expire after time 720
 

PfR マップを使用してアクティブ音声プローブ用に高速フェールオーバーが設定され、プローブ頻度が 2 秒に設定されました。高速フェールオーバー モニタリング モードはイネーブルであり、監視対象音声トラフィックは、IP プレフィクス リストを使用して 10.1.1.0/24 プレフィクスを指定することによって識別されます。高速フェールオーバー モードで発生するオーバーヘッドを削減するために、アクティブ音声プローブが PfR の強制ターゲットに割り当てられます。

Router# show run | sec oer-map
 
oer-map MAP 10
match traffic-class prefix-list VOICE_FAIL_LIST
set mode select-exit best
set mode monitor fast
set jitter threshold 12
set active-probe jitter 120.120.120.1 target-port 20 codec g729a
set probe frequency 2
 

プレフィクスがポリシー キーワードで指定されているときの show oer master prefix コマンドの次の出力は、10.1.1.0/24 プレフィクスに設定されたポリシーを示します。mode monitor は fast に設定されています。したがって、select-exit は自動的に best に設定され、probe frequency を 2 に設定できます。

Router# show oer master prefix 10.1.1.0/24 policy
 
* Overrides Default Policy Setting
oer-map MAP 10
sequence no. 8444249301975040, provider id 1, provider priority 30
host priority 0, policy priority 10, Session id 0
match ip prefix-lists: VOICE_FAIL_LIST
backoff 90 90 90
delay relative 50
holddown 90
periodic 0
*probe frequency 2
mode route control
*mode monitor fast
*mode select-exit best
loss relative 10
*jitter threshold 12
mos threshold 3.60 percent 30
unreachable relative 50
next-hop not set
forwarding interface not set
resolve jitter priority 1 variance 10
resolve utilization priority 12 variance 20
 
Forced Assigned Target List:
active-probe jitter 10.120.120.1 target-port 20 codec g729a
 

次のタスクに示されるように、マスター コントローラが高速フェールオーバー用に設定された後でトラフィック クラスがポリシー違反を犯すと、次のロギング出力に、10.1.1.0/24 プレフィクスで表されるトラフィック クラスが、OER によって 3 秒以内に 10.3.3.4 インターフェイスの新しいボーダー ルータ出口を経由してルーティングされることが表示されます。ロギング出力から、トラフィック クラスは、ジッターしきい値を超えたためにポリシー違反状態になったと考えられます。

May 2 10:55:27.355: %OER_MC-5-NOTICE: Active ABS Jitter OOP Prefix 10.1.1.0/24,
jitter 15, BR 10.4.4.2, i/f Et2/0
May 2 10:55:27.367: %OER_MC-5-NOTICE: Route changed Prefix 10.1.1.0/24, BR 10.3.3.4,
i/f Et5/0, Reason Jitter, OOP Reason Jitter

アクティブ プローブのソース アドレスの設定:例

次に、グローバル コンフィギュレーション モードを開始して、FastEthernet 0/0 をアクティブ プローブのソース インターフェイスとして設定する例を示します。

Router(config)# oer border
Router(config-oer-br)# active-probe address source interface FastEthernet 0/0

PfR ポリシーの設定および学習済みトラフィック クラスへの適用:例

次に、学習済みトラフィック クラスを使用して多数のデフォルト ポリシー設定を上書きし、設定されたポリシー設定またはデフォルトのポリシー設定のいずれかがそれぞれのしきい値を超えた場合に利用可能な最良の出口にトラフィック クラスを移動するようにマスター コントローラを設定する例を示します。

enable
configure terminal
oer master
backoff 200 2000 200
delay threshold 2000
holddown 400
loss threshold 1500
periodic 180
unreachable threshold 1000
mode select-exit best
end

PfR ポリシーの設定および設定されたトラフィック クラスへの適用:例

次に、プレフィクス リストおよびアクセス リストによってフィルタリングされたトラフィック クラスを使用し、デフォルトのポリシー設定の一部を上書きする例を示します。ポリシーは、音声トラフィックを表す異なるトラフィック クラスに適用する 2 つの PfR マップを使用して設定します。マスター コントローラは、設定されたポリシー設定またはデフォルトのポリシー設定のいずれかがそれぞれのしきい値を超えた場合に最初のポリシー準拠リンクにトラフィック クラスを移動するように設定します。次のタスクを実行するには、マスター コントローラとボーダー ルータの両方が、Cisco IOS リリース 12.4(9)T、12.2(33)SRB、またはそれ以降で稼動している必要があります。

enable
configure terminal
ip prefix-list CONFIG_TRAFFIC_CLASS seq 10 permit 10.1.5.0/24
ip access-list extended VOICE_TRAFFIC_CLASS
permit udp any range 16384 32767 10.1.5.0 0.0.0.15 range 16384 32767 dscp ef
exit
oer-map CONFIG_MAP 10
match ip address prefix-list CONFIG_TRAFFIC_CLASS
set backoff 100 1000 100
set delay threshold 1000
set loss relative 25
set periodic 360
set unreachable relative 20
exit
oer-map VOICE_MAP 10
match ip address access-list VOICE_TRAFFIC_CLASS
set active-probe jitter 10.1.5.1 target-port 2000 codec g729a
set probe-frequency 20
set jitter threshold 30
set mos threshold 4.0 percent 25
set mode select-exit good
end

学習済みプレフィクスの PfR 最適化の防止:例

次に、指定したプレフィクスが最適化されないように PfR を設定する例を示します。次の例では、IP プレフィクス リストは、最適化されない異なるプレフィクスに対する 2 つのエントリで作成されます。PfR マップは、1 つのシーケンスの 2 つのエントリで設定されます。これによって、プレフィクスは学習されますが、PfR は、プレフィクス リストで指定したプレフィクスを最適化しなくなります。PfR マップ エントリのシーケンス番号が逆方向になった場合、PfR はプレフィクスを学習し、プレフィクスの最適化を試みます。

enable
configure terminal
ip prefix-list DENY_PREFIX deny 172.17.10.0/24
ip prefix-list DENY_PREFIX deny 172.19.10.0/24
oer-map DENY_PREFIX_MAP 10
match ip address prefix-list DENY_PREFIX
exit
oer-map DENY_PREFIX_MAP 20
match oer learn throughput
end

PfR マップ用ポリシー ルールの設定:例

次に、 policy-rules コマンドを設定して、OER マスター コントローラ モードで BLUE という名前の PfR マップの設定を適用する例を示します。

enable
configure terminal
oer-map BLUE 10
match oer learn delay
set loss relative 90
exit
oer master
policy-rules BLUE
exit

複数 PfR ポリシーの競合解決の設定:例

次に、遅延を最高プライオリティに設定し、損失、使用率の順にプライオリティを設定する PfR 解決ポリシーを設定する例を示します。遅延ポリシーは、20% の分散を許可するように設定され、損失ポリシーは、30% の分散を許可するように設定されます。使用率ポリシーは、10% の分散を許可するように設定されます。

enable
configure terminal
oer master
resolve delay priority 1 variance 20
resolve loss priority 2 variance 30
resolve utilization priority 3 variance 10
end

出口リンクの ロード バランシング PfR ポリシーの設定:例

次に、ボーダー ルータの出口リンク上のトラフィック クラス フローに PfR ロード バランシング ポリシーを設定する例を示します。この例のタスクは、マスター コントローラ上で実行され、出口リンクの使用率範囲、出口リンクの使用率しきい値、使用率および範囲ポリシーに設定されるポリシー プライオリティが設定されます。パフォーマンス ポリシー、遅延および損失は、ディセーブルです。PfR は、使用率および範囲のしきい値の両方を使用して、出口リンク上のトラフィック フローのロード バランシングを行います。

enable
configure terminal
oer master
max-range-utilization percentage 25
mode select-exit best
resolve range priority 1
resolve utilization priority 2 variance 15
no resolve delay
no resolve loss
border 10.1.4.1
interface Ethernet 1/0 external
max-xmit-utilization absolute 10000
exit
exit
border 10.1.2.1
interface Ethernet 1/0 external
max-xmit-utilization absolute 10000
end

PfR マップを使用したブラック ホール ルーティングの設定:例

次に、PREFIX_BLACK_HOLE という名前の IP プレフィクス リストで定義されたトラフィックに一致する、BLACK_HOLE_MAP という名前の PfR マップを作成する例を示します。PfR マップは、ヌル インターフェイスに転送されるパケット、つまり、「ブラック ホール」に廃棄されるパケットをフィルタリングします。IP プレフィクスが、ネットワーク上の攻撃のソースとして識別されると、プレフィクス リストが設定されます。

enable
configure terminal
ip prefix-list PREFIX_BLACK_HOLE seq 10 permit 10.1.5.0/24
oer-map BLACK_HOLE_MAP 10
match ip address prefix-list PREFIX_BLACK_HOLE
set interface null0
end

PfR マップを使用したシンクホール ルーティングの設定:例

次に、PREFIX_SINK_HOLE という名前の IP プレフィクス リストで定義されたトラフィックに一致する、SINK_HOLE_MAP という名前の PfR マップを作成する例を示します。PfR マップは、ネクスト ホップに転送されるパケットをフィルタリングします。ネクスト ホップは、パケットの保存、分析、または廃棄を実行できるルータです(シンクホール アナロジー)。IP プレフィクスがネットワーク上の攻撃のソースとして識別されると、プレフィクス リストが設定されます。

enable
configure terminal
ip prefix-list PREFIX_SINK_HOLE seq 10 permit 10.1.5.0/24
oer-map SINK_HOLE_MAP 10
match ip address prefix-list PREFIX_SINK_HOLE
set next-hop 10.1.1.3
end

挿入された PfR スタティック ルートのタグ値の設定:例

次に、挿入されたスタティック ルートにタグ値を設定し、ルートが一意に識別されるようにする例を示します。スタティック ルートは、トラフィック クラスによって定義されるトラフィックがポリシー違反になったときに、そのトラフィックを制御するために PfR によって挿入されることがあります。デフォルトでは、PfR は挿入されたスタティック ルートに 5000 のタグ値を使用します。次のタスクでは、PfR ルート制御モードが、OER マスター コントローラ コンフィギュレーション モードの mode コマンドでグローバルに設定され、挿入されたすべてのスタティック ルートが 15000 の値をタグ付けされます。

Router(config)# oer master
Router(config-oer-mc)# mode route control
Router(config-oer-mc)# mode metric static tag 15000
Router(config-oer-mc)# end

PfR 制御 BGP ルートの BGP ローカル プリファレンス値の設定:例

次に、BGP ローカル プリファレンス属性値を設定する例を示します。PfR は、BGP Local_Pref 値を使用して、強制出口リンクの選択方法として内部 BGP(iBGP)ネイバー上での BGP 最良パス選択に影響を及ぼします。デフォルトでは、PfR は 5000 の Local_Pref 値を使用します。次のタスクでは、プレフィクス リストに一致するトラフィックのルート制御はイネーブルであり、60000 の BGP ローカル プリファレンス値が設定されています。

Router(config)# oer-map BLUE 10
Router(config-oer-map)# match ip address prefix-list BLUE
Router(config-oer-map)# set mode route control
Router(config-oer-map)# set mode metric bgp local-pref 60000
Router(config-oer-map)# end

アプリケーション トラフィックの制御:例

次に、ポリシーベース ルーティング(PBR)を使用して、指定したアプリケーション トラフィック クラスを PfR で制御できるようにする例を示します。Telnet トラフィックなどのアプリケーション トラフィックは、遅延に影響されやすいトラフィックです。TCP 遅延が長いと、Telnet セッションの使用が困難になることがあります。この例は、マスター コントローラ上で設定されます。192.168.1.0/24 ネットワークをソースとする Telnet トラフィックに一致させ、ポリシーを適用して、この Telnet トラフィックが 30 ミリ秒以下の応答時間で出口リンクを経由して送信されるようにします。

Router(config)# ip access-list extended TELNET
Router(config-ext-nacl)# permit tcp 192.168.1.0 0.0.0.255 any eq telnet
Router(config-ext-nacl)# exit
Router(config)# oer-map SENSITIVE
Router(config-route-map)# match ip address access-list TELNET
Router(config-route-map)# set mode route control
Router(config-route-map)# set delay threshold 30
Router(config-route-map)# set resolve delay priority 1 variance 20
Router(config-route-map)# end
 

次に、ポート 23(Telnet)に基づいてフィルタリングされた TCP アプリケーション トラフィックの例を示します。

Router# show oer master appl tcp 23 23 dst policy
Prefix Appl Prot Port Port Type Policy
--------------------------------------------------------------------------------
10.1.1.0/24 tcp [23, 23] src 10

確認フェーズのタスク:例

「PfR ルート制御変更の手動確認:例」

PfR ルート制御変更の手動確認:例

次に、PfR 施行フェーズで実行されたトラフィック制御が実際にトラフィック フローを変更し、OOP イベントをポリシー準拠に変更したことを手動で確認する例を示します。マスター コントローラで show logging コマンドを使用すると、システム ロギング(syslog)の状態および標準的なシステム ロギング バッファの内容を表示されます。省略可能な区切り文字を使用すると、特定のプレフィクスの PfR メッセージ付きでロギング バッファを表示できます。 show oer master prefix コマンドでは、監視対象プレフィクスのステータスが表示されます。ボーダー ルータで show oer border routes コマンドを使用すると、PfR 制御の BGP またはボーダー ルータ上のスタティック ルートに関する情報が表示されます。これらのコマンドの出力例については、「PfR ルート強制変更の手動確認」を参照してください。

マスター コントローラ

Router# show logging | i 10.1.1.0
Router# show oer master prefix 10.1.1.0
Router# end

ボーダー ルータ

Router# show oer border routes static
Router# show oer border routes bgp
Router# end

次の作業

概念の詳細については、 「Understanding Performance Routing」 モジュールを参照してください。詳細、設定タスクおよび例については、 「Cisco IOS Performance Routing Features Roadmap」 の個々の機能を参照してください。

他のパフォーマンス ルーティング機能の詳細または一般的な概念に関する資料については、「関連資料」に記載の資料を参照してください。

参考資料

ここではアドバンスド パフォーマンス ルーティングの設定に関する参考資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

Cisco OER コマンド(コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例)

Cisco IOS Optimized Edge Routing Command Reference』

ベーシック PfR 設定

「Configuring Basic Performance Routing」 モジュール

パフォーマンス ルーティングの運用フェーズを理解するために必要な概念

「Understanding Performance Routing」 モジュール

PfR 機能の位置

「Cisco IOS Performance Routing Features Roadmap」 モジュール

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

アドバンスド パフォーマンス ルーティングに関する機能情報

表 1 に、この機能のリリース履歴を示します。

本書に記載されていないこのテクノロジーの機能については、 「Cisco IOS Performance Routing Features Roadmap」 を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 アドバンスド パフォーマンス ルーティングに関する機能情報

機能名
リリース
機能情報

Optimized Edge Routing(OER)

12.3(8)T
12.2(33)SRB

OER が導入されました。パフォーマンス ルーティングは OER の拡張機能です。

ポリシー ルール設定に対する OER のサポート

12.3(11)T
12.2(33)SRB

ポリシー ルール設定に対する OER の サポート機能に、OER マップを選択し、OER マスター コントローラ コンフィギュレーション モードで設定を適用できる機能が導入されました。定義済みの OER マップ間での切り替えを容易に実行できます。

この機能に関する詳細については、次の各項を参照してください。

「PfR マップ用ポリシー ルールの設定」

「PfR マップ用ポリシー ルールの設定:例」

policy-rules コマンドが、この機能によって導入または変更されました。

expire after コマンド1

12.3(14)T
12.2(33)SRB

expire after コマンドは、学習済みプレフィクスの有効期間の設定に使用します。デフォルトでは、マスター コントローラは、中央ポリシー データベースから非アクティブなプレフィクスを削除します。これは、メモリが必要とされるためです。このコマンドを使用すると、制限に基づいて時間またはセッションを設定することによって、この動作を改良できます。時間ベースの制限は、分単位で設定します。セッション ベースの制限は、監視期間数(またはセッション数)に対して設定します。

OER アクティブ プローブ ソース アドレス

12.4(2)T
12.2(33)SRB

OER アクティブ プローブ ソース アドレス機能では、ボーダー ルータ上の特定の出口インターフェイスをアクティブ プローブのソースとして設定できます。

この機能に関する詳細については、次の各項を参照してください。

「アクティブ プローブのソース アドレスの設定」

「アクティブ プローブのソース アドレスの設定:例」

active-probe address source コマンドが、この機能によって導入されました。

OER アプリケーション アウェア ルーティング:PBR

12.4(2)T
12.2(33)SRB

OER アプリケーション アウェア ルーティング:PBR 機能によって、監視対象プレフィクスによって伝送されるアプリケーションのタイプに基づいて IP トラフィックを最適化できるようになっています。トラフィックのサブセット(アプリケーション)には、個別のポリシー設定が適用されます。

この機能に関する詳細については、次の各項を参照してください。

「アプリケーション トラフィックの制御」

「アプリケーション トラフィックの制御:例」

debug oer border pbr debug oer master prefix match ip address(OER) show oer master active-probes 、および show oer master appl の各コマンドが、この機能によって導入または変更されました。

OER DSCP モニタリング

12.4(9)T
12.2(33)SRB

OER DSCP モニタリングに、プロトコル、ポート番号、および DSCP 値に基づいたトラフィック クラスの自動学習が導入されました。トラフィック クラスは、プロトコル、ポート番号、および DSCP 値で構成され、不要なトラフィックをフィルタリングでき、関心のあるトラフィックを集約できる、キーの組み合わせによって定義できます。レイヤ 3 プレフィクス情報に加えて、プロトコル、ポート番号、および DSCP 情報などのレイヤ 4 情報もマスター コントローラ データベースに送信されるようになりました。この新しい機能により、OER によるアプリケーション トラフィックのアクティブ モニタリングおよびパッシブ モニタリングの両方が可能になりました。

この機能に関する詳細については、次の各項を参照してください。

「アクセス リストを使用して自動的に学習されたアプリケーション トラフィック クラスの学習リストの定義」

「プレフィクス リストを使用した、プレフィクスベースのトラフィック クラスの手動選択」

「PfR ポリシーの設定および学習済みトラフィック クラスへの適用」

show oer border passive applications show oer border passive cache show oer border passive learn show oer master appl traffic-class aggregation traffic-class filter 、および traffic-class keys の各コマンドが、この機能によって導入または変更されました。

パフォーマンス ルーティング - リンク グループ

12.4(15)T

パフォーマンス ルーティング - リンク グループ機能によって、出口リンクのグループを優先リンク セットとして、または PfR 用フォールバック リンク セットとして定義し、PfR ポリシーで指定されたトラフィック クラスを最適化する際に使用できるようになっています。

link-group set link-group 、および show oer master link-group の各コマンドが、この機能によって導入または変更されました。

高速フェールオーバー モニタリングのサポート2

12.4(15)T

高速フェールオーバー モニタリングに、高速モニタリング モードを設定できる機能が導入されました。高速フェールオーバー モニタリング モードでは、アクティブ モニタリングとパッシブ モニタリングを使用して、すべての出口が継続的にプローブされます。高速フェールオーバー モニタリング モードのプローブ頻度は、他のモニタリング モードよりも低く設定できます。これにより、より迅速なフェールオーバー機能が可能になります。高速フェールオーバー モニタリングは、すべてのタイプのアクティブ プローブ(ICMP エコー、ジッター、TCP 接続、および UDP エコー)で使用できます。

この機能に関する詳細については、次の項を参照してください。

「高速フェールオーバー用 PfR 音声プローブの設定」

「高速フェールオーバー用 PfR 音声プローブの設定:例」

mode(OER) コマンドおよび set mode コマンドが、この機能によって変更されました。

1.これは、マイナーな機能拡張です。マイナーな機能拡張は、通常、Feature Navigator には表示されません。

2.これは、マイナーな機能拡張です。マイナーな機能拡張は、通常、Feature Navigator には表示されません。

CCDE, CCENT, CCSI, Cisco Eos, Cisco Explorer, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco TrustSec, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco and/or its affiliates in the United States and certain other countries.