Cisco IOS ワイドエリア ネットワーキング コンフィ ギュレーション ガイド
PPP over Frame Relay
PPP over Frame Relay
発行日;2012/02/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

PPP over Frame Relay

機能概要

利点

用語一覧

制約事項

プラットフォーム

前提条件

サポートされている MIB および RFC

機能説明

設定作業

PPP over Frame Relay のイネーブル化

設定例

PPP over Frame Relay DTE の例

PPP over Frame Relay DCE の例

コマンド リファレンス

PPP over Frame Relay

機能概要

PPP over Frame Relay 機能で、ルータでフレームリレー上にエンドツーエンド Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)セッションを確立できるようにします。IP データグラムは、RFC 1973 準拠のフレームリレー フレーム構成を使用して PPP リンクで送信されます。この機能は図 1 のように、リモート ユーザが PPP を実行してフレームリレー企業ネットワークにアクセスする際に利用できます。図 2 で、Cisco 90i D4 チャネル カードを使用した接続シナリオを示しています。このカードは、Integrated Services Digital Network(ISDN)Digital Service Loop(DSL; デジタル サービス ループ)、PPP、またはフレームリレーをサポート可能で、Internet Service Provider(ISP; インターネット サービス プロバイダ)または企業ネットワークに接続します。

図 1 PPP over Frame Relay シナリオ

 

図 2 Cisco 90i D4 チャネル ユニットを使用した PPP over Frame Relay

 

利点

PPP over Frame Relay には次の利点があります。

フレームリレー上のエンドツーエンド PPP セッションが可能。

ISDN DSL でフレームリレーと Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル)の両方をサポートする 90i IDSL チャネル ユニットをサポート。

用語一覧

Data-Link Connection Identifier(DLCI; データリンク接続識別子) :フレームリレー ネットワークの PVC または SVC を指定する値。基本的なフレームリレーの仕様では、DLCI はローカルで重要です(接続装置で、異なる値を使用して同じ接続を指定することができます)。LMI 拡張仕様では、DLCI はグローバルで重要です(DLCI はエンド デバイスを個別に指定します)。

Integrated Services Digital Network(ISDN):電話会社が提供する通信プロトコルで、電話回線でのデータ、音声、その他の送信元トラフィックの伝送が可能。

Link Control Protocol LCP; リンク コントロール プロトコル) :PPP で使用されるデータリンク接続を確立、設定、テストするプロトコル。

Permanent Virtual Circuit(PVC; 相手先固定接続) :永続的に確立される仮想回線。PVC は、回線の確立に関連した帯域幅を節約し、特定の仮想回線が常に存在しなければならない状況をなくします。

Point-to-Point Protocol(PPP; ポイントツーポイント プロトコル) :ポイントツーポイント リンク上のネットワーク層プロトコル情報をカプセル化するプロトコル。PPP 用の RFC は RFC 1661 です。

Virtual Circuit(VC; 仮想回線) :2 つのネットワーク デバイス間で信頼性の高い通信を確保するために作成される論理回線。仮想回線は固定(PVC)とスイッチド(SVC)があります。仮想回線は、フレームリレーおよび X.25 で使用されます。

制約事項

PPP over Frame Relay を使用する場合、次の制約事項が適用されます

フレームリレー PVC のみがサポートされます。

Internet Protocol(IP; インターネット プロトコル)のみがサポートされます。

プラットフォーム

この機能は、次のプラットフォームでサポートされます

Cisco 1600 シリーズ

Cisco 2500 シリーズ

Cisco 2600 シリーズ

Cisco 3600 シリーズ

Cisco 4000 シリーズ(Cisco 4000、4000-M、4500、4500-M、4700、4700-M)

Cisco 7200 シリーズ

Cisco 7500 シリーズ

前提条件

PPP over Frame Relay を設定する前に、フレームリレーが encapsulation frame-relay コマンドを使用してルータでイネーブルになっている必要があります。

サポートされている MIB および RFC

この機能は、RFC 1973 をサポートしています。

この機能によってサポートされる新しい MIB はありません。

機能説明

PPP over Frame Relay は、RFC 1973 で規定された機能およびカプセル化仕様に準拠しています。フレーム形式を図 3 に示します。

PPP 接続はフレームリレー Permanent Virtual Circuit(PVC; 相手先固定接続)で確立されます。関連するフレームリレー PVC が「アクティブ」状態にならない限り、PPP セッションは発生しません。フレームリレー VC は、RFC 1490 やシスコ独自の異なるフレームリレーカプセル化方法を使用した他の回線と、同じフレームリレー リンク上で共存できます。複数のフレームリレー内 PPP 回線が 1 つのフレームリレー リンクに存在できます。

1 つの PPP 接続が、1 つの仮想アクセス インターフェイスに存在します。この接続は、仮想テンプレート インターフェイスから内部で作成されます。仮想アクセス インターフェイスは仮想テンプレート インターフェイスから複製されます。仮想アクセス インターフェイスは、対応する DLCI が設定された場合、フレームリレー回線の作成と共存します。1 つの仮想テンプレート インターフェイスは、必要なすべての PPP とネットワーク プロトコル情報が含まれており、複数の仮想アクセス インターフェイスで共有されます。ハードウェア圧縮と仮想キューイング アルゴリズム(重み付け均等化キューイング、カスタム キューイング、プライオリティ キューイングなど)は、仮想アクセス インターフェイスに適用されません。フレームリレー回線が PPP over Frame Relay を使用して確立されると、この回線のすべての着信および送信パケットは、この DLCI が設定から削除されるまで RFC 1973 PPP-in-Frame-Relay カプセル化に準拠します。 フレームリレー設定オプションについては 、Cisco IOS リリース 11.3 の『 Wide Area Configuration Guide および Command Reference 』マニュアルを参照してください。

図 3 PPP over Frame Relay のフレーム形式

 

フレームリレー フレーム形式のコンポーネントの説明を、 表 1 に示します。

 

表 1 PPP フレームリレー形式の説明

フィールド
説明
Flag
フレームの開始または終了を示す 1 バイト。
Address
物理チャネルにマッピングする論理接続を示す 2 バイトのフィールド。DLCI。
Control
ユーザ データの送信を要求する 1 バイト。PPP over Frame Relay では、0X03 の値を使用します。これは、フレームが Unnumbered Information(UI; アンナンバード インフォメーション)フレームであることを示します。
NLPID
シングル バイトのネットワーク層プロトコル ID で、フレームリレーへの PPP パケットを一意に特定します。
PPP protocol
PPP パケット タイプを識別します。

設定作業

PPP over Frame Relay の実装に必要な作業は、次の項で説明するように、ローカルで終了する PVC があるインターフェイスと、関連する PPP および IP の仮想テンプレートを設定するだけです。

PPP over Frame Relay のイネーブル化

Cisco ルータの設定後や、フレームリレーをカプセル化するサーバへのアクセス後、物理インターフェイスに PVC を設定し、PPP カプセル化を含む仮想テンプレートを、そのインターフェイスに適用する DLCI に適用する必要があります。PPP セッションを伝送し、適切な仮想テンプレート インターフェイスにリンクする物理インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次のタスクを実行します。

 

タスク
コマンド
PVC を定義し、それを仮想テンプレートにマッピングします。
frame-relay interface-dlci dlci [ppp virtual-template-name-string]

設定例

ここでは、次の例について説明します。

PPP over Frame Relay DTE の例

PPP over Frame Relay DCE の例

PPP over Frame Relay DTE の例

次は、ルータを PPP over Frame Relay の Data Terminating Equipment(DTE; データ終端着信側機器)装置として設定します。サブインターフェイス 2.1 には、必要な DLCI と仮想テンプレート情報が含まれています。仮想テンプレート インターフェイス(interface virtual-template 1)には、シリアル サブインターフェイス 2.1 の DLCI 32 に関連付けられた PPP セッションに適用される PPP 情報が含まれています。 フレームリレー設定オプションについては 、Cisco IOS リリース 11.3 の『 Wide-Area Configuration Guide および Wide-Area Networking Command Reference 』を参照してください。

interface serial 2
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface serial 2.1 point-to-point
frame-relay interface-dlci 32 ppp virtual-template1
!
interface Virtual-Template1
ip unnumbered ethernet 0
ppp authentication chap pap

) デフォルトでは、仮想テンプレート インターフェイスのカプセル化タイプは PPP カプセル化です。したがって、encapsulation ppp はルータの設定を表示するときには表示されません。


PPP over Frame Relay DCE の例

次は、ルータが Data Communications Equipment(DCE; データ通信装置)機器として動作するように設定した例です。一般に、ルータを他のルータに直接接続する場合や、電話会社のチャネル バンクの 90i D4 チャネル ユニットに接続する場合に、DCE として設定します。このタイプの設定には、 frame-relay switching、frame-relay intf-type dce、 および frame-relay route コマンドの、3 つのコマンドが必要です。この設定では、次のようになります。

frame-relay switching
!
interface Serial2/0:0
no ip address
encapsulation frame-relay IETF
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 31 interface Serial1/2 100
frame-relay interface-dlci 32 ppp Virtual-Template1
!
interface Serial2/0:0.2 point-to-point
no ip address
frame-relay interface-dlci 40 ppp Virtual-Template2
!
interface Virtual-Template1
ip unnumbered Ethernet0/0
peer default ip address pool default
ppp authentication chap pap
!
interface Virtual-Template2
ip address 100.1.1.2 255.255.255.0
ppp authentication chap pap

) デフォルトでは、仮想テンプレート インターフェイスのカプセル化タイプは PPP カプセル化です。したがって、encapsulation ppp はルータの設定を表示するときには表示されません。


コマンド リファレンス

次に示すコマンドは、このモジュールに記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、 Cisco IOS Wide-Area Networking Command Reference 』( http://www.cisco.com/en/US/docs/ios/wan/command/reference/wan_book.html )を参照してください。 Cisco IOS の全コマンドを参照する場合は、参照先( http://tools.cisco.com/Support/CLILookup )の Command Lookup Tool を使用するか、 または Cisco IOS Master Commands List 』にアクセスしてください。

frame-relay interface-dlci

show frame-relay pvc

debug frame-relay ppp