Cisco IOS ワイドエリア ネットワーキング コンフィ ギュレーション ガイド
MQC ベースのフレームリレー トラフィック シェーピング
MQC ベースのフレームリレー トラフィック シェーピング
発行日;2012/02/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 5MB) | フィードバック

目次

MQC ベースのフレームリレー トラフィック シェーピング

機能情報の検索

マニュアルの内容

MQC ベースのフレームリレー トラフィック シェーピングの前提条件

MQC ベースのフレームリレー トラフィック シェーピングの制限事項

MQC ベースのフレームリレー トラフィック シェーピングに関する情報

MQC の概要

FRTS の概要

MQC ベースのフレームリレー トラフィック シェーピングの機能設計

サポートされる MQC フレームリレー トラフィック シェーピング コマンド

MQC ベースのフレームリレー トラフィック シェーピングの利点

MQC ベースのフレームリレー トラフィック シェーピングの設定方法

CBWFQ2 のクラス マップの作成と一致基準の指定

ポリシー マップの作成とクラス マップの CBWFQ パラメータの入力

シェーピング ポリシー マップの作成と、デフォルト クラス マップの FRTS 値の入力

CBWFQ ポリシー マップのシェーピング ポリシー マップへの適用

マップ クラスの指定とサービス ポリシーの PVC への適用

フレームリレーでのインターフェイスまたはサブインターフェイスの設定マップ クラスと PVC との関連付け

PVC のフラグメンテーション パラメータの定義

ポリシー マップのマップ クラスへの追加

MQC ベース フレームリレー トラフィック シェーピングの設定例

CBWFQ の設定例

フラグメンテーション付き CBWFQ の設定例

参考資料

関連資料

規格

MIB

シスコのテクニカル サポート

MQC ベースのフレームリレー トラフィック シェーピングの機能情報

MQC ベースのフレームリレー トラフィック シェーピング

MQC ベースのフレームリレー トラフィック シェーピング機能で、モジュラ Quality of Service(QoS; サービス品質)Command Line Interface(CLI; コマンドライン インターフェイス)のコマンドを使用して、Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)を設定できます。モジュラ QoS CLI は、MQC と呼ばれます。

この機能は、「サポートされているプラットフォーム」で指定する Cisco ルータで使用できます。

サポートされているプラットフォーム

Cisco 1700 シリーズ、Cisco 2500 シリーズ、Cisco 2600 シリーズ、Cisco 3620 ルータ、Cisco 3631 ルータ、Cisco 3640 ルータ、Cisco 3660 ルータ、Cisco 3725 ルータ、Cisco 3745 ルータ、Cisco 7200 シリーズ、Cisco 7400 シリーズ、Cisco 7500 シリーズおよびそれ以降

機能情報の検索

このモジュールに記載されている機能の一部が、ご使用のソフトウェア リリースでサポートされていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「MQC ベースのフレームリレー トラフィック シェーピングの機能情報」を参照してください。

プラットフォームのサポート、ならびに Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。 Cisco.com のアカウントは必要ありません。

MQC ベースのフレームリレー トラフィック シェーピングの前提条件

MQC を使用した FRTS を適用する Permanent Virtual Circuit(PVC; 相手先固定接続)では、関連付けられたインターフェイスで、 encapsulation frame-relay コマンドを使用してフレームリレーカプセル化をイネーブルにする必要があります。


「サポートされているプラットフォーム」で指定するルータで MQC を使用した FRTS を利用する場合、分散型シスコ エクスプレス フォワーディングは不要です。Cisco 7500 のルータおよび上記の製品範囲で MQC を使用した FRTS を利用する場合は、分散型シスコ エクスプレス フォワーディングが必要です。


MQC ベースのフレームリレー トラフィック シェーピングの制限事項

フレームリレー PVC で MQC を使用した FRTS を設定するには、 class class-default コマンドで指定したサービス ポリシーに従って、デフォルト クラスを作成する必要があります。デフォルト クラスには、適用されているすべての FRTS が含まれます。サービス ポリシーのデフォルト クラス構造の作成については、「ポリシー マップの作成とクラス マップの CBWFQ パラメータの入力」を参照してください。

FRTS およびフラグメンテーションが、MQC を使用した PVC に適用されると、インターフェイス キューが、デュアル First-In First-Out(FIFO; 先入れ先出し)キューイングに変更されます。この 2 つのキューは、VoIP および特定の制御パケットを伝送する高優先順位のキューと、その他すべてのパケットを伝送する低優先順位のキューで構成されています。


) 従来の FRTS コマンドを使用して作成した設定では、最低許容発信 Committed Information Rate(minCIR; 認定情報レート)は、PVC でマップ クラスに追加された Class-based Weighted Fair Queueing(CBWFQ; クラスベース WFQ)があるポリシー マップで、使用可能な総帯域幅として使用されます。

MQC ベースのフレームリレー トラフィック シェーピング機能を使用して FRTS を設定する場合で、CBWFQ が設定されている場合、MQC を使用した親ポリシー マップで設定されたシェーピング レートが、子ポリシー マップで使用可能な総帯域幅として使用されます。shape averageshape adaptive コマンドの両方がトラフィック シェーピングで使用される場合、使用可能な帯域幅は、shape adaptive コマンドで指定されたパラメータが基になります。


MQC ベースのフレームリレー トラフィック シェーピングに関する情報

MQC ベースのフレームリレー トラフィック シェーピングを設定するには、次の概念について理解する必要があります。

「MQC の概要」

「FRTS の概要」

「MQC ベースのフレームリレー トラフィック シェーピングの機能設計」

「サポートされる MQC フレームリレー トラフィック シェーピング コマンド」

「MQC ベースのフレームリレー トラフィック シェーピングの利点」

MQC の概要

MQC は、FRTS の設定に使用します。MQC は、分類ポリシーと、適用された分類ポリシーの結果動作するその他のパラメータの仕様とを明確に区別するフレームワークです。

この機能が Cisco IOS リリース 12.2(13)T で導入される前は、「サポートされているプラットフォーム」の項で指定する Cisco ルータの FRTS は、従来の FRTS コマンド(詳細は「MQC ベースのフレームリレー トラフィック シェーピングの設定方法」を参照してください)を使用してのみ設定できます。MQC ベースのフレームリレー トラフィック シェーピング機能の追加により、Cisco ルータ製品全般で、MQC を使用して FRTS を設定できます。

大まかに、次のような手順で MQC を設定し実装します。

class-map コマンドでトラフィック クラスを定義します。

トラフィック クラスを 1 つまたは複数の QoS 機能に関連付け、サービス ポリシーを作成します。これには、 policy-map コマンドを使用します。

service-policy コマンドで、インターフェイスにサービス ポリシーを設定します。

MQC に関する詳細については、『 Modular Quality of Service Command-Line Interface 』のマニュアルを参照してください。 FRTS で使用する MQC コマンドについての詳細は、本マニュアルの「MQC ベースのフレームリレー トラフィック シェーピングの設定方法」の項を参照してください。

FRTS の概要

FRTS で、PVC を通り抜けるトラフィックを、そのフローとリモート ターゲット インターフェイスの速度が一致し、設定されているパラメータとトラフィックが一致するよう制御できます。特定のプロファイルに一致するトラフィックは、ダウンストリーム要件を満たすよう整形される場合があります。これにより、データレートが一致しないトポロジで発生するボトルネックが排除されます。

FRTS を使用する主な理由には次があります。

高優先順位のパケットを、カプセル化してフレームリレー ネットワーク上を転送することにより、他のパケットよりも優先できる。FRTS は、VoIP やストリーミング ビデオなどの、低遅延であることが効果的なアプリケーションで活用できます。

使用可能な帯域幅へのアクセスを制御する。

トラフィックが、このトラフィック用に設定したパラメータと一致するようにする。

送信トラフィックがリモート ターゲット インターフェイスのアクセス速度を超えたときに発生する場合がある輻輳を避けるため、トラフィックのフローを規制する。

中央サイトの高速度接続、およびブランチ サイトの低速度接続のフレームリレー ネットワークのボトルネックを、中央サイトの Virtual Circuit(VC; 仮想回線)上に送信されるデータを制限するレート強制を設定することで排除する。レート強制は発信トラフィックを制限するために設定される最大レートです。

MQC ベースのフレームリレー トラフィック シェーピングの機能設計

MQC ベースのフレームリレー トラフィック シェーピング機能により、「サポートされているプラットフォーム」で指定する Cisco ルータで、従来の FRTS コマンドではなく MQC を使用して FRTS を設定できます。

この機能が Cisco IOS リリース 12.2(13)T で導入される前は、「サポートされているプラットフォーム」の項で指定する Cisco ルータの FRTS は、従来の FRTS コマンド( frame-relay traffic-shaping コマンドなど)を使用してのみ設定できます。従来の FRTS では、すべてのトラフィック シェーピングとフラグメンテーションの値は、マップ クラスで入力します。トラフィック シェーピングを、 map-class frame-relay コマンドを入力して定義し、その後トラフィック シェーピングと、必要に応じてフラグメンテーション値を入力します。

Cisco 7500 およびそれ以降の製品範囲のルータの場合、Distributed Traffic Shaping(DTS; 分散化トラフィック シェーピング)がトラフィックの整形に使用されます。DTS を使用して、トラフィックシェーピング値を policy-map コマンドを入力して設定し、その後トラフィックシェーピング値を入力します。ただし、フラグメンテーション値は、マップ クラスで入力します。まず map-class frame-relay コマンドを使用してからフラグメンテーション値を入力します。

MQC ベースのフレームリレー トラフィック シェーピングでサポートするトラフィックシェーピングコマンドは「サポートされる MQC フレームリレー トラフィック シェーピング コマンド」の項で一覧で示しています。

また、CBWFQ も、ポリシー マップで policy-map コマンドを入力し、トラフィックシェーピング CBWFQ 値を入力することで設定できます。


) MQC を使用したトラフィック シェーピングの設定と、従来の FRTS コマンドを使用した設定は、同時に行えません。トラフィック シェーピングは、両方の方法を使用して同じインターフェイスで設定できません。


サポートされる MQC フレームリレー トラフィック シェーピング コマンド

次の MQC トラフィックシェーピング コマンドが、MQC ベースのフレームリレー トラフィック シェーピング機能でサポートされます。

shape { average | peak }

shape adaptive

shape fecn-adapt

shape max-buffers

frame-relay ip rtp priority コマンドはサポートされません。


) この機能が Cisco IOS リリース 12.2(13)T で導入される前は、「サポートされているプラットフォーム」の項で指定する Cisco ルータの FRTS は、従来の FRTS コマンド(詳細は「MQC ベースのフレームリレー トラフィック シェーピングの設定方法」を参照してください)を使用してのみ設定できます。


MQC ベースのフレームリレー トラフィック シェーピングの利点

MQC で、QoS パラメータ単独でのトラフィック クラスを指定できます。

MQC ベースのフレームリレー トラフィック シェーピング機能で、Cisco ルータ製品全体で、MQC を使用して FRTS パラメータを適用できます。

この機能は、FRTS が、Cisco 7500 および上記の製品範囲だけではなく、Cisco ルータ製品全体でルータで同じ形式で定義されるようにします。

この機能が Cisco IOS リリース 12.2(13)T で導入される前は、「サポートされているプラットフォーム」の項で指定する Cisco ルータの FRTS は、従来の FRTS コマンドを使用してのみ定義できます。異なるルータに異なる FRTS の定義方法を使用すると、FRTS が異なるルータ プラットフォームで実装されたときに不整合だったり、複雑になったりすることがあります。

MQC ベースのフレームリレー トラフィック シェーピングの設定方法

ここでは、次の各手順について説明します。それぞれ、必須の手順か任意の手順かわかるようになっています。

CBWFQ2 のクラス マップの作成と一致基準の指定(任意)

ポリシー マップの作成とクラス マップの CBWFQ パラメータの入力(任意)

シェーピング ポリシー マップの作成と、デフォルト クラス マップの FRTS 値の入力(必須)

CBWFQ ポリシー マップのシェーピング ポリシー マップへの適用(任意)

マップ クラスの指定とサービス ポリシーの PVC への適用(必須)

フレームリレーでのインターフェイスまたはサブインターフェイスの設定マップ クラスと PVC との関連付け(必須)

PVC のフラグメンテーション パラメータの定義(任意)

ポリシー マップのマップ クラスへの追加(必須)

CBWFQ2 のクラス マップの作成と一致基準の指定

CBWFQ のクラス マップを作成し、一致基準を指定するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. class-map class-map-name

4. match match-criteria

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

class-map class-map-name

 

Router(config)# class-map voice

指定したクラスとパケットのマッチングに使用されるクラス マップを作成し、クラスマップ コンフィギュレーション モードを開始します。

この例のコマンドでは「voice」という名前のクラス マップを作成します。

ステップ 4

match match-criteria

 

Router(config-cmap)# match ip dscp ef

クラス マップに属するパケットを特定します。

この例のコマンドでは、EF(101110)の IP Differentiated Service Code Point(DSCP; ディファレンシエーテッド サービス コード ポイント)の値を「voice」という名前のクラス マップの一致基準として特定します。

ステップ 5

end

 

Router(config-cmap)# end

(任意)クラスマップ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ポリシー マップの作成とクラス マップの CBWFQ パラメータの入力

ポリシー マップを作成し、クラス マップの CBWFQ パラメータを入力するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class name

5. priority { bandwidth-kbps | percent percentage } [ burst ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map llq

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成し、サービス ポリシーを指定してポリシーマップ コンフィグレーション モードを開始します。

この例のコマンドでは「llq」という名前のポリシー マップを作成します。このポリシー マップは、低遅延キューイング(LLQ)で使用されます。

ステップ 4

class name

 

Router(config-pmap)# class voice

作成したいポリシーのクラス名を指定し、ポリシーマップ クラス コンフィグレーション モードを開始します。

この例のコマンドでは「voice」という名前のトラフィック マップを作成します。

ステップ 5

priority [ bandwidth-kbps | percent percentage ] [ burst ]

 

Router(config-pmap-c)# priority 32

(任意)ポリシー マップに含めるトラフィックのクラスに、優先順位を付けます。

この例のコマンドは 32 kbps の保証許容帯域幅と、最大 32 kbps の保証低遅延を、ステップ 4で作成した「voice」トラフィック クラスに提供します。

ステップ 6

end

 

Router(config-pmap-c)# end

(任意)ポリシーマップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

シェーピング ポリシー マップの作成と、デフォルト クラス マップの FRTS 値の入力

ポリシー マップを作成し、デフォルト クラス マップの FRTS 値を入力するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-default

5. shape { average | peak } { mean-rate [ burst-size [ excess-burst-size ]] | percent percentage [ burst-size ms [ excess-burst [ ms ]]]}

6. shape adaptive mean-rate-lower-bound

7. shape fecn-adapt

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map shape-policy-map

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成し、サービス ポリシーを指定してポリシーマップ コンフィグレーション モードを開始します。

この例のコマンドでは、shape-policy-map という名前のポリシー マップを作成します。

ステップ 4

class class-default

 

Router(config-pmap)# class class-default

デフォルト クラス(通常、class-default クラスと呼ばれます)を、ポリシーを設定する前に指定し、ポリシーマップ クラス コンフィグレーション モードを開始します。

class-default クラスは、トラフィックが、ポリシー マップでポリシーが定義されている他のクラスの一致基準を満たさない場合に、そのトラフィックが誘導されるクラスです。

このコマンド(class-default クラス)を使用して定義されるクラスは 1 つのみです。従って、このクラスはすべてのトラフィックに適用されます。

ステップ 5

shape { average | peak } { mean-rate [ burst-size [ excess-burst-size ]] | percent percentage [ burst-size ms [ excess-burst [ ms ]]]}

 

Router(config-pmap-c)# shape average 64000

指定されたアルゴリズムに従い、示されたビット レートにトラフィックを整形します。

この例のコマンドでは、64,000 バイト/秒(bps)の CIR での整形エンティティを設定します。

この機能でサポートされる FRTS コマンドはすべて、トラフィック シェーピングに使用できます。サポートされる FRTS コマンドのリストについては、「MQC ベースのフレームリレー トラフィック シェーピングの制限事項」の項を参照してください。

ステップ 6

shape adaptive mean-rate-lower-bound

 

Router(config-pmap-c)# shape adaptive 32000

(任意)フレームリレー PVC を、トラフィック シェーピングがイネーブルの場合に Backward Explicit Congestion Notification(BECN; 逆方向明示的輻輳通知)によって使用可能帯域幅を予想する設定にします。

この例のコマンドでは、BECN を受信したときの下限 CIR を 32,000 bps に設定します。

ステップ 7

shape fecn-adapt

 

Router(config-pmap-c)# shape fecn-adapt

(任意)フレームリレー インターフェイスを、Q.922「Test Response」メッセージに従って BECN ビットが受信した Forward Explicit Congestion Notification(FECN; 順方向明示的輻輳通知)ビット)を反映する設定にします。

この例のコマンドでは、FECN でのフレームリレー メッセージを BECN に適応させます。

ステップ 8

end

 

Router(config-pmap-c)# end

(任意)ポリシーマップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

CBWFQ ポリシー マップのシェーピング ポリシー マップへの適用

CBWFQ ポリシー マップをシェーピング ポリシー マップに適用するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-default

5. service-policy policy-map-name

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map shape-policy-map

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成し、サービス ポリシーを指定してポリシーマップ コンフィグレーション モードを開始します。

この例のコマンドでは、shape-policy-map という名前のポリシー マップを作成します。

ステップ 4

class class-default

 

Router(config-pmap)# class class-default

デフォルト クラス(通常、class-default クラスと呼ばれます)を、ポリシーを設定する前に指定し、ポリシーマップ クラス コンフィグレーション モードを開始します。

class-default クラスは、トラフィックが、ポリシー マップでポリシーが定義されている他のクラスの一致基準を満たさない場合に、そのトラフィックが誘導されるクラスです。

このコマンド(class-default クラス)を使用して定義されるクラスは 1 つのみです。従って、このクラスはすべてのトラフィックに適用されます。

ステップ 5

service-policy policy-map-name

 

Router(config-pmap-c)# service-policy llq

サービス ポリシーを、ポリシー マップのシェーピング ポリシーに従って適用します。

この親子のサービス ポリシー関係を、階層型サービス ポリシーと呼びます。

この例のコマンドでは、親ポリシー マップが「shape-policy-map」、子ポリシー マップが「llq」の階層型サービス ポリシーを作成しています。

ステップ 6

end

 

Router(config-pmap-c)# end

(任意)ポリシーマップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

マップ クラスの指定とサービス ポリシーの PVC への適用

マップ クラスを指定し、サービス ポリシーを PVC に適用するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. map-class frame-relay map-class-name

4. service-policy { input | output } policy-name

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

map-class frame-relay map-class-name

 

Router (config)# map-class frame-relay shape-map-class

マップ クラスを指定して、PVC と MQC ポリシー マップの適用の両方で、フラグメンテーション値を定義し、静的マップ クラス コンフィギュレーション モードを開始します。

この例のコマンドでは、shape-map-class という名前のマップ クラスを指定します。

ステップ 4

service-policy { input | output } policy-map-name

 

Router(config-map-class)# service-policy input shape-policy-map

PVC にサービス ポリシーを適用します。

ステップ 5

end

 

Router(config-map-class)# end

(任意)静的マップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

フレームリレーでのインターフェイスまたはサブインターフェイスの設定マップ クラスと PVC との関連付け

フレームリレーでインターフェイスまたはサブインターフェイスを設定し、マップ クラスを PVC に関連付けるには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. interface type number [ name-tag ]

4. encapsulation frame-relay [ MFR | ietf ]

5. exit

6. interface type slot / port . subinterface-number [ multipoint | point-to-point ]

7. ip address ip-address mask [ secondary ]

8. frame-relay interface-dlci dlci [ ietf | cisco ]

9. class name

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number [ name-tag ]

 

Router(config)# interface serial 0/0

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation frame-relay [ MFR | ietf ]

 

Router(config-if)# encapsulation frame-relay

フレームリレーのカプセル化をイネーブルにします。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface type slot / port . subinterface-number [ multipoint | point-to-point ]

 

Router(config)# interface serial 0/0.1 point-to-point

サブインターフェイスを設定し、サブインターフェイス コンフィギュレーションモードを開始します。

ステップ 7

ip address ip-address mask [ secondary ]

 

Router(config-subif)# ip address 192.168.1.1 255.255.255.0

プライマリ IP アドレスとサブインターフェイスのマスクを設定します。

ステップ 8

frame-relay interface-dlci dlci [ ietf | cisco ]

 

Router(config-subif)# frame-relay interface-dlci 100

Data-Link Connection Identifier(DLCI; データリンク接続識別子)を、ルータの指定したフレームリレー サブインターフェイスに割り当て、フレームリレー DLCI コンフィギュレーション モードを開始します。

この例のコマンドでは、DLCI 番号が 100 の PVC を、シリアル 0/0.1 サブインターフェイス配下に作成します。

ステップ 9

class name

 

Router(config-fr-dlci)# class shape-map-class

マップ クラスをサブインターフェイスと関連付けます。

この例のコマンドでは、shape-map-class という名前のマップ クラスをステップ 8で作成した PVC に関連付けます。

ステップ 10

end

 

Router(config-fr-dlci)# end

(任意)フレームリレー DLCI コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

PVC のフラグメンテーション パラメータの定義

PVC のフラグメンテーション パラメータを定義するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. map-class frame-relay map-class-name

4. frame-relay fragment fragment-size [ switched ]

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

map-class frame-relay map-class-name

 

Router (config)# map-class frame-relay shape-map-class

マップ クラスを指定して、PVC と MQC ポリシー マップの適用の両方で、フラグメンテーション パラメータを定義し、静的マップ クラス コンフィギュレーション モードを開始します。

この例のコマンドでは、shape-map-class という名前のマップ クラスを指定します。

ステップ 4

frame-relay fragment fragment-size [ switched ]

 

Router(config-map-class)# frame-relay fragment 80

(任意)フレームリレー マップ クラスのフレームリレーフレームのフラグメンテーションをイネーブルにします。

この例のコマンドでは、元のフレームリレー フレームから各フラグメントに 80 ペイロード バイト送信されるよう指定します。

ステップ 5

end

 

Router(config-map-class)# end

(任意)静的マップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ポリシー マップのマップ クラスへの追加

ポリシー マップをマップ クラスに追加するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. policy-map policy-map-name

4. class class-default

5. service-policy policy-map

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

policy-map policy-map-name

 

Router(config)# policy-map shape-policy-map

1 つまたは複数のインターフェイスに適用できるポリシー マップを作成し、サービス ポリシーを指定してポリシーマップ コンフィグレーション モードを開始します。

この例のコマンドでは、shape-policy-map という名前のポリシー マップを作成します。

ステップ 4

class class-default

 

Router(config-pmap)# class class-default

デフォルト クラス(通常、class-default クラスと呼ばれます)を、ポリシーを設定する前に指定し、ポリシーマップ クラス コンフィグレーション モードを開始します。

class-default クラスは、トラフィックが、ポリシー マップでポリシーが定義されている他のクラスの一致基準を満たさない場合に、そのトラフィックが誘導されるクラスです。

このコマンド(class-default クラス)を使用して定義されるクラスは 1 つのみです。従って、このクラスはすべてのトラフィックに適用されます。

ステップ 5

service-policy policy-map

 

Router(config-pmap-c)# service-policy shape-policy-map

ポリシー マップをマップ クラスに追加し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

この例のコマンドでは、shape-policy-map という名前のポリシー マップを追加します。このコマンドは、ポリシー マップ整形を、マップ クラスを使用する他の PVC にも適用します。

ステップ 6

end

 

Router(config-pmap-c)# end

(任意)ポリシーマップ クラス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

MQC ベース フレームリレー トラフィック シェーピングの設定例

ここでは、前の項で説明した設定作業に沿った設定例を説明します。

「CBWFQ の設定例」

「フラグメンテーション付き CBWFQ の設定例」

CBWFQ の設定例

次は、FRTS を使用した CBWFQ の設定のサンプル例です。

class-map voice
match ip dscp ef
policy-map llq
class voice
priority 32
policy-map shape-policy-map
class class-default
shape average 64000
shape adaptive 32000
service-policy llq
 
map-class frame-relay shape-map-class
service-policy output shape-policy-map
 
interface serial 0/0
encapsulation frame-relay
 
interface serial 0/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 100
class shape-map-class
 

フラグメンテーション付き CBWFQ の設定例

次は、FRTS を使用した CBWFQ およびフラグメンテーションの設定のサンプル例です。この設定例は「CBWFQ の設定例」で説明した例とまったく同じで、フラグメンテーションの設定用に frame-relay fragment コマンドを追加しています。

class-map voice
match ip dscp ef
 
policy-map llq
class voice
priority 32
policy-map shape-policy-map
class class-default
shape average 64000
shape adaptive 32000
service-policy llq
 
map-class frame-relay shape-map-class
frame-relay fragment 80
service-policy output shape-policy-map
 
interface serial 0/0
encapsulation frame-relay
 
interface serial 0/0.1 point-to-point
ip address 192.168.1.1 255.255.255.0
frame-relay interface-dlci 100
class shape-map-class

参考資料

次の項で、MQC ベースのフレームリレー トラフィック シェーピング機能に関する参考資料を示します。

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

MQC ベースのフレームリレー トラフィック シェーピングの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 MQC ベースのフレームリレー トラフィック シェーピングの機能情報

機能名
リリース
機能情報

MQC ベースのフレームリレー トラフィック シェーピング

12.2(13)T

MQC ベースのフレームリレー トラフィック シェーピング機能で、モジュラ Quality of Service(QoS; サービス品質)Command-Line Interface(CLI; コマンドライン インターフェイス)のコマンドを使用して、Frame Relay Traffic Shaping(FRTS; フレームリレー トラフィック シェーピング)を設定できます。モジュラ QoS CLI は、MQC と呼ばれます。

shape adaptive shape fecn-adapt の各コマンドが導入または変更されました。

CCDE, CCENT, CCSI, Cisco Eos, Cisco HealthPresence, Cisco IronPort, the Cisco logo, Cisco Nurse Connect, Cisco Pulse, Cisco SensorBase, Cisco StackPower, Cisco StadiumVision, Cisco TelePresence, Cisco Unified Computing System, Cisco WebEx, DCE, Flip Channels, Flip for Good, Flip Mino, Flipshare (Design), Flip Ultra, Flip Video, Flip Video (Design), Instant Broadband, and Welcome to the Human Network are trademarks; Changing the Way We Work, Live, Play, and Learn, Cisco Capital, Cisco Capital (Design), Cisco:Financed (Stylized), Cisco Store, Flip Gift Card, and One Million Acts of Green are service marks; and Access Registrar, Aironet, AllTouch, AsyncOS, Bringing the Meeting To You, Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Lumin, Cisco Nexus, Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, Continuum, EtherFast, EtherSwitch, Event Center, Explorer, Follow Me Browsing, GainMaker, iLYNX, IOS, iPhone, IronPort, the IronPort logo, Laser Link, LightStream, Linksys, MeetingPlace, MeetingPlace Chime Sound, MGX, Networkers, Networking Academy, PCNow, PIX, PowerKEY, PowerPanels, PowerTV, PowerTV (Design), PowerVu, Prisma, ProConnect, ROSA, SenderBase, SMARTnet, Spectrum Expert, StackWise, WebEx, and the WebEx logo are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.