Cisco IOS Flexible NetFlow コンフィギュレーショ ン ガイド
フロー エクスポータによる Cisco IOS Flexible NetFlow のデータ エクスポートの 設定
フロー エクスポータによる Cisco IOS Flexible NetFlow のデータ エクスポートの設定
発行日;2012/02/07 | 英語版ドキュメント(2011/07/20 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

フロー エクスポータによる Cisco IOS Flexible NetFlow のデータ エクスポートの設定

機能情報の検索

マニュアルの内容

フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の前提条件

フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の制約事項

フロー エクスポータによる Flexible NetFlow のデータ エクスポートについて

フロー エクスポータ

Flexible NetFlow フロー エクスポータの利点

フロー エクスポータによる Flexible NetFlow のデータ エクスポートの設定方法

フロー エクスポータ

制約事項

フロー エクスポータの設定

フロー エクスポータの現在のステータスの表示

フロー エクスポータの設定確認

データ エクスポートによる Flexible NetFlow と設定とイネーブル化

フロー モニタ

制約事項

フロー モニタ キャッシュのデータ エクスポートがイネーブルになっていることの確認

前提条件

フロー エクスポータによる Flexible NetFlow データ エクスポートの設定例

複数のエクスポート先の設定:例

QoS を使用したエクスポート パケットの送信の設定:例

バージョン 5 エクスポートの設定:例

次の作業

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

Flexible NetFlow の機能情報

フロー エクスポータによる Cisco IOS Flexible NetFlow のデータ エクスポートの設定

このドキュメントには、NetFlow コレクタを実行している UNIX サーバなどのリモート システムへ Flexible NetFlow データをエクスポートするフロー エクスポータについて、およびその設定方法が記載されています。

NetFlow は、ルータを流れるパケットの統計情報が得られる、Cisco IOS 技術の 1 つです。NetFlow は、IP ネットワークから実際の IP データを取得するための標準規格です。NetFlow を利用すると、ネットワークとセキュリティの監視、ネットワーク計画、トラフィック分析、および IP アカウンティングをサポートするためのデータが得られます。

Flexible NetFlow は、実際の要件に合わせてトラフィック分析パラメータをカスタマイズする機能を追加することで、以前の NetFlow よりも改善されています。Flexible NetFlow では、トラフィック分析のための非常に複雑な構成を作成したり、再利用可能な構成コンポーネントを使用してデータをエクスポートすることが容易になります。

機能情報の検索

このモジュールに記載されている機能の一部が、ご使用のソフトウェア リリースでサポートされていない場合があります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「Flexible NetFlow の機能情報」を参照してください。

プラットフォームのサポート、ならびに Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の前提条件

Flexible NetFlow を設定するには、次の前提条件を満たしている必要があります。

Cisco IOS Flexible NetFlow Overview 」モジュールに記載された内容をよく理解していること。

ネットワーク デバイスで、Flexible NetFlow がサポートされた Cisco IOS リリースが稼動していること。Flexible NetFlow をサポートした Cisco IOS ソフトウェア リリースのリストについては、「 Cisco IOS Flexible NetFlow Features Roadmap 」を参照してください。

IPv4 トラフィック

ネットワーク デバイスが、IPv4 ルーティング用に設定されていること。

シスコ エクスプレス フォワーディングまたは分散型シスコ エクスプレス フォワーディングのいずれかが、使用中のルータおよび Flexible NetFlow をイネーブルにするすべてのインターフェイスでイネーブルにされていること。

IPv6 トラフィック

ネットワーク デバイスが、IPv6 ルーティング用に設定されていること。

シスコ エクスプレス フォワーディング IPv6 または分散型シスコ エクスプレス フォワーディングのいずれかが、使用中のルータおよび Flexible NetFlow をイネーブルにするすべてのインターフェイスでイネーブルにされていること。

フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の制約事項

フロー エクスポータによる Flexible NetFlow のデータ エクスポートの設定には、次の制約事項が適用されます。

Cisco IOS リリース 12.4(22)T で最初に出荷された NetFlow バージョン 5 エクスポート プロトコルは、Flexible NetFlow の事前定義済みレコードを使用するフロー モニタだけでサポートされます。

フロー エクスポータによる Flexible NetFlow のデータ エクスポートについて

フロー エクスポータを設定するには、その前に次の概念を理解しておく必要があります。

「フロー エクスポータ」

「Flexible NetFlow フロー エクスポータの利点」

フロー エクスポータ

フロー エクスポータは、ルータの設定内に独立したコンポーネントとして作成されます。エクスポータは、フロー モニタ キャッシュから NetFlow コレクタなどのリモート システムへデータをエクスポートするために、フロー モニタに割り当てられます。フロー モニタは、複数のエクスポータをサポートできます。各エクスポータは、それが使用されるフロー モニタ、およびデータのエクスポート先となる NetFlow コレクタ システムの要件に合わせてカスタマイズできます。

Flexible NetFlow フロー エクスポータの利点

Flexible NetFlow では、要件に応じて、多数のさまざまなフロー エクスポータを設定できます。Flexible NetFlow フロー エクスポータには、次のような利点があります。

フロー エクスポータを使用すると、分析対象となるあらゆるタイプのトラフィック用のエクスポータを作成できるため、トラフィックをタイプごとに別の NetFlow コレクタに送信できます。以前の NetFlow では、分析されたすべてのトラフィックのキャッシュ内のデータが、最大 2 つのエクスポート先に送信されました。

フロー エクスポータでは、1 つのフロー モニタにつき最大 10 のエクスポータがサポートされます。以前の NetFlow では、1 つのキャッシュにつき、2 つのエクスポート宛先だけに制限されていました。

Cisco IOS リリース 12.4(20)T 以降のリリースでは、フロー エクスポータ で、エクスポート先に送信されるパケット内の Class of Service(CoS; サービス クラス)を使用できるため、ネットワーク全体でパケットに適切なプライオリティが指定されます。以前の NetFlow エクスポータは、エクスポート先に送信されるパケット内で CoS を使用していませんでした。

Cisco IOS リリース 12.4(20)T 以降のリリースでは、フロー エクスポータ トラフィックを暗号化できます。

フロー エクスポータによる Flexible NetFlow のデータ エクスポートの設定方法

この項のタスクでは、Flexible NetFlow で収集されるデータを、詳細な分析と保存のためにリモート システムにエクスポートする方法について説明します。

フロー エクスポータ

フロー エクスポータは、Flexible NetFlow で収集したデータを、NetFlow コレクタなどのリモート システムに送信するために使用されます。フロー エクスポータではトランスポート プロトコルとして、UDP(ユーザ データグラム プロトコル)を使用します。

制約事項

それぞれのエクスポータがサポートする宛先は 1 つだけです。複数の宛先にデータをエクスポートする場合は、複数のフロー エクスポータを設定し、それらをフロー モニタに割り当てる必要があります。フロー エクスポータがフロー モニタに追加されると、フロー モニタ キャッシュからのデータ エクスポートがイネーブルになります。


) これらのタスクでは、そのタスクで使用される Flexible NetFlow コマンドに必要なキーワードと引数だけが示されています。これらの Flexible NetFlow コマンドで使用可能なその他のキーワードと引数については、『Cisco IOS Flexible NetFlow Command Reference』を参照してください。


Flexible NetFlow のデータ エクスポートを設定するには、この項のタスクを実行します。

「フロー エクスポータの設定」(必須)

「フロー エクスポータの現在のステータスの表示」(任意)

「フロー エクスポータの設定確認」(任意)

「データ エクスポートによる Flexible NetFlow と設定とイネーブル化」(必須)

「フロー モニタ キャッシュのデータ エクスポートがイネーブルになっていることの確認」(任意)

フロー エクスポータの設定

フロー エクスポータを設定するには、次の必須タスクを実行します。

手順の概要

1. enable

2. configure terminal

3. flow exporter exporter-name

4. description description

5. destination { ip-address | hostname } [ vrf vrf-name ]

6. export-protocol { netflow-v5 | netflow-v9 }

7. dscp dscp

8. source interface-type interface-number

9. option { exporter-stats | interface-table | sampler-table } [ timeout seconds ]

10. output-features

11. template data timeout seconds

12. transport udp udp-port

13. ttl seconds

14. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

flow exporter exporter-name

 

Router(config)# flow exporter EXPORTER-1

フロー エクスポータを作成し、Flexible NetFlow フロー エクスポータ コンフィギュレーション モードを開始します。

このコマンドでは、既存のフロー エクスポータを変更することもできます。

ステップ 4

description description

 

Router(config-flow-exporter)# description Exports to the datacenter

(任意)設定および show flow exporter コマンドの出力に表示される、エクスポータの説明を設定します。

ステップ 5

destination { ip-address | hostname } [ vrf vrf-name ]

 

Router(config-flow-exporter)# destination 172.16.10.2

エクスポータの宛先システムの IP アドレスまたはホスト名を指定します。

ステップ 6

export-protocol { netflow-v5 | netflow-v9 }

 

Router(config-flow-exporter)# export-protocol netflow-v9

エクスポータで使用される NetFlow エクスポート プロトコルのバージョンを指定します。

デフォルト: netflow-v9

ステップ 7

dscp dscp

 

Router(config-flow-exporter)# dscp 63

(任意)エクスポータによって送信されるデータグラムの Differentiated Services Code Point(DSCP)パラメータを設定します。

dscp 引数の範囲は、0 ~ 63 です。デフォルト:0

ステップ 8

source interface-type interface-number

 

Router(config-flow-exporter)# source ethernet 0/0

(任意)エクスポートされるデータグラムの送信元 IP アドレスとして、エクスポータで IP アドレスを使用するローカル インターフェイスを指定します。

ステップ 9

option { exporter-stats | interface-table | sampler-table } [ timeout seconds ]

 

Router(config-flow-exporter)# option exporter-stats timeout 120

(任意)エクスポータのオプション データ パラメータを設定します。

3 つのオプションを同時に設定できます。

seconds 引数の範囲は、1 ~ 86,400 です。デフォルト:600

ステップ 10

output-features

 

Router(config-flow-exporter)# output-features

(任意)Quality of Service(QoS; サービス品質)および暗号化を使用した、エクスポート パケットの送信をイネーブルにします。

ステップ 11

template data timeout seconds

 

Router(config-flow-exporter)# template data timeout 120

(任意)タイムアウトに基づくテンプレートの再送を設定します。

seconds 引数の範囲は、1 ~ 86400 です(86400 秒 = 24 時間)。

ステップ 12

transport udp udp-port

 

Router(config-flow-exporter)# transport udp 650

宛先システムが、エクスポートされるデータグラムを待ち受ける UDP ポートを指定します。

udp-port 引数の範囲は、1 ~ 65536 です。

ステップ 13

ttl seconds

 

Router(config-flow-exporter)# ttl 15

(任意)エクスポータから送信されるデータグラムの Time-to-Live(TTL; 存続可能時間)値を設定します。

seconds 引数の範囲は、1 ~ 255 です。

ステップ 14

end

 

Router(config-flow-exporter)# end

フロー エクスポータ コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

フロー エクスポータの現在のステータスの表示

フロー エクスポータの現在のステータスを表示するには、次の任意タスクを実行します。

手順の概要

1. enable

2. show flow exporter exporter-name

手順の詳細


ステップ 1 enable

enable コマンドによって、特権 EXEC モードを開始します(プロンプトが表示されたらパスワードを入力します)。

Router> enable
 
Router#
 

ステップ 2 show flow exporter exporter-name

show flow exporter コマンドでは、指定したフロー エクスポータの現在のステータスが表示されます。

Router# show flow exporter EXPORTER-1
 
Flow Exporter EXPORTER-1:
Description: Exports to the datacenter
Transport Configuration:
Destination IP address: 172.16.10.2
Source IP address: 172.16.6.2
Source Interface: Ethernet0/0
Transport Protocol: UDP
Destination Port: 650
Source Port: 55864
DSCP: 0x3F
TTL: 15
Output Features: Used
Options Configuration:
exporter-stats (timeout 120 seconds)
interface-table (timeout 120 seconds)
sampler-table (timeout 120 seconds)
 

フロー エクスポータの設定確認

入力した設定コマンドを確認するには、次の任意タスクを実行します。

手順の概要

1. enable

2. show running-config flow exporter exporter-name

手順の詳細


ステップ 1 enable

enable コマンドによって、特権 EXEC モードを開始します(プロンプトが表示されたらパスワードを入力します)。

Router> enable
 
Router#
 

ステップ 2 show running-config flow exporter exporter-name

show running-config flow exporter コマンドでは、指定したフロー エクスポータの設定コマンドが表示されます。

Router# show running-config flow exporter EXPORTER-1
 
Building configuration...
 
Current configuration:
!
flow exporter EXPORTER-1
description Exports to the datacenter
destination 172.16.10.2
source Ethernet0/0
output-features
dscp 63
ttl 15
transport udp 650
template data timeout 120
option exporter-stats timeout 120
option interface-table timeout 120
option sampler-table timeout 120
!
end


 


 

データ エクスポートによる Flexible NetFlow と設定とイネーブル化

キャッシュ データをエクスポートするトラフィックのタイプを設定するには、フロー モニタを作成する必要があります。1 つ以上のインターフェイスにフロー モニタを適用してデータのエクスポートを開始することで、フロー モニタをイネーブルにする必要があります。データ エクスポートで Flexible NetFlow を設定してイネーブルにするには、次の必須タスクを実行します。

フロー モニタ

各フロー モニタは、それに関連付けられた個別のキャッシュを持っています。各フロー モニタには、キャッシュ エントリの内容とレイアウトを定義するためのレコードが必要です。レコード フォーマットは、いずれかの事前定義済みレコードのフォーマットにできますが、高度なユーザは Flexible NetFlow のフロー レコード コンフィギュレーション モードで collect および match コマンドを使用し、独自のレコード フォーマットを作成することもできます。

制約事項

フロー モニタのレコード フォーマットを record コマンドで変更するには、その前にフロー モニタを適用してあるすべてのインターフェイスから、フロー モニタを削除しておく必要があります。

事前定義済みレコード「NetFlow original」、または「NetFlow IPv4 original input」あるいは「NetFlow IPv6 original input」をフロー モニタに指定して、以前の NetFlow をエミュレートする場合は、フロー モニタを入力(受信)トラフィックの分析だけに使用できます。

事前定義済みレコード「NetFlow IPv4 original output」または「NetFlow IPv6 original output」をフロー モニタに指定して、出力 NetFlow アカウンティング機能をエミュレートする場合は、フロー モニタを出力(発信)トラフィックの分析だけに使用できます。

手順の概要

1. enable

2. configure terminal

3. flow monitor monitor-name

4. record { record-name | netflow-original | netflow { ipv4 | ipv6 } record [ peer ]}

5. exporter exporter-name

6. exit

7. interface type number

8. { ip | ipv6 } flow monitor monitor-name { input | output }

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

flow monitor monitor-name

 

Router(config)# flow monitor FLOW-MONITOR-1

フロー モニタを作成し、Flexible NetFlow フロー モニタ コンフィギュレーション モードを開始します。

このコマンドでは、既存のフロー モニタを変更することもできます。

ステップ 4

record { record-name | netflow-original | netflow { ipv4 | ipv6 } record [ peer ]}

 

Router(config-flow-monitor)# record netflow ipv4 original-input

フロー モニタのレコードを指定します。

ステップ 5

exporter exporter-name

 

Router(config-flow-monitor)# exporter EXPORTER-1

作成済みのエクスポータの名前を指定します。

ステップ 6

exit

 

Router(config-flow-monitor)# exit

Flexible NetFlow フロー モニタ コンフィギュレーション モードを終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 7

interface type number

 

Router(config)# interface ethernet 0/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

{ ip | ipv6 } flow monitor monitor-name { input | output }

 

Router(config-if)# ip flow monitor FLOW-MONITOR-1 input

作成済みのフロー モニタを、トラフィックの分析対象となるインターフェイスに割り当てることで、そのフロー モニタをアクティブにします。

ステップ 9

end

 

Router(config-if)# end

フロー インターフェイス コンフィギュレーション モードを終了して、特権 EXEC モードに戻ります。

フロー モニタ キャッシュのデータ エクスポートがイネーブルになっていることの確認

フロー モニタ キャッシュのデータ エクスポートがイネーブルになっていることを確認するには、次の任意タスクを実行します。

前提条件

フロー モニタ キャッシュ内のフローを表示するためには、NetFlow original レコードで定義された基準に適合するトラフィックを受信するインターフェイスに、入力フロー モニタを適用する必要があります。

手順の概要

1. enable

2. show flow monitor name monitor-name

手順の詳細


ステップ 1 enable

enable コマンドによって、特権 EXEC モードを開始します(プロンプトが表示されたらパスワードを入力します)。

Router> enable
 
Router#
 

ステップ 2 show flow monitor name monitor-name

フロー モニタのステータスと統計情報を表示します。

Router# show flow monitor name FLOW-MONITOR-1
 
Flow Monitor FLOW-MONITOR-1:
Description: User defined
Flow Record: netflow original-input
Flow Exporter: EXPORTER-1
Cache:
Type: normal
Status: allocated
Size: 4096 entries / 311316 bytes
Inactive Timeout: 15 secs
Active Timeout: 1800 secs
Update Timeout: 1800 secs
 


 

フロー エクスポータによる Flexible NetFlow データ エクスポートの設定例

ここでは、次の設定例について説明します。

「複数のエクスポート先の設定:例」

「QoS を使用したエクスポート パケットの送信の設定:例」

「バージョン 5 エクスポートの設定:例」

複数のエクスポート先の設定:例

次の例は、IPv4 および IPv6 のトラフィックに Flexible NetFlow の複数のエクスポート先を設定する方法を示しています。

このサンプルは、グローバル コンフィギュレーション モードから開始します。

!
flow exporter EXPORTER-1
destination 172.16.10.2
transport udp 90
exit
!
flow exporter EXPORTER-2
destination 172.16.10.3
transport udp 90
exit
!
flow monitor FLOW-MONITOR-1
record netflow ipv4 original-input
exporter EXPORTER-2
exporter EXPORTER-1
!
!
flow monitor FLOW-MONITOR-2
record netflow ipv6 original-input
exporter EXPORTER-2
exporter EXPORTER-1
!
 
ip cef
!
interface Ethernet0/0
ip address 172.16.6.2 255.255.255.0
ipv6 address 2001:DB8:2:ABCD::2/48
ip flow monitor FLOW-MONITOR-1 input
ipv6 flow monitor FLOW-MONITOR-2 input
 
!
 

次の表示出力は、フロー モニタによる 2 つのエクスポータへのデータのエクスポートを示しています。

Router# show flow monitor FLOW-MONITOR-1
 
Flow Monitor FLOW-MONITOR-1:
Description: User defined
Flow Record: netflow original-input
Flow Exporter: EXPORTER-1
EXPORTER-2
Cache:
Type: normal
Status: allocated
Size: 4096 entries / 311316 bytes
Inactive Timeout: 15 secs
Active Timeout: 1800 secs
Update Timeout: 1800 secs

QoS を使用したエクスポート パケットの送信の設定:例

次の例では、Quality of Service(QoS; サービス品質)を使用して Flexible NetFlow エクスポート パケットの送信を設定する方法を示します。


) 宛先ホスト(IP アドレス 10.0.1.2)への Flexible NetFlow エクスポート パケットは、QoS を使用してイーサネット インターフェイス 0/1 で送信されます。


このサンプルは、グローバル コンフィギュレーション モードから開始します。

!
flow record FLOW-RECORD-1
match ipv4 source address
collect counter packets
!
flow exporter FLOW-EXPORTER-1
destination 10.0.1.2
output-features
dscp 18
!
flow monitor FLOW-MONITOR-1
record FLOW-RECORD-1
exporter FLOW-EXPORTER-1
cache entries 1024
!
ip cef
!
class-map match-any COS3
!
policy-map PH_LABS_FRL_64k_16k_16k_8k_8k
class COS3
bandwidth percent 2
random-detect dscp-based
random-detect exponential-weighting-constant 1
random-detect dscp 18 200 300 10
!
interface Ethernet0/0
ip address 10.0.0.1 255.255.255.0
ip flow monitor FLOW-MONITOR-1 input
!
interface Ethernet0/1
ip address 10.0.1.1 255.255.255.0
service-policy output PH_LABS_FRL_64k_16k_16k_8k_8k
!
 

次の表示出力は、エクスポートされたデータでの QoS の使用を可能にする出力機能サポートを使用した、フロー モニタでのデータ エクスポートを示しています。

Router# show flow monitor FLOW-MONITOR-1
 
Flow Exporter FLOW-EXPORTER-1:
Description: User defined
Tranport Configuration:
Destination IP address: 10.0.1.2
Source IP address: 10.0.0.1
Transport Protocol: UDP
Destination Port: 9995
Source Port: 56750
DSCP: 0x12
TTL: 255
Output Features: Used

バージョン 5 エクスポートの設定:例

次の例は、Flexible NetFlow に対するバージョン 5 エクスポートの設定方法を示しています。

このサンプルは、グローバル コンフィギュレーション モードから開始します。

!
flow exporter EXPORTER-1
destination 172.16.10.2
export-protocol netflow-v5
transport udp 90
exit
!
flow monitor FLOW-MONITOR-1
record netflow ipv4 original-input
exporter EXPORTER-1
!
 
ip cef
!
interface Ethernet0/0
ip address 172.16.6.2 255.255.255.0
ip flow monitor FLOW-MONITOR-1 input
 
!
 

次の作業

QoS と帯域幅モニタリング、アプリケーションおよびユーザ フロー モニタリングとプロファイリング、セキュリティ分析など、特定の目的に対する Flexible NetFlow の高度な設定の詳細については、 「Customizing Cisco IOS Flexible NetFlow Flow Records and Flow Monitors」 モジュールを参照してください。

フロー サンプリングを設定して、トラフィック分析による CPU オーバーヘッドを軽減する場合は、 「Using Cisco IOS Flexible NetFlow Flow Sampling to Reduce the CPU Overhead of Analyzing Traffic」 モジュールを参照してください。

Flexible NetFlow に対していずれかの事前定義済みレコードを設定する場合は、 「Configuring Cisco IOS Flexible NetFlow with Predefined Records」 モジュールを参照してください。

参考資料

ここでは、Flexible NetFlow に関する参考資料について説明します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

Flexible NetFlow の概要

「Cisco IOS Flexible NetFlow Overview」

Flexible NetFlow の機能ロードマップ

「Cisco IOS Flexible NetFlow Features Roadmap」

Flexible NetFlow による以前の NetFlow のエミュレーション

「Getting Started with Configuring Cisco IOS Flexible NetFlow」

Flexible NetFlow のカスタマイズ

「Customizing Cisco IOS Flexible NetFlow Flow Records and Flow Monitors」

Flexible NetFlow のトラフィック監視によるオーバーヘッド軽減のためのフロー サンプリング設定

「Using Cisco IOS Flexible NetFlow Flow Sampling to Reduce the CPU Overhead of Analyzing Traffic」

事前定義済みレコードを使用した Flexible NetFlow の設定

「Configuring Cisco IOS Flexible NetFlow with Predefined Records」

Flexible NetFlow Top N Talkers を使用したネットワーク トラフィックの分析

「Using Cisco IOS Flexible NetFlow Top N Talkers to Analyze Network Traffic」

Flexible NetFlow 用の IPv4 マルチキャスト統計情報サポートの設定

「Configuring IPv4 Multicast Statistics Support for Cisco IOS Flexible NetFlow」

Flexible NetFlow の設定コマンド

『Cisco IOS Flexible NetFlow Command Reference』

規格

規格
タイトル

なし

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3954

Cisco Systems NetFlow Services Export Version 9

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

Flexible NetFlow の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS リリース 12.2(1)、あるいは Cisco IOS リリース 12.2(1) または 12.0(3)S 以降のリリースで導入または変更された機能だけが示されています。

ここに示されていないこの技術の機能の詳細については、「 Cisco IOS Flexible NetFlow Features Roadmap 」を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 Flexible NetFlow の機能情報

機能名
リリース
機能情報

Flexible NetFlow

12.2(33)SRC 12.4(9)T

Flexible NetFlow が導入されました。

この機能のサポートは、Cisco 7200 シリーズ ルータ用として Cisco IOS リリース 12.2(33)SRC で追加されました。

Flexible NetFlow 機能については、次の各項に説明があります。

「フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の前提条件」

「フロー エクスポータによる Flexible NetFlow のデータ エクスポートについて」

「フロー エクスポータによる Flexible NetFlow のデータ エクスポートの設定方法」

「フロー エクスポータによる Flexible NetFlow データ エクスポートの設定例」

次のコマンドが導入または変更されました。 cache (Flexible NetFlow) clear flow exporter clear flow monitor、clear sampler、collect counter、collect flow、collect interface、collect ipv4、collect ipv4 destination、collect ipv4 fragmentation、collect ipv4 section、collect ipv4 source、collect ipv4 total-length、collect ipv4 ttl、collect routing、collect timestamp sys-uptime、collect transport、collect transport icmp ipv4、collect transport tcp、collect transport udp、debug flow exporter、debug flow monitor、debug flow record、debug sampler、description (Flexible NetFlow) destination、dscp(Flexible NetFlow)、exporter、flow exporter、flow monitor、flow record、ip flow monitor、match flow、match interface (Flexible NetFlow) match ipv4、match ipv4 destination、match ipv4 fragmentation、match ipv4 section、match ipv4 source、match ipv4 total-length、match ipv4 ttl、match routing、match transport、match transport icmp ipv4、match transport tcp、match transport udp、mode (Flexible NetFlow) option (Flexible NetFlow) record、sampler、show flow exporter、show flow interface、show flow monitor、show flow record、show sampler、source (Flexible NetFlow) statistics packet、template data timeout、transport (Flexible NetFlow)

Flexible NetFlow--IPv4 Unicast Flows

12.2(33)SRC 12.4(9)T

Flexible NetFlow で IPv4 トラフィックを監視できます。

この機能のサポートは、Cisco 7200 シリーズ ルータ用として Cisco IOS リリース 12.2(33)SRC で追加されました。

Flexible NetFlow:IPv4 Unicast Flows 機能については、次の各項に説明があります。

「データ エクスポートによる Flexible NetFlow と設定とイネーブル化」

「複数のエクスポート先の設定:例」

次のコマンドが導入または変更されました。 collect routing、debug flow record、collect ipv4、collect ipv4 destination、collect ipv4 fragmentation、collect ipv4 section、collect ipv4 source、ip flow monitor、match ipv4、match ipv4 destination、match ipv4 fragmentation、match ipv4 section、match ipv4 source、match routing、record、show flow monitor、show flow record

Flexible NetFlow--NetFlow v9 Export Format

12.2(33)SRE 12.4(9)T

バージョン 9 のエクスポート フォーマットを使用してエクスポート パケットを送信できます。

この機能のサポートは、Cisco 7200 および 7300 Network Processing Engine(NPE; ネットワーク処理エンジン)シリーズ ルータ用として、Cisco IOS リリース 12.2(33)SRE で追加されました。

Flexible NetFlow--NetFlowV9 Export Format 機能については、次の各項に説明があります。

「フロー エクスポータの設定」

この機能のために導入または変更されたコマンドはありません。

Flexible NetFlow--IPv6 Unicast Flows

12.2(33)SRE 12.4(20)T

Flexible NetFlow で IPv6 トラフィックを監視できます。

この機能のサポートは、Cisco 7200 および 7300 Network Processing Engine(NPE; ネットワーク処理エンジン)シリーズ ルータ用として、Cisco IOS リリース 12.2(33)SRE で追加されました。

Flexible NetFlow--IPv6 Unicast Flows 機能については、次の各項に説明があります。

「データ エクスポートによる Flexible NetFlow と設定とイネーブル化」

「複数のエクスポート先の設定:例」

次のコマンドが導入または変更されました。 collect routing、debug flow record、match routing、record、show flow monitor、show flow record、collect ipv6、collect ipv6 destination、collect ipv6 extension map、collect ipv6 fragmentation、collect ipv6 hop-limit、collect ipv6 length、collect ipv6 section、collect ipv6 source、collect transport icmp ipv6、ipv6 flow monitor、match ipv6、match ipv6 destination、match ipv6 extension map、match ipv6 fragmentation、match ipv6 hop-limit、match ipv6 length、match ipv6 section、match ipv6 source、match transport icmp ipv6

Flexible NetFlow--Output Features on Data Export

12.4(20)T

QoS および暗号化を使用して、エクスポート パケットを送信できます。

Flexible NetFlow--Output Features 機能については、次の各項に説明があります。

「フロー エクスポータの設定」

「QoS を使用したエクスポート パケットの送信の設定:例」

次のコマンドが導入されました。 output-features

Flexible NetFlow--NetFlow V5 Export Protocol

12.2(33)SRE 12.4(22)T

バージョン 5 のエクスポート プロトコルを使用してエクスポート パケットを送信できます。

この機能のサポートは、Cisco 7200 および 7300 Network Processing Engine(NPE; ネットワーク処理エンジン)シリーズ ルータ用として、Cisco IOS リリース 12.2(33)SRE で追加されました。

Flexible NetFlow--NetFlowV5 export protocol 機能については、次の各項に説明があります。

「フロー エクスポータによる Flexible NetFlow のデータ エクスポート設定の制約事項」

「フロー エクスポータの設定」

「バージョン 5 エクスポートの設定:例」

次のコマンドが導入されました。 export-protocol