Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS VPN:ポリシーベース ルーティングを 使用した VRF 選択
MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択

機能情報の確認

この章の構成

ポリシーベース ルーティングを使用した VRF 選択の前提条件

ポリシーベース ルーティングを使用した VRF 選択の制約事項

ポリシーベース ルーティングを使用した VRF 選択に関する情報

ポリシーベース ルーティングを使用した VRF 選択の概要

ポリシーベース ルーティングの set 句:概要

ポリシーベース ルーティングを使用した VRF 選択の設定方法

PBR VRF 選択に使用する一致基準の定義

パケット長に基づいて定義された一致基準

前提条件

標準アクセス リストを使用した PBR VRF 選択の設定

名前付きアクセス リストを使用した PBR VRF 選択の設定

ルート マップでの PBR VRF 選択の設定

前提条件

制約事項

インターフェイスでの PBR の設定

制約事項

インターフェイスでの IP VRF Receive の設定

ポリシーベース ルーティングを使用した VRF 選択の設定の確認

ポリシーベース ルーティングを使用した VRF 選択の設定例

アクセス リストでの PBR VRF 選択の定義:例

ポリシーベース ルーティングを使用した VRF 選択の確認:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

ポリシーベース ルーティングを使用した VRF 選択の機能情報

用語集

MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択

MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択機能は、MPLS VPN:送信元 IP アドレスに基づく VRF 選択機能を拡張したものです。この機能によって Policy-Based Routing(PBR; ポリシーベース ルーティング)メカニズムが導入され、複数の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)選択の一致基準に基づいて Virtual Private Network(VPN; バーチャル プライベート ネットワーク)トラフィックの分類と転送が行われます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「ポリシーベース ルーティングを使用した VRF 選択の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

ポリシーベース ルーティングを使用した VRF 選択の前提条件

この機能を設定するには、ルータが PBR をサポートする必要があります。PBR をサポートしないプラットフォームについては、Cisco IOS Release 12.0(22)S で導入された送信元 IP アドレスに基づく VRF 選択機能を使用します。

この機能を設定する前に VRF を定義しておく必要があります。VRF が存在しない場合は、コンソールにエラー メッセージが表示されます。

このマニュアルでは、ネットワークで Multiprotocol BGP(mBGP; マルチプロトコル BGP)、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)、およびシスコ エクスプレス フォワーディングがイネーブルになっていることを前提としています。

ポリシーベース ルーティングを使用した VRF 選択の制約事項

ポリシーベース ルーティングを使用した VRF 選択機能は、サービス プロバイダー(-p-)イメージだけでサポートされます。

ポリシーベース ルーティングを使用した VRF 選択機能と送信元 IP アドレスに基づく VRF 選択機能は同じルータ上に共存できますが、同じインターフェイスには同時に設定できません。これは、これらの機能の設定を誤った場合に VRF テーブル選択の衝突を防ぐよう設計された動作です。同じインターフェイス上で ip vrf select source コマンドと ip policy route-map コマンドを設定しようとすると、コンソールにエラー メッセージが表示されます。

Protocol Independent Multicast(PIM; プロトコル独立マルチキャスト)およびマルチキャスト パケットは PBR をサポートしていません。また、この機能の一致基準になっている送信元 IP アドレスには、PIM とマルチキャスト パケットを設定できません。

ポリシーベース ルーティングを使用した VRF 選択機能は IP プレフィクス リストでは設定できません。

ポリシーベース ルーティングを使用した VRF 選択に関する情報

ポリシーベース ルーティングを使用した VRF 選択を設定する前に、次の概念を理解しておく必要があります。

「ポリシーベース ルーティングを使用した VRF 選択の概要」

「ポリシーベース ルーティングの set 句:概要」

ポリシーベース ルーティングを使用した VRF 選択の概要

ポリシーベース ルーティングを使用した VRF 選択機能は、送信元 IP アドレスに基づく VRF 選択機能を拡張したものです。VRF 選択機能の PBR 実装を使用すると、ポリシーの一致基準に基づいて VPN トラフィックをルーティングできます。一致基準の定義は IP アクセス リストであったり、パケット長であったりします。Cisco IOS ソフトウェアがサポートする一致基準は、次のとおりです。

IP アクセス リスト:IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて、一致基準を定義します。サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。一致基準の定義には Cisco IOS ソフトウェアのすべての IP アクセス リスト設定オプションを使用できます。

パケット長:パケットの長さ(バイト単位)に基づいて、一致基準を定義します。パケット長フィルタは、match length ルート マップ コンフィギュレーション コマンドを使用してルート マップに定義します。

ポリシー ルーティングはルート マップで定義します。ルート マップは、ip policy route-map インターフェイス コンフィギュレーション コマンドを使用して着信インターフェイスに適用します。IP アクセス リストは、match ip address ルート マップ コンフィギュレーション コマンドを使用してルート マップに適用します。パケット長一致基準は、match length ルート マップ コンフィギュレーション コマンドを使用してルート マップに適用します。設定アクションは、set vrf ルート マップ コンフィギュレーション コマンドを使用して定義します。一致基準が評価されると、set 句によって適切な VRF が選択されます。この組み合せを使用すると、着信 VPN トラフィックの一致基準を定義し、VPN パケットをポリシーに従って適切な VRF にルーティングできます。

ポリシーベース ルーティングの set 句:概要

PBR を設定する場合は、次の 4 つの set 句を使用して通常のルーティングおよび転送動作を変更できます。

set default interface

set interface

set ip default next-hop

set ip next-hop

いずれかの set 句を設定すると、パケットの通常のルーティングおよび転送動作は上書きされます。

ポリシーベース ルーティングを使用した VRF 選択機能によって、5 番めの set 句が追加されます。この句を使用すると、通常のルーティングおよび転送動作を変更できます。set vrf コマンドを使用して、ルート マップ内で適切にマッチングが行われたあとの適切な VRF を選択してください。

ポリシーベース ルーティングを使用した VRF 選択の設定方法

ここでは、次の各手順について説明します。

「PBR VRF 選択に使用する一致基準の定義」(必須)

「ルート マップでの PBR VRF 選択の設定」(必須)

「インターフェイスでの PBR の設定」(必須)

「インターフェイスでの IP VRF Receive の設定」(必須)

「ポリシーベース ルーティングを使用した VRF 選択の設定の確認」 (任意)

PBR VRF 選択に使用する一致基準の定義

PBR VRF ルート選択に使用する一致基準は、アクセス リストに定義します。サポートされているアクセス リストは、標準アクセス リストおよび名前付きアクセス リストです。ここでは、PBR ルート選択を設定する方法について説明します。

「標準アクセス リストを使用した PBR VRF 選択の設定」(必須)

「名前付きアクセス リストを使用した PBR VRF 選択の設定」(必須)

パケット長に基づいて定義された一致基準

一致基準は、match length ルート マップ コンフィギュレーション コマンドを使用して、パケット長に基づいて定義することもできます。この設定オプションはすべてルート マップの中だけで定義されます。

前提条件

この作業を実行する前に、VRF および関連する IP アドレスが定義されていることを確認します。

標準アクセス リストを使用した PBR VRF 選択の設定

VPN トラフィックのデータ パケット送信を許可または拒否するために、標準アクセス リストを作成し、そのリストに PBR VRF ルート選択の一致基準を定義するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. access-list access-list-number { deny | permit } source-addr [ source-wildcard ] [ log]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

access-list access-list-number { deny | permit } source-addr [ source-wildcard] [ log ]

 

Router(config)# access-list 40 permit 192.168.1.0 0.0.0.255

アクセス リストを作成し、ルート マップの一致基準を定義します。

一致基準は、IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて定義できます。サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。一致基準の定義には Cisco IOS ソフトウェアのすべての IP アクセス リスト設定オプションを使用できます。

この例は、番号 40 の標準アクセス リストを作成しています。このフィルタにより、192.168.1.0/24 サブネットの IP アドレスを持つホストからのトラフィックが許可されます。

名前付きアクセス リストを使用した PBR VRF 選択の設定

VPN トラフィックのデータ パケット送信を許可または拒否するために、名前付きアクセス リストに PBR VRF ルート選択の一致基準を定義するには、次のコマンドを使用します。

手順の概要

1. enable

2. configure terminal

3. ip access-list { standard | extended} [ access-list-name | access-list-number ]

4. [ sequence-number ] { permit | deny } protocol source-addr source-wildcard destination-addr destination-wildcard [ option option-value] [ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip access-list { standard | extended } [ access-list-name | access-list-number ]

 

Router(config)# ip access-list extended NAMEDACL

IP アクセス リストのタイプを指定し、対応するアクセス リスト コンフィギュレーション モードを開始します。

標準、拡張、または名前付きのアクセス リストを使用できます。

ステップ 4

[ sequence-number ] { permit | deny} protocol source-addr source-wildcard destination-addr destination-wildcard [ option option-value ][ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

 

Router(config-ext-nacl)# permit ip any any option any-options

アクセス リストでパケットを許可または拒否する基準を定義します。

一致基準は、IP アドレス、IP アドレスの範囲、および他の IP パケット アクセス リストのフィルタリング オプションに基づいて定義できます。サポートされるアクセス リストは、名前付きアクセス リスト、番号付きアクセス リスト、標準アクセス リスト、および拡張アクセス リストです。一致基準の定義には Cisco IOS ソフトウェアのすべての IP アクセス リスト設定オプションを使用できます。

この例は、設定された IP オプションをすべて許可する名前付きアクセス リストを作成しています。

ルート マップでの PBR VRF 選択の設定

VPN トラフィックのデータ パケット送信を許可または拒否するために、アウトバウンド VPN パケットをポリシーに従ってルーティングする VRF を設定するには、次のコマンドを使用します。

着信パケットは、ルート マップに定義された一致基準を使用してフィルタリングされます。マッチングが適切に行われたあと、set vrf コマンド コンフィギュレーションによって、アウトバウンド VPN パケットをポリシーに従ってルーティングする VRF が決定されます。

前提条件

ルート マップを設定する前に、VRF を定義しておく必要があります。定義されていない場合はコンソールにエラー メッセージが表示されます。

受信エントリは、ip vrf receive コマンドを使用して VRF 選択テーブルに追加する必要があります。ルート マップで match と set の処理が行われたときにローカル VRF テーブルに受信エントリがない場合、パケットの宛先がローカルであればそのパケットはドロップされます。

制約事項

なし

手順の概要

1. enable

2. configure terminal

3. route-map map-tag [ permit | deny ] [ sequence-number]

4. match ip address {acl-number [acl-number ... | acl-name ...] | acl-name

[acl-name ... | acl-number ...]}

または

match length minimum-length maximum-length

5. set vrf vrf-name

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map map1 permit 10

ルート マップ コンフィギュレーション モードを開始します。

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配布する条件を定義するか、またはポリシー ルーティングをイネーブルにします。

ステップ 4

match ip address { acl-number [ acl-number ... | acl-name ...] | acl-name [ acl-name ... | acl-number ...]}

または

match length minimum-length maximum-length

 

Router(config-route-map)# match ip address 1

または

 

Router(config-route-map)# match length 3 200

標準アクセス リストまたは拡張アクセス リストで許可されている宛先ネットワーク番号アドレスを持つルートを配布し、一致したパケットに対してポリシー ルーティングを実行します。

IP アクセス リストがサポートされます。

この例は、標準アクセス リスト 1 を使用して一致基準を定義するように、ルートマップを設定しています。

または

クラス マップ内の一致基準として、IP ヘッダーのレイヤ 3 パケット長を指定します。

この例は、サイズが 3 ~ 200 バイトのパケットに一致するルート マップを設定しています。

ステップ 5

set vrf vrf-name

 

Router(config-route-map)# set vrf map1

PBR VRF 選択の同じルート マップ シーケンスで適切にマッチングが行われた VPN パケットをルーティングする VRF を定義します。

この例は、一致したパケットをポリシーに従って map1 という名前の VRF にルーティングします。

ステップ 6

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

インターフェイスでの PBR の設定

着信 VPN トラフィック データ パケットをフィルタリングするには、次のコマンドを使用します。着信パケットは、ルート マップに定義された一致基準を使用してフィルタリングされます。

ルート マップは着信インターフェイスに適用されます。着信インターフェイスにルート マップを付加するには、ip policy route-map グローバル コンフィギュレーション コマンドを使用します。

制約事項

ポリシーベース ルーティングを使用した VRF 選択機能と送信元 IP アドレスに基づく VRF 選択機能は同じルータ上に共存できますが、同じインターフェイスには 2 つの機能を同時に設定できません。これは、これらの機能の設定を誤った場合に VRF テーブル選択の衝突を防ぐよう設計された動作です。同じインターフェイス上で ip vrf select source コマンドと ip policy route-map コマンドを設定しようとすると、コンソールにエラー メッセージが表示されます。

手順の概要

1. enable

2. configure terminal

3. interface type number [ name-tag ]

4. ip policy route-map map-tag

5. ip vrf receive vrf-name

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number [ name-tag ]

 

Router(config)# interface FastEthernet 0/1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip policy route-map map-tag

 

Router(config-if)# ip policy route-map map1

インターフェイスでポリシー ルーティングに使用するルート マップを指定します。

この設定例は、map1 という名前のルート マップをインターフェイスに付加しています。

ステップ 5

ip vrf receive vrf-name

 

Router(config-if)# ip vrf receive VRF1

インターフェイスに関連付けられた IP アドレスを VRF テーブルに追加します。

このコマンドは、VRF 選択に使用される VRF ごとに設定する必要があります。

ステップ 6

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

インターフェイスでの IP VRF Receive の設定

VRF ルーティング テーブル内の接続されたルート エントリとしてインターフェイスの IP アドレスを挿入するには、次のコマンドを使用します。このことにより、パケットがドロップされなくなります。

VRF 選択テーブルには送信元 IP アドレスを追加する必要があります。VRF 選択は一方向(単一方向)の機能で、着信インターフェイスに適用されます。ルート マップで match と set の処理が行われたときにローカル VRF テーブルに VRF 受信エントリがない場合、パケットの宛先がローカルであればそのパケットはドロップされます。

手順の概要

1. enable

2. configure terminal

3. interface type number [ name-tag ]

4. ip policy route-map map-tag

5. ip vrf receive vrf-name

6. end

手順の詳細

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number [ name-tag ]

 

Router(config)# interface FastEthernet 0/1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip policy route-map map-tag

 

Router(config-if)# ip policy route-map map1

インターフェイスでポリシー ルーティングに使用するルート マップを指定します。

この設定例は、map1 という名前のルート マップをインターフェイスに付加しています。

ステップ 5

ip vrf receive vrf-name

 

Router(config-if)# ip vrf receive VRF1

インターフェイスに関連付けられた IP アドレスを VRF テーブルに追加します。

このコマンドは、VRF 選択に使用される VRF ごとに設定する必要があります。

ステップ 6

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ポリシーベース ルーティングを使用した VRF 選択の設定の確認

ポリシーベース ルーティングを使用した VRF 選択機能の設定を確認するには、この項の各手順を指定された順序で実行します。

手順の概要

1. enable

2. show ip access-list [ access-list-number | access-list-name ]

3. show route-map [ map-name ]

4. show ip policy

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip access-list [ access-list-number | access-list-name ]

 

Router# show ip access-list

現在のすべての IP アクセス リストの内容を表示します。

アクセス リストに定義された一致基準を確認するには、このコマンドを使用します。名前付きアクセス リストと番号付きアクセス リストの両方がサポートされます。

ステップ 3

show route-map [ map-name ]

 

Router# show route-map

設定済みのすべてのルート マップを表示するか、または指定した 1 つのルート マップだけを表示します。

ルート マップ内の match 句および set 句を確認するには、このコマンドを使用します。

ステップ 4

show ip policy

 

Router# show ip policy

ポリシー ルーティングに使用されるルート マップを表示します。

このコマンドを使用すると、ルート マップおよび関連付けられたインターフェイスを表示できます。

ポリシーベース ルーティングを使用した VRF 選択の設定例

ここでは、次の設定例について説明します。

「アクセス リストでの PBR VRF 選択の定義:例」

「ポリシーベース ルーティングを使用した VRF 選択の確認:例」

アクセス リストでの PBR VRF 選択の定義:例

次に、3 つの標準アクセス リストを作成して、3 つの異なるサブネットの一致基準を定義する例を示します。Ethernet 0/1 インターフェイスで受信したパケットは、PBR-VRF-Selection ルート マップを使用するポリシーに従って、同じルート マップ シーケンスで一致した VRF にルーティングされます。パケットの送信元 IP アドレスが 10.1.0.0/24 サブネットに含まれる場合は、ルーティングおよび転送に VRF1 が使用されます。

 
access-list 40 permit 10.1.0.0 0.0.255.255
access-list 50 permit 10.2.0.0 0.0.255.255
access-list 60 permit 10.3.0.0 0.0.255.255
 
route-map PBR-VRF-Selection permit 10
match ip address 40
set vrf VRF1
!
route-map PBR-VRF-Selection permit 20
match ip address 50
set vrf VRF2
!
route-map PBR-VRF-Selection permit 30
match ip address 60
set vrf VRF3
!
interface Ethernet0/1
ip address 192.168.1.6 255.255.255.252
ip policy route-map PBR-VRF-Selection
ip vrf receive VRF1
ip vrf receive VRF2
ip vrf receive VRF3

ポリシーベース ルーティングを使用した VRF 選択の確認:例

次に、定義された一致基準とルート マップ ポリシー設定を確認する例を示します。

一致基準の確認

PBR VRF 選択の一致基準の設定を確認するには、show ip access-list コマンドを使用します。

次の show ip access-list コマンド出力には、3 つの標準アクセス リストに一致基準として定義された、3 つのサブネット範囲が表示されます。

Router# show ip access-list
 
Standard IP access list 40
10 permit 10.1.0.0, wildcard bits 0.0.255.255
Standard IP access list 50
10 permit 10.2.0.0, wildcard bits 0.0.255.255
Standard IP access list 60
10 permit 10.3.0.0, wildcard bits 0.0.255.255

ルート マップの設定の確認

ルート マップの設定を確認するには、show route-map コマンドを使用します。出力には、各ルート マップ シーケンスの一致基準および設定アクションが表示されます。また、出力には、ルート マップ シーケンスごとに、ポリシー ルーティングが行われたパケット数とバイト数も表示されます。

Router# show route-map
 
route-map PBR-VRF-Selection, permit, sequence 10
Match clauses:
ip address (access-lists): 40
Set clauses:
vrf VRF1
Policy routing matches: 0 packets, 0 bytes
route-map PBR-VRF-Selection, permit, sequence 20
Match clauses:
ip address (access-lists): 50
Set clauses:
vrf VRF2
Policy routing matches: 0 packets, 0 bytes
route-map PBR-VRF-Selection, permit, sequence 30
Match clauses:
ip address (access-lists): 60
Set clauses:
vrf VRF3
Policy routing matches: 0 packets, 0 bytes

PBR VRF 選択ポリシーの確認

次の show ip policy コマンド出力には、ポリシー ルーティングを設定したインターフェイスおよび関連付けられたルート マップが表示されます。

Router# show ip policy
 
Interface Route map
Ethernet0/1 PBR-VRF-Selection

 

その他の関連資料

ここでは、MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択機能の関連資料について説明します。

関連資料

関連項目
参照先

送信元 IP アドレスに基づく VRF 選択

『Directing MPLS VPN Traffic Using a Source IP Address』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存規格のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS MPLS Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List, All Releases 』( http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html )にアクセスしてください。

ip vrf receive

set vrf

ポリシーベース ルーティングを使用した VRF 選択の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 ポリシーベース ルーティングを使用した VRF 選択の機能情報

機能名
リリース
機能情報

MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択

12.3(7)T
12.2(25)S
12.2(33)SRB
12.2(33)SXI

MPLS VPN:ポリシーベース ルーティングを使用した VRF 選択機能は、MPLS VPN:送信元 IP アドレスに基づく VRF 選択機能を拡張したものです。この機能によって Policy-Based Routing(PBR; ポリシーベース ルーティング)メカニズムが導入され、複数の VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)選択の一致基準に基づいて Virtual Private Network(VPN; バーチャル プライベート ネットワーク)トラフィックの分類と転送が行われます。

この機能は、12.3(7)T で導入されました。

この機能は、Cisco IOS Release 12.2(25)S に統合されました。

この機能は、Cisco IOS Release 12.2(33)SRB に統合されました。

この機能は、Cisco IOS Release 12.2(33)SXI に統合されました。

次のコマンドが導入または変更されました。 ip vrf receive、set vrf

用語集

PBR :Policy-Based Routing(ポリシーベース ルーティング)。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。

VRF :Virtual Routing and Forwarding(仮想ルーティングおよび転送)。