Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS VPN - Inter-AS オプション AB
MPLS VPN - Inter-AS オプション AB
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS VPN - Inter-AS オプション AB

この章の構成

MPLS VPN - Inter-AS オプション AB の前提条件

MPLS VPN - Inter-AS オプション AB の制約事項

MPLS VPN - Inter-AS オプション AB に関する情報

MPLS VPN - Inter-AS オプション AB の概要

MPLS VPN - Inter-AS オプション AB の利点

MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送

VPN 1 のルート配布

VPN 1 のパケット転送

VPN 2 のルート配布

MPLS VPN - Inter-AS オプション AB の CSC におけるルート配布およびパケット転送

VPN 1 のルート配布

VPN 1 のパケット転送

Inter-AS オプション AB の設定方法

Inter-AS オプション AB 接続の設定

各 VPN カスタマーの ASBR インターフェイスへの VRF の設定

ASBR ピア間での MP-BGP セッションの設定

Inter-AS 接続を必要とする VPN のルーティング ポリシーの設定

Inter-AS オプション A 配置のオプション AB 配置への変更

MPLS VPN - Inter-AS オプション AB の設定例

Inter-AS AB ネットワーク設定:例

CE1:例

CE2:例

PE1:例

ルート リフレクタ 1:例

ASBR1:例

ASBR3:例

PE2:例

CE3:例

CE4:例

Inter-AS AB CSC 設定:例

CE1:例

CE2:例

CE3:例

CE4:例

PE1:例

CSC-CE1:例

CSC-PE1:例

PE2:例

CSC-CE2:例

ASBR1:例

CSC-PE3:例

CSC-CE3:例

CSC-CE4:例

PE3:例

PE4:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS VPN - Inter-AS オプション ABの機能情報

用語集

MPLS VPN - Inter-AS オプション AB

MPLS VPN - Inter-AS オプション AB 機能は、Inter-AS オプション(10)A ネットワークと Inter-AS オプション(10)B ネットワークの最良の機能を組み合せたものです。Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービス プロバイダーは、この機能を使用して、さまざまな自律システムを相互接続して VPN サービスを提供できます。これらのネットワークは、RFC 4364 の第 10 項「Multi-AS Backbones」でオプション「a」およびオプション「b」としてそれぞれ定義されています。

MPLS VPN - Inter-AS オプション AB 設定においてさまざまな自律システムが相互接続されると、ネットワーク設定全体がスケーラブルで簡易なものとなり、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)ピア間で IP Quality of Service(QoS; サービス品質)機能が維持されます。

Inter-AS オプション A ネットワークでは、ASBR ピアは複数のサブインターフェイスによって接続され、2 つの自律システムにまたがるインターフェイス VPN が少なくとも 1 つ設定されます。これらの ASBR では、各サブインターフェイスが VRF およびラベル付けされていない IP プレフィクスのシグナリング用の BGP セッションに関連付けられます。その結果、連続する VRF 間のトラフィックは IP となります。このシナリオでは、各 VPN は相互に分離されます。また、トラフィックが IP であるため、IP トラフィック上で動作する QoS メカニズムを適用して、カスタマー Service Level Agreement(SLA; サービス レベル契約)を実現できます。この設定の欠点は、各サブインターフェイスに 1 つの BGP セッションが必要となることです(各 VPN に少なくとも 1 つのサブインターフェイスも必要となります)。このことは、このネットワークの規模が大きくなるにつれて、スケーラビリティに関する問題が発生する原因となります。

Inter-AS オプション B ネットワークでは、ASBR ピアは、MPLS トラフィックを受信できる 1 つ以上のサブインターフェイスによって接続されます。ASBR 間でのラベル付き VPN プレフィクスの配布には、Multi-Protocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)セッションが使用されます。その結果、それらの間のトラフィック フローはラベル付きとなります。この設定の欠点は、トラフィックが MPLS であるため、IP トラフィックにだけ適用できる QoS メカニズムを適用できず、VRF を分離することもできないことです。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用の Cisco IOS ソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、 「MPLS VPN - Inter-AS オプション ABの機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS VPN - Inter-AS オプション AB の前提条件

次のマニュアルに説明されている適切な設定作業を実行してください。

『Configuring MPLS Layer 3 VPNs』

MPLS VPN Inter-AS with ASBRs Exchanging VPN-IPv4 Addresses

MPLS VPN Inter-AS with ASBRs Exchanging IPv4 Routes and MPLS Labels

MPLS VPN - Inter-AS オプション AB 機能を設定する前に、次の前提条件を設定する必要があります。

MPLS VPN ルーティングおよび転送動作に必要なシスコ エクスプレス フォワーディングのイネーブル化

MPLS VPN - Inter-AS オプション AB ネットワークの VPN の特定、およびこれらの VPN が属する VRF の設定 これらの VRF は、ASBR インターフェイス上の Inter-AS オプション AB 接続で使用されます。

MPLS VPN - Inter-AS オプション AB の制約事項

この機能には、次の制約事項があります。

In Service Software Upgrade(ISSU; インサービス ソフトウェア アップグレード)機能は、スタンバイ Route Processor(RP; ルート プロセッサ)でこの機能がサポートされている場合にだけアクティブ RP に設定できます。アクティブ RP とスタンバイ RP の両方でこの機能がサポートされている場合には、ISSU 機能を設定できます。

Carrier Supporting Carrier(CSC)MPLS ロードバランシングは、ASBR オプション AB VRF インターフェイスではサポートされていません。

VPNv6 はサポートされていません。

MPLS VPN - Inter-AS オプション AB に関する情報

ここでは、MPLS VPN - Inter-AS オプション AB 機能およびその利点について説明します。

「MPLS VPN - Inter-AS オプション AB の概要」

「MPLS VPN - Inter-AS オプション AB の利点」

「MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送」

「MPLS VPN - Inter-AS オプション AB の CSC におけるルート配布およびパケット転送」

MPLS VPN - Inter-AS オプション AB の概要

MPLS VPN サービス プロバイダーは、さまざまな自律システムを相互接続して、複数の VPN カスタマーにサービスを提供する必要があります。MPLS VPN - Inter-AS オプション AB 機能を使用すると、グローバル ルーティング テーブル内の単一の MP-BGP セッションを使用してさまざまな自律システムを相互接続し、コントロール プレーン トラフィックを伝送できます。この MP-BGP セッションでは、2 つの ASBR 間で、各 Virtual Routing and Forwarding(VRF)インスタンスの VPN プレフィクスがシグナリングされます。データ プレーン トラフィックは VRF インターフェイス経由で送受信されます。このトラフィックは、IP または MPLS です。


) Inter-AS 接続は、異なるプロバイダー間の接続を持つ ASBR 間でも持たない ASBR 間でも設定できます。


MPLS VPN - Inter-AS オプション AB の利点

MPLS VPN - Inter-AS オプション AB 機能には、サービス プロバイダーにとって次の利点があります。

ASBR で各 VRF に対して 1 つの BGP セッションだけが設定されるため、ネットワーク設定が簡略化されます。

BGP セッションが 1 つで済むため、CPU 使用率が低減されます。

ルータでグローバルにイネーブル化される単一の MP-BGP セッションだけが必要なため複数の VPN で必要となるセッション数が減り、また VPN が相互に分離および保護されることによって、ネットワークのスケーラビリティを向上できます。

ASBR ピア間の IP QoS 機能を維持し、カスタマー SLA を実現できます。

データ プレーン トラフィックは、セキュリティ上の目的で VRF ごとに分離されます。

MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送

ここでは、MPLS VPN - Inter-AS オプション AB の動作について説明します。

「VPN 1 のルート配布」

「VPN 1 のパケット転送」

「VPN 2 のルート配布」


) すべてのルートのインポートは、適切な Route Target(RT; ルート ターゲット)を設定することによって行われます。


次のアトリビュートは、図 1 に示すサンプル MPLS VPN - Inter-AS オプション AB ネットワークのトポロジを示しています。

カスタマー エッジ 1(CE1)と CE3 は VPN 1 に属しています。

CE2 と CE4 は VPN 2 に属しています。

プロバイダー エッジ 1(PE1)では、VPN 1(VRF 1)にルート識別子 1(RD 1)を、VPN 2(VRF 2)に RD 2 を使用しています。

PE2 では、VPN 1(VRF 1)に RD 3 を、VPN 2(VRF 2)に RD 4 を使用しています。

ASBR1 では、VRF 1 が RD 5 に、VRF 2 が RD 6 にプロビジョニングされています。

ASBR2 では、VRF 1 が RD 7 に、VRF 2 が RD 8 にプロビジョニングされています。

ASBR1 と ASBR2 との間には 3 つのリンクがあります。

VRF 1

VRF 2

MP-BGP セッション


) ASBR に設定された VRF は「オプション AB VRF」と呼ばれます。ASBR の eBGP ピアは「オプション AB ピア」と呼ばれます。


図 1 MPLS VPN Inter-AS オプション AB トポロジ

 

VPN 1 のルート配布

Route Distinguisher(RD; ルート識別子)は、各ルートにどの VPN が属しているかを識別するためにルートに付加される識別子です。各ルーティング インスタンスには、一意な RD 自律システムが関連付けられている必要があります。RD は、VPN の周囲に境界を設置して、異なる VPN で同じ IP アドレス プレフィクスを使用してもこれらの IP アドレス プレフィクスが重複しないようにするために使用されます。


) RD 文は、インスタンス タイプが VRF である場合は必須です。


次のプロセスは、図 1 の VPN 1 のルート配布プロセスを示しています。このプロセスで使用されているプレフィクス「N」は、VPN の IP アドレスを示しています。

1. CE1 は、プレフィクス N を PE1 にアドバタイズします。

2. PE1 は、VPN プレフィクス RD 1:N を ASBR1 に MP internal BGP(iBGP; 内部 BGP)経由でアドバタイズします。

3. ASBR1 は、プレフィクスを VPN 1 にインポートして、プレフィクス RD 5:N を作成します。

4. ASBR1 は、インポートしたプレフィクス RD 5:N を ASBR2 にアドバタイズします。ASBR1 は、自身をプレフィクス RD 5:N のネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルを割り当てます。

5. ASBR1 は、最初に受信した RT ではなく、VRF に設定されたエクスポート RT を使用してルートをアドバタイズします。デフォルトで、ASBR1 はソース プレフィクス RD 1:N を ASBR2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。


) オプション 10B 接続では、ASBR1 がオプション 10B 接続を持っている他の ASBR にソース プレフィクスをアドバタイズできます。オプション 10B 接続を持っている ASBR では、すべての VPNv4 ルートが BGP テーブルに維持されます。


6. ASBR2 は、プレフィクス RD 5:N を受信して、RD 7:N として VPN 1 にインポートします。

7. ASBR2 は、最初に受信した RT ではなく、VRF に設定されたエクスポート RT を使用してルートをアドバタイズします。

8. プレフィクスのインポート時に、ASBR2 は RD 7:N のネクストホップを VRF 1 の ASBR1 インターフェイス IP アドレスに設定します。ネクストホップ テーブル ID も VRF 1 に設定されます。RD 7:N 用の MPLS 転送エントリをインストールする場合、デフォルトで発信ラベルは転送にはインストールされません。これにより、ASBR 間のトラフィックを IP にすることができます。

9. ASBR2 は、インポートしたプレフィクス RD 7:N を PE2 にアドバタイズします。ASBR2 は、自身をこのプレフィクスのネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルも割り当てます。デフォルトで、ASBR2 はソース プレフィクス RD 5:N を PE2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。

10. PE2 は、RD 7:N を RD 3:N として VRF 1 にインポートします。

VPN 1 のパケット転送

次のパケット転送プロセスは、オプション A のシナリオと同様に動作します。ASBR は VPN の終端となることによって PE と同様に動作し、トラフィックを標準 IP パケットとして VPN ラベルなしで次の PE に転送します。その後、次の PE で VPN プロセスが繰り返されます。したがって、各 PE ルータは隣接 PE ルータを CE ルータとして扱い、各自律システムでのルート再配布には標準的なレイヤ 3 MPLS VPN メカニズムが使用されます。つまり、各 PE は、external BGP(eBGP; 外部 BGP)を使用して相互にラベルなし IPv4 アドレスを配布します。


) このプロセスで使用されているプレフィクス「N」は、VPN の IP アドレスを示しています。


1. CE3 は、N 宛てのパケットを PE2 に送信します。

2. PE2 は、ASBR2 によって割り当てられた VPN ラベル、およびパケットを ASBR2 にトンネリングするために必要な IGP ラベルでパケットをカプセル化します。

3. パケットは、VPN ラベルが付いた状態で ASBR2 に到達します。ASBR2 は VPN ラベルを削除し、パケットを IP として ASBR1 の VRF 1 インターフェイスに送信します。

4. IP パケットが、ASBR1 の VRF 1 インターフェイスに到達します。ASBR1 は、PE1 によって割り当てられた VPN ラベル、およびパケットを PE1 にトンネリングするために必要な IGP ラベルでパケットをカプセル化します。

5. パケットは、VPN ラベルが付いた状態で PE1 に到達します。PE1 は VPN ラベルを削除して、IP パケットを CE1 に転送します。

VPN 2 のルート配布

次の情報は、図 1 の VPN 2 のルート配布プロセスを示しています。

1. CE2 は、プレフィクス N を PE1 にアドバタイズします。N は VPN IP アドレスです。

2. PE1 は、VPN プレフィクス RD 2:N を ASBR1 に MP-iBGP 経由でアドバタイズします。

3. ASBR1 は、プレフィクスを VPN 2 にインポートして、プレフィクス RD 6:N を作成します。

4. ASBR1 は、インポートしたプレフィクス RD 6:N を ASBR2 にアドバタイズします。ASBR2 は、自身をこのプレフィクスのネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルも割り当てます。デフォルトで、ASBR1 はソース プレフィクス RD 2:N を ASBR2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。


) オプション 10B 接続では、ASBR1 がオプション 10B 接続を持っている他の ASBR にソース プレフィクスをアドバタイズできます。オプション 10B 接続を持っている ASBR では、すべての VPNv4 ルートが BGP テーブルに維持されます。


5. ASBR2 は、プレフィクス RD 6:N を受信して、RD 8:N として VPN 2 にインポートします。

6. プレフィクスのインポート時に、ASBR2 は RD 8:N のネクストホップを VRF 2 の ASBR1 インターフェイス アドレスに設定します。ネクストホップ テーブル ID も VRF 2 の ID に設定されます。RD 8:N 用の MPLS 転送エントリをインストールする場合、デフォルトで発信ラベルは転送にはインストールされません。これにより、ASBR 間のトラフィックを IP にすることができます。

7. ASBR2 は、インポートしたプレフィクス RD 8:N を PE2 にアドバタイズします。ASBR2 は、自身をこのプレフィクスのネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルも割り当てます。デフォルトで、ASBR2 はソース プレフィクス RD 6:N を PE2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。

8. PE2 は、RD 8:N を RD 4:N として VRF 2 にインポートします。

MPLS VPN - Inter-AS オプション AB の CSC におけるルート配布およびパケット転送

ここでは、CSC シナリオにおける VPN 1 の MPLS VPN - Inter-AS オプション AB 動作について説明します。ここでの説明は、「MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送」での VPN 1 についての説明と似ていますが、MPLS ラベルが 2 つの ASBR 間で処理される方法が異なります。

「VPN 1 のルート配布」

「VPN 1 のパケット転送」


) ここでは、VPN 2 については説明しません。


図 2 に、VPN 1 によって小規模カスタマー キャリアに VPN サービスが提供され、さらにその小規模カスタマー キャリアが顧客に VPN サービスを提供するようすを示します。この設定では、小規模カスタマー キャリアの PE(PE3 および PE4)ループバック インターフェイス間で Label Switched Path(LSP; ラベル スイッチド パス)を提供するために VPN 1 が使用されています。

図 2 MPLS VPN Inter-AS オプション AB CSC トポロジ

 


) ここでの RD、RT、VRF、およびリンクのプロビジョニングは、「MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送」の VPN 1 についての例と同様です。


VPN 1 のルート配布

次の情報は、図 1 の VPN 1 のルート配布プロセスを示しています。これらの手順で使用されているプレフィクス「N」は、VPN の IP アドレスを示しています。

1. CE1 は、PE3 ループバック N を PE1 にアドバタイズします。

2. PE1 は、VPN プレフィクス RD 1:N を ASBR1 に MP-iBGP 経由でアドバタイズします。

3. ASBR1 は、プレフィクスを VPN 1 にインポートして、プレフィクス RD 5:N を作成します。

4. ASBR1 は、インポートしたプレフィクス RD 5:N を ASBR2 にアドバタイズします。ASBR2 は、自身をこのプレフィクスのネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルも割り当てます。

5. ASBR1 は、最初に受信した RT ではなく、VRF に設定されたエクスポート RT を使用してルートをアドバタイズします。デフォルトで、ASBR1 はソース プレフィクス RD 1:N を ASBR2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。


) オプション 10B 接続では、ASBR1 がオプション 10B 接続を持っている他の ASBR にソース プレフィクスをアドバタイズできます。オプション 10B 接続を持っている ASBR では、すべての VPNv4 ルートが BGP テーブルに維持されます。


6. ASBR2 は、プレフィクス RD 5:N を受信して、RD 7:N として VPN 1 にインポートします。

7. ASBR2 は、最初に受信した RT ではなく、VRF に設定されたエクスポート RT を使用してルートをアドバタイズします。

8. プレフィクスのインポート時に、ASBR2 は RD 7:N のネクストホップを VRF 1 の ASBR1 インターフェイス アドレスに設定します。ネクストホップ テーブル ID も VRF 1 の ID に設定されます。


) CSC シナリオでは、設定を変更することによって、転送に発信 MPLS ラベルをインストールできます。「Inter-AS オプション AB の設定方法」 を参照してください。


9. RD 7:N 用の MPLS 転送エントリをインストールする場合、転送プロセス中に発信ラベルがインストールされ、これにより ASBR 間のトラフィックを MPLS トラフィックにすることができます。

10. ASBR2 は、インポートしたプレフィクス RD 7:N を PE2 にアドバタイズします。ASBR2 は、自身をこのプレフィクスのネクストホップとして設定し、このプレフィクスとともにシグナリングされるローカル ラベルも割り当てます。デフォルトで、ASBR2 はソース プレフィクス RD 5:N を PE2 にアドバタイズしません。このプレフィクスは、オプション AB VRF にインポートされるプレフィクスであるため、アドバタイズされません。

11. PE2 は、RD 7:N を RD 3:N として VRF 1 にインポートします。

VPN 1 のパケット転送

次のパケット転送プロセスは、オプション A のシナリオと同様に動作します。オプション A の詳細については、「MPLS VPN - Inter-AS オプション AB の非 CSC ネットワークにおけるルート配布およびパケット転送」を参照してください。

1. PE4 は、N 宛ての MPLS パケットを CE2 に送信します。

2. CE2 は MPLS ラベルを交換して、N 宛てのパケットを PE2 に送信します。

3. PE2 は、ASBR2 によって割り当てられた VPN ラベル、およびパケットを ASBR2 にトンネリングするために必要な IGP ラベルでパケットをカプセル化します。

4. パケットは、VPN ラベルが付いた状態で ASBR2 に到達します。ASBR2 は受信した VPN ラベルを ASBR1 から受信した発信ラベルと交換して、MPLS パケットを VRF 1 インターフェイスに送信します。

5. MPLS パケットが、ASBR1 の VRF 1 インターフェイスに到達します。ASBR1 は、受信した MPLS ラベルを、PE1 によって割り当てられた VPN ラベルおよびパケットを PE1 にトンネリングするために必要な IGP ラベルで構成されるラベル スタックと交換します。

6. パケットは、VPN ラベルが付いた状態で PE1 に到達します。PE1 は VPN ラベルを削除して、MPLS パケットを CE1 に転送します。その後、CE1 はラベルを交換して、ラベル付きパケットを PE3 に転送します。

Inter-AS オプション AB の設定方法

ここでは、MPLS VPN または CSC をサポートする MPLS VPN において ASBR で Inter-AS オプション AB 機能を設定する方法について説明します。

「Inter-AS オプション AB 接続の設定」

「Inter-AS オプション A 配置のオプション AB 配置への変更」

Inter-AS オプション AB 接続の設定

ここでは、ASBR に Inter-AS オプション AB 接続を設定する方法について説明します。

「各 VPN カスタマーの ASBR インターフェイスへの VRF の設定」

「ASBR ピア間での MP-BGP セッションの設定」

「Inter-AS 接続を必要とする VPN のルーティング ポリシーの設定」


) MPLS VPN における PE および CE ルータの設定の詳細については、『Configuring MPLS Layer 3 VPNs』の章を参照してください。


各 VPN カスタマーの ASBR インターフェイスへの VRF の設定

各 VPN カスタマーの ASBR インターフェイスに VRF を設定して、これらの VPN が MPLS VPN - Inter-AS オプション AB を使用して接続できるようにするには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip vrf forwarding vrf-name

5. mpls bgp forwarding (任意)

6. end


mpls bgp forwarding コマンドは、CSC をサポートする VRF の ASBR インターフェイスでだけ使用されます。


ASBR インターフェイスに設定する必要がある追加の VRF およびピア ASBR インターフェイスに設定する必要がある VRF を設定するには、次に示すすべての手順を使用します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number
 
Router(config)# interface Ethernet 5/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 4

ip vrf forwarding vrf-name
 
Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 5

mpls bgp forwarding
 
Router(config-if)# mpls bgp forwarding

(任意)この手順は CSC ネットワークにだけ適用されます。BGP を設定して、MPLS トラフィックをサポートする必要がある VRF の接続インターフェイスで MPLS 転送をイネーブルにします。

ステップ 6

end
 
Router(config-if)# end

(任意)終了して、特権 EXEC モードに戻ります。

ASBR ピア間での MP-BGP セッションの設定

BGP では、IPv4 以外のアドレス ファミリのサポートを定義する BGP マルチプロトコル拡張を使用して、PE ルータ間で VPN-IPv4 プレフィクスの到達可能性情報が伝播されます(RFC 2283、『 Multiprotocol Extensions for BGP-4 』を参照)。この拡張を使用すると、指定された VPN のルートが、その VPN の他のメンバによってだけ学習されるようになり、VPN のメンバ間の相互通信が可能になります。

ASBR で MP-BGP セッションを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. neighbor { ip-address | peer-group-name } remote-as as-number

5. address-family vpnv4 [ unicast ]

6. neighbor { ip-address | peer-group-name } activate

7. neighbor { ip-address | peer-group-name } inter-as-hybrid

8. exit-address-family

9. end

ピア ASBR で MP-BGP セッションを設定するには、次に示すすべての手順を使用します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

 
Router(config-router)# neighbor 192.168.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 5

address-family vpn4 [unicast]

 
Router(config-router)# address-family vpn4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 
Router(config-router-af)# neighbor 192.168.0.1 activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

neighbor { ip-address | peer-group-name } inter-as-hybrid

 
Router(config-router-af)# neighbor 192.168.0.1 inter-as-hybrid

eBGP ピア ルータ(ASBR)を Inter-AS オプション AB ピアとして設定します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

プレフィクスがオプション AB VRF にインポートされると、インポートされたパスがこのピアにアドバタイズされます。

プレフィクスがこのピアから受信され、オプション AB VRF にインポートされると、インポートされたパスが iBGP ピアにアドバタイズされます。

(注) アドバタイズされるルートは、VRF に設定された RT を持ちます。アドバタイズされるルートには、元の RT は設定されません。

ステップ 8

exit-address-family

 
Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション サブモードを終了します。

ステップ 9

end

 
Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

Inter-AS 接続を必要とする VPN のルーティング ポリシーの設定

適切なルーティング ポリシーおよびオプション AB 設定を設定することによって ASBR ピア間に Inter-AS 接続を必要とする VPN の VRF を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. vrf definition vrf-name

4. rd route-distinguisher

5. address-family ipv4

6. route-target { import | export | both } route-target-ext-community

7. inter-as-hybrid [ csc ]

8. inter-as-hybrid [ csc ] next-hop ip-address

9. exit

この ASBR とピア ASBR に Inter-AS オプション AB 接続を必要とする追加の VPN を設定するには、次に示すすべての手順を使用します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vrf definition vrf-name
 
Router(config)# vrf definition vpn1

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 4

rd route-distinguisher
 
Router(config-vrf)# rd 100:1

ルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットの自律システム番号:32 ビットの番号。101:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.168.122.15:1 など。

ステップ 5

address-family ipv4

 

Router(config-vrf)# address-family ipv4

VRF アドレス ファミリ コンフィギュレーション モードを開始して、VRF のアドレス ファミリを指定します。

ipv4 キーワードは、VRF の IPv4 アドレス ファミリを指定します。

ステップ 6

route-target {import | export | both} route-target-ext-community
 
Router(config-vrf-af)# route-target import 100:1

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートまたはエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

inter-as-hybrid [ csc ]
 
Router(config-vrf-af)# inter-as-hybrid

VRF をオプション AB VRF として指定します。これには、次のような効果があります。

この VRF にインポートされたルートは、オプション AB ピアおよび VPNv4 iBGP ピアにアドバタイズできます。

ルートがオプション AB ピアから受信され、VRF にインポートされると、ルートのネクストホップ テーブル ID が VRF のテーブル ID に設定されます。

csc キーワードが使用されていない場合、VRF 単位のラベルがインポートされたルートに割り当てられます。

ルートがオプション AB ピアから受信され、VRF にインポートされると、学習された発信ラベルは csc キーワードが使用されている場合にだけ転送にインストールできます。

csc キーワードを指定すると、次のような効果があります。

インポートされたルートにプレフィクス単位のラベルが割り当てられます。

オプション AB ピアから受信され、VRF にインポートされるルートでは、学習された発信ラベルが転送にインストールされます。

ステップ 8

inter-as-hybrid [ csc ] next-hop ip-address
 
Router(config-vrf-af)# inter-as-hybrid next-hop 192.168.1.0

(任意)VRF にインポートされ、オプション AB ピアから受信されるパスにネクストホップ IP アドレスを設定することを指定します。ネクストホップ コンテキストも、これらのパスをインポートする VRF に設定されます。

csc キーワードを指定すると、次のような効果があります。

インポートされたルートにプレフィクス単位のラベルが割り当てられます。

オプション AB ピアから受信され、VRF にインポートされるルートでは、学習された発信ラベルが転送にインストールされます。

ステップ 9

exit
 
Router(config-vrf-af)# exit

グローバル コンフィギュレーション モードに戻ります。

Inter-AS オプション A 配置のオプション AB 配置への変更

オプション A 配置では、VRF インスタンスは ASBR ルータ間で連続しており、異なる自律システムの PE ルータ間は直接接続されています。PE ルータは複数の物理または論理インターフェイスによって接続され、それぞれのインターフェイスは(VRF インスタンスを通して)特定の VPN に関連付けられています。

オプション AB 配置では、グローバル ルーティング テーブル内の単一の MP-BGP セッションを使用してさまざまな自律システムが相互接続され、コントロール プレーン トラフィックが伝送されます。

MPLS VPN Inter-AS オプション A 配置をオプション AB 配置に変更するには、次の手順を実行します。

1. ASBR で MP-BGP セッションを設定します。特定の VPN のルートをその VPN の他のメンバだけが学習でき、VPN のメンバが相互に通信できるように、BGP マルチプロトコル拡張を使用して IPv4 以外のアドレス ファミリのサポートが定義されます。設定の詳細については、「ASBR ピア間での MP-BGP セッションの設定」を参照してください。

2. オプション A からのアップグレードを必要とする VRF を特定して、 inter-as-hybrid コマンドを使用することによってそれらの VRF をオプション AB として設定します。設定の詳細については、「Inter-AS 接続を必要とする VPN のルーティング ポリシーの設定」を参照してください。

3. 次の手順を実行して、eBGP(ピア ASBR)ネイバーの設定を削除します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. address-family ipv4 vrf vrf-name

5. no neighbor { ip-address | peer-group-name }

6. exit-address-family

7. end

次のすべての手順を繰り返して、その他の eBGP(ピア ASBR)ネイバーの設定を削除します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 
Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 vrf vrf-name

 
Router(config-router)# address-family ipv4 vrf vpn4

特定の VPN のルートをその VPN の他のメンバだけが学習でき、VPN のメンバが相互に通信できるように、ASBR の MP-BGP セッションで識別される各 VRF を設定します。アドレス ファミリ コンフィギュレーション モードを開始して、VRF のアドレス ファミリを指定します。

ステップ 5

no neighbor { ip-address | peer-group-name }

 
Router(config-router-af)# no neighbor 192.168.0.1

ネイバー eBGP(ASBR)ルータと情報を交換するための設定を削除します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 6

exit-address-family

 
Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 7

end

 
Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

MPLS VPN - Inter-AS オプション AB の設定例

ここでは、Inter-AS AB 機能を使用する 2 つの ASBR 間における標準 MPLS VPN 設定および CSC MPLS VPN 設定について説明します。

「Inter-AS AB ネットワーク設定:例」

「Inter-AS AB CSC 設定:例」

Inter-AS AB ネットワーク設定:例

次に、重複しない IP アドレスを使用した Inter-AS オプション AB ネットワークの設定の例を示します。

「CE1:例」

「CE2:例」

「PE1:例」

「ルート リフレクタ 1:例」

「ASBR1:例」

「ASBR3:例」

「PE2:例」

「CE3:例」

「CE4:例」

CE1:例

!
ip cef distributed
!
interface lo0
ip address 192.168.13.13 255.255.255.255
no shutdown
!
interface et4/0
ip address 192.168.36.1 255.255.255.0
no shutdown
!
router ospf 300
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface et4/0
network 192.168.13.13 0.0.0.0 area 300
!
router bgp 300
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
neighbor 192.168.36.2 remote-as 100
neighbor 192.168.36.2 advertisement-interval 5
address-family ipv4 no auto-summary
redistribute connected
neighbor 192.168.36.2 activate

CE2:例

!
ip cef distributed
!
interface lo0
ip address 192.168.14.14 255.255.255.255
no shutdown
!
interface et1/6
ip address 192.168.37.1 255.255.255.0
no ipv6 address
no shutdown
!
router ospf 400
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface et1/6
network 192.168.14.14 0.0.0.0 area 400
!
router bgp 400
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
neighbor 192.168.0.2 remote-as 100
neighbor 192.168.0.2 advertisement-interval 5
address-family ipv4 no auto-summary
redistribute connected
neighbor 192.168.0.2 activate
!

PE1:例

!
ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target import 100:1
route-target import 200:1
route-target export 100:1
!
ip vrf vpn2
rd 100:2
route-target import 100:2
route-target import 200:2
route-target export 100:2
!
mpls ldp router-id lo0 force
mpls ldp graceful-restart
mpls ip
mpls ip propagate-ttl
mpls ldp advertise-labels
mpls label protocol ldp
!
interface lo0
ip address 192.168.17.17 255.255.255.255
no shutdown
!
interface gi3/1
ip vrf forwarding vpn1
ip address 192.168.36.2 255.255.255.0
no shutdown
!
interface gi3/8
mpls ip
mpls label protocol ldp
ip address 192.168.31.2 255.255.255.0
!
interface gi3/10
mpls ip
mpls label protocol ldp
ip address 192.168.40.1 255.255.255.0
no shutdown
!
interface gi3/13
ip vrf forwarding vpn2
ip address 192.168.0.2 255.0.0.0
no shutdown
!
router ospf 100
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface gi3/1
passive-interface gi3/13
network 192.168.0.0 0.0.255.255 area 10
network 192.168.17.17 0.0.0.0 area 100
network 192.168.0.0 0.0.255.255 area 100
!
router bgp 100
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no bgp default ipv4-unicast
no synchronization
neighbor 192.168.19.19 remote-as 100
neighbor 192.168.19.19 update-source Loopback0
address-family ipv4 vrf vpn1
no auto-summary
redistribute connected
neighbor 192.168.36.1 remote-as 300
neighbor 192.168.36.1 activate
neighbor 192.168.36.1 advertisement-interval 5
address-family ipv4 vrf vpn2 no auto-summary
redistribute connected
neighbor 192.168.37.1 remote-as 400
neighbor 192.168.37.1 activate
neighbor 192.168.37.1 advertisement-interval 5
address-family vpnv4
bgp scan-time import 5
neighbor 192.168.19.19 activate
neighbor 192.168.19.19 send-community extended
!

ルート リフレクタ 1:例

!
ip cef distributed
 
mpls ldp router-id lo0 force
mpls ldp graceful-restart
mpls ip
mpls ip propagate-ttl
mpls ldp advertise-labels
mpls ip
mpls label protocol ldp
!
interface lo0
ip address 192.168.19.19 255.255.255.255
no shutdown
!
interface gi3/3
mpls ip
mpls label protocol ldp
ip address 192.168.40.2 255.255.255.0
no shutdown
!
router ospf 100
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
network 192.168.19.19 0.0.0.0 area 100
network 192.168.0.0 0.0.255.255 area 100 !
router bgp 100
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.11.11 remote-as 100
neighbor 192.168.11.11 update-source Loopback0
neighbor 192.168.17.17 remote-as 100
neighbor 192.168.17.17 update-source Loopback0
neighbor 192.168.11.11 route-reflector-client
address-family ipv4
no neighbor 192.168.17.17 activate
neighbor 192.168.11.11 route-reflector-client
address-family vpnv4
bgp scan-time import 5
neighbor 192.168.11.11 activate
neighbor 192.168.11.11 send-community extended
neighbor 192.168.17.17 activate
neighbor 192.168.17.17 send-community extended
neighbor 192.168.11.11 route-reflector-client
neighbor 192.168.17.17 route-reflector-client
!

ASBR1:例

!
ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target import 100:1
route-target import 200:1
route-target export 100:1
inter-as-hybrid next-hop 192.168.32.2
exit
 
ip vrf vpn2
rd 100:2
route-target import 100:2
route-target import 200:2
route-target export 100:2
inter-as-hybrid next-hop 192.168.33.2
exit
mpls ldp router-id lo0 force
mpls ldp graceful-restart
mpls ip
mpls ip propagate-ttl
mpls ldp advertise-labels
mpls ip
mpls label protocol ldp
 
interface lo0
ip address 192.168.11.11 255.255.255.255
no ipv6 address
ip route-cache distributed
ip route-cache cef distributed
no shutdown
 
interface gi3/8
mpls ip
mpls label protocol ldp
ip address 192.168.13.1 255.255.255.0
no ipv6 address
ip route-cache distributed
ip route-cache cef distributed
no shutdown
 
interface gi3/10
ip vrf forwarding vpn1
ip address 192.168.32.1 255.255.255.0
no ipv6 address
ip route-cache distributed
ip route-cache cef distributed
no shutdown
 
interface gi3/11
ip vrf forwarding vpn2
ip address 192.168.33.1 255.255.255.0
no ipv6 address
ip route-cache distributed
ip route-cache cef distributed
no shutdown
 
interface gi3/46
ip address 192.168.34.1 255.255.255.0
no ipv6 address
ip route-cache distributed
ip route-cache cef distributed
no shutdown
 
router ospf 100
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface gi3/10
passive-interface gi3/11
passive-interface gi3/46
network 192.168.0.0 0.0.255.255 area 100
network 192.168.11.11 0.0.0.0 area 100
 
router bgp 100
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
no bgp default route-target filter
bgp router-id 192.168.11.11
neighbor 192.168.34.2 remote-as 200
neighbor 192.168.34.2 advertisement-interval 5
neighbor 192.168.19.19 remote-as 100
neighbor 192.168.19.19 update-source Loopback0
address-family ipv4
no auto-summary
address-family ipv4 vrf vpn1
no auto-summary
address-family ipv4 vrf vpn2
no auto-summary
address-family vpnv4
bgp scan-time import 5
neighbor 192.168.34.2 activate
neighbor 192.168.34.2 send-community both
neighbor 192.168.34.2 inter-as-hybrid
neighbor 192.168.19.19 activate
neighbor 192.168.19.19 send-community extended !
ip route vrf vpn1 192.168.12.12 255.255.255.255 gi3/10 192.168.32.2
ip route vrf vpn2 192.168.12.12 255.255.255.255 gi3/11 192.168.33.2
!

ASBR3:例

!
ip cef distributed
!
ip vrf vpn1
rd 200:1
route-target import 100:1
route-target import 200:1
route-target export 200:1
inter-as-hybrid next-hop 192.168.32.1
!
ip vrf vpn2
rd 200:2
route-target import 100:2
route-target import 200:2
route-target export 200:2
inter-as-hybrid next-hop 192.168.33.1
!
mpls ldp router-id lo0 force
mpls ldp graceful-restart
mpls ip
mpls ip propagate-ttl
mpls ldp advertise-labels
mpls label protocol ldp
!
interface lo0
ip address 192.168.12.12 255.255.255.255
no shutdown
!
interface po2/1/0
mpls ip
mpls label protocol ldp
ip address 192.168.35.1 255.255.255.0
crc 16
clock source internal
no shutdown
!
interface gi3/10
ip vrf forwarding vpn1
ip address 192.168.32.2 255.255.255.0
no shutdown
!
interface gi3/11
ip vrf forwarding vpn2
ip address 192.168.33.2 255.255.255.0
no shutdown
!
interface gi3/45
ip address 192.168.34.2 255.255.255.0
no shutdown
!
router ospf 200
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface gi3/10
passive-interface gi3/11
passive-interface gi3/45
network 192.168.0.0 0.0.255.255 area 200 network 192.168.12.12 0.0.0.0 area 200
 
router bgp 200
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
no bgp default route-target filter
bgp router-id 192.168.12.12
neighbor 192.168.34.1 remote-as 100
neighbor 192.168.34.1 advertisement-interval 5
neighbor 192.168.20.20 remote-as 200
neighbor 192.168.20.20 update-source Loopback0
address-family ipv4
no auto-summary
address-family ipv4 vrf vpn1
no auto-summary
address-family ipv4 vrf vpn2
no auto-summary
address-family vpnv4
bgp scan-time import 5
neighbor 192.168.34.1 activate
neighbor 192.168.34.1 send-community both
neighbor 192.168.34.1 inter-as-hybrid
neighbor 192.168.20.20 activate
neighbor 192.168.20.20 send-community extended !
ip route vrf vpn1 192.168.11.11 255.255.255.255 gi3/10 192.168.32.1
ip route vrf vpn2 192.168.11.11 255.255.255.255 gi3/11 192.168.33.1
!

PE2:例

!
ip cef distributed
!
ip vrf vpn1
rd 200:1
route-target import 100:1
route-target import 200:1
route-target export 200:1
!
ip vrf vpn2
rd 200:2
route-target import 100:2
route-target import 200:2
route-target export 200:2
!
mpls ldp router-id lo0 force
mpls ldp graceful-restart
mpls ip
mpls ip propagate-ttl
mpls ldp advertise-labels
mpls label protocol ldp
!
interface lo0
ip address 192.168.18.18 255.255.255.255
no shutdown
!
interface po1/0/0
mpls ip
mpls label protocol ldp
ip address 192.168.35.2 255.255.255.0
crc 16
clock source internal
no shutdown
!
interface gi3/2
ip vrf forwarding vpn1
ip address 192.168.38.2 255.255.255.0
no shutdown
!
interface gi3/8
mpls ip
mpls label protocol ldp
ip address 192.168.4.1 255.255.255.0
no shutdown
!
interface gi3/10
ip vrf forwarding vpn2
ip address 192.168.39.2 255.255.255.0
no shutdown
!
router ospf 200
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface gi3/10
passive-interface gi3/2
network 192.168.0.0 0.0.255.255 area 200
network 192.168.18.18 0.0.0.0 area 200
network 192.168.0.0 0.0.255.255 area 200 !
router bgp 200
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no bgp default ipv4-unicast
no synchronization
neighbor 192.168.20.20 remote-as 200
neighbor 192.168.20.20 update-source Loopback0
address-family ipv4 vrf vpn1
no auto-summary
redistribute connected
neighbor 192.168.38.1 remote-as 500
neighbor 192.168.38.1 activate
neighbor 192.168.38.1 advertisement-interval 5
address-family ipv4 vrf vpn2
no auto-summary
redistribute connected
neighbor 192.168.9.1 remote-as 600
neighbor 192.168.9.1 activate
neighbor 192.168.9.1 advertisement-interval 5
address-family vpnv4
bgp scan-time import 5
neighbor 192.168.20.20 activate
neighbor 192.168.20.20 send-community extended
!

CE3:例

!
ip cef distributed
!
interface lo0
ip address 192.168.15.15 255.255.255.255
no shutdown
!
interface gi0/2
ip address 192.168.38.1 255.255.255.0
no shutdown
!
router ospf 500
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface gi0/2
network 192.168.15.15 0.0.0.0 area 500
!
router bgp 500
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
neighbor 192.168.38.2 remote-as 200
neighbor 192.168.38.2 advertisement-interval 5
address-family ipv4
no auto-summary
redistribute connected
neighbor 192.168.38.2 activate
!

CE4:例

!
ip cef distributed
!
interface lo0
ip address 192.168.16.16 255.255.255.255
no shutdown
!
interface et6/2
ip address 192.168.9.1 255.255.255.0
no shutdown
!
router ospf 600
nsf enforce global
redistribute connected subnets
auto-cost reference-bandwidth 1000
passive-interface et6/2
network 192.168.16.16 0.0.0.0 area 600
!
router bgp 600
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
no synchronization
neighbor 192.168.39.2 remote-as 200
neighbor 192.168.39.2 advertisement-interval 5
address-family ipv4 no auto-summary
redistribute connected
neighbor 192.168.39.2 activate
!

Inter-AS AB CSC 設定:例

次に、CSC を使用した Inter-AS オプション AB ネットワークの設定の例を示します。

「CE1:例」

「CE2:例」

「CE3:例」

「CE4:例」

「PE1:例」

「CSC-CE1:例」

「CSC-PE1:例」

「PE2:例」

「CSC-CE2:例」

「ASBR1:例」

「CSC-PE3:例」

「CSC-CE3:例」

「CSC-CE4:例」

「PE3:例」

「PE4:例」

CE1:例

!
ip cef distributed
!
interface Loopback0
ip address 192.168.20.20 255.255.255.255
!
interface Ethernet3/3
ip address 192.168.41.2 255.255.255.0
!
!
router bgp 500
bgp router-id 192.168.20.20
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.4.1 remote-as 300
!
address-family ipv4
redistribute connected
neighbor 192.168.4.1 activate
neighbor 192.168.4.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

CE2:例

!
ip cef distributed
!
interface Loopback0
ip address 192.168.21.21 255.255.255.255
!
interface Ethernet0/0/7
ip address 192.168.42.2 255.255.255.0
!
router bgp 600
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart neighbor 192.168.42.1 remote-as 400
!
address-family ipv4
redistribute connected
neighbor 192.168.42.1 activate
neighbor 192.168.42.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

CE3:例

!
ip cef distributed
!
interface Loopback0
ip address 192.168.22.22 255.255.255.255
!
interface Ethernet6/2
ip address 192.168.43.2 255.255.255.0
!
router bgp 500
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart neighbor 192.168.43.1 remote-as 300
!
address-family ipv4
redistribute connected
neighbor 192.168.43.1 activate
neighbor 192.168.43.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

CE4:例

!
ip cef distributed
!
interface Loopback0
ip address 192.168.23.23 255.255.255.255
!
!
interface Ethernet0/0/7
ip address 192.168.44.2 255.255.255.0
!
router bgp 600
bgp router-id 192.168.23.23
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.44.1 remote-as 400
!
address-family ipv4
redistribute connected
neighbor 192.168.44.1 activate
neighbor 192.168.44.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

PE1:例

!
ip cef distributed
!
ip vrf vpn3
rd 300:3
route-target export 300:3
route-target import 300:3
!
mpls ldp graceful-restart
!
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.192.10 255.255.255.255
!
interface Ethernet3/1
ip vrf forwarding vpn3
ip address 192.168.4.1 255.255.255.0
!
interface Ethernet5/3
ip address 192.168.3.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
router ospf 300
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network 192.168.192.10 0.0.0.0 area 300
network 192.168.0.0 0.0.255.255 area 300
!
router bgp 300
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.19.19 remote-as 300
neighbor 192.168.19.19 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.19.19 activate
neighbor 192.168.19.19 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn3
redistribute connected
neighbor 192.168.41.2 remote-as 500
neighbor 192.168.41.2 activate
neighbor 192.168.41.2 as-override
neighbor 192.168.41.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

CSC-CE1:例

!
ip cef distributed
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.11.11 255.255.255.255
!
!
interface Ethernet3/4
ip address 192.168.30.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
router ospf 300
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
redistribute bgp 300 metric 3 subnets
passive-interface FastEthernet1/0
network 192.168.11.11 0.0.0.0 area 300
network 192.168.0.0 0.0.255.255 area 300
distance ospf intra-area 19 inter-area 19
!
router bgp 300
bgp router-id 192.168.11.11
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.13.1 remote-as 100
!
address-family ipv4
redistribute ospf 300 metric 4 match internal external 1 external 2
neighbor 192.168.13.1 activate
neighbor 192.168.13.1 send-label
no auto-summary
no synchronization
exit-address-family
!

CSC-PE1:例

!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
route-target import 100:5
route-target import 200:1
!
ip vrf vpn2
rd 100:2
route-target export 100:2
route-target import 100:2
route-target import 100:6
route-target import 200:2
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.12.12 255.255.255.255
!
!
interface FastEthernet4/0/0
ip address 192.168.34.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
interface FastEthernet4/0/1
ip vrf forwarding vpn1
ip address 192.168.13.1 255.255.255.0
mpls bgp forwarding
!
!
interface FastEthernet4/1/0
ip vrf forwarding vpn2
ip address 192.168.33.1 255.255.255.0
mpls bgp forwarding
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.12.12 0.0.0.0 area 100
network 192.168.0.0 0.0.255.255 area 100
!
router bgp 100
bgp router-id 192.168.12.12
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.15.15 remote-as 100
neighbor 192.168.15.15 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.15.15 activate
neighbor 192.168.15.15 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 192.168.33.2 remote-as 400
neighbor 192.168.33.2 update-source FastEthernet4/1/0
neighbor 192.168.33.2 activate
neighbor 192.168.33.2 as-override
neighbor 192.168.33.2 advertisement-interval 5
neighbor 192.168.33.2 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf vpn1
neighbor 192.168.31.2 remote-as 300
neighbor 192.168.31.2 update-source FastEthernet4/0/1
neighbor 192.168.31.2 activate
neighbor 192.168.31.2 as-override
neighbor 192.168.31.2 advertisement-interval 5
neighbor 192.168.31.2 send-label
no auto-summary
no synchronization
exit-address-family
!

PE2:例

ip cef distributed
!
ip vrf vpn4
rd 400:4
route-target export 400:4
route-target import 400:4
!
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.13.13 255.255.255.255
!
!
interface Ethernet4/1/2
ip vrf forwarding vpn4
ip address 192.168.42.1 255.255.255.0
!
!
interface Ethernet4/1/6
ip address 192.168.32.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
router ospf 400
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.13.13 0.0.0.0 area 400
network 192.168.0.0 0.0.255.255 area 400
!
router bgp 400
bgp router-id 192.168.13.13
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.25.25 remote-as 400
neighbor 192.168.25.25 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.25.25 activate
neighbor 192.168.25.25 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn4
redistribute connected
neighbor 192.168.42.2 remote-as 600
neighbor 192.168.42.2 activate
neighbor 192.168.42.2 as-override
neighbor 192.168.42.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

CSC-CE2:例

!
ip cef distributed
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
interface Loopback0
ip address 192.168.14.14 255.255.255.255
!
!
interface GigabitEthernet8/16
ip address 192.168.33.2 255.255.255.0
mpls bgp forwarding
!
!
interface GigabitEthernet8/24
ip address 192.168.32.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
router ospf 400
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
redistribute bgp 400 metric 3 subnets
passive-interface GigabitEthernet8/16
network 192.168.14.14 0.0.0.0 area 400
network 192.168.0.0 0.0.255.255 area 400
distance ospf intra-area 19 inter-area 19
!
router bgp 400
bgp router-id 192.168.14.14
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.33.1 remote-as 100
!
address-family ipv4
no synchronization
redistribute connected
redistribute ospf 400 metric 4 match internal external 1 external 2
neighbor 192.168.33.1 activate
neighbor 192.168.33.1 advertisement-interval 5
neighbor 192.168.33.1 send-label
no auto-summary
exit-address-family
!

ASBR1:例

!
ip vrf vpn5
rd 100:5
route-target export 100:5
route-target import 100:5
route-target import 100:1
route-target import 200:5
inter-as-hybrid csc next-hop 192.168.35.2
!
ip vrf vpn6
rd 100:6
route-target export 100:6
route-target import 100:6
route-target import 100:2
route-target import 200:6
inter-as-hybrid csc next-hop 192.168.36.2
!
mpls ldp graceful-restart
mpls label protocol ldp
!
!
interface Loopback0
ip address 192.168.15.15 255.255.255.255
!
interface GigabitEthernet2/3
ip vrf forwarding vpn5
ip address 192.168.35.1 255.255.255.0
mpls bgp forwarding
!
interface GigabitEthernet2/4
ip vrf forwarding vpn6
ip address 192.168.36.1 255.255.255.0
mpls bgp forwarding
!
!
interface GigabitEthernet2/5
ip address 192.168.34.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
interface GigabitEthernet2/16
ip address 192.168.37.1 255.255.255.0
mpls bgp forwarding
!
!
router ospf 100
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.15.15 0.0.0.0 area 100
network 192.168.0.0 0.0.255.255 area 100
!
router bgp 100
bgp router-id 192.168.15.15
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.12.12 remote-as 100
neighbor 192.168.12.12 update-source Loopback0
neighbor 192.168.0.2 remote-as 200
neighbor 192.168.0.2 disable-connected-check
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 192.168.12.12 activate
neighbor 192.168.12.12 send-community extended
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 send-community extended
neighbor 192.168.0.2 inter-as-hybrid
exit-address-family
!
address-family ipv4 vrf vpn5
no synchronization
exit-address-family
!
address-family ipv4 vrf vpn6
no synchronization
exit-address-family
!
ip route 192.168.16.16 255.255.255.255 GigabitEthernet2/16 192.168.0.2
ip route vrf vpn5 192.168.16.16 255.255.255.255 GigabitEthernet2/3 192.168.35.2
ip route vrf vpn6 192.168.16.16 255.255.255.255 GigabitEthernet2/4 192.168.36.2
!
ip vrf vpn5
rd 200:5
route-target export 200:5
route-target import 200:5
route-target import 200:1
route-target import 100:1
route-target import 100:5
inter-as-hybrid csc next-hop 192.168.35.1
!
ip vrf vpn6
rd 200:6
route-target export 200:6
route-target import 200:6
route-target import 200:2
route-target import 100:2
route-target import 100:6
inter-as-hybrid csc next-hop 192.168.36.1
!
mpls ldp graceful-restart
mpls label protocol ldp
!
!
interface Loopback0
ip address 192.168.16.16 255.255.255.255
!
!
interface GigabitEthernet3/1
ip vrf forwarding vpn5
ip address 192.168.35.2 255.255.255.0
mpls bgp forwarding
!
interface GigabitEthernet3/2
ip vrf forwarding vpn6
ip address 192.168.36.2 255.255.255.0
mpls bgp forwarding
! !
interface GigabitEthernet3/14
ip address 192.168.0.2 255.0.0.0
mpls bgp forwarding
!
interface GigabitEthernet3/15
ip address 192.168.38.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.16.16 0.0.0.0 area 200
network 192.168.0.0 0.0.255.255 area 200
!
router bgp 200
bgp router-id 192.168.16.16
no bgp default ipv4-unicast
no bgp default route-target filter
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.17.17 remote-as 200
neighbor 192.168.17.17 update-source Loopback0
neighbor 192.168.37.1 remote-as 100
neighbor 192.168.37.1 disable-connected-check
!
address-family ipv4
no synchronization
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 192.168.17.17 activate
neighbor 192.168.17.17 send-community extended
neighbor 192.168.37.1 activate
neighbor 192.168.37.1 send-community extended
neighbor 192.168.37.1 inter-as-hybrid
exit-address-family
!
address-family ipv4 vrf vpn5
no synchronization
exit-address-family
!
address-family ipv4 vrf vpn6
no synchronization
exit-address-family
!
ip route 192.168.15.15 255.255.255.255 GigabitEthernet3/14 192.168.37.1
ip route vrf vpn5 192.168.15.15 255.255.255.255 GigabitEthernet3/1 192.168.35.1
ip route vrf vpn6 192.168.15.15 255.255.255.255 GigabitEthernet3/2 192.168.36.1
!

CSC-PE3:例

ip vrf vpn1
rd 200:1
route-target export 200:1
route-target import 200:1
route-target import 200:5
route-target import 100:1
!
ip vrf vpn2
rd 200:2
route-target export 200:2
route-target import 200:2
route-target import 200:6
route-target import 100:2
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.17.17 255.255.255.255
!
interface FastEthernet4/0/2
ip vrf forwarding vpn2
ip address 192.168.5.1 255.255.255.0
mpls bgp forwarding
!
!
interface FastEthernet4/0/4
ip vrf forwarding vpn1
ip address 192.168.9.1 255.255.255.0
mpls bgp forwarding
!
!
interface FastEthernet4/0/7
ip address 192.168.38.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.17.17 0.0.0.0 area 200
network 192.168.0.0 0.0.255.255 area 200
!
router bgp 200
bgp router-id 192.168.17.17
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.16.16 remote-as 200
neighbor 192.168.16.16 update-source Loopback0
!
address-family vpnv4
neighbor 192.168.16.16 activate
neighbor 192.168.16.16 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 192.168.55.0 remote-as 400
neighbor 192.168.55.0 update-source FastEthernet4/0/2
neighbor 192.168.55.0 activate
neighbor 192.168.55.0 as-override
neighbor 192.168.55.0 advertisement-interval 5
neighbor 192.168.55.0 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf vpn1
neighbor 192.168.39.2 remote-as 300
neighbor 192.168.39.2 update-source FastEthernet4/0/4
neighbor 192.168.39.2 activate
neighbor 192.168.39.2 as-override
neighbor 192.168.39.2 advertisement-interval 5
neighbor 192.168.39.2 send-label
no auto-summary
no synchronization
exit-address-family
!

CSC-CE3:例

!
interface Loopback0
ip address 192.168.18.18 255.255.255.255
!
!
interface Ethernet3/3
ip address 192.168.40.2 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
interface FastEthernet5/0
ip address 192.168.39.2 255.255.255.0
mpls bgp forwarding
!
!
router ospf 300
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
redistribute bgp 300 metric 3 subnets
network 192.168.18.18 0.0.0.0 area 300
network 192.168.0.0 0.0.255.255 area 300
distance ospf intra-area 19 inter-area 19
!
router bgp 300
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.9.1 remote-as 200
!
address-family ipv4
redistribute connected
redistribute ospf 300 metric 4 match internal external 1 external 2
neighbor 192.168.9.1 activate
neighbor 192.168.9.1 advertisement-interval 5
neighbor 192.168.9.1 send-label
no auto-summary
no synchronization
exit-address-family
!

CSC-CE4:例

!
ip cef distributed
!
mpls ldp graceful-restart
mpls label protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.24.24 255.255.255.255
!
!
interface FastEthernet1/1
ip address 192.168.55.0 255.255.255.0
mpls bgp forwarding
!
!
interface Ethernet3/5
ip address 192.168.56.2 255.255.255.0
mpls label protocol ldp
mpls ip
 
!
!
router ospf 400
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
redistribute bgp 400 metric 3 subnets
network 192.168.24.24 0.0.0.0 area 400
network 192.168.0.0 0.0.255.255 area 400
!
router bgp 400
bgp log-neighbor-changes
neighbor 192.168.5.1 remote-as 200
!
address-family ipv4
redistribute connected
redistribute ospf 400 metric 4 match internal external 1 external 2
neighbor 192.168.5.1 activate
neighbor 192.168.5.1 advertisement-interval 5
neighbor 192.168.5.1 send-label
no auto-summary
no synchronization
exit-address-family

PE3:例

!
ip cef distributed
!
ip vrf vpn3
rd 300:3
route-target export 300:3
route-target import 300:3
mpls ip
!
!
mpls ldp graceful-restart
mpls label protocol ldp
!
!
interface Loopback0
ip address 192.168.19.19 255.255.255.255
!
!
interface Ethernet5/1/1
ip vrf forwarding vpn3
ip address 192.168.43.1 255.255.255.0
!
!
interface Ethernet5/1/4
ip address 192.168.40.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
router ospf 300
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.19.19 0.0.0.0 area 300
network 192.168.0.0 0.0.255.255 area 300
network 192.168.0.0 0.0.255.255 area 300
!
router bgp 300
bgp router-id 192.168.19.19
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.192.10 remote-as 300
neighbor 192.168.192.10 update-source Loopback0
!
address-family ipv4
no neighbor 192.168.192.10 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.192.10 activate
neighbor 192.168.192.10 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn3
neighbor 192.168.43.2 remote-as 500
neighbor 192.168.43.2 activate
neighbor 192.168.43.2 as-override
neighbor 192.168.43.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

PE4:例

!
ip cef distributed
!
ip vrf vpn4
rd 400:4
route-target export 400:4
route-target import 400:4
!
mpls ldp graceful-restart
mpls ldp protocol ldp
!
mpls ip
!
interface Loopback0
ip address 192.168.25.25 255.255.255.255
!
!
interface Ethernet5/0/4
ip address 192.168.56.1 255.255.255.0
mpls label protocol ldp
mpls ip
!
!
interface Ethernet5/0/7
ip vrf forwarding vpn4
ip address 192.168.44.1 255.255.255.0
!
!
router ospf 400
log-adjacency-changes
auto-cost reference-bandwidth 1000
nsf enforce global
redistribute connected subnets
network 192.168.25.25 0.0.0.0 area 400
network 192.168.0.0 0.0.255.255 area 400
!
router bgp 400
bgp router-id 192.168.25.25
bgp log-neighbor-changes
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor 192.168.13.13 remote-as 400
neighbor 192.168.13.13 ebgp-multihop 7
neighbor 192.168.13.13 update-source Loopback0
!
address-family ipv4
no neighbor 192.168.13.13 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 192.168.13.13 activate
neighbor 192.168.13.13 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn4
neighbor 192.168.44.2 remote-as 600
neighbor 192.168.44.2 activate
neighbor 192.168.44.2 as-override
neighbor 192.168.44.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family
!

その他の関連資料

ここでは、MPLS VPN - Inter-AS オプション AB機能に関する関連資料について説明します。

「関連資料」

「規格」

「MIB」

「RFC」

「シスコのテクニカル サポート」

関連資料

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2283

『Multiprotocol Extensions for BGP-4』

RFC 4366

『BGP/MPLS IP Virtual Private Networks』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS VPN - Inter-AS オプション ABの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS VPN - Inter-AS オプション ABの機能情報

機能名
リリース
機能情報

MPLS VPN - Inter-AS オプション AB

12.2(33)SRC

この機能は、Inter-AS オプション(10)A ネットワークと Inter-AS オプション(10)B ネットワークの最良の機能を組み合せたものです。MPLS VPN サービス プロバイダーは、この機能を使用して、さまざまな自律システムを相互接続して VPN サービスを提供できます。

この機能は、12.2(33)SRC で導入されました。

15.0(1)M

この機能は、15.0(1)M で導入されました。次のコマンドが導入または変更されました。

neighbor inter-as-hybrid

inter-as-hybrid

用語集

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。他の BGP システムとネットワーク到達可能性情報を交換する、ドメイン間ルーティング プロトコル(同じ自律システム内の場合も、複数の自律システム間の場合もあります)。

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。カスタマー ネットワークの一部であり、Provider Edge(PE; プロバイダー エッジ)ルータへのインターフェイスとなるルータ。CE ルータは、関連する MPLS VPN を認識しません。

CSC :Carrier Supporting Carrier。小規模サービス プロバイダー(カスタマー キャリア)が MPLS バックボーンを経由してそれぞれの IP ネットワークまたは MPLS ネットワークを相互接続できる階層型 VPN モデル。これにより、カスタマー キャリアは独自の MPLS バックボーンを構築および維持する必要がなくなります。

eBGP :external Border Gateway Protocol(外部ボーダー ゲートウェイ プロトコル)。異なる自律システムにあるルータ間の BGP。異なる自律システムにある 2 つのルータが互いに 2 ホップ以上離れている場合、これら 2 つのルータ間の eBGP セッションはマルチホップ BGP であると見なされます。

iBGP :internal Border Gateway Protocol(内部ボーダー ゲートウェイ プロトコル)。同じ自律システム内にあるルータ間の BGP。

IGP :Interior Gateway Protocol(内部ゲートウェイ プロトコル)。単一の自律システム内でのルーティング情報の交換に使用されるインターネット プロトコル。インターネット IGP プロトコルの例として、IGRP、OSPF、IS-IS、RIP があります。

IP :Internet Protocol(インターネット プロトコル)。TCP/IP スタックにおいてコネクションレス型のネットワーク間サービスを提供するネットワーク レイヤ プロトコル。IP では、アドレッシング、タイプ オブ サービス指定、フラグメンテーションと再編成、セキュリティなどの機能が提供されます。RFC 791 に定義されています。

LFIB :Label Forwarding Information Base(ラベル転送情報ベース)。着信ラベルと発信ラベル、および関連する Forward Equivalence Class(FEC)パケットについての情報を保持するために MPLS で使用されるデータ構造。

MP-BGP :Multiprotocol BGP(マルチプロトコル BGP)。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。ラベル スイッチングを担当する IETF ワーキング グループの名前、およびそのワーキング グループで標準化されたラベル スイッチング アプローチの名前。

NLRI :Network Layer Reachability Information(ネットワーク レイヤ到達可能性情報)。BGP では、ルートおよびそのルートへのアクセス方法を記述した NLRI を含むルーティング アップデート メッセージが送信されます。この場合、NLRI がプレフィクスとなります。BGP アップデート メッセージでは、1 つ以上の NLRI プレフィクス、および NLRI プレフィクスのルートのアトリビュートが伝送されます。ルート アトリビュートには、BGP ネクストホップ ゲートウェイ アドレスおよび拡張コミュニティ値が含まれています。

NSF :Nonstop Forwarding(ノンストップ フォワーディング)によって、ルータは、ルート プロセッサが他のルート プロセッサにテイクオーバーまたはスイッチオーバーされたあとでも継続して IP パケットを転送できます。NSF では、レイヤ 3 のルーティングおよび転送情報をバックアップ ルート プロセッサに保持および更新することによって、スイッチオーバーやルート収束のプロセス中にも継続して IP パケットおよびルーティング プロトコル情報が転送されることが保証されます。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。サービス プロバイダーのネットワークの一部であるルータ。このルータは、Customer Edge(CE; カスタマー エッジ)ルータに接続されます。すべての MPLS VPN 処理は PE ルータで実行されます。

QoS :Quality of Service。転送システムのパフォーマンスを測定したものであり、転送品質およびサービス アベイラビリティを示します。

RD :Route Distinguisher(ルート識別子)。IPv4 プレフィクスに連結される 8 バイトの値で、一意の VPN IPv4 プレフィクスを形成します。

RT :Route Target(ルート ターゲット)。プレフィクスのインポート先となる VRF ルーティング テーブルの識別に使用する拡張コミュニティ アトリビュート。

SLA :VPN 加入者に保証される Service Level Agreement(サービス レベル契約)。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。1 つ以上の物理ネットワークのリソースを共有する、セキュアな MPLS ベースのネットワーク。VPN には地理的に分散したサイトが含まれており、共有バックボーン ネットワーク上で安全に通信できるようになっています。

VRF :VPN Routing and Forwarding(VPN ルーティングおよび転送)インスタンス。PE ルータに付加される VPN サイトを定義するルーティング情報。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。

自律システム :共通管理で共通のルーティング方針が共有される、ネットワークの集合。