Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
ASBR で IPv4 ルートおよび MPLS ラベルを 交換する MPLS VPN Inter-AS
ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS

機能情報の確認

この章の構成

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-ASの前提条件

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の制約事項

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS に関する情報

MPLS VPN Inter-AS の概要

MPLS VPN Inter-AS の利点

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の使用についての情報

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の利点

ASBR が MPLS ラベル付きの IPv4 ルートを交換する場合の Inter-AS の動作

BGP ルーティング情報

BGP メッセージのタイプと MPLS ラベル

BGP においてルートとともに MPLS ラベルが送信される方法

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定方法

IPv4 ルートおよび MPLS ラベルを交換する ASBR の設定

VPN-IPv4 ルートを交換するようにルート リフレクタを設定する

ルート リフレクタが自律システム内でリモート ルートを反映するように設定する

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS 設定の確認

ルート リフレクタ設定の確認

CE1 が CE2 と通信できることの確認

PE1 が CE2 と通信できることの確認

PE2 が CE2 と通信できることの確認

ASBR の設定の確認

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定例

MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例

ルート リフレクタ 1 の設定例(MPLS VPN サービス プロバイダー)

ASBR1 の設定例(MPLS VPN サービス プロバイダー)

ルート リフレクタ 2 の設定例(MPLS VPN サービス プロバイダー)

ASBR2 の設定例(MPLS VPN サービス プロバイダー)

非 MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例

ルート リフレクタ 1 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR1 の設定例(非 MPLS VPN サービス プロバイダー)

ルート リフレクタ 2 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR2 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR3 の設定例(非 MPLS VPN サービス プロバイダー)

ルート リフレクタ 3 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR4 の設定例(非 MPLS VPN サービス プロバイダー)

コマンド リファレンス

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-ASの機能情報

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS 機能を使用すると、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)がサービス プロバイダーおよび自律システムにまたがることができます。この章では、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)が Provider Edge(PE; プロバイダー エッジ)ルータの MPLS ラベル付きの IPv4 ルートを交換できるように MPLS VPN Inter-AS ネットワークを設定する方法について説明します。Route Reflector(RR; ルート リフレクタ)は、マルチホップ マルチプロトコル external Border Gateway Protocol(eBGP; 外部ボーダー ゲートウェイ プロトコル)を使用して VPN-IPv4 ルートを交換します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-ASの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-ASの前提条件

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS を設定する前に、ネットワークで MPLS VPN 動作が適切に設定されている必要があります。

表 1 に、Cisco IOS S リリースにおける Cisco 12000 シリーズ ラインカードのサポートを示します。

 

表 1 Cisco IOS S リリースにおける Cisco 12000 シリーズ ラインカードのサポート

タイプ
ラインカード
サポートされる Cisco IOS リリース

ATM

4-Port OC-3 ATM
1-Port OC-12 ATM
4-Port OC-12 ATM
8-Port OC-3 ATM

12.0(22)S、12.0(23)S、12.0(27)S

チャネライズド インターフェイス

2-Port CHOC-3
6-Port Ch T3 (DS1)
1-Port CHOC-12 (DS3)
1-Port CHOC-12 (OC-3)
4-Port CHOC-12 ISE
1-Port CHOC-48 ISE

電気インターフェイス

6-Port DS3
12-Port DS3
6-Port E3
12-Port E3

12.0(22)S、12.0(23)S、12.0(27)S

イーサネット

3-Port GbE

12.0(23)S、12.0(27)S

Packet over SONET(POS)

4-Port OC-3 POS
8-Port OC-3 POS
16-Port OC-3 POS
1-Port OC-12 POS
4-Port OC-12 POS
1-Port OC-48 POS
4-Port OC-3 POS ISE
8-Port OC-3 POS ISE
16-Port OC-3 POS ISE
4-Port OC-12 POS ISE
1-Port OC-48 POS ISE

12.0(22)S、12.0(23)S、12.0(27)S

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の制約事項

この機能には、次の制約事項があります。

eBGP マルチホップが設定されたネットワークでは、非隣接ルータ間に Label Switched Path(LSP; ラベル スイッチド パス)を設定する必要があります。

複数の BGP スピーカーを接続する物理インターフェイスは、シスコ エクスプレス フォワーディングまたは分散シスコ エクスプレス フォワーディングと MPLS をサポートしている必要があります。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS に関する情報

MPLS VPN Inter-AS を設定する前に、次の概念を理解しておく必要があります。

「MPLS VPN Inter-AS の概要」

「MPLS VPN Inter-AS の利点」

「ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の使用についての情報」

「ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の利点」

「ASBR が MPLS ラベル付きの IPv4 ルートを交換する場合の Inter-AS の動作」

MPLS VPN Inter-AS の概要

自律システムとは、共通のシステム管理グループによって管理され、単一の明確に定義されたルーティング プロトコルを使用する、単一のネットワークまたはネットワークのグループのことです。

VPN が大規模になるにつれて、その要件も多くなります。異なる地理的エリアにある異なる自律システムに VPN を設定する必要がある場合もあります。また、一部の VPN は、複数のサービス プロバイダーにまたがって設定する必要があります(オーバーラッピング VPN)。VPN がどのように複雑で、どのような場所にあっても、自律システム間の接続はカスタマーに対してシームレスである必要があります。

MPLS VPN Inter-AS の利点

MPLS VPN Inter-AS には次の利点があります。

VPN が複数のサービス プロバイダー バックボーンをまたがることが可能

異なる自律システムを実行する複数のサービス プロバイダーが、共同で同じカスタマーに MPLS VPN サービスを提供できます。あるサイトから開始し、さまざまな VPN サービス プロバイダー バックボーンを通過して、同じカスタマーの別のサイトに到達するように VPN を設定できます。以前は、MPLS VPN は、単一の BGP 自律システム サービス プロバイダー バックボーンだけを通過できました。この機能により、複数の自律システムが、サービス プロバイダーのカスタマー サイト間に連続性がありシームレスなネットワークを形成できます。

VPN が異なるエリアに存在可能

サービス プロバイダーは、異なる地理的エリアに VPN を作成できます。すべての VPN トラフィック フローが(エリア間で)1 箇所のポイントを通過するようにすると、エリア間のネットワーク トラフィックのレートをより適切に制御できます。

iBGP メッシングを最適化するための連合が可能

自律システム内の internal Border Gateway Protocol(iBGP; 内部ボーダー ゲートウェイ プロトコル)メッシングがより整理され、管理しやすくなります。この機能では、自律システムを複数の異なるサブ自律システムに分割して、それらを単一の連合に分類できます(ただし、VPN バックボーン全体は単一の自律システムと見なされます)。連合を形成するサブ自律システム間でのラベル付き VPN-IPv4 Network Layer Reachability Information(NLRI; ネットワーク レイヤ到達可能性情報)の交換がサポートされているため、サービス プロバイダーはこの機能を使用して、連合全体で MPLS VPN を提供できます。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の使用についての情報

この機能では、ASBR が PE ルータの MPLS ラベル付きの IPv4 ルートを交換できるように MPLS VPN Inter-AS ネットワークを設定できます。RR は、マルチホップ マルチプロトコル external Border Gateway Protocol(eBGP; 外部ボーダー ゲートウェイ プロトコル)を使用して VPN-IPv4 ルートを交換します。このように Inter-AS システムを設定する方法は、多くの場合 MPLS VPN Inter-AS - IPv4 BGP ラベル配布と呼ばれます。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の利点

Inter-AS システムを設定して、ASBR で MPLS ラベル付きの IPv4 ルートが交換できるようにすることには、次のような利点があります。

ASBR にすべての VPN-IPv4 ルートを格納する必要がなくなります。VPN-IPv4 ルートを格納し、それらを PE ルータに転送するルート リフレクタを使用すると、ASBR にすべての VPN-IPv4 ルートを格納して VPN-IPv4 ラベルに基づいてルートを転送する設定と比較して、スケーラビリティが向上します。

ルート リフレクタに VPN-IPv4 ルートを保持することによって、ネットワークの境界における設定が簡易化されます。

非 VPN コア ネットワークが、VPN トラフィックの中継ネットワークとして動作できます。MPLS ラベルの付いた IPv4 ルートを非 MPLS VPN サービス プロバイダー経由で送信できます。

隣接 LSR 間で他のラベル配布プロトコルが必要なくなります。隣接する 2 つの Label Switching Router(LSR; ラベル スイッチング ルータ)が BGP ピアでもある場合、BGP で MPLS ラベルの配布を実行できます。これら 2 つの LSR 間で、他のラベル配布プロトコルは必要ありません。

ASBR が MPLS ラベル付きの IPv4 ルートを交換する場合の Inter-AS の動作

MPLS ラベル付きの IPv4 ルートを交換する VPN サービス プロバイダー ネットワークを設定できます。VPN サービス プロバイダー ネットワークは次のように設定できます。

ルート リフレクタは、マルチホップ マルチプロトコル eBGP を使用して VPN-IPv4 ルートを交換します。この設定では、自律システムをまたがってネクストホップ情報および VPN ラベルが維持されます。

ローカル PE ルータ(たとえば図 1 の PE1)は、リモート PE ルータ(PE2)のルートおよびラベル情報を把握する必要があります。この情報は、次のいずれかの方法で PE ルータおよび ASBR 間で交換できます。

Internal Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)と Label Distribution Protocol(LDP; ラベル配布プロトコル):ASBR は、eBGP から学習した IPv4 ルートおよび MPLS ラベルを IGP および LDP に再配布できます。その逆も可能です。

internal Border Gateway Protocol(iBGP; 内部ボーダー ゲートウェイ プロトコル)IPv4 ラベル配布:ASBR および PE ルータは、直接 iBGP セッションを使用して、VPN-IPv4 と IPv4 ルートおよび MPLS ラベルを交換できます。

または、ルート リフレクタが、ASBR から学習した IPv4 ルートおよび MPLS ラベルを VPN の PE ルータに反映できます。これは、ASBR がルート リフレクタと IPv4 ルートおよび MPLS ラベルを交換することによって実現されます。ルート リフレクタは、VPN-IPv4 ルートも VPN の PE ルータに反映します。たとえば、図 1 の VPN1 で、RR1 は、学習した VPN-IPv4 ルート、および ASBR1 から学習した IPv4 ルートと MPLS ラベルを PE1 に反映します。ルート リフレクタを使用して VPN-IPv4 ルートを格納し、それらを PE ルータおよび ASBR 経由で転送することによって、スケーラブルな設定が可能となります。

図 1 eBGP および iBGP を使用してルートと MPLS ラベルを配布する VPN

BGP ルーティング情報

BGP ルーティング情報には、次の項目が含まれています。

宛先の IP アドレスであるネットワーク番号(プレフィクス)。

ルートがローカル ルータに到達するために通過する他の自律システムのリストである自律システム パス。リスト内の最初の自律システムはローカル ルータに最も近いシステムです。リスト内の最後の自律システムはローカル ルータから最も遠いシステムであり、通常、ルートの始点となる自律システムです。

ネクストホップなどの、自律システム パスについての他の情報を提供するパス アトリビュート。

BGP メッセージのタイプと MPLS ラベル

MPLS ラベルは、ルータが送信するアップデート メッセージに含まれています。ルータ間では、次のタイプの BGP メッセージが交換されます。

キープアライブ メッセージ:ルータ間では、ネイバー ルータがルーティング情報を交換可能であるかどうかを判断するためにキープアライブ メッセージが交換されます。ルータは、定期的にこれらのメッセージを送信します (Cisco ルータのデフォルトは 60 秒です)。キープアライブ メッセージには、ルーティング データは含まれていません。メッセージ ヘッダーだけが含まれています。

通知メッセージ:ルータでエラーが検出されると、通知メッセージが送信されます。

オープン メッセージ:ルータがネイバー ルータとの間で TCP 接続を確立すると、ルータ間でオープン メッセージが交換されます。このメッセージには、ルータが属している自律システム番号、およびメッセージ送信元ルータの IP アドレスが含まれています。

アップデート メッセージ:ルータのルートが新規作成、変更、または切断された場合、ルータはネイバー ルータにアップデート メッセージを送信します。このメッセージには、使用可能なルートの IP アドレスのリストである NLRI が含まれています。アップデート メッセージには、使用できなくなったすべてのルートが含まれています。また、アップデート メッセージには、使用可能なパスと使用できないパスの両方のパス アトリビュートと長さも含まれています。アップデート メッセージでは、VPN-IPv4 ルートのラベルは RFC 2858 の規定に従って符号化されます。また、アップデート メッセージでは、IPv4 ルートのラベルは RFC 3107 の規定に従って符号化されます。

BGP においてルートとともに MPLS ラベルが送信される方法

BGP(eBGP および iBGP)でルートを配布するときに、そのルートにマッピングされている MPLS ラベルも配布できます。ルートの MPLS ラベル マッピング情報は、ルートについての情報を含む BGP アップデート メッセージによって伝送されます。ネクストホップが変わらない場合は、ラベルも維持されます。

両方の BGP ルータで neighbor send-label コマンドを発行すると、それらのルータでルートとともに MPLS ラベルを送信できるという内容がルータ間で相互にアドバタイズされます。ルータ間で MPLS ラベルを送信可能であると正常にネゴシエーションされると、それらのルータからのすべての発信 BGP アップデートに MPLS ラベルが追加されます。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定方法

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS を設定するには、次の各項で説明する作業を実行します。

「IPv4 ルートおよび MPLS ラベルを交換する ASBR の設定」

「VPN-IPv4 ルートを交換するようにルート リフレクタを設定する」

「ルート リフレクタが自律システム内でリモート ルートを反映するように設定する」

「ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS 設定の確認」

図 2 に、次の設定例を示します。

この設定は、2 つの VPN で構成されています。

ASBR は、MPLS ラベル付きの IPv4 ルートを交換します。

ルート リフレクタは、マルチホップ MPLS eBGP を使用して VPN-IPv4 ルートを交換します。

ルート リフレクタは、自律システム内の他のルータに IPv4 ルートおよび VPN-IPv4 ルートを反映します。

図 2 IPv4 ルートおよび MPLS ラベルを交換する 2 つの VPN サービス プロバイダーの設定

IPv4 ルートおよび MPLS ラベルを交換する ASBR の設定

IPv4 ルートおよび MPLS ラベルを交換する ASBR を設定するには、次の作業を実行します。この設定手順では、例として ASBR1 を使用します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. neighbor { ip-address | peer-group-name } remote-as as-number

5. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

6. neighbor { ip-address | peer-group-name } activate

7. neighbor ip-address send-label

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor hh.0.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 5

address-family ipv4 [ multicast | unicast | mdt | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

標準 IPv4 アドレス プレフィクスを使用する BGP などのルーティング セッションを設定するために、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

mdt キーワードでは、IPv4 Multicast Distribution Tree(MDT; マルチキャスト配布ツリー)アドレス ファミリ セッションを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスの名前を指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor hh.0.0.1 activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

neighbor ip-address send - label

 

Router(config-router-af)# neighbor hh.0.0.1 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 9

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

VPN-IPv4 ルートを交換するようにルート リフレクタを設定する

ルート リフレクタでマルチホップ マルチプロトコル eBGP を使用して VPN-IPv4 ルートを交換できるようにするには、次の作業を実行します。

また、この手順では、自律システム間でネクストホップ情報および VPN ラベルが維持されるように指定します。この手順では、ルート リフレクタの例として RR1 を使用します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. neighbor { ip-address | peer-group-name } remote-as as-number

5. address-family vpnv4 [ unicast ]

6. neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

7. neighbor { ip-address | peer-group-name } activate

8. neighbor { ip-address | peer-group-name } next-hop unchanged

9. exit-address-family

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

自律システム番号によって、他の自律システム内のルータで RR1 が特定されます。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor bb.bb.bb.bb remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 5

neighbor { ip-address | peer-group-name } ebgp-multihop [ ttl ]

 

Router(config-router)# neighbor bb.bb.bb.bb ebgp-multihop 255

直接接続されていないネットワーク上の外部ピアからの BGP 接続を受け入れ、またそのピアへの BGP 接続を試みます。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ttl 引数には、1 ~ 255 ホップの範囲の存続可能時間を指定します。

ステップ 6

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、BGP セッションなどの、標準 VPNv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 7

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor bb.bb.bb.bb activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 8

neighbor { ip-address | peer-group-name } next-hop unchanged

 

Router(config-router-af)# neighbor ip-address next-hop unchanged

eBGP マルチホップ ピアで、ネクストホップを変更せずに伝播できるようにします。

ip-address 引数では、ネクストホップの IP アドレスを指定します。

peer-group-name 引数には、ネクストホップである BGP ピア グループの名前を指定します。

ステップ 9

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 10

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

ルート リフレクタが自律システム内でリモート ルートを反映するように設定する

RR が ASBR から学習した IPv4 ルートおよびラベルを自律システム内の PE ルータに反映できるようにするには、次の作業を実行します。

これは、ASBR および PE ルータを RR のルート リフレクタ クライアントにすることによって実現されます。また、この手順では、RR で VPN-IPv4 ルートを反映できるようにする方法についても説明します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. neighbor { ip-address | peer-group-name } activate

6. neighbor ip-address route-reflector-client

7. neighbor ip-address send-label

8. exit-address-family

9. address-family vpnv4 [ unicast ]

10. neighbor { ip-address | peer-group-name } activate

11. neighbor ip-address route-reflector-client

12. exit-address-family

13. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータでルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4

アドレス ファミリ コンフィギュレーション モードを開始して、BGP セッションなどの、標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF インスタンスの名前を指定します。

ステップ 5

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor ee.ee.ee.ee activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 6

neighbor ip-address route-reflector-client

 

Router(config-router-af)# neighbor ee.ee.ee.ees route-reflector-client

ルータを BGP ルート リフレクタとして設定し、指定したネイバーをそのクライアントとして設定します。

ip-address 引数には、クライアントとして設定する BGP ネイバーの IP アドレスを指定します。

ステップ 7

neighbor ip-address send-label

 

Router(config-router-af)# neighbor ee.ee.ee.ee send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 9

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、BGP セッションなどの、標準 VPNv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 10

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor ee.ee.ee.ee activate

ネイバー ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 11

neighbor ip-address route-reflector-client

 

Router(config-router-af)# neighbor ee.ee.ee.ee route-reflector-client

RR がネイバー ルータに iBGP ルートを送信できるようにします。

ステップ 12

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 13

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS 設定の確認

IPv4 ラベルの配布に ASBR を、VPN-IPv4 ルートの配布にルート リフレクタを使用する場合は、次の手順を使用して設定を確認します。

「ルート リフレクタ設定の確認」

「CE1 が CE2 と通信できることの確認」

「PE1 が CE2 と通信できることの確認」

「PE2 が CE2 と通信できることの確認」

「ASBR の設定の確認」

図 3 に、以降の項で参照される設定を示します。

図 3 IPv4 ルートおよび MPLS ラベルを交換する 2 つの VPN サービス プロバイダーの設定

ルート リフレクタ設定の確認

ルート リフレクタ設定を確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

3. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all summary

 

(任意)BGP テーブルの VPN アドレス情報を表示します。

ルート リフレクタ間にマルチホップ マルチプロトコル eBGP セッションが存在し、ルート リフレクタ間で VPNv4 ルートが交換されていることを確認するには、 all キーワードと summary キーワードを使用します。

コマンド出力の最後の 2 行に、次の情報が表示されます。

プレフィクスが PE1 から学習されて RR2 に渡されていること。

プレフィクスが RR2 から学習されて PE1 に渡されていること。

ルート リフレクタ間で VPNv4 ラベル情報が交換されていることを確認するには、 all キーワードと labels キーワードを使用します。

ステップ 3

disable

 

Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

CE1 が CE2 と通信できることの確認

ルータ CE1 がルータ CE2 の NLRI を持っていることを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route [ ip-address [ mask ] [ longer-prefixes ]] | [protocol [process-id]] | [ list access-list-number | access-list-name]

3. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route [ ip-address [ mask ] [ longer-prefixes ]] | [protocol [process-id]] | [ list access-list-number | access-list-name]

 

Router# show ip route nn.nn.nn.nn

 

ルーティング テーブルの現在のステータスを表示します。

ip-address 引数を使用して、CE1 に CE2 へのルートが含まれていることを確認します。

このコマンドを使用して、CE1 が学習したルートを確認します。CE2 へのルートがリストされていることを確認します。

ステップ 3

disable

 

Router# disable

(任意)終了して、特権 EXEC モードに戻ります。

PE1 が CE2 と通信できることの確認

ルータ PE1 がルータ CE2 の NLRI を持っていることを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route vrf vrf-name [ connected ] [ protocol [ as-number ] [ tag ] [ output-modifiers ]] [ list number [ output-modifiers ]] [ profile ] [ static [ output-modifiers ]] [ summary [ output-modifiers ]] [ supernets-only [ output-modifiers ]] [ traffic-engineering [ output-modifiers ]]

3. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ ip-prefix | length [ longer-prefixes ] [output-modifiers]] [network-address [mask] [ longer-prefixes ] [output-modifiers]] [ cidr-only ] [community] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics ] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ tags ]

4. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

5. show mpls forwarding - table [{ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

6. show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

7. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

8. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route vrf vrf-name [ connected ] [ protocol [ as-number ] [ tag ] [ output-modifiers ]] [ list number [ output-modifiers ]] [ profile ] [ static [ output-modifiers ]] [ summary [ output-modifiers ]] [ supernets-only [ output-modifiers ]] [ traffic-engineering [ output-modifiers ]]

 

Router# show ip route vrf vpn1 nn.nn.nn.nn

 

(任意)VRF に関連付けられている IP ルーティング テーブルを表示します。

このコマンドを使用して、ルータ PE1 がルータ CE2(nn.nn.nn.nn)からルートを学習していることを確認します。

ステップ 3

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ ip-prefix | length [ longer-prefixes ] [output-modifiers]] [network-address [mask] [ longer-prefixes ] [output-modifiers]] [ cidr-only ] [community] [ community-list ] [ dampened-paths ] [ filter-list ] [ flap-statistics ] [ inconsistent-as ] [ neighbors ] [ paths [ line ]] [ peer-group ] [ quote-regexp ] [ regexp ] [ summary ] [ tags ]

 

Router# show ip bgp vpnv4 vrf vpn1 nn.nn.nn.nn

 

Router# show ip bgp vpnv4 all nn.nn.nn.nn

(任意)BGP テーブルの VPN アドレス情報を表示します。

ルータ PE2 がルータ CE2 の BGP ネクストホップであることを確認するには、 vrf キーワードまたは all キーワードを使用します。

ステップ 4

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef vrf vpn1 nn.nn.nn.nn

(任意)Forwarding Information Base(FIB; 転送情報ベース)のエントリを表示するか、または FIB のサマリーを表示します。

このコマンドを使用して、シスコ エクスプレス フォワーディング エントリが正しいことを確認します。

ステップ 5

show mpls forwarding - table [{ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table

(任意)MPLS LFIB の内容を表示します。

このコマンドを使用して、BGP ネクストホップ ルータ(自律システム境界)の IGP ラベルを確認します。

ステップ 6

show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

 

Router# show ip bgp ff.ff.ff.ff

(任意)BGP ルーティング テーブルのエントリを表示します。

show ip bgp コマンドを使用して、リモート出力 PE ルータ(PE2)のラベルを確認します。

ステップ 7

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all labels

(任意)BGP テーブルの VPN アドレス情報を表示します。

PE2 からアドバタイズされた CE2 の VPN ラベルを確認するには、 all キーワードと summary キーワードを使用します。

ステップ 8

disable

 

Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

PE2 が CE2 と通信できることの確認

PE2 が CE2 にアクセスできることを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route vrf vrf-name [ connected ] [ protocol [ as-number ] [ tag ] [ output-modifiers ]] [ list number [ output-modifiers ]] [ profile ] [ static [ output-modifiers ]] [ summary [ output-modifiers ]] [ supernets-only [ output-modifiers ]] [ traffic-engineering [ output-modifiers ]]

3. show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

4. show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

5. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

6. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip route vrf vrf-name [ connected ] [ protocol [ as-number ] [ tag ] [ output-modifiers ]] [ list number [ output-modifiers ]] [ profile ] [ static [ output-modifiers ]] [ summary [ output-modifiers ]] [ supernets-only [ output-modifiers ]] [ traffic-engineering [ output-modifiers ]]

 

Router# show ip route vrf vpn1 nn.nn.nn.nn

(任意)VRF に関連付けられている IP ルーティング テーブルを表示します。

このコマンドを使用して、CE2 の VPN ルーティングおよび転送テーブルを確認します。出力に、ネクストホップ情報が表示されます。

ステップ 3

show mpls forwarding-table [ vrf vrf-name ] [{ network { mask | length } | labels label [ -label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]}] [ detail ]

 

Router# show mpls forwarding-table vrf vpn1 nn.nn.nn.nn

(任意)LFIB の内容を表示します。

CE2 の VPN ルーティングおよび転送テーブルを確認するには、 vrf キーワードを使用します。出力に、CE2 のラベルと発信インターフェイスが表示されます。

ステップ 4

show ip bgp vpnv4 { all | rd route-distinguisher | vrf vrf-name } [ summary ] [ labels ]

 

Router# show ip bgp vpnv4 all labels

(任意)BGP テーブルの VPN アドレス情報を表示します。

マルチプロトコル BGP テーブル内の CE2 の VPN ラベルを確認するには、 all キーワードと labels キーワードを使用します。

ステップ 5

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef vpn1 nn.nn.nn.nn

(任意)FIB のエントリを表示するか、または FIB のサマリーを表示します。

このコマンドを使用して、CE2 のシスコ エクスプレス フォワーディング エントリを確認します。コマンド出力に、CE2 のローカル ラベルと発信インターフェイスが表示されます。

ステップ 6

disable
 

Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

ASBR の設定の確認

ASBR 間で、ルート マップの指定に従って MPLS ラベル付きの IPv4 ルートまたはラベルなしの IPv4 ルートが交換されていることを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

3. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

4. disable

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

show ip bgp [ network ] [ network-mask ] [ longer-prefixes ]

 

Router# show ip bgp ff.ff.ff.ff

 

 

(任意)BGP ルーティング テーブルのエントリを表示します。

このコマンドを使用して次のことを確認します。

ASBR1 が ASBR2 から PE2 の MPLS ラベルを受信していること。

ASBR1 が ASBR2 から RR2 のラベルなし IPv4 ルートを受信していること。

ASBR2 が ASBR1 に PE2 の MPLS ラベルを配布していること。

ASBR2 が ASBR1 に RR2 のラベルを配布していないこと。

ステップ 3

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef ff.ff.ff.ff

 

Router# show ip cef bb.bb.bb.bb

(任意)FIB のエントリを表示するか、または FIB のサマリーを表示します。

ASBR1 および ASBR2 からこのコマンドを使用して、次のことを確認します。

PE2 のシスコ エクスプレス フォワーディング エントリが正しいこと。

RR2 のシスコ エクスプレス フォワーディング エントリが正しいこと。

ステップ 4

disable
 
Router# disable

(任意)終了して、ユーザ EXEC モードに戻ります。

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定例

次に、MPLS VPN Inter-AS の設定例を示します。

「MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例」

「非 MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例」

MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例

ここでは、BGP を使用して MPLS VPN サービス プロバイダー経由でルートおよび MPLS ラベルを配布する Inter-AS の次の設定例について説明します。

「ルート リフレクタ 1 の設定例(MPLS VPN サービス プロバイダー)」

「ASBR1 の設定例(MPLS VPN サービス プロバイダー)」

「ルート リフレクタ 2 の設定例(MPLS VPN サービス プロバイダー)」

「ASBR2 の設定例(MPLS VPN サービス プロバイダー)」

図 4 には、2 つの MPLS VPN サービス プロバイダーが示されています。サービス プロバイダーは、ルート リフレクタ間で VPN-IPv4 ルートを配布します。MPLS VPN サービス プロバイダーは、ASBR 間で MPLS ラベル付きの IPv4 ルートを配布します。

設定例では、リモートの RR と PE の VPN-IPv4 ルートおよび MPLS ラベル付きの IPv4 ルートをローカルの RR と PE に配布するために使用できる次の 2 つの技術を示しています。

自律システム 100 は、RR を使用して、リモート RR から学習した VPN-IPv4 ルートを配布します。また、RR は、IPv4 ラベルを使用して、ASBR1 から学習したリモート PE アドレスとラベルを配布します。

自律システム 200 では、ASBR2 が学習した IPv4 ルートは IGP に再配布されます。

図 4 MPLS VPN サービス プロバイダー間での IPv4 ルートと MPLS ラベルの配布

 

ルート リフレクタ 1 の設定例(MPLS VPN サービス プロバイダー)

RR1 の設定例では、次のことが指定されています。

RR1 は、マルチプロトコル マルチホップ eBGP を使用して、RR2 と VPN-IPv4 ルートを交換します。

自律システム間で VPN-IPv4 ネクストホップ情報および VPN ラベルが維持されます。

RR1 から PE1 に次の内容が反映されます。

RR2 から学習した VPN-IPv4 ルート

ASBR1 から学習した IPv4 ルートおよび MPLS ラベル

ip subnet-zero
ip cef
!
interface Loopback0
ip address aa.aa.aa.aa 255.255.255.255
!
interface Ethernet0/3
ip address dd.0.0.2 255.0.0.0
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
network aa.aa.aa.aa 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp cluster-id 1
bgp log-neighbor-changes
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
neighbor ww.ww.ww.ww remote-as 100
neighbor ww.ww.ww.ww update-source Loopback0
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb ebgp-multihop 255
neighbor bb.bb.bb.bb update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !IPv4+labels session to PE1
neighbor ee.ee.ee.ee send-label
neighbor ww.ww.ww.ww activate
neighbor ww.ww.ww.ww route-reflector-client !IPv4+labels session to ASBR1
neighbor ww.ww.ww.ww send-label
no neighbor bb.bb.bb.bb activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !VPNv4 session with PE1
neighbor ee.ee.ee.ee send-community extended
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb next-hop-unchanged !MH-VPNv4 session with RR2
neighbor bb.bb.bb.bb send-community extended !with next hop unchanged
exit-address-family
!
ip default-gateway 3.3.0.1
no ip classless
!
snmp-server engineID local 00000009020000D0584B25C0
snmp-server community public RO
snmp-server community write RW
no snmp-server ifindex persist
snmp-server packetsize 2048
!
end

ASBR1 の設定例(MPLS VPN サービス プロバイダー)

ASBR1 は、ASBR2 と IPv4 ルートおよび MPLS ラベルを交換します。

この例では、ASBR1 で、次のルート マップを使用してルートがフィルタリングされています。

OUT というルート マップでは、ASBR1 において、PE1 ルート(ee.ee)はラベルを付けて配布し、RR1 ルート(aa.aa)はラベルを付けずに配布する必要があることが指定されています。

IN というルート マップでは、ASBR1 にラベル付きの PE2 ルート(ff.ff)とラベルなしの RR2 ルート(bb.bb)を受け入れさせるように指定しています。

 
ip subnet-zero
mpls label protocol ldp
!
interface Loopback0
ip address ww.ww.ww.ww 255.255.255.255
!
interface Ethernet0/2
ip address hh.0.0.2 255.0.0.0
!
interface Ethernet0/3
ip address dd.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet0/2
network ww.ww.ww.ww 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
 
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa update-source Loopback0
neighbor hh.0.0.1 remote-as 200
no auto-summary
!
!
address-family ipv4 ! Redistributing IGP into BGP
redistribute ospf 10 ! so that PE1 & RR1 loopbacks
neighbor aa.aa.aa.aa activate ! get into the BGP table
neighbor aa.aa.aa.aa send-label
neighbor hh.0.0.1 activate
neighbor hh.0.0.1 advertisement-interval 5
neighbor hh.0.0.1 send-label
neighbor hh.0.0.1 route-map IN in ! accepting routes in route map IN.
neighbor hh.0.0.1 route-map OUT out ! distributing routes in route map OUT.
neighbor kk.0.0.1 activate
neighbor kk.0.0.1 advertisement-interval 5
neighbor kk.0.0.1 send-label
neighbor kk.0.0.1 route-map IN in ! accepting routes in route map IN.
neighbor kk.0.0.1 route-map OUT out ! distributing routes in route map OUT.
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
access-list 1 permit ee.ee.ee.ee log !Setting up the access lists
access-list 2 permit ff.ff.ff.ff log
access-list 3 permit aa.aa.aa.aa log
access-list 4 permit bb.bb.bb.bb log
 
route-map IN permit 10 !Setting up the route maps
match ip address 2
match mpls-label
!
route-map IN permit 11
match ip address 4
!
route-map OUT permit 12
match ip address 3
!
route-map OUT permit 13
match ip address 1
set mpls-label
!
end

ルート リフレクタ 2 の設定例(MPLS VPN サービス プロバイダー)

RR2 は、マルチホップ マルチプロトコル eBGP を使用して、RR1 と VPN-IPv4 ルートを交換します。また、この設定では、自律システム間でネクストホップ情報および VPN ラベルが維持されるように指定されています。

ip subnet-zero
ip cef
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Serial1/1
ip address ii.0.0.2 255.0.0.0
!
router ospf 20
log-adjacency-changes
network bb.bb.bb.bb 0.0.0.0 area 200
network ii.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp cluster-id 1
bgp log-neighbor-changes
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa ebgp-multihop 255
neighbor aa.aa.aa.aa update-source Loopback0
neighbor ff.ff.ff.ff remote-as 200
neighbor ff.ff.ff.ff update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor aa.aa.aa.aa activate
neighbor aa.aa.aa.aa next-hop-unchanged !Multihop VPNv4 session with RR1
neighbor aa.aa.aa.aa send-community extended !with next-hop-unchanged
neighbor ff.ff.ff.ff activate
neighbor ff.ff.ff.ff route-reflector-client !VPNv4 session with PE2
neighbor ff.ff.ff.ff send-community extended
exit-address-family
!
ip default-gateway 3.3.0.1
no ip classless
!
end

ASBR2 の設定例(MPLS VPN サービス プロバイダー)

ASBR2 は、ASBR1 と IPv4 ルートおよび MPLS ラベルを交換します。ただし、ASBR1 とは異なり、ASBR2 は RR を使用して IPv4 ルートおよび MPLS ラベルを PE2 に反映しません。ASBR2 は、ASBR1 から学習した IPv4 ルートおよび MPLS ラベルを IGP に再配布します。これで、PE2 がこれらのプレフィクスに到達できるようになります。

ip subnet-zero
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address xx.xx.xx.xx 255.255.255.255
!
interface Ethernet1/0
ip address hh.0.0.1 255.0.0.0
!
interface Ethernet1/2
ip address jj.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 20
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
redistribute bgp 200 subnets ! Redistributing the routes learned from
passive-interface Ethernet1/0 ! ASBR1(eBGP+labels session) into IGP
network xx.xx.xx.xx 0.0.0.0 area 200 ! so that PE2 will learn them
network jj..0.0 0.255.255.255 area 200
!
router bgp 200
bgp log-neighbor-changes
timers bgp 10 30
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb update-source Loopback0
neighbor hh.0.0.2 remote-as 100
no auto-summary
!
address-family ipv4
redistribute ospf 20 ! Redistributing IGP into BGP
neighbor hh.0.0.2 activate ! so that PE2 & RR2 loopbacks
neighbor hh.0.0.2 advertisement-interval 5 ! will get into the BGP-4 table.
neighbor hh.0.0.2 route-map IN in
neighbor hh.0.0.2 route-map OUT out
neighbor hh.0.0.2 send-label
neighbor kk.0.0.2 activate
neighbor kk.0.0.2 advertisement-interval 5
neighbor kk.0.0.2 route-map IN in
neighbor kk.0.0.2 route-map OUT out
neighbor kk.0.0.2 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
access-list 1 permit ff.ff.ff.ff log !Setting up the access lists
access-list 2 permit ee.ee.ee.ee log
access-list 3 permit bb.bb.bb.bb log
access-list 4 permit aa.aa.aa.aa log
 
route-map IN permit 11 !Setting up the route maps
match ip address 2
match mpls-label
!
route-map IN permit 12
match ip address 4
!
route-map OUT permit 10
match ip address 1
set mpls-label
!
route-map OUT permit 13
match ip address 3
end
 

非 MPLS VPN サービス プロバイダー経由での ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の設定:例

ここでは、BGP を使用して非 MPLS VPN サービス プロバイダー経由でルートおよび MPLS ラベルを配布する Inter-AS の次の設定例について説明します。

「ルート リフレクタ 1 の設定例(非 MPLS VPN サービス プロバイダー)」

「ASBR1 の設定例(非 MPLS VPN サービス プロバイダー)」

「ルート リフレクタ 2 の設定例(非 MPLS VPN サービス プロバイダー)」

「ASBR2 の設定例(非 MPLS VPN サービス プロバイダー)」

「ASBR3 の設定例(非 MPLS VPN サービス プロバイダー)」

「ルート リフレクタ 3 の設定例(非 MPLS VPN サービス プロバイダー)」

「ASBR4 の設定例(非 MPLS VPN サービス プロバイダー)」

図 5 に、非 MPLS VPN サービス プロバイダー経由で接続された 2 つの MPLS VPN サービス プロバイダーを示します。ネットワークの中央にある自律システムは、LDP または Tag Distribution Protocol(TDP; タグ配布プロトコル)を使用して MPLS ラベルを配布するバックボーン自律システムとして設定されています。TDP や LDP の代わりにトラフィック エンジニアリング トンネルを使用して、非 MPLS VPN サービス プロバイダー全体に LSP を構築することもできます。

図 5 非 MPLS VPN サービス プロバイダー経由でのルートと MPLS ラベルの配布

 

ルート リフレクタ 1 の設定例(非 MPLS VPN サービス プロバイダー)

RR1 の設定例では、次のことが指定されています。

RR1 は、マルチプロトコル マルチホップ eBGP を使用して、RR2 と VPN-IPv4 ルートを交換します。

自律システム間で VPN-IPv4 ネクストホップ情報および VPN ラベルが維持されます。

RR1 から PE1 に次の内容が反映されます。

RR2 から学習した VPN-IPv4 ルート

ASBR1 から学習した IPv4 ルートおよび MPLS ラベル

ip subnet-zero
ip cef
!
interface Loopback0
ip address aa.aa.aa.aa 255.255.255.255
!
interface Serial1/2
ip address dd.0.0.2 255.0.0.0
clockrate 124061
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
network aa.aa.aa.aa 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
!
router bgp 100
bgp cluster-id 1
bgp log-neighbor-changes
timers bgp 10 30
neighbor ee.ee.ee.ee remote-as 100
neighbor ee.ee.ee.ee update-source Loopback0
neighbor ww.ww.ww.ww remote-as 100
neighbor ww.ww.ww.ww update-source Loopback0
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb ebgp-multihop 255
neighbor bb.bb.bb.bb update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !IPv4+labels session to PE1
neighbor ee.ee.ee.ee send-label
neighbor ww.ww.ww.ww activate
neighbor ww.ww.ww.ww route-reflector-client !IPv4+labels session to ASBR1
neighbor ww.ww.ww.ww send-label
no neighbor bb.bb.bb.bb activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor ee.ee.ee.ee activate
neighbor ee.ee.ee.ee route-reflector-client !VPNv4 session with PE1
neighbor ee.ee.ee.ee send-community extended
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb next-hop-unchanged !MH-VPNv4 session with RR2
neighbor bb.bb.bb.bb send-community extended with next-hop-unchanged
exit-address-family
!
ip default-gateway 3.3.0.1
no ip classless
!
snmp-server engineID local 00000009020000D0584B25C0
snmp-server community public RO
snmp-server community write RW
no snmp-server ifindex persist
snmp-server packetsize 2048
!
end

ASBR1 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR1 は、ASBR2 と IPv4 ルートおよび MPLS ラベルを交換します。

この例では、ASBR1 で、次のルート マップを使用してルートがフィルタリングされています。

OUT というルート マップでは、ASBR1 において、PE1 ルート(ee.ee)はラベルを付けて配布し、RR1 ルート(aa.aa)はラベルを付けずに配布する必要があることが指定されています。

IN というルート マップでは、ASBR1 にラベル付きの PE2 ルート(ff.ff)とラベルなしの RR2 ルート(bb.bb)を受け入れさせるように指定しています。

ip subnet-zero
ip cef distributed
mpls label protocol ldp
!
interface Loopback0
ip address ww.ww.ww.ww 255.255.255.255
!
interface Serial3/0/0
ip address kk.0.0.2 255.0.0.0
ip route-cache distributed
!
interface Ethernet0/3
ip address dd.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Serial3/0/0
network ww.ww.ww.ww 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
 
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa update-source Loopback0
neighbor kk.0.0.1 remote-as 200
no auto-summary
!
address-family ipv4
redistribute ospf 10 ! Redistributing IGP into BGP
neighbor aa.aa.aa.aa activate ! so that PE1 & RR1 loopbacks
neighbor aa.aa.aa.aa send-label ! get into BGP table
neighbor kk.0.0.1 activate
neighbor kk.0.0.1 advertisement-interval 5
neighbor kk.0.0.1 send-label
neighbor kk.0.0.1 route-map IN in ! Accepting routes specified in route map IN
neighbor kk.0.0.1 route-map OUT out ! Distributing routes specified in route map OUT
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
access-list 1 permit ee.ee.ee.ee log
access-list 2 permit ff.ff.ff.ff log
access-list 3 permit aa.aa.aa.aa log
access-list 4 permit bb.bb.bb.bb log
!
route-map IN permit 10
match ip address 2
match mpls-label
!
route-map IN permit 11
match ip address 4
!
route-map OUT permit 12
match ip address 3
!
route-map OUT permit 13
match ip address 1
set mpls-label
!
end

ルート リフレクタ 2 の設定例(非 MPLS VPN サービス プロバイダー)

RR2 は、マルチホップ マルチプロトコル eBGP を使用して、RR1 と VPN-IPv4 ルートを交換します。また、この設定では、自律システム間でネクストホップ情報および VPN ラベルが維持されるように指定されています。

ip subnet-zero
ip cef
!
interface Loopback0
ip address bb.bb.bb.bb 255.255.255.255
!
interface Serial1/1
ip address ii.0.0.2 255.0.0.0
!
router ospf 20
log-adjacency-changes
network bb.bb.bb.bb 0.0.0.0 area 200
network ii.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp cluster-id 1
bgp log-neighbor-changes
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa ebgp-multihop 255
neighbor aa.aa.aa.aa update-source Loopback0
neighbor ff.ff.ff.ff remote-as 200
neighbor ff.ff.ff.ff update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor aa.aa.aa.aa activate
neighbor aa.aa.aa.aa next-hop-unchanged !MH vpnv4 session with RR1
neighbor aa.aa.aa.aa send-community extended !with next-hop-unchanged
neighbor ff.ff.ff.ff activate
neighbor ff.ff.ff.ff route-reflector-client !vpnv4 session with PE2
neighbor ff.ff.ff.ff send-community extended
exit-address-family
!
ip default-gateway 3.3.0.1
no ip classless
!
end

ASBR2 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR2 は、ASBR1 と IPv4 ルートおよび MPLS ラベルを交換します。ただし、ASBR1 とは異なり、ASBR2 は RR を使用して IPv4 ルートおよび MPLS ラベルを PE2 に反映しません。ASBR2 は、ASBR1 から学習した IPv4 ルートおよび MPLS ラベルを IGP に再配布します。これで、PE2 がこれらのプレフィクスに到達できるようになります。

ip subnet-zero
ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address xx.xx.xx.xx 255.255.255.255
!
interface Ethernet0/1
ip address qq.0.0.2 255.0.0.0
!
interface Ethernet1/2
ip address jj.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 20
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
redistribute bgp 200 subnets !redistributing the routes learned from
passive-interface Ethernet0/1 !ASBR2 (eBGP+labels session) into IGP
network xx.xx.xx.xx 0.0.0.0 area 200 !so that PE2 will learn them
network jj.0.0.0 0.255.255.255 area 200
!
router bgp 200
bgp log-neighbor-changes
timers bgp 10 30
neighbor bb.bb.bb.bb remote-as 200
neighbor bb.bb.bb.bb update-source Loopback0
neighbor qq.0.0.1 remote-as 100
no auto-summary
!
address-family ipv4 ! Redistributing IGP into BGP redistribute ospf 20 ! so that PE2 & RR2 loopbacks
neighbor qq.0.0.1 activate ! will get into the BGP-4 table
neighbor qq.0.0.1 advertisement-interval 5
neighbor qq.0.0.1 route-map IN in
neighbor qq.0.0.1 route-map OUT out
neighbor qq.0.0.1 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor bb.bb.bb.bb activate
neighbor bb.bb.bb.bb send-community extended
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
access-list 1 permit ff.ff.ff.ff log
access-list 2 permit ee.ee.ee.ee log
access-list 3 permit bb.bb.bb.bb log
access-list 4 permit aa.aa.aa.aa log
!
route-map IN permit 11
match ip address 2
match mpls-label
!
route-map IN permit 12
match ip address 4
!
route-map OUT permit 10
match ip address 1
set mpls-label
!
route-map OUT permit 13
match ip address 3
!
end

ASBR3 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR3 は、非 MPLS VPN サービス プロバイダーに属しています。ASBR3 は、ASBR1 との間で IPv4 ルートおよび MPLS ラベルを交換します。また、ASBR3 は、ASBR1 から学習したルートを RR3 経由で ASBR3 に渡します。


) iBGP を使用してルートおよびラベルを配布する場合は、学習した eBGP ルートを iBGP に再配布しないでください。このような設定はサポートされていません。


ip subnet-zero
ip cef
!
interface Loopback0
ip address yy.yy.yy.yy 255.255.255.255
interface Hssi4/0
ip address mm.0.0.0.1 255.0.0.0
mpls ip
hssi internal-clock
!
interface Serial5/0
ip address kk.0.0.1 255.0.0.0
load-interval 30
clockrate 124061
!
router ospf 30
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network yy.yy.yy.yy 0.0.0.0 area 300
network mm.0.0.0 0.255.255.255 area 300
!
router bgp 300
bgp log-neighbor-changes
timers bgp 10 30
neighbor cc.cc.cc.cc remote-as 300
neighbor cc.cc.cc.cc update-source Loopback0
neighbor kk.0.0.2 remote-as 100
no auto-summary
!
address-family ipv4
neighbor cc.cc.cc.cc activate ! iBGP+labels session with RR3
neighbor cc.cc.cc.cc send-label
neighbor kk.0.0.2 activate ! eBGP+labels session with ASBR1
neighbor kk.0.0.2 advertisement-interval 5
neighbor kk.0.0.2 send-label
neighbor kk.0.0.2 route-map IN in
neighbor kk.0.0.2 route-map OUT out
no auto-summary
no synchronization
exit-address-family
!
ip classless
!
access-list 1 permit ee.ee.ee.ee log
access-list 2 permit ff.ff.ff.ff log
access-list 3 permit aa.aa.aa.aa log
access-list 4 permit bb.bb.bb.bb log
!
route-map IN permit 10
match ip address 1
match mpls-label
!
route-map IN permit 11
match ip address 3
!
route-map OUT permit 12
match ip address 2
set mpls-label
!
route-map OUT permit 13
match ip address 4
!
ip default-gateway 3.3.0.1
ip classless
!
end

ルート リフレクタ 3 の設定例(非 MPLS VPN サービス プロバイダー)

RR3 は、MPLS ラベル付きの IPv4 ルートを ASBR3 および ASBR4 に反映する非 MPLS VPN RR です。

ip subnet-zero
mpls label protocol ldp
mpls traffic-eng auto-bw timers
no mpls ip
!
interface Loopback0
ip address cc.cc.cc.cc 255.255.255.255
!
interface POS0/2
ip address pp.0.0.1 255.0.0.0
crc 16
clock source internal
!
router ospf 30
log-adjacency-changes
network cc.cc.cc.cc 0.0.0.0 area 300
network pp.0.0.0 0.255.255.255 area 300
!
router bgp 300
bgp log-neighbor-changes
neighbor zz.zz.zz.zz remote-as 300
neighbor zz.zz.zz.zz update-source Loopback0
neighbor yy.yy.yy.yy remote-as 300
neighbor yy.yy.yy.yy update-source Loopback0
no auto-summary
!
address-family ipv4
neighbor zz.zz.zz.zz activate
neighbor zz.zz.zz.zz route-reflector-client
neighbor zz.zz.zz.zz send-label ! iBGP+labels session with ASBR3
neighbor yy.yy.yy.yy activate
neighbor yy.yy.yy.yy route-reflector-client
neighbor yy.yy.yy.yy send-label ! iBGP+labels session with ASBR4
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
end

ASBR4 の設定例(非 MPLS VPN サービス プロバイダー)

ASBR4 は、非 MPLS VPN サービス プロバイダーに属しています。ASBR4 と ASBR3 は、RR3 経由で IPv4 ルートと MPLS ラベルを交換します。


) iBGP を使用してルートおよびラベルを配布する場合は、学習した eBGP ルートを iBGP に再配布しないでください。このような設定はサポートされていません。


ip subnet-zero
ip cef distributed
!
interface Loopback0
ip address zz.zz.zz.zz 255.255.255.255
!
interface Ethernet0/2
ip address qq.0.0.1 255.0.0.0
!
interface POS1/1/0
ip address pp.0.0.2 255.0.0.0
ip route-cache distributed
!
interface Hssi2/1/1
ip address mm.0.0.2 255.0.0.0
ip route-cache distributed
mpls label protocol ldp
mpls ip
hssi internal-clock
!
router ospf 30
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet0/2
network zz.zz.zz.zz 0.0.0.0 area 300
network pp.0.0.0 0.255.255.255 area 300
network mm.0.0.0 0.255.255.255 area 300
!
router bgp 300
bgp log-neighbor-changes
timers bgp 10 30
neighbor cc.cc.cc.cc remote-as 300
neighbor cc.cc.cc.cc update-source Loopback0
neighbor qq.0.0.2 remote-as 200
no auto-summary
!
address-family ipv4
neighbor cc.cc.cc.cc activate
neighbor cc.cc.cc.cc send-label
neighbor qq.0.0.2 activate
neighbor qq.0.0.2 advertisement-interval 5
neighbor qq.0.0.2 send-label
neighbor qq.0.0.2 route-map IN in
neighbor qq.0.0.2 route-map OUT out
no auto-summary
no synchronization
exit-address-family
!
ip classless
!
access-list 1 permit ff.ff.ff.ff log
access-list 2 permit ee.ee.ee.ee log
access-list 3 permit bb.bb.bb.bb log
access-list 4 permit aa.aa.aa.aa log
!
route-map IN permit 10
match ip address 1
match mpls-label
!
route-map IN permit 11
match ip address 3
!
route-map OUT permit 12
match ip address 2
set mpls-label
!
route-map OUT permit 13
match ip address 4
!
ip default-gateway 3.3.0.1
ip classless
!
end

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

『MPLS Product Literature』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1700

『Assigned Numbers』

RFC 1966

BGP Route Reflection: An Alternative to Full Mesh IBGP

RFC 2842

Capabilities Advertisement with BGP-4

RFC 2858

『Multiprotocol Extensions for BGP-4』

RFC 3107

『Carrying Label Information in BGP-4』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-ASの機能情報

表 2 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 2 ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS の機能情報

機能名
リリース
機能設定情報

ASBR で IPv4 ルートおよび MPLS ラベルを交換する MPLS VPN Inter-AS

12.0(21)ST
12.0(22)S
12.0(23)S
12.2(13)T
12.0(24)S
12.2(14)S
12.0(27)S
12.0(29)S

この章では、ASBR が Provider Edge(PE; プロバイダー エッジ)ルータの MPLS ラベル付きの IPv4 ルートを交換できるように MPLS VPN Inter-AS ネットワークを設定する方法について説明しています。Route Reflector(RR; ルート リフレクタ)は、マルチホップ マルチプロトコル external Border Gateway Protocol(eBGP; 外部ボーダー ゲートウェイ プロトコル)を使用して VPN-IPv4 ルートを交換します。

この機能では、新しいコマンドや変更されたコマンドは使用されません。