Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS LDP セッション保護
MPLS LDP セッション保護
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS LDP セッション保護

この章の構成

MPLS LDP セッション保護に関する情報

MPLS LDP セッション保護の設定方法

MPLS LDP セッション保護のイネーブル化

前提条件

制約事項

MPLS LDP セッション保護のカスタマイズ

LDP ターゲット Hello 隣接の保持期間の指定

MPLS LDP セッション保護を適用するルータの指定

MPLS LDP セッション保護の確認

トラブルシューティングのヒント

MPLS LDP セッション保護の設定例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

MPLS LDP セッション保護

MPLS LDP セッション保護機能を使用すると、リンクが停止してから回復するときに、ラベル配布プロトコルのコンバージェンスが迅速に行われます。MPLS LDP セッション保護は、直接接続されているネイバー間の Label Distribution Protocol(LDP; ラベル配布プロトコル)セッションまたは Traffic Engineering(TE; トラフィック エンジニアリング)トンネルに対して確立された LDP セッションを保護します。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。 この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、 「MPLS LDP セッション保護の機能情報」(P.23) を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

MPLS LDP セッション保護に関する情報

MPLS LDP セッション保護は、リンクに障害が発生した場合に LDP バインディングを保持します。MPLS LDP セッションは、LDP Hello メッセージを使用して保護されます。MPLS LDP をイネーブルにすると、Label Switched Router(LSR; ラベル スイッチド ルータ)はメッセージを送信して、LDP セッションを作成できる他の LSR を探します。

LSR がそのネイバーから 1 つめのホップである場合、LSR はネイバーに直接接続されています。LSR は、LDP Hello メッセージを User Datagram Protocol(UDP; ユーザ データグラム プロトコル)パケットとしてサブネット上のすべてのルータに送信します。この hello メッセージを LDP リンク Hello と呼びます。ネイバー LSR が hello メッセージに応答すると、2 つのルータは LDP セッションの確立を開始します。

LSR がネイバーから 2 つめ以降のホップである場合、LSR はそのネイバーに直接接続されていません。LSR は、有向型 Hello メッセージを UDP パケットとして、特にその LSR に宛てられたユニキャスト メッセージとして送信します。この hello メッセージを LDP ターゲット Hello と呼びます。直接接続されていない LSR が Hello メッセージに応答すると、2 つのルータは LDP セッションを確立します (2 つの LSR 間のパスがトラフィック エンジニアリングされ、そのパスで LDP がイネーブルになっている場合、2 つの LSR 間の LDP セッションをターゲット セッションと呼びます)。

MPLS LDP セッション保護では、LDP ターゲット Hello を使用して LDP セッションを保護します。たとえば、2 つの直接接続されているルータで LDP がイネーブルになっており、これらのルータがネットワークで代替 IP ルートを使用して相互に到達できるとします。この場合、2 つのルータの間に存在する LDP セッションを LDP リンク Hello 隣接と呼びます。MPLS LDP セッション保護がイネーブルになっている場合、LDP セッションに対して LDP ターゲット Hello 隣接も確立されます。2 つのルータ間のリンクで障害が発生した場合は、LDP リンク隣接も失敗します。ただし、IP を使用して LDP ピアにまだ到達可能であれば、LDP ターゲット Hello 隣接がルータ間にまだ存在するため、LDP セッションはアップ状態のままです。直接接続されているリンクが回復したら、セッションを再確立する必要も、プレフィクスの LDP バインディングを再学習する必要もありません。

MPLS LDP セッション保護の設定方法

ここでは、MPLS LDP セッション保護を設定し、確認する方法について説明します。

「MPLS LDP セッション保護のイネーブル化」(必須)

「MPLS LDP セッション保護のカスタマイズ」 (任意)

「MPLS LDP セッション保護の確認」 (任意)

MPLS LDP セッション保護のイネーブル化

MPLS LDP セッション保護をイネーブルにするには、 mpls ldp session protection コマンドを使用します。このコマンドを使用すると、リンクの障害発生中に LDP セッションを保護できます。デフォルトでは、すべての LDP セッションが保護されます。このコマンドには、保護する LDP セッションを指定するためのいくつかのオプションがあります。 vrf キーワードを使用すると、指定した VRF の LDP セッションを保護できます。 for キーワードを使用すると、保護するプレフィクスの標準の IP Access Control List(ACL; アクセス コントロール リスト)を指定できます。 duration キーワードを使用すると、LDP リンク Hello 隣接の損失後に LDP ターゲット Hello 隣接をルータで保持する期間を指定できます。

前提条件

LSR は、LDP ターゲット hello に応答できる必要があります。応答できない場合、LSR はターゲット隣接を確立できません。MPLS LDP セッション保護に関わるすべてのルータは、ターゲット hello に応答できる必要があります。両方のネイバー ルータにセッション保護を設定するか、または一方のルータにセッション保護を設定してもう一方のルータをターゲット hello に応答するように設定する必要があります。

制約事項

この機能は、次の場合はサポートされません。

TDP セッションを使用する。

拡張アクセス リストを使用する。

LC-ATM ルータを使用する。

手順の概要

1. enable

2. configure terminal

3. ip cef [distributed]

4. interface loopback number

5. ip address {prefix mask}

6. interface interface

7. mpls ip

8. mpls label protocol { ldp | tdp | both }

9. exit

10. mpls ldp session protection [ vrf vpn-name] [ for acl] [ duration seconds]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [ distributed ]

 

Router(config)# ip cef

シスコ エクスプレス フォワーディングを設定します。

ステップ 4

interface loopbacknumber

 

Router(config)# interface Loopback0

ループバック インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address {prefix mask}

 

Router(config-if)# ip address 10.25.0.11 255.255.255.255

ループバック インターフェイスに IP アドレスを割り当てます。

ステップ 6

interface interface

 

Router(config-if)# interface POS3/0

設定するインターフェイスを指定します。

ステップ 7

mpls ip

 

Router(config-if)# mpls ip

指定したインターフェイスに対して MPLS ホップバイホップ転送を設定します。

ステップ 8

mpls label protocol {ldp | tdp | both}

 

Router(config-if)# mpls label protocol ldp

特定のインターフェイスまたはすべてのインターフェイスに対して LDP の使用を設定します。

インターフェイス コンフィギュレーション モードの場合、このコマンドを発行すると、インターフェイスのデフォルトのラベル配布プロトコルが LDP に設定され、グローバルな mpls label protocol コマンドによって設定されたデフォルトが上書きされます。

グローバル コンフィギュレーション モードの場合、このコマンドを発行すると、すべてのインターフェイスに対して LDP が設定されます。

ステップ 9

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 10

mpls ldp session protection [vrf vpn-name] [for acl] [duration seconds]

 

Router(config)# mpls ldp session protection

MPLS LDP セッション保護をイネーブルにします。

MPLS LDP セッション保護のカスタマイズ

mpls ldp session protection コマンドでキーワードを使用して、MPLS LDP セッション保護を変更できます。ここでは、機能のカスタマイズ方法について説明します。

LDP ターゲット Hello 隣接の保持期間の指定

mpls ldp session protection コマンドのデフォルトの動作では、LDP リンク Hello 隣接の損失後、LDP ターゲット Hello 隣接は無期限に存続できます。 duration キーワードを発行すると、LDP リンク Hello 隣接の損失後、LDP ターゲット Hello 隣接を保持する秒数(30 ~ 2,147,483)を指定できます。リンクが損失すると、タイマーが始動します。タイマーが切れると、LDP ターゲット Hello 隣接が削除されます。

MPLS LDP セッション保護を適用するルータの指定

mpls ldp session protection コマンドのデフォルトの動作では、すべてのネイバー セッションに MPLS LDP セッション保護を適用できます。 vrf または for キーワードを発行すると、保護するネイバー セッションの数を制限できます。

指定した VPN ルーティングおよび転送インスタンスに対する MPLS LDP セッション保護のイネーブル化

ルータに少なくとも 1 つの VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスが設定されている場合、 vrf キーワードを使用して、保護する VRF を選択できます。 mpls ldp session protection コマンドで複数の VRF を指定することはできません。複数の VRF を指定するには、このコマンドを複数回発行します。

指定したピア ルータに対する MPLS LDP セッション保護のイネーブル化

複数のピア ルータを含むアクセス リストを作成できます。そのアクセス リストを for キーワードとともに指定して、アクセス コントロール リスト内のピア ルータの LDP セッション保護をイネーブルにすることができます。

MPLS LDP セッション保護の確認

LDP セッション保護が正しく設定されていることを確認するには、次の手順を実行します。

手順の概要

1. show mpls ldp discovery

2. show mpls ldp neighbor

3. show mpls ldp neighbor detail

手順の詳細


ステップ 1 show mpls ldp discovery

このコマンドを発行して、出力にピア ルータへの xmit/recv が含まれていることを確認します。

Router# show mpls ldp discovery
 
Local LDP Identifier:
10.0.0.5:0
Discovery Sources:
Interfaces:
ATM5/1/0.5 (ldp): xmit/recv
LDP Id: 10.0.0.1:0
Targeted Hellos:
10.0.0.5 -> 10.0.0.3 (ldp): active, xmit/recv
LDP Id: 10.0.0.3:0
 

ステップ 2 show mpls ldp neighbor

このコマンドを発行して、ターゲット hello がアクティブであることを確認します。

Router# show mpls ldp neighbor
 
Peer LDP Ident: 10.0.0.3:0; Local LDP Ident 10.0.0.5:0
TCP connection: 10.0.0.3.646 - 10.0.0.5.11005
State: Oper; Msgs sent/rcvd: 1453/1464; Downstream
Up time: 21:09:56
LDP discovery sources:
Targeted Hello 10.0.0.5 -> 10.0.0.3, active
Addresses bound to peer LDP Ident:
10.3.104.3 10.0.0.2 10.0.0.3
 

ステップ 3 show mpls ldp neighbor detail

このコマンドを発行して、MPLS LDP セッション保護の状態が Ready または Protecting であることを確認します。出力の最後から 2 行めに Incomplete と表示されている場合、ターゲット Hello 隣接はまだアップ状態ではありません。

Router# show mpls ldp neighbor detail
 
Peer LDP Ident: 10.16.16.16:0; Local LDP Ident 10.15.15.15:0
TCP connection: 10.16.16.16.11013 - 10.15.15.15.646
State: Oper; Msgs sent/rcvd: 53/51; Downstream; Last TIB rev sent 74
Up time: 00:11:32; UID: 1; Peer Id 0;
LDP discovery sources:
Targeted Hello 10.15.15.15 -> 10.16.16.16, active, passive;
holdtime: infinite, hello interval: 10000 ms
Addresses bound to peer LDP Ident:
10.0.0.2 10.16.16.16 10.101.101.101 11.0.0.1
Peer holdtime: 180000 ms; KA interval: 60000 ms; Peer state: estab
Clients: Dir Adj Client
LDP Session Protection enabled, state: Protecting
duration: infinite


 

トラブルシューティングのヒント

リンクのダウン後に LDP セッションを終了する必要がある場合は、 clear mpls ldp neighbor コマンドを使用します。この機能は、リンクをアウト オブ サービスにする必要がある場合、または別のネイバーに接続する必要がある場合に便利です。

MPLS LDP セッション保護に関連するイベントの表示をイネーブルにするには、 debug mpls ldp session protection コマンドを使用します。

MPLS LDP セッション保護の設定例

図 1 に、MPLS LDP セッション保護のサンプル設定を示します。

図 1 MPLS LDP セッション保護の例

R1

redundancy
no keepalive-enable
mode hsa
!
ip cef distributed
no ip domain-lookup
multilink bundle-name both
mpls label protocol ldp
mpls ldp session protection
no mpls traffic-eng auto-bw timers frequency 0
tag-switching tdp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Multilink4
no ip address
no ip directed-broadcast
no ip mroute-cache
load-interval 30
ppp multilink
multilink-group 4
!
interface Ethernet1/0/0
ip address 10.3.123.1 255.255.0.0
no ip directed-broadcast
!
interface Ethernet4/0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet4/0/1
description -- ip address 10.0.0.2 255.255.255.0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet4/0/4
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
tag-switching ip
!
interface Ethernet4/0/6
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
tag-switching ip
!
interface Ethernet4/0/7
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.1 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless

R2

redundancy
no keepalive-enable
mode hsa
!
ip subnet-zero
ip cef distributed
mpls label protocol ldp
mpls ldp session protection
no mpls traffic-eng auto-bw timers frequency 0
tag-switching tdp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.3 255.255.255.255
no ip directed-broadcast
!
interface Ethernet5/0/0
no ip address
no ip directed-broadcast
shutdown
full-duplex
!
interface Ethernet5/0/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
tag-switching ip
!
interface Ethernet5/0/6
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
ip load-sharing per-packet
full-duplex
mpls label protocol ldp
tag-switching ip
!
interface FastEthernet5/1/0
ip address 10.3.123.112 255.255.0.0
no ip directed-broadcast
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.3 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless

R3

ip cef
no ip domain-lookup
mpls label range 200 100000 static 16 199
mpls label protocol ldp
no mpls traffic-eng auto-bw timers frequency 0
tag-switching tdp router-id Loopback0 force
!
interface Loopback0
ip address 10.0.0.5 255.255.255.255
no ip directed-broadcast
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
half-duplex
!
interface Ethernet1/2
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
tag-switching ip
!
interface Ethernet1/4
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
full-duplex
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected
network 10.0.0.5 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
ip classless

その他の関連資料

ここでは、MPLS LDP セッション保護機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS LDP

『MPLS Label Distribution Protocol』

MPLS LDP-IGP 同期

『MPLS LDP-IGP Synchronization』

LDP 自動設定

『LDP Autoconfiguration』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

MPLS LDP MIB

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3037

『LDP Applicability』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。サービス契約が有効で、ログイン ID またはパスワードを取得していない場合は、Cisco.com でまず登録手続きを行ってください。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List 』にアクセスしてください。

debug mpls ldp session protection

mpls ldp session protection

show mpls ldp neighbor

MPLS LDP セッション保護の機能情報