Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS LDP-IGP 同期
MPLS LDP-IGP 同期
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS LDP-IGP 同期

機能情報の確認

この章の構成

MPLS LDP-IGP 同期の前提条件

MPLS LDP-IGP 同期の制約事項

MPLS LDP-IGP 同期に関する情報

MPLS LDP-IGP 同期の機能

ピアとの MPLS LDP-IGP 同期

MPLS LDP-IGP 同期遅延タイマー

IGP ノンストップ フォワーディングと MPLS LDP-IGP 同期の非互換性

LDP グレースフル リスタートと MPLS LDP-IGP 同期の互換性

MPLS LDP-IGP 同期の設定方法

OSPF インターフェイスでの MPLS LDP-IGP 同期の設定

一部の OSPF インターフェイスでの MPLS LDP-IGP 同期のディセーブル

OSPF での MPLS LDP-IGP 同期の確認

IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定

すべての IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定

1 つの IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定

一部の IS-IS インターフェイスでの MPLS LDP-IGP 同期のディセーブル

IS-IS での MPLS LDP-IGP 同期の確認

トラブルシューティングのヒント

MPLS LDP-IGP 同期の設定例

OSPF での MPLS LDP-IGP 同期:例

IS-IS での MPLS

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS LDP-IGP 同期の機能履歴

MPLS LDP-IGP 同期

MPLS LDP-IGP 同期機能では、Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)パスがスイッチングに使用される前に Label Distribution Protocol(LDP; ラベル配布プロトコル)が完全に確立されていることが保証されます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS LDP-IGP 同期の機能履歴」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS LDP-IGP 同期の前提条件

この機能は、Open Shortest Path First(OSPF)または Intermediate System-to-System(IS-IS)プロセスを実行しているインターフェイスでだけサポートされます。

この機能は、 mpls ip コマンドまたは mpls ldp autoconfig コマンドを使用してインターフェイスで LDP がイネーブルになっている場合に動作します。

MPLS LDP-IGP 同期の制約事項

Cisco IOS Release 12.2(33)SB および Cisco IOS Release 12.2(33)SRB では、MPLS LDP-IGP 同期機能で IS-IS はサポートされません。OSPF だけがサポートされます。

Tag Distribution Protocol(TDP; タグ配布プロトコル)はサポートされていません。ルータまたはインターフェイスのデフォルトのラベル配布プロトコルとして LDP を指定する必要があります。

この機能は、トンネル インターフェイスまたは LC-ATM インターフェイスではサポートされません。

この機能は、インターフェイス ローカル ラベル空間または Downstream-on-Demand(DoD; ダウンストリームオンデマンド)要求ではサポートされません。

この機能では、ターゲット LDP セッションはサポートされません。したがって、Any Transport over MPLS(AToM)セッションはサポートされません。

MPLS LDP-IGP 同期に関する情報

MPLS LDP-IGP 同期機能を設定するには、次の概念を理解しておく必要があります。

「MPLS LDP-IGP 同期の機能」

「ピアとの MPLS LDP-IGP 同期」

「MPLS LDP-IGP 同期遅延タイマー」

「IGP ノンストップ フォワーディングと MPLS LDP-IGP 同期の非互換性」

「LDP グレースフル リスタートと MPLS LDP-IGP 同期の互換性」

MPLS LDP-IGP 同期の機能

IGP と LDP のアクションが同期していないためにパケット損失が発生することがあります。パケット損失は、次の状況で発生することがあります。

IGP 隣接が確立されると、ルータは、そのリンク上のピア間で LDP ラベル交換が完了する前に、新しい隣接を使用してパケットの転送を開始します。

LDP セッションが終了した場合、ルータは、LDP セッションと完全に同期した代替経路ではなく、LDP ピアに関連付けられているリンクを使用してトラフィックの転送を継続します。

MPLS LDP-IGP 同期機能では、次の処理が行われます。

LDP と IGP を同期して、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)パケット損失を最小化する手段を提供します。

IGP OSPF または IS-IS プロセスに関連付けられている各インターフェイスで LDP-IGP 同期をグローバルにイネーブルにできます。

LDP-IGP 同期をイネーブルにする必要がないインターフェイスで LDP-IGP 同期をディセーブルにする手段を提供します。

同期の競合による MPLS パケット損失を防ぎます。

mpls ip または mpls ldp autoconfig コマンドを使用してインターフェイス上で LDP がイネーブルになっている場合に動作します。

OSPF または IS-IS プロセスに属する各インターフェイスで LDP-IGP 同期をイネーブルにするには、 mpls ldp sync コマンドを入力します。一部のインターフェイスで LDP-IGP 同期をイネーブルにしない場合は、該当するインターフェイスに対して no mpls ldp igp sync コマンドを発行します。

LDP ピアが到達可能な場合、IGP は(デフォルトで)同期の実施を無制限に待機します。IGP セッションが待機する時間の長さを制限するには、 mpls ldp igp sync holddown コマンドを入力します。LDP ピアが到達不能な場合、IGP は隣接を確立して LDP セッションを確立できるようにします。

IGP 隣接がリンク上に確立されていても、LDP-IGP 同期がまだ実現されていないか失われた場合、IGP はそのリンクで max-metric をアドバタイズします。

ピアとの MPLS LDP-IGP 同期

MPLS LDP-IGP 同期機能がインターフェイスでイネーブルになっている場合、LDP は、ルーティング テーブルでピアのトランスポート アドレスを探すことにより、インターフェイスによって接続されているピアが到達可能かどうかを判断します。ピアのルーティング エントリ(最長一致またはデフォルトのルーティング エントリを含む)が存在する場合、LDP は、インターフェイスに LDP-IGP 同期が必要であると想定し、IGP に LDP コンバージェンスを待機するよう通知します。

ピアとの LDP-IGP 同期には、ピアのトランスポート アドレスのルーティング テーブルが正確であることが必要です。ルーティング テーブルに、ピアのトランスポート アドレスのルートがあることが示されている場合は、そのルートでピアのトランスポート アドレスに到達できる必要があります。ただし、ルートがサマリー ルート、デフォルト ルート、または静的に設定されたルートの場合は、ピアに対して適切なルートではない可能性があります。ルーティング テーブル内のルートでピアのトランスポート アドレスに到達できることを確認する必要があります。

ルーティング テーブルに、ピアのトランスポート アドレスの不正確なルートがある場合、LDP はピアとのセッションを設定できず、IGP が同期ホールドダウン時間にわたって LDP コンバージェンスを不必要に待機する原因となります。

MPLS LDP-IGP 同期遅延タイマー

Cisco IOS Release 12.0(32)SY およびそれ以降のリリースの MPLS LDP-IGP 同期機能では、インターフェイスごとに MPLS LDP と IGP の同期の遅延時間を設定するオプションが提供されます。通常、LDP-IGP 同期が設定されている場合は、LDP が収束するとすぐに LDP によって IGP に通知されます。遅延タイマーが設定されている場合、この通知は遅延します。インターフェイスに遅延時間を設定する場合は、インターフェイス コンフィギュレーション モードで mpls ldp igp sync delay delay-time コマンドを使用します。指定したインターフェイスから遅延タイマーを削除するには、 no mpls ldp igp sync delay コマンドを入力します。このコマンドでは、遅延時間が 0 秒に設定されますが、MPLS LDP-IGP 同期はイネーブルのままになります。

LDP が完全に確立されて同期されると、LDP によって遅延タイマーがチェックされます。

遅延時間を設定した場合は、LDP によってタイマーが開始されます。タイマーが期限切れになると、LDP によって同期がまだ有効であることがチェックされて OSPF プロセスに通知されます。

遅延時間を設定しなかった場合、同期がディセーブルになっているかダウンしている場合、またはインターフェイスが IGP プロセスから削除された場合は、LDP によってタイマーが停止され、OSPF プロセスに即時に通知されます。

タイマーの実行中に新しい遅延時間を設定した場合は、LDP によって新しい遅延時間が保存されますが、実行中のタイマーは再設定されません。

IGP ノンストップ フォワーディングと MPLS LDP-IGP 同期の非互換性

IGP Nonstop Forwarding(NSF; ノンストップ フォワーディング)が設定されている場合、スタートアップ期間中は MPLS LDP-IGP 同期機能がサポートされません。MPLS LDP-IGP 同期機能は、スタートアップ中に IGP が NSF を実行している場合に IGP NSF と競合します。NSF スタートアップの完了後、MPLS LDP-IGP 同期機能がサポートされます。

LDP グレースフル リスタートと MPLS LDP-IGP 同期の互換性

LDP グレースフル リスタートでは、LDP セッションが失われた場合にトラフィックが保護されます。グレースフル リスタートがイネーブルになっている LDP セッションをサポートするインターフェイスに障害が発生した場合でも、グレースフル リスタートで保護されている間、インターフェイス上で MPLS LDP-IGP 同期が実現されます。MPLS LDP-IGP 同期は次の状況で最終的に失われます。

LDP グレースフル リスタート再接続タイマーが期限切れになる前に LDP が再起動できない場合

LDP セッションが他のインターフェイスを通じて再起動し、LDP グレースフル リスタート回復タイマーが期限切れになったときに保護されたインターフェイス上の LDP セッションが回復できない場合

MPLS LDP-IGP 同期の設定方法

ここでは、次の各手順について説明します。

「OSPF インターフェイスでの MPLS LDP-IGP 同期の設定」(必須)

「一部の OSPF インターフェイスでの MPLS LDP-IGP 同期のディセーブル」 (任意)

「OSPF での MPLS LDP-IGP 同期の確認」 (任意)

「IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定」(必須)

「一部の IS-IS インターフェイスでの MPLS LDP-IGP 同期のディセーブル」 (任意)

「IS-IS での MPLS LDP-IGP 同期の確認」 (任意)

OSPF インターフェイスでの MPLS LDP-IGP 同期の設定

OSPF インターフェイスで MPLS LDP-IGP 同期を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. interface type number

6. ip address prefix mask

7. mpls ip

8. exit

9. router ospf process-id

10. network ip-address wildcard-mask area area-id

11. mpls ldp sync

12. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip

 

Router(config)# mpls ip

ホップバイホップ転送をグローバルにイネーブルにします。

ステップ 4

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

デフォルトのラベル配布プロトコルとして LDP を指定します。

ステップ 5

interface type number

 

Router(config)# interface POS3/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 6

ip address prefix mask

 

Router(config-if)# ip address 10.25.0.11 255.255.255.255

インターフェイスに IP アドレスを割り当てます。

ステップ 7

mpls ip

 

Router(config-if)# mpls ip

インターフェイスでホップバイホップ転送をイネーブルにします。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 9

router ospf process-id

 

Router(config)# router ospf 1

OSPF ルーティングをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 10

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 10.0.0.0 0.255.255.255 area 3

OSPF を実行するインターフェイスを定義し、そのインターフェイスに対するエリア ID を定義します。

ステップ 11

mpls ldp sync

 

Router(config-router)# mpls ldp sync

OSPF または IS-IS プロセスのインターフェイスに対して MPLS LDP-IGP 同期をイネーブルにします。

ステップ 12

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

一部の OSPF インターフェイスでの MPLS LDP-IGP 同期のディセーブル

mpls ldp sync コマンドを発行すると、OSPF プロセスに属しているすべてのインターフェイスで LDP-IGP 同期がイネーブルになります。一部のインターフェイスから LDP-IGP 同期を削除するには、該当するインターフェイスで no 形式の mpls ldp igp sync コマンドを使用します。次の設定手順は、 mpls ldp sync コマンドを使用してインターフェイスに LDP-IGP 同期を設定したあとに、一部の OSPF インターフェイスで LDP-IGP 同期をディセーブルにする方法を示しています。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp sync

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface POS3/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no mpls ldp igp sync

 

Router(config-if)# no mpls ldp igp sync

そのインターフェイスの MPLS LDP-IGP 同期をディセーブルにします。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

OSPF での MPLS LDP-IGP 同期の確認

LDP、OSPF、および LDP-IGP 同期のインターフェイスを設定したあとで、 show mpls ldp igp sync および show ip ospf mpls ldp interface コマンドを使用して設定が正しく動作していることを確認します。

手順の概要

1. enable

2. show mpls ldp igp sync

3. show ip ospf mpls ldp interface

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。

ステップ 2 show mpls ldp igp sync

このコマンドの出力(次の例に示します)は、LDP が設定され、SYNC ステータスによって同期がイネーブルになっていることが示されるため、MPLS LDP-IGP 同期が正しく設定されていることを示しています。

Router# show mpls ldp igp sync
 
Ethernet0/0:
LDP configured; SYNC enabled.
SYNC status: sync achieved; peer reachable.
IGP holddown time: infinite.
Peer LDP Ident: 10.0.0.1:0
IGP enabled: OSPF 1
 

MPLS LDP-IGP 同期がインターフェイスでイネーブルになっていない場合、出力は次のように表示されます。

Ethernet5/1:
LDP configured; LDP-IGP Synchronization not enabled.
 

ステップ 3 show ip ospf mpls ldp interface

次の例の show ip ospf mpls ldp interface コマンドの出力は、インターフェイスが正しく設定されていることを示します。

Router# show ip ospf mpls ldp interface
 
Ethernet3/0/0
Process ID 1, Area 0
LDP is configured through LDP autoconfig
LDP-IGP Synchronization: Yes
Holddown timer is not configured
Timer is not running
Ethernet3/0/2
Process ID 1, Area 0
LDP is configured through LDP autoconfig
LDP-IGP Synchronization: Yes
Holddown timer is not configured
Timer is not running


 

IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定


) Cisco IOS Release 12.2(33)SRB および 12.2(33)SB では、MPLS LDP-IGP 同期機能で IS-IS はサポートされません。OSPF だけがサポートされます。


ここでは、IS-IS プロセスを実行しているインターフェイスに対して MPLS LDP-IGP 同期を設定する手順と例を示します。

「すべての IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定」

「1 つの IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定」

すべての IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定

ここでは、IS-IS プロセスを実行しているすべてのインターフェイスで MPLS LDP-IGP 同期機能を設定する手順を示します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. mpls label protocol ldp

5. router isis process-name

6. mpls ldp sync

7. mpls ldp autoconfig

8. exit

9. interface type number

10. ip address prefix mask

11. ip router isis process-name

12. mpls ip

13. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip

 

Router(config)# mpls ip

ホップバイホップ転送をグローバルにイネーブルにします。

ステップ 4

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

デフォルトのラベル配布プロトコルとして LDP を指定します。

ステップ 5

router isis process-name

 

Router(config)# router isis ISIS

ルータで IS-IS プロトコルをイネーブルにし、IS-IS プロセスを指定し、ルータ コンフィギュレーション モードを開始します。

ステップ 6

mpls ldp sync

 

Router(config-router)# mpls ldp sync

IS-IS プロセスに属するインターフェイスに対して MPLS LDP-IGP 同期をイネーブルにします。

ステップ 7

mpls ldp autoconfig

 

Router(config-router)# mpls ldp autoconfig

自動設定を設定して、自動同期をすばやく設定します。自動設定が設定されている場合、MPLS がイネーブルになっているインターフェイスで自動同期設定は不要です。

ステップ 8

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface POS0/3

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 10

ip address prefix mask

 

Router(config-if)# ip address 10.25.25.11 255.255.255.0

インターフェイスに IP アドレスを割り当てます。

ステップ 11

ip router isis process-name

 

Router(config-if)# ip router isis ISIS

IS-IS をイネーブルにします。

ステップ 12

mpls ip

 

Router(config-if)# mpls ip

MPLS IP をイネーブルにします。

ステップ 13

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

1 つの IS-IS インターフェイスでの MPLS LDP-IGP 同期の設定

ここでは、IS-IS プロセスを実行している 1 つのインターフェイスで MPLS LDP-IGP 同期機能を設定する手順を示します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address prefix mask

5. mpls ldp igp sync

6. ip router isis

7. exit

8. router isis

9. mpls ldp sync

10. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface POS0/2

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address prefix mask

 

Router(config-if)# ip address 10.50.72.4 255.0.0.0

インターフェイスに IP アドレスを割り当てます。

ステップ 5

mpls ldp igp sync

 

Router(config-if)# mpls ldp igp sync

MPLS LDP-IGP 同期をイネーブルにします。

ステップ 6

ip router isis

 

Router(config-if)# ip router isis

インターフェイスで IP の IS-IS プロトコルをイネーブルにします。

ステップ 7

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

router isis

 

Router(config)# router isis

ルータで IS-IS プロセスをイネーブルにします。

ステップ 9

mpls ldp sync

 

Router(config-router)# mpls ldp sync

IS-IS プロセスに属するインターフェイスに対して LDP-IGP 同期をイネーブルにします。

ステップ 10

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

一部の IS-IS インターフェイスでの MPLS LDP-IGP 同期のディセーブル

mpls ldp sync コマンドを発行すると、IS-IS プロセスに属しているすべてのインターフェイスで LDP-IGP 同期がイネーブルになります。一部のインターフェイスから LDP-IGP 同期を削除するには、該当するインターフェイスで no 形式の mpls ldp igp sync コマンドを使用します。次の設定手順は、 mpls ldp sync コマンドを使用してインターフェイスに LDP-IGP 同期を設定したあとに、一部の IS-IS インターフェイスで LDP-IGP 同期をディセーブルにする方法を示しています。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. no mpls ldp igp sync

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface POS3/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no mpls ldp igp sync

 

Router(config-if)# no mpls ldp igp sync

そのインターフェイスの MPLS LDP-IGP 同期をディセーブルにします。

ステップ 5

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

IS-IS での MPLS LDP-IGP 同期の確認

IS-IS との LDP-IGP 同期用にインターフェイスを設定したあとで、 show isis mpls ldp コマンドを使用して設定が正しく動作していることを確認できます。

手順の概要

1. enable

2. show isis mpls ldp

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたらパスワードを入力します。

ステップ 2 show isis mpls ldp

次のコマンドの出力は、インターフェイスで IS-IS が設定されていること(ISIS is UP)および IS-IS との MPLS LDP-IGP 同期が正しく設定されていること(SYNC achieved)を示しています。

Router# show isis mpls ldp
 
Interface: POS0/2; ISIS tag null enabled
ISIS is UP on interface
AUTOCONFIG Information :
LDP enabled: NO
SYNC Information :
Required: YES
Achieved: YES
IGP Delay: NO
Holddown time: Infinite
State: SYNC achieved

 

IS-IS との MPLS LDP-IGP 同期がインターフェイスでイネーブルになっていない場合、出力は次のようになります。

Interface: Ethernet0; ISIS tag null enabled
ISIS is UP on interface
AUTOCONFIG Information :
LDP enabled: NO
SYNC Information :
Required: NO

 

IS-IS との MPLS LDP-IGP 同期が設定されていても、イネーブルになっていない場合、出力は次のようになります。

Interface: Ethernet0/0; ISIS tag ISIS-1 enabled
ISIS is UP on interface
AUTOCONFIG Information :
LDP enabled: YES
SYNC Information :
Required: YES
Achieved: NO
IGP Delay: YES
Holddown time: Infinite
State: Holding down until SYNC

 

IS-IS プロセスは、同期がイネーブルになるまでインターフェイスの隣接をダウンしたままにします。


 

トラブルシューティングのヒント

MPLS LDP-IGP 同期関連のイベントを表示するには debug mpls ldp igp sync コマンドを使用します。

MPLS LDP-IGP 同期の設定例

次の項は、OSPF および IS-IS プロセスとの MPLS LDP-IGP 同期機能の例を示しています。

「OSPF での MPLS LDP-IGP 同期:例」

「IS-IS での MPLS LDP-IGP 同期:例」

OSPF での MPLS LDP-IGP 同期:例

次のコンフィギュレーション コマンドによって、OSPF プロセス 1 の LDP がイネーブルになります。 mpls ldp sync コマンドと OSPF network コマンドによって、それぞれインターフェイス POS0/0、POS0/1、および POS1/1 で LDP がイネーブルになります。インターフェイス POS1/0 で no mpls ldp igp sync コマンドを使用すると、インターフェイス POS1/0 で OSPF がイネーブルの場合でも、このインターフェイスで LDP がイネーブルにならなくなります。

Router# configure terminal
Router(config)# interface POS0/0
Router(config-if)# ip address 10.0.0.1
Router(config-if)# mpls ip
!
Router(config)# interface POS0/1
Router(config-if)# ip address 10.0.1.1
Router(config-if)# mpls ip
!
Router(config)# interface POS1/1
Router(config-if)# ip address 10.1.1.1
Router(config-if)# mpls ip
!
Router(config)# interface POS1/0
Router(config-if)# ip address 10.1.0.1
Router(config-if)# mpls ip
!
Router(config)# router ospf 1
Router(config-router)# network 10.0.0.0 0.0.255.255 area 3
Router(config-router)# network 10.1.0.0 0.0.255.255 area 3
Router(config-router)# mpls ldp sync
Router(config-router)# exit
Router(config)# interface POS1/0
Router(config-if)# no mpls ldp igp sync

IS-IS での MPLS LDP-IGP 同期:例


) Cisco IOS Release 12.2(33)SRB および 12.2(33)SB では、MPLS LDP-IGP 同期機能で IS-IS はサポートされません。OSPF だけがサポートされます。


次のコマンドは、IS-IS プロセスを実行しているインターフェイス POS0/2 および POS0/3 で MPLS LDP-IGP 同期を設定します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface POS0/2
Router(config-if)# ip router isis
Router(config-if)# exit
Router(config)# router isis
Router(config-router)# mpls ldp sync
!
!
Router(config)# interface POS0/3
Router(config-if)# ip router isis
Router(config-if)# exit
Router(config)# router isis
Router(config-router)# mpls ldp sync

その他の関連資料

ここでは、MPLS LDP-IGP 同期機能に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS LDP

『MPLS Label Distribution Protocol』

MPLS LDP 自動設定

『MPLS LDP Autoconfiguration』

MPLS LDP セッション保護

『MPLS LDP Session Protection』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS LDP MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットに対する MIB を特定してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3037

『LDP Applicability』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS LDP-IGP 同期の機能履歴

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS LDP-IGP 同期の機能情報

機能名
リリース
機能情報

MPLS LDP-IGP 同期

12.0(30)S
12.0(32)SY
12.2(33)SB
12.2(33)SRB
15.0(1)M
12.3(14)T
Cisco IOS XE
Release 2.1

MPLS LDP-IGP 同期機能では、IGP パスがスイッチングに使用される前に LDP が完全に確立されていることが保証されます。

この機能は、12.0(30)S で導入されました。

Intermediate System-to-System(IS-IS)プロセスを実行しているインターフェイスでの同期のイネーブルのサポートは、12.0(32)SY で追加されました。

この機能は、12.2(33)SB で統合されました。IS-IS の MPLS LDP-IGP 同期は、このリリースではサポートされていません。

この機能は、12.2(33)SRB で統合されました。IS-IS の MPLS LDP-IGP 同期は、このリリースではサポートされていません。

この機能は、12.3(14)T で統合されました。IS-IS の MPLS LDP-IGP 同期は、このリリースではサポートされていません。

IS-IS プロセスを実行しているインターフェイスでの同期のイネーブルのサポートは、15.0(1)M で追加されました。

この機能は、XE 2.1 で Cisco ASR 1000 シリーズ ルータに実装されました。

次のコマンドが変更されました。 debug mpls ldp igp sync mpls ldp igp sync mpls ldp igp sync holddown mpls ldp sync show ip ospf mpls ldp interface show isis mpls ldp 、および show mpls ldp igp sync