Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
Multilink Frame Relay over L2TPv3/AToM
Multilink Frame Relay over L2TPv3/AToM
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

Multilink Frame Relay over L2TPv3/AToM

この章の構成

Multilink Frame Relay over L2TPv3/AToM の設定の前提条件

Multilink Frame Relay over L2TPv3/AToM の設定の制約事項

Multilink Frame Relay over L2TPv3/AToM の設定に関する情報

Multilink Frame Relay over L2TPv3/AToM

マルチリンク フレーム リレーのインターネットワーキング サポート

Multilink Frame Relay over L2TPv3/AToM のサービス品質サポート

Multilink Frame Relay over L2TPv3/AToM の設定方法

マルチリンク フレーム リレー バンドル インターフェイスの設定

マルチリンク フレーム リレー バンドル リンク インターフェイスの設定

ルータ間のフレーム リレー PVC の接続

Multilink Frame Relay over L2TPv3/AToM の確認

Multilink Frame Relay over L2TPv3/AToM の設定例

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Frame Relay over L2TPv3:例

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet VLAN Interworking over L2TPv3:例

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet Interworking over MPLS:例

MQC カラー対応ポリシング:例

DE ビット マッチング:例

DLCI ベース キューイング:例

廃棄クラスベース WRED:例

集約シェーピング:例

VC シェーピング:例

FECN/BECN マーキング:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

Multilink Frame Relay over L2TPv3/AToM の機能情報

Multilink Frame Relay over L2TPv3/AToM

この機能は、Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)および Any Transport over MPLS(AToM)上のマルチリンク フレーム リレー スイッチングをイネーブルにします。この機能は、like-to-like インターフェイスおよび異種インターフェイス(L2VPN インターワーキング)で動作します。

マルチリンク フレーム リレーは、User-to-Network Interface/Network-to-Network Interface(UNI/NNI; ユーザ ネットワーク インターフェイス/ネットワーク間インターフェイス)の 2 つのデバイス間の 1 つ以上の物理インターフェイスを 1 つのフレーム リレー データ リンクとして論理的にグループ化したものです。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。 この章に記載されている特定の機能に関する説明へのリンク、および各機能がサポートされているリリースのリストについては、「Multilink Frame Relay over L2TPv3/AToM の機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

Multilink Frame Relay over L2TPv3/AToM の設定の前提条件

Multilink Frame Relay over L2TPv3/AToM を設定する前に、Layer 2 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)とマルチリンク フレーム リレーの設定方法を理解する必要があります。これらの機能の設定方法と使用方法について説明する章へのポインタについては、「その他の関連資料」を参照してください。

Multilink Frame Relay over L2TPv3/AToM の設定の制約事項

各 Data-Link Connection Identifier(DLCI; データリンク接続識別子)が自身を独自の擬似回線にマップする DLCI-to-DLCI スイッチングだけがサポートされます。Local Management Interface(LMI; ローカル管理インターフェイス)など、ポートの内容全体が単一の擬似回線で搬送されるポート間モード(HDLC モードとも呼ぶ)はサポートされません。

次の機能はサポートされません。

UNI/NNI またはエンドツーエンド フラグメンテーション

ノンストップ フォワーディング/ステートフル スイッチオーバー

4 バイトの DLCI

Cisco 7500 シリーズ ルータでは、すべてのバンドル リンクが Versatile Interface Processor(VIP)の同じ Port Adapter(PA; ポート アダプタ)に存在する必要があります。複数の PA に広がるリンクはサポートされません。

Cisco 7500 シリーズ ルータでは、VIP6-80、VIP4-80、VIP4-50、VIP2-50、CH-STM1、CT3/CE3、CT1/CE1、PA-4T+、PA-8T のポート アダプタがサポートされます。

Cisco 12000 シリーズ ルータでは、マルチリンク フレーム リレーは、Cisco 4 ポート チャネライズド T3(DSO)共有ポート アダプタ、Cisco 8 ポート チャネライズド T1/E1 共有ポート アダプタ、および Cisco 1 ポート チャネライズド OC-3/STM-1 共有ポート アダプタというプラグイン可能なモジュールでだけサポートされます。

Multilink Frame Relay over L2TPv3/AToM の設定に関する情報

Multilink Frame Relay over L2TPv3/AToM を設定するには、次の概念を理解する必要があります。

「Multilink Frame Relay over L2TPv3/AToM」

「マルチリンク フレーム リレーのインターネットワーキング サポート」

「Multilink Frame Relay over L2TPv3/AToM のサービス品質サポート」

Multilink Frame Relay over L2TPv3/AToM

Multilink Frame Relay over L2TPv3/AToM では、次の機能がサポートされます。

Permanent Virtual Circuit(PVC; 相手先固定接続)ステータス シグナリング

LMI タイプ cisco、q933a、および ANSI

シーケンス

フレーム リレー ポリシング(非分散)

L2TPv3 の Type of Service(ToS; タイプ オブ サービス)マーキング

マルチリンク フレーム リレーのインターネットワーキング サポート

マルチリンク フレーム リレー インターフェイスのインターワーキング サポートでは、次の機能がサポートされます。

Frame Relay to Ethernet/VLAN(イーサネットおよび IP インターワーキング)

Frame Relay to PPP および ATM(IP インターワーキング)

Customer-Edge(CE; カスタマーエッジ)ルータ上の Cisco および Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)カプセル化

シーケンス

CE ルータに PVC ステータスの変化を通知するための LMI インターワーキング

Multilink Frame Relay over L2TPv3/AToM のサービス品質サポート


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


フレーム リレーに対してサポートされている L2VPN Quality of Service(QoS; サービス品質)機能は、Multilink Frame Relay over L2TPv3/AToM 機能でもサポートされます。マップクラス メカニズムを使用してマルチリンク フレーム リレー インターフェイス、またはインターフェイス上の個々の DLCI に入力サービス ポリシーを添付して、トラフィックを規制またはマーキングできます。Multilink Frame Relay(MFR; マルチリンク フレーム リレー)インターフェイスに出力ポリシーを添付して、 match fr-dlci コマンドを使用した DLCI ごとのキューイングなどのクラスベースのキューイングを実行できます。

Multilink Frame Relay over L2TPv3/AToM 機能では次の入力 QoS 機能がサポートされます。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)EXP またはトンネル Differentiated Services Code Point(DSCP; DiffServ コード ポイント)を設定するための Discard Eligibility(DE; 廃棄適性)ビットでのインターフェイス入力ポリシー マッチング

DE ビットを入力カラーとして使用し、カラーに基づいて MPLS EXP ビットまたはトンネル DSCP ビットを設定する、カラー対応の 2 レート 3 カラー ポリサーで設定された Virtual Circuit(VC; 仮想回線)入力ポリシー


) VC レベルとインターフェイス レベルの入力ポリシーを同じインターフェイスで同時には使用できません。


Multilink Frame Relay over L2TPv3/AToM 機能では次の出力 QoS 機能がサポートされます。

テール ドロップまたは廃棄クラスベースの Weighted Random Early Detection(WRED; 重み付けランダム早期検出)を使用した出力キューイング。あとでコア インターフェイス入力ポリシーを使用して、MPLS EXP またはトンネル DSCP に基づいて廃棄クラスを設定できます。

(MPLS EXP またはトンネル DSCP で選択された)QoS グループに対するインターフェイス出力ポリシー マッチング。

キューイング ポリシーを使用したインターフェイス集約シェーピング ポリシー。

テール ドロップまたは廃棄クラスベース WRED を使用した VC 出力シェーピング ポリシー。

Forward Explicit Congestion Notification(FECN; 順方向明示的輻輳通知)/Backward Explicit Congestion Notification(BECN; 逆方向明示的輻輳通知)マーキング。


) VC レベルとインターフェイス レベルの出力ポリシーを同じインターフェイスで同時には使用できません。



) 出力キューイングとシェーピング ポリシーは、Cisco 7200 シリーズ ルータ上のマルチリンク フレーム リレーではサポートされません。


Multilink Frame Relay over L2TPv3/AToM の設定方法

ここでは、次の各手順について説明します。

「マルチリンク フレーム リレー バンドル インターフェイスの設定」 (必須)

「マルチリンク フレーム リレー バンドル リンク インターフェイスの設定」 (必須)

「ルータ間のフレーム リレー PVC の接続」 (必須)

「Multilink Frame Relay over L2TPv3/AToM の確認」 (任意)

マルチリンク フレーム リレー バンドル インターフェイスの設定

バンドル インターフェイスは、1 つの仮想パイプへの単一のインターフェイスの下で複数のメンバ リンクの帯域幅を集約するように設定します。マルチリンク フレーム リレーのバンドル インターフェイスを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface mfr number

4. frame-relay multilink bid name

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface mfr number

 

 

Router(config)# interface mfr 1

マルチリンク フレーム リレー バンドル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

frame-relay multilink bid name

 

 

Router(config-if)# frame-relay multilink bid int1

 

(任意)バンドル識別名をマルチリンク フレーム リレー バンドルに割り当てます。

コマンドを使用することです。

マルチリンク フレーム リレー バンドル リンク インターフェイスの設定

マルチリンク フレーム リレー バンドル リンク インターフェイスを設定すると、複数の低速シリアル リンクの帯域幅を 1 つの大きなパイプに結合し、新しいハードウェアのアップグレードや購入の必要性を回避できます。マルチリンク フレーム リレーのバンドル リンク インターフェイスを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface serial number

4. encapsulation frame-relay mfr number [ name ]

5. frame-relay multilink lid name

6. frame-relay multilink hello seconds

7. frame-relay multilink ack seconds

8. frame-relay multilink retry number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface serial number

 

Router(config)# interface serial 1/1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

encapsulation frame-relay mfr number [ name ]

 

Router(config-if)# encapsulation frame-relay mfr 1

マルチリンク フレーム リレー バンドル リンクを作成し、リンクをバンドルに関連付けます。

ヒント パケットの到着順序から生じる遅延を最小化するために、同じ回線速度の物理リンクを 1 つのバンドルにバンドルすることを推奨します。

ステップ 5

frame-relay multilink lid name

 

Router(config-if)# frame-relay multilink lid four

(任意)バンドル リンク識別名をマルチリンク フレーム リレー バンドル リンクに割り当てます。

コマンドを使用することです。

ステップ 6

frame-relay multilink hello seconds

 

Router(config-if)# frame-relay multilink hello 20

(任意)バンドル リンクが hello メッセージを送信する間隔を設定します。デフォルト値は 10 秒です。

ステップ 7

frame-relay multilink ack seconds

 

Router(config-if)# frame-relay multilink ack 10

(任意)バンドル リンクが hello メッセージを再送信する前に hello メッセージの確認応答を待機する秒数を設定します。デフォルト値は 4 秒です。

ステップ 8

frame-relay multilink retry number

 

Router(config-if)# frame-relay multilink retry 5

(任意)確認応答を待機している間、バンドル リンクが hello メッセージを再送信する最大回数を設定します。デフォルト値は 2 回です。

ルータ間のフレーム リレー PVC の接続

ルータ間でフレーム リレー PVC を接続することにより、レベル 2 VPN バックボーン上にフレーム リレーを統合し、アップグレードを行わずに既存のフレーム リレー ネットワークを使用できるようにすることができます。ルータ間でフレーム リレー PVC を接続するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. connect connection-name mfr number dlci l2transport

4. xconnect peer-router-id vcid encapsulation mpls

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

connect connection-name mfr number dlci l2transport

 

Router(config)# connect fr1 mfr 1 100 l2transport

フレーム リレー PVC 間に接続を定義します。

l2transport キーワードを使用して、PVC がローカルにスイッチングされずに、バックボーン ネットワーク上でトンネリングされるように指定します。

connection-name 引数は、指定するテキスト文字列です。

dlci 引数は、接続される PVC の DLCI 番号です。

接続コンフィギュレーション サブモードを開始します。

ステップ 4

xconnect peer-router-id vcid encapsulation mpls

 

 

 

Router(config-fr-pw-switching)# xconnect 10.0.0.1 123 encapsulation mpls

レイヤ 2 パケットを転送するための VC を作成します。DLCI-to-DLCI 接続タイプでは、Frame Relay over MPLS は xconnect コマンドを接続コンフィギュレーション サブモードで使用します。

Multilink Frame Relay over L2TPv3/AToM の確認

マルチリンク フレーム リレーの設定を確認するには、次の手順を実行します。トンネルとセッションは確立済み(est)状態にある必要があります。

手順の概要

1. show l2tunnel

2. show mpls forwarding

手順の詳細


ステップ 1 show l2tunnel

両方の PE ルータで、次のコマンドを使用して、Multilink Frame Relay over L2TPv3 の設定を確認します。

PE1# show l2tunnel
 
Tunnel and Session Information Total tunnels 1 sessions 1
 
LocID RemID Remote Name State Remote Address Port Sessions L2TPclass
35788 41451 FRWI1 est 10.9.9.9 0 1 l2tp_default_cl
 
LocID RemID TunID Username, Intf/ State
Vcid, Circuit
8161 54072 35788 6, MF1:206 est
 
PE2# show l2tunnel
 
Tunnel and Session Information Total tunnels 1 sessions 1
 
LocID RemID Remote Name State Remote Address Port Sessions L2TPclass
41451 35788 FRWI3 est 10.8.8.8 0 1
 
LocID RemID TunID Username, Intf/ State
Vcid, Circuit
54072 8161 41451 6, Fa0/1.6:6 est
 

ステップ 2 show mpls forwarding

両方の PE ルータで、次のコマンドを使用して、Multilink Frame Relay over MPLS の設定を確認します。

PE1# show mpls forwarding
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Pop tag 10.0.0.0/24 0 PO4/1/0 point2point
17 Untagged l2ckt(5) 0 MF1 point2point
18 Untagged l2ckt(6) 0 MF1 point2point
19 17 10.9.9.9/32 0 PO4/1/0 point2point
 
PE2# show mpls forwarding
 
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 16 10.8.8.8/32 0 PO2/0 point2point
17 Pop tag 10.13.0.0/24 0 PO2/0 point2point
18 Untagged l2ckt(5) 2244 MF2 point2point
19 Untagged l2ckt(6) 510 MF2 point2point
 


 

Multilink Frame Relay over L2TPv3/AToM の設定例

ここでは、次の設定例を示します。

「マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Frame Relay over L2TPv3:例」

「マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet VLAN Interworking over L2TPv3:例」

「マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet Interworking over MPLS:例」

「MQC カラー対応ポリシング:例」

「DE ビット マッチング:例」

「DLCI ベース キューイング:例」

「廃棄クラスベース WRED:例」

「集約シェーピング:例」

「VC シェーピング:例」

「FECN/BECN マーキング:例」

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Frame Relay over L2TPv3:例

次の例では、PE ルータ間でフレーム リレー データを転送するようにマルチリンク フレーム リレー インターフェイスを設定します。

 

PE1
PE2
configure terminal
ip cef distributed
frame-relay switching
!
interface loopback 0
ip address 10.8.8.8 255.255.255.255
no shutdown
!
pseudowire-class fr-xconnect
encapsulation l2tp
protocol l2tpv3
ip local interface loopback0
!
controller T3 1/1/1
t1 1 framing esf
t1 1 clock source internal
t1 1 channel-group 1 timeslots 1-24 speed 64
!
t1 2 framing esf
t1 2 clock source inter
t1 2 channel-group 1 timeslots 1-24 speed 64
!
interface mfr 1
encapsulation frame-relay
logging event dlci-status-change
frame-relay intf-type nni
no shutdown
!
interface Serial1/1/1/1:1
encapsulation frame-relay mfr1
interface Serial1/1/1/2:1
encapsulation frame-relay mfr1
!
interface POS4/1/0
clock source internal
ip address 10.13.0.0 255.255.255.0
no shutdown
no fair-queue
!
connect fr-fr mfr1 206 l2
xconnect 10.9.9.9 6 pw-class fr-xconnect
!
router ospf 10
network 10.13.0.0 0.0.0.0 area 0
network 10.8.8.8 0.0.0.0 area 0
end
configure terminal
ip routing
ip cef
frame-relay switching
!
interface loopback 0
ip address 10.9.9.9 255.255.255.255
no shutdown
!
interface p2/0
clock source internal
ip address 10.14.0.2 255.255.255.0
no shutdown
no fair-queue
!
controller T3 3/1
t1 1 framing esf
t1 1 clock source internal
t1 1 channel-group 1 timeslots 1-24 speed 64
!
t1 2 framing esf
t1 2 clock source internal
t1 2 channel-group 1 timeslots 1-24 speed 64
!
interface mfr2
encapsulation frame-relay
logging event dlci-status-change
frame-relay intf-type dce
no shutdown
!
interface serial3/1/1:1
encapsulation frame-relay mfr2
!
interface s3/1/2:1
encapsulation frame-relay mfr2
!
pseudowire-class fr-xconnect
encapsulation l2tpv3
protocol l2tpv3
ip local interface loopback0
!
connect fr-fr mfr2 306 l2transport
xconnect 10.8.8.8 6 pw-class fr-xconnect
!
router ospf 10
network 10.14.0.2 0.0.0.0 area 0
network 10.9.9.9 0.0.0.0 area 0
end

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet VLAN Interworking over L2TPv3:例

次の例では、PE ルータ間で Frame Relay-to-Ethernet VLAN インターワーキングを実行するようにマルチリンク フレーム リレー インターフェイスを設定します。この例では、ルーテッド インターワーキングとも呼ばれる IP インターワーキングを使用します。

PE1
PE2
configure terminal
ip cef distributed
frame-relay switching
!
!
interface loopback 0
ip address 10.8.8.8 255.255.255.255
no shutdown
!
pseudowire-class ip
encapsulation l2tp
interworking ip
ip local interface loopback0
!
interface mfr 1
encapsulation frame-relay
logging event dlci-status-change
no shutdown
frame-relay intf-type nni
!
interface Serial1/1/1/1:1
encapsulation frame-relay mfr1
interface Serial1/1/1/2:1
encapsulation frame-relay mfr1
!
interface POS4/1/0
clock source internal
ip address 13.0.0.2 255.255.255.0
no shutdown
no fair-queue
!
connect fr-vlan mfr1 206 l2
xconnect 9.9.9.913.0.0.2 6 pw-class ip
!
router ospf 10
network 10.13.0.2 0.0.0.0 area 0
network 10.8.8.8 0.0.0.0 area 0
end
configure terminal
ip routing
ip cef
frame-relay switching
!
interface loopback 0
ip address 10.9.9.9 255.255.255.255
no shutdown
!
pseudowire-class ip
encapsulation l2tp
interworking ip
ip local interface loopback0
!
interface p2/0
clock source internal
ip address 10.14.0.2 255.255.255.0
no shutdown
no fair-queue
!
interface FastEthernet0/1
no shutdown
!
interface FastEthernet0/1.6
encapsulation dot1Q 6
xconnect 10.8.8.8 6 pw-class ip
no shutdown
!
router ospf 10
network 10.14.0.2 0.0.0.0 area 0
network 10.9.9.9 0.0.0.0 area 0
!
end

マルチリンク フレーム リレー インターフェイス上の Frame Relay-to-Ethernet Interworking over MPLS:例

次の例では、PE ルータ間で Frame Relay-to-Ethernet インターワーキングを実行するようにマルチリンク フレーム リレー インターフェイスを設定します。この例では、ルーテッド インターワーキングとも呼ばれる IP インターワーキングを使用します。

PE1
PE2
configure terminal
ip cef distributed
frame-relay switching
!
!
interface loopback 0
ip address 10.8.8.8 255.255.255.255
no shutdown
!
interface mfr 1
encapsulation frame-relay
logging event dlci-status-change
no shutdown
frame-relay intf-type nni
!
interface Serial1/1/1/1:1
encapsulation frame-relay mfr1
interface Serial1/1/1/2:1
encapsulation frame-relay mfr2
!
interface POS4/1/0
clock source internal
ip address 10.13.0.2 255.255.255.0
no shutdown
mpls ip
!
router ospf 10
network 10.13.0.2 0.0.0.0 area 0
network 10.8.8.8 0.0.0.0 area 0
!
mpls label protocol ldp
mpls ldp router-id loopback0
mpls ip
!
pseudowire-class atom
encapsulation mpls
interworking ip
!
connect fr-eth mfr1 207 l2
xconnect 10.9.9.9 7 pw-class atom
!
end
configure terminal
ip routing
ip cef
frame-relay switching
!
interface loopback 0
ip address 10.9.9.9 255.255.255.255
no shutdown
!
interface POS2/0
clock source internal
ip address 10.14.0.2 255.255.255.0
no shutdown
no fair-queue
mpls ip
!
router ospf 10
network 10.14.0.2 0.0.0.0 area 0
network 10.9.9.9 0.0.0.0 area 0
!
mpls label protocol ldp
mpls ldp router-id loopback0
mpls ip
!
pseudowire-class atom
encapsulation mpls
interworking ip
!
interface FastEthernet0/1
xconnect 10.8.8.8 7 pw-class atom
no shutdown
!
end

MQC カラー対応ポリシング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例では、DE ビットを入力カラーとして使用し、カラーに基づいてトンネル Differentiated Services Code Point(DSCP; DiffServ コード ポイント)を設定して、カラー対応の 2 レート 3 カラー ポリシング方式で VC 入力ポリシーを設定します。ピーク レートの超過パケットは廃棄されます。

class-map not-fr-de
match not fr-de
!
policy-map police
class class-default
police cir 64000 pir 256000
conform-color not-fr-de
conform-action set-dscp-tunnel-transmit af31
exceed-action set-dscp-tunnel-transmit af32
violate-action drop
!
interface MFR1
frame-relay interface-dlci 206 switched
class police
!
connect fr-vlan mfr1 206 l2
xconnect 10.9.9.9 6 pw-class ip
!
map-class frame-relay police
service-policy input police

DE ビット マッチング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、トンネル DSCP を設定するための DE ビットでのインターフェイス入力ポリシー マッチングの設定を示しています。

class-map de
match fr-de
!
policy-map de
class de
set ip dscp tunnel af32
class class-default
set ip dscp tunnel af31
!
interface MFR1
service-policy input de

DLCI ベース キューイング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、DLCI に基づく QoS グループでのインターフェイス出力ポリシー マッチングの設定を示しています。

class-map dlci100
match fr-dlci 100
class-map dlci200
match fr-dlci 200
!
policy-map dlci
class dlci100
bandwidth percent 10
class dlci200
bandwidth percent 20
!
interface MFR1
service-policy output dlci

廃棄クラスベース WRED:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、トンネル DSCP に基づく QoS グループでのインターフェイス出力ポリシー マッチングの設定を示しています。

class-map conform
match ip dscp af31
match mpls experimental 4
class-map exceed
match ip dscp af32
match mpls experimental 3
class-map cos1
match qos-group 1
!
policy-map core
class conform
set qos-group 1
set discard-class 1
class exceed
set qos-group 1
set discard-class 2
!
policy-map wred
class cos1
bandwidth percent 40
random-detect discard-class-based
random-detect discard-class 1 20 30 10
random-detect discard-class 2 1 9 10
!
interface POS1/0
service-policy input core
!
interface MFR1
service-policy output wred

集約シェーピング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、DLCI ベース キューイング ポリシーを使用したインターフェイス集約シェーピング ポリシーの設定を示しています。

class-map dlci205
match fr-dlci 205
class-map dlci206
match fr-dlci 206
!
policy-map dlci
class dlci205
bandwidth 128
class dlci206
bandwidth 256
!
policy-map shape
class class-default
shape average 512000 2048 2048
service-policy dlci
!
interface MFR1
service-policy output shape

VC シェーピング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、廃棄クラス ベース WRED を使用した VC 出力シェーピング ポリシーの設定を示しています。

class-map conform
match mpls experimental 4
class-map exceed
match mpls experimental 3
class-map cos1
match qos-group 1
!
policy-map core
class conform
set qos-group 1
set discard-class 1
class exceed
set qos-group 1
set discard-class 2
!
policy-map vc-wred
class class-default
bandwidth percent 40
random-detect discard-class-based
random-detect discard-class 1 20 30 10
random-detect discard-class 2 1 9 10
!
policy-map shape
class class-default
shape average 512000 2048 2048
service-policy vc-wred
!
interface POS4/1/0
service-policy input core
!
interface MFR1
frame-relay interface-dlci 206 switched
class shape
!
map-class frame-relay shape
service-policy output shape

FECN/BECN マーキング:例


) サービス品質機能は、Cisco IOS Release 12.4(11)T ではサポートされません。


次の例は、BECN および FECN ビットを設定する出力ポリシーの設定を示しています。

policy-map dlci
class dlci100
bandwidth percent 10
class dlci200
bandwidth percent 20
set fr-fecn-becn 1
interface MFR1
service-policy output dlci
frame-relay congestion-management
threshold ecn 20

その他の関連資料

ここでは、Multilink Frame Relay over L2TPv3/AToM機能に関する関連資料について説明します。

関連資料

関連項目
参照先

マルチリンク フレーム リレー

Cisco 7500 シリーズ ルータの場合:

『Distributed Multilink Frame Relay (FRF.16)』

Cisco 7200 シリーズ ルータの場合:

『Multilink Frame Relay (FRF.16)』

L2VPN インターワーキング

『L2VPN Interworking』

レイヤ 2 トンネリング プロトコル、バージョン 3

『L2TPV3』

レイヤ 2 ローカル スイッチング

『Layer 2 Local Switching』

規格

規格
タイトル

draft-martini-l2circuit-trans-mpls-08.txt

『Transport of Layer 2 Frames Over MPLS』

draft-martini-l2circuit-encap-mpls-04.txt

『Encapsulation Methods for Transport of Layer 2 Frames Over MPLS』

draft-ietf-l2tpext-l2tp-base-03.txt

『Layer Two Tunneling Protocol (Version 3)』

MIB

 

MIB
MIB リンク

『Cisco Frame Relay MIB』(CISCO-FRAME-RELAY-MIB.my)

『Interfaces MIB』(IF-MIB.my)

『MPLS LDP MIB』(MPLS-LDP-MIB.my)

RFC

 

RFC
タイトル

RFC 2661

『Layer Two Tunneling Protocol』

シスコのテクニカル サポート

 

説明
リンク

シスコのテクニカル サポートおよびドキュメンテーション Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、この章に記載されている機能または機能群において、新たに導入または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS Multiprotocol Label Switching Command Reference 』( http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_book.html )を参照してください。Cisco IOS の全コマンドを参照する場合は、Command Lookup Tool( http://tools.cisco.com/Support/CLILookup )を使用するか、または『 Cisco IOS Master Command List 』にアクセスしてください。

xconnect

Multilink Frame Relay over L2TPv3/AToM の機能情報

この機能は、Layer 2 Tunnel Protocol Version 3(L2TPv3; レイヤ 2 トンネル プロトコル バージョン 3)および Any Transport over MPLS(AToM)上のマルチリンク フレーム リレー スイッチングをイネーブルにします。この機能は、like-to-like インターフェイスおよび異種インターフェイス(L2VPN インターワーキング)で動作します。

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 Multilink Frame Relay over L2TPv3/AToM の機能情報

機能名
リリース
機能情報

Multilink Frame Relay over L2TPv3/AToM

12.0(28)S
12.2(25)S
12.0(32)S
12.4(11)T

この機能は、Cisco 7200 および 7500 シリーズ ルータ用の Cisco IOS Release 12.0(28)S で導入されました。

この機能は、Cisco IOS Release 12.2(25)S に統合されました。

Cisco IOS Release 12.0(32)S では、この機能により、Cisco 12000 シリーズ ルータの Cisco 4 ポート チャネライズド T3(DSO)共有ポート アダプタ、Cisco 8 ポート チャネライズド T1/E1 共有ポート アダプタ、および Cisco 1 ポート チャネライズド OC-3/ STM-1 共有ポート アダプタというプラグイン可能なモジュールのサポートが追加されました。

この機能は、Cisco IOS Release 12.4(11)T に統合されました。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。