Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS VPN の同じ IP アドレスを持つ宛先へ のダイヤル
MPLS VPN の同じ IP アドレスを持つ宛先へのダイヤル
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS VPN の同じ IP アドレスを持つ宛先へのダイヤル

この章の構成

同じ IP アドレスを持つ宛先へのダイヤルの前提条件

同じ IP アドレスを持つ宛先へのダイヤルの制約事項

同じ IP アドレスを持つ宛先へのダイヤルに関する情報

同じ IP アドレスを持つ宛先へのダイヤルの概要

この機能の利点

同じ IP アドレスを持つ宛先へのダイヤルをイネーブルにする方法

ダイヤル ストリングへの VRF とネクストホップ アドレスのマッピング

前提条件

設定の確認

トラブルシューティングのヒント

同じ IP アドレスを持つ宛先へのダイヤルの設定例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

同じ IP アドレスを持つ宛先へのダイヤルの機能情報

MPLS VPN の同じ IP アドレスを持つ宛先へのダイヤル

Release 12.2(8)T よりも前の Cisco IOS のダイヤラ ソフトウェアでは、同じ IP アドレスの 2 つの異なる宛先にダイヤルできませんでした。具体的には、Network Access Server(NAS; ネットワーク アクセス サーバ)で重複するアドレスを持つクライアントへのダイヤルがサポートされるネットワークでは、ダイヤルアウトに失敗します。この章では、同じ IP アドレスの複数の宛先にダイヤルする方法について説明します。

変更履歴

このマニュアルの初版の発行は 2005 年 5 月 2 日で、最終更新日は 2005 年 5 月 2 日です。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、一部サポートされていない機能があります。機能のサポートと設定の詳細については、「同じ IP アドレスを持つ宛先へのダイヤルの機能情報」を参照してください。

同じ IP アドレスを持つ宛先へのダイヤルの前提条件

この機能を設定する前に、次のネットワーク機能の設定方法を理解する必要があります。

2 方向 AAA 認証の仮想プロファイル

MPLS VPN

これらの機能の設定については、「その他の関連資料」に記載されているマニュアルを参照してください。

同じ IP アドレスを持つ宛先へのダイヤル機能は、次の Cisco ルータおよびアクセス サーバ プラットフォームでサポートされています。

Cisco 1600 シリーズ

Cisco 1720

Cisco 1721

Cisco 1750

Cisco 1751

Cisco 3600 シリーズ

Cisco 3631

Cisco 3725

Cisco 3745

Cisco 7200 シリーズ

Cisco 7500 シリーズ

Cisco 802

Cisco 820

Cisco 828

Cisco uBR7200

同じ IP アドレスを持つ宛先へのダイヤルの制約事項

MPLS または MPLS VPN 環境でスタティック ルートを設定する場合は、 ip route コマンドおよび ip route vrf コマンドの一部のバリエーションがサポートされません。これらのコマンド バリエーションは、Tag Forwarding Information Base(TFIB; タグ転送情報ベース)をサポートする Cisco IOS リリース、特に Cisco IOS Release 12.xT、12.xM、および 12.0S ではサポートされていません。プレフィクスが通過する再帰ルートがいったん失われて再び現れる場合、TFIB はプレフィクスを解決できません。ただし、MPLS Forwarding Infrastructure(MFI)をサポートする Cisco IOS リリース、特に Cisco IOS Release 12.2(25)S 以降では、これらのコマンド バリエーションがサポートされています。スタティック ルートを設定するときは、次の注意事項に従ってください。

MPLS 環境でサポートされるスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface next-hop-address

MPLS 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route
destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS 環境でサポートされないスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS 環境でスタティック ルートを設定し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS 環境でスタティック ルートを設定し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop1
ip route
destination-prefix mask next-hop2

スタティック ルートを指定する場合は、interface an next-hop 引数を使用します。

MPLS VPN 環境でサポートされるスタティック ルート

次の ip route vrf コマンドは、MPLS VPN 環境でスタティック ルートを設定し、ネクストホップとインターフェイスが同じ VRF に存在する場合はサポートされません。

ip route vrf vrf-name destination-prefix mask next-hop-address

ip route vrf vrf-name destination-prefix mask interface next-hop-address

ip route vrf vrf-name destination-prefix mask interface1 next-hop1
ip route vrf vrf-name destination-prefix mask interface2 next-hop2

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがグローバル ルーティング テーブルの MPLS クラウドのグローバル テーブルに存在する場合は、次の ip route vrf コマンドがサポートされます。たとえば、ネクストホップがインターネット ゲートウェイを指している場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask next-hop-address global

ip route vrf vrf-name destination-prefix mask interface next-hop-address
(このコマンドは、ネクストホップおよびインターフェイスがコアにある場合にサポートされます)

MPLS VPN 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route
destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS VPN 環境でサポートされないスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop-address global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop1 global
ip route vrf destination-prefix mask next-hop2 global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップおよびインターフェイスが同じ VRF にある場合は、次の ip route vrf コマンドがサポートされません。

ip route vrf vrf-name destination-prefix mask next-hop1
ip route vrf
vrf-name destination-prefix mask next-hop2

ネクストホップが CE ルータ上のグローバル テーブルに存在する MPLS VPN 環境でサポートされるスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが CE 側のグローバル テーブルにある場合は、次の ip route vrf コマンドがサポートされます。たとえば、EBGP マルチホップの場合と同様に、宛先プレフィクスが CE ルータのループバック アドレスである場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask interface next-hop-address

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが CE 側のグローバル テーブルに存在し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 nexthop1
ip route
destination-prefix mask interface2 nexthop2

同じ IP アドレスを持つ宛先へのダイヤルに関する情報

この機能を設定する前に、次の概念を理解する必要があります。

「同じ IP アドレスを持つ宛先へのダイヤルの概要」

「この機能の利点」

同じ IP アドレスを持つ宛先へのダイヤルの概要

Cisco IOS ダイヤラ ソフトウェアは、VRF に格納されている情報を使用して、同じ IP アドレスの 2 つの宛先を区別できます。この機能は、既存の 2 つの Cisco IOS コマンド dialer map ip route を、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)情報を含めるように拡張することによってダイヤラ ソフトウェアに提供されています。

以前の Cisco IOS リリースでは、ダイヤラ ソフトウェアは、 dialer map コマンドで設定された宛先 IP アドレスに基づいて、ダイヤルアウトの電話番号を取得していました。現在では、拡張された dialer map コマンドで VRF の名前を指定するため、ダイヤル先の電話番号は VRF 名と宛先 IP アドレスに基づいています。VRF はパケットの着信インターフェイスに基づいて識別され、 dialer map コマンドで定義された宛先 IP アドレスでダイヤル先の電話番号を特定するために使用されます。

ip route コンフィギュレーション コマンドにも VRF 情報が含まれます。特定の VRF に属している着信インターフェイスにパケットが到達すると、その VRF に対応する ip route コマンドだけが宛先インターフェイスの特定に使用されます。

この機能の利点

この機能を使用すると、ダイヤラ ソフトウェアは MPLS ベースの VPN でダイヤルアウトできます。MPLS VPN モデルによってネットワーク ルーティングが簡略化されます。たとえば、MPLS VPN ユーザは、多数の仮想回線で構成される複雑な仮想ネットワーク バックボーン上のルーティングを管理する必要がなく、サービス プロバイダーのバックボーンをデフォルト ルートとして使用して他のすべての VPN サイトと通信できます。

このデフォルト ルート機能を使用すると、サービス プロバイダー ネットワークを介して複数のサイトを透過的に相互接続できます。1 つのサービス プロバイダー ネットワークで複数の異なる IP VPN をサポートでき、ユーザからはそれぞれの IP VPN が個別のプライベート ネットワークに見えます。各 VPN は 1 つ以上の VRF に関連付けられているため、VPN 内では、各サイトから同じ VPN 内の他のサイトに IP パケットを送信できます。VRF には、カスタマー VPN サイトを定義するルーティング情報が格納されるため、VRF は VPN テクノロジーの重要な要素です。

同じ IP アドレスを持つ宛先へのダイヤルをイネーブルにする方法

ここでは、次の手順について説明します。

「ダイヤル ストリングへの VRF とネクストホップ アドレスのマッピング」(必須)

「設定の確認」 (任意)

ダイヤル ストリングへの VRF とネクストホップ アドレスのマッピング

VRF とネクストホップ アドレスの組み合せをダイヤル ストリングにマッピングして、ダイヤラ ソフトウェアを MPLS VPN の VRF 対応にするには、次の手順を実行します。

前提条件

これらのコマンドは、必要な設定の一部に過ぎず、VRF とネクストホップ アドレスの組み合せをダイヤル ストリングにマッピングする方法を示すものです。ネットワーク設定におけるこれらのコマンドの追加位置については、「その他の関連資料」に記載されているマニュアルおよび「同じ IP アドレスを持つ宛先へのダイヤルの設定例」の例を参照してください。

手順の概要

1. enable

2. configure terminal

3. interface dialer number

4. dialer map ip protocol-next-hop-address vrf vrf-name name host-name dial-string

5. end

6. ip route vrf vrf-name ip-address mask interface-type interface-number

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface dialer number

 

Router(config)# interface dialer 1

インターフェイス コンフィギュレーション モードを開始し、ダイヤラの設定を開始します。

ステップ 4

dialer map ip protocol-next-hop-address vrf vrf-name name host-name dial-string

 

Router(config-if)# dialer map ip 60.0.0.12 vrf yellow name rubbertree02 5552171

VRF とネクストホップ アドレスの組み合せをダイヤル ストリング(電話番号)にマッピングします。

ステップ 5

end

 

Router(config-if)# end

(任意)インターフェイス コンフィギュレーション モードを終了します。

ステップ 6

ip route vrf vrf-name ip-address mask interface-type interface-number

 

Router(config)# ip route vrf blue 10.0.0.1 255.255.255.255 Dialer0

ダイヤラ ソフトウェアで接続を確立するインターフェイスを指す VRF とネクストホップ アドレスの組み合せを設定します。

設定の確認

設定を確認するには、次の手順を実行します。

手順の概要

1. ping

2. show adjacency

手順の詳細


ステップ 1 ping

カスタマー エッジ NAS でこのコマンドを使用して、ピアへのコールを発信します。期待どおりの結果では、NAS は正常にそのピアにダイヤルアウトします。

ステップ 2 show adjacency

コールに失敗した場合は、このコマンドを使用して、Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)隣接関係テーブルの情報をチェックします。


 

トラブルシューティングのヒント

この機能で問題が発生した場合は、NAS で次の debug 特権 EXEC コマンドを使用すると、問題が発生した場所の特定に役立ちます。

debug aaa authentication

debug aaa authorization

debug dialer

debug ppp authentication

debug ppp negotiation

debug radius

同じ IP アドレスを持つ宛先へのダイヤルの設定例

ここでは、図 1 に示す単純なネットワーク トポロジにおけるこの機能の設定例を示します。

図 1 MPLS VPN トポロジ

 


) 次の設定で使用されているネットワーク アドレスと電話番号は、単なる例であり、実際のネットワーク設定では動作しません。


Customer Edge(CE; カスタマー エッジ)ルータ

!
hostname oaktree02
enable secret 5 !1!35Fg$Ep4.D8JGpg7rKxQa49BF9/
!
ip subnet-zero
no ip domain-lookup
!
controller T1 5/0
!
controller T1 5/1
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
no ip mroute-cache
shutdown
duplex auto
speed auto
!
interface Ethernet1/0
ip address 10.0.58.11 255.255.255.0
no ip mroute-cache
half-duplex
!
interface Ethernet1/1
ip address 50.0.0.2 255.0.0.0
no ip mroute-cache
half-duplex
!
interface Ethernet1/2
no ip address
no ip mroute-cache
shutdown
half-duplex
!
interface Ethernet1/3
no ip address
no ip mroute-cache
shutdown
half-duplex
!
interface Serial2/0
no ip address
no ip mroute-cache
shutdown
no fair-queue
serial restart-delay 0
!
interface Serial2/1
no ip address
no ip mroute-cache
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
no ip mroute-cache
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
no ip mroute-cache
shutdown
serial restart-delay 0
!
interface FastEthernet4/0
no ip address
no ip mroute-cache
shutdown
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.58.1
ip route 60.0.0.0 255.0.0.0 50.0.0.1
no ip http server
!
!
snmp-server manager
banner motd ^C AV-8B OAKTREE^C
alias exec r sh run
!
line con 0
exec-timeout 0 0
line aux 0
login
line vty 0 4
no login
!
end

Provider Edge(PE; プロバイダー エッジ)ルータ

hostname pinetree02
!
aaa new-model
!
!
aaa authentication login con-log none
aaa authentication ppp default group radius
aaa authorization network default group radius
aaa session-id common
enable secret 5 $1$7KlA$xpC8l4dJCZogbzZvGUtFl/
!
username rubbertree02 password 0 Hello
ip subnet-zero
!
no ip domain-lookup
!
ip vrf yellow
rd 100:1
ip cef
virtual-profile aaa
isdn switch-type primary-5ess
!
controller T1 3/0
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 3/1
framing esf
linecode b8zs
!
controller T1 3/2
framing esf
linecode b8zs
!
controller T1 3/3
framing esf
linecode b8zs
!
controller T1 3/4
framing esf
linecode b8zs
!
controller T1 3/5
framing esf
linecode b8zs
!
controller T1 3/6
framing esf
linecode b8zs
!
controller T1 3/7
framing esf
linecode b8zs
!
interface Loopback0
ip vrf forwarding yellow
ip address 70.0.0.1 255.0.0.0
!
interface FastEthernet1/0
no ip address
shutdown
duplex half
!
interface Ethernet2/0
ip address 10.0.58.3 255.255.255.0
duplex full
!
interface Ethernet2/1
ip vrf forwarding yellow
ip address 50.0.0.1 255.0.0.0
duplex half
!
interface Ethernet2/2
no ip address
shutdown
duplex half
!
interface Ethernet2/3
no ip address
shutdown
duplex half
!
interface Serial3/0:23
description phone# 555-3123
no ip address
encapsulation ppp
dialer rotary-group 0
dialer-group 1
isdn switch-type primary-5ess
ppp authentication chap
!
interface Serial4/0
no ip address
shutdown
no fair-queue
!
interface Dialer0
ip address negotiated
encapsulation ppp
dialer in-band
dialer map ip 60.0.0.12 vrf yellow name rubbertree02 5552171
dialer map ip 60.0.0.2 5552172
dialer-group 1
ppp authentication chap
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.58.1
ip route 60.0.0.2 255.255.255.255 Dialer0
ip route vrf yellow 60.0.0.0 255.0.0.0 Dialer0 permanent
no ip http server
ip pim bidir-enable
!
ip director cache time 60
dialer-list 1 protocol ip permit
!
radius-server host 172.19.192.89 auth-port 1645 acct-port 1646 key rad123
radius-server retransmit 3
call rsvp-sync
!
no mgcp timer receive-rtcp
!
mgcp profile default
!
dial-peer cor custom
!
gatekeeper
shutdown
!
banner motd ^C F/A-18 PINETREE ^C
!
line con 0
exec-timeout 0 0
login authentication con-log
 
line aux 0
line vty 5 15
!
end

ピア ルータ

hostname rubbertree02
!
logging buffered 32000 debugging
enable secret 5 $1$RCKC$scgtdlaDzjSyUVAi7KK5Q.
enable password Windy
!
username pinetree02 password 0 Hello
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-5ess
!
interface Ethernet0
ip address 10.0.58.9 255.255.255.0
no ip route-cache
!
interface BRI0
description phone# 555-2171
ip address 60.0.0.12 255.0.0.0
encapsulation ppp
no ip route-cache
dialer map ip 60.0.0.11 5553123
dialer map ip 60.0.0.2 5552172
dialer-group 1
isdn switch-type basic-5ess
isdn fast-rollover-delay 45
!
ip default-gateway 10.0.58.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.58.1
ip route 50.0.0.0 255.0.0.0 70.0.0.1
no ip http server
!
dialer-list 1 protocol ip permit
no cdp run
banner motd ^C F-4B RUBBERTREE^C
!
line con 0
exec-timeout 0 0
line vty 0 4
password Windy
login
!
end

AAA サーバのユーザ ファイル

[aaa-serv]/usr/testing/bin> ./radiusd_1.16 -d . -a . -x
 
 
greentree-16 Password = "Hello", Expiration = "Dec 31 2005"
Service-Type = Framed-User,
Framed-Protocol = PPP
cisco-avpair = "lcp:interface-config=ip vrf forwarding yellow \nip
unnumbered Loopback0"

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

『MPLS Product Literature』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1164

『Application of the Border Gateway Protocol in the Internet』

RFC 1171

『A Border Gateway Protocol 4』

RFC 1700

『Assigned Numbers』

RFC 1966

『BGP Route Reflection: An Alternative to Full Mesh IBGP』

RFC 2283

『Multiprotocol Extensions for BGP-4』

RFC 2547

『BGP/MPLS VPNs』

RFC 2842

『Capabilities Advertisement with BGP-4』

RFC 2858

『Multiprotocol Extensions for BGP-4』

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクなど、技術的なコンテンツを検索可能な形で大量に提供しています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport

同じ IP アドレスを持つ宛先へのダイヤルの機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 同じ IP アドレスを持つ宛先へのダイヤルの機能情報

機能名
リリース
機能設定情報

12.2(8)T

Cisco IOS ダイヤラ ソフトウェアは、「MPLS VPN の VRF に対応」しています。つまり、VRF に格納されている情報を使用して、同じ IP アドレスの 2 つの宛先を区別できます。

この機能に関する詳細については、次の各項を参照してください。

「同じ IP アドレスを持つ宛先へのダイヤルの概要」

「同じ IP アドレスを持つ宛先へのダイヤルをイネーブルにする方法」