Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS レイヤ 3 VPN の設定
MPLS レイヤ 3 VPN の設定
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS レイヤ 3 VPN の設定

機能情報の確認

この章の構成

MPLS レイヤ 3 VPN の前提条件

MPLS レイヤ 3 VPN の制約事項

MPLS レイヤ 3 VPNに関する情報

MPLS VPN の定義

MPLS VPN の機能

MPLS VPN での仮想ルーティング/転送テーブルの機能

MPLS VPN における VPN ルーティング情報の配布方法

VPN ルーティング情報の BGP 配布

MPLS 転送

MPLS VPN の主要コンポーネント

MPLS VPN の利点

MPLS レイヤ 3 VPN の設定方法

コア ネットワークの設定

MPLS VPN カスタマーのニーズの評価

コアにおけるルーティング プロトコルの設定

コアにおける MPLS の設定

コアで CEF がイネーブルになっているかどうかの確認

PE ルータおよびルート リフレクタでのマルチプロトコル BGP の設定

MPLS VPN カスタマーの接続

カスタマーの接続を可能にするための、PE ルータでの VRF の定義

各 VPN カスタマー用の PE ルータでの VRF インスタンスの設定

PE ルータと CE ルータ間でのルーティング プロトコルの設定

VPN の設定の確認

MPLS VPN サイト間の接続の確認

MPLS コアを介した CE ルータから CE ルータへの IP 接続の確認

ローカル CE ルータとリモート CE ルータがルーティング テーブルに存在することの確認

MPLS VPN の設定例

BGP を使用する MPLS VPN の設定:例

RIP を使用する MPLS VPN の設定:例

スタティック ルート使用する MPLS VPN の設定:例

OSPF を使用する MPLS VPN の設定:例

EIGRP を使用する MPLS VPN の設定:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS レイヤ 3 VPN の機能情報

MPLS レイヤ 3 VPN の設定

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)は、MPLS プロバイダー コア ネットワークによって相互接続された一連のサイトで構成されます。各カスタマー サイトでは、1 つ以上の Customer Edge(CE; カスタマー エッジ)ルータが、1 つ以上の Provider Edge(PE; プロバイダー エッジ)ルータに接続されます。この章では、MPLS VPN の作成方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「MPLS レイヤ 3 VPN の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS レイヤ 3 VPN の前提条件

MPLS レイヤ 3 VPN を設定する前に、MPLS、Label Distribution Protocol(LDP; ラベル配布プロトコル)、および Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)が、ネットワークにインストールされている必要があります。PE ルータを含む、コア内のすべてのルータは、CEF および MPLS 転送をサポートできる必要があります。詳細については、「MPLS VPN カスタマーのニーズの評価」を参照してください。

MPLS レイヤ 3 VPN の制約事項

MPLS または MPLS VPN 環境でスタティック ルートを設定する場合は、 ip route コマンドおよび ip route vrf コマンドの一部のバリエーションがサポートされません。これらのコマンド バリエーションは、Tag Forwarding Information Base(TFIB; タグ転送情報ベース)をサポートする Cisco IOS リリース、特に Cisco IOS Release 12.xT、12.xM、および 12.0S ではサポートされていません。プレフィクスが通過する再帰ルートがいったん失われて再び現れる場合、TFIB はプレフィクスを解決できません。ただし、MPLS Forwarding Infrastructure(MFI)をサポートする Cisco IOS リリース、特に Cisco IOS Release 12.2(25)S 以降では、これらのコマンド バリエーションがサポートされています。スタティック ルートを設定するときは、次の注意事項に従ってください。

MPLS 環境でサポートされるスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface next-hop-address

MPLS 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングを設定する場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route
destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS 環境でサポートされないスタティック ルート

MPLS 環境でスタティック ルートを設定する場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS 環境でスタティック ルートを設定し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop-address

MPLS 環境でスタティック ルートを設定し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route destination-prefix mask next-hop1
ip route
destination-prefix mask next-hop2

スタティック ルートを指定する場合は、interface an next-hop 引数を使用します。

MPLS VPN 環境でサポートされるスタティック ルート

次の ip route vrf コマンドは、MPLS VPN 環境でスタティック ルートを設定し、ネクストホップとインターフェイスが同じ VRF に存在する場合はサポートされません。

ip route vrf vrf-name destination-prefix mask next-hop-address

ip route vrf vrf-name destination-prefix mask interface next-hop-address

ip route vrf vrf-name destination-prefix mask interface1 next-hop1
ip route vrf vrf-name destination-prefix mask interface2 next-hop2

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがグローバル ルーティング テーブルの MPLS クラウドのグローバル テーブルに存在する場合は、次の ip route vrf コマンドがサポートされます。たとえば、ネクストホップがインターネット ゲートウェイを指している場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask next-hop-address global

ip route vrf vrf-name destination-prefix mask interface next-hop-address
(このコマンドは、ネクストホップおよびインターフェイスがコアにある場合にサポートされます)

MPLS VPN 環境でスタティック ルートを設定し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 next-hop1
ip route
destination-prefix mask interface2 next-hop2

TFIB を使用する MPLS VPN 環境でサポートされないスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのパスでネクストホップに到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop-address global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップがコア内の MPLS クラウドのグローバル テーブルに存在し、2 つのネクストホップで宛先に到達できる場所でロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされません。

ip route vrf destination-prefix mask next-hop1 global
ip route vrf destination-prefix mask next-hop2 global

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップおよびインターフェイスが同じ VRF にある場合は、次の ip route vrf コマンドがサポートされません。

ip route vrf vrf-name destination-prefix mask next-hop1
ip route vrf
vrf-name destination-prefix mask next-hop2

ネクストホップが CE ルータ上のグローバル テーブルに存在する MPLS VPN 環境でサポートされるスタティック ルート

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが CE 側のグローバル テーブルにある場合は、次の ip route vrf コマンドがサポートされます。たとえば、EBGP マルチホップの場合と同様に、宛先プレフィクスが CE ルータのループバック アドレスである場合は、次のコマンドがサポートされます。

ip route vrf vrf-name destination-prefix mask interface next-hop-address

MPLS VPN 環境でスタティック ルートを設定し、ネクストホップが CE 側のグローバル テーブルに存在し、スタティックな非再帰ルートと特定の発信インターフェイスを使用するロード シェアリングをイネーブルにする場合は、次の ip route コマンドがサポートされます。

ip route destination-prefix mask interface1 nexthop1
ip route
destination-prefix mask interface2 nexthop2

MPLS レイヤ 3 VPNに関する情報

MPLS レイヤ 3 VPN を設定する前に、次の概念を理解しておく必要があります。

「MPLS VPN の定義」

「MPLS VPN の機能」

「MPLS VPN の主要コンポーネント」

「MPLS VPN の利点」

MPLS VPN の定義

MPLS VPN を定義する前に、一般的な VPN を定義する必要があります。VPN の説明を次に示します。

パブリック インフラストラクチャを介してプライベート ネットワーク サービスを提供する、IP ベースのネットワーク

インターネットまたはその他のパブリック ネットワークやプライベート ネットワークを介してプライベートに相互通信できる一連のサイト

通常の VPN は、完全メッシュのトンネル、または Permanent Virtual Circuit(PVC; 相手先固定接続)を VPN 内のすべてのサイトに設定することで作成されます。このタイプの VPN は、新しいサイトを追加した場合に VPN 内の各エッジ デバイスを変更する必要があるため、維持または拡張が簡単ではありません。

MPLS ベースの VPN は、レイヤ 3 に作成され、ピア モデルに基づきます。ピア モデルによって、サービス プロバイダーおよびカスタマーは、レイヤ 3 のルーティング情報を交換できます。サービス プロバイダーは、カスタマー サイト間でデータをリレーします。このとき、カスタマー側では何をする必要もありません。

MPLS VPN は、通常の VPN よりも簡単に管理および拡張できます。新しいサイトが MPLS VPN に追加された場合、更新する必要があるのは、カスタマー サイトにサービスを提供するサービス プロバイダーのエッジ ルータだけです。

MPLS VPN のさまざまな部分について、次に説明します。

プロバイダー(P)ルータ:プロバイダー ネットワークのコア内のルータ。P ルータは MPLS スイッチングを実行し、ルーティングされるパケットに VPN ラベル(PE ルータによって割り当てられた、各ルート内の MPLS ラベル)を付加しません。VPN ラベルは、データ パケットを正しい出力ルータに誘導するために使用されます。

PE ルータ:着信パケットが受信されるインターフェイスまたはサブインターフェイスに基づいて、着信パケットに VPN ラベルを付加するルータ。PE ルータは、CE ルータに直接接続します。

カスタマー(C)ルータ:ISP または企業ネットワークのルータ。

カスタマー エッジ ルータ:ネットワーク上の PE ルータに接続する、ISP のネットワーク上のエッジ ルータ CE ルータには、PE ルータとのインターフェイスが設定されている必要があります。

図 1 に、基本的な MPLS VPN を示します。

図 1 基本的 MPLS VPN 用語

 

MPLS VPN の機能

MPLS VPN 機能は、MPLS ネットワークのエッジでイネーブルになっています。PE ルータでは、次の処理を実行します。

CE ルータとルーティング アップデートを交換する。

CE ルーティング情報を VPNv4 ルートに変換する。

Multiprotocol Border Gateway Protocol(MP-BGP; マルチプロトコル ボーダー ゲートウェイ プロトコル)を介して、他の PE ルータと VPNv4 ルートを交換する。

MPLS VPN での仮想ルーティング/転送テーブルの機能

各 VPN は、1 つ以上の Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)インスタンスに関連付けられています。VRF では、PE ルータに接続されているカスタマー サイトの VPN メンバシップを定義します。VRF は、次のコンポーネントで構成されています。

IP ルーティング テーブル

取得された CEF テーブル

転送テーブルを使用する一連のインターフェイス

転送テーブルに格納されている情報を制御するための一連のルールおよびルーティング プロトコル パラメータ

1 対 1 の関係は、カスタマー サイトと VPN 間に必ずしも存在する必要はありません。1 つのサイトを複数の VPN のメンバにできます。ただし、サイトは、1 つの VRF とだけ関連付けることができます。サイトの VRF には、そのサイトがメンバとなっている VPN からサイトへの、利用できるすべてのルートが含まれています。

パケット転送情報は、VRF ごとに IP ルーティング テーブルおよび CEF テーブルに格納されます。VRF ごとに別個のルーティング テーブルおよび CEF テーブルのセットが維持されます。これらのテーブルにより、情報が VPN の外部に転送されることが防止されます。また、VPN の外部にあるパケットが VPN 内のルータに転送されることも防止されます。

MPLS VPN における VPN ルーティング情報の配布方法

VPN ルーティング情報の配布は、BGP 拡張コミュニティによって実装される VPN ルート ターゲット コミュニティを使用して制御されます。VPN ルーティング情報は、次のように配布されます。

CE ルータから学習した VPN ルートが BGP に注入されると、VPN ルート ターゲット拡張コミュニティ アトリビュートのリストが、そのルートに関連付けられます。通常、ルート ターゲット コミュニティ拡張値のリストは、ルートの学習元の VRF に関連付けられているルート ターゲットのエクスポート リストから設定されます。

ルート ターゲット拡張コミュニティのインポート リストは、各 VRF に関連付けられています。インポート リストには、ルートが VRF にインポートされるために、ルートに設定されている必要のある、ルート ターゲット拡張コミュニティ アトリビュートが定義されています。たとえば、ある特定の VRF のインポート リストにルート ターゲット拡張コミュニティ A、B、および C が含まれている場合、これらのルート ターゲット拡張コミュニティ A、B、または C のいずれか を伝送するすべての VPN ルートが VRF にインポートされます。

VPN ルーティング情報の BGP 配布

PE ルータは、次のソースから IP プレフィクスを学習します。

スタティック設定の CE ルータ

CE ルータとの BGP セッション

CE ルータと交換する Routing Information Protocol(RIP; ルーティング情報プロトコル)

IP プレフィクスは、IPv4 アドレス ファミリのメンバです。PE ルータは、IP プレフィクスを学習したあと、その IP プレフィクスを 8 バイトの Route Distinguisher(RD; ルート識別子)に結合することで、VPN-IPv4 プレフィクスに変換します。生成されたプレフィクスは、VPN-IPv4 アドレス ファミリのメンバです。このプレフィクスによって、カスタマー サイトでグローバルに一意でない(登録されていないプライベート)IP アドレスが使用される場合でも、カスタマーのアドレスが一意に識別されます。VPN-IPv4 プレフィクスを生成するために使用されるルート識別子は、PE ルータ上で VRF に関連付けられているコンフィギュレーション コマンドによって指定されます。

BGP は、各 VPN の VPN-IPv4 プレフィクスに関する到達可能性情報を配布します。BGP 通信は、次の 2 つのレベルで行われます。

自律システム(interior BGP(IBGP; 内部 BGP))と呼ばれる、IP ドメイン内

自律システム間(external BGP(EBGP; 外部 BGP))

PE と PE 間のセッションまたは PE と Route Reflector(RR; ルート リフレクタ)間のセッションは、IBGP セッションであり、PE と CE 間のセッションは EBGP セッションです。EIGRP PE-CE 環境では、EIGRP 内部ルートが 1 つの PE によって BGP に再配布されると、次に、別の PE によって EIGRP に戻されます。このとき、このルートの送信元ルータ ID が 2 番めの PE のルータ ID に設定され、元の内部ルータ ID が置き換えられます。

BGP では、IPv4 以外のアドレス ファミリのサポートを定義する BGP マルチプロトコル拡張(RFC 2283、『 Multiprotocol Extensions for BGP-4 』を参照)を使用して、PE ルータ間の VPN-IPv4 プレフィクスの到達可能性情報を伝播します。この拡張を使用すると、指定された VPN のルートが、その VPN の他のメンバによってだけ学習されるようになり、VPN のメンバ間の相互通信が可能になります。

MPLS 転送

VRF IP ルーティング テーブルおよび VRF CEF テーブルに格納されているルーティング情報に基づき、MPLS を使用してパケットが宛先に転送されます。

PE ルータでは、CE ルータから学習した各カスタマー プレフィクスにラベルをバインドし、他の PE ルータにアドバタイズするプレフィクスのネットワーク到達可能性情報に、そのラベルを含めます。PE ルータは、プロバイダー ネットワークを介して CE ルータから受信したパケットを転送するときに、宛先 PE ルータから学習したラベルを使用してパケットにラベルを付けます。宛先 PE ルータは、ラベルの付いたパケットを受信すると、そのラベルをポップし、パケットを正しい CE ルータに誘導するために使用します。プロバイダー バックボーン経由のラベル転送は、ダイナミック ラベル スイッチングまたはトラフィック エンジニアリング パスのいずれかに基づきます。カスタマー データ パケットがバックボーンを通過する場合、2 つのレベルのラベルが伝送されます。

最上位ラベルによって、パケットが正しい PE ルータに誘導されます。

2 番めのラベルは、PE ルータがパケットを CE ルータに転送する方法を示します。

MPLS VPN の主要コンポーネント

MPLS ベースの VPN ネットワークには、次の 3 つの主要コンポーネントがあります。

VPN ルート ターゲット コミュニティ:VPN ルート ターゲット コミュニティは、VPN コミュニティのすべてのメンバのリストです。VPN ルート ターゲットは、各 VPN コミュニティ メンバに設定する必要があります。

VPN コミュニティ PE ルータの Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)ピアリング:MP-BGP は、VPN コミュニティのすべてのメンバに VRF 到達可能性情報を伝播します。MP-BGP ピアリングは、VPN コミュニティ内のすべての PE ルータに設定する必要があります。

MPLS 転送:MPLS は、VPN サービス プロバイダー ネットワーク上のすべての VPN コミュニティ メンバ間のすべてのトラフィックを転送します。

1 対 1 の関係は、カスタマー サイトと VPN 間に必ずしも存在する必要はありません。1 つの指定されたサイトを複数の VPN のメンバにできます。ただし、サイトは、1 つの VRF とだけ関連付けることができます。カスタマー サイトの VRF には、そのサイトがメンバとなっている VPN からサイトへの、利用できるすべてのルートが含まれています。

MPLS VPN の利点

MPLS VPN を使用すると、サービス プロバイダーは、スケーラブルな VPN を展開し、次のような付加価値サービスを提供する基盤を構築できます。

コネクションレス型サービス :MPLS VPN の重要な技術的メリットとして、コネクションレスであることを挙げることができます。インターネットの成功には、TCP/IP という基礎的な技術が貢献しています。TCP/IP は、パケットを基礎とする、コネクションレス ネットワーク パラダイムに基づいて構築されています。これは、ホスト間の通信を確立するための事前のアクションが不要となり、2 者間の通信が簡単になることを意味します。現在の VPN ソリューションでは、コネクションレス型の IP 環境でプライバシーを確立するために、ネットワーク上でコネクション型ポイントツーポイントのオーバーレイを行っています。VPN がコネクションレス型ネットワーク上で動作しても、VPN では接続の容易さや、コネクションレス型ネットワークで利用できる多様なサービスを活用できません。コネクションレス VPN を作成すると、ネットワーク プライバシーのためのトンネルおよび暗号化が不要となり、その結果、複雑さが大幅に軽減されます。

集中型サービス :レイヤ 3 に VPN を構築すると、VPN に代表されるユーザ グループに目的のサービスを配布できます。VPN がサービス プロバイダーに提供する内容は、ユーザがイントラネット サービスにプライベートに接続するためのメカニズムだけではありません。VPN では、付加価値サービスを対象のカスタマーに柔軟に提供する方法も提供する必要があります。カスタマーがそのイントラネットやエクストラネットでサービスをプライベートに使用できるようにするために、スケーラビリティが重要となります。MPLS VPN は、プライベート イントラネットと見なされ、次のような新しい IP サービスを使用できます。

マルチキャスト

Quality of Service(QoS; サービス品質)

VPN でのテレフォニー サポート

コンテンツや VPN への Web ホスティングを含む、集中型サービス

カスタマーごとに特化したサービスを、複数組み合せてカスタマイズできます。たとえば、IP マルチキャストを低遅延のサービス クラスに組み合せると、ビデオ会議をイントラネット内で実施できます。

スケーラビリティ :コネクション型ポイントツーポイントのオーバーレイ、フレーム リレー、または ATM Virtual Connection(VC; 仮想接続)を使用する VPN を作成する場合、その VPN では、主にスケーラビリティが問題となります。特に、カスタマー サイト間での完全メッシュ接続のないコネクション型 VPN は、最適ではありません。MPLS ベースの VPN では、スケーラビリティの高い VPN ソリューションを活用するために、代わりに、ピア モデルとレイヤ 3 コネクションレス型アーキテクチャを使用します。このピア モデルでは、カスタマー サイトがピアリングする必要があるのは、VPN のメンバであるその他のすべての Customer Edge(CE; カスタマー エッジ)ルータではなく、1 つの PE ルータだけとなります。コネクションレス型アーキテクチャによって、レイヤ 3 に VPN を作成することができ、トンネルまたは VC を行う必要がなくなります。

MPLS VPN のその他のスケーラビリティ機能は、PE ルータ間での VPN ルートのパーティショニング、およびコア ネットワークでの PE ルータと Provider(P; プロバイダー)ルータ間での VPN と IGP ルートのパーティショニングから得られます。

PE ルータは、メンバである VPN に対して VPN ルートを維持する必要があります。

P ルータでは、VPN ルートを一切維持する必要がありません。

これにより、プロバイダーのコアのスケーラビリティが高まり、いずれのデバイスもスケーラビリティのボトルネックとなりません。

セキュリティ :MPLS VPN は、コネクション型 VPN と同じレベルのセキュリティを提供します。1 つの VPN からのパケットが、間違って別の VPN に送信されることはありません。

セキュリティは、次の領域で提供されます。

プロバイダー ネットワークのエッジでは、カスタマーから受信したパケットが、正しい VPN に配置されることが保証されます。

バックボーンでは、VPN トラフィックが常に分離されます。悪意のあるスプーフィング(PE ルータへのアクセスを取得するための試行)は、ほぼ不可能です。これは、カスタマーから受信するパケットが IP パケットであるためです。これらの IP パケットは、VPN ラベルと一意に識別される特定のインターフェイスまたはサブインターフェイスで受信される必要があります。

作成の容易さ :VPN を最大限に活用するには、カスタマーは、新しい VPN とユーザ コミュニティを簡単に作成できる必要があります。MPLS VPN はコネクションレスであるため、特定のポイントツーポイント接続マップまたはトポロジは必要ありません。イントラネットやエクストラネットにサイトを追加して、非公開ユーザ グループを形成できます。この方法で VPN を管理すると、指定された任意のサイトを複数の VPN のメンバにできるため、イントラネットやエクストラネットを構築する場合の柔軟性が最大限に高められます。

柔軟なアドレッシング :VPN サービスへのアクセスをより簡単にするために、サービス プロバイダーのカスタマーは、サービス プロバイダーのその他のカスタマーのアドレッシング計画とは関係なく、独自のアドレッシング計画を設計できます。多くのカスタマーは、RFC 1918 で定義されているようにプライベート アドレス空間を使用しており、イントラネットの接続性を得るために時間と費用をかけてパブリック IP アドレスに変換することは望んでいません。MPLS VPN を使用すると、カスタマーは、アドレスのパブリック ビューとプライベート ビューを提供することで、Network Address Translation(NAT; ネットワーク アドレス変換)を使用することなく現在のアドレス空間を引き続き使用できます。NAT は、重複するアドレス空間を持つ 2 つの VPN が通信する必要がある場合にだけ必要となります。これにより、カスタマーは、パブリック IP ネットワーク上で、独自の未登録プライベート アドレスを使用して自由に通信できます。

統合 Quality of Service(QoS; サービス品質)サポート :QoS は、多くの IP VPN カスタマーにとって重要な要件です。統合 QoS を使用すると、次の 2 つの基本的な VPN 要件に対処できます。

予測可能なパフォーマンスおよびポリシーの実装

MPLS VPN における複数レベルのサービスのサポート

ネットワーク トラフィックは、ネットワークのエッジで分類およびラベル付けされたあとに、加入者によって定義されたポリシーに従って集約され、プロバイダーで実行され、プロバイダー コア経由で転送されます。その後、破棄確率または遅延ごとに、ネットワークのエッジおよびコアでのトラフィックを異なるクラスに分けることができます。

直接的な移行 :サービス プロバイダーは、VPN サービスを迅速に展開するために、直接的な移行パスを使用します。MPLS VPN の独自な特長として、IP、ATM、フレーム リレー、およびハイブリッド ネットワークを含む、複数のネットワーク アーキテクチャ上に構築できることを挙げることができます。

CE ルータ上で MPLS をサポートする必要がなく、カスタマーのイントラネットに変更を加える必要がないため、エンド ユーザの移行作業は簡単になります。

MPLS レイヤ 3 VPN の設定方法

VPN を設定および確認するには、次の項で説明する作業を実行します。

「コア ネットワークの設定」(必須)

「MPLS VPN カスタマーの接続」(必須)

「MPLS VPN サイト間の接続の確認」 (任意)

MPLS VPN カスタマーのニーズの評価

MPLS VPN を設定する前に、コア ネットワーク トポロジを識別して、MPLS VPN カスタマーに最適なサービスが提供されるようにする必要があります。コア ネットワーク トポロジを識別するには、次の作業を実行します。

手順の概要

1. ネットワークのサイズを識別します。

2. ルーティング プロトコルを識別します。

3. MPLS ハイ アベイラビリティのサポートが必要であるかどうかを判断します。

4. BGP ロード シェアリングおよび冗長パスが必要であるかどうかを決定します。

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

ネットワークのサイズを識別します。

必要となるルータとポートの数を決定するために、次の内容を識別します。

サポートする必要があるカスタマーの数

カスタマーごとに必要となる VPN の数

各 VPN に存在する、仮想ルーティングおよび転送インスタンスの数

ステップ 2

コアにおけるルーティング プロトコルを識別します。

コア ネットワークで必要なルーティング プロトコルを決定します。

ステップ 3

MPLS VPN ハイ アベイラビリティのサポートが必要であるかどうかを判断します。

MPLS VPN ノンストップ フォワーディングおよびグレースフル リスタートは、選択ルータおよび Cisco IOS リリースでサポートされています。Cisco サポートに問い合せて、正確な要件およびハードウェア サポートを確認してください。

ステップ 4

MPLS VPN コアで BGP ロード シェアリングおよび冗長パスが必要であるかどうかを決定します。

設定手順については、『 Load Sharing MPLS VPN Traffic 』を参照してください。

コアにおけるルーティング プロトコルの設定

BGP、OSPF、IS-IS、EIGRP、スタティックなどのルーティング プロトコルを設定するには、次のマニュアルを参照してください

BGP の設定

『Configuring OSPF』

Configuring IS-IS

Configuring ERGRP

Configuring static routes

コアにおける MPLS の設定

コア内のすべてのルータで MPLS をイネーブルにするには、ラベル配布プロトコルを設定する必要があります。次のいずれかをラベル配布プロトコルとして使用できます。

MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)。設定については、『 MPLS Label Distribution Protocol (LDP) 』を参照してください。

MPLS トラフィック エンジニアリング Resource Reservation Protocol(RSVP; リソース予約プロトコル)。設定については、『 MPLS Traffic Engineering and Enhancements 』を参照してください。

コアで CEF がイネーブルになっているかどうかの確認

Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)は、PE ルータを含む、コア内のすべてのルータでイネーブルになっている必要があります。CEF がイネーブルであるかどうかを確認する方法については、『 Configuring Basic Cisco Express Forwarding 』を参照してください。

PE ルータおよびルート リフレクタでのマルチプロトコル BGP の設定

PE ルータおよびルート リフレクタで Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)接続を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. address-family vpnv4 [ unicast ]

8. neighbor { ip-address | peer-group-name } send-community extended

9. neighbor { ip-address | peer-group-name } activate

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as - number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

(任意)IPv4 ユニキャスト アドレス ファミリをすべてのネイバーでディセーブルにします。

ネイバーを MPLS ルートだけに使用している場合は、 bgp default ipv4-unicast コマンドを no 形式で使用します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor pp.0.0.1 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 8

neighbor { ip-address | peer-group-name } send-community extended

 

Router(config-router-af)# neighbor pp.0.0.1 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 10

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip bgp neighbor コマンドを入力して、ネイバーが稼動中であることを確認できます。このコマンドが成功しなかった場合は、 debug ip bgp x.x.x.x events コマンドを入力します。ここで、 x.x.x.x はネイバーの IP アドレスです。

MPLS VPN カスタマーの接続

MPLS VPN カスタマーを VPN に接続するには、次の作業を実行します。

「カスタマーの接続を可能にするための、PE ルータでの VRF の定義」(必須)

「各 VPN カスタマー用の PE ルータでの VRF インスタンスの設定」(必須)

「PE ルータと CE ルータ間でのルーティング プロトコルの設定」(必須)

カスタマーの接続を可能にするための、PE ルータでの VRF の定義

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスを定義するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. import map route-map

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vpn1

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

ルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数によって、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットの AS 番号:32 ビットの番号。101:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.168.122.15:1 など。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf)# route-target import 100:1

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートまたはエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 6

import map route-map

 

Router(config-vrf)# import map vpn1-route-map

(任意)VRF のインポート ルート マップを作成します。

route-map 引数には、VRF のインポート ルート マップとして使用されるルート マップを指定します。

ステップ 7

exit

 

Router(config-vrf)# exit

(任意)終了して、グローバル コンフィギュレーション モードに戻ります。

各 VPN カスタマー用の PE ルータでの VRF インスタンスの設定

PE ルータ上のインターフェイスまたはサブインターフェイスに VRF を関連付けるには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip vrf forwarding vrf-name

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface Ethernet 5/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 4

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 5

end

 

Router(config-if)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE ルータと CE ルータ間でのルーティング プロトコルの設定

CE ルータで使用されているのと同じルーティング プロトコルを使用して、PE ルータを設定します。次のルーティング プロトコルを設定できます。

「PE ルータと CE ルータ間でのルーティング プロトコルとしての BGP の設定」

「PE ルータと CE ルータ間でのルーティング プロトコルとしての RIPv2 の設定」

「PE ルータと CE ルータ間でのスタティック ルートの設定」

「PE ルータと CE ルータ間でのルーティング プロトコルとしての OSPF の設定」

「PE ルータと CE ルータ間でのルーティング プロトコルとしての EIGRP の設定」

「MPLS VPN における EIGRP 再配布の設定」

PE ルータと CE ルータ間でのルーティング プロトコルとしての BGP の設定

BGP を使用して PE から CE へのルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } activate

7. exit-address-family

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router-af)# neighbor pp.0.0.1 remote-as 200

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor pp.0.0.1 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 7

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE ルータと CE ルータ間でのルーティング プロトコルとしての RIPv2 の設定

RIPv2 を使用して PE から CE へのルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router rip

4. version { 1 | 2 }

5. address-family ipv4 [multicast | unicast | vrf vrf-name ]

6. network ip-address

7. redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router rip

 

Router(config)# router rip

RIP をイネーブルにします。

ステップ 4

version { 1 | 2 }

 

Router(config-router)# version 2

ルータがグローバルに使用する Routing Information Protocol(RIP)バージョンを指定します。

ステップ 5

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 6

network ip-address

 

Router(config-router-af)# network 192.168.7.0

PE から CE へのリンク上で RIP をイネーブルにします。

ステップ 7

redistribute protoco l [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

 

Router(config-router-af)# redistribute bgp 200

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

RIPv2 ルーティング プロトコルの場合は、 redistribute bgp as-number コマンドを使用します。

その他の引数およびキーワードについては、 redistribute コマンドを参照してください。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 9

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE ルータと CE ルータ間でのスタティック ルートの設定

スタティック ルートを使用する、PE から CE へのルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip route vrf vrf-name

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

6. redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

7. exit-address-family

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip route vrf vrf-name

 

Router(config)# ip route vrf 200

PE から CE への各セッション用のスタティック ルート パラメータを定義します。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

redistribute protoco l [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

 

Router(config-router-af)# redistribute static

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

VRF スタティック ルートを VRF BGP テーブルに再配布するには、 redistribute static コマンドを使用します。

その他の引数およびキーワードについては、このコマンドを参照してください。

ステップ 6

redistribute protoco l [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

 

Router(config-router-af)# redistribute connected

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

直接接続されているネットワークを VRF BGP テーブルに再配布するには、 redistribute connected コマンドを使用します。

その他の引数およびキーワードについては、 redistribute コマンドを参照してください。

ステップ 7

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE ルータと CE ルータ間でのルーティング プロトコルとしての OSPF の設定

OSPF を使用する、PE から CE へのルーティング セッションを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router ospf process-id [ vrf vpn-name ]

4. network ip-address wildcard-mask area area-id

5. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

6. redistribute protocol [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

7. exit-address-family

8. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router ospf process-id [ vrf vpn-name ]

 

Router(config)# router ospf 1 vrf grc

OSPF ルーティングをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

process-id 引数により、OSPF プロセスを識別します。

vrf キーワードと vpn-name 引数により、VPN が識別されます。VPN ルートを受信する VRF ごとに個別の OSPF プロセスを作成します。

ステップ 4

network ip-address wildcard-mask area area-id

 

Router(config-router)# network 192.168.129.16 0.0.0.3 area 20

OSPF を実行するインターフェイスを定義し、それらのインターフェイスに対するエリア ID を定義します。

ip-address 引数により、IP アドレスが識別されます。

wildcard-mask 引数により、「don't care」(一致する必要のない)ビットが含まれた IP アドレス タイプのマスクを識別します。

area-id 引数により、OSPF アドレス範囲と関連付けられるエリアを識別します。10 進数値または IP アドレスのいずれかで指定できます。IP サブネットにエリアを関連付けるには、 area-id 引数の値としてサブネット アドレスを指定します。

ステップ 5

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 6

redistribute protoco l [ process-id ] { level-1 | level-1-2 | level-2 } [ as-number ] [ metric metric-value ] [ metric-type type-value ] [ match { internal | external 1 | external 2 }] [ tag tag-value ] [ route-map map-tag ] [ subnets ]

 
Router(config-router-af)# redistribute rip metric 1 subnets

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

複数のプロトコルを含めることで、すべての IBGP ルートが VRF に確実に配布されるようにする必要があります。

その他の引数およびキーワードについては、 redistribute コマンドを参照してください。

ステップ 7

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 8

end

 

Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

PE ルータと CE ルータ間でのルーティング プロトコルとしての EIGRP の設定

PE ルータと CE ルータ間で Enhanced Interior Gateway Routing Protocol(EIGRP)を使用すると、MPLS 対応 BGP コア ネットワークを介して EIGRP カスタマー ネットワークを透過的に接続できるため、EIGRP ルートは、internal BGP(iBGP; 内部 BGP)として BGP ネットワーク全体で VPN を介して再配布されます。

EIGRP を使用する、PE から CE へのルーティング セッションを設定するには、次の作業を実行します。

前提条件

BGP が、ネットワーク コアで設定されている必要があります。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. no synchronization

5. neighbor ip-address remote-as as-number

6. neighbor ip-address update-source loopback interface-number

7. address-family vpnv4

8. neighbor ip-address activate

9. neighbor ip-address send-community extended

10. exit-address-family

11. address-family ipv4 vrf vrf-name

12. redistribute eigrp as-number [ metric metric-value ][ route-map map-name ]

13. no synchronization

14. exit-address-family

15. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 10

ルータ コンフィギュレーション モードを開始し、BGP ルーティング プロセスを作成します。

ステップ 4

no synchronization

 

Router(config-router)# no synchronization

IGP との同期を待機せずにアドバタイズメントを送信するように、BGP を設定します。

ステップ 5

neighbor ip-address remote-as as-number

 

Router(config-router)# neighbor 10.0.0.1 remote-as 10

指定したネイバーまたはピア グループとのピアリングを確立します。

この手順では、他の CE サイトにある CE ルータに接続された PE ルータとの iBGP セッションを確立します。

ステップ 6

neighbor ip-address update-source loopback interface-number

 

Router(config-router)# neighbor 10.0.0.1 update-source loopback 0

TCP 接続用の任意の動作インターフェイスを使用するように、BGP を設定します。

この設定手順は、必須ではありません。ただし、BGP ルーティング プロセスが、インターフェイスまたはリンク フラッピングの影響を受けにくくなります。

ステップ 7

address-family vpnv4

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、BGP、RIP、スタティック ルーティング セッションなどの標準 IPv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

ステップ 8

neighbor ip-address activate

 

Router(config-router-af)# neighbor 10.0.0.1 activate

指定したネイバーまたはピア グループとのピアリングを確立します。

この手順では、PE ルータ間での VPNv4 ルーティング情報の交換をアクティブ化します。

ステップ 9

neighbor ip-address send-community extended

 

Router(config-router-af)# neighbor 10.0.0.1 send-community extended

指定したネイバーに対して拡張コミュニティ アトリビュート情報を送信するように、ローカル ルータを設定します。

この手順は、EIGRP 拡張コミュニティ アトリビュートを交換する場合は必須です。

ステップ 10

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

ステップ 11

address-family ipv4 vrf vrf-name

 

Router(config-router)# address-family ipv4 vrf RED

EIGRP VRF 用の IPv4 アドレス ファミリを設定し、アドレス ファミリ コンフィギュレーション モードを開始します。

アドレス ファミリ VRF は、PE ルータと CE ルータ間で実行される各 EIGRP VRF に設定する必要があります。

ステップ 12

redistribute eigrp as-number [ metric metric-value ][ route-map map-name ]

 

Router(config-router-af)# redistribute eigrp 101

EIGRP VRF を BGP に再配布します。

CE ネットワークの自律システム番号は、この手順で設定します。

ステップ 13

no synchronization

 

Router(config-router-af)# no synchronization

IGP との同期を待機せずにアドバタイズメントを送信するように、BGP を設定します。

ステップ 14

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

ステップ 15

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

MPLS VPN における EIGRP 再配布の設定

MPLS VPN で EIGRP 再配布をイネーブルにするには、VPN サービスを提供するすべての PE ルータに対して次の作業を実行します。

前提条件

外部 EIGRP 自律システムおよび EIGRP 以外のネットワークからのルートにメトリックを設定すると、これらのルートを EIGRP CE ルータに再配布できます。このメトリックは、 redistribute (IP) コマンドを使用して再配布文で設定するか、または default-metric (EIGRP) コマンドを使用して設定できます。外部ルートが、別の EIGRP 自律システムまたは EIGRP 以外のネットワークから受信されたが、メトリックが設定されていない場合、そのルートは CE ルータにアドバタイズされません。

制約事項

ネイティブ EIGRP VRF 間の再配布はサポートされていません。これは、設計された動作です。

手順の概要

1. enable

2. configure terminal

3. router eigrp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name ]

5. network ip-address wildcard-mask

6. redistribute bgp { as-number } [ metric bandwidth delay reliability load mtu ] [ route-map map-name ]

7. autonomous-system as-number

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

Router(config)# router eigrp 1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

PE ルータの EIGRP ルーティング プロセスは、この手順で作成します。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf RED

アドレス ファミリ コンフィギュレーション モードを開始して、VRF を作成します。

この VRF 名は、前の項で作成した VRF 名と一致する必要があります。

ステップ 5

network ip-address wildcard-mask

 

Router(config-router-af)# network 172.16.0.0 0.0.255.255

VRF のネットワークを指定します。

このネットワーク文は、EIGRP に含めるインターフェイスを識別するために使用します。VRF は、ネットワーク文の wildcard-mask の範囲内にあるアドレスを使用して設定する必要があります。

ステップ 6

redistribute bgp { as-number } [ metric bandwidth delay reliability load mtu ] [ route-map map-name ]

 

Router(config-router-af)# redistribute bgp 10 metric 10000 100 255 1 1500

BGP を EIGRP に再配布します。

BGP ネットワークの自律システム番号とメトリックは、この手順で設定します。BGP を CE サイトの EIGRP に再配布して、EIGRP 情報を伝送する BGP ルートを受け入れるようにする必要があります。また、メトリックを BGP ネットワークに指定する必要もあります。メトリックは、この手順で設定します。

ステップ 7

autonomous-system as-number

 

Router(config-router-af)# autonomous-system 101

カスタマー サイトの EIGRP ネットワークの自律システム番号を指定します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードを開始します。

ステップ 9

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

VPN の設定の確認

ルート識別子を VRF 用に設定する必要があります。また、VRF を伝送するインターフェイス上で MPLS を設定する必要があります。 show ip vrf コマンドを使用して、VRF 用に設定されている Route Distinguisher(RD; ルート識別子)とインターフェイスを確認します。

手順の概要

1. show ip vrf

手順の詳細


ステップ 1 show ip vrf

このコマンドを使用して、一連の定義済み VRF インスタンスおよび関連付けられているインターフェイスを表示します。また、この出力では、VRF インスタンスが設定済みルート識別子にマップされます。


 

MPLS VPN サイト間の接続の確認

ローカルおよびリモートの CE ルータが MPLS コアを介して通信できることを確認するには、次の作業を実行します。

「MPLS コアを介した CE ルータから CE ルータへの IP 接続の確認」

「ローカル CE ルータとリモート CE ルータがルーティング テーブルに存在することの確認」

MPLS コアを介した CE ルータから CE ルータへの IP 接続の確認

MPLS VPN を介した CE ルータから CE ルータへの IP 接続を確認するには、次の作業を実行します。

手順の概要

1. enable

2. ping [ protocol ] { host-name | system-address }

3. trace [ protocol ] [ destination ]

4. show ip route [ ip-address [ mask ] [ longer-prefixes ]] | [ protocol [ process-id ]] | [ list access-list-number | access-list-name ]

5. disable

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。

ステップ 2 ping [ protocol ] { host-name | system-address }

このコマンドを使用して、AppleTalk、CLNS、IP、Novell、Apollo、VINES、DECnet、または XNS ネットワークでの基本的なネットワーク接続を診断します。 ping コマンドを使用して、ある CE ルータから別の CE ルータへの接続を確認します。

ステップ 3 trace [ protocol ] [ destination ]

このコマンドを使用して、パケットがその宛先に送信されるときに取るルートを検出します。 trace コマンドを使用して、パケットがその最終的な宛先に到達するまでに通過するパスを確認します。 trace コマンドは、2 つのルータが通信できない場合に問題のある箇所を分離するのに役立ちます。

ステップ 4 show ip route [ ip-address [ mask ] [ longer-prefixes ]] | [ protocol [ process-id ]] | [ list access-list-number | access-list-name ]

このコマンドを使用して、ルーティング テーブルの現在の状態を表示します。 ip-address 引数を使用して、CE1 に CE2 へのルートが含まれていることを確認します。CE1 から学習したルートを確認します。CE2 へのルートがリストされていることを確認します。


 

ローカル CE ルータとリモート CE ルータがルーティング テーブルに存在することの確認

ローカル CE ルータとリモート CE ルータが PE ルータのルーティング テーブルに存在することを確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip route vrf vrf-name [ prefix ]

3. show ip cef vrf vrf-name [ ip-prefix ]

4. exit


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。

ステップ 2 show ip route vrf vrf-name [ prefix ]

このコマンドを使用して、VRF に関連付けられている IP ルーティング テーブルを表示します。ローカル CE ルータとリモート CE ルータのループバック アドレスが、PE ルータのルーティング テーブルに存在することを確認します。

ステップ 3 show ip cef vrf vrf-name [ ip-prefix ]

このコマンドを使用して、VRF に関連付けられている CEF 転送テーブルを表示します。リモート CE ルータのプレフィクスが、CEF テーブルに存在することを確認します。

ステップ 4 exit


 

MPLS VPN の設定例

「BGP を使用する MPLS VPN の設定:例」

「RIP を使用する MPLS VPN の設定:例」

「スタティック ルート使用する MPLS VPN の設定:例」

「OSPF を使用する MPLS VPN の設定:例」

「EIGRP を使用する MPLS VPN の設定:例」

BGP を使用する MPLS VPN の設定:例

次に、BGP を使用して設定された MPLS VPN の例を示します。

PE の設定
CE の設定

ip vrf vpn1

rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 34.0.0.2 255.0.0.0
no cdp enable
!
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 100
network 10.0.0. 0.0.0.0 area 100
network 30.0.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
neighbor 34.0.0.1 remote-as 200
neighbor 34.0.0.1 activate
neighbor 34.0.0.1 as-override
neighbor 34.0.0.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
ip address 34.0.0.1 255.0.0.0
no cdp enable
!
router bgp 200
bgp log-neighbor-changes
neighbor 34.0.0.2 remote-as 100
!
address-family ipv4
redistribute connected
neighbor 34.0.0.2 activate
neighbor 34.0.0.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

RIP を使用する MPLS VPN の設定:例

次に、RIP を使用して設定された MPLS VPN の例を示します。

 

PE の設定
CE の設定

ip vrf vpn1

rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 34.0.0.2 255.0.0.0
no cdp enable
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router rip
version 2
timers basic 30 60 60 120
!
address-family ipv4 vrf vpn1
version 2
redistribute bgp 100 metric transparent
network 34.0.0.0
distribute-list 20 in
no auto-summary
exit-address-family
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
redistribute rip
no auto-summary
no synchronization
exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
ip address 34.0.0.1 255.0.0.0
no cdp enable
 
router rip
version 2
timers basic 30 60 60 120
redistribute connected
network 10.0.0.0
network 34.0.0.0
no auto-summary

スタティック ルート使用する MPLS VPN の設定:例

次に、スタティック ルートを使用して設定された MPLS VPN の例を示します。

 

PE の設定
CE の設定

ip vrf vpn1

rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 34.0.0.2 255.0.0.0
no cdp enable
!
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
router ospf 100
network 10.0.0. 0.0.0.0 area 100
network 30.0.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
redistribute static
no auto-summary
no synchronization
exit-address-family
!
ip route vrf vpn1 10.0.0.9 255.255.255.255 34.0.0.1
ip route vrf vpn1 34.0.0.0 255.0.0.0 34.0.0.1

ip cef

!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
ip address 34.0.0.1 255.0.0.0
no cdp enable
!
ip route 10.0.0.9 255.255.255.255 34.0.0.2 3
ip route 31.0.0.0 255.0.0.0 34.0.0.2 3

OSPF を使用する MPLS VPN の設定:例

次に、OSPF を使用して設定された MPLS VPN の例を示します。

PE の設定
CE の設定

ip vrf vpn1

rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 34.0.0.2 255.0.0.0
no cdp enable
!
router ospf 1000 vrf vpn1
log-adjacency-changes
redistribute bgp 100 metric-type 1 subnets
network 10.0.0.13 0.0.0.0 area 10000
network 34.0.0.0 0.255.255.255 area 10000
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
redistribute ospf 1000 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
ip address 34.0.0.1 255.0.0.0
no cdp enable
!
router ospf 1000
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
network 34.0.0.0 0.255.255.255 area 1000
network 10.0.0.0 0.0.0.0 area 1000

EIGRP を使用する MPLS VPN の設定:例

次に、EIGRP を使用して設定された MPLS VPN の例を示します。

PE の設定
CE の設定

ip vrf vpn1

rd 100:1
route-target export 100:1
route-target import 100:1
!
ip cef
mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.1 255.255.255.255
interface Ethernet0/0
ip vrf forwarding vpn1
ip address 34.0.0.2 255.0.0.0
no cdp enable
interface Ethernet 1/1
ip address 30.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
router eigrp 1000
auto-summary
!
address-family ipv4 vrf vpn1
redistribute bgp 100 metric 10000 100 255 1 1500
network 34.0.0.0
distribute-list 20 in
no auto-summary
autonomous-system 1000
exit-address-family
!
router bgp 100
no synchronization
bgp log-neighbor changes
neighbor 10.0.0.3 remote-as 100
neighbor 10.0.0.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.0.0.3 activate
neighbor 10.0.0.3 send-community extended
bgp scan-time import 5
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute connected
redistribute eigrp
no auto-summary
no synchronization
exit-address-family
 

ip cef

mpls ldp router-id Loopback0 force
mpls label protocol ldp
!
interface Loopback0
ip address 10.0.0.9 255.255.255.255
!
interface Ethernet0/0
ip address 34.0.0.1 255.0.0.0
no cdp enable
!
router eigrp 1000
network 34.0.0.0
auto-summary

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

MPLS レイヤ 3 VPN の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS レイヤ 3 VPN の機能情報

機能名
リリース
機能設定情報

MPLS バーチャル プライベート ネットワーク

12.0(5)T

12.0(21)ST

12.0(22)S

12.0(23)S

12.2(13)T

12.2(14)S

12.0(26)S

この機能を使用すると、MPLS プロバイダーのコア ネットワークによって相互接続された一連のサイトを構築できます。各カスタマー サイトでは、1 つ以上の Customer Edge(CE; カスタマー エッジ)ルータが、1 つ以上の Provider Edge(PE; プロバイダー エッジ)ルータに接続されます。

この機能に関する詳細については、次の各項を参照してください。

「MPLS VPN の定義」

「MPLS VPN の機能」

「MPLS VPN の主要コンポーネント」

「MPLS VPN の利点」

「MPLS レイヤ 3 VPN の設定方法」

プロバイダー エッジとカスタマー エッジ間の EIGRP に対する MPLS VPN サポート

12.0(22)S

12.2(15)T

12.2(18)S

12.0(27)S

この機能を使用すると、EIGRP を実行しているカスタマーを MPLS VPN に接続できます。

この機能に関する詳細については、次の各項を参照してください。

「PE ルータと CE ルータ間でのルーティング プロトコルとしての EIGRP の設定」

「MPLS VPN における EIGRP 再配布の設定」