Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
MPLS VPN でのルータ間の MPLS ラベルの 配布を制御するためのルート マップの設定
MPLS VPN でのルータ間の MPLS ラベルの配布を制御するためのルート マップの設定
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

MPLS VPN でのルータ間の MPLS ラベルの配布を制御するためのルート マップの設定

この章の構成

MPLS VPN でルート マップを使用する際の制約事項

MPLS VPN でルート マップを使用する際の前提条件

MPLS VPN でのルート マップに関する情報

MPLS VPN でのルート マップの設定方法

着信ルート用のルート マップの設定

発信ルート用のルート マップの設定

MPLS VPN エッジ ルータへのルート マップの適用

MPLS VPN でのルート マップの設定例

MPLS VPN Inter-AS ネットワークでのルート マップの使用:例

MPLS VPN CSC ネットワークでのルート マップの使用:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS VPN でのルート マップの機能情報

MPLS VPN でのルータ間の MPLS ラベルの配布を制御するためのルート マップの設定

ルート マップを使用すると、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ラベルを使用して配布するルートを指定できます。また、ルータが受信し、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)テーブルに追加する MPLS ラベル付きのルートを指定することもできます。

変更履歴

このマニュアルの初版の発行は 2005 年 5 月 2 日で、最終更新日は 2005 年 5 月 2 日です。

この章で紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、一部サポートされていない機能があります。 機能のサポートと設定の詳細については、「MPLS VPN でのルート マップの機能情報」を参照してください。

MPLS VPN でルート マップを使用する際の制約事項

Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)で MPLS ラベル付きの IPv4 ルートを交換する MPLS VPN Inter-AS では、ルート マップを使用できます。ASBR で VPN-IPv4 アドレスを交換する MPLS VPN Inter-AS では、ルート マップを使用できません。

MPLS VPN でルート マップを使用する際の前提条件

ルート マップを設定および適用する前に、Access Control List(ACL; アクセス コントロール リスト)を作成し、ルータに MPLS ラベルを使用して配布させるルートを指定する必要があります。

MPLS VPN でのルート マップに関する情報

ルータが MPLS ラベルを使用してルートを配布するように設定されている場合、すべてのルートがマルチプロトコル拡張を使用して符号化されます。また、すべてのルートに MPLS ラベルが付いています。ルート マップを使用して、ルータ間の MPLS ラベルの配布を制御できます。

ルート マップを使用すると、MPLS ラベルを使用して配布するルートを指定できます。また、ルータが受信し、BGP テーブルに追加する MPLS ラベル付きのルートを指定することもできます。ルート マップで指定できるルートは次のとおりです。

MPLS ラベルを配布するルータの場合、MPLS ラベルを使用して配布するルートを指定できる。

MPLS ラベルを受信するルータの場合、受け入れて BGP テーブルにインストールするルートを指定できる。

ルート マップは ACL と連動します。ACL にルートを入力し、ルート マップの設定時にその ACL を指定します。ルート マップで指定されているルートだけを受け入れるようにルータを設定できます。ルータは、BGP アップデート メッセージに示されているルートを指定の ACL 内のルートのリストと照合します。BGP アップデート メッセージ内のルートが ACL 内のルートと一致した場合、そのルートは受け入れられて、BGP テーブルに追加されます。

MPLS VPN でのルート マップの設定方法

ルート マップで指定されているルートとともに MPLS ラベルを送信できるようにルータを設定するには、次の作業を実行します。

「着信ルート用のルート マップの設定」 (任意)

「発信ルート用のルート マップの設定」 (任意)

「MPLS VPN エッジ ルータへのルート マップの適用」 (任意)

着信ルート用のルート マップの設定

着信ルートをフィルタリングするルート マップを作成するには、次の作業を実行します。ACL を作成し、ルータで受け入れて BGP テーブルに追加させるルートを指定します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. route-map map-name [ permit | deny ] sequence-number

5. match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ...| access-list-name ] | prefix-list prefix-list-name [ prefix-list-name. ..]}

6. match mpls-label

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

route-map map-name [ permit | deny ] sequence-number

 

Router(config-router)# route-map csc-mpls-routes-in permit

ルート マップ コンフィギュレーション モードを開始し、指定した名前のルート マップを作成します。

map-name 引数では、ルート マップの名前を識別します。

permit キーワードでは、すべての条件が満たされた場合にアクションが実行されるようにします。

deny キーワードでは、すべての条件が満たされた場合にアクションが実行されないようにします。

sequence-number 引数では、ルート マップにプライオリティを設定できます。複数のルート マップが存在し、それらにプライオリティを設定する場合、それぞれに番号を割り当てます。最初に最も低い番号のルート マップが実装され、次に 2 番めに低い番号のルート マップが実装され、それ以降も同様です。

ステップ 5

match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ...| access-list-name ] | prefix-list prefix-list-name [ prefix-list-name. ..]}

 

Router(config-route-map)# match ip address acl-in

標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されている宛先ネットワーク番号アドレスを持つルートを配布するか、パケットに対してポリシー ルーティングを実行します。

access-list-number 引数は、標準アクセス リストまたは拡張アクセス リストの番号です。1 ~ 199 の整数を指定できます。省略符号は、複数の値を入力できることを示します。

access-list-name 引数は、標準アクセス リストまたは拡張アクセス リストの名前です。1 ~ 199 の整数を指定できます。省略符号は、複数の値を入力できることを示します。

prefix-list キーワードでは、プレフィクス リストに基づいてルートを配布します。

prefix-list-name 引数は、特定のプレフィクス リストの名前です。省略符号は、複数の値を入力できることを示します。

ステップ 6

match mpls-label

 

Router(config-route-map)# match mpls-label

ルートがルート マップで指定された条件を満たす場合、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)ラベルを含むルートを再配布します。

ステップ 7

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

発信ルート用のルート マップの設定

この設定は任意です。

発信ルートをフィルタリングするルート マップを作成するには、次の作業を実行します。アクセス リストを作成し、ルータに MPLS ラベルを使用して配布させるルートを指定します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. route-map map-name [ permit | deny ] sequence-number

5. match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ...| access-list-name ] | prefix-list prefix-list-name [ prefix-list-name. ..]}

6. set mpls-label

7. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。

有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

route-map map-name [ permit | deny ] sequence-number

 

Router(config-router)# route-map csc-mpls-routes-out permit

ルート マップ コンフィギュレーション モードを開始し、指定した名前のルート マップを作成します。

map-name 引数では、ルート マップの名前を識別します。

permit キーワードでは、すべての条件が満たされた場合にアクションが実行されるようにします。

deny キーワードでは、すべての条件が満たされた場合にアクションが実行されないようにします。

sequence-number 引数では、ルート マップにプライオリティを設定できます。複数のルート マップが存在し、それらにプライオリティを設定する場合、それぞれに番号を割り当てます。最初に最も低い番号のルート マップが実装され、次に 2 番めに低い番号のルート マップが実装され、それ以降も同様です。

ステップ 5

match ip address { access-list-number [ access-list-number ... | access-list-name ...] | access-list-name [ access-list-number ...| access-list-name ] | prefix-list prefix-list-name [ prefix-list-name. ..]}

 

Router(config-route-map)# match ip address acl-out

標準アクセス リスト、拡張アクセス リスト、またはプレフィクス リストで許可されている宛先ネットワーク番号アドレスを持つルートを配布するか、パケットに対してポリシー ルーティングを実行します。

access-list-number 引数は、標準アクセス リストまたは拡張アクセス リストの番号です。1 ~ 199 の整数を指定できます。省略符号は、複数の値を入力できることを示します。

access-list-name 引数は、標準アクセス リストまたは拡張アクセス リストの名前です。1 ~ 199 の整数を指定できます。省略符号は、複数の値を入力できることを示します。

prefix-list キーワードでは、プレフィクス リストに基づいてルートを配布します。

prefix-list-name 引数は、特定のプレフィクス リストの名前です。省略符号は、複数の値を入力できることを示します。

ステップ 6

set mpls-label

 

Router(config-route-map)# set mpls-label

ルートがルート マップで指定された条件を満たす場合、MPLS ラベルを使用してルートを配布できるようにします。

ステップ 7

exit

 

Router(config-route-map)# exit

ルート マップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

MPLS VPN エッジ ルータへのルート マップの適用

この設定は任意です。

エッジ ルータでルート マップを使用できるようにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 [ multicast | unicast | vrf vrf-name }

5. neighbor ip-address route-map route-map-name in

6. neighbor ip-address route-map route-map-name out

7. neighbor ip-address send-label

8. exit-address-family

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

address-family ipv4 [ multicast | unicast | vrf vrf-name ]

 

Router(config-router)# address-family ipv4 vrf vpn1

IPv4 アドレス ファミリ タイプを指定し、アドレス ファミリ コンフィギュレーション モードを開始します。

multicast キーワードでは、IPv4 マルチキャスト アドレス プレフィクスを指定します。

unicast キーワードでは、IPv4 ユニキャスト アドレス プレフィクスを指定します。

vrf vrf-name キーワードおよび引数では、後続の IPv4 アドレス ファミリ コンフィギュレーション モード コマンドに関連付ける VRF の名前を指定します。

ステップ 5

neighbor ip-address route-map map-name in

 

Router(config-router-af)# neighbor pp.0.0.1 route-map csc-mpls-routes-in in

着信ルートにルート マップを適用します。

ip-address 引数では、ルート マップを適用するルートを指定します。

map-name 引数では、ルート マップの名前を指定します。

in キーワードでは、着信ルートにルート マップを適用します。

ステップ 6

neighbor ip-address route-map map-name out

 

Router(config-router-af)# neighbor pp.0.0.1 route-map csc-mpls-route-out out

発信ルートにルート マップを適用します。

ip-address 引数では、ルート マップを適用するルートを指定します。

map-name 引数では、ルート マップの名前を指定します。

out キーワードでは、発信ルートにルート マップを適用します。

ステップ 7

neighbor ip-address send-label

 

Router(config-router-af)# neighbor pp.0.0.1 send-label

BGP ルートとともに MPLS ラベルをネイバー BGP ルータに送信できるように BGP ルータを設定します。

ip-address 引数では、ネイバー ルータの IP アドレスを指定します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

ステップ 9

end
 
Router(config-router)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show route-map map-name コマンドを入力して、ルート マップが PE ルータに適用されていることを確認できます。


) ルート マップに変更を加えたあと、その変更を有効にするには、BGP 接続をリセットする必要があります。


MPLS VPN でのルート マップの設定例

ここでは、次の MPLS VPN ルート マップの例を示します。

「MPLS VPN Inter-AS ネットワークでのルート マップの使用:例」

「MPLS VPN CSC ネットワークでのルート マップの使用:例」

MPLS VPN Inter-AS ネットワークでのルート マップの使用:例

この例では、ルート マップは Autonomous System Border Router(ASBR; 自律システム境界ルータ)に適用されています。この ASBR は、IPv4 ルートおよび MPLS ラベルを別の ASBR と交換します。

OUT というルート マップでは、ASBR にラベル付きの PE1 ルート(ee.ee)とラベルなしの RR1 ルート(aa.aa)を配布させるように指定しています。

IN というルート マップでは、ASBR にラベル付きの PE2 ルート(ff.ff)とラベルなしの RR2 ルート(bb.bb)を受け入れさせるように指定しています。

 
ip subnet-zero
mpls label protocol tdp
!
interface Loopback0
ip address ww.ww.ww.ww 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Ethernet0/2
ip address hh.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet0/3
ip address dd.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
tag-switching ip
!
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
redistribute connected subnets
passive-interface Ethernet0/2
network ww.ww.ww.ww 0.0.0.0 area 100
network dd.0.0.0 0.255.255.255 area 100
 
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor aa.aa.aa.aa remote-as 100
neighbor aa.aa.aa.aa update-source Loopback0
neighbor hh.0.0.1 remote-as 200
no auto-summary
!
!
address-family ipv4 ! Redistributing IGP into BGP
redistribute ospf 10 ! so that PE1 & RR1 loopbacks
neighbor aa.aa.aa.aa activate ! get into the BGP table
neighbor aa.aa.aa.aa send-label
neighbor hh.0.0.1 activate
neighbor hh.0.0.1 advertisement-interval 5
neighbor hh.0.0.1 send-label
neighbor hh.0.0.1 route-map IN in ! accepting routes in route map IN.
neighbor hh.0.0.1 route-map OUT out ! distributing routes in route map OUT.
neighbor kk.0.0.1 activate
neighbor kk.0.0.1 advertisement-interval 5
neighbor kk.0.0.1 send-label
neighbor kk.0.0.1 route-map IN in ! accepting routes in route map IN.
neighbor kk.0.0.1 route-map OUT out ! distributing routes in route map OUT.
no auto-summary
no synchronization
exit-address-family
!
ip default-gateway 3.3.0.1
ip classless
!
access-list 1 permit ee.ee.ee.ee log !Setting up the access lists
access-list 2 permit ff.ff.ff.ff log
access-list 3 permit aa.aa.aa.aa log
access-list 4 permit bb.bb.bb.bb log
 
route-map IN permit 10 !Setting up the route maps
match ip address 2
match mpls-label
!
route-map IN permit 11
match ip address 4
!
route-map OUT permit 12
match ip address 3
!
route-map OUT permit 13
match ip address 1
set mpls-label
!
end

MPLS VPN CSC ネットワークでのルート マップの使用:例

次の例では、2 つのルート マップが作成されています。名前は次のとおりです。

IN(着信ルート用)

OUT(発信ルート用)

ルート マップでは、次のように指定されています。

着信 BGP アップデート メッセージ内の IP アドレスがアクセス リスト 99 内の IP アドレスと一致する場合、そのルートは BGP テーブルに追加されます。

発信 BGP アップデート メッセージ内の IP アドレスがアクセス リスト 88 内の IP アドレスと一致する場合、そのルートはルータによって配布されます。

ルート マップは、アドレス qq.0.0.1 の CSC-PE ルータに適用されています。

address-family ipv4 vrf vpn2
neighbor qq.0.0.1 remote-as 200
neighbor qq.0.0.1 activate
neighbor qq.0.0.1 as-override
neighbor qq.0.0.1 advertisement-interval 5
neighbor qq.0.0.1 route-map IN in
neighbor qq.0.0.1 route-map OUT out
neighbor qq.0.0.1 send-label
!
access-list 88 permit rr.rr.rr.rr
access-list 88 permit ss.ss.ss.ss
access-list 88 permit tt.tt.tt.tt
access-list 99 permit uu.uu.uu.uu
access-list 99 permit vv.vv.vv.vv
access-list 99 permit ww.ww.ww.ww
!
route-map IN permit 1
match ip address 99
!
route-map OUT permit 1
match ip address 88
set mpls-label
!

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクなど、技術的なコンテンツを検索可能な形で大量に提供しています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport

MPLS VPN でのルート マップの機能情報

表 1 に、この章に記載されている機能および具体的な設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 MPLS VPN でのルート マップの機能情報

機能名
リリース
機能設定情報

この機能は、次の機能の一部として含まれています。

MPLS VPN 相互自律システム - IPv4 BGP ラベル配布

IPv4 BGP ラベル配布を備えた MPLS VPN Carrier Supporting Carrier

12.0(21)ST

12.0(22)S

12.0(23)S

12.2(13)T

12.0(24)S

12.2(14)S

12.0(27)S

12.0(29)S

ルート マップを使用すると、MPLS ラベルを使用して配布するルートを指定できます。また、ルータが受信し、BGP テーブルに追加する MPLS ラベル付きのルートを指定することもできます。

この機能に関する詳細については、次の各項を参照してください。

「MPLS VPN でのルート マップに関する情報」

「MPLS VPN でのルート マップの設定方法」