Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
LDP および IGP を使用する MPLS VPN Carrier Supporting Carrier
LDP および IGP を使用する MPLS VPN Carrier Supporting Carrier
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

LDP および IGP を使用する MPLS VPN Carrier Supporting Carrier

機能情報の確認

この章の構成

LDP および IGP を使用する MPLS VPN CSC の前提条件

LDP および IGP を使用する MPLS VPN CSC の制約事項

LDP および IGP を使用する MPLS VPN CSC の概要

MPLS VPN CSC の概要

MPLS VPN CSC の実装の利点

LDP および IGP を使用する MPLS VPN CSC の設定オプション

カスタマー キャリアが ISP である場合

カスタマー キャリアが BGP/MPLS VPN サービス プロバイダーである場合

LDP および IGP を使用する MPLS VPN CSC の設定方法

バックボーン キャリア コアの設定

前提条件

CSC コアにおける IP 接続と LDP 設定の確認

CSC-PE ルータの VRF の設定

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定

CSC-PE ルータと CSC-CE ルータの設定

前提条件

CSC-PE ルータと CSC-CE ルータでの LDP の設定

CSC-PE ルータと CSC-CE ルータでの MPLS カプセル化のイネーブル化

Carrier Supporting Carrier 設定の確認

LDP および IGP を使用する MPLS VPN CSC の設定例

ISP であるカスタマーを含む MPLS VPN CSC ネットワーク:例

CSC-CE1 の設定

CSC-PE1 の設定

CSC-PE2 の設定

CSC-CE2 の設定

MPLS VPN プロバイダーであるカスタマーを含む MPLS VPN CSC ネットワーク:例

CE1 の設定

PE1 の設定

CSC-CE1 の設定

CSC-PE1 の設定

CSC-PE2 の設定

CSC-CE2 の設定

PE2 の設定

CE2 の設定

ルート リフレクタを含む MPLS VPN CSC ネットワーク:例

バックボーン キャリアの設定

カスタマー キャリア サイト 1 の設定

カスタマー キャリア サイト 2 の設定

VPN を持つカスタマーがネットワーク エッジに存在する MPLS VPN CSC ネットワーク:例

バックボーン キャリアの設定

カスタマー キャリア サイト 1 の設定

カスタマー キャリア サイト 2 の設定

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

LDP および IGP を使用する MPLS VPN CSC の機能情報

用語集

LDP および IGP を使用する MPLS VPN Carrier Supporting Carrier

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)Carrier Supporting Carrier(CSC)を使用すると、MPLS VPN ベースのサービス プロバイダーは、そのバックボーン ネットワークのセグメントを他のサービス プロバイダーが使用できるようにすることができます。この章では、MPLS ラベルを配布するための MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)、およびルートを配布するための Interior Gateway Protocol(IGP; 内部ゲートウェイ プロトコル)を使用する MPLS VPN CSC ネットワークを設定する方法について説明します。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「LDP および IGP を使用する MPLS VPN CSC の機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

LDP および IGP を使用する MPLS VPN CSC の前提条件

この機能には、次の前提条件があります。

バックボーン キャリアの Provider Edge(PE; プロバイダー エッジ)ルータには、128 MB のメモリが必要です。

バックボーン キャリアでは、Customer Edge(CE; カスタマー エッジ)ルータから PE ルータが受信するパケットに、PE ルータが CE ルータにアドバタイズしたラベルだけが含まれていることを確認するように、PE ルータをイネーブルにする必要があります。これにより、データ スプーフィングを防ぐことができます。データ スプーフィングは、認識できない IP アドレスがルータに送信された場合に発生します。

LDP および IGP を使用する MPLS VPN CSC の制約事項

この機能では、次の機能がサポートされていません。

ATM MPLS

Carrier Supporting Carrier トラフィック エンジニアリング

Carrier Supporting Carrier Quality of Service(QoS; サービス品質)

RSVP 集約

カスタマー キャリアとバックボーン キャリア ネットワーク間の VPN マルチキャスト

次のルータ プラットフォームは、MPLS VPN のエッジでサポートされています。

Cisco 7200 シリーズ

Cisco 7500 シリーズ

Cisco 12000 シリーズ

Cisco IOS リリースに追加された Cisco 12000 シリーズ ラインカードのサポートについては、 表 1 を参照してください。

 

表 1 Cisco IOS リリースに追加された Cisco 12000 シリーズ ラインカードのサポート

タイプ
ラインカード
追加された Cisco IOS リリース

Packet over SONET(POS)

4-Port OC-3 POS
1-Port OC-12 POS
8-Port OC-3 POS
16-Port OC-3 POS
4-Port OC-12 POS
1-Port OC-48 POS
4-Port OC-3 POS ISE
8-Port OC-3 POS ISE
16 x OC-3 POS ISE
4 Port OC-12 POS ISE
1-Port OC-48 POS ISE

12.0(16)ST

12.0(21)ST



12.0(22)S

電気インターフェイス

6- Port DS3
12- Port DS3
6-Port E3

12.0(16)ST

12.0(21)ST

ATM

4-Port OC-3 ATM
1-Port OC12 ATM
4-Port OC-12 ATM

12.0(22)S

チャネライズド インターフェイス

2-Port CHOC-3
6-Port Ch T3 (DS1)
1-Port CHOC-12 (DS3)
1-Port CHOC-12 (OC-3)
4-Port CHOC-12 ISE
1-Port CHOC-48 ISE

LDP および IGP を使用する MPLS VPN CSC の概要

MPLS VPN CSC を設定する前に、次の概念を理解しておく必要があります。

「MPLS VPN CSC の概要」

「MPLS VPN CSC の実装の利点」

「LDP および IGP を使用する MPLS VPN CSC の設定オプション」

MPLS VPN CSC の概要

Carrier Supporting Carrier により、サービス プロバイダーは、そのバックボーン ネットワークのセグメントを別のサービス プロバイダーが使用できるようにすることができます。別のプロバイダーにバックボーン ネットワークのセグメントを提供するサービス プロバイダーは、バックボーン キャリアと呼ばれます。バックボーン ネットワークのセグメントを使用するサービス プロバイダーは、カスタマー キャリアと呼ばれます。

バックボーン キャリアは、Border Gateway Protocol および Multiprotocol Label Switching(BGP/MPLS; ボーダー ゲートウェイ プロトコル/マルチプロトコル ラベル スイッチング)VPN サービスを提供します。カスタマー キャリアは、次のいずれかになります。

Internet Service Provider(ISP; インターネット サービス プロバイダー)

BGP/MPLS VPN サービス プロバイダー

MPLS VPN CSC の実装の利点

MPLS VPN CSC は、サービス プロバイダー(バックボーン キャリア)およびカスタマー キャリアに次の利点をもたらします。

バックボーン キャリアにとっての利点

バックボーン キャリアは、多数のカスタマー キャリアに対応し、そのバックボーンにカスタマー キャリアがアクセスできるようにします。バックボーン キャリアは、それぞれのカスタマー キャリア用に個別のバックボーンを作成および維持する必要はありません。1 つのバックボーン ネットワークを使用して複数のカスタマー キャリアをサポートすると、バックボーン キャリアの VPN 動作が簡略化されます。バックボーン キャリアは、一貫した方法を使用して、バックボーン ネットワークを管理および維持します。この方法は、個々のバックボーンを維持するよりも安価かつ効率的でもあります。

MPLS VPN Carrier Supporting Carrier 機能は、スケーラブルです。Carrier Supporting Carrier では、帯域幅および接続の変化するニーズに合わせて VPN を変更できます。この機能は、予定外の成長や変更に対応できます。Carrier Supporting Carrier 機能により、同じネットワーク上で何千もの VPN を設定でき、サービス プロバイダーは VPN サービスとインターネット サービスの両方を提供できます。

MPLS VPN Carrier Supporting Carrier 機能は、柔軟なソリューションです。バックボーン キャリアは、多くのタイプのカスタマー キャリアに対応できます。バックボーン キャリアは、ISP であるカスタマー キャリアおよび VPN サービス プロバイダーであるカスタマー キャリアのいずれかまたは両方を受け入れることができます。バックボーン キャリアは、セキュリティおよびさまざまな帯域幅を必要とするカスタマー キャリアに対応できます。

カスタマー キャリアにとっての利点

MPLS VPN Carrier Supporting Carrier 機能により、カスタマー キャリアでは、独自のバックボーンを設定、運用、および維持する必要がなくなります。カスタマー キャリアは、バックボーン キャリアのバックボーン ネットワークを使用しますが、ネットワークのメンテナンスと運用はバックボーン キャリアが担当します。

バックボーン キャリアが提供する VPN サービスを使用するカスタマー キャリアには、フレーム リレーまたは ATM ベースの VPN が提供するのと同じレベルのセキュリティがもたらされます。また、カスタマー キャリアは VPN で IPSec を使用することにより、より高いレベルのセキュリティを確保できます。これは、バックボーン キャリアにとっては完全に透過的です。

カスタマー キャリアは、任意のリンク レイヤ テクノロジー(SONET、デジタル加入者線、フレーム リレーなど)を使用して、CE ルータを PE ルータに接続し、PE ルータを P ルータに接続します。MPLS VPN Carrier Supporting Carrier 機能は、リンク レイヤとは独立しています。CE ルータと PE ルータは IP を使用して通信し、バックボーン キャリアは MPLS を使用します。

カスタマー キャリアは、任意のアドレッシング方式を使用でき、バックボーン キャリアによるサポートを引き続き受けることができます。カスタマーのアドレス空間およびルーティング情報は、他のカスタマー キャリアまたはバックボーン プロバイダーのアドレス空間およびルーティング情報とは独立しています。

LDP および IGP を使用する MPLS VPN CSC の設定オプション

バックボーン キャリアは、BGP サービスと MPLS VPN サービスを提供します。カスタマー キャリアは、ここで説明する 2 つのタイプのサービス プロバイダーのいずれかになります。ここでは、バックボーン キャリアとカスタマー キャリアが IPv4 ルートと MPLS ラベルを配布する方法について説明します。

「カスタマー キャリアが ISP である場合」

「カスタマー キャリアが BGP/MPLS VPN サービス プロバイダーである場合」

カスタマー キャリアが ISP である場合

この項では、BGP/MPLS VPN サービス プロバイダー(バックボーン キャリア)が、そのバックボーン ネットワークのセグメントを ISP であるカスタマーに提供する方法について説明します。

次の例について考えてみます。

ISP には 2 つのサイトがあります。1 つはカリフォルニア州に、もう 1 つはメイン州にあります。各サイトは、Point of Presence(POP)です。ISP は、バックボーン キャリアが提供する VPN サービスを使用してこれらのサイトを接続しようと考えています。図 1 に、この状況を示します。

図 1 ISP をサポートするサンプル BGP/MPLS バックボーン キャリア


) この図の CE ルータは、バックボーン キャリアにとっての CE ルータです。ただし、これらはカスタマー キャリアにとっては PE ルータです。


この例では、バックボーン キャリアだけが MPLS を使用します。カスタマー キャリア(ISP)は IP だけを使用します。そのため、バックボーン キャリアは、カスタマー キャリアのすべてのインターネット ルート(100,000 ルートにもなる可能性があります)を伝送する必要があります。これにより、バックボーン キャリアに関してスケーラビリティの問題が生じる可能性があります。スケーラビリティの問題を解決するには、バックボーン キャリアを次のように設定する必要があります。

バックボーン キャリアでは、カスタマー キャリアの CE ルータとバックボーン キャリアの PE ルータ間で、カスタマー キャリアの内部ルート(IGP ルート)だけが交換されることを許可します。

MPLS は、カスタマー キャリアの CE ルータとバックボーン キャリアの PE ルータ間のインターフェイスでイネーブルになっています。

内部ルートと外部ルートは、次の方法で区別されています。

内部ルートは、ISP 内のいずれかのルータに進みます。

外部ルートはインターネットに進みます。

内部ルートの数は、外部ルートの数よりも大幅に少なくなります。カスタマー キャリアの CE ルータとバックボーン キャリアの PE ルータ間のルートを制限すると、PE ルータが維持する必要があるルートの数が大幅に減ります。

PE ルータは、VRF ルーティング テーブル内の外部ルートを伝送する必要がないため、パケット内の着信ラベルを使用して、カスタマー キャリアのインターネット トラフィックを転送できます。MPLS をルータに追加すると、カスタマー キャリアからバックボーン キャリアへのパケット転送を一貫した方法で行うことができます。MPLS により、PE ルータと CE ルータ間で、すべての内部カスタマー キャリア ルートの MPLS ラベルを交換できます。カスタマー キャリアのルータには、インターネットに接続するために、internal Border Gateway Protocol(iBGP; 内部ボーダー ゲートウェイ プロトコル)またはルート再配布のいずれかを経由するすべての外部ルートが含まれています。図 2 に、ネットワークがこの方法で設定されている場合に、情報が交換される方法を示します。

図 2 バックボーン キャリアと、ISP であるカスタマー キャリアとの間のルーティング情報の交換

図 3 では、ルートは、バックボーン キャリアとカスタマー キャリア サイトとの間で作成されています。ASBR2 は、ネットワーク外で生成されたインターネット ルートを受信します。ISP サイトのすべてのルータは、ルータ間の IBGP 接続を介してすべての外部ルートを取得します。

図 3 バックボーン キャリアと、ISP であるカスタマー キャリアとの間でのルートの確立

表 2 に、ルートを確立するプロセスの説明を示します。このプロセスは、次の 2 つの独立した手順に分けられます。

バックボーン キャリアは、カスタマー キャリアの IGP 情報を伝播します。これにより、カスタマー キャリア ルータは、リモート サイトのすべてのカスタマー キャリア ルータに到達できます。

異なるサイト内のカスタマー キャリアのルータに到達可能になると、バックボーン キャリア ルータを使用しないで IBGP を使用して、外部ルートをカスタマー キャリア サイト内で伝播できるようになります。

 

表 2 バックボーン キャリアとカスタマー キャリア ISP 間でのルートの確立

手順
説明

1

CSC-CE2 は、サイト 2 内の内部ルートを CSC-PE2 に送信します。これらのルートには、ASBR2 へのルートが含まれています。

2

CSC-PE2 は、MPLS VPN プロセスを使用して、サイト 2 から CSC-PE1 にルーティング情報を送信します。CSC-PE1 は、ASBR2 の VPN-IP アドレスへのルートに関連付けられている 1 つのラベル(L3 と呼びます)を取得します。CSC-PE1 は、CSC-PE2 へのルートに関連付けられている別のラベル(L2 と呼びます)を取得します。

3

CSC-PE1 は、内部ルートに関連付けられているルーティング情報をサイト 2 から CSC-CE1 に送信します。CSC-PE1 は、ラベル バインディング情報も送信します。その結果、CSC-CE1 は、ネクストホップとして、CSC-PE1 による ASBR2 へのルートを取得します。このルートに関連付けられているラベルを L1 と呼びます。

4

CSC-CE1 は、サイト 1 経由でルーティング情報を配布します。サイト 1 のすべてのルータは、サイト 2 のすべての内部宛先へのルートを取得します。したがって、サイト 1 のすべてのルータは、サイト 2 のルータに到達でき、IBGP を介して外部ルートを学習できます。

5

ASBR2 は、インターネット ルートを受信します。

6

IBGP セッションは、インターネットへのルートを含む、ISP の外部ルーティング情報を交換します。サイト 1 のすべてのルータは、ASBR2 をルートのネクストホップとして使用して、インターネットへのルートを認識します。

カスタマー キャリアが BGP/MPLS VPN サービス プロバイダーである場合

バックボーン キャリアとカスタマー キャリアの両方が BGP/MPLS VPN サービスを提供する場合、データの転送方式は、カスタマー キャリアが ISP サービスだけを提供する場合とは異なります。次のリストは、これらの相違の重要点を示しています。

カスタマー キャリアが BGP/MPLS VPN サービスを提供する場合、その外部ルートは VPN-IPv4 ルートです。カスタマー キャリアが ISP である場合、その外部ルートは IP ルートです。

カスタマー キャリアが BGP/MPLS VPN サービスを提供する場合、カスタマー キャリア内のすべてのサイトは、MPLS を使用する必要があります。カスタマー キャリアが ISP である場合、そのサイトでは MPLS を使用する必要はありません。

図 4 に、MPLS VPN サービスがすべてのカスタマー キャリア サイトおよびバックボーン キャリアに存在する場合の情報の交換方法を示します。

図 4 バックボーン キャリアと、MPLS VPN サービス プロバイダーであるカスタマー キャリアとの間の情報の交換

図 5 の例では、ルートは、バックボーン キャリアとカスタマー キャリア サイトとの間で作成されています。

図 5 バックボーン キャリアと、MPLS VPN サービス プロバイダーであるカスタマー キャリアとの間でのルートの確立

表 3 に、ルートの確立プロセスの説明を示します。

 

表 3 バックボーン キャリアとカスタマー キャリア サイトとの間のルートの確立

手順
説明

1

CE2 は、サイト 2 内のすべての内部ルートを CSC-PE2 に送信します。

2

CSC-PE2 は、MPLS VPN プロセスを使用して、サイト 2 から CSC-PE1 にルーティング情報を送信します。CSC-PE1 は、PE2 の VPN-IP アドレスへのルートに関連付けられている 1 つのラベル(L3 と呼びます)を取得します。CSC-PE1 は、CSC-PE2 へのルートに関連付けられている別のラベル(L2 と呼びます)を取得します。

3

CSC-PE1 は、内部ルートに関連付けられているルーティング情報をサイト 2 から CSC-CE1 に送信します。CSC-PE1 は、ラベル バインディング情報も送信します。その結果、CSC-CE1 は、ネクストホップとして、CSC-PE1 による PE2 へのルートを取得します。このルートに関連付けられているラベルを L1 と呼びます。

4

CE1 は、サイト 1 経由でルーティングとラベル情報を配布します。サイト 1 のすべてのルータは、サイト 2 のすべての内部宛先へのルートを取得します。したがって、PE1 は、PE2 との MP-IBGP セッションを確立できます。

5

CE2 は、MPLS VPN サイト 2 の内部ルートを PE2 にアドバタイズします。

6

PE2 は、MP-IBGP を使用して、すべての VPN ルートのラベルを割り当て(標準の MPLS VPN 機能)、ラベルを PE1 にアドバタイズします。

7

PE1 は、VPN サイト 2 を宛先とする、VPN サイト 1 からのトラフィックを転送できます。

LDP および IGP を使用する MPLS VPN CSC の設定方法

ここでは、次の各手順について説明します。

「バックボーン キャリア コアの設定」(必須)

「CSC-PE ルータと CSC-CE ルータの設定」(必須)

「Carrier Supporting Carrier 設定の確認」 (任意)

バックボーン キャリア コアの設定

バックボーン キャリア コアの設定では、CSC コアおよび CSC-PE ルータに接続およびルーティング機能を設定する必要があります。

CSC コア(バックボーン キャリア)を設定および確認するには、次の作業を実行します。

「CSC コアにおける IP 接続と LDP 設定の確認」 (任意)

「CSC-PE ルータの VRF の設定」(必須)

「バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定」(必須)

前提条件

バックボーン キャリア コアを設定する前に、CSC コア ルータ上で次のプロトコルを設定します。

IGP ルーティング プロトコル:BGP、OSPF、IS-IS、EIGRP、スタティックなど。詳細については、『 Configuring a Basic BGP Network 』、『 Configuring OSPF 』、『 Configuring a Basic IS-IS Network 』、および『 Configuring EIGRP 』を参照してください。

Label Distribution Protocol(LDP; ラベル配布プロトコル)。詳細については、『 MPLS Label Distribution Protocol 』を参照してください。

CSC コアにおける IP 接続と LDP 設定の確認

CSC コアにおける IP 接続と LDP 設定を確認するには、次の作業を実行します。この作業の設定例については、「CSC コアにおける IP 接続と LDP 設定の確認」を参照してください。

手順の概要

1. enable

2. ping [ protocol ] { host - name | system - address }

3. trace [ protocol ] [ destination ]

4. show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

5. show mpls ldp discovery [ vrf vrf-name | all ]

6. show mpls ldp neighbor [[ vrf vrf-name ] [ address | interface ] [ detail ] | all ]

7. show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

8. show mpls interfaces [[ vrf vrf-name ] [ interface ] [ detail ] | all ]

9. show ip route

10. disable

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

ping [ protocol ] { host-name | system- address }

 

Router# ping ip 10.0.0.1

(任意)AppleTalk、Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)、IP、Novell、Apollo、VINES、DECnet、または Xerox Network System(XNS)ネットワークでの基本的なネットワーク接続を診断します。

ping ip コマンドを使用して、CSC コア ルータから別の CSC コア ルータへの接続を確認します。

ステップ 3

trace [ protocol ] [ destination ]

 

Router# trace ip 10.0.0.1

(任意)パケットがその宛先に送信されるときに実際に取るルートを検出します。

trace コマンドを使用して、パケットがその最終的な宛先に到達するまでに通過するパスを確認します。 trace コマンドは、2 つのルータが通信できない場合に問題のある箇所を分離するのに役立ちます。

ステップ 4

show mpls forwarding-table [ network { mask | length } | labels label [- label ] | interface interface | next-hop address | lsp-tunnel [ tunnel-id ]] [ vrf vrf-name ] [ detail ]

 

Router# show mpls forwarding-table

(任意)MPLS Label Forwarding Information Base(LFIB; ラベル転送情報ベース)の内容を表示します。

show mpls forwarding-table コマンドを使用して、MPLS パケットが転送されていることを確認します。

ステップ 5

show mpls ldp discovery [ vrf vrf-name | all ]

 

Router# show mpls ldp discovery

(任意)LDP ディスカバリ プロセスのステータスを表示します。

show mpls ldp discovery コマンドを使用して、LDP が CSC コアで動作していることを確認します。

ステップ 6

show mpls ldp neighbor [[ vrf vrf-name ] [ address | interface ] [ detail ] | all ]

 

Router# show mpls ldp neighbor

(任意)LDP セッションのステータスを表示します。

show mpls ldp neighbor コマンドを使用して、CSC コアにおける LDP 設定を確認します。

ステップ 7

show ip cef [ vrf vrf-name ] [ network [ mask ]] [ longer-prefixes ] [ detail ]

 

Router# show ip cef

(任意)Forwarding Information Base(FIB; 転送情報ベース)のエントリを表示します。

show ip cef コマンドを使用して、転送テーブル(プレフィクス、ネクスト ホップ、およびインターフェイス)を確認します。

ステップ 8

show mpls interfaces [[ vrf vrf-name ] [ interface ] [ detail ] | all ]

 

Router# show mpls interfaces

(任意)ラベル スイッチングに設定されている 1 つ以上のインターフェイスまたはすべてのインターフェイスに関する情報を表示します。

show mpls interfaces コマンドを使用して、LDP を使用するようにインターフェイスが設定されていることを確認します。

ステップ 9

show ip route

 

Router# show ip route

(任意)IP ルーティング テーブルのエントリを表示します。

show ip route コマンドを使用して、ホスト IP アドレス、ネクストホップ、インターフェイスを含む、ルーティング テーブル全体を表示します。

ステップ 10

disable

 

Router# disable

(任意)特権 EXEC モードに戻ります。

トラブルシューティングのヒント

ping コマンドと trace コマンドを使用して、コアにおける MPLS 接続の詳細を確認します。さらに show コマンドを使用して、有用なトラブルシューティング情報を入手することもできます。

CSC-PE ルータの VRF の設定

VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスをバックボーン キャリア エッジ(CSC-PE)ルータに設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target { import | export | both } route-target-ext-community

6. import map route-map

7. exit

8. interface type number

9. ip vrf forwarding vrf-name

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vpn1

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 100:1

ルーティング テーブルと転送テーブルを作成します。

route-distinguisher 引数により、8 バイトの値が IPv4 プレフィクスに追加され、VPN IPv4 プレフィクスが作成されます。RD は、次のいずれかの形式で入力できます。

16 ビットの AS 番号:32 ビットの番号。101:3 など。

32 ビットの IP アドレス:16 ビットの番号。192.168.122.15:1 など。

ステップ 5

route-target { import | export | both } route-target-ext-community

 

Router(config-vrf)# route-target import 100:1

VRF 用の route-target 拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

both キーワードを使用すると、ターゲット VPN 拡張コミュニティとの間でルーティング情報がインポートまたはエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ アトリビュートが、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 6

import map route-map

 

Router(config-vrf)# import map vpn1-route-map

(任意)VRF のインポート ルート マップを作成します。

route-map 引数には、VRF のインポート ルート マップとして使用されるルート マップを指定します。

ステップ 7

exit

 

Router(config-vrf)# exit

(任意)終了して、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface type number

 

Router(config)# interface Ethernet5/0

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 9

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding vpn1

指定したインターフェイスまたはサブインターフェイスに VRF を関連付けます。

vrf-name 引数は、VRF に割り当てられている名前です。

ステップ 10

end

 

Router(config-if)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip vrf detail コマンドを入力し、MPLS VPN が稼動しており、適切なインターフェイスに関連付けられていることを確認します。

バックボーン キャリアにおける VPN 接続のマルチプロトコル BGP の設定

バックボーン キャリアで VPN 接続の Multiprotocol BGP(MP-BGP; マルチプロトコル BGP)を設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. router bgp as - number

4. no bgp default ipv4-unicast

5. neighbor { ip-address | peer-group-name } remote-as as-number

6. neighbor { ip-address | peer-group-name } update-source interface-type

7. address-family vpnv4 [ unicast ]

8. neighbor { ip-address | peer-group-name } send-community extended

9. neighbor { ip-address | peer-group-name } activate

10. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as - number

 

Router(config)# router bgp 100

BGP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

as-number 引数は、ルータを他の BGP ルータに対して識別し、転送するルーティング情報にタグを設定する自律システムの番号を示します。有効な番号は 0 ~ 65535 です。内部ネットワークで使用可能なプライベート自律システム番号は、64512 ~ 65535 です。

ステップ 4

no bgp default ipv4-unicast

 

Router(config-router)# no bgp default ipv4-unicast

(任意)IPv4 ユニキャスト アドレス ファミリをすべてのネイバーでディセーブルにします。

ネイバーを MPLS ルートだけに使用している場合は、 bgp default-unicast コマンドを no 形式で使用します。

ステップ 5

neighbor { ip-address | peer-group-name } remote-as as-number

 

Router(config-router)# neighbor 10.0.0.1 remote-as 100

BGP ネイバーテーブルまたはマルチプロトコル BGP ネイバーテーブルにエントリを追加します。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

as-number 引数には、ネイバーが属している自律システムを指定します。

ステップ 6

neighbor { ip-address | peer-group-name } update-source interface-type

 

Router(config-router)# neighbor 10.0.0.1 update-source loopback0

BGP セッションで、TCP 接続の特定の動作インターフェイスを使用できるようになります。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

interface-type 引数には、ソースとして使用するインターフェイスを指定します。

ステップ 7

address-family vpnv4 [ unicast ]

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用する、BGP などのルーティング セッションを設定します。

省略可能な unicast キーワードは、VPNv4 ユニキャスト アドレス プレフィクスを指定する場合に使用します。

ステップ 8

neighbor { ip-address | peer-group-name } send-community extended

 

Router(config-router-af)# neighbor 10.0.0.1 send-community extended

コミュニティ アトリビュートを BGP ネイバーに送信する必要があることを指定します。

ip-address 引数には、BGP スピーキング ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 9

neighbor { ip-address | peer-group-name } activate

 

Router(config-router-af)# neighbor 10.12.12.12 activate

ネイバー BGP ルータとの情報交換をイネーブルにします。

ip-address 引数には、ネイバーの IP アドレスを指定します。

peer-group-name 引数には、BGP ピア グループの名前を指定します。

ステップ 10

end

 

Router(config-router-af)# end

(任意)終了して、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

show ip bgp neighbor コマンドを入力して、ネイバーが稼動中であることを確認できます。このコマンドでエラー メッセージが生成された場合は、 debug ip bgp x. x . x . x events コマンドを入力します。ここで、 x . x . x . x は、ネイバーの IP アドレスです。

CSC-PE ルータと CSC-CE ルータの設定

ルートおよび MPLS ラベルを配布するように、CSC-PE ルータと CSC-CE ルータをイネーブルにするには、次の作業を実行します。

「CSC-PE ルータと CSC-CE ルータでの LDP の設定」(必須)

「CSC-PE ルータと CSC-CE ルータでの MPLS カプセル化のイネーブル化」(必須)

前提条件

CSC-PE ルータと CSC-CE ルータを設定する前に、CSC-PE ルータと CSC-CE ルータで IGP を設定する必要があります。バックボーン キャリアをカスタマー キャリアに接続する PE ルータと CE ルータとの間には、ルーティング プロトコルが必要です。ルーティング プロトコルにより、カスタマー キャリアは IGP ルーティング情報をバックボーン キャリアと交換できます。カスタマー キャリアが使用するのと同じルーティング プロトコルを使用します。ルーティング プロトコルとして、RIP、OSPF、またはスタティック ルーティングを選択できます。BGP はサポートされていません。設定手順については、『 Configuring MPLS Layer 3 VPNs 』を参照してください。

CSC-PE ルータと CSC-CE ルータでの LDP の設定

バックボーン キャリアをカスタマー キャリアに接続する PE ルータと CE ルータとの間には、MPLS LDP が必要です。LDP をデフォルトのラベル配布プロトコルとして、ルータ全体、または VRF の PE から CE へのインターフェイスだけに設定できます。

手順の概要

1. enable

2. configure terminal

3. mpls label protocol ldp

4. interface type number

5. mpls label protocol ldp

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls label protocol ldp

 

Router(config)# mpls label protocol ldp

MPLS LDP をルータのデフォルトのラベル配布プロトコルとして指定します。

ステップ 4

interface type number

 

Router(config)# interface Ethernet5/0

(任意)設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 5

mpls label protocol ldp

 

Router(config-if)# mpls label protocol ldp

(任意)MPLS LDP をインターフェイスのデフォルトのラベル配布プロトコルとして指定します。

ステップ 6

exit

 

Router(config-if)# exit

(任意)終了して、特権 EXEC モードに戻ります。

CSC-PE ルータと CSC-CE ルータでの MPLS カプセル化のイネーブル化

バックボーン キャリアを通過するすべてのパケットはカプセル化される必要があるため、パケットには MPLS ラベルが含まれています。MPLS カプセル化は、ルータ全体に対してイネーブルにしたり、PE や CE ルータのインターフェイスに対してだけイネーブルにしたりすることができます。パケットのカプセル化をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. mpls ip

4. interface type number

5. mpls ip

6. exit

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls ip

 

Router(config)# mpls ip

ルータの MPLS カプセル化をイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface Ethernet5/0

(任意)設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

type 引数には、設定するインターフェイスのタイプを指定します。

number 引数には、ポート、コネクタ、またはインターフェイス カード番号を指定します。

ステップ 5

mpls ip

 

Router(config-if)# mpls ip

(任意)指定したインターフェイスの MPLS カプセル化をイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

(任意)終了して、特権 EXEC モードに戻ります。

Carrier Supporting Carrier 設定の確認

次のコマンドを使用して、バックボーン キャリアとカスタマー キャリア間に設定された LDP セッションのステータスを確認します。これで、カスタマー キャリア ISP サイトが、バックボーン キャリアの VPN カスタマーとして表示されます。

手順の概要

1. show mpls ldp discovery vrf vrf-name

2. show mpls ldp discovery all

手順の詳細


ステップ 1 show mpls ldp discovery vrf vrf-name

このコマンドを使用して、バックボーン キャリアの PE ルータの VRF VPN1 に LDP セッションが存在することを示します。次に例を示します。

Router# show mpls ldp discovery vrf vpn1
 
Local LDP Identifier:
10.0.0.0:0
Discovery Sources:
Interfaces:
Ethernet1/0 (ldp): xmit/recv
LDP Id: 10.0.0.1:0
POS6/0 (ldp): xmit
 

ステップ 2 show mpls ldp discovery all

このコマンドを使用して、ルータのすべての LDP セッションのリストを表示します。次に例を示します。

Router# show mpls ldp discovery all
 
Local LDP Identifier:
10.10.10.10:0
Discovery Sources:
Interfaces:
Ethernet1/5 (ldp): xmit/recv
LDP Id: 10.5.5.5:0
VRF vpn1: Local LDP Identifier:
10.0.0.1:0
Discovery Sources:
Interfaces:
Ethernet1/0 (ldp): xmit/recv
LDP Id: 10.0.0.1:0
POS6/0 (ldp): xmit
 

Local LDP Identifier フィールドには、このセッションのローカル ラベル スイッチング ルータの LDP ID が表示されます。Interfaces フィールドには、次のように、LDP ディスカバリ アクティビティを行うインターフェイスが表示されます。

xmit は、インターフェイスが LDP ディスカバリ hello パケットを送信することを示します。

recv は、インターフェイスが LDP ディスカバリ hello パケットを受信することを示します。


 

LDP および IGP を使用する MPLS VPN CSC の設定例

ここでは、次の設定例について説明します。

「ISP であるカスタマーを含む MPLS VPN CSC ネットワーク:例」

「MPLS VPN プロバイダーであるカスタマーを含む MPLS VPN CSC ネットワーク:例」

「ルート リフレクタを含む MPLS VPN CSC ネットワーク:例」

「VPN を持つカスタマーがネットワーク エッジに存在する MPLS VPN CSC ネットワーク:例」

ISP であるカスタマーを含む MPLS VPN CSC ネットワーク:例

図 6 に、カスタマー キャリアが ISP である Carrier Supporting Carrier ネットワーク設定を示します。このカスタマー キャリアには 2 つのサイトがあり、それぞれが POP です。カスタマー キャリアは、バックボーン キャリアによって提供される VPN サービスを使用してこれらのサイトを接続します。バックボーン キャリアは MPLS を使用します。ISP サイトは IP を使用します。ISP サイトとバックボーン キャリア間のパケット転送をイネーブルにするには、ISP をバックボーン キャリアに接続する CE ルータで MPLS が実行されている必要があります。

図 6 ISP であるカスタマー キャリアを含む Carrier Supporting Carrier ネットワーク

次に、Carrier Supporting Carrier ネットワーク内の各ルータの設定例を示します。OSPF を使用して、カスタマー キャリアをバックボーン キャリアに接続します。

CSC-CE1 の設定

mpls label protocol ldp
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.14.14.14 0.0.0.0 area 200
network 10.15.0.0 0.255.255.255 area 200
network 10.16.0.0 0.255.255.255 area 200

CSC-PE1 の設定

ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.11.11.11 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface ATM1/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1/0.1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.11.11.11 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute bgp 100 metric-type 1 subnets
network 10.19.19.19 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.12.12.12 remote-as 100
neighbor 10.12.12.12 update-source Loopback0
!
address-family ipv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-PE2 の設定

ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.20.20.20 255.255.255.255
no ip directed-broadcast
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.12.12.12 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute bgp 100 metric-type 1 subnets
network 10.20.20.20 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.11.11.11 remote-as 100
neighbor 10.11.11.11 update-source Loopback0
!
address-family ipv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-CE2 の設定

ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.16.16.16 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

MPLS VPN プロバイダーであるカスタマーを含む MPLS VPN CSC ネットワーク:例

図 7 に、カスタマー キャリアが MPLS VPN プロバイダーである Carrier Supporting Carrier ネットワーク設定を示します。カスタマー キャリアには 2 つのサイトがあります。バックボーン キャリアおよびカスタマー キャリアは、MPLS を使用します。IBGP セッションは、ISP の外部ルーティング情報を交換します。

図 7 MPLS VPN プロバイダーであるカスタマー キャリアを含む Carrier Supporting Carrier ネットワーク

次の設定例は、Carrier Supporting Carrier ネットワーク内の各ルータの設定を示しています。OSPF は、カスタマー キャリアをバックボーン キャリアに接続するために使用されるプロトコルです。

CE1 の設定

ip cef
!
interface Loopback0
ip address 10.17.17.17 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
router ospf 300
log-adjacency-changes
redistribute bgp 300 subnets
passive-interface Ethernet0/1
network 10.17.17.17 0.0.0.0 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 advertisement-interval 5
no auto-summary

PE1 の設定

ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
ip address 10.13.13.13 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface Ethernet3/0
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
passive-interface Ethernet3/0
network 10.13.13.13 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.15.15.15 remote-as 200
neighbor 10.15.15.15 update-source Loopback0
!
address-family ipv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
neighbor 10.0.0.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

CSC-CE1 の設定

mpls label protocol ldp
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.14.14.14 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

CSC-PE1 の設定

ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
ip address 11.11.11.11 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface ATM1/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.11.11.11 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute bgp 100 metric-type 1 subnets
network 10.19.19.19 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.12.12.12 remote-as 100
neighbor 10.12.12.12 update-source Loopback0
!
address-family ipv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.12.12.12 activate
neighbor 10.12.12.12 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-PE2 の設定

ip cef distributed
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
no mpls aggregate-statistics
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.20.20.20 255.255.255.255
no ip directed-broadcast
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
log-adjacency-changes
passive-interface ATM3/0/0.1
passive-interface Loopback100
network 10.12.12.12 0.0.0.0 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute bgp 100 metric-type 1 subnets
network 10.20.20.20 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.11.11.11 remote-as 100
neighbor 10.11.11.11 update-source Loopback0
!
address-family ipv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-CE2 の設定

ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.16.16.16 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
network 10.0.0.0 0.255.255.255 area 200

PE2 の設定

ip cef
ip cef accounting non-recursive
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
ip address 10.15.15.15 255.255.255.255
no ip directed-broadcast
!
interface Ethernet3/0
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
!
interface ATM5/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
passive-interface Ethernet3/0
network 10.15.15.15 0.0.0.0 area 200
network 10.0.0.0 0.255.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.13.13.13 remote-as 200
neighbor 10.13.13.13 update-source Loopback0
!
address-family ipv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn2
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
neighbor 10.0.0.2 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

CE2 の設定

ip cef
!
interface Loopback0
ip address 10.18.18.18 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
router ospf 300
log-adjacency-changes
redistribute bgp 300 subnets
passive-interface Ethernet0/1
network 10.18.18.18 0.0.0.0 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 advertisement-interval 5
no auto-summary

ルート リフレクタを含む MPLS VPN CSC ネットワーク:例

図 8 に、ルート リフレクタを含む Carrier Supporting Carrier ネットワーク設定を示します。カスタマー キャリアには 2 つのサイトがあります。

図 8 ルート リフレクタを含む Carrier Supporting Carrier ネットワーク

 


) Route Reflector(RR; ルート リフレクタ)間の接続は必要ありません。


次の設定例は、Carrier Supporting Carrier ネットワーク内の各ルータの設定を示しています。次の点に注意してください。

ルータの IP アドレスは、読みやすさのために省略されています。たとえば、PE 1 のループバック アドレスの 25 は、10.25.25.25 に相当します。

次のリストに、CSC-PE ルータのループバック アドレスを示します。

CSC-PE1(75K-37-3):ループバック 0 = 10.15.15.15、ループバック 1 = 10.18.18.18

CSC-PE2(75K-38-3):ループバック 0 = 10.16.16.16、ループバック 1 = 10.20.20.20

バックボーン キャリアの設定

ルート リフレクタ 1(72K-37-1)の設定

interface Loopback0
ip address 10.13.13.13 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 mpls
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
interface ATM1/1
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1.1 mpls
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
router ospf 100
auto-cost reference-bandwidth 10000
network 10.0.0.0 0.255.255.255 area 100
network 10.1.0.0 0.255.255.255 area 100
network 10.2.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
no bgp default ipv4-unicast
bgp cluster-id 1
redistribute static
neighbor 10.15.15.15 remote-as 100
neighbor 10.15.15.15 update-source Loopback0
neighbor 10.16.16.16 remote-as 100
neighbor 10.16.16.16 update-source Loopback0
!
address-family ipv4 vrf vpn1
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 route-reflector-client
neighbor 10.15.15.15 send-community extended
neighbor 10.16.16.16 activate
neighbor 10.16.16.16 route-reflector-client
neighbor 10.16.16.16 send-community extended
bgp scan-time import 5
exit-address-family

ルート リフレクタ 2(72K-38-1)の設定

interface Loopback0
ip address 10.14.14.14 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 mpls
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
interface ATM1/1
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1.1 mpls
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
router ospf 100
auto-cost reference-bandwidth 10000
network 10.0.0.0 0.255.255.255 area 100
network 10.1.0 0.255.255.255 area 100
network 10.2.0.0 0.255.255.255 area 100
!
router bgp 100
no synchronization
no bgp default ipv4-unicast
bgp cluster-id 1
redistribute static
neighbor 10.15.15.15 remote-as 100
neighbor 10.15.15.15 update-source Loopback0
neighbor 10.16.16.16 remote-as 100
neighbor 10.16.16.16 update-source Loopback0
!
address-family ipv4 vrf vpn1
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.15.15.15 activate
neighbor 10.15.15.15 route-reflector-client
neighbor 10.15.15.15 send-community extended
neighbor 10.16.16.16 activate
neighbor 10.16.16.16 route-reflector-client
neighbor 10.16.16.16 send-community extended
bgp scan-time import 5
exit-address-family

CSC-PE1(75K-37-3)の設定

ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface Loopback0
ip address 10.15.15.15 255.255.255.255
no ip directed-broadcast
!
interface Loopback1
ip vrf forwarding vpn1
ip address 10.18.18.18 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/0/1
ip vrf forwarding vpn1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no ip route-cache distributed
mpls label protocol ldp
mpls ip
!
interface ATM1/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1/0.1 mpls
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 6 32 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/1/0.1 mpls
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
router ospf 100
auto-cost reference-bandwidth 10000
network 10.0.0.0 0.255.255.255 area 100
network 10.1.0.0 0.255.255.255 area 100
network 10.2.0.0 0.255.255.255 area 100
network 10.3.0.0 0.255.255.255 area 100
network 10.4.0.0 0.255.255.255 area 100
!
router ospf 1 vrf vpn1
redistribute bgp 100 metric-type 1 subnets
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.13.13.13 remote-as 100
neighbor 10.13.13.13 update-source Loopback0
neighbor 10.14.14.14 remote-as 100
neighbor 10.14.14.14 update-source Loopback0
!
address-family ipv4
redistribute static
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
neighbor 10.14.14.14 activate
neighbor 10.14.14.14 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 1 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

CSC-PE2(75K-38-3)の設定

ip cef distributed
!
ip vrf vpn1
rd 100:1
route-target export 100:1
route-target import 100:1
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip directed-broadcast
!
interface Loopback1
ip vrf forwarding vpn1
ip address 10.20.20.20 255.255.255.255
no ip directed-broadcast
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM0/1/0.1 mpls
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
interface ATM2/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM2/1/0.1 mpls
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no atm enable-ilmi-trap
mpls label protocol ldp
mpls atm vpi 2-5
mpls ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 6 32 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
interface ATM3/1/0
no ip address
no ip directed-broadcast
no ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/1/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 101 6 33 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls ip
!
router ospf 100
auto-cost reference-bandwidth 10000
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
network 10.0.0.0 0.255.255.255 area 100
!
router ospf 1 vrf vpn1
redistribute bgp 100 metric-type 1 subnets
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
!
router bgp 100
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.13.13.13 remote-as 100
neighbor 10.13.13.13 update-source Loopback0
neighbor 10.14.14.14 remote-as 100
neighbor 10.14.14.14 update-source Loopback0
!
address-family ipv4
redistribute static
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.13.13.13 activate
neighbor 10.13.13.13 send-community extended
neighbor 10.14.14.14 activate
neighbor 10.14.14.14 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 1 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

カスタマー キャリア サイト 1 の設定

PE1(72K-36-8)の設定

ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
no mpls ip propagate-ttl
!
interface Loopback0
ip address 10.25.25.25 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
mpls label protocol ldp
mpls ip
!
interface Ethernet3/0
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet3/1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/2
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
!
router bgp 200
neighbor 10.22.22.22 remote-as 200
neighbor 10.22.22.22 update-source Loopback0
neighbor 10.23.23.23 remote-as 200
neighbor 10.23.23.23 update-source Loopback0
!
address-family ipv4 vrf vpn2
redistribute connected
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.22.22.22 activate
neighbor 10.22.22.22 send-community extended
neighbor 10.23.23.23 activate
neighbor 10.23.23.23 send-community extended
exit-address-family

CSC-CE1(72K-36-9)の設定

ip cef
no ip domain-lookup
!
interface Loopback0
ip address 10.11.11.11 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 6 32 aal5snap
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
mpls label protocol ldp
mpls ip
!
interface Ethernet3/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/1
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101

PE2(72K-36-7)の設定

ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
no mpls ip propagate-ttl
!
interface Loopback0
ip address 10.24.24.24 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Ethernet3/0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/1
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet3/2
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
interface Ethernet3/3
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
network 10.0.0.0 0.255.255.255 area 101
!
router bgp 200
neighbor 10.22.22.22 remote-as 200
neighbor 10.22.22.22 update-source Loopback0
neighbor 10.23.23.23 remote-as 200
neighbor 10.23.23.23 update-source Loopback0
!
address-family ipv4 vrf vpn2
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.22.22.22 activate
neighbor 10.22.22.22 send-community extended
neighbor 10.23.23.23 activate
neighbor 10.23.23.23 send-community extended
exit-address-family

ルート リフレクタ 3(36K-38-4)の設定

ip cef
!
interface Loopback0
ip address 10.23.23.23 255.255.255.255
!
interface Ethernet1/1
ip address 10.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
interface Ethernet1/2
ip address 10.0.0.1 255.0.0.0
mpls label protocol ldp
mpls ip
!
interface ATM3/0
no ip address
no ip mroute-cache
atm clock INTERNAL
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM3/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
atm pvc 100 0 55 aal5snap
mpls label protocol ldp
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 101
network 10.1.0.0 0.255.255.255 area 101
network 10.2.0.0 0.255.255.255 area 101
network 10.3.0.0 0.255.255.255 area 101
!
router bgp 200
no synchronization
no bgp default ipv4-unicast
bgp cluster-id 2
redistribute static
neighbor 10.21.21.21 remote-as 200
neighbor 10.21.21.21 update-source Loopback0
neighbor 10.24.24.24 remote-as 200
neighbor 10.24.24.24 update-source Loopback0
neighbor 10.25.25.25 remote-as 200
neighbor 10.25.25.25 update-source Loopback0
!
address-family ipv4 vrf vpn2
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.21.21.21 activate
neighbor 10.21.21.21 route-reflector-client
neighbor 10.21.21.21 send-community extended
neighbor 10.24.24.24 activate
neighbor 10.24.24.24 route-reflector-client
neighbor 10.24.24.24 send-community extended
neighbor 10.25.25.25 activate
neighbor 10.25.25.25 route-reflector-client
neighbor 10.25.25.25 send-community extended
exit-address-family

CE1(36K-36-1)の設定

ip cef
!
interface Loopback0
ip address 10.28.28.28 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/2
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
router bgp 300
network 10.0.0.0
network 10.0.0.0
network 10.0.0.0
neighbor 10.0.0.1 remote-as 200
neighbor 10.0.0.1 remote-as 200

カスタマー キャリア サイト 2 の設定

CSC-CE3(72K-36-6)の設定

ip cef
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 6 32 aal5snap
mpls label protocol ldp
 
mpls ip
!
interface POS2/0
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 40 aal5snap
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.1.0.0 0.255.255.255 area 101
network 10.2.0.0 0.255.255.255 area 101
network 10.3.0.0 0.255.255.255 area 101

PE3(72K-36-4)の設定

ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
!
interface Loopback0
ip address 10.21.21.21 255.255.255.255
no ip directed-broadcast
!
interface Ethernet3/0
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
!
interface Ethernet3/1
ip vrf forwarding vpn2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
!
interface Ethernet3/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
mpls label protocol ldp
mpls ip
!
interface ATM5/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 40 aal5snap
mpls label protocol ldp
mpls ip
!
interface ATM6/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 20 aal5snap
mpls label protocol ldp
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.1.0.0 0.255.255.255 area 101
network 10.2.0.0 0.255.255.255 area 101
network 10.3.0.0 0.255.255.255 area 101
!
router bgp 200
neighbor 10.22.22.22 remote-as 200
neighbor 10.22.22.22 update-source Loopback0
neighbor 10.23.23.23 remote-as 200
neighbor 10.23.23.23 update-source Loopback0
!
address-family ipv4 vrf vpn2
redistribute connected
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
neighbor 10.0.0.2 as-override
neighbor 10.0.0.2 remote-as 300
neighbor 10.0.0.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.22.22.22 activate
neighbor 10.22.22.22 send-community extended
neighbor 10.23.23.23 activate
neighbor 10.23.23.23 send-community extended
exit-address-family

CSC-CE4(72K-36-5)の設定

ip cef
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
no ip directed-broadcast
!
interface POS4/0
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
encapsulation ppp
mpls label protocol ldp
mpls ip
clock source internal
!
interface ATM5/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
atm pvc 100 0 20 aal5snap
mpls label protocol ldp
mpls ip
!
interface ATM6/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
atm pvc 100 6 33 aal5snap
mpls label protocol ldp
mpls ip
!
router ospf 1
network 10.0.0.0 0.255.255.255 area 101
network 10.1.0.0 0.255.255.255 area 101
network 10.2.0.0 0.255.255.255 area 101
network 10.3.0.0 0.255.255.255 area 101

ルート リフレクタ 4(36K-38-5)の設定

ip cef
!
interface Loopback0
ip address 10.22.22.22 255.255.255.255
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
mpls label protocol ldp
mpls ip
!
interface ATM2/0
no ip address
no ip mroute-cache
atm clock INTERNAL
no atm scrambling cell-payload
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip address 10.0.0.1 255.0.0.0
atm pvc 100 0 55 aal5snap
mpls label protocol ldp
mpls ip
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.255.255.255 area 101
network 10.1.0.0 0.255.255.255 area 101
network 10.2.0.0 0.255.255.255 area 101
!
router bgp 200
no synchronization
no bgp default ipv4-unicast
bgp cluster-id 2
redistribute static
neighbor 10.21.21.21 remote-as 200
neighbor 10.21.21.21 update-source Loopback0
neighbor 10.24.24.24 remote-as 200
neighbor 10.24.24.24 update-source Loopback0
neighbor 10.25.25.25 remote-as 200
neighbor 10.25.25.25 update-source Loopback0
!
address-family ipv4 vrf vpn2
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.21.21.21 activate
neighbor 10.21.21.21 route-reflector-client
neighbor 10.21.21.21 send-community extended
neighbor 10.24.24.24 activate
neighbor 10.24.24.24 route-reflector-client
neighbor 10.24.24.24 send-community extended
neighbor 10.25.25.25 activate
neighbor 10.25.25.25 route-reflector-client
neighbor 10.25.25.25 send-community extended
exit-address-family

CE2(36K-36-2)の設定

ip cef
!
interface Loopback0
ip address 10.26.26.26 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
interface Ethernet0/2
ip address 10.0.0.1 255.0.0.0
no ip directed-broadcast
!
router ospf 300
redistribute bgp 300
network 10.0.0.0 0.255.255.255 area 300
network 10.0.0.0 0.255.255.255 area 300
!
router bgp 300
network 10.0.0.0
network 10.1.0.0
network 10.2.0.0
neighbor 10.0.0.1 remote-as 200

CE3(36K-36-3)の設定

ip cef
!
interface Loopback0
ip address 10.27.27.27 255.255.255.255
no ip directed-broadcast
!
interface Ethernet1/1
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
interface Ethernet1/2
ip address 10.0.0.2 255.0.0.0
no ip directed-broadcast
!
router ospf 300
redistribute bgp 300
network 10.0.0.0 0.255.255.255 area 300
network 10.0.0.0 0.255.255.255 area 300
!
router bgp 300
network 10.0.0.0
network 10.1.0.0
network 10.2.0.0
neighbor 10.0.0.1 remote-as 200
 

VPN を持つカスタマーがネットワーク エッジに存在する MPLS VPN CSC ネットワーク:例

図 9 に、VPN を持つカスタマーがネットワーク エッジに存在する Carrier Supporting Carrier ネットワーク設定を示します。

図 9 Carrier Supporting Carrier ネットワーク

 

バックボーン キャリアの設定

CSC-PE1(72K-36-9)の設定

ip cef
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
!
!
interface Loopback0
ip address 10.14.14.14 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.22.22.22 255.255.255.255
no ip directed-broadcast
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.1.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/0.2 point-to-point
ip address 10.2.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/0.3 point-to-point
ip address 10.3.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM2/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM2/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.15.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM2/0.2 point-to-point
ip vrf forwarding vpn1
ip address 10.16.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM2/0.3 point-to-point
ip vrf forwarding vpn1
ip address 10.17.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
passive-interface ATM2/0.1
passive-interface ATM2/0.2
passive-interface ATM2/0.3
passive-interface Loopback100
network 10.14.14.14 0.0.0.0 area 100
network 10.1.0.0 0.0.255.255 area 100
network 10.2.0.0 0.0.255.255 area 100
network 10.3.0.0 0.0.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute connected subnets
redistribute bgp 100 metric-type 1 subnets
network 10.22.22.22 0.0.0.0 area 200
network 10.15.0.0 0.0.255.255 area 200
network 10.16.0.0 0.0.255.255 area 200
network 10.17.0.0 0.0.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.11.11.11 remote-as 100
neighbor 10.11.11.11 update-source Loopback0
!
address-family ipv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.11.11.11 activate
neighbor 10.11.11.11 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

P1(75K-37-3)の設定

ip cef distributed
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.12.12.12 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/1/0
no ip address
no ip directed-broadcast
ip route-cache distributed
atm clock INTERNAL
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/1/0.1 point-to-point
ip address 10.7.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 103 0 53 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/1/0.2 point-to-point
ip address 10.8.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 104 0 54 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/1/0.3 point-to-point
ip address 10.9.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 105 0 55 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM3/0/0
no ip address
no ip directed-broadcast
ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/0/0.1 point-to-point
ip address 10.1.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
mpls accounting experimental input
tag-switching ip
!
interface ATM3/0/0.2 point-to-point
ip address 10.2.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM3/0/0.3 point-to-point
ip address 10.3.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.12.12.12 0.0.0.0 area 100
network 10.1.0.0 0.0.255.255 area 100
network 10.2.0.0 0.0.255.255 area 100
network 10.3.0.0 0.0.255.255 area 100
network 10.7.0.0 0.0.255.255 area 100
network 10.8.0.0 0.0.255.255 area 100
network 10.9.0.0 0.0.255.255 area 100

P2(75K-38-3)の設定

ip cef distributed
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.13.13.13 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM0/1/0
no ip address
no ip directed-broadcast
ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM0/1/0.1 point-to-point
ip address 10.7.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 103 0 53 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM0/1/0.2 point-to-point
ip address 10.8.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 104 0 54 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM0/1/0.3 point-to-point
ip address 10.9.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 105 0 55 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM3/1/0
no ip address
no ip directed-broadcast
ip route-cache distributed
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM3/1/0.1 point-to-point
ip address 10.4.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM3/1/0.2 point-to-point
ip address 10.5.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM3/1/0.3 point-to-point
ip address 10.6.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
network 10.13.13.13 0.0.0.0 area 100
network 10.4.0.0 0.0.255.255 area 100
network 10.5.0.0 0.0.255.255 area 100
network 10.6.0.0 0.0.255.255 area 100
network 10.7.0.0 0.0.255.255 area 100
network 10.8.0.0 0.0.255.255 area 100
network 10.9.0.0 0.0.255.255 area 100
!

CSC-PE2(72K-36-5)の設定

ip cef
!
ip vrf vpn1
rd 100:0
route-target export 100:0
route-target import 100:0
mpls label protocol ldp
!
interface Loopback0
ip address 10.11.11.11 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Loopback100
ip vrf forwarding vpn1
ip address 10.23.23.23 255.255.255.255
no ip directed-broadcast
!
interface ATM5/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip vrf forwarding vpn1
ip address 10.18.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.2 point-to-point
ip vrf forwarding vpn1
ip address 10.19.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.3 point-to-point
ip vrf forwarding vpn1
ip address 10.20.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
ip address 10.4.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0.2 point-to-point
ip address 10.5.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0.3 point-to-point
ip address 10.6.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 100
log-adjacency-changes
redistribute connected subnets
passive-interface ATM5/0.1
passive-interface ATM5/0.2
passive-interface ATM5/0.3
passive-interface Loopback100
network 10.11.11.11 0.0.0.0 area 100
network 10.4.0.0 0.0.255.255 area 100
network 10.5.0.0 0.0.255.255 area 100
network 10.6.0.0 0.0.255.255 area 100
!
router ospf 200 vrf vpn1
log-adjacency-changes
redistribute connected subnets
redistribute bgp 100 metric-type 1 subnets
network 10.23.23.23 0.0.0.0 area 200
network 10.18.0.0 0.0.255.255 area 200
network 10.19.0.0 0.0.255.255 area 200
network 10.20.0.0 0.0.255.255 area 200
!
router bgp 100
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.14.14.14 remote-as 100
neighbor 10.14.14.14 update-source Loopback0
!
address-family ipv4
neighbor 10.14.14.14 activate
neighbor 10.14.14.14 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.14.14.14 activate
neighbor 10.14.14.14 send-community extended
exit-address-family
!
address-family ipv4 vrf vpn1
redistribute ospf 200 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family

カスタマー キャリア サイト 1 の設定

CSC-CE1(72K-36-8)の設定

ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.15.15.15 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface ATM1/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM1/0.1 point-to-point
ip address 10.15.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/0.2 point-to-point
ip address 10.16.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM1/0.3 point-to-point
ip address 10.17.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface Ethernet3/1
ip address 10.10.0.2 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
tag-switching ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.15.15.15 0.0.0.0 area 200
network 10.10.0.0 0.0.255.255 area 200
network 10.15.0.0 0.0.255.255 area 200
network 10.16.0.0 0.0.255.255 area 200
network 10.17.0.0 0.0.255.255 area 200

PE1(72K-36-7)の設定

ip cef
!
ip vrf customersite
rd 200:1
route-target export 200:1
route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
ip address 10.16.16.16 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Ethernet3/1
ip vrf forwarding customersite
ip address 10.35.0.2 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet3/2
ip address 30.10.0.1 255.255.0.0
no ip directed-broadcast
no ip mroute-cache
mpls label protocol ldp
tag-switching ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
passive-interface Ethernet3/1
network 10.16.16.16 0.0.0.0 area 200
network 10.10.0.0 0.0.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.18.18.18 remote-as 200
neighbor 10.18.18.18 update-source Loopback0
!
address-family ipv4
neighbor 10.18.18.18 activate
neighbor 10.18.18.18 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.18.18.18 activate
neighbor 10.18.18.18 send-community extended
exit-address-family
!
address-family ipv4 vrf customersite
neighbor 10.35.0.1 remote-as 300
neighbor 10.35.0.1 activate
neighbor 10.35.0.1 as-override
neighbor 10.35.0.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

CE1(36K-36-1)の設定

ip cef
!
interface Loopback0
ip address 10.19.19.19 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/2
ip address 30.35.0.1 255.255.0.0
no ip directed-broadcast
!
router ospf 300
log-adjacency-changes
redistribute connected subnets
redistribute bgp 300 subnets
passive-interface Ethernet0/2
network 10.19.19.19 0.0.0.0 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.35.0.2 remote-as 200
neighbor 10.35.0.2 advertisement-interval 5
no auto-summary

カスタマー キャリア サイト 2 の設定

CSC-CE2(72K-36-4)の設定

ip cef
!
mpls label protocol ldp
!
interface Loopback0
ip address 10.17.17.17 255.255.255.255
no ip directed-broadcast
!
interface ATM5/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.11.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.2 point-to-point
ip address 10.12.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.3 point-to-point
ip address 10.13.0.2 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0
no ip address
no ip directed-broadcast
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM6/0.1 point-to-point
ip address 10.18.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0.2 point-to-point
ip address 10.19.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM6/0.3 point-to-point
ip address 10.20.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
network 10.17.17.17 0.0.0.0 area 200
network 10.11.0.0 0.0.255.255 area 200
network 10.12.0.0 0.0.255.255 area 200
network 10.13.0.0 0.0.255.255 area 200
network 10.18.0.0 0.0.255.255 area 200
network 10.19.0.0 0.0.255.255 area 200
network 10.20.0.0 0.0.255.255 area 200

PE2(72K-36-6)の設定

ip cef
!
ip vrf customersite
rd 200:1
route-target export 200:1
route-target import 200:1
mpls label protocol ldp
!
interface Loopback0
ip address 10.18.18.18 255.255.255.255
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
!
interface Ethernet3/0
ip vrf forwarding customersite
ip address 10.29.0.2 255.255.0.0
no ip directed-broadcast
!
interface Ethernet3/1
ip vrf forwarding customersite
ip address 10.30.0.2 255.255.0.0
no ip directed-broadcast
!
interface ATM5/0
no ip address
no ip directed-broadcast
no ip mroute-cache
atm clock INTERNAL
atm sonet stm-1
no atm enable-ilmi-trap
no atm ilmi-keepalive
!
interface ATM5/0.1 point-to-point
ip address 10.11.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 100 0 50 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.2 point-to-point
ip address 10.12.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 101 0 51 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
interface ATM5/0.3 point-to-point
ip address 10.13.0.1 255.255.0.0
no ip directed-broadcast
atm pvc 102 0 52 aal5snap
no atm enable-ilmi-trap
mpls label protocol ldp
tag-switching ip
!
router ospf 200
log-adjacency-changes
redistribute connected subnets
passive-interface Ethernet3/0
passive-interface Ethernet3/1
network 10.18.18.18 0.0.0.0 area 200
network 10.11.0.0 0.0.255.255 area 200
network 10.12.0.0 0.0.255.255 area 200
network 10.13.0.0 0.0.255.255 area 200
!
router bgp 200
no bgp default ipv4-unicast
bgp log-neighbor-changes
timers bgp 10 30
neighbor 10.16.16.16 remote-as 200
neighbor 10.16.16.16 update-source Loopback0
!
address-family ipv4
neighbor 10.16.16.16 activate
neighbor 10.16.16.16 send-community extended
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 10.16.16.16 activate
neighbor 10.16.16.16 send-community extended
exit-address-family
!
address-family ipv4 vrf customersite
neighbor 10.29.0.1 remote-as 300
neighbor 10.29.0.1 activate
neighbor 10.29.0.1 as-override
neighbor 10.29.0.1 advertisement-interval 5
neighbor 10.30.0.1 remote-as 300
neighbor 10.30.0.1 activate
neighbor 10.30.0.1 as-override
neighbor 10.30.0.1 advertisement-interval 5
no auto-summary
no synchronization
exit-address-family

CE2(36K-38-4)の設定

ip cef
!
interface Loopback0
ip address 10.21.21.21 255.255.255.255
!
interface Ethernet1/3
ip address 10.29.0.1 255.255.0.0
!
interface Ethernet5/0
ip address 10.14.0.1 255.255.0.0
!
router ospf 300
log-adjacency-changes
redistribute connected subnets
redistribute bgp 300 subnets
passive-interface Ethernet1/3
network 10.21.21.21 0.0.0.0 area 300
network 10.14.0.0 0.0.255.255 area 300
!
router bgp 300
no synchronization
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.29.0.2 remote-as 200
neighbor 10.29.0.2 advertisement-interval 5
no auto-summary

CE3(36K-38-5)の設定

ip cef
!
interface Loopback0
ip address 10.20.20.20 255.255.255.255
no ip directed-broadcast
!
interface Ethernet0/2
ip address 10.30.0.1 255.255.0.0
no ip directed-broadcast
!
interface Ethernet0/3
ip address 10.14.0.2 255.255.0.0
no ip directed-broadcast
!
router ospf 300
log-adjacency-changes
redistribute connected subnets
redistribute bgp 300 subnets
passive-interface Ethernet0/2
network 10.20.20.20 0.0.0.0 area 300
network 10.14.0.0 0.0.255.255 area 300
!
router bgp 300
no synchronization
bgp log-neighbor-changes
timers bgp 10 30
redistribute connected
redistribute ospf 300 match internal external 1 external 2
neighbor 10.30.0.2 remote-as 200
neighbor 10.30.0.2 advertisement-interval 5
no auto-summary

その他の関連資料

ここでは、MPLS VPN に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS

『MPLS Product Literature』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。またこの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

LDP および IGP を使用する MPLS VPN CSC の機能情報

表 4 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 4 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 4 LDP および IGP を使用する MPLS VPN CSC の機能情報

機能名
リリース
機能設定情報

MPLS VPN Carrier Supporting Carrier

12.0(14)ST
12.0(16)ST
12.2(8)T
12.0(21)ST
12.0(22)S
12.0(23)S

この機能により、LDP を使用して MPLS ラベルを転送し、IGP を使用してルートを転送する MPLS VPN CSC ネットワークをセットアップおよび作成できます。

この機能は、12.0(14)ST で導入されました。

この機能は、12.0(16)ST で統合されました。

この機能は、12.2(8)T で統合されました。

この機能は、12.0(21)ST で統合されました。

この機能は、12.0(22)S で統合されました。

この機能は、12.0(23)S で統合されました。

用語集

ASBR:Autonomous System Boundary router(自律システム境界ルータ)。自律システムを別の自律システムに接続するルータ。

BGP :Border Gateway Protocol(ボーダー ゲートウェイ プロトコル)。個別のルーティング ポリシーが含まれた個別のルーティング ドメイン(自律システム)間のループフリー ルーティングを提供するように設計されたドメイン間ルーティング プロトコル。

Carrier Supporting Carrier :サービス プロバイダーが、そのバックボーン ネットワークのセグメントを別のサービス プロバイダーが使用できるようにする状況。

CE ルータ :Customer Edge(カスタマー エッジ)ルータ。カスタマー ネットワークの一部であり、Provider Edge(PE; プロバイダー エッジ)ルータへのインターフェイスとなるルータ。このマニュアルでは、CE ルータはカスタマー キャリア ネットワークのエッジにあります。

IGP :Interior Gateway Protocol(内部ゲートウェイ プロトコル)。自律システム内でのルーティング情報の交換に使用されるインターネット プロトコル。

LDP :Label Distribution Protocol(ラベル配布プロトコル)。パケットの転送に使用されるラベル(アドレス)をネゴシエーションするための、MPLS 対応ルータ間の標準プロトコル。

MPLS :Multiprotocol Label Switching(マルチプロトコル ラベル スイッチング)。ラベルを使用して IP トラフィックを転送するスイッチング方式。このラベルによって、ネットワーク内のルータおよびスイッチが、事前に確立された IP ルーティング情報に基づくパケットの転送先を指示されます。

PE ルータ :Provider Edge(プロバイダー エッジ)ルータ。サービス プロバイダーのネットワークのエッジにある、CE ルータへのインターフェイスとなるルータ。

VPN :Virtual Private Network(VPN; バーチャル プライベート ネットワーク)。トンネリングを使用することにより、パブリック TCP/IP ネットワーク経由でも IP トラフィックをセキュアに転送できるネットワーク。

エッジ ルータ :ネットワークのエッジにあるルータ。MPLS ネットワークの境界を定義します。パケットを送受信します。エッジ ラベル スイッチ ルータおよびラベル エッジ ルータとも呼ばれます。