Cisco IOS マルチプロトコル ラベル スイッチング コ ンフィギュレーション ガイド リリース15.1
AToM グレースフル リスタート
AToM グレースフル リスタート
発行日;2012/01/16 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

AToM グレースフル リスタート

機能情報の確認

この章の構成

AToM グレースフル リスタートの概要

AToM グレースフル リスタートの機能

AToM グレースフル リスタートの設定方法

AToM グレースフル リスタートの設定

前提条件

制約事項

AToM グレースフル リスタートの設定例

AToM グレースフル リスタート:設定例

AToM グレースフル リスタート:LDP セッションの中断からの回復例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

AToM グレースフル リスタートの機能情報

AToM グレースフル リスタート

AToM グレースフル リスタート機能は、Any Transport over MPLS(AToM)の NonStop Forwarding(NSF; ノンストップ フォワーディング)、Stateful Switchover(SSO; ステートフル スイッチオーバー)、および Graceful Restart(GR; グレースフル リスタート)を備えたネイバー ルータが、サービスの停止から正常に回復するのを支援します。AToM GR は、ヘルパー モードでだけ機能します。つまり、NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート機能がイネーブルになっている他のルータの回復を支援します。AToM GR を備えたルータに障害が発生すると、そのルータのピアはルータの回復を支援できません。AToM GR は、MPLS Label Distribution Protocol(LDP; ラベル配布プロトコル)グレースフル リスタート機能に基づいています。

このマニュアルを参照する際には、次の点に注意してください。

このマニュアルで説明している AToM GR 機能はヘルパー モードを指しています。

NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート機能は、Cisco IOS Release 12.2(25)S および 12.2(33)SRA でサポートされています。このマニュアルでは、簡潔に、NSF/SSO:Any Transport over MPLS および AToM グレースフル リスタート機能は AToM SSO/NSF と呼ばれます。

機能情報の確認

ご使用のソフトウェア リリースによっては、この章に記載されている機能の中に、一部サポートされていないものがあります。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「AToM グレースフル リスタートの機能情報」を参照してください。

プラットフォーム サポートと Cisco IOS および Catalyst OS ソフトウェア イメージ サポートに関する情報を入手するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

AToM グレースフル リスタートの概要

AToM GR を設定するには、次の概念を理解する必要があります。

「AToM グレースフル リスタートの機能」

AToM グレースフル リスタートの機能

AToM GR は、厳格なヘルパー モードで機能します。つまり、AToM NSF/SSO を備えた隣接ルート プロセッサが、MPLS フォワーディング ステートを維持したまま、サービスの中断から回復するのを支援します。サービスの中断は、TCP や User Datagram Protocol(UDP; ユーザ データグラム プロトコル)イベント、またはルート プロセッサのステートフル スイッチオーバーが原因で発生する可能性があります。AToM GR は、LDP セッションの停止時に AToM 回線の転送情報を維持する MPLS LDP グレースフル リスタート機能に基づいています。ネイバー ルータが新しいセッションを確立すると、LDP バインディングおよび MPLS フォワーディング ステートが回復します。LDP グレースフル リスタート機能のしくみに関する詳細情報については、『 MPLS LDP Graceful Restart 』の機能の章を参照してください。

AToM グレースフル リスタートの設定方法

ここでは、次の各手順について説明します。

「AToM グレースフル リスタートの設定」(必須)

AToM グレースフル リスタートの設定

AToM GR に関する AToM 固有の設定はありません。AToM NSF/SSO を使用して設定されているネイバー ルータが、LDP セッションの中断時にフォワーディング ステートを維持するのを支援するように、LDP GR をイネーブルにします。

前提条件

LDP GR の機能、およびご使用のネットワーク用に LDP GR をカスタマイズする方法については、『 MPLS LDP Graceful Restart 』マニュアルを参照してください。

AToM を設定します。AToM のセットアップおよび設定については、『 Any Transport over MPLS 』マニュアルを参照してください。

制約事項

AToM GR は、厳格なヘルパー モードでサポートされています。

AToM NSF/SSO は、Cisco IOS Release 12.2(25)S および 12.2(33)SRA でサポートされています。

Tag Distribution Protocol(TDP; タグ配布プロトコル)セッションはサポートされていません。LDP セッションだけがサポートされています。

MPLS LDP GR は、Label-Controlled ATM(LC-ATM; ラベル制御 ATM)インターフェイス上では設定できません。

手順の概要

1. enable

2. configure terminal

3. ip cef [ distributed ]

4. mpls ldp graceful-restart

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたらパスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef [distributed]

 

Router(config)# ip cef distributed

シスコ エクスプレス フォワーディングをイネーブルにします。

ステップ 4

mpls ldp graceful-restart

 
Router(config)# mpls ldp graceful-restart

サービスの中断時に LDP バインディングおよび MPLS フォワーディング ステートを保護するように、ルータをイネーブルにします。

AToM GR がグローバルにイネーブルになります。AToM GR をイネーブルにしても、既存の LDP セッションには影響しません。確立された新しい LDP セッションは、AToM GR を実行できます。

AToM グレースフル リスタートの設定例

ここでは、次の設定例について説明します。

「AToM グレースフル リスタート:設定例」

「AToM グレースフル リスタート:LDP セッションの中断からの回復例」

AToM グレースフル リスタート:設定例

次に、イーサネット VLAN over MPLS の設定例を示します。PE1 には、AToM グレースフル リスタートが設定されています。PE2 には AToM NSF/SSO が設定されています。AToM GR および NSF/SSO を設定するためのコマンドは、太字で示しています。

AToM GR が設定された PE1
AToM NSF/SSO が設定された PE2
ip cef
!
mpls label protocol ldp
mpls ldp graceful-restart
mpls ldp router-id Loopback0
!
pseudowire-class atom
encapsulation mpls
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
!
interface FastEthernet5/1/1
no ip address
!
interface FastEthernet5/1/1.2
description “xconnect to PE2”
encapsulation dot1Q 2 native
xconnect 10.2.2.2 1002 pw-class mpls
!
! IGP for MPLS
router ospf 10
log-adjacency-changes
auto-cost reference-bandwidth 1000
network 10.1.1.2 10.0.0.0 area 0
network 10.1.1.0 10.0.0.255 area 0
 
redundancy
mode sso
ip cef
!
mpls label protocol ldp
mpls ldp graceful-restart
mpls ldp router-id Loopback0
!
pseudowire-class atom
encapsulation mpls
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
!
interface Ethernet3/3
no ip address
!
interface Ethernet3/3.2
description “xconnect to PE1”
encapsulation dot1Q 2
xconnect 10.1.1.2 1002 pw-class mpls
!
! IGP for MPLS
router ospf 10
log-adjacency-changes
nsf enforce global
auto-cost reference-bandwidth 1000
network 10.2.2.2 10.0.0.0 area 0
network 10.1.1.0 10.0.0.255 area 0

AToM グレースフル リスタート:LDP セッションの中断からの回復例

次の各例は、通常の動作時、および LDP セッションが中断から回復した場合の show mpls l2transport vc コマンドの出力を示しています。

次に、通常の動作時の、AToM GR が設定された PE1 での VC のステータス例を示します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa5/1/1.2 Eth VLAN 2 10.2.2.2 1002 UP
 

次に、VC が LDP セッションの中断から回復しているときの、AToM GR が設定された PE1 での VC のステータス例を示します。回線のフォワーディング ステートは、中断前と同じになります。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa5/1/1.2 Eth VLAN 2 10.2.2.2 1002 RECOVERING
 

次に、LDP セッションの中断が解消されたあとの、AToM GR が設定された PE1 での VC のステータス例を示します。AToM ラベル バインディングは、割り当てられた時間内にアドバタイズされ、ステータスはアップに戻っています。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa5/1/1.2 Eth VLAN 2 10.2.2.2 1002 UP
 

次に、通常の動作時の、AToM GR が設定された PE1 での VC の詳細なステータス例を示します。

Router# show mpls l2transport vc detail
 
Local interface: Fa5/1/1.2 up, line protocol up, Eth VLAN 2 up
Destination address: 10.2.2.2, VC ID: 1002, VC status: up
Preferred path: not configured
Default path: active
Tunnel label: imp-null, next hop point2point
Output interface: Se4/0/3, imposed label stack {16}
Create time: 1d00h, last status change time: 1d00h
Signaling protocol: LDP, peer 10.2.2.2:0 up
MPLS VC labels: local 21, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: "xconnect to PE2"
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 3466, send 12286
byte totals: receive 4322368, send 5040220
packet drops: receive 0, send 0
 

次に、VC が回復しているときの、AToM GR が設定された PE1 での VC の詳細なステータス例を示します。

Router# show mpls l2transport vc detail
 
Local interface: Fa5/1/1.2 up, line protocol up, Eth VLAN 2 up
Destination address: 10.2.2.2, VC ID: 1002, VC status: recovering
Preferred path: not configured
Default path: active
Tunnel label: imp-null, next hop point2point
Output interface: Se4/0/3, imposed label stack {16}
Create time: 1d00h, last status change time: 00:00:03
Signaling protocol: LDP, peer 10.2.2.2:0 down
MPLS VC labels: local 21, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description: "xconnect to PE2"
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 20040, send 28879
byte totals: receive 25073016, send 25992388
packet drops: receive 0, send 0
 

その他の関連資料

ここでは、AToM GR に関する関連資料について説明します。

関連資料

関連項目
参照先

MPLS LDP グレースフル リスタート

『MPLS LDP Graceful Restart』

AToM の設定

『Any Transport over MPLS』

AToM のノンストップ フォワーディングおよびステートフル スイッチオーバー

『NSF/SSO - Any Transport over MPLS and AToM Graceful Restart』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

MPLS ラベル配布プロトコル MIB バージョン 8 アップグレード

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3036

『LDP Specification』

RFC 3478

『Graceful Restart Mechanism for Label Distribution』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

この機能では、新しいコマンドや変更されたコマンドは使用されません。

AToM グレースフル リスタートの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、Cisco IOS ソフトウェア イメージおよび Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していないかぎり、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 AToM グレースフル リスタートの機能情報

機能名
リリース
機能情報

AToM グレースフル リスタート

12.0(29)S
12.2(33)SRA
12.4(11)T
12.2(33)SXH

この機能は、12.0(29)S で導入されました。

Cisco 7600 シリーズ ルータのサポートは、12.2(33)SRA で追加されました。

この機能は、12.4(11)T でこのリリースに統合されました。

この機能は、12.2(33)SXH でこのリリースに統合されました。